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CONTAINED HEREIN MAY NOT BE SUITABLE FOR EVERY 
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How to Use This Book
Who This Book Is For
This book is for the reader who has never used this 
particular technology or software application. It is also 
for readers who want to expand their knowledge.

The Conventions in This Book

1 Steps
This book uses a step-by-step format to guide you 
easily through each task. Numbered steps are actions 
you must do; bulleted steps clarify a point, step, or 
optional feature; and indented steps give you the 
result.

2 Notes
Notes give additional information — special conditions 
that may occur during an operation, a situation that 
you want to avoid, or a cross reference to a related 
area of the book.

3 Icons and Buttons
Icons and buttons show you exactly what you need to 
click to perform a step.

4 Tips
Tips offer additional information, including warnings 
and shortcuts.

5 Bold
Bold type shows command names, options, and text 
or numbers you must type.

6 Italics
Italic type introduces and defines a new term.

Adding and Editing Worksheet Graphics chapter14

66

55

33

11

44

22

Can I add text to a 
shape?
Yes. You can add text to the 
interior of any 2-D shape 
(that is, any shape that is 
not a line). After you draw 
the shape, right-click the 
shape, click Edit Text, and 
then type your text inside 
the shape. You can use the 
Home tab’s Font controls to 
format the text. When you finish, click outside of 
the shape.

Is there an easy way to 
draw a perfect circle or 
square?
Yes, Excel offers an easy 
technique for drawing 
circles and squares. Hold 
down the  key as 
you click and drag the 
shape to constrain the 
shape into a perfect circle or square. When you 
finish drawing the shape, release .

● The program draws the shape and 
adds edit handles around the 
shape’s edges.

Note: If you need to move or size the shape, see 
“Move or Resize a Graphic” later in this chapter.

5 Click and drag the mouse  to 
draw the shape.

6 When the shape is the size you 
want, release the mouse button.

4 Click the shape you want to draw.

  changes to .

1 Display the worksheet on which 
you want to draw the shape.

2 Click the Insert tab.

3 Click Shapes ( ).

Draw a Shape

Excel’s Shapes gallery comes with more than 150 
predefined objects called shapes (or sometimes 
AutoShapes) that enable you to quickly and easily 
draw anything from simple geometric figures such 
as lines, rectangles, and ovals, to more elaborate 
items such as starbursts, flowchart symbols, and 
callout boxes.

Draw a 
Shape

1

43

6

25
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Working 
with Excel

You use Microsoft Excel 
to create spreadsheets, 
which are documents that 
enable you to manipulate 
numbers and formulas to 
quickly create powerful 
mathematical, financial, 
and statistical models. In 
this chapter you learn about 
Excel, take a tour of the 
program’s features, and 
learn how to customize 
some aspects of the 
program.
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Add a Function
A function is a predefined formula 
that performs a specific task. For 
example, the AVERAGE function 
calculates the average of a list of 
numbers, and the PMT function 
calculates a loan or mortgage 
payment. You can use functions on 
their own, preceded by =, or as 
part of a larger formula. Click 
Insert Function ( ) to see a list 
of the available functions.

Add a Formula
A formula is a collection of 
numbers, cell addresses, and 
mathematical operators that 
performs a calculation. In Excel, 
you enter a formula in a cell by 
typing an equal sign (=) and 
then the formula text. For example, 
the formula =B1-B2 subtracts the 
value in cell B2 from the value in 
cell B1.

Add Data
You can insert text, numbers, and 
other characters into any cell in the 
spreadsheet. Click the cell that you 
want to work with and then type 
your data in the Formula bar. This is 
the large text box above the column 
letters. Your typing appears in the 
cell that you selected. When you are 
done, press Enter. To edit existing 
cell data, click the cell and then edit 
the text in the Formula bar.

Working with Excel involves two basic 
tasks: building a spreadsheet and then 
manipulating the data on the spreadsheet.

This section just gives you an overview of these tasks. 
You learn about each task in greater detail as you work 
through the book.

Getting to 
Know Excel

Vol. 01 Vol. 01 

Excel 101

Excel 101

Excel 101

Excel 101

Build a Spreadsheet
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Add a Chart
A chart is a graphic representation of spreadsheet 
data. As the data in the spreadsheet changes, the 
chart also changes to reflect the new numbers. Excel 
offers a wide variety of charts, including bar charts, 
line charts, and pie charts.

Manage Tables
The row-and-column format of a spreadsheet makes 
the program suitable for simple databases called 
tables. Each column becomes a field in the table, and 
each row is a record. You can sort the records, filter 
the records to show only certain values, and add 
subtotals.

Fill a Series
Excel enables you to save time by completing a series 
of values automatically. For example, if you need to 
enter the numbers 1 to 100 in consecutive cells, you 
can enter just the first few numbers, select the cells, 
and then click and drag the lower right corner to fill 
in the rest of the numbers. Most programs also fill in 
dates, as well as the names for weekdays and months.

Calculate Totals Quickly
If you just need a quick sum of a list of numbers, click 
a cell below the numbers and then click the Sum 
button ( ), which is available in the Home tab of 
Excel’s Ribbon. In Excel, you can also select the cells 
that you want to sum, and their total appears in the 
status bar.

Manipulate Data
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CLOSE
CLOSE
CLOSE

OPENOPENOPENOPEN
EXCELEXCELEXCEL

 The App Programs menu appears.

3 Click Microsoft Office.

1 Click Start.

 The Start menu appears.

2 Click All Programs.

Start Excel

Before you can perform tasks such as adding 
data and building formulas, you must first 
start Excel. This brings the Excel window 
onto the Windows desktop, and you can 
then begin using the program.

This task and the rest of the book assume that you have 
already installed Excel 2010 on your computer.

Start 
Excel
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 The Microsoft Excel window 
appears on the desktop.

 The Microsoft Office menu 
appears.

4 Click Microsoft Excel 2010.

Are there faster methods I can use to start Excel?
Yes. After you have used Excel a few times, it should appear on the main Start 
menu in the list of your most-used programs. If so, you can click that icon to 
start the program. You can also force the Excel icon onto the Start menu by 
following Steps 1 to 3, right-clicking the Microsoft Excel 2010 icon, and 
then clicking Pin to Start Menu. If you are using Windows 7, you can also 
click Pin to Taskbar to add the Excel icon to the taskbar.
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Tour the Excel 
Window

To get up to speed quickly with Excel, it helps to understand the various elements of the 
Excel window. These include standard window elements such as the title bar and status bar, 
as well as Office-specific elements such as the Ribbon and the File tab.

Title Bar
The title bar displays the name of 
the current workbook.

Quick Access Toolbar
This area gives you one-click access 
to a few often-used features. To 
learn how to customize this 
toolbar, see “Customize the Quick 
Access Toolbar.”

Ribbon
This area gives you access to all of 
Excel’s commands, options, and 
features. To learn how to use this 
element, see “Work with Excel’s 
Ribbon.”

Excel Window Controls
You use these controls to minimize, 
maximize, restore, and close Excel’s 
application window.

Workbook Window Controls
You use these controls to minimize, 
maximize, restore, and close the 
current workbook window.

File Tab
Click this tab to access file-related 
commands, such as Save and 
Open.

Worksheet
This area displays the current 
worksheet, and it is where you will 
do most of your Excel work.

Status Bar
This area displays the messages 
about Excel’s current status, the 
results of certain operations, and 
other information.
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 Excel displays the controls in the 
tab.

● Each tab is organized into groups 
of related controls, and the group 
names appear here.

● In many groups you can click the 
dialog box launcher button ( ) 
to display a dialog box that 
contains group settings.

2 Click the control for the feature.

● If the control displays a list of 
options, click the option you want.

 Excel runs the command or sets 
the option.

1 Click the tab that contains the 
Excel feature you want to work 
with.

Work with Excel’s Ribbon

Hom
e

Hom
e

Excel Ribbon
Excel Ribbon

You use Excel’s Ribbon element to access all of the program’s 
features and commands. The Ribbon is the horizontal strip 
that runs across the top of the Excel window, just below the 
title bar. The Ribbon is organized into various tabs, such as 
File, Home and Insert, and each tab contains related controls, 
which usually include buttons, lists, and check boxes.

There is no menu bar in Excel, so you do not use pull-down menus to access commands.

Work with 
Excel’s Ribbon
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Picture Effects GalleryPicture Effects GalleryPicture Effects Gallery

 Excel displays a list of the gallery’s 
contents.

4 Move the mouse  over a gallery 
option to see a preview of the 
effect.

● Excel displays a preview of the 
effect.

5 Click the gallery option you want 
to use.

 Excel applies the gallery options to 
the selected object.

Work with a Gallery List

1 If necessary, click the object with 
which you want to apply an 
option from the gallery.

2 Click the tab that contains the 
gallery you want to use.

3 Click the gallery’s More arrow 
( ).

● You can also scroll through the 
gallery by clicking the Down ( ) 
and Up ( ) arrows.

Work with Excel’s Galleries

In Excel’s Ribbon, a gallery is a collection 
of preset options that you can apply to the 
selected object in the worksheet. To get the 
most out of galleries, you need to know how 
they work.

Although some galleries are available all the time, in most 
cases you must select an object — such as a range of cells or 
a clip art image — before you work with a gallery.

Work with 
Excel’s Galleries
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If I find the gallery preview feature distracting, can I turn it off?
Yes. The Live Preview feature is often handy because it shows you exactly 
what will happen when you click a gallery option. However, as you move 
the mouse  through the gallery, the previews can be distracting. To turn 
off Live Preview, click the File tab, click Options, click the General tab, 
click Enable Live Preview (  changes to ), and then click OK.

Work with a Drop-Down Gallery

1 If necessary, click the object with 
which you want to apply an 
option from the gallery.

2 Click the tab that contains the 
gallery you want to use.

3 Click the gallery’s drop-down 
arrow ( ).

 Excel displays a list of the gallery’s 
contents.

4 If the gallery contains one or more 
subgalleries, click the subgallery 
you want to use.

 Excel displays the subgallery’s 
contents.

● If a gallery has commands that you 
can run, those commands appear 
at the bottom of the gallery menu.

5 Move the mouse  over a gallery 
option to see a preview of the 
effect.

● Excel displays a preview of the 
effect.

6 Click the gallery option you want 
to use.

 Excel applies the gallery option to 
the selected object.
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 The Excel Options dialog box 
appears.

● Excel automatically displays the 
Quick Access Toolbar tab.

3 Click the Choose commands 
from .

4 Click the command category you 
want to use.

1 Click the Customize Quick 
Access Toolbar button ( ).

● If you see the command you 
want, click it and skip the rest of 
the steps in this section.

2 Click More Commands.

Customize the Quick Access Toolbar

You can make Excel easier to use by 
customizing the Quick Access Toolbar to 
include the Excel commands you use most 
often. You run Quick Access Toolbar buttons 
with a single click, so adding your favorite 
commands saves time.

By default, the Quick Access Toolbar contains three buttons: 
Save, Undo, and Redo, but you can add any of Excel’s 
hundreds of commands.

Customize the Quick 
Access Toolbar
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● Excel adds a button for the 
command to the Quick Access 
Toolbar.

5 Click the command you want 
to add.

6 Click Add.

● Excel adds the command.

● To remove a command, click it 
and then click Remove.

7 Click OK.

Is there a faster way to add 
buttons to the Quick Access 
Toolbar?
Yes. If the command you want 
to add appears on the Ribbon, 
you can add a button for the 
command directly from the 
Ribbon. Click the Ribbon tab 
that contains the command, right-click the command, 
and then click Add to Quick Access Toolbar. Excel 
inserts a button for the command on the Quick 
Access Toolbar.

Can I get more room on 
the Quick Access Toolbar 
to show more buttons?
Yes, you can increase the 
space available to the Quick 
Access Toolbar by moving it 
below the Ribbon. This gives 
the toolbar the full width of 
the Excel window, so you can 
add many more buttons. Click the Customize 
Quick Access Toolbar button ( ) and then click 
Show Below the Ribbon.
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Add a New Tab or Group

 The Excel Options dialog box 
appears.

● Excel automatically displays the 
Customize Ribbon tab.

1 Click the tab you want to 
customize.

● You can also click New Tab to 
create a custom tab.

2 Click New Group.

● Excel adds the group.

3 Click Rename.

4 Type a name for the group.

5 Click OK.

Display the Customize Ribbon 
Tab

1 Right-click any part of the Ribbon.

2 Click Customize the Ribbon.

Customize the Ribbon

You can improve your Excel productivity by 
customizing the Ribbon with extra commands 
that you use frequently.

To add a new command to the Ribbon, you must first create a 
new tab or a new group within an existing tab, and then add 
the command to the new tab or group.

Customize 
the Ribbon
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How do I restore the Ribbon 
to its default configuration?
Right-click any part of the Ribbon 
and then click Customize the 
Ribbon to display the Excel 
Options dialog box with the 
Customize Ribbon tab displayed. 
To restore a tab, click the tab, click Restore 
Defaults, and then click Restore only selected 
Ribbon tab. To remove all customizations, click 
Restore Defaults and then click Restore all Ribbon 
tabs and Quick Access Toolbar customizations.

Can I customize the tabs 
that appear only when I 
select an Excel object?
Yes. Excel calls these tool tabs, 
and you can add custom groups 
and commands to any tool tab. 
Right-click any part of the Ribbon 
and then click Customize the Ribbon to display the 
Excel Options dialog box with the Customize Ribbon 
tab displayed. Click the Customize the Ribbon  
and then click Tool Tabs. Click the tab you want and 
then follow the steps in this section to customize it.

Add a Command

1 Click the Choose commands 
from .

2 Click the command category you 
want to use.

3 Click the command you want to 
add.

4 Click the custom group or tab you 
want to use.

5 Click Add.

● Excel adds the command.

● To remove a custom command, 
click it and then click Remove.

6 Click OK.

● Excel adds the new group and 
command to the Ribbon.

03_577646-ch01.indd   1503_577646-ch01.indd   15 3/8/10   6:53 PM3/8/10   6:53 PM



16

22

11

2 Click the smart tag.

● The smart tag displays a list of its 
options.

1 Perform an action that displays a 
smart tag, such as copying and 
pasting a cell as shown here.

● The smart tag appears.

Work with Smart Tags

You can make your Excel work faster and easier 
by taking advantage of smart tags. A smart tag 
is a special icon that appears when you perform 
certain Excel tasks, such as pasting data and 
using the AutoFill feature. Clicking the smart 
tag displays a list of options that enable you to 
control or modify the task you just performed.

Some smart tags appear automatically in response to certain 
conditions. For example, if Excel detects an inconsistent formula, 
it displays a smart tag to let you know.

Work with 
Smart Tags
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Are there other types of smart tags I can use?
Yes, Excel offers a few other smart tag types. For example, a Date smart 
tag recognizes a worksheet date and offers options such as scheduling 
a meeting on that date. To turn on these extra smart tags, click File, 
click Options, click Proofing, click AutoCorrect Options, and then 
click the Smart Tags tab. Click the Label data with smart tags check 
box (  changes to ), and then click the check box beside each 
smart tag in the Recognizers list (  changes to ). Click OK.

● Excel applies the option to the 
task you performed in Step 1.

3 Click the option you want to 
apply.
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Switch to Page Break Preview

1 Click the View tab.

2 Click Page Break Preview.

● You can also click the Page 
Break Preview button ( ).

Switch to Page Layout View

1 Click the View tab.

2 Click Page Layout.

● You can also click the Page 
Layout button ( ).

● Excel switches to Page Layout 
view.

Change the View

You can adjust the Excel window to suit what you are currently 
working on by changing the view to match your current task. 
Excel offers three different views: Normal, which is useful for 
building and editing worksheets; Page Layout, which displays 
worksheets as they would appear if you printed them out; and 
Page Break Preview, which displays the page breaks as blue 
lines, as described in the first Tip on the next page.

Excel offers three different views: Page Layout, which displays worksheets as printed pages; Page Break Preview, which 
displays the page breaks as blue lines, as described in the first Tip on the next page; and Normal, which is useful for building 
and editing worksheets.

Change 
the View
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Switch to Normal View

1 Click the View tab.

2 Click Normal.

● You can also click the Normal 
button ( ).

 Excel switches to Normal view.

● The Welcome to Page Break 
Preview dialog box appears.

● Excel switches to Page Break 
Preview.

3 Click OK.

PAGE 1PAGE 1PAGE 1

PAGE 2

PAGE 2

PAGE 2 AA
11
22
33

BB CC
What does Full Screen 
view do?
Full Screen view is useful 
when you want to see the 
maximum amount of a 
worksheet on the screen. 
Full Screen view removes 
many of the Excel window features, 
including the File button, Ribbon, Quick 
Access Toolbar, Formula bar, and status bar. 
To return to the Normal view, press , or 
click the Restore Down button ( ).

What does Page Break 
Preview do?
In Excel, a page break is a position 
within a worksheet where a new 
page begins when you print the 
worksheet. When you switch to Page 
Break Preview, Excel displays the 
page breaks as blue lines. If a page 
break occurs in a bad position — for example, the page 
break includes the headings from a range, but not the cells 
below the headings — you can use your mouse  to click 
and drag the page breaks to new positions.
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HARDWARE

2 Click Options.

1 Click the File tab.

Configure Excel Options

You can customize Excel and set up the 
program to suit the way you work by 
configuring the Excel options. To use these 
options, you must know how to display the 
Excel Options dialog box.

These options are dialog box controls such as check boxes, option 
buttons, and lists that enable you to configure many aspects of 
Excel.

Configure 
Excel Options
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How do I know what each 
option does?
Excel offers pop-up 
descriptions of some — 
but, unfortunately, not 
all — of the options. If you 
see a small i with a circle 
around it to the right of the 
option name, it means pop-up help 
is available for that option. Hover the mouse  
over the option and Excel displays a pop-up 
description of the option after a second or two.

Are there faster methods I can 
use to open the Excel Options 
dialog box?
Yes. Some features of the Excel 
interface offer shortcut methods that 
get you to the Excel Options dialog 
box faster. For example, right-click 
the Ribbon and then click Customize 
Ribbon to open the Excel Options dialog box with 
the Customize Ribbon tab displayed. From the 
keyboard, you can open the Excel Options dialog box 
by pressing +  and then pressing .

4 Use the controls on the right side 
of the dialog box to configure the 
options you want to change.

5 Click OK.

 Excel puts the new options into 
effect.

 The Excel Options dialog box 
appears.

3 Click a tab on the left side of 
the dialog box to choose the 
configuration category you want 
to work with.

● The controls that appear on the 
right side of the dialog box change 
according to the tab you select.
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● After you quit Excel, the icon 
remains on the taskbar, and you 
can now launch Excel by clicking 
the icon.

1 With Excel running, right-click the 
Excel icon in the taskbar.

2 Click Pin this program to 
taskbar.

Add Excel to the Windows 7 Taskbar

If you use Excel regularly, you can start the program 
with just a single mouse click by adding an icon for 
Excel to the Windows 7 taskbar.

This task requires that you are running Excel using the Windows 7 
operating system.

Add Excel to the 
Windows 7 Taskbar
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Quit Excel Using the Taskbar

1 Right-click the Excel taskbar icon.

2 Click Close window.

Note: If you have any open documents with 
unsaved changes, Excel prompts you to save those 
changes.

Quit Excel Using the Office Menu

1 Click the File tab.

2 Click Exit.

Note: If you have any open documents with 
unsaved changes, Excel prompts you to save those 
changes.

Note: Another way to quit the program is to press 
+ .

Quit Excel

When you have finished your work with Excel, you should 
shut down the program. This reduces clutter on the 
desktop and in the taskbar, and it also conserves memory 
and other system resources.

Quit 
Excel
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Entering and Editing 
Excel Data

Are you ready to start 
building a spreadsheet? 
To create a spreadsheet 
in Excel, you must know 
how to enter data into the 
worksheet cells, and how to 
edit that data to fix typos, 
adjust information, and 
remove data you no longer 
need.
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In Excel, a spreadsheet file is called a workbook, and each workbook consists of one or more 
worksheets. These worksheets are where you enter your data and formulas, so you need to 
know the layout of a typical worksheet.

Learning the Layout 
of a Worksheet

Cell
A cell is a box in 
which you enter your 
spreadsheet data.

Column
A column is a vertical 
line of cells. Each 
column has a unique 
letter that identifies 
it. For example, the 
leftmost column is A, 
and the next column 
is B.

Row
A row is a horizontal 
line of cells. Each 
row has a unique 
number that 
identifies it. For 
example, the 
topmost row is 1, 
and the next row 
is 2.

Cell Address
Each cell has its own address, 
which is determined by the letter 
and number of the intersecting 
column and row. For example, 
the cell at the intersection of 
column C and row 10 has the 
address C10.

Range
A range is a rectangular grouping 
of two or more cells. The range 
address is given by the address of 
the top-left cell and the address of 
the bottom-right cell. H12:K16 is 
an example of a range of cells, and 
it refers to all of the cells selected 
between column H, cell 12 and 
column K, cell 16.

Worksheet Tab
The worksheet tab displays the 
worksheet name. Most workbooks 
contain multiple worksheets, and 
you use the tabs to navigate 
between the worksheets.

Mouse Pointer
Use the Excel mouse  to select 
cells.
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chapter2Understanding the Types 
of Data You Can Use

To build a spreadsheet in Excel, it helps to understand the 
three main types of data that you can enter into a cell: text, 
numbers, and dates and times.

TimesTimes

NumbersNumbers
DatesDates

TextText

Text
Text entries can include any combination of letters, symbols, and 
numbers. You will mostly use text to describe the contents of 
your worksheets. This is very important because even a modest-
sized spreadsheet can become a confusing jumble of numbers 
without some kind of text guidelines to keep things straight. 
Most text entries are usually labels such as Sales or Territory that 
make a worksheet easier to read. However, text entries can also 
be text/number combinations for items such as phone numbers 
and account codes.

A L I E N

1 9 7 9

R I D L E Y  

S C O T T

1 9 8 0

S T A N L E Y

K U B R I C

S T E VS P

1 9 8 0
N G

01000111110110110101000111110001
101000011111010110101100101010110
100111001001101010001110011011010
010010111010100101010110110000110
01000111110110110101000111110001
101000011111010110101100101010110
100111001001101010001110011011010
010010111010100101010110110000110
01000111110110110101000111110001
101000011111010110101100101010110
100111001001101010001110011011010
010010111010100101010110110000110

8/23/2010

Numbers
Numbers are the most common type of Excel data. The numbers 
you enter into a cell can be dollar values, weights, interest rates, 
temperatures, or any other numerical quantity. In most cases 
you just type the number that you want to appear in the cell. 
However, you can also precede a number with a dollar sign ($) or 
other currency symbol to indicate a monetary value, or follow a 
number with a percent sign (%) to indicate a percentage value.

Dates and Times
Date entries appear in spreadsheets that include dated data, such 
as invoices and sales. You can either type out the full date — such 
as August 23, 2010 — or use either the forward slash (/) or the 
hyphen (-) as a date separator — such as 8/23/2010 or 8-23-
2010. Note that the order you enter the date values depends on 
your regional settings. For example, in the United States the format 
is month/day/year. For time values, you use a colon (:) as a time 
separator, followed by either AM or PM — such as 9:15 AM.
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2 Start typing your text.

● Excel opens the cell for editing 
and displays the text as you type.

● Your typing also appears in the 
Formula bar.

Note: Rather than typing the text directly into 
the cell, you can also type the text into the 
Formula bar.

1 Click the cell in which you want 
to enter the text.

● Excel marks the current cell by 
surrounding it with a thick, black 
border.

Enter Text into a Cell

Your first step when building a spreadsheet is 
usually to enter the text data that defines the 
spreadsheet’s labels or headings. Most labels 
appear in the cell to the right or above where the 
data will appear, while most headings appear at 
the top of a column of data or to the left of a 
row of data.

Enter Text 
into a Cell
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When I start typing text into 
a cell, why does Excel 
sometimes display the text 
from another cell?
This is part of an Excel feature 
called AutoComplete. If the 
letters you type at the start of 
a cell match the contents of 
another cell in the worksheet, 
Excel fills in the full text from the other cell under the 
assumption that you are repeating the text in the 
new cell. If you want to use the text, click  or 
press ; otherwise, just keep typing your text.

When I press Enter the 
selection moves to the 
next cell down. Can I 
make the selection 
move to the right 
instead?
Yes. When you have 
finished adding the data 
to the cell, press . This 
tells Excel to close the current cell for editing 
and move the selection to the next cell on the 
right. If you prefer to move left instead, press 

; if you prefer to move up, press .

● Excel closes the cell for editing.

● If you pressed , Excel 
moves the selection to the cell 
below.

3 When your text entry is complete, 
press .

● If you do not want Excel to move 
the selection, click Enter ( ) or 
press +  instead.
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B1 + B2 = 13.4
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AutoSum

2 Start typing your number.

● Excel opens the cell for editing 
and displays the number as you 
type.

● Your typing also appears in the 
Formula bar.

Note: Rather than typing the number directly into 
the cell, you can also type the number into the 
Formula bar.

1 Click the cell in which you want to 
enter the number.

● Excel marks the current cell by 
surrounding it with a thick, black 
border.

Enter a Number into a Cell

Excel is all about numbers, so most of your 
worksheets will include numeric values. To get 
the most out of Excel, you need to know how 
to enter numeric values, including percentages 
and currency values.

Enter a Number 
into a Cell
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Is there a quick 
way to repeat a 
number rather 
than entering the 
entire number all 
over again?
Excel offers a few 
methods for doing 
this. The easiest 
method is to select the cell directly below 
the value you want to repeat and then 
press +’. Excel adds the value to the 
cell. For another method, see “Fill a Range 
with the Same Data” in Chapter 3.

Can I use symbols such as a 
comma, decimal point, or minus 
sign when I enter a numeric 
value?
Yes. If your numeric value is in the 
thousands, you can include the 
thousands separator (,) within the 
number. For example, if you enter 
10000, Excel displays the value as 
10000; however, if you enter 10,000, Excel displays the value 
as 10,000, which is easier to read. If your numeric value 
includes one or more decimals, you can include the decimal 
point ( .) when you type the value. If your numeric value is 
negative, precede the value with a minus sign (–).

● Excel closes the cell for editing.

● To enter a percentage value, type 
the number followed by a percent 
sign (%).

● To enter a currency value, type 
the dollar sign ($) followed by the 
number.

3 When your number is complete, 
press .

● If you do not want Excel to move 
the selection, click Enter ( ) or 
press +  instead.
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2 Type the date.

Note: The format you use depends on your 
location. In the United States, for example, you can 
use the month/day/year format — 8/23/2010. 
See the Tip on the next page.

3 When your date is complete, press 
.

● If you do not want Excel to move 
the selection, click Enter ( ) or 
press +  instead.

 Excel closes the cell for editing.

Enter a Date

1 Click the cell in which you want to 
enter the date.

● Excel marks the current cell by 
surrounding it with a thick, black 
border.

Enter a Date or Time into a Cell

Many Excel worksheets use dates and times 
either as part of the sheet data or for use in 
calculations, such as the number of days an 
invoice is overdue. For these and similar uses, 
you need to know how to enter date and time 
values into a cell.

Enter a Date or 
Time into a Cell
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2 Type the time.

Note: The general format for entering a time 
is hour:minute:second AM/PM; for example, 
3:15:00 PM. See the following Tip.

3 When your time is complete, 
press .

● If you do not want Excel to move 
the selection, click Enter ( ) or 
press +  instead.

 Excel closes the cell for editing.

Enter a Time

1 Click the cell in which you want to 
enter the time.

● Excel marks the current cell by 
surrounding it with a thick, black 
border.
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How can I tell which date and time formats my 
version of Excel accepts?
Follow these steps:

1 Click the Home tab.

2 Click the dialog box launcher button in the bottom right 
corner of the Number group.

3 Click the Number tab.

4 Click Date.

5 Click the Locale (location) drop-down arrow  
and then click your location.

6 Examine the Type list to see the formats you can use 
to enter dates.

7 Click Time.

8 Examine the Type list to see the formats you can use 
to enter times.

9 Click Cancel.
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3 Click the Insert tab.

4 Click Symbol.

1 Click the cell in which you want 
the symbol to appear.

2 Type the text that you want to 
appear before the symbol, if any.

Insert a Symbol

You can make your Excel worksheets more 
readable and more useful by inserting 
special symbols that are not available via 
your keyboard’s standard keys.

These special symbols include foreign characters such as 
ö and é, mathematical symbols such as ÷  and ∞, financial 
symbols such as ¢ and ¥, commercial symbols such as 
© and ®, and many more.

Insert a 
Symbol
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Are there keyboard shortcuts available for symbols I use 
frequently?
Yes, in many cases. In the Symbol dialog box, click  in the from list and 
select ASCII (decimal). Click the symbol you want to insert and then 
examine the number in the Character code text box. This number tells you 
that you can enter the symbol via the keyboard by holding down , 
pressing , and then typing the number. For example, you can enter the © 
symbol by pressing + . Be sure to type all the numbers using 
your keyboard’s numeric keypad.

8 Repeat Steps 6 and 7 to insert 
any other symbols you require.

9 Click Close.

 The Symbol dialog box appears.

5 Click the Symbols tab.

6 Click the symbol you want to 
insert.

Note: Many other symbols are available in the 
Webdings and Wingdings fonts. To see these 
symbols, click the Font , and then click either 
Webdings or Wingdings.

7 Click Insert.

● Excel inserts the symbol.
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● Excel opens the cell for editing 
and moves the cursor to the end 
of the existing data.

● Excel displays Edit in the status 
bar.

● You can also click inside the 
Formula bar and edit the cell data 
there.

3 Make your changes to the cell 
data.

1 Click the cell in which you want to 
edit the text.

2 Press .

 You can also double-click the cell 
you want to edit.

Edit Cell Data

If the data you entered into a cell has changed 
or is incorrect, you can edit the data. You can 
edit cell data either directly in the cell or by 
using the Formula bar.

Edit Cell 
Data
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I made a mistake when I 
edited a cell. Do I have to fix 
the text by hand?
 Most likely not. If the cell edit was 
the last action you performed in 
Excel, press +  or click the 
Undo button ( ) in the Quick 
Launch Toolbar. If you have 
performed other actions in the 
meantime, click the Undo  and then click the edit 
in the list that appears. Note, however, that doing this 
will also undo the other actions you performed after 
the edit.

Is there a faster way 
to open a cell for 
editing?
Yes. Move  over the 
cell you want to edit, and 
center  over the 
character where you want 
to start editing. Double-
click the mouse. Excel 
opens the cell for editing and positions the 
cursor at the spot where you double-clicked.

● Excel closes the cell for editing.

● If you pressed , Excel 
moves the selection to the cell 
below.

4 When you finish editing the data, 
press .

● If you do not want Excel to move 
the selection, click Enter ( ) or 
press +  instead.
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= SUM + 22
= SUM + 22

BUDGET
BUDGET

2 Click the Home tab.

3 Click Clear ( ).

4 Click Clear Contents.

Note: You can also delete cell data by pressing 
Delete .

Delete Cell Data

1 Select the cell that contains the 
data you want to delete.

Delete Data from a Cell

If your worksheet has a cell that contains data 
you no longer need, you can delete that data. 
This helps to reduce worksheet clutter and makes 
your worksheet easier to read.

If you want to delete data from multiple cells, you must first select 
those cells; see “Select a Range” in Chapter 3. To delete cells and 
not just the data, see “Delete a Range” in Chapter 3.

Delete Data 
from a Cell
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BOLDBOLD= SUM + 22

= SUM + 22

CLEAR

Is it possible to delete 
just a cell’s formatting?
Yes. Excel offers a command 
that deletes just the cell 
formatting while leaving the 
cell data intact. Select the cell 
with the formatting that you 
want to delete. Click Home, 
click , and then click Clear 
Formats. Excel removes just the formatting from 
the selected cell.

When I delete cell data, 
Excel keeps the cell 
formatting intact. Is it 
possible to delete the data 
and the formatting?
Yes. Excel offers a command 
that deletes everything from a 
cell. First, select the cell with 
the data and formatting that 
you want to delete. Click Home, click , and then 
click Clear All. Excel removes both the data and 
the formatting from the selected cell.

Undo Cell Data Deletion

1 Click the Undo .

2 Click Clear.

Note: If the data deletion was the most recent 
action you performed, you can undo it by pressing 

+  or by clicking Undo ( ).

● Excel restores the data to the cell.

● Excel removes the cell data.
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HELLO
my range name is

SalesSalesSales

Working with 
Excel Ranges

In Excel, a range is a 
collection of two or more 
cells that you work with as a 
group rather than separately. 
This enables you to fill the 
range with values, move or 
copy the range, sort the 
range data, filter the range to 
show only certain values, 
and insert and delete ranges. 
You learn these and other 
range techniques in this 
chapter, and in later chapters 
you learn techniques such as 
formatting a range, applying 
a formula to a range, and 
building a chart from a 
range.
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Select a Range of Individual 
Cells

1 Click in the first cell that you want 
to include in the range.

2 Hold down  and click in each 
of the other cells that you want to 
include in the range.

● Each time you click in a cell, Excel 
adds it to the range.

3 Release  to end the range 
selection.

Select a Rectangular Range

1 Position  over the first cell you 
want to include in the range.

2 Click and drag  over the cells 
that you want to include in the 
range.

● Excel selects the cells.

3 Release the mouse button to end 
the range selection.

Select a Range

To work with a range in Excel, you must 
select the cells that you want to include in the 
range. After you select the range, you can fill 
it with data, move it to another part of the 
worksheet, format the cells, and so on.

You can select a range as a rectangular group of cells, as a 
collection of individual cells, or as an entire row or column.

Select 
a Range
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Is there an 
easy way to 
select every 
cell in the 
worksheet?
Yes. Excel offers two methods you can 
use. Either press + , or click 
the Select All button ( ) in the 
upper left corner of the worksheet.

Are there keyboard techniques I can 
use to select a range?
Yes. To select a rectangular range, navigate 
to the first cell that you want to include in 
the range, hold down , and then 
press  or  to extend the selection. To 
select an entire row, navigate to any cell in 
the row and press + . To 
select an entire column, navigate to any 
cell in the column and then press + .

Select an Entire Column

1 Position  over the header of the 
column you want to select.

  changes to .

2 Click the column header.

● Excel selects the entire column.

 To select multiple columns, click 
and drag across the column 
headers, or hold down  and 
click each column header.

Select an Entire Row

1 Position  over the header of the 
row you want to select.

  changes to .

2 Click the row header.

● Excel selects the entire row.

 To select multiple rows, click and 
drag across the row headers or 
hold down  and click each 
row header.
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Fill a Vertical or Horizontal 
Range

1 In the first cell of the range you 
want to work with, enter the data 
you want to fill.

2 Position  over the bottom-right 
corner of the cell.

  changes to .

3 Click and drag  down to fill a 
vertical range or across to fill a 
horizontal range.

4 Release the mouse button.

● Excel fills the range with the initial 
cell value.

Fill a Range with the Same Data

If you need to fill a range with the same data, you 
can save time by getting Excel to fill the range for 
you. Excel’s AutoFill feature makes it easy to fill a 
vertical or horizontal range with the same value, 
but you can also fill any selected range.

See “Select a Range” to learn how to select a range of cells.

Fill a Range with 
the Same Data
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How do I fill a vertical or horizontal range without also 
copying the formatting of the original cell?
Follow these steps:

1 Perform Steps 1 to 4 to fill the data.

● Excel displays the AutoFill Options smart tag ( ).

2 Click the AutoFill Options .

3 Click Fill Without Formatting.

 Excel removes the original cell’s formatting from the copied cells.

● Excel fills the range with the value 
you typed.

Fill a Selected Range

1 Select the range you want to fill.

2 Type the text, number, or other 
data.

3 Press + .
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AutoFill a Series of Numeric, 
Date, or Alphanumeric Values

1 Click in the first cell and type the 
first value in the series.

2 Click in an adjacent cell and type 
the second value in the series.

3 Select the two cells.

4 Position  over the bottom-right 
corner of the second cell.

  changes to .

5 Click and drag  down to fill a 
vertical range or across to fill a 
horizontal range.

● As you drag through each cell, 
Excel displays the series value that 
it will add to the cell.

6 Release the mouse button.

● Excel fills the range with a series 
that continues the pattern of the 
initial two cell values.

Fill a Range with a Series of Values

If you need to fill a range with a series of values, you 
can save time by using Excel’s AutoFill feature to 
create the series for you. AutoFill can fill a series of 
numeric values such as 5, 10, 15, 20, and so on; a 
series of date values such as January 1, 2011, January 
2, 2011, and so on; or a series of alphanumeric values 
such as Chapter 1, Chapter 2, Chapter 3, and so on.

You can also create your own series with a custom step value, which 
determines the numeric difference between each item in the series.

Fill a Range with 
a Series of Values
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Fill a Custom Series of Values

1 Click in the first cell and type the 
first value in the series.

2 Select the range you want to fill, 
including the initial value.

3 Click the Home tab.

4 Click Fill ( ).

5 Click Series.

 The Series dialog box appears.

6 In the Type group, select the 
type of series you want to fill 
(  changes to ).

7 If you selected Date in Step 6, 
select an option in the Date unit 
group (  changes to ).

8 In the Step value text box, type the 
value you want to use.

9 Click OK.

● Excel fills the range with the series 
you created.

88

7755

66

Can I create my own AutoFill series?
Yes. Follow these steps:

1 Click the File tab.

2 Click Options.

3 Click Advanced.

4 Click Edit Custom Lists.

5 Click NEW LIST.

6 In the List entries box, 
type each item in your 
list, and press  
after each item.

7 Click Add.

8 Click OK.

47
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Move a Range

1 Select the range you want to 
move.

2 Position  over any outside 
border of the range.

  changes to .

3 Click and drag the range to the 
new location.

  changes to .

● Excel displays an outline of the 
range.

● Excel displays the address of the 
new location.

4 Release the mouse button.

● Excel moves the range to the new 
location.

Move or Copy a Range

You can restructure or reorganize a worksheet 
by moving an existing range to a different 
part of the worksheet.

You can also make a copy of a range, which is a useful 
technique if you require either a duplicate of the range 
elsewhere, or if you require a range that is similar to an 
existing range.

Move or 
Copy a Range
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Can I move or copy a range 
to another workbook?
Yes. If you can see the other 
workbook on-screen, click and 
drag the range as described in 
this section, and then drop it on 
the other workbook. Remember 
to hold down  if you are 
copying the range. Otherwise, 
select the range, click the Home tab, click Cut ( ) to 
move the range or Copy ( ) to copy it, switch to the 
other workbook, select the cell where you want the 
range to appear, click Home, and then click Paste ( ).

Can I move or copy a 
range to another 
worksheet?
Yes. Click and drag the 
range as described in 
this section. Remember 
to hold down  if 
you are copying the 
range. Press and hold 

 and then drag the mouse pointer over 
the tab of the sheet you want to use as the 
destination. Excel displays the worksheet. 
Release  and then drop the range on the 
worksheet.

Copy a Range

1 Select the range you want to copy.

2 Press and hold .

3 Position  over any outside 
border of the range.

  changes to .

4 Click and drag the range to the 
location where you want the copy 
to appear.

● Excel displays an outline of the 
range.

● Excel displays the address of the 
new location.

5 Release the mouse button.

6 Release .

● Excel creates a copy of the range 
in the new location.
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● Excel inserts the new row.

● The rows below the new row are 
shifted down.

5 Click the Format smart tag ( ).

6 Select a formatting option for the 
new row (  changes to ).

Insert a Row

1 Click in any cell in the row above 
where you want to insert the 
new row.

2 Click the Home tab.

3 Click the Insert .

4 Click Insert Sheet Rows.

Insert a Row or Column

You can insert a row or column into your 
existing worksheet data to accommodate more 
information. This is particularly useful if the 
information you need to add fits naturally 
within the existing data, rather than at 
the end.

Insert a Row 
or Column
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Can I insert more than one row or column at a time?
Yes. You can insert as many new rows or columns as you need. First, select the 
same number of rows or columns that you want to insert. (See “Select a Range” 
earlier in this chapter to learn how to select rows and columns.) For example, if 
you want to insert four rows, select four existing rows. Follow Steps 2 to 4 in 
“Insert a Row” to insert rows, or Steps 2 to 4 in “Insert a Column” to insert 
columns.

● Excel inserts the new column.

● The columns to the right of the 
new column are shifted to the 
right.

5 Click the Format smart tag ( ).

6 Select a formatting option for the 
new column (  changes to ).

Insert a Column

1 Click any cell in the row to the left 
of where you want to insert the 
new column.

2 Click the Home tab.

3 Click the Insert .

4 Click Insert Sheet Columns.
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2 Click the Home tab.

3 Click the Insert .

4 Click Insert Cells.

Note: You can also press + + = .

1 Select the cell or range where you 
want the inserted cell or range to 
appear.

Insert a Cell or Range

If you need to add data to an existing range, you 
can insert a single cell or a range of cells within 
that range.

When you insert a cell or range, Excel shifts the existing data to 
accommodate the new cells.

Insert a Cell 
or Range

05_577646-ch03.indd   5205_577646-ch03.indd   52 3/8/10   6:51 PM3/8/10   6:51 PM



53

Working with Excel Ranges chapter3

77
88

55

66

How do I know which 
cells to select to get my 
inserted cell or range in 
the correct position?
The easiest way to do this 
is to select the existing cell 
or range that is exactly 
where you want the new 
cell or range to appear. For 
example, if you want the new range to be A5:B5 as 
shown in this section’s example, you first select the 
existing A5:B5 range. When you insert the new 
range, Excel shifts the existing cells down (in this 
case) to accommodate it.

Under what 
circumstances would I 
insert a cell or range 
instead of inserting an 
entire row or column?
In most cases, it is better 
to insert a cell or range 
when you have other data 
either to the left or right 
of the existing range, or 
above or below the range. For example, if you 
have data to the left or right of the existing 
range, inserting an entire row would create a 
gap in the other data.

 The Insert dialog box appears.

5 Select the option that corresponds 
to how you want Excel to shift the 
existing cells to accommodate your 
new cells (  changes to ).

Note: In most cases, if you selected a horizontal 
range, click the Shift cells down option; if you 
selected a vertical range, click the Shift cells right 
option.

6 Click OK.

● Excel inserts the cell or range.

● The existing data is shifted down 
(in this case) or to the right.

7 Click the Format smart tag ( ).

8 Select a formatting option for the 
new row (  changes to ).
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2 Click the Home tab.

3 Click Clear ( ).

4 Click Clear Contents.

● If you want to delete the range 
data and its formatting, click 
Clear All instead.

Delete Range Data

1 Select the range that contains the 
data you want to delete.

Delete Data from a Range

If your worksheet has a range that contains 
data you no longer need, you can delete that 
data. This helps to reduce worksheet clutter 
and makes your worksheet easier to read.

If you want to delete cells and not just the data, see “Delete a 
Range” later in this chapter.

Delete Data 
from a Range
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Is it possible to delete a 
cell’s numeric formatting?
Yes. Select the range with the 
formatting that you want to 
delete, click Home, click , 
and then click Clear Formats. 
Excel removes all the 
formatting from the selected 
range. If you prefer to delete 
only the numeric formatting, click Home, click the 
Number Format , and then click General.

Are there faster ways 
to delete the data 
from a range?
Yes. Probably the fastest 
method is to select the 
range and then press 
Delete . You can also 

select the range, right-
click any part of the 
range, and then click Clear Contents.

Undo Range Data Deletion

1 Click the Undo .

2 Click Clear.

Note: If the data deletion was the most recent 
action you performed, you can undo it by pressing 

+  or by clicking Undo ( ).

● Excel restores the data to the 
range.

● Excel removes the range data.
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2 Click the Home tab.

3 Click the Delete .

4 Click Delete Cells.

1 Select the range that you want to 
delete.

Delete a Range

If your worksheet contains a range that you no 
longer need, you can delete that range. Note that 
when you delete a range, Excel deletes not just 
the data within the range, but the range cells 
themselves. Excel shifts the remaining worksheet 
data to replace the deleted range.

Delete 
a Range
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Shortcut
How do I delete a row or 
column?
To delete a row, select any cell 
in the row, click the Home tab, 
click the Delete , and then 
click Delete Sheet Rows. To 
delete a column, select any cell 
in the column, click the Home 
tab, click the Delete , and 
then click Delete Sheet Columns. Note, too, that 
you can delete multiple rows or columns by 
selecting at least one cell in each row or column.

Are there faster ways 
to delete a range?
Yes. Probably the fastest 
method is to select the 
range and then press 

+ . You can also 
select the range, right-
click any part of the 
range, and then click 
Delete. Both methods display the Delete 
dialog box.

 The Delete dialog box appears.

5 Select the option that corresponds 
to how you want Excel to shift the 
remaining cells after it deletes the 
range (  changes to ).

Note: In most cases, if you have data below the 
selected range, click the Shift cells up option; if 
you have data to the right of the selected range, 
click the Shift cells left option.

6 Click OK.

● Excel deletes the range and shifts 
the remaining data.
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36507778950

36507778950

36507778950

36507778957

36507778958

36507778959

36507778960

36507778961

NameNaammee
Aaron Bellmont

John Chatham

Paula Differen

Matt Principal

Cathy Rudman

Chris Vincent

Henry Willer

Jeremy Wright

PPPhone #
31

31

31

31

31

31

31

31

● Excel removes the row from the 
worksheet display.

● Excel displays a slightly thicker 
heading border between the 
surrounding rows to indicate that 
a hidden row lies between them.

 Another way to hide a row is to 
move  over the bottom edge 
of the row heading (  changes 
to ) and then click and drag 
the edge up until the height 
displays 0.

Hide a Row

1 Click in any cell in the row you 
want to hide.

2 Click the Home tab.

3 Click Format.

4 Click Hide & Unhide.

5 Click Hide Rows.

Note: You can also hide a row by pressing 
+ .

Hide a Row or Column

If you do not need to see or work with a row 
or column temporarily, you can make your 
worksheet easier to read and to navigate by 
hiding the row or column.

Hiding a row or column is also useful if you are showing 
someone a worksheet that contains private or sensitive data 
that you do not want the person to see.

Hide a Row 
or Column
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ID #ID  #
36507778950

36507778950

36507778950

36507778957

36507778958

How do I display a hidden row or column?
To display a hidden row, select the row above and the row below the hidden row, 
click Home, click Format, click Hide & Unhide, and then click Unhide Rows. 
Alternatively, move  between the headings of the selected rows (  changes 
to ) and then double-click. To unhide row 1, right-click the top edge of the row 
2 header and then click Unhide.

To display a hidden column, select the column to the left and the column to the 
right of the hidden column, click Home, click Format, click Hide & Unhide, and 
then click Unhide Columns. Alternatively, move  between the headings of the 
selected columns (  changes to ) and then double-click. To unhide column A, 
right-click the left edge of the column B header and then click Unhide.

● Excel removes the column from 
the worksheet display.

● Excel displays a slightly thicker 
heading border between the 
surrounding columns to indicate 
that a hidden column lies between 
them.

 Another way to hide a column is 
to move  over the right edge of 
the column heading (  changes 
to ) and then click and drag 
the edge left until the width 
displays 0.

Hide a Column

1 Click in any cell in the column you 
want to hide.

2 Click the Home tab.

3 Click Format.

4 Click Hide & Unhide.

5 Click Hide Columns.

Note: You can also hide a column by pressing 
+ .
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44● Excel splits the worksheet into two 
horizontal panes.

4 Click the View tab.

5 Click Freeze Panes.

6 Click Freeze Panes.

● If you want to freeze just the first 
row, you can bypass Steps 1 to 3 
and click the Freeze Top Row 
command.

 Excel freezes the panes.

Freeze Rows

1 Scroll the worksheet so that the 
row or rows that you want to 
freeze are visible.

2 Position  over the horizontal 
split bar ( ).

  changes to .

3 Click and drag  and drop it 
below the row you want to freeze.

Freeze Rows or Columns

You can keep your column labels in view as 
you scroll the worksheet by freezing the row 
or rows that contain the labels. This makes 
it easier to review and add data to the 
worksheet because you can always see the 
column labels.

If your worksheet also includes row labels, you can keep 
those labels in view as you horizontally scroll the worksheet 
by freezing the column or columns that contain the labels.

Freeze Rows 
or Columns
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How do I unfreeze a row 
or column?
If you no longer require a row 
or column to be frozen, you 
can unfreeze it by clicking 
View, clicking Freeze Panes, 
and then clicking Unfreeze 
Panes. If you no longer want 
your worksheet split into two 
panes, click View and then click Split ( ).

Can I adjust the position 
of a frozen row or column?
Yes. Begin by unfreezing the 
panes: click View, click Freeze 
Panes, and then click 
Unfreeze Panes. Excel 
unfreezes the panes and 
displays the split bar. Click and 
drag the split bar to the new 
location. Click View, click Freeze Panes, and then 
click Freeze Panes.

● Excel splits the worksheet into two 
vertical panes.

4 Click the View tab.

5 Click Freeze Panes.

6 Click Freeze Panes.

● If you want to freeze just the first 
column, you can bypass Steps 1 
to 3 and click the Freeze First 
Column command.

 Excel freezes the panes.

Freeze Columns

1 Scroll the worksheet so that the 
column or columns that you want 
to freeze are visible.

2 Position  over the vertical split 
bar ( ).

  changes to .

3 Click and drag  and drop it on 
the right edge of the column you 
want to freeze.
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2 Click the Home tab.

3 Click the Merge and Center .

4 Click Merge Cells.

1 Select the cells that you want to 
merge.

Merge Two or More Cells

You can create a single large cell by merging 
two or more cells. For example, it is 
common to merge some of the top row of 
cells to use as a worksheet title.

Another common reason for merging cells is to create a 
label that applies to multiple columns of data.

Merge Two 
or More Cells
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How do I center text across multiple columns?
This is a useful technique for your worksheet titles or headings. You can 
center a title across the entire worksheet, or you can center a heading across 
the columns that it refers to. Follow Steps 1 to 3 and then click Merge & 
Center. Excel creates the merged cell and formats the cell with the Center 
alignment option. Any text you enter into the merged cell appears centered 
within the cell.

5 Type your text in the merged cell.

● Excel merges the selected cells 
into a single cell.
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2 Click the Home tab.

3 Click Copy ( ).

1 Select the range that includes the 
data you want to transpose.

Transpose Rows and Columns

You can use Excel’s Transpose command 
to easily turn a row of data into a column 
of data, or a column of data into a row of 
data.

You can also transpose rows and columns together in 
a single command, which is handy when you need to 
restructure a worksheet.

Transpose Rows 
and Columns
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Can I transpose range 
values as well as range 
labels?
Yes, Excel’s Transpose 
command works with text, 
numbers, dates, formulas, 
and any other data that you 
can add to a cell. So if you 
have a rectangular region of 
data that includes row labels, column labels, 
and cell values within each row and column, 
you can select the entire range and transpose it.

How do I know which cells 
to select?
The range you select before 
copying depends on what you 
want to transpose. If you want to 
transpose a single horizontal or 
vertical range of cells, then select 
just that range. If you want to 
transpose a horizontal range of 
cells and a vertical range of cells at the same time, 
select the range that includes all the cells, as 
shown in this section’s example.

● Excel transposes the data and 
then pastes it to the worksheet.

4 Click where you want the 
transposed range to appear.

5 Click the Paste .

6 Click Transpose ( ).
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Working with 
Range Names

You can make it easier to 
navigate Excel worksheets 
and build Excel formulas 
by applying names to your 
ranges. This chapter explains 
range names and shows you 
how to define, edit, and use 
range names.
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A
42.65
58.36
87.69 12.35

=AVERAGE(A1:B4)

22.17
85.47
B

=AVERAGE(A1:B4)

More Accurate
Range names are more accurate than range 
coordinates. For example, consider the range address 
A1:B3, which consists of four different pieces of 
information: the column (A) and row (1) of the cell in 
the upper left corner of the range, and the column (B) 
and row (3) of the cell in the lower right corner. If you 
get even one of these values wrong, it can cause 
errors throughout a spreadsheet. By contrast, with a 
range name you need only reference the name itself.

More Intuitive
Range names are more intuitive than range 
coordinates, particularly in formulas. For example, if 
you see the range B2:B10 in a formula, the only way 
to know what the range refers to is to look at the 
data. However, if you see the name Quarterly_Sales in 
the formula, then you already know what the range 
refers to.

A range name is a text label that you apply to a 
single cell or to a range of cells. Once you have 
defined a name for a range, you can use that 
name in place of the range coordinates, which 
has several benefits.

Understanding the Benefits 
of Using Range Names
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Easier to Remember
Range names are easier to remember than range 
coordinates. For example, if you want to use a particular 
range in a formula, but that range is not currently visible, 
to get the coordinates you must scroll until you can see 
the range and then determine the range’s coordinates. 
However, if you have already assigned the range an intuitive 
name such as Project_Expenses, you can add that name 
directly without having to view the range.

B1:B10?B1:B10?B1:B10?
B2:B11?B2:B11?B2:B11?

A1:E5A1:E5

Lab DataLab Data

H1:L5H1:L5

Lab DataLab Data

Inventory
Table

Names Do Not Change
Range names do not change when you adjust the position 
of a range, as they do with range coordinates. For example, 
if you move the range A1:B5 to the right by five columns, 
the range coordinates change to F1:G5. If you have a 
formula that references that range, Excel updates the 
formula with the new range coordinates, which could 
confuse someone examining the worksheet. By contrast, 
a range name does not change when you move a range.

Easier Navigation
Range names make it easier to navigate a worksheet. For 
example, Excel has a Go To command that enables you to 
choose a range name and Excel takes you directly to the 
range. You can also use the Name box to select a range 
name and navigate to that range. You can also use Go To 
and the Name box to specify range coordinates, but range 
coordinates are much more difficult to work with.
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my range name is

SalesSalesSales

2 Click the Formulas tab.

3 Click Define Name.

1 Select the range you want to 
name.

Define a Range Name

Before you can use a range name in your 
formulas or to navigate a worksheet, you must 
first define the range name. You can define as 
many names as you need, and you can even 
define multiple names for the same range.

You can create range names by hand, or you can get Excel to 
create the names for you automatically based on the existing 
text labels in a worksheet. For the latter, see “Use Worksheet 
Text to Define a Range Name.”

Define a 
Range Name
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Is there an easier way to define a range name?
Yes, you can follow these steps to bypass the New Name 
dialog box:

1 Select the range you want to name.

2 Click inside the Name box.

3 Type the name you want to use.

4 Press .

 Excel assigns the name to the range.

 The New Name dialog box 
appears.

4 Type the name you want to use 
into the Name text box.

Note: The first character of the name must be 
a letter or an underscore (_). The name cannot 
include spaces or cell references, and it cannot 
be any longer than 255 characters.

5 Click OK.

 Excel assigns the name to the 
range.

● The new name appears in the 
Name box whenever the range 
is selected.
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SalesSalesSales

2 Click the Formulas tab.

3 Click Create from Selection.

1 Select the range or ranges you 
want to name.

● Be sure to include the text labels 
you want to use for the range 
names.

Use Worksheet Text to Define a Range Name

If you have several ranges to name, you can 
speed up the process by getting Excel to create 
the names for you automatically based on the 
range’s text labels.

You can create range names from worksheet text when the labels 
are in the top or bottom row of the range, or the left or right 
column of the range.

Use Worksheet Text to 
Define a Range Name
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Given a table with 
labels in the top 
row and left column, 
is there a way to 
automatically assign 
a name to the table 
data?
Yes. The table data 
refers to the range of 
cells that does not include the table headings in the 
top row and left column. To assign a name to the data 
range, type a label in the top left corner of the table. 
When you run the Create from Selection command on 
the entire table, Excel assigns the top left label to the 
data range, as shown here.

Is there a faster 
way to run the 
Create from 
Selection 
command?
Yes, Excel offers a 
keyboard shortcut for 
the command. Select 
the range or ranges you 
want to work with and then 
press + + . Excel displays the 
Create Names from Selection dialog box. 
Follow Steps 4 and 5 to create the range 
names.

 The Create Names from Selection 
dialog box appears.

4 Select the setting or settings that 
correspond to where the text 
labels are located in the selected 
range (  changes to ).

 If Excel has activated a check box 
that does not apply to your data, 
click it (  changes to ).

5 Click OK.

 Excel assigns the text labels as 
range names.

● When you select one of the 
ranges, the range name assigned 
by Excel appears in the Name box.

Note: If the label text contains any illegal 
characters, such as a space, Excel replaces each 
of those characters with an underscore (_).

SHORT
CUT SHORT
CUT SHORT
CUT 
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● Excel selects the range.

Navigate Using the Name Box

1 Open the workbook that contains 
the range you want to work with.

2  Click the Name box .

3 Click the name of the range you 
want to select.

Navigate a Workbook Using Range Names

One of the big advantages of defining range 
names is that they make it easier to navigate 
a worksheet. You can choose a range name 
from a list and Excel automatically selects the 
associated range.

Excel offers two methods for navigating a workbook using range 
names: the Name box and the Go To command.

Navigate a Workbook 
Using Range Names
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Is it possible to navigate to a named range in a different 
workbook?
Yes, but it is not easy or straightforward:

 The Go To dialog box appears.

5 Click the name of the range you 
want to select.

6 Click OK.

Navigate Using the Go To 
Command

1 Open the workbook that contains 
the range you want to work with.

2 Click the Home tab.

3 Click Find & Select.

4 Click Go To.

Note: You can also select the Go To command by 
pressing + .

● Excel selects the range.

22
33

1 Follow Steps 1 to 4 on this page 
to display the Go To dialog box.

2 In the Reference text box, type 
the following:

 ‘[workbook]worksheet’!name

 Replace workbook with the file 
name of the workbook, worksheet 
with the name of the worksheet 
that contains the range, and 
name with the range name.

3 Click OK.
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 The Name Manager dialog box 
appears.

4 Click the name you want to 
change.

5 Click Edit.

1 Open the workbook that contains 
the range name you want to 
change.

2 Click the Formulas tab.

3 Click Name Manager.

Change a Range Name

You can change any range name to a more 
suitable or accurate name. This is useful if you 
are no longer satisfied with the original name 
you applied to a range, or if you do not like the 
name that Excel generated automatically from 
the worksheet labels.

If you want to change the range coordinates associated with a range 
name, see the second Tip on the next page.

Change a 
Range Name
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Can I assign a name to a 
different range?
Yes. If you add another range 
to your workbook and you feel 
that an existing name would 
be more suited to that range, 
you can modify the name to 
refer to the new range. Follow 
Steps 1 to 5 to open the Edit 
Name dialog box. Click inside the Refers to reference 
box, and then click and drag the mouse  on the 
worksheet to select the new range. Click OK.

Is there a faster 
method I can use 
to open the Name 
Manager dialog 
box?
Yes, Excel offers a 
shortcut key that 
enables you to bypass 
Steps 2 and 3. Open 
the workbook that contains the range name 
you want to change, and then press + . 
Excel opens the Name Manager dialog box.

● The new name appears in the 
Name Manager dialog box.

8 Repeat Steps 4 to 7 to rename 
other ranges as needed.

9 Click Close.

 The Edit Name dialog box 
appears.

6 Use the Name text box to edit 
the name.

7 Click OK.

SalesSalesSalesSales

SalesSalesSalesSales
SHORT

CUT SHORT
CUT SHORT
CUT F3F3F3
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 The Name Manager dialog 
box appears.

4 Click the name you want to 
delete.

5 Click Delete.

1 Open the workbook that contains 
the range name you want to 
delete.

2 Click the Formulas tab.

3 Click Name Manager.

Note: You can also select the Name Manager 
command by pressing + .

Delete a Range Name

If you have a range name that you no longer need, 
you should delete it. This reduces clutter in the 
Name Manager dialog box, and makes the Name 
box easier to navigate.

Delete a 
Range Name
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Is there a faster way to delete multiple range names?
Yes, you can delete two or more range names at once. First, follow 
Steps 1 to 3 to display the Name Manager dialog box. Next, select 
the range names you want to delete: To select consecutive names, 
click the first name you want to delete, hold down , and then 
click the last name you want to delete; to select nonconsecutive 
names, hold down  and click each name you want to delete. 
When you have selected the name you want to remove, click Delete 
and then click OK when Excel asks you to confirm the deletion.

● Excel deletes the range name.

7 Repeat Steps 4 to 6 to delete 
other range names as needed.

8 Click Close.

 Excel asks you to confirm the 
deletion.

6 Click OK.
S
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S
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S
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Payments

Paymen

E
xp
en
se
s

E
xp
en
se
s

E
xp
en
se
s

06_577646-ch04.indd   7906_577646-ch04.indd   79 3/8/10   7:04 PM3/8/10   7:04 PM



80

22

33

44

55

11

SalesSales

CostsCosts
ExpensesExpenses

GLUE

3 Click the Formulas tab.

4 Click Use in Formula.

5 Click Paste Names.

1 Open the workbook that contains 
the range names you want to 
paste.

2 Select the cell where you want the 
pasted list to appear.

Note: Excel will overwrite existing data, so select 
a location where there is no existing cell data or 
where the existing cell data is okay to delete.

Paste a List of Range Names

To make your workbook easier to use, especially 
for other people who are not familiar with the 
name you have defined, you can paste a list of the 
workbook’s range names to a worksheet.

The pasted list contains two columns: one for the range names and 
one for the range coordinates associated with each name.

Paste a List of
Range Names
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Is there a faster method I can use to paste a list of range 
names?
Yes, Excel offers a handy keyboard shortcut that you can use. 
Open the workbook that contains the range names you want to 
paste, and then select the cell where you want the pasted list to 
appear. Press  to open the Paste Name dialog box, and then 
click Paste List.

 Excel closes the Paste Name 
dialog box.

● Excel pastes the list of range 
names to the worksheet.

 The Paste Name dialog box 
appears.

6 Click Paste List.
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Formatting 
Excel Ranges

Microsoft Excel 2010 
offers many commands 
and options for formatting 
ranges, including the font, 
text color, text alignment, 
background color, number 
format, column width, row 
height, and more.
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● Excel applies the font to the text in 
the selected range.

1 Select the range you want to 
format.

2 Click the Home tab.

3 To change the typeface, click  
in the Font list and then click the 
typeface you want to apply.

Change the Font and Font Size

When you work in an Excel worksheet, you can 
add visual appeal to a cell or range by changing 
the font and font size.

In this section, the term font is synonymous with typeface, and 
both refer to the overall look of each character. Also, the font size 
is measured in points, where there are roughly 72 points in an inch.

Change the Font 
and Font Size
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Can I change the 
default font and 
font size?
Yes. Click the File 
tab and then click 
Options to open the 
Excel Options dialog 
box. Click the General 
tab, click the Use this 
font , and then click the typeface you want 
to use as the default. Click the Font size  
and then click the size you prefer to use as 
the default. Click OK.

In the Theme Fonts section 
of the Font list, what do the 
designations Body and 
Headings mean?
When you create a workbook, 
Excel automatically applies a 
document theme to the 
workbook, and that theme 
includes predefined fonts. The 
theme’s default font is referred to as Body, and it is the 
font used for regular worksheet text. Each theme also 
defines a Headings font, which Excel uses for cells 
formatted with a heading or title style.

● Excel applies the font size to the 
text in the selected range.

4 To change the font size, click  in 
the Font Size list and then click 
the size you want to apply.

● You can also type the size you 
want in the Size text box.

FONTFONTSIZESIZE
FONTSIZE

CHANGE
CHANGEFONTFONT

CHANGEFONT
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4 To format the text as italic, click 
the Italic button ( ).

5 To format the text as underline, 
click the Underline button ( ).

● Excel applies the effects to the 
selected range.

6 Click the Font dialog box 
launcher ( ).

1 Select the range you want to 
format.

2 Click the Home tab.

3 To format the text as bold, click 
the Bold button ( ).

● Excel applies the bold effect to 
the selected range.

Apply Font Effects

You can improve the look and impact of text in 
an Excel worksheet by applying font effects to a 
range.

Font effects include common formatting such as bold, italic, and 
underline, as well as special effects such as strikethrough, 
superscripts, and subscripts.

Apply Font 
Effects
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Are there any font-related keyboard shortcuts I can use?
Yes. Excel supports the following font shortcuts:

Press To

+ Toggle the selected range as bold

+ Toggle the selected range as italic

+ Toggle the selected range as underline

+ Toggle the selected range as strikethrough

8 To format the text as a superscript, 
click Superscript (  changes 
to ).

● To format the text as a subscript, click 
Subscript (  changes to ).

9 Click OK.

 Excel applies the font effects.

 The Format Cells dialog box 
appears with the Font tab 
displayed.

7 To format the text as strikethrough, 
click Strikethrough (  changes 
to ).

SHORT
CUT SHORT
CUT SHORT
CUT 

control
control
control

BBBB

III

UUU
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4 Click a theme color.

● Alternatively, click one of Excel’s 
standard colors.

● Excel applies the color to the 
range text.

Select a Theme or Standard 
Color

1 Select the range you want to 
format.

2 Click the Home tab.

3 Click  in the Font Color 
list ( ).

Change the Font Color

When you work in an Excel worksheet, you can 
add visual interest by changing the font color.

You can change the font color by applying a color from the 
workbook’s theme, from Excel’s palette of standard colors, 
or from a custom color that you create yourself.

Change the 
Font Color
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How can I make the best use of fonts in my documents?
● Do not use many different typefaces in a single document. Stick to one, 

or at most two, typefaces to avoid the ransom note look.
● Avoid overly decorative typefaces because they are often difficult to 

read.
● Use bold only for document titles, subtitles, and headings.
● Use italics only to emphasize words and phrases, or for the titles of 

books and magazines.
● Use larger type sizes only for document titles, subtitles, and, possibly, 

the headings.
● If you change the text color, be sure to leave enough contrast between the 

text and the background. In general, dark text on a light background is the 
easiest to read.

 The Colors dialog box appears.

5 Click the color you want to use.

● You can also click the Custom tab 
and then either click the color you 
want or enter the values for the 
Red, Green, and Blue components 
of the color.

6 Click OK.

 Excel applies the color to the 
selected range.

Select a Custom Color

1 Select the range you want to 
format.

2 Click the Home tab.

3 Click  in the Font Color 
list ( ).

4 Click More Colors.
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 Excel aligns the data horizontally within 
each selected cell.

● In this example, the data in the cells is 
centered.

Align Text Horizontally

1 Select the range you want to format.

2 Click the Home tab.

3 In the Alignment group, click the horizontal 
alignment option you want to use:

 Click Align Text Left ( ) to align data 
with the left side of each cell.

 Click Center ( ) to align data with the 
center of each cell.

 Click Align Text Right ( ) to align 
data with the right side of each cell.

Align Text Within a Cell

You can make your worksheets easier to read by 
aligning text and numbers within each cell. By 
default, Excel aligns numbers with the right side 
of the cell, and it aligns text with the left side of 
the cell.

You can also align your data vertically within each cell. By default, 
Excel aligns all data with the bottom of each cell, but you can also 
align text with the top or middle.

Align Text 
Within a Cell
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How do I indent cell text?
Select the range you want to 
indent, click the Home tab, and 
then click the Alignment group’s 
dialog box launcher ( ). In the 
Alignment tab, click the Horizontal 
list  and then click Left (Indent). 
Use the Indent text box to type the indent, in 
characters, and then click OK. You can also click 
the Increase Indent ( ) or Decrease Indent 
( ) button in the Home tab’s Alignment group.

How do I format text so that it 
aligns with both the left and 
right sides of the cell?
This is called justified text, and it is 
useful if you have a lot of text in one 
or more cells. Select the range, click 
the Home tab, and then click the dialog 
box launcher ( ) in the Alignment group. The 
Format Cells dialog box appears with the Alignment 
tab displayed. In the Horizontal list, click  and then 
click Justify. Click OK to justify the cells.

 Excel aligns the data vertically 
within each selected cell.

● In this example, the text is aligned 
with the middle of the cell.

Align Text Vertically

1 Select the range you want to format.

2 Click the Home tab.

3 In the Alignment group, click the 
vertical alignment option you want 
to use:

 Click Top Align ( ) to align data 
with the top of each cell.

 Click Middle Align ( ) to align 
data with the middle of each cell.

 Click Bottom Align ( ) to align 
data with the bottom of each cell.

JUSTIFY 
INDENT 
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2 Click the Home tab.

3 In the Alignment group, click the 
dialog box launcher ( ).

1 Select a range that consists of the 
text you want to work with and 
the cells across which you want to 
center the text.

Center Text Across Multiple Columns

You can make a worksheet more visually 
appealing and easier to read by centering text 
across multiple columns. This feature is most 
useful when you have text in a cell that you use as 
a label or title for a range. By centering the text 
across the range, it makes it easier to see that the 
label or title applies to the entire range.

Center Text Across 
Multiple Columns
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Is there an easier way to center text across multiple columns?
Yes, although it does require you to merge the selected cells into a 
single cell. (See Chapter 3 to learn more about merging cells.) Follow 
Steps 1 and 2 and then, in the Alignment group, click the Merge & 
Center button ( ). Excel merges the selected cells into a single cell 
and centers the text within that cell.

● Excel centers the text across the 
selected cells.

 Excel opens the Format Cells 
dialog box with the Alignment tab 
displayed.

4 Click the Horizontal  and then 
click Center Across Selection.

5 Click OK.

CENTER TEXTCENTER TEXTCENTER TEXT
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 The Format Cells dialog box 
appears with the Alignment tab 
displayed.

5 Click an orientation marker.

● You can also use the Degrees spin 
box to type or click a degree of 
rotation. (See the Tip on the 
following page.)

1 Select the range containing the 
text you want to angle.

2 Click the Home tab.

3 Click Orientation ( ).

● If you want to use a predefined 
orientation, click one of the menu 
items and skip the rest of the 
steps.

4 Click Format Cell Alignment.

Rotate Text Within a Cell

You can add visual interest to your text by 
slanting the text upward or downward in the 
cell. You can also use this technique to make a 
long column heading take up less horizontal 
space on the worksheet.

You can choose a predefined rotation, or you can make cell text 
angle upward or downward by specifying the degrees of rotation.

Rotate Text 
Within a Cell
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How does the Degrees spin box work?
If you use the Degrees spin box to set the text orientation, you can set the 
text orientation to a positive number, such as 25, and Excel angles the text 
in an upward direction. If you set the text orientation to a negative number, 
such as –40, Excel angles the text in a downward direction.

You can specify values in the range from 90 degrees (which is the same as 
clicking the Rotate Text Up command in the Orientation menu) to –90 
degrees (which is the same as clicking the Rotate Text Down command).

● Excel rotates the cell text.

● The row height automatically 
increases to contain the slanted 
text.

● You can reduce the column width 
to free up space and make your 
cells more presentable.

● You can click the vertical text area 
to display your text vertically 
instead of horizontally in the cell.

6 Click OK.
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Background Colors

Background Colors

DATADATADAT

4 Click a theme color.

● Alternatively, click one of Excel’s 
standard colors.

● Excel applies the color to the 
range text.

● To remove the background color 
from the range, click No Fill.

Select a Theme or Standard 
Color

1 Select the range you want to 
format.

2 Click the Home tab.

3 Click  in the Fill Color 
list ( ).

Add a Background Color to a Range

You can make a range stand out from the rest of 
the worksheet by applying a background color to 
the range.

You can change the background color by applying a color from the 
workbook’s theme, from Excel’s palette of standard colors, or from 
a custom color that you create yourself.

Add a Background 
Color to a Range
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Can I apply a 
background that 
fades from one color 
to another?
Yes. This is called a gradient 
effect. Select the range, click 
the Home tab, and then 
click the Font group’s dialog 
box launcher ( ). Click the 
Fill tab and then click Fill Effects. In the Fill 
Effects dialog box, use the Color 1  and the 
Color 2  to choose your colors. Click an option 
in the Shading styles section (  changes to ), 
and then click OK.

Are there any pitfalls 
to watch out for when 
I apply background 
colors?
Yes. The biggest pitfall is 
applying a background 
color that clashes with the 
range text. For example, 
the default text color is 
black, so if you apply any 
dark background color, the text will be very difficult 
to read. Always use either a light background color 
with dark-colored text, or a dark background color 
with light-colored text.

 The Colors dialog box appears.

5 Click the color you want to use.

● You can also click the Custom tab 
and then either click the color you 
want or enter the values for the 
Red, Green, and Blue components 
of the color.

6 Click OK.

 Excel applies the color to the 
selected range.

Select a Custom Color

1 Select the range you want to 
format.

2 Click the Home tab.

3 Click  in the Fill Color 
list ( ).

4 Click More Colors.
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2 Click the Home tab.

3 Click the Number Format .

4 Click the number format you 
want to use.

1 Select the range you want to 
format.

Apply a Number Format

You can make your worksheet easier to read by 
applying a number format to your data. For 
example, if your worksheet includes monetary data, 
you can apply the Currency format to display each 
value with a dollar sign and two decimal places.

Excel offers ten number formats, most of which apply to numeric data. 
However, you can also apply the Date format to date data, the Time 
format to time data, and the Text format to text data.

Apply a 
Number Format

07_577646-ch05.indd   9807_577646-ch05.indd   98 3/8/10   7:05 PM3/8/10   7:05 PM



99

Formatting Excel Ranges chapter5

55

66

44

Is there a way to get more control over the number 
formats?
Yes. Follow these steps:

● For large numbers, you can also 
click Comma Style ( ).

● Excel applies the number format 
to the selected range.

● For monetary values, you can also 
click Accounting Number 
Format ( ).

● For percentages, you can also 
click Percent Style ( ).

1 Select the range you want to format.

2 Click the Home tab.

3 Click the Number group’s dialog box 
launcher ( ).

 The Format Cells dialog box appears 
with the Number tab displayed.

4 In the Category list, click the type of 
number format you want to apply.

5 Use the controls that Excel 
displays to customize the 
number format.

 The controls you see vary 
depending on the number 
format you chose in Step 4.

6 Click OK.

 Excel applies the number format.
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● Excel decreases the number of 
decimal places by one.

4 Repeat Step 3 until you get the 
number of decimal places you 
want.

Decrease the Number of Decimal 
Places

1 Select the range you want to 
format.

2 Click the Home tab.

3 Click the Decrease Decimal 
button ( ).

Change the Number of Decimal Places Displayed

You can make your numeric values easier to 
read and interpret by adjusting the number of 
decimal places that Excel displays. For example, 
you might want to ensure that all dollar-and-cent 
values show two decimal places, while dollar-only 
values show no decimal places.

You can either decrease or increase the number of decimal places 
that Excel displays.

Change the Number of 
Decimal Places Displayed
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My range currently has values that display different numbers of decimal 
places. What happens when I change the number of decimal places?
In this situation, Excel uses the value that has the most displayed decimal 
places as the basis for formatting all the values. For example, if the selected 
range has values that display no, one, two, or four decimal places, Excel uses 
the value with four decimals as the basis. If you click Decrease Decimal, Excel 
displays every value with three decimal places; if you click Increase Decimal, 
Excel displays every value with five decimal places.

● Excel increases the number of 
decimal places by one.

4 Repeat Step 3 until you get the 
number of decimal places you 
want.

Increase the Number of Decimal 
Places

1 Select the range you want to 
format.

2 Click the Home tab.

3 Click the Increase Decimal 
button ( ).
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2 Click AutoFormat ( ).

Note: See Chapter 1 to learn how to add a button 
to the Quick Access Toolbar. In this case, you must 
add the QuickFormat button.

1 Select the range you want to 
format.

Apply an AutoFormat to a Range

You can save time when formatting your Excel 
worksheets by using the AutoFormat feature. This 
feature offers a number of predefined formatting 
options that you can apply to a range all at once. The 
formatting options include the number format, font, 
cell alignment, borders, patterns, row height, and 
column width.

The AutoFormats are designed for data in a tabular format, particularly 
where you have headings in the top row and left column, numeric data in 
the rest of the cells, and a bottom row that shows the totals for each column.

Apply an AutoFormat 
to a Range
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How do I remove 
an AutoFormat?
If you do not like or 
no longer need the 
AutoFormat you 
applied to the cells, 
you can revert to a 
plain, unformatted 
state. Select the 
range and then click 

 to display the AutoFormat dialog box. In 
the format list, click None, and then click OK. 
Excel removes the AutoFormat from the 
selected range.

Is there a way to apply an 
AutoFormat without using 
some of its formatting?
Yes. Excel enables you to 
control all six formats that are 
part of each AutoFormat: 
Number, Font, Alignment, 
Border, Patterns, and Width/
Height. Follow Steps 1 to 3 to 
choose the AutoFormat you 
want to apply. Click Options to expand the dialog box 
and display the Formats to apply group. Deselect the 
option for each format you do not want to apply 
(  changes to ), and then click OK.

● Excel applies the AutoFormat to 
the selected range.

 The AutoFormat dialog box 
appears.

3 In the Table format list, click the 
AutoFormat you want to use.

4 Click OK.

AutoFormat
Number
Font
Alignment
Border
Patterns
Width/Height
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 An operator dialog box appears, 
such as the Greater Than dialog 
box shown here.

6 Type the value you want to use 
for your condition.

● You can also click the collapse 
dialog box button ( ) and then 
click in a worksheet cell.

 Depending on the operator, you 
may need to specify two values.

7 Click this  and then click the 
formatting you want to use.

● To create your own format, click 
Custom Format.

1 Select the range you want to work 
with.

2 Click the Home tab.

3 Click Conditional Formatting.

4 Click Highlight Cells Rules.

5 Click the operator you want to use 
for your condition.

Apply a Conditional Format to a Range

You can make a worksheet easier to analyze by 
applying a conditional format to a range. A 
conditional format is formatting that Excel applies 
only to cells that meet the condition you specify. 
For example, you can tell Excel to apply the 
formatting only if a cell’s value is greater than some 
specified amount.

When you set up your conditional format, you can specify the font, 
border, and background pattern, which helps to ensure that the cells 
that meet your criteria stand out from the other cells in the range.

Apply a Conditional 
Format to a Range
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How do I remove a 
conditional format 
from a range?
If you no longer require 
a conditional format, 
you can delete it. Follow 
Steps 1 to 3 to select the 
range and display the 
Conditional Formatting 
menu, and then click 
Manage Rules. Excel displays the Conditional 
Formatting Rules Manager dialog box. Click the 
conditional format you want to remove and then 
click Delete Rule.

Can I set up more than 
one condition for a 
single range?
Yes. Excel enables you 
to specify multiple 
conditional formats. For 
example, you could set 
up one condition for 
cells that are greater 
than some value, and a 
separate condition for cells that are less than some 
other value. You can apply unique formats to each 
condition. Follow Steps 1 to 8 to configure the 
new condition.

● Excel applies the formatting to 
cells that meet your condition.

8 Click OK.

CONDITIONAL

FORMATTING RULES

NEW
RULENEW
RULENEW
RULE Conditi

onal

Formatting
RULE #1

RULE #2

RULE #RULE #1

RULE #2
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2 Click the Home tab.

3 Click Cell Styles.

1 Select the range you want to 
format.

Apply a Style to a Range

You can reduce the time it takes to format your 
worksheets by applying Excel’s predefined styles 
to your ranges. Excel comes with more than 20 
predefined styles for different worksheet elements 
such as headings, as well as two dozen styles 
associated with the current document theme.

Each style includes the number format, cell alignment, font typeface 
and size, border, and fill color.

Apply a Style 
to a Range
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Can I create my own 
style?
Yes. This is useful if you 
find yourself applying the 
same set of formatting 
options over and over. 
By saving those options 
as a custom style, you 
can apply it by following 
Steps 1 to 4. Apply your 
formatting to a cell or range, and then select that 
cell or range. Click Home, click Cell Styles, and 
then click New Cell Style. In the Style dialog box, 
type a name for your style, and then click OK.

Are there styles I can 
use to format tabular 
data?
Yes. Excel comes with a 
gallery of table styles 
that offer formatting 
options that highlight 
the first row, apply 
different formats to 
alternating rows, and so 
on. Select the range that includes your data, click 
the Home tab, and then click Format as Table. In 
the gallery that appears, click the table format you 
want to apply.

● Excel applies the style to the 
range.

 Excel displays the Cell Styles 
gallery.

4 Click the style you want to apply.

Note: If the style is not exactly the way you want, 
you can right-click the style, click Modify, and 
then click Format to customize the style.

STYLETYSTYLTYLSTYLTYSTTYLS YYYYYYYLLLLLELELELETTTTTTT EEEEEEEESSSSS EEEEEEEESSS EEESSSSSSTTTYYYYYLLEEEEEYY
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2 Click the Home tab.

3 Click Format.

4 Click Column Width.

1 Click in any cell in the column you 
want to resize.

Change the Column Width

If you have a large number or a long line of text 
in a cell, Excel may display only part of the cell 
value. To avoid this, you can increase the width of 
the column. Similarly, if a column only contains a 
few characters in each cell, you can decrease the 
width to fit more columns on the screen.

Change the 
Column Width
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Is there a way to change all the column 
widths at once?
Yes. Click  (or press + ) to select the 
entire worksheet, and then follow the steps in this 
section to set the width you prefer. If you have 
already adjusted some column widths and you 
want to change all the other widths, click Home, 
click Format, and then click Default Width to 
open the Standard 
Width dialog box. 
Type the new 
standard column 
width, and then 
click OK.

Is there an easier way to 
adjust the column width 
to fit the contents of a 
column?
Yes. You can use Excel’s 
AutoFit feature, which 
automatically adjusts the 
column width to fit the 
widest item in a column. 
Click any cell in the column, click Home, click 
Format, and then click AutoFit Column Width. 
Alternatively, move  over the right edge of the 
column heading (  changes to ) and then 
double-click.

 The Column Width dialog box 
appears.

5 In the Column width text box, type 
the width you want to use.

6 Click OK.

● Excel adjusts the column width.

● You can also move  over the 
right edge of the column heading 
(  changes to ) and then 
click and drag the edge to set the 
width.

AUTOFIT
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2 Click the Home tab.

3 Click Format.

4 Click Row Height.

1 Select a range that includes at 
least one cell in every row you 
want to resize.

Change the Row Height

You can make your worksheet more visually appealing by 
increasing the row heights to create more space. This is 
particularly useful in worksheets that are crowded with 
text.

If you want to change the row height to display multiline text within a cell, you 
must also turn on text wrapping within the cell. See “Wrap Text Within a Cell” 
later in this chapter.

Change the 
Row Height
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Is there a way to 
change all the row 
heights at once?
Yes. Click  
(or press + ) 
to select the entire 
worksheet. You can 
then either follow 
the steps in this section to set the height by hand, or 
you can move  over the bottom edge of any row 
heading (  changes to ) and then click and drag 
the edge to set the height of all the rows.

Is there an easier 
way to adjust the 
row height to fit the 
contents of a row?
Yes. You can use Excel’s 
AutoFit feature, which 
automatically adjusts the 
row height to fit the tallest 
item in a row. Click in any cell 
in the row, click Home, click Format, and 
click AutoFit Row Height. Alternatively, move 

 over the bottom edge of the row heading 
(  changes to ) and then double-click.

 The Row Height dialog box 
appears.

5 In the Row height text box, type 
the height you want to use.

6 Click OK.

● Excel adjusts the row heights.

● You can also move  over the 
bottom edge of a row heading 
(  changes to ) and then click 
and drag the edge to set the 
height.

AUTOFITAUTOFITAUTOFIT
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2 Click the Home tab.

1 Select the cell that you want to 
format.

Wrap Text Within a Cell

If you type more text in a cell than can fit 
horizontally, Excel either displays the text over the 
next cell if it is empty or displays only part of the 
text if the next cell contains data. To prevent Excel 
from showing only truncated cell data, you can 
format the cell to wrap text within the cell.

Wrap Text 
Within a Cell
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My text is only slightly bigger than the cell. Is there a way to 
view the entire text without turning on text wrapping?
Yes. There are several things you can try. For example, you can widen 
the column until you see all your text; see “Change the Column Width” 
earlier in this chapter.

Alternatively, you can try reducing the cell font size. One way to do this 
is to choose a smaller value in the Font Size list of the Home tab’s Font 
group. However, an easier way is to click the Alignment group’s dialog 
box launcher ( ) to open the Format Cells dialog box with the 
Alignment tab displayed. Click the Shrink to fit check box (  changes 
to ) and then click OK.

 Excel turns on text wrapping for 
the selected cell.

● If the cell has more text than can 
fit horizontally, Excel wraps the 
text onto multiple lines and 
increases the row height to 
compensate.

3 Click Wrap Text ( ).
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2 Click the Home tab.

3 Click the Borders .

1 Select the range that you want to 
format.

Add Borders to a Range

You can make a range stand out from the rest of 
your worksheet data by adding a border around the 
range. You can also use borders to make a range 
easier to read. For example, if your range has totals 
on the bottom row, you can add a double border 
above the totals.

Add Borders 
to a Range
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None of the border types is 
quite right for my worksheet. 
Can I create a custom border?
Yes. You can draw the border by 
hand. Click the Borders  and 
then click Draw Border. Use the 
Line Style and Line Color lists to configure your 
border. Click a cell edge to add a border to that 
edge; click and drag a range to add a border 
around that range. If you prefer to create a grid 
where the border surrounds every cell, click the 
Draw Border Grid command instead.

How do I get my borders to 
stand out from the worksheet 
gridlines?
One way to make your borders 
stand out is to click the Borders , 
click Line Style, and then click a 
thicker border style. You can also click Line Color 
and then click a color that is not a shade of gray. 
However, perhaps the most effective method is to 
turn off the worksheet gridlines. Click the View 
tab, and then in the Show group click the 
Gridlines check box (  changes to ).

● Excel applies the border to the 
range.

4 Click the type of border you want 
to use.
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2 Click the Home tab.

3 Click Format Painter ( ).

  changes to .

1 Select the cell that has the 
formatting you want to copy.

Copy Formatting from One Cell to Another

You can save yourself a great deal of time by 
copying existing formatting to other areas of a 
worksheet. After you spend time formatting text 
or data, rather than spending time repeating the 
steps for other data, you can use the Format 
Painter tool to copy the formatting with a 
couple of mouse clicks.

Copy Formatting from 
One Cell to Another
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Is there an easy way to copy formatting to multiple cells or ranges?
Yes. If the cells are together, you can click and drag over the cells to apply the 
copied formatting. If the cells or ranges are not together, Excel offers a shortcut 
that means you do not have to select the Format Painter multiple times to 
copy formatting to multiple ranges.

Click the cell that contains the formatting you want to copy, click the Home 
tab, and then double-click . Click each cell to which you want to copy the 
formatting, or click and drag over each range that you want to format. When 
you are done, click  to cancel the Format Painter command.

● Excel copies the formatting to 
the cell.

4 Click the cell to which you want 
to copy the formatting.

Note: If you want to apply the formatting to 
multiple cells, click and drag  over the 
cells.
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B1 + B2 = 13.4

 Building Formulas 
and Functions

Are you ready to start 
creating powerful and useful 
worksheets by building your 
own formulas? This chapter 
explains formulas, shows 
you how to build them, 
and shows you how to 
incorporate Excel’s versatile 
worksheet functions into 
your formulas.
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Operators
In an Excel formula that contains 
two or more operands, each 
operand is separated by an 
operator, which is a symbol that 
combines the operands in some 
way, usually mathematically. 
Example operators include the plus 
sign (+) and the multiplication sign 
(*). For example, the formula 
=B1+B2 adds the values in cells 
B1 and B2.

Formulas
A formula is a set of symbols and 
values that perform some kind of 
calculation and produce a result. 
All Excel formulas have the same 
general structure: an equal sign (=) 
followed by one or more operands 
and operators. The equal sign tells 
Excel to interpret everything that 
follows in the cell as a formula. For 
example, if you type =5+8 into a 
cell, Excel interprets the 5+8 text 
as a formula, and displays the 
result in the cell (13).

Operands
Every Excel formula includes one or 
more operands, which are the data 
that Excel uses in the calculation. 
The simplest type of operand is a 
constant value, which is usually a 
number. However, most Excel 
formulas include references to 
worksheet data, which can be a 
cell address (such as B1), a range 
address (such as B1: B5), or a 
range name. Finally, you can also 
use any of Excel’s built-in functions 
as an operand.
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To get the most out of Excel, you need to understand formulas so that you can perform 
calculations on your worksheet data. You need to know the components of a formula, you 
need to understand arithmetic and comparison formulas, and you need to understand the 
importance of precedence when building a formula.

Understanding 
Excel Formulas
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Arithmetic Formulas
An arithmetic formula combines numeric 
operands — numeric constants, functions that 
return numeric results, and fields or items that 
contain numeric values — with mathematical 
operators to perform a calculation. Because Excel 
worksheets primarily deal with numeric data, 
arithmetic formulas are by far the most common 
formulas used in worksheet calculations.

The table at right lists the seven arithmetic 
operators that you can use to construct 
arithmetic formulas.

Comparison Formulas
A comparison formula combines numeric operands — numeric constants, functions that return numeric results, 
and fields or items that contain numeric values — with special operators to compare one operand with 
another. A comparison formula always returns a 
logical result. This means that if the comparison 
is true, then the formula returns the value 1, 
which is equivalent to the logical value TRUE; 
if the comparison is false, then the formula 
returns the value 0, which is equivalent to the 
logical value FALSE.

The table at right lists the six operators that you 
can use to construct comparison formulas.

Operator Precedence
Most of your formulas include multiple operands and operators. In many cases, the order in which Excel 
performs the calculations is crucial. For example, consider the formula =3 + 5 ^ 2. If you calculate from 
left to right, the answer you get is 64 (3 + 5 equals 8, and 8 ^ 2 equals 64). However, if you perform the 
exponentiation first and then the addition, the 
result is 28 (5 ^ 2 equals 25, and 3 + 25 
equals 28). Therefore, a single formula can 
produce multiple answers, depending on the 
order in which you perform the calculations.

To solve this problem, Excel evaluates a formula 
according to a predefined order of precedence, 
which is determined by the formula operators, 
as shown in the table at right.

Operator Name Example Result

+ Addition =10 + 5 15

– Subtraction =10 – 5 5

– Negation =–10 –10

* Multiplication =10 * 5 50

/ Division =10 / 5 2

% Percentage =10% 0.1

^ Exponentiation =10 ^ 5 100000

Operator Name Example Result

= Equal to =10 = 5 0

< Less than =10 < 5 0

< = Less than or equal to =10 < = 5 0

> Greater than =10 > 5 1

> = Greater than or equal to =10 > = 5 1

< > Not equal to =10 < > 5 1

Operator Operation Precedence

( ) Parentheses 1st

– Negation 2nd

% Percentage 3rd

^ Exponentiation 4th

* and / Multiplication and division 5th

+ and – Addition and subtraction 6th

= < < = > > = < > Comparison 7th
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3 Type or click an operand. For 
example, to reference a cell in 
your formula, click in the cell.

● Excel inserts the address of the 
clicked cell into the formula.

1 Click in the cell in which you want 
to build the formula.

2 Type =.

● Your typing also appears in the 
Formula bar.

Note: You can also type the formula into the 
Formula bar.

Build a Formula

You can add a formula to a worksheet cell using 
a technique similar to adding data to a cell. To 
ensure that Excel treats the text as a formula, be 
sure to begin with an equal sign (=) and then type 
your operands and operators.

When you add a formula to a cell, Excel displays the formula result 
in the cell, not the formula itself. For example, if you add the 
formula =C3+C4 to a cell, that cell displays the sum of the values in 
cells C3 and C4. To see the formula, click the cell and examine the 
Formula bar.

Build a 
Formula
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If I have many formulas, 
is there an easy way to 
view the formulas?
Yes. You can configure the 
worksheet to show the 
formulas instead of their 
results. Click File and then 
click Options to open the 
Excel Options dialog box. 
Click the Advanced tab, scroll to the Display 
options for this worksheet section, click the Show 
formulas in cells instead of their calculated 
results check box (  changes to ), and then 
click OK. You can also toggle between formulas 
and results by pressing + ‘ .

If Excel displays only 
the result of the 
formula, how do I 
make changes to the 
formula?
Excel displays the formula 
result in the cell, but it still 
keeps track of the original 
formula. To display the 
formula again, you have two choices: Click the cell 
and then edit the formula using the Formula bar, or 
double-click the cell to display the original formula 
in the cell and then edit the formula. In both cases, 
press  when you finish editing the formula.

● Excel displays the formula result 
in the cell.

4 Type an operator.

5 Repeat Steps 3 and 4 to add 
other operands and operators to 
your formula.

6 Click  or press .

1
2
3
4

1
2
3
4
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Function Structure
Every worksheet function has 
the same basic structure: 
NAME(Argument1, Argument2, ...). 
The NAME part identifies the 
function. In worksheet formulas 
and custom PivotTable formulas, 
the function name always appears 
in uppercase letters: PMT, SUM, 
AVERAGE, and so on. The items 
that appear within the parentheses 
are the functions’ arguments. The 
arguments are the inputs that 
functions use to perform 
calculations. For example, the 
function SUM(A1,B2,C3) adds the 
values in cells A1, B2, and C3.

Function Advantages
Functions are designed to take you 
beyond the basic arithmetic and 
comparison formulas by offering 
two main advantages. First, 
functions make simple but 
cumbersome formulas easier to 
use. For example, calculating a 
loan payment requires a complex 
formula, but Excel’s PMT function 
makes this easy. Second, functions 
enable you to include complex 
mathematical expressions in your 
worksheets that otherwise would 
be difficult or impossible to 
construct using simple arithmetic 
operators.

Functions
A function is a predefined formula 
that performs a specific task. For 
example, the SUM function 
calculates the total of a list of 
numbers, and the PMT (payment) 
function calculates a loan or 
mortgage payment. You can use 
functions on their own, preceded 
by =, or as part of a larger formula.

To build powerful and useful formulas, you often need to include one or more Excel 
functions as operands. You need to understand the advantages of using functions, you need 
to know the basic structure of every function, and you need to review Excel’s function types.

Understanding 
Excel Functions

Mathematical Functions
The following table lists some common mathematical functions:

Function Description

MOD(number,divisor) Returns the remainder of number after dividing by divisor

PI( ) Returns the value Pi

PRODUCT(number1,number2,...) Multiplies the specified numbers

RAND( ) Returns a random number between 0 and 1

RANDBETWEEN(number1,number2) Returns a random number between the two numbers

ROUND(number,digits) Rounds number to a specified number of digits

SQRT(number) Returns the positive square root of number

SUM(number1,number2,...) Adds the arguments
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Statistical Functions
The following table lists some common statistical functions:

Function Description

AVERAGE(number1,number2,...) Returns the average of the arguments

COUNT(number1,number2,...) Counts the numbers in the argument list

MAX(number1,number2,...) Returns the maximum value of the arguments

MEDIAN(number1,number2,...) Returns the median value of the arguments

MIN(number1,number2,...) Returns the minimum value of the arguments

MODE(number1,number2,...) Returns the most common value of the arguments

STDEV(number1,number2,...) Returns the standard deviation based on a sample

STDEVP(number1,number2,...) Returns the standard deviation based on an entire population

Financial Functions
Most of Excel’s financial functions use the following arguments:

Argument Description

rate The fixed rate of interest over the term of the loan or investment

nper The number of payments or deposit periods over the term of the loan or investment

pmt The periodic payment or deposit

pv The present value of the loan (the principal) or the initial deposit in an investment

fv The future value of the loan or investment

type The type of payment or deposit: 0 (the default) for end-of-period payments or deposits; 1 for beginning-of-
period payments or deposits

The following table lists some common financial functions:

Function Description

FV(rate,nper,pmt,pv,type) Returns the future value of an investment or loan

IPMT(rate,per,nper,pv,fv,type) Returns the interest payment for a specified period of a loan

NPER(rate,pmt,pv,fv,type) Returns the number of periods for an investment or loan

PMT(rate,nper,pv,fv,type) Returns the periodic payment for a loan or investment

PPMT(rate,per,nper,pv,fv,type) Returns the principal payment for a specified period of a loan

PV(rate,nper,pmt,fv,type) Returns the present value of an investment

RATE(nper,pmt,pv,fv,type,guess) Returns the periodic interest rate for a loan or investment
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 The Insert Function dialog box 
appears.

5 Click  and then click the 
category that contains the 
function you want to use.

6 Click the function.

7 Click OK.

1 Click in the cell in which you want 
to build the formula.

2 Type =.

3 Type any operands and operators 
you need before adding the 
function.

4 Click the Insert Function 
button ( ).

Add a Function to a Formula

To get the benefit of an Excel function, you 
need to use it within a formula. You can use a 
function as the only operand in the formula, or 
you can include the function as part of a larger 
formula.

To make it easy to choose the function you need and to add the 
appropriate arguments, Excel offers the Insert Function feature.

Add a Function 
to a Formula

08_577646-ch06.indd   12608_577646-ch06.indd   126 3/8/10   6:53 PM3/8/10   6:53 PM



127

Building Formulas and Functions chapter6
99 88

00
00

!!

How do I calculate a 
monthly financial result if 
I only have yearly values?
This is a common problem. 
For example, if your loan 
payment worksheet contains 
an annual interest rate and a 
loan term in years, how do 
you calculate the monthly 
payment using the PMT 
function? You need to convert 
the rate and term to monthly values. That is, you divide 
the annual interest rate by 12, and you multiply the term 
by 12. For example, if the annual rate is in cell B2, the 
term in years is in B3, and the loan amount is in B4, the 
function PMT(B2/12, B3*12, B4) calculates the monthly 
payment.

Do I have to 
specify a value 
for every 
function 
argument?
Not necessarily. 
Some function 
arguments are 
required to obtain a 
result, but some are 
optional. In the PMT function, for example, 
the rate, nper, and pv arguments are 
required, but the fv and type arguments are 
optional. When the Function Arguments 
dialog box displays a result for the function, 
then you know you have entered all of the 
required arguments.

 The Function Arguments dialog 
box appears.

8 Click inside an argument box.

9 Click the cell that contains the 
argument value.

 You can also type the argument 
value.

0 Repeat Steps 8 and 9 to fill as 
many arguments as you need.

● The function result appears here.

! Click OK.

● Excel adds the function to the 
formula.

● Excel displays the formula result.

Note: In this example, the result appears in the 
parentheses to indicate a negative value. In loan 
calculations, money that you pay out is always a 
negative amount.

Note: If your formula requires any other operands 
and operators, press  and then type what you 
need to complete your formula.

PMT () Function
PMT () Function

rate
nper
pv

rate
nper
pv

fv
type

fv
type

RequiredArguments

RequiredArguments OptionalArguments

OptionalArguments
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3 Use the mouse  to click and 
drag the row or column of 
numbers that you want to add.

● Excel adds a reference for the 
range to the formula.

1 Click in the cell where you want 
the sum to appear.

2 Type =sum(.

● When you begin a function, Excel 
displays a banner that shows you 
the function’s arguments.

Note: In the function banner, bold arguments are 
required, and arguments that appear in square 
brackets are optional.

Add a Row or Column of Numbers

You can quickly add worksheet numbers by 
building a formula that uses Excel’s SUM 
function. When you use the SUM function in 
a formula, you can specify as the function’s 
argument a reference to either a row or a column 
of numbers.

Add a Row or 
Column of Numbers
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Can I use the SUM function 
to total only certain values 
in a row or column?
Yes. The SUM function can 
accept multiple arguments, so 
you can enter as many cells or 
ranges as you need. After you 
type =sum(, hold down  
and either click each cell that you want to include in 
the total, or use the mouse  to click and drag each 
range that you want to sum.

Can I use the SUM 
function to total rows 
and columns at the 
same time?
Yes, the SUM function 
works not only with 
simple row and column 
ranges, but with any 
rectangular range. After you type =sum(, use 
the mouse  to click and drag the entire range 
that you want to sum.

● Excel enters the formula.

● Excel displays the sum in the cell.

4 Type ).

5 Click  or press .

C3+C5+C8
C3+C5+C8
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2 Click the Sum button ( ).

● If you want to use a function other 
than SUM, click the Sum  and 
then click the operation you want 
to use: Average, Count Numbers, 
Max, or Min.

1 Click in the cell where you want 
the sum to appear.

Note: For AutoSum to work, the cell you select 
should be below or to the right of the range you 
want to sum.

Build an AutoSum Formula

You can reduce the time it takes to build a 
worksheet as well as reduce the possibility of 
errors by using Excel’s AutoSum feature. This 
tool adds a SUM function formula to a cell and 
automatically adds the function arguments based 
on the structure of the worksheet data.

Build an AutoSum 
Formula
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Is there a faster 
way to add an 
AutoSum formula?
Yes. If you know the 
range you want to 
sum, and that range is 
either a vertical 
column with a blank 
cell below it or a 
horizontal row with a 
blank cell to its right, select the range 
(including the blank cell) and then click  
or press + = . Excel populates the blank 
cell with a SUM formula that totals the 
selected range.

Is there a way to see the 
sum of a range without 
adding an AutoSum 
formula?
Yes. You can use Excel’s 
status bar to do this. When 
you select any range, Excel 
adds the range’s numeric 
values and displays the 
result on the right side of the 
status bar — for example, Sum: 75200. By default, Excel 
also displays the Average and Count. If you want to see 
a different calculation, right-click the result in the status 
bar and then click the operation you want to use: 
Numerical Count, Maximum, or Minimum.

● Excel displays the sum.

 ● Excel adds a SUM function 
formula to the cell.

Note: You can also press + =  instead of 
clicking .

● Excel guesses that the range 
above (or to the left) of the cell 
is the one you want to add.

 If Excel guessed wrong, select the 
correct range.

3 Click  or press .
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3 Click Use in Formula.

● Excel displays a list of the range 
names in the current workbook.

4 Click the range name you want 
to use.

1 Click in the cell in which you want 
to build the formula, type =, and 
then type any operands and 
operators you need before adding 
the range name.

2 Click the Formulas tab.

Add a Range Name to a Formula

You can make your formulas easier to build, 
more accurate, and easier to read by using 
range names as operands. For example, the 
formula =SUM(B2:B10) is difficult to decipher 
on its own, but the formula =SUM(Expenses) 
is immediately obvious.

See Chapter 4 to learn how to define names for ranges in Excel.

Add a Range Name 
to a Formula
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Do I have to use the 
list of range names 
to insert range 
names into my 
formulas?
No. As you build your 
formula, you can type 
the range name by 
hand, if you know it. 
Alternatively, as you 
build your formula, click 
the cell or select the range that has the defined 
name, and Excel adds the name to your formula 
instead of the range address. If you want to work 
from a list of the defined range names, click an 
empty area of the worksheet, click Formulas, click 
Use in Formula, click Paste Names, and then 
click Paste List.

If I create a range 
name after I build my 
formula, is there an 
easy way to convert 
the range reference 
to the range name?
Yes. Excel offers an 
Apply Names feature 
that replaces range 
references with their 
associated range names throughout a worksheet. 
Click the Formulas tab, click the Define Name , 
and then click Apply Names to open the Apply 
Names dialog box. In the Apply names list, click 
the range name you want to use, and then click 
OK. Excel replaces the associated range references 
with the range name in each formula in the 
current worksheet.

● If you need to insert other range 
names into your formula, repeat 
Steps 2 to 5 for each name.

6 Click  or press .

 Excel calculates the formula result.

● Excel inserts the range name into 
the formula.

5 Type any operands and operators 
you need to complete your 
formula.

1
2
3
4
5

1
2
3
4
5

22222222

=SUM(B2:B10)=SUM(B2:B10)

08_577646-ch06.indd   13308_577646-ch06.indd   133 3/8/10   6:53 PM3/8/10   6:53 PM



134

1
2
3
4
5
6

1
2
3
4
5
6

Regional SalesRegional SalesRegional Sales

1
2
3
4
5
6

1
2
3
4
5
6

Total SalesTotal SalesTotal Sales

11

22

2 Press +  until the 
worksheet you want to use 
appears.

1 Click in the cell in which you want 
to build the formula, type =, and 
then type any operands and 
operators you need before adding 
the range reference.

Reference Another Worksheet Range in a Formula

You can add flexibility to your formulas by adding 
references to ranges that reside in other worksheets. 
This enables you to take advantage of work you have 
done in other worksheets so you do not have to waste 
time repeating your work on the current worksheet.

Reference Another Worksheet 
Range in a Formula
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Can I reference a range 
in another workbook in 
my formula?
Yes. First make sure the 
workbook you want to 
reference is open. When you 
reach the point in your 
formula where you want to 
add the reference, click the 
Excel icon ( ) in the 
Windows taskbar, and then click the other workbook to 
switch to it. Click the worksheet that has the range you 
want to reference, and then select the range. Click  
and then click the original workbook to switch back to 
it. Excel adds the other workbook range reference to 
your formula.

Can I reference 
a range in 
another 
worksheet by 
hand?
Yes. Rather than 
selecting the other 
worksheet range 
with your mouse, 
you can type the 
range reference directly into your formula. 
Type the worksheet name, surrounded by 
single quotation marks (‘) if the name 
contains a space; type an exclamation mark 
(!); then type the cell or range address. Here 
is an example: ‘Expenses 2010’!B2:B10.

● A reference to the range on the 
other worksheet appears in your 
formula.

5 Type any operands and operators 
you need to complete your 
formula.

6 Click  or press .

 Excel calculates the formula result.

3 Select the range you want to use.

4 Press +  until you 
return to the original worksheet.

11
22
33
44
55
66
77
88
99

AA

BB
CC

FF
GG HH

AA

BB
CC

FF
GG HH

11
22
33
44
55
66
77
88
99

1
2
3
4
5
6

1
2
3
4
5
6

4444444
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Move a Formula

1 Click the cell that contains the 
formula you want to move.

2 Position  over any outside 
border of the cell.

  changes to .

3 Click and drag the cell to the new 
location.

  changes to .

● Excel displays an outline of 
the cell.

● Excel displays the address of the 
new location.

4 Release the mouse button.

● Excel moves the formula to the 
new location.

● Excel does not change the 
formula’s range references.

Move or Copy a Formula

You can restructure or reorganize a worksheet by 
moving an existing formula to a different part of 
the worksheet. When you move a formula, Excel 
preserves the formula’s range references.

Excel also enables you to make a copy of a formula, which is a useful 
technique if you require a duplicate of the formula elsewhere or if 
you require a formula that is similar to an existing formula. When you 
copy a formula, Excel adjusts the range references to the new location.

Move or Copy 
a Formula
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Why does Excel adjust the range references when I copy a 
formula?
When you make a copy of a formula, Excel assumes that you want that 
copy to reference different ranges than in the original formula. In particular, 
Excel assumes that the ranges you want to use in the new formula are 
positioned relative to the ranges used in the original formula, and that the 
relative difference is equal to the number of rows and columns you 
dragged the cell to create the copy.

For example, suppose your original formula references cell A1, and you 
make a copy of the formula in the cell one column to the right. In that 
case, Excel also adjusts the cell reference one column to the right, so it 
becomes B1 in the new formula. To learn how to control this behavior, see 
“Switch to Absolute Cell References.”

Copy a Formula

1 Click the cell that contains the 
formula you want to copy.

2 Press and hold .

3 Position  over any outside 
border of the cell.

  changes to .

4 Click and drag the cell to the 
location where you want the copy 
to appear.

● Excel displays an outline of 
the cell.

● Excel displays the address of the 
new location.

5 Release the mouse button.

6 Release .

● Excel creates a copy of the 
formula in the new location.

● Excel adjusts the range references.

Note: You can make multiple copies by dragging 
the bottom-right corner of the cell. Excel fills the 
adjacent cells with copies of the formula. See 
“Switch to Absolute Cell References” for an 
example.

A B C D E F G
=B1+B2=B1+B2=B1+B2 =G1+G2=G1+G2=G1+G2
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● Excel switches the address to an 
absolute cell reference.

4 Repeat Steps 2 and 3 to switch 
any other cell addresses that you 
require in the absolute reference 
format.

5 Click  or press .

1 Double-click the cell that contains 
the formula you want to edit.

2 Select the cell reference you want 
to change.

3 Press .

Switch to Absolute Cell References

You can make some formulas easier to copy by 
switching to absolute cell references. When you 
use a regular cell address — called a relative cell 
reference — such as A1 in a formula, Excel 
adjusts that reference when you copy the 
formula to another location. To prevent that 
reference from changing, you must change it 
to the absolute cell reference format: $A$1.

See the tip on the following page to learn more about the 
difference between relative and absolute cell references.

Switch to Absolute 
Cell References

08_577646-ch06.indd   13808_577646-ch06.indd   138 3/8/10   6:53 PM3/8/10   6:53 PM



139

Building Formulas and Functions chapter6

66

How do I return a cell 
address back to a 
relative cell reference?
The  keyboard 
technique actually runs the 
address through four 
different reference formats. 
Press  once to switch to 
the absolute cell reference 
format, such as $A$1. Press  again to switch to 
a mixed reference format that uses a relative 
column and absolute row (A$1). Press  a third 
time to switch to a mixed reference format that 
uses an absolute column and relative row ($A1). 
Finally, press  a fourth time to return to the 
relative cell reference (A1).

What is the difference 
between absolute cell 
references and relative 
cell references?
When you use a cell 
reference in a formula, 
Excel treats that reference 
as being relative to the 
formula’s cell. For example, 
if the formula is in B5 and it references cell A1, 
Excel effectively treats A1 as the cell four rows 
up and one column to the left. If you copy the 
formula to cell D10, then the cell four rows up and 
one column to the left now refers to cell C6, so in 
the copied formula Excel changes A1 to C6. If the 
original formula instead refers to $A$1, then the 
copied formula in cell D10 also refers to $A$1.

● Excel preserves the absolute cell 
references in the copied formulas.

● Excel adjusts the formula.

6 Copy the formula.

Note: See “Move or Copy a Formula,” earlier in 
this chapter, to learn how to copy a formula.
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● Excel removes the Formula bar 
from the window.

Hide the Formula Bar

1 Click the View tab.

2 Click Show.

Note: If you have Excel maximized, you may not 
see the Show button, so skip to Step 3.

3 Click Formula Bar (  changes 
to ).

Toggle the Formula Bar On and Off

You can give yourself a bit more room in the Excel 
window by hiding the Formula bar. This is a good 
idea if you never use the Formula bar to enter or edit 
cell data, and you never use Formula bar features such 
as the Name box and the Insert Function button.

After hiding the Formula bar, if you find that you need it, you can 
quickly restore it to the Excel window.

Toggle the Formula 
Bar On and Off
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If I have a long entry in a cell, I only see part of the entry in the Formula bar. Can I fix that?
Yes, you can use Excel’s Expand Formula Bar feature to expand the formula to show multiple lines of data 
instead of just a single line. On the right side of the Formula bar, click the Expand Formula Bar button ( ) 
or press + +  to increase the size of the Formula bar as shown here. If you still cannot see the 
entire cell entry, either click and drag the bottom edge of the Formula bar to expand it even further, or click 

 and  to scroll through the entry.

When you are done, click Collapse Formula Bar ( ) or 
press + +  to return the Formula bar to its 
normal state.

● Excel restores the Formula bar.

Display the Formula Bar

1 Click the View tab.

2 Click Show.

3 Click Formula Bar (  changes 
to ).
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Despite your best efforts, a formula may return 
an inaccurate or erroneous result. To help you 
fix such problem formulas, there are a few 
troubleshooting techniques you can use, such as 
checking your references, function arguments, and 
parentheses. If Excel displays an error instead of a 
result, then you also need to understand these 
error messages so that you can correct the 
problem.

Troubleshoot 
Formula Errors

A B C D E F G H I J K

1
2
3
4
5
6
7
8
9

L
XL

= SUM(A1:D1)

341.75
D

8.49 120
642 07

C E

Confirm Range References
If your formula is returning an unexpected or 
inaccurate result, first check your range and cell 
references. For example, if your data is in the range 
A1:A10, but your formula uses A1:A9, then the result 
will be inaccurate. The easiest way to check the 
range and cell references is to double-click the cell 
containing the formula. Excel highlights the ranges 
referenced by the formula, so you can see at a glance 
which ranges your formula is using.

Confirm Range Data
If your formula is correct but it is still producing 
unexpected results, the problem might lie with the 
data instead of the formula. Double-check your range 
data to make sure that it is accurate and up to date.
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Confirm Punctuation
Many formulas produce inaccurate or erroneous results 
because of incorrect punctuation. Look for missing colons 
in range references; missing or misplaced quotation marks 
in string data or links to other worksheets or workbooks; 
and missing commas in function arguments. Also check 
parentheses to make sure you have one closing parenthesis 
for each opening parenthesis, and that your parentheses are 
in the correct locations within the formula.

operatorprecedencecheckin progress

Confirm Operator Precedence
The order in which Excel calculates numeric formulas can 
make a big difference to the final result, particularly if you are 
mixing addition and subtraction with multiplication and 
division. Confirm the correct order of precedence that your 
formula requires; compare this with Excel’s natural order of 
operator precedence, as described earlier in “Understanding 
Excel Formulas,” and then use parentheses to force the 
correct order if necessary.

Understand Excel’s Error Values
Excel may display an error value instead of a formula result. The following table lists the six main error types:

Error Description

#DIV/0 Your formula is dividing by 0. Check the divisor input cells for values that are either 0 or blank.

#N/A Your formula could not return a legitimate result. Check that your function arguments are appropriate 
for each function.

#NAME? Your formula uses a name that Excel does not recognize. Check your range names and function 
names.

#NUM! Your formula uses a number inappropriately. Check the arguments for your mathematical functions to 
make sure they use the correct types of numbers.

#REF# Your formula contains an invalid cell reference. This usually occurs when you delete a cell referenced 
by a formula. Adjust the formula to use a different cell.

#VALUE! Your formula uses an inappropriate value in a function argument. Check your function arguments to 
make sure they use the correct data type.
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Manipulating Excel 
Worksheets

An Excel worksheet is where 
you enter your headings and 
data and build your formulas. 
You will spend most of your 
time in Excel operating within 
a worksheet, so you need to 
know how to navigate and 
perform worksheet tasks 
such as renaming, moving, 
copying, and deleting.
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Keyboard Techniques for Navigating a Worksheet

Press To Move

Left one cell

Right one cell

Up one cell

Down one cell

Home To the beginning of the current row

Down one screen

Up one screen

+

One screen to the right

+

One screen to the left

+ Home To the beginning of the worksheet

+ To the bottom right corner of the used portion of the worksheet

+arrow keys In the direction of the arrow to the next nonblank cell if the current cell is 
blank, or to the last nonblank cell if the current cell is not blank

You can use a few keyboard techniques that make 
it easier to navigate data after it is entered in a 
worksheet.

It is usually easiest to use your mouse to click in the next cell you 
want to work with. However, if you are entering data, then using 
the keyboard to navigate to the next cell is often faster.

Navigate a 
Worksheet

1
2
3
4
5
6

1
2
3
4
5
6
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5 If you want to edit the existing 
name, press either  or  to 
deselect the text.

6 Type the new worksheet name.

7 Press .

 Excel assigns the new name to the 
worksheet.

1 Display the worksheet you want 
to rename.

2 Click the Home tab.

3 Click Format.

4 Click Rename Sheet.

● You can also double-click the 
worksheet’s tab.

● Excel opens the worksheet name 
for editing and selects the text.

Rename a Worksheet

You can make your Excel workbooks easier to understand 
and navigate by providing each worksheet with a name that 
reflects the contents of the sheet.

Excel provides worksheets with generic names such as Sheet1 and Sheet2, 
but you can change these to more descriptive names such as Sales 2010, 
Amortization, or Budget Data.

Rename a 
Worksheet
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● Excel inserts the worksheet.

Note: You can also insert a blank worksheet by 
pressing + .

Insert a Blank Worksheet

1 Open the workbook to which you 
want to add the worksheet.

2 Click the Home tab.

3 Click the Insert .

4 Click Insert Sheet.

Create a New Worksheet

Excel supports multiple worksheets in a single 
workbook, so you can add as many worksheets 
as you need for your project or model.

In most cases, you will add a blank worksheet, but Excel also 
comes with several predefined worksheet templates that you 
can use.

Create a New 
Worksheet
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 The Insert dialog box appears.

4 Click the Spreadsheet Solutions 
tab.

5 Click the type of worksheet you 
want to add.

● You can also click Templates on 
Office Online to download 
worksheet templates from the Web.

6 Click OK.

Insert a Worksheet from a 
Template

1 Open the workbook to which you 
want to add the worksheet.

2 Right-click a worksheet tab.

3 Click Insert.

● Excel inserts the worksheet.

How do I navigate from one worksheet to another?
Click the tab of the worksheet you want to use. Press 

+  to move to the next worksheet, and +  
to move to the previous worksheet. You can also click the 
following controls:

Move to the first worksheet.

Move to the previous worksheet.

Move to the next worksheet.

Move to the last worksheet.

Is there an easier way to add a blank 
worksheet?
Yes. Open the workbook to which you 
want to add the worksheet, and then click 
the Insert Worksheet button ( ).

● Click .

149
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3 Click the Home tab.

4 Click Format.

5 Click Move or Copy Sheet.

● You can also right-click the tab 
and then click Move or Copy 
Sheet.

 The Move or Copy dialog box 
appears.

1 If you want to move the 
worksheet to another workbook, 
open that workbook and then 
return to the current workbook.

2 Click the tab of the worksheet you 
want to move.

Move a Worksheet

You can organize an Excel workbook and make 
it easier to navigate by moving your worksheets 
to different positions within the workbook. You 
can also move a worksheet to another workbook.

Move a 
Worksheet
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Is there an easier way to move a worksheet within the same workbook?
Yes. It is usually much easier to use your mouse to move a worksheet within the same workbook:

1 Move  over the tab of the worksheet you want to move.

2 Click and drag the worksheet tab left or right to the new position within the workbook.

  changes to .

● As you drag, an arrow shows the position of the 
worksheet.

3 When you have the worksheet positioned where you 
want it, drop the worksheet tab.

 Excel moves the worksheet.

6 If you want to move the sheet to 
another workbook, click the To 
book  and then click the 
workbook.

7 Use the Before sheet list to click a 
destination worksheet.

 When Excel moves the worksheet, 
it will appear to the left of the 
sheet you selected in Step 7.

8 Click OK.

● Excel moves the worksheet.

11
22

33
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3 Click the Home tab.

4 Click Format.

5 Click Move or Copy Sheet.

● You can also right-click the tab 
and then click Move or Copy 
Sheet.

 The Move or Copy dialog box 
appears.

1 If you want to copy the worksheet 
to another workbook, open that 
workbook and then return to the 
current workbook.

2 Click the tab of the worksheet you 
want to copy.

Copy a Worksheet

Excel enables you to make a copy of a 
worksheet, which is a useful technique if you 
require a new worksheet that is similar to an 
existing worksheet. You can copy the sheet to 
the same workbook or to another workbook.

Copy a 
Worksheet
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Is there an easier way to copy a worksheet within the same workbook?
Yes. It is usually much easier to use your mouse to copy a worksheet within the same workbook:

1 Move  over the tab of the worksheet you want to copy.

2 Hold down .

3 Click and drag the worksheet tab left or right.

  changes to .

● As you drag, an arrow shows the position of the 
worksheet.

4 When you have the worksheet positioned where you 
want it, drop the worksheet tab.

 Excel copies the worksheet.

6 If you want to copy the sheet to 
another workbook, click the To 
book  and then click the 
workbook.

7 Use the Before sheet list to click a 
destination worksheet.

 When Excel copies the worksheet, 
the copy will appear to the left of 
the sheet you selected in Step 7.

8 Click the Create a copy check 
box (  changes to ).

9 Click OK.

● Excel copies the worksheet.

● Excel gives the new worksheet the 
same name as the original, but 
with (2) appended.

Note: See “Rename a Worksheet” earlier in this 
chapter to learn how to edit the name of the copied 
worksheet.

11
33

44
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2 Click the Home tab.

3 Click the Delete .

4 Click Delete Sheet.

● You can also right-click the tab 
and then click Delete Sheet.

1 Click the tab of the worksheet 
you want to delete.

Delete a Worksheet

If you have a worksheet that you no longer need, 
you can delete it from the workbook. This 
reduces the size of the workbook and makes the 
workbook easier to navigate.

You cannot undo a worksheet deletion, so check the worksheet 
contents carefully before proceeding with the deletion.

Delete a 
Worksheet
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I have several worksheets I need to delete. Do I have to delete 
them individually?
No. You can select all the sheets you want to remove and then run the 
deletion. To select multiple worksheets, click the tab of one of the 
worksheets, hold down , and then click the tabs of the other 
worksheets.

If your workbook has many worksheets and you want to delete most of 
them, an easy way to select the sheets is to right-click any worksheet tab 
and then click Select All Sheets. Hold down , and then click the tabs 
of the worksheets that you do not want to delete.

After you have selected your worksheets, follow Steps 3 to 5 to delete all 
the selected worksheets at once.

 If the worksheet contains data, 
Excel asks you to confirm that you 
want to delete the worksheet.

5 Click Delete.

● Excel removes the worksheet.

XL
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3 Click Options.

1 Click the tab of the worksheet you 
want to customize.

2 Click the File tab.

Change the Gridline Color

You can add some visual interest to your worksheet 
by changing the color that Excel uses to display the 
gridlines. The default color is blank, but Excel 
offers a palette of 56 colors that you can choose 
from.

Changing the gridline color also has practical value because it enables 
you to differentiate between the gridlines and the borders that you add 
to a range or a table.

Change the 
Gridline Color
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Can I change the gridline color for all the sheets in my 
workbook?
Yes. One method would be to follow the steps in this section for each 
worksheet in your workbook. However, an easier method is to first select 
all the sheets in the workbook. To do this, right-click any worksheet tab 
and then click Select All Sheets.

You can now follow Steps 2 to 8 to apply the new gridline color to all 
your worksheets. Once you have done that, right-click any worksheet tab 
and then click Ungroup Sheets to collapse the grouping.

● Excel displays the gridlines using 
the color you selected.

 The Excel Options dialog box 
appears.

4 Click Advanced.

5 Scroll down to the Display options 
for this worksheet section.

6 Click the Gridline color .

7 Click the color you want to use.

8 Click OK.

XL
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● Excel turns off the gridline display.

Turn Gridlines On

● To turn the gridlines back on, click 
Gridlines (  changes to ).

Turn Gridlines Off

1 Click the tab of the worksheet you 
want to work with.

2 Click the View tab.

3 Click Gridlines (  changes 
to ).

Toggle Worksheet Gridlines On and Off

You can make your worksheet look cleaner and make 
the worksheet text easier to read by turning off the 
sheet gridlines. When you do this, Excel displays the 
worksheet with a plain white background, which 
often makes the worksheet easier to read.

If you find you have trouble selecting ranges with the gridlines turned 
off, you can easily turn them back on again.

Toggle Worksheet 
Gridlines On and Off
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● Excel turns off the headings.

Turn Headings On

● To turn the headings back on, 
click Headings (  changes 
to ).

Turn Headings Off

1 Click the tab of the worksheet you 
want to work with.

2 Click the View tab.

3 Click Headings (  changes 
to ).

Toggle Worksheet Headings On and Off

You can give yourself a bit more room to work by 
turning off the worksheet’s row headings — the numbers 
1, 2, and so on to the left of the worksheet — and column 
headings — the letters A, B, and so on above the 
worksheet.

If you find you have trouble reading your worksheet or building formulas with 
the headings turned off, you can easily turn them back on again.

Toggle Worksheet 
Headings On and Off
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2 Click the Home tab.

3 Click Format.

4 Click Tab Color.

1 Click the tab of the worksheet you 
want to format.

Set the Worksheet Tab Color

You can make a workbook easier to navigate by 
color-coding the worksheet tabs. For example, if 
you have a workbook with sheets associated with 
several projects, you could apply a different tab 
color for each project. Similarly, you could format 
the tabs of incomplete worksheets with one color, 
and completed worksheets with another color.

Excel offers 10 standard colors as well as 60 colors associated with 
the current workbook theme.

Set the Worksheet 
Tab Color
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How do I remove a 
tab color?
If you no longer 
require a worksheet 
to have a colored tab, 
you can remove the 
color. Follow Steps 1 
to 4 to select the 
worksheet and 
display the Tab Color palette, and then click 
No Color. Excel removes the color from the 
worksheet’s tab.

If I want to apply the same color 
to several worksheets, do I have 
to format them individually?
No. You can select all the sheets you 
want to format and then apply the 
tab color. To select multiple 
worksheets, click the tab of one of 
the worksheets, hold down , 
and then click the tabs of the other 
worksheets. After you have selected your worksheets, 
follow Steps 2 to 5 to apply the tab color to all the 
selected worksheets at once.

● Excel applies the color to the tab.

Note: You can also right-click the tab, click Tab 
Color, and then click the color you want to apply.

 Excel displays the Tab Color 
palette.

5 Click the color you want to use 
for the current tab.
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2 Click the Page Layout tab.

3 Click Background ( ).

1 Click the tab of the worksheet you 
want to customize.

Set the Worksheet Background

You can add visual interest to a worksheet by 
replacing the standard white sheet background 
with a photo, drawing, or other image.

When choosing the image you want to use as the background, be 
sure to select a picture that will not make the worksheet text 
difficult to read. If your sheet text is a dark color, choose a   
light-colored image as the background.

Set the Worksheet 
Background
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How do I remove the 
background image 
from the worksheet?
If you find that having the 
background image makes 
it difficult to read the 
worksheet text, then you 
should remove the 
background. Click the tab 
of the worksheet, click 
Page Layout, and then click Delete Background 
( ). Excel removes the background image from 
the worksheet.

How do I apply a 
background color 
instead of a background 
image?
Excel does not have a 
command that changes the 
background color of the 
entire worksheet. Instead, 
you must first select all the 
cells in the worksheet by clicking . Click the 
Home tab, click the Fill Color , and then click 
the color you want to use. Excel applies the color 
to the background of every cell.

● Excel formats the worksheet 
background with the image 
you selected.

 The Sheet Background dialog 
box appears.

4 Select the location of the image 
you want to use.

5 Click the image.

6 Click Insert.

My Spreadsheet

File   Edit   View   Insert  Format  Tools  Data  Winow  Help
ABC

X
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2 Click the View tab.

3 Click Zoom ( ).

● You can also run the Zoom 
command by clicking the zoom 
level in the status bar.

1 Click the tab of the worksheet you 
want to zoom.

Zoom In On or Out of a Worksheet

You can get a closer look at a portion of a 
worksheet by zooming in on that range. When 
you zoom in on a range, Excel magnifies the 
range, which makes it easier to see.

If you want to get a sense of the overall structure of a worksheet, 
you can also zoom out. When you zoom out, Excel decreases the 
magnification, so you see more of the worksheet.

Zoom In On or Out 
of a Worksheet
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Is there an easier way to zoom in and out of a 
worksheet?
Yes, you can use the Zoom slider, which appears on 
the far right side of the Excel status bar. Drag the 
slider  to the right to zoom in on the worksheet, or 
drag  to the left 
to zoom out. You 
can also click the 
Zoom In ( ) or 
Zoom Out ( ) 
button to change 
the magnification.

How can I zoom in on 
a particular range?
Excel offers the Zoom to 
Selection feature that 
enables you to quickly 
and easily zoom in on a 
range. First, select the 
range that you want to 
magnify. Click the View 
tab and then click Zoom 
to Selection ( ). Excel magnifies the selected 
range to fill the entire Excel window.

 The Zoom dialog box appears.

4 Click the magnification level you 
want to use (  changes to ).

● You can also click Custom 
(  changes to ) and then 
type a magnification level in the 
text box.

Note: Select a magnification level above 100% 
to zoom in on the worksheet; select a level under 
100% to zoom out of the worksheet.

5 Click OK.

 Excel changes the magnification 
level and redisplays the 
worksheet.

● You can click 100% ( ) to 
return to the normal zoom level.

++
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2 Select a cell in column A that is 
below the point where you want 
the split to occur.

 For example, if you want to place 
the first six rows in the top pane, 
select cell A7.

1 Click the tab of the worksheet you 
want to split.

Split a Worksheet into Two Panes

You can make it easier to examine your 
worksheet data by splitting the worksheet into 
two scrollable panes that each show different 
parts of the worksheet. This is useful if you have 
cell headings at the top of the worksheet that you 
want to keep in view as you scroll down the 
worksheet.

Splitting a worksheet into two panes is also useful if you want to 
keep some data or a formula result in view while you scroll to 
another part of the worksheet.

Split a Worksheet 
into Two Panes
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Can I split a worksheet 
into four panes?
Yes. This is useful if you have 
three or four worksheet 
areas that you want to 
examine separately. To 
perform a four-way split, first 
select the cell where you 
want the split to occur. Note 
that this cell must not be in either row 1 or column 
A. When you click , Excel splits the worksheet into 
four panes. The cell you selected becomes the 
upper-left cell in the bottom-right pane.

Can I split a worksheet 
into two vertical 
panes?
Yes. To do this, you must 
first select a cell in the top 
row of the worksheet. In 
particular, select the top 
cell in the column to the 
right of where you want 
the split to occur. For example, if you want to 
show only column A in the left pane, select 
cell B1. When you click , Excel splits the 
worksheet into two vertical panes.

● Excel splits the worksheet into 
two horizontal panes at the 
selected cell.

● You can adjust the size of the 
panes by clicking and dragging 
the split bar up or down.

 To remove the split, either click 
 again, or double-click the 

split bar.

3 Click the View tab.

4 Click Split ( ).
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 Worksheet Worksheet Worksheet

● Excel temporarily removes the 
worksheet from the workbook.

Hide a Worksheet

1 Click the tab of the worksheet 
you want to hide.

2 Click the Home tab.

3 Click Format.

4 Click Hide & Unhide.

5 Click Hide Sheet.

● You can also right-click the 
worksheet tab and then click 
Hide Sheet.

Hide and Unhide a Worksheet

You can hide a worksheet so that it no longer 
appears in the workbook. This is useful if you 
need to show the workbook to other people, 
but the workbook contains a worksheet with 
sensitive data that you do not want others 
to see.

To learn how to protect a workbook so that other people cannot 
unhide a worksheet, see Chapter 15.

Hide and Unhide 
a Worksheet
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I have several worksheets I need to hide. Do I have to hide them 
individually?
No. You can select all the sheets you want to work with and then hide 
them. To select multiple worksheets, click the tab of one of the 
worksheets, hold down , and then click the tabs of the other 
worksheets.

If your workbook has many worksheets and you want to hide most of 
them, an easy way to select the sheets is to right-click any worksheet tab 
and then click Select All Sheets. Hold down , and then click the tabs 
of the worksheets that you do not want to hide.

After you have selected your worksheets, follow Steps 3 to 5 to hide all the 
selected worksheets at once.

 The Unhide dialog box appears.

5 Click the worksheet you want to 
restore.

6 Click OK.

Unhide a Worksheet

1 Click the Home tab.

2 Click Format.

3 Click Hide & Unhide.

4 Click Unhide Sheet.

● You can also right-click any 
worksheet tab and then click 
Unhide Sheet.

● Excel returns the worksheet to 
the workbook.
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Dealing with Excel 
Workbooks

Everything you do in Excel 
takes place within a 
workbook, which is the 
standard Excel file. This 
chapter shows you how to 
get more out of workbooks 
by creating new files; saving, 
opening, and closing files; 
checking spelling; and more.
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2 Click New.

1 Click the File tab.

Create a New Blank Workbook

To perform new work in Excel, you need to 
first create a new, blank Excel workbook. 
Excel automatically creates a blank workbook 
each time you start the program, but for 
subsequent files you must create a new 
workbook yourself.

If you prefer to create a workbook based on one of Excel’s 
templates, see “Create a New Workbook from a Template.”

Create a New 
Blank Workbook
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shortshort
cutcut
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Book 1

When I start Excel and then open an 
existing workbook, Excel often removes 
the new, blank workbook that it opened 
automatically. How can I prevent this?
Excel assumes that you want to use a fresh 
workbook when you start the program, so it 
opens a blank workbook for you automatically. 
However, if you do not make any changes to 
the blank workbook and then open an existing file, Excel assumes 
you do not want to use the new workbook, so it closes it. To 
prevent this from happening, make a change to the blank 
workbook before opening any existing file.

Is there a 
faster method 
I can use to 
create a new 
workbook?
Yes. Excel offers 
a keyboard 
shortcut for faster 
workbook creation. From the 
keyboard, press + .

● Excel creates the blank workbook 
and displays it in the Excel 
window.

3 Click Blank Workbook.

4 Click Create.
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2 Click New.

3 Click Sample templates.

● To use an Office Online template, 
click a category in the Office.com 
Templates section. Click the 
template you want to use, and 
then click Download.

1 Click the File tab.

Create a New Workbook from a Template

You can save time and effort by creating a new 
workbook based on one of Excel’s template files. 
Each template includes a working spreadsheet 
model that includes predefined labels and 
formulas, as well as preformatted colors, fonts, 
styles, and more.

Excel 2010 offers seven templates, and many more are available 
through Microsoft Office Online.

Create a New Workbook 
from a Template
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Formatting
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Sales Template

Sales TemplateCan I create a new 
workbook based on 
an existing 
workbook?
Yes. This is useful if you 
want to create a new 
workbook that is the 
same or similar to an 
existing file. Click File, 
click New, and then click 
New from Existing. In 
the New from Existing Workbook dialog box, 
click the existing workbook and then click 
Open.

Can I create my own 
template?
Yes. If you have a specific 
workbook structure that you 
use frequently, you should 
save it as a template so that 
you do not have to re-create 
the same structure from 
scratch each time. Open the 
workbook, click File, and then click Save As. In the 
Save As dialog box, click the Save as type  and 
then click Excel Template. Type a File name and 
then click Save. To use the template, click File, click 
New, and then click My Templates.

● Excel creates the new workbook 
and displays it in the Excel 
window.

4 Click the template you want to 
use.

● A preview of the template appears 
here.

5 Click Create.
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After you create a workbook in Excel and make changes 
to it, you can save the document to preserve your work.

When you edit a workbook, Excel stores the changes in your computer’s 
memory, which is erased each time you shut down your computer. Saving 
the document preserves your changes on your computer’s hard drive.
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1 Click the File tab.

2 Click Save ( ).

 You can also click  in the Quick 
Access Toolbar, or you can press 

+ .

 If you have saved the document 
previously, your changes are now 
preserved, and you do not need 
to follow the rest of the steps in 
this section.

 The Save As dialog box appears.

 If this is a new document that you 
have never saved before, the Save 
dialog box appears.

3 Click in the File name text box 
and type the name that you want 
to use for the document.

4 Select a folder in which to store 
the file.

5 Click Save.

 Excel saves the file.

Note: To learn how to save a workbook in an 
older Excel format, see Chapter 15.

Save a Workbook
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Open a 
Workbook

To view or make changes to an Excel workbook that you 
have saved in the past, you can open it in Excel.

If you have used the workbook recently, you can save time by opening the 
workbook from Excel’s Recent menu.

 Worksheet 1

33

22

44

55

111 Click the File tab.

● You can click Recent to see a list 
of your recently used workbooks. 
If you see the file you want, click it 
and then skip the rest of these 
steps.

2 Click Open ( ).

 You can also press + .

 The Open dialog box appears.

3 Select the folder that contains the 
workbook you want to open.

4 Click the workbook.

5 Click Open.

 The workbook appears in a 
window.

Open a Workbook

Dealing with Excel Workbooks chapter8
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 Workbook 3

 Workbook 3

 Workbook 3
 Workbook 3 Workbook 3 Workbook 3 Workbook 1

 Workbook 1
 Workbook 1

 Workbook1
 Workbook1
 Workbook1

 Workbook 2 Workbook 2 Workbook 2

 Workbook 2
 Workbook 2
 Workbook 2

 Workbook 3
 Workbook 3
 Workbook 3

22

33

3 Click Arrange All ( ).

 The Arrange Windows dialog box 
appears.

1 Open the workbooks you want to 
view.

2 Click the View tab.

Arrange Workbook Windows

You can view two or more workbooks at once 
by arranging the workbook windows within 
the main Excel window.

Excel offers four view modes for arranging workbook windows: 
Tiled, Horizontal, Vertical, and Cascade.

Arrange Workbook 
Windows
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Is it possible to view 
two different sections 
of a single workbook 
at the same time?
Yes. Excel enables you to 
create a second window 
for a workbook, and you 
can then arrange the two 
windows as described in 
this section. To create the 
second window, switch to 
the workbook you want to 
view, click the View tab, and then click New 
Window ( ). Follow Steps 1 to 4 to open the 
Arrange Windows dialog box and select a view 
option. Click the Windows of active workbook 
check box (  changes to ), and then click OK.

How do I return to 
viewing one workbook 
at a time?
Click the workbook you 
want to use, and then 
click the workbook 
window’s Maximize 
button ( ). This 
maximizes the workbook 
within the Excel window, 
so you only see that 
workbook. Excel also maximizes the other open 
workbooks, but you only see them if you switch to 
them.

4 Click a view mode (  changes 
to ).

 Tiled arranges the workbooks 
evenly within the Excel window.

 Horizontal stacks the workbooks 
one above the other.

 Vertical displays the workbooks 
side by side.

 Cascade arranges the workbooks 
in an overlapping cascade pattern.

5 Click OK.

● Excel arranges the workbook 
windows.

 This example shows two 
workbooks arranged with the 
Horizontal view mode.

10_577646-ch08.indd   17910_577646-ch08.indd   179 3/8/10   6:52 PM3/8/10   6:52 PM



180

ExcelExcelExcel

 Worksheet 1 Worksheet 1 Worksheet 1

11

44

33

22

55

 The Find and Replace dialog box 
appears.

4 Click in the Find what text box 
and type the text you want to find.

5 Click Find Next.

1 Click the Home tab.

2 Click Find & Select.

3 Click Find.

Note: You can also run the Find command by 
pressing + .

Find Text in a Workbook

In large workbooks with multiple sheets, 
when you need to find specific text, you can 
save a lot of time by using Excel’s Find 
feature, which searches the entire workbook 
in the blink of an eye.

Find Text in 
a Workbook

10_577646-ch08.indd   18010_577646-ch08.indd   180 3/8/10   6:52 PM3/8/10   6:52 PM



181

Dealing with Excel Workbooks chapter8

66 77

 Worksheet 1

When I search for a 
name such as Bill, 
Excel also matches the 
non-name bill. Is there 
a way to fix this?
In Excel’s Find and Replace 
dialog box, click Options 
to expand the dialog box. 
Select the Match case 
check box (  changes 
to ). This option tells Excel to match the search 
text only if it has the same mix of uppercase and 
lowercase letters that you specify in the Find what 
text box. If you type Bill, for example, the program 
matches only Bill and not bill.

When I search for a 
particular term, Excel 
only looks in the 
current worksheet. 
How can I get Excel 
to search the entire 
workbook?
In Excel’s Find and 
Replace dialog box, click 
Options to expand the 
dialog box. Click the 
Within  and then 
click Workbook. This option tells Excel to examine 
the entire workbook for your search text.

● Excel selects the next cell that 
contains an instance of the search 
text.

Note: If the search text does not exist in the 
document, Excel displays a dialog box to let you 
know.

6 If the selected instance is not the 
one you want, click Find Next 
until Excel finds the correct 
instance.

7 Click Close to close the Find and 
Replace dialog box.

● Excel leaves the cell selected.
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 The Find and Replace dialog box 
appears.

4 In the Find what text box, type the 
text you want to find.

5 In the Replace with text box, type 
the text you want to use as the 
replacement.

6 Click Find Next.

1 Click the Home tab.

2 Click Find & Select.

3 Click Replace.

Note: You can also run the Replace command by 
pressing + .

Replace Text in a Workbook

Do you need to replace a word or part of a 
word with some other text? If you have several 
instances to replace, you can save time and do 
a more accurate job if you let Excel’s Replace 
feature replace the text for you.

Replace Text 
in a Workbook
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Is there a faster way to replace every instance of the search 
text with the replacement text?
Yes. In the Find and Replace dialog box, click Replace All. This tells 
Excel to replace every instance of the search text with the replacement 
text. However, you should exercise some caution with this feature 
because it may make some replacements that you did not intend. Click 
Find Next a few times to make sure the matches are correct. Also, 
consider clicking Options and then selecting the Match case check box 
(  changes to ), as described in “Find Text in a Workbook.”

● Excel selects the cell that contains 
the next instance of the search 
text.

Note: If the search text does not exist in the 
document, Excel displays a dialog box to let you 
know.

7 If the selected instance is not the 
one you want, click Find Next 
until Excel finds the correct 
instance.

8 Click Replace.

● Excel replaces the selected text 
with the replacement text.

● Excel selects the next instance of 
the search text.

9 Repeat Steps 7 and 8 until you 
have replaced all of the instances 
you want to replace.

0 Click Close to close the Find and 
Replace dialog box.
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● The Spelling dialog box appears 
and selects the cell that contains 
the first error.

3 Click the correction you want to 
use.

4 Click Change.

● Click Change All to correct every 
instance of the error.

1 Click the Review tab.

2 Click Spelling ( ).

Note: You can also press .

Check Spelling and Grammar

You can reduce the number of errors in your 
Excel workbooks by taking advantage of the 
spell-checker, which identifies potentially 
misspelled words and suggests corrections.

When the spell-checker flags a word as misspelled, you can 
correct the word, tell the spell-checker to ignore it, or you can 
add it to the spell-checker’s dictionary.

 Check Spelling 
and Grammar
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Can I remove a word that I added to the spell-checker’s 
dictionary?
Yes. Follow these steps:

1 Click File.

2 Click Options.

3 Click Proofing.

4 Click Custom Dictionaries.

5 Click Edit Word List.

6 Click the term you want to remove.

 7 Click Delete.

8 Click OK.

● The spell-checker displays the next 
error.

5 If you want to correct the word, 
repeat Step 4.

● If you do not want to correct the 
word, click one of the following 
buttons:

 Click Ignore Once to skip this 
instance of the error.

 Click Ignore All to skip all 
instances of the error.

 Click Add to Dictionary to 
include the word in the spell-
checker’s dictionary.

6 When the check is complete, click 
OK.
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222 Click the File tab.

1 Display the workbook you want to 
close.

Close a Workbook

When you finish adding and editing text in 
an Excel workbook, you should close the 
workbook to reduce desktop clutter. If the 
workbook is very large or contains many 
images, closing the file also frees up memory 
and other system resources.

Close a 
Workbook
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Are there faster methods I can use to close a document?
Yes. You can also close a document using a keyboard shortcut or with 
a mouse click. From your keyboard, press +  to close the current 
document; with your mouse, click the Close button ( ) in the upper left 
corner of the document window.

 If you have unsaved changes in 
the workbook, Excel asks if you 
want to save your work.

4 Click Save.

● If you do not want to preserve 
your changes, click Don’t Save.

● If you decide to keep the 
document open, click Cancel.

 The program saves your work and 
then closes the document.

3 Click Close.
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Formatting 
Excel Workbooks

Excel offers several settings 
that enable you to control 
the look of a workbook, 
including the workbook 
colors, fonts, and special 
effects. You can also apply 
a workbook theme, and add 
a header and footer to a 
workbook.
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3 Click Colors ( ).

1 Open or switch to the workbook 
you want to format.

2 Click the Page Layout tab.

Modify the Workbook Colors

You can give your workbook a new look by 
selecting a different color scheme. Each color 
scheme affects the workbook’s text colors, 
background colors, border colors, and more. 
Excel offers more than 20 color schemes.

To get the most out of Excel’s color schemes, you must apply 
styles to your ranges, as described in Chapter 5.

Modify the 
Workbook Colors
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44Can I create my own color scheme?
Yes, by following these steps:

1 Click the Page Layout tab.

2 Click .

3 Click Create New Theme Colors.

 The Create New Theme Colors dialog box appears.

4 For each theme color, click  and then click the color you want to use.

● The Sample area shows what your theme colors look like.

5 Type a name for the custom color scheme.

6 Click Save.

● Excel applies the color scheme to 
the workbook.

4 Click the color scheme you want 
to apply.
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3 Click Fonts ( ).

1 Open or switch to the workbook 
you want to format.

2 Click the Page Layout tab.

Set the Workbook Fonts

You can add visual appeal to your workbook 
by selecting a different font scheme. Each font 
scheme has two defined fonts: a heading font 
for the titles and headings, and a body font for 
the regular worksheet text. Excel offers more 
than 20 font schemes.

To get the most out of Excel’s font schemes, particularly the 
heading fonts, you must apply styles to your ranges, as 
described in Chapter 5.

Set the 
Workbook Fonts
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● Excel applies the heading font to 
the workbook’s headings.

● Excel applies the body font to the 
workbook’s regular text.

4 Click the font scheme you want to 
apply.

44

55

77

66

Can I create my own font scheme?
Yes, by following these steps:

1 Click the Page Layout tab.

2 Click .

3 Click Create New Theme Fonts.

 The Create New Theme Fonts dialog box appears.

4 Click the Heading font  and then click the font 
you want to use for titles and headings.

5 Click the Body font  and then click the font you 
want to use for regular sheet text.

● The Sample area shows what your theme fonts look like.

6 Type a name for the custom font scheme.

7 Click Save.

193
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3 Click Effects ( ).

1 Open or switch to the workbook 
you want to format.

2 Click the Page Layout tab.

Choose Workbook Effects

You can enhance the look of your workbook by 
selecting a different effect scheme. The effect 
scheme applies to charts and graphic objects, and 
each scheme defines a border style, fill style, 
and added effect such as a drop shadow or 
glow. Excel offers more than 20 effect schemes.

To get the most out of Excel’s effect schemes, you must apply 
a style to your chart, as described in Chapter 13; or to your 
graphic object, as described in Chapter 14.

Choose Workbook 
Effects
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Why are all the effect schemes 
the same color?
The color you see in the effect 
schemes depends on the color scheme 
you have applied to your workbook. If 
you apply a different color scheme, as 
described in “Modify the Workbook 
Colors,” you will see a different color in 
the effect schemes. If you want to use 
a custom effect color, create a custom color scheme and 
change the Accent 1 color to the color you want.

Can I create a 
custom effect 
scheme?
No. Unlike with the 
color schemes and 
font schemes 
described earlier in 
this chapter, Excel 
does not have a 
feature that enables you to create 
your own effect scheme.

● Excel applies the effect scheme 
to the workbook’s charts and 
graphics.

4 Click the effect scheme you want 
to apply.
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3 Click Themes ( ).

1 Open or switch to the workbook 
you want to format.

2 Click the Page Layout tab.

Apply a Workbook Theme

You can give your workbook a completely new 
look by selecting a different workbook theme. 
Each theme consists of the workbook’s colors, 
fonts, and effects. Excel offers more than 20 
predefined workbook themes.

To get the most out of Excel’s workbook themes, you must apply 
styles to your ranges, as described in Chapter 5; to your charts, as 
described in Chapter 13; and to your graphic objects, as described 
in Chapter 14.

Apply a 
Workbook Theme
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Can I create my own workbook theme?
Yes, by following these steps:

1 Format the workbook with a color scheme, font scheme, and effect scheme, as described in the previous three 
sections.

2 Click the Page Layout tab.

3 Click .

4 Click Save Current Theme.

 The Save Current Theme dialog box appears.

5 Type a name for the custom theme.

6 Click Save.

● Excel applies the theme to the 
workbook.

4 Click the workbook theme you 
want to apply.
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● Excel opens the header area for 
editing.

● Excel adds the Header & Footer 
Tools tab.

4 Click the Design tab.

1 Click the View tab.

2 Click Page Layout ( ).

 Excel switches to Page Layout 
view.

● You can also click the Page 
Layout button ( ).

3 Click the Click to add header 
text.

Add a Workbook Header

If you will be printing a workbook, you can 
enhance the printout by building a custom header 
that includes information such as the page number, 
date, file name, or even a picture.

The header is an area on the printed page between the top of the page 
text and the top margin. Excel offers a number of tools that make it 
easy to build a custom header.

Add a Workbook 
Header
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Can I have multiple headers in a workbook?
Yes. You can have a different header and footer on the first page, which is useful if 
you want to add a title or explanatory text to the first page. In the Design tab, click 
the Different First Page check box (  changes to ).

You can also have different headers and footers on the even and odd pages of the 
printout, such as showing the file name on the even pages and the page numbers on 
the odd pages. In the Design tab, click the Different Odd & Even Pages check box 
(  changes to ).

7 Click a button in the Header & 
Footer Elements group to add that 
element to the header.

● Excel inserts a code into the 
header, such as &[Date] for the 
Current Date element, as shown 
here.

8 Repeat Steps 5 to 7 to build the 
header.

9 Click outside the header area.

5 Type any text you want to in the 
header.

6 If you want to include a 
predefined header item, click 
Header and then click the item.
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● Excel adds the Header & Footer 
Tools tab.

4 Click the Design tab.

5 Click Go to Footer ( ).

● Excel opens the footer area for 
editing.

1 Click the View tab.

2 Click Page Layout ( ).

 Excel switches to Page Layout 
view.

● You can also click the Page 
Layout button ( ).

3 Click the Click to add header 
text.

Note: You can also scroll down the bottom of the 
page and click the Click to add footer text. If 
you do this, you can skip Step 5.

Add a Workbook Footer

If you will be printing a workbook, you can enhance 
the printout by building a custom footer that includes 
information such as the current page number, the total 
number of pages, the worksheet name, and more.

The footer is an area on the printed page between the bottom of the page 
text and the bottom margin. Excel offers a number of tools that make it easy 
to build a custom footer.

Add a 
Workbook Footer
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Can I view my headers and footers before I 
print the workbook?
Yes. Follow these steps:

1 Click the File tab.

2 Click Print.

● The right side of the tab shows you a preview of the 
workbook printout.

● Click the arrows to scroll through the pages.

8 Click a button in the Header & 
Footer Elements group to add that 
element to the footer.

● Excel inserts a code into the 
footer, such as &[Pages] for the 
Number of Pages element, as 
shown here.

9 Repeat Steps 6 to 8 to build the 
footer.

0 Click outside the footer area.

6 Type any text you want to in the 
footer.

7 If you want to include a 
predefined footer item, click 
Footer and then click the item.
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Printing Excel 
Workbooks

If you want to distribute 
hard copies of one or more 
worksheets or an entire 
workbook, you can use 
Excel’s Print feature. Before 
you print, you can adjust 
print-related options such 
as the margins, page 
orientation, and paper size.
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5 Use the spin boxes to specify the 
margin sizes in inches.

Note: Do not make the margins too small or your 
document may not print properly. Most printers 
cannot handle margins smaller than about 0.25 
inch, although you should consult your printer 
manual to confirm this. In particular, see if your 
printer offers a “borderless” printing option.

6 Click OK.

 Excel adjusts the margin sizes.

Adjust Margins Using the 
Ribbon

1 Open the workbook you want to 
print.

2 Click the Page Layout tab.

3 Click Margins ( ).

● If you see a margin setting you 
want to use, click the setting and 
skip the rest of these steps.

4 Click Custom Margins.

 The Page Setup dialog box 
appears with the Margins tab 
selected.

Adjust the Workbook Margins

You can get more room on the printed page to 
display your worksheet data by using narrow page 
margins. The margins are the blank areas that 
surround the printed data.

If you or another person will be writing notes on the printouts, 
consider using wider margins to allow more room for the notes.

Adjust the 
Workbook Margins
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What are the header and 
footer margins?
The header margin is the 
space between the workbook 
header and the top of the 
page, and the footer margin is 
the space between the workbook 
footer and the bottom of the page. 
(See Chapter 9 to learn how to add a header and 
footer to your workbook.) In the Margins tab of the 
Page Setup dialog box, use the Header and Footer 
spin boxes to set these margins.

I increased my margin sizes 
to get more room around the 
text. Is there a way to center 
the text on the page?
Yes. This is a good idea if you 
want to ensure that you have 
the same amount of whitespace 
above and below the text, and to the 
left and right of the text. Follow Steps 1 to 4 
on the previous page to open the Page Setup 
dialog box with the Margins tab selected. Click 
Horizontally (  changes to ), click Vertically 
(  changes to ), and then click OK.

Adjust Margins Using the Ruler

1 Open the workbook you want to 
print.

2 Click Page Layout ( ).

3 Move the  over the right edge 
of the ruler’s left margin area 
(  changes to ).

4 Click and drag the edge of the 
margin to set the left margin 
width.

5 Click and drag the left edge of the 
right margin area to set the right 
margin width.

6 Move the  over the bottom edge 
of the ruler’s top margin area 
(  changes to ).

7 Click and drag the edge of the 
margin to set the top margin 
width.

8 Click and drag the top edge of the 
bottom margin area (not shown) 
to set the bottom margin width.

Note: You need to scroll down to the bottom of the 
page to see the bottom margin.

 Excel adjusts the margin sizes.

HEADERHEADER
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Change the 
Page Orientation

You can improve the look of your printout by changing the page orientation to suit your 
data. The page orientation determines whether Excel prints more rows or columns on a page. 
Portrait orientation is taller, so it prints more rows; landscape orientation is wider, so it 
prints more columns.

Choose the orientation based on your worksheet data. If your worksheet has many rows and only a few columns, choose 
portrait; if your worksheet has many columns but just a few rows, choose landscape.

206

 Worksheet 1
 Worksheet 1
 Worksheet 1

 Worksheet 2
 Worksheet 2
 Worksheet 2

22

44

11

33
1 Open the workbook you want to 

print.

2 Click the Page Layout tab.

3 Click Orientation ( ).

4 Click the orientation you want to 
use.

● Excel adjusts the orientation.

● Click  to see the orientation.

Change the Page Orientation
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Insert a 
Page Break

You can control what data appears on each printed page by 
inserting a page break in your worksheet. A page break is a 
location within a worksheet where Excel begins a new printed 
page. Excel normally inserts its own page breaks based on the 
number of rows in the sheet, the number and width of the 
sheet columns, the margin widths, and the page orientation.

A vertical page break starts a new page at a particular column; a horizontal page 
break starts a new page at a particular row.

Report A

         Page 1

X L

33

44
55

22

11

1 Open the workbook you want to 
print.

2 Select the cell to the right of and 
below where you want the vertical 
and horizontal page breaks to 
appear.

Note: Select a cell in row 1 to create just a vertical 
page break; select a cell in column A to create just 
a horizontal page break.

3 Click the Page Layout tab.

4 Click Breaks ( ).

5 Click Insert Page Break.

● Excel inserts the page breaks and 
indicates the breaks with dashed 
lines.

Insert a Page Break

Printing Excel Workbooks chapter10
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2 Click the Page Layout tab.

3 Click Size ( ).

● If you see a page size you want to 
use, click the size and skip the rest 
of these steps.

4 Click More Paper Sizes.

1 Open the workbook you want to 
print.

Choose a Paper Size

You can customize your print job by choosing a 
paper size that is appropriate for your printout. 
For example, if your worksheet has many rows, 
you might prefer to print it on a longer sheet of 
paper, such as a legal-size page (81⁄2 inches wide 
by 14 inches long).

Check your printer manual to make sure your printer can handle 
the paper size you select.

Choose a 
Paper Size
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 Worksheet 1 

 Worksheet 1 

 Worksheet 1 

 Worksheet 1
 

 Worksheet 1
 

 Worksheet 1
 

Is there a way to ensure that all my worksheet columns fit onto a single 
page?
Yes. First, try selecting a wider page size as described in this section. If that does 
not help, you can also try reducing the left and right margins, as described earlier 
in “Adjust the Workbook Margins.” Alternatively, switch to the landscape orientation, 
as described earlier in “Change the Page Orientation.” 

If you still cannot get all of your columns to fit onto a single page, follow Steps 1 
to 4 to display the Page Setup dialog box with the Page tab selected. Click Fit to 
(  changes to ), and set the page(s) wide spin box to 1. Set the tall spin box to 
a number large enough that all of your printed rows will fit on a single page. (If you 
are not sure about the correct number, you can click Print Preview to check.) Click OK.

6 Click OK.

 Excel uses the new paper size 
option when you print the 
workbook.

 The Page Setup dialog box 
appears with the Page tab 
selected.

5 Click the Paper size  and then 
click the size you want to use.
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2 Select the range that you want to 
print.

1 Open the workbook you want to 
print.

Set the Print Area

You can control the cells that Excel includes in the 
printout by setting the print area for the worksheet. 
The print area is a range of cells that you select. 
When Excel prints the workbook, it prints only the 
cells within the print area.

You normally define a single range of cells as the print area, but it is 
possible to set up two or more ranges as the print area. See the first 
Tip at the bottom of the next page.

Set the 
Print Area
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How do I remove an 
existing print area?
First, note that if you just 
want to set a new print area, 
you do not need to remove 
the existing print area first. 
Instead, select the range you 
want to use and then follow 
Steps 3 to 5. Excel replaces 
the original print area with the new one. If you no 
longer want a print area defined, click the Page 
Layout tab, click , and then click Clear Print 
Area.

Can I define two 
different ranges as the 
print area?
Yes. The easiest way to do 
this is to follow the steps in 
this section to set the first 
range as the print area. 
Next, select the second 
range, click the Page Layout 
tab, click , and then click Add to Print Area. 
You can repeat this procedure to add as many 
ranges as you require to the print area.

● Excel displays a dashed line 
around the print area.

 When you print the worksheet, 
Excel prints only the cells within 
the print area.

3 Click the Page Layout tab.

4 Click Print Area ( ).

5 Click Set Print Area.
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 Excel opens the Page Setup dialog 
box with the Sheet tab displayed.

5 Click inside the Rows to repeat 
at top range box.

6 Click the Collapse Dialog button 
( ).

1 Open the workbook you want to 
print.

2 Click the tab of the worksheet you 
want to configure.

3 Click the Page Layout tab.

4 Click Print Titles ( ).

Configure Titles to Print on Each Page

You can make your printout easier to read by 
configuring the worksheet to print the range 
titles on each page of the printout. For example, 
if your data has a row of headings at the top, you 
can configure the worksheet to display those 
headings at the top of each printout page.

Similarly, if your data has a column of headings at the left, you can 
configure the worksheet to display those headings on the left side of 
each printout page.

Configure Titles to 
Print on Each Page
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How do I configure my worksheet to print a column of 
headings on each page?
If your headings appear in a column rather than a row, you can still 
configure the sheet to print them on each page. Follow these steps:

1 Follow Steps 1 to 4 to open the Page Setup dialog box with the 
Sheet tab displayed.

2 Click inside the Columns to repeat at left range box.

3 Click .

4 Use the mouse  to click the column that you want to appear on 
the left of each printed page.

5 Click .

6 Click OK.

● Excel collapses the Page Setup 
dialog box.

 The mouse pointer changes from 
 to .

7 Use the mouse  to click the row 
that you want to appear at the top 
of each printed page.

 If you want more than one row to 
repeat at the top of each page, 
use the mouse  to click the last 
row that you want to repeat.

8 Click the Restore Dialog button 
( ).

● The address of the row appears in 
the Rows to repeat at top box.

9 Click OK.
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4 Click Print.

 The Print Settings window 
appears.

● Excel displays a preview of the 
printout.

Note: If you do not see the preview, click Show 
Print Preview.

5 Click Print Preview Next Page 
( ) to scroll through the printout 
pages.

1 Open the workbook you want to 
print.

2 Click the tab of the worksheet you 
want to preview.

3 Click the File tab.

Preview the Printout

You can save time and paper by using the 
Print Preview feature to examine your 
printout on-screen before you send it to the 
printer. You can use Print Preview to make 
sure settings such as margins, page 
orientation, page breaks, print areas, and sheet 
titles all result in the printout you want.

If you see a problem in the preview, you can use the Print 
Preview screen to make adjustments to some printout options.

Preview the 
Printout
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Can I fine-tune the margins in Print Preview?
Yes. The Margins list only offers a few predefined margin sets. 
To define custom margins in Print Preview, follow these steps:

1 Click Show Margins ( ).

● Print Preview augments the preview with lines that indicate the 
margins.

2 Click and drag a line to adjust that margin.

7 When you are done, click a 
Ribbon tab to return to the 
workbook.

6 Click Print Preview Previous 
Page ( ) to return to a printout 
page.

● You can click the Portrait 
Orientation  to change the 
page orientation.

● You can click the Letter  to 
change the page size.

● You can click the Normal 
Margins  to change the 
margins.
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4 Click Print.

Note: You can also press + .

1 Open the workbook you want to 
print.

2 If you only want to print a single 
worksheet, click the tab of that 
worksheet.

Note: To print multiple worksheets, hold down 
 and click the top of each sheet you want to 

print.

3 Click the File tab.

Print a Workbook

When you need a hard copy of your document, 
either for your files or to distribute to someone 
else, you can send the document to your printer.

This section assumes that you have a printer connected to your 
computer and that the printer is turned on.

Print a 
Workbook
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Can I print just part of a worksheet?
Yes, you can tell Excel to print just a range. Begin 
by selecting the range or ranges you want to print. 
(See Chapter 3 to learn how to select a range.) 
Follow Steps 3 to 5 to open the Print Settings 
window and choose the number of copies. Click 
the Print What  and then click Print Selection. 
Click Print.

Is there a faster way to print?
Yes. If you only want to print a single copy of the 
selected worksheet, you can use Excel’s Quick Print 
command to send the worksheet directly to your 
default printer. Click  in the Quick Access Toolbar, 
and then click Quick Print to add this command 
to the toolbar. You can then click Quick Print ( ) 
to print the current worksheet without having to go 
through the Print Settings window.

 The Print Settings window 
appears.

5 Type the number of copies to 
print in the Copies text box.

● If you have more than one printer, 
click the Printer  and then click 
the printer that you want to use.

● By default, Print Active Sheets 
appears in the Print What list, 
which tells Excel to print only 
the selected sheets. If you want 
to print all the sheets in the 
workbook, click the Print What 

 and then click Print Entire 
workbook.

6 Click Print.

 Windows prints the document.

● The printer icon ( ) appears in 
the taskbar’s notification area 
while the document prints.
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Ch. 11 
Ch. 11 

Analyzing 
Excel Data

You can get more out of 
Excel by performing data 
analysis, which is the 
application of tools and 
techniques to organize, 
study, and reach conclusions 
about a specific collection of 
information.
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 The Sort dialog box appears.

4 Click the Sort by  and then 
click the field you want to use for 
the main sort level.

5 Click the Order  and then 
click a sort order for the field.

6 To sort on another field, click Add 
Level.

1 Click any cell in the range you 
want to sort.

2 Click the Data tab.

3 Click Sort ( ).

Sort a Range

You can make a range easier to read and easier 
to analyze by sorting the data based on the 
values in one or more columns.

You can sort the data in either ascending or descending order. An 
ascending sort arranges the values alphabetically from A to Z, or 
numerically from 0 to 9; a descending sort arranges the values 
alphabetically from Z to A, or numerically from 9 to 0.

Sort a 
Range

13_577646-ch11.indd   22013_577646-ch11.indd   220 3/8/10   7:00 PM3/8/10   7:00 PM



221

Analyzing Excel Data chapter11

8877

00

99

SORT DATASORT DATASORT DATA

How do I sort a range 
using the values in a row 
instead of a column?
Excel normally sorts a range 
from top to bottom based on 
the values in one or more 
columns. However, you can 
tell Excel to sort the range 
from left to right based on 
the values in one or more rows. Follow Steps 1 to 
3 to display the Sort dialog box. Click Options to 
display the Sort Options dialog box, select the Sort 
left to right option (  changes to ), and then 
click OK.

Is there a faster way 
to sort a range?
Yes, as long as you only 
need to sort your range 
on a single column. First, 
click in any cell inside 
the column you want to 
use for the sort. Click the 
Data tab and then click 
one of the following 
buttons in the Sort & Filter group:

Click for an ascending sort.

Click for a descending sort.

● Excel adds another sort level.

7 Click the Then by  and then 
click the field you want to use for 
the sort level.

8 Click the Order  and then 
click a sort order for the field.

9 Repeat Steps 6 to 8 to add more 
sort levels as needed.

0 Click OK.

● Excel sorts the range.
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● Excel adds  to each field.

4 Click  for the field you want to 
use as the filter.

1 Click inside the table.

2 Click the Data tab.

3 Click Filter ( ).

Filter a Range

You can analyze table data much faster by 
filtering the data so that you only view the table 
records that you want to work with. One way to 
do this is to use the AutoFilter feature, which 
presents you with a list of check boxes for each 
unique value in a field. You filter the data by 
activating the check boxes for the records you 
want to see.

Filter a 
Range
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Can I create more sophisticated filters?
Yes, by using a second technique called quick filters, which enables you to specify criteria for a field:

1 Follow Steps 1 to 4 to display the filter list for the field you want to use.

2 Click Number Filters.

Note: If the field is a date field, click Date Filters; if the field is a text field, click Text Filters.

3 Click the filter you want to use.

Note: Some quick filters do not require extra input, 
so you can skip the next two steps.

4 Enter the value you want to use.

5 Click OK.

 Excel filters the table.

● Excel filters the table to show only 
those records that have the field 
values you selected.

● Excel displays the number of 
records found.

● The field’s drop-down list displays 
a filter icon ( ).

7 To remove the filter, click Clear 
( ).

● Excel displays a list of the unique 
values in the field.

5 Click the check box for each value 
you want to see (  changes 
to ).

6 Click OK.
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 The Data Validation dialog box 
appears.

4 Click the Settings tab.

5 In the Allow list, click the type of 
data you want to allow in the cell.

6 Use the Data list to click the 
operator you want to use to 
define the allowable data.

7 Specify the validation criteria, such 
as the Maximum and Minimum 
allowable values shown here.

Note: The criteria boxes you see depend on the 
operator you chose in Step 6.

1 Click the cell you want to restrict.

2 Click the Data tab.

3 Click Data Validation ( ).

Set Data Validation Rules

You can make Excel data entry more efficient 
by setting up data entry cells to accept only 
certain values. To do this, you can set up a cell 
with data validation criteria that specify the 
allowed value or values.

Excel also lets you tell the user what to enter by defining an input 
message that appears when the user selects the cell.

Set Data 
Validation Rules
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How do I remove data 
validation from a cell?
If you no longer need to 
use data validation on a 
cell, you should clear the 
settings. Follow Steps 1 to 
3 to display the Data 
Validation dialog box and 
then click Clear All. Excel 
removes all the validation 
criteria, as well as the input message and the error 
alert. Click OK.

Can I configure the 
cell to display a 
message if the user 
tries to enter an 
invalid value?
Yes. Follow Steps 1 to 3 
to open the Data 
Validation dialog box, and 
then click the Error Alert 
tab. Make sure the Show 
error alert after invalid data is entered check box is 
clicked ( ), and then specify the Style, Title, and 
Error Message. Click OK.

8 Click the Input Message tab.

9 Make sure the Show input 
message when cell is selected 
check box is clicked ( ).

0 Type a message title in the Title 
text box.

! Type the message you want to 
display in the Input message 
text box.

@ Click OK.

 Excel configures the cell to accept 
only values that meet your 
criteria.

● When the user selects the cell, the 
input message appears.
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2 Click the Insert tab.

3 Click Table ( ).

Note: You can also choose the Table command by 
pressing + .

  1 Click a cell within the range that 
you want to convert to a table.

Convert a Range to a Table

You can apply Excel’s powerful table tools to any 
range by first converting that range to a table. In 
Excel, a table is a collection of related information 
with an organizational structure that makes it easy 
to add, edit, and sort data.

A table is a type of database where the data is organized into rows 
and columns: Each column represents a database field, and each row 
represents a database record.

Convert a Range 
to a Table
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How do I convert a table 
back into a range?
If you no longer require the table 
tools, you can convert the table 
back into a regular range. Select 
any cell within the table, click the 
Design tab, and then click 
Convert to Range ( ). When 
Excel asks you to confirm, click 
Yes. Excel removes the AutoFilter 
drop-down lists and hides the Table Tools 
contextual tab.

How do I add records 
to the table?
To add a record to the end 
of the table, click inside 
the table, press +  
and then +  to 
move to the last field in 
the last record, and then 
press . To add a record within the table, 
right-click the record above where you want to 
insert the new record, click Insert, and then click 
Table Rows Above.

 Excel converts the range to a 
table.

● Excel applies a table format to the 
range.

● The Table Tools contextual tab 
appears.

● AutoFilter drop-down lists appear 
in each field heading.

5 Click the Design tab to see Excel’s 
table design tools.

 The Create Table dialog box 
appears.

● Excel selects the range that it will 
convert to a table.

● If you want to change the range, 
click , drag the mouse  over 
the new range, and then click .

4 Click OK.
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2 Select the range that includes the 
input values and the formula.

3 Click the Data tab.

4 Click What-If Analysis ( ).

5 Click Data Table.

1 Type the input values:

 To enter the values in a column, 
start the column one cell down 
and one cell to the left of the cell 
containing the formula, as shown 
here.

 To enter the values in a row, start 
the row one cell up and one cell 
to the right of the cell containing 
the formula.

Create a Data Table

If you are interested in studying the effect a range 
of values has on the formula, you can set up a data 
table. This is a table that consists of the formula 
you are using, and multiple input values for that 
formula. Excel automatically creates a solution to 
the formula for each different input value.

Do not confuse data tables with the Excel tables that you learned 
about in “Convert a Range to a Table.” A data table is a special range 
that Excel uses to calculate multiple solutions to a formula.

Create a 
Data Table
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When I try to delete part 
of the data table, I get an 
error. Why?
The data table results are 
created as an array formula, 
which is a special formula 
that Excel treats as a unit. 
This means that you cannot 
move or delete part of the 
results. If you need to work with the data table 
results, you must first select the entire results 
range.

What is what-if analysis?
The technique called what-if 
analysis is perhaps the most 
basic method for analyzing 
worksheet data. With what-if 
analysis, you first calculate a 
formula D, based on the input 
from variables A, B, and C. 
You then say, “What happens 
to the result if I change the value of variable A?”, 
“What happens if I change B or C?”, and so on.

 The Data Table dialog box 
appears.

6 Specify the formula cell you want 
to use as the data table’s input 
cell:

 If the input values are in a 
column, enter the input cell’s 
address in the Column input 
cell text box.

 If you entered the input values 
in a row, enter the input cell’s 
address in the Row input cell 
text box.

7 Click OK.

● Excel displ ays the results.
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222 Click the Data tab.

3 Click Subtotal ( ).

1 Click a cell within the range you 
want to subtotal.

Summarize Data with Subtotals

Although you can use formulas and worksheet 
functions to summarize your data in various 
ways, including sums, averages, counts, 
maximums, and minimums, if you are in a hurry, 
or if you just need a quick summary of your data, 
you can get Excel to do most of the work for you. 
The secret here is a feature called automatic 
subtotals, which are formulas that Excel adds to a 
worksheet automatically.

Summarize Data 
with Subtotals
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SUM

Can I only calculate totals?
No. The word “subtotal” here 
is a bit misleading because 
you can summarize more 
than just totals. You can also 
count values, calculate the 
average of the values, 
determine the maximum or 
minimum value, and more. To 
change the summary calculation, follow Steps 1 to 
4, click the Use function , and then click the 
function you want to use for the summary.

Do I need to prepare my 
worksheet to use 
subtotals?
Excel sets up automatic 
subtotals based on data 
groupings in a selected field. 
For example, if you ask for 
subtotals based on the 
Customer field, Excel runs down 
the Customer column and creates a new subtotal 
each time the name changes. To get useful 
summaries, then, you need to sort the range on 
the field containing the data groupings you are 
interested in.

 The Subtotal dialog box appears.

4 Click the At each change in  
and then click the column you 
want to use to group the 
subtotals.

5 In the Add subtotal to list, click the 
check box for the column you 
want to summarize (  changes 
to ).

6 Click OK.

● Excel calculates the subtotals and 
adds them into the range.

● Excel adds outline symbols to the 
range.

Note: See “Group Related Data” to learn more 
about outlining in Excel.
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● Excel outlines the worksheet data.

● Excel uses level bars to indicate 
the grouped ranges.

● Excel displays level symbols to 
indicate the various levels of the 
detail that are available in the 
outline.

Create the Outline

1 Display the worksheet you want to 
outline.

2 Click the Data tab.

3 Click the Group .

4 Click Auto Outline.

Group Related Data

You can control a worksheet range display by 
grouping the data based on the worksheet 
formulas and data.

Grouping the data creates a worksheet outline, which you can 
use to “collapse” sections of the sheet to display only summary 
cells, or “expand” hidden sections to show the underlying detail.

Group Related 
Data
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GroupingChecklist
Formulas

ConsistentPattern

Do I have to prepare my worksheet before I can group the data?
Yes. Not all worksheets can be grouped, so you need to make sure your 
worksheet is a candidate for outlining. First, the worksheet must contain 
formulas that reference cells or ranges directly adjacent to the formula cell. 
Worksheets with SUM( ) functions that subtotal cells above or to the left are 
particularly good candidates for outlining.

Second, there must be a consistent pattern to the direction of the formula 
references. For example, a worksheet with formulas that always reference cells 
above or to the left can be outlined. Excel won’t outline a worksheet with, say, 
SUM( ) functions that reference ranges above and below a formula cell.

● Excel collapses the range.

2 Click the Expand symbol ( ) to 
view the range again.

● You can also show multiple 
ranges that are on the same 
outline level by clicking the 
appropriate level symbol.

Use the Outline to Control the 
Range Display

1 Click a Collapse symbol ( ) to 
hide the range indicated by the 
level bar.

● You can also collapse multiple 
ranges that are on the same 
outline level by clicking the 
appropriate level symbol.
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Month        Day                     Year               SavingsJan.         15                    08               $430
Feb.         01                     08                $485
May          15                      08                  $590
July          30                     08                  $670
Sept.         01                      08                   $815

Jan.         30                      09                   $1300April        30                     09                   $2500

Feb.         01                     09                   $1355

Month Daay
Year

At this rate, you will have a new car by . . .

11

22

33

44

2 Click the Data tab.

3 Click What-If Analysis ( ).

4 Click Goal Seek.

 The Goal Seek dialog box appears.

1 Set up your worksheet model.

Note: See the first Tip on the next page to learn 
more about setting up a worksheet for Goal Seek.

Analyze Data with Goal Seek

If you already know the formula result you 
want, but you must find an input value that 
produces that result, you can use Excel’s 
Goal Seek tool to solve the problem. You 
tell Goal Seek the final value you need and 
which variable to change, and it finds a 
solution for you.

For example, you might know that you want to have $50,000 saved 
to purchase new equipment five years from now, so you need to 
calculate how much to invest each year.

Analyze Data 
with Goal Seek

13_577646-ch11.indd   23413_577646-ch11.indd   234 3/8/10   7:00 PM3/8/10   7:00 PM



235

Analyzing Excel Data chapter11

99

66

55
77

88

00

!!

WorksheetSetup

Formula

Changing CellInput Values

FEBRUARY

PAYMENT JUNE
SALES

BREAK–
EVEN

POINT

What other types of 
problems can Goal Seek 
solve?
One common problem is called 
a break-even analysis, where 
you determine the number of 
units you have to sell of a 
product so that your total profits 
are 0. In this case, the changing 
cell is the number of units sold, and the formula is 
the profit calculation. You can also use Goal Seek 
to determine which price (the changing cell) is 
required to return a particular profit margin (the 
formula).

How do I set up my 
worksheet to use Goal 
Seek?
Setting up your worksheet 
model for Goal Seek means 
doing three things. First, set 
up one cell as the changing 
cell, which is the value that 
Goal Seek will manipulate to 
reach the goal. Enter an initial value (such as 0) 
into the cell. Second, set up the other input values 
for the formula and give them proper initial values. 
Third, create a formula for Goal Seek to use to 
reach the goal.

5 Click inside the Set cell box.

6 Click the cell that contains the 
formula you want Goal Seek to 
work with.

7 Use the To value text box to type 
the value that you want Goal Seek 
to find.

8 Click inside the By changing cell 
box.

9 Click the cell that you want Goal 
Seek to modify.

0 Click OK.

● Goal Seek adjusts the changing 
cell value until it reaches a 
solution.

● The formula now shows the value 
you entered in Step 7.

! Click OK.
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2 Click the Data tab.

3 Click What-If Analysis ( ).

4 Click Scenario Manager.

Create a Scenario

1 Set up your worksheet model.

Analyze Data with Scenarios

You can analyze the result of a formula by 
creating sets of values that plug multiple input 
values into the formula.

For example, one set of values might represent a best-case 
approach, while another might represent a worst-case approach. 
In Excel, each of these coherent sets of input values — known as 
changing cells — is called a scenario.

Analyze Data 
with Scenarios
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Scenar
io

Descrip
tions

Do I need to add a 
description to each scenario?
As you see on the next page, 
once you have one or more 
scenarios defined, they appear in 
the Scenario Manager, and for 
each scenario you see its 
changing cells and its description. 
The description is often very 
useful, particularly if you have several scenarios defined, 
so be sure to write a detailed description in Step 9 to 
help you differentiate your scenarios later on.

Are there any 
restrictions on the 
changing cells?
When you are building a 
worksheet model for use 
with scenarios, make 
sure that each changing 
cell is a constant value. If 
you use a formula for a 
changing cell, Excel replaces that formula with 
a constant value defined in the scenario, so 
you lose your formula.

 The Add Scenario dialog box 
appears.

6 Type a name for the scenario.

7 Click inside the Changing cells 
box.

8 Select the cells you want to 
change in the scenario.

9 Type a description for the 
scenario.

0 Click OK.

 The Scenario Manager dialog box 
appears.

5 Click Add.
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A             B           C            D            E            F           H            I            J
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25

Worksheet 1 2 3

Bob
Carol
Cindy

Rick 
Kevin
Dave
Jason

Lisa
Carry
Levi
Jimmy

Rene
Sandy
Jerome
Bill

Gary
Alex
Wanda
Pokey
Jake

Greg
Peter
Merv
Haywood
George

Calvin
Tommy
Ken

Kate
Ashley
Lorie
Kelly

Save ScenarioSave Scenario
cannedcorn.xls

Save Save As...

???

Home Insert Page Layout Formulas Data Review View Add-Ins

Clipboard Font Alignment

Paste

Number Cells

Alba Matter 11

B A AUI
A ab

+a+

General
$ % ,
.0

.00
.00
.0

Editing

A
Styles

Insert
A
ZDelete

SORT &
FILTER

FIND &
SELECT

Format

@@

!!

##

 The Scenario Values dialog box 
appears.

! Use the text boxes to specify a 
value for each changing cell.

● To add more scenarios, click Add 
and then repeat Steps 6 to 11.

@ Click OK.

# Click Close.

Analyze Data with Scenarios (continued)

Excel stores your scenarios in the Scenario 
Manager, and you can use that tool to apply 
your scenarios to the worksheet, and to make 
changes to your scenarios.

Analyze Data with 
Scenarios (continued)
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SCENARIO VALUES 

ScenarioScenario
ManagerManager
Scenario
Manager

How do I remove a scenario?
If you have a scenario that you 
no longer need, you should 
delete it to reduce clutter in the 
Scenario Manager. Click the Data 
tab, click , and then click 
Scenario Manager. Click the 
scenario you want to delete. 
Note that Excel does not ask you to 
confirm the deletion, so double-check that you have 
selected the correct scenario. Click Delete and then 
click Close.

How do I edit a scenario?
If you need to make changes 
to a scenario, you can edit 
the name, the changing cells, 
the description, and the 
scenario’s input values. Click 
the Data tab, click , and 
then click Scenario 
Manager. In the Scenario Manager dialog 
box, click the scenario you want to modify, 
and then click Edit.

 The Scenario Manager dialog box 
appears.

4 Click the scenario you want to display.

5 Click Show.

● Excel enters the scenario values into 
the changing cells and displays the 
formula result.

6 Repeat Steps 4 and 5 to display other 
scenarios.

7 Click Close.

Display Scenarios

1 Click the Data tab.

2 Click .

3 Click Scenario Manager.
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 The Create PivotTable dialog box 
appears.

4 Click New Worksheet 
(  changes to ).

● If you want to place the 
PivotTable in an existing location, 
click Existing Worksheet 
(  changes to ) and then use 
the Location range box to select 
the worksheet and cell where you 
want the PivotTable to appear.

5 Click OK.

1 Click a cell within the table that 
you want to use as the source 
data.

2 Click the Design tab.

3 Click Summarize with 
PivotTable ( ).

Create a PivotTable

You can more easily analyze a large amount of 
data by creating a PivotTable from that data. A 
PivotTable is a powerful data analysis tool because 
it automatically groups large amounts of data into 
smaller, more manageable categories, and it 
displays summary calculations for each group.

You can also manipulate the layout of — or pivot — the PivotTable 
to see different views of your data. For best results, convert your 
range to a table before creating the PivotTable (see “Convert a 
Range to a Table”).

Create a 
PivotTable
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Can I add multiple fields to each 
area?
Yes. You can add as many fields as 
you like to each area. You can also 
move a PivotTable’s fields from one 
area of the PivotTable to another. 
This enables you to view your data 
from different perspectives, which 
can greatly enhance the analysis of the data. Moving a 
field within a PivotTable is called pivoting the data. To 
move a field, use the PivotTable Field List to click and 
drag a field from one area and drop it on another.

Are there faster ways to 
build a PivotTable?
Yes. In the PivotTable Field 
List, if you click a check 
box for a text or date field 
(  changes to ), Excel 
adds the field to the Row 
Labels area; if you click a check box for a 
numeric field (  changes to ), Excel adds 
the field to the Values area. You can also 
right-click a field and then click the area you 
want to use.

● Excel adds the field’s unique values 
to the PivotTable’s row area.

7 Click and drag a numeric field and 
drop it inside the Values area.

● Excel sums the numeric values 
based on the row values.

8 If desired, click and drag fields and 
drop them in the Column Labels 
area and the Report Filter area.

 Each time you drop a field in an 
area, Excel updates the PivotTable to 
include the new data.

● Excel creates a blank PivotTable.

● Excel displays the PivotTable Field 
List.

6 Click and drag a field and drop it 
inside the Row Labels area.
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 •Random number generation
 •Sampling

 •Regression analysis
 •and more . . .

Featuring: 
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 The Excel Options dialog box 
appears.

3 Click Add-Ins.

4 In the Manage list, click Excel 
Add-ins.

5 Click Go.

1 Click the File tab.

2 Click Options.

Load Excel’s Analysis ToolPak

You can get access to a number of powerful 
statistical analysis tools by loading the Analysis 
ToolPak add-in. The Analysis ToolPak consists 
of 19 statistical tools that calculate statistical 
measures such as correlation, regression, and 
moving averages.

You can also use the analysis tools to generate descriptive statistics 
(such as median, mode, and standard deviation), random numbers, 
and histograms.

Load Excel’s 
Analysis ToolPak

13_577646-ch11.indd   24213_577646-ch11.indd   242 3/8/10   7:01 PM3/8/10   7:01 PM



243

Analyzing Excel Data chapter11
66

88
99

77

33

44

How do I use the statistical tools?
The specific steps you follow vary from tool to tool, but you can follow these general steps to use any of 
the Analysis ToolPak’s statistical tools:

1 Click the Data tab.

2 Click .

 The Data Analysis dialog box appears.

3 Click the tool you want to use.

4 Click OK.

 Excel displays a dialog box for the tool.

5 Fill in the dialog box (the controls vary from tool to tool).

6 Click OK.

 Excel loads the Analysis ToolPak 
add-in.

8 Click the Data tab.

9 Click Data Analysis ( ) to 
access the Analysis ToolPak tools.

 The Add-Ins dialog box appears.

6 Click the Analysis ToolPak check 
box (  changes to ).

7 Click OK.
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Visualizing Data 
with Excel Charts

You can take a worksheet 
that is full of numbers and 
display them as a chart. 
Visualizing your data in this 
way makes the data easier 
to understand and easier to 
analyze. To help you see 
your data exactly the way 
you want, Excel offers a 
wide variety of chart types 
and a large number of chart 
options.
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Data Marker
A symbol that represents a 
specific data value. The 
symbol used depends on 
the chart type.

Chart Title
The title of the chart.

Category Axis
The axis (usually the 
X axis) that contains 
the category groupings.

A chart is a graphic representation of spreadsheet data. As the data in the spreadsheet changes, 
the chart also changes to reflect the new numbers. To get the most out of charts, you need to 
familiarize yourself with the basic chart elements.

Examining Chart 
Elements

Data Value
A single piece of data. 
Also called a data point.

Gridlines
Optional horizontal 
and vertical extensions 
of the axis tick marks. 
These make data values 
easier to read.

Plot Area
The area bounded by the category 
and value axes. It contains the data 
points and gridlines.

Value Axis
The axis (usually the Y axis) 
that contains the data values.

Data Series
A collection of related 
data values. Normally, 
the marker for each 
value in a series has the 
same pattern.

Legend
A guide that shows the 
colors, patterns, and 
symbols used by the 
markers for each data 
series.
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Chart Type Description

Area A chart that shows the relative contributions over time that each data series makes to the whole 
picture.

Bar A chart that compares distinct items or shows single items at distinct intervals. A bar chart is laid 
out with categories along the vertical axis and values along the horizontal axis.

Bubble A chart that is similar to an XY chart, except that there are three data series, and in the third series 
the individual plot points are displayed as bubbles (the larger the value, the larger the bubble).

Column A chart that, like a bar chart, compares distinct items or shows single items at distinct intervals. 
However, a column chart is laid out with categories along the horizontal axis and values along the 
vertical axis.

Doughnut A chart that, like a pie chart, shows the proportion of the whole that is contributed by each value 
in a data series. The advantage of a doughnut chart is that you can plot multiple data series.

Line A chart that shows how a data series changes over time. The category (X) axis usually represents 
a progression of even increments (such as days or months), and the series points are plotted on 
the value (Y) axis.

Pie A chart that shows the proportion of the whole that is contributed by each value in a single data 
series. The whole is represented as a circle (the “pie”), and each value is displayed as a 
proportional “slice” of the circle.

Radar A chart that makes comparisons within a data series and between data series relative to a center 
point. Each category is shown with a value axis extending from the center point.

Stock A chart that is designed to plot stock market prices, such as a stock’s daily high, low, and closing 
values.

Surface A chart that analyzes two sets of data and determines the optimum combination of the two.

XY A chart that shows the relationship between numeric values in two different data series. It can 
also plot a series of data pairs in XY coordinates. (Also called a scatter chart.)

Excel offers 11 different types of charts, including 
column charts, bar charts, line charts, and pie charts. 
The chart type you use depends on the type of data 
and how you want to present that data visually.

Understanding 
Chart Types

PIESPIES
PIESPIES BARSBARSBARS

PIEPIEPIE BARBARBAR

PIEPIEPIE

LineLineLine
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2 Click the Insert tab.

3 Click a chart type.

1 Select the data that you want to 
visualize in a chart.

● If your data includes headings, be 
sure to include those headings in 
the selection.

Create a Chart

You can create a chart from your Excel 
worksheet data with just a few mouse clicks. 
Excel offers more than 70 default chart 
configurations, so there should always be 
a type that best visualizes your data.

Regardless of the chart type you choose originally, you can 
change to a different chart type at any time. See “Select a 
Different Chart Type.”

Create a 
Chart
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Is there a way to create a chart on a separate 
sheet?
Yes. You can use a special workbook sheet called a 
chart sheet. If you have not yet created your chart, 
select the worksheet data, right-click any worksheet tab, 
and then click Insert to display the Insert dialog box. 
Click the General tab, click Chart, and then click OK. 
Excel creates a new chart sheet and inserts the chart.

If you have already created your chart, you can move it 
to a separate chart sheet. See the tip in “Move or Resize 
a Chart.”

● Excel inserts the chart.

 The tasks in the rest of this 
chapter show you how to 
configure, format, and move 
the chart.

● Excel displays a gallery of 
configurations for the chart type.

4 Click the chart configuration you 
want to use.
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Add Chart 
Titles

You can make your chart easier to understand by 
adding chart titles. You can add an overall chart 
title, which appears at the top of the chart, and you 
can add titles to the horizontal and vertical axes.
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221 Click the chart.

2 Click the Layout tab.

3 Click Chart Title ( ).

4 Click Above Chart.

● Excel adds the title.

5 Type the title.

6 Click Axis Titles ( ).

7 Click Primary Horizontal Axis 
Title.

8 Click Title Below Axis.

● Excel adds the title.

9 Type the title.

0 Click .

! Click Primary Vertical Axis 
Title.

@ Click Rotated Title (not shown).

● Excel adds the title.

# Type the title.

Add Chart Titles
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Add Data 
Labels

You can make your chart easier to read by adding data 
labels. A data label is a small text box that appears in or 
near a data marker and displays the value of that data 
point.

Excel offers several position options for the data labels, and these options 
depend on the chart type. For example, with a column chart you can place the 
data labels within or above each column, and for a line chart you can place 
the labels to the left or right, or above or below, the data marker.

33

22

44

11

1 Click the chart.

2 Click the Layout tab.

3 Click Data Labels ( ).

4 Click the position you want to use 
for the data labels.

Note: Remember that the position options you see 
depend on the chart type.

● Excel adds the labels to the chart.

Add Data Labels

Visualizing Data with Excel Charts chapter12
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● Excel moves the legend.

1 Click the chart.

2 Click the Layout tab.

3 Click Legend ( ).

4 Click the position you want to use 
for the legend.

Position the Chart Legend

You can change the position of the chart legend, which 
identifi es the colors associated with each data series 
in the chart. For example, you might find the legend 
easier to read if it appears to the left of the chart. 
Alternatively, if you want more horizontal room to 
display your chart, you can move the legend above or 
below the chart.

Position the 
Chart Legend
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Display Chart 
Gridlines

You can make your chart easier to read and easier to analyze 
by adding gridlines. Horizontal gridlines extend from the 
vertical (value) axis and are useful with area, bubble, and 
column charts. Vertical gridlines extend from the horizontal 
(category) axis and are useful with bar and line charts.

Major gridlines are gridlines associated with the major units: the values you see 
displayed on the vertical and horizontal axes; minor gridlines are gridlines 
associated with the minor units: values between each major unit.
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1 Click the chart.

2 Click the Layout tab.

3 Click Gridlines ( ).

4 Click Primary Horizontal 
Gridlines.

5 Click the horizontal gridline option 
you prefer.

● Excel displays the horizontal 
gridlines.

6 Click .

7 Click Primary Vertical 
Gridlines.

8 Click the vertical gridline option 
you prefer.

● Excel displays the vertical 
gridlines.

Display Chart Gridlines

Visualizing Data with Excel Charts chapter12
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Display a 
Data Table

You can make it easier for yourself and others to 
interpret your chart by adding a data table. A data 
table is a tabular grid where each row is a data series 
from the chart, each column is a chart category, and 
each cell is a chart data point.

Excel gives you the option of displaying the data table with or without 
legend keys, which are markers that identify each series.
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1 Click the chart.

2 Click the Layout tab.

3 Click Data Table ( ).

4 Click Show Data Table with 
Legend Keys.

● If you prefer not to display the 
legend keys, click Show Data 
Table.

● Excel adds the data table below 
the chart.

Display a Data Table

14_577646-ch12.indd   25414_577646-ch12.indd   254 3/8/10   6:55 PM3/8/10   6:55 PM



255

Change the Chart 
Layout and Style

You can quickly format your chart by applying a 
different chart layout and a different chart style. The 
chart layout includes elements such as the titles, data 
labels, legend, gridlines, and data table. Excel’s Quick 
Layouts feature enables you to apply these elements in 
different combinations with just a few mouse clicks.

The chart style represents the colors used by the chart data markers and 
background. LayoutsLayoutsQuickQuick

LayoutsLayoutsQuickQuick
StylesStyles

Sales Chart
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1 Click the chart.

2 Click the Design tab.

3 Click Quick Layout ( ).

4 Click the layout you want to use.

 Excel applies the layout.

5 Click the Chart Styles .

6 Click the chart style you want to 
use.

● Excel applies the style to the chart.

Change the Chart Layout and Style

Visualizing Data with Excel Charts chapter12
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 The Change Chart Type dialog box 
appears.

4 Click the chart type you want to 
use.

1 Click the chart.

2 Click the Design tab.

3 Click Change Chart Type ( ).

Select a Different Chart Type

If you feel that the current chart type is not 
showing your data in the best way, you can change 
the chart type with just a few mouse clicks. For 
example, you might want to change a bar chart to 
a pie chart or a line chart to a stock chart.

Select a Different 
Chart Type
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CUSTOMIZE 

CUSTOMIZE 

Can I save the chart type and 
formatting so that I can reuse 
it later on a different chart?
Yes. You do this by saving your 
work as a chart template. Follow 
the steps in this section and in 
the previous few sections of this 
chapter to set the chart type, 
titles, labels, legend position, 
gridlines, layout, and style. Click the Design tab, click 
Save as Template ( ), type a name for the template, 
and then click Save. To reuse the template, follow Steps 
1 to 3, click Templates, click your template, and then 
click OK.

Can I tell Excel to 
always use a particular 
chart type each time I 
create a new chart?
Yes, you can configure that 
chart type as the default 
type for new charts. Follow 
Steps 1 to 5 to open the 
Change Chart Type dialog 
box and select a chart type and 
configuration. Click the Set as Default 
Chart button, and then click OK.

● Excel applies the new chart type.

 Excel displays the chart type 
configurations.

5 Click the configuration you want 
to use.

6 Click OK.
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● Excel selects the chart’s source 
data.

2 Move the mouse  over the 
lower right corner of the range.

  changes to .

1 Click the chart to select it.

Change the Chart Source Data

You can keep your chart up to date and accurate by 
adjusting the chart when its source data changes. 
For example, if the source range adds a row or 
column, you can adjust the chart to include the new 
data.

Change the Chart 
Source Data
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Chart TitleIs there a way to remove 
a series from a chart 
without deleting the data 
from the source range?
Yes. You can use Excel’s 
Select Data Source dialog 
box to remove individual 
series. Click the chart to 
select it, and then click the 
Design tab. Click Select Data ( ) to open the 
Select Data Source. In the Legend Entries (Series) 
list, click the series you want to get rid of, and then 
click Remove. Click OK.

Is there a way to swap 
the chart series with the 
chart categories without 
modifying the source 
data?
Yes. Excel has a feature that 
enables you to switch the 
row and column data, which 
swaps the series and 
categories without affecting the source data. First 
click the chart to select it, and then click the 
Design tab. Click Switch Row/Column ( ). Excel 
swaps the series and categories. Click  again to 
return to the original layout.

4 Release the mouse button.

● Excel redraws the chart to include 
the new data.

3 Click and drag  until the 
selection includes all the data you 
want to include in the chart.

● Excel displays a blue outline to 
show you the new selection.
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11Move a Chart

1 Click the chart.

● Excel displays a border around the 
chart.

2 Move  over the chart border.

  changes to .

Note: Do not position the mouse pointer over a 
corner or over the middle of any side of the 
border.

3 Click and drag the chart border to 
the location you want.

● Excel displays a gray outline of the 
new chart position.

4 Release the mouse button.

● Excel moves the chart.

Move or Resize a Chart

You can move a chart to another part of the 
worksheet. This is useful if the chart is blocking 
the worksheet data or if you want the chart to 
appear in a particular part of the worksheet.

You can also resize a chart. For example, if you find that the chart is 
difficult to read, making the chart bigger often solves the problem. 
Similarly, if the chart takes up too much room on the worksheet, you 
can make it smaller.

Move or 
Resize a Chart
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How do I delete a chart?
How you delete a chart 
depends on whether your chart 
exists as an object in a 
worksheet or in its own sheet. 
If the chart is in a worksheet, 
click the chart and then press 
Delete . If the chart exists on a 

separate sheet, right-click the 
sheet tab, click Delete Sheet, and then 
click Delete.

Can I move a chart to a 
separate sheet?
Yes. In “Create a Chart” you 
learned how to create a new 
chart in a separate sheet. If 
your chart already exists in a 
worksheet, you can move it to 
a new sheet. Click the chart, 
click the Design tab, and then click Move Chart to 
open the Move Chart dialog box. Select the New 
sheet option (  changes to ). In the New 
sheet text box, type a name for the new sheet, 
and then click OK.

Resize a Chart

1 Click the chart.

● Excel displays a border around the 
chart.

● The border includes sizing handles 
on the corners and sides.

2 Move  over a sizing handle.

  changes to  (left or right);  
(top or bottom); or  (corner).

3 Click and drag the handle.

● Excel displays a gray outline of the 
new chart size.

4 Release the mouse button.

● Excel resizes the chart.
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2 Click the Insert tab.

3 Click the type of sparkline you 
want to create.

1 Select the row or column of data 
you want to visualize.

Add a Sparkline to a Cell

If you want a quick visualization of your data 
without having a chart take up a large amount of 
worksheet space, you can add a sparkline to a single 
cell. A sparkline is a small chart that visualizes a row 
or column of data and fits inside a single cell.

Excel offers three types of sparklines: Line (similar to a line chart), 
Column (similar to a column chart), and Win/Loss (for data that 
includes positive and negative values).

Add a Sparkline 
to a Cell
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Can I add a sparkline to multiple rows or columns at once?
Yes. To do this, first select the rows or columns of data that you want to 
visualize. Follow Steps 2 to 4 to open the Create Sparklines dialog box and 
place the cursor inside the Location Range box. Select a single cell for each 
row or column that you have selected. For example, if you have selected 
five rows, select five cells. Click OK. Excel adds a sparkline for each selected 
row or column.

 The Create Sparklines dialog box 
appears.

4 Click inside the Location Range 
box.

5 Click the cell where you want the 
sparkline to appear.

6 Click OK.

● Excel adds the sparkline to the 
cell.

● Excel displays the Sparkline Tools 
tab.

● Use the tools in the Design tab to 
format your sparkline.
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chapter 

Formatting 
Excel Charts

You use Excel charts to 
visualize worksheet data, 
and you can make these 
visualizations more 
eye-catching and more 
effective by formatting chart 
elements. In this chapter, 
you learn how to customize 
chart elements by formatting 
backgrounds, outlines, and 
effects, and by applying 
styles.
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 The Format dialog box appears for 
the object you selected. Here, it 
is the Format Chart Title dialog 
box.

4 Click a tab.

5 Change the formatting options.

6 Repeat Steps 4 and 5 to set other 
formatting options.

7 Click Close.

 Excel applies the formatting.

Format Chart Elements Using the 
Format Dialog Box

1 Click the chart element you want 
to format.

2 Click the Format tab.

● You can also select a chart 
element by clicking the Chart 
Title  and then clicking the 
object.

3 Click Format Selection ( ).

Format Chart Elements

You can customize the look of your chart by 
formatting the various chart elements. These 
elements include the axes, titles, labels, legend, 
gridlines, data series, plot area (the area where the 
chart data appears), and the chart area (the overall 
background of the chart).

You can format chart elements using either the Format dialog box or 
the Ribbon. The rest of the sections in this chapter provide you with 
more detail on using the Ribbon commands.

Format Chart 
Elements
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Chart TitleHow do I know where to click 
to select a chart element?
The easiest way to be sure you 
are clicking the correct element is 
to position  over the object. If  
is positioned correctly, a banner 
appears and the banner text 
displays the name of the chart element. If the 
banner does not appear, or if the banner displays 
a chart element name other than the one you 
want to format, move  until the correct banner 
appears.

Are there any formatting 
shortcuts I can use?
Yes. Excel offers several methods 
you can use to quickly open the 
Format dialog box. If you are 
using your mouse, position  
over the element you want to 
format, and then double-click. From the keyboard, 
first click the chart element you want to format 
and then press + . You can also right-click 
the chart element and then click Format Element 
(where Element is the name of the element).

2 Click the Format tab.

3 Use the Ribbon controls to change 
the formatting options.

Note: Not all of the Ribbon controls will be 
available for each chart element.

 Excel applies the formatting.

Format Chart Elements Using the 
Ribbon

1 Click the chart element you want 
to format.
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● Excel formats the element’s 
background with the color you 
selected.

Apply a Color Fill

1 Click the chart element you want 
to format.

2 Click the Format tab.

3 Click the Shape Fill .

4 Click the color you want to apply.

Customize a Chart Element Background

You can add visual interest to a chart element by 
customizing the element’s background, or what 
Excel calls the fill.

Most fills consist of a single color, but you can also apply a color 
gradient, a texture, or even a picture.

Customize a Chart 
Element Background
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How do I use a picture as an element’s background?
Follow these steps:

1 Follow Steps 1 to 3 to select the element and display the Shape Fill 
gallery.

2 Click Picture.

3 Click the folder that contains the image file.

4 Click the image file you want to use as the background.

5 Click Insert.

Apply a Texture Fill

1 Click the chart element you want 
to format.

2 Click the Format tab.

3 Click the Shape Fill .

4 Click Texture.

5 Click the texture you want to 
apply.

● Excel formats the element’s 
background with the texture you 
selected.

Apply a Gradient Fill

1 Click the chart element you want 
to format.

2 Click the Format tab.

3 Click the Shape Fill .

4 Click Gradient.

5 Click the gradient you want to 
apply.

● Excel formats the element’s 
background with the gradient you 
selected.
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5 Click the Shape Outline .

6 Click Weight.

7 Click the line thickness you want 
to apply.

1 Click the chart element you want 
to format.

2 Click the Format tab.

3 Click the Shape Outline .

4 Click the color you want to apply.

Set a Chart Element’s Outline

You can make a chart element stand out by 
customizing the element’s outline, which 
refers to the border that appears around the 
element, as well as to single-line elements, 
such as gridlines and axes.

You can customize the outline’s color, its weight — that is, its 
thickness — and whether the line is solid or consists of a series 
of dots or dashes.

Set a Chart 
Element’s Outline
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Can I display my chart with a rounded outline?
Yes. Follow these steps:

1 Click the chart border to select the chart area element.

2 Click the Format tab.

3 Click Format Selection ( ).

 Excel displays the Format Chart Area dialog box.

4 Click the Border Styles tab.

5 Click Rounded corners (  changes to ).

6 Click Close.

● Excel formats the element’s 
outline with the color, weight, and 
style you selected.

8 Click the Shape Outline .

9 Click Dashes.

0 Click the line style you want to 
apply.
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Add a Glow Effect

1 Click the chart element you want 
to format.

2 Click the Format tab.

3 Click the Shape Effects .

4 Click Glow.

5 Click the glow effect you want to 
apply.

● Excel formats the element with the 
glow you selected.

Add a Shadow Effect

1 Click the chart element you want 
to format.

2 Click the Format tab.

3 Click the Shape Effects .

4 Click Shadow.

5 Click the shadow effect you want 
to apply.

● Excel formats the element with the 
shadow you selected.

Add Effects to a Chart Element

You can make your chart elements more 
visually striking by customizing them with 
special effects.

For most chart elements, you can add one or more effects, 
including a shadow, glow, soft edges, or bevel.

Add Effects to 
a Chart Element
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ShortcutIs there an easier way to apply 
multiple special effects to a 
chart element?
Yes. Excel comes with several 
preset combinations of special 
effects, each of which includes two 
or more effects, such as a shadow 
and a bevel. To apply preset effects, click the chart 
element you want to format, click the Format tab, 
click the Shape Effects , click Preset, and then 
click the preset effect you want to use.

The shadow I selected is not 
very noticeable. How can I get 
a better shadow effect?
Excel offers several controls that 
enable you to manually adjust 
various aspects of the shadow. 
Follow Steps 1 to 4 in “Add a Shadow Effect” and 
then click Shadow Options. Either use the Size 
spin box to increase the size of the shadow, or use 
the Distance spin box to increase the space 
between the chart element and the shadow. Click 
Close when you are done.

Add a Bevel Effect

1 Click the chart element you want 
to format.

2 Click the Format tab.

3 Click the Shape Effects .

4 Click Bevel.

5 Click the bevel effect you want to 
apply.

● Excel formats the element with the 
bevel you selected.

Add a Soft Edges Effect

1 Click the chart element you want 
to format.

2 Click the Format tab. 

3 Click the Shape Effects .

4 Click Soft Edges.

5 Click the soft edges effect you 
want to apply.

● Excel formats the element with the 
soft edges you selected.
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2 Click the Format tab.

3 Click the Shape Styles .

1 Click the chart element you want 
to format.

Apply a Style to a Chart Element

You can reduce the time it takes to format 
a chart element by applying a style to that 
element. Excel comes with more than 40 
predefined element styles, each of which is 
a collection of chart-formatting features, 
including a background, outline, and special 
effects.

Apply a Style to 
a Chart Element
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Style 1Style 1Style 1How do I remove a style from a chart element?
Unfortunately, Excel does not offer a simple method for removing a 
style. Instead, you must remove the background, outline, and effects 
individually. To begin, click the chart element you want to work with, 
and then click the Format tab.

For the background, click the Shape Fill  and then click No Fill. For 
the outline, click the Shape Outline  and then click No Outline. For 
the special effects, click the Shape Effects , click Preset, and then 
click No Presets.

● Excel applies the style.

 Excel displays the Shape Styles 
gallery.

4 Click the style you want to apply.
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2 Click the Format tab.

3 Click the WordArt Quick 
Styles .

1 Click the chart element you want 
to format.

Apply a WordArt Style to Chart Text

You can add visual interest to your chart text by 
formatting the text with a WordArt style. You 
can apply a WordArt style to the chart title, axis 
titles, axis text, legend text, and data labels.

Each WordArt style is a combination of text color, text outline, and 
one or more text effects.

Apply a WordArt Style 
to Chart Text
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Can I customize the WordArt formatting?
Yes. First follow Steps 1 to 4 to apply a WordArt style to the chart element. 
With the chart element still selected, you can use the following three lists 
in the Format tab’s WordArt Styles section:

Text Fill ( )  Click  and then click a color. You can also apply a 
gradient, texture, or picture.

Text Outline ( )  Click  and then click an outline color, weight, and 
style.

Text Effects ( )  Click  and then apply one or more effects using 
the Shadow, Reflection, and Glow galleries.

● Excel applies the WordArt style to 
the text.

 Excel displays the WordArt Quick 
Styles gallery.

4 Click the WordArt style you want 
to use.
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Adding and Editing 
Worksheet Graphics

You can enhance the visual 
appeal and effectiveness 
of your Excel worksheets 
by incorporating graphic 
objects such as shapes, clip 
art, pictures, or WordArt 
and SmartArt images. This 
chapter shows you how 
to insert, format, and edit 
graphics.
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4 Click the shape you want to draw.

  changes to .

1 Display the worksheet on which 
you want to draw the shape.

2 Click the Insert tab.

3 Click Shapes ( ).

Draw a Shape

Excel’s Shapes gallery comes with more than 150 
predefined objects called shapes (or sometimes 
AutoShapes) that enable you to quickly and easily 
draw anything from simple geometric figures such 
as lines, rectangles, and ovals, to more elaborate 
items such as starbursts, flowchart symbols, and 
callout boxes.

Draw a 
Shape
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Can I add text to a 
shape?
Yes. You can add text to the 
interior of any 2-D shape 
(that is, any shape that is 
not a line). After you draw 
the shape, right-click the 
shape, click Edit Text, and 
then type your text inside 
the shape. You can use the 
Home tab’s Font controls to 
format the text. When you finish, click outside of 
the shape.

Is there an easy way to 
draw a perfect circle or 
square?
Yes, Excel offers an easy 
technique for drawing 
circles and squares. Hold 
down the  key as 
you click and drag the 
shape to constrain the 
shape into a perfect circle or square. When you 
finish drawing the shape, release .

● The program draws the shape and 
adds edit handles around the 
shape’s edges.

Note: If you need to move or size the shape, see 
“Move or Resize a Graphic” later in this chapter.

5 Click and drag the mouse  to 
draw the shape.

6 When the shape is the size you 
want, release the mouse button.

16_577646-ch14.indd   28116_577646-ch14.indd   281 3/8/10   6:57 PM3/8/10   6:57 PM



282

Home         Insert       Page Layout  References Mailings

New Docum
Shapes

Tables
Table

Illustrations

Picture  Clip Art  Char
A

Cover Page
 Blank Page

  Page BreakPages

33

11

44

22

55

● Excel displays the Clip Art pane.

4 Use the Search for text box to type 
a word that describes the type of 
clip art image you want to insert.

5 Click Go.

1 Display the worksheet on which 
you want to insert the clip art 
image.

2 Click the Insert tab.

3 Click Clip Art ( ).

Insert a Clip Art Image

You can improve the look of an Excel worksheet 
by adding a clip art image to the sheet.

Clip art refers to small images or artwork that you can insert into 
your documents. Excel 2010 ships with more than 300 clip art 
images that you can use without charge.

Insert a Clip 
Art Image
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Is there an easier way to locate the clip art image that I want?
Yes. You can filter the clip art list to show only those images from a 
particular category, such as Animals or People. Follow these steps:

1 Click the Insert tab.

2 Click .

3 Click the Search in .

4 Click the Everywhere check box (  changes to ).

5 Click the Office Collections .

6 Click the check box beside the category you want to view (  changes to ).

7 Click Go.

 The Clip Art pane displays only the clip art images from the category you chose.

● Excel inserts the clip art.

Not e: If you need to move or size the clip art, see 
“Move or Resize a Graphic” later in this chapter.

● Excel displays a list of clip art 
images that match your search 
term.

6 Click and drag the clip art 
image from the Object Palette 
(  changes to ) and drop it 
inside the document at the spot 
where you want the image to 
appear.
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3 Click the Insert tab.

4 Click Picture ( ).

1 Open the worksheet where you 
want to insert the photo.

2 Click the cell where you want the 
upper left corner of the photo to 
appear.

Insert a Photo

You can enhance the visual appeal and 
strengthen the message of an Excel 
worksheet by adding a photo to the file.

Excel can work with the most popular picture formats, 
including BMP, JPEG, TIFF, PNG, and GIF.

Insert a 
Photo
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Is there a way to reduce 
the size of a workbook 
that has lots of photos?
Yes, you can use the 
Compress Pictures feature to 
convert the photos to a 
smaller resolution and so 
reduce the size of the 
workbook. Click any image in 
the workbook, click the Format tab, and then click 
Compress Pictures ( ). Click Apply only to this 
picture (  changes to ), click a Target output 
(  changes to ), and then click OK.

My photo has a 
distracting background. 
Can I remove it?
Yes. Excel 2010 comes with a 
new Background Removal 
feature that can eliminate the 
background in most photos. 
Click the photo, click the 
Format tab, and then click 
Background Removal ( ). If part of the 
foreground is in the removal color, click Mark 
Areas to Keep and then click and drag a line 
through the part you want to retain. When you are 
finished, click Keep Changes.

● Excel inserts the photo into the 
worksheet.

Note: If you need to move or size the photo, see 
“Move or Resize a Graphic” later in this chapter.

 The Insert Picture dialog box 
appears.

5 Open the folder that contains the 
photo you want to insert.

6 Click the photo.

7 Click Insert.
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2 Click the Insert tab.

3 Click WordArt ( ).

 The WordArt gallery appears.

4 Click the WordArt style you want 
to use.

1 Open the worksheet in which you 
want to insert the WordArt image.

Insert a WordArt Image

You can add some pizzazz to your Excel 
workbooks by inserting a WordArt image. 
A WordArt image is a graphic object that 
contains text stylized with shadows, outlines, 
reflections, and other predefined effects.

WordArt images enable you to apply sophisticated and fun 
effects to text with just a few mouse clicks.

Insert a 
WordArt Image
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Can I make my WordArt 
text run vertically?
Yes. Click the WordArt image 
to select it. Click the Format 
tab, and then click the dialog 
box launcher ( ) in the 
WordArt Styles group. In the 
Format Text Effects dialog 
box, click the Text Box tab. 
Click the Text direction  and then click 
Stacked. Click Close. Excel displays the WordArt 
text vertically.

Can I change the default 
WordArt formatting?
Yes. Click the WordArt image 
to select it, and then use the 
Home tab’s Font controls to 
adjust the WordArt text font. 
Click the Format tab. In the 
WordArt Styles group, use the 
Text Fill ( ), Text Outline ( ), 
and Text Effects ( ) galleries to format the 
WordArt image. You can also use the Quick Styles 
gallery to select a different WordArt style.

6 Click outside the image to set it.

Note: You will likely have to move the WordArt 
image into position; see “Move or Resize a 
Graphic” later in this chapter.

● The WordArt image appears in the 
worksheet.

5 Type the text that you want to 
appear in the WordArt image.
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 The Choose a SmartArt Graphic 
dialog box appears.

4 Click a SmartArt category.

5 Click the SmartArt style you want 
to use.

6 Click OK.

1 Open the worksheet in which you 
want to insert the SmartArt image.

2 Click the Insert tab.

3 Click SmartArt ( ).

Insert a SmartArt Graphic

You can add a SmartArt graphic to a workbook 
to help present information in a compact, visual 
format. A SmartArt graphic is a collection of 
nodes — shapes with some text inside — that 
enables you to convey information visually.

For example, you can use a SmartArt graphic to present a 
company organization chart, the progression of steps in a 
workflow, the parts that make up a whole, and much more.

Insert a 
SmartArt Graphic
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Can I use shapes other than 
the ones supplied in the 
default SmartArt graphics?
Yes. Click the node you want to 
change. Click the Format tab, and 
then click the Change Shape  
to display the Shapes gallery. 
Click the shape you want to use. 
Excel updates the SmartArt 
graphic node with the new shape.

How do I add a node to my 
SmartArt graphic?
To add a node to the SmartArt 
graphic, first decide where you 
want that node to appear in the 
current image. That is, decide 
which existing node you want 
the new node to come before or 
after. Click the existing node, click the Design tab, 
click the Add Shape , and then click Add Shape 
After. (If you want the new node to appear before 
the existing node, click Add Shape Before.)

9 Repeat Steps 7 and 8 to fill in the 
other nodes in the SmartArt 
graphic.

● You can click Text Pane ( ) to 
hide the Text pane.

Note: You will likely have to move the SmartArt 
graphic into position; see “Move or Resize a 
Graphic” later in this chapter.

● The SmartArt graphic appears in 
the document.

● You use the Text pane to type the 
text for each node and to add and 
delete nodes.

7 Click a node in the Text pane.

8 Type the text that you want to 
appear in the node.

● The text appears automatically in 
the associated shape.
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● Excel moves the graphic to the 
new location.

Move a Graphic

1 Click and drag the graphic you 
want to move.

 The mouse  changes to .

2 Drop the graphic in the location 
you prefer.

● As you drag the graphic, Excel 
displays the graphic’s outline to 
show you the current position.

Move or Resize a Graphic

To ensure that a graphic is ideally placed within 
an Excel worksheet, you can move the graphic 
to a new location, or you can resize the graphic 
in its current location. You can move or resize 
any graphic, including shapes, clip art, pictures, 
WordArt images, and SmartArt graphics.

Move or 
Resize a Graphic
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Is it possible to resize a 
graphic in all directions 
at once to keep the 
proportions the same?
Yes. You normally resize one 
side at a time by dragging a 
side handle, or two sides at a 
time by dragging a corner 
handle. To resize all four sides 
at once, hold down the  key and then click 
and drag any corner handle.

Can I rotate a graphic?
Yes. Most graphic objects come 
with a green rotate handle. 
Follow these steps:

1 Move the mouse  over the 
rotate handle (  changes 
to ).

2 Click and drag the rotate 
handle clockwise or counterclockwise to rotate the 
graphic.

3 Release the mouse button when the graphic is in 
the position you want.

Resize a Graphic

1 Click the graphic you want to 
resize.

● Sizing handles appear around the 
graphic’s edges.

2 Click and drag a sizing handle.

 The mouse  changes to .

● Drag a side handle to adjust that 
side.

● Drag a corner handle to adjust the 
two sides adjacent to the corner.

3 Release the mouse button when 
the handle is in the position you 
want.

● Excel resizes the graphic.

4 Repeat Steps 2 and 3 to resize 
other sides of the graphic, as 
necessary.
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2 Click the Format tab.

3 Click the Crop button ( ).

● Crop handles appear around the 
picture.

1 Click the picture you want to crop.

Crop a Picture

If a picture contains extraneous material near 
the outside edges of the image, you can crop the 
picture to remove that material. This not only 
reduces the size of the picture in the worksheet, 
but it also serves to focus more attention on the 
remaining part of the image.

Crop a 
Picture
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Can I crop a picture to a 
particular aspect ratio or 
shape?
Yes. Excel offers a couple of 
cropping options. If you know the 
aspect ratio (the ratio of the 
width to the height) you want, 
click the Crop , click Aspect Ratio, and then 
click the ratio, such as 3:5 or 4:6. If you prefer to 
crop to a shape, such as an oval or arrow, click the 
Crop , click Crop to Shape, and then click the 
shape.

If I have a picture with the 
main element in the middle, 
is it possible to crop in all 
directions at once to keep 
just that middle element?
Yes. You normally crop one side 
at a time by clicking and 
dragging a side crop handle, or 
two sides at a time by clicking 
and dragging a corner crop handle. To crop all four 
sides at once, hold down the  key and then 
click and drag any corner crop handle.

6 Click .

 Excel turns off the Crop feature.

● Excel crops the picture.

4 Click and drag a crop handle.

 The mouse  changes to .

● Click and drag a side handle to 
crop that side.

● Click and drag a corner handle to 
crop the two sides adjacent to the 
corner.

5 Release the mouse button when 
the handle is in the position you 
want.
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● Excel displays the Picture Styles 
gallery.

4 Click the picture style you want 
to use.

● Excel applies the Quick Style to 
the picture.

Apply a Picture Style

1 Click the picture you want to 
format.

2 Click the Format tab.

3 Click the Picture Styles .

Format a Picture

You can enhance your clip art and pictures by 
formatting the images. For example, Excel 
offers a number of picture styles, which are 
predefined formats that apply shadows, 
reflections, and borders. Excel also offers several 
3-D picture effects, which are preset special 
effects such as bevels and 3-D rotations.

Format a 
Picture
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If I do not like the formatting 
that I have applied to a 
picture, can I return the 
picture to its original look?
Yes. If you have not performed any 
other tasks since applying the 
formatting, click Undo ( ) until 
Excel has removed the formatting. Alternatively, 
click , click Preset, and then click No Preset. To 
reverse all the changes you have made to a picture 
since you inserted the image, click the picture, click 
Format, and then click Reset Picture.

I applied a Quick Style to 
a picture, but now I want 
to change the picture to 
something else. Do I have to 
start over?
No. You can simply replace the 
existing picture with the other 
picture, and Excel preserves the Quick Style so you 
do not have to repeat your work. Click the existing 
picture, click the Format tab, and then click the 
Change Picture button ( ). Click the new picture 
you want to use, and then click Insert.

● Excel applies the effect to the 
picture.

Apply a Picture Effect

1 Click the picture you want to 
format.

2 Click the Format tab.

3 Click the Picture Effects 
button ( ).

Note: If the image is a shape, the  button is 
named Shape Effects.

4 Click Preset.

5 Click the effect you want to apply.
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● Excel applies the shadow to the 
picture.

Add a Shadow to a Picture

1 Click the picture you want to 
format.

2 Click the Format tab.

3 Click the Shape Effects 
button ( ).

Note: For non-shape images, the  button is 
named Picture Effects.

4 Click Shadow.

5 Click the shadow effect you want 
to use.

Add a Shadow or Glow to a Picture

You can give your clip art, photos, shapes, and 
other pictures more prominence by enhancing 
them with either a shadow effect or a glow 
effect. Excel offers a number of predefined 
shadow and glow effects that you can apply 
with just a few mouse clicks.

Add a Shadow or 
Glow to a Picture
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How do I remove a shadow 
or glow from a picture?
If you no longer require a 
shadow or glow effect, you can 
remove it. If the effect was the 
last thing you did, click Undo 
( ) to reverse it. Otherwise, to 
remove a shadow, follow Steps 
1 to 4 in “Add a Shadow to a 
Picture,” and then click the No Shadow button. To 
remove a glow, follow Steps 1 to 4 in “Add a Glow 
to a Picture,” and then click the No Glow button.

Can I manually adjust the 
shadow to get the exact 
effect I want?
Yes. Excel offers several 
controls that enable you to 
manually adjust various 
aspects of the shadow. Click 
the picture, click the Format 
tab, and then click the  in the Picture Styles 
group. In the Format Picture dialog box, click the 
Shadow tab. Use the Angle slider to adjust the 
angle of the shadow; use the Size slider to set the 
shadow size; and use the Blur and Transparency 
sliders to set the look of the shadow.

● Excel applies the glow to the 
picture.

Add a Glow to a Picture

1 Click the picture you want to 
format.

2 Click the Format tab.

3 Click the Picture Effects 
button ( ).

Note: If the image is a shape, the  button is 
named Shape Effects.

4 Click Glow.

5 Click the glow effect you want 
to use.
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● Excel applies the reflection to the 
picture.

Add a Reflection to a Picture

1 Click the picture you want to 
format.

2 Click the Format tab.

3 Click the Picture Effects 
button ( ).

Note: If the image is a shape, the  button is 
named Shape Effects.

4 Click Reflection.

5 Click the reflection effect you want 
to use.

Add a Reflection or 3-D Effect to a Picture

You can make your clip art, photos, shapes, and 
other pictures stand out by enhancing them 
with either a reflection effect or a 3-D effect. 
Excel offers a number of predefined reflection 
and 3-D bevel and rotation effects that you 
can apply with just a few mouse clicks.

Add a Reflection or 
3-D Effect to a Picture
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How do I remove a reflection 
or 3-D effect from a picture?
If the effect was the last thing you 
did, click Undo ( ). Otherwise, to 
remove a reflection, follow Steps 1 
to 4 in “Add a Reflection to a 
Picture,” and then click the No Reflection button. 
To remove a bevel, follow Steps 1 to 4 in “Add a 
3-D Effect to a Picture,” and then click the No 
Bevel button. To remove a 3-D rotation, follow 
Steps 6 and 7 in “Add a 3-D Effect to a Picture,” 
and then click the No Rotation button.

Can I manually adjust the 3-D 
settings to get the exact 
effect I want?
Yes. Excel offers several controls 
that enable you to manually 
adjust various aspects of a bevel 
and 3-D rotation. Click the picture, 
click the Format tab, and then click the  in the 
Picture Styles group. In the Format Picture dialog 
box, click the 3-D Format tab to set the location 
and size of the bevel, and click the 3-D Rotation 
tab to adjust the 3-D angle and perspective.

● Excel applies the bevel effect to 
the picture.

6 Click .

7 Click 3-D Rotation.

8 Click the 3-D rotation effect you 
want to use.

 Excel applies the 3-D rotation 
effect to the picture.

Add a 3-D Effect to a Picture

1 Click the picture you want to 
format.

2 Click the Format tab.

3 Click the Picture Effects 
button ( ).

Note: If the image is a shape, the  button is 
named Shape Effects.

4 Click Bevel.

5 Click the bevel effect you want 
to use.
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2 Click the Format tab.

3 Click the Artistic Effects 
button ( ).

1 Click the photo you want to 
format.

Add an Artistic Effect to a Photo

You can add a bit of flair to a worksheet by 
applying an effect that makes a photo look like 
it was created using an artistic technique. Excel 
comes with more than 20 artistic effects, 
including Pencil Sketch, Chalk Sketch, Paint 
Brush, Watercolor Sponge, and Glass.

Add an Artistic 
Effect to a Photo
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How do I remove an 
artistic effect from a 
photo?
If the artistic effect was the 
last thing you did in Excel, 
click Undo ( ). Otherwise, 
follow Steps 1 to 3 to display 
the Artistic Effects gallery, and 
then click the None icon in 
the upper left corner of the gallery.

Can I manually adjust the 
artistic effect to get the 
exact look I want?
Yes. For most of the artistic 
effects, Excel offers a couple 
of controls that enable you 
to manually adjust the effect. 
Click the picture, click the 
Format tab, click  to open 
the Artistic Styles gallery, and then click Artistic 
Effects Options. Excel opens the Format Picture 
dialog box with the Artistic Effects tab displayed. 
Use the controls to customize the effect, and then 
click Close.

● Excel applies the artistic effect to 
the photo.

4 Click the effect you want to use.

16_577646-ch14.indd   30116_577646-ch14.indd   301 3/8/10   6:57 PM3/8/10   6:57 PM



302

11

22

33

2 Click the Format tab.

3 Click the Color button ( ).

1 Select the image you want to 
recolor.

Recolor an Image

You can modify the colors in an image to get 
the effect you want. For example, you can 
change a picture to black and white or you 
can apply a sepia effect to make the photo 
look older. You can also apply one of the 
document’s theme colors to help get the image 
to match the document. This is known as 
recoloring the image.

Recolor an  
Image
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How do I remove a 
recolor effect from a 
picture?
If the recolor effect was the 
last thing you did in Excel, 
click Undo ( ). Otherwise, 
follow Steps 1 to 3 to display 
the Color gallery, and then 
click the No Recolor icon in the upper left 
corner of the gallery’s Recolor section.

Can I manually adjust the 
recolor effect?
Yes. For each color effect, Excel 
enables you to adjust the 
saturation (the amount of color) 
and the tone (the intensity of the 
color). Click the picture, click the 
Format tab, click  to open the Color gallery, and 
then click Picture Color Options. Excel opens the 
Format Picture dialog box with the Picture Color tab 
displayed. Use the Saturation and Temperature sliders 
to customize the effect, and then click Close.

● Excel recolors the image.

 Excel displays the Color gallery.

4 Click the color effect you want to 
apply.
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Workbook 3

 Collaborating with 
Other People

If you want to collaborate 
with other people on a 
workbook, Excel gives you 
several ways to do this, 
including adding comments, 
sharing a workbook, and even 
working on a spreadsheet 
online.

17_577646-ch15.indd   30417_577646-ch15.indd   304 3/8/10   6:56 PM3/8/10   6:56 PM



Add a Comment to a Cell ..............................306

Protect a Worksheet’s Data ...........................308

Protect a Workbook’s Structure and 
Windows ........................................................310

Share a Workbook with Other Users ..........312

Track Workbook Changes ..............................314

Accept or Reject Workbook Changes .........316

Send a Workbook as an E-Mail 
Attachment ....................................................318

Save Excel Data as a Web Page ...................320

Make a Workbook Compatible with 
Earlier Versions of Excel ............................322

Collaborate on a Workbook Online ............324

17_577646-ch15.indd   30517_577646-ch15.indd   305 3/8/10   6:56 PM3/8/10   6:56 PM



306

22

55

11

44

33

Home Insert Page Layout Formulas Data Review View Add-Ins

Clipboard
Font

Alignment

Paste

Number

Cells

Alba Matter 11

B
A A

UI

A ab

+a+

General

$ % ,
.0

.00
.00

.0

Editing

A
Styles

Insert

A

Z

Delete

SORT &

FILTER

FIND &

SELECT

Format Matt:These figures were

given before the
June inventory.

 Excel displays a comment balloon.

● Excel precedes the comment with 
your Excel user name.

4 Type your comment.

5 Click outside the comment 
balloon.

Add a Comment

1 Click the cell you want to 
comment on.

2 Click the Review tab.

3 Click New Comment ( ).

Note: You can also right-click the cell and then 
click Insert Comment.

Add a Comment to a Cell

If you have received a workbook from 
another person, you can provide feedback 
to that person by adding a comment to a 
cell in the workbook. A comment is often 
the best way to give feedback because 
it does not change anything on the 
worksheet itself.

Comments are attached to a particular cell, and Excel 
displays each comment in a balloon.

Add a Comment 
to a Cell
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How do I change my 
Excel user name?
When collaborating, your 
user name is important 
because it tells other people 
who added the comments. If 
your current user name 
consists of only your first 
name or your initials, you 
can change it. Click File and then click Options to 
open the Excel Options dialog box. Click the 
General tab and then use the User name text box 
to edit the name. Click OK. Note, however, that 
this does not change your user name in any 
existing comments.

Can I edit or remove a 
comment?
Yes. To edit an existing 
comment, click the cell that 
contains the comment, click 
the Review tab, click Edit 
Comment ( ) to open the 
comment in a balloon, and 
then edit the balloon text. To 
remove a comment, click the cell that contains the 
comment, click the Review tab, and then click 
Delete ( ).

View a Comment

1 Move the mouse  over the cell.

● Excel displays the comment in a 
balloon.

● In the Review tab, you can also 
click Next ( ) and Previous 
( ) to run through the 
comments.

● In the Review tab, you can also 
click Show All Comments ( ) 
to display every comment at once.

● Excel adds a comment indicator 
( ) to the top right corner of the 
cell.
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 Excel displays the Protect Sheet 

dialog box.

4 Make sure the Protect worksheet 
and contents of locked cells check 
box is activated ( ).

5 Use the Password to unprotect 
sheet password box to type a 
password, if required.

1 Display the worksheet you want to 
protect.

2 Click the Review tab.

3 Click Protect Sheet ( ).

Protect a Worksheet’s Data

If you will be distributing a workbook to 
other people, you can enable Excel’s options 
for safeguarding worksheet data by activating 
the sheet’s protection feature. You can also 
configure the worksheet to require a password 
to unprotect it.

There are two main methods you can use to safeguard 
worksheet data: You can unlock only those cells that users are 
allowed to edit, and you can configure a range to require a 
password before it can be edited.

Protect a 
Worksheet’s Data
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When I protect a 
worksheet, can I configure 
a range to require a 
password before a user 
can edit the range?
Yes. First, unprotect the sheet if 
it is currently protected. Select 
the range you want to protect, 
click the Review tab, and then click Allow Users 
to Edit Ranges. In the Allow Users to Edit Ranges 
dialog box, click New to open the New Range 
dialog box. Type a title for the range, use the 
Range password box to type a password, and then 
click OK. When Excel prompts you to reenter the 
password, type the password and then click OK.

When I protect a 
worksheet, no one can edit 
any of the cells. Is there a 
way to allow users to edit 
some of the cells?
Yes. This is useful if you have a 
data entry area or other range 
that you want other people to 
be able to edit, but you do not want them to alter 
any other part of the worksheet. First, unprotect 
the sheet if it is currently protected. Select the 
range you want to unlock, click Home, click 
Format, and then click Lock Cell to turn off that 
option for the selected range.

 If you specified a password, Excel 
asks you to confirm the password.

8 Type the password.

9 Click OK.

 If you want to make changes to a 
worksheet, click the Review tab, 
click Unprotect Sheet ( ), type 
the unprotect password, and then 
click OK.

6 Click the check box beside each 
action that you want to allow 
unauthorized users to perform 
(  changes to ).

7 Click OK.
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 Excel displays the Protect 
Structure and Windows 
dialog box.

4 Click the Structure check box to 
protect the workbook’s structure 
(  changes to ).

5 Click the Windows check box to 
protect the workbook’s windows 
(  changes to ).

6 Type a password in the Password 
text box, if required.

7 Click OK.

1 Display the workbook you want to 
protect.

2 Click the Review tab.

3 Click Protect Workbook ( ).

Protect a Workbook’s Structure and Windows

You can prevent unwanted changes to a workbook 
by activating protection for the workbook’s 
windows and structure. You can also configure the 
workbook to require a password to unprotect it.

See the Tips on the following page to learn what Excel does when you 
protect a workbook’s structure and windows.

Protect a Workbook’s 
Structure and Windows
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What happens when I 
protect a workbook’s 
windows?
Excel hides the window’s 
Close, Maximize, and 
Minimize buttons. If the 
workbook is not maximized, 
Excel also disables the 
window borders, which 
means the window cannot be moved, sized, or 
closed. Excel also disables the View tab’s New 
Window, Split, Freeze Panes, and View Side By 
Side commands when the window is active.

What happens when I 
protect a workbook’s 
structure?
Excel disables most 
worksheet-related 
commands, including Insert 
Sheet, Delete Sheet, Rename 
Sheet, Move or Copy Sheet, 
Tab Color, Hide Sheet, and 
Unhide Sheet. Excel also prevents the Scenario 
Manager from creating a summary report.

● If you protected the windows, 
Excel hides the window controls.

● If you protected the windows, 
Excel disables many 
window-related commands 
on the View tab.

● If you protected the structure, 
Excel disables most sheet-related 
commands on the sheet shortcut 
menu.

 If you specified a password, Excel 
asks you to confirm it.

8 Type the password.

9 Click OK.
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 The Share Workbook dialog box 
appears.

4 Click the Editing tab.

5 Click the Allow changes by 
more than one user at the 
same time check box 
(  changes to ).

6 Click OK.

1 Display the workbook you want to 
share.

2 Click the Review tab.

3 Click Share Workbook ( ).

Share a Workbook with Other Users

You can allow multiple users to modify a 
workbook simultaneously by sharing the 
workbook. Once you have shared a workbook, 
other users can open the workbook via a network 
connection and edit the file at the same time.

When you share a workbook, Excel automatically begins tracking 
the changes made to the file. For more information on this feature, 
see “Track Workbook Changes” later in this chapter.

Share a Workbook 
with Other Users
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How do I know if other people currently have the 
workbook open?
The Editing tab of the Share Workbook dialog box maintains a list 
of the users who have the workbook open. To see this list, follow 
these steps:

1 Display the shared workbook.

2 Click the Review tab.

3 Click .

 The Share Workbook dialog box appears.

4 Click the Editing tab.

● The Who has this workbook open now list displays the users who 
are currently editing the file.

5 Click OK.

 Excel saves the workbook and 
activates sharing.

● Excel displays [Shared] in the 
title bar.

 You and users on your network 
can now edit the workbook at the 
same time.

 Excel tells you that it will now save 
the workbook.

7 Click OK.
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 The Highlight Changes dialog box 
appears.

5 Click the Track changes while 
editing check box (  changes 
to ).

● Leave the When check box 
activated ( ) and leave All 
selected in the list.

● To learn more about the Who and 
Where options, see the Tips on 
the next page.

● Leave the Highlight changes on 
screen check box activated ( ) 
to view the workbook changes.

6 Click OK.

1 Display the workbook you want to 
track.

2 Click the Review tab.

3 Click Track Changes ( ).

4 Click Highlight Changes.

Track Workbook Changes

If you want other people to make changes to a 
workbook, you can keep track of those changes so 
you can either accept or reject them (see “Accept 
or Reject Workbook Changes”). Excel’s Track 
Changes feature enables you to do this.

When you turn on Track Changes, Excel monitors the activity of each 
reviewer and stores that reviewer’s cell edits, row and column 
additions and deletions, range moves, worksheet insertions, and 
worksheet renames.

Track Workbook 
Changes
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Can I track changes in just 
part of the worksheet?
Yes, you can modify this task 
so that Excel only tracks 
changes in a specific range. 
Follow Steps 1 to 4 to open 
the Highlight Changes dialog 
box. Click the Where check 
box (  changes to ), click 
inside the Where range box, and then select the 
range you want to track. Click OK to put the new 
setting into effect.

Is there a way to avoid 
having my own 
changes highlighted?
Yes, you can configure the 
workbook to show every 
user’s changes but your 
own. Follow Steps 1 to 4 
to open the Highlight 
Changes dialog box. Click 
the Who check box (  changes to ), click the 
Who , and then click Everyone but Me. Click 
OK to put the new setting into effect.

 Excel activates the Track Changes 
feature.

● Excel shares the workbook and 
indicates this by displaying 
[Shared] beside the workbook 
name.

Note: See “Share a Workbook with Other Users” 
to learn more about workbook sharing.

 Excel tells you it will now save the 
workbook.

7 Click OK.
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 If your workbook has unsaved 
changes, Excel tells you it will now 
save the workbook.

5 Click OK.

 The Select Changes to Accept or 
Reject dialog box appears.

1 Display the workbook you are 
tracking.

2 Click the Review tab.

3 Click Track Changes ( ).

4 Click Accept/Reject Changes.

Accept or Reject Workbook Changes

After you turn on Excel’s Track Changes 
features (see “Track Workbook Changes”), you 
can then accept or reject the changes that other 
users make to the workbook.

Accept or Reject 
Workbook Changes
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When I complete my 
review, should I turn off 
the tracking feature?
Unless you know that other 
people still require access to 
the workbook, you should turn 
off the tracking feature when 
your review is complete. To do 
this, click the Review tab, click 

, and then click Highlight Changes to open the 
Highlight Changes dialog box. Click the Track 
changes while editing check box (  changes 
to ), and the click OK.

What happens if I and 
another user make 
changes that affect the 
same cell?
In this situation, when you 
save the workbook, Excel 
displays the Resolve 
Conflicts dialog box, which 
shows the change you made as well as the change 
the other user made. If your change is the correct 
one, click Accept Mine; otherwise, click Accept 
Other. If there are multiple conflicts, you can save 
time by clicking either Accept All Mine or Accept 
All Others.

● Leave the When check box 
activated ( ) and leave Not yet 
reviewed selected in the list.

● If you only want to review 
changes made by a particular 
user, click the Who check box 
(  changes to ), click the 
Who , and then click the user’s 
name.

6 Click OK.

 The Accept or Reject Changes 
dialog box appears.

● Excel displays the details of the 
current change.

7 Click an action for the change.

● Click Accept to leave the change 
in the workbook.

● Click Reject to remove the 
change from the workbook.

 Excel displays the next change.

8 Repeat Step 7 to review all the 
changes.

● You can also click Accept All or 
Reject All to accept or reject all 
changes at once.
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3 Click Save & Send.

4 Click Send Using E-mail.

 Excel displays the Send Using 
E-mail commands.

5 Click Send as Attachment.

1 Open the workbook you want to 
send.

2 Click the File tab.

Send a Workbook as an E-Mail Attachment

If you want to send an Excel workbook to 
another person, you can attach the workbook to 
an e-mail message and send it to that person’s 
e-mail address. The other person can then open 
the workbook in Excel after receiving your 
message.

Send a Workbook as an 
E-Mail Attachment
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PDFPDF
mark-o-matic

 Worksheet 1

 Worksheet 1

 Worksheet 1

PDFPDF

What can I do if the 
recipient does not have 
Excel?
If the other person does not use 
Excel, you can send the 
workbook in a different format. 
One possibility would be to save the workbook 
as a Web Page (see “Save Excel Data as a Web 
Page”). Alternatively, if your recipient can view 
PDF (Portable Document Format) files, follow 
Steps 1 to 4 to display the Send Using E-mail 
options, and then click Send as PDF.

Are there any restrictions 
related to sending file 
attachments?
There is no practical limit to the 
number of workbooks you can attach 
to a message. However, you should 
be careful with the total size of the files you send. If 
you or the recipient has a slow Internet connection, 
sending or receiving the message can take an 
extremely long time. Also, many Internet service 
providers (ISPs) place a limit on the size of a message’s 
attachments, which is usually between 2 and 5MB.

8 Click Send.

 Outlook sends the message.

 Outlook creates a new e-mail 
message.

● Outlook attaches the workbook to 
the message.

6 Type the address of the recipient.

7 Type your message text.
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222 Click File.

3 Click Save As.

1 Open the workbook that contains 
the data you want to save as a 
Web page.

● To save a worksheet as a Web 
page, click the worksheet tab.

● To save a range as a Web page, 
select the range.

Save Excel Data as a Web Page

If you have an Excel range, worksheet, or 
workbook that you want to share on the Web, 
you can save that data as a Web page that you 
can then upload to your Web site.

When you save a document as a Web page, you can also specify 
the title text that appears in the browser’s title bar and the 
keywords that search engines use to index the page.

Save Excel Data 
as a Web Page
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Can I save an Excel workbook to my Windows Live SkyDrive?
Yes. Follow these steps:

1 Sign in to your Windows Live account. In Excel, open the workbook you want to share.

2 Click the File tab.

3 Click Save & Send.

4 Click Save to Web.

5 Click the Web folder you want to use.

6 Click Save As.

7 Click Save.

 The Enter Text dialog box appears.

7 Type the page title in the Page title text box.

8 Click OK.

9 Click Tags and then type one or more 
keywords, separated by semicolons.

0 Choose which part of the file you want to save 
as a Web page (  changes to ):

● Click Entire Workbook to save the whole 
workbook.

● Click Selection to save either the current 
worksheet or the selected cells.

! Click Save.

 Excel saves the data as a Web page.

 The Save As dialog box appears.

4 Click the Save as type  and then click 
Web Page.

5 Select the folder where you want to store the 
Web page file.

6 Click Change Title.
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 The Save As dialog box appears.

4 Select the folder in which to store 
the new workbook.

5 Click in the File name text box 
and type the name that you want 
to use for the new workbook.

6 Click the Save as type . 

1 Open the workbook you want to 
make compatible.

2 Click File.

3 Click Save As.

Make a Workbook Compatible with Earlier Versions of Excel

You can save an Excel workbook in a special format 
that makes it compatible with earlier versions of Excel. 
This enables you to share your workbook with other 
Excel users.

If you have another computer that uses a version of Excel prior to Excel 
2007, or if the people you work with use earlier Excel versions, those 
programs cannot read documents in the standard format used by Excel 
2010 and Excel 2007.

Make a Workbook Compatible 
with Earlier Versions of Excel
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Which versions of Excel are 
compatible with the Excel 
97-2003 Workbook file format?
For Windows, the Excel 97-2003 
Workbook file format is compatible 
with Excel 97, Excel 2000, Excel XP, 
and Excel 2003. For the Mac, the 
Excel 97-2003 Workbook file format is compatible with 
Excel 98, Excel 2001, and Office 2004. In the unlikely 
event that you need to share a document with 
someone using either Excel 5.0 or Excel 95, use the 
Microsoft Excel 5.0/95 Workbook file format instead.

Can people using Excel 2007 
open my Office documents?
Yes. The file format used by 
both Excel 2010 and Excel 2007 
is the same. If you only work 
with people who use either or 
both of these Excel versions, 
then you should stick with the default file 
format — which is called Excel Workbook — 
because it offers many benefits in terms of 
Excel features.

8 Click Save.

 Excel saves the file using the Excel 
97-2003 Workbook format.

7 Click the Excel 97-2003 
Workbook file format.
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 Your Windows Live SkyDrive 
appears.

3 Click the folder that contains the 
workbooks you want to share.

1 Log on to your Windows Live 
account.

2 Click SkyDrive.

Collaborate on a Workbook Online

If you have a Windows Live account, you can use 
the SkyDrive feature to store an Excel workbook 
in an online folder, and then allow other users to 
collaborate on that workbook using the Excel 
Web App.

To allow another person to collaborate with you on your online 
workbook, that person must have a Windows Live ID.

Collaborate on a 
Workbook Online
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How do I know when other people are also using a workbook 
online?
When you open a workbook using the Excel Web App, examine the 
lower right corner of the Excel screen. If you see 1 person editing, it 
means you are the only user who is working on the file. However, if you 
see 2 people editing, then it means another person is collaborating on 
the workbook with you. To see who it is, click the 2 people editing 
message (●), as shown here.

4 Click More.

5 Click Edit permissions.

 The folder’s Edit Permissions page 
appears.

6 Type the Windows Live e-mail 
address of the person you want to 
collaborate with.

7 Press .

● Windows Live adds the person to 
the list.

8 Click  here and then click Can 
add, edit details, and delete 
files.

9 Click Save.

 Windows Live prompts you to 
send a notification for the folder.

0 Type a message to the user.

! Click Send.

 Windows Live sends an e-mail 
message to the user. The user 
clicks the link in that message, 
logs on to Windows Live, and can 
then edit a workbook in the 
shared folder.
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Symbols and Numerics
+ (addition operator), 121
, (comma), 31, 99
/ (division operator), 121
= (equal sign) in formulas, 4, 120, 122
= (equal-to operator), 121
^ (exponentiation operator), 121
> (greater-than operator), 121
>= (greater-than or equal-to operator), 121
< (less-than operator), 121
<= (less-than or equal-to operator), 121
* (multiplication operator), 121
- (negation operator), 121
( ) (parentheses, and operator precedence), 121, 143
% (percentage operator), 121
+ (plus sign), 121
- (subtraction operator), 121
3-D effect, adding to worksheet graphic, 298, 299

A
absolute cell reference format, 138–139
Accounting Number format, 99
active or current cell, 28
Add Scenario dialog box, 237
Add-Ins dialog box, 243
addition. See SUM function
addition operator (+), 121
address. See cell address
aligning text

within cell, 90–91
centering across columns, 63, 92–93

Analysis ToolPak add-in, 242–243
Apply Names feature, 133
area chart

description, 247
horizontal gridlines for, 253

arithmetic formula, 121
Arrange Windows dialog box, 178–179
array formula, 229
arrow keys, using to navigate worksheet, 146
artistic effects, for worksheet photos, 300–301
ASCII code symbol, 35
attachment, e-mail, sending workbook as, 318–319
AutoComplete feature, 29
AutoFill feature

customizing, 47
invoking, 46

AutoFilter feature, 222–223

AutoFit feature, 109, 111
AutoFormat feature, 102–103
automatic subtotals feature, 230
AutoShape. See shapes
AutoSum feature, 130–131
AVERAGE function, 4, 125
axis

category, 246, 253
formatting, 266–269
value, 246

B
background

adding
color, 96–97
image, 162–163

changing color, 163
removing image, 163

bar chart
description, 247
vertical gridlines for, 253

bevel effect, adding
to chart element, 273
to worksheet graphic, 298, 299

blank worksheet, adding to workbook, 148–149
BMP picture format, 284
body font, 192
border

adding to cells and ranges, 114–115
custom, creating, 115
selecting line style, 115

break-even analysis, 235
bubble chart

description, 247
horizontal gridlines for, 253

C
category axis, 246, 253
cell address

absolute reference format, 138–139
defined, 26
mixed reference format, 139
relative reference format, 138, 139

cells. See also columns; ranges; rows
absolute vs. relative vs. mixed reference formats, 

138–139
active or current, 28
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centering text across columns, 63, 92–93
changing. See also editing

chart layout, 255
chart source data, 258–259
color in worksheet, 86–87, 156–157, 163, 190–191
column width, 108–109
Excel user name, 307
font and font characteristics, 84–87
font scheme, 192–193
print area, 211
range name, 76–77
row height, 110–111
type of chart, 256–257
workbook margins, 204–205

changing cell, 236–237
chart

adding
special effect to element, 272–273
title, 246, 250

applying style, 255, 274–277
changing

layout, 255
source data, 258–259

changing type, 256–257
clicking on element to select, 267
creating

as part of worksheet, 248–249
on separate sheet, 249

customizing element
background, 268–269
outline, 270–271

defined, 5, 246
deleting, 261
element, defined, 246
formatting, 266–277
gridlines on, 246, 253, 266–269
inserting into worksheet, 248–249
list of types, 247
moving

to new sheet, 261
on worksheet, 260, 261

removing data series, 259
resizing, 260, 261
saving as template, 257
selecting

chart type, 248–249
data for, 248

single-cell, 262–263

adding
background color, 96–97
border, 114–115
comment, 306–307
data to, 4, 28–29
formula, 4, 122–123
sparkline chart, 262–263

aligning text within, 90–91
applying style, 106–107
AutoComplete feature, 29
changing

column width, 108–109
font and font characteristics, 84–87
row height, 110–111

copying
formatting between, 116–117
and pasting using smart tags, 16–17

data validation rules for, 224–225
defined, 26
deleting

comments, 307
data and formatting, 39, 54, 55
data but not formatting, 38–39
formatting but not data, 39

editing
comment in, 307
data, 4, 36–37

entering
data, 4, 28–33
date, 32–33
formula, 4, 120–121
numbers, 30–31
text, 28–29
time of day into, 32–33

filling series, 5, 46–47
formatting, 82–117
inserting special symbol, 34–35
locking and unlocking, 308–309
merging, 62–63
multiple, calculating SUM, 129
new, inserting one or more into existing range, 52–53
nonadjacent, selecting, 42
protecting data, 308–309
rotating text within, 94–95
selecting

all cells, 43
range of cells, 42–43

wrapping text within, 112–113
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color scheme, 190–191
Colors dialog box, 97
column chart

description, 247
horizontal gridlines for, 253

column sparkline, defined, 262
column width, changing, 108–109
columns

adding up numbers using SUM function, 128–129
changing width, 108–109
defined, 26
deleting, 57
as element of row-and-column spreadsheet format, 5
freezing and unfreezing, 60–61
hiding and unhiding, 58–59
multiple, centering text across, 63, 92–93
new, inserting one or more in worksheet, 51
repeating title on each printout page, 212, 213
selecting, 43
toggling A-Z headings on and off, 159
transposing with rows, 64–65

comma (,), 31, 99
command, Excel

adding
to Quick Access Toolbar, 12–13
to Ribbon, 15

removing
from Quick Access Toolbar, 13
from Ribbon, 15

comment
adding to cell, 306–307
editing in cell, 307
removing from cell, 307

comparison formula, 121
conditional format

applying, 104–105
defined, 104
multiple, specifying, 105
removing, 105

copying
cell, using smart tag, 16–17
formatting, 116–117
formula, 136, 137, 139
range, 49
worksheet, 152–153

COUNT function, 125
Create Names from Selection dialog box, 73
Create Table dialog box, 227

sparkline, 262–263
switching series and categories in, 259

chart area
customizing background, 268–269
defined, 266
formatting, 266–267

chart categories
in chart data table, 254
swapping with chart series in data table, 259

chart series. See data series
chart sheet, defined, 249
chart title

adding
to axis, 250
to chart, 250

defined, 246
formatting, 266–269

checking spelling, 184–185
Choose a SmartArt Graphic dialog box, 288
circle, drawing, 281
clip art

adding
glow effect, 296, 297
reflection effect, 298, 299
shadow effect, 296, 297
3-D effect, 298, 299

applying predefined style or effect to, 294–299
defined, 282
filtering, 283
formatting, 294–299
inserting image in worksheet, 282–283
moving, 290, 291
recoloring, 302–303
resizing, 290, 291
rotating, 291

closing
Excel, 23
workbook, 186–187

color. See also recoloring worksheet image
adding

to background, 96–97
to worksheet tab, 160–161

changing
background, 163
workbook scheme, 190–191
for worksheet font, 86–87
for worksheet gridlines, 156–157
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decimal place, controlling display, 100–101
Degrees spin box, 94–95
deleting

cell, 56–57
cell data, 38–39
cell data from range, 54–55
cell formatting along with data, 39, 54, 55
cell formatting but not data, 39
chart, 261
column, 57
comment in cell, 307
range, 54–57
range name, 78–79
row, 57

dictionary, custom, 185
division operator (/), 121
doughnut chart, defined, 247
drop-down galleries, 11

E
editing. See also changing

cell data, 4, 36–37
comment in cell, 307
formula, 123
scenario, 239

effect scheme
applying

to chart element, 272–273
to graphic object, 294–299

defined, 194–195
e-mail attachment, sending workbooks as, 318–319
entering data into cell, 4, 28–33
equal sign (=) in formula, 4, 120, 122
equal-to operator (=), 121
error message alert, 225
Excel. See also specific topics

adding icon to Windows 7 taskbar, 7, 22
commands, 12–13, 15
description, 4–5
quitting, 23
starting, 6–7, 22
version file format compatibility, 322–323
window, 7, 8–9

Excel Options dialog box
changing Excel user name, 307
customizing

Excel, 20–21
Quick Access Toolbar, 12–13
Ribbon, 14–15

cropping picture, 292–293
Currency format, 98

D
data analysis

Analysis ToolPak add-in for, 242–243
converting range to table for, 226–227
creating

data table for, 228–229
PivotTable for, 240–241
scenario for, 236–239

defined, 218
filtering data for, 222–223
Goal Seek tool for, 234–235
grouping data for, 232–233
rules for data validation, 224–225
sorting data for, 220–221
summarizing data, 230–231

data label
adding to chart, 251
applying WordArt style to, 276–277
defined, 251

data marker
defined, 246
label for, 251

data point
in chart data table, 254
defined, 246
labeling, 251

data series
in chart data table, 254, 259
defined, 246
formatting, 266–269
swapping with chart categories in data table, 259

data table
comparison with Excel table, 228
creating for use with formula, 228–229
defined, 228
displaying in chart, 254

data type, 27
data validation rules, 224–225
data value, defined, 246
database, spreadsheet as, 5
date

description of data type, 27
entering into cell, 32–33
filtering, 223
formatting options, 32, 33
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filling range without copying, 45
image in worksheet, 294–301
keeping when deleting cell data, 38, 39, 54–55
number, 98–101
predefined, 102–103
workbook, 188–201
worksheet range, 82–117
wrapping text within cell, 112–113

Formula bar
adding data to cell, 4, 28
defined, 4
editing data in cell, 4, 36–37
expanding, 141
hiding/showing, 140–141
toggling on and off, 140–141

formulas
absolute cell reference in, 138–139
adding

to cell, 4, 122–123
function to, 4, 126–127
range name to, 68, 69, 132–133

array-type, 229
building, 122–123
copying, 136, 137, 139
defined, 4, 120
description, 120–121
editing, 123
entering in cell, 4, 120–121
error type, 143
moving, 136
referencing range in another worksheet, 134–135
relative cell reference in, 138, 139
troubleshooting error, 142–143
viewing result, 122

Full Screen view, 19
Function Arguments dialog box, 127
functions

adding to formula, 4, 126–127
advantages of, 124
defined, 4, 124
description of, 124–125
financial, 125
listing of, 4, 126
mathematical, 124
statistical, 125
structure of, 124

FV function, 125

loading Excel add-in, 242–243
ways to open, 21

exiting Excel, 23
exponentiation operator (^), 121

F
File tab, 8
Fill Effects dialog box, 97
filling of range

AutoFill feature, 46
by creating custom AutoFill list, 47
with customized series of values, 47
with same data, 44–45
with series of data values, 5, 46–47
without copying original cell’s formatting, 45

fills
adding background color to worksheet range, 96–97, 

163
customizing chart element background, 268–269

filtering data, 222–223, 283
financial function, 125
financial symbol, inserting, 34–35
Find and Replace dialog box

finding text, 180–181
replacing text, 182–183

finding text in workbook, 180–181
font

applying effect, 86–87
changing

color, 86–87
size, 84–85
type of, 84–85
workbook scheme, 192–193

creating new workbook scheme, 193
font scheme, defined, 192
footer, for workbook printout, 201, 205
foreign character, inserting, 34–35
Format Painter feature, 116–117
formatting

adding to new row or column, 50, 51
by applying AutoFormat feature, 102–103
chart element, 266–277
clearing from cell, 39, 54, 55
conditional, 104–105
copying between ranges, 116–117
date and time, 32, 33
deleting along with data, 39, 54, 55
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hiding
selected row or column, 58–59
selected worksheet in workbook, 168, 169
unhiding row or column, 59
unhiding worksheet in workbook, 169

Highlight Changes dialog box, 314–315
horizontal panes, splitting worksheet into, 166–167

I
images

adding
glow effect, 296, 297
reflection effect, 298, 299
shadow, 296, 297
3-D effect, 298, 299

applying predefined style or effect to, 294–299
as chart element background, 269
cropping, 292–293
inserting in worksheet

clip art, 282–283
photo, 284–285
SmartArt, 288–289
WordArt, 286–287

moving, 290, 291
recoloring, 302–303
resizing, 290, 291
rotating, 291

IPMT function, 125

J
JPEG format, 284

K
keyboard shortcuts and techniques

closing documents, 187
creating

new workbook, 173
range name, 73

deleting
data from range, 57
range, 57

entering symbol, 35
font-related, 87
navigating worksheet, 146
pasting range name list, 81
selecting range, 43

G
galleries, Ribbon, 10–11
GIF format, 284
glow effect, adding

to chart element, 272
to worksheet graphic, 296, 297

Go To dialog box, 75
Goal Seek tool, 234–235
gradient effect, 97, 268, 269
graphics, worksheet

adding
glow effect, 296, 297
reflection effect, 298, 299
shadows, 296, 297
3-D effect, 298, 299

applying predefined style or effect to, 294–299
drawing shape on worksheet, 280–281
inserting

clip art image, 282–283
photo, 284–285
SmartArt image, 288–289
WordArt image, 286–287

moving, 290, 291
recoloring, 302–303
resizing, 290, 291
rotating, 291

greater-than operator (>), 121
greater-than or equal-to operator (>=), 121
gridlines

on chart
defined, 246
displaying, 253
formatting, 266–269

on worksheet
changing color, 156–157
toggling on and off, 158

grouping related data, 232–233

H
header, for workbook printout, 198–199, 205
headings

font for, 192, 193
row and column

repeating, 212–213
toggling 1, 2, etc. on and off, 159
toggling A-Z on and off, 159
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naming. See also renaming

range, 68–73
worksheet, 147

negation operator (-), 121
new worksheet, creating, 148–149
node, in SmartArt graphic

adding shape, 289
changing shape, 289
defined, 288

nonadjacent cells, selecting, 42
Normal view, 18, 19
NPER function, 125
numbers

adding up row or column using SUM function, 128–129
decimal place in, 100–101
description of data type, 27
entering into cell, 30–31
filtering, 223
formatting in cell, 98–99
including symbol in, 31
repeating, 31

O
online workbook collaboration, 324–325
opening

cell for editing, 36, 37
Excel Options dialog box, 21
workbook, 177

operand
in Excel formula, 120
function as, 124–125

operators
arithmetic, 121
in comparison formula, 121
defined, 120
order of precedence, 121, 143

orientation
page, landscape vs. portrait, 206
rotating text within cell, 94–95

P
page break

inserting in worksheet, 207
previewing, 18, 19

Page Layout view, 18
page orientation, 206

L
label. See text label; titles, row and column
landscape page orientation, 206
legend, chart

defined, 246
formatting, 266–269
positioning, 252

less-than operator (<), 121
less-than or equal-to operator (<=), 121
line. See border; page break; wrapping text within cell
line chart

description, 247
vertical gridlines for, 253

line sparkline, defined, 262
Live Preview feature, 11

M
margins, for workbook printouts

adjusting in Print Preview, 215
footer options, 205
header options, 205

marker, data
defined, 246
label for, 251

mathematical function, 124
mathematical symbol, inserting, 34–35
MAX function, 125
maximizing window, 179
MEDIAN function, 125
merging cells, 62–63
MIN function, 125
minus sign (-), 121
mixed cell reference format, 139
MOD function, 124
MODE function, 125
moving

chart, 260, 261
formula, 136
range, 48, 49
worksheet, 150–151

multiplication operator (*), 121

N
Name Manager dialog box

changing range name, 76–77
deleting range name, 78–79
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pinning Excel icon to Windows 7 taskbar, 7, 22
PivotTable, creating, 240–241
plot area

defined, 246
formatting, 266–269

plus sign (+), 121
PMT function, 4, 125, 127
PNG format, 284
pop-up help, 21
portrait page orientation, 206
PPMT function, 125
preview

header or footer, 201
with Live Preview feature, 11
printout, 214–215

print area
changing, 211
defined, 210
removing, 211
setting, 210–211
specifying non-contiguous ranges, 211

printing
choosing paper size, 208–209
fitting worksheets onto single page, 209
previewing result, 214–215
sending document to printer, 216–217

PRODUCT function, 124
protecting

workbook structure, 310–311
worksheet data, 308–309

PV function, 125

Q
Quick Access Toolbar

adding command to, 12–13
customizing, 12–13
default buttons, 12
defined, 8
increasing available space on, 13
moving below Ribbon, 13
Redo button, 12
removing command from, 13
Undo button, 12, 37

quick filter, 223
Quick Styles, 276–277, 287, 295
quitting Excel, 23

Page Setup dialog box
Margins tab, 204, 205
Page tab, 209
Sheet tab, 212–213

panes, splitting worksheet into, 166–167
paper size, choosing, 208–209
parentheses, and operator precedence, 121, 143
password-protecting worksheet, 308–309
pasting. See also copying; moving

cell, using smart tag, 16–17
list of range names, 80–81

PDF file, creating from workbook, 319
percentage

applying number format, 99
entering directly into cell, 31

percentage operator (%), 121
photos

adding
artistic effect, 300–301
glow effect, 296, 297
reflection effect, 298, 299
shadow, 296, 297
3-D effect, 298, 299

compressing to reduce file size, 285
cropping, 292–293
inserting in worksheet, 284–285
moving, 290, 291
recoloring, 302–303
removing background from, 285
resizing, 290, 291
rotating, 291

pictures. See also shapes
adding

glow effect, 296, 297
reflection effect, 298, 299
shadow, 296, 297
3-D effect, 298, 299

applying predefined style or effect to, 294–299
as chart element background, 269
formatting, 294–299
inserting

clip art in worksheet, 284–285
photo in worksheet, 284–285

recoloring, 302–303
rotating, 291

pie chart, defined, 247
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moving, 48, 49
naming, 68–73
protecting data, 308–309
rectangular, 42
referencing in another worksheet, 134–135
saving data as Web page, 320–321
selecting, 42–43
setting as print area, 210–211
sorting, 220–221
tracking changes, 315
transposing rows and columns, 65
troubleshooting formula result, 142–143

RATE function, 125
recoloring worksheet image, 302–303
Redo button, on Quick Access Toolbar, 12
reference format. See cell address
reflection effect, adding to worksheet graphic, 298, 299
relative cell reference format, 138, 139
removing command from Quick Access Toolbar, 13
renaming

range, 76–77
worksheet, 147

replacing text in workbook, 182–183
resizing. See also zooming in and out

chart, 260, 261
graphic, 290, 291

Ribbon
adding

command to, 15
new group to existing tab, 14–15
new tab to, 14–15

customizing, 14–15
defined, 8, 9
description, 9
formatting chart element, 266, 267, 268–269
galleries in, 10–11
moving Quick Access Toolbar below, 13
removing command from, 15
restoring default configuration, 15
as source of commands for Quick Access Toolbar, 13

rotation
applying 3-D effect to worksheet graphic, 298, 299
dragging handle to turn worksheet graphic, 291
slanting text within cell, 94–95

ROUND function, 124
row height, changing, 110–111

R
radar chart, defined, 247
RAND function, 124
RANDBETWEEN function, 124
range name

adding to formula, 68, 69, 132–133
Apply Names feature, 133
basing on text label, 72–73
benefits, 68–69
changing, 76–77
creating, 70–72
defined, 68
defining, 70–71
deleting, 78–79
ease of use, 68, 69
navigating

between workbooks using, 75
worksheet using, 74–75

pasting list, 80–81
ranges

adding
background color, 96–97
border, 114–115
up row or column using SUM function, 129

aligning text within cells, 90–91
applying style, 106–107
changing

column width, 108–109
font and font characteristics, 84–87
name, 76–77
row height, 110–111

converting to table, 226–227
copying, 49
copying formatting between, 116–117
defined, 26, 40
deleting, 56–57

data and formatting from, 54, 55
data but not formatting, 54–55
name, 78–79

existing, inserting new cell into, 52–53
filling

with same data, 44–45
with series of data values, 46–47

filtering, 222–223
formatting, 82–117
locking and unlocking, 308–309
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resizing, 290, 291
rotating, 291
style, applying to chart element, 274–275

sharing workbook
accommodating earlier Excel version format, 322–323
cell comments, 306–307
online collaboration, 324–325
protecting

cell data, 308–309
structure, 310–311

saving data as Web page, 320–321
sending as e-mail attachment, 318–319
setup for, 312–313
tracking changes, 314–317

sheet. See chart sheet, defined; worksheets
single-cell chart, 262–263
SkyDrive, saving Excel workbook to, 321
smart tag, 16–17
SmartArt graphic

defined, 288
inserting in worksheet, 288–289
moving, 290, 291
resizing, 290, 291
rotating, 291

soft edges effect, adding to chart element, 273
sorting worksheet range, 220–221
sparkline, 262–263
special symbol, inserting, 34–35
spell-checker, 184–185
splitting worksheet into panes, 166–167
spreadsheet overview, 2, 4–5. See also worksheets
SQRT function, 124
square, drawing, 281
Start menu, Windows, 6–7
starting Excel, 6–7
statistical function, 125
statistical tool, 242–243
status bar

changing zoom level, 164, 165
defined, 8
displaying sum of selected range, 5, 131
Edit indicator, 36

STDEV function, 125
STDEVP function, 125
stock chart, defined, 247

rows
changing height, 110–111
defined, 26
deleting, 57
as element of row-and-column spreadsheet format, 5
freezing and unfreezing, 60–61
hiding and unhiding, 58–59
merging cells to create title row, 62–63
new, inserting one or more in worksheet, 50, 51
repeating title on each printout page, 212–213
selecting, 43
toggling headings on and off, 159
transposing with columns, 64–65

S
Save button on Quick Access Toolbar, 12
saving

Excel data as Web page, 320–321
workbook, 176, 187

in format compatible with earlier Excel version, 
322–323

saving data as Web page, 320–321
scenario

creating, 236–237
defined, 236
deleting, 239
editing, 239
storing, 237, 238
writing description for, 237

scheme. See color scheme; effect scheme
searching for text in workbook, 180–181
securing worksheet data, 308–309
series, filling automatically, 5, 46–47
shadow effect, adding

to chart element, 272
to worksheet graphic, 296, 297

shapes. See also node, in SmartArt graphic
adding

glow effect, 296, 297
reflection effect, 298, 299
shadow, 296, 297
text to, 281
3-D effect, 298, 299

defined, 280
drawing on worksheet, 280–281
moving, 290, 291
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centering across multiple columns, 63, 92–93
description of data type, 27
entering into cell, 28–29
filtering, 223
formatting within cell, 90–91
replacing in worksheet, 182–183
rotating within cell, 94–95
searching worksheet for, 180–181
ways to view without wrapping, 113
wrapping within cell, 112–113

text label. See also titles, row and column
adding to chart, 251, 276–277
creating range name based on, 72–73

theme, workbook, 196–197
3-D effect, adding to worksheet graphic, 298, 299
TIFF format, 284
time of day

description of data type, 27
entering into cell, 32–33
formatting options, 33

title, chart. See also data label
adding

to axis, 250
to chart, 250

defined, 246
formatting, 266–269

title bar, 8
titles

row and column
creating range names based on, 72–73
freezing, 60–61
repeating on each printout page, 212–213
unfreezing, 61

worksheet, merging cells to create, 62–63
tool tab, 15
total. See Sum button
Track Changes feature

accepting or rejecting change, 316–317
Everyone but Me option, 315
limiting task to specific range, 315
resolving change conflict, 317
tracking workbook changes, 314–315
turning off, 317
turning on, 314

transposing rows and columns, 64–65
troubleshooting formula error, 142–143

styles
customizing for worksheet data, 107
for formatting tabular data, 107
predefined

chart, applying to, 255, 274–277
worksheet, applying to, 106–107

subgalleries, 11
subtotals, summarizing data by using, 230–231
subtraction operator (-), 4, 121
Sum button, 5, 130–131
SUM function, 124, 128–129, 130, 131, 233. See also 

AutoSum feature
summarizing data, 230–231
surface chart, defined, 247
symbol, inserting, 34–35

T
tab, Ribbon, 14–15
tab, worksheet

coloring, 160–161
defined, 26
hiding and unhiding, 168–169
removing color from, 161
renaming, 147

table, Excel. See also data table
adding record to, 227
assigning name to table data, 73
comparison with data table, 228
converting

back to range, 226
range to, 226–227

defined, 226
formatting tabular data, 107
in spreadsheet, described, 5

tabular data, formatting, 102, 107
taskbar, Windows 7, adding Excel icon to, 7, 22
template

creating
new template, 175
new workbook from, 174–175
new worksheet from, 149

saving chart as, 257
text. See also WordArt

adding
to shape, 281
to SmartArt graphic, 289

aligning within cell, 90–91
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header to printout, 198–199, 205
worksheet template to, 149

adjusting margins, 204–205
applying theme to, 196–197
centering pages for printing, 205
changing

color scheme, 190–191
font scheme, 192–193

choosing effect scheme, 194–195
closing, 186–187
collaborating on, 306–325
copying worksheets within, 152, 153
creating

based on existing workbook, 175
new, blank, 172–173
PDF to attach to e-mail, 319
from template, 174–175

defined, 26, 170
deleting worksheet, 154–155
formatting, 188–201
hiding and unhiding worksheet, 168–169
moving worksheet within, 150, 151
multiple

arranging windows for viewing, 178–179
copying range between, 49
copying worksheet between, 153
moving range between, 49
moving worksheet between, 151
navigating between by using range name, 75

navigating between worksheets, 149
new, blank, creating, 172–173
online collaboration using Windows Live SkyDrive, 

324–325
opening, 177
printing, 216–217
protecting structure and windows, 310–311
referencing range between, 135
replacing worksheet text, 182–183
saving, 176, 187

data as Web page, 320–321
in format compatible with earlier Excel version, 

322–323
searching for text, 181
sending as e-mail attachment, 318–319
setting up for printing, 204–215
sharing with other users, 312–313
tracking changes, 314–317
window elements, 8, 26
worksheet tabs, 14–15, 26, 147, 160–161, 168–169

U
undoing

cell edit, 37
data deletion, 39, 55
picture formatting, 295
worksheet deletion, 55, 154

unfreezing row or column, 60–61
unhiding

hidden row or column, 59
hidden worksheet, 169

user name, in Excel, changing, 307

V
validation. See data validation rules
value axis, 246
vertical panes, splitting worksheet into, 167

W
Web page, saving Excel data as, 320–321
Webdings font, 35
what-if analysis, 229, 236
window, Excel

basic elements, 8
vs. Full Screen view, 19
view options, 18–19
viewing multiple workbooks within, 178–179
worksheet elements, 26

Windows 7
adding Excel icon to taskbar, 7, 22
starting Excel, 6–7

Windows Live
collaborating on workbooks online, 324–325
saving Excel workbooks to SkyDrive, 321

Wingdings font, 35
win/loss sparkline, defined, 262
WordArt

applying style to chart text, 276–277
customizing style, 277
image, defined, 286
inserting image in worksheet, 286–287
moving image on worksheet, 290, 291
resizing image on worksheet, 290, 291
rotating image on worksheet, 291

workbooks. See also worksheets
adding

blank worksheet to, 148–149
footer to printout, 200–201, 205
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Index
photo, 284–285
SmartArt graphic, 288–289
WordArt image, 286–287

moving
range between, 49
within a workbook, 150, 151
between workbooks, 151

navigating between, 149
navigating within by using range name, 74–75
new, creating, 148–149
overview, 2, 4–5
page break, 19, 207
protecting data, 308–309
recoloring image, 302–303
referencing range between, 134–135
renaming, 147
replacing text, 182–183
rotating text within cell, 94–95
saving data as Web page, 320–321
searching for text, 180–181
selecting

all cells, 43
range of cells, 42–43

setting area to print, 210–211
sorting range, 220–221
splitting into panes, 166–167
tabs, 14–15, 26, 147, 160–161, 168–169
toggling headings A-Z and 1, 2, etc. on and off, 159
transposing rows and columns, 64–65
troubleshooting formula result, 142–143
zooming in and out, 164–165

wrapping text within cell, 112–113

X
XY charts, defined, 247

Z
zooming in and out, 164–165

worksheets. See also workbooks
adding

artistic effect to photo, 300–301
background color, 96–97
chart to, 5, 248–249
graphic object to, 278–301
header to printout, 198–199, 205
image to background, 162–163
row or column to, 50–51
template to workbook, 149

aligning text within cells, 90–91
applying style, 106–107
centering text across multiple columns, 63, 92–93
changing

column width, 108–109
font and font characteristics, 84–87
row height, 110–111

checking spelling, 184–185
collaborating on, 306–325
copying

range between, 49
within a workbook, 152, 153
between workbooks, 153

defined, 2, 8, 26
deleting from workbook, 154–155
drawing shape on, 280–281
editing cell data, 4, 36–37
entering data into cell, 4, 28–33
filtering data, 222–223
fitting onto single page, 209
formatting overview, 188–201
freezing row or column, 60–61
gridlines on, 156–157, 158
grouping related data, 232–233
hiding and unhiding, 168–169
hiding row or column, 58–59
inserting

clip art image, 282–283
new cell into existing range, 52–53
new row or column, 50–51
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