
US $ 34.99

Shelve in
Applications/MS Excel

User level:
Beginning–Advanced

www.apress.com

BOOKS FOR PROFESSIONALS BY PROFESSIONALS®

Guy Hart-Davis

Hart-Davis
Learn Excel 2016 for OS X

Learn

Excel 2016
for OS X

Master data management, analysis, and 
presentation with Excel 2016

9 781484 210208

53499
ISBN 978-1-4842-1020-8

Microsoft Excel 2016 for OS X is a powerful application, but many of 
its most impressive features can be difficult to find. Learn Excel 2016 

for OS X is a practical, hands-on approach to learning all the details of 
Excel 2016 in order to get work done efficiently on OS X. From using 
formulas and functions to creating databases, from analyzing data to 
automating tasks, you’ll learn everything you need to know to put this 
powerful application to use for a variety of tasks.

• How to create effective workbooks and templates

• How to quickly format worksheets

• How to perform custom calculations and formulas

• How to build persuasive charts

• How to illustrate your worksheets with SmartArt, 
pictures, and more

• Ways to solve business problems using Excel

• How to analyze data with pivot tables

• How to edit workbooks with your colleagues and share 
data with Windows users

www.allitebooks.com

http://www.allitebooks.org


Learn Excel 2016  
for OS X

Second Edition

Guy Hart-Davis

www.allitebooks.com

http://www.allitebooks.org


Learn Excel 2016 for OS X

Copyright © 2015 by Guy Hart-Davis

This work is subject to copyright. All rights are reserved by the Publisher, whether the whole or part of the 
material is concerned, specifically the rights of translation, reprinting, reuse of illustrations, recitation, 
broadcasting, reproduction on microfilms or in any other physical way, and transmission or information 
storage and retrieval, electronic adaptation, computer software, or by similar or dissimilar methodology now 
known or hereafter developed. Exempted from this legal reservation are brief excerpts in connection with 
reviews or scholarly analysis or material supplied specifically for the purpose of being entered and executed 
on a computer system, for exclusive use by the purchaser of the work. Duplication of this publication or 
parts thereof is permitted only under the provisions of the Copyright Law of the Publisher’s location, in its 
current version, and permission for use must always be obtained from Springer. Permissions for use may be 
obtained through RightsLink at the Copyright Clearance Center. Violations are liable to prosecution under 
the respective Copyright Law.

ISBN-13 (pbk): 978-1-4842-1020-8

ISBN-13 (electronic): 978-1-4842-1019-2

Trademarked names, logos, and images may appear in this book. Rather than use a trademark symbol with 
every occurrence of a trademarked name, logo, or image we use the names, logos, and images only in an  
editorial fashion and to the benefit of the trademark owner, with no intention of infringement of the 
 trademark.

The use in this publication of trade names, trademarks, service marks, and similar terms, even if they are  
not identified as such, is not to be taken as an expression of opinion as to whether or not they are subject to 
proprietary rights.

While the advice and information in this book are believed to be true and accurate at the date of publication, 
neither the authors nor the editors nor the publisher can accept any legal responsibility for any errors or 
omissions that may be made. The publisher makes no warranty, express or implied, with respect to the  
material contained herein.

Managing Director: Welmoed Spahr
Lead Editor: Michelle Lowman
Technical Reviewer: Michael Thomas
Editorial Board: Steve Anglin, Louise Corrigan, Jonathan Gennick, Robert Hutchinson,  

Michelle Lowman, James Markham, Susan McDermott, Matthew Moodie, Jeffrey Pepper,  
Douglas Pundick, Ben Renow-Clarke, Gwenan Spearing, Steve Weiss

Coordinating Editor: Mark Powers
Copy Editor: William McManus
Compositor: SPi Global
Indexer: SPi Global
Artist: SPi Global

Distributed to the book trade worldwide by Springer Science+Business Media New York, 233 Spring Street,  
6th Floor, New York, NY 10013. Phone 1-800-SPRINGER, fax (201) 348-4505, e-mail orders-ny@springer-sbm.com, 
or visit www.springeronline.com. Apress Media, LLC is a California LLC and the sole member (owner) is Springer 
Science + Business Media Finance Inc (SSBM Finance Inc). SSBM Finance Inc is a Delaware corporation. 

For information on translations, please e-mail rights@apress.com, or visit www.apress.com. 

Apress and friends of ED books may be purchased in bulk for academic, corporate, or promotional use.  
eBook versions and licenses are also available for most titles. For more information, reference our Special 
Bulk Sales–eBook Licensing web page at www.apress.com/bulk-sales.

Any source code or other supplementary materials referenced by the author in this text is available to readers at 
www.apress.com/9781484210208. For detailed information about how to  locate your book’s source code, go to 
www.apress.com/source-code/. Readers can also access source code at  SpringerLink in the Supplementary  
Material section for each chapter. 

www.allitebooks.com

mailto:orders-ny@springer-sbm.com
www.springeronline.com
mailto:rights@apress.com
www.apress.com
www.apress.com/bulk-sales
www.apress.com/9781484210208
www.apress.com/source-code/
http://www.allitebooks.org


 

iii

Contents at a Glance

About the Author �����������������������������������������������������������������������������������������������������xv

About the Technical Reviewer �������������������������������������������������������������������������������xvii

Acknowledgments ��������������������������������������������������������������������������������������������������xix

Introduction ������������������������������������������������������������������������������������������������������������xxi

 ■Part I: Becoming Proficient with Excel for Mac ���������������������������������� 1

 ■Chapter 1: Learning the Secrets of the Excel for Mac Interface ���������������������������� 3

 ■Chapter 2: Configuring Excel to Suit the Way You Work �������������������������������������� 49

 ■Chapter 3: Creating Effective Workbooks and Templates ������������������������������������ 67

 ■Chapter 4: Formatting Your Worksheets Quickly and Efficiently ����������������������� 101

 ■Part II: Performing Calculations and Presenting Data �������������������� 143

 ■Chapter 5: Performing Custom Calculations with Formulas ����������������������������� 145

 ■Chapter 6: Using Excel’s Built-In Functions������������������������������������������������������� 167

 ■Chapter 7: Creating Clear and Persuasive Charts ���������������������������������������������� 207

 ■Chapter 8: Using Data Bars, Color Scales, Icon Sets, and Sparklines ��������������� 245

 ■Chapter 9: Illustrating Your Worksheets with Pictures, SmartArt, and More ���� 261

www.allitebooks.com

http://www.allitebooks.org


 
iv Contents at a Glance

 ■Part III: Analyzing Data and Sharing and Automating Workbooks ���� 283

 ■Chapter 10: Creating Databases Using Tables ��������������������������������������������������� 285

 ■ Chapter 11: Solving Business Questions with What-If Analysis,  
Goal Seek, and Solver ���������������������������������������������������������������������������������������� 305

 ■Chapter 12: Analyzing Data with PivotTables ���������������������������������������������������� 329

 ■Chapter 13: Collaborating and Sharing with Macs and Windows PCs �������������� 361

Index ��������������������������������������������������������������������������������������������������������������������� 391

www.allitebooks.com

http://www.allitebooks.org


 

v

Contents

About the Author �����������������������������������������������������������������������������������������������������xv

About the Technical Reviewer �������������������������������������������������������������������������������xvii

Acknowledgments ��������������������������������������������������������������������������������������������������xix

Introduction ������������������������������������������������������������������������������������������������������������xxi

 ■Part I: Becoming Proficient with Excel for Mac ���������������������������������� 1

 ■Chapter 1: Learning the Secrets of the Excel for Mac Interface ���������������������������� 3

Getting Ready to Learn Excel’s Secrets ���������������������������������������������������������������������������� 3

Three Ways to Control Excel ��������������������������������������������������������������������������������������������� 4

Secrets of the Ribbon ����������������������������������������������������������������������������������������������������������������������������� 5

Using the Menu Bar ������������������������������������������������������������������������������������������������������������������������������ 10

Driving Excel with Keyboard Shortcuts ������������������������������������������������������������������������������������������������ 10

Navigating Quickly Through Worksheets and Workbooks ���������������������������������������������� 11

Elements of the Excel User Interface ���������������������������������������������������������������������������������������������������� 12

Navigating Among Worksheets ������������������������������������������������������������������������������������������������������������� 14

Changing the Active Cell ����������������������������������������������������������������������������������������������������������������������� 14

Selecting and Manipulating Cells  �������������������������������������������������������������������������������������������������������� 15

Tools for Entering Text and Formulas Quickly ���������������������������������������������������������������� 17

Importing Data �������������������������������������������������������������������������������������������������������������������������������������� 17

Connecting a Worksheet to External Data Sources ������������������������������������������������������������������������������ 25

www.allitebooks.com

http://www.allitebooks.org


 
vi Contents

Entering Text Using AutoCorrect ����������������������������������������������������������������������������������������������������������� 25

Entering Text with AutoFill and Custom Lists ���������������������������������������������������������������������������������������� 28

Entering Text Using Copy, Paste, and Paste Options ����������������������������������������������������������������������������� 32

Entering Text with Find and Replace ���������������������������������������������������������������������������������������������������� 35

Inserting Symbols in a Document ��������������������������������������������������������������������������������������������������������� 37

Viewing Your Workbooks ������������������������������������������������������������������������������������������������ 39
Splitting the Window to View Separate Parts of a Worksheet �������������������������������������������������������������� 40

Opening Extra Windows to Show Other Parts of a Workbook ��������������������������������������������������������������� 42

Changing the Window and Arranging Open Windows ��������������������������������������������������������������������������� 42

Zooming to Show the Data You Need to See ���������������������������������������������������������������������������������������� 44

Freezing Rows and Columns So They Stay Onscreen ��������������������������������������������������������������������������� 44

Using Custom Views ������������������������������������������������������������������������������������������������������� 46

Summary ������������������������������������������������������������������������������������������������������������������������ 47

 ■Chapter 2: Configuring Excel to Suit the Way You Work �������������������������������������� 49

Opening the Excel Preferences Window ������������������������������������������������������������������������� 49

Controlling How the Excel Window Appears ������������������������������������������������������������������� 51
Choosing Options in the Show in Workbook Area  
of View Preferences ������������������������������������������������������������������������������������������������������������������������������ 53

Choosing How to Display Comments ���������������������������������������������������������������������������������������������������� 54

Choosing How to Display Objects ��������������������������������������������������������������������������������������������������������� 55

Choosing Ribbon Options ���������������������������������������������������������������������������������������������������������������������� 55

Choosing Editing Options ����������������������������������������������������������������������������������������������� 56
Choosing Options in the Edit Options Area ������������������������������������������������������������������������������������������� 56

Choosing Options in the Cut and Paste Options Area ��������������������������������������������������������������������������� 57

Choosing Options in the Date Options Area ������������������������������������������������������������������������������������������ 58

Setting Preferences for Creating and Saving Your Workbooks ��������������������������������������� 58
Creating Workbooks with the Number of Worksheets You Need ���������������������������������������������������������� 59

Choosing the Default Format for Saving Workbooks ���������������������������������������������������������������������������� 59

Setting AutoRecover to Keep Backups of Your Workbooks for Safety �������������������������������������������������� 60

Making Excel Prompt You to Enter Workbook Properties ��������������������������������������������������������������������� 62

Creating Custom Keyboard Shortcuts ���������������������������������������������������������������������������� 62

Opening One or More Workbooks Automatically with Excel ������������������������������������������� 64

Summary ������������������������������������������������������������������������������������������������������������������������ 65

www.allitebooks.com

http://www.allitebooks.org


 
viiContents

 ■Chapter 3: Creating Effective Workbooks and Templates ������������������������������������ 67

Creating Workbooks from Scratch or from Templates ���������������������������������������������������� 67

Creating a New Blank Workbook ���������������������������������������������������������������������������������������������������������� 68

Creating a New Workbook Based on a Template ���������������������������������������������������������������������������������� 69

Creating a New Workbook Based on an Existing Workbook ����������������������������������������������������������������� 69

Saving a Workbook ������������������������������������������������������������������������������������������������������������������������������� 70

Protecting a Workbook with Passwords  ���������������������������������������������������������������������������������������������� 70

Entering Workbook Properties �������������������������������������������������������������������������������������������������������������� 73

Finding Your Workbooks by Using Properties ��������������������������������������������������������������������������������������� 77

Saving Your Workbooks for Use with Older Versions of Excel ���������������������������������������� 80

Organizing the Worksheets in a Workbook ��������������������������������������������������������������������� 81

Inserting a New Worksheet ������������������������������������������������������������������������������������������������������������������� 82

Naming a Worksheet ���������������������������������������������������������������������������������������������������������������������������� 82

Changing a Worksheet’s Tab Color ������������������������������������������������������������������������������������������������������� 82

Deleting a Worksheet ���������������������������������������������������������������������������������������������������������������������������� 82

Rearranging the Worksheets in a Workbook ����������������������������������������������������������������������������������������� 83

Four Easy Rules for Laying Out Your Worksheets ����������������������������������������������������������� 84

Entering Data on Multiple Worksheets at Once �������������������������������������������������������������� 85

Identifying Parts with Named Ranges ���������������������������������������������������������������������������� 86

Assigning a Name to a Cell or Range ��������������������������������������������������������������������������������������������������� 86

Creating Range Names Automatically  ������������������������������������������������������������������������������������������������� 88

Using a Range Name in Your Formulas������������������������������������������������������������������������������������������������� 89

Deleting a Range Name  ����������������������������������������������������������������������������������������������������������������������� 90

Changing the Cell or Range a Name Refers To ������������������������������������������������������������������������������������� 91

Creating a Collapsible Worksheet by Outlining It ������������������������������������������������������������ 91

Having Excel Create an Outline Automatically �������������������������������������������������������������������������������������� 92

Changing the Settings for Outlining  ����������������������������������������������������������������������������������������������������� 94

Creating an Outline Manually ��������������������������������������������������������������������������������������������������������������� 95

Expanding and Collapsing an Outline ��������������������������������������������������������������������������������������������������� 96

Updating the Outline After Adding or Deleting Rows or Columns ��������������������������������������������������������� 96

Removing an Outline ���������������������������������������������������������������������������������������������������������������������������� 97

www.allitebooks.com

http://www.allitebooks.org


 
viii Contents

Making the Most of Templates  �������������������������������������������������������������������������������������� 97

Creating a Template Based on an Existing Workbook ��������������������������������������������������������������������������� 98

Saving a Template �������������������������������������������������������������������������������������������������������������������������������� 98

Summary ������������������������������������������������������������������������������������������������������������������������ 99

 ■Chapter 4: Formatting Your Worksheets Quickly and Efficiently ����������������������� 101

Working with Rows and Columns ��������������������������������������������������������������������������������� 101

Inserting and Deleting Rows, Columns, and Cells ������������������������������������������������������������������������������ 101

Setting Row Height ����������������������������������������������������������������������������������������������������������������������������� 104

Setting Column Width ������������������������������������������������������������������������������������������������������������������������� 105

Hiding Rows and Columns ������������������������������������������������������������������������������������������������������������������ 106

Formatting Cells and Ranges ��������������������������������������������������������������������������������������� 107

Understanding the Two Main Tools for Applying Formatting��������������������������������������������������������������� 107

Controlling How Data Appears by Applying Number Formatting �������������������������������������������������������� 109

Setting the Workbook’s Overall Look by Applying a Theme ���������������������������������������������������������������� 116

Choosing How to Align Cell Contents �������������������������������������������������������������������������������������������������� 117

Choosing Font Formatting ������������������������������������������������������������������������������������������������������������������ 118

Applying Borders and Fills ������������������������������������������������������������������������������������������������������������������ 119

Applying Protection to Cells ���������������������������������������������������������������������������������������������������������������� 122

Using Paste Special to Paste Formatting and Perform Actions ������������������������������������ 122

Identifying Unusual Values with Conditional Formatting ���������������������������������������������� 124

Understanding Excel’s Preset Types of Conditional Formatting ���������������������������������������������������������� 125

Applying a Preset Form of Conditional Formatting ����������������������������������������������������������������������������� 126

Creating Custom Conditional Formatting �������������������������������������������������������������������������������������������� 127

Changing the Order in Which Excel Applies Conditional Formatting Rules ����������������������������������������� 128

Clearing Conditional Formatting from a Cell, Range, or Worksheet ���������������������������������������������������� 130

Checking Input with Data Validation ����������������������������������������������������������������������������� 130

Formatting Quickly with Table Formatting and Styles �������������������������������������������������� 135

Formatting with Table Formatting ������������������������������������������������������������������������������������������������������ 135

Formatting with Styles ����������������������������������������������������������������������������������������������������������������������� 135

Adding Headers and Footers to Your Worksheets �������������������������������������������������������� 140

Summary ���������������������������������������������������������������������������������������������������������������������� 142

www.allitebooks.com

http://www.allitebooks.org


 
ixContents

 ■Part II: Performing Calculations and Presenting Data �������������������� 143

 ■Chapter 5: Performing Custom Calculations with Formulas ����������������������������� 145

Understanding the Difference between Formulas and Functions �������������������������������� 146

Referring to Cells and Ranges in Formulas and Functions ������������������������������������������ 146

Referring to a Cell ������������������������������������������������������������������������������������������������������������������������������� 146

Referring to a Range ��������������������������������������������������������������������������������������������������������������������������� 148

Making One Row or Column Refer to another Row or Column ����������������������������������������������������������� 148

Referring to Named Cells and Ranges ������������������������������������������������������������������������������������������������ 149

Understanding the Components of Formulas ��������������������������������������������������������������� 149

Meet Excel’s Calculation Operators ���������������������������������������������������������������������������������������������������� 149

Creating Straightforward Formulas ������������������������������������������������������������������������������ 151

Creating Complex Formulas ����������������������������������������������������������������������������������������� 154

Understanding the Order in Which Excel Evaluates Operators ����������������������������������������������������������� 154

Nesting Parts of a Formula to Control Operator Precedence �������������������������������������������������������������� 155

Breaking up a Complex Formula into Separate Steps ������������������������������������������������������������������������ 156

Entering Formulas Quickly by Copying and Using AutoFill ������������������������������������������� 156

Choosing Preferences for Error Checking �������������������������������������������������������������������� 157

Troubleshooting Common Problems with Formulas ����������������������������������������������������� 160

Summary ���������������������������������������������������������������������������������������������������������������������� 165

 ■Chapter 6: Using Excel’s Built-In Functions������������������������������������������������������� 167

Understanding the Components of a Function ������������������������������������������������������������� 167

Entering Functions in Your Worksheets ������������������������������������������������������������������������ 168

Inserting Functions with the AutoSum Pop-up Menu ������������������������������������������������������������������������� 169

Inserting Functions with the Formula Builder ������������������������������������������������������������������������������������ 170

Inserting Functions with the Function Library Pop-up Menus ������������������������������������������������������������ 174

Inserting Functions by Typing Them into a Worksheet ����������������������������������������������������������������������� 175

Nesting One Function inside Another Function ������������������������������������������������������������ 176

Meeting Excel’s Built-in Functions ������������������������������������������������������������������������������� 177

Database Functions ���������������������������������������������������������������������������������������������������������������������������� 178

Date and Time Functions �������������������������������������������������������������������������������������������������������������������� 178

www.allitebooks.com

http://www.allitebooks.org


 
x Contents

Engineering Functions ������������������������������������������������������������������������������������������������������������������������ 181

Financial Functions����������������������������������������������������������������������������������������������������������������������������� 184

Logical Functions �������������������������������������������������������������������������������������������������������������������������������� 191

Information Functions ������������������������������������������������������������������������������������������������������������������������� 192

Lookup and Reference Functions ������������������������������������������������������������������������������������������������������� 194

Mathematical and Trigonometric Functions ��������������������������������������������������������������������������������������� 195

Statistical Functions ��������������������������������������������������������������������������������������������������������������������������� 198

Text Functions������������������������������������������������������������������������������������������������������������������������������������� 199

Cube Functions ����������������������������������������������������������������������������������������������������������������������������������� 202

Choosing the Right Calculation Preferences  
for Your Needs �������������������������������������������������������������������������������������������������������������� 203

Choosing When to Calculate Worksheets ������������������������������������������������������������������������������������������� 204

Controlling Iteration of Calculations ��������������������������������������������������������������������������������������������������� 204

Choosing Workbook Options ��������������������������������������������������������������������������������������������������������������� 205

Summary ���������������������������������������������������������������������������������������������������������������������� 205

 ■Chapter 7: Creating Clear and Persuasive Charts ���������������������������������������������� 207

Learning the Essentials of Charts in Excel ������������������������������������������������������������������� 207

Understanding Embedded Charts and Chart Sheets �������������������������������������������������������������������������� 207

Understanding the Components of a Chart ����������������������������������������������������������������������������������������� 209

Choosing the Best Chart Type for Your Data ����������������������������������������������������������������� 212

Creating, Laying Out, and Formatting a Chart �������������������������������������������������������������� 213

Creating a Chart ���������������������������������������������������������������������������������������������������������������������������������� 214

Changing a Chart from an Embedded Chart to a Chart Sheet ������������������������������������������������������������ 215

Changing the Chart Type ��������������������������������������������������������������������������������������������������������������������� 216

Switching the Rows and Columns in a Chart �������������������������������������������������������������������������������������� 216

Changing the Source Data for a Chart ������������������������������������������������������������������������������������������������ 216

Choosing the Layout for the Chart ������������������������������������������������������������������������������������������������������ 218

Adding a Separate Data Series to a Chart ������������������������������������������������������������������������������������������ 219

Applying a Style to a Chart ����������������������������������������������������������������������������������������������������������������� 219

Adding a Title to a Chart ��������������������������������������������������������������������������������������������������������������������� 220

Adding Axis Titles to the Chart ������������������������������������������������������������������������������������������������������������ 222

Changing the Scale or Numbering of an Axis ������������������������������������������������������������������������������������� 222



 
xiContents

Adding a Legend to a Chart ���������������������������������������������������������������������������������������������������������������� 228

Adding Axis Labels from a Range Separate from the Chart Data ������������������������������������������������������� 229

Adding Data Labels to the Chart ��������������������������������������������������������������������������������������������������������� 229

Choosing Which Gridlines to Display �������������������������������������������������������������������������������������������������� 231

Formatting a Chart Wall and Chart Floor �������������������������������������������������������������������������������������������� 232

Formatting Individual Chart Elements ������������������������������������������������������������������������������������������������ 235

Copying a Chart’s Formatting to Another Chart ������������������������������������������������������������ 236

Reusing Your Own Designs by Creating Custom Chart Types ��������������������������������������� 237

Controlling Which Chart ScreenTips Excel Displays ����������������������������������������������������� 238

Using Your Charts in Word Documents and PowerPoint Presentations ������������������������ 238

Understanding How You Can Add a Chart to a Document or Slide������������������������������������������������������ 238

Summary ���������������������������������������������������������������������������������������������������������������������� 243

 ■Chapter 8: Using Data Bars, Color Scales, Icon Sets, and Sparklines ��������������� 245

Using Data Bars ������������������������������������������������������������������������������������������������������������ 245

Creating Data Bars ������������������������������������������������������������������������������������������������������������������������������ 246

Using Color Scales ������������������������������������������������������������������������������������������������������� 250

Representing Data Graphically with Icon Sets ������������������������������������������������������������� 252

Showing Data Trends with Sparklines �������������������������������������������������������������������������� 256

Inserting Sparklines ���������������������������������������������������������������������������������������������������������������������������� 257

Formatting Your Sparklines ���������������������������������������������������������������������������������������������������������������� 257

Summary ���������������������������������������������������������������������������������������������������������������������� 260

 ■Chapter 9: Illustrating Your Worksheets with Pictures, SmartArt, and More ���� 261

Inserting Pictures in Your Workbooks ��������������������������������������������������������������������������� 262

Inserting Pictures from the Photos App ���������������������������������������������������������������������������������������������� 262

Inserting Pictures from Your Mac’s File System ��������������������������������������������������������������������������������� 263

Adding and Formatting a Shape ����������������������������������������������������������������������������������� 264

Applying a Style to a Shape ���������������������������������������������������������������������������������������������������������������� 266

Rotating a Graphical Object ������������������������������������������������������������������������������������������ 268

Positioning a Graphical Object ������������������������������������������������������������������������������������� 269

Making a Picture Look the Way You Want It ����������������������������������������������������������������� 270



 
xii Contents

Adjusting a Picture’s Sharpness, Brightness, Contrast, and Colors ���������������������������������������������������� 270

Applying a Picture Style ���������������������������������������������������������������������������������������������������������������������� 271

Cropping a Picture ������������������������������������������������������������������������������������������������������������������������������ 271

Saving Space by Compressing Pictures ��������������������������������������������������������������������������������������������� 273

Inserting SmartArt Diagrams ���������������������������������������������������������������������������������������� 274

Adding Decorative Text with WordArt ��������������������������������������������������������������������������� 277

Positioning Graphical Objects Relative to Cells ������������������������������������������������������������ 279

Arranging Graphical Objects to Control Which Is Visible ���������������������������������������������� 281

Summary ���������������������������������������������������������������������������������������������������������������������� 281

 ■Part III: Analyzing Data and Sharing and Automating Workbooks ����283

 ■Chapter 10: Creating Databases Using Tables ��������������������������������������������������� 285

Creating Databases in Excel ����������������������������������������������������������������������������������������� 285

Understanding What You Can and Can’t Do with Excel Tables ������������������������������������������������������������ 285

Creating a Table and Entering Data ���������������������������������������������������������������������������������������������������� 287

Connecting a Table to an External Data Source ���������������������������������������������������������������������������������� 291

Connecting to a Database ������������������������������������������������������������������������������������������������������������������� 292

Importing Data from a FileMaker Pro Database ��������������������������������������������������������������������������������� 296

Resizing a Table ���������������������������������������������������������������������������������������������������������������������������������� 296

Sorting a Table by One or More Fields ������������������������������������������������������������������������������������������������ 297

Identifying and Removing Duplicate Records in a Table ��������������������������������������������������������������������� 299

Filtering a Table ���������������������������������������������������������������������������������������������������������������������������������� 301

Using Database Functions with Tables ������������������������������������������������������������������������� 303

Summary ���������������������������������������������������������������������������������������������������������������������� 304

 ■ Chapter 11: Solving Business Questions with What-If Analysis,  
Goal Seek, and Solver ���������������������������������������������������������������������������������������� 305

Assessing the Impact of Variables Using Data Tables �������������������������������������������������� 305

Creating a Data Table with One Variable ��������������������������������������������������������������������������������������������� 306

Creating a Data Table with Two Variables ������������������������������������������������������������������������������������������� 309

Examining Different Scenarios in a Worksheet ������������������������������������������������������������ 311

Creating the Worksheet for Your Scenarios ���������������������������������������������������������������������������������������� 311

Opening the Scenario Manager Dialog Box ���������������������������������������������������������������������������������������� 313



 
xiiiContents

Creating Scenarios ����������������������������������������������������������������������������������������������������������������������������� 313

Applying Protection to Your Scenarios ������������������������������������������������������������������������������������������������ 316

Editing and Deleting Scenarios ����������������������������������������������������������������������������������������������������������� 317

Switching Among Your Scenarios ������������������������������������������������������������������������������������������������������� 317

Merging Scenarios into a Single Worksheet ��������������������������������������������������������������������������������������� 318

Creating Reports from Your Scenarios ������������������������������������������������������������������������������������������������ 319

Using Goal Seek ����������������������������������������������������������������������������������������������������������� 321

Solving Multiple-Variable Problems with Solver ���������������������������������������������������������� 323

Enabling the Solver Add-In ����������������������������������������������������������������������������������������������������������������� 323

Using Solver ���������������������������������������������������������������������������������������������������������������������������������������� 324

Summary ���������������������������������������������������������������������������������������������������������������������� 327

 ■Chapter 12: Analyzing Data with PivotTables ���������������������������������������������������� 329

Understanding What PivotTables Are and What You Can Do with Them ����������������������� 329

Creating and Laying Out a PivotTable ��������������������������������������������������������������������������� 331

Creating a PivotTable Automatically ��������������������������������������������������������������������������������������������������� 331

Creating a PivotTable Manually ���������������������������������������������������������������������������������������������������������� 333

Changing the PivotTable to Show Different Data �������������������������������������������������������������������������������� 340

Changing the Function Used to Summarize a Field ���������������������������������������������������������������������������� 344

Controlling the Design of a PivotTable �������������������������������������������������������������������������� 346

Formatting a PivotTable ������������������������������������������������������������������������������������������������ 348

Applying a PivotTable Style ����������������������������������������������������������������������������������������������������������������� 348

Choosing Options for a PivotTable Style ��������������������������������������������������������������������������������������������� 348

Naming a PivotTable and Setting Options for It ������������������������������������������������������������ 349

Renaming a PivotTable ����������������������������������������������������������������������������������������������������������������������� 350

Choosing Display Options for a PivotTable ����������������������������������������������������������������������������������������� 350

Choosing Layout Options for a PivotTable ������������������������������������������������������������������������������������������ 351

Choosing Data Options for a PivotTable ���������������������������������������������������������������������������������������������� 353

Refreshing the Data in a PivotTable ���������������������������������������������������������������������������������������������������� 355

Changing the Source of a PivotTable �������������������������������������������������������������������������������������������������� 355

Sorting and Filtering a PivotTable �������������������������������������������������������������������������������� 356

Summary ���������������������������������������������������������������������������������������������������������������������� 359



 
xiv Contents

 ■Chapter 13: Collaborating and Sharing with Macs and Windows PCs �������������� 361

Making Your Worksheets Print Correctly ���������������������������������������������������������������������� 361

Telling Excel Which Part of the Worksheet to Print ����������������������������������������������������������������������������� 362

Checking the Page Layout and Where the Page Breaks Fall �������������������������������������������������������������� 362

Printing a Worksheet or Workbook ����������������������������������������������������������������������������������������������������� 364

Sharing Your Worksheets as PDFs �������������������������������������������������������������������������������� 366

Exporting Data to CSV Files ������������������������������������������������������������������������������������������ 369

Documenting Your Workbooks �������������������������������������������������������������������������������������� 370

Adding Explanatory Text to Workbooks ����������������������������������������������������������������������������������������������� 371

Adding Comments to Cells������������������������������������������������������������������������������������������������������������������ 371

Adding Information with Data Validation �������������������������������������������������������������������������������������������� 373

Sharing Your Workbooks with Your Colleagues ������������������������������������������������������������ 374

Protecting a Workbook or Some of Its Worksheets ����������������������������������������������������������������������������� 374

Tracking Changes to a Workbook ������������������������������������������������������������������������������������������������������� 377

Sharing a Workbook So That Your Colleagues Can Edit It ������������������������������������������������������������������� 379

Working in a Shared Workbook ���������������������������������������������������������������������������������������������������������� 381

Resolving Conflicts in a Shared Workbook ����������������������������������������������������������������������������������������� 382

Reviewing Tracked Changes in a Shared Workbook ��������������������������������������������������������������������������� 383

Merging Multiple Workbooks into a Single Workbook �������������������������������������������������� 384

Consolidating Multiple Worksheets into a Single Worksheet ��������������������������������������� 385

Preparing to Consolidate Worksheets ������������������������������������������������������������������������������������������������� 385

Consolidating Worksheets by Their Position ��������������������������������������������������������������������������������������� 385

Consolidating Worksheets by Category ���������������������������������������������������������������������������������������������� 388

Summary ���������������������������������������������������������������������������������������������������������������������� 389

Index ��������������������������������������������������������������������������������������������������������������������� 391



 

xv

About the Author

Guy Hart-Davis is the author of more than 100 computer books 
including Learn Microsoft Office 2011 for Mac OS X and Pro 
Office for iPad, both from Apress.



 

xvii

About the Technical 
Reviewer

Michael Thomas has worked in software development for more 
than 20 years as an individual contributor, team lead, program 
manager, and vice president of engineering. Michael has more 
than 10 years of experience working with mobile devices. His 
current focus is in the medical sector, using mobile devices to 
accelerate information transfer between patients and health  
care providers.



 

xix

Acknowledgments

My thanks go to the many people who helped create this book:

	Michelle Lowman for signing me to write the book.

	Jim Markham for developing the manuscript.

	Michael Thomas for reviewing the manuscript for technical accuracy and 
contributing helpful suggestions.

	Bill McManus for editing the manuscript with skill and care.

	Kevin Walter and Mark Powers for coordinating the book project and 
keeping things running.

	SPi Global, for for laying out the chapters of the book and creating  
the index.



 

xxi

Introduction

Do you need to get your work done with Excel—smoothly, confidently, and as quickly  
as possible?

If so, you’ve picked up the right book.

Who Is This Book For?
This book is designed to help beginning and intermediate users get up to speed quickly with 
Excel 2016 for Mac and immediately become productive with it.

If you need to learn to use Excel to accomplish everyday tasks, at work or at home, you’ll 
benefit from this book’s focused approach and detailed advice. You can either start from 
the beginning of the book and work through the chapters in sequence, or use the Table of 
Contents or the Index to find the topic you need immediately, and then jump right in there.

What Does This Book Cover?
This book contains three parts that cover everything you need to know to use Excel 2016 
effectively.

Part 1, “Becoming Proficient with Excel for Mac,” makes sure you know essential moves for 
using Excel:

	Chapter 1, “Learning the Secrets of the Excel for Mac Interface,” 
teaches you the ins and outs of the three main means of controlling 
Excel: the Ribbon, the menus on the menu bar, and keyboard shortcuts. 
You grasp how to navigate through worksheets and workbooks; learn 
about quick ways of entering text in workbooks; and use splitting, 
freezing, and custom views to display exactly the items you need.

http://dx.doi.org/10.1007/978-1-4842-1019-2_1
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	Chapter 2, “Configuring Excel to Suit the Way You Work,” shows 
you how to make Excel work your way by setting the most important 
preferences and by creating custom keyboard shortcuts for menu  
items. You also learn how to open workbooks automatically when you 
launch Excel.

	Chapter 3, “Creating Effective Workbooks and Templates,” explains 
how to create workbooks in which you can enter, edit, and manipulate 
data quickly and effectively. You learn which file formats to save the 
workbooks in, how to add property information to help you identify 
workbooks when searching, and how to make the most of templates—
including creating templates of your own. You also learn how to organize 
worksheets, lay data out effectively, define named ranges to make 
navigation easier, and create a collapsible worksheet.

	Chapter 4, “Formatting Your Worksheets Quickly and Efficiently,” 
shows you how to format worksheets quickly and efficiently using the 
various tools that Excel provides. We start with formatting rows and 
columns—everything from changing column width and row height to 
inserting and deleting rows and columns and hiding sensitive data. Then 
we go through how to apply straightforward formatting, how to apply 
conditional formatting to quickly flag values that need attention, and 
how to use data validation to check for invalid entries. Finally, we cover 
how to save time by using table formatting or Excel’s styles, and how to 
add headers and footers to worksheets.

Part 2, “Performing Calculations and Presenting Data,” gets you up to speed with formulas, 
functions, charts, and graphical elements such as pictures and sparklines:

	Chapter 5, “Performing Custom Calculations with Formulas,” makes 
sure you know what formulas and functions are, and what the difference 
between the two is. This chapter then teaches you how to create 
your own formulas using Excel’s calculation operators, starting with 
straightforward formulas that use a single calculation operator each, and 
then moving on to more complex formulas that use multiple calculation 
operators. You also learn how to override Excel’s default order for 
evaluating operators and how to troubleshoot common problems that 
occur with formulas.

	Chapter 6, “Using Excel’s Built-In Functions,” explains how to insert 
functions in your worksheets using the various tools that Excel provides, 
find the functions you want, and point the functions to the data they 
need for the calculations. The second part of the chapter reviews Excel’s 
different categories of functions, such as database functions, logical 
functions, and math and trigonometric functions, and gives examples of 
how to use widely used functions.

www.allitebooks.com

http://dx.doi.org/10.1007/978-1-4842-1019-2_2
http://dx.doi.org/10.1007/978-1-4842-1019-2_3
http://dx.doi.org/10.1007/978-1-4842-1019-2_4
http://dx.doi.org/10.1007/978-1-4842-1019-2_5
http://dx.doi.org/10.1007/978-1-4842-1019-2_6
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	Chapter 7, “Creating Clear and Persuasive Charts,” teaches you how 
to present data clearly and persuasively using Excel’s wide range of 
charts. You learn the different ways you can place charts in worksheets, 
the components of charts, and the types of charts you can use. We then 
dig into how you create a chart from your data, lay it out the way you 
want, and then give it the look it needs. We also look at ways of reusing 
the custom charts you create and ways of using Excel charts in Word 
documents or PowerPoint presentations.

	Chapter 8, “Using Data Bars, Color Scales, Icon Sets, and Sparklines,” 
shows you how to add visual appeal to your worksheets by using those 
four types of single-cell graphical elements. You quickly get the hang 
of using data bars to compare the values in a range of cells, adding 
color scales to adjust the background colors of cells to provide a visual 
reference to their values, and using icon sets to provide quick visual 
reference to performance. And you learn to create single-cell charts 
using sparklines.

	Chapter 9, “Illustrating Your Worksheets with Pictures, SmartArt, and 
More,” explains ways of giving your workbooks visual interest by adding 
graphics, shapes, SmartArt diagrams, and WordArt items. You learn how 
to make a picture look the way you want it, how to position graphical 
objects wherever you need them, and how to position graphical items 
relative to cells and how to arrange graphical objects to control which 
ones are visible.

Part 3, “Analyzing Data and Sharing and Automating Your Workbooks,” shows you how to 
analyze, manipulate, and share the workbooks you’ve built:

	Chapter 10, “Creating Databases Using Tables,” covers using Excel’s 
tables to create databases for storing information, sorting it, and filtering 
it to find the records you need. You also learn how to put Excel’s 
database functions to work with tables.

	Chapter 11, “Solving Business Questions with What-If Analysis, Goal 
Seek, and Solver,” teaches you how to analyze your data using four 
powerful tools. You learn to use data tables to assess the impact of 
one or two variables on a calculation and how to use scenarios to 
experiment with different sets of values without changing your core 
data. You also learn to use Goal Seek to solve single-variable problems 
and Solver to crack multi-variable problems.

	Chapter 12, “Analyzing Data with PivotTables,” explains what 
PivotTables are and how you can use them to examine the data in your 
worksheets and find the secrets it contains. You learn how to create 
PivotTables either using Excel’s automated tool or by placing fields 
manually where you need them, how to change the PivotTable once 
you’ve created it, and how to sort and filter the data it contains.

http://dx.doi.org/10.1007/978-1-4842-1019-2_7
http://dx.doi.org/10.1007/978-1-4842-1019-2_8
http://dx.doi.org/10.1007/978-1-4842-1019-2_9
http://dx.doi.org/10.1007/978-1-4842-1019-2_10
http://dx.doi.org/10.1007/978-1-4842-1019-2_11
http://dx.doi.org/10.1007/978-1-4842-1019-2_12
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	Chapter 13, “Collaborating and Sharing with Macs and Windows 
PCs,” takes you through ways of sharing your workbooks with others. 
We start by covering how to print worksheets, create PDF files from 
them, and export data to comma-separated values files. We then 
move on to sharing workbooks so that multiple people can work on 
them at the same time, tracking the changes if necessary so that you 
can review them. We finish by looking at how to merge changes from 
separate copies of the same workbook into one workbook and how to 
consolidate multiple worksheets into a single worksheet.

Conventions Used in This Book 
This book uses several conventions to make its meaning clear without wasting words:

	Ribbon commands. The ➤ arrow shows the sequence for choosing 
an item from the Ribbon. For example, “choose Page Layout ➤ Page 
Setup ➤ Print Area ➤ Set Print Area” means that you click the Page 
Layout tab of the Ribbon (displaying the tab’s contents), go to the Page 
Setup group, and click the Print Area button (displaying a pop-up menu), 
and then click Set Print Area.

	Menu commands. The ➤ arrow shows the sequence of commands for 
choosing an item from the menu bar. For example, “choose Data ➤ 
Data Table” means that you open the Data menu and then click the 
Data Table item on it.

	Special paragraphs. Special paragraphs present information that you 
may want to pay extra attention to. Note paragraphs contain information 
you may want to know; Tip paragraphs present techniques you may 
benefit from using; and Caution paragraphs warn you of potential 
problems.

	Check boxes. Excel uses many check boxes—the square boxes that 
can either have a check mark in them (indicating that the option is 
turned on) or not (indicating that the option is turned off). This book tells 
you to “select” a check box when you need to put a check mark in the 
check box, and to “clear” a check box when you need to remove the 
check mark from it. If the check box is already selected or cleared, you 
don’t need to change it—just make sure it’s set the right way.

	Keyboard shortcuts. In Excel, you can often save time and effort by 
using a keyboard shortcut rather than a Ribbon command or a menu 
command. This book uses + signs to represent keyboard shortcuts. For 
example, “press Cmd+S” means that you hold down the Cmd key, press 
the S key, and then release the Cmd key. “Press Cmd+Option+T” means 
that you hold down the Cmd key and the Option key, press the T key, 
and then release the Cmd key and the Option key.

http://dx.doi.org/10.1007/978-1-4842-1019-2_13
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Part I
Becoming Proficient with 
Excel for Mac 

In this part of the book, you become proficient at the essentials of Excel for Mac.

In Chapter 1, you learn the ins and outs of the three main means of controlling Excel: the 
Ribbon, the menus, and keyboard shortcuts. You grasp how to navigate through worksheets 
and workbooks; learn about quick ways to enter text in workbooks; and use splitting, 
freezing, and custom views to display exactly the items you need.

In Chapter 2, we cover how to make Excel work your way by setting the most important 
preferences and by creating custom keyboard shortcuts as needed. You also learn how to 
open workbooks automatically when you launch Excel.

In Chapter 3, you study how to create workbooks in which you can enter, edit, and 
manipulate data quickly and effectively. You learn which file formats to save the workbooks 
in, how to add property information to help you identify workbooks when searching, and 
how to make the most of templates—including creating templates of your own. You also 
learn how to organize worksheets, lay out data effectively, define named ranges to make 
navigation easier, and create a collapsible worksheet.

In Chapter 4, we go through how to format worksheets quickly and efficiently using the 
various tools that Excel provides. We start with formatting rows and columns—everything 
from changing column width and row height to inserting and deleting rows and columns 
and hiding sensitive data. Then we see how to apply straightforward formatting, how to 
apply conditional formatting to quickly flag values that need attention, and how to use data 
validation to check for invalid entries. Finally, we cover how to save time by using table 
formatting and Excel’s styles, and how to add headers and footers to worksheets.

http://dx.doi.org/10.1007/978-1-4842-1019-2_1
http://dx.doi.org/10.1007/978-1-4842-1019-2_2
http://dx.doi.org/10.1007/978-1-4842-1019-2_3
http://dx.doi.org/10.1007/978-1-4842-1019-2_4
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Chapter 1
Learning the Secrets of the 
Excel for Mac Interface
In this chapter, you’ll learn the ins and outs of the Excel for Mac interface and the many 
secrets it holds.

We’ll start by looking at the three main ways to control Excel: the Ribbon, the menus on the 
menu bar, and keyboard shortcuts. These give you great flexibility in the way you control 
Excel, especially when you set them up as you prefer.

From there, we’ll discuss how to navigate through worksheets and workbooks. We’ll then 
go through the various ways in which you can get data into your Excel workbooks—from 
importing existing data to entering it more quickly using AutoCorrect, AutoFill, and even the 
Replace feature.

Toward the end of the chapter, I’ll show you the smart ways to view your workbooks so you 
can work quickly and efficiently. These include splitting the window to show different parts of 
the worksheet at the same time, opening extra windows, and freezing key rows and columns 
so that they stay onscreen when you scroll to other parts of the worksheet. You can even 
create custom views to keep your data laid out exactly as you need it.

Getting Ready to Learn Excel’s Secrets
You’ll probably want to have Excel running as you go through this chapter so you can try 
out the modifications and techniques that interest you. So launch Excel if it’s not already 
running: either click the Excel icon on the Dock or (if there isn’t one) click the Launchpad 
icon on the Dock to display the Launchpad screen, and then click the Excel icon on it.

When you launch Excel, the app may display the Microsoft Excel dialog box (see Figure 1-1),  
which enables you to connect to services such as OneDrive, create new documents, and 
open existing documents. If the Microsoft Excel dialog box does open, click the New tab in 
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the left column, click the Blank Workbook item, and then click the Create button. This makes 
Excel create a blank workbook rather than one based on a content template. We’ll look at 
how to use the Microsoft Excel dialog box, which is also called the Workbook Gallery, to 
create workbooks in Chapter 3.

Three Ways to Control Excel
To control Excel, you give commands. For example, when you need a new workbook, you 
give the command to create a new workbook.

In Excel 2016 (see Figure 1-2), you can give commands in three main ways:

	Menus. Like most Mac applications, Excel provides a set of menus that 
appear on the OS X menu bar when Excel is the active application. To 
give a command, you click the menu, and then click the command.

	Ribbon. The Ribbon is the main control strip in many Microsoft apps. To 
give a command, you click its button or control.

	Keyboard shortcuts. To give a command, you press the associated key 
combination.

 

Figure 1-1. If the Microsoft Excel dialog box opens when you launch Excel, click New in the left column, click Blank 
Workbook in the main section, and then click the Create button in the lower-right corner

http://dx.doi.org/10.1007/978-1-4842-1019-2_3
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Let’s dig into each of these in turn, starting with the Ribbon.

Secrets of the Ribbon
The Ribbon is the control strip that runs across the top of the Excel window below the 
window’s title bar. The Ribbon is a control bar that contains multiple tabs, each containing 
several groups of controls. At any time, the Ribbon displays one tab’s contents; to switch to 
the contents of another tab, you click that tab. As you can see in Figure 1-3, the active tab’s 
name and background appear in different colors than those of the other tabs, so you can 
easily pick it out. 

Figure 1-2. You can control Excel using the Ribbon, the menus on the menu bar, or keyboard shortcuts
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Understanding How the Ribbon’s Tabs Work
Most of the time, the Ribbon displays seven tabs that contain controls for most normal 
operations in Excel:

	Home. This tab contains controls for cut, copy, and paste; font, 
alignment, and number formatting; conditional formatting and styles; 
inserting and deleting rows, columns, and cells; and applying themes.

	Insert. This tab contains controls for inserting tables, illustrations, charts, 
sparklines (miniature charts that fit in a single cell), and slicers (a type 
of filters); comments (text attached to cells); text objects including text 
boxes, headers and footers, and WordArt decorative text; and symbol 
characters and equations.

	Page Layout. This tab contains controls for applying themes (overall 
looks), manipulating page setup, scaling the workbook to fit printed 
pages, and choosing whether to view and print gridlines and headings.

Note To make clear where you find the controls, I give Ribbon instructions in the sequence 
tab–group–control. For example, “choose Formulas ➤ Formula Auditing ➤ Trace Precedents” 
means that you click the Formulas tab to display its contents, go to the Audit Formulas group 
(without clicking it), and then click the Trace Precedents button. To follow these instructions easily, 
make sure Excel is displaying Ribbon groups. With Excel active, click Excel on the menu bar, 
and then click Preferences on the menu to open the Excel Preferences window. In the Authoring 
category, click the View icon to display the View preferences pane. In the section called “In Ribbon, 
Show,” select the Group Titles check box (placing a check in it). Then close the Excel Preferences 
window by clicking the Close button (the red button) at the left end of the window’s title bar.

Figure 1-3. The active tab of the Ribbon appears in a different color than the other tabs. Each tab contains groups of 
controls, such as buttons and pop-up menus
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	Formulas. This tab contains controls for inserting functions, working with 
named ranges, auditing formulas, and controlling how Excel performs 
calculations.

	Data. This tab contains controls for sorting and filtering data, creating 
PivotTables and performing what-if analysis, connecting to external 
data sources, validating data, and grouping and outlining worksheets. 
(Chapter 3 discusses grouping and outlining.)

	Review. This tab contains controls for checking spelling, working with 
comments, applying protection and change-tracking to a worksheet or 
workbook, and sharing a workbook.

	View. This tab contains controls for switching among workbook views; 
controlling whether the ruler, gridlines, the Formula bar, and headings 
appear on screen; zooming the window; freezing and splitting the 
window; and recording and running macros.

As well as these standard tabs, the Ribbon contains other tabs that it displays only when 
you need them. These are sometimes called context-sensitive tabs. For example, when you 
select a chart, Excel automatically displays the Chart Design tab and the Format tab (see 
Figure 1-4). 

Note In Office for Windows, the Ribbon replaces the menu bar and the toolbars completely, so 
you have to use the Ribbon unless you set up myriad keyboard shortcuts. By contrast, Office on the 
Mac still has the menus, and you can give a fair number of commands from them; in fact, some 
commands are available only from the menus, not via the Ribbon.

Figure 1-4. The Ribbon displays context-sensitive tabs when you select an object for which tabs are available. Here, 
the Chart Design tab and Format tab appear on the Ribbon because a chart is active

http://dx.doi.org/10.1007/978-1-4842-1019-2_3
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Understanding How the Ribbon’s Groups and Controls Work
Chances are you got the hang of using the Ribbon’s tabs the first time you used Excel. The 
groups and controls are a little trickier because they change depending on whether the Excel 
window is wide enough to display the entire Ribbon.

When the Excel window is wide enough, all the groups appear, and they display their 
controls—the buttons, pop-up menus, check boxes, and so on—in their most spacious 
arrangement. For example, the top part of Figure 1-5 shows the rightmost sections of the 
Home tab of the Ribbon. All the controls in (going from right to left) the Editing group, the 
Cells group, and the Styles group appear with labels, so you can easily identify each control; 
and the Styles group displays a wide panel of cell styles.

But when there’s less space, Excel gradually collapses parts of the Ribbon so as to display 
as much as possible in the available space. For example, the middle part of Figure 1-5 
shows the rightmost sections of the Home tab again, but this time the panel in the Styles 
group has gone, replaced by the Cell Styles pop-up menu.

When the window is even narrower, Excel collapses the groups and controls further. In the 
lower part of Figure 1-5, you can see that Excel has collapsed the Cells group to a single 
pop-up button that you can click to display a pop-up menu containing the buttons that 
previously appeared in it. Similarly, the Editing pop-up button replaces the Editing group, 
and the Number pop-up button replaces the Number group. The Styles group retains its 
three pop-up menus, but they now appear in a vertical stack instead of side by side.

Figure 1-5. As the Excel window becomes narrower, Excel hides first the labels for the less important controls and 
then the controls themselves, as you can see here with the controls on the right side of the Home tab of the Ribbon
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By automatically changing the Ribbon to suit the window width, Excel keeps as many 
controls as possible at the tip of your mouse. But because labels may not appear, you will 
sometimes need to display the ScreenTip to identify a control; to display the ScreenTip, hold 
the mouse pointer over the control for a moment (see Figure 1-6).

Figure 1-6. When a control’s label doesn’t appear on the Ribbon, hold the mouse pointer over the control to display a 
ScreenTip containing its name. When the Excel window is narrow, some Ribbon tabs display the arrow button shown on 
the right here, which you can click to display controls that are currently hidden

Figure 1-7. Click the Collapse Ribbon button to collapse the Ribbon to just its tabs. Click the Expand Ribbon button 
(which replaces the Collapse Ribbon button) to expand the Ribbon again

Further, because some controls may appear in different places when the Ribbon’s whole 
width isn’t displayed, you may sometimes need to hunt for the controls you need. This book 
assumes that the window is displayed wide enough for you to see all the controls on the 
Ribbon, but it notes some of the disappearing controls that can cause confusion.

If you can’t see a command that’s supposed to be there, have a poke around the remaining 
controls in the group to find where Excel has hidden the control, or to see if one of the 
controls opens a dialog box that contains the controls. (Or use the menu alternative if there 
is one.)

Collapsing the Ribbon
When you need more space to work on a worksheet, collapse the Ribbon to just its tab bar 
(see Figure 1-7) in one of these ways:

	Click the tab that’s currently active.

	Click the Collapse ribbon button (the ^ button) at the right end of the 
Ribbon.

	Choose View ➤ Ribbon from the menu bar (removing the check mark 
next to the Ribbon item).

	Press Cmd+Option+9. 

www.allitebooks.com
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As you’d guess, you use almost the same moves to display the Ribbon again:

	Click the tab you want to see.

	Click the Expand Ribbon button (the Ú button) at the right end of the 
Ribbon.

	Choose View ➤ Ribbon from the menu bar (placing a check mark on 
the Ribbon item).

	Press Cmd+Option+R.

Using the Menu Bar
If you’ve used other Mac applications, you probably know how to use the menu bar:

1. If the application for which you want to issue a command isn’t active, 
click one of the application’s windows to make it active. OS X then 
displays the application’s menus on the menu bar. For example, 
when Excel is active, you see its menus, with Excel’s own menu 
appearing at the left end of the menu bar.

2. Click the menu you want to open.

3. Click the command you want to give. Or, if the command is on a 
submenu, click or highlight the submenu item to display the 
submenu, then click the item. 

Driving Excel with Keyboard Shortcuts
If you like to work with the keyboard, spend some time learning Excel’s built-in keyboard 
shortcuts and creating custom shortcuts for other commands you want to be able to give 
from the keyboard.

For the commands you use often from the menu bar, you can quickly learn the keyboard 
shortcuts by opening the menus and looking at the shortcut keys shown to the right of the 
commands. The File menu (shown on the left in Figure 1-8) and the Edit menu (shown on the 
right in Figure 1-8) have the most keyboard shortcuts assigned at first.

Note An ellipsis (…) at the end of a menu command’s name usually indicates that the command 
displays a dialog box rather than taking an action. For example, the Close command on the File 
menu closes the active document, while the Save As… command displays the Save As dialog box. 
(The Save command also displays the Save As dialog box—but only if you’ve never saved this 
workbook before.)
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To find other keyboard shortcuts, click the Help menu on the menu bar to open it, type excel 
keyboard shortcuts in the Search box, and then click the Show All Help Topics topic that 
Excel offers. In the Excel Help window that opens, click the Keyboard Shortcuts in Excel 
2016 for Mac topic.

If you find that Excel doesn’t have a keyboard shortcut for a menu command, or that the 
existing keyboard shortcut is awkward to press or hard to remember, you can create your 
own shortcut. See the section “Creating Custom Keyboard Shortcuts” in Chapter 2 for 
instructions.

Navigating Quickly Through Worksheets and 
Workbooks
To work swiftly and easily in Excel, you need to know the best ways of navigating through 
worksheets and workbooks. We’ll look at these in this section—after we check that we’re 
using the same terms to refer to the elements in the Excel user interface.

Note Throughout the book, I’ll teach you the most widely useful keyboard shortcuts alongside the 
Ribbon and menu methods of giving commands.

Figure 1-8. You can quickly learn essential keyboard shortcuts by looking at the menus

http://dx.doi.org/10.1007/978-1-4842-1019-2_2
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Elements of the Excel User Interface
When you’ve created a new workbook or opened an existing one, Excel displays the 
workbook’s worksheets. Figure 1-9 shows Excel with a workbook open and the main 
elements of the user interface labeled. 

	Formula bar. This is the bar below the Ribbon. This area shows the data 
or formula in the active cell and gives you an easy place to enter and 
edit data.

	Reference area. This area appears at the left end of the Formula bar.  
It shows the active cell’s address (for example, A1) or the name you’ve 
given the cell so as to refer to it easily.

	Row headings. These are the numbers at the left side of the screen that 
identify each row. The first row is 1, the second row 2, and so on, up to 
the last row, 1048576.

Figure 1-9. The main elements of the Excel application window and a workbook
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	Column headings. These are the letters at the top of the worksheet grid 
that identify the columns. 

	The first column is A, the second column B, and so on up to Z.

	Excel then uses two letters: AA to AZ, BA to BZ, and so forth until ZZ.

	After that, Excel uses three letters: AAA, AAB, and so on up to the last 
column, XFD.

	Cells. These are the boxes formed by the intersections of the rows and 
columns. Each cell is identified by its column letter and row number. 
For example, the first cell in column A is cell A1 and the second cell in 
column B is cell B2. The last cell in the worksheet is XFD1048576.

	Active cell. This is the cell you’re working in—the cell that receives the 
input from the keyboard. Excel displays a green rectangle around the 
active cell.

	Select All button. Click this button at the intersection of the row 
headings and column headings to select all the cells in the worksheet.

	Worksheet tabs. Each worksheet has a tab at the bottom that bears its 
name. To display a worksheet, you click its tab in the worksheet tab bar. 

	Insert Sheet button. Click this button to insert a new worksheet after the 
active sheet.

	Scroll buttons. Click these buttons to scroll the worksheet tabs so you 
can see the ones you need. Click the leftmost button to scroll all the way 
back to the first tab, or click the rightmost button to scroll to the last tab. 
Click the two middle buttons to scroll back or forward by one tab.

	View buttons. Click these buttons to switch between Normal view 
and Page Layout view. You’ll learn how to use these views later in this 
chapter.

	Split boxes. You use these boxes when you need to split the worksheet 
window into two or four areas. You’ll learn how to do this in the section 
“Splitting the Window to View Separate Parts of a Worksheet” later in 
this chapter.

	Record Macro button. Click this button to start recording a macro. A 
macro is a sequence of commands that you can record to automate 
actions you need to take consistently.

	Zoom control. Drag the slider to zoom in or out on the worksheet. Click 
the – button to decrease the zoom by 10% increments. Click the + button  
to increase the zoom by 10% increments.
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Navigating Among Worksheets
Each workbook consists of one or more worksheets or other sheets, such as chart sheets 
or macro sheets. You can use as many worksheets as you need to separate your data 
conveniently within a single workbook file. For example, you can have a separate budget-
planning worksheet for each department in a single workbook file rather than having a 
separate workbook for each department.

To display the worksheet you want to use, click its tab in the worksheet tab bar (see 
Figure 1-10). If the worksheet’s tab isn’t visible in the worksheet tab bar, click the scroll 
buttons to display it (unless you’ve hidden the worksheet).  

Tip Cmd+click the Scroll tabs left button to scroll to the first tab in the workbook. Similarly, 
Cmd+click the Scroll tabs right button to scroll to the last tab in the workbook.

Tip You can quickly move to the next worksheet by pressing Cmd+Page Down or to the previous 
worksheet by pressing Cmd+Page Up.

Figure 1-10. Use the worksheet tab bar to display the worksheet you want or to insert a new worksheet

Changing the Active Cell
In Excel, you usually work in a single cell at a time. That cell is called the active cell and it 
receives the input from the keyboard.

You can move the active cell—in other words, change which cell is the active cell—easily 
using either the mouse or the keyboard:

	Mouse. Click the cell you want to make active.

	Keyboard. Press the arrow keys to move the active cell up or down by 
one row or left or right by one column at a time. You can also press the 
keyboard shortcuts shown in Table 1-1 to move the active cell further.
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Selecting and Manipulating Cells 
To work with a single cell, you need only click it or use the keyboard to make it the active 
cell. When you need to affect multiple cells at once, you select the cells using the mouse or 
keyboard.

Excel calls a selection of cells a range. A range can consist of either a rectangle of 
contiguous cells or two or more cells that aren’t next to each other. The left illustration in 
Figure 1-11 shows a range of contiguous cells, while the right illustration shows a range of 
separate cells.

Table 1-1. Keyboard Shortcuts for Changing the Active Cell

To Change the Active Cell Press This Keyboard Shortcut

To the first cell in the row Home

To the first cell in the active worksheet Cmd+Home

To the last cell used in the worksheet Cmd+End

Down one screen Page Down

Up one screen Page Up

Right one screen Option+Page Down

Left one screen Option+Page Up

To the last row in the worksheet Cmd+down arrow

To the last column in the worksheet Cmd+right arrow

To the first row in the worksheet Cmd+up arrow

To the first column in the worksheet Cmd+left arrow or Home

To the next corner cell clockwise in a 
selected range

Ctrl+. (Ctrl and the period key)

Tip If your Mac’s keyboard doesn’t have the Home key, End key, Page Up key, and Page Down 
key, you’ll need to use function-key shortcuts. Press Fn+left arrow for Home, Fn+right arrow for 
End, Fn+up arrow for Page Up, and Fn+down arrow for Page Down. Use these keys as needed with 
the keyboard shortcuts in Table 1-1—for example, press Cmd+Fn+left arrow to move to the first 
cell in the active worksheet.
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You can select a range of contiguous cells in any of these three ways:

	Click and drag. Click the first cell in the range, then drag to select all the 
others. For example, if you click cell B2 and then drag to cell E7, you 
select a range that’s four columns wide and six rows deep. Excel uses 
the notation B2:E7 to describe this range—the starting cell address, a 
colon, and then the ending cell address.

	Click and then Shift+click. Click the first cell in the range, then 
Shift+click the last cell. Excel selects all the cells in between. You can 
use this technique anytime, but it’s most useful when the first cell and 
last cell are widely separated; for example, when the first cell and last 
cell don’t appear in the Excel window at the same time.

	Hold down Shift and use the arrow keys. Use the arrow keys to move 
the active cell to where you want to start the range; then hold down Shift 
and use the arrow keys to extend the selection for the rest of the range. 
This method is good if you prefer using the keyboard to the mouse.

You can select a range of noncontiguous cells by clicking the first cell (or dragging through a 
range of contiguous cells) and then holding down Cmd while you click other individual cells 
or drag through ranges of contiguous cells. Excel uses commas to separate the individual 
cells in this type of range. For example, the range D3,E5,F7,G1:G13 consists of three 
individual cells (D3, E5, and F7) and one range of contiguous cells (G1 through G13).

Note You can quickly select a row by clicking its row heading or pressing Shift+spacebar when 
the active cell is in that row. Likewise, you can select a column by clicking its column heading or 
pressing Ctrl+spacebar when the active cell is in that column. To select all the cells in the active 
worksheet, click the Select All button (where the row headings and column headings meet). You can 
also either press Cmd+A or press Shift+spacebar followed by Ctrl+spacebar (or vice versa).

Figure 1-11. You can select either a range of contiguous cells (left) or a range of individual cells (right). Excel darkens 
the headers of the rows and columns that contain the range to make the range easier to see
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To deselect a range you’ve selected, click anywhere outside the range.

Tools for Entering Text and Formulas Quickly
The most straightforward way of entering text and formulas in your workbooks is to type it 
in. But no matter how fast you type, it pays to know all the alternative ways of getting data 
and formulas into your workbooks. These include importing the data from an existing file, 
connecting to an external data source, speeding up data entry by maxing out AutoCorrect, 
taking advantage of the powerful AutoFill feature, and using copy and paste in all its flavors. 
You can even use the Replace feature to enter text.

Importing Data
If you have the data you need in an existing file, you can usually import it into Excel. Excel 
can import files in these five formats:

	Comma-separated values (CSV). A CSV file uses a comma to separate 
the contents of cells. 

	Tab-separated values (TSV). A TSV file uses a tab to separate the 
contents of cells.  

	Space-separated values. A space-separated values file (not usually 
referred to as SSV) uses a space to separate the contents of cells.

	FileMaker Pro database. FileMaker Pro is a heavy-duty database 
application that runs on both OS X and Windows. FileMaker Pro files 
use file extensions starting with .fp and continuing with a number, such 
as .fp12.

	HTML. HTML (HyperText Markup Language) is the markup language 
used for web pages. 

Note Most spreadsheet applications and database applications can export data in CSV format or 
TSV format. You can also create these files manually if necessary. For example, if you need to create 
some data on a mobile device that doesn’t have a spreadsheet application, you can create it as a 
text file with a comma separating each field.

Note Importing works best when you need all the data from a file. When you need only some of 
the data, copy and paste is usually more effective. Alternatively, you can import all the data and 
then delete what you don’t need.
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To import data from an existing file, follow these steps:

1. Open the workbook you want to import the data into. If you want to 
put the data in a new workbook, press Cmd+N to create one.

2. Choose File ➤ Import to display the Import dialog box  
(see Figure 1-12).

3. Select the CSV file option button, the FileMaker Pro database option 
button, the HTML file option button, or the Text file option button  
(for tab-separated files or space-separated files).

Figure 1-12. In the Import dialog box, select the appropriate option button based on the type of file you want to import

Note To import data from a FileMaker Pro database, you must have FileMaker Pro installed on 
your Mac. Without FileMaker Pro, Excel can’t read a FileMaker Pro database.

4. Click the Import button to display the dialog box for identifying the 
file. The name of this dialog box varies depending on your choice in 
step 3: it’s the Choose a File dialog box for CSV files or text files, the 
Choose a Database dialog box for FileMaker Pro, and the Open tab 
of the Microsoft Excel dialog box for HTML files.
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5. Choose the file that contains the data and then click the Get Data 
button, the Choose button, or the Open button (depending on the 
dialog box).

6. Follow the steps of the Import Wizard that opens. The following 
sections explain the main considerations.

Importing Data from a Comma-Separated Values File or a Text File
When you import data from a comma-separated values file or a text file, the Text Import 
Wizard walks you through the import process.

On the wizard’s first screen (see Figure 1-13), start by making sure that Excel has selected 
the Delimited option button if your file is delimited with commas, tabs, or another character. 
If it’s a text file that uses spaces to create fixed-width columns, select the Fixed width option 
button. 

If you need to skip some rows at the beginning of the file, increase the value in the Start 
import at row box. To start from the beginning, make sure this box is set to 1.

If the preview in the Preview of selected data box looks wrong, open the File origin pop-up  
menu and choose the encoding the file uses. For example, if the file was created on a 
Windows PC, you may need to choose the Windows (ANSI) item to make the text display 
correctly. If the file was created on a Mac, choosing Macintosh in the File origin pop-up 
menu should do the trick.

Figure 1-13. Make sure that the Text Import Wizard has made the right choice between the Delimited option button and 
the Fixed width option button. You can also decide at which row to start importing

www.allitebooks.com

http://www.allitebooks.org


 
20 CHAPTER 1: Learning the Secrets of the Excel for Mac Interface

When the preview looks okay, click the Next button to move to the second screen  
(see Figure 1-14). 

In the Delimiters list, make sure Excel has selected the check box for the delimiter the file 
uses—for example, the Tab check box.

Select the Treat consecutive delimiters as one check box if you want Excel to treat two 
or more consecutive delimiters as a single delimiter. Using this setting has the effect of 
collapsing blank fields in the data. Normally, you won’t need to use this setting.

If your data file uses single quotes or double quotes to mark strings of text, make sure that 
Excel has selected the right type of quotes in the Text qualifier pop-up menu. If not, select it 
yourself.

Note For a text file laid out with fixed-with columns, the second screen of the Text Import Wizard 
lets you create, delete, and move break lines to make the fields the right widths. The options on the 
third screen of the Text Import Wizard are the same for a text file laid out with fixed-width columns 
as for a delimited text file.

Figure 1-14. On the second screen of the Text Import Wizard for a CSV or TSV file, make sure that Excel has identified 
the correct delimiters
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Check that the data in the Preview of selected data box looks okay, and then click the Next 
button to display the third and final screen of the Text Import Wizard (see Figure 1-15). On 
this screen, you can set the data format of any column by clicking the column in the Preview 
of selected data box and then selecting the appropriate option button in the Column data 
format list:

	General. The Text Import Wizard suggests this format for most columns. 
The General format makes Excel convert numeric values to numbers, 
convert date values to dates, and treat any other type of data as text. 
This works pretty well for most fields, so you may want to simply leave 
this setting. Otherwise, you can set each field to the type needed.

	Text. Select this format for any data you want Excel to treat as text. 
Sometimes you may want to set this format for data that Excel would 
otherwise convert to numbers.

	Date. Select this format to make sure Excel knows that a column 
contains dates. In the pop-up menu, choose the order in which the 
month (M), day (D), and year (Y) appear: MDY, DMY, YMD, MYD, DYM, 
or YDM. If you’re using the U.S. localization, Excel uses the MDY format 
by default so you won’t need to change it unless the file has come from 
somewhere that treats dates differently.

	Do not import column (Skip). Select this button for any column you want 
to skip. This option can be great for data you’re sure you don’t need, 
though you may find it easier to import all of the columns and delete 
those you don’t need after the import.  

Figure 1-15. On the third screen of the Text Import Wizard for a CSV or TSV file, you can set the data format for each 
column. You can also tell Excel not to import particular columns you don’t need
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When you finish choosing text-import settings, click the Finish button. The Text Import 
Wizard imports the data into the active worksheet.

Importing Data from a FileMaker Pro Database
When you import data from a FileMaker Pro database, the FileMaker Pro Import Wizard  
(see Figure 1-16) walks you through the process of choosing the right fields. 

On the first screen of the FileMaker Pro Import Wizard, follow these steps:

1. Click the Layouts option button if you want to use a layout. Click the 
Tables option button if you want to use a table.

2. Open the pop-up menu below the Layouts option button or Tables 
option button (whichever you chose), and then click the layout or 
table you want to use. Excel displays the fields from the layout or 
table in the Available fields list box.

Figure 1-16. On the first screen of the FileMaker Pro Import Wizard, choose the layout or table you want to import, pick 
the fields, and then arrange them into your preferred order

Note If you need to set Excel to use a different character than the period as the decimal separator 
or the comma as the thousands separator, click the Advanced button on the third screen of the Text 
Import Wizard. In the Advanced Text Import Settings dialog box that opens, choose the appropriate 
setting in the Decimal separator pop-up menu and the Thousands separator pop-up menu, and then 
click the OK button.
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3. Add the fields you need to the Import these fields list box:

	Add a single field. Click the field in the Available fields list box and  
then click the Add button. Repeat as needed.

	Add all the fields. Click the Add All button. Often, you’ll want to add  
all the fields and then remove a few of them.

	Remove a field. Click the field in the Import these fields list box and  
then click the Remove button.

	Remove all fields. Click the Remove All button.

4. In the Import these fields list box, put the fields in your preferred 
order. To move a field up or down, click it and then click the Up 
button or the Down button.

When you’ve chosen the fields you want and arranged them into your preferred order, click 
the Next button to display the second and final screen of the FileMaker Pro Import Wizard 
(see Figure 1-17). On this screen, you can set the criteria to pick only the records you want 
from the table or layout you chose.

Figure 1-17. On the second screen of the FileMaker Pro Import Wizard, set up the criteria needed to limit the import to 
only the records you want
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If you want all the records in the table or layout, you can simply click the Finish button. But 
if you want to strip the table or layout down to only records that match particular criteria, 
follow these steps:

1. In the Criteria 1 area, set up your first criterion:

	Open the left pop-up menu and click the field to use for the criterion.

	Open the middle pop-up menu and click the comparison: =, <=, >=, <, >, 
begins with, ends with, or contains.

	In the text box, specify the value for the comparison.

2. If you need a second criterion, select the appropriate option button:

	Select the And option button to make the records match the first criterion 
and the second criterion—for example, Depreciation Years >= 2014 And 
Remaining Years <= 1.

	Select the Or option button to make the records match either the first  
criterion or the second criterion—for example, Depreciation Years >= 2014  
Or Value >=25.

3. Set up the second criterion in the Criterion 2 box using the same 
technique as for the first.

4. If you need a third criterion, select the And option button or the Or 
option button (as appropriate), and then use the third line of controls 
to specify the criterion.

When you’ve nailed down your criteria, click the Finish button to close the FileMaker Pro 
Import Wizard. The Wizard displays the Import Data dialog box (see Figure 1-18).

Figure 1-18. In the Import Data dialog box, choose the Existing sheet option button or the New sheet option button as 
appropriate. Then click the OK button
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In the Where do you want to put the data area, select the Existing sheet option button if you 
want to put the incoming data on the worksheet you’ve selected. Usually, this is the best 
bet. The text box shows the active cell; if you need to change it, you can type a different 
address, or click in the workbook and then click the cell you want to use as the upper-left 
corner of the range. Otherwise, if you want to create a new worksheet and put the data on it, 
select the New sheet option button.

Click the OK button to close the Import Data dialog box. The Wizard queries the database, 
returns the records that match your criteria, and then enters them in the worksheet you 
specified.

Importing Data from an HTML File
When you import data from an HTML file, Excel simply opens the file without displaying any 
Import Wizard screens. You can then manipulate the contents of the file as needed. 

Connecting a Worksheet to External Data Sources
If you have an external data source that contains data you need to use in your Excel 
worksheet, you can connect the worksheet to the data source and pull in the data so you 
can work with it in Excel.

To get the data into the worksheet, you use the same tools we just discussed for importing 
data—for example, you use the FileMaker Pro Import Wizard to import data from a FileMaker 
Pro database. After importing the data, you can refresh some or all of it as needed, updating 
the worksheet with the latest data from the data source.

Chapter 11 explains how to work with external data.

Entering Text Using AutoCorrect
As you work in a worksheet, the AutoCorrect feature analyzes the characters you type and 
springs into action if it detects a mistake it can fix or some formatting it can apply. This 
feature can save you a lot of time and effort and can substantially speed up your typing, so 
it’s well worth using—but you need to set it up to meet your needs. AutoCorrect also has 
some features that can cause surprises, so you’ll want to choose settings that suit the way 
you work.

Opening the AutoCorrect Preferences Pane
To set up AutoCorrect, choose Tools ➤ AutoCorrect from the menu bar to display the 
AutoCorrect preferences pane in the Excel Preferences window (see Figure 1-19).

http://dx.doi.org/10.1007/978-1-4842-1019-2_11
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Choosing Options to Make AutoCorrect Work Your Way
With the AutoCorrect preferences pane displayed, select the check box for each option you 
want to use:

	Replace internet and network paths with hyperlinks. Select this check 
box to have AutoCorrect insert a hyperlink when you type a URL (for 
example, www.apress.com) or a network path (such as \\server1\users). 
This option is helpful if you want live hyperlinks in your workbooks—
for example, if you’re making a list of products with URLs, and you 
want to be able to click a link to open the web page in your browser. 
Other times, you may want to be able to enter URLs and paths without 
creating links; in this case, turn this feature off.

	Capitalize names of days. Select this check box to have AutoCorrect 
automatically capitalize the first letter of the day names (for example, 
Sunday). This option is usually helpful unless you’re writing minimalist 
poetry in Excel.

	Correct TWo INitial CApitals. Select this check box to have AutoCorrect 
apply lowercase to a second initial capital—for example, changing 
“THree” to “Three.”

Figure 1-19. You can use AutoCorrect to enter text quickly in your worksheets as well as to correct typos and create 
hyperlinks

http://www.apress.com/
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	Capitalize first letter of sentences. Select this check box if you want 
AutoCorrect to automatically start each new sentence in a cell with a 
capital letter. AutoCorrect doesn’t capitalize the first sentence in the 
cell, as this option only kicks in once you’ve typed some text followed 
by a period. Clear this check box if you want to control capitalization 
yourself.

	Replace text as you type. Select this check box to use AutoCorrect’s 
main feature, replacing misspellings and abbreviations with their 
designated replacement text. You will want to use this feature to make 
the most of AutoCorrect.

Creating Replace-As-You-Type Entries
Inserting missed capitals and creating hyperlinks automatically helps a bit, but the main 
point of AutoCorrect is to correct typing errors. 

AutoCorrect comes with a list of standard errors, such as “abbout” for “about,” that you’ll 
probably want it to correct automatically. But where you can really take advantage of 
AutoCorrect is by creating entries that aren’t errors but rather abbreviations that you type 
deliberately and have AutoCorrect expand for you. For example, you can create an entry that 
changes “vpm” to “Vice President of Marketing” or one that changes “ssf” to “Second 
Storage Facility, Virginia (Security Grade II)”.

Creating AutoCorrect Entries
To create an AutoCorrect entry, follow these steps:

1. Type the entry name (the text that triggers the replacement) in the 
Replace box. The name can be up to 32 characters long, but shorter 
entries save you more time.

Note Excel shares its AutoCorrect entries with Word, PowerPoint, and Outlook, so no matter which 
application you create an entry in, you can use it in the others as well. Each entry must be unique—
you can’t use “vpm” for “Vice President of Marketing” in Word and “virtual processor module” in 
Excel. In Word, you can also create formatted AutoCorrect entries that contain formatting, paragraph 
marks, and other objects (such as graphics or tables); these entries work only in Word. Word, 
PowerPoint, and Outlook also support AutoCorrect exceptions, which enable you to define first-
letter, initial-caps, and other terms you don’t want AutoCorrect to change, even though they would 
normally trigger a change. Earlier versions of Excel used to support AutoCorrect exceptions, but 
Excel 2016 does not.
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2. Type or paste the replacement text in the With box. The replacement 
can be up to 255 characters long (including spaces and punctuation).

Tip When naming an AutoCorrect entry, you’ll usually want to avoid using any words or names 
you may need to type in your workbooks. The exception is when you always want to change a 
particular word. For example, if your boss has a pet hate of the word “purchase,” you could set up 
AutoCorrect entries to change “purchase” to “buy,” “purchased” to “bought,” and so on.

Note You can enter AutoCorrect entries only into a single cell. Even if you select multiple cells and 
paste them into the With box in the AutoCorrect pane, AutoCorrect strips out the cell divisions.

3. Click the Add button.

If you need to delete an existing entry, select it either by clicking in the Replace box and 
typing its name or by scrolling down to it and clicking it. Then click the Delete button.

Using Your AutoCorrect Entries
Once you’ve set up your AutoCorrect entries, Excel automatically replaces an entry after you 
type it and then press the spacebar or a punctuation key or move to another cell.

Entering Text with AutoFill and Custom Lists
In many workbooks, you’ll need to enter a series of data, such as a list of months or years, 
a sequence of numbers, or a progression of dates (such as every Monday). In many cases, 
you can save time and effort by using Excel’s AutoFill feature.

AutoFill works by analyzing the contents of one or more cells you select, and then entering 
the relevant series of data in the cells to which you extend the selection by dragging. AutoFill 
figures out mathematical sequences or date sequences on the fly and uses built-in custom 
lists to fill in the days of the week or the months of the year. You can also create your own 
custom lists for data you want to teach Excel to fill in.

Using AutoFill’s Built-in Capabilities
The best way to grasp what you can do with AutoFill is to try it. So open a workbook you’re 
comfortable experimenting with and try the examples in this section.
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First, have AutoFill fill in the days of the week. Follow these steps:

1. Type Monday in cell A1 and click the Enter button on the Formula 
bar to enter the data. (If you prefer to press Return to enter the data, 
click cell A1 again to select it once more.)

2. Drag the AutoFill handle—the green square that appears at the 
lower-right corner of the selection—down to cell A7. As you drag 
past each cell, AutoFill displays a ScreenTip showing the data it will 
fill in that cell (see Figure 1-20).

3. Release the mouse button on cell A7. AutoFill fills in the days 
Tuesday through Sunday. 

Now drag through the range to select it, then press Delete to clear the data. Then follow 
these steps to enter a sequence of months:

1. Click cell B2, and type a date such as 5-15-16 in it.

2. Click the Enter button on the Formula bar. Excel changes the date 
value to a full date—for example, 5/15/2016.

3. Ctrl+click or right-click the AutoFill handle and drag it to cell G2. As 
you drag, AutoFill displays dates incremented by one day for each 
column (5/16/2016, 5/17/2016, and so on), but when you release the 
mouse button, AutoFill displays a context menu (see Figure 1-21).

Note If AutoFill doesn’t work, you need to turn it on. Choose Excel ➤ Preferences to display 
the Excel Preferences window, and then click the Edit icon in the Authoring area to display the 
Edit pane. Select the Enable fill handle and cell drag-and-drop check box, and then click the Close 
button (the red button at the left end of the title bar) to close the Excel Preferences window.

Figure 1-20. Drag the AutoFill handle down or across to fill in a series of data derived from one or more existing 
entries. In this case, AutoFill fills in the days of the week and repeats the series if you drag farther

www.allitebooks.com
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4. Click the Fill Months item, and Excel fills in a separate month for 
each column: 6/15/2016, 7/15/2016, and so on.

Now clear your data again and then create a sequence of numbers. Follow these steps:

1. Click cell A1 and type 5 in it.

2. Press Return to move to cell A2, type 25 in it, and press the up arrow 
to move back to cell A1.

3. Press Shift+down arrow to select cells A1 and A2.

4. Click the AutoFill handle and drag downward. AutoFill fills in a series 
with intervals of 20—cell A3 gets 45, cell A4 gets 65, and so on—using 
a linear trend.

Delete the data that AutoFill entered, leaving 5 in cell A1 and 25 in cell A2. Then follow  
these steps:

1. Select cells A1 and A2.

2. Ctrl+click or right-click the AutoFill handle and drag downward. As you 
drag, you’ll see ScreenTips for the same values as in the previous list.

3. Release the mouse button and then click Growth Trend on the 
context menu. AutoFill enters a growth trend instead of the linear 
trend: because the second value (25) is 5 times the first value (5), 
Excel multiplies each value by 5, giving the sequence 5, 25, 125, 625, 
3125, and so on. 

Note The AutoFill context menu also contains items for filling the cells with formatting only 
(copying the formatting from the first cell), filling the cells without formatting (ignoring the first cell’s 
formatting), and filling in days, weekdays, months, and years.

Figure 1-21. To reach more AutoFill options, Ctrl+drag or right-drag the AutoFill handle, and then click the fill option 
you want on the context menu
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Those are the basics of AutoFill. But you can also create custom AutoFill lists to quickly 
enter exactly the data you need.

Creating Your Own Custom AutoFill Lists
If you need to enter the same series of data frequently, follow these steps to create your own 
AutoFill lists:

1. Choose Excel ➤ Preferences or press Cmd+, (Cmd and the comma 
key) to display the Excel Preferences window.

2. In the Formulas and Lists area, click the Custom Lists item to display 
the Custom Lists pane (shown in Figure 1-22 with settings chosen).

Figure 1-22. You can supplement Excel’s built-in AutoFill lists by creating your own data series

3. In the Custom lists box, click the NEW LIST item.

4. Enter the items for your list in one of these ways:

	Click in the List entries box, and then type your list, putting one item  
on each line.

	Click the Collapse Dialog button, select the range containing the list  
entries in the worksheet, and then click the Collapse Dialog button  
again to restore the dialog.

5. If you’ve just entered a list, click the Add button to add the list to the 
Custom lists box. If you imported a list from a worksheet, click the 
Import button.

6. Click the Close button (the red button at the left end of the title bar) 
to close the Excel Preferences window.
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Entering Text Using Copy, Paste, and Paste Options
Often, you can enter text more quickly in your workbooks by pasting it in from other sources. 
For example, if you receive sales figures in an e-mail message, you can copy and paste 
them into a worksheet. To paste, select the upper-left cell of the range of cells into which you 
want to paste the data, and then give a Paste command—for example, choose  
Home ➤ Clipboard ➤ Paste from the Ribbon or press Cmd+V.

Excel lets you paste data in with or without all its formatting. Usually it’s easiest to go  
ahead with a straightforward paste operation and then use the Paste Options action button 
(see Figure 1-23) to change the result if it’s not what you want.

When you paste in data you’ve copied from another application and you know you don’t 
want to paste the formatting, use the Paste Special command like this:

1. Copy the data in the other application.

2. Switch to Excel.

3. Click the cell at the upper-left corner of the range you want to paste 
the data in.

4. Choose Edit ➤ Paste Special from the menu bar or Home ➤ 
Clipboard ➤ Paste ➤ Paste Special from the Ribbon (clicking 
the Paste pop-up button rather than the main part of the button) to 
display the Paste Special dialog box (see Figure 1-24).

Figure 1-23. Use the Paste Options action button to switch pasted text from using its original formatting to matching 
the formatting of the destination
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5. In the As box, click the Text item.

Figure 1-24. Select the Text item in the As box in the Paste Special dialog box to paste in data from another application 
without pasting its formatting

Tip If pasting using the Text item in the Paste Special dialog box puts all the text in one cell rather 
than in multiple cells, try using the Unicode Text item instead.

6. Click the OK button. 

Switching Data from Rows to Columns
Often when you’re laying out a worksheet, the best way to arrange the data isn’t obvious at 
first—so you may find you’ve laid out your data in rows when a column arrangement would 
work better. 

Note The options in the Paste Special dialog box vary depending on the data you’ve copied. 
As you’ll see in Chapter 4, when you paste data copied from Excel, the Paste Special dialog box 
provides many more options.

http://dx.doi.org/10.1007/978-1-4842-1019-2_4
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Instead of spending hours retyping the data or using drag-and-drop to move it, you can fix 
the problem in moments using Excel’s Transpose command. Follow these steps:

1. Make space for the transposed version of the data. Usually, it’s 
easiest to put it on a separate worksheet; if so, click the Insert Sheet 
button to add one.

2. Select the data you want to switch from rows to columns.

3. Give a Copy command in any of the usual ways, such as pressing 
Cmd+C or choosing Edit ➤ Copy from the menu bar.

4. Click the cell at the upper-left corner of the area into which you want 
to paste the transposed data.

5. Choose Home ➤ Clipboard ➤ Paste ➤ Transpose from the 
Ribbon, clicking the Paste pop-up button rather than the main part 
of the button. Excel pastes in the data, transposing its rows and 
columns.

If Excel displays the This selection is not valid dialog box (see Figure 1-25) when you give 
the Transpose command, make sure you’re not trying to paste the data back into its original 
location. Even though the dialog box implies that you can paste the data back into the 
original location or an overlapping location as long as you’ve selected the right number of 
rows and columns, pasting the data back like this simply doesn’t work at this writing.

Figure 1-25. The This Selection Is Not Valid dialog box may indicate that you’re trying to paste the transposed data 
back into its original location, an overlapping location, or a location that’s the wrong shape



 
35CHAPTER 1: Learning the Secrets of the Excel for Mac Interface

Pasting in a Table from Word
If you have data in a table in Word, you can paste it straight into a worksheet in Excel. Excel 
places each table cell in a different worksheet cell, as you’d want. 

You’ll get the best results from a table that has a regular layout, with the same number of 
cells in each row. If some rows have more cells than other rows, you may need to move 
some cells in Excel after pasting them. In most cases, it’s easiest to make the table regular in 
Word (for example, by making a copy of it in a spare document and then changing the copy) 
before pasting it into Excel.

Getting Comma-Separated Data into a Worksheet
If you have data in comma-separated format, you can get it into an Excel worksheet in  
three ways:

	Use the Text Import Wizard. Choose File ➤ Import from the menu bar, 
then follow the steps described earlier in this chapter to open and use 
the Text Import Wizard to control exactly how Excel imports the text.

	Open the file in Excel. You can simply use the File ➤ Open command 
and the Open dialog box to open a comma-separated file in Excel. Excel 
automatically puts each comma-separated item in a separate cell. You 
can then copy and paste the data as needed.

	Convert the comma-separated data to a Word table, then paste it. If you 
have the data in comma-separated format as part of a document or 
e-mail message, follow these steps:

1. Paste the data into a Word document.

2. In Word, select the pasted data.

3. Choose Insert ➤ Tables ➤ Table ➤ Convert Text to Table from 
the menu bar to display the Convert Text to Table dialog box.

4. In the Separate text at area, make sure the Commas option 
button is selected.

5. Click the OK button. Word converts the text to a table.

6. Select the table.

7. Copy the table.

8. Switch to Excel and paste in the table.

Entering Text with Find and Replace
Excel includes a powerful Replace feature that you can use to replace text items in either 
the active worksheet or every worksheet in the active workbook. You can limit the search to 
matching the case you specify or by finding the match only as the entire contents of a cell 
rather than within a cell’s contents.
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To work with Replace, follow these steps:

1. Open the Replace dialog box (see Figure 1-26) in one of these ways:

	Mouse. Click the pop-up button on the Search field at the right end  
of the title bar, then click Replace on the pop-up menu.

	Menus. Choose Edit ➤ Find ➤ Replace.

	Keyboard. Press Ctrl+Shift+F to display the Find dialog box, then  
click the Replace button.

Figure 1-26. You can use the Replace dialog box to quickly make changes throughout a worksheet or all the 
worksheets in a workbook

2. Type the search term in the Find what box.

3. Type the replacement text in the Replace with box.

4. In the Within pop-up menu, choose Sheet if you want to replace 
instances of the search term only on the active worksheet. Choose 
Workbook if you want to replace items on all the sheets in the 
workbook.

5. In the Search pop-up menu, choose By Rows if you want to search 
across each row in turn. Choose By Columns if you want to search 
down each column in turn.

6. Select the Match case check box if you want to locate only instances 
that match the way you’ve typed the search term in the Find  
what box.
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7. Select the Find entire cells only check box if you want to find only the 
cells whose entire contents match the search term. With this check 
box cleared, Excel also finds matches that form only part of a cell’s 
contents.

8. Click the appropriate command button:

	Find Next. Click this button to find the next instance of the search term  
so that you can decide whether to replace it.

	Replace. Click this button to replace the instance that Excel has found  
and to find the next instance (if there is one). Lather, rinse, and repeat.

	Replace All. Click this button to replace all the instances in the worksheet  
or workbook (depending on the setting you’ve chosen in the Within  
pop-up menu).

	Close. Click this button when you’ve finished using the Replace dialog box.

Inserting Symbols in a Document
Just by typing, you can easily insert any characters that appear on your keyboard—but 
many documents need other symbols, such as letters with dieresis marks over them  
(for example, ë) or ligatures that bind two characters (for example, Æ). 

You can quickly insert one or more symbols in a workbook by using the Characters pop-up 
panel or the Characters window. The Characters pop-up panel is a cut-down version of the 
Characters window. Excel opens the Characters pop-up panel at first, and you can open the 
full Characters window from it if necessary.

To insert a symbol, follow these steps:

1. Click the cell in which you want the symbol to appear.

2. Choose Insert ➤ Symbols ➤ Symbol Insert ➤ Symbol from the 
menu bar to display the Characters pop-up panel. The left screen in 
Figure 1-27 shows the top part of the pop-up panel, with labels on the 
first several tabs at the bottom, and the right screen in Figure 1-27  
shows a lower part of the panel, with labels on the remaining tabs.
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3. Find the symbol you want in one of these ways:

	Browse all symbols. Scroll up or down the Characters panel. The different 
sets of characters appear in a vertical stack that corresponds to the tabs: 
Frequently Used at the very top, People next, then Nature, and so on.

	Display only a set of symbols. Click the tab for the set of characters you  
want to view. For example, click the Travel & Places tab to display symbols 
showing taxis, trucks, planes, and the like.

	Search for a symbol. Click the Search box at the top and type your  
search term.

4. Click the symbol to insert it in the document. The Characters panel 
closes automatically.

When you need to insert multiple symbols in sequence, open the Characters panel and then 
click the Characters window button in the upper-right corner. (You need to be scrolled up to 
the top of the Characters panel for this button to be visible.) The Characters window  
(see Figure 1-28) opens, giving you different options for browsing symbols, and stays open 
after you insert a symbol, so you can continue inserting other symbols.

Figure 1-27. To insert a symbol in a workbook, click the symbol in the Characters pop-up panel. Click a tab at the 
bottom of the panel to display the set of symbols you want



 
39CHAPTER 1: Learning the Secrets of the Excel for Mac Interface

When you finish using the Characters window, close it by clicking the Close button (the red 
button) at the left end of its title bar.

Viewing Your Workbooks
Excel offers two views for working in your workbooks:

	Normal view. This is the view in which workbooks normally open and 
it’s the one in which you’ll do most of your data entry, formatting, and 
reviewing. Normal view is the view in which you’ve seen Excel so far in 
this chapter.

	Page Layout view. This view shows your worksheets as they’ll look when 
laid out on paper. You use it to adjust the page setup. You’ll learn how to 
do this in the section “Formatting Pages” in Chapter 4.

To switch the view, click the Normal button or the Page Layout button in the lower-right 
corner of the Excel window (see Figure 1-29) or choose View ➤ Normal or View ➤ Page 
Layout from the menu bar. If you prefer to use the Ribbon, choose View ➤ Workbook 
Views ➤ Normal or View ➤ Workbook Views ➤ Page Layout. 

Figure 1-28. Use the Characters window when you need to insert multiple symbols in sequence. Click the Add to 
Favorites button on the right side to add the selected character to your Frequently Used list

www.allitebooks.com
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Splitting the Window to View Separate Parts of a Worksheet
Often, it’s useful to be able to see two parts of a worksheet at the same time—for example, 
to make sure your notes correctly describe your data or when you’re copying information 
from one part to another.

When you need to see two parts of the worksheet in the same window, you can split the 
window either horizontally or vertically. To do so, you use the horizontal split box at the right 
end of the horizontal scroll bar, the vertical split box at the top end of the vertical scroll bar, 
or the Split button in the Window group of the View tab of the Ribbon.

Double-click the horizontal split box to split the window horizontally above the active cell, or 
double-click the vertical split box to split the window vertically to the left of the active cell. If 
the active cell isn’t in the right place for splitting, click the horizontal split box or the vertical 
split box, and then drag it until the split bar appears where you want the split.

If you want to split the window into four panes, you can also split it in the other dimension. 
For example, if you’ve already split the window horizontally, now split it vertically as well. 
Figure 1-30 shows the Excel window split into four panes. 

Note In Excel 2016, the split boxes on the scroll bars are so understated that they’re barely visible: 
All you see is a small gap above the top of the vertical scroll bar, or at the right end of the horizontal 
scroll bar, with a faint line on it. But when you move the mouse pointer over this gap, a double-
headed arrow with a line across its middle appears, indicating that the pointer is over the split box.

Tip When you want to see as much of a worksheet as possible, choose View ➤ Enter Full 
Screen from the menu bar or press Cmd+Ctrl+F. When you want to leave Full Screen view, you can 
press Esc (the simplest way), press Cmd+Ctrl+F, or move the mouse pointer up to the top of the 
screen (making the menu bar appear) and choose View ➤ Exit Full Screen.

Figure 1-29. Use the View buttons at the left end of the status bar to change views quickly
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Once you split the window, you get a separate scroll bar in each part, so you can scroll the 
panes separately to display whichever areas of the worksheet you need.

To reposition the split, click the split bar, and drag it to where you want it. If you’ve split the 
window into four panes, you can resize all four panes at once by clicking where the split bars 
cross and then dragging.

Note When you split the window, you may find it helpful to freeze certain rows and columns, 
as discussed later in this chapter, to keep them visible even when you scroll to other areas of the 
worksheet.

Figure 1-30. Split the Excel window into two or four panes when you need to work in separate areas of the worksheet 
at the same time

Note You can also split the window into four panes by choosing View ➤ Window ➤ Split from 
the Ribbon or Window ➤ Split from the menu bar.
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To remove the split, either double-click the split bar or click and drag it all the way to the left 
of the screen or all the way to the top. You can also choose View ➤ Window ➤ Split from 
the Ribbon or Window ➤ Remove Split from the menu bar.

Opening Extra Windows to Show Other Parts of a Workbook
Instead of splitting a window, you can open one or more extra windows to show other parts 
of the workbook.

Choose Window ➤ New Window from the menu bar to open a new window showing the 
active workbook. Excel distinguishes the windows by adding :1 to the name of the first and 
:2 to the name of the second—for example, General Data.xlsx:1 and General Data.xlsx:2.

Changing the Window and Arranging Open Windows
The easiest way to change the window you’re working in is to click the window you want to 
use—either click the window itself (if you can see it) or click its button on the Dock. You can 
also choose to open the Window menu on the menu bar and then click the window in the list 
at the bottom.

When you’ve opened several windows, you can arrange them using standard OS X 
techniques, such as by dragging them to the size and position you want. You can also use 
Excel’s Arrange Windows dialog box to place the windows.

Note Opening extra windows has two advantages over splitting a window. First, you can display 
other worksheets in the windows if you want, rather than just other parts of the same worksheet. 
Second, you can zoom each window by a different amount as needed or use a different view in 
each window.

Note If you’ve selected the Minimize windows into application icon check box in the Dock 
preferences pane in System Preferences, your open Excel windows appear under the Excel app’s 
icon on the Dock rather than as separate windows. To switch to a window via the Dock, first open 
the app’s context menu by clicking and holding, or Ctrl+clicking, or right-clicking the Excel icon on 
the Dock. Then click the window you want to view.
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2. Click the option button for the arrangement you want:

	Tiled. Select this option button to make Excel resize all the non-minimized 
windows to roughly even sizes so they fit in the Excel window. If you have 
several windows open, tiling may make them too small to work in, but it’s 
good for seeing which windows are open and closing those you don’t need.

	Horizontal. Select this option button to arrange all the windows horizontally in 
the Excel window. This arrangement works well for two windows in which the 
data is laid out in rows rather than columns.

	Vertical. Select this option button to arrange all the windows vertically in the 
Excel window. This arrangement works well for two windows in which the 
data is laid out in columns rather than rows.

	Cascade. Select this option button to arrange the windows in a stack so you 
can see each one’s title bar. This arrangement is useful for picking the window 
you want out of many open windows.

3. To arrange only the windows of the active workbook, select the 
Windows of active workbook check box. This option is good for the 
Horizontal and Vertical arrangements.

4. Click the OK button to close the Arrange Windows dialog box. Excel 
arranges the windows as you chose. 

Tip When you don’t need to see a particular window, you can hide it to get it out of the way. Click 
the window, and then choose Window ➤ Hide. To display the window again, choose Window ➤ 
Unhide, click the window in the Unhide dialog box, and then click the OK button.

Figure 1-31. Use the Arrange Windows dialog box to tile or otherwise arrange all Excel windows or only those from the 
active workbook

To position windows using the Arrange Windows dialog box, follow these steps:

1. Choose Window ➤ Arrange from the menu bar to display the 
Arrange Windows dialog box (see Figure 1-31).
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Zooming to Show the Data You Need to See
To make a worksheet’s data easier to read, you can zoom in. Or if you need to see more of a 
worksheet at once, you can zoom out.

The easiest way to zoom in or out is by using the Zoom slider at the right end of the status 
bar on the Excel window. Click the – button to zoom out by 10% increments; click the + 
button to zoom in by 10% increments; or drag the slider to zoom quickly.

If you want to zoom to a different percentage, click the current percentage readout to the 
right of the + button to display the Zoom dialog box (see Figure 1-32); alternatively, choose 
View ➤ Zoom from the menu bar to open this dialog box. Select the appropriate option 
button for your needs, and then click the OK button. 

Note The Fit selection option button in the Zoom dialog box enables you to zoom to the right 
percentage to fit a particular selection. Make the selection before you open the Zoom dialog box, 
then click the Fit selection option button and click the OK button.

Figure 1-32. When you need to zoom to a specific percentage, or to fit the selection, open the Zoom dialog box, click 
the appropriate option button, and then click the OK button

Freezing Rows and Columns So They Stay Onscreen
To keep your data headings onscreen when you scroll down or to the right on a large 
worksheet, you can freeze the heading rows and columns in place. For example, if you 
have headings in column A and row 1, you can freeze column A and row 1 so they remain 
onscreen.
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You can quickly freeze the first column, the top row, or your choice of rows and columns:

	Freeze the first column. Choose View ➤ Window ➤ Freeze First 
Column from the Ribbon.

	Freeze the first row. Choose View ➤ Window ➤ Freeze Top Row from 
the Ribbon.

	Freeze your choice of rows and columns. Click the cell below the row 
and to the right of the column you want to freeze. For example, to freeze 
the top two rows and column A, select cell B3. Then choose View ➤ 
Window ➤ Freeze Panes from the Ribbon or Window ➤ Freeze Panes 
from the menu bar.

Excel displays a gray line along the gridlines of the frozen cells. Once you’ve applied the 
freeze, the frozen columns and rows don’t move when you scroll down or to the right. 
Figure 1-33 shows a worksheet with rows 1 and 2 and column A frozen.

Figure 1-33. Freeze the heading rows and columns to keep them in place when you scroll down or across the 
worksheet

When you no longer need the freezing, choose View ➤ Window ➤ Unfreeze Panes from 
the Ribbon or Window ➤ Unfreeze Panes from the menu bar to remove it.
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Using Custom Views
When you need to keep your data laid out in a particular way, you can create a custom view. 
To do so, follow these steps:

1. Set up the workbook exactly the way you want it. For example:

	Display the worksheet you want to see.

	Hide any columns and rows you don’t want to view. You’ll learn how to hide 
columns and rows in Chapter 4.

	Switch to the view you want.

	Zoom the view as needed.

	Set the print area.

	Apply any filtering needed (see Chapter 10).

2. Choose View ➤ Workbook Views ➤ Custom Views from the menu 
bar to display the Custom Views dialog box (shown on the left in 
Figure 1-34 with several views already added).

Figure 1-34. Use the Custom Views dialog box (left) to add, delete, and display custom views. Use the Add View dialog 
box (right) to create a new custom view

3. Click the + button to display the Add View dialog box (shown on the 
right in Figure 1-34). Excel closes the Custom Views dialog box.

4. Type the name for the view in the Name text box.

5. Select the Print settings check box if you want the view to include 
the current print settings.

6. Select the Hidden rows, columns, and filter settings check box if 
you want the view to include hidden rows, hidden columns, and any 
filtering you’ve applied.

7. Click the OK button to close the Add View dialog box. Excel creates 
the view.

http://dx.doi.org/10.1007/978-1-4842-1019-2_4
http://dx.doi.org/10.1007/978-1-4842-1019-2_10
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You can now switch to the view by choosing View ➤ Custom Views from the menu bar to 
display the Custom Views dialog box, clicking the view in the Views list, and then clicking 
the Show button.

Summary
In this chapter, you learned the secrets of the Excel for Mac interface and how to navigate 
it. You know how to control Excel using the Ribbon, the menu bar, and keyboard shortcuts; 
how to get around worksheets and workbooks; and how to enter data in your workbooks by 
importing it or using tools such as AutoCorrect, AutoFill, and the Replace feature. You also 
learned how to work more quickly and efficiently by splitting the window, freezing panes, 
opening extra windows, and using custom views.

In the next chapter, I’ll show you how to customize Excel to suit the way you work.



49

 

Chapter 2
Configuring Excel to Suit the 
Way You Work
In this chapter, we look at how to configure Excel for Mac to suit the way you work. You can 
change Excel’s appearance and behavior in many ways, and by setting it up as you prefer, 
you can save yourself plenty of time and effort.

The main way of configuring Excel is by setting its preferences in the Excel Preferences 
window. This window contains more settings than we can sensibly cover all at once, 
so we’ll concentrate on the ones that will make the most difference in the way you use 
Excel most of the time—General, View, Edit, Save, and Compatibility. We cover other 
preferences elsewhere in the book when we reach their topics. For example, Chapter 1 
covers AutoCorrect and Custom Lists preferences; Chapter 7 covers Chart preferences; and 
Chapter 10 covers Tables & Filter preferences.

Our first move is to open the Excel Preferences window. We look next at how to control how 
the Excel window appears, then move on to choose editing options and default settings for 
saving your workbooks. After that, I show you how to create custom keyboard shortcuts for 
Excel menu commands and how to open one or more workbooks automatically when you 
launch Excel.

Opening the Excel Preferences Window
To work through this chapter, open the Excel Preferences window by choosing Excel ➤ 
Preferences from the menu bar or by pressing Cmd+, (Cmd and the comma key).

As you can see in Figure 2-1, the Excel Preferences window contains three main categories 
of preferences—Authoring, Formulas and Lists, and Sharing and Privacy. Each category 
contains a group of icons that you click to display the corresponding preferences pane.

http://dx.doi.org/10.1007/978-1-4842-1019-2_1
http://dx.doi.org/10.1007/978-1-4842-1019-2_7
http://dx.doi.org/10.1007/978-1-4842-1019-2_10
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You navigate the Excel Preferences window much as you do OS X’s System Preferences 
window:

	Click the icon for the preferences pane you want to display. For 
example, click the General icon to display the General preferences pane.

	Click the Show All icon to return to the overview screen so you can 
display another category of preferences.

	Click the Back button (the button with the < symbol) to return to the 
previous screen. The previous screen is almost always the overview 
screen, so clicking the Back button tends to have the same effect as 
clicking the Show All button.

	Click the Forward button (the button with the > symbol) to go forward 
again to the last screen you were on.

	To search for a preference, click in the Search box, then type a keyword. 
In the list of matching preferences that Excel displays, click the 
preference you want. Excel highlights the relevant icon for a moment so 
you can identify it, then displays the preferences pane that contains  
the icon.

Figure 2-1. From the overview screen of the Excel Preferences window, click the icon for the preferences pane you 
want to display

www.allitebooks.com

http://www.allitebooks.org
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Controlling How the Excel Window Appears
A good place to start configuring Excel is by setting the options that control how the Excel 
window appears.

Start by displaying the General preferences (see Figure 2-2) and then set the following 
options:

	Confirm before opening other applications. Select this check box if 
you want Excel to ask your permission before opening other apps—for 
example, when you click a linked file such as a Word document.

	Open Workbook Gallery when opening Excel. Select this check box if 
you want Excel to display the Excel dialog box on launch. Clear this 
check box if you don’t need the Excel dialog box displayed at first.

	Prompt for workbook properties. Select this check box if you want Excel 
to display the Properties dialog box when you first save a file. If you 
use properties to help identify your workbooks, having this automatic 
prompt to enter property information can be helpful; if not, clear this 
check box.

	Play Office sounds. Select this check box if you want Excel to play 
sounds for events that occur in Office apps, such as when Excel has 
finished saving or printing a document.

	Show file extensions. Select this check box if you want Excel to display 
file extensions, such as the .xlsx file extension on Excel Workbook files 
in the latest file format. Having file extensions displayed can be helpful if 
you deal with Excel workbooks in different formats, such as the  
Excel 97–2004 format, and you need to be clear which type of file you’re 
working on.

	Use R1C1 reference style. Make sure this check box is cleared unless 
you want to use R1C1 references, in which both the columns and the 
rows are identified by number. For example, the reference for cell A1 is 
R1C1 (row 1, column 1), and the reference for cell E2 is R2C5.

	Ruler units. In this pop-up menu, choose Inches, Centimeters, or 
Millimeters, as needed.

	Sheets in new workbooks. In this box, set the number of worksheets you 
want each new blank workbook to have. You can either type the number 
or click the spin buttons. 
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	 Default font. In this pop-up menu, choose the font you want to use as 
the default, the one that Excel uses until you apply a different font. If you 
choose the Body Font item, Excel uses the font that’s set as the Body 
Font in the workbook’s theme.

	Font size. In this pop-up menu, choose the default font size.

	At startup, open all files in. If you want to have Excel automatically open 
all the files in a particular folder, click the Select button, navigate to and 
select the folder in the Choose a Folder: Microsoft Excel dialog box, and 
then click the Choose button. If you then need to stop opening all the 
files in that folder, click the Clear button. (You can’t simply delete the 
contents of the text box.)

	User name. Make sure this box shows your name the way you want it to 
appear in workbook properties.

Figure 2-2. In the General preferences pane, you can choose essential settings, including whether to display the Work 
book Gallery, the number of sheets in a new workbook, and your default font and font size

Note The Sheets in new workbooks setting affects only blank workbooks. When you create a new 
workbook based on a template, you get the number of sheets that the template contains.
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	Office theme. In this pop-up menu, choose the overall theme you want 
to use for the Office apps. Your choice is between the Classic theme 
and the Colorful theme. The Classic theme shows each app’s title bar 
and inactive Ribbon tabs in subdued gray and the status bar in the 
app’s color, such as green for Excel and blue for Word. The Colorful 
theme shows the app’s title bar and inactive Ribbon tabs in the app’s 
color and the status bar in gray.

Now click the Show All button to go back to the Overview screen, and then click the View 
icon to display the View preferences pane (see Figure 2-3).

Figure 2-3. The settings in the View preferences pane let you control the display of the Formula bar and sheet tabs, 
choose your preferred view, control how comments and objects appear, and decide which Ribbon features appear

You can now choose settings as described in the following subsections.

Choosing Options in the Show in Workbook Area  
of View Preferences
The Show in Workbook area of the View preferences pane contains ten preferences you’ll 
want to make sure are set the way you like:

	Formula bar. Select this check box to make Excel show the Formula bar, 
which is typically useful.

	Sheet tabs. Select this check box to display worksheet tabs. These also are 
typically useful, but you may want to hide them when you’re working on a 
single-sheet workbook, you’re using a small screen or window, or both.
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	Row and column headers. Select this check box to display the row 
headers and column headers. These too are usually helpful, because 
they not only provide visual reference to where you are working on the 
active worksheet but also enable you to give various commands using 
the context menu. But you may sometimes want to hide the row and 
column headers to conceal from others the fact that you’ve hidden 
some rows and columns. 

	Outline symbols. Select this check box to display the + and – signs 
Excel uses to mark an outline. These appear only when you’ve outlined 
a worksheet (see the section “Creating a Collapsible Worksheet by 
Outlining It” in Chapter 3), and normally you’ll want to display them.

	Gridlines. Select this check box to display gridlines between cells on 
screen. These too are usually helpful. To set the color, open the pop-up 
menu and choose either Automatic or the specific color you want.

	Zero values. Select this check box to display a 0 (zero) in each cell 
whose value is zero. Showing zero values is usually helpful; if you need 
to suppress zero values, clear this check box.

	Page breaks. Select this check box to make Excel display where page 
breaks fall. Usually, you need to see page breaks only right before 
printing, so you’ll probably want to clear this check box.

	Formulas. Select this check box to make Excel display the formulas 
rather than the values they produce. Showing the formulas is helpful 
when you’re troubleshooting calculations, but there’s an easier way to 
show them, as you’ll see in Chapter 4. Normally, you want to keep this 
check box cleared.

	Function ScreenTips. Select this check box to have Excel display a 
ScreenTip showing the arguments of a function you’re typing into a cell. 
These ScreenTips are usually helpful, but you can clear this check box if 
they bug you.

	Preferred view for new sheets. In this pop-up menu, click Normal if you 
want to use Normal view for each new sheet you add to a workbook. Click 
Page Layout if you want Excel to use Page Layout view for new sheets.

Choosing How to Display Comments
In the For Cells with Comments, Show area of the View preferences pane, select the option 
button that describes how you want to display comments attached to cells:

	No comments or indicators. Select this option button when you need to 
simplify a worksheet’s look by hiding the comments.

	Indicators only, and comments on rollover. Select this option button to 
display a comment indicator (a red triangle in the upper-right corner of 
the cell) for each comment, and to display the comment in a balloon 
when the user holds the mouse pointer over the cell. This is the default 
setting and is usually the best choice for regular work.

http://dx.doi.org/10.1007/978-1-4842-1019-2_3
http://dx.doi.org/10.1007/978-1-4842-1019-2_4
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	Comments and indicators. Select this option button to display both 
comment indicators and comment balloons all the time. Use this 
setting when you want to make certain you see all the comments in a 
worksheet.

Choosing How to Display Objects
In the For Objects, Show area of the View preferences pane, select the appropriate option 
button to control how objects such as pictures and command buttons appear in the 
worksheets:

	All. Select this option button to display all graphical objects in the 
workbook. This setting lets you see where everything in the workbook is, 
but it may make Excel display or scroll worksheets with many graphical 
objects more slowly.

	Placeholders. Select this option button to display empty-rectangle 
placeholders instead of pictures, but show command buttons.

	Nothing (hide objects). Select this option button to hide all objects so 
you can see the data without distractions. 

Choosing Ribbon Options
In the In Ribbon, Show area of the View preferences pane, choose whether to display the 
Developer tab and the Group Titles:

	Developer tab. Select this check box to display the Developer tab at the 
right end of the Ribbon. The Developer tab contains controls for working 
with Visual Basic for Applications (VBA, the programming language built 
into the Office applications), running add-ins, and building forms with 
controls such as check boxes, list boxes, and command buttons.

	Group Titles. Select this check box to display the group titles at the 
bottom of each control group on the Ribbon. 

Note The For Objects, Show setting applies only to the active workbook, not to all workbooks.

Tip Please select the Group Titles check box in the In Ribbon, Show area of the View Preferences 
pane, because this book uses the group titles to make the Ribbon command sequences easier to 
understand. For example, when the book says “Choose Data ➤ Sort & Filter ➤ Advanced,” it 
means you should click the Data tab of the Ribbon, go to the Sort & Filter group, and then click the 
Advanced button. If you don’t have the group titles displayed, the Ribbon command sequences will 
appear to have an extra, unnecessary step.
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Choosing Editing Options
To control how Excel behaves when you’re editing your worksheets, display the Edit 
preferences pane (see Figure 2-4). You can then choose options in the Edit Options area, the 
Cut and Paste Options area, and the Date Options area.

Figure 2-4. The Edit preferences pane contains various important settings you should understand, even if you choose 
not to change them

Choosing Options in the Edit Options Area
In the Edit Options area of the Edit preferences pane, you can set the following options:

	Edit directly in cells. Select this check box if you want to be able to 
double-click a cell to open it up for editing. This is usually helpful—but 
if you clear this check box, double-clicking a cell makes Excel select 
the first cell referenced by the formula in that cell. This capability can be 
great when you’re checking through formulas, so you need to decide 
which of the two double-click behaviors will be most helpful to you.  

	Allow fill handle and cell drag-and-drop. Select this check box if you 
want to be able to use the AutoFill feature (explained in Chapter 1) for 
entering custom lists and text sequences, and to be able to use drag-
and-drop to move the contents of one cell to another cell. If you select 
this check box, you can select the Alert before overwriting cells check 
box to have Excel display a warning dialog box when an AutoFill or 
drag-and-drop operation will overwrite the existing contents of cells. 

http://dx.doi.org/10.1007/978-1-4842-1019-2_1
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	Extend data range formats and formulas. Select this check box to make 
Excel automatically extend formatting and formulas when you get to 
the end of the current data range and add another row or column. This 
behavior usually saves time and effort.

	Provide feedback with animation. Select this check box if you want 
Excel to animate the insertion or deletion of cells, rows, or columns in 
the worksheet. The animation makes each change easier to see, but it 
may make Excel run slowly on an underpowered Mac; if so, clear this 
check box.

	Ask to update automatic links. Select this check box if you want Excel 
to display a dialog box asking you for permission to update automatic 
links. Having this confirmation is good if you need to maintain control 
of automatic links rather than have Excel update them without 
consulting you.

	Display this number of decimal places. If you want Excel to automatically 
insert a decimal point in numbers you enter in cells, select this check 
box, and use the spin buttons to set the number of decimal points. For 
example, if your standard format for numbers uses two decimal places, 
select this check box, and then enter 2 in the box. Then, when you type 
123 in a cell, Excel automatically converts it to 1.23 without your having 
to type in the decimal point. You can set a negative number if you want 
Excel to multiply the number by that power of 10—for example, if you 
set –3, Excel multiplies each number by 1000, so if you enter 9, you get 
9000. (You can set any value from –300 to 300, but you’ll seldom need 
to go near these limits.) 

	 After pressing Return, move selection. Select this check box if you want 
Excel to automatically select another cell after you press Return to enter 
the contents of the active cell. This movement is usually helpful. In the 
Direction pop-up menu, choose the direction: Down, Up, Right, or Left. 
The default direction is Down.

Choosing Options in the Cut and Paste Options Area
The Cut and Paste Options area in the Edit preferences pane contains three settings for 
controlling how Excel handles Cut and Paste operations:

	Cut, copy, and sort inserted objects with related cells. Select this check 
box if you want Excel to include objects (such as graphics and buttons) 
with cells you cut, copy, or sort. This is normal behavior.

Caution For normal use of Excel, make sure the Display this number of decimal places check box 
in the Edit preferences pane is cleared.
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	Show Paste Options. Select this check box if you want Excel to display 
a Paste Options action button after you paste in an item. You can click 
the Paste Options action button to display a pop-up menu of other ways 
of pasting in the data. This is usually helpful.

	Show Insert Options. Select this check box if you want Excel to display 
an Insert Options action button when you insert cells, rows, or columns. 
You can click the Insert Options action button to display choices for 
formatting the items you’ve inserted. This too is usually helpful.

Choosing Options in the Date Options Area
The Date Options area in the Edit preferences pane contains three settings for controlling 
how Excel handles dates:

	Preserve display of dates entered with four-digit years. Select this check 
box if you want Excel to maintain four-digit years (such as 2015 or 2016) 
that you type in your worksheets rather than converting the dates to 
two-digit years (for example, 10/2/16 for the date 10/2/2016 that you 
entered).

	Automatically convert date system. Select this check box if you want 
Excel to automatically convert dates between the 1900 date system 
used by Excel for Windows and current versions of Excel for Mac and 
the 1904 date system used by most versions of Excel for Mac up till 
recently. 

	 Interpret as 21st century for two-digit years before. In this text box, 
enter the two-digit value before which you want Excel to assume you 
mean the 21st century rather than the 20th century. The default setting 
is 30, so entering 12/31/29 gives you 31st December 2029 but entering 
1/1/30 gives you 1st January 1930.

Setting Preferences for Creating and Saving Your 
Workbooks
One thing you’re pretty much certain to do in Excel is create workbooks and save them. So 
it’s worth spending a minute or two to set Excel to create workbooks with the right number 
of worksheets, using the workbook format you prefer. You’ll also want to choose whether to 

Note The 1900 date system uses the serial number 1 to represent 1 January 1900; the 1904 
date system uses the serial number 1 to represent 1 January 1904. Unless you have a compelling 
reason to use the 1904 date system, stick with the 1900 date system for clarity. Excel stores dates 
and times as serial numbers so that it can perform math operations with them easily.
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save preview pictures with new workbooks and whether to keep automatic backups as you 
work. You can also have Excel prompt you to enter property information in your workbooks 
to make them easier to identify.

Creating Workbooks with the Number of Worksheets You Need
When you create a new blank workbook, Excel gives it a single worksheet by default. You 
can add as many other worksheets as you need by clicking the Insert Sheet button, but if you 
usually need multiple worksheets in each workbook, you can have Excel add them for you.

To control how many worksheets Excel gives each workbook, set the number in the Sheets 
in new workbooks box in the General preferences pane.

Choosing the Default Format for Saving Workbooks
Next, make sure Excel is set to save workbooks in the format you prefer. To do this, go to 
the Compatibility preferences pane (see Figure 2-5), open the Save files in this format  
pop-up menu, and then click the appropriate format.

Note Unlike earlier versions of Excel, Excel 2016 for Mac does not enable you to set a default 
folder for opening and saving workbooks.

Figure 2-5. In the Compatibility pane, pick your default format in the Save files in this format pop-up menu. You  
may want to select the Transition formula evaluation check box to make sure Excel alerts you to compatibility issues 
with formulas
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Excel typically provides about two dozen formats, but you’re likely to use one of these four 
formats as your standard format:

	Excel Workbook. This is Excel’s default format. Use it if you will be the 
only person to use the workbooks or if your colleagues have a recent 
version of Office—Office 2008 for Mac or a later version, or Office 2007 
for Windows or a later version. Anyone with Office 2004 for Mac or 
Office 2003 for Windows will need to install filters (file converters) to be 
able to open the workbooks.

	Excel Macro-Enabled Workbook. Use this format if you need to include 
macros in your workbooks to perform custom actions. Again, to open 
these workbooks, your colleagues will need to have a recent version of 
Office or either Office 2004 or Office 2003 with filters installed. 

	 Excel Binary Workbook. Use this format if you create large and complex 
workbooks and need to improve performance. Once more, to work with 
these workbooks, your colleagues will need to have a recent version of 
Office or either Office 2004 or Office 2003 with filters installed.

	Excel 97–2004 Workbook. Use this format if your colleagues have 
Office 2004 for Mac, Office 2003 for Windows, or an earlier version of 
Office. You can also use this format for greater compatibility with other 
spreadsheet applications, such as older versions of OpenOffice.org Calc 
(later versions of Calc can handle the Excel Workbook format).

While you’re in the Compatibility preferences pane, make sure that the Transition formula 
evaluation check box at the top of the pane is selected. This setting ensures that when you 
save a workbook in Excel 97–2003 or another format with fewer capabilities than the Excel 
Workbook format, Excel warns you about any formulas that may not appear correctly in 
that format.

Setting AutoRecover to Keep Backups of Your Workbooks  
for Safety
Next, decide whether to keep AutoRecover files of your workbooks. AutoRecover is a safety 
net that automatically saves a copy of each open workbook every few minutes in case 
Excel or your Mac crashes and loses the changes you’ve made. After such a crash, when 
Excel restarts automatically or you restart it manually, it opens the latest AutoRecover files 
for you so you can choose which versions to keep. If you save your workbooks and then 
quit Excel normally (for example, by choosing Excel ➤ Quit), Excel gets rid of the saved 
AutoRecover files.

Note Office 2008 for Mac doesn’t include VBA. So although you can include macros in an Excel 
Macro-Enabled Workbook file, Excel 2008 users won’t be able to run them.



 
61CHAPTER 2: Configuring Excel to Suit the Way You Work

To choose AutoRecover settings, follow these steps:

1. Display the Save preferences pane (see Figure 2-6).

Caution Never rely on AutoRecover as protection against disasters. When AutoRecover works 
as it should, it can save your bacon, but sometimes it doesn’t save everything, especially if Excel 
or your Mac crashes shortly before an AutoRecover save is due. So, you should always save your 
workbooks frequently while working on them and use AutoRecover only if disaster strikes. You 
can save a workbook at any time by pressing Cmd+S, clicking the Save button on the title bar, or 
choosing File ➤ Save from the menu bar.

Figure 2-6. In the Save preferences pane, choose whether to save AutoRecover information and, if so, at what interval. 
You can also choose whether to save preview pictures with new workbooks

2. Select or clear the Save AutoRecover info in every N minutes  
check box.

3. If you select the check box, enter the number of minutes in the text box.

	You can set any interval from 1 minute to 120 minutes.

	An interval of around 3 minutes usually works well, because it saves 
information frequently enough to avoid disaster but doesn’t overly interrupt 
your work by saving constantly.

	If you edit workbooks that contain many worksheets and lots of data, saving 
the AutoRecover files may take long enough to interrupt your work. In this 
case, either increase the AutoRecover interval to make the interruptions less 
frequent or turn AutoRecover off and save the workbook manually whenever 
is convenient. 

Note Also in the Save preferences pane, you can select the Save preview pictures with new 
workbooks check box if you want to create a preview picture in each new workbook. You might 
want to do this if your workbooks are visually distinctive enough to identify using preview pictures. 
If all your workbooks look much the same, you likely won’t find preview pictures helpful. You can 
also enable or disable the preview picture for an individual workbook on the Summary sheet of the 
workbook’s Properties dialog box.



 
62 CHAPTER 2: Configuring Excel to Suit the Way You Work

Making Excel Prompt You to Enter Workbook Properties
In each workbook you save, you can store extra information to help yourself and your 
colleagues identify the workbook, its purpose, and its status. Excel provides slots called 
properties to contain such information. 

Excel fills in some properties for you—for example, it enters your user name in the Author 
property, fills in the Created property with the time you first saved the workbook, and 
updates the Modified property each time you save the document. But filling in the rest of the 
properties is up to you. The best time to get started filling in the properties is when you save 
the workbook for the first time.

To make Excel automatically display the Properties dialog box when you save a workbook 
for the first time, select the Prompt for workbook properties check box in the Settings area 
at the top of the General preferences pane.

Creating Custom Keyboard Shortcuts
Excel comes with various built-in keyboard shortcuts for giving commands. Many of these 
keyboard shortcuts are mapped to commands that appear on the menus, so you can use 
the menus as a quick reference to the shortcuts. For example, if you open the File menu 
(see Figure 2-7), you can see the keyboard shortcuts for New Workbook (Cmd+N), Open 
(Cmd+O), Save (Cmd+S), Save As (Shift+Cmd+S), and so on. 

Note You can open the Properties dialog box at any point by choosing File ➤ Properties. We look 
at the Properties dialog box in Chapter 3.

Figure 2-7. Existing keyboard shortcuts appear next to their commands on Excel’s menus

http://dx.doi.org/10.1007/978-1-4842-1019-2_3
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You can create further keyboard shortcuts for menu commands by using the OS X Shortcuts 
feature. Follow these steps:

1. Ctrl-click or right-click the System Preferences icon on the Dock 
and then click Keyboard to display the Keyboard pane in System 
Preferences.

2. Click the Shortcuts button to display the Shortcuts pane.

Note Unlike earlier versions, Excel 2016 for Mac does not enable you to create custom keyboard 
shortcuts within the app itself. You can create keyboard shortcuts only using the Shortcuts feature 
within OS X, which works only for commands on Excel’s menus.

Figure 2-8. In the Keyboard pane in System Preferences, click the Shortcuts button to display the Shortcuts pane, and 
then click App Shortcuts in the left pane

Note If the System Preferences icon doesn’t appear on the Dock, choose Apple ➤ System 
Preferences from the menu bar to open the System Preferences window. Then click the Keyboard 
icon to display the Keyboard pane.

3. In the left pane, click the App Shortcuts item. The current list of 
shortcuts set for apps appears in the right pane (see Figure 2-8).
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4. Click the Add (+) button to start creating a new shortcut. The Add 
dialog box opens (see Figure 2-9).

Figure 2-9. In the Add dialog box, choose the app, type the command’s name, and press the keyboard shortcut

5. Open the Application pop-up menu and click Microsoft Excel.

6. Click the Menu Title box and then type the command’s name as it 
appears on the menu. You don’t need to type the menu name.

7. Click the Keyboard Shortcut box and press the keys for the keyboard 
shortcut you want to assign.

8. Click the Add button to close the Add dialog box and add the 
shortcut.

Opening One or More Workbooks Automatically  
with Excel
If you want, you can have Excel automatically open one or more workbooks when you 
launch the application. This is handy when you generally need to work with the same 
workbook or workbooks each time you use Excel.

To make Excel open one or more workbooks automatically, create a folder that contains only 
those workbooks. Then go to the General preferences pane, click the Select button to the 
right of the “At startup, open all files in” box, select the folder in the Choose a Folder: 
Microsoft Excel dialog box, and then click the Choose button.

Tip If you want to launch Excel automatically when you log in, Ctrl+click or right-click the Excel 
icon on the Dock. Click or highlight Options to display the Options submenu and then click the Open 
at Login item, placing a check mark next to it.
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Summary
In this chapter, you learned how to configure Excel for Mac to suit the way you work by 
setting essential preferences, including the General preferences, the View preferences, the 
Edit preferences, the Save preferences, and the Compatibility preferences. You also now 
know how to create custom keyboard shortcuts for Excel menu items and how to open 
workbooks automatically when you launch Excel.

With Excel set up the way you want, you’re ready to roll up your sleeves and get to 
work. We’ll start in the next chapter by looking at how to create effective workbooks and 
templates. Turn the page when you’re ready to start.
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Chapter 3
Creating Effective Workbooks 
and Templates
In this chapter, I’ll show you how to create workbooks in which you can enter, edit, and 
manipulate data quickly and effectively. You’ll learn how to save the workbooks, which file 
formats to use when, and how to add property information to help you identify workbooks 
when searching.

You may need to start some workbooks from scratch, but you’ll be able to save time 
and effort by basing other workbooks on templates. Excel comes with a good variety of 
templates, and you can download others from the Office web site; but to save the most time, 
you’ll likely want to create your own templates, as discussed at the end of the chapter.

After seeing how to create and save workbooks, you’ll learn how to organize the worksheets 
in a workbook, how to lay out data effectively, and how to enter data quickly on multiple 
worksheets at the same time. From there, we’ll move on to creating named ranges to identify 
parts of your worksheets easily, and creating a collapsible worksheet by using Excel’s 
outlining feature.

Creating Workbooks from Scratch or from Templates
When you launch Excel, it automatically displays the New tab of the Microsoft Excel dialog 
box (see Figure 3-1) so you can create a new workbook or open one you’ve recently used.  
In this section, we’ll look at how to create a new workbook, either from scratch or based on 
a template; how to save the workbook in a suitable format; and how to enter information in 
its properties to make it easier to identify.
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Creating a New Blank Workbook
When you need a new workbook with no contents or formatting, create it in one of these ways:

	Microsoft Excel dialog box. Click the New tab if it’s not already 
displayed. Then click the Blank Workbook item and click the  
Create button.

	Keyboard. Press Cmd+N.

	Menu bar. Choose File ➤ New Workbook.

Figure 3-1. From the New tab of the Microsoft Excel dialog box, you can create a blank workbook, a workbook 
based on a template on your Mac, or a workbook based on an online template. You can also open a workbook 
you’ve used recently

Note If you don’t want the Microsoft Excel dialog box to open when you launch Excel, you can turn 
it off. With Excel open, choose Excel ➤ Preferences or press Cmd+, (Cmd and the comma key) to 
display the Excel Preferences window. In the Authoring area, click the General icon to display the 
General pane. Clear the Open Workbook Gallery when opening Excel check box, and then click the 
OK button.
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Creating a New Workbook Based on a Template
To create a new workbook based on a template, you use the New tab of the Microsoft 
Excel dialog box (see Figure 3-1). By default, it opens when you launch Excel, but you can 
also display it at any other time by clicking the File button on the Excel window’s title bar, 
choosing File ➤ New from Template from the menu bar, or pressing Cmd+Shift+P.

From here, you can choose the template you want:

	Template on your Mac. To create a new workbook based on a template 
that’s stored on your Mac, click the template in the list on the New tab, 
and then click the Create button.

	Online template. To create a workbook based on a template from 
Microsoft’s Office.com site, click the Search All Templates box in the 
upper-right corner of the New tab and type your search term or terms. 
You don’t need to press Return, because Excel searches as you type. 
Click the result that seems most suitable, and then click the  
Create button.

Creating a New Workbook Based on an Existing Workbook
Templates can save you a lot of time if you set them up right, but often the easiest way  
to create a new workbook is to base it on an existing workbook. To do this, follow  
these steps:

1. Click the File button on the Excel window’s title bar to open the 
Microsoft Excel dialog box. This dialog box shows whichever tab you 
displayed last.

2. Click the tab you need. For example, click the Open tab and then 
click the appropriate location, such as On My Mac; or click the 
Recent tab if you need to use a recent workbook.

3. Navigate to the existing workbook, and then click it.

4. Click the Open button. Excel closes the Microsoft Excel dialog box 
and opens the workbook.

5. Choose File ➤ Save As to display the Save As dialog box, and then 
save the workbook under a name you specify. 

Caution Be sure to use the File ➤ Save As command immediately to save the workbook under a 
different file name so that you don’t inadvertently change the original file.
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Saving a Workbook
To save a workbook for the first time, give the Save command in any of the usual ways—by 
clicking the Save button on the title bar, by choosing File ➤ Save from the menu bar, or by 
pressing Cmd+S. In the Save As dialog box, select the folder in which to save the workbook, 
type the workbook name, and then click the Save button.

When you save a workbook, Excel selects the file type that’s set in the Compatibility 
preferences pane. If you’ve chosen the format you want, as discussed in the section 
“Choosing the Default Format for Saving Workbooks” in Chapter 2, you’re all set. If you 
haven’t chosen a different format, Excel uses the format called Excel Workbook, which 
works well for recent versions of Excel but may cause problems for versions before Excel 
2008 for Mac or Excel 2007 for Windows.

If you need to save the workbook in a different format than the default one, open the File 
Format pop-up menu and click the format you want to use. For example, if you will share the 
workbook with people who use Excel 2004 for Mac or Excel 2003 for Windows (or even 
older versions of Excel), choose the Excel 97–2004 Workbook format.

Protecting a Workbook with Passwords 
You may need to protect important or confidential workbooks with a password. Excel lets 
you use two different types of passwords:

	Password to open. This is a password that anyone who wants to open 
the workbook must provide. Without the right password, Excel won’t 
open the workbook. Use a password to open when you want to make 
sure that only authorized people can open the workbook.

Tip If you start recording or writing macros to automate your work in Excel, you’ll need to use a 
workbook format that can contain macros, because the Excel Workbook format can’t. Use the Excel 
Macro-Enabled Workbook format for recent versions of Excel, or use the Excel 97–2004 format if 
the workbook is for Excel 2004, Excel 2003, or an earlier version. Excel 2008 for Mac doesn’t run 
macros.

Note The latest Excel file format (the one called simply Excel Workbook) is technically superior 
to the earlier file format (Excel 97–2004 Workbook or Excel 97–2003 Workbook). Using the Excel 
Workbook format, you can create workbooks containing more worksheets and each worksheet 
can have many more rows and columns. This file format is also more resistant to data corruption. 
But for normal-size spreadsheets, such as those most business users and home users create, the 
earlier file format still works just fine.

http://dx.doi.org/10.1007/978-1-4842-1019-2_2
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	Password to modify. This is a password that anyone who wants to 
open the original copy of the workbook must provide. Without the 
right password, Excel lets you open a copy of the workbook, but not 
the original file. Use a password to modify when you need to protect a 
particular workbook against changes but want to allow free access to 
the information in the workbook.

The best time to put password protection in place is the first time you save the workbook. 
Follow these steps:

1. In the Save As dialog box, click the Options button to display the 
Save Options dialog box (see Figure 3-2).

Figure 3-2. In the Save Options dialog box, you can apply a password to open, a password to modify, or both. You can 
also set Excel or to recommend that others open the workbook as read-only

2. To apply a password to open, type it in the Password to open text box.

3. To apply a password to modify, type it in the Password to modify text box.

4. If you want to recommend that people open the workbook in a read-
only state, so that they can’t save changes to it, select the Read-only 
(recommended) check box.

Caution Avoid using the Read-only (recommended) feature. Unless your colleagues are 
exceptionally amenable, it won’t prevent them from editing the workbook. To force them to open 
the workbook as read-only, give the workbook a password to modify, and don’t share it with  
your colleagues.

5. Click the OK button. If you set either kind of password, Excel 
displays the Confirm Password dialog box (see Figure 3-3) prompting 
you to enter it again (to make sure you got it right). Type the 
password, and then click the OK button.
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6. After Excel returns you to the Save As dialog box, finish saving the 
workbook as usual.

When you open a workbook protected with a password, Excel displays the Password 
dialog box. The left screen in Figure 3-4 shows the Password dialog box for a password to 
open; either you provide the password, or you can’t open the workbook. The right screen in 
Figure 3-4 shows the Password dialog box for a password to modify; here, you can either 
provide the password and click the OK button to open the workbook for editing, or click the 
Read-Only button without providing the password to open the workbook without being able 
to save changes to it.

Figure 3-3. Type the password again in the Confirm Password dialog box. If you set both a password to open and a 
password to modify, the Confirm Password dialog box opens twice—the first time for the password to open (which it 
calls the “password to proceed”), the second time for the password to modify

Figure 3-4. When you try to open a workbook protected with a password to open, the Password dialog box requests 
the password (left). If the workbook has a password to modify, the Password-Protected dialog box opens (right).  
You can click the Read-Only button to open the workbook without providing the password
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To remove the password from a workbook, follow these steps:

1. Open the workbook, providing the password when Excel demands it.

2. Choose File ➤ Save As to display the Save As dialog box.

3. Click the Options button to display the Save Options dialog box.

4. Delete the password in the Password to open text box or the 
Password to modify text box, as appropriate.

5. Click the OK button to close the Save Options dialog box. Excel 
returns you to the Save As dialog box.

6. Click the Save button, saving the workbook with its original name 
and location. Excel displays a dialog box to confirm that you want to 
overwrite the file.

7. Click the Replace button. Excel saves the workbook without the 
password.

Entering Workbook Properties
If you selected the Prompt for workbook properties check box in the General preferences 
pane, Excel displays the Properties dialog box automatically when you save a workbook 
for the first time. As you can see in Figure 3-5, the Properties dialog box contains five 
tabs: General, Summary, Statistics, Content, and Custom. You can enter data on only 
the Summary tab and Custom tab, so start by clicking the Summary tab to bring it to 
the front. 
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Note The General tab of the Properties dialog box contains readouts for the file name, type (for 
example, Microsoft Excel Workbook), location (the folder that contains the workbook), created date 
(when you first saved the workbook), and last-modified date (when you last saved the workbook). 
Excel doesn’t compile this information until you first save the workbook, so the fields will be blank 
when Excel displays the Properties dialog box automatically when you’re saving a file for the first 
time. The General tab also contains a Read-Only check box and a Hidden check box. The Statistics 
tab contains readouts of when the file was created, last modified, and last printed; the name of the 
user who last saved it; the revision number; and the total editing time. The Content tab contains a 
list of the document’s worksheets, chart sheets, macro sheets, and dialog sheets.

Figure 3-5. Enter the workbook’s details in the fields on the Summary tab of the Properties dialog box
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Entering Standard Properties on the Summary Tab
Enter the relevant details in the fields on the Summary tab—the workbook’s title and subject, 
your name, your manager’s name, and so on. Excel puts your user name in the Author 
box but leaves the others up to you. Even if Excel enters your name correctly (rather than 
something like Authorized User, which may be set as your user name), you may want to 
change the Author field to include coworkers or a business team—or to put the blame for 
the workbook on your manager.

Select the Save preview picture with this document check box if you want Excel to include 
a preview in the workbook. Saving a preview can make the workbook easier to recognize in 
Quick Look, and it makes the workbook file only a little larger, so it’s usually a good idea.

Entering Extra Data on the Custom Tab
The fields on the Summary tab are enough to store essential metadata, but if you need to 
manage your workbooks tightly, you’ll want to store more property information in them. To 
do so, click the Custom tab to display it (see Figure 3-6). Here you’ll find a list of built-in 
properties including Client, Date completed, Department, and Project. You can also create 
your own properties.

Tip You can use Spotlight to search using the Title, Subject, Authors, Keywords, and Comments 
fields—so you’ll probably want to fill in these fields in your workbooks.

Note In the Hyperlink base box, you can enter the URL that forms the basis for hyperlinks in the 
workbook. For example, if all the URLs start with http://www.surrealmacs.com, enter that 
URL in the Hyperlink base box. You then need enter only the remaining part of each URL in the 
worksheet. (For URLs that don’t use the hyperlink base, enter the full URL in the worksheet.)

http://www.surrealmacs.com/
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To create custom properties, you type their names in the Name text box. You can also assign 
to a property the contents of the first cell in a named range in the workbook. This capability 
enables you to store the contents of specific cells automatically in the properties and thus 
have them indexed along with the other property information.

To add property information, follow these steps:

1. Choose the property:

	If the property is built-in, click its name in the Name list box.

	To create a custom property, type a new name in the Name box.

2. In the Type pop-up menu, select the appropriate type for the 
property: Text, Date, Number, or Yes or no. This choice isn’t relevant 
if you’re linking the property to a range in the workbook.

Figure 3-6. On the Custom tab of the Properties dialog box, you can enter data for a wide range of built-in properties or 
create extra properties of your own. You can also link a property to content in the workbook
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3. Enter the data for the property as appropriate:

	Text, Date, or Number value. Type the value in the Value text box.

	Yes or no. Select the Yes option button or the No option button.

	Information contained in a named range in a worksheet. Select 
the Link to content check box. Excel displays a Source pop-up 
menu that contains the named ranges in the workbook. Select 
the range from this list.

Note The section “Identifying Parts with Named Ranges,” later in this chapter, explains how to 
create named ranges.

4. Click the Add button. Excel adds the property and data to the 
Properties list box.

To delete a field, select it in the Properties list box and click the Delete button.

Finding Your Workbooks by Using Properties
When you’ve entered properties in your workbooks, you can use the property information 
to identify the workbooks more easily when searching with Spotlight. This is great when you 
have many workbooks and need to find the right one quickly.

To search using property information in Spotlight, follow these steps:

1. Ctrl+click or right-click the Finder icon on the Dock, and then click 
New Finder Window on the context menu to open a new Finder 
window. If you don’t have any other Finder windows open, you can 
also simply click the Finder icon on the Dock to open a new window.

2. Navigate to the folder where you want to start the search. For 
example, if you keep all your workbooks in the same folder, select that 
folder rather than searching your whole Mac and its connected drives.

3. Choose File ➤ Find or press Cmd+F to switch to Search mode.

4. In the Search bar at the top of the window, click the folder you 
selected in step 2.

5. On the line of search controls under the Search bar, open the Any 
pop-up menu, and then click Other.

6. Type Microsoft Excel Workbook in the text box that the Finder 
displays when you select Other in the pop-up menu. Excel displays 
the files of that type in the folder you selected. Figure 3-7 shows the 
search at this intermediate stage.
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7. Click the + button at the right end of the line of search controls to 
display another line of controls for refining the search.

8. On the line of search controls, open the Any pop-up menu, and then 
click Other.

9. Click the + button at the end of the first line of search controls to 
display another line.

10. Open the left pop-up menu, and then click Other to display the 
Select a search attribute dialog box (see Figure 3-8).

Figure 3-7. After adding property information to your workbooks, you can locate workbooks using their properties.  
This search currently shows Microsoft Excel Workbook files in the selected folder and its subfolders

Figure 3-8. In the Select a search attribute dialog box, click the attribute you want to search by. Select the In Menu 
check box if you want to make the attribute easier to use in searches
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11. Click the attribute (in other words, the property) you want to 
use for the search. Using the Title, Subject, Authors, Keywords, 
and Comment attributes is usually the best way of finding Excel 
workbooks for which you’ve set properties.

Figure 3-9. Choosing an Excel workbook property such as Comment enables you to find exactly the workbooks you need

Tip If you will need to search by a particular property frequently, select the In Menu check box on 
its row to make OS X include the property in the pop-up menu. That way, you won’t need to open 
the Select a search attribute dialog box to reach the property.

12. Click the OK button to close the Select a search attribute dialog box. 
The attribute you selected appears in the pop-up menu.

13. Use the remaining controls on the line to specify the comparison. 
For example, use Comment contains draft to search for workbooks 
whose Comment property includes the word “draft,” as in Figure 3-9.

14. Add any other search criteria needed. For example, you may want to 
find only workbooks modified in the past two weeks, or ones whose 
Authors property includes your boss.

As you complete each condition, the Finder window displays the list of matching workbooks. 
As soon as you identify the workbook you want, you can open it by double-clicking it. Or if 
you need to look quickly at its contents without opening it, press Spacebar to use the Quick 
Look feature.
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Saving Your Workbooks for Use with Older  
Versions of Excel
Over the years, Microsoft has added many features to Excel and has changed its file format 
several times. As a result, two problems occur:

	An older version of Excel may not be able to open a workbook you 
create in Excel 2016. If the older version can open the workbook, it may 
not display correctly.

	An older version of Excel can’t support the features that have been 
added to Excel in subsequent versions. For example, Microsoft added 
sparklines (in-cell charts) in Excel 2011; earlier versions, such as Excel 
2008 and Excel 2004, don’t have sparklines.

You can work around the first problem by choosing a suitable file format:

	Excel Workbook format. Use this format for sharing with Excel 2016 for 
Mac or Excel 2016 for Windows, Excel 2013 for Windows, Excel 2011 
for Mac, Excel 2010 for Windows, Excel 2008 for Mac, or Excel 2007 for 
Windows. You can also use it for sharing with Excel 2004 for Mac or 
Excel 2003 for Windows provided that computer has installed filters that 
enable it to read this file format (which Microsoft introduced in Excel 
2007). This format uses the .xlsx file extension. 

	 Excel 97–2004 Workbook format. Use this format for sharing with Excel 
2004 for Mac, Excel 2003 for Windows, or older versions of Excel. This 
format, which uses the .xls file extension, is also good for sharing with 
other spreadsheet applications.

Note  You can download the filters for free from the Microsoft web site (www.microsoft.com/
downloads/). For Windows, look for the Microsoft Office Compatibility Pack for Word, Excel, and 
PowerPoint File Formats download. For Mac, click in the Search Microsoft.com field and enter 
“Open XML File Format Converter for Mac” as your search term. Get the latest version of the 
converter, which may not appear at the top of the list.

Tip When you’ve created a search like this, you can save it as a Smart Folder by clicking the Save 
button in the upper-right corner of the Search window. A Smart Folder is OS X’s name for a saved 
search. In the Specify a name and location for your Smart Folder dialog box that opens, type the name 
for the Smart Folder and select the folder in which to store it; the default folder, the Saved Searches 
folder, works well unless you have somewhere better. Select the Add To Sidebar check box if you want 
to add the Smart Folder to the Search For list in the Sidebar, where you can reach it in moments.

http://www.microsoft.com/downloads/
http://www.microsoft.com/downloads/
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To save a workbook file in a format different from the one it currently uses, follow these steps:

1. Choose File ➤ Save As from the menu bar or press Cmd+Shift+S to 
display the Save As dialog box.

2. In the File Format pop-up menu, choose the format you want to use.

3. Optionally, change the file name in the Save As text box, or choose  
a different folder. Because the Excel Workbook format and the  
Excel 97–2004 Workbook format use different file extensions, you 
usually needn’t change the name—but having two workbooks with 
almost identical names can be confusing.

4. Click the Save button. Excel closes the Save As dialog box and 
saves the workbook.

The second problem is trickier. Whereas Excel 2011 provided a tool called the Compatibility 
Report palette to help you identify features that Excel might not carry through to a different 
file format, Excel 2016 simply warns you that features “will not work or may be removed” 
(see Figure 3-10). Excel doesn’t tell you which features may be problematic, so you will need 
to review the file in its new format to see what’s missing—or circulate the workbook and wait 
for your colleagues to complain.

Figure 3-10. Excel warns you when you save a workbook in a format that may not support all its features

Organizing the Worksheets in a Workbook
When you create a blank workbook, Excel gives it the number of sheets set in the Sheets in 
new workbook box in the General preferences pane—by default, a single worksheet. If you 
need more worksheets, you can easily insert them. And you can get rid of any worksheets 
you no longer need.

Excel gives each worksheet a default name at first—Sheet1, Sheet2, and so on. Usually, you 
want to give the worksheets descriptive names so you can easily identify them. You may 
also need to rearrange the worksheets into a different order.
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Figure 3-11. Click the Delete button to confirm that you want to delete the worksheet

Inserting a New Worksheet
To insert a new worksheet, take one of these actions:

	Insert a new worksheet after the last existing worksheet. Click the Insert 
Sheet button that appears on the tab bar after the last worksheet tab.

	Insert a new worksheet after a particular worksheet. Ctrl+click or  
right-click the existing worksheet, and then click Insert Sheet on the 
context menu. 

Naming a Worksheet
To make a worksheet easier to identify, give it a descriptive name. Double-click the 
worksheet’s tab to select the default name, type the name you want, and then press Return 
to apply the name. You can use up to 31 characters in the name—enough for several words. 

Changing a Worksheet’s Tab Color
If you want to make a worksheet’s tab stand out, Ctrl+click or right-click the tab, click Tab 
Color to display the Tab Color panel, and then click the color for the tab. 

Deleting a Worksheet
To delete a worksheet, Ctrl+click or right-click its tab, and then click Delete on the context 
menu. Excel displays an Alert dialog box (see Figure 3-11) to double-check that you’re 
prepared to delete it; click the Delete button to go ahead. 

Tip Excel’s default keyboard shortcut for inserting a new worksheet after the active worksheet is 
Shift+F11. This keyboard shortcut works only if OS X isn’t using F11 for a different purpose, such 
as the Show Desktop feature in Exposé.

Note If you copy a worksheet, the copy gets the same tab color as the original—so you may want 
to change the color to make the copy easier to distinguish.
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Rearranging the Worksheets in a Workbook
To get a workbook’s worksheets in the order you want, you can rearrange them.

The quick way to move a worksheet is to click its tab, drag it left or right until Excel 
displays a downward arrow between the worksheets where you want to place it, and 
then drop it.

Dragging a worksheet tab is easy for short distances, but when you need to move a 
worksheet further, use the Move or Copy dialog box instead. You can also use the Move 
or Copy dialog box to move or copy worksheets to a different workbook. Follow  
these steps:

1. If you want to move or copy the worksheets to a different workbook, 
open that workbook.

2. In the source workbook, Ctrl+click or right-click the worksheet’s tab 
to display the context menu. To move multiple worksheets, select 
them, and then Ctrl+click or right-click one of the selected tabs.

3. On the context menu, click the Move or Copy item to display the 
Move or Copy dialog box (see Figure 3-12).

Tip To move two or more worksheets, select them first. To select a range of worksheets that 
appear next to each other, click the first worksheet’s tab, and then Shift+click the tab for the 
worksheet at the other end of the range. To select worksheets that aren’t next to each other, click 
the first worksheet’s tab, and then Cmd+click each other worksheet’s tab in turn.

Note If the worksheet contains no data, Excel deletes it without displaying the Alert dialog box.
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4. In the To book pop-up menu, make sure the current workbook 
is selected unless you want to move the worksheet to another 
workbook—in which case, select that workbook.

5. In the Before sheet list box, click the worksheet before which you 
want to position the worksheet you’re moving. If you want to put the 
worksheets at the end of the workbook, select the (move to end) item.

6. Select the Create a copy check box if you want to copy the 
worksheet to the destination rather than move it. Copying tends to 
be most useful when the destination is another workbook, but you 
can copy within a workbook as well.

7. Click the OK button to close the dialog box. Excel moves or copies 
the worksheet to the destination you chose.

Four Easy Rules for Laying Out Your Worksheets
Excel gives you a great deal of flexibility in how you lay out your worksheets. Each 
worksheet contains more than 16 billion cells, and you can put pretty much as many 
worksheets in a workbook as you want. 

Figure 3-12. Use the Move or Copy dialog box to move one or more worksheets farther than you can comfortably drag 
within a workbook, or to move or copy worksheets to another open workbook
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Here are four rules to follow when laying out your worksheets to make them as easy as 
possible to use.

	Put different topics on different worksheets. Given that Excel’s 
worksheets can contain a huge amount of information, you may feel 
tempted to put all your data on a single one. But usually it’s better to 
break the data up and put a different topic on each worksheet. 

	 Divide up your data by columns. Lay out the data so that the cells in 
any given column contain the same type of data. Doing this enables you 
to sort and filter the range by rows.

	Put important data above the range rather than beside it. When you 
need to include notes or other explanatory data, put that data above the 
range it’s related to. Don’t put the data to the left or right of the range, 
because Excel may hide the data if you filter the range to show only 
certain values.

	Separate your data ranges from each other. If you include several 
different types of data in the same worksheet, put each type in a 
separate range, with one or more blank columns and one or more blank 
rows between the ranges. Having this extra space makes it easier for 
both Excel and you to identify and select the ranges individually.

Entering Data on Multiple Worksheets at Once
You may sometimes be able to save time by entering data on multiple worksheets at once. 
For example, if a workbook needs a separate worksheet for each month’s sales, you may 
need to create 12 worksheets with a similar structure.

To enter the data, follow these steps:

1. Create the worksheets if they don’t already exist.

2. Select the tab of each worksheet you want to receive the data. For 
example, click the first tab, and then Shift+click the last tab. The selected 
tabs appear white rather than gray, as in Figure 3-13. Excel displays 
[Group] after the workbook’s name in the title bar as a reminder.

Tip Give the worksheet tabs descriptive labels so you can easily pick the worksheet you want. 
If a workbook has so many worksheets that navigating with worksheet tabs is awkward, create a 
summary worksheet at the front containing a list of the other worksheets and their contents—and 
hyperlinks you can click to jump directly to each sheet.

Note If you pack a huge number of worksheets into a workbook and populate them all with data, 
you may find that Excel slows your Mac down. If this happens, move some of the worksheets into 
another workbook to improve performance.
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3. You can now enter the data in the cells of the worksheet that’s 
displayed. Excel enters the same data in each of the other selected 
worksheets.

4. When you’ve finished working with the group, either Shift+click the 
active tab or click an unselected tab to cancel the grouping.

Identifying Parts with Named Ranges
When you’re setting up formulas in your workbooks, you’ll often need to refer to particular 
cells and ranges. You can always refer to cells and ranges using their addresses, but these 
can be hard to remember—especially if you change their location by adding cells, rows, or 
columns to your worksheet.

To make your references easier to enter and recognize, you can give a name to any cell or 
range. You can then refer to the cell or range by that name. Excel tracks the current position 
of each name, so even if you add or delete cells (or rows or columns), you can still use the 
name without worrying about exactly where it is.

You can also use named ranges to navigate your worksheets easily: To go to a named range, 
open the pop-up menu in the reference area and click the range’s name.

Assigning a Name to a Cell or Range
You can assign a name to a cell or range either quickly using the Reference area or more 
formally using the Define Name dialog box. The advantage to using the Define Name dialog 
box is that you can manage your existing range names from there too.

Figure 3-13. To enter data on multiple worksheets at once, select the tab for each worksheet, so that Excel adds 
[Group] to the title bar. You can then enter the data as usual in the worksheet that’s displayed
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Figure 3-14. In the Define Name dialog box, type the name you want to assign the cell or range so you can easily refer to it

These are the rules for creating names:

	The name must start with a letter or an underscore.

	The name can contain only letters, numbers, and underscores. It can’t 
contain spaces or symbols.

	The name must be unique in the workbook.

Assigning a Name to a Cell or Range Quickly
To assign a name to a cell or range quickly using the Reference area, follow these steps:

1. Select the cell or range you want to name.

2. Click in the Reference area. Excel selects its current contents, which 
is the reference of the active cell (for example, B5).

3. Type the name for the cell or range, and then press Return to apply it. 

Assigning a Name to a Cell or Range with the Define Name Dialog Box
To assign a name to a cell or range using the Define Name dialog box, follow these steps:

1. Select the cell or range you want to name.

2. Choose Insert ➤ Name ➤ Define from the menu bar to display the 
Define Name dialog box (shown in Figure 3-14 with settings chosen).

Note If you type an existing name in the Reference area, Excel selects that cell or range when  
you press Return—just as if you’d opened the pop-up menu in the Reference area and then clicked 
the name.
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Note In order to create names, each heading must begin with a letter rather than a number.  
So if you need to create names for cells containing (say) years, you need to preface the numbers 
with one or more letters—for example, Year 2015 rather than plain 2015.

3. In the Enter a name for the data range text box, type the name for 
the cell or range.

4. Make sure that the Select the range of cells box shows the right cell 
or range. If not, select the right cell or range in the worksheet. If you 
need to get the Define Name dialog box out of the way, you can click 
the Collapse Dialog button, but most likely you won’t need to.

5. If you want to create only this one name, click the OK button to apply 
the name to the range and close the Define Name dialog box. If you 
want to create more names before you close the Define Name dialog 
box, click the Add button (the + button).

Creating Range Names Automatically 
If your worksheet has headings in the first column or last column or the first row or last row 
of an area, you can have Excel automatically create range names for you. This feature can 
save you time and effort.

When Excel creates the named ranges, it makes each an equal-sized section of the range 
you select. For example, if you create named ranges using the top row of the selection 
(A1:F6) shown in Figure 3-15, Excel creates a range named Stockton for cells B2:B6, a range 
called Modesto for cells C2:C6, and so on. Excel replaces spaces, punctuation, symbols, 
and other characters in the headings that aren’t allowed in names with underscores—for 
example, the heading City of Industry produces the name City_of_Industry.

Figure 3-15. Creating named ranges using the headings in this selection produces ranges named Stockton for the 
range B2:B6, Modesto for the range C2:C6, and City_of_Industry for the range F2:F6

To create names automatically, follow these steps:

1. Enter the headings in the worksheet.
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Note When selecting the range from which to create labels, you must select more than one row 
(if the headings are in a row) or more than one column (if the headings are in a column). Otherwise, 
Excel displays the The Selection Is Not Valid dialog box. If this happens, click the OK button and 
change your selection.

Figure 3-16. In the Create Names dialog box, select the check box for each column and row that contains the headings 
you want to turn into range names

2. Select the range that contains the headings. The headings must be in 
the top row, bottom row, left column, or right column of the selection.

3. Choose Insert ➤ Name ➤ Create to display the Create Names 
dialog box (see Figure 3-16).

4. In the Create names in list, select the Top row check box, the Left 
column check box, the Bottom row check box, or the Right column 
check box, as appropriate.

5. Click the OK button. Excel closes the Create Names dialog box and 
creates the names.

Excel doesn’t display a dialog box or otherwise confirm that it has created the names. If you 
want to check that the names are there, open the pop-up menu on the Reference area and 
you’ll see them in alphabetical order.

Using a Range Name in Your Formulas
After you name a range, you can use the name in your formulas instead of the cell reference 
or range reference. Named ranges can be a great time-saver, because names are much 
easier to remember and type than the cell references or range references. For example, if 
you give a cell the name Interest_Rate, you can use it in a formula like this:

=B1*Interest_Rate
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Tip If you want to create a list of all the range names in a worksheet along with their locations, 
position the active cell where you want the list to start, choose Insert ➤ Name ➤ Paste to display 
the Paste Name dialog box, and then click the Paste List button.

Figure 3-17. Use the Paste Name dialog box to paste a range name into a formula. You can also paste the whole list of 
range names and their locations for reference

When your range names are straightforward like this, you may want to just type them in. 
Other times, you may find it easier to paste a name in like this:

1. Move the active cell to where you want the formula.

2. Start the formula as usual. For example, type =.

3. When you reach the part of the formula that needs the name, choose 
Insert ➤ Name ➤ Paste to display the Paste Name dialog box  
(see Figure 3-17).

4. In the list box, click the range name you want to paste.

5. Click the OK button. Excel closes the Paste Name dialog box and 
pastes in the name.

Deleting a Range Name 
To delete a range name, follow these steps:

1. Choose Insert ➤ Name ➤ Define from the menu bar to display the 
Define Name dialog box.

2. Click the range name in the Names in workbook list box.

3. Click the Delete button (the – button).

4. Delete other range names as needed, then click the Close button to 
close the Define Name dialog box.
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Figure 3-18. Use Excel’s outline features to create a worksheet that you can collapse and expand to show only the 
sections you need

Changing the Cell or Range a Name Refers To
If you need to change the cell or range a name refers to, follow these steps:

1. Choose Insert ➤ Name ➤ Define from the menu bar to display the 
Define Name dialog box.

2. Click the existing name in the Names in workbook list box.

3. Triple-click in the Select the range of cells box to select the current 
reference.

4. In the worksheet, click the cell or select the new range. (You can 
click the Collapse Dialog button first if you need to reduce the Define 
Name dialog box, but usually it’s easier just to work around it.)

5. Click the OK button if you want to make the change and close the 
Define Name dialog box. Click the Add button (the + button) if you 
want to make the change but keep the Define Name dialog box open.

Creating a Collapsible Worksheet by Outlining It
Worksheets that contain many columns or rows of data can become hard to navigate even 
if you freeze the headings on screen the way you learned in Chapter 1. To make navigation 
easier, you can use Excel’s outlining feature to create a collapsible worksheet, and then expand 
only those sections you need to see at any particular time. Figure 3-18 shows a worksheet 
containing an outline with some rows and columns expanded and others collapsed.

http://dx.doi.org/10.1007/978-1-4842-1019-2_1
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Outlining works best for worksheets whose data is arranged in a structure or hierarchy. You 
can create up to eight levels for rows and eight levels for columns, giving you fine control 
over the outlines.

You can have Excel create an outline automatically for you from the structure it detects in a 
worksheet you’ve laid out with formulas. This is often the best way to start. If you find the 
automatic outline isn’t what you need, you can create an outline manually instead, putting 
the levels exactly where you want them.

Having Excel Create an Outline Automatically
To have Excel create an outline automatically, you must set up the structure of the worksheet 
with the formulas in place. Excel uses the formulas to determine the hierarchy of the outline, 
so if the formulas aren’t there, outlining doesn’t work. You don’t need to enter all the rows 
and columns of data—just those that contain the formulas and enough of the data rows and 
columns for the formulas to refer to.

The left screen in Figure 3-19 shows the beginning of a worksheet structured with formulas 
that will produce an outline. Here’s what you can see:

	The leftmost column (column A) contains the divisions, states, and city 
offices of a large and nefarious organization that we’ll allow to remain 
nameless. You can see the Western Division (which contains California, 
Oregon, Washington, Idaho, Nevada, Utah, and Arizona) and the Central 
Division (which includes New Mexico, Montana, Colorado, and various 
states you can’t see).

	Each state contains just a couple of the offices to get the structure right. 
Once the structure is in place, you can add the extra rows needed.

	Each state’s row contains a SUM( ) formula that adds up the results of 
the city offices. For example, the California row contains the formula 
=SUM(B4:B5) in cell B3, adding the rich pickings from Bakersfield  
and Chico.

	Each division’s row contains a SUM( ) formula that adds up the results 
of the division’s states. For example, the Western Division row contains 
the formula =SUM(B3,B6,B9,B12,B15,B18,B22) in cell B2, adding the 
results from California, Oregon, and so on. 
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When you’ve got the formulas in place, choose Data ➤ Outline ➤ Group ➤ Auto Outline 
from the Ribbon or Data ➤ Group and Outline ➤ Auto Outline from the menu bar to 
create the outline automatically. The right screen in Figure 3-19 shows the same range of 
data turned into an outline with three levels. You can click one of the – signs in the outlining 
bar on the left to collapse a section, and click the + sign that replaces the – sign to expand 
a section again.

If the outline turns out the way you want it, you can enter the remaining formulas and 
data. In many cases, you’ll be able to use the AutoFill feature (discussed in Chapter 1) to 
automatically insert the formulas in a row or column based on an existing formula.

If the automatic outline doesn’t suit you, try changing the settings for automatic outlining,  
as discussed next. Alternatively, clear the outline by choosing Data ➤ Outline ➤ Ungroup ➤ 
Clear Outline from the Ribbon or Data ➤ Group and Outline ➤ Clear Outline from the menu 
bar. You can then create your outline manually, as discussed in the section after next.

Figure 3-19. By setting up a worksheet with a hierarchy of formulas (left), you can use Excel’s automatic outlining 
feature to create an outline based on the formulas (right)

http://dx.doi.org/10.1007/978-1-4842-1019-2_1
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Changing the Settings for Outlining 
To change the settings that Excel uses for outlining, follow these steps:

1. Choose the data range:

	To change an existing outline, click any cell in the outline.

	To create a new outline, select the data range.

2. Choose Data ➤ Group and Outline ➤ Settings from the menu bar 
to display the Settings dialog box (see Figure 3-20).

3. In the Direction area, select the Summary rows below detail check 
box if the summary rows are below the detail rows. Select the 
Summary columns to right of detail check box if the worksheet 
uses summary columns that appear to the right of the columns they 
summarize.

4. Select the Automatic styles check box if you want Excel to 
automatically apply styles to the outline to differentiate the different 
outline levels. Excel applies the RowLevel_1 style to the first level of 
rows, the RowLevel_2 style to the second level of rows, and so on. 
For the columns, Excel uses styles named ColLevel_1, ColLevel_2, 
and so on.

5. Click the command button to close the Settings dialog box and take 
the action you want:

	Create. Click this button to create a new outline.

	Apply Styles. Click this button to apply styles to an existing 
outline. You’ll need to have selected the Automatic styles  
check box.

	OK. Click this button to apply the Direction settings you’ve 
chosen to an existing outline.

Figure 3-20. Use the Settings dialog box to control the way Excel creates an automatic outline from your worksheet
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Figure 3-21. In the Group dialog box (left) or the Ungroup dialog box (right), select the Rows option button or the 
Columns option button, as appropriate

Tip You can speed up the process of grouping or ungrouping rows or columns by selecting entire 
rows or entire columns rather than just cells in them. When you do this, Excel doesn’t display the 
Group dialog box or the Ungroup dialog box, because it can tell from the selection whether it’s rows 
or columns you want to group or ungroup.

Creating an Outline Manually
Often, it’s not convenient to build the structure of a worksheet fully so that Excel can outline 
it automatically. In these cases, create the outline manually by using the Group command. 
You can also use the Group command (and its counterpart, Ungroup) to adjust an outline 
Excel has created for you.

Grouping Rows or Columns
To group rows or columns, follow these steps:

1. Select cells in the rows or columns you want to group. For example:

	To group rows 4 and 5 under row 3, select cells in rows 4 and 5.

	To group columns B, C, and D under column E, select cells in  
columns B, C, and D.

2. Choose Data ➤ Outline ➤ Group from the Ribbon (clicking the main 
part of the Group button rather than its pop-up button) or Data ➤ 
Group and Outline ➤ Group from the menu bar to display the Group 
dialog box (shown on the left in Figure 3-21).

3. Select the Rows option button if you want to group by rows. Select 
the Columns option button if you want to group by columns.

4. Click the OK button to close the Group dialog box. Excel applies the 
grouping.
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Repeat this procedure to create more groups as needed. For example, in the worksheet 
shown earlier in Figure 3-19, you would first group the cities under their states, and then 
group the states under their divisions.

Ungrouping Rows or Columns
To ungroup rows or columns, follow these steps:

1. Select the range you want to ungroup.

2. Choose Data ➤ Outline ➤ Ungroup from the Ribbon (clicking 
the main part of the Ungroup button rather than its pop-up button) 
or Data ➤ Group and Outline ➤ Ungroup from the menu bar to 
display the Ungroup dialog box (shown on the right in Figure 3-21).

3. Select the Rows option button or the Columns option button, as 
appropriate.

4. Click the OK button to close the Ungroup dialog box and remove the 
grouping.

Expanding and Collapsing an Outline
When you have created the outline, you can expand it or collapse it so it shows exactly what 
you need to see. 

Click the Column Level button for the column level you want to see. For example, click the 
Column Level 2 button to display all the second-level columns.

Click the Row Level button for the row level you want to see. For example, click the Row 
Level 3 button to display all of the third-level rows.

Click the + button to expand a collapsed section of rows or columns or the – button to 
collapse an expanded section.

Updating the Outline After Adding or Deleting Rows or 
Columns
After you add or delete rows or columns within the outlined area of a worksheet, you need to 
update the outline. Follow these steps:

1. Place the active cell anywhere in the outlined area.

2. Choose Data ➤ Outline ➤ Group ➤ Auto Outline from the Ribbon 
or Data ➤ Group and Outline ➤ Auto Outline from the menu bar. 
Excel displays the Alert dialog box shown in Figure 3-22.
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Figure 3-22. Click the OK button in this Alert dialog box to update the outline with details of the rows or columns 
you’ve added or deleted

3. Click the OK button. Excel updates the outline.

Removing an Outline
To remove outlining from a worksheet, choose Data ➤ Outline ➤ Ungroup ➤ Clear Outline  
from the Ribbon or Data ➤ Group and Outline ➤ Clear Outline from the menu bar.

Making the Most of Templates 
As you know, each workbook you create in Excel is based on a template. If you create a 
blank workbook, Excel uses a skeleton workbook template that gives you complete freedom 
of movement but doesn’t save you any time. By contrast, if you use a template that comes 
complete with contents and formatting, you may need to fill in only a small amount of 
information to produce a complete workbook.

As you saw earlier in this chapter, Excel comes with a good variety of templates, and you 
can access many more online by searching on the New tab in the Microsoft Excel dialog 
box. But to save the most time, you’ll almost certainly need to create your own templates, 
either from scratch or by customizing existing templates.

To make the most out of templates, follow these suggestions:

	Assess your needs carefully. Examine the workbooks that you and 
your colleagues create most often—sales analysis, project planning, 
budgets, invoices, timesheets, or whatever it may be. Figure out which 
of these workbooks you and your colleagues could create more quickly 
and easily using a template.

	Base the template on an existing workbook or template. If you 
have an existing workbook that contains much (or even some) of the 
information the template will need, open a copy of that workbook, and 
then save it as a template. (You’ll learn these two moves later in this 
section.) You may be able to save further time and effort by copying 
and pasting items from other existing workbooks or templates into 
your new template.
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	Make the template as complete as possible. Needs will vary, but 
you’ll normally want to do the following:

	Insert the number of worksheets most workbooks based on the 
template will need.

	Name the worksheets. Color the worksheet tabs if this will help 
you pick out key tabs quickly.

	Set up each worksheet with standard text and formulas.

	Format cells with validation to ensure users enter suitable values.

	Apply conditional formatting to make extreme values stand out.

	Add comments to cells to explain what information is required 
and what is optional.

	Automate the template with macros. To help users enter and 
manipulate data swiftly and accurately, you may need to add macros to 
your templates.

Creating a Template Based on an Existing Workbook
To create a template based on an existing workbook, follow these steps:

1. Open Excel if it’s not already running.

2. Click the File button on the title bar, or press Cmd+O, to display the 
Microsoft Excel dialog box.

3. Click the Open tab if Excel doesn’t display it at first.

4. Navigate to the folder that contains the existing workbook on which 
you want to base the template, and then click that workbook.

5. Click the Open button to open the workbook.

6. Choose File ➤ Save As Template to open the Save As dialog 
box and automatically select your Templates folder and the Excel 
Template file format.

You can now save the template as described in the next section.

Saving a Template
Excel provides the Save as Template command for saving a template. When you give this 
command, Excel displays the Save As dialog box, automatically switches to your Templates 
folder, and automatically selects the Excel Template item in the File Format pop-up menu. 
For many templates, this is all you need apart from a snappy name; for other templates, you 
may need to change the template format, the folder, or both.
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Note To create a workbook based on a template that’s stored in a folder other than the template 
folders that Excel checks, you need to open the template and then use the File ➤ Save As 
command to save a workbook form the template.

Note If you need to store macros in the template, choose Excel Macro-Enabled Template (.xltm).  
If colleagues using Excel 2004 (Mac) or Excel 2003 (Windows) or earlier versions will need to use 
the template, choose Excel 97–2004 (.xlt) in the Format pop-up menu; this template format can 
contain macros if necessary.

To save the active workbook as a template, follow these steps:

1. Choose File ➤ Save as Template to display the Save As dialog box. As 
just mentioned, Excel selects your Templates folder as the destination folder 
and selects the Excel Template item in the File Format pop-up menu.

2. If necessary, open the File Format pop-up menu, and then click the 
format you need. See the next Note for suggestions.

3. If necessary, change the folder in which to store the template. For example,  
if you plan to share the template with your colleagues, you may want to 
store it in a folder on the network instead of in your Templates folder.

4. Click the Save button.

Summary
In this chapter, you learned how to create workbooks and templates in which you can work 
smoothly and effectively. You now know how to create workbooks based on templates, 
how to choose the best file formats for saving them, and how to add property information 
to make the workbooks easier to identify. You can also create your own templates—basing 
them on existing workbooks or templates if needed.

We also looked at how to organize the worksheets in a workbook, how to lay out data 
logically, and how to enter data quickly on multiple worksheets at the same time. You saw 
how to identify parts of your worksheets quickly by creating named ranges and how to make 
a large worksheet manageable by outlining it.

In the next chapter, I’ll show you how to format your workbooks quickly and efficiently.
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Chapter 4
Formatting Your Worksheets 
Quickly and Efficiently
To make your worksheets show the information you need and present it so that it’s easy to 
understand, you’ll need to format them. This chapter shows you how to format worksheets 
quickly and efficiently using the various tools that Excel provides.

The first essential is to format the worksheet’s rows and columns. You may need to insert 
or delete rows, columns, or blocks of cells; you’ll often need to hide some rows or columns 
to get them out of the way or remove them from inquisitive eyes; and you’ll almost certainly 
need to change some column widths and row heights. We’ll cover this first.

After that, I’ll show you how to format cells and ranges, how to apply conditional formatting 
to quickly flag values that need attention, and how to use data validation to check for invalid 
entries.

Toward the end of the chapter, we’ll look at how to format worksheets quickly using table 
formatting or Excel’s styles, and how to add headers and footers to worksheets to make 
them and their contents easy to identify.

Working with Rows and Columns
In this section, you’ll learn how to insert and delete rows, columns, and cells; change the 
width of columns and the height of rows; and hide rows or columns when you don’t need to 
see them.

Inserting and Deleting Rows, Columns, and Cells
When laying out your worksheets, you’ll often need to insert or delete entire columns or 
rows. Sometimes you may also need to delete a block of cells without deleting an entire 
column or row.
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Inserting Columns and Rows
The easiest way to insert a column or row is to Ctrl+click or right-click the heading of the 
existing column or row before which you want to insert the new one and then click Insert on 
the context menu. 

To insert more than one column or row, select the same number of columns or rows first. For 
example, to insert three columns before column F, drag through the headings of columns 
F, G, and H to select those columns; then Ctrl+click or right-click anywhere in the selected 
headings, and click Insert on the context menu.

You can also insert a column by selecting a cell in the column before which you want to add 
the new column, and then giving either of these commands:

	Ribbon. Choose Home ➤ Cells ➤ Insert ➤ Insert Sheet Columns.

	Menu bar. Choose Insert ➤ Columns.

Similarly, you can insert a row by selecting a cell in the row before which you want to add 
the new row and then giving either of these commands:

	Ribbon. Choose Home ➤ Cells ➤ Insert ➤ Insert Sheet Rows.

	Menu bar. Choose Insert ➤ Rows.

As before, if you want to insert multiple columns or rows, select cells in the corresponding 
number of columns or rows first.

Inserting Some Cells
To insert just some cells, follow these steps:

1. Select the range before which you want to insert the cells.

2. Choose Home ➤ Cells ➤ Insert ➤ Insert Cells to display the Insert 
dialog box (see Figure 4-1).

Note If the Excel window isn’t wide enough for the Insert button, Delete button, and Format 
button to appear in the Cells group, the Cells pop-up button appears instead. Click this button to 
display a pop-up menu with an Insert submenu, a Delete submenu, and a Format submenu. Click 
the appropriate menu, and then make your choice from it.

Note What the Insert button in the Cells group on the Home tab of the Ribbon inserts depends on 
what you’ve selected. Select one or more columns to make the Insert button insert columns; select 
one or more rows to make the Insert button insert rows; or select one or more cells to make the 
Insert button insert cells. If you haven’t selected the appropriate item, click the Insert pop-up button 
rather than the main Insert button, and then choose the item you want from the pop-up menu.
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3. Select the Shift cells right option button to move the existing cells 
to the right. Select the Shift cells down option button to move the 
existing cells down the worksheet. You can also select the Entire row 
option button to insert a whole row or select the Entire column option 
button to insert a whole column, but it’s usually easier to insert a row 
or column by using the methods described earlier.

4. Click the OK button to close the Insert dialog box. Excel inserts the 
cells.

Deleting Columns or Rows
The easiest way to delete a column or row is to Ctrl+click or right-click its heading, and then 
click Delete on the context menu. Alternatively, you can select the row or column and then 
choose Edit ➤ Delete from the menu bar or Home ➤ Cells ➤ Delete (clicking the main part 
of the Delete button) from the Ribbon.

Instead of selecting the column or row, you can click a cell in it, choose Home ➤ Cells ➤ 
Delete (clicking the Delete pop-up button), and then click Delete Columns or Delete Rows, 
as needed. Usually, it’s easier to select the row or column first.

Deleting Some Cells
To delete just some cells, select them, and then choose Home ➤ Cells ➤ Delete ➤  
Delete Cells. In the Delete dialog box (see Figure 4-2) that Excel displays, select the Shift 
cells left option button or the Shift cells up option button, as appropriate, and then click the 
OK button.

Figure 4-1. When you insert a block of cells, click the Shift cells right option button or the Shift cells down option 
button in the Insert dialog box to tell Excel which way to move the existing cells
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Setting Row Height
Excel normally sets the row height automatically to accommodate the tallest character or 
object in the row. For example, if you type an entry in a cell, select the cell, and click the 
Increase Font Size button in the Font group of the Home tab a few times, Excel automatically 
increases the row height so that there’s enough space for the tallest characters. 

If Excel doesn’t set the row height automatically, select the rows you want to affect, and then 
choose Home ➤ Cells ➤ Format ➤ AutoFit Row Height to force automatic fitting.

Automatic row height works well for many worksheets, but you may sometimes need to set 
the row height manually. Use either of these ways:

	Drag the lower border of the row heading. Move the mouse pointer over 
the lower border of the row heading so that the pointer changes to an 
arrow pointing up and down, and then click and drag the border up (to 
make the row shallower) or down (to make the row deeper).

	Use the Row Height dialog box. Ctrl+click or right-click the row heading, 
and then click Row Height on the context menu to display the Row 
Height dialog box (see Figure 4-3). Type the row height you want, and 
then click the OK button.

Note You can also display the Row Height dialog box by choosing Home ➤ Cells ➤ Format ➤ 
Row Height from the Ribbon or Format ➤ Row ➤ Height from the menu bar.

Figure 4-2. When you delete a block of cells, click the Shift cells left option button or the Shift cells up option button in 
the Delete dialog box to tell Excel how to fill the gap in the worksheet

Note In the Delete dialog box, you can select the Entire row option button to delete the row the 
selected cell is in, or select the Entire column option button to delete the column. This is useful 
when you realize you need to delete entire rows or columns rather than just a block of cells. 
Otherwise, you don’t need to open the Delete dialog box to delete rows or columns.
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Setting Column Width
Unlike with row height, Excel doesn’t automatically adjust column width as you enter data in 
a worksheet. This is because the cells in many columns contain entries of varying lengths, 
so automatic adjustment would likely make constant changes.

You can quickly set column width in any of these ways:

	AutoFit a column. Double-click the right border of the column heading. 
Excel automatically changes the column’s width so that it’s wide enough 
to contain the widest entry in the column.

	AutoFit several columns. Select cells in all the columns you want to affect, 
and then double-click the right border of any of the selected column 
headings. Excel automatically fits each column’s width to suit its contents. 
You can also select the cells and then choose Home ➤ Cells ➤  
Format ➤ AutoFormat Column Width from the Ribbon or Format ➤ 
Column ➤ AutoFit Selection. 

	Resize a column by hand. Drag the right border of the column heading 
as far as needed.

	Resize a column precisely. Ctrl+click or right-click the column heading, 
and then click Column Width on the context menu to display the 
Column Width dialog box (see Figure 4-4). Type the column width, and 
then click the OK button.

Tip AutoFit is usually the best way to resize a worksheet’s columns. But if some cells have such 
long contents that AutoFit will create huge columns, set the column widths manually and hide parts 
of the longest contents. You can also wrap the text within a cell so that it occupies as many lines as 
it needs; you’ll learn how to do this in the section “Setting Alignment” later in this chapter.

Setting Row Height
Excel normally sets the row height automatically to accommodate the tallest character or 
object in the row. For example, if you type an entry in a cell, select the cell, and click the 
Increase Font Size button in the Font group of the Home tab a few times, Excel automatically 
increases the row height so that there’s enough space for the tallest characters. 

If Excel doesn’t set the row height automatically, select the rows you want to affect, and then 
choose Home ➤ Cells ➤ Format ➤ AutoFit Row Height to force automatic fitting.

Automatic row height works well for many worksheets, but you may sometimes need to set 
the row height manually. Use either of these ways:

	Drag the lower border of the row heading. Move the mouse pointer over 
the lower border of the row heading so that the pointer changes to an 
arrow pointing up and down, and then click and drag the border up (to 
make the row shallower) or down (to make the row deeper).

	Use the Row Height dialog box. Ctrl+click or right-click the row heading, 
and then click Row Height on the context menu to display the Row 
Height dialog box (see Figure 4-3). Type the row height you want, and 
then click the OK button.

Note You can also display the Row Height dialog box by choosing Home ➤ Cells ➤ Format ➤ 
Row Height from the Ribbon or Format ➤ Row ➤ Height from the menu bar.

Figure 4-3. Use the Row Height dialog box when you need to set a row’s height precisely
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	Resize several columns precisely to the same width. Select the columns 
by dragging through their column headings or by selecting cells in each 
column. Ctrl+click or right-click in the selected column headings, then 
click Column Width on the context menu to display the Column Width 
dialog box. Type the column width and then click the OK button.

Hiding Rows and Columns
Sometimes it’s helpful to hide particular columns and rows so that they’re not visible in the 
worksheet. You may want to do this to keep sensitive data from showing or simply to make 
the part of the worksheet you’re actually using fit on the screen all at once.

To hide a column or row, Ctrl+click or right-click its column heading or row heading and then 
click Hide on the context menu. You can also click a cell in the row or column and choose 
Home ➤ Cells ➤ Format ➤ Hide & Unhide ➤ Hide Row or Home ➤ Cells ➤ Format ➤ 
Hide & Unhide ➤ Hide Column from the Ribbon or Format ➤ Row ➤ Hide or Format ➤ 
Column ➤ Hide from the menu bar.

To unhide a row or column, select the rows above and below it or the columns on either side 
of it. Then Ctrl+click or right-click the selected row headings or column headings and click 
Unhide on the context menu.

Tip To quickly hide the active row or selected rows, press Ctrl+9. To hide the active column or 
selected columns, press Ctrl+0. To unhide a row, select the rows above and below the hidden row, 
and then press Ctrl+Shift+9. To unhide a column, select the columns before and after the hidden 
column, and then press Ctrl+Shift+0.

Note You can also hide and unhide items by choosing Home ➤ Cells ➤ Format ➤ Hide & 
Unhide ➤ Unhide Rows or Home ➤ Cells ➤ Format ➤ Hide & Unhide ➤ Unhide Columns 
from the Ribbon or by choosing Format ➤ Row ➤ Unhide or Format ➤ Column ➤ Unhide from 
the menu bar.

Figure 4-4. Use the Column Width dialog box when you need to set the column width precisely
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Formatting Cells and Ranges
In Excel, you can format cells in a wide variety of ways—everything from choosing how to 
display the borders and background to controlling how Excel represents the text you enter 
in the cell. This section shows you how the most useful kinds of formatting work and how to 
apply them.

Each cell comes with basic formatting applied to it—the font and font size to use and usually 
the General number format, which you’ll meet shortly. So when you create a new workbook 
and start entering data in it, Excel displays the data in a normal-size font.

Understanding the Two Main Tools for Applying Formatting
Excel gives you two main tools for applying formatting to cells and ranges:

	Home tab of the Ribbon. The Font group provides widely used font 
formatting; the Alignment group offers horizontal and vertical alignment, 
orientation, indentation, wrapping, and merging; and the Number group 
gives you a quick way to apply essential number formatting. Figure 4-5 
shows the Font group with its controls labeled. Figure 4-6 shows the 
Alignment group and Number group with their controls labeled.

Tip To control the font and font size Excel uses for new workbooks, choose Excel ➤ Preferences 
or press Cmd+, (Cmd and the comma key). Click the General icon in the Authoring area of the 
Excel Preferences window to display the General pane. Open the Default font pop-up menu and 
click the font you want. The Body Font choice at the top of the list gives you the body font set in the 
workbook’s template; if you change this font, you change the font used in all the styles except the 
Title style (which uses the Heading font). Then choose the size in the Size pop-up menu. Click the 
close button at the left end of the title bar to close the Excel Preferences window.
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Figure 4-6. From the Alignment group on the Home tab of the Ribbon, you can set horizontal and vertical alignment, 
orientation, and wrapping. From the Number group, you can apply number formatting

Figure 4-5. You can quickly apply essential font formatting, borders, and fills from the Font group on the Home tab of 
the Ribbon
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	Format Cells dialog box. When you need to apply formatting types 
that don’t appear on the Home tab of the Ribbon, open the Format 
Cells dialog box and work on its six tabs, which you’ll meet later in this 
chapter. The easiest way to display the Format Cells dialog box is to 
Ctrl+click or right-click a cell or a selection and then click Format Cells 
on the context menu. You can also open the Format Cells dialog box by 
pressing Cmd+1 or choosing Format ➤ Cells from the menu bar.

Controlling How Data Appears by Applying Number 
Formatting
When you enter a number in a cell, Excel displays it according to the number formatting 
applied to that cell. For example, if you enter 42524 in a cell formatted with General 
formatting, Excel displays it as 42524. If the cell has Currency formatting, Excel displays a 
value such as $42,524.00 (depending on the details of the format). And if the cell has Date 
formatting, Excel displays a date such as 3 June 2016 (again, depending on the details of 
the format). In each case, the number stored in the cell remains the same—so if you change 
the cell’s formatting to a different type, the way that Excel displays the data changes to 
match.

Table 4-1 explains Excel’s number formats and tells you the keyboard shortcuts for applying 
them. You can also apply number formatting by using the buttons on the Number Format 
pop-up menu and buttons in the Number group of the Home tab of the Ribbon and by using 
the controls on the Number tab of the Format Cells dialog box (see Figure 4-7).
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Table 4-1. Excel’s Number Formats

Number Format Explanation Examples Keyboard Shortcut

General Excel’s default format for all cells in 
new worksheets.

No specific format, but displays up 
to 11 digits per cell and uses no 
thousands separator. For any entry 
longer than 11 digits, General format 
uses scientific notation (see the 
“Scientific” entry later in this table).

1234567 Industry Ctrl+Shift+~ (tilde)

Number Displays the number of decimal 
places you choose. You can choose 
whether to use the thousands 
separator and how  
to display negative numbers.

1000 1,000 1,000.00 Ctrl+Shift+!

Currency Displays the number of decimal 
places you choose, using the 
thousands separator. You can choose 
which currency symbol to display 
(for example, $) and how to display 
negative numbers.

$2,345.67 –$2,345.67 Ctrl+Shift+$

Accounting Displays the number of decimal 
places you choose, using the 
thousands separator. You can choose 
which currency symbol to use. The 
symbol appears aligned at the left 
edge of the cell. Negative numbers 
appear with parentheses around them.

$  1,000,000 $  
(99.999.00)

—

Date Displays any of a variety of date 
formats.

6/24/2016 Thursday, 
June 24, 2016

Ctrl+Shift+#

Time Displays any of a variety of time 
formats.

11:59:59 PM 23:59:59 Ctrl+Shift+@

Percentage Displays a percent sign and the 
number of decimal places you 
choose.

78.79% 200% Ctrl+Shift+%

Fraction Displays the number as a fraction. 
Fractions tend to be visually confusing 
in spreadsheets, so use them only if 
you must—for example, for betting 
charts.

1/2 1 ¼ —

Scientific Displays the number in exponential 
form, with E and the power to which 
to raise the number. You can choose 
how many decimal places to use.

1.2346E+08 
–9.8765E+07

Ctrl+Shift+^

(continued)
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Table 4-1. (continued )

Number Format Explanation Examples Keyboard Shortcut

Text Displays and treats the data as text, 
even when it appears to be another 
type of data (for example, a number 
or date).

Product List 18 —

Special Displays the data in the format you 
choose: Zip Code, Zip Code + 4, 
Phone Number, or Social Security 
Number.

10013 10013-8295 
(212) 555-9753 722-
86-8261

—

Custom Displays the data in the custom 
format you choose. Excel provides 
dozens of custom formats, but you 
can also create your own formats.

[Various] —

Figure 4-7. Use the Number tab of the Format Cells dialog box when you need access to the full range of number 
formatting
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UNDERSTANDING HOW EXCEL STORES DATES AND TIMES

Excel stores dates as serial numbers starting from 1 (Sunday, January 1, 1900) and running way into the future. 
To give you a couple of points of reference, 42370 represents Friday, January 1, 2016, while 42736 represents 
Saturday, January 1, 2017.

You can enter a date by typing the serial number (if you know it or care to work it out), but it’s much easier 
to type a date in a conventional format, because Excel recognizes most of them. For example, if you type 
1/1/2017, Excel converts it to 42736 and displays the date in whichever format you’ve chosen.

Excel stores times as decimal parts of a day. For example, 42370.25 is 6 a.m. (one quarter of the way through 
the day) on January 1, 2016.

Older versions of Excel used the starting date January 2, 1904, by default for workbooks. Excel 2016 doesn’t 
do this, but you can set the 1904 starting date manually if necessary (for example, if you’re using an older 
workbook with 1904-based dates). To switch to 1904-based dates, choose Excel ➤ Preferences or press 
Cmd+, (Cmd and the comma key). In the Excel Preferences window, click the Calculation icon in the Formulas 
and Lists area to display the Calculation pane. In the When Calculating Workbooks area, select the Use the 1904 
date system check box, and then click the close button at the left end of the title bar.

To create a custom number format of your own, follow these steps:

1. Select a cell that contains the right kind of data. For example, if 
you want to create a custom date format, select a cell with Date 
formatting and a date entered in it.

2. Open the Format Cells dialog box by pressing Cmd+1.

3. Click the Number tab if it’s not displayed at first.

4. In the Category list box, click the Custom item. Excel displays the 
controls for creating a custom format (see Figure 4-8). Your sample 
data appears in the Sample box at the top.



 
113CHAPTER 4: Formatting Your Worksheets Quickly and Efficiently

5. Scroll down the list box until you find the format that’s closest to the 
format you want to create, then click that format. Excel adds the 
codes for the format to the Type text box and shows the sample data 
in that format.

6. Edit the format so that the sample data appears the way you want it 
(see the instructions after this list).

7. Click the OK button to close the Format Cells dialog box.

Figure 4-8. You can create custom number formats by typing them in the Type text box on the Number tab of the 
Format Cells dialog box. Click the most similar format in the list box to give yourself a head start
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To create a custom format, you enter format codes telling Excel how to display the 
information. A custom format can contain a single format, like the date format shown in 
Figure 4-9, but you can include up to four different formats, separated by semicolons:

	First format. How to display positive numbers.

	Second format. How to display negative numbers.

	Third format. How to display zero values.

	Fourth format. How to display text.

Table 4-2 explains the codes for creating custom number formats.

Table 4-2. Codes for Creating Custom Number Formats

Code Effect Example

[color name] Display the color named. Put the appropriate color in brackets as the first 
item in the section: [Black], [Red], [Blue], [Green], 
[White], [Cyan], [Magenta], or [Yellow]. For example, 
#,##0_);[Red](#,##0) displays negative numbers in 
red.

Number Format Codes

# Display a significant digit. ###.# displays three significant digits before the 
decimal point and one significant digit after it.  
(A significant digit is a nonzero figure.)

0 Display a zero if no digit would 
otherwise appear in this place.

000 displays a three-digit number, padding it out 
with leading zeros if necessary. For example, if you 
enter 7, Excel displays 007.

% Display a percentage. #% displays the number multiplied by 100 and with 
a percent sign. For example, 8 appears as 800%.

? Display as a fraction. # ???/??? displays a number and three-digit 
fractions—for example, 9 107/112.

. Display a decimal point. ###.## displays three significant digits before the 
decimal point and two significant digits after it.

, Two meanings: display the 
thousands separator or scale 
the number down by 1,000.

Thousands separator: $#,###,### displays the dollar 
sign, seven significant digits, and the thousands 
separator. Scale by 1,000: €#.##,,, " million" displays 
the euro symbol, one significant digit before the 
decimal point and two after, the number scaled 
down by a million, and the word million (after a 
space). For example, if you enter 12345689, Excel 
displays €1.23 million.

(continued)
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(continued)

Code Effect Example

Date and Time Format Codes

d Display the day in numeric 
format.

d-mmm-yyyy displays 6/1/17 as 1-Jun-2017.

dd Display the day in numeric 
format with a leading zero for 
single-digit days.

dd/mmm/yy displays 6/1/17 as 01/Jun/17. Leading 
zeros can be helpful for standardizing on two-digit 
dates and for aligning date entries.

ddd Display the day as a three-letter 
abbreviation.

ddd dd/mm/yyyy displays 6/1/17 as Thu 01/06/2017.

dddd Display the day in full. dddd, dd/mm/yyyy displays 6/1/17 as Thursday, 
01/06/2017.

m Display the month in numeric 
format.

d/m/yy displays 6/1/17 as 6/1/17.

mm Display the month in numeric 
format with a leading zero.

mm/dd/yy displays 6/1/17 as 06/01/17.

mmm Display the month as a  
three-letter abbreviation.

dd-mmm-yy displays 6/1/17 as 01-Jun-2017.

mmmm Display the month in full. dd mmmm, yyyy displays 6/1/17 as 01 June, 2017.

mmmmm Display the month as a  
one-letter abbreviation.

January, June, and July appear as J; April and 
August appear as A; and so on. This code works 
when you’re short of space and include all the 
months in sequence; if you use only some months, 
it’s confusing.

yy Display the year as a  
two-digit number.

m/d/yy displays 6/1/17 as 6/1/17.

yyyy Display the year in full. dd-mmm-yyyy displays 6/1/17 as 01-Jun-2017.

h Display the hour. h:m displays 2:22 as 2:22.

hh Display the hour with a  
leading zero.

hh:mm displays 2:22 as 02:22.

m Display the minute. h:m displays 2:01 as 2:1.

mm Display the minute with  
a leading zero.

hh:mm displays 2:22 as 02:22. To distinguish mm 
from the months code (also mm), use it immediately 
after hh or immediately before ss.

s Display the second. h:m:s displays 2:22:01 as 2:22:1.

ss Display the second with a 
leading zero.

hh:mm:ss displays 2:22:01 as 02:22:01.

.0, .00, .000 Display tenths, hundredths,  
or thousandths of seconds.

h:mm:ss.000 displays 2:22:01.11 as 2:22:01.110.

Table 4-2. (continued)
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Table 4-2. (continued )

Code Effect Example

A/P Display A for a.m. and P for p.m. h:mm A/P displays 2:22 as 2:22 A. You can use 
uppercase A/P or lowercase a/p to specify which 
case to display.

AM/PM Display AM for a.m. and PM  
for p.m.

h:mm am/pm displays 14:22 as 2:22 PM. Excel uses 
uppercase regardless of which case you use.

[ ] Display the elapsed time in  
the specified unit.

[h]:mm:ss displays the elapsed time in hours, 
minutes, and seconds—for example, 55:38:43.

Text Format Codes

_ Display a space as wide as the 
specified character.

_) makes Excel enter a space the width of a closing 
parenthesis. You’d use this to align positive numbers 
with negative numbers that appear in parentheses.

* Repeat the specified character 
to fill the cell.

*0 makes Excel fill the cell with 0 (zero) characters. 
This format is specialized, but you may need it to 
draw the viewer’s attention to particular cells.

\ Display the following character. [Blue]$#,###.00 \*;[Green]$#,###.00 \D displays 
positive numbers in blue and followed by an asterisk, 
and negative numbers in green and followed by a D.

"string" Display the string of text. $#,##0.00" Net" displays the word Net after the 
entry. Note the leading space between the " and the 
word.

@ Concatenate the specified 
string with the user’s text input.

"Value: "@ enters Value: and a space before the 
user’s text input. You can use this only in the fourth 
section (the text section) of a custom format.

N/A Display the specified character. $ - + = / ( ) { } : ! ^ & ' ' ~ < > [SPACE]

Setting the Workbook’s Overall Look by Applying a Theme
To control the overall look of a workbook, apply a suitable theme to it by choosing Page 
Layout ➤ Themes ➤ Themes and then clicking the theme you want on the Themes panel.

The theme applies a set of colors and a pair of fonts to the workbook. After applying the 
theme, you can change the colors or fonts by using the Colors pop-up menu or the Fonts 
pop-up menu in the Themes group on the Home tab of the Ribbon.
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Choosing How to Align Cell Contents
You can quickly align the contents of cells by using the buttons in the Alignment group on 
the Home tab of the Ribbon or the controls on the Alignment tab of the Format Cells dialog 
box (see Figure 4-9):

	Horizontal alignment. You can align the text Left (Indent), Center, Right, 
or Justify; apply General alignment, which depends on the data type (left 
for text, right for numbers); choose Center Across Selection to center 
the text across multiple cells; or choose Distributed to distribute the text 
across the cell (using wider spaces between words). 

Note Choosing the Fill option for Horizontal alignment fills the cell with the character you specify.

Figure 4-9. The Alignment tab of the Format Cells dialog box lets you rotate text to precise angles when needed
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	Vertical alignment. You can align text Top, Center, Bottom, or Justify. You 
can also choose Distributed to distribute the text vertically, which can be 
useful when you rotate the text so that it runs vertically.

	Rotate text. Use the Orientation box on the Alignment tab of the Format 
Cells dialog box or the Orientation pop-up menu in the Alignment group.

	Indent. You can indent the text as far as is needed.

	Wrap text. You can wrap the text to make a long entry appear on several 
lines in a cell rather than disappear where the next cell’s contents start. 
When you wrap text, Excel automatically increases the row height to 
accommodate the wrapped text. (If you set a specific row height that’s 
less than the height needed to display all the wrapped text, only the text 
that fits appears in the cell.)

	Shrink to fit. Select this check box on the Alignment tab of the Format 
Cells dialog box to shrink the text so that it fits in the cell. Shrinking 
works well when the text is only a bit too big for the cell. If the text is 
much too big, shrinking makes it too small to read.

	Merge cells. Use the Merge & Center pop-up menu in the Alignment 
group to merge selected cells together into a single cell. You can also 
center an entry across a merged cell. In the Format Cells dialog box, 
you can merge cells by selecting the Merge cells check box on the 
Alignment tab.

Choosing Font Formatting
You can quickly format the contents of a cell (or the selected part of a cell’s contents) by 
using the controls in the Font group on the Home tab or the Font tab of the Format Cells 
dialog box (see Figure 4-10).
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Applying Borders and Fills
To apply borders to the active cell or range, open the Borders pop-up menu in the Font 
group on the Home tab of the Ribbon, and then click the border type you want (see 
Figure 4-11).

Figure 4-10. Use the Font tab of the Format Cells dialog box when you need a fuller range of font formatting than the 
Ribbon’s Font group provides
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Figure 4-11. You can quickly apply borders from the Borders pop-up menu in the Font group of the Home tab. You can 
also draw a border or a border grid with the mouse
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For more border options, click the More Borders item at the bottom of the Borders pop-up  
menu to display the Border tab of the Format Cells dialog box (see Figure 4-12). You can 
also choose Format ➤ Cells from the menu bar (or press Cmd+1) and then click the Border 
tab. Use the controls on the Border tab to set up the borders you want. For example, to 
apply a heavy bottom border, click a dark line in the Line Style box, and then click the 
Bottom Border button in the Border area. Then click the OK button.

Figure 4-12. Use the Border tab of the Format Cells dialog box when you need to change the line style or color of 
borders

Note The options in the Draw Borders section of the Borders pop-up menu enable you to draw 
borders on and around cells by dragging the mouse pointer across the worksheet. For example, you 
can open the Borders pop-up menu, click Draw Border Grid, and then drag across the cells to which 
you want to apply the grid. You can then open the Borders pop-up menu again, click Erase Border, 
and use the mouse pointer to erase any borders you don’t need within the grid you’ve applied. 
Press Esc to turn off the current tool. Depending on the type of table you need to create, this can be 
a quicker way of working than selecting the cells and then applying the border formatting.
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To apply a fill, use the Fill Colors pop-up menu in the Font group on the Home tab of the 
Ribbon or work on the Fill tab of the Format Cells dialog box.

Applying Protection to Cells
The Protection tab of the Format Cells dialog box contains only two controls:

	Locked. Select this check box to lock a cell against changes.

	Hidden. Select this check box to hide the formula in a cell (the formula’s 
result remains visible).

After selecting either of these check boxes, you must protect the worksheet before the 
locking or hiding takes effect. You’ll learn how to protect a worksheet in the section 
“Protecting a Worksheet or Workbook” in Chapter 13.

Using Paste Special to Paste Formatting and Perform 
Actions
If one part of your worksheet contains the type of formatting you need to apply to another 
part, you can often save time by using the Paste Special command and choosing options 
in the Paste Special dialog box. For example, you can paste formats or column widths 
only instead of pasting all the data and formatting from the cells you’ve copied. The Paste 
Special command also enables you to transpose data and perform mathematical operations 
on the cells you’re pasting to.

You can access most of the Paste Special options from either the Paste pop-up menu in the 
Clipboard group of the Home tab or the Paste Options pop-up menu, but in most cases it’s 
clearest to use the Paste Special dialog box.

To display the Paste Special dialog box (see Figure 4-13), use one of these commands:

	Ribbon. Choose Home ➤ Clipboard ➤ Paste ➤ Paste Special.

	Menu bar. Choose Edit ➤ Paste Special.

	Context menu. Ctrl+click or right-click the destination cell, and then 
click Paste Special.

	Keyboard. Press Cmd+Ctrl+V.

http://dx.doi.org/10.1007/978-1-4842-1019-2_13
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You then select the option button you want in the Paste area:

	All. Select this option button to paste all the data and all its formatting. 
Normally, you’ll want to do this only if you’re using the Skip Blanks 
check box, the Transpose check box, or the Paste Link button—
otherwise, it’s easier to use the Paste command.

	Formulas. Select this option button to paste in all the formulas and 
constants without formatting.

	Values. Select this option button to paste in formula values instead of 
pasting in the formulas themselves. Excel removes the formatting from 
the values.

	Formats. Select this option button to paste in the formatting without the 
data. This option is great for making one worksheet’s formatting similar 
to another’s.

	Comments. Select this option button to paste in only comments. This 
option is handy when you’re integrating different colleagues’ takes on 
the same worksheet.

	Validation. Select this option button to paste in data-validation criteria.

	All using Source theme. Select this option button to paste in all the data 
using the theme from the workbook the data came from.

Figure 4-13. Use the Paste Special dialog box when you need to paste only some of the data, when you need to 
perform an operation on the data, or when you need to transpose its rows and columns
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	All except borders. Select this option button to paste in all the data and 
formatting but to strip out the cell borders.

	Column widths. Select this option button to paste in only the column 
widths—no data and no other formatting. This option is useful when you 
need to lay one worksheet out like another existing worksheet but put all 
different data in it.

	Formula and number formats. Select this option button to paste in 
formulas and number formatting but no other formatting.

	Values and number formats. Select this option button to paste in values 
(rather than formulas) and number formatting.

	All, merge conditional formats. Select this option button to copy all data 
and formatting and to merge in any conditional formatting. See the next 
section for details on conditional formatting.

If you need to perform a mathematical operation using the data you’re pasting, go to the 
Operation area of the Paste Special dialog box and select the Add option button, the 
Subtract option button, the Multiply option button, or the Divide option button, as needed. 
For example, if you want to multiply the current values in the cells by the values you’re 
pasting, select the Multiply option button. Otherwise, leave the None option button selected 
to paste the data without performing math with it.

In the bottom section of the Paste Special dialog box, you can select or clear the two check 
boxes as needed:

	Skip Blanks. Select this check box to prevent Excel from pasting blank 
cells.

	Transpose. Select this check box to transpose columns to rows and 
rows to columns. This option is much quicker than retyping data that’s 
laid out the wrong way.

When you’ve chosen the options you want, click the OK button. Excel closes the Paste 
Special dialog box and pastes the data or formatting you chose.

Identifying Unusual Values with Conditional Formatting
In many worksheets, it’s useful to be able to monitor the values in the cells and to pick 
out values that stand out in particular ways. For example, you may want to see which ten 
products are bringing in the most revenue, or you may need an easy way to make unusually 
high values or unusually low values stand out from the others.

Note If you need to link the data you’re pasting back to its source, click the Paste Link button in 
the Paste Special dialog box instead of the OK button. This makes Excel create a link to the source 
data so that when the source data changes, the linked data changes too. If the source data is in the 
same workbook, Excel updates the links automatically. If the source data is in another workbook, 
Excel updates the data when you open the workbook that contains the links.
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To monitor the values in a cell or a range, you can apply conditional formatting—formatting 
that Excel displays only when the condition is met. For example, if you’re monitoring 
temperatures in Fahrenheit, you could apply conditional formatting to highlight low 
temperatures (say, below 20F) and high temperatures (say, above 100F). Temperatures in 
the normal range would not receive any conditional formatting, so the low temperatures and 
high temperatures would jump out on the worksheet.

Understanding Excel’s Preset Types of Conditional Formatting
Excel provides five kinds of preset conditional formatting, which you can apply from the 
Conditional Formatting panel in the Styles group of the Home tab of the Ribbon. Figure 4-14 
shows the Conditional Formatting panel with the Icon Sets panel displayed.

Figure 4-14. The Conditional Formatting panel includes sets of icons you can apply to indicate data trends
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	Highlight Cells Rules. This panel gives you an easy way to set up 
conditional formatting using Greater Than, Less Than, Between, Equal 
To, Text that Contains, A Date Occurring, or Duplicate Values criteria.

	Top/Bottom Rules. This panel lets you apply conditional formatting 
for Top 10 Items, Top 10 %, Bottom 10 Items, Bottom 10 %, Above 
Average, and Below Average criteria.

	Data Bars. This panel enables you to apply different gradient fills and 
solid fills.

	Color Scales. This panel lets you set up color scales using two or three 
colors—for example, using green, amber, and red to indicate different 
levels of risk associated with activities.

	Icon Sets. This panel provides different sets of icons, such as directional 
arrows (up, sideways, down) or a checkmark–exclamation point–cross 
set, for indicating data trends.

Applying a Preset Form of Conditional Formatting
To apply one of the preset forms of conditional formatting, open the Conditional Formatting 
panel, display the appropriate panel from it, click the type of formatting, and then specify the 
details. For example:

1. Select the cell or range you want to affect.

2. Choose Home ➤ Styles ➤ Conditional Formatting ➤ Highlight 
Cells Rules ➤ Greater Than to display the New Formatting Rule 
dialog box (see Figure 4-15).

Figure 4-15. Excel’s preset conditional formatting types make it easy to apply conditional formatting to cells quickly

3. In the Style pop-up menu, you can choose a different style for the 
conditional formatting if you want. Excel automatically selects the 
style that suits the type of conditional formatting you chose—in the 
example, Classic.
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4. The Comparison pop-up menu below the Style pop-up menu 
shows the comparison for the type of conditional formatting—in the 
example, Format only cells that contain. You can choose a different 
comparison if necessary, but you won’t normally need to do so.

5. On the next line of controls, set up the comparison. In the example, 
the first pop-up menu is set to Cell value, and the second pop-up 
menu is set to “greater than” because this is a Greater Than rule. In 
the third box, you enter the comparison. You can either type in the 
value or collapse the dialog box, click the cell that contains the value, 
and then restore the dialog box.

6. In the Format with pop-up menu, choose the formatting you want. 
Excel provides various canned options, but you can also create 
custom formatting by clicking the custom format item at the bottom 
of the list and working in the Format Cells dialog box that opens. 
(This is a cut-down version of the Format Cells dialog box you met 
earlier in the chapter—it has only the Font tab, the Border tab, and 
the Fill tab.)

7. Click the OK button to close the New Formatting Rule dialog box. 
Excel applies the conditional formatting.

Creating Custom Conditional Formatting
If none of the preset conditional formatting rules meets your needs, you can define 
conditional formatting rules of your own. To do so, follow these steps:

1. Select the cell or range you want to affect.

2. Choose Home ➤ Styles ➤ Conditional Formatting ➤ New Rule to 
display the New Formatting Rule dialog box.

3. In the Style pop-up menu, choose the type of conditional formatting: 
2-Color Scale, 3-Color Scale, Data Bars, Icon Sets, or Classic. 
The New Formatting Rule dialog box displays controls for creating 
that type of conditional formatting. Figure 4-16 shows the New 
Formatting Rule dialog box displaying the controls for creating an 
icon set.
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4. Use the controls to specify what conditional formatting the rule will 
apply. For example, for the Icon Sets style shown in Figure 4-16, you 
could do the following:

	Open the Icons pop-up menu, and then click the set of icons you 
want to use as the basis for the formatting.

	In the Options area, select the Reverse icon order check box if you 
want to use the icon sequence the other way around—for example, 
green-yellow-red instead of red-yellow-green. Select the Show icon 
only check box if you want the icon to appear without the value that 
produced it; this can be good for simplifying complex worksheets, but 
it may prompt too many questions about values to be worth using.

	In the Display area, open each pop-up menu, and choose the 
symbol to use (or simply accept the default symbol). Then use the 
controls to set up the condition, value, and type.

5. When you’ve finished creating the rule, click the OK button to close 
the New Formatting Rule dialog box.

Changing the Order in Which Excel Applies Conditional 
Formatting Rules
Many cells and ranges need only one type of conditional formatting applied—but others 
may need two or more types. When you apply multiple types of conditional formatting, 
you may need to change the order Excel applies the conditional formatting rules in. Or you 
may simply need an easy way to see which conditional formatting rules you’ve applied to a 
particular cell or range.

Figure 4-16. When none of the conditional formatting rules is what you need, use the New Formatting Rule dialog box 
to create a custom rule
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To see which conditional formatting rules you’ve applied to cells, and to change the order, 
follow these steps:

1. Select the cell or range you’re interested in.

2. Choose Home ➤ Styles ➤ Conditional Formatting ➤ Manage 
Rules to display the Manage Rules dialog box (see Figure 4-17).

Figure 4-17. Use the Manage Rules dialog box to check which conditional formatting rules you’ve applied to a cell or 
range and to change the order in which Excel uses the rules

3. Verify that the Show formatting rules for pop-up menu shows Current 
Selection rather than another range. If not, choose Current Selection.

4. In the list box in the center of the Manage Rules dialog box, look 
through the list of rules. Change the rules or their order as needed.

	Change the order of the rules. Click the rule you want to move, go to 
the Change rule order area, and then click the Move Up button (the 
up arrow) or the Move Down button (the down arrow), as needed.

	Delete a rule. Click the rule, and then click the Remove (–) button.

	Edit a rule. Click the rule, click the Edit Rule button, and then work 
in the Edit Formatting Rule dialog box. This dialog box has the same 
controls as the New Formatting Rule dialog box.

	Create a new rule. Click the Add (+) button, and then work in the 
New Formatting Rule dialog box, as discussed in the previous 
section. When you finish creating the rule, move it up the list to 
where it belongs.
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	Apply the rule to a different range. In the rule’s Applies to column, 
click the Collapse Dialog button to collapse the Manage Rules 
dialog box. Select the appropriate range, and then click the Collapse 
Dialog button again to restore the Manage Rules dialog box.

	Stop evaluating other rules if a rule is true. Select the rule’s check 
box in the Stop if true column.

5. Click the OK button to close the Manage Rules dialog box. Excel 
applies your choices to your selection.

Clearing Conditional Formatting from a Cell, Range, or 
Worksheet
If a cell, range, worksheet, table, or PivotTable no longer needs conditional formatting, clear 
it as follows:

1. Choose the item:

	Select the cell or range.

	Click in the table or PivotTable.

	Activate the worksheet.

2. Choose Home ➤ Styles ➤ Conditional Formatting ➤ Clear Rules, 
and then click the appropriate item on the submenu: Clear Rules 
from Selected Cells, Clear Rules from Entire Sheet, Clear Rules from 
This Table, or Clear Rules from This PivotTable.

Checking Input with Data Validation
When you’re entering large amounts of data, it’s easy to type an incorrect value by mistake. 
To help avoid errors in your data, you can use Excel’s data validation feature to check entries 
automatically and flag those that may be wrong. For example, if every entry in a range of 
cells should be between 250 and 1000 (inclusive), you can validate the data to flag any entry 
that is not in that range.

To apply validation to cells, follow these steps:

1. Click the cell or select the range you want to validate.

2. Choose Data ➤ Data Tools ➤ Data Validation (clicking the main part 
of the Data Validation button) from the Ribbon or Data ➤ Validation 
from the menu bar to display the Data Validation dialog box.

Caution Data validation works only when the user types in a value. If the user pastes in a value, 
Excel doesn’t validate it.
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3. Click the Settings tab (shown in Figure 4-18 with settings chosen) to 
bring it to the front of the dialog box if it’s not already there.

4. In the Allow pop-up menu, choose the type of data you want to 
validate, and then use the controls that appear to set the details.

	Any value. Select this item when you want to turn off validation for 
the cell or range. Even with this setting, you can use the Input 
Message tab (discussed later in this list) to display a message about 
the cell or range.

Tip When setting the criteria for your data validation, you can either type in a value or click the 
Collapse Dialog button and then click the cell that contains the value. Using a value in a cell enables 
you to change the value easily without editing the data validation.

Figure 4-18. Set up the validation criteria on the Settings tab of the Data Validation dialog box. The controls that 
appear depend on the data type you choose in the Allow pop-up menu
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	Whole number. Select this item to set criteria for a whole number—
one with no decimal places. For example, in the Data pop-up menu, 
click the between item and then set the minimum value in the 
Minimum box and the maximum value in the Maximum box.

	Decimal. Select this item to set criteria for a number with decimal 
places. For example, in the Data pop-up menu, click the greater 
than or equal to item and then set the minimum value in the 
Minimum box.

	List. Select this item when you need to restrict the cell to a list of 
valid entries that you specify. You can enter this list in two ways: 
either type it in the Source box, separating each entry with a 
comma, or click the Collapse Dialog button at the right end of the 
Source box, select the worksheet range that contains the data, and 
then click the Collapse Dialog button again to restore the dialog 
box. Select the In-cell drop-down check box to make Excel display 
a pop-up menu with the valid entries in the cell so that the user can 
enter them easily.

	Date. Select this item to set criteria for a date. For example, click the 
greater than item in the Data pop-up menu and then enter the start 
date in the Start date box.

	Time. Select this item to set criteria for a time. For example, click the 
not between item in the Data pop-up menu, then enter the start time 
in the Start time box and the end time in the End time box.

	Text length. Select this item to set criteria for a text entry or formula. 
For example, click the less than or equal to item in the Data pop-up 
menu, then enter the maximum length in the Maximum box.

	Custom. Select this item when you need to enter a formula that 
returns a logical value of TRUE or FALSE.

5. Select the Ignore blank check box if you want to let the user leave 
the cell blank. Clear this check box to make the user fill in the cell 
with valid data.

6. Click the Input Message tab to display it. The left screen in 
Figure 4-19 shows the Input Message tab with settings chosen.
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7. To display a message when the user makes the cell active, select the 
Show input message when cell is selected check box. Type the title 
in the Title box and the message in the Input message box. The right 
screen in Figure 4-19 shows how the message appears.

8. Click the Error Alert tab to bring it to the front. The left screen in 
Figure 4-20 shows the Error Alert tab with settings chosen; the right 
screen in Figure 4-20 shows how the error message appears.

Figure 4-19. On the Input Message tab of the Data Validation dialog box (left), enter the message you want the user to 
see when the cell is active (right)

Figure 4-20. On the Error Alert tab of the Data Validation dialog box (left), set up the error to display when the user 
enters invalid data in the cell (right)
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	Warning. The error dialog box ends with a “Continue?” prompt after 
your message. On Windows, the error dialog box has a Yes button, 
a No button, and a Cancel button; on OS X, the error dialog box has 
a Yes button and a No button. If the user clicks the Yes button, Excel 
accepts the value, even though it has failed validation. If the user 
clicks the No button, Excel selects the entry that failed validation 
so that the user can change it. If the user clicks the Cancel button, 
Excel restores the cell’s previous entry.

	Information. The error dialog box has an OK button and a Cancel 
button on Windows and only an OK button on OS X. If the user 
clicks the OK button, Excel accepts the value, even though it has 
failed validation. On Windows, if the user clicks the Cancel button, 
Excel restores the cell’s previous entry.

11. Enter the title and error message for the message box.

12. Click the OK button to close the Data Validation dialog box. Excel 
applies the validation.

Tip To force the user to enter valid data, choose the Stop item in the Style pop-up menu on the 
Error Alert tab of the Data Validation dialog box. The Warning style and the Information style can 
be useful for when you’re providing gentler guidance on how to use the worksheet and it’s not 
essential that the data conform.

9. Select the Show error alert after invalid data is entered check box 
if you want Excel to display an error message box when the user 
enters invalid data. Usually, this is helpful.

10. In the Style pop-up menu, choose the icon type for the behavior you 
want:

	Stop. The error dialog box has a Retry button and a Cancel button. 
If the user clicks the Retry button, Excel selects the entry that 
failed validation so that the user can change it. If the user clicks the 
Cancel button, Excel restores the cell’s previous entry.

Note On Windows, the Stop, Warning, and Information settings in the Style pop-up menu make 
the error message box show the different icons that appear under the Style pop-up menu when you 
make your choice. For example, the Stop style shows the red circle bearing a white cross that you 
see on the left in Figure 4-20. On OS X, the error message box displays the same Excel icon (shown 
on the right in Figure 4-20) for each style, but with different command buttons and behavior.
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Formatting Quickly with Table Formatting and Styles
To save you time with formatting, Excel provides preset formatting that you can apply to a 
table to give it an overall look. And to save you the effort of applying many different types 
of formatting over and over again to different cells, Excel includes styles—collections of 
formatting you can apply all at once.

Formatting with Table Formatting
When you need to format a table quickly, see if Excel’s preset table formatting will do the 
trick. Select the table, choose Table ➤ Table Styles ➤ Table Styles, and then click the style 
you want. 

Formatting with Styles
As you’ve seen earlier in this chapter, you can give any cell exactly the formatting you want 
by using the controls in the Font group, Alignment group, and Number group of the Home 
tab of the Ribbon or by opening the Format Cells dialog box and working on its tabs. But 
applying formatting one aspect at a time—font, font size, alignment, and so on—is slow 
work, and it’s easy to apply formatting inconsistently.

To save time and ensure your formatting is consistent, you can use Excel’s styles. Each style 
is a collection of formatting that you can apply to one or more cells. The style contains six 
types of formatting, one for each tab of the Format Cells dialog box:

	Number. For example, General, Currency, or Percentage.

	Alignment. Horizontal alignment (for example, General, Center, or 
Justify), vertical alignment (for example, Top, Center, or Bottom), and 
any trimmings (such as wrapping the text to the cell).

	Font. The font, font size, font color, and so on.

	Border. Any borders you’ve applied to the style, or No Borders if it has 
no borders.

	Fill. Any fill you’ve applied to the style, or No Shading if it’s plain.

	Protection. Locked, Hidden, both, or No Protection.

Most Excel templates contain plenty of styles to get you started, but you can create your 
own custom styles as well if you need to.

Note See Chapter 10 for instructions on creating and working with Excel tables.

http://dx.doi.org/10.1007/978-1-4842-1019-2_10
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Meeting Excel’s Styles
To see which styles are available in a workbook, choose Home ➤ Styles ➤ Cell Styles and 
look at the Cell Styles panel (see Figure 4-21). This panel lists the styles in the following 
categories:

	Custom. This category appears only when you have created one or 
more custom styles in the workbook.

Figure 4-21. The Cell Styles panel displays your custom styles at the top and Excel’s built-in styles in different 
categories

	Good, Bad and Neutral. This category contains Good, Bad, and Neutral 
styles that you can use to apply color coding to cells. Here is also where 
you will find the Normal style that Excel applies to any cell that doesn’t 
have another style.

	Data and Model. This category contains the Calculation, Check Cell, 
Explanatory, Followed Hyperlink, Hyperlink, Input, Linked Cell, Note, 
Output, and Warning Text styles. Most of these styles are used for 
data modeling. Excel automatically applies the Hyperlink style to cells 
containing hyperlinks you have not clicked yet, changing their style to 
Followed Hyperlink once you have clicked them. 
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	Titles and Headings. This category contains four styles for descending 
levels of headings (Heading 1, Heading 2, Heading 3, and Heading 4), 
the Title style for giving a worksheet a title, and the Total style for easily 
formatting cells that contain totals.

	Themed Cell Styles. This category contains six Accent styles (Accent 1 
through Accent 6) featuring six of the theme colors, with four degrees of 
shading for each. This category appears only if the workbook’s template 
contains themed cell styles.

	Number Format. This category contains styles for number formats such 
as Comma, Comma [0], Currency, Currency [0], and Percent.

Applying a Style
To apply a style, choose Home ➤ Styles ➤ Cell Styles, and then click the style on the Cell 
Styles panel. You can also apply the various Number styles (such as the Currency styles, the 
Percent style, and the Comma style) from the Number group on the Home tab of the Ribbon.

Creating Custom Styles
If none of Excel’s styles meets your needs, you can create your own. To create a style, follow 
these steps:

1. Format a cell with the formatting you want the style to have. 

2. Select the cell you’ve formatted.

3. Choose Home ➤ Styles ➤ Cell Styles ➤ New Cell Style to display 
the New Cell Style dialog box (shown in Figure 4-22 with settings 
chosen).

Tip To jump-start your formatting, apply the existing style that’s nearest to the look and formatting 
you want. Then change the formatting so it looks the way you want.

Note The Hyperlink style appears in the Data and Model category in the Cell Styles panel only 
if the workbook contains hyperlinks. Similarly, the Followed Hyperlink style appears only if the 
workbook contains hyperlinks you’ve followed.
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4. In the Style name box, type the name you want to give the style.

5. In the “The selected style has formatting for the following properties” 
area, clear the check boxes for any formatting the cell has that you 
want to omit from the style. For example, clear the Protection check 
box to leave out the Locked or Hidden formatting. 

6. Click the OK button to close the New Cell Style dialog box and 
create the style. Excel adds the style to the Custom area at the top of 
the Cell Styles panel.

Note If you need to alter the formatting, click the Format button to display the Format Cells 
dialog box. Make the changes needed, and then click the OK button to return to the New Cell  
Style dialog box.

Tip Instead of creating a new style, you can modify one of the built-in styles. Choose Home ➤ 
Styles ➤ Cell Styles to display the Cell Styles panel, Ctrl+click or right-click the style you want to 
change, then click the Modify item on the context menu. In the Modify Cell Style dialog box, select 
or clear the check boxes in the “The selected style has formatting for the following properties” area 
or click the Format button to display the Format Cells dialog box, and make the changes you need. 
When you have finished, click the OK button to return to the Modify Cell Style dialog box, then click 
the OK button.

Figure 4-22. In the New Cell Style dialog box, you can quickly create a new style based on the formatting of the 
selected cell. You can change the formatting as needed by clicking the Format button and working in the Format Cells 
dialog box
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Copying Styles from One Workbook to Another
If you have styles in one workbook that you want to use in another workbook, you can copy 
the styles across. Excel calls this merging styles or importing styles. When you merge the 
styles, the destination workbook receives all the styles from the source workbook—you can’t 
pick and choose (but see the nearby Tip).

To import the styles, follow these steps:

1. Open the source workbook (the workbook that contains the styles) 
and the destination workbook.

2. Switch to the destination workbook by clicking in it.

3. Choose Home ➤ Format ➤ Styles ➤ Merge Styles to display the 
Import Cell Styles dialog box (see Figure 4-23).

Figure 4-23. Use the Import Cell Styles dialog box to copy all the styles from one workbook into another workbook

4. In the Copy cell styles from an open workbook list box, click the 
source workbook.

5. Click the OK button to close the Import Cell Styles dialog box. Excel 
copies the styles into the destination workbook and you can then 
start using them.

Tip If you need to copy just one style from one workbook to another, apply that style to a cell in 
the source workbook. Then copy that cell and switch back to the destination workbook. Ctrl+click or 
right-click a cell you don’t mind changing, and then click Paste Special to display the Paste Special 
dialog box. In the Paste area, select the Formats option button, and then click the OK button. Excel 
pastes the style onto the cell, and you can then use the style in the workbook.
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Deleting Styles You Don’t Need
If you no longer need a style, you can delete it. Choose Home ➤ Styles ➤ Cell Styles, 
Ctrl+click or right-click the style in the Cell Styles panel, and then click Delete on the context 
menu. 

Adding Headers and Footers to Your Worksheets
Before distributing a worksheet for viewing on screen, on paper, or as a PDF file, you’ll 
probably want to add headers, footers, or both to identify the pages. Excel gives each 
worksheet a separate header and footer, which you can fill with either preset text or custom 
text. Each header and footer area consists of a left section, a center section, and a right 
section, so you can easily add several different pieces of information.

Excel’s main way to add or edit headers or footers is by working directly on the worksheet. 
To do so, follow these steps:

1. Choose Insert ➤ Text ➤ Header & Footer. If the worksheet is in 
Normal view, Excel switches automatically to Page Layout view. Excel 
adds the Header & Footer tab to the Ribbon, displays its controls, and 
selects the center section of the header (see Figure 4-24). 

Note Excel prevents you from deleting the Normal style, because it uses this style for any cell that 
doesn’t have another style applied.

Note You can also add headers and footers by choosing File ➤ Page Setup from the menu bar 
and then working on the Header/Footer tab of the Page Setup dialog box. Here, you can create a 
header either by opening the Header pop-up menu and choosing a preset header or by clicking 
the Custom Header button and working in the Header dialog box. Similarly, you can create a footer 
either by opening the Footer pop-up menu and clicking a preset footer or by clicking the Custom 
Footer button and working in the Footer dialog box. You can also select or clear the Different odd 
and even pages check box, the Different first page check box, the Scale with document check box, 
and the Align with page margins check box, as needed. Click the OK button when you’re ready to 
close the Page Setup dialog box.
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2. Click the section of the header you want to change. (If you want to 
start in the center section, you’re all set.) If you want to work in the 
footer, choose Header & Footer ➤ Navigation ➤ Go to Footer to 
display the footer. 

Tip You can insert a preset header by choosing Header & Footer ➤ Header & Footer ➤ Header 
and then clicking the appropriate preset header on the pop-up menu. Similarly, you can insert a 
preset footer by choosing Header & Footer ➤ Header & Footer ➤ Footer and then clicking the 
appropriate preset footer on the pop-up menu.

Figure 4-24. After giving the Insert ➤ Text ➤ Header & Footer command, you can use the controls on the Header & 
Footer tab of the Ribbon to create the header or footer a worksheet needs

Tip You can also start editing a header or footer in Page Layout view. Scroll so that you can see 
the “Click to add header” prompt or “Click to add footer” prompt on the sheet you want to change, 
and then click the prompt. Excel adds the Header & Footer tab to the Ribbon, but you’ll need to click 
the tab to display its controls.

Note If you switch to another workbook, Excel closes the header or footer you were editing.
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3. Add the header or footer by following these techniques:

	Click a button in the Header & Footer Elements group to insert a 
field code (such as &[Date] for the date) or a piece of information 
(such as the sheet name).

	Type in any text needed.

	Format the text as needed by selecting it and applying formatting 
from either the Home tab of the Ribbon or the Font tab of the 
Format Cells dialog box.

4. In the Options group on the Header & Footer tab of the Ribbon, 
select or clear the four check boxes as needed:

	Different First Page. Select this check box to give the worksheet a 
different header or footer on the first page, or to have no header or 
footer on the first page.

	Different Odd & Even Pages. Select this check box to use different 
headers and footers on the odd pages and the even pages, as you 
might do in a facing-pages layout.

	Scale with Document. Select this check box (which is normally 
selected by default) to have Excel scale the header and footer 
with the document. This setting is mostly useful for making sure 
that headers and footers you create for portrait pages don’t look 
absurdly big when you switch the pages to landscape orientation. If 
you scale down a worksheet to make it fit on a sheet of paper, you 
may prefer to keep the headers and footers full size.

	Align with Page Margins. Select this check box (which also is 
normally selected by default) to have Excel align the headers and 
footers with the page margins. This type of alignment works well for 
many worksheets; if not, you can override it easily.

5. When you have finished creating or editing the header or footer, click 
a cell in the worksheet to close the header or footer. You can then 
click the Normal View button on the status bar if you want to switch 
back to Normal view.

Summary
In this chapter, you learned how to apply all of Excel’s most useful types of formatting to 
a worksheet. You know how to manipulate the worksheet’s rows and columns to make it 
fit your data, how to format cells and ranges, and how to save time and worry by using 
conditional formatting and data validation.

You also saw how to format quickly with table formatting and styles, and learned how to give 
your worksheets headers and footers to help identify them and their contents easily.

This is the end of the first part of the book. In the second part, I’ll show you how to perform 
calculations and present your data.
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Part II
Performing Calculations and 
Presenting Data
In this part of the book, you get up to speed with formulas, functions, charts, and graphical 
elements such as pictures and sparklines.

In Chapter 5, we go over what formulas and functions are, and what the difference between 
the two is. This chapter then teaches you how to create your own formulas using Excel’s 
calculation operators, starting with straightforward formulas that use a single calculation 
operator each, and then moving on to more complex formulas that use multiple calculation 
operators. You also learn how to override Excel’s default order for evaluating operators and 
how to troubleshoot common problems that occur with formulas.

In Chapter 6, you learn how to insert functions in your worksheets using the various 
tools that Excel provides, find the functions you want, and point the functions to the data 
they need for the calculations. The second part of the chapter explains Excel’s different 
categories of functions, such as database functions, logical functions, and math and 
trigonometric functions, and gives examples of how to use widely used functions.

In Chapter 7, we cover how to present data clearly and persuasively using Excel’s wide 
range of charts. You learn the different ways you can place charts in worksheets, the 
components of charts, and the types of charts you can use. We then dig into how you create 
a chart from your data, lay it out the way you want, and give it the look it needs. We also 
look at ways of reusing the custom charts you create and ways of using Excel charts in Word 
documents or PowerPoint presentations.

In Chapter 8, we look at how to add visual appeal to your worksheets by using four types of 
graphical elements that each fit within a single cell. You quickly grasp how to use data bars 
to compare the values in a range of cells, how to add color scales to adjust the background 
colors of cells to provide a visual reference to their values, and how to use icon sets to 
provide quick visual references to performance. And you learn to create miniature charts 
using sparklines.

http://dx.doi.org/10.1007/978-1-4842-1019-2_5
http://dx.doi.org/10.1007/978-1-4842-1019-2_6
http://dx.doi.org/10.1007/978-1-4842-1019-2_7
http://dx.doi.org/10.1007/978-1-4842-1019-2_8
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In Chapter 9, we look at ways of giving your workbooks visual interest by adding graphics, 
shapes, SmartArt diagrams, and WordArt items. You learn how to make a picture look as 
you want it to, how to position graphical objects wherever you need them, how to position 
graphical items relative to cells, and how to arrange graphical objects to control which ones 
are visible.

http://dx.doi.org/10.1007/978-1-4842-1019-2_9
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Chapter 5
Performing Custom 
Calculations with Formulas
To make your worksheets deliver the information you want, you’ll probably need to perform 
calculations with your data. To perform calculations, you enter formulas and functions in 
cells. You’ll learn to use formulas in this chapter and functions in Chapter 6.

We’ll start by going over what functions and formulas are so that you’re clear on the 
difference, and then make sure you know how you refer to cells and ranges in Excel.

After that, I’ll show you how to create your own formulas using Excel’s calculation operators. 
We’ll start with straightforward formulas that use a single calculation operator, and then 
move on to more complex formulas that use multiple calculation operators.

When you use multiple calculation operators in a formula, you need to make sure Excel 
evaluates them in the right order—otherwise, you can produce results not only in the 
wrong ballpark but also in a different league. So you need to know Excel’s default order for 
evaluating operators, and how to change the order when necessary. With this knowledge, 
you can build complex formulas—but you may want to take the easy route and build them 
one piece at a time so you can easily detect and fix problems.

At the end of the chapter, I’ll introduce you to common problems that occur with formulas 
and tell you how to troubleshoot them.

http://dx.doi.org/10.1007/978-1-4842-1019-2_6
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Understanding the Difference between Formulas  
and Functions
In Excel, you can perform calculations in two main ways, each of which starts with an 
equal sign:

	By using a function. A function is preset to perform a standard 
calculation. For example, when you need to add several values together, 
you use the SUM( ) function—for instance, =SUM(1,2,3,4,5,6), which is 
simpler than =1+2+3+4+5+6 but has the same effect.

	By using a formula. A formula is a custom calculation that you create when 
none of Excel’s functions do what you need. The word formula tends to 
sound imposing, but a formula can be a simple calculation; for example, 
to subtract 50 from 100, you can type =100-50 in a cell (the equal sign 
tells Excel you’re starting a formula). Formulas can also be more complex. 
For example, say you need to add the contents of the cells in the range 
A1:A6 and then divide them by the contents of cell B1. Excel doesn’t have 
a built-in function for doing this, because it’s not a standard calculation. 
So instead, you create a formula such as this: =SUM(A1:A6)/B1. (In this 
example, / is the keyboard equivalent of the ÷ symbol.)

I’ll show you how to use formulas in this chapter and functions in the next chapter. But 
before we start on formulas, let’s go over the ways of referring to cells and ranges in 
formulas and functions.

Referring to Cells and Ranges in Formulas  
and Functions
To make your formulas and functions work correctly, you need to refer to the cells and 
ranges you want. This section makes sure you know how to refer to cells and ranges, 
both when they’re on the same worksheet as the formula and when they’re on a different 
worksheet. You can even refer to cells and ranges in another workbook—as long as it will 
remain in the same place in your Mac’s file system.

Referring to a Cell
To refer to a cell on the same worksheet, simply use its column lettering and its row number. 
For example, use =A10 to refer to cell A10.

To refer to a cell on a different worksheet, enter the worksheet’s name followed by an 
exclamation point and the cell reference. For example, use =Supplies!A10 to refer to cell A10 
on the worksheet named Supplies. The easiest way to set up such a reference is like this:

 1. Start creating the formula. For example, type = in the cell where you 
want the formula.

 2. Click the worksheet tab for the worksheet that contains the cell you 
want to refer to.
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 3. Click that cell.

 4. Click the Enter button (the check-mark button) on the Formula bar 
to enter the reference. Excel returns you to the worksheet on which 
you’re creating the formula. You’ll see that the cell displays the result 
of the formula; that is, whatever value was in the cell you clicked in 
Step 3—rather than the formula itself. 

 5. Press Ctrl+U to resume editing the cell. Alternatively, click in the 
Formula bar, and continue editing there. Either way, Excel displays 
the formula, such as ='Sales Results'!A10.

 6. Finish creating the formula as usual.

To refer to a cell in a different workbook, enter the workbook’s path, then the file name 
in brackets, then the worksheet’s name, and then the cell reference. For example, the 
reference ='Shared:Spreads:[Results.xlsx]Sales!'AB12 refers to cell AB12 on the 
worksheet named Sales in the workbook Results.xlsx in the Shared:Spreads folder.

Unless you happen to know the path, file name, worksheet name, and cell, it’s usually 
easiest to set up the reference using the mouse. Follow these steps:

 1. Open the workbook you want to refer to.

 2. In the workbook that will contain the reference, start creating the 
formula. For example, type = in the cell.

Note If the worksheet’s name contains any spaces, you must put the name inside single quotes; 
for example, ='Sales Results'!A10 rather than =Sales Results!A10. You can also use the single 
quotes on worksheet names that don’t have spaces if you find it easier to be consistent. If you omit 
the single quotes when they’re needed, Excel either displays the Open dialog box, with a message 
such as “Cannot find ‘Results’. Copy from:”, inviting you to find the right workbook, or displays an 
error message.

Note Instead of clicking the Enter button on the Formula bar in Step 4, you can press Return to 
enter the cell reference. When you do this, Excel moves the active cell to the cell below the formula 
on the worksheet on which you’re creating the formula. You then need to press the up arrow key 
before taking Step 5.
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 3. Switch to the other workbook.

	If you can see the other workbook, click it.

	If you can’t see the other workbook, open the Window menu on the menu bar, 
and then click the appropriate window.

 4. Navigate to the worksheet that contains the cell, and then click the cell.

 5. Switch back to the workbook in which you’re creating the reference, 
and then complete the formula.

When you create a reference to a cell in another workbook, Excel keeps the value of the 
referring cell updated. If you move or delete the other workbook, Excel displays a dialog box 
warning you that it can’t find the workbook and asking if you want to locate it manually.

Referring to a Range
To refer to a range that consists of a block of cells, give the addresses of the first cell and 
the last cell, separating them with a colon. For example, to refer to the range from cell P10 to 
cell Q12, use =P10:Q12.

To refer to a range that consists of individual cells, give the address of each cell, separating 
the addresses with commas. For example, to refer to cell J14, cell K18, and cell Z20,  
use =J14,K18,Z20.

To refer to a range on a different worksheet or in a different workbook, use the techniques 
explained in the previous section. For example, if you need to refer to the range P10 to Q12 
on the worksheet named Stock Listing, use ='Stock Listing'!P10:Q12.

Making One Row or Column Refer to another Row or Column
Sometimes you may need to make the contents of one row or column refer to another row or 
column. For example, say you need to make each cell in row 25 refer to the corresponding 
cell in row 4, so that cell A25 refers to cell A4, cell B25 to cell B4, and so on.

To do this, click the row heading for row 25, selecting the row. Then type =4:4 to create 
the reference to row 4, and press Cmd+Return to enter it in all the cells of the selection. 
Similarly, you can refer to a whole column by entering its letter designation, a colon, and the 
letter designation again; for example, E:E.

UNDERSTANDING ABSOLUTE REFERENCES, RELATIVE REFERENCES, AND MIXED REFERENCES

Using cell addresses or range addresses is straightforward enough, but when you start using formulas, there’s 
a complication. When you copy a formula and paste it, you need to tell Excel whether the pasted formula should 
refer to the cells it originally referred to, or the cells in the same relative positions to the cell where the formula 
now is, or a mixture of the two. (If you move a formula to another cell by using drag and drop or Cut and Paste, 
Excel keeps the formula as it is.)
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To make references clear, Excel uses three types of references:

	Absolute reference. A reference that always refers to the same cell, no matter where you 
copy it. Excel uses a dollar sign ($) to indicate that each part of the reference is absolute. 
For example, $B$3 is an absolute reference to cell B3.

	Relative reference. A reference that refers to the cell by its position relative to the cell that 
holds the reference. For example, if you select cell A3 and enter =B5 in it, the reference 
means “the cell one column to the right and two rows down.” So if you copy the formula 
to cell C4, Excel changes the cell reference to cell D6, which is one column to the right 
and two rows down from cell C4. To indicate a relative reference, Excel uses a plain 
reference without any dollar signs; for example, B5.

	Mixed reference. A reference that is absolute for either the column or the row and relative 
for the other. For example, $B4 is absolute for the column (B) and relative for the row (4), 
while B$4 is relative for the column and absolute for the row. When you copy and paste a 
mixed reference, the absolute part stays the same, but the relative part changes to reflect 
the new location.

If you’re typing a reference, you can type the $ signs into the reference to make it absolute or mixed. If you’re 
entering references by selecting cells, click in the reference in the cell you’re editing or in the Formula bar, and 
then type the $ signs needed.

Referring to Named Cells and Ranges
To make your references easier to enter and recognize, you can assign a name to any cell 
or range, as discussed in the section “Identifying Parts with Named Ranges” in Chapter 3. 
You can then refer to the cell or range by the name, even if it’s on another worksheet whose 
name you’ve forgotten.

Understanding the Components of Formulas
When you need to perform a custom calculation in a cell, use a formula rather than a 
function. All you need to do is type in a simple formula using the appropriate calculation 
operators, such as + signs for addition and – signs for subtraction. In this section, you’ll 
meet the calculation operators, try using them in a worksheet, and learn the order in which 
Excel applies them—and how to change that order.

Meet Excel’s Calculation Operators
To perform calculations in Excel, you need to know the operators for the different 
operations—addition, division, comparison, and so on. Table 5-1 explains the full set of 
calculation operators you can use in your formulas in Excel.

http://dx.doi.org/10.1007/978-1-4842-1019-2_3
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Table 5-1. Calculation Operators You Can Use in Excel

Calculation Operator Operation Explanation or Example

Arithmetic Operators

+ Addition =1+2 adds 2 to 1.

– Subtraction =1–2 subtracts 2 from 1.

* Multiplication =2*2 multiplies 2 by 2.

/ Division =A1/4 divides the value in cell A1 by 4.

% Percentage =B1% returns the value in cell B2 expressed as a 
percentage. Excel displays the value as a decimal unless 
you format the cell with the Percentage style.

^ Exponentiation =B1^2 raises the value in cell B1 to the power 2.

Comparison Operators

= Equal to =B2=15000 returns TRUE if cell B2 contains the value 
15000. Otherwise, it returns FALSE.

<> Not equal to =B2<>15000 returns TRUE if cell B2 does not contain 
the value 15000. Otherwise, it returns FALSE.

> Greater than =B2>15000 returns TRUE if cell B2 contains a value 
greater than 15000. Otherwise, it returns FALSE.

>= Greater than or 
equal to

=B2>=15000 returns TRUE if cell B2 contains a value greater 
than or equal to 15000. Otherwise, it returns FALSE.

< Less than =B2<15000 returns TRUE if cell B2 contains a value less 
than 15000. Otherwise, it returns FALSE.

<= Less than or  
equal to

=B2<=15000 returns TRUE if cell B2 contains a value 
less than or equal to 15000. Otherwise, it returns FALSE.

Reference Operators

[cell reference]:[cell 
reference]

The range of cells 
between the two 
cell references

A1:G5 returns the range of cells whose upper-left cell is 
cell A1 and whose lower-right cell is cell G5.

[cell reference],[cell 
reference]

The range of cells 
listed

A1,C3,E5 returns three cells: A1, C3, and E5.

[cell or range reference] 
[space][cell or range 
reference]

The range (or 
cell) that appears 
in both cells or 
ranges given

=A7:G10 B10:B12 returns the cell B10, because this is 
the only cell that appears in both the ranges given. If 
more than one cell appears in the range, this returns a 
#VALUE! error.

Text Operator

& Concatenation 
(joining values as 
text)

=A1&B1 returns the values from cells A1 and B1 joined 
together as a text string. For example, if A1 contains  
“New York ” (including a trailing space) and B1 contains 
“Sales”, this formula returns “New York Sales”. If A1 
contains 100 and B1 contains 50, this formula returns 10050.
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Creating Straightforward Formulas
Now that you know what the calculation operators are, try the following example of 
creating a worksheet (see Figure 5-1) with formulas that use the four most straightforward 
operators—addition, subtraction, multiplication, and division.

Figure 5-1. Create this simple worksheet using Excel’s addition, subtraction, multiplication, and division operators

To create the worksheet, follow these steps:

 1. Create a new workbook. The quickest way to do this is to press 
Cmd+N.

 2. Type the following text in cells A1 through A7:

	A1. Gross

	A2. Expenses

	A3. Tax Rate

	A4. Tax Amount

	A5. Net

	A6. Months

	A7. Monthly Net

 3. Apply boldface to column A by clicking the column heading and then 
choosing Home ➤ Font ➤ Bold.

 4. Apply the Currency format to column B by clicking the column heading 
and then choosing Home ➤ Number ➤ Number Format ➤ Currency.
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 5. Type the following text in cells B1 through B3:

	B1. 84000

	B2. 30000

	B3. 0.18

 6. Apply the Percentage style to cell B3 by clicking the cell and then 
choosing Home ➤ Number ➤ Percent Style. 

 7. Now enter the formula =B1*B3 in cell B4, like this:

a. Click cell B4 to select it.

b. Type = to start creating a formula in the cell.

c. Click cell B1 to enter it in the formula. Excel displays a shimmering dotted 
blue outline around the cell and adds it to the formula in the cell and to the 
Formula bar (see Figure 5-2).

Figure 5-2. When you click cell B1, Excel adds it to the formula in both the cell and the Formula bar and displays a 
dotted blue outline around it

d. Type * to tell Excel you want to multiply the value in cell B1. Excel enters the 
asterisk in the formula and changes the outline around cell B1 to solid blue.

e. Click cell B3 to enter it in the formula. Excel displays a shimmering dotted 
outline (green this time) around the cell and adds it to the formula in the cell 
and in the Formula bar (see Figure 5-3).

Note You can also enter the percentage in Step 6 by typing 18% and pressing Return. Excel 
automatically changes the number format to Percentage.
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f. Press Return or click the Enter button (the check-mark button in the Formula 
bar) to finish entering the formula in cell B4.

 8. Enter the formula =B1-(B2+B4) in cell B5. Follow these steps:

a. Click cell B5 to select it. If you pressed Return to enter the previous formula, 
Excel may have selected this cell already.

b. Type = to start creating a formula in the cell.

c. Click cell B1 to add it to the formula.

d. Type – to enter the subtraction operator.

e. Type ( to start a nested expression. (More on this shortly.)

f. Click cell B2 to add it to the formula.

g. Type + to enter the addition operator.

h. Click cell B4 to add it to the formula.

i. Type ) to end the nested expression.

j. Click the Enter button to finish entering the formula.

 9. Enter 12 in cell B6 and apply general formatting to it. Follow  
these steps:

a. Click cell B6.

b. Choose Home ➤ Number ➤ Number Format ➤ General.

c. Type 12.

d. Press the down arrow to enter the value and move the active cell to cell B7.

10. Enter the formula =B5/B6 in cell B7. This time, simply type the 
formula in—lowercase is fine—and then press Return. You’ll notice 
that when you type B5, Excel selects cell B5 to let you check visually 
that you have the right cell.

Figure 5-3. Click cell B3 to add it to the formula
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Now that you’ve created the worksheet, try changing the figures in cells B1, B2, and B3. 
You’ll see the results of the formulas in cells B4, B5, and B7 change accordingly. Excel 
recalculates the formulas each time you change a value in a cell, so the formula results 
remain up to date.

TURNING OFF AUTOMATIC RECALCULATION FOR LARGE WORKBOOKS

If you create a workbook with huge amounts of data, automatic recalculation may make Excel run slowly, 
especially when one recalculated value causes many other values to need recalculation.

If you find Excel struggling to recalculate a workbook, turn off automatic calculation by choosing Formulas ➤ 
Calculation ➤ Calculation Options ➤ Manual. If recalculation was the problem, you’ll notice the difference 
immediately.

You can recalculate manually when necessary by choosing Formulas ➤ Calculation ➤ Calculate Sheet (to 
recalculate just the active worksheet) or choosing Formulas ➤ Calculation ➤ Calculate Now to recalculate 
the whole workbook.

Creating Complex Formulas
As you saw in the previous section, you can quickly create straightforward formulas with a 
single operator. But often you’ll need to create formulas that use multiple operators, as you 
also did in the previous section. When you do, you must understand the order in which Excel 
evaluates the operators so that you can get the calculation correct. You also need to know 
how to tell Excel to evaluate the operators in a different order. And you may want to break a 
complex formula into multiple steps so you can see exactly what you’re doing.

Understanding the Order in Which Excel Evaluates Operators
In the previous example, you entered the formula =B1-(B2+B4) in cell B5. The parentheses 
are necessary because the calculation has two separate stages—one stage of subtraction 
and one stage of addition—and you need to control the order in which they occur.

Try changing the formula in cell B5 to =B1-B2+B4 and see what happens. Follow these steps:

 1. Click cell B5.

 2. Click in the Formula bar to start editing the formula there. (You can 
also edit in the cell by double-clicking the cell or pressing Ctrl+U, but 
editing in the Formula bar gives you more space, so it’s often easier.)

 3. Delete the opening and closing parentheses.

 4. Click the Enter button on the Formula bar.
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You’ll notice that the Net amount (cell B5) jumps substantially. This is because you’ve 
changed the meaning of the formula:

	=B1-(B2+B4). This formula means “add the value in cell B2 to the value 
in cell B4, and then subtract the result from the value in cell B1.”

	=B1-B2+B4. This formula means “subtract the value in cell B2 from the 
value in cell B1, and then add the value in cell B4 to the result.”

Click cell B5 and press Ctrl+U to open the cell for editing. Position the insertion point before 
B2 and type (; and then position the insertion point after B4 and type ). Then press Return to 
enter the formula in the cell.

The order in which Excel evaluates the operators is called operator precedence, and it can 
make a huge difference in your formulas—so it’s vital to know both how it works and how to 
override it. Table 5-2 shows you the order in which Excel evaluates the operators in formulas.

Table 5-2. Excel’s Operator Precedence in Descending Order

Precedence Operators Explanation

1 – Negation

2 % Percentage

3 ^ Exponentiation

4 * and / Multiplication and division

5 + and – Addition and subtraction

6 & Concatenation

7 =, <>, <, <=, >, and >= Comparison operators

Note When you use nested parentheses in a formula, Excel uses a different color for each pair of 
parentheses to help you see which closing parenthesis and opening parenthesis go together.

When two operators are at the same level, Excel performs the operator that appears earlier 
in the formula first.

Nesting Parts of a Formula to Control Operator Precedence
You can control operator precedence in any formula by nesting one or more parts of the 
formula in parentheses. For example, as you just saw, using =B1-(B2+B4) makes Excel 
evaluate B2+B4 before the subtraction.
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You can nest parts of the formula several levels deep if necessary. For example, the 
following formula uses three levels of nesting and returns 180:

=10*(5*(4/(1+1))+8)

Breaking up a Complex Formula into Separate Steps
A cell can accept more or less as complex a formula as you care to create—and some 
people enjoy creating formulas that are so complex that it takes an expert to figure them out.

Unless you like to work this way, when you have to create a complex formula, consider 
breaking it up into separate steps, putting each step in its own cell or row. For example, you 
could break up that =10*(5*(4/(1+1))+8) formula like this:

	Cell B1. =1+1

	Cell B2. =4/B1

	Cell B3. =5*B2

	Cell B4. =B3+8

	Cell B5. =10*B4

Broken up like this, each formula is easy to read, and you can easily see if any of the steps 
gives the wrong result. You can type a text description of each step in the next cell for 
reference, or (more discreetly) insert a comment describing the step.

When you’ve checked that the formula works, you have the option of creating a new version 
of the formula that goes into a single cell. But if you want to keep the worksheet easy to read 
and easy to audit, leave the formula in its step-by-step form.

Entering Formulas Quickly by Copying and  
Using AutoFill
In many worksheets, you’ll need to enter related formulas in several cells. For example, say 
you have the worksheet shown in Figure 5-4, which lists a range of products with their prices 
and sales. Column D needs to show the total revenue derived by multiplying the Units figure 
by the Price value.
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Each cell in column D needs a different formula: Cell D2 needs =B2*C2, Cell D3 needs 
=B3*C3, and so on. Because the formula is the same except for the row number, you can 
use either AutoFill or Copy and Paste to enter the formula from cell D2 into the other cells  
as well.

To enter the formula using AutoFill, click the cell that contains the formula (here, cell D2), and 
then drag the AutoFill handle (the green square at the lower-right corner of the active cell) 
down through cell D5. Excel automatically fills in the formulas, adjusting each for the change 
in row.

To enter the formula using Copy and Paste, click the cell that contains the formula, and then 
give the Copy command (for example, press Cmd+C). Select the destination cells, and then 
give the Paste command (for example, press Cmd+V).

Choosing Preferences for Error Checking
Excel can automatically identify various errors in your formulas. To choose which errors 
Excel marks, you set the error-checking preferences. Choose Excel ➤ Preferences or press 
Cmd+, (Cmd and the comma key) to display the Excel Preferences window, and then click 
the Error Checking icon in the Formulas and Lists area to display the Error Checking pane 
(see Figure 5-5).

Note If you need to copy a formula to a different row or column but have it refer to the original 
column or row, create the formula using mixed references. If you need to keep the column the 
same, make the column absolute (for example, =$B2); if you need to keep the row the same, make 
the row absolute (for example, =B$2). If you need the formula to refer to the same cell or range 
always, create it as an absolute reference.

Figure 5-4. When a worksheet needs similar formulas in a column or row, you can enter one formula manually and 
then use AutoFill or Copy and Paste to enter it quickly in the other cells
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You can then choose the following settings in the upper box:

	Turn on background error checking. Select this check box to turn on 
error checking in the background. Background error checking is a good 
idea for small and medium-size workbooks, but you may want to turn 
it off for larger workbooks because it can slow Excel down. If you do 
turn off background error checking, be sure to check for errors manually 
(choose Formulas ➤ Formula Auditing ➤ Error Checking, clicking the 
main part of the Error Checking button).

	Indicate errors using this color. In this pop-up menu, choose the color 
to use for indicating errors. The default setting is Automatic, which lets 
Excel choose the color. You might prefer to choose a garish color to 
make errors stand out.

	Reset Ignored Errors. Click this button to reset all the errors in the active 
workbook that you’ve told Excel to ignore. You may find it helpful to 
ignore errors when you’re building a worksheet and errors occur because 
the data is not yet in place. When the worksheet is finished, you can click 
the Reset Ignored Errors button to see any remaining errors.

Figure 5-5. In the Error Checking pane of the Excel Preferences window, choose whether to use background error 
checking and decide which errors to show
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In the Show Errors For box, you can select or clear the following check boxes to control 
which errors (or apparent errors) Excel indicates by putting a green triangle at the upper-left 
corner of the cell:

	Formulas that result in an error. Select this check box to make Excel 
mark cells whose formulas produce errors. This is normally helpful.

	Years in 2 digits. Select this check box to make Excel mark cells 
that contain years represented by two digits rather than four digits 
(for example, 16 instead of 2016). Using four-digit years helps avoid 
confusion in your spreadsheets.

	Numbers formatted as text. Select this check box to make Excel mark 
numbers that have text formatting rather than number formatting or that 
you’ve preceded with an apostrophe to force Excel to treat them as text. 
This option can be helpful, but it’s apt to mark cells you’ve deliberately 
formatted as text.

	Formulas that don’t match nearby formulas. Select this check box to 
make Excel mark formulas that appear wrong because they’re different 
from formulas in adjoining cells. For example, if you have a row of eight 
cells, and six contain SUM( ) formulas adding the cells above them 
but two contain SUM( ) formulas adding the three cells to their left, 
this setting makes Excel mark those two cells because they contain 
formulas different from their neighbors. This can be helpful, but if the 
two oddball cells are summarizing the fiscal year quarters, you may 
want the formulas to be different.

	Formulas omitting cells in a region. Select this check box to make Excel 
mark formulas that are apparently intended to cover a whole region 
of a worksheet but omit particular cells in it. If these omissions are 
intentional, you can suppress the warnings.

	Unlocked cells containing formulas. Select this check box to make 
Excel mark unlocked cells that contain formulas. This setting can help 
you track down cells you need to lock to prevent your colleagues from 
taking liberties with your calculations.

	Formulas referring to empty cells. Select this check box to make Excel 
mark formulas that try to use empty cells. Empty cells can cause plenty 
of problems in your formulas, including division-by-zero errors, so having 
Excel identify formulas that use empty cells is usually a good idea.

	Inconsistent calculated column formula in tables. Select this check box 
to make Excel mark formulas in tables that differ from the other formulas 
in their columns. (Chapter 10 shows you how to create tables.)

When you’ve finished choosing error-checking preferences, click the Close button (the red 
button at the left end of the title bar) to close the Preferences window.

http://dx.doi.org/10.1007/978-1-4842-1019-2_10
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Troubleshooting Common Problems with Formulas
Formulas are great when they work, but a single-letter typo or a wrong reference can prevent 
a formula from working correctly. This section shows you how to deal with common 
problems with formulas, starting with solutions to the error messages you’re most likely to 
produce.

Understanding Common Errors—and Resolving Them
Excel includes an impressive arsenal of error messages, but some of them appear far more 
frequently than others. Table 5-3 shows you eight errors you’re likely to encounter, explains 
what they mean, and tells you how to solve them.

Caution This section shows you how to troubleshoot problems that Excel can identify because 
they prevent your calculations from working. But what can be much more dangerous are mistakes 
in formulas that don’t cause errors but instead give the wrong results; because the formulas work 
correctly, Excel can’t detect the errors and so raises no objections, but the values you get aren’t 
what you intend. If having your calculations give the correct results is important to you (as is usually 
the case), have a competent colleague check your worksheets for mistakes. You may also want to 
get a book such as Spreadsheet Check and Control by Patrick O’Beirne (Systems Publishing, 2005), 
which teaches you how to audit Excel worksheets.

Table 5-3. How to Solve Excel’s Eight Most Common Errors

Error What the Problem Is How to Solve It

##### The formula result is too wide 
to fit in the cell.

Make the column wider—for example, double-click the 
column head’s right border to AutoFit the column width.

#NAME? A function name is misspelled, 
or the formula refers to a 
range that doesn’t exist.

Check the spelling of all functions; correct any mistakes. 
If the formula uses a named range, check that the name 
is right and that you haven’t deleted the range.

#NUM! The function tries to use a 
value that is not valid for 
it—for example, returning 
the square root of a negative 
number.

Give the function a suitable value.

#VALUE! The function uses an invalid 
argument—for example, using 
=FACT() to return the factorial 
of text rather than a number.

Give the function the right type of data.

#N/A The function does not have a 
valid value available.

Make sure the function’s arguments provide values of 
the right type.

(continued )
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Error What the Problem Is How to Solve It

#DIV/0 The function is trying to 
divide by zero (which is 
mathematically impossible).

Change the divisor value from zero. Often, you’ll find that 
the function is using a blank cell (which has a zero value) 
as the argument for the divisor; in this case, enter a value 
in the cell.

#REF! The formula uses a cell 
reference or a range reference 
that’s not valid—for example, 
because you’ve deleted a 
worksheet.

Edit the formula and provide a valid reference.

#NULL! There is no intersection 
between the two ranges 
specified.

Change the ranges to produce an intersection.

Seeing the Details of an Error in a Formula
When Excel identifies an error in a formula, it displays a green triangle at the upper-left 
corner of the cell that contains the formula. Click the cell to display an action button that you 
can hold the mouse over to display a ScreenTip explaining the problem (as shown on the left 
in Figure 5-6) or click to display a menu of actions you can take to resolve the problem (as 
shown on the right in Figure 5-6).

Caution The =SUM( ) function is smart enough to ignore text values that you feed it. For example, 
if cell A1 contains the value 1 and cell A2 contains the text Dog, the function =SUM(A1:A2) returns  
1 even though the formula =A1+A2 returns a #VALUE! error. The =SUM() function’s smartness here 
is a mixed blessing: you get a usable result, which is presumably what you want—but this hides 
the mistake you’ve made in trying to add text instead of a numerical value.

Figure 5-6. Hold the mouse pointer over the action button for an error cell to display a ScreenTip explaining what’s wrong

Table 5-3. (continued )
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Tracing an Error Back to Its Source
To see which cell is causing an error, click the error cell, then choose Formulas ➤ Formula 
Auditing ➤ Error Checking ➤ Trace Error. Excel displays an arrow from the cell or cells 
causing the error to the error cell. The left screen in Figure 5-7 shows a simple example of 
tracing an error; the more complex the worksheet, the more helpful this feature is. Excel 
displays a worksheet symbol (see the right screen in Figure 5-7) if the cell reference is on 
another worksheet or in another workbook.

Figure 5-7. Use the Formulas ➤ Formula Auditing ➤ Error Checking ➤ Trace Error command to identify the cell or 
cells causing an error. If the cell reference is on another worksheet or in another workbook, Excel displays a worksheet 
symbol, as shown on the right

Note If you’ve turned off background error checking in the Error Checking pane, choose 
Formulas ➤ Formula Auditing ➤ Error Checking (clicking the main part of the Error Checking 
button) from the Ribbon or Tools ➤ Error Checking from the menu bar to check for errors.

Displaying All the Formulas in a Worksheet
When you need to review or check all the formulas in a worksheet, choose Formulas ➤ 
Formula Auditing ➤ Show Formulas, making the Show Formulas button appear pushed 
in. Excel displays the formulas and automatically widens the worksheet columns to give you 
more space (see Figure 5-8).
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When you’ve finished viewing the formulas, choose Formulas ➤ Auditing ➤ Show 
Formulas again. Excel automatically restores the columns to their former widths.

Seeing Which Cells a Formula Uses
To see which cells a formula uses, or to trace errors, click the cell that contains the formula, 
and then choose Formulas ➤ Formula Auditing ➤ Trace Precedents from the Ribbon. 
Excel displays an arrow showing the formula back to its roots. If one of the cells the formula 
uses contains a formula itself, you can click that cell and click the Trace Precedents button 
again to display its precedents in turn. Figure 5-9 shows the precedents of cell D6 and one 
of the cells that it uses, cell D2.

Figure 5-8. Choose Formulas ➤ Formula Auditing ➤ Show Formulas when you need to see all the formulas in a 
worksheet

Figure 5-9. Use the Trace Precedents command to see which cells you’re using to produce a formula result. In this example, 
cells B2 and C2 go to make up the formula in cell D2, which in turn appears in the =SUM(D2:D5) formula in cell D6

When you need to look at the problem the other way and see which formulas use a 
particular cell, click the cell, and then choose Formulas ➤ Formula Auditing ➤ Trace 
Dependents from the Ribbon. Again, Excel displays arrows, this time from the cell going to 
each of the formulas that use it. Figure 5-10 shows an example of tracing dependent cells.
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When you’ve finished tracing precedents and dependents (or errors), choose Formulas ➤  
Formula Auditing ➤ Remove Arrows (clicking the main part of the Remove Arrows button) 
to remove the arrows from the screen. If you want to remove just precedent arrows or 
dependent arrows, click the Remove Arrows pop-up button, and then click the Remove 
Precedent Arrows item or the Remove Dependent Arrows item on the pop-up menu.

Removing Circular References
Even if you’re careful, it’s easy enough to create a circular reference—one that refers to itself.

Circular references most often occur when you enter a formula that refers to a cell that in 
turn refers to the cell in which you’re entering the formula. For example, say cell A1 contains 
the formula =B1. If you enter the formula =A1 in cell B1, you’ve created a circular reference: 
cell B1 gets its value from cell A1, which gets its value from cell B1, and so on.

You can also enter a circular reference by making a cell refer to itself. For example, if you 
enter =A1/B1 in cell A1, you’ve created a circular reference in that cell, because cell A1 refers 
to itself. This type of circular reference is usually easier to avoid than the previous type.

Circular references can be useful in some specialized circumstances, such as when you 
need to perform iterations of a calculation, but normally you don’t want them in your 
worksheets, so Excel helps you to get rid of them.

When you create a circular reference that Excel can’t calculate, Excel displays the Excel 
cannot calculate a formula dialog box shown in Figure 5-11. Click the OK button if you want 
to open a Help window showing information on how to deal with circular references, or click 
the Cancel button if you want to go ahead and enter the circular reference in the cell (for 
example, because you can tell what the problem is and will be able to fix it easily).

Figure 5-10. Use the Trace Dependents command to see which formulas use a particular cell’s value to produce their results

Note You can use the Trace Precedents command and the Trace Dependents command either 
with formulas displayed or with formula results displayed, whichever you find most useful.
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Summary
In this chapter, you learned how to use formulas to perform calculations in your workbooks. 
You know that a formula is the recipe for a calculation, and you know how to assemble it 
from its various components—an equal sign, cell or range references, operators, and more. 
You know how to create the formulas you need and how to troubleshoot them when they 
go wrong.

In the next chapter, I’ll show you how to use Excel’s built-in functions, either on their own or 
in your formulas.

Figure 5-11. Circular references can cause problems in worksheets, so Excel warns you when you enter one. You can 
click the Cancel button if you’re sure you want to create the circular reference

Note If you leave circular references in a worksheet, use the Circular readout on the status bar to 
identify them. This readout shows the location of the most recent circular reference that Excel has 
identified. When you’ve dealt with that circular reference, the Circular readout shows the next one, 
and so on, until there are none left.
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Chapter 6
Using Excel’s Built-In 
Functions
As you saw in the previous chapter, a function is a predefined formula for performing a 
standard calculation. Excel includes several hundred built-in functions that you can simply 
insert in a cell and provide with the data they need to deliver the answer. Functions save you 
from having to create complex formulas from scratch and from getting such formulas wrong, 
so when you need to perform a standard calculation, check whether Excel has a function for 
it. There’s no point in reinventing the wheel.

In this chapter, you’ll learn how to insert functions into your worksheets using the various 
tools that Excel provides, how to find the functions you want, and how to point the functions 
to the data they need for the calculations.

Once you’re comfortable with how functions work, we’ll review the different categories of 
functions that Excel provides, such as database functions, logical functions, and math and 
trigonometric functions. I’ll explain the functions you’re most likely to find useful, giving 
examples where they’ll be helpful.

Understanding the Components of a Function
In Excel, a function has a name written in capitals followed by a pair of parentheses, which 
enclose the pieces of data (if any) the function needs. Here are three examples:

	SUM( ). This widely used function adds together two or more values that 
you specify.

	COUNT( ). This function counts the number of cells that contain numbers 
(as opposed to text, blanks, or other data types) in the range you 
specify.

	TODAY( ). This function enters the current date in the cell.
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Most functions take arguments, pieces of information that tell the function what you want it 
to work on. Excel prompts you to provide the arguments each function needs. For example, 
when you enter the function in a cell, Excel displays a ScreenTip showing the arguments 
needed. Figure 6-1 shows an example using the SUM( ) function.

Figure 6-1. When you enter a function in a cell, Excel prompts you to supply the arguments it needs

The ScreenTip shows that the SUM( ) function has one required argument and one optional 
argument, and you can add further arguments as needed:

	Required argument. Each required argument appears without 
brackets, like the argument number1 in the ScreenTip. You separate 
the arguments with commas, as in the example in the next paragraph. 
For example, you can use SUM( ) to add the values of cells in a 
range: SUM(C1:C10). Here, C1:C10 is a single argument, the required 
argument.

	Optional argument. Each optional argument appears in brackets, in the 
ScreenTip. For example, you can use SUM( ) to add the values of two 
cells: SUM(C1,C3). Here, C1 is the required argument, and C3 is the first 
optional argument.

	Extra arguments. The ellipsis (…) shows that you can enter extra 
arguments of the same type. For example, you can use SUM( ) to add 
the values of many cells: SUM(C1,C3,D4,D8,E1,XF202). Here, C1 is the 
required argument, and all the other cell references are optional 
arguments.

Entering Functions in Your Worksheets
Excel puts the most widely used functions right at your fingertips, and you can enter even 
the most specialized functions quickly and easily.

Note A few functions take no arguments. For example, you don’t need to tell the TODAY( ) function 
which day you’re talking about. Similarly, the NOW( ) function needs no arguments to return the 
current date and time, and the NA( ) function simply enters #(N/A) in a cell to indicate that the 
information is not available. Even when a function takes no arguments, you still need to include the 
parentheses to make Excel recognize the function.
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These are the three ways of inserting functions:

	Use the AutoSum button or AutoSum pop-up menu. The AutoSum 
button and pop-up menu appear in the Function group on the Formulas 
tab of the Ribbon and give quick access to five widely used functions.

	Use the Formula Builder. The Formula Builder is a pane that walks 
you through putting together the formula you need. You can open the 
Formula Builder in various ways, such as by clicking the fx button on 
the Formula bar, clicking the Insert Function button in the Function 
Library group on the Formulas tab of the Ribbon, or choosing Insert ➤ 
Function from the menu bar.

	Type the function in manually. When you know which function you want, 
you can type it straight into a cell.

We’ll look at the details in the following sections.

Inserting Functions with the AutoSum Pop-up Menu
The quickest and easiest way to enter any of five widely used functions—SUM( ), 
AVERAGE( ), COUNT( ), MAX( ), or MIN( )—in your worksheets is to use the AutoSum pop-up 
menu in the Function Library group on the Formulas tab of the Ribbon. Follow these steps:

1. Click the cell you want to enter the function in.

2. If you want to create a SUM( ) function for the cells immediately 
above or to the left of the selected cell, click the AutoSum button 
itself. Otherwise, click the AutoSum pop-up button, and then click 
the function (see Figure 6-2).

Figure 6-2. Use the AutoSum pop-up menu when you need to insert the SUM( ), AVERAGE( ), COUNT( ), MAX( ), or MIN( ) 
function quickly
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3. Excel inserts the function in the cell you chose and selects the range 
it thinks you may want to use as the argument. Figure 6-3 shows an 
example with the AVERAGE( ) function.

Figure 6-3. When you insert a function from the AutoSum pop-up menu, Excel selects a range of data it thinks may  
be suitable

4. If you need to change the range, do so in one of these ways:

Click and drag to select the right range.

Type the range over the range selected within the parentheses.

5. Add another argument to the formula if needed. For example, type a 
comma, and then click and drag to select another range.

6. When the formula is as you want it, press Return to enter it in the 
cell. Excel displays the result of the formula.

Inserting Functions with the Formula Builder
When you need to find the right function to insert or when you need to learn about the 
arguments for a function, use the Formula Builder to insert the function. The Formula 
Builder is a pane that gives you access to a complete list of Excel’s functions, together with 
descriptions and details of the arguments they use.
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To insert a function with the Formula Builder, follow these steps:

1. Select the cell in which you want to enter the function.

2. Open the Formula Builder in one of these ways:

Formula bar. Click the fx button.

Menu bar. Choose View ➤ Formula Builder or Insert ➤ Function.

Ribbon. Choose Formulas ➤ Function Library ➤ Insert Function or choose 
a function from one of the pop-up menus in the Function Library group. For 
example, click the Date & Time pop-up menu and then click a function.

3. If you want to search for a function, click in the Search box at the 
top, type keywords to search for, and then press Return. The Formula 
Builder displays a list of results, as shown on the left in Figure 6-4.

Figure 6-4. To find a function, type a search term in the Search pane of the Formula Builder and press Return; the 
Formula Builder shows a list of results (left). Otherwise, browse the full list of functions, and click the function you want 
to see information on (right)
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4. Otherwise, browse through the list of functions to find the function 
you need, as shown on the right in Figure 6-4. The Formula Builder 
breaks the functions up into the following categories (listed as 
presented in the right pane), most of which we’ll examine in depth 
later in this chapter:

Most Recently Used. This category provides quick access to the functions 
you’ve used most recently—so if you’re looking for a function you’ve used 
before, start by looking here.

All. This category contains the full list of functions.

Financial. This category contains functions for financial calculations—for 
example, calculating the payments on your mortgage or the depreciation on 
an asset.

Date and Time. This category contains functions ranging from returning the 
current date with the TODAY( ) function to using  
the WEEKDAY( ) function to return the day of the week for a particular date.

Math and Trigonometry. This category contains mathematical functions, 
such as the SQRT( ) function for returning a square root, and trigonometric 
functions, such as the COS( ) function for calculating a cosine.

Statistical. This category contains functions for performing statistical 
calculations, such as working out standard deviations based on a 
population or a sample.

Lookup and Reference. This category contains functions for looking up data 
from other parts of a worksheet or referring to other cells in it.

Database. This category contains functions for working with databases—for 
example, returning the average of values in a column or list or the count of 
cells containing numbers in a field.

Text. This category contains functions for manipulating text, such as the 
TRIM( ) function (for trimming off leading and trailing spaces) and the LEFT( ) 
function, which returns the leftmost part of the value.

Logical. This category contains functions for performing logical tests—for 
example, testing whether a particular cell contains an error.

Information. This category contains functions for returning information 
about data, such as whether it is text or a number.

Note The Formula Builder appears docked to the right side of the Excel window at first. You can 
undock it and reposition it by clicking and dragging its title bar. You can then resize the Formula 
Builder window as needed—for example, making it taller to give yourself a better view of the 
function information.
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Engineering. This category contains functions including the DEC2HEX( ) 
function (for converting a decimal number to hexadecimal, base 16) and the 
HEX2OCT( ) function (for converting a hexadecimal number to octal, base 8).

Cube. This category contains functions for manipulating data cubes, which 
are multidimensional sets of values.

Compatibility. This category contains functions included for compatibility 
with older versions of Excel. It’s best to use these functions only for 
compatibility with these older versions; if you’re developing worksheets for 
Excel 2015 or Excel 2013 (Windows), use the newer functions that these 
versions support—for example, use the new POISSON.DIST( ) function 
rather than the old POISSON( ) function.

5. To learn more about a function, click it. The Formula Builder shows 
its details at the bottom of the window, as shown on the left in 
Figure 6-5. From here, you can click the More help on this function 
link to open a Help window showing detailed information about the 
function and its arguments.

Figure 6-5. Use the description at the bottom of the Formula Builder to identify the function you want (left). When you 
click Insert Function, the Formula Builder displays a pane showing boxes for the arguments the function needs (right)
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6. When you’ve found the function you want to insert, click Insert 
Function. The Formula Builder displays the pane in which you enter 
the arguments for the function, as shown on the right in Figure 6-5 
(with one argument already entered).

7. Click in the box for the first argument, and then enter the data. 
You can type in a value or range name, type in a cell reference or 
range, or use the mouse to choose a cell reference or range in the 
worksheet (or in another worksheet or workbook).

8. Fill in each of the other arguments for the function. When you have 
entered all the required arguments, the Result readout to the left of 
the Done button in the Function Builder window shows the result of 
the function.

9. Click Done or press Return to enter the function in the worksheet.

If you have finished using the Function Builder, close it by clicking its Close button  
(the button at the left end of its title bar) or choosing View ➤ Formula Builder.

Inserting Functions with the Function Library Pop-up Menus
When you know which function you want to insert, the easiest way to insert it (unless it’s 
one of the five functions on the AutoSum pop-up menu) is to use the pop-up menus in the 
Function Library group on the Formulas tab of the Ribbon. These pop-up menus enable you 
to pick the function by category and insert it directly in the cell.

To insert a function using the pop-up menus, follow these steps:

1. Select the cell in which you want to enter the function.

2. Click the Formulas tab of the Ribbon to display its contents.

3. Go to the Function Library group at the left end of the Ribbon and 
locate the function category for the function you want to insert. There 
are nine categories: AutoSum (which we’ve discussed already), 
Recently Used, Financial, Logical, Text, Date & Time, Lookup & 
Reference, Math & Trig, and More Functions (which displays a submenu 
showing Statistical, Engineering, Cube, Information, Compatibility, and 
Web). As you’ll notice, these categories are similar to those that appear 
in the Formula Builder, discussed earlier in this chapter.

4. Click the function category’s button to display the pop-up menu 
containing the functions. Figure 6-6 shows the Date & Time  
submenu open.
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5. Click the function you want to insert. Excel inserts it in the cell and 
opens the Formula Builder with the pane for entering arguments 
displayed.

6. Enter the arguments for the function using the Function Builder.

7. Click Done in the Formula Builder, press Return, or click the Enter 
button on the Formula bar to enter the formula in the cell.

Inserting Functions by Typing Them into a Worksheet
You can also enter functions in your worksheets by typing them into cells. You’ll probably 
want to use this approach when you’re familiar with the function you need and you know its 
arguments. Follow these general steps:

1. Click the cell to select it.

2. Type = to tell Excel that you’re creating a formula.

Figure 6-6. In the Function Library group on the Formulas tab of the Ribbon, click the button for the category of 
functions you want to insert
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3. Start typing the function’s name. Excel displays a list of matching 
functions (see Figure 6-7).

Figure 6-7. When you start typing a function name into a cell, Excel lists matching functions. Click the function you 
want to insert, or press the down arrow key (and up arrow key, if necessary) to select the function and press Return

Note You can also keep typing until you’ve typed enough to identify the function uniquely—or 
type the whole of the function name if you prefer.

4. To enter a function, double-click it, or move the highlight to it by 
pressing the down arrow or up arrow, and then press Return.

5. Specify the arguments for the function. You can either type in a value 
or a reference or use the mouse to select a cell or range.

Nesting One Function inside Another Function
When you first start using functions, you’ll probably use a single function in a cell. But as you 
become more experienced with functions, you’ll find you sometimes need to use multiple 
functions to perform the calculations you want.

Note After entering a function in a cell, you can open the function for editing by double-clicking 
the cell or by making the cell active and then pressing Ctrl+U. You can edit the function either 
directly in the cell or in the Formula bar.
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When you need to use two or more functions together, you can nest one function inside 
another function. For example, if you need to return the current hour, you can nest the 
NOW( ) function (which returns the current date and time) in the HOUR( ) function (which 
returns the hour from a given time in 24-hour format; change the cell format if you need the 
hour in AM/PM format):

=HOUR(NOW( ))

As with formulas, you can nest functions many layers deep if you need to. Here’s an 
example with three layers of nesting:

=INT(AVERAGE(ROUND(SUM(C1:C6),2),ROUND(SUM(D1:D6),2)))

Here’s what happens:

	SUM(C1:C6). This SUM( ) function adds the values in the range C1:C6. 
Similarly, SUM(D1:D6) adds the values in the range D1:D6.

	ROUND(SUM(C1:C6),2). This ROUND( ) function rounds the result 
of the SUM(C1:C6) formula to two decimal places. Similarly, 
ROUND(SUM(D1:D6),2) rounds the result of the SUM(D1:D6) formula to 
two decimal places.

	AVERAGE. This function returns the average of the results returned by 
the two ROUND( ) functions.

	INT. This function returns the integer portion of the result from the 
AVERAGE( ) function.

Meeting Excel’s Built-in Functions
In this section, I’ll introduce you to Excel’s eleven main categories of built-in functions: 
Database, Date and Time, Engineering, Financial, Logical, Information, Lookup and 
Reference, Math and Trigonometry, Statistical, Text, and Cube. We’ll look at the functions 
that are most widely useful, with examples where they’ll be helpful.

Tip Nesting functions makes for compact spreadsheets and can impress your colleagues. But 
when you’re working out which functions to use, you may find it easier to put each function in a 
separate cell so that you can see the result each returns—and perhaps add comments explaining 
what each step does. Once you’ve got the functions working in separate cells, create the nested 
version in a single cell, and make sure it gives the same result as the step-by-step version. Again, 
you may want to add a comment explaining how the nested formula works.
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Database Functions
Excel includes 12 database functions you use to identify values in an Excel table that match 
your specified criteria. (A table is a flat-form database you create on a worksheet; Chapter 10  
explains how to create tables and gives you examples of using the database functions.) 
Table 6-1 explains the database functions.

Table 6-1. Excel’s Database Functions

Database Function What It Returns

DAVERAGE The average of the values in a column that match the criteria you specify.

DCOUNT The count of cells in the database field that match the criteria you specify.

DCOUNTA The count of nonblank cells in the database field that match the criteria 
you specify.

DGET The database record that matches the criteria you specify for a particular 
field.

DMAX The largest number in the database field that matches the criteria you 
specify.

DMIN The smallest number in the database field that matches the criteria you 
specify.

DPRODUCT The result of multiplying the values of the records that match the criteria 
you specify.

DSTDEV The standard deviation of the selected database entries from a sample.

DSTDEVP The standard deviation based on the entire population of the selected 
entries.

DSUM The value that results from adding the values in the fields that match the 
criteria you specify.

DVAR The variance based on a sample of database entries.

DVARP The variance based on the entire population of database entries.

Date and Time Functions
Table 6-2 explains Excel’s date and time functions, which you’ll find useful in many 
worksheets.

http://dx.doi.org/10.1007/978-1-4842-1019-2_10
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Table 6-2. Excel’s Date and Time Functions

Date and Time Function What It Returns

DATE The serial number of the specified date. For example, =DATE(2015,11,18) 
returns 42326, the serial date for 18 November 2015. Excel displays this 
value as a date unless you set the cell format to General.

TIME The serial number of the specified time. For example, =TIME(11,59,59) 
returns 0.499988426, the serial number for 11:59.59 AM. Excel displays this 
value as time unless you set the cell format to General.

DATEVALUE The serial number of the specified date that’s formatted as text. For 
example, =DATEVALUE(“12 December 2015”) returns 42350, the serial 
date for 12 December 2015.

TIMEVALUE The serial number of the specified time that’s formatted as text. For 
example, =TIMEVALUE(“3:25.00 PM”) returns 0.502372685, the serial 
number for 3:25 PM.

DAY A serial number between 1 and 31, representing the day of the month for 
the specified serial date. For example, =DAY(42500) returns 10, indicating 
that the date falls on the tenth day in the month.

DAYS The number of days that the first specified date is after the second 
specified date. For example, =DAYS(“12/1/16”, “10/1/16”) returns 61, the 
number of days that 1 December 2016 is after 1 October 2016.

MONTH A serial number between 1 and 12, representing the month in which 
the specified serial date falls. For example, =MONTH(42500) returns 5, 
indicating that the date is in May.

YEAR The four-digit number for the specified serial date. For example, 
=YEAR(42500) returns 2016, indicating that the date is in 2016.

YEARFRAC A number showing how many years are between the 
specified start date and the specified end date. For example, 
=YEARFRAC(DATE(2015,1,1),DATE (2016,3,1)) returns 1.166666667, the 
number of years between 1 January 2015 and 1 March 2016.

DAYS360 A number showing the number of days between the specified start date 
and the specified end date, assuming there are 360 days in a year (this is an 
accounting technique rather than a straightforward denial of conventional 
timekeeping). For example, =DAYS360(DATE(2015,1,1),DATE(2016,3,1)) 
returns 420, the number of days between 1 January 2015 and 1 March 
2016 (with that 360-day year).

HOUR A serial number between 0 and 23 representing the hour for the time given. 
For example, =HOUR(0.25) returns 6, representing 6 AM, which is one 
quarter of the way through the 24 hours in a day.

MINUTE A serial number between 0 and 59 representing the minute for the time given. 
For example, =MINUTE(0.55) returns 12, being the minutes in 1:12 PM, 
which is the time 55% through a day.

(continued )



 
180 CHAPTER 6: Using Excel’s Built-In Functions

Date and Time Function What It Returns

SECOND A serial number between 0 and 59 representing the second for the time 
given. For example, =SECOND(0.61) returns 24, being the seconds in 
2:38.24 PM, which is the time 61% through a day.

TODAY The current date in date format. For example, =TODAY( ) returns 6/12/2016 
on 12 June 2016.

NOW The current date and time in date and time format. For example, =NOW( ) 
returns a date and time such as 6/2/2016 03:15.

WEEKNUM A serial number between 1 and 52, showing the week of the year the 
specified date occurs in. For example, =WEEKNUM(42500) returns 20, 
indicating that the date falls in the 20th week of the year.

ISOWEEKNUM The number of the ISO week in which the specified date falls. For example, 
=ISOWEEKNUM(“30 June 2016”) returns 26, indicating that the date is in 
the 26th ISO week.

WEEKDAY A serial number between 1 (Sunday) and 7 (Saturday) showing the weekday 
for the specified date. For example, =WEEKDAY(42500) returns 3, indicating 
that the day is a Tuesday.

WORKDAY A serial number giving the date that is the specified number of workdays 
before or after the specified start date, including the number of holidays 
specified. For example, =WORKDAY(DATE(2016,6,12),40,2) returns 42587, 
the serial number of 5 August 2016, the workday 40 days after 12 June 2016 
if there are two holidays.

NETWORKDAYS A number giving the net number of workdays (“net workdays”) between the 
specified starting date and the specified ending date, minus the number of 
holidays specified. For example, =NETWORKDAYS(DATE(2016,6,12),DATE  
(2016,10,20),2) returns 94, the net number of workdays between 12 June 
2016 and 20 October 2016, assuming that two holidays fall in that period.

NETWORKDAYS.INTL A number giving the net number of workdays between the specified starting 
date and the specified ending date, minus the number of days you give as 
weekend days. For example, =NETWORKDAYS.INTL(DATE(2015,10,30), 
DATE(2016,2,28),2,3) returns 113, the number of workdays between  
30 October 2015 and 28 February 2016, assuming that Sunday and 
Monday are weekend days (this is the 2 value) and that three holidays occur 
(that’s the 3 value) in this period.

EDATE The serial number of the date that is the specified number of months before 
or after the given start date. For example, =EDATE(42500,4) returns 42623, 
the serial date four months after the serial date 42500.

EOMONTH The serial number of the last day of the month that is the specified number of  
months before or after the given start date. For example, =EOMONTH(DATE 
(2015,7,14),6) returns 42400, the serial number for 31 January 2016, the last 
day of the month that is six months after 14 July 2015.

Table 6-2. (continued )
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Engineering Functions
Table 6-3 explains Excel’s engineering functions, which range from calculating Bessel 
functions to converting numbers to and from binary, octal, and hexadecimal.

Table 6-3. Excel’s Engineering Functions

Engineering Function What It Returns

BESSELI The modified Bessel function In(x), the contour integral. For example, 
=BESSELI(1.8,1) returns 1.31716723.

BESSELJ The Bessel function Jn(x). This is also called cylindrical harmonics. For 
example, =BESSELJ(1.5,2) returns 0.232087679.

BESSELK The modified Bessel function Kn(x). This is also called the Basset function or 
Macdonald function. For example, =BESSELK(1.8,3) returns 0.95783635.

BESSELY The Bessel function Yn(x), also called the Neumann function or the Weber 
function. For example, =BESSELY(3.5,1) returns 0.410188417.

BIN2DEC The decimal (base 10) equivalent of the specified binary (base 2) number. 
For example, =BIN2DEC(1001101) returns 77. The binary number can be up 
to ten characters long; longer numbers cause #NUM! errors.

BIN2HEX The hexadecimal (base 16) equivalent of the specified binary (base 2) 
number, optionally specifying the number of characters to use. For example, 
=BIN2HEX(111011111) returns 1DF, while =BIN2HEX(111011111,4) returns 
01DF. The binary number can be up to ten characters long; longer numbers 
cause #NUM! errors.

BIN2OCT The octal (base 8) equivalent of the specified binary (base 2) number, 
optionally specifying the number of characters to use. For example, 
=BIN2OCT(1011,4) returns 0013.

BITAND The result of a bitwise AND operation using the two specified integers, each 
of which must be 0 or greater. For example, =BITAND(1,9) returns 1.

BITLSHIFT The number resulting from the specified number being shifted left by the 
specified number of bits, effectively adding zeros to the end of the number. 
For example, =BITLSHIFT(1,2) returns 4, because shifting a binary 1 two 
bits to the left makes it a 4.

BITOR The result of a bitwise OR operation on the two specified integers, each of 
which must be 0 or greater. For example, =BITOR(8,4) returns 12.

BITRSHIFT The number resulting from the specified number being shifted right by the 
specified number of bits, effectively removing the rightmost digits from the 
number. For example, =BITRSHIFT(27,7) removes the rightmost two digits 
from 27 (binary 11011), returning 6 (binary 110).

BITXOR The result of a bitwise Exclusive OR operation on the two specified integers. 
For example, =BITXOR(32,16) returns 48.

(continued )
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Engineering Function What It Returns

COMPLEX The complex number produced by real and imaginary coefficients. For 
example, =COMPLEX(4,5) returns 4+5i.

CONVERT The equivalent value in the specified destination measuring system of the 
value in the specified source measuring system. You can convert Weight and 
Mass, Distance, Pressure, Force, Energy, Power, Magnetism, Temperature, 
Liquid, and Metric measurements; see the Help file for details. For example, 
=CONVERT(200,“kg”,“lbm”) converts 200Kg to its equivalent weight in 
pounds (440.9245244).

DEC2BIN The binary (base 2) equivalent of the specified decimal (base 10) number, 
optionally specifying the number of characters to use. For example, 
=DEC2BIN(100) returns 1100100, while =DEC2BIN(100,10) returns 
0001100100.

DEC2HEX The hexadecimal (base 16) equivalent of the specified decimal (base 10) 
number, optionally specifying the number of characters to use. For example, 
=DEC2HEX(-90) returns FFFFFFFFA6.

DEC2OCT The octal (base 8) equivalent of the specified decimal (base 10) number, 
optionally specifying the number of characters to use. For example, 
=DEC2OCT(100,6) returns 000144.

DELTA 1 if the two numbers are equal, 0 if they are not. For example, 
=DELTA(B1,B2) returns 1 if the values in cells B1 and B2 are equal; 
otherwise, it returns 0.

ERF The error function integrated between the specified lower limit and specified 
upper limit. If you omit the upper limit, the error function between zero and 
the specified lower limit. For example, =ERF(0.5,2) returns 0.474822387, the 
error function integrated between 0.5 and 2.

ERF.PRECISE The error function integrated between the specified lower limit and infinity. 
For example, =ERF.PRECISE(2) returns 0.99532227.

ERFC The complementary error function integrated between the specified lower 
bound and infinity. For example, =ERFC(2) returns 0.004677735.

ERFC.PRECISE The complementary error function integrated between the specified lower 
bound and infinity. For example, =ERFC.PRECISE(2) returns 0.004677735.

GESTEP 1 if the specified number is greater than or equal to the specified threshold, 
0 if it is not. For example, =GESTEP(5,D1) returns 1 if 5 is greater than or 
equal to the value in cell D1; otherwise, it returns 0.

HEX2BIN The binary (base 2) equivalent of the specified hexadecimal (base 16) 
number, optionally specifying the number of characters to use. For example, 
=HEX2DEC(“AF”,8) returns 10101111.

Table 6-3. (continued )

(continued )
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Engineering Function What It Returns

HEX2DEC The decimal (base 10) equivalent of the specified hexadecimal (base 16) 
number. For example, =HEX2DEC(“FFFF0000”) returns 4294901760.

HEX2OCT The octal (base 8) equivalent of the specified hexadecimal (base 16) 
number, optionally specifying the number of characters to use. For example, 
=DEX2OCT(“AF00”) returns 127400.

IMABS The modulus (absolute value) of a complex number. For example, 
=IMABS(“6+2i”) returns 6.708203932.

IMAGINARY The imaginary coefficient of a complex number. For example, 
=IMAGINARY(“8+3i”) returns 3.

IMARGUMENT The theta argument, an angle expressed in radians, for the specified 
complex number. For example, =IMARGUMENT(“4+5i”) returns 
0.896055385.

IMCONJUGATE The complex conjugate of the specified complex number. For example, 
=IMCONJUGATE(“4+5i”) returns 4-5i.

IMCOS The cosine of the specified complex number. For example, =IMCOS(A22) 
returns the cosine of the value in cell A22.

IMDIV The quotient of the specified two complex numbers. For example, 
=IMDIV(“10+25i”,“-240+280i”) calculates the quotient of the two numbers 
given.

IMCOSH The hyperbolic cosine of a complex number. For example, 
=IMCOSH(“2+3i”) returns -3.72454550491532+0.511822569987385i.

IMCOT The cotangent of a complex number. For example, =IMCOT(“2+2i”) returns 
-0.0270655117325534-0.97596873511731i.

IMCSC The cosecant of a complex number. For example, =IMCSC(“2+2i”) returns 
0.244687073586957+0.107954592221385i.

IMCSCH The hyperbolic cosecant of a complex number. For example, 
=IMCSCH(“2+1j”) returns 0.141363021612408-0.2283750655999687j.

IMEXP The exponential of the specified complex number. For example, 
=IMEXP(“2+i”) returns 3.99232404844127+6.21767631236797i.

IMLN The natural logarithm of the specified complex number. For example, 
=IMLN(“8+10i”) returns 2.5499332139121+0.896055384571344i.

IMLOG10 The base-10 logarithm of the specified complex number. For example, 
=IMLOG10(“8+10i”) returns 1.10742192402385+0.389151908999031i.

IMLOG2 The base-2 logarithm of the specified complex number. For example, 
=IMLOG2(“8+10i”) returns 3.67877600230904+1.29273465968293i.

IMPOWER The specified complex number raised to the specified power. For example, 
=IMPOWER(“4+2i”,3) returns 16+88i.

Table 6-3. (continued )

(continued )



 
184 CHAPTER 6: Using Excel’s Built-In Functions

Engineering Function What It Returns

IMPRODUCT The product of the specified complex numbers. For example, 
=IMPRODUCT(“3+4i”,“2+3i”) returns -6+17i.

IMREAL The real coefficient of the specified complex number. For example, 
=IMREAL(“3+4i”) returns 3.

IMSIN The sine of the specified complex number. For example, =IMSIN(“3+4i”) 
returns 3.85373803791938-27.0168132580039i.

IMSEC The secant of the specified complex number. For example, =IMSEC(“3+4i”) 
returns -0.0362534969158689+0.00516434460775318i.

IMSECH The hyperbolic cosecant of the specified complex number. For example, 
=IMSECH(“3+4i”) returns -0.065294027857947+0.0752249603027732i.

IMSIN The sine of the specified complex number. For example, =IMSIN(“3+4i”) 
returns -0.065294027857947+0.0752249603027732i.

IMSINH The hyperbolic sine of a complex number. For example, =IMSINH(“3+4i”) 
returns -6.548120040911-7.61923172032141i.

IMSQRT The square root of the specified complex number. For example, 
=IMSQRT(“3+4i”) returns 2+i.

IMSUB The difference between the two specified complex numbers. For example, 
=IMSUB(“3+4i”,“4+5i”) returns -1-i.

IMSUM The sum of the specified complex numbers. For example, 
=IMSUM(“3+4i”,“4+5i”) returns 7+9i.

IMTAN The tangent of the specified complex number. For example, =IMTAN(“3+4i”) 
returns -0.000187346204629478+0.999355987381473i.

OCT2BIN The binary (base 2) equivalent of the specified octal (base 8) number, 
optionally specifying the number of characters to use. For example, 
=OCT2BIN(45,8) returns 00100101.

OCT2DEC The decimal (base 10) equivalent of the specified octal (base 8) number. For 
example, =OCT2DEC(45) returns 37.

OCT2HEX The hexadecimal (base 16) equivalent of the specified octal (base 8) number. 
For example, =OCT2HEX(45,8) returns 00000025.

Table 6-3. (continued )

Financial Functions
Table 6-4 introduces you to Excel’s financial functions, which cover most common financial 
calculations and various more specialized calculations.

Note For a security or investment, the issue date is when the seller makes the instrument 
available. The settlement date is when the buyer purchases a coupon for the financial instrument. 
The maturity date is when the instrument comes to term and the coupon expires.
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Table 6-4. Excel’s Financial Functions

Financial Function What It Returns

ACCRINT The interest accrued on a security that pays interest periodically. For example, 
=ACCRINT(DATE(2015,8,1),DATE(2015,9,1),DATE(2015,8,15),10%,5000,4) 
calculates the interest on a security with an issue date of 1 August 2015, a 
first interest date of 1 September 2015, a settlement date of 15 August 2015, 
an interest rate of 10%, a par value of $5000, and a frequency of four coupon 
payments per year.

ACCRINTM The interest accrued on a security that pays interest on maturity rather 
than along the way. For example, =ACCRINTM(DATE(2015,1,15),DA
TE(2016,2,15),10%,10000) calculates the interest on a security with an issue 
date of 15 January 2015, a maturity date of 15 February 2016, a rate of 10%, and 
a par value of $10,000.

AMORDEGRC An asset’s prorated linear depreciation for each accounting period (in the French 
accounting system). For example, =AMORDEGRC(5000,DATE(2014,12,3), 
DATE(2015,3,30),2000,2,12.5%) calculates the prorated linear depreciation of an 
asset bought on 3 December 2014 for $5000, putting the end of the first period 
on 30 March 2015, using a salvage value of $2000, two periods, and a 12.5% 
depreciation rate.

AMORLINC An asset’s prorated linear depreciation for each accounting period (in the French 
accounting system). For example, =AMORLINC(4000,DATE(2014,12,3), 
DATE(2015,6,30),1500,1,18%) calculates the prorated linear depreciation of 
an asset bought on 3 December 2014 for $4000, putting the end of the first 
and only period on 30 June 2015, using a salvage value of $1500 and an 18% 
depreciation rate.

COUPDAYBS The number of days from the coupon period’s beginning to the settlement date. 
For example, =COUPDAYBS(DATE(2015,2,19),DATE(2017,2,19),4) returns the 
number of days for a bond with a settlement date of 19 February 2015, a maturity 
date of 19 February 2017, and quarterly coupon payments.

COUPDAYS The number of days in the coupon period containing the settlement date. For 
example, =COUPDAYS(DATE(2015,3,1),DATE(2015,12,1),2) returns the number 
of days from the start of the coupon period to the settlement date for a bond with 
a settlement date of 1 March 2015, a maturity date of 1 December 2015, and 
semiannual coupons.

COUPDAYSNC The number of days to the next coupon date from the settlement date. For 
example, =COUPDAYSNC(DATE(2015,7,4),DATE(2016,4,8),2) calculates the 
number of days for a bond with a settlement date of 4 July 2015, a maturity date 
of 8 April 2016, and semiannual coupons.

COUPNCD The next coupon date after the settlement date. For example, 
=COUPNCD(DATE(2015,11,12), DATE(2016,12,13),4) returns the next coupon 
date after the settlement date of 12 November 2015 for a bond with a maturity 
date of 13 December 2016 and quarterly coupons.

(continued )
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Financial Function What It Returns

COUPNUM The number of coupons payable between the settlement date and the maturity 
date. For example, =COUPNUM(DATE(2015,1,5),DATE(2017,5,8),2) returns the 
number of coupons payable between the settlement date of 5 January 2015 and 
the maturity date of 8 May 2017 for a bond with a semiannual coupon.

COUPPCD The previous coupon date before the settlement date. For example,  
=COUPPCD(DATE(2015,1,8),DATE(2016,1,8),4) returns the previous coupon 
date before the settlement date of 8 January 2015 for a bond with a maturity date 
of 8 January 2016 and quarterly coupons.

CUMIPMT The cumulative interest paid between the two periods specified. For example, 
=CUMIPMT(1%,60,10000,1,12,1) calculates the cumulative interest paid at 
a monthly rate of 1% (making 12% per year), on a loan that uses 60 periods 
(five years), with a value of $10,000. The function calculates the cumulative 
interest paid in the periods 1 to 12 (the first year), assuming the payment is at 
the beginning of the month (the final 1) rather than the end of the month (which 
would be represented by 0).

CUMPRINC The cumulative principal paid on a loan between the two periods specified. For 
example, =CUMPRINC(0.5%,24,1500,1,6,0) calculates the cumulative principal 
paid on a $1500 loan for the first 6 months of a 24-month period. The loan uses a 
rate of 0.5% a month, and the payments are made at the end of the month (the 0 
at the end) rather than at the start of the month (which would be represented by 1).

DB The depreciation calculated using the fixed-declining balance method. For example, 
=DB(1000,250,6,2) calculates the second-year depreciation on an asset that costs 
$1000, has a salvage value of $250, and depreciates over six years.

DDB The depreciation calculated using the double-declining balance method or 
another method. For example, =DDB(2000,500,8,4,2) calculates the fourth-year 
depreciation on an asset that costs $2000 and has a salvage value of $500. The 
asset’s value depreciates over eight years using the double-declining balance 
method (represented by the 2 at the end).

DISC The discount rate for a security. For example, =DISC(DATE(2015,1,11),DATE 
(2016,2,20),96.5,100,3) calculates the discount rate for a security with a 
settlement date of 11 January 2015, a maturity date of 20 February 2016, a price 
of $96.50 per $100, a redemption rate of $100 per $100 of face value, using the 
Actual/365 day count basis.

DOLLARDE The decimal dollar price equivalent of the specified fractional dollar price. For 
example, =DOLLARDE(1.08,32) calculates the decimal dollar price of 1 dollar 
and 8/32, returning 1.25.

DOLLARFR The fractional dollar price equivalent of the specified decimal dollar price. For 
example, =DOLLARFR(1.25,32) calculates the fractional dollar price equivalent 
of $1.25 in thirty-seconds, returning 1.08.

Table 6-4. (continued )
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Financial Function What It Returns

DURATION The annual duration of a security that pays interest periodically. For example, 
=DURATION(DATE(2015,1,20),DATE(2016,6,12),7%,10%,2) calculates the 
annual duration of a security with a settlement date of 20 January 2015, a maturity 
date of 12 June 2016, an annual coupon rate of 7%, and an annual yield of 10%.

EFFECT The effective annual interest rate. For example, =EFFECT(6%,4) calculates the 
effective annual interest rate for a 6% interest rate that uses four compounding 
periods per year.

FV The future value of an investment. For example, =FV(8%/12,60,-500) calculates 
the future value of an investment into which you put $500 a month for 60 months 
and receive 8% interest over 12 months.

FVSCHEDULE The future value of an investment to which compound interest rates have been 
applied. For example, =FVSCHEDULE(100,{0.09,0.1,0.11,0.12}) calculates the 
future value of an investment of $100 that receives 9% interest the first year,  
10% interest the second year, 11% interest the third year, and 12 percent interest 
the fourth year.

INTRATE The interest rate for a security that is fully vested. For example, =INTRATE(DATE 
(2015,1,20),DATE(2016,6,15),10000,11000) returns the interest rate on a $10,000 
security with a settlement date of 20 January 2015, a maturity date of 15 June 
2016, and a redemption value of $11,000.

IPMT The interest payments for an investment for a specified period. For example, 
=IPMT(4%/12,1,24,-1000) calculates the interest period for the first month of a 
24-month investment that has a value of $1000 and that receives a princely  
4% divided over 12 months.

IRR The internal rate of return for cash flows. For example,  
=IRR({-50000,10000,12000,19000,28000}) calculates the internal rate of return 
for a venture that costs $50,000 up front and brings in $10,000 the first year, 
$12,000 the second year, $19,000 the third year, and $28,000 the fourth year.

ISPMT The interest paid for an investment over a specified period. For example, 
=ISPMT(7%/12,6,5*12,5000) calculates the payment in the sixth month of a  
five-year (5*12 months) investment of $5000 that earns 7% interest divided by  
12 months.

MDURATION The Macauley modified duration for a security that has an assumed par value of 
$100. For example, =MDURATION(DATE(2015,2,18),DATE(2018,2,28),7%,9%,2) 
calculates the Macauley modified duration for a security that has a settlement 
date of 18 February 2015, a maturity date of 28 February 2018, a 7% annual 
coupon rate, a 9% annual yield, and semiannual coupon payments.

MIRR The modified internal rate of return for cash flows. For example, =MIRR({-50000, 
10000,12000,19000,28000},3.5%,9%) calculates the modified internal rate of return 
for a business that costs $50,000 to buy and brings in $10,000 the first year, $12,000 
the second year, $19,000 the third year, and $28,000 the fourth year. You borrow 
money at 3.5% interest per year and manage to reinvest your cash flows at 9%.

Table 6-4. (continued )
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Financial Function What It Returns

NOMINAL The annual nominal interest rate. For example, =NOMINAL(4.6%,4) calculates 
the annual nominal interest rate for an effective interest rate of 4.6% with four 
compounding periods per year.

NPER The number of periods for an investment that uses constant payments and a 
constant rate of interest. For example, =NPER(6.5%/12,-250,5000) calculates 
the number of periods to pay off $5000 at $250 per month, given an interest rate 
of 6.5% annually (divided by 12 for the months).

NPV The net present value of an investment. For example, 
=NPV(8%/12,{500,750,1000}) calculates the net present value of an investment 
that brings in $500 in the first period, $750 in the second period, and $1000 in 
the third period, using an 8% discount rate divided by 12 months.

ODDFPRICE The price per $100 face value of a security that uses an odd first period. For 
example, =ODDFPRICE(DATE(2014,11,9),DATE(2021,4,1),DATE(2014,9,1), 
DATE(2015,2,1),0.08,0.065,100,2) calculates the price per $100 face value of 
a security that has a settlement date of 9 November 2014, a maturity date of 
1 April 2021, an issue date of 1 September 2014, and a first coupon date of 1 
February 2015. The security has an interest rate of 8%, an annual yield of 0.065, 
a redemption value of $100 per $100 face value, and two coupon payments  
per year.

ODDFYIELD The yield of a security that uses an odd first period. For example, 
=ODDFYIELD (DATE(2015,10,1),DATE(2026,3,1),DATE(2015,9,15),DA
TE(2016,3,1),6%,86,100,2,0) calculates the yield of a security that has a 
settlement date of 1 October 2015, a maturity date of 1 March 2026, an issue 
date of 15 September 2015, and a first coupon date of 1 March 2016. The 
security has a 6% interest rate, a price of $86, and a redemption value of $100. 
The coupon payments are semiannual, and the calculation uses the US 30/360 
day count basis.

ODDLPRICE The price per $100 face value of a security that uses an odd last period. For 
example, =ODDLPRICE(DATE(2016,6,6),DATE(2017,8,4),DATE(2016,5,16), 
7%,7.25%,100,4,0) calculates the price per $100 face value of a security that 
has a settlement date of 6 June 2016, a maturity date of 4 August 2017, and a 
last interest date of 16 May 2016. The security has an interest rate of 7%, an 
annual yield of 7.25%, and a redemption value of $100. The coupon frequency is 
quarterly, with payments made on a 30/360 basis.

ODDLYIELD The yield of a security that uses an odd last period. For example, =ODDLYIELD 
(DATE(2015,7,11),DATE(2016,11,11),DATE(2016,5,4),4.25%,97.5,100,2) 
calculates the yield on a security that has a settlement date of 11 July 2015, a 
maturity date of 11 November 2016, and a last interest date of 4 May 2016. The 
security draws a 4.25% interest rate, has a price of $97.50 and a redemption 
value of $100, and pays twice a year.

Table 6-4. (continued )
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Financial Function What It Returns

PDURATION The number of periods an investment will take to reach a specified value. For 
example, =PDURATION(5%,4000,6000) returns 8.3, the number of years an 
investment of $4000 will take to reach $6000 at a 5% interest rate.

PMT The payment for a loan that uses constant payments and a fixed interest rate. 
For example, =PMT(8%/12,36,-5000) calculates the monthly payment required 
to pay off a loan of $5000 in monthly payments over a 36-month period with an 
interest rate of 8%.

PPMT The payment for a particular period on the principal for an investment 
that uses constant payments and a fixed interest rate. For example, 
=PPMT(7.5%/12,1,24,-2000) calculates the payment for the first month of a 
24-month plan on a $2000 investment running at 7.5% interest annually.

PRICE The price per $100 face value of a security that pays interest periodically. For 
example, =PRICE(DATE(2015,3,4),DATE(2016,6,5),6.5%,7.4%,100,4) calculates 
the price per $100 face value of a security that has a settlement date of 4 March 
2015 and a maturity date of 5 June 2016. The security has a 6.5% interest rate, a 
7.4% yield, a $100 redemption value, and quarterly frequency.

PRICEDISC The price per $100 face value of a discounted security. For example,  
=PRICEDISC(DATE(2015,8,4),DATE(2016,9,17),5%,100) calculates the price 
per $100 face value of a security with a settlement date of 4 August 2015 and a 
maturity date of 17 September 2016. The security has a 5% discount rate and a 
$100 redemption value.

PRICEMAT The price per $100 face value of a security that pays interest when it reaches 
maturity. For example, =PRICEMAT(DATE(2015,8,14),DATE(2017,5,5),DATE 
(2015,6,15),8.5%,8%) calculates the price per $100 face value of a security 
with a settlement date of 14 August 2015, a maturity date of 5 May 2017, and 
an issue date of 15 June 2015. The security has an interest rate of 8.5% and an 
annual yield of 8%.

PV The present value of an investment—how much a series of future payments is 
worth altogether now. For example, =PV(10%/12,36,-250) calculates how much 
36 monthly payments of $250 is worth at 10% interest.

RATE The interest rate per period of an investment. For example, =RATE(60,-380, 
14000) calculates the interest rate per month on a $14,000 investment that 
receives $380 per month for 60 months.

RECEIVED The value at maturity of a fully invested security. For example, =RECEIVED  
(DATE(2015,7,17),DATE(2017,8,4),10000,4%) calculates the value at maturity of 
a security worth $10,000 with a settlement date of 17 July 2015, a maturity date 
of 4 August 2017, and a discount rate of 4%.

RRI The interest rate equivalent to the specified growth of an investment. For 
example, =RRI(5*12,5000,10000) calculates the interest rate equivalent to an 
investment that has grown from $5000 to $10,000 over five years (60 months).

Table 6-4. (continued )
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Financial Function What It Returns

SLN The straight-line depreciation for an asset over one period. For example, 
=SLN(3000,300,3) calculates the depreciation per period of an asset that costs 
$3000 new and has a salvage value of $300 after 3 years. (That’s right—it’s a 
high-end computer.)

SYD The sum-of-years’ digits depreciation for an asset over a specified period. For 
example, =SYD(3000,300,3,1) shows how much you lose on the previous example’s 
$3000 computer (with a salvage value of $300 after 3 years) in the first year.

TBILLEQ A percentage showing the bond-equivalent yield of a treasury bill. For example, 
=TBILLEQ(DATE(2015,12,1),DATE(2016,8,1),8.2%) shows the bond-equivalent 
yield of a treasury bill with a settlement date of 1 December 2015, a maturity date 
of 1 August 2016, and an 8.2% discount rate. The maturity date must be one 
year or less after the settlement date.

TBILLPRICE A treasury bill’s price per $100 face value. For example, =TBILLPRICE(DATE  
(2015,9,10),DATE(2016,7,12),7.2%) calculates the price per $100 face value of 
a treasury bill with a settlement date of 10 September 2015, a maturity date of 
12 July 2016, and a discount rate of 7.2 percent. The maturity date must be one 
year or less after the settlement date.

TBILLYIELD A percentage showing a treasury bill’s yield. For example, =TBILLYIELD(DATE 
(2015,8,20),DATE(2016,8,19),94.25) calculates the yield for a treasury bill with 
a settlement date of 20 August 2015, a maturity date of 19 August 2016, and a 
price per $100 face value of $94.25.

VDB The depreciation for an asset using the double-declining balance method or a 
variable declining balance. For example, =VDB(8000,2000,10,2,3,3) calculates 
the depreciation for an asset with an initial cost of $8000 and a salvage value of 
$2000 after 10 years. The function calculates the depreciation for the second to 
third year of the asset’s life, using a depreciation factor of 3.

XIRR The internal rate of return (IRR) for a schedule of cash flows with variable dates 
rather than regular dates. For example, =XIRR(E43:E46,F43:F46) calculates the 
internal rate of return for the cash flows in the range E43:E46 and the dates in the 
range F43:F46.

XNPV The net present value (NPV) for cash flows that use a variable schedule (or a 
periodic schedule—but for periodic cash flows, NPV is usually a better choice). 
For example, =XNPV(10%,{1000,900},F43:F44) calculates the net present value 
for the cash flows $1000 and $900 and their corresponding dates in the range 
F43:F44, using a 10% discount rate.

YIELD The yield on a security that has periodic interest payments, such as a bond. 
For example, =YIELD(DATE(2015,8,10),DATE(2018,7,12),7.25%,94.75,100,4) 
calculates the yield on a security that has a settlement date of 10 August 2015, a 
maturity date of 12 July 2018, and an interest rate of 7.25%. The security’s price 
is $94.75, its redemption value is $100, and its frequency is quarterly.

Table 6-4. (continued )
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Financial Function What It Returns

YIELDDISC A discounted security’s annual yield. For example, =YIELDDISC(DATE (2015,3,15), 
DATE(2016,9,14),94.5,100) calculates the annual yield on a security with a 
settlement date of 15 March 2015, a maturity date of 14 September 2016, a price 
of $94.50, and a redemption value of $100.

YIELDMAT The annual yield of a security that pays interest when it matures. For example, 
=YIELDMAT(DATE(2015,5,10),DATE(2017,4,30),DATE(2015,3,31),8%,93.2) 
calculates the annual yield of a security with a settlement date of 10 May 2015, a 
maturity date of 30 April 2017, an issue date of 31 March 2015, an interest rate of 
8%, and a price of $93.2 per $100 face value.

Table 6-4. (continued )

Logical Functions
When you need to evaluate logical conditions, use Excel’s logical functions, which you’ll find 
explained in Table 6-5. For many worksheets, after using a logical function to find out the 
situation, you’ll want to use other functions to make Excel take suitable actions.

Table 6-5. Excel’s Logical Functions

Logical Function What It Returns

AND TRUE if all the specified arguments are TRUE; otherwise FALSE. For example, 
=AND(C1=“Minneapolis”, D1=2016) returns TRUE if cell C1 contains the text 
“Minneapolis” and D1 contains the value 2016.

FALSE FALSE. You use this function to generate a FALSE value—for example, for testing. 
Simply enter =FALSE( ) in the cell that you need to provide a FALSE value.

IF The first of the specified values if the condition is TRUE, the second 
of the specified values if the condition is FALSE. For example, 
=IF(HOUR(NOW( ))<12,“AM”,“PM”) displays “AM” if the current hour is less than 
12 and “PM” otherwise.

IFERROR The specified error value if the expression causes an error; otherwise, the 
expression itself. For example, =IFERROR(E4,“Enter a value in cell E3.”) displays 
the message “Enter a value in cell E3” if cell E4 contains an error.

IFNA The value you specified if the result of the expression is #N/A; otherwise, the 
result of the expression. For example, =IFNA(B49,“Not available”) displays “Not 
available” if the result of cell B49 is #N/A.

NOT FALSE from a TRUE value, or TRUE from a FALSE value. For example, 
=NOT(TRUE) returns FALSE.

(continued )
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Information Functions
When you need to return information about the contents or formatting of a particular cell or 
range, use the information functions that Table 6-6 explains.

Table 6-5. (continued )

Logical Function What It Returns

OR TRUE if any of the specified conditions is TRUE; FALSE if all the conditions are 
FALSE. For example, =OR(F6=“Minneapolis”,F6=“Little Rock”, F6=“Sioux 
Falls”) returns TRUE if one of the three city names appears in cell F6; otherwise, it 
returns FALSE.

TRUE TRUE. You use this function to generate a TRUE value—for example, for testing. 
Simply enter =TRUE( ) in the cell that you need to provide a TRUE value.

XOR A logical OR of all the specified arguments. For example, =XOR(10>20,20>10) 
returns TRUE because one of the specified arguments (20>10) is TRUE.

(continued )

Table 6-6. Excel’s Information Functions

Information Function What It Returns

CELL The details of the contents, location, or formatting of the first cell in the range 
you specify. You can return various pieces of information. For example, 
=CELL(“address”,Tax_Rate) returns the address of the cell with the defined 
name Tax_Rate.

ERROR.TYPE A number giving the error type the cell contains: 1 for #NULL!, 2 for #DIV/0!, 
3 for #VALUE!, 4 for #REF!, 5 for #NAME?, 6 for #NUM!, and 7 for #N/A. For 
example, =IF(ERROR.TYPE(F3)=2,“Enter a number other than zero in cell 
F2.”) displays a message in cell F3 if it contains a divide-by-zero error.

INFO Information about Excel, the operating system, or the computer. For example, 
=INFO(“system”) returns “mac” if Excel is running on a Mac or “pcdos” if 
Excel is running on a PC. =INFO(“release”) returns the version of Excel—for 
instance, 15.11 for Excel 2015.

ISBLANK TRUE if the cell is blank; FALSE if it has contents. For example, 
=ISBLANK(A24) returns TRUE if cell A24 is blank.

ISERR TRUE if the cell contains any error except #N/A; otherwise FALSE. For 
example, =ISERR(B3) returns TRUE if cell B3 contains any error except #N/A.

ISERROR TRUE if the cell contains any error (including #N/A); otherwise FALSE. For 
example, ISERROR(B3) returns TRUE if cell B3 contains any error.

ISEVEN TRUE if the cell contains an even number (ignoring any decimal places); 
otherwise FALSE. For example, =ISEVEN(4.7) returns TRUE.

ISFORMULA TRUE if the cell referred to contains a formula; otherwise FALSE. For example, 
=ISFORMULA(A56) returns TRUE if cell A56 contains a formula.
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Information Function What It Returns

ISLOGICAL TRUE if the cell contains a logical value; otherwise FALSE. For example, 
=ISLOGICAL(B10) returns TRUE if cell B10 contains the value TRUE or the 
value FALSE.

ISNA TRUE if the cell contains #N/A; otherwise FALSE. For example, =ISNA(C8) 
returns TRUE if cell C8 contains #N/A.

ISNONTEXT TRUE if the cell is blank or contains anything except text; otherwise FALSE. 
For example, =ISNONTEXT(B1) returns FALSE if cell B1 contains text.

ISNUMBER TRUE if the cell contains a number; otherwise FALSE. For example, 
=ISNUMBER(B1) returns TRUE if cell B1 contains a number.

ISODD TRUE if the cell contains an odd number; otherwise FALSE. For example, 
=ISODD(A14) returns TRUE if cell A14 contains an odd number.

ISREF TRUE if the value is a valid reference to a cell, range, or defined name; 
otherwise FALSE. For example, =ISREF(“Gross_Income”) returns TRUE if the 
workbook contains a range named Gross_Income.

ISTEXT TRUE if the cell contains text; otherwise FALSE. For example, ISTEXT(A1) 
returns TRUE if cell A1 contains text.

N A number converted from the specified value. Specifically, a number returns 
the same number; a date returns the equivalent serial date; TRUE returns 1, 
and FALSE returns 0; an error returns its error value (explained in the ERROR.
TYPE entry earlier in this table); and anything else returns 0. Because Excel 
automatically converts values, you seldom need to use this function; Excel 
provides it for compatibility with other spreadsheet applications.

NA #N/A. You use this function to enter the error value deliberately in the cell. For 
example, enter =NA( ) in cell A1 causes it to show the error value #N/A.

SHEET Returns the name of the specified sheet. For example, 
=SHEET(“ArizonaSales”) returns the number of the sheet that contains the 
named range ArizonaSales.

SHEETS Returns the number of sheets for a specified reference or workbook. For 
example, =SHEETS( ) returns the number of sheets in the workbook, and 
=SHEETS(DataRef) returns the number of sheets encompassed by the 3D 
reference DataRef.

TYPE A number representing the data type the cell contains: 1 for a number,  
2 for text, 4 for a logical value, 16 for an error value, and 64 for an array. For 
example, =TYPE(B2) returns 2 if cell B2 contains text.

Table 6-6. (continued )



 
194 CHAPTER 6: Using Excel’s Built-In Functions

Lookup and Reference Functions
For returning information from lists and tables (flat-file databases), Excel includes the lookup 
and reference functions explained in Table 6-7.

Table 6-7. Excel’s Lookup and Reference Functions

Lookup and  
Reference Function

What It Returns

ADDRESS The cell reference denoted by the row number and the column number.

AREAS The number of different areas contained in a reference. An area can 
be either a single cell or a range of contiguous cells (not a range of 
noncontiguous cells).

CHOOSE The value (in a set of values) that you specify by index number.

COLUMN The column number of the reference you provide.

COLUMNS The number of columns in the reference or array.

FORMULATEXT The text of the formula at the specified reference.

GETPIVOTDATA Data from a PivotTable report.

HLOOKUP The value from the specified row in the data table. Horizontal lookup 
matches the field in the top row of the table, then returns the value from the 
specified row further down the same column.

HYPERLINK Contains a hyperlink.

INDEX A value from a table or a reference to such a value.

INDIRECT A reference specified by a text string in a cell. You can use INDIRECT( ) to 
change the reference in the cell without changing the formula.

LOOKUP A value from either a one-column or one-range row or from an array.

MATCH The position of a matching item in an array (rather than the item’s contents).

OFFSET A reference to the range offset from a specified cell or range by the number 
of rows and columns you specify.

ROW The row number of the specified reference.

ROWS The number of rows in the specified reference or array.

RTD A Component Object Model (COM) add-in from the specified server.

TRANSPOSE Cells transposed from a vertical range to a horizontal range, or vice versa. 
You must use TRANSPOSE( ) as an array formula.

VLOOKUP The value from the specified column in the data table. Vertical lookup 
matches the field in the first column of the table, then returns the value from 
the specified column further across the same row.
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Mathematical and Trigonometric Functions
Table 6-8 explains the mathematical and trigonometric functions that Excel offers, providing 
examples only for those that are less straightforward.

Table 6-8. Excel’s Mathematical and Trigonometric Functions

Mathematical and  
Trigonometric Function

What It Returns

ABS The absolute value of the specified number.

ACOS The arccosine of the specified number.

ACOSH The inverse hyperbolic cosine of the specified number.

ACOT The arccotangent of the specified number.

ACOTH The hyperbolic arccotangent of the specified number.

AGGREGATE An aggregate in the specified list or database.

ARABIC The Arabic equivalent of the specified Roman numeral. For example, 
=ARABIC(“IV”) returns 4.

ASIN The arcsine of the specified number.

ASINH The inverse hyperbolic sine of the specified number.

ATAN The arctangent of the specified number.

ATAN2 The arctangent from the specified x and y coordinates.

ATANH The inverse hyperbolic tangent of the specified number.

BASE The text of the specified number converted into the specified base. For 
example, =BASE(20,2) returns 10100, the binary (base 2) equivalent of 
20 in decimal.

CEILING The specified number rounded to the nearest integer or to the nearest 
significant multiple.

CEILING.MATH The specified number rounded up to the nearest integer or to the 
nearest significant multiple.

CEILINGPRECISE The specified number rounded up to the nearest integer or the nearest 
significant multiple.

COMBIN The number of combinations for the specified number of items.

COMBINA The number of combinations for the specified number of items, with 
repetitions.

COS The cosine of the specified angle.

COSH The hyperbolic cosine of the specified number.

COT The cotangent of the specified number.

COTH The hyperbolic cotangent of the specified number.

CSC The cosecant of the specified number.

(continued )
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Table 6-8. (continued )

Mathematical and  
Trigonometric Function

What It Returns

CSCH The hyperbolic cosecant of the specified number.

DECIMAL The text of the specified number converted to decimal. For example, 
=DECIMAL(1011101,2) returns 93, the decimal equivalent of 1011101 in 
binary (base 2).

DEGREES The number of degrees for the specified number of radians.

EVEN The next integer up from the specified positive number, or the next 
integer down from the specified negative number.

EXP The specified number raised to the power of the specified number.

FACT The factorial of the specified number (for example, 1x2x3x4 if you 
specify 4).

FACTDOUBLE The double factorial of the specified number.

FLOOR The specified number rounded down to the next significant multiple.

FLOOR.MATH The specified number rounded down to the nearest integer or to the 
nearest significant multiple.

FLOOR.PRECISE The specified number rounded down to the nearest integer or the 
nearest significant multiple. FLOOR.PRECISE( ) rounds the number down 
whether the number is positive or negative.

GCD The greatest common divisor for the specified numbers. For example, 
=GCD(240,100) returns 20.

INT The specified number rounded down to the nearest integer.

LCM The least common multiple of the specified numbers. For example, 
=LCM(3,4) returns 12.

LN The natural logarithm of the specified number.

LOG The logarithm of the specified number to the base you enter. For 
example, =LOG(12,2) returns the logarithm of 12 with base 2.

LOG10 The base-10 logarithm of the specified number.

MDETERM The matrix determinant of the specified array.

MINVERSE The inverse matrix for the specified array.

MMULT The matrix product of the two specified arrays. Each array must have 
the same number of rows and columns as the other.

MOD The modulus (remainder) after the specified number is divided by the 
specified divisor. For example, =MOD(7,2) returns 1.

MROUND The specified number rounded to the specified multiple. For example, 
=MROUND(7,3) returns 6.

(continued )
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Mathematical and  
Trigonometric Function

What It Returns

MULTINOMIAL The multinomial of the specified set of numbers.

MUNIT The unit matrix for the specified dimension.

ODD The next odd integer above the specified positive number, or the next 
odd integer below the specified negative number.

PI The value of Pi to 15 digits (3.14159265358979).

POWER The specified number raised to the specified power. For example, 
=POWER(10,5) returns 100000.

PRODUCT The product of the specified numbers. For example, =PRODUCT(2,3,4) 
returns 24.

QUOTIENT The quotient, the integer portion of a division. For example, 
=QUOTIENT(25,3) returns 8.

RADIANS The number of radians for the specified number of degrees.

RAND A random number between 0 and 1, inclusive. The number changes 
each time you recalculate the worksheet. (Technically, the number is 
pseudo-random rather than truly random; this distinction is important for 
some purposes.)

RANDBETWEEN A random number between the specified bottom value and top value. 
For example, =RANDBETWEEN(1,10) returns a random number 
between 1 and 10, inclusive. The number changes each time you 
recalculate the worksheet. (Technically, the number is pseudo-random 
rather than truly random.)

ROMAN The Roman numeral equivalent of the specified Arabic numeral. For 
example, =ROMAN(2015) returns MMXV.

ROUND The specified number rounded to the specified number of digits. For 
example, =ROUND(3.33333,2) returns 3.33.

ROUNDDOWN The specified number rounded down to the specified number of digits. 
For example, =ROUNDDOWN(18.57321,2) returns 18.57.

ROUNDUP The specified number rounded up to the specified number of digits. For 
example, =ROUNDUP(18.57321,2) returns 18.58.

SEC The secant of the specified number.

SECH The hyperbolic secant of the specified number.

SERIESSUM The sum of a power series.

SIGN Returns 1 if the specified number is positive, 0 if it is zero, or -1 if it  
is negative.

SIN The sine of the specified angle.

SINH The hyperbolic sine of the specified number.

Table 6-8. (continued )
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Mathematical and  
Trigonometric Function

What It Returns

SQRT The square root of the specified number.

SQRTPI The square root of the specified number multiplied by Pi.

SUBTOTAL The subtotal of the specified section of a database.

SUM The sum of the specified numbers. For example, =SUM(1,2,3) returns 6.

SUMIF The sum of the cells specified by a criterion.

SUMIFS The sum of the cells specified by multiple criteria.

SUMPRODUCT The sum of the products in the specified ranges or arrays.

SUMSQ The sum of the squares of the specified numbers. For example, 
=SUMSQ(3,4) returns 25.

SUMX2MY2 The sum of the differences between the squares of the two specified 
ranges.

SUMX2PY2 The sum total of the sums of the squares of numbers in the two 
specified ranges.

SUMXMY2 The sum of the squares of the differences in the two specified ranges.

TAN The tangent of the specified angle.

TANH The hyperbolic tangent of the specified number.

TRUNC The specified number truncated to the specified number of digits. For 
example, =TRUNC(24.567,1) returns 24.5.

Table 6-8. (continued )

Statistical Functions
Excel includes many statistical functions for statistical calculations such as these:

	Deviations. These functions include AVEDEV( ), STDEVA( ), STDEV( ), and 
STDEVP( ).

	Distributions. These functions include BETA.DIST( ), CHISQ.DIST( ), 
BINOM.DIST( ), EXPON.DIST( ), KURT( ), POISSON.DIST( ), and 
WEIBULL.DIST( ).

	Transformations. These functions include FISHER( ) and FISHERINV( ).

Many of the statistical functions are too specialized to cover here. Table 6-9 covers the 
statistical functions that are used for more general business and study purposes. If you work 
with statistics, look through the full list in the Statistical section of the Formula Builder list to 
find the other functions you want.
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Table 6-9. Excel’s Most Widely Useful Statistical Functions

Statistical Function What It Returns

AVERAGE The average of the specified values, cells, ranges, or arrays. For example, 
=AVERAGE(1,2,3) returns 2, and =AVERAGE(B1:B6) returns the average of 
the range B1:B6.

MEDIAN The median (the number in the middle of the given set) of the numbers or the 
values in the specified cells. For example, =MEDIAN(1,2,2,3,4,4,6) returns 3.

MODE The mode, the value that occurs most frequently in the specified values or 
range of cells. For example, =MODE(1,1,2,2,2,3,3,4,18) returns 2.

COUNT The number of cells in the specified range that either contain numbers or 
include numbers in their list of arguments. For example, =COUNT(C1:C8) 
returns the number of cells in the range C1:C8 that contain numbers or 
include numbers.

COUNTBLANK The number of empty cells in the specified range. For example, 
=COUNTBLANK(C1:C8) returns the number of empty cells in the range 
C1:C8.

COUNTIF The number of cells in the specified range that meet the criteria you set. For 
example, =COUNTIF(C1:C10,“>2”) counts the cells in the range C1:C10 that 
contain numbers larger than 2.

MAX The largest value in the specified range. For example, =MAX(C1:C6) returns 
the largest value in the range C1:C6.

MIN The lowest value in the specified range. For example, =MIN(C1:C6) returns 
the lowest value in the range C1:C6.

Text Functions
When you need to manipulate text in your worksheets, use the text functions explained in 
Table 6-10. For example, you may need to return only a particular part of a text string, find 
one string in another string, or change the case of text.

Note DBCS is the abbreviation for double-byte character set. You can use DBCS with Chinese 
(Simplified), Chinese (Traditional), Japanese, and Korean.
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Table 6-10. Excel’s Text Functions

Text Function What It Returns

BAHTTEXT The number converted to Thai text and with the Baht suffix.

CHAR The character represented by the specified character code. For example, 
=CHAR(66) returns a B. Normally, you’d just type the letters you need, but this 
function can be useful when working with workbooks created using different 
character sets.

CLEAN The specified text string with all nonprintable characters removed. For example, 
=CLEAN(A1) strips all nonprintable characters from the text string in cell A1. This 
function is sometimes useful when importing files created in other spreadsheet 
formats.

CODE The character code for the first character in the specified string. For example, 
=CODE(“$”) returns 36, the character code for the $ sign.

CONCATENATE A text string consisting of the specified text strings joined together. For example, 
=CONCATENATE(“San Francisco ”,“Depot”) returns the text string “San 
Francisco Depot.” Note that you must include any spaces needed—otherwise, 
Excel smashes the text together. Instead of using this function, you can simply use 
the concatenation operator (the & sign).

DBCS Double-byte (full-width) versions of the specified single-byte (half-width) English 
letters or Japanese katakana.

DOLLAR The specified number converted to text in the Currency format. For example, 
=DOLLAR(9) returns $9.00.

EXACT TRUE if the two text strings match exactly, containing the same characters in the 
same case; otherwise FALSE. For example, =EXACT(“Oakland”,“OAKLAND”) 
returns FALSE because the two strings use different case.

FIND The starting position of one specified text string within another text string. This 
function is case-sensitive. For example, =FIND(“juve”,“Bovine Rejuvenation 
Ointment”) returns 10, because the j is the tenth character (including the space).

FINDB The starting position of one specified text string within another text string. FINDB( ) 
counts 2 bytes per character when you have set a DBCS language as the default.

FIXED The specified number rounded to the specified number of decimals, with or 
without commas. For example, =FIXED(“10.8726”,2) returns 10.87.

LEFT The specified number of characters from the beginning of the text string. For 
example, =LEFT(“Product Ratings”,7) returns “Product.”

LEFTB The specified number of bytes from the beginning of the text string. LEFTB( ) 
counts 2 bytes per character when you have set a DBCS language as the default.

LEN The number of characters in the specified text string, including spaces. For 
example, =LEN(“Product Ratings”) returns 15.

LENB The number of characters in the specified text string, including spaces. LENB( ) 
counts 2 bytes per character when you have set a DBCS language as the default.

(continued )
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Text Function What It Returns

LOWER The text string converted to lowercase. For example, =LOWER(“OAKLAND 
WAREHOUSE”) returns “oakland warehouse.”

MID The specified number of characters after the starting point given in the specified 
text string. For example, =MID(“Human Heart-Rate Monitor”,7,10) returns 
“Heart-Rate.”

MIDB The specified number of characters after the starting point given in the specified 
text string. MIDB( ) counts 2 bytes per character when you have set a DBCS 
language as the default.

NUMBERVALUE The number value for the specified text. For example, =NUMBERVALUE(“50%”) 
returns 0.5.

PROPER The text string converted to “proper case” (first letter capitalized, the rest 
lowercase). For example, =PROPER(“OAKLAND WAREHOUSE”) returns 
“Oakland Warehouse.”

REPLACE The specified text string with the given replacement string inserted in the location 
specified. For example, =REPLACE(“Human Heart-Rate Monitor”,7,10,“Pulse”) 
returns “Human Pulse Monitor.”

REPT The specified text string repeated the specified number of times. For example, 
=REPT(“IMPROVED! ”,4) returns “IMPROVED! IMPROVED! IMPROVED! 
IMPROVED!”

RIGHT The specified number of characters from the end of the specified text string. For 
example, =RIGHT(“Product Ratings”,7) returns “Ratings.”

RIGHTB The specified number of characters from the end of the specified text string. 
RIGHTB( ) counts 2 bytes per character when you have set a DBCS language as 
the default.

SEARCH The character position at which the specified character is located in the specified 
string. For example, =SEARCH(“P”,“Human Pulse Monitor”) returns 7, the 
position of the letter P in the string “Human Pulse Monitor.”

SEARCHB The character position at which the specified character is located in the specified 
string. SEARCHB( ) counts 2 bytes per character when you have set a DBCS 
language as the default.

SUBSTITUTE The specified text string with the given new text string substituted for the 
specified old text string. For example, =SUBSTITUTE(“Make the Most of Excel 
2011”,“Excel 2011”,“Excel 2015”) replaces the text “Excel 2011” with the text 
“Excel 2015” in the text string “Make the Most of Excel 2011.”

T The text string for a text value, or empty double quotation marks (a blank string) 
for a nontext value. For example, =T(A19) returns the text string or a blank string 
for the contents of cell A19. You don’t normally need to use the T function, 
because Excel automatically converts values to text as needed.

Table 6-10. (continued )

(continued )
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Text Function What It Returns

TEXT The text string containing the specified value converted to the format chosen. 
For example, =“Results for ” &TEXT(“4 August 2015”,“mmmm yyyy”) returns 
“Results for August 2015” because of the format specified in the function.

TRIM The specified text string with spaces removed from the beginning and ends, and 
extra spaces between words removed to leave one space between words. For 
example, =TRIM(“ 4512 Christy Blvd. ”) strips out the superfluous spaces and 
returns “4512 Christy Blvd.”

UNICHAR The Unicode character for the specified Unicode number. For example, 
=UNICHAR(65) returns A.

UNICODE The Unicode number for the specified character, or for the first character in the 
specified string. For example, =UNICODE(“A”) returns 65.

UPPER The text string converted to uppercase. For example, =UPPER(“don’t walk”) 
returns “DON'T WALK.”

VALUE The value contained in the specified text string. For example, =VALUE(“5”) returns 
5. Normally, you seldom need to use this function, because Excel converts values 
automatically as needed.

Table 6-10. (continued )

Cube Functions
When you need to manipulate date cubes, use the cube functions explained in Table 6-11.

Table 6-11. Excel’s Cube Functions

Cube Function What It Returns

CUBEKPIMEMBER The specified key performance indicator (KPI) for the cube set.

CUBEMEMBER The specified member or tuple from the cube set.

CUBEMEMBERPROPERTY The value of the specified member property in the cube set.

CUBERANKEDMEMBER The member of the cube set at the specified ranking—for example, 
the second member of the set.

CUBESET The calculated cube set of members resulting from the specified 
expression.

CUBESETCOUNT The number of items in the cube set.

CUBEVALUE The aggregated value from the data cube.
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Choosing the Right Calculation Preferences  
for Your Needs
If you create complex worksheets, you may need to change the calculation settings Excel 
uses—for example, by switching from automatic recalculation to manual recalculation, by 
limiting the number of iterations Excel performs, or by changing values from full precision to 
the number of decimal places actually shown in the cells.

To change the calculation settings, open the Calculation preferences pane (see Figure 6-8) 
like this:

1. Choose Excel ➤ Preferences or press Cmd+, (Cmd and the comma 
key) to display the Excel Preferences window.

2. In the Formulas and Lists area, click the Calculation icon.

Caution In the Calculation preferences pane, the Calculation options settings and the Use iterative 
calculation settings affect all your workbooks, not just the active workbook. The When Calculating 
Workbooks settings affect only the active workbook.

Figure 6-8. In the Calculation preferences pane of the Excel Preferences window, you can choose when to calculate 
worksheets, limit iteration, and change workbook-specific options
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Choosing When to Calculate Worksheets
In the Calculation Options area, first choose how to recalculate the worksheets by selecting 
the appropriate option button:

	Automatic. Select this option button to have Excel recalculate all 
dependent formulas every time you change a value. This is the default 
setting and ensures your worksheets remain up-to-date. Use this  
setting unless your worksheets are complex and recalculating them 
becomes slow.

	Automatic except for data tables. Select this option button to recalculate 
all dependent cells except those in data tables each time you change 
a value. Use this setting when recalculating data tables automatically 
becomes too slow. You can then recalculate data tables manually as 
needed.

	Manual. Select this option button to turn off automatic recalculation 
altogether. Use this setting for large and complex worksheets in which 
automatic recalculation becomes slow enough to be disruptive.

If you select the Manual option button, select the Recalculate workbook before saving 
check box if you want Excel to recalculate each workbook when you save it. The advantage 
to doing this is that it ensures that the saved version of the workbook displays the 
correct values, which is especially important the next time you open the workbook. The 
disadvantage is that saving the workbook takes much longer.

You can force recalculation of the entire workbook by choosing Formulas ➤ Calculation ➤ 
Calculate Now (or pressing Cmd+=) or Formulas ➤ Calculation ➤ Calculate Sheet from 
the Ribbon.

Controlling Iteration of Calculations
When Excel runs into a circular reference, it stops automatically either after 100 iterations of 
the calculation or when all the values change by less than 0.001. These settings work well 
for general use—especially if your worksheets don’t need circular references (as is the case 
for many worksheets).

If your worksheets do need circular references, you can control the iteration of calculations 
by selecting the Use iterative calculation check box in the Calculation preferences pane. 
Adjust the values in the Maximum iterations text box and the Maximum change text box as 
necessary.

Tip You can quickly switch between automatic recalculation and manual recalculation by 
choosing Formulas ➤ Calculation ➤ Calculation Options ➤ Manual or Formulas ➤ Calculation ➤ 
Calculation Options ➤ Automatic from the Ribbon.
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Choosing Workbook Options
In the When Calculating Workbooks area in the Calculation preferences pane, you can 
choose three settings that affect only the active workbook:

	Set precision as displayed. Select this check box if you want Excel to 
change the values in the workbook’s cells to match the values that are 
displayed in the cells. Excel stores values using 15 digits, which is called 
full precision. You can format cells to display only as many decimal 
places as you want. For example, you may need to see currency 
amounts with two decimal places (such as $110.28), even though the 
number Excel is storing has further digits (such as 110.2769821). If you 
select the Set precision as displayed check box, Excel changes the 
underlying value to match the displayed value—for example, changing 
110.2769821 to 110.28.

	Use 1904 date system. Select this check box to use serial dates starting 
with 2 January 1904 rather than 1 January 1901, the standard start date. 
Normally, you will need to do this only if you’re working with dates in 
workbooks developed in earlier versions of Excel:Mac.

	Save external link values. Select this check box if you want Excel to save 
values from an external data source in the workbook. This is usually a 
good idea, but you may need to clear this check box if you’re bringing 
in large amounts of data from an external source, as saving the data in 
Excel may take a long time or make the workbook large and unwieldy.

When you’ve finished choosing Calculation preferences, click the close button (the red 
button at the left end of the title bar) to close the Excel Preferences window.

Summary
In this chapter, you learned how to use functions to perform calculations in your workbooks. 
You know that a function is a preset formula built into Excel, how to insert functions using 
the various tools Excel provides, and how to furnish functions with the arguments they need 
to work. You met Excel’s main categories of functions and learned about the most useful 
functions they contain for general use.

In the next chapter, I’ll show you how to create clear and persuasive charts.

Caution Select the Set precision as displayed check box only if you’re certain you need to change 
the values—for example, because you’re performing a financial operation that requires you to 
round or truncate a value and then use that rounded or truncated value rather than the underlying 
value. Normally, you want to keep the underlying precise values even if you format the cells to 
display only a small number of decimal places (or none).
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Chapter 7
Creating Clear and 
Persuasive Charts
In this chapter, you’ll learn how to create powerful charts that present your data clearly and 
persuasively.

We’ll start by going over the essentials of charts, such as the different ways you can place 
them in your workbooks, which components charts have, and which types of charts you 
can create. We’ll then spend most of the chapter looking in detail at how you create a chart 
from your data, lay it out the way you want, then give it the look it needs—everything from 
displaying or hiding components to formatting components for impact.

Once you’ve created a chart that looks just right, you can reuse your custom chart formatting 
by either pasting it onto an existing chart or by creating a custom chart template from it.

At the end of the chapter, you’ll learn how to use your Excel charts in Word documents or 
PowerPoint presentations.

Learning the Essentials of Charts in Excel
Before you start creating charts, let’s look at the two ways you can place charts in your 
workbooks, go over what the different components of charts are called and what they show, 
and get an overview of the many different types of charts that Excel offers you.

Understanding Embedded Charts and Chart Sheets
In Excel, you can place a chart either on a worksheet (for example, with its data) or on  
its own chart sheet:

	Chart on a worksheet. Excel calls a chart on a worksheet an embedded 
chart—the chart object is embedded in the worksheet. Usually, the 
worksheet also contains the chart’s data, but you can embed a chart 
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on a different worksheet if necessary. Create an embedded chart when 
you want to look at the chart alongside its data or alongside other 
information. Figure 7-1 shows an embedded chart.

Figure 7-1. Create an embedded chart on a worksheet when you want to work on the chart or view it alongside its data

	Chart on chart sheet. Instead of creating an embedded chart, you can 
create a chart on a chart sheet—a separate sheet in the workbook that 
contains only a chart. Using a chart sheet gives you more space to lay 
out the chart and view it. The chart sheet doesn’t contain the source 
data, but you can add a data table showing the source data if you don’t 
mind sacrificing some of the chart sheet’s space for the table. Figure 7-2 
shows a chart on a chart sheet without a data table.
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Understanding the Components of a Chart
Excel’s charts vary widely in looks and uses, but most of them use the same set of 
components. Figure 7-3 shows a typical type of chart—a 3-D column chart—of rainfall data 
for six months for seven weather stations, with the main parts of the chart labeled.

Figure 7-2. Place a chart on its own chart sheet when you want to give it plenty of space

Note You can change an embedded chart to a chart on its own chart sheet, or a chart on a chart 
sheet to an embedded chart, as needed. I’ll show you how to do so a little later in this chapter.
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Figure 7-3. This column chart contains most of the typical elements of Excel charts. The chart area is the whole area 
occupied by the chart, and the plot area is where the data series are plotted

Note If you have some sample data you’re ready to turn into a chart, select the data and choose 
Insert ➤ Charts ➤ Column, then click a chart type on the Column panel (for example, click 
Clustered Column). This will give you a quick column chart that you can experiment with as we go 
through the components of charts. If you’d like to create your own version of the Rainfall Data chart 
used for most of the examples in this chapter, go to this book’s apress.com product page  
(www.apress.com/9781484210208), and download the workbook named 978-1-4842-1020-8 
chart.xlsx.

http://www.apress.com/9781484210208
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The following sections discuss the individual components of charts.

Chart Area and Plot Area
The chart area is the whole area occupied by the chart. If the chart has a white background, 
the easiest way to see the extent of the chart area is to click the chart so that Excel displays 
a border around it.

The plot area is the area of the chart that contains the plotted data—in other words, the main 
part of the chart area, excluding the areas occupied by the chart title, the axis titles, and the 
legend (if it appears outside the plot area).

Chart Axes
Most charts have one, two, or three axes:

	Horizontal axis. This is the axis along which the data categories are laid 
out—for example, the weather stations in the sample chart. This axis is 
also called the category axis or the x-axis.

	Vertical axis. This is the axis along which the data series are laid out. 
This axis is also called the y-axis.

	Depth axis. In 3-D charts, this is the axis that provides the third 
dimension. This axis is also called the z-axis. Figure 7-3 doesn’t show 
the depth axis labeled.

Each axis has tick marks that show where the values appear on it.

Categories and Data Series
The categories are the subdivisions of data that appear on the horizontal axis. For example, 
in the sample chart, each weather station is a category.

The data series are the sets of data used to create the chart. For example, in the sample 
chart, the data series contain the rainfall measurements.

Chart Title and Axis Titles
The chart title is text that identifies the chart as a whole. Normally, you put the chart title at 
the top of the chart, where the reader will see it immediately, but you can place it elsewhere 
if you want. For example, you may place the chart title in open space in the chart area so 
that you can make the chart itself larger.

The horizontal axis title is text that explains what is shown on the horizontal axis; for 
example, the weather stations in the sample chart.

The vertical axis title is text that explains what the vertical axis shows; for example, the 
amount of rainfall in the sample chart.

A 3-D chart can also have a depth axis title that explains what the depth axis shows.
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Legend
The legend is a key, table, or list that explains the colors or symbols used in the chart. For 
example, in Figure 12-3, the legend shows that dark blue represents January, liverish red 
represents February, and so on.

Data Markers, Gridlines, and Data Labels
The data markers are the points on the chart that show where each data point appears. 
Each series typically contains several data markers. Depending on the chart type, the data 
markers may appear as separate points, or they may be linked together. In the column chart 
shown in Figure 7-3, the data markers are the tops of the columns.

To make it easy to see how the data markers relate to the axes, you can add gridlines to the 
chart—lines that run across or up from the data markers.

Data labels are text items that display the exact value of data points. You can display data 
labels when viewers need to see the exact figure for each data point rather than judging the 
value from the chart.

Choosing the Best Chart Type for Your Data
Excel enables you to create an impressive variety of different types of charts. Some of 
the charts are useful for many purposes, whereas others are highly specialized. Table 7-1 
describes the types of charts that Excel provides and suggests typical uses for them. The 
table lists the charts in the same order as Excel’s Insert ➤ Chart submenu; the order in the 
Charts group on the Insert tab of the Ribbon is a little different.

Note Chart titles and axis titles are optional, so you can include only those your chart needs. 
Generally, people viewing your charts will benefit from having clear chart titles and axis titles. But 
don’t feel obliged to include any element that seems to complicate your charts. Remember the 
adage, “if in doubt, leave it out.”
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Table 7-1. Excel’s Chart Types and Suggested Uses

Chart Category Description Suggested Uses

Column Displays data in vertical bars. Comparing equivalent items (such 
as sales results) or sets of data that 
change over time (such as rainfall).

Line Displays each series in a line. Showing evenly spaced values that 
change over time, such as temperatures.

Pie Displays a single data series as a pie 
divided up by the contribution of each  
data point.

Showing how much each item 
contributes to the whole; for 
example, breaking down expenses by 
department.

Bar Displays data in horizontal bars. Comparing similar items or indicating 
progress.

Area Displays data as lines but with the areas 
between the lines shaded.

Showing how values have changed 
over time, especially the contribution 
of different data points in the series.

XY (Scatter) Displays each data point as a point  
(or cross, or similar marker) on the  
plot area.

Showing values sampled at different 
times or that are not directly related to 
each other.

Stock Displays each data series as a vertical  
line or bar indicating three or more  
prices or measurements (for example, 
high, low, and closing prices).

Showing the daily prices of stocks. 
Also suitable for some scientific data.

Surface Displays the data points as a three-
dimensional surface.

Comparing two sets of data to find a 
suitable combination of them.

Radar Displays the combined values of  
different data series.

Showing how the combined values 
of separate data series compare to 
each other (for example, the sales 
contributions of several different 
products over several periods of time).

Note Earlier versions of Excel, such as Excel 2011 for Mac, offered two other chart categories: the 
Doughnut category and the Bubble category. Excel 2016 brings the Doughnut chart type into the Pie 
category, perhaps because they share a round shape and belong to the same food group, and adds 
the Bubble chart type and the 3D Bubble chart type to the XY (Scatter) category.

Creating, Laying Out, and Formatting a Chart
In this section, we’ll look at how to create a chart from your data, lay it out with the 
components and arrangement you want, and apply the most useful types of formatting.
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Creating a Chart
To create a chart, you use the commands on the Charts tab of the Ribbon. Follow these steps:

1. Select the data you want to chart, including any row or column 
headings needed. For example, click the first cell in the data range, 
then Shift+click the last cell. If you’ve downloaded the sample 
workbook, select cells A1:G8 on the Rainfall Data sheet. 

2. Click the Insert tab of the Ribbon to display its contents, then click the 
appropriate button in the Chart group: Column, Bar, Pie, Line, XY (Scatter), 
or Insert Area, Stock, Surface or Radar Chart (the button that shows 
assorted chart types). For the sample chart, click the Column button.

3. On the panel that opens, click the chart type you want. Figure 7-4 
shows the Column panel, which is one of the most widely useful. For 
the sample chart, click the 3-D Clustered Column chart type.

Tip You can create a chart from either a block range or a range of separate cells. To use separate 
cells, select them as usual—for example, click the first cell, then Cmd+click each of the others. Make 
sure that the cells contain comparable data, or the resulting chart will be odd and perhaps deceptive.

Figure 7-4. To insert a chart, click the appropriate pop-up button in the Charts group on the Insert tab of the Ribbon, 
then click the chart type you want
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Excel creates the chart as an embedded chart in the current worksheet, as shown earlier in 
Figure 7-1. You can then reposition it, resize it, or move it to a chart sheet as follows:

	Reposition the chart. If you want to keep the chart as an embedded 
chart, move the mouse pointer over the chart so that the pointer turns 
into a four-headed arrow, then drag the chart to where you want it.

	Resize the chart. Click to select the chart, then drag one of the 
handles that appears. Drag a corner handle to resize the chart in both 
dimensions; you can also Shift+drag to resize the chart proportionally. 
Drag a side handle to resize the chart in only that dimension; for 
example, drag the bottom handle to resize the chart only vertically.

	Move the chart to a chart sheet. If you want to move the chart to a chart 
sheet, follow the instructions in the next section.

When a chart is active, as it is immediately after you insert it, the Chart Design tab and the 
Format tab appear on the Ribbon, as you’ll see later in this chapter. The Chart Design tab is 
active at first.

Changing a Chart from an Embedded Chart to a Chart Sheet
You can change a chart from being embedded in a worksheet to being on its own chart 
sheet like this:

1. Click the chart on the worksheet it’s embedded in.

2. Choose Chart Design ➤ Location ➤ Move Chart from the Ribbon 
to display the Move Chart dialog box (see Figure 7-5). 

Figure 7-5. Use the Move Chart dialog box to change a chart from being embedded to being on its own chart sheet

Tip You can also display the Move Chart dialog box by Ctrl+clicking or right-clicking the chart and 
then clicking Move Chart on the context menu.
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3. Select the New sheet option button.

4. Type the name for the new chart sheet in the New sheet text box.

5. Click the OK button. Excel creates the new chart sheet and moves 
the chart to it. The chart is still attached to its source data, so if you 
change the data, Excel changes the chart too.

Changing the Chart Type
If you find the chart type you’ve chosen doesn’t work for your data, you can change the 
chart type easily without having to create the chart again from scratch. Follow these steps:

1. Click the chart to select it.

2. Click the Chart Design tab of the Ribbon to display its contents.

3. In the Type group, click Change Chart Type to display the Change 
Chart Type panel, click the chart category to display the category’s 
pop-up panel, and then click the chart type.

Switching the Rows and Columns in a Chart
When Excel displays the chart, you may realize that the data series are in the wrong place; 
for example, the chart is displaying months by rainfall instead of rainfall by months.

When this happens, there’s a quick fix: switch the rows and columns by choosing Chart 
Design ➤ Data ➤ Switch Row/Column from the Ribbon. Excel displays the chart with the 
series the other way around.

Changing the Source Data for a Chart
Sometimes you may find that your chart doesn’t work well with the source data you’ve 
chosen. For example, you may have selected so much data that the chart is crowded, or you 
may have missed a vital row or column.

When this happens, you don’t need to delete the chart and start again from scratch. Instead, 
follow these steps:

1. Click the chart to select it.

2. Choose Chart Design ➤ Data ➤ Select Data from the Ribbon bar 
to display the Select Data Source dialog box (see Figure 7-6).

Note You can also use the Move Chart dialog box to move a chart from a chart sheet to an 
embedded chart on a worksheet or to move an embedded chart from one worksheet to another.
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3. In the Chart data range box, enter the data range you want to use:

	Usually, it’s easiest to click the Collapse Dialog button to collapse 
the dialog box, drag on the worksheet to select the right data 
range, then click the Collapse Dialog button again to restore the 
dialog box. (If you have plenty of space on screen, you can just 
work around the Select Data Source dialog box instead.)

	You can also type the data range in the Chart data range box. 
This is easy when you just need to change a column letter or row 
number to fix the data range.

4. If you need to switch the rows and columns as well, click the Switch 
Row/Column button.

5. If your chart data contains empty cells, open the Show empty cells 
as pop-up menu and choose how to represent them. Your choices 
are Gaps (the default setting for most charts) or Zero.

Figure 7-6. Use the Select Data Source dialog box to change the source data the chart is using
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6. Select the Show data in hidden rows and columns check box only 
if you want the chart to include data in hidden rows and columns 
within the source range. Normally, you’ll want to keep these hidden, 
but it’s sometimes useful to show them.

7. Click the OK button to close the Select Data Source dialog box. 
Excel applies the changes to the chart.

Choosing the Layout for the Chart
When you’ve sorted out the chart type and the source data, it’s time to choose the layout for 
the chart. For each chart type, Excel provides various preset layouts that control where the 
title, legend, and other elements appear. After applying a layout, you can customize it further 
as needed.

To apply a layout, click the chart, choose Chart Design ➤ Chart Layouts ➤ Quick Layout 
to display the Quick Layout panel (see Figure 7-7), and then click the layout you want to 
apply to the chart.

Figure 7-7. To set the overall layout of chart elements, such as the chart title and legend, open the Quick Layout panel, 
then click the layout you want
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Adding a Separate Data Series to a Chart
Sometimes you may find you need to add to a chart a data series that doesn’t appear in the 
chart’s source data—for example, to add projections of future success to your current data.

To add a data series, work from the Select Data Source dialog box. Follow these steps:

1. Click the chart to select it.

2. Choose Chart Design ➤ Data ➤ Select Data from the Ribbon to 
display the Select Data Source dialog box. You can also Ctrl+click or 
right-click the chart and then click Select Data on the context menu.

3. Click the Add (+) button below the Legend entries (Series) box. Excel 
adds a new item to the series box, giving it a default name such as 
Series3 or Series4.

4. Click in the Name text box, then type the name you want to give 
the series. If the name appears in a cell on the worksheet, you can 
click it. When you move the focus out of the Name text box, Excel 
changes the default name to the name you type.

5. In the Y values text box, type the values for the series inside 
the braces, putting a comma between the values; for example, 
{4.5,8.3,6.2,5.1,4.8,10.2}. If the values appear in cells on the 
worksheet, you can enter them by selecting the range. 

6. Click the OK button to close the Select Data Source dialog box.

Applying a Style to a Chart
To control the overall graphical look of a chart, apply one of Excel’s styles to it from the 
Chart Styles box or the Chart Styles panel in the Chart Styles group on the Chart Design 
tab of the Ribbon. Click the chart to select it, then click the Chart Design tab of the Ribbon 
to display its controls. Either click a style in the Chart Styles box or hold the mouse pointer 
over the Chart Styles box until the panel button appears, click the panel button to display 
the Chart Styles panel (see Figure 7-8), then click the style.

Note When adding a new data series, you don’t normally need to change the contents of the 
Horizontal (Category) axis labels text box. This text box contains the range of cells that provide the 
labels for the horizontal axis.
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Adding a Title to a Chart
To let viewers know what a chart is about, you’ll normally want to add a title to it. To do so, 
follow these steps:

1. Click the chart to select it.

2. Choose Chart Design ➤ Chart Layouts ➤ Add Chart Element ➤ 
Chart Title from the Ribbon, then choose the title type you want:

	None. Choose this item to remove the existing title. You can also 
click the title and press Delete to delete it.

	Above Chart. Choose this item to place the title above the chart, 
making the chart smaller to provide space for the title. Use this 
placement when you want to keep the title clearly separated from 
the chart; for example, because the chart is busy.

	Centered Overlay. Choose this item to place the title on the chart, 
centered over the top. Placing the title on the chart lets you keep 
the chart as large as possible. If the title lands on top of data, you 
can click it and drag it to a different position.

Figure 7-8. To give the chart an overall graphical look, apply a style from the Chart Styles box or the Chart Styles panel 
in the Chart Styles group of the Charts Design tab of the Ribbon
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	More Title Options. Choose this item to display the Format Chart 
Title pane. Here, you can click the Title Options tab to work on 
the title area or the Text Options tab to work on the text itself. On 
either tab, you can use the controls in the Fill & Line pane (shown 
on the left in Figure 7-9), the Effects pane (shown in the center), 
or the Size & Properties pane (shown on the right) to apply exactly 
the formatting you want.

3. Triple-click to select the contents of the Chart Title placeholder that 
Excel adds for you.

4. Type the title for the chart over the default text.

5. If necessary, drag the chart title placeholder to a different position.

6. Click elsewhere to deselect the chart title.

Tip You can also display the Format Chart Title pane by Ctrl+clicking or right-clicking the chart 
title and then clicking Format Chart Title on the context menu.

Figure 7-9. You can create a custom chart title by working in the Format Chart Title pane. Click the Title Options tab 
or the Text Options tab, and then work on the Fill & Line pane (left), the Effects pane (center), and the Size & Properties 
pane (right), as needed



 
222 CHAPTER 7: Creating Clear and Persuasive Charts

Adding Axis Titles to the Chart
To make clear what the chart shows, you’ll usually want to add titles to the axes. To do so, 
follow these steps:

1. Click the chart to select it.

2. Choose Chart Design ➤ Chart Layouts ➤ Add Chart Element ➤  
Axis Titles to display the Axis Titles panel, and then click to 
select the appropriate axis, such as Primary Horizontal or Primary 
Vertical. A check mark appears next to the axis you clicked, and the 
placeholder appears on the chart. 

3. Triple-click to select the contents of the placeholder.

4. Type the text for the axis title.

5. If necessary, drag the placeholder to a different position.

Changing the Scale or Numbering of an Axis
When you insert a chart, Excel automatically numbers the axes as to suit the data range the 
chart uses. This automatic numbering works well for many charts, but for other charts, you 
may need to change the scale or numbering of an axis.

The options for formatting an axis vary depending on the chart type and the axis type. In this 
section, we’ll explore the formatting options for first the horizontal axis and then the vertical 
axis of a column chart, which are fairly typical and will put you in a good position to format 
other chart types.

Changing the Scale or Numbering of a Horizontal Axis
If you need to change the scale or numbering of the horizontal axis of a chart, follow these steps:

1. Double-click the horizontal axis, or Ctrl+click or right-click in the 
horizontal axis titles area, then click Format Axis on the context menu to 
display the Format Axis pane. The Axis Options pane appears at the front. 
This pane contains four sections: the Axis Options section and the Tick 
Marks section (shown on the left in Figure 7-10) and the Labels section 
and the Number section (shown on the right in Figure 7-10). You can 
expand or collapse each section as needed by clicking its heading.

Note In most chart layouts, Excel uses a vertical placeholder for the vertical axis and a horizontal 
placeholder for the horizontal axis and the depth axis. You can rotate a placeholder as needed by 
Ctrl+clicking or right-clicking it, clicking Format Axis Title, and then using the controls in the Format 
Axis Title pane. These controls work like those in the Format Chart Title pane (shown in Figure 7-9, 
earlier in this chapter).
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2. In the Axis Type area, select the appropriate option button:

	Automatically select based on data. Select this option button to 
have Excel automatically determine the axis type based on the 
data the chart uses. This setting often works well, but if you need 
to make changes, select one of the other option buttons.

	Text axis. Select this option button to specify that the axis uses 
text (even if that text looks like dates).

	Date axis. Select this option button if the axis uses dates.

3. In the Vertical Axis Crosses area, select the appropriate option button 
to control where the vertical axis crosses the horizontal axis:

	Automatic. Select this option button to have Excel decide where 
the vertical axis crosses.

	At category number. To make the vertical axis cross the horizontal 
axis at a particular category number, select this option button and 
type the category number in the text box.

	At maximum category. Select this option button to make the 
vertical axis cross the horizontal axis at the largest category.

Figure 7-10. Use the controls in the Format Axis pane to format a horizontal axis to control its axis type, its tick marks, 
its labels, and its number format
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4. Also in the Vertical Axis Crosses area, you can select the Categories 
in reverse order check box if you want to reverse the category order.

5. In the Tick Marks section, choose how to display tick marks on the axis:

	Interval between marks. In this box, type the number to determine 
the spacing of tick marks. For example, instead of the default 1 that 
Excel uses for many charts, you could type 5 to use fewer tick marks.

	Major type. Open this pop-up menu and then click the type of 
tick mark you want for major tick marks. You can select Inside to 
have the major tick marks appear inside the chart, select Outside 
to have them appear outside (on the axis side), or select Cross 
to have them appear on both sides. Alternatively, you can select 
None if you do not want major tick marks.

	Minor type. Open this pop-up menu and then click the type of tick 
mark you want for minor tick marks. As with major tick marks, 
your choices are Inside, Outside, Cross, or None.

6. In the Labels section, set the controls to specify how you want Excel 
to label the axis:

	Automatic. Select this option button to have Excel automatically 
determine the interval between labels.

	Specify interval unit. To control the interval between labels, select 
this option button and type the value in the text box.

	Distance from axis. In this text box, type a number between 0 and 
1000 to specify how far the labels should appear from the axis. 
Using 0 puts the labels very close to the axis; using 1000 puts the 
labels a fair distance away.

	Label position. Open this pop-up menu and then click Next to 
axis, High, Low, or None. Choosing High puts the labels above 
the chart, whereas choosing Low puts the labels below the chart 
(which may have the same effect as choosing Next to axis). 
Choosing None suppresses the labels.

7. In the Number section, choose how to format the numbers on the axis:

	Category. Open this pop-up menu and choose the number 
category, such as General, Currency, or Date. These are the 
same formats you use for controlling how data appears in cells; 
depending on the format you choose, the Number section may 
display other options you can set for the format. For example, 
if you choose the Number category, you can set the number of 
decimal places, choose whether to use the thousands separator, 
and specify how to display negative numbers.
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	Format Code. In this text box, you can specify formatting codes 
for the category. For example, for the Date category, you can 
specify codes such as m/d/yy or mm/dd/yyyy to control how the 
dates appear. Click the Add button to add the formatting code 
you’ve entered.

	Linked to source. Select this check box if the data is linked to its 
source in the worksheet.

8. When you finish choosing formatting for the axis, click the Close 
button (the X button in the upper-right corner) to close the Format 
Axis pane.

Changing the Scale or Numbering of a Vertical Axis
When you need to change the scale or numbering of the vertical axis of a chart, follow  
these steps:

1. Double-click the vertical axis, or Ctrl+click or right-click in the vertical 
axis titles area, then click Format Axis on the context menu to display 
the Format Axis pane. The Axis Options pane appears at the front. 
As for a horizontal axis, this pane contains four sections: the Axis 
Options section (shown on the left in Figure 7-11) and the Tick Marks 
section, the Labels section, and the Number section (shown on the 
right in Figure 7-11). You can expand or collapse each section as 
needed by clicking its heading.
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2. Use the controls in the Bounds area of the Axis Options section to 
set the minimum and maximum bounds for the axis:

	Minimum. Type the value for the minimum bound over the value 
that Excel has set.

	Maximum. Type the value for the maximum bound over the value 
that Excel has set.

3. Use the controls in the Units area to set the major and minor units:

	Major. Type the value for the major units over the value that Excel 
has set. Depending on how big your chart is, you’ll probably 
want between five and ten major units on the scale you’ve set by 
choosing the Minimum value and Maximum value.

Figure 7-11. Use the controls in the Format Axis pane to format a vertical axis to control its axis type, its tick marks, its 
labels, and its number format
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	Minor. Type the value for the minor units over the value that Excel 
has set. You’ll normally want between four and ten minor units per 
major unit, depending on what the chart shows.

4. In the Floor Crosses At area, choose where the horizontal axis should 
cross the vertical axis:

	Automatic. Select this option button to have Excel place the 
crossing point automatically—for example, at 0.

	Axis value. To have the horizontal axis cross at a specific value of 
the vertical axis, select this option button and type the value in 
the text box.

	Maximum axis value. Select this option button to have Excel place 
the crossing point at the maximum value of the vertical axis.

5. If you want to display the units the chart uses, open the Display units 
pop-up menu and click the appropriate item, such as the Hundreds 
item, the Thousands item, or the Millions item. If you choose to 
display units, make sure the Show display units label on chart check 
box is selected, making Excel display a label showing the units. If 
you don’t want to show the units, choose None in the Display units 
pop-up menu.

6. If you need the chart to use a logarithmic scale rather than an 
arithmetic scale, select the Logarithmic scale check box, then enter 
the logarithm base in the Base box. For example, enter 10 to have 
the scale use the values 1, 10, 100, 1000, 10000, and so on, at 
regular intervals.

7. If you need the chart to show the values in reverse order, select the 
Values in reverse order check box. For example, you might need 
a chart to show the lowest value at the top instead of the highest 
values.

8. In the Tick Marks section, choose how to display tick marks on  
the axis:

	Major type. Open this pop-up menu and then click the type of 
tick mark you want for major tick marks. You can select Inside to 
have the major tick marks appear inside the chart, select Outside 
to have them appear outside (on the axis side), or select Cross 
to have them appear on both sides. Alternatively, you can select 
None if you do not want major tick marks.

	Minor type. Open this pop-up menu and then click the type of tick 
mark you want for minor tick marks. As with major tick marks, 
your choices are Inside, Outside, Cross, or None.
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9. In the Labels section, open the Label position pop-up menu and 
then click Next to axis, High, Low, or None. Choosing High puts the 
labels above the chart, whereas choosing Low puts the labels below 
the chart (which may have the same effect as choosing Next to axis). 
Choosing None suppresses the labels.

10. In the Number section, choose how to format the numbers on the 
axis:

	Category. Open this pop-up menu and choose the number 
category, such as General, Currency, or Date. These are the 
same formats you use for controlling how data appears in cells; 
depending on the format you choose, the Number section may 
display other options you can set for the format. For example, 
if you choose the Number category, you can set the number of 
decimal places, choose whether to use the thousands separator, 
and specify how to display negative numbers.

	Format Code. In this text box, you can specify formatting codes 
for the category. For example, for the Date category, you can 
specify codes such as m/d/yy or mm/dd/yyyy to control how the 
dates appear. Click the Add button to add the formatting code 
you’ve entered.

	Linked to source. Select this check box if the data is linked to its 
source in the worksheet.

11. When you’re satisfied with the axis, click the Close button (the × 
button in the upper-right corner) to close the Format Axis pane.

Adding a Legend to a Chart
Many charts benefit from having a legend that summarizes the colors used for different 
data series. You can add a legend by selecting the chart, choosing Chart Design ➤ Chart 
Layouts ➤ Add Chart Element ➤ Legend, then clicking the placement you want: Right, 
Top, Left, or Bottom.

To control whether the legend appears outside the chart area (which reduces the available 
chart area) or overlaps the chart area, choose Chart Design ➤ Chart Layouts ➤ Add Chart 
Element ➤ Legend ➤ More Legend Options. The Format Legend pane opens, showing 
the Legend Options pane in the Legend Options tab (yes, this gets recursive). You can then 
select or clear the Show the legend without overlapping the chart check box, as needed.

Whichever placement you use for the legend, you can drag it to a better position as needed. 
You can also resize the legend by clicking it and then dragging one of the handles that 
appears around it.

If you need to remove a legend from a chart, simply click the legend and then press Delete. If 
you’re feeling more formal, choose Chart Design ➤ Chart Layouts ➤ Add Chart Element 
➤ Legend ➤ None.
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Adding Axis Labels from a Range Separate from the Chart Data
Depending on how the worksheet containing the source data is laid out, you may need to 
add axis labels that are in separate cells from the chart data. This move is often useful when 
you’re creating a chart that uses only some of the available data.

To add axis labels from a separate range, follow these steps:

1. Click the chart to select it.

2. Choose Chart Design ➤ Data ➤ Select Data from the Ribbon to 
display the Select Data Source dialog box.

3. If necessary, click the Collapse Dialog button to the right of the 
Horizontal (Category) axis labels text box to collapse the dialog box. 
If you’ve got plenty of space to work in, just click the Horizontal 
(Category) axis labels box to tell Excel what you want to affect.

4. Drag through the cells in the worksheet that contain the axis labels. 
Excel enters them in the Horizontal (Category) axis labels text box.

5. If you collapsed the Select Data Source dialog box, click the 
Collapse Dialog button again to restore it.

6. Click the OK button to close the Select Data Source dialog box. 
Excel applies the labels to the axis.

Adding Data Labels to the Chart
If viewers will need to see the precise value of data points rather than just getting a general 
idea of their value, add data labels to the chart. To do so, click the chart, then choose 
Chart Design ➤ Chart Layouts ➤ Add Chart Element ➤ Data Labels and then click the 
placement you want on the Data Labels submenu. The Data Labels submenu offers different 
options, depending on the chart type. For example, for a column chart, you choose among 
Center, Inside End, Inside Base, and Outside End.

To control the data that appears in the data labels, choose Chart Design ➤ Chart Layouts 
➤ Add Chart Element ➤ Data Labels ➤ More Data Label Options and then make your 
choices in the Format Data Labels pane. Your choices here too vary depending on the chart 
type. The left screen in Figure 7-12 shows the options for a column chart; the right screen in 
Figure 7-12 shows the options for a pie chart.



 
230 CHAPTER 7: Creating Clear and Persuasive Charts

When you add data labels to a chart, Excel displays a data label for each data marker. If 
you want to display only some data labels, delete the ones you don’t need. To delete a data 
label, click it once to select all data labels, then click it again to select just the one label. 
Then either press Delete or Ctrl+click or right-click the selection and click Delete on the 
context menu.

Caution Use data labels sparingly. Only some charts benefit from data labels—other charts 
may become too busy, or having the details may distract the audience from the overall thrust 
of the chart.

Figure 7-12. The Label Options pane on the Label Options tab of the Format Data Labels pane offers different label 
contents and label position options for different chart types. The left screen shows the options for a typical column 
chart. The right screen shows the options for a pie chart
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Choosing Which Gridlines to Display
On many types of charts, you can choose whether to display horizontal and vertical gridlines 
to help the viewer judge how the data points relate to each other and to the axes.

To control which gridlines appear, follow these steps:

1. Select the chart.

2. Choose Chart Design ➤ Chart Layouts ➤ Add Chart Element ➤ 
Gridlines to display the Gridlines submenu.

3. Click the menu item for the type of gridlines you want to display, 
placing a check mark next to it. The menu items available depend 
on the chart type, but these options (for a column chart) are  
fairly typical:

	Primary Major Horizontal. Click this item to display horizontal 
gridlines at the major divisions in the data series. For example, if 
your data is in the range 0–25, major gridlines normally appear at 
5, 10, 15, 20, and 25. The left chart in Figure 7-13 shows a chart 
with both major and minor horizontal gridlines.

	Primary Major Vertical. Click this item to display vertical gridlines 
at the major divisions.

	Primary Minor Horizontal. Click this item to display horizontal 
gridlines at the minor divisions in the data series. For example, 
if your data is in the range 0–25, minor gridlines normally 
appear at each integer—1, 2, 3, and so on up to 25. The right 
chart in Figure 7-13 shows a chart with only minor horizontal 
gridlines.

	Primary Minor Vertical. Click this item to display vertical gridlines 
at the minor divisions. 

Tip You can edit the text of data labels if necessary. Click a data label once to select all data 
labels, then click it again to select just that data label. You can then double-click the data label to 
select its contents and then type in your text. For example, you might want to add text explaining 
the figure, write the figure in a more accessible format (such as “One MILLION dollars!” instead of 
$1,000,000), or simply falsify the figure.
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4. Repeat steps 2 and 3 for each set of gridlines the chart needs.

Formatting a Chart Wall and Chart Floor
Some charts look fine with a plain background, but for 3-D charts, you may want to decorate 
the chart walls (the areas at the back and the side of the chart) and the chart floor (the area 
at the bottom of the chart). You can add a solid color, a gradient, a picture, or a texture to 
the walls, the floor, or both. Figure 7-14 shows a chart that uses a picture for the walls.

Note To change the values at which the gridlines appear, format the axis, as described in the 
section “Changing the Scale or Numbering of an Axis” earlier in this chapter.

Figure 7-13. Using both major and minor gridlines (left) usually makes a chart easier to read than using only minor 
gridlines (right)

Tip When the viewer needs to see clearly where each value falls, use either data labels or major 
and minor gridlines. If using minor gridlines (with or without major gridlines) makes the chart look 
cluttered, use only major gridlines. Normally, it’s best not to use both horizontal and vertical minor 
gridlines, because they tend to make charts look confusingly busy—but sometimes your charts 
may need them.
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To format the chart wall or the chart floor, follow these steps:

1. Click the chart to select it.

2. Choose Format ➤ Current Selection ➤ Chart Elements to open 
the Chart Elements pop-up menu. (The Chart Elements pop-up menu 
is the pop-up menu at the top of the Current Selection group; it 
shows the currently selected element.) Then click the item you want 
to format: Back Wall, Floor, Side Wall, or Walls (to format both the 
back wall and the side wall).

Figure 7-14. You can give a chart a themed look by applying a picture to the chart walls

Tip Usually, the chart walls and floors are the elements that look best with a custom fill (such as 
a picture). But you can apply a custom fill to many other chart elements as well. To do so, display 
the Format pane for the element (as described in the following section, “Formatting Individual Chart 
Elements”), click the Fill button, then make your choices.
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3. Still on the Format tab, go to the Format group and click the Format 
Selection button to display the Format pane for the item you 
selected. Figure 7-15 shows the Format Walls pane displaying the 
controls for inserting a picture fill.

4. Make sure the Fill tab is displayed. If not, click the Fill tab  
button—the one that shows a tipping paint can.

5. In the Fill section, set up the fill you want:

	No fill. Select this option button to use no fill.

	Solid fill. Select this option button to create a solid fill. Open 
the Color pop-up menu, then click the color you want. Drag the 
Transparency slider, or type a value in the text box, to choose how 
transparent the fill is.

Figure 7-15. Use the Format pane to apply a picture fill to objects such as the chart walls or floor
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	Gradient fill. Select this option button to create a gradient fill. 
Open the Preset Gradients pop-up menu and select the style, 
then open the Type pop-up menu and choose the gradient style 
you want: Linear, Radial, Rectangular, or Path. Use the Direction 
pop-up menu and the Angle knob to set the angle and direction 
of the gradient if applicable. Use the Gradient stops bar to adjust 
the points at which the color gradient changes, and then use the 
Color, Position, Transparency, and Brightness controls to tweak 
the gradient as needed.

	Picture or texture fill. Select this option button to create a picture 
fill or a texture fill. To use a picture, you can either click the File 
button, click the picture in the Choose a Picture dialog box, and 
then click the Insert button; or simply click the Clipboard button to 
paste in a picture you’ve already copied to the Clipboard. To use a 
texture, choose it from the Texture pop-up palette. Set the degree 
of transparency by dragging the Transparency slider or entering a 
percentage in the text box. Then select the Stretch option button 
if you want to stretch the picture or texture to fill the space, select 
the Stack option button if you want to tile the picture or texture 
to occupy the space without distorting it, or select the Stack and 
scale with option button and enter a value in the Units/Picture 
box to tile the picture with the number of units you specify. If you 
need to offset the picture from one of the sides, adjust the value in 
the Offset left box, the Offset right box, the Offset top box, or the 
Offset bottom box.

	Pattern fill. Select this option button to create a pattern fill. In 
the Pattern area that appears, click the pattern you want. Then 
choose the foreground color in the Foreground color pop-up menu 
and the background color in the Background color pop-up menu.

	Automatic. Select this option button to use an automatic fill.

6. Click the Close button (the × button in the upper-right corner) to 
close the Format pane for the element you chose.

Formatting Individual Chart Elements
You can format any of the individual elements of a chart—for example, the legend, the 
gridlines, or the data labels—by selecting the element and then using its Format pane. This 
dialog box includes the name of the element it affects: the Format Data Labels dialog box, 
the Format Plot Area dialog box, and so on.

You can display the Format pane in either of these ways:

	Ctrl+click or right-click the element, then click the Format item on  
the context menu. This is usually the easiest way of opening the  
Format pane.
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	Select the element in the Chart Elements pop-up menu, then click 
the Format Selection button. If it’s hard to Ctrl+click or right-click the 
element on the chart (for example, because the chart is busy), choose 
Format ➤ Current Selection ➤ Chart Elements, then click the 
element you want on the pop-up menu. You can then click the Format 
Pane button in the Format group of the Format tab to open the Format 
pane for the element.

The contents of the Format pane vary depending on the object you’ve selected, but for most 
objects, you’ll find categories such as these:

	Fill. You can fill in a solid shape with a solid color, color gradient, picture, 
or texture. See the previous section, “Formatting a Chart Wall and Chart 
Floor,” for instructions on creating fills.

	Line. You can give a shape a color border, gradient border, or no line. 
You can also choose among different border styles, change the border 
width, and pick a suitable line type.

	Shadow. You can add a shadow to the shape, set its color, and adjust its 
transparency, width, and other properties.

	Glow and Soft Edges. You can make an object stand out by giving it a 
glow, choosing a color that contrasts with the object’s surroundings, 
and choosing how wide the glow should be. You can also apply soft 
edges to a shape.

	3-D Format. You can apply a 3-D format to different aspects of a 
shape—for example, setting a different bevel for the top and bottom of 
the shape.

	3-D Rotation. You can apply a 3-D rotation to the object.

	Font. For objects that use text, you can control how the text looks.

Copying a Chart’s Formatting to Another Chart
After you set up a chart with all the formatting you need, you can apply that formatting to 
another chart by using Copy and Paste. Follow these steps:

1. Click the formatted chart to select its chart area.

2. Right-click the border of the chart, then click Copy on the context 
menu to copy the chart and its formatting to the Clipboard.

Tip If the chart element contains text, you can also format it by using the controls on the Home 
tab of the Ribbon or keyboard shortcuts. For example, to apply boldface to the data labels, click the 
data labels, then choose Home ➤ Font ➤ Bold (or press Ctrl+B). This is often easier than using 
the Font controls in the Format pane for the element.



 
237CHAPTER 7: Creating Clear and Persuasive Charts

3. Go to the sheet that contains the chart onto which you want to paste 
the formatting.

4. Choose Home ➤ Clipboard ➤ Paste ➤ Paste Special to display 
the Paste Special dialog box shown in Figure 7-16.

Figure 7-16. In the Paste Special dialog box, select the Formats option button to paste just the formatting from one 
chart onto another chart

5. Select the Formats option button.

6. Click the OK button to close the Paste Special dialog box. Excel 
applies the formatting to the chart.

Reusing Your Own Designs by Creating Custom  
Chart Types
If you want to be able to reuse a chart design you’ve created, you can turn it into a custom 
chart type. Follow these steps:

1. Select the formatted chart either on a chart sheet or on a worksheet.

2. Choose Chart Design ➤ Type ➤ Change Chart Type ➤ Save As 
Template from the Ribbon to display the Save as Template dialog 
box. This is a standard Save As dialog box.

3. If you want, change the folder in which to save the chart type. Excel 
suggests using the ~/Library/Application Support/Microsoft/Office/
Chart Templates/ folder (where ~ represents your home folder). This 
is a good location for a template that only you will use, but if your 
colleagues will need to use the template too, store it in a shared 
folder on the network.

4. Type a descriptive name for the template in the Save As text box.

5. Click the Save button to close the Save as Template dialog box. 
Excel saves the template in the folder you chose.
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To create a chart based on your template, follow these steps:

1. Select the source data for the chart.

2. Choose Insert ➤ Charts ➤ Insert Area, Stock, Surface, or Radar 
Chart ➤ Templates to display the Templates pop-up panel.

3. Click the template.

Controlling Which Chart ScreenTips Excel Displays
The Chart pane in the Excel Preferences window contains two options for controlling 
which ScreenTips Excel displays when you move the mouse over a chart. Choose Excel ➤ 
Preferences or press Cmd+, (Cmd and the comma key) to display the Excel Preferences 
window, and then click the Chart icon in the Authoring area to display the Chart preferences 
pane. You can then select or clear these two check boxes as needed:

	Show names of chart elements on rollover. Select this check box to 
make Excel display a ScreenTip containing an item’s name when you 
hold the mouse pointer over that item. For example, when you hold the 
mouse pointer over a data series, a ScreenTip shows the data series’ 
name and details.

	Show data point values on rollover. Select this check box to make Excel 
display a ScreenTip showing the value of a data marker when you hold 
the mouse pointer over the data marker.

When you’ve finished choosing Chart preferences, close the Excel Preferences window by 
clicking the Close button (the red button at the left end of the window’s title bar).

Using Your Charts in Word Documents and  
PowerPoint Presentations
Excel is Office’s application for creating charts, but you will likely also want to use charts 
to illustrate Word documents and PowerPoint presentations. You can either reuse a chart 
you’ve already created in Excel or create a new chart especially for that document or 
presentation.

Understanding How You Can Add a Chart to a  
Document or Slide
A chart can be a great way of presenting complex or detailed information in a manner that’s 
instantly clear in a document or on a slide. You can add a chart to a Word document or a 
PowerPoint presentation in either of these ways:

	Create a chart on an embedded worksheet. Choose Insert ➤ 
Illustrations ➤ Charts to display the Charts panel, then click the chart 
type you want. Word or PowerPoint then opens Excel for you and 
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creates a new workbook so that you can enter the chart data and create 
the chart. The workbook is embedded in the Word document or 
PowerPoint presentation, so it becomes part of that file. 

	Copy a chart from an Excel workbook. Create your chart in Excel using 
the techniques described earlier in this chapter, then copy the finished 
chart and paste it into the Word document or onto the PowerPoint 
slide. You can choose whether to embed the chart’s data in the Word 
document or PowerPoint presentation or just to insert the chart as a 
picture or PDF file.

Here’s how to choose when to create a new embedded workbook, embed an existing chart 
and its data, link back to a workbook, or insert a picture:

	Create a new embedded workbook. Do this when you don’t yet have the 
data for the chart in Excel and you need to keep the chart’s data with 
the Word document or PowerPoint presentation. For example, you’ll 
send the presentation to someone else who will need to work on the 
chart data too.

	Embed an existing chart and its data. Do this when you have the data 
for the chart or the chart itself in a workbook in Excel and you need to 
keep the chart’s data available in the Word document or PowerPoint 
presentation. After embedding the chart and its data, you can open the 
chart from Word in Excel and edit it there.

	Link back to a workbook. Do this when you want to be able to change 
the chart or its source data in Excel and then automatically bring those 
changes into Word or PowerPoint by updating the chart. Linking 
requires the workbook to stay in the same relative place in the 
computer’s file system to the document or presentation so that Word or 
PowerPoint can find the updated data. Moving the document or 
presentation to a different computer breaks the link. 

	Insert a picture. Do this when you don’t need to keep the connection 
between the chart and its source data and you will not need to edit the 
chart in the document or presentation.

Note In PowerPoint, you can also click the Insert Chart icon in a content placeholder to start 
creating a chart on an embedded worksheet.

Caution Linking a chart can be great when it works—but links can fail at the most awkward 
times. Before giving a presentation that includes linked charts, double-check that the links are 
working. That way, you’ll have a chance to fix any problems rather than discovering them when 
your audience sees them.
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Creating a Chart in a New Embedded Workbook
To create a chart on a worksheet in a new workbook embedded in a Word document or 
PowerPoint presentation, follow these steps:

1. Open the document in Word or the presentation in PowerPoint.

2. On the document page or slide where you want to create the chart, 
choose Insert ➤ Illustrations ➤ Charts to display the Charts panel.

3. Click or highlight the category of chart you want to create. For example, 
click or highlight the Column category to display the Column panel.

4. In the Insert Chart group, click the pop-up button for the category 
of chart you want to create. For example, click the Column pop-up 
button to display the Column panel.

5. On the panel, click the chart type. Word or PowerPoint creates a 
chart of that type on the slide and launches Excel, which creates 
a new workbook, embeds it in the document or presentation, and 
gives it a name such as Chart in Microsoft Office Word or Chart in 
Microsoft Office PowerPoint.

6. Change the chart range and the sample data (Figure 7-17 shows an 
example using PowerPoint) to the data your chart needs. Word or 
PowerPoint automatically updates the chart to match the data in the 
Excel worksheet.

Figure 7-17. Excel enters sample data on the first worksheet in the embedded workbook. Change this data to create 
your chart
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7. When you finish changing the data, close the workbook or close 
Excel. For example, click the Close button (the red button at the left 
end of the title bar) or choose Excel ➤ Quit Excel. 

8. With the chart selected in Word or PowerPoint, use the controls on 
the Chart Design tab and the Format tab of the Ribbon to format 
the chart the way you want it. Figure 7-18 shows a PowerPoint slide 
containing a chart with formatting under way.

Figure 7-18. After inserting a chart using an embedded workbook, use the controls on the Chart Design tab and the 
Format tab of the Ribbon in Word or PowerPoint (shown here) to format the chart

Note Excel saves the data in the embedded workbook automatically, so you don’t need to save it 
while you’re working in the Excel window.
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9. Save your Word document or PowerPoint presentation.

Pasting a Chart from Excel into a Word Document or PowerPoint Slide
If you have a chart already created in Excel or if you have a workbook containing the data 
from which you will create the chart, you can paste the chart into Word or PowerPoint. 
Follow these general steps:

1. Create the chart using the techniques explained earlier in this 
chapter.

2. Click the chart to select it.

3. Copy the chart to the Clipboard. For example, choose Home ➤ 
Clipboard ➤ Copy from the Ribbon, choose Edit ➤ Copy from the 
menu bar, or press Cmd+C.

4. Switch to Word or PowerPoint, then navigate to the document or 
slide on which you want to insert the chart.

5. Paste in the chart from the Clipboard. For example, choose Home ➤ 
Clipboard ➤ Paste from the Ribbon, choose Edit ➤ Paste from the 
menu bar, or press Cmd+V.

6. Click the Paste Options button at the lower-right corner of the chart, 
then click the appropriate option button in the upper group on the 
Paste Options pop-up menu (see Figure 7-19):

	Paste as Picture (Word) or Picture of Chart (smaller file size) 
(PowerPoint). Select this option button to insert a picture of the 
chart. As the PowerPoint name says, inserting the picture helps 
keep the presentation file size down. The disadvantage is that you 
can’t edit the picture.

	Chart (Embedded Workbook) in Word; Excel Chart (entire 
workbook) in PowerPoint. Select this option button to embed the 
entire Excel workbook in the Word document or the PowerPoint 
presentation.

	Chart (Linked to Excel Data). Select this option button to link the 
chart back to the Excel workbook it came from.

Note To edit the data on your chart again, select the chart, then choose Chart Design ➤ Data ➤ 
Edit Data in Excel from the Ribbon. Word or PowerPoint opens Excel, which displays the embedded 
worksheet.
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7. If you want the chart on the slide or in the document to use the original 
formatting you gave it in Excel, click the Paste Options button again, 
then select the Keep Source Formatting option button. Otherwise, 
leave the Use Destination Theme option button selected, and the chart 
will pick up the formatting from the document or presentation.

8. Use the controls on the Chart Design tab or the Format tab of the 
Ribbon to format the chart the way you want it. (If you inserted the chart 
as a picture, use the controls on the Picture Format tab of the Ribbon.)

9. Save the document or presentation.

To edit the data in either an embedded or linked chart, click the chart, and then choose 
Chart Design ➤ Data ➤ Edit Data in Excel.

Summary
In this chapter, you learned how to create powerful and persuasive charts from your data. 
You know what the separate components of charts are called, how to create a chart, and 
how to position it either on a worksheet or on its own chart sheet. You can also make Excel 
show the components you want for a chart and format them as needed. To save time and 
effort, you also learned how to reuse your custom chart formatting either by pasting it onto 
an existing chart or by creating a custom chart template from it.

You now also understand the different ways you can use an Excel chart in a Word document 
or a PowerPoint presentation; you know which way works best in which circumstances; and 
you know how to insert the chart, format it, and edit it.

In the next chapter, I’ll show you how to enhance your worksheets with data bars, color 
scales, icon sets, and sparklines. Turn the page when you’re ready to get started.

Figure 7-19. When pasting a chart from Excel into a Word document (left) or PowerPoint slide (right), click the Paste 
Options button, and use the option buttons on the pop-up menu to choose how to paste the chart
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Chapter 8
Using Data Bars, Color Scales, 
Icon Sets, and Sparklines
In this chapter, we’ll look at how you can use four graphical elements to give your 
worksheets more visual appeal and oomph without using full-scale charts. These four 
elements are data bars, color scales, icon sets, and sparklines. Each is a graphical element 
that appears in a single cell.

Data bars, color scales, and icon sets are part of Excel’s conditional formatting, which you 
learned about in Chapter 4. Data bars are like single-cell bar charts that you use to compare 
the values in a range of cells. Color scales give you an easy way to adjust the background 
colors of cells to reflect their values—for example, red for poor performance and green for 
good performance. Icon sets enable you to quickly add an icon that represents how a value 
compares to the rest of its cohort; for example, you can add up-pointing arrows to good results.

Sparklines are miniature charts that fit in a single cell. You use sparklines much as you would 
use a tiny chart—to illustrate a series of data. For example, you can create a sparkline that 
shows a line indicating a stock’s price movements over a number of days.

Using Data Bars
A data bar is a horizontal bar that appears in a cell to graphically represent the value in a 
corresponding cell. Normally, you’ll use data bars to represent the values of multiple cells so 
that you can see the relationship among the cells’ values.

For example, the worksheet in Figure 8-1 uses data bars to show the sales by five different 
salespeople for April, May, June, and the second quarter of the year as a whole. Each cell 
that contains a data bar has the same value as the cell to its left, so the data bar in cell 
C4 illustrates the value shown in cell B4. Looking at the data bars, you can easily see that 
although Salesperson Ramirez had a disastrous April and a modest May, her strong June 
sales brought her up to a respectable result for the quarter overall.

http://dx.doi.org/10.1007/978-1-4842-1019-2_4
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Creating Data Bars
By default, Excel places data bars alongside the data they represent. You can choose to 
display only the data bars in the cells, or you can display the data bars in separate cells to 
make the worksheet easier to read.

Creating Data Bars in the Same Cells as Their Data
To create data bars that appear in the same cells as their data, follow these steps:

1. Enter the data from which you’ll create the data bars. If the data is 
already in the worksheet, you’re all set.

2. Select the cells that contain the data.

3. Choose Home ➤ Styles ➤ Conditional Formatting ➤ Data Bars to 
display the Data Bars panel (see Figure 8-2).

Figure 8-1. Data bars give a quick graphical representation of the values in the cells. Here, each cell showing a data 
bar contains the same value as the cell to its left
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4. Click the color and fill type you want in either the Gradient Fill section 
or the Solid Fill section of the Data Bars panel. Excel creates the data 
bars in the cell. The left screen in Figure 8-3 shows an example. 

Figure 8-2. Use the Home ➤ Styles ➤ Conditional Formatting ➤ Data Bars command to create data bars in the 
selected cells. You can choose between a gradient fill and a solid fill

Tip A gradient fill works best for data bars you display in the same cells as their data, because 
the lighter end of the gradient leaves the text readable. For data bars you display in cells on their 
own, you may prefer solid fills.

Figure 8-3. After creating data bars (left), you may need to widen the column to give them more impact (right)
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5. Change the column width if necessary. For example, drag the right 
border of the cell’s column heading to the right to make the column 
wider and give the data bars more impact, as shown on the right in 
Figure 8-3.

Creating Data Bars in Different Cells than Their Data
To make your data bars easy to read, you may want to have them appear in cells on their 
own, either with the underlying data appearing in cells alongside them (or elsewhere, as 
needed) or without the data appearing at all. You can make the data bars appear on their 
own in cells by setting Excel to display only the data bars there. If you want the data for the 
data bars to be visible, you need to place it in different cells.

To make the data bars appear without their data, follow these steps:

1. Create the data bars as described in the previous section, so that the 
data bars appear in the same cells as their data.

2. With the cells still selected, choose Home ➤ Styles ➤ Conditional 
Formatting ➤ Manage Rules to display the Manage Rules dialog 
box (see Figure 8-4).

Figure 8-4. In the Manage Rules dialog box, select the rule for the data bars, then click the Edit Rule button

3. Make sure the right rule is selected. If you’ve applied only one 
conditional formatting rule to the cells, it will be selected; if you’ve 
applied multiple rules, you may need to select the right rule.

4. Click the Edit Rule button to display the Edit Formatting Rule dialog 
box (see Figure 8-5).
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5. Select the Show data bar only check box.

6. Click the OK button to close the Edit Formatting Rule dialog box.

7. Click the OK button to close the Manage Rules dialog box.

Tip With the Edit Formatting Rule dialog box open, you can quickly change among data bars, icon 
sets, and color scales. Just open the Style pop-up menu and choose 2-Color Scale, 3-Color Scale, 
Data Bar, or Icon Sets, as appropriate.

Figure 8-5. In the Edit Formatting Rule dialog box, select the Show data bar only check box if you want to display the 
data bars without the values that produced them
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To create data bars that appear in separate cells from the values that produce them, set up 
the cells that will contain the data bars with formulas referring to the cells that contain the 
values. For example, the worksheet shown in Figure 8-6 uses simple formulas such as =B2 
to make the cells in column C have the same values as the corresponding cells in column B. 
You can then set up the data bars as described earlier in this chapter in the target cells—in 
this case, in column C.

Figure 8-7. You can add impact and clarity to mundane data such as temperatures by formatting the cells with a color 
scale. In this worksheet, the shading for much of January, February, and March is blue, indicating colder temperatures. 
The shading for April, May, and June is red, indicating higher temperatures

Figure 8-6. When you need to produce data bars in cells separate from their data, use formulas to give the data-bar 
cells the same values as the cells that provide the data. For example, cell C2 here contains the formula =B2 and will 
show the data bar for the value in cell B2

Using Color Scales
Color scales are a handy way of showing how the values in a set of cells compare to each 
other by setting the background color of each cell to represent its value. Excel lets you 
use either two-color scales or three-color scales. For example, to illustrate a range of 
temperatures, you could use a two-color scale with blue for the low temperatures and red for 
the high temperatures, or a three-color scale with blue representing an uncomfortably low 
temperature, green comfortable, and red uncomfortably warm. Figure 8-7 shows an example 
of this kind of daily temperature chart for the first half of a year using a two-color scale.
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To create a color scale, follow these steps:

1. Enter the data from which you’ll create the color scale.

2. Select the cells that contain the data.

3. Choose Home ➤ Styles ➤ Conditional Formatting ➤ Color Scales 
to display the Color Scales panel (see Figure 8-8).

Figure 8-8. On the Color Scales panel, click the scale type you want. You can change the colors later if you need to

4. Click the type of color scale you want. Excel applies it to the cells.

Sometimes the color scale’s default settings may suit your needs, but usually you’ll need 
to adjust the color scale to change the points at which each color is used or to change the 
colors themselves. To adjust a color scale, follow these steps:

1. With the cells still selected, choose Home ➤ Styles ➤ Conditional 
Formatting ➤ Manage Rules to display the Manage Rules dialog 
box (shown in Figure 8-4, earlier in this chapter).

2. Make sure the right rule is selected. If you’ve applied only one 
conditional formatting rule to the cells, it will be selected; if you’ve 
applied multiple rules, you may need to click the right rule.

3. Click the Edit Rule button to display the Edit Formatting Rule dialog 
box (see Figure 8-9).
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4. If you need to change from a three-color scale to a two-color scale or 
vice versa, open the Style pop-up menu, then click 3-Color Scale or 
2-Color Scale, as appropriate.

5. In the Minimum column, open the Type pop-up menu and choose 
Lowest Value, Number, Percent, Formula, or Percentile, as needed. 
Next, enter a suitable value in the Value box, either by typing it in or 
by clicking the Collapse Dialog button, clicking the appropriate cell 
in the worksheet, then clicking the Collapse Dialog button again. If 
necessary, open the Color pop-up menu and choose a different color.

6. For a three-color scale, go to the Midpoint column, then set the type, 
value, and color.

7. In the Maximum column, set the type, value, and color.

8. Click the OK button to close the Edit Formatting Rule dialog box. 
Excel returns you to the Manage Rules dialog box.

9. Click the OK button to close the Manage Rules dialog box. Excel 
applies the changes to the worksheet.

Representing Data Graphically with Icon Sets
Another helpful way of representing data graphically is by using icon sets to indicate the 
relationship of a set of values to each other. For example, you can apply a set of directional 
arrows to make Excel show green up arrows on high values, yellow right-pointing arrows on 
midpoint values, and red down arrows on low values. Figure 8-10 shows this kind of icon set 
used to track the month-by-month and full-quarter performance of the five salespeople you 
met earlier in this chapter.

Figure 8-9. Use the Edit Formatting Rule dialog box to set the Minimum value, Midpoint value, and Maximum value for 
the scale. You can also change the colors by using the three Color pop-up menus
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To apply an icon set to cells, follow these steps:

1. Enter the data that will produce the icon set.

2. Select the cells that contain the data.

3. Choose Home ➤ Styles ➤ Conditional Formatting ➤ Icon Sets to 
display the Icon Sets panel (see Figure 8-11).

Figure 8-10. Apply an icon set to a range of cells to provide a quick visual reference to their relationship. This 
worksheet uses four icon sets—one on column B, one on column C, one on column D, and one on column E—rather 
than a single icon set, which would compare all the values in B2:E6 to each other and show that the third-quarter totals 
in column E made the monthly values look pretty miserable
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4. Click the icon set you want to apply.

Many icon sets work straight out of the box (as it were), but you may need to adjust others 
as follows:

1. With the cells still selected, choose Home ➤ Styles ➤ Conditional 
Formatting ➤ Manage Rules to display the Manage Rules dialog 
box (shown in Figure 8-4, earlier in this chapter).

2. Make sure the right rule is selected. If you’ve applied only one 
conditional formatting rule to the cells, it will be selected; if you’ve 
applied multiple rules, you may need to click the right rule.

Figure 8-11. On the Icon Sets panel, click the set of icons you want to apply to the selected cells
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3. Click the Edit Rule button to display the Edit Formatting Rule dialog 
box (see Figure 8-12).

Figure 8-12. In the Edit Formatting Rule dialog box, you can change the icons, reverse the order, show only the icons, 
and change the threshold values

4. To change the icons used, open the Icons pop-up menu, then click 
the icon set you want.

5. If you want to show the icons in reverse order, select the Reverse 
icon order check box.

6. If you want to show the icons without the values that produce them, 
select the Show icon only check box. 

7. In the Display area, choose the icons you want to use and the 
threshold values for them.

8. Click the OK button to close the Edit Formatting Rule dialog box. 
Excel returns you to the Manage Rules dialog box.

9. Click the OK button to close the Manage Rules dialog box and return 
to your worksheet, which shows the changes you made.

Tip When you want to show each value in one cell and its icon in another cell, set up the icon 
cells with formulas that refer to the value cells. For example, enter =B2 in cell C2, then apply an 
icon set to the icon cells, open the Edit Formatting Rule dialog box, and select the Show icon only 
check box.
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Showing Data Trends with Sparklines
As you saw in Chapter 7, charts are great for illustrating medium to large quantities of 
information, but sometimes you’ll want something smaller—a chart that’ll fit inside a single 
cell, giving a quick visual indication of a trend. Excel calls such charts sparklines.

Excel provides three kinds of sparklines:

	Sparkline. A sparkline is a straightforward line that runs through the 
data points, as in the top part of Figure 8-13. I’ll refer to them as “plain 
sparklines” to distinguish them from column sparklines and win/loss 
sparklines. A plain sparkline is good for showing data that flows from 
one data point to the next, such as temperatures.

Figure 8-13. Sparklines are single-cell charts that you can use to indicate trends or results visually

	Column. A column sparkline shows the data as a series of columns, as 
in a column chart. The middle part of Figure 8-13 shows an example. A 
column sparkline is good for comparing data points that are separate 
from each other, such as sales results by month.

	Win/Loss. A win/loss sparkline shows results as either a win (a positive 
result) or a loss (a negative result). The lower part of Figure 8-13 shows 
an example of win/loss sparklines. A win/loss sparkline is good for 
when you want to take a black-and-white view of results—for example, 
whether your investments are up or down in a particular month. In a win/
loss sparkline, a zero value appears as a blank.

http://dx.doi.org/10.1007/978-1-4842-1019-2_7
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Inserting Sparklines
To insert one or more sparklines in a worksheet, follow these steps:

1. Select the range that contains the data you will use for the 
sparklines.

2. Click the Insert tab to display its contents, click the Sparklines button 
to display the pop-up panel, and then click Sparklines, Column, or 
Win/Loss, as needed. Whichever button you click, Excel displays the 
Insert Sparklines dialog box (see Figure 8-14).

Figure 8-14. In the Insert Sparklines dialog box, choose the data range for the sparklines and the cells in which to 
place them

3. Make sure the Select a data range for the sparklines text box 
contains the source range for the sparklines. If you chose the range 
before displaying the Insert Sparklines dialog box, it’ll be correct. 
Otherwise, click in this text box, then drag in the worksheet to select 
the range.

4. Click the Select where to place sparklines text box, and then drag in 
the worksheet to select the range. Or, if you prefer, type in the range.

5. Click the OK button to close the Insert Sparklines dialog box. Excel 
inserts the sparklines in the cells.

Formatting Your Sparklines
After inserting sparklines, you can format them by using the controls on the Sparkline Design 
tab of the Ribbon. Click a cell in the sparklines to select the group of sparklines and make 
Excel add the Sparkline Design tab to the Ribbon. If Excel doesn’t display the Sparkline 
Design tab automatically, click the tab to display it (see Figure 8-15).
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These are the main moves for formatting your sparklines:

	Change the source data for a group of sparklines. Click a cell in the 
group of sparklines, then choose Sparkline Design ➤ Sparkline ➤ Edit 
Data from the Ribbon (clicking the main part of the Edit Data button). 
Excel displays the Edit Sparklines dialog box, which has the same 
controls as the Insert Sparklines dialog box (shown in Figure 8-14).

	Change the source data for a single sparkline. Click the sparkline cell, 
then choose Sparkline Design ➤ Sparkline ➤ Edit Data ➤ Edit Single 
Sparkline’s Data. Excel displays the Edit Sparkline dialog box, which 
works like the Insert Sparklines dialog box, but affects only the cell you 
chose.

	Change a sparkline to a different type. Click the sparkline cell, then click 
the Line button, the Column button, or the Win/Loss button in the Type 
group on the Sparkline Design tab of the Ribbon.

	Add markers to the sparklines. In the Show group on the Sparkline 
Design tab of the Ribbon, select the High Point check box, the Low 
Point check box, the Negative Points check box, the First Point check 
box, or the Last Point check box as needed. To display a marker for 
each data point on a plain sparkline, select the Markers check box. To 
change the marker color, choose Sparkline Design ➤ Style ➤ Marker 
Color ➤ Markers, then click the appropriate color in the Markers panel 
(see Figure 8-16). 

Figure 8-15. Use the controls on the Sparkline Design tab of the Ribbon to format sparklines to look the way you want 
them to
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	Apply a style to the sparklines. In the Format group on the Sparkline 
Design tab of the Ribbon, either click a style in the Styles box or hold 
the mouse pointer over the Styles box to display the panel button. Next, 
click the panel button to display the Styles panel, then click the style 
you want.

	Change the color of the sparklines. Choose Sparkline Design ➤ Style ➤ 
Sparkline Color to display the Sparkline Color panel, then click the color 
you want.

	Change the axes for the sparklines. Choose Sparkline Design ➤ Group 
➤ Axis to display the Axes dialog box (see Figure 8-17), then make your 
choices in it.

Figure 8-16. Use the Markers panel to change the colors of markers and to choose which ones appear on the 
sparklines

Tip For many kinds of data, the High Point marker and Low Point marker are the most useful. 
Win/loss sparklines use the Negative Points marker by default, while plain sparklines and column 
sparklines don’t use any markers by default.
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	Group sparklines together. If you need to format separate sets of 
sparklines quickly, group them together. Select each set of sparklines, 
then choose Sparkline Design ➤ Group ➤ Group from the Ribbon to 
group them.

	Clear sparklines. When you no longer need sparklines, clear them from 
the cells. Select the sparkline cells you want to clear, then choose 
Sparkline Design ➤ Group ➤ Clear, clicking the main part of the Clear 
button. You can also click a single cell and then choose Sparkline 
Design ➤ Group ➤ Clear ➤ Clear Selected Sparkline Groups to clear 
all the cells in the group.

Summary
In this chapter, you’ve learned how to illustrate your worksheets by attaching data bars, 
color scales, and icon sets to conditional formatting. You’ve also learned how to show data 
trends with sparklines.

In the next chapter, I’ll show you how to illustrate your worksheets further using pictures, clip 
art, SmartArt diagrams, and shapes.

Figure 8-17. You can use the Axes dialog box to choose settings for the horizontal and vertical axes of the sparklines
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Chapter 9
Illustrating Your Worksheets 
with Pictures, SmartArt,  
and More
To give your workbooks visual interest, you can add graphics, shapes, SmartArt 
diagrams, and WordArt items to them. Graphics are pictures and images in the various 
formats that Excel can import, and shapes are Excel’s built-in shapes, which include 
everything from simple arrows and regular shapes (such as circles, squares, and 
triangles) to complex shapes you create on the fly. SmartArt includes a range of graphics 
such as organization charts and flowcharts, while WordArt is graphical text that you 
create to your preferred design.

This chapter shows you how to insert pictures, how to insert shapes and format them, 
and how to position graphical objects where you want them. You’ll learn how to make a 
picture look the way you want it, how to position graphical objects wherever you need them, 
and how to illustrate your workbooks by adding SmartArt diagrams and WordArt items. 
Beyond that, I show you how to position graphical items relative to cells and how to arrange 
graphical objects to control which ones are visible.

Before we start, there’s one vital thing you need to know: Even though a worksheet appears 
to be flat, it actually consists of multiple separate layers. Until you add objects to a layer, 
the layer is transparent, so you see through the layer to whatever is underneath. One layer 
contains the worksheet’s cells; the other layers contain graphical objects. Having these 
multiple layers enables you to position graphical objects either in front of the cells or behind 
them. You can also position a graphical object in front of another graphical object; for 
example, to superimpose one image on another.
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Inserting Pictures in Your Workbooks
To illustrate your workbooks, you can insert your own photos and other pictures. You 
can insert either pictures you’ve added to the Photos app or pictures that are in your 
Mac’s file system but not in Photos. Because Photos is OS X’s standard application for 
importing photos from a digital camera and editing them, you’ll probably want to use it 
much of the time.

Inserting Pictures from the Photos App
To insert a picture from the Photos App, follow these steps:

1. Choose Insert ➤ Illustrations ➤ Pictures ➤ Photo Browser from 
the Ribbon or Insert ➤ Picture ➤ Photo Browser from the menu 
bar to open the Photos Browser (see Figure 9-1).

Figure 9-1. Use the Photos Browser to add a picture from the Photos app to a workbook
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2. In the pop-up menu, choose the source of the pictures. For example, 
expand Photos to see all pictures in Photos, expand Albums to see 
a list of albums you’ve created in Photos, and then click Favorites to 
see the photos you’ve marked as favorites.

3. Click the photo you want, and then drag it to the workbook window, 
dropping it where you want it to appear.

4. Leave the Photos Browser window open if you want to use it further. 
Otherwise, click the Close button (the red button in its upper-left 
corner) to close it.

Inserting Pictures from Your Mac’s File System
To insert a picture that’s not in the Photos app but is stored in your Mac’s file system or  
on a network drive, follow these steps:

1. Click the cell where you want the upper-left corner of the picture to 
appear.

2. Choose Insert ➤ Illustrations ➤ Pictures ➤ Picture from File from 
the Ribbon or Insert ➤ Picture ➤ Picture from File from the menu 
bar to display the Choose a Picture dialog box (see Figure 9-2).

Figure 9-2. From the Choose a Picture dialog box, you can choose whether to link the picture to the workbook
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3. Navigate to the folder that contains the file, and then click the file.

4. If you want to link the picture file to the workbook rather than insert 
it, select the Link to File check box. When you do this, you can select 
the Save with Document check box to store the latest version of the 
picture file in the workbook. See the sidebar “Linking a Picture to a 
Workbook” for advice about linking.

5. Click the Insert button. Excel closes the Choose a Picture dialog box 
and inserts the picture in the workbook.

LINKING A PICTURE TO A WORKBOOK

When you add a picture to a workbook from your Mac’s file system, you can either insert it or link it. Inserting 
the picture adds a copy of the picture to the workbook. Excel saves the picture in the workbook, so even if you 
move the workbook, the picture stays in it.

If you need to keep the workbook’s file size down or if you need to be able to update the picture easily, you 
can link the picture instead. Linking makes Excel add to the workbook a link to the picture file. When you open 
the workbook, Excel loads the current version of the picture from the file. But if you move the workbook to a 
different computer, the link no longer works, because Excel can’t find the picture file.

To solve the problem of broken links, you can link a picture but also save the latest version of it. To do this, 
select the Link to File check box and the Save with Document check box in the Choose a Picture dialog box. 
When you open the workbook, Excel checks to see whether the linked version is available. If so, Excel loads the 
linked picture; if not, it displays the version saved in the workbook.

Adding and Formatting a Shape
If a workbook needs a drawing, you can create it from scratch by using shapes. Excel 
provides a wide variety of shapes, from arrows and basic shapes to stars, banners, and 
callouts. 

To insert a shape, follow these steps:

1. Display the area of the workbook where you want to add the shape. 
When adding a shape, you don’t need to select a particular cell or 
range.

2. Choose Insert ➤ Illustrations ➤ Shapes to display the Shapes 
panel (see Figure 9-3). 

Tip You can also insert a picture file by dragging it from a Finder window to a workbook.
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3. Go to the category you want: Lines, Rectangles, Basic Shapes, Block 
Arrows, Equation Shapes, Flowchart, Stars and Banners, or Callouts. 
You’ll need to scroll to reach the last couple of categories.

4. Click the shape you want. Excel changes the mouse pointer to a crosshair.

5. With this crosshair, click where you want to place one corner of 
the shape, and then drag to the opposite corner (see Figure 9-4). It 
doesn’t matter which corner you place first, because you can drag in 
any direction, but placing the upper-left corner first is usually easiest.

Figure 9-3. Choose the type of shape from the Shapes panel. Hold the mouse pointer over a shape to see a ScreenTip 
showing its description

Note You can also insert a shape by choosing Insert ➤ Shape from the menu bar, clicking the 
appropriate shape type—Rectangle, Rounded Rectangle, Triangle, Oval, or Line—on the Shape 
submenu, and then dragging the crosshair pointer to create the shape. You can refine the shape’s 
type afterward if needed. But in general it’s easiest to use the Shapes pop-up panel, which gives 
you direct access to a wide variety of shapes.
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When you release the mouse button, the shape appears with selection handles around it, so 
you can work with it as described in the following sections. When the shape is selected, the 
Ribbon automatically displays the Shape Format tab, which provides controls for formatting 
the shape.

Applying a Style to a Shape
After inserting a shape, you can apply a style to it from the Shape Styles box or panel in the 
Shape Styles group on the Shape Format tab of the Ribbon. If the style you want appears in 
the Shape Styles box, click it; otherwise, move the mouse pointer over the Shape Styles box 
so that the panel button appears, and then click the button to display the panel  
(see Figure 9-5). You can then click the style you want.

Figure 9-4. Click and drag with the crosshair to place and size the shape you’re inserting. The Shape Format tab of the 
Ribbon then appears automatically, giving you access to commands for formatting shapes
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To refine the shape, open the Shape Fill panel, the Shape Outline panel, or the Shape Effects 
panel in the Shape Styles group, and then click the option you want. For example, choose 
Shape Format ➤ Shape Styles ➤ Shape Effects ➤ 3-D Rotation, and then click one of 
the 3D rotation effects (see Figure 9-6).

Figure 9-5. To change a shape’s style, open the Shape Styles panel on the Shape Format tab of the Ribbon, and then 
click the style you want
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Rotating a Graphical Object
After inserting a graphical object, you can rotate it as needed. Click to select the object, and 
then drag the round rotation handle to the left to rotate counterclockwise (see Figure 9-7) or 
to the right to rotate clockwise.

Figure 9-6. Use the Shape Fill panel, the Shape Outline panel, or the Shape Effects panel (shown here with the 3-D 
Rotation panel) to make the shape look the way you want

Figure 9-7. Drag the round rotation handle with the curling arrow to the left or right to rotate a graphical object.  
The ScreenTip shows the amount of rotation
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Positioning a Graphical Object
If you don’t get a graphical object in precisely the right position when you insert it, you can 
easily move it afterward.

The quick way to reposition a graphical object is to click it and then drag it to where you 
want it. This works well most of the time, but for more precision you can also click the object 
to select it and then press an arrow key (for example, the left arrow key) to nudge it a small 
distance in the arrow’s direction.

When you need to control exactly where the object appears, Ctrl+click or right-click the 
object, and then click the Format command on the context menu to display the Format 
pane for the object (for example, click the Format Shape command to display the Format 
Shape pane, or click the Format Picture command to display the Format Picture pane). 
At the top of the pane, click the Size & Properties tab to display its contents, and then 
click the Size heading to display the controls for resizing the object and controlling its 
placement. Figure 9-8 shows the Size section in the Format Picture pane.

Figure 9-8. Use the controls in the Size section of the Format pane for an object to resize and position the  
object precisely



 
270 CHAPTER 9: Illustrating Your Worksheets with Pictures, SmartArt, and More 

Making a Picture Look the Way You Want It
After you insert a picture, you can use the controls that appear on the Picture Format tab of 
the Ribbon to make the picture look the way you want it. You can adjust the picture’s colors, 
apply a picture style to the picture, or crop the picture so that only part of it shows.

Adjusting a Picture’s Sharpness, Brightness, Contrast, and 
Colors
To adjust the sharpness, brightness, or contrast in a picture, click the picture to select it,  
and then choose Picture Format ➤ Adjust ➤ Corrections to open the Corrections panel 
(see Figure 9-9). Click the color correction you want.

Figure 9-9. To fix problems with a picture’s sharpness, brightness, or contrast, open the Corrections panel and choose 
the look you want

To change the colors in a picture, click it, choose Picture Format ➤ Adjust ➤ Color, and 
then click the effect you want. The Color panel has different sections for Color Saturation, 
Color Tone, and Recolor (for example, Grayscale or Sepia).
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To apply an effect such as paint strokes or a light screen to a picture, click the picture, 
choose Picture Format ➤ Adjust ➤ Artistic Effects, and then click the effect you want.

To change the picture’s transparency, click the picture, choose Picture Format ➤ Adjust ➤ 
Transparency, and then click the thumbnail that looks right.

To reset a picture to its original look, choose Picture Format ➤ Adjust ➤ Reset Picture, 
clicking the main part of the Reset Picture button. To reset the picture’s size as well as the 
look, choose Picture Format ➤ Adjust ➤ Reset Picture ➤ Reset Picture & Size.

Applying a Picture Style
To apply a picture style to a picture, click the picture, choose Picture Format ➤ Picture 
Styles ➤ Quick Styles to display the Quick Styles panel, and then click the picture style you 
want (see Figure 9-10). 

Figure 9-10. Choose the picture style from the Quick Styles panel in the Picture Styles group of the Picture Format tab 
on the Ribbon

Cropping a Picture
If you need the workbook to show only part of a picture rather than the whole picture, you 
can crop off the parts you don’t want. 

Excel lets you crop a picture in several ways, but this way is usually the easiest:

1. Click the picture to select it. Excel adds the Picture Format tab to  
the Ribbon.

2. Click the Picture Format tab if Excel has not displayed it.

3. Choose Picture Format ➤ Arrange ➤ Size ➤ Crop (if the window 
is narrow) or Picture Format ➤ Arrange ➤ Crop (if the window is 
wider); either way, click the main part of the Crop button rather than 
the pop-up button. Excel displays crop handles on the picture  
(see Figure 9-11).
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4. Drag the crop handles to make the cropping area contain the part of 
the picture you want to show:

	Shift+drag to crop the image proportionally.

	Option+drag to crop the image evenly around its center point.

	Option+Shift+drag to crop the image proportionally around its 
center point.

	Cmd+drag to crop the image in increments of worksheet cells. 

Tip If you make the crop area exactly the size you need, you can click and drag within the 
crop area to make a different part of the picture appear in it. You move the picture, not the crop 
area—much as if you were to reach through a window and move the landscape until the window 
displayed the part you wanted to see.

Figure 9-11. To crop a picture, choose Picture Format ➤ Arrange ➤ Size ➤ Crop and drag the crop handles until they 
encompass the part of the picture you want to keep
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5. Press Esc or click the Crop button again to turn off the Crop tool, or 
click elsewhere in the workbook to deselect the picture. Excel 
applies the cropping to the picture.

Saving Space by Compressing Pictures
When you insert pictures in a workbook (rather than linking them, as discussed earlier in this 
chapter), Excel saves a copy of each picture in the workbook. This can greatly increase the 
file size of the workbook. 

To keep the workbook’s file size down, you can compress the pictures and delete any areas 
you’ve cropped off. To do so, follow these steps:

1. Click a picture to make Excel add the Picture Format tab to the 
Ribbon.

2. Choose Picture Format ➤ Adjust ➤ Compress Pictures to display 
the Compress Pictures dialog box (see Figure 9-12).

Note You can also crop a picture to a particular aspect ratio or to fit into a shape. Choose Picture 
Format ➤ Arrange ➤ Size ➤ Crop, clicking the Crop pop-up arrow button rather than the main 
part of the button. On the pop-up menu that appears, choose Aspect Ratio and then click the aspect 
ratio, such as 1:1 or 16:10; or click Crop to Shape, and then click the shape you want.

Figure 9-12. Use the Compress Pictures dialog box when you want to reduce the file size of one or more pictures or 
when you want to delete the cropped areas of pictures
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3. In the Picture Quality pop-up menu, select the picture quality you want:

	Print (220 ppi). Compresses the pictures only a little, leaving 
them high enough quality for most purposes.

	On-screen (150 ppi). Compresses the pictures a bit further but 
leaves them looking good enough for use on the screen.

	Email (96 ppi). Compresses the pictures to the extent that they 
start to look bad but are OK for viewing on the screen at small 
sizes.

	Use Original Quality. Keeps the pictures at their current 
resolution. You’d use this setting for removing the cropped parts 
of pictures without changing the resolution.

4. Select the Delete cropped areas of pictures check box if you want 
to get rid of the areas you’ve cropped off. This is a good idea once 
you’re sure you won’t need to adjust the cropping of any pictures in 
the workbook to reveal more.

5. In the Apply to area, select the Selected pictures only option button 
if you want to affect only the picture you’ve selected. Normally, you’ll 
want to select the All pictures in this file option button to make Excel 
compress all the pictures in the workbook. 

6. Click the OK button. Excel closes the Compress Pictures dialog box 
and changes the quality or cropping as you specified.

Inserting SmartArt Diagrams
When you need to create an illustration such as an organization chart, a flowchart, or a Venn 
diagram, use the SmartArt feature. Follow these steps:

1. Position the insertion point or the selection where you want to insert 
the SmartArt object.

2. Choose Insert ➤ Illustrations ➤ SmartArt to display the SmartArt 
panel, and then click or highlight the category of SmartArt graphic 
you want: List, Process, Cycle, Hierarchy, Relationship, Matrix, 
Pyramid, or Picture. A panel opens, showing the available types. 
Figure 9-13 shows the Hierarchy panel, which includes various kinds 
of organization charts. 

Note Removing the cropped picture regions not only reduces the file size, but it can save 
embarrassment if the cropped areas contain sensitive information.
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3. Click the type of diagram you want. Excel inserts it in the workbook 
and displays the Text Pane (see Figure 9-14). 

Figure 9-13. In the SmartArt panel, choose the category of SmartArt diagrams you want, and then click the type  
of diagram

Note You can also start inserting a SmartArt diagram from the menu bar. Choose Insert ➤ SmartArt  
to display the SmartArt submenu, and then click List, Process, Cycle, Hierarchy, Relationship, Matrix, 
Pyramid, or Picture, as needed. Excel inserts the default SmartArt type for the category you choose. 
You can then change the type by choosing SmartArt Design ➤ Layouts ➤ Change Layout from 
the Ribbon.
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4. In the Text Pane, type the text for each item. As you do, Excel adds 
the text to the SmartArt diagram (see Figure 9-15).

Figure 9-14. When you insert a SmartArt diagram, Excel displays the Text Pane next to it so that you can enter text

Note If Excel doesn’t display the Text Pane, click the Text Pane button (the left-pointing arrow) 
at the upper-left corner of the SmartArt graphic to display the Text Pane. When the Text Pane is 
displayed, this button appears as a right-pointing arrow; you can click this button to hide the Text 
Pane when you don’t need it.
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5. Add any other items the SmartArt diagram needs. For example, 
to add the titles to the organization chart shown, click in each title 
placeholder, and then type the title.

6. Resize the SmartArt diagram to suit the workbook best. For example, 
you may need to make it the right size to go alongside related data.

7. If you need to change the layout of the SmartArt diagram, choose 
SmartArt Design ➤ Layouts ➤ Change Layout and select another 
layout from the Change Layout panel.

8. Apply a style to the SmartArt graphic by choosing a style from the 
SmartArt Styles box or the SmartArt Styles panel on the SmartArt 
Design tab.

When you have finished creating the SmartArt graphic, save the workbook as usual.

Adding Decorative Text with WordArt
If you need to add a design touch to a workbook, you can add a WordArt item. WordArt gives 
you an easy way to turn text into graphical items—for example, for your company logo.

To create a WordArt item, follow these steps:

1. Choose Insert ➤ Text ➤ WordArt from the Ribbon and then click 
the style you want in the WordArt panel (see Figure 9-16). Excel 
inserts a WordArt item in that style and adds the Shape Format tab to 
the Ribbon.

Figure 9-15. Add the text to the SmartArt diagram by typing in the Text Pane
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2. Type your text over the placeholder text (“Your Text Here”) in the 
WordArt box (see Figure 9-17).

3. Drag the WordArt item to where you want it. Move the mouse pointer 
over the item’s border, and then drag.

4. Resize the WordArt item as needed. You can either drag a side or 
corner handle or change the values in the Height box and Width box 
in the Size group on the Shape Format tab. Select the check box on 
the right side of the Size group if you want to preserve the aspect 
ratio of the WordArt item (so that Excel automatically adjusts the 
width when you change the height, and vice versa).

Figure 9-17. Type your text in the WordArt container and drag it to where you want it in the worksheet

Figure 9-16. Choose the WordArt style on the WordArt panel
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5. Format the WordArt item so it looks the way you want it:

	Move the mouse pointer over the Shape Styles box, click the 
panel button that appears, and then click the style you want  
to use.

	To change the WordArt item’s fill, choose Shape Format ➤ 
Shape Styles ➤ Shape Fill, and then click the fill you want.

	To change the WordArt item’s line color, weight, or type, choose 
Shape Format ➤ Shape Styles ➤ Shape Outline, and then 
choose suitable options.

	To apply an effect, choose Shape Format ➤ Shape Styles 
➤ Shape Effects, and then choose the effect you want. For 
example, click the 3-D Rotation submenu, and then choose a 
rotation effect.

	To change the text style, work with the controls in the WordArt 
Styles group on the Shape Format tab.

Positioning Graphical Objects Relative to Cells
As you’ve seen earlier in this chapter, you can drag a graphical object to wherever in the 
worksheet you need it to appear. But you can also connect the graphical object to the cells 
over which it appears, so that when you move the cells, the object moves too. This setting 
is handy when you need to keep the graphical object with particular cells. You can also have 
Excel resize the object when you resize the cells.

To control whether a graphical object moves and changes size with cells, follow these steps:

1. Ctrl+click or right-click the graphical object, and then click the Size 
and Properties command on the context menu to display the Size & 
Properties tab in the Format pane (see Figure 9-18). This pane varies 
depending on the object—for example, for a picture, it’s the Format 
Picture pane.
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2. If the Properties section is collapsed, click the Properties heading to 
expand the section.

3. In the Properties section, select the Move and size with cells option 
button, the Move but don’t size with cells option button, or the Don’t 
move or size with cells option button, as appropriate. 

4. Click the Close button (the × in the upper-right corner) to close the 
Format pane.

Figure 9-18. On the Size & Properties tab in the Format pane, choose whether to move and resize the graphical object 
with cells. You can also choose whether to print the object, lock it, or lock its text

Note In the Properties section of the Size & Properties tab in the Format pane, you can also clear 
the Print object check box if you want to avoid printing the graphical object. You can also select 
the Locked check box to lock the object, or the Lock text check box to lock the object’s text; these 
settings take effect only when you protect the worksheet against changes.



 
281CHAPTER 9: Illustrating Your Worksheets with Pictures, SmartArt, and More 

Arranging Graphical Objects to Control Which Is Visible
When you have placed multiple graphical objects in the same area of a workbook, you may 
need to arrange the order in which they appear in the workbook’s layers to control how they 
appear in relation to each other. For example, you may need to move a particular object 
to the front of the stack of layers, so that it appears on top of the other objects, or move 
another object back so that it appears behind one of its companion objects.

To change where an object appears in the layers, Ctrl+click or right-click the object, click 
or highlight the Bring to Front submenu or the Send to Back submenu, and then click the 
appropriate command:

	Bring to Front ➤ Bring to Front. Click this command to bring the item to 
the very front of the stack.

	Bring to Front ➤ Bring Forward. Click this command to bring the object 
forward by one layer. Give the command again as many times as 
necessary to bring the object up the stack to where you need it.

	Send to Back ➤ Send to Back. Click this command to send the item 
right to the back of the stack.

	Send to Back ➤ Send Backward. Click this command to send the object 
backward by one layer. As with the Bring Forward command, you may 
need to give this command multiple times to get the object to where you 
need it.

Summary
In this chapter, you learned how to work with graphical objects in Excel. You now know how 
to insert your own pictures from Photos or your Mac’s file system, how to insert shapes and 
format them, and how to position graphical objects where you want them. You also learned 
how to recolor, crop, and compress pictures; how to create SmartArt graphics and WordArt 
items to illustrate your workbooks; and how to position graphical objects relative to cells and 
arrange graphical objects to control which is visible.

This is the end of Part II of the book. In Part III, I show you how to analyze your data, how to 
share your workbooks with your colleagues, and how to automate your workbooks.
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Part III
Analyzing Data and Sharing 
and Automating Workbooks
In this part of the book, you learn to analyze, manipulate, and share the workbooks  
you’ve built.

In Chapter 10, we look at how to use Excel’s tables to create databases for storing 
information, sorting it, and filtering it to find the records you need. You also learn how to  
put Excel’s database functions to work with tables.

In Chapter 11, we cover how to analyze your data using four powerful tools. You learn to  
use data tables to assess the impact of one or two variables on a calculation, and learn  
to use scenarios to experiment with different sets of values without changing your core data. 
You also learn to use Goal Seek to solve single-variable problems and Solver to crack  
multi-variable problems.

In Chapter 12, we go through what PivotTables are and how you can use them to examine 
the data in your worksheets and find the secrets it contains. You learn how to create 
PivotTables either using Excel’s automated tool or by placing fields manually where you need 
them; how to change the PivotTable once you’ve created it; and how to sort and filter the 
data it contains.

In Chapter 13, we talk about ways to share your workbooks with others. We start  
by covering how to print worksheets, create PDF files from them, and export data to 
comma-separated values files. We then move on to sharing workbooks so that multiple 
people can work on them at the same time, and how to track the changes if necessary 
so that you can review them later. We finish by looking at how to merge changes from 
separate copies of the same workbook into one workbook and how to consolidate multiple 
worksheets into a single worksheet.

http://dx.doi.org/10.1007/978-1-4842-1019-2_10
http://dx.doi.org/10.1007/978-1-4842-1019-2_11
http://dx.doi.org/10.1007/978-1-4842-1019-2_12
http://dx.doi.org/10.1007/978-1-4842-1019-2_13
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Chapter 10
Creating Databases  
Using Tables
Packed with more than 16,000 columns and more than 1 million rows, each Excel worksheet 
has enough space to contain serious amounts of data—so it’s great for creating a database 
to store information and quickly find the items you need.

In this chapter, you’ll learn to use Excel’s tables to create databases for storing information, 
sorting it, and filtering it to show the information you need. You’ll also learn how to put 
Excel’s database functions to work with tables.

Creating Databases in Excel
When you need to store a lot of the same type of information in a worksheet, you can create 
a database in a table. For example, if you run a business, you can make a database of your 
customers and their orders.

The first step is to set up the table and to tell Excel that you’re creating a table rather than a 
regular worksheet. The next step is to add your data to the table.

Once the data is in the table, you can sort the table to reveal different aspects of its contents 
or filter it to identify items that match the criteria you specify.

Understanding What You Can and Can’t Do with Excel Tables
Before you start creating a table in Excel, it’s important to be clear about what you can and 
can’t do with Excel tables.

As you know, an Excel worksheet consists of rows and columns. To create a table on a 
worksheet, you make each row into a record—an item that holds all the details of a single 
entry. For example, in a table that records your sales to customers, a record would contain 
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the details of a purchase. You make each column a field in the table—a column for the 
purchase number, a column for the date, a column for the customer’s last name, and so on. 
Figure 10-1 shows part of an Excel table for tracking sales to customers.

Figure 10-1. Excel enables you to create tables, also called flat-file databases, which contain records such as the 
customer details shown here

This is what’s called a flat-file database: all the data in the database is stored in a single 
table rather than in separate tables that are linked to each other.

This means you can use Excel to create any database for which you can store all the data 
for a record in a single row. Because you have a million rows at your disposal, you can 
create large databases if necessary, but they may make Excel run slowly.

What you can’t do with Excel is create relational databases—ones that store the data 
in linked tables. A relational database is the kind of database you create with full-bore 
database applications such as FileMaker, Microsoft Access (on Windows), Oracle (on various 
operating systems), or SQL Server (on Windows). In a relational database, every record has 
a unique ID number or field that the application uses to link the data in the different tables.
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Creating a Table and Entering Data
In this section, you’ll look at how to create a table and enter data in it.

Creating a Table
To create a table, follow these steps:

1. Create a workbook as usual. For example, you can:

	Create a new blank workbook. Press Cmd+N or choose File ➤ New 
Workbook from the menu bar. You can also click File toward the 
left end of the title bar, click Blank Workbook on the New tab of the 
Microsoft Excel dialog box, and then click Create.

	Create a workbook based on a template. Open the Microsoft 
Excel dialog box by clicking File toward the left end of the title bar, 
pressing Cmd+Shift+P, or choosing File ➤ New from Template. 
You can then click the template you want to use, and then  
click Create.

	Open an existing workbook and use Save As to create a copy of it.

2. Name the worksheet on which you’ll create the table. Double-click 
the worksheet tab, type the name you want (up to 31 characters, 
including spaces), then press Return to apply the name.

3. Type the headings for the table. For example, if the table will contain 
customer names and addresses, you’d type fields such as Last 
Name, First Name, Middle Initial, Title, Address 1, and so on. Try to 
get all the fields in place at this point; you can add columns to the 
table later, but you’ll then need to add extra data to the existing 
records.

4. Format the headings differently from the rows below them. For 
example, click the row header for the heading row, then press 
Cmd+B to apply boldface.

Note Earlier versions of Excel included a data-entry form that simplified the process of adding 
data to a form and editing records. Unfortunately, Microsoft has removed this feature from Excel 
2016, so you need to enter data in your table by working along the rows.

Note Usually, it’s easiest to put the headings in the first row of the worksheet, but if you need to 
have information appear above the table, leave rows free for it.
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5. Select the headings and at least one row below them.

6. Choose Insert ➤ Tables ➤ Table from the Ribbon or Insert ➤ Table 
from the menu bar to display the Create Table dialog box  
(see Figure 10-2).

Figure 10-2. In the Create Table dialog box, verify that the Where is the data for your table? box shows the correct 
range and that the My table has headers check box is selected before clicking OK

7. Make sure that the Where is the data for your table? box shows the 
correct range. If not, either type the correct range into the box or 
click and drag in the worksheet to enter it.

8. Select the My table has headers check box (assuming your table has 
headers, as in the example).

9. Click OK. Excel closes the Create Table dialog box and makes the 
following changes:

	Creates the table.

	Gives the table a default name, such as Table1 or Table2.

	Turns the header row into headers with pop-up buttons.

	Applies a table style with shading based on the workbook’s theme. 
You can change the style later as needed.

	Displays the Table tab of the Ribbon, which contains controls for 
working with tables.

10. Rename your table by following these steps:

a. Choose Table ➤ Properties ➤ Table Name, double-clicking in the 
Name text box to select the table name.
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b. Type the new name for the table. As with chart names, the table 
name must be unique in the workbook, must start with a letter or an 
underscore, and cannot contain spaces or symbols.

c. Press Return to apply the table name. You can also simply click 
elsewhere.

Customizing the Table’s Looks
At this point, you can start entering data in the table (as discussed next)—but before you do, 
you may want to change the way it looks. To do so, follow these steps:

1. Click anywhere in the table.

2. Click the Table tab of the Ribbon if it’s not already displayed.

3. If a suitable style appears in the Table Styles box on the Ribbon, click 
it. If not, hold the mouse pointer over the Table Styles box to display 
the panel button, then click the panel button to display the Table 
Styles panel (see Figure 10-3). Click the style you want to apply.

Figure 10-3. You can format a table quickly by applying one of Excel’s table styles from the Table Styles panel on the 
Table tab of the Ribbon. Scroll down the panel to see the other styles



 
290 CHAPTER 10: Creating Databases Using Tables 

4. In the Table Style Options group on the Table tab of the Ribbon, 
select the check box for each table style option you want to use:

	Header Row. Select this check box to display the header row. This is 
almost always useful.

	Total Row. Select this check box to add a row labeled Total immediately 
after the table’s last row. This is useful when you need to add a total 
formula or another formula in the last row. To add a formula, click a cell 
in the Total row, click the pop-up button that appears, then click the 
formula you want on the pop-up menu (see Figure 10-4).

	Banded Rows. Select this check box to apply a band of color to 
every other row. This helps you read the rows of data without your 
eyes wandering to another row. Some table styles apply banding to 
the rows automatically.

	First Column. Select this check box if you want the first column to 
have different formatting. You may want to do this if the first column 
contains the main field for identifying each record (for example, a 
unique number).

Tip The pop-up menu in the Total row of a table gives you instant access to the most widely 
used functions in databases—Average, Count, Count Numbers, Max, Min, Sum, StdDev (Standard 
Deviation), or Var (calculating variance based on a sample). You can also click the More Functions 
item at the bottom of the pop-up menu to display the Formula Builder, from which you can access 
the full range of Excel’s functions. For example, you can insert the COUNTBLANK( ) function to count 
the number of blank cells in a column. You might do this to ensure that a column of essential data 
contains no blanks.

Figure 10-4. Adding a Total row to a table lets you quickly insert functions in the row’s cells. Excel changes the header 
row to column labels when you scroll down the worksheet
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	Last Column. Select this check box if you want the last column to 
have different formatting. Usually, you’ll want this only if the last 
column contains data that is more important in some way than the 
data in the other columns.

	Banded Columns. Select this check box to apply a band of color 
to every other column. This is sometimes helpful but usually less 
helpful than banded rows. (Don’t use both—the effect is seldom 
useful.)

When you’ve finished choosing a style and options for the table, save your work as usual.

Entering Data in a Table
A table is essentially an Excel worksheet at heart, so you can enter data in the table by using 
the standard techniques you’ve learned in the earlier chapters of this book. For example, 
click a cell, then type data into it; or, if you have the data in another worksheet, copy it and 
paste it in. 

When you enter data in the row immediately after the last row in the table, Excel 
automatically expands the table to include that row. To add a row within the table, click a cell 
in the row above which you want to add the new row, then choose Insert ➤ Rows from the 
menu bar. Again, Excel automatically expands the table to include the new row.

To insert a column in the table, click a cell in the column before which you want to add the 
new column, then choose Insert ➤ Columns from the menu bar. Once more, Excel 
automatically expands the table.

Connecting a Table to an External Data Source
If you have your data in an external data source, such as a relational database, you can 
import the data into an Excel table to work with it. You can then refresh the data in the Excel 
table with the latest data from the database.

Tip You can quickly select a row, a column, or an entire table with the mouse. To select a row, 
move the mouse pointer to the left part of a cell in the table’s leftmost column, then click with the 
horizontal arrow that appears. To select a column, move the mouse pointer over a column heading, 
then click with the downward arrow that appears. To select the whole table, move the mouse 
pointer over the upper-left cell in the table, then click with the diagonal arrow that appears.
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Connecting to a Database
To connect to a relational database, such as a Microsoft Access database or an Oracle 
database, you need to install an Open Database Connectivity (ODBC) driver for Excel. You 
can then establish the connection, import the data, and refresh it as needed.

Getting and Installing an ODBC Driver
Before you can import data into a table in Excel, you must install an ODBC driver. This is a 
piece of software that enables Excel to connect to the database and pull data out of it.

Microsoft doesn’t provide ODBC drivers for Excel for Mac, so you need to get one from 
a third-party vendor. To find the latest list of compatible ODBC drivers, open your web 
browser and go to https://support.office.com/en-gb/article/ODBC-drivers-that-are-
compatible-with-Excel-for-Mac-9fa6bc7f-d19e-4f7f-9be4-92e85c77d712. At this writing, 
there are three providers:

	OpenLink Software (http://www.openlinksw.com/)

	actualtechnologies LLC (http://www.actualtech.com/)

	Simba Technologies Inc. (http://www.simba.com)

Each offers several different ODBC drivers for different types of database, so make sure 
you get the right one. Normally, you’ll want to start by getting the trial version to make sure 
it does what you need, then pay for the full version. Some trial versions are limited by time; 
others are limited by the amount of data they’ll return. Either way, you’ll eventually need to 
buy the full version.

Establishing a Connection to a Database
To establish a connection to a database, position the active cell on the appropriate 
worksheet in the workbook you want to use, then choose Data ➤ Get External Data ➤ 
New Database Query ➤ SQL Server ODBC to open the dialog box for setting up the 
connection. Figure 10-5 shows the iODBC Data Source Chooser dialog box, which you use 
to establish a connection using OpenLink Software’s ODBC driver.

https://support.office.com/en-gb/article/ODBC-drivers-that-are-compatible-with-Excel-for-Mac-9fa6bc7f-d19e-4f7f-9be4-92e85c77d712
https://support.office.com/en-gb/article/ODBC-drivers-that-are-compatible-with-Excel-for-Mac-9fa6bc7f-d19e-4f7f-9be4-92e85c77d712
http://www.openlinksw.com/
http://www.actualtech.com/
http://www.simba.com/
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Use the controls in the dialog box to specify the connection to the data source. The specifics 
depend on the ODBC driver you’re using.

When you have set up the connection, click the Return Data button. Excel displays the 
Import Data dialog box (see Figure 10-6). In this dialog box, you can choose where to place 
the data that the connection returns:

	Existing sheet. To put the data on an existing worksheet, select this 
option button, then click the cell you want to use as the upper-left 
corner of the range. You can click the Collapse Dialog button to get the 
Import Data dialog box out of the way if necessary, but usually it’s easy 
enough just to work around it.

	New sheet. Select this option button if you want to put the data on a 
new sheet. Excel creates this sheet for you and starts inserting the data 
at cell A1.

	PivotTable. Select this option button if you want to create a PivotTable 
from the data. This option button is available only for some types of 
database connections. (PivotTables are discussed in Chapter 12.)

Figure 10-5. Choose your database in the dialog box for the ODBC driver you installed. This screen shows the iODBC 
Data Source Chooser dialog box

http://dx.doi.org/10.1007/978-1-4842-1019-2_12


 
294 CHAPTER 10: Creating Databases Using Tables 

If you need to choose options for how Excel returns the data, click the Properties button in 
the Import Data dialog box to display the External Data Range Properties dialog box  
(see Figure 10-7). Here you can choose the following options:

	Name. In this text box, type the name you want to give to the external 
data range. This name is to help you identify the data range; it becomes 
more important when you use multiple data ranges.

	Query Definition. In this area, select the Save query definition check 
box if you want to save the query; normally, you’ll want to do this so 
you don’t have to set it up again. If the query uses a password, you can 
select the Save password check box to store the password too; you 
may prefer (or be forced) to enter the password each time for security.

	Refresh Control. In this area, select the Prompt for file name on refresh 
check box if you want Excel to prompt you to enter the file name when 
you refresh the data. Select the Refresh data when opening the file check 
box if you want Excel to refresh the data automatically each time you 
open the workbook; this is usually helpful if you normally want to work 
with the latest data. Select the Remove external data from worksheet 
before saving check box if you want Excel to remove the external data 
from the workbook when you save it—for example, because you’re using 
the workbook to manipulate data you don’t want others to see in it.

	Data Formatting and Layout. In the top part of this area, select the 
Include field names check box and the Include row numbers check box 
if you want to include these items, as is usually helpful. Select the Adjust 
column width check box if you want Excel to adjust the column width to 
fit the data. Select the Import HTML table(s) only check box if you want 
to import only tables when importing from an HTML data source.

	If the number of rows in the data range changes upon refresh. In this 
area of the Data Formatting and Layout area, select the appropriate 
option button: Insert cells for new data, delete unused cells, Insert entire 
rows for new data, clear unused cells, or Overwrite existing cells with 
new data, clear unused cells. Normally, the Insert cells for new data, 
delete unused cells option button is the best choice.

Figure 10-6. In the Import Data dialog box, choose whether to put the data on an existing worksheet, on a new worksheet, 
or in a PivotTable. You can click the Properties button to set the properties for the data returned from the database
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	Fill down formulas in columns adjacent to data. Select this check box 
if you want Excel to automatically fill in formulas down the cells of 
columns next to the data—for example, to continue a SUM formula 
you’ve entered.

	Use table. Select this check box to have Excel put the external data in a 
table. This is what you’ll usually want.

When you’ve finished choosing options in the External Data Range Properties dialog box, 
click the OK button to close it and return to the Import Data dialog box. Then click the OK 
button to close this dialog box. Excel brings in the data from the data source.

Note Some of the options in the External Data Range Properties dialog box are available only for 
certain types of connections.

Figure 10-7. In the External Data Range Properties dialog box, name the connection, choose whether to save the query 
definition, decide when to refresh the data, and choose the layout to use
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Refreshing the Data from a Database
If you’ve set the table to update the data from the database automatically at intervals or 
when you open the workbook, Excel takes care of the refreshing. If you’ve set the table for 
manual refreshing, or if you need to pull the latest data into the table right this moment, 
you can refresh the table manually by using the commands on the Data ➤ Connections ➤ 
Refresh menu. Click the Refresh All command to refresh all the tables, or click the Refresh 
command to refresh just the data in the current table.

If a refresh seems to be taking too long, choose Data ➤ Connections ➤ Refresh ➤ Cancel 
Refresh to cancel it.

Importing Data from a FileMaker Pro Database
If you need to pull data from a FileMaker Pro database into a table, choose Table ➤ Get 
External Data ➤ From FileMaker to launch the FileMaker Pro Import Wizard. Follow 
through the steps of this Wizard as discussed in the section “Importing Data from a 
FileMaker Pro Database” in Chapter 1.

Resizing a Table
When you’ve created a table, Excel normally resizes it for you automatically when you add or 
delete rows or columns. For example, when you add a record by using the Form dialog box, 
Excel expands the table to include it.

Excel also expands the table automatically if you add data to the row after the current last row 
in a table that doesn’t have a Total row. Excel calls this feature Table AutoExpansion. If you 
don’t want Excel to do this, click the AutoCorrect actions button that appears below and to the 
right of the first cell in the added row, then click Undo Table AutoExpansion (see Figure 10-8). 
Click the actions button again, then click Stop Automatically Expanding Tables.

Note To import data from a FileMaker Pro database, you must have FileMaker Pro installed on the 
Mac you’re running Excel on.

Note When you add a new row to a table using Table AutoExpansion, Excel makes the change 
only when you start typing data in the row. When you do, Excel applies the style to the row, and you 
can see that it’s part of the table. But until you start typing, it’s just another plain row.

http://dx.doi.org/10.1007/978-1-4842-1019-2_1
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Sorting a Table by One or More Fields
When you need to examine the data in your table, it’s often useful to sort it. Excel lets you 
sort a table either quickly by a single field or by using multiple fields.

Sorting Quickly by a Single Field
To sort a table by a single field, click any cell in the column you want to sort by, then choose 
Data ➤ Sort & Filter ➤ Sort A to Z. This produces a sort in ascending order (A to Z, low 
values to high values, early dates to later dates, and so on). To reverse the sort to descending 
order, choose Data ➤ Sort & Filter ➤ Sort Z to A.

After you sort, the table remains sorted that way until you change it.

Sorting a Table by Multiple Fields
Often, it’s useful to sort your table by two or more fields at the same time. For example, in 
a customer database, you may need to sort your customers first by state and then by city 
within the state.

Note To turn Table AutoExpansion back on, choose Excel ➤ Preferences or press Cmd+,  
(Cmd and the comma key). In the Excel Preferences dialog box, click the Tables & Filters icon in the 
Formulas and Lists area to display the Tables preferences pane. Select the Automatically expand 
tables check box, then click the OK button.

Tip If you need to be able to return a table to its original order, include a column with sequential 
numbers in it. These numbers may be part of your records (for example, sequential sales numbers 
for transactions) or simply ID numbers for the records. In either case, you can use AutoFill to enter 
them quickly. To return the table to its original order, you can then sort it by this column.

Figure 10-8. You can use the AutoCorrect actions button both to undo Table AutoExpansion and to turn it off
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To sort by multiple fields, follow these steps:

1. Choose Data ➤ Sort & Filter ➤ Sort from the Ribbon or Data ➤ 
Sort from the menus to display the Sort dialog box. Figure 10-9  
shows the Sort dialog box with two criteria entered and a third 
criterion under way.

Figure 10-9. In the Sort dialog box, you can set up exactly the sort criteria you need to identify data in your database

2. Set up your first sort criterion using the controls on the first row of 
the main part of the Sort dialog box. Follow these steps:

a. Open the Column pop-up menu in the Sort by row, then click the 
column you want to sort by first. For example, click the State column.

b. Open the Sort On pop-up menu in the same row, then click what 
you want to sort by: Values, Cell Color, Font Color, or Cell Icon. In 
most cases, you’ll want to use Values, but the other three items are 
useful for tables to which you’ve applied conditional formatting.

c. Open the Order pop-up menu on the same row, then click the sort 
order you want. If you choose Values in the Sort On pop-up menu, 
you can choose A to Z for an ascending sort, Z to A for a descending 
sort, or Custom List. Choosing Custom List opens the Custom List 
dialog box, which you can use to choose a custom list by which to 
sort the results. For example, you could use a custom list of your 
company’s products or offices to sort the database into a custom 
order rather than being restricted to ascending or descending order.
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d. If you need the sort to be case sensitive (so that “smith” appears 
before “Smith,” and so on), click the Options button. In the dialog 
box that opens (see Figure 10-10), select the Case Sensitive  
check box, then click the OK button.

Figure 10-10. Select the Case sensitive check box in this dialog box if you want to treat lowercase letters differently 
than their uppercase versions

3. Click the Add (+) button to add a second line of controls to the main 
part of the Sort dialog box.

4. Set up the criterion for the second-level sort on the Then by line 
using the same technique. For example, set up a second-level sort 
using the City column in the database.

5. Set up any other criteria needed by repeating steps 3 and 4.

6. Click the OK button to close the Sort dialog box. Excel sorts the data 
using the criteria you specified.

Identifying and Removing Duplicate Records in a Table
When you’ve created a large table, you may need to check it for duplicate records and 
remove those you find. Excel provides a Remove Duplicates feature that saves your having 
to comb the records by hand.

Note When you’re sorting data that’s not in a table, there are two main differences. First, the 
My list has headers check box in the Sort dialog box is available, and you must select it if the 
data range you’re sorting includes a header row. (Otherwise, Excel sorts the headers into the data 
range.) Second, you can select the Sort left to right option button in the Sort Options dialog box to 
sort columns rather than rows, a choice that’s not available in a data table.
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To remove duplicate records from a table, follow these steps:

1. Click any cell in the table.

2. Choose Table ➤ Data Tools ➤ Remove Duplicates from the Ribbon 
or Data ➤ Table Tools ➤ Remove Duplicates from the menu bar to 
display the window shown in Figure 10-11.

Caution Two warnings before removing duplicate values: First, make sure you have a backup 
copy of your database workbook—for example, use Finder to copy the current version of a file to a 
safe location. Second, be certain you know which fields in the table should contain unique values 
and which can contain duplicate values. For example, a customer ID number field must be unique, 
because each customer has a different ID number; but a customer last name field can’t reasonably 
be unique, because many customers will likely share last names. Most databases need a unique ID 
number or code of this type.

Figure 10-11. Use this window to locate duplicate values in columns that should contain only unique values. The 
window’s title bar shows the name of the data table

3. If the Select All check box contains a check mark, click the check 
box to remove the check mark. Doing this clears all the other check 
boxes.

4. Select the check box for each column you want to check for 
duplicates. The readout at the bottom of the dialog box shows the 
number of duplicates.

Tip Normally, it’s best to check a single column at a time for duplicate values. Make sure that the 
column is one that must contain a unique value.
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5. Click the Remove Duplicates button if you want to remove the 
duplicates.

6. Repeat the process with another field if necessary.

7. When you have finished removing duplicates, click the red Close 
button at the left end of the title bar to close the window.

Filtering a Table
When you need to find records in a table that match the terms you specify, you can filter it. 
Filtering makes Excel display only the records that match your search terms, hiding all the 
other records. 

To make filtering easy, Excel provides a feature named AutoFilter. To use AutoFilter, follow 
these steps:

1. Click a cell in the table.

2. Click the Data tab of the Ribbon to display its contents.

3. In the Sort & Filter group, click the Filter button so that it looks 
pushed in; if not, click the main part of the button. Selecting this 
button makes Excel display a pop-up button on each column 
heading in the table.

4. On the column you want to use for filtering, click the pop-up button 
to display the AutoFilter window (shown on the left in Figure 10-12). 
The AutoFilter window’s title bar shows the name of the field you 
clicked.

Note You can also search for records by using Excel’s Find feature. Choose Edit ➤ Find ➤ Find 
from the menu bar or press Ctrl+Shift+F to display the Find dialog box, type your search term in the 
Find What box, then click the Find Next button. Filtering displays all the matching records together 
rather than spread out in the table, so it’s often more convenient than using Find.

3. If the Select All check box contains a check mark, click the check 
box to remove the check mark. Doing this clears all the other check 
boxes.

4. Select the check box for each column you want to check for 
duplicates. The readout at the bottom of the dialog box shows the 
number of duplicates.

Tip Normally, it’s best to check a single column at a time for duplicate values. Make sure that the 
column is one that must contain a unique value.
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5. Click the type of sorting or filtering you want to apply:

	Sort. Click the type of sort you want to apply. Normally, you’ll want 
to click either the Ascending button or the Descending button. But 
if your data table uses colors, you can sort by color instead—just 
choose the color in the By color pop-up menu in the Sort area.

	Filter. If you want to filter the table by color, choose the color in the 
By color pop-up menu. Otherwise, open the pop-up menu that 
appears as Choos... in the left part of Figure 10-12, then choose the 
comparison from it. For example, choose Equals to set a filter that 
picks particular states, or choose Begins With to set a filter that 
selects cities that start with text you specify. Use the fields in the 
Custom AutoFilter window to set up the rest of the comparison; the 
right screen in Figure 10-12 shows an example that filters by Equals 
AK or Equals AL, returning the records that have the state AK or the 
state AL.

Note The filter comparisons depend on the contents of the column you selected in the table. For 
example, if the column contains numbers, the comparisons include the mathematical comparisons 
Greater Than, Greater Than or Equal To, Less Than, Less Than or Equal To, Between, Top 10, Bottom 
10, Above Average, and Below Average. If the column contains dates, the comparisons include 
Before, After, Between, Tomorrow, Next Week, Next Month, and Next Year.

Figure 10-12. To apply filtering, click the pop-up arrow on a column heading to display the AutoFilter window (left). 
In the Filter area, open the first pop-up menu, and choose the comparison you want (right). You can then add further 
comparisons as needed
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When you’ve specified the details of the filter, Excel applies it to the table and reduces the 
display to those rows that match the filter. Excel displays a filter symbol in place of the  
drop-down button on the column that contains the filtering (as on the State column heading 
in Figure 10-13).

Figure 10-13. The filter symbol (shown on the State column heading here) indicates that you’re filtering the table  
by that column

To remove filtering from a single column, click the filter symbol on the column heading, then 
click the Clear Filter button in the AutoFilter window.

To remove filtering from the table as a whole, choose Data ➤ Sort & Filter ➤ Filter, 
deselecting the Filter button in the Sort & Filter group.

Using Database Functions with Tables
As you saw in Chapter 6, Excel contains 12 database functions for use with tables. Each of 
these functions requires three arguments:

	database. This argument tells the function which database or table to 
use. You can specify database as either a range (for example, A1:F4) or 
by the table’s name (for example, “Customer_Sales”).

	field. This argument tells the function which field in the database you’re 
interested in. For example, you could specify “State” to use the field 
named State.

	criteria. This argument tells the function the range in which to find the 
criteria for the comparison. The range must have at least one column 
label and at least one cell under the column label; this is where you 
specify the condition.

Note Usually it’s best to place the criteria range above the table rather than below it, because 
placing the range below the table can prevent the Table AutoExpansion feature from working. 
Placing the criteria range above the table also helps make sure that it doesn’t overlap the table’s 
own range. Placing the criteria range to the side of the table also works, but it makes the range 
hard to view unless the table is relatively narrow.

http://dx.doi.org/10.1007/978-1-4842-1019-2_6
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Figure 10-14 shows an example of using a database function. As you’ll remember from 
Chapter 6, the DAVERAGE( ) function returns the average value of the cells in the specified 
field that match your criteria. Here, the DAVERAGE(A4:C8, “Satisfaction”, A1:C2) function in 
cell C9 works like this:

	A4:C8 specifies the range of the table.

	“Satisfaction” tells the function to use the Satisfaction field (in column C).

	A1:C2 tells the function to look for the criteria in the range A1:C2. Cell 
B2 gives the criterion to use: the number in the Staff column must be 
less than 20 (Staff>20).

	Given this information, the DAVERAGE( ) function takes the Satisfaction 
values of the two rows for which Staff>20 is true (San Francisco and 
Oakland) and averages them, returning 8.4.

Figure 10-14. To use a database function such as DAVERAGE( ), you must set up a criteria range in the worksheet. 
The best place for the criteria range is above the table

Summary
In this chapter, you learned how to use Excel’s tables to create a database in which you can 
store information, sort it, and apply filtering to find the records you need. You also learned 
how to use Excel’s database functions with tables.

In the next chapter, I’ll show you how to solve business questions using what-if analysis, the 
Goal Seek feature, and the Solver add-in. Turn the page when you’re ready to start.

http://dx.doi.org/10.1007/978-1-4842-1019-2_6
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Chapter 11
Solving Business Questions 
with What-If Analysis, Goal 
Seek, and Solver
For much of your work with Excel, you’ll probably want to manipulate the hard data you 
already have, as you’ve been doing so far in the book. But at other times, you’ll need to 
ask questions of your data—for example, by how much do you need to raise prices to 
boost your revenue by a certain amount, or what will happen if you cut 10 percent off your 
manufacturing costs?

In this chapter, we’ll look at four tools Excel gives you for performing what-if analysis:

	Data tables. Use a data table when you want to assess the impact of 
one or two variables on a calculation.

	Scenarios. Use scenarios when you want to experiment with different 
data in your worksheet without changing the core data that you already 
have.

	Goal Seek. Use Goal Seek when you need to make one cell’s value 
reach a particular figure by changing one other value.

	Solver. Use the Solver add-in tool when you need to make one cell’s 
value reach a particular figure by changing two or more other values.

Assessing the Impact of Variables Using Data Tables
A data table is a tool you can use to calculate how one or two variables change the result 
of a calculation. Use a data table when you want to see the range of results in a worksheet 
rather than seeing a single result at a time.
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Creating a Data Table with One Variable
When you need to see how only one variable changes the result of a calculation, you can 
quickly create a data table. You place the input values—the values you want to test—in 
either a row or a column, and then tell Excel where to find them.

Creating a data table seems odd at first, but you’ll quickly get the hang of it. Try this example 
of putting together a data table that uses one variable.

First, create a new worksheet and set up the straightforward =FV( ) formula shown in 
Figure 11-1 to calculate the future value of an investment that pays 10% interest over  
12 months, has a period of 60 months, and takes $600 out of your pay packet every month. 
Follow these steps:

1. Enter these data labels in the following cells:

A1. Interest Rate

A2. Months

A3. Payment

A4. Future Value

Figure 11-1. The example calculation for the data table uses the FV( ) function to calculate the future value of a 
$600-a-month investment

2. Enter the formula =10%/12 in cell B1. Apply the Percentage number 
format to this cell and make the cell show two decimal places so 
that you see 0.83% rather than the 1% that Excel typically displays 
(which makes the calculation visually confusing).

3. Enter the value 60 in cell B2.

4. Enter the value -600 in cell B3. Apply the Currency number format to 
make its meaning visually clear.

5. Enter the FV function in cell B4: =FV(B1,B2,B3).
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So far, so good. Now set up the input values for the data table. Follow these steps:

1. Enter the label Months in cell A6.

2. Enter the values for the data table in cells A7:A10:

A7. 48

A8. 60

A9. 72

A10. 84 

Your worksheet should now look like the one in Figure 11-2.

Tip It’s easy enough to type in the input values for this small data table, but if you want to extend 
the sequence, try entering 48 in cell A7 and 60 in cell A8, selecting the cells, and then dragging the 
AutoFill handle to fill in the remaining cells.

Figure 11-2. Enter the input values for the data table in cells A7:A10

Now you can enter the formula that uses the data table. For the data table to work, you need 
to place the formula in the cell where Excel expects to find it:

	Column-oriented data table. Enter the formula in the row above the first 
input value, and in the next column to the right. In the example, this is 
cell B6.

	Row-oriented data table. Enter the formula in the column to the left of 
the first input value and in the next row down.
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In this case, we’re creating a column-oriented data table, so we need to enter the formula 
in cell B6. Enter the formula =FV(B1,A5,B3), as shown in Figure 11-3—in other words, the 
same formula as in cell B4, but using cell A5 instead of cell B2 to supply the number of 
months. 

Figure 11-3. Enter the formula in the cell above and to the right of the input values

Figure 11-4. In the Data Table dialog box, enter the row input cell or the column input cell for the data table you’re 
creating

Note  When you enter the formula for the data table, Excel usually displays either a value that’s 
clearly wrong or an error value. In this example, the formula cell displays the result $0.00, because 
cell A5 is blank and so is supplying a zero value for the Months argument. In other formulas, a zero 
value produces an error value. This isn’t a problem, as you’ll see in a moment.

Now you’re ready to set up the data table. Follow these steps:

1. Select the range of cells that contains the input values and the 
formula. In this example, select the range A6:B10.

2. Choose Data ➤ Data Tools ➤ What-If Analysis ➤ Data Table from 
the Ribbon or Data ➤ Data Table from the menu bar to display the 
Data Table dialog box (see Figure 11-4).
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3. Click in the Column input cell box, and then click the cell you used 
as the input value—in this case, cell A5. Excel enters an absolute 
reference, $A$5.

Figure 11-5. After you create the data table, the results appear alongside the input values

Note When you’re creating a row-oriented data table, click in the Row input cell box in the Data 
Table dialog box, and then click the cell you used for the input value.

4. Click the OK button to close the Data Table dialog box. Excel 
enters the array formula {=TABLE(,A5)} in each cell alongside a cell 
containing an input value.

5. Apply the Currency number format to the results cells so that the 
results appear as dollar values.

Figure 11-5 shows the data table with the results in place.

Creating a Data Table with Two Variables
When you need to analyze what happens when two pieces of information used in a 
calculation change, create a data table with two variables. For example, when calculating 
an investment with the FV( ) function, you may need to look at not only different numbers of 
months for the period but also different payments.
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To create a two-variable data table, you place one set of input data down a column to the 
left of the table and the other set of input data across a row above the table. For example, 
Figure 11-6 shows a two-variable data table that uses the FV( ) function to calculate the 
future value of an investment:

	The range D6:D11 contains the input values for the Period argument  
(48, 60, 72, 84, 96, or 108 months).

	The range E5:I5 contains the input values for the Payment argument 
(-$500.00, -$550.00, -$600.00, -$650.00, or -$700.00). These cells are 
formatted with the Currency number format.

	Cell A7 is the row input cell, and cell A9 is the column input cell. When 
you create the data table by choosing Data ➤ Data Tools ➤ What-If 
Analysis ➤ Data Table from the Ribbon or Data ➤ Data Table from the 
menu bar, you specify both the row input cell and the column input cell 
in the Data Table dialog box.

	Cell D5 contains the formula for the data table: =FV(B1,A9,A7).

	Each results cell contains the formula {=TABLE(A7,A9)}.  

Figure 11-6. In a two-variable data table, you enter one set of input values down a column (here, column D) and the 
other set of input values in a row (here, row 5). The formula goes in the cell where the column and row intersect (here, 
cell D5)

Note When you no longer need a data table, select the table, and then press Delete or choose 
Home ➤ Editing ➤ Clear ➤ Clear All.
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Examining Different Scenarios in a Worksheet
Often, when you’ve built a worksheet, you’ll want to experiment with different data in it. For 
example, if you’re setting budgets, you may need to play around with different figures for the 
different departments to get the overall balance you require.

You can experiment with different data by changing the values directly in your worksheet—
but then you may need to restore your original values afterward. Another approach is to 
create multiple copies of the worksheet (or of the workbook) and then change the values in 
the copies, leaving the original untouched. This works fine, but if you then need to change 
the original worksheet (for example, adding another column of data), the changes quickly 
become messy.

Instead of working in these awkward ways, you can use Excel’s scenarios. A scenario is a 
way of entering different values into a set of cells without changing the underlying values. 
You can switch from one scenario to another as needed, and you can merge scenarios from 
different versions of the same worksheet into a single worksheet.

Creating the Worksheet for Your Scenarios
Start by creating the workbook and worksheet you’ll use for your scenarios. If you have an 
existing workbook with the data in it, go ahead and open it. Set up the data and formulas in 
your worksheet as usual.

Figure 11-7 shows the sample worksheet this section uses as an example. The worksheet 
summarizes the financial returns from a modest portfolio of rental properties.

Tip To make your scenarios easy to set up and adjust, define a name for each cell that you will 
change in the scenario. Click the cell, choose Insert ➤ Name ➤ Define to display the Define 
Name dialog box, and then work as described in the “Assigning a Name to a Cell or Range” section 
in Chapter 3. For example, type the name in the Enter a name for the data range text box, and 
then click the Add (+) button to add the name and leave the dialog box open so that you can click 
another cell and define a name for it, too.

http://dx.doi.org/10.1007/978-1-4842-1019-2_3
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Here’s what you see on the worksheet:

	The Property Address column shows each property’s address.

	The Monthly Rent column shows each property’s monthly rent. Cell B10 
contains a SUM( ) formula to produce the total rent. Each of the cells here 
has a name to make it easy to recognize—Rent_Lincoln, Rent_Pacific_A, 
and so on.

	The Operating Costs column shows the monthly operating cost for 
each property, including all mortgage costs and other financial horrors. 
Cell C10 uses a SUM( ) formula to produce the total running cost. The 
numbers in this column are rounded. Each of these cells has a name: 
Costs_Lincoln, Costs_Pacific_A, and so on. Again, this is so that we can 
refer to the cells easily and clearly.

	The Property Profit column shows how much profit each rental unit 
returns after subtracting the operating cost from the rent (for example, 
cell D5 contains the sum =B5-C5). The numbers in this column are 
rounded. Cell D10 uses a SUM( ) formula to return the total profit.

	The Property Profitability column shows the property’s profitability as a 
percentage. To produce the profitability figure, we divide the Property 
Profit value by the Monthly Rent value—for example, cell E5 contains 
the formula = D5/B5. At the bottom of the column, cell E10 uses an 
AVERAGE( ) formula to show the average profitability of the properties.

	The Financial Contribution column shows each property’s contribution 
to the total profit as a percentage. To produce the contribution figure, we 
divide each property’s profit by the total profit in cell D10. For example, 
cell F9 contains the formula =D9/D$10, using a mixed reference to keep 
the row absolute when copying the formula. Cell F10 contains a SUM( ) 
formula that adds the percentages, letting us see that they total 100%.

Figure 11-7. To start using scenarios, create a worksheet containing your existing data and the formulas needed
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Times are bad, and the total profit is too low. So, we’ll use scenarios to see how we can 
improve matters by raising rents and shaving costs.

Opening the Scenario Manager Dialog Box
When you’re ready to start working with scenarios, choose Data ➤ Data Tools ➤ What-If 
Analysis ➤ Scenario Manager from the Ribbon or Tools ➤ Scenarios from the menu 
bar to display the Scenario Manager dialog box. At first, when the workbook contains no 
scenarios, the Scenario Manager dialog box appears as shown in Figure 11-8.

Figure 11-8. At first, the Scenario Manager dialog box contains no scenarios. Click the Add (+) button to start creating 
a scenario

Creating Scenarios
After opening the Scenario Manager dialog box, you can create your scenarios.

To create a scenario, follow these steps:

1. From the Scenario Manager dialog box, click the Add (+) button to 
display the Add Scenario dialog box (see Figure 11-9).

Tip First, create a scenario containing your original data. This gives you an easy way to go back to 
the original data when you’ve finished testing scenarios.
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2. In the Scenario name text box, type a descriptive name for the 
scenario.

3. Click in the Changing cells text box, and then enter the details of 
the cells that users of the scenario are allowed to change. For the 
original scenario, we’re not making changes; but for a scenario that 
involves changing the rent, the range is cells B6:B9.

Click and drag in the worksheet to select a range of contiguous cells. 
If you need to select noncontiguous cells, click the first one, and then 
Cmd+click each other cell.

You can also type the name of a range into the Changing cells text box.

There’s a Collapse Dialog button to the right of the Changing cells text 
box, but you don’t need to use it, because Excel automatically collapses 
the Add Scenario dialog box when you click in the worksheet. After 
you’ve selected the changing cells, Excel expands the dialog box again.

Figure 11-9. Use the Add Scenario dialog box to set up each scenario. First create a scenario for your original data so 
that you can easily return to it
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4. In the Comment text box, you can type a comment that explains 
what the scenario is and how to use it. Excel creates a default 
comment of Created by, your user name (as set in the Office 
applications), and the date, but a descriptive comment is usually 
more helpful.

5. Choose settings as needed in the Protection area at the bottom of 
the dialog box:

Prevent changes. Select this check box when you need to prevent 
changes to the scenario. To make the protection take effect, you’ll 
need to protect the worksheet as described in the next section.

Hide. Select this check box when you need to prevent others from 
seeing this scenario—for example, because you want them to 
experiment with their own figures rather than looking at yours.  
Again, you need to protect the worksheet.

6. Click the OK button to close the Add Scenario dialog box. Excel 
displays the Scenario Values dialog box (see Figure 11-10). This 
dialog box shows a list box containing the changing cells in the 
scenario. Here’s where you see the benefit of naming the changing 
cells—each text box is easy to identify. If you haven’t named the 
changing cells, the cell addresses appear, and you may need to refer 
to the worksheet to see which cell is which.

Figure 11-10. In the Scenario Values dialog box, enter the values to use for the new scenario you’re creating.  
The cell names produce the labels (Rent_Lincoln and so on), which are much easier to refer to than cell addresses  
(for example, B5)
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7. Click each changing cell and verify the value in the Please enter 
a value box. Normally, you’d be entering values here for the new 
scenario, but because this scenario is for the original figures, you 
don’t need to change them.

8. Click the OK button to close the Scenario Values dialog box. Excel 
returns you to the Scenario Manager dialog box, where the scenario 
now appears in the Scenarios list box.

To add another scenario, click the Add button in the Scenario Manager dialog box, and then 
repeat the previous process. This time, you’ll want to change the figures.

Applying Protection to Your Scenarios
If you selected either the Prevent changes check box or the Hide check box in the 
Protection area of the Add Scenario dialog box, you need to protect the worksheet to make 
the protection take effect.

To protect the worksheet, follow these steps:

1. If the Scenario Manager dialog box is open, click the Close button to 
close it.

2. Choose Review ➤ Changes ➤ Protect Sheet from the Ribbon or 
Tools ➤ Protection ➤ Protect Sheet from the menu bar to display 
the Protect the sheet and contents of locked cells dialog box.

3. Type a password in the Password text box and again in the Verify 
text box.

4. In the Allow users of this sheet to box, make sure the Edit scenarios 
check box is cleared.

5. Click the OK button to close the dialog box. Excel applies the 
protection.

6. Save the workbook. For example, press Cmd+S or click the Save 
button at the left end of the title bar.
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After protecting the scenarios in the worksheet like this, you’ll need to turn off the protection 
before you can edit the scenarios. To turn off the protection, choose Review ➤ Changes 
➤ Unprotect Sheet from the Ribbon or Tools ➤ Protection ➤ Unprotect Sheet from the 
menu bar, type the password in the dialog box that Excel displays, and then click the OK 
button.

Editing and Deleting Scenarios
From the Scenario Manager dialog box, you can quickly edit a scenario by clicking it in the 
Scenarios list box, clicking the Edit button, and then working in the Edit Scenario dialog box. 
Excel automatically updates the scenario’s comment for you with details of the modification 
(for example, “Modified by Jack Cunningham on 08/18/2015”), but you’ll often want to type 
in more details, such as what you’re trying to make the scenario show.

When you no longer need a scenario, delete it by clicking the scenario in the Scenarios list 
box and clicking the Delete button. Excel doesn’t confirm the deletion; but if you delete 
a scenario by mistake, and recovering it is more important than losing any other changes 
you’ve made since you last saved the workbook, you can recover the scenario by closing 
the workbook without saving changes (assuming the scenario was already saved in the 
workbook).

Switching Among Your Scenarios
Once you’ve created multiple scenarios for the same worksheet, you can switch among 
them by clicking the scenario you want in the Scenarios list box in the Scenario Manager 
dialog box (see Figure 11-11) and then clicking the Show button. Excel displays the 
scenario’s figures in the worksheet’s cells. The Scenario Manager dialog box stays open, so 
you can quickly switch to another scenario.
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Merging Scenarios into a Single Worksheet
If you develop and share your scenarios in a single workbook, you can keep them all 
together. But sometimes you may need to develop your scenarios in separate workbooks 
and then combine them. You can do this easily by using the Merge command in the 
Scenario Manager dialog box.

To merge scenarios, follow these steps:

1. Open all the workbooks containing the scenarios you will merge.

2. Make active the workbook and worksheet you will merge the 
scenarios into.

3. Choose Data ➤ Data Tools ➤ What-If Analysis ➤ Scenario 
Manager from the Ribbon or Tools ➤ Scenarios from the menu bar 
to display the Scenario Manager dialog box.

Figure 11-11. To switch to another scenario, click the scenario in the Scenarios list box in the Scenario Manager dialog 
box, and then click the Show button
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4. Click the Merge button to display the Merge Scenarios dialog box 
(see Figure 11-12).

Figure 11-12. In the Merge Scenarios dialog box, choose the workbook and worksheet that contain the scenarios you 
want to merge into the active workbook

5. Open the Book pop-up menu, and choose the open workbook that 
contains the scenarios you want to merge in. The Sheet list box 
shows a list of the worksheets in the workbook.

6. In the Sheet list box, click the worksheet that contains the scenarios. 
The readout at the bottom of the Merge Scenarios dialog box shows 
how many scenarios the worksheet contains, which helps you pick 
the right worksheet.

7. Click the OK button. Excel closes the Merge Scenarios dialog box, 
merges the scenarios, and then displays the Scenario Manager 
dialog box again. 

Creating Reports from Your Scenarios
Sometimes you can make the decisions you need by simply creating scenarios and looking 
at them in the worksheet. At other times, it’s helpful to create a report from the scenarios so 
that you can compare them. Excel gives you an easy way to create either a summary report 
or a PivotTable report straight from the Scenario Manager dialog box.

Note If any scenario you merge into the active worksheet has the same name as an existing 
scenario in the worksheet, Excel adds the current date to the incoming scenario to distinguish it.
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To create a report from your scenarios, follow these steps:

1. Choose Data ➤ Data Tools ➤ What-If Analysis ➤ Scenario 
Manager from the Ribbon or Tools ➤ Scenarios from the menu bar 
to display the Scenario Manager dialog box.

2. Click the Summary button to display the Scenario Summary dialog 
box (see Figure 11-13).

Figure 11-13. In the Scenario Summary dialog box, choose between a scenario summary and a scenario PivotTable, 
and then select the result cells for the summary

3. In the Report type box, select the Scenario summary option button 
if you want to create a summary worksheet. If you want to create a 
scenario PivotTable, select the Scenario PivotTable option button.

4. Click in the Result cells text box, and then enter the addresses of the 
cells whose results you want the report or PivotTable to show. You 
can type in addresses or range names or select the appropriate cells 
in the worksheet.

5. Click the OK button to close the Scenario Summary dialog box. 
Excel creates the report or PivotTable. Figure 11-14 shows a sample 
of a summary report, which Excel places on a new worksheet named 
Scenario Summary at the beginning of the workbook.
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Using Goal Seek
When you’re planning or forecasting, you’ll often need to work backward from your target to 
derive the figures you need. For example, when planning your next financial year, you may 
need to find out how much you need to raise the selling price for your widgets to make an 
extra $30,000 a year.

To work this out, you can try increasing the unit price for the widgets until your revenue 
figure is $30,000 higher. But you can save time and effort by using Excel’s Goal Seek feature 
to derive the required price automatically by working backward from the revenue figure.

To derive values using Goal Seek, follow these steps:

1. Open the workbook that contains the data, and navigate to the 
worksheet that contains the calculation.

2. Make active the cell that contains the formula.

3. Choose Data ➤ Data Tools ➤ What-If Analysis ➤ Goal Seek from 
the Ribbon or Tools ➤ Goal Seek from the menu bar to display the 
Goal Seek dialog box (shown in Figure 11-15 with settings chosen).

Figure 11-14. Excel places a summary report on a new worksheet named Scenario Summary at the beginning of the 
workbook
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4. Make sure the Set cell text box contains the right cell. (If you selected 
the cell in step 2, it will.) If necessary, change the cell either by typing 
the correct reference or by double-clicking the current contents  
of the Set cell text box (to select it) and then clicking the right cell 
in the worksheet. (You can also click the Collapse Dialog button to 
collapse the Goal Seek dialog box, but the dialog box is so small 
anyway that it’s usually easier to work around it.)

5. In the To value text box, type the value you want to get.

6. In the By changing cell text box, enter the cell whose value you 
want to change—in the example, the cell containing the price of the 
widgets. Again, you can type the cell reference or simply click the 
cell in the worksheet.

7. Click the OK button. Goal Seek calculates the answer, enters it in the 
worksheet, and then displays the Goal Seek Status dialog box (see 
Figure 11-16).

Figure 11-15. Use the Goal Seek dialog box to work backward from your desired result to the figure you need

Figure 11-16. When Excel displays the Goal Seek Status dialog box, look at the value in the target cell in the 
worksheet. Click the OK button if you want to keep the value. Click the Cancel button if you want to revert to the 
previous value
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Note If the calculation is straightforward, Goal Seek finds a solution quickly. But if the calculation 
is more complex, Goal Seek may take a while. If this happens, you can click the Pause button to 
pause the calculation to see which value Goal Seek is trying at the moment. If you want to follow 
the individual values Goal Seek is trying, click the Step button to display the next value but keep the 
calculation paused; keep clicking the Step button as needed to see further values. Click the Resume 
button when you want Goal Seek to resume the calculation at full speed.

Figure 11-17. In the Add-Ins dialog box, select the Solver Add-In check box, and then click OK

8. Look at the value in the target cell. Click the OK button if you want 
to keep it. Click the Cancel button if you want to go back to the 
previous value.

Solving Multiple-Variable Problems with Solver
If you find Goal Seek useful, but you need more power, you’ll want to try Solver. Solver is a 
free add-in that lets you change multiple variables, which enables you to ask more complex 
questions of your data.

Enabling the Solver Add-In
Solver is an add-in tool included with Excel. To enable Solver, follow these steps:

1. Choose Tools ➤ Add-Ins from the menu bar to display the Add-Ins 
dialog box (see Figure 11-17).
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2. Select the Solver Add-In check box.

3. Click the OK button to close the Add-Ins dialog box. Excel loads 
Solver.

Using Solver
You can now use Solver like this:

1. Open the workbook and activate the worksheet that contains the data.

2. Make active the cell that contains the formula you want to analyze.

3. Choose Tools ➤ Solver from the menu bar to display the Solver 
Parameters dialog box (see Figure 11-18).

Figure 11-18. In the Solver Parameters dialog box, set the parameters for the problem you want Solver to solve
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4. Make sure the Set Objective box shows the cell you want to analyze. 
(This box shows the cell you selected in step 2.) If it’s the wrong cell, 
click in the Set Objective box, and then click the right cell.

You can click the Collapse Dialog button at the left end of the Set 
Objective box if you want to collapse the Solver Parameters dialog 
box out of the way.

You can also type the cell reference or cell name in the Set  
Objective box.

5. In the To area, select the Max option button, the Min option button, 
or the Value Of option button. If you select the Value Of option 
button, type the value in the box to its right.

6. In the By Changing Variable Cells box, enter the references or names 
of the cells you want Solver to change. You can click the cells in the 
worksheet (either collapsing the Solver Parameters dialog box or 
working around it) or type in the references or names.

7. If you want to constrain what Solver can do with the cell values, work 
with the controls to the right of the Subject to the Constraints box:

a. Click the Add button to display the Add Constraint dialog box  
(see Figure 11-19).

Figure 11-19. Use the Add Constraint dialog box to set up any constraints needed for the calculation

b. Enter a cell reference or name in the Cell Reference box.

c. Choose the comparison in the pop-up menu in the middle.

d. Enter the constraint in the Constraint box. You can enter a value or the 
reference or name of the cell in which you’ll enter the value.

e. Click the Add button if you want to add another constraint. Otherwise, click 
the OK button to close the Add Constraint dialog box. The constraints you 
added appear in the Subject to the Constraints list box.

8. Select the Make Unconstrained Variables Non-Negative check box if 
you want Solver to use only non-negative (positive or zero) values for 
variables you haven’t constrained.
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9. In the Select a Solving Method pop-up menu, choose GRG 
Nonlinear, Simplex LP, or Evolutionary, as needed. If you’re not 
familiar with different solving methods, start with GRG Nonlinear.

Figure 11-20. You can choose advanced options on the three tabs of the Options dialog box for Solver

Note Solver uses the Simplex method to solve linear problems (ones in which the change 
between two related quantities is directly proportional) and the Generalized Reduced Gradient (GRG) 
Nonlinear method to solve nonlinear problems (ones in which the change between the related 
quantities isn’t directly proportional). The Evolutionary method uses genetic algorithms.

10. If you need to control how Solver performs the calculation, click the 
Options button, and then choose options on the three tabs of the 
Options dialog box (shown in Figure 11-20).

11. Click the Solve button to set Solver analyzing the problem. If Solver 
finds a solution, it displays the Solver Results dialog box with the 
message “Solver found a solution” (see Figure 11-21).
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12. Select the Keep Solver Solution option button if you want to keep the 
solution Solver found. Otherwise, select the Restore Original Values 
option button.

13. Click the OK button to close the Solver Results dialog box.

Summary
In this chapter, you’ve learned how to use data tables to assess the impact of one or two 
variables on a calculation, how to use scenarios to experiment with different data, and how 
to solve straightforward problems with Goal Seek. You’ve also learned how to download, 
install, and use Solver to crack harder problems.

In the next chapter, I’ll show you how to use Excel’s powerful PivotTables feature.

Figure 11-21. From the Solver Results dialog box, you can choose whether to keep Solver’s solution or restore the 
original solution

Note If Solver can’t find a solution to the problem, select the Return to Solver Parameters Dialog 
check box in the Solver Results dialog box, and then click the OK button. In the Solver Parameters 
dialog box, change the parameters, and try solving the problem again.
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Chapter 12
Analyzing Data with 
PivotTables
In this chapter, we’ll look at how you can use PivotTables to analyze the data in your 
worksheets and draw conclusions from it. PivotTables are great for asking questions of your 
data and looking at the data in different ways without having to enter it multiple times in 
separate worksheets.

We’ll start by going over what PivotTables are and what you can do with them. After that, I’ll 
show you how to create a PivotTable either by using Excel’s automated tool, which can give 
you a jump-start by creating a recommended PivotTable that you can adjust as needed, or 
by placing the fields on the PivotTable framework manually, which gives you total control.

After you build a PivotTable, you’ll often need to change it so that it shows different data or 
shows the same data differently. I’ll show you several examples of the types of changes you 
can make easily to a PivotTable once you’ve constructed it.

When the PivotTable is arranged the way you need it, you can format the PivotTable and 
choose options to control how it appears. And you can sort and filter the data within the 
PivotTable to show only the information you’re after.

Understanding What PivotTables Are and What You Can 
Do with Them
A PivotTable is a special kind of report that rearranges the fields and records in a table into a 
different order so that you can examine their relationships. You pivot (in other words, rotate) 
the columns in a PivotTable to display the data summarized in a different way.
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For example, take a look at the worksheet shown in Figure 12-1. This worksheet contains a 
data table that tracks sales made by a company with four product lines: Hardware, Software, 
Services, and Supplies. The table uses the following columns:

	Sale. A unique sequential number used to identify each sale.

	Year, Month, and Day. The year, month, and day of the sale. Having 
these items in separate columns makes it easier to filter by time—for 
example, to compare one month against another or to see which 
salesperson sold what in January.

	Salesperson. The name of the sales rep who executed the sale.

	Line. The product line of the product sold.

	Product. The name of the product sold.

	Quantity. The quantity of the product sold.

	Price. The unit price of the product sold.

	Total Price. The total price of the products sold (Quantity multiplied  
by Price).

	Customer. The name of the company or organization that bought the 
products.

Figure 12-1. The sample table we’ll use for creating PivotTables in this chapter
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This is all straightforward. You can also easily see your sum total of sales (for example, by 
adding the figures in the Total Price column). But when you need to dig into the details, you 
need a different tool.

This is where PivotTables come in. By creating a PivotTable from a data table such as this, 
you can quickly find the answers to questions such as these:

	Which is your best-selling product line? And your best-selling product?

	How do this year’s sales compare to last year’s?

	Who was your star salesperson for March? And does another 
salesperson need some encouragement—or a pink slip?

	Which are your key customers? Which of them needs more one-on-one 
attention to bring sales up to where they were last year?

In the following sections, we’ll put together a PivotTable with the data in the data table, then 
manipulate it to see what it shows.

Creating and Laying Out a PivotTable
You can create a PivotTable either from a database table or from a range of data. If you 
have a database table already, as in the example, you can create the PivotTable from that. 
Otherwise, create the database table you’ll use, or enter the data in a worksheet as usual 
without creating a database table.

Once your data is ready, you can create a PivotTable either automatically, using the 
Recommended PivotTables command, or manually. Which works best depends on your data 
and what you’re trying to do with it, but often you can save time by creating a PivotTable 
automatically and then adjusting it as necessary. If an automatic PivotTable turns out not to 
be what you need, you can create the PivotTable manually from scratch instead.

Creating a PivotTable Automatically
To create a PivotTable automatically, follow these steps:

1. Open the workbook and display the worksheet that contains the 
table or data you’ll use in the PivotTable.

2. Click in the table that you’ll use for the PivotTable. If you’ll use a 
range rather than a named table, select the range.

Note If you want to work through the examples in this chapter, you’ll need a database table like the 
one shown in the screens. You can either create one yourself or (much easier) download the sample 
workbook from the book’s page on the Apress web site (www.apress.com/9781484210208).

http://www.apress.com/9781484210208
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3. Choose Insert ➤ Tables ➤ Recommended PivotTables from the 
Ribbon. Excel then does the following:

	Inserts a new worksheet with a default name, such as Sheet5

	Inserts an automatic PivotTable on that worksheet, using a 
recommended layout

	Displays the PivotTable Builder window

	Adds the PivotTable Analyze tab and the Design tab to the 
Ribbon, and displays the PivotTable Analyze tab

	Displays some information about PivotTables the first time you 
create one

Figure 12-2 shows the automatic PivotTable produced from the sample data table, with the 
PivotTable Builder window positioned in front of the worksheet.

Figure 12-2. The quickest way to create a PivotTable is to have Excel create a recommended PivotTable automatically. 
You will usually need to adjust the PivotTable using the PivotTable Builder window to make the PivotTable show the 
information you want. Depending on the data you’re using, the PivotTable may look substantially different from this one
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After creating a PivotTable automatically, you’ll normally need to adjust it. This is because 
Excel seldom guesses exactly which information you need where.

To adjust a PivotTable, use the techniques you’ll learn in the next section, which shows you 
how to build a PivotTable from scratch.

Creating a PivotTable Manually
If creating an automatic PivotTable doesn’t give a useful result or if you prefer to do things by 
hand, you can build the PivotTable manually using the PivotTable Builder. 

To create a PivotTable manually, follow these steps:

1. Open the workbook, and display the worksheet that contains the 
table or data you’ll use in the PivotTable.

2. Click in the table that you’ll use for the PivotTable. If you’ll use a 
range rather than a named table, select the range.

3. Choose Insert ➤ Tables ➤ PivotTable from the Ribbon or Data ➤ 
Summarize with PivotTable from the menu bar to display the Create 
PivotTable dialog box (see Figure 12-3). If you’re using a named 
table, you can also choose Tables ➤ Tools ➤ Summarize with 
PivotTable from the Ribbon; if you’re using a range, this command 
isn’t available.

Figure 12-3. In the Create PivotTable dialog box, choose the table or range of data from which to create the PivotTable. 
Then choose between putting the PivotTable on a new worksheet or an existing worksheet
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4. In the Choose the data that you want to analyze area at the top of the 
Create PivotTable dialog box, choose the Select a table or a range 
option button.

5. Make sure the Table/Range text box in the Choose the data that you 
want to analyze area shows the table or range you want to use. If you 
clicked in the table or selected the range in step 2, you’ll be all set. 
If not, type in the table name or click and drag in the worksheet to 
select the range. If necessary, click the Collapse Dialog button first to 
get the Create PivotTable dialog box out of the way first.

6. In the Choose where to place the PivotTable area of the Create 
PivotTable dialog box, choose the appropriate option button:

	New worksheet. Select this option button if you want to place the 
PivotTable on a new worksheet. This is often clearest, because it 
gives you plenty of room for the PivotTable.

	Existing worksheet. Select this option button if you want to place 
the PivotTable on an existing worksheet. Click in the Table/
Range text box, click the worksheet’s tab, then click and drag 
in the worksheet to enter the location. Again, you can click the 
Collapse Dialog button to collapse the Create PivotTable dialog 
box if necessary.

7. Click the OK button to close the Create PivotTable dialog box. Excel 
positions a PivotTable framework on a new worksheet or the existing 
worksheet you chose and displays the PivotTable Builder window. 
Figure 12-4 shows the PivotTable framework on a new worksheet 
named Sheet3.

Note Instead of creating a PivotTable from data in a worksheet, you can create a PivotTable from 
an external data source such as a FileMaker database or Access database. To do so, you select the 
Use an external data source option button in the Choose the data that you want to analyze area of 
the Create PivotTable dialog box, click the Choose Connection button, then choose the data source. 
Before you can do this, you must install an Open Database Connectivity (ODBC) driver to enable 
Excel to connect to the data source, as discussed in Chapter 10.

http://dx.doi.org/10.1007/978-1-4842-1019-2_10
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Now that you’ve inserted the framework for the PivotTable, you can add fields to it from the 
Field Name list box in the PivotTable Builder window.

Understanding the Contents of the PivotTable Builder Window
Take a moment to look at the PivotTable Builder window. You use the PivotTable Builder 
window to set up the fields for your PivotTable. As you do so, Excel adds the fields to the 
appropriate places in the PivotTable framework.

Here are the essentials you need to know about the PivotTable Builder window:

	Field Name list box. This list box contains an entry for each of the fields 
that Excel found in the data table or range you chose. Each item in the 
list has a check box that you can select to add the field to the PivotTable 
or clear to remove the field from the PivotTable.

	Filters. This box shows the filters you apply to the PivotTable. After 
applying filters, you can drag them into a different order if necessary.

Figure 12-4. When you insert a PivotTable manually, Excel creates an empty framework on which you lay out the 
PivotTable the way you need it
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	Columns. This box shows the fields you add as columns to the 
PivotTable. After adding fields, you can drag them up and down the 
Columns box as needed to arrange the columns into the order in which 
you want them to appear on the PivotTable.

	Rows. This box shows the fields you add as rows to the PivotTable. 
After adding fields, you can drag them up or down the Rows box to 
rearrange the order of the rows in the PivotTable.

	Values. This box contains the fields you add as values to the PivotTable 
and the fields that Excel adds automatically. You can drag the fields up 
or down the Values box to change their order as needed.

If this doesn’t make sense yet, don’t worry. You’ll see how PivotTables work in just a 
moment.

Adding the Fields to the PivotTable Framework
To create the PivotTable, you add fields to the PivotTable framework by dragging fields to  
the Filters box, the Rows box, the Columns box, and the Values box in the PivotTable  
Builder window.

Which fields you need to drag where depends on your data source and what you’re trying to 
make it show. Here’s a walk-through using the fields in the data source. If you’re using the 
sample data source, your results should look similar; if your data source is different, they’ll 
look different, but the PivotTable will work in much the same way.

1. In the Field Name list box in the PivotTable Builder window, click the 
Year field and drag it to the Filters box. Excel selects the Year check 
box, enters Year in cell A2, and creates a pop-up menu for selecting 
the years in cell B2 (see Figure 12-5).

Note You can also add fields by selecting their check boxes in the Field Name list box. When you 
select a field, Excel places it automatically depending on what its contents appear to be. Because 
Excel doesn’t know what your data represents and what you’re trying to show, it often puts the field 
in the wrong place. So it’s usually best to place the fields yourself by dragging them.
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2. In the Field Name list box, click the Salesperson field and drag it to 
the Rows box. Excel selects the Salesperson check box and creates 
a row label for each salesperson’s name (see Figure 12-6).

Figure 12-5. Drag the Year button from the Field name box in the PivotTable Builder window to the Filters box to 
create the Year pop-up menu shown in cell B2 here. Excel selects the (All) item in the pop-up menu at first, making the 
PivotTable show all the years



 
338 CHAPTER 12: Analyzing Data with PivotTables

3. Drag the Line field from the Field Name list box in the PivotTable 
Builder window to the Columns box. Excel selects the Line check 
box in the Field Name list box and adds the product lines as column 
labels (see Figure 12-7).

Figure 12-6. Moving the Salesperson button to the Rows box makes Excel create a row label for each salesperson’s name
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4. Now click the Total Price field in the Field Name list box, and drag  
it to the Values box in the PivotTable Builder window. Excel adds to 
the PivotTable the values of the items the salespeople sold  
(see Figure 12-8).

Figure 12-7. Drag the Line item from the Field Name list box in the PivotTable Builder window to the Columns box. 
Excel adds the product lines as column labels and selects the Line check box for you
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This gives us a PivotTable that shows how much of each product line each salesperson sold. 
At first, the PivotTable shows (All) in the Year pop-up menu in cell B2. To see a breakdown by 
a year, open the Year pop-up menu, then click the year you want.

This is useful—but it’s just the start of what you can do with the PivotTable.

Changing the PivotTable to Show Different Data
The great thing about PivotTables is how easy they are to change to show different data. You 
can change a PivotTable by adding different fields to it, removing fields it’s currently using, 
or rearranging the fields among the Filters box, the Columns box, the Rows box, and the 
Values box in the PivotTable Builder window.

Here are four examples of how you can change the basic PivotTable created earlier in this 
chapter. These examples work as a sequence, so you’ll need to make each change in turn if 
you want to work through them.

	In the Field Name list box, click the Product field, then drag it to  
the Rows box in the PivotTable Builder window. Excel adds a list  
of the product names of the products each salesperson has sold  
(see Figure 12-9).

Figure 12-8. Drag the Total Price field from the Field Name list box to the Values box in the PivotTable Builder window 
to add the totals of each salesperson’s sales to the PivotTable



 
341CHAPTER 12: Analyzing Data with PivotTables

	In the Rows box in the PivotTable Builder window, drag the Salesperson 
field below the Product field. The PivotTable then shows each product  
with a collapsible list of the salespeople who have been selling it  
(see Figure 12-10).

Figure 12-9. Drag the Product field to the Rows box in the PivotTable Builder window to add a list of the products each 
salesperson has sold. You can collapse any list by clicking the disclosure button to the left of the salesperson’s name
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	Drag the Product field from the Rows box in the PivotTable Builder 
window to the Columns box. Then drag the Line field from the Columns 
box outside the PivotTable Builder window and drop it, making it 
disappear from the PivotTable. (You can also clear the Line check 
box in the Field Name list box.) These changes produce a PivotTable 
showing the salespeople by row and what they’ve sold of the products 
in columns (see Figure 12-11).

Figure 12-10. Drag the Salesperson field below the Product field in the Rows box in the PivotTable Builder window to 
produce a list of products showing the salespeople who have been selling them
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	Make the following changes to see which of your product lines each of 
your customers bought in a specific period:

1. Drag the Month field from the Field Name list box in the PivotTable 
Builder window to the Filters box, placing it below the Year field. You 
can now filter by month as well as by field. For example, you can 
choose 2015 as the Year filter, then choose January as the Month 
filter to see only your January 2015 results.

2. In the Field Name list box, clear the Salesperson check box to 
remove the Salesperson field from the Rows area. Then drag 
the Customer field from the Field Name list box to the Rows box 
instead, making the PivotTable show one customer in each row.

3. In the Field Name list box, clear the Product check box to remove 
the Product field from the Columns area. Then drag the Line field  
to the Columns box to make the PivotTable show the product  
lines in the columns. Figure 12-12 shows the resulting PivotTable.

Figure 12-11. Removing the product lines and making column labels of the products produces this PivotTable that 
shows how much each salesperson has sold of each product
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When you’ve finished working with the PivotTable Builder window, you can close it by 
clicking the red Close button at the left end of its title bar or by choosing PivotTable  
Analyze ➤ Show ➤ Field List from the Ribbon.

If you need to open the PivotTable Builder window again, choose PivotTable Analyze ➤ 
Show ➤ Field List from the Ribbon.

Changing the Function Used to Summarize a Field
When you add values to a PivotTable, Excel tries to automatically use the right function 
for the calculation that type of data needs. For example, when you add a field that shows 
prices, Excel uses the SUM( ) function on the assumption that you want to add the values. 
And if you use nonnumeric data such as names, Excel uses the COUNT( ) function, giving 
you the number of different items.

Figure 12-12. You can add the Month field to the Filters box, putting it below the Year field, to filter your PivotTable by 
first the year (here, 2015) and then the month (here, January). This PivotTable shows how much customers bought from 
each product line in January 2015
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If you need to change a field to a different function, follow these steps:

1. Click the field, or click a cell containing data that the field produces.

2. Choose PivotTable Analyze ➤ Active Field ➤ Field Settings from 
the Ribbon to display the PivotTable Field dialog box. The main part 
of this dialog box contains two tabs, the Summarize by tab (shown 
on the left in Figure 12-13) and the Show data as tab (shown on the 
right in Figure 12-13). The Summarize by tab is selected at first.

Tip You can also open the PivotTable Field dialog box for a field by clicking the i button to the right 
of the field’s name in the PivotTable Builder window.

Figure 12-13. In the PivotTable Field dialog box, use the Summarize by tab (left) to change the formula used to 
summarize the field’s data. Use the Show data as tab (right) to change the way the data appears

3. In the list box on the Summarize by tab, click the function you want 
to use. For example, click the Average function if you want the field 
to show an average instead of a sum. Excel automatically changes 
the contents of the Field name text box to reflect the function you 
chose—for example, changing the text from Sum of Total Price to 
Average of Total Price.

4. If you need to present the data in a different format (for example, as 
the amount of difference from a base value), click the Show data as 
tab in the PivotTable Field dialog box to display the tab’s controls 
(see the right screen in Figure 12-13). In the pop-up menu, choose 
the format you want—for example, Difference From. Then select the 
base field in the Base field list box and the base item in the Base 
item list box.
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5. If you want to change the field name, type the change in the Field 
name text box.

6. Click the OK button to close the PivotTable Field dialog box.

Controlling the Design of a PivotTable
After setting up the framework for your PivotTable, you can use the tools in the Layout group 
on the Design tab of the Ribbon to choose where to display subtotals and grand totals, 
choose among the PivotTable layouts that Excel offers, and decide whether to insert blank 
rows between items to make the PivotTable more readable. The Design tab appears on 
the Ribbon when a PivotTable is active, so if you’re not seeing the Design tab, click in your 
PivotTable.

The Design group contains four pop-up menus:

	Subtotals. Open this pop-up menu and then specify how to place the 
subtotals by clicking Show All Subtotals at Bottom of Group, Show All 
Subtotals at Top of Group, or Don’t Show Subtotals.

	Grand Totals. Open this pop-up menu and then specify how to place the 
grand totals by clicking On for Rows & Columns, On for Rows Only, On 
for Columns Only, or Off for Rows & Columns.

	Report Layout. Open this pop-up menu, and then first choose the layout 
form you want by clicking Show in Compact Form, Show in Outline 
Form, or Show in Tabular Form on the upper part of the menu. Click 
to place a check mark next to the layout you want: Compact Form 
(the default, shown at the top of Figure 12-14), Outline Form (shown in 
the middle of Figure 12-14), or Tabular Form (shown at the bottom of 
Figure 12-14).
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Figure 12-14. You can choose among three layout forms for your PivotTables. Compact Form (left) is good for presenting 
data in a small space. Outline Form (right) and Tabular Form (bottom) take up more space but make the data easier to read
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	Blank Rows. Open this pop-up menu and specify whether to insert blank 
rows by clicking Insert Blank Line After Each Item or Remove Blank Line 
After Each Item. Blank lines make the PivotTable take up much more 
space but can make it far easier to read.

Formatting a PivotTable
To make a PivotTable look good and convey its contents effectively, you can format it. You 
can apply the formatting at any point, but usually it’s best to lay out the framework and fields 
of the PivotTable first so that you have a fair idea of how it will appear.

Applying a PivotTable Style
As you’ve seen in the examples so far in this chapter, Excel applies a style to a PivotTable 
when you create it. The style helps you distinguish the different areas of the PivotTable 
visually.

To change the way a PivotTable looks, apply a different style to it from the PivotTable Styles 
group on the Design tab of the Ribbon. You can either click one of the styles in the Quick 
Styles box or hold the mouse pointer over the Quick Styles box, click the panel button that 
appears, then click the PivotTable style you want on the Quick Styles panel.

Choosing Options for a PivotTable Style
After applying a PivotTable style, you can choose options for it by displaying the Design tab 
of the Ribbon and then selecting or clearing the four check boxes in the PivotTable Style 
Options group:

	Row Headers. Select this check box to use the style’s formatting on the 
row headers.

	Column Headers. Select this check box to use the style’s formatting on 
the column headers.

	Banded Rows. Select this check box to make lines or shaded bands 
(depending on the style) appear along the rows.

	Banded Columns. Select this check box to make lines or shaded bands 
(depending on the style) appear up and down the columns.

Note You can also create your own PivotTable styles. To do so, choose Design ➤ PivotTable 
Styles ➤ Quick Styles ➤ New PivotTable Style, then work in the New PivotTable Quick Style 
dialog box that Excel displays. Briefly, you give the style a name in the Name text box, then click an 
element in the Table element list box, click the Format button, and choose the formatting you want 
for the element. After you create a new style, you can apply it from the Custom section at the top of 
the Quick Styles panel.
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Naming a PivotTable and Setting Options for It
When you insert a PivotTable, Excel gives it an automatic name (such as PivotTable1 
or PivotTable2) and sets default display options, layout options, and data options. The 
PivotTable’s name appears in the PivotTable Name box in the PivotTable group at the left 
end of the PivotTable Analyze tab of the Ribbon when the Excel window is moderately wide; 
when the window is narrower, Excel collapses the PivotTable group into a PivotTable button 
that you can click to display the group’s contents on a pop-up panel.

To rename the PivotTable, go to the PivotTable group if the Excel window is wide enough, or 
click the PivotTable button if the window is not. Type the new name in the PivotTable Name 
text box, and then press Return.

For an alternative way to rename the PivotTable, or to choose different options, choose 
PivotTable Analyze ➤ PivotTable ➤ Options to display the PivotTable Options dialog box, 
then work with its controls.

Figure 12-15 shows the PivotTable Options dialog box with its Display tab at the front.

Figure 12-15. On the Display tab of the PivotTable Options dialog box, choose whether to show items such as expand/
collapse buttons and tooltips on the PivotTable and whether to print headings and row labels
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Renaming a PivotTable
To rename a PivotTable, type the new name over the existing name in the PivotTable name 
text box at the top of the PivotTable Options dialog box. PivotTable names can include 
spaces, so you can make them descriptive and readable.

Choosing Display Options for a PivotTable
To control how Excel displays a PivotTable, click the Display tab in the PivotTable Options 
dialog box to display its controls (shown in Figure 12-15), then choose the options you want.

These are the options you can choose in the Show area:

	Expand/collapse buttons. Select this check box if you want to display 
the disclosure buttons you click to expand or collapse row labels or 
column labels. Usually it’s useful to display these disclosure buttons, but 
you can clear this check box if you want to hide them to prevent others 
from changing the display of a PivotTable.

	Print expand/collapse buttons. Select this check box if you want to 
print the disclosure buttons on printouts of the PivotTables. Printing the 
disclosure buttons is often useful for PivotTables you print for your own 
consumption, but you may prefer not to print the buttons on printouts 
you produce for other people.

	Contextual tooltips. Select this check box if you want the PivotTable to 
display tooltips (another term Microsoft uses for ScreenTips, the little 
pop-up information boxes) for fields and for values when you hold the 
mouse pointer over a cell. This option is usually helpful.

	Field captions and filters. Select this check box if you want captions to 
appear at the top of the PivotTable and filter pop-up buttons on column 
labels and row labels. These are usually helpful too.

	Error values as. If you want to display standard text in cells that contain 
errors rather than displaying error messages, select this check box and 
type the text in the text box.

	Empty cells as. If you want to display standard text in empty cells 
instead of having them simply be empty, select this check box and type 
the text in the text box.

Note When you create a PivotTable on its own worksheet, you’ll normally want to rename the 
worksheet from its default name (for example, Sheet5) to a descriptive name (for example, Sales 
PivotTable). Double-click the current name on the worksheet tab, type the new name, then press 
Return to apply it.
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The Show items with no data area contains two settings that are available only for 
PivotTables that use an OLAP (Online Analytical Processing) data source:

	On rows. Select this check box to display row items that have no values.

	On columns. Select this check box to display column items that have no 
values.

The Print area contains three options for controlling which items print along with the 
PivotTable:

	Repeat row labels on each page. Select this check box to make Excel 
print the row labels on each page the PivotTable occupies rather than 
just on the first page. Repeating the row labels makes the PivotTable 
easier to read, so it’s usually a good idea.

	Page, row and column headings. Select this check box to repeat the 
page headings, row headings, and column headings. This too is  
usually helpful.

	Item labels when no fields are on the table. This check box is normally 
selected but dimmed and unavailable, because it applies only to 
PivotTables created in Excel 2004 (Mac), Excel 2003 (Windows), or earlier 
versions of Excel. If the check box is available, selecting it makes the 
PivotTable display item labels even when the table contains no fields.

Choosing Layout Options for a PivotTable
To control the layout of a PivotTable, click the Layout tab in the PivotTable Options dialog 
box to display its controls (see Figure 12-16), then choose the settings you want.
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These are the settings you can choose in the Layout area of the Layout tab:

	Allow multiple filters per field. Select this check box if you want to be 
able to filter the PivotTable by two or more filters on a single field rather 
than by just one filter.

	AutoFit column widths on update. Select this check box to make Excel 
automatically resize the column widths to accommodate the data with 
which you’ve refreshed the PivotTable. AutoFit is usually helpful.

	Preserve cell formatting on update. Select this check box to make Excel 
retain cell formatting you’ve applied directly to cells when you update 
the information in the PivotTable. This option too is usually helpful.

	Merge and center cells with labels. Select this check box if you want 
Excel to merge a label cell with a blank cell next to it and center the 
label across the cells. Try this look to see whether you prefer it to the 
regular look.

	Indent row labels when in compact form. In this pop-up menu, choose 
the number of spaces by which you want to indent row labels when 
using the Compact Form for a PivotTable.

Figure 12-16. On the Layout tab of the PivotTable Options dialog box, you can set options for the layout, for the report 
filter, and for sorting
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These are the settings you can choose in the Report filter area of the Layout tab:

	Arrange fields option buttons. Select the Down, then over option button 
to have Excel arrange the fields downward first and then across to the 
right. Select the Over, then down option button if you prefer to arrange 
the fields first to the right and then downward.

	Filter fields per column. In this pop-up menu, choose the number of fields 
to display in the report filter before moving to another column or row.

These are the settings you can choose in the Sort area of the Layout tab:

	Use custom lists when sorting. Select this check box if you want Excel 
to sort by your custom lists when it encounters the data in them. For 
example, if you’ve created a custom list of your company’s offices, 
select this check box to make Excel sort the PivotTable by the order in 
that list rather than in ascending order or another standard sort order.

	Sort A to Z. Select this option button if you want to sort in ascending 
order.

	Sort by data source order. Select this option button if you want to sort 
the PivotTable in the same order as the data source. This is the default 
setting and is useful if you’ve laid out the data source in your preferred 
order. If not, select the Sort A to Z option button instead.

Choosing Data Options for a PivotTable
The Data tab of the PivotTable Options dialog box (see Figure 12-17) lets you control how 
Excel stores the PivotTable’s data from an external connection and whether Excel refreshes 
the data automatically. For a PivotTable connected to an external data source, you can also 
choose whether to save the connection password with the Excel workbook and whether to 
run queries in the background.
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In the Data area of the Data tab, you can choose the following options:

	Save source data with file. Select this check box if you want to store the 
source data from an external data source in the workbook that contains 
the PivotTable. This setting has no effect on a PivotTable that contains 
data drawn from its own workbook, because that workbook contains the 
data already.

	Enable show details. Select this check box if you want to be able to drill 
down in the PivotTable to show details from the data source.

	Retain items deleted from the data source. Select this check box if you 
want Excel to store data that has been deleted from the data source. 
Storing the data is useful if you are working with older data in a data 
source that’s being updated.

	Number to retain per field. Select the Automatic option button to have Excel 
store the default number of items for each field of data. Select the Max 
option button to store as many items as possible for each field of data.

	Refresh data when opening file. Select this check box if you want Excel 
to automatically refresh the data in the PivotTable when you open the 
workbook. Automatic refreshing is useful when you need to make sure 
you’re working with the latest figures.

Figure 12-17. On the Data tab of the PivotTable Options dialog box, choose how to handle the PivotTable’s data and 
connection
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In the Connection area, you can choose these two options:

	Save password with file. For an external connection, select this check 
box to save the connection’s password in the workbook. Saving the 
password means you don’t need to enter it manually on each refresh, so 
you’ll usually want to do this unless security dictates otherwise.

	Run queries in the background. For an external connection, select 
this check box to run queries in the background rather than in the 
foreground. Running queries in the background typically makes the 
queries take longer but allows Excel to remain more responsive while a 
query is running.

When you’ve finished choosing options in the PivotTable Options dialog box, click the OK 
button to close the dialog box.

Refreshing the Data in a PivotTable
Even when you create a PivotTable from a data source in the same workbook, the data in 
a PivotTable remains static rather than updating automatically the way most other Excel 
objects do. 

When you want to make sure your PivotTable contains the latest data from the data source, 
choose PivotTable Analyze ➤ Data ➤ Refresh, clicking the main part of the Refresh 
button.

To refresh all the PivotTables in a workbook, choose PivotTable Analyze ➤ Data ➤ Refresh 
➤ Refresh All.

If your PivotTable uses an external data source, and you find the refresh operation is taking 
too long, choose PivotTable Analyze ➤ Data ➤ Refresh ➤ Cancel Refresh to cancel the 
operation.

Changing the Source of a PivotTable
Sometimes, after building a PivotTable, you may find you need to change its source data. 
You can do this without deleting the PivotTable and starting again, which is good news.

To change the source data of a PivotTable, follow these steps:

1. From the Ribbon, choose PivotTable Analyze ➤ Data ➤ Change 
Source to display the Change PivotTable Data Source dialog box 
(see Figure 12-18).
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2. In the Location text box, enter the range you want to use instead of 
the current range. You can type in a table name or a range name; 
type in a range reference; or click the Collapse Dialog button, select 
the range in the worksheet, then click the Collapse Dialog button 
again.

3. Click the OK button to close the Change PivotTable Data Source 
dialog box. Excel updates the PivotTable with data from the new data 
source.

Sorting and Filtering a PivotTable
To make a PivotTable show the data you require, you may need to sort it or filter it.

To sort a PivotTable, click the pop-up button of the field by which you want to sort. Excel 
displays the sorting and filtering window for that field. The window bears the field’s name, as 
you can see in Figure 12-19, which shows the sorting and filtering window for the Product 
field. You can then click the Ascending button to produce an ascending sort (from A to Z, 
from small numbers to large numbers, and from early dates and times to later ones) or the 
Descending button to produce a descending sort (the opposite).

Figure 12-18. Use the Change PivotTable Data Source dialog box when you need to switch the PivotTable to a different 
data source
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Note To control how Excel sorts a PivotTable, choose sorting options in the Sort area of the Layout 
tab of the PivotTable Options dialog box, as discussed earlier in this chapter.

Figure 12-19. To sort or filter a PivotTable, open the sorting and filtering window for the field, then choose options in 
the Sort area or the Filter area. The sorting and filtering window’s title bar shows the field’s name (here, Product)

When you apply sorting to a field, the field name pop-up button changes to show an 
arrow indicating the direction of the sort. For example, in Figure 12-20, you can see an 
upward arrow indicating a descending sort on the Salesperson field and a downward arrow 
indicating an ascending sort on the Line field and the Product field. The Month field shows 
the regular pop-up button.
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To filter the PivotTable, click the pop-up button next to the field’s name to display the sorting 
and filtering window, then choose the filtering criteria in the Filter area. Here are some 
examples:

	Filter by label. To filter by label, open the By label pop-up menu, choose 
the comparison type, then specify the data required. For example, choose 
the Contains comparison to find labels that match the text string you type 
in the text box that appears, as shown on the left in Figure 12-21.

Figure 12-20. When you sort a PivotTable, the field’s pop-up button shows an upward arrow for a descending sort  
(as on the Salesperson field here) or a downward arrow for ascending sort (as on the Line field and the Product field here)

Figure 12-21. You can filter a field by its label (as shown on the left here) or by its value (as shown on the right). You 
can also search in the Search box or clear the check boxes of items you want to exclude
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	Filter by value. To filter by value, open the By value pop-up menu, then 
choose the comparison you want. For example, choose the Top 10 item 
to create a top-however-many-you-choose filter, then set the number 
of items in the left of the two pop-up menus that appear below the 
By value pop-up menu when it’s showing Top 10 (see the right screen 
in Figure 12-21). In the right of the two pop-up menus, choose Item, 
Percentage, or Sum as needed for the filtering.

	Filter by individual values. To filter by individual values, clear the  
(Select All) check box in the lower part of the Filter area, then select 
the check box for each item you want to use in the filter. To find only 
particular items so that you can select or clear their check boxes, click 
in the Search box, then type the search term.

When you apply a filter, the field’s pop-up button displays a funnel-like filter symbol, as you 
can see on the Price field in Figure 12-22.

Figure 12-22. Excel displays a funnel-like filter on a field’s pop-up button to indicate that you’ve applied filtering to 
that field

To remove filtering, open the sorting and filtering window again, then click the Clear Filter 
button at the bottom.

Summary
In this chapter, you learned what PivotTables are and how to create them from your existing 
tables or other data sources. You know how to start a PivotTable automatically or build it 
manually, how to rearrange its fields to change the information it displays and the way it 
displays the information, and how to design and format the PivotTable. Lastly, you learned 
how to sort and filter PivotTables to make them show the information you need.

In the next chapter, I’ll show you how to share your workbooks with your colleagues.
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Chapter 13
Collaborating and Sharing 
with Macs and Windows PCs
In this chapter, I’ll show you how to work with other people on your workbooks.

You can give others your workbooks the old-fashioned way—by printing the worksheets 
and distributing them on paper—or you can take the more modern approach and create 
PDF files that you can share on a network or via the Internet. You can also export data to a 
comma-separated values format to make it compatible with many programs.

You can share your workbooks with your colleagues so that two or more of you can work 
on the same workbook at the same time, and you can track the changes people make to 
your workbooks so that you can review them closely. These features work on both OS X 
and Windows, so it doesn’t matter which platform your colleagues use. Better still, Excel 
provides an automated tool for merging the changes in separate copies of the same 
workbook together, allowing you to easily collate the changes, track them, and review them.

At the end of the chapter, I’ll show you how to consolidate multiple worksheets into a single 
worksheet. This is great when you need to pull together information quickly from related 
worksheets.

Making Your Worksheets Print Correctly
To print from Excel, you use the Print dialog box. But before you print, you need to tell Excel 
which part of the workbook to print. You may also want to check the page setup to make 
sure the page breaks fall where you want them to fall.
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Telling Excel Which Part of the Worksheet to Print
Given that each worksheet contains billions of cells, you seldom need to print the whole of a 
worksheet—you want to print only the range of cells you’ve used, or perhaps only a small 
subset of that range. So when you’re printing, the first thing to do is tell Excel which part of 
the worksheet you want to print. Excel calls this setting the print area. You can set a 
separate print area for each worksheet.

To set the print area, follow these steps:

1. Click the worksheet whose print area you want to set.

2. Select the range of cells you want to print.

3. Choose File ➤ Print Area ➤ Set Print Area from the menu bar. Excel 
displays a dotted blue line around the print area to indicate that it is set. 

If you need to change the print area, select a new range of cells, then give the File ➤ Print 
Area ➤ Set Print Area command again.

If you need to clear the print area so that the worksheet has no print area set, click the 
worksheet, then choose File ➤ Print Area ➤ Clear Print Area from the menu bar.

Checking the Page Layout and Where the Page Breaks Fall
When printing a large worksheet, check the page layout of the worksheet and adjust it as 
needed. Follow these steps:

1. Switch to Page Layout view by clicking the Page Layout View button 
at the left end of the status bar, choosing View ➤ Workbook Views 
➤ Page Layout from the Ribbon, or choosing View ➤ Page Layout 
from the menu bar.

2. Click the Page Layout tab of the Ribbon to show its controls. 
Figure 13-1 shows a worksheet in Page Layout view with the Page 
Layout tab displayed.

Caution Until you set the print area, Excel assumes you want to print all the cells you’ve used on 
the worksheet—even if there are huge amounts of blank space between them. So it’s a good idea 
always to set the print area before printing.

Note When you create a print area that consists of multiple ranges of cells, the ranges don’t need 
to be contiguous. Excel prints each separate range on a separate page.
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3. Use the controls in the Page Setup group to change the page setup 
as needed:

Change the margins. Open the Margins pop-up menu, then click Normal, 
Wide, or Narrow. For greater control, click Custom Margins, work on the 
Margins tab of the Page Setup dialog box, then click the OK button. 

Change the orientation. Open the Orientation pop-up menu, then click 
Portrait or Landscape.

Change the paper size. Open the Size pop-up menu, then click the  
paper size.

Set or clear the print area. Open the Print Area pop-up menu, then click Set 
Print Area or Clear Print Area.

Insert a page break. Click the column before which you want to insert  
a manual page break. Open the Breaks pop-up menu, then click Insert 
Page Break.

Note If you prefer to work in Normal view, you can still adjust the page breaks—drag the dotted 
lines that represent them, or use the controls in the Page Setup group.

Figure 13-1. To see a worksheet’s pages laid out, switch to Page Layout view. You can then use the controls on the 
Page Layout tab of the Ribbon to refine the layout
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When you have finished laying out the pages, it’s a good idea to save the workbook—for 
example, click the Save button on the title bar, or press Cmd+S—to store the print settings.

Printing a Worksheet or Workbook
After you’ve set the print area for each worksheet you want to print, you can print a 
worksheet or workbook like this:

1. If you want to print anything less than a whole workbook, choose 
what you want to print:

Print a worksheet. Make that worksheet active. For example, click its 
worksheet tab.

Print multiple worksheets. Make all those worksheets active by selecting 
their worksheet tabs.

Print a selection of cells. Select the cells.

2. Choose File ➤ Print or press Cmd+P to display the Print dialog box 
(see Figure 13-2). If the Print dialog box opens at its smaller size, 
click Show Details to expand the dialog box to its larger size.

Note If you put a page break in the wrong place, click the column after it, then choose Page 
Layout ➤ Page Setup ➤ Breaks ➤ Remove Page Break from the Ribbon. To restore all page 
breaks to where Excel had placed them, choose Page Layout ➤ Page Setup ➤ Breaks ➤  
Reset All Page Breaks.
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3. In the Print pop-up menu, choose what to print:

Selection. Select this option to print only the cells you’ve selected. This 
option is useful for printing smaller amounts without resetting the print area.

Active Sheets. Select this option to print the active worksheet (if you’ve 
selected only one) or active worksheets (if you’ve selected more than one).

Entire Workbook. Select this option to print every worksheet in the 
workbook. Normally, you’ll use this option only for small workbooks.

4. Check that the preview of the printout looks right. If you need to 
change the scaling to make the printout fit the paper better, select 
the Scale to fit check box, then set the number of pages in the N 
pages wide box and the by N pages tall box. For example, you might 
choose 1 pages wide by 2 pages tall.

5. Click the Print button to print the worksheets.

Figure 13-2. Choose print options in the Print dialog box
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Sharing Your Worksheets as PDFs
If you want to share your worksheets electronically so that other people can view them easily 
but not edit them—at least, not without going to some trouble—you can create files in the 
widely used Portable Document Format (PDF).

To create PDFs from a worksheet, follow these steps:

1. Select the range of cells you want to create the PDF from.

2. Choose File ➤ Print from the menu bar or press Cmd+P to display 
the Print dialog box. If the Print dialog box opens at its smaller size, 
click Show Details to expand the dialog box to its larger size.

3. Click the PDF button to display the PDF pop-up menu, then click 
Save as PDF. Excel displays the Save as PDF sheet (shown in 
Figure 13-3 with the navigation area expanded).
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4. Enter the file name in the Save As box.

5. Apply any tags, such as Work or Important, in the Tags box.

6. Specify the destination folder either in the Where pop-up menu or in 
the navigation pane.

7. In the lower half of the dialog box, enter any metadata the document 
needs: the title, author, subject, and keywords. Type a comma or 
press the Return key after each keyword or keyword phrase to create 
a keyword button.

Figure 13-3. In the Save as PDF sheet, you can add a title, author, subject, and any keywords needed to a PDF file 
you’re creating from an Excel worksheet
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9. Click the Save button. Excel closes the Print dialog box and saves 
the PDF. 

8. If you want to secure the PDF with a password for opening or 
printing it, click the Security Options button, then work in the PDF 
Security Options dialog box (see Figure 13-4). For example, you 
can select the Require password to open document check box and 
type a password if you want anybody who tries to open the PDF 
to provide a password. Click the OK button when you’ve finished 
choosing security options.

Figure 13-4. Use the PDF Security Options dialog box to apply a password to open the document or a password to print 
the document. You can also require a password for copying content from the PDF file

Tip If you just need to e-mail a PDF version of an entire workbook without adding metadata or 
applying a password, you can use Excel’s Share command. With the workbook open, click the Share 
button at the right end of the title bar and choose Send Attachment ➤ PDF; alternatively, choose 
File ➤ Share ➤ Send PDF from the menu bar. Either way, Excel creates a new message in your 
default e-mail application (for example, Outlook or Mail) and attaches a PDF file of the document to the 
message. You can then address the message, add a subject and any text needed, and then send it.
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7. Click the Save Active Sheet button to proceed with exporting just 
the active worksheet. If the worksheet contains any nontext items 
that Excel will need to strip out to create the CSV file, Excel displays 
the dialog box shown in Figure 13-6, warning you that it will remove 
some features. Most worksheets contain items that Excel will need to 
remove, so you’ll usually see this dialog box.

Exporting Data to CSV Files
When you need to share only the data from an Excel worksheet, you can export it to a 
comma-separated values (CSV) file. CSV is a very widely used standard for data exchange 
and consists of text with commas separating the contents of each cell. So when you export 
a worksheet to a CSV file, you export only the text—Excel strips out all formatting and 
nontext objects, such as charts or pictures.

To export a worksheet to a CSV file, follow these steps:

1. If the workbook contains any unsaved changes, save it.

2. Make active the worksheet you want to export.

3. Choose File ➤ Save As from the menu bar to display the Save As 
dialog box.

4. Specify the filename and choose the folder as usual.

5. In the File Format pop-up menu, choose Comma Separated  
Values (.csv).

6. Click the Save button. If the workbook contains more than one 
worksheet, Excel displays the dialog box shown in Figure 13-5, 
which warns you that it can’t save the workbook in CSV format 
because it contains multiple worksheets.

Figure 13-5. Click the Save Active Sheet button in this dialog box to export only the active worksheet to a CSV file
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8. Click the Continue button. Excel ceases its protests and saves the 
worksheet as a CSV file. 

Documenting Your Workbooks
When you’re creating a workbook and entering data in it, you’ll probably be clear about 
which data is which, why you’re laying the data out in the way you’ve chosen, and 
why you’re using particular types of charts or have decided to construct formulas in an 
idiosyncratic way.

But someone else who opens your workbooks may not intuitively grasp how you’ve done 
things. So when you create a workbook you plan to share with others, or when you prepare 
a workbook for sharing, it’s a good idea to document the workbook. This can save you time, 
bewilderment, and any number of infuriating questions in the days, weeks, or months to come.

Excel provides three main tools for documenting your workbooks:

	Text in cells

	Comments attached to cells

	Data-validation tools

We’ll look at each of these tools in turn.

Caution After you save a worksheet as a CSV file, Excel changes the workbook’s window name to 
that of the CSV file but continues to display the full workbook with all the nontext objects and other 
worksheets that the CSV conversion has stripped out. Don’t work in this workbook, because you’re 
not seeing the CSV file as it actually is. Instead, click the Close button or choose File ➤ Close to 
close the workbook. When Excel prompts you to save the changes you made to the workbook,  
click the Don’t Save button—there aren’t any changes you can save in this format. Then choose 
File ➤ Open Recent and click the CSV file on the Open Recent submenu. You’ll then see the CSV 
file as it actually is.

Figure 13-6. If Excel warns you that it needs to remove features to create the CSV file, click the Continue button
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Adding Explanatory Text to Workbooks
The most straightforward way to document a workbook is to enter text in the cells. You 
already know how to do this, so the only issue is what text to enter and how to format it so 
that nobody can miss it.

As a general rule, you’ll save yourself grief by explaining more than seems strictly necessary. 
For example, it should perhaps be obvious that the worksheet named Western Region Sales 
2016 contains sales results for the Western Region in 2016—but you should probably put 
that information in a cell at the top of the worksheet as well for anyone who doesn’t look at 
the worksheet tab. Similarly, even if the formulas you’ve used are standard and 
straightforward, it’s a good idea to make clear how the figures they show are derived. For 
this, you can either use text in nearby cells or attach comments to the cells themselves (as 
discussed in the next section).

Adding Comments to Cells
Entering explanatory text directly in cells makes it easy to see, but you may also want to 
add information using comments. A comment is text attached to a cell. Excel displays 
a comment indicator in the cell to indicate a comment is attached; when you hold the 
mouse pointer over the cell, the comment appears in a balloon. You can also display all the 
comment balloons on a worksheet, and rearrange them if they overlap.

Adding a Comment
To add a comment to a cell, follow these steps:

1. Make active the cell to which you want to add the comment.

2. Choose Review ➤ Comments ➤ New Comment from the Ribbon 
or Insert ➤ Comments ➤ New Comment from the Ribbon—
whichever you find more convenient—or Insert ➤ New Comment 
from the menu bar. Excel displays the comment marker and a red 
triangle in the upper-right corner of the cell, opens a comment 
balloon, and enters your user name in the balloon in boldface.

Tip For a complex workbook that contains many worksheets, add a Summary worksheet or 
Introduction worksheet at the beginning. On this worksheet, state the workbook’s purpose and enter 
a list of the worksheets and what they contain. You may also want to note who’s supposed—or 
permitted—to do what with the workbook. For example, managers must fill in their budget figures, 
while VPs are to look at the Executive Overview worksheet and approve the figures there but not 
mess with any other worksheets. You can add hyperlinks to the Summary worksheet to display 
particular worksheets, providing an easy way to navigate the workbook.
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3. Type the text of the comment. Figure 13-7 shows an example.

Tip Excel enters your user name (as set in Excel’s General preferences pane) in each comment 
for you, but you can edit the name if necessary, or simply delete it. To make your comments more 
readable or dramatic, you can apply text formatting to them. For example, click the Bold button or 
press Cmd+B to make selected text bold.

Figure 13-7. The red triangle at the upper-right corner of the Q2 cell here is the comment marker. Type or paste the 
text for the comment in the comment balloon

4. When you have finished creating the comment, click anywhere in the 
worksheet to move the focus from the comment. 

Note If the comment indicator doesn’t appear in the cell, Excel is set to hide comments and 
indicators. Choose Excel ➤ Preferences from the menu bar to open the Preferences window, and 
then click View to display the View preferences. In the For cells with comments, show area, select 
the Indicators only, and comments on rollover option button if you want to display comments only 
when the mouse pointer is over the cell. Select the Comments and indicators option button if you 
want to display both the indicators and their comments all the time.

 
Tip When you’re working with multiple versions of the same worksheet, you may need to paste 
comments from one worksheet to another. You can do this easily by using the Paste Special 
command. Select the range that contains the comments, then copy it to the Clipboard as usual 
(for example, press Cmd+C). Next click the cell at the upper-left corner of the destination range, 
choose Home ➤ Clipboard ➤ Paste ➤ Paste Special, select the Comments option button in the 
Paste area, then click the OK button. You can also give the Paste Special command by Ctrl-clicking 
or right-clicking the cell at the upper-left corner of the destination range and then clicking Paste 
Special on the contextual menu.
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Viewing Comments
Normally, Excel displays only the comment markers in a worksheet. To view a comment, 
you hold the mouse pointer over a cell that contains a comment, and Excel displays the 
comment in a balloon. You can also click the cell and then choose Review ➤ Comments ➤ 
Show/Hide Comment from the Ribbon to display a comment and keep it displayed while 
you move to other parts of the worksheet; click the Show/Hide Comment button again when 
you want to hide the comment once more.

If you want to display all the comments, choose Review ➤ Comments ➤ Show All 
Comments from the Ribbon.

To select the next comment, choose Review ➤ Comments ➤ Next. To select the previous 
comment, choose Review ➤ Comments ➤ Previous.

Deleting Comments
To delete a comment, follow these steps:

1. Select the comment. You can either click the cell that contains the 
comment or choose Review ➤ Comments ➤ Next or Review ➤ 
Comments ➤ Previous to select the comment.

2. Give the Delete command. Either press the Delete key or choose 
Review ➤ Comments ➤ Delete. 

Adding Information with Data Validation
As you saw in the section “Checking Input with Data Validation” in Chapter 4, you can apply 
data-validation formatting to a cell to make sure that the value the user enters in it meets 
your requirements. For example, you can use data validation to ensure that the value the 
user enters is between 250 and 1000 (inclusive) and to display an error alert message box if 
it’s not.

Tip You can edit a comment by Ctrl-clicking or right-clicking a commented cell and then clicking 
Edit Comment. Similarly, you can delete a comment by Ctrl-clicking or right-clicking a commented 
cell, and then clicking Delete Comment.

http://dx.doi.org/10.1007/978-1-4842-1019-2_4
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You can use data validation to add information to your worksheets in two ways:

	Display an input message. On the Input Message tab of the Data 
Validation dialog box (choose Data ➤ Data Tools ➤ Data Validation 
from the Ribbon, and then click the Input Message tab), select the Show 
input message when cell is selected check box, then type the title in the 
Title text box and the message in the Input message text box. When 
the user selects the cell, Excel displays a balloon containing the input 
message. This works like an automated comment and can be a great 
way of providing focused guidance on how to use a workbook.

	Display an error alert. On the Error Alert tab of the Data Validation dialog 
box, select the Show error alert after invalid data is entered check box, 
then specify the title and error message to include in the dialog box. 
You can also use this feature to provide detailed instructions for users of 
your workbooks.

Sharing Your Workbooks with Your Colleagues
You may create some workbooks on your own, but for others, you’ll probably need to  
work with colleagues to collect, enter, and analyze data. You can either share a workbook on 
the network so that one person can work on it at a time or turn on Excel’s sharing features 
that enable you and your colleagues to work on the workbook at the same time.

Before sharing a workbook, you may choose to protect it with a password or to allow your 
colleagues to make only some types of changes to it.

Protecting a Workbook or Some of Its Worksheets
Before sharing a workbook with your colleagues for editing individually on a network, you 
may want to restrict the changes your colleagues can make in the workbook or on some of 
its worksheets. Excel calls this protecting the workbook or worksheets.

Protecting a Workbook
To protect a workbook, follow these steps:

1. Choose Review ➤ Changes ➤ Protect Workbook from the Ribbon 
or Tools ➤ Protection ➤ Protect Workbook from the menu bar to 
display the dialog box shown in Figure 13-8.
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2. Select the Protect structure check box to prevent your colleagues 
from inserting, deleting, or otherwise changing whole worksheets.

3. Select the Protect windows check box only if you need to prevent 
your colleagues from changing the number or sizes of windows that 
you’re using for the workbook. Normally, you don’t need to do this if 
your colleagues will work conventionally in the workbook.

4. Type a password in the Password text box and in the Verify text box.

5. Click the OK button to close the dialog box.

6. Save the workbook. For example, click the Save button on the 
Standard toolbar or press Cmd+S. 

Note To unprotect a workbook, choose Review ➤ Changes ➤ Protect Workbook from the  
Ribbon or Tools ➤ Protection ➤ Unprotect Workbook from the menu bar. Excel displays a  
dialog box prompting you for the password. Type it, click the OK button, then save the changes to 
the workbook.

Figure 13-8. When protecting a workbook, you’ll normally want to protect the structure but not the windows
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3. Type a password in the Password text box and the Verify text box.

4. In the Allow users of this sheet to box, select each check box for 
actions you want your colleagues to be able to take. Clear the other 
check boxes.

5. Click the OK button. Excel closes the dialog box and applies the 
protection

6. Save the workbook. For example, press Cmd+S or click the Save 
button on the title bar.

Protecting a Worksheet
When you need to limit the changes your colleagues can make to a particular worksheet, 
apply protection to it. Follow these steps:

1. Click the worksheet to activate it.

2. Choose Review ➤ Changes ➤ Protect Sheet from the Ribbon or 
Tools ➤ Protection ➤ Protect Sheet from the menu bar to display 
the Protect the sheet and contents of locked cells dialog box (shown 
in Figure 13-9 with settings chosen).

Figure 13-9. Protect a worksheet when you need to prevent your colleagues from making specific types of changes to it
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2. Select the check box called “Track changes while editing. This also 
shares your workbook.” Excel then enables the other controls in the 
dialog box.

Tracking Changes to a Workbook
When you share a workbook with other people, you may need to track the changes they 
make to it so that you can easily review them without having to compare old and new 
versions of the worksheet. To track the changes, you turn on the Track Changes feature. 
When you turn on Track Changes, Excel automatically shares the workbook for you.

To turn on Track Changes and share a workbook, follow these steps:

1. Choose Review ➤ Changes ➤ Track Changes ➤ Highlight 
Changes from the Ribbon or Tools ➤ Track Changes ➤  
Highlight Changes from the menu bar to display the Highlight 
Changes dialog box (see Figure 13-10).

Figure 13-10. In the Highlight Changes dialog box, select the Track changes while editing check box, then choose 
which changes to save and whether to highlight them on screen
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Note Excel makes the List changes on a new sheet check box available only when you’ve turned 
on Track Changes and the workbook contains at least one tracked change. This means that you’ll 
need to close the Highlight Changes dialog box, make some tracked changes, then open the dialog 
box again before you can select the List changes on a new sheet check box.

3. To specify the time period over which to track the changes, select 
the When check box, open the pop-up menu, then click the 
appropriate item:

Since I last saved. Select this item to track only the changes since you last 
saved the workbook. If you save the workbook only after reviewing the 
changes, this can be a good way of keeping the number of changes down 
to a manageable level.

All. Select this item to track all the changes.

Not yet reviewed. Select this item to track changes only until you review 
them. This is another approach to keeping down the number of changes 
that remain in the workbook.

Since date. Select this item if you want to specify the date at which to begin 
tracking the changes. Excel suggests the current date, but you can change 
it as needed.

4. To choose whose changes Excel tracks, select the Who check box, 
open the pop-up menu, then click the Everyone item or the Everyone 
but Me item, as needed. (The idea is that you may not need to see 
the changes you yourself have made.)

5. To specify the range for which to track the changes, select the Where 
check box, then drag through the range in the worksheet to enter it 
in the text box. If you need to get the Highlight Changes dialog box 
out of the way, click the Collapse Dialog button, but usually it’s easier 
just to work around it. You can also type in the range if you prefer.

6. Select the Highlight changes on-screen check box if you want Excel 
to highlight the changes on screen. This is usually helpful.

7. Select the List changes on a new sheet check box if you want 
Excel to create a new worksheet and put a list of the changes on it. 
Creating this list can be a handy way of reviewing the changes, as 
you can add comments next to them if you need to.

8. Click the OK button to close the Highlight Changes dialog box. Excel 
displays the Alert dialog box (see Figure 13-11), telling you that it will 
save the workbook.
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Figure 13-11. After turning on Track Changes, Excel displays the Alert dialog box to tell you it will save the workbook. 
Click the OK button

9. Click the OK button. Excel saves the workbook and shares it.

After sharing a workbook by turning on Track Changes, you may need to adjust the sharing. 
To do so, follow the instructions in the next section.

Sharing a Workbook So That Your Colleagues Can Edit It
When you need to be able to work on a workbook with your colleagues, turn on sharing. 
Follow these steps:

1. Open the workbook.

2. Choose Review ➤ Changes ➤ Share Workbook from the Ribbon 
or Tools ➤ Share Workbook from the menu bar to display the Share 
Workbook dialog box. The left screen in Figure 13-12 shows the 
Editing tab of the Share Workbook dialog box, which is where you 
start the sharing process.
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3. Select the Allow changes by more than one user at the same time 
check box on the Editing tab.

4. Check the Who has this workbook open now list box. It should show 
only your name and should include the word Exclusive to indicate 
that you’ve got sole access to the workbook.

5. Click the Advanced tab to display its contents (shown on the right in 
Figure 13-12).

6. In the Track Changes area, choose how long to keep the change 
history for the workbook:

Normally, you’ll want to select the Keep change history for option button 
and set the number of days in the days box.

The default setting is 30 days, but if you develop your workbooks quickly, 
you may want to reduce the interval to 7 days or 14 days to prevent Excel 
from keeping large amounts of history you don’t need.

The alternative is to select the Don’t keep change history option button, 
but usually it’s best to keep change history so that you can unravel any 
mysterious changes.

Figure 13-12. On the Editing tab (left) of the Share Workbook dialog box, select the Allow changes by more than one 
user at the same time check box. You can then choose options on the Advanced tab (right)
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7. In the Update Changes area, choose when to update the changes to 
the workbook:

The default setting is the When file is saved option button, which generally 
works pretty well.

The alternative is to select the Automatically every option button and set 
the number of minutes in the minutes box. The default setting is  
15 minutes; if you work fast, you may want to shorten the interval to 5 or  
10 minutes.

If you select the Automatically every option button, you can choose 
between the Save my changes and see others’ changes option button 
(usually the better choice) and the Just see other users’ changes option 
button.

8. In the Conflicting Changes Between Users area, choose how to handle 
conflicting changes to the workbook. Normally, you’ll want to select 
the Ask me which changes win option button so that you can decide 
which of the conflicting changes to keep. The alternative is to select 
the option button called The changes being saved win, which tells 
Excel to overwrite the conflicting changes with the latest changes.

9. In the Include in Personal View area, select the Print settings 
check box if you want to include print settings in your view of the 
workbook. Select the Filter settings check box if you want to include 
filter settings. (See Chapter 10 for instructions on filtering an Excel 
database table.)

10. Click the OK button to close the Share Workbook dialog box. Excel 
sets up the sharing and adds “[Shared]” to the workbook’s title bar 
so that you can easily see it’s shared. 

Working in a Shared Workbook
Once you’ve shared a workbook or someone else has shared it, you can perform basic 
editing in it much as normal. You can enter data and formulas in cells or edit their existing 
contents, format cells, and use both drag and drop and cut, copy, and paste. You can also 
insert rows, columns, and even whole worksheets. 

Beyond these basics, Excel prevents you from making changes that may cause problems 
with the sharing. These are the main restrictions:

Tip When you store workbooks in a shared folder, either on your Mac or on a network, you may 
need to protect them with passwords so that only authorized people can open them. To apply a 
password to open or a password to modify, use the procedure described in the section “Protecting a 
Workbook with Automatic Backups and Passwords” in Chapter 3.

http://dx.doi.org/10.1007/978-1-4842-1019-2_10
http://dx.doi.org/10.1007/978-1-4842-1019-2_3
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	Apply conditional formatting. If your workbook needs conditional 
formatting, apply it before sharing the workbook.

	Insert objects. You can’t insert pictures, SmartArt, charts, hyperlinks, or 
various other objects.

	Insert or delete blocks of cells. You can insert or delete a whole row or 
column, but you can’t insert or delete a block of cells. You also can’t 
merge cells together.

	Delete a worksheet. You can’t delete a worksheet from the shared 
workbook.

	Protect a sheet with a password. Any protection you’ve applied before 
sharing the workbook remains in force, but you can’t apply protection to 
a sheet in a shared workbook.

	Outline the workbook. You can’t create an outline in a shared workbook. 
See the section “Creating a Collapsible Worksheet by Outlining It” in 
Chapter 3 for information on outlining a workbook.

Resolving Conflicts in a Shared Workbook
If you choose the Ask me which changes win option button when sharing the workbook, 
Excel prompts you to deal with conflicts that arise between the changes you’re saving and 
the changes that your colleagues have already saved. The Resolve Conflicts dialog box (see 
Figure 13-13) takes you through each of the changes in turn, showing the change you made 
and the conflicting change.

Figure 13-13. When you and another user have changed the same cells, the Resolve Conflicts dialog box walks you 
through each change in turn. You can accept all your changes, all your colleagues’ changes, or some of each

http://dx.doi.org/10.1007/978-1-4842-1019-2_3
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3. Use the controls in the dialog box to choose which changes Excel 
presents for your review:

When. Select this check box to specify a date range. Then open the  
pop-up menu and choose the Not yet reviewed item if you want to review 
all the changes you haven’t yet reviewed, or select the Since date item and 
enter the date in the text box.

Who. Select this check box if you want to specify whose changes you’ll 
review. Then open the pop-up menu and choose Everyone, Everyone but 
Me, or a user name.

Where. Select this check box if you want to see the changes in only part of 
the workbook. Then click in the text box and drag through the range in the 
worksheet.

Figure 13-14. In the Select Changes to Accept or Reject dialog box, choose which changes you want to review, then 
click the OK button

For each change, you can click the Accept Mine button to accept your change or click the 
Accept Other button to accept your colleague’s change. To clear all the changes at once, 
click the Accept All Mine button or the Accept All Others button. Excel closes the Resolve 
Conflicts dialog box automatically when you’ve finished reviewing the conflicts.

Reviewing Tracked Changes in a Shared Workbook
When you’ve tracked changes in a shared workbook, you can review them, accepting the 
changes you want to keep and rejecting the other changes. 

To review the tracked changes, follow these steps:

1. Open the shared workbook if it’s not already open.

2. Choose Review ➤ Share ➤ Track Changes ➤ Accept or Reject 
Changes from the Ribbon or Tools ➤ Track Changes ➤ Accept or 
Reject Changes from the menu bar to display the Select Changes to 
Accept or Reject dialog box (see Figure 13-14).
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5. Work through the changes using the Accept button and the Reject 
button. You can also take the nuclear option and click the Accept 
All button if you decide all the changes are worthwhile or the Reject 
All button if you decide they’re worthless; if you click either button, 
Excel closes the Accept or Reject Changes dialog box for you.

6. When you’ve worked your way through the changes, click the Close 
button to close the Accept or Reject Changes dialog box.

Merging Multiple Workbooks into a Single Workbook
When you have multiple versions of a workbook that you’ve shared with Track Changes on, 
you can merge them into a single workbook. 

Note You must turn on the Track Changes feature, as discussed earlier in this chapter, before you 
can merge workbooks. Until Track Changes is on, the Merge Workbooks command is unavailable.

The workbooks you’re going to merge must have different names from each other. You can’t 
merge workbooks that have the same name but are stored in different folders. (This limitation isn’t 
peculiar to merging—Excel refuses to have two workbooks open that have the same name.)

4. Click the OK button to close the Select Changes to Accept or Reject 
dialog box. Excel displays the Accept or Reject Changes dialog box 
(see Figure 13-15), which shows the number of changes and the 
details of the first change.

Figure 13-15. Use the Accept or Reject Changes dialog box to work your way through the tracked changes in a shared 
workbook
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To merge the workbooks, follow these steps:

1. Open the workbook into which you want to merge the changes.

2. Choose Tools ➤ Merge Workbooks to display the Select File to 
Merge into Current Workbook dialog box. Despite its long name, this 
is a standard dialog box for selecting files, like the Open dialog box.

3. Navigate to the workbook, then select it.

4. Click the OK button to merge the workbooks. Excel marks the cells 
that have changes.

You can then review the changes as described in the previous section.

Consolidating Multiple Worksheets into a Single 
Worksheet
When you work with many worksheets, you may need to consolidate worksheets of the same 
type into a single worksheet. For example, if you have a year’s worth of weekly spreadsheets 
containing sales figures, you may want to consolidate them to get yearly figures. 

Excel enables you to consolidate worksheets that have the same layout or worksheets 
that have different layouts but the same row labels or column labels. You can consolidate 
up to 255 source worksheets into the destination worksheet, either linking the destination 
worksheet to the source worksheets or copying the data from the source worksheets to the 
destination worksheet but not creating a link.

Preparing to Consolidate Worksheets
To consolidate worksheets, you need to open the destination worksheet so that you can 
enter information in it. 

When you’re consolidating just a few workbooks, you’ll usually also want to open the 
source workbooks so that you can create references to them easily; while you can create 
the references without opening the source worksheets, it’s more work, because you need 
to type in the references. When you’re consolidating dozens of workbooks, having them 
all open at once tends to be awkward, and you will usually find it easier to create the 
references using a single source workbook, then copy the references and edit them for the 
other workbooks.

Consolidating Worksheets by Their Position
When the worksheets you want to consolidate have the same layout, you can consolidate 
them by position. Consolidating by position essentially means getting data from the same 
cell address in each of the source worksheets.
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To consolidate worksheets by their position, follow these steps:

1. Open the workbooks that contain the source worksheets. If 
you’re consolidating source worksheets that are in the destination 
workbook, skip this step.

2. Open the destination workbook and activate the destination 
worksheet. If necessary, add a worksheet that will become the 
destination worksheet.

3. Make active the upper-left cell of the range you want to put the 
consolidated data in.

4. Choose Data ➤ Data Tools ➤ Consolidate to display the 
Consolidate dialog box (shown in Figure 13-16 with settings chosen).

Figure 13-16. In the Consolidate dialog box, set up the references to the source worksheets you want to consolidate 
into the destination worksheet

Caution For consolidating by position to work, the worksheets must have identical layouts. If 
any of the worksheets has a different layout, it won’t work—even if the difference is as little as a 
single row or column having been added or deleted. If you’re planning to consolidate worksheets by 
position, it’s a good idea to protect the worksheets against changes before having your colleagues 
work on them.
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Note If you need to open a workbook to add its reference, click the Select button in the 
Consolidate dialog box to display the Choose a Workbook dialog box. Click the workbook, and then 
click the OK button.

5. Open the Function pop-up menu and choose the function to use for 
the consolidation:

Sum. This function adds the numbers. This is the default function for 
consolidation.

Count. This function counts the number of items.

Average. This function returns the average of the values.

Max. This function returns the largest value.

Min. This function returns the smallest value.

Product. This function returns the product of multiplying the numbers.

Count Numbers. This function returns the count of numerical values.

StdDev. This function returns the standard deviation of the values.

StdDevp. This function returns the standard deviation based on an entire 
population.

Var. This function returns the variance based on a sample.

Varp. This function returns the variance based on an entire population.

6. Add the references to the All references list box. Follow these steps:

a. Click in the Reference box to place the focus there.

b. If you need to move the Consolidate dialog box out of the way, click the 
Collapse Dialog button. If you’ve got space to work around the dialog box, 
you don’t need to collapse it.

c. If the source worksheet is in another workbook, activate that workbook. For 
example, click its window or use the Window menu to switch to it.

d. Click the source worksheet’s tab to display the source worksheet.

e. Select the cell or range on the worksheet.

f. If you collapsed the Consolidate dialog box, restore it by clicking the Collapse 
Dialog button.

g. Click the Add button (the + button) to add the cell or range address to the All 
references list box.

h. Repeat these steps to add further references. On the assumption that you’re 
consolidating worksheets by position, Excel automatically suggests the same 
cell or range in each worksheet, so you don’t have to select the cell or range.
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To consolidate worksheets by category, follow these steps:

1. Open the workbooks that contain the source worksheets. If 
you’re consolidating source worksheets that are in the destination 
workbook, skip this step.

2. Open the destination workbook and activate the destination 
worksheet. If necessary, add a worksheet that will become the 
destination worksheet.

3. Make active the upper-left cell of the range you want to put the 
consolidated data in.

4. Choose Data ➤ Data Tools ➤ Consolidate to display the 
Consolidate dialog box (shown in Figure 13-16, earlier in this chapter).

7. Select the Create links to source data check box if you want Excel to 
create links to the source worksheets.

8. In the Use labels in area at the bottom of the Consolidate dialog box, 
clear the Top row check box and the Left column check box.

9. Click the OK button to close the Consolidate dialog box. Excel 
consolidates the data into the cell.

Consolidating Worksheets by Category
If the worksheets you want to consolidate don’t have identical layouts, but do have the same 
labels, you can use the labels to consolidate by category. 

For example, look at the two months of production results shown in Figure 13-17. The 
names in the Staff column appear in a different order in each, so you can’t consolidate by 
position. But because the labels are the same, you can consolidate by category. In effect, 
you’re telling Excel “give me the Week 1 result for Cheung’s row, whichever row that is” 
rather than “give me cell B1.”

Figure 13-17. When the source worksheets have consistent labels but a different layout, you can consolidate the 
worksheets by category
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5. In the Use labels in area, select the Top row check box if the labels 
are in the top row. Select the Left column check box if the labels are 
in the left column, as in the example.

6. Open the Function pop-up menu and choose the function. In 
this example, you’d select the Sum function, which is the default 
function.

7. Click in the Reference box to place the focus there.

8. Add the references using the method explained in step 6 of the list 
in the previous section. Select the consolidation range manually on 
each source worksheet.

9. Select the Create links to source data check box if you want Excel to 
create links to the source worksheets.

10. Click the OK button to close the Consolidate dialog box. Excel 
consolidates the data into the cell. 

Summary
In this chapter, you learned how to use Excel’s features for sharing your workbooks and 
collaborating with others.

You’ve learned how to make your worksheets print correctly by setting the print area and 
checking the page layout and breaks, and you know how to share your worksheets as PDF 
files or by exporting data to CSV files. You’re aware of the three main ways of documenting 
your workbooks, and you know how to implement sharing, tracking changes along the way. 
You’ve also learned how to merge multiple workbooks into a single workbook and how to 
consolidate multiple worksheets into a single worksheet.

Tip To update a consolidation, select the range that contains it, choose Data ➤ Data Tools ➤ 
Consolidate to display the Consolidate dialog box, then click the OK button. Excel updates  
the consolidation.
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 ■A
Absolute reference, 149
ACCRINT financial function, 185
ACCRINTM financial function, 185
Active cell, 14
ADDRESS lookup and reference function, 194
AMORDEGRC financial function, 185
AMORLINC financial function, 185
AND logical function, 191
Area chart category, 213
AREAS lookup and reference function, 194
Arithmetic operators, 150
AutoFill, using with formulas, 156–157
AutoSum pop-up menu, 169
AVERAGE( ) function, 177
AVERAGE, statistical function, 199
Axes, charts, 211
Axis titles, 211–212

 ■B
BAHTTEXT, text function, 200
Bar chart category, 213
BESSELI engineering function, 181
BESSELJ engineering function, 181
BESSELK engineering function, 181
BESSELY engineering function, 181
BIN2DEC engineering function, 181
BIN2HEX engineering function, 181
BIN2OCT engineering function, 181
BITAND engineering function, 181
BITLSHIFT engineering function, 181
BITOR engineering function, 181
BITRSHIFT engineering function, 181
BITXOR engineering function, 181
Built-in functions. See Functions

 ■C
CELL information function, 192
Cells and ranges

assign name, 86
Define Name dialog, 87
Reference area, 87

delete command, 90
formulas, 89
named ranges, automatically, 88
refers to, 91

Change and arrange windows dialog, 42
Chart area, 211
Chart axes, 211
CHAR, text function, 200
Charts

adding axis labels, 229
axis titles, 222
changing chart types, 216
changing source data, 216–218
components of, 209

categories and data series, 211
chart area and plot area, 211
chart axes, 211
chart title and axis titles, 211–212
data markers, gridlines, and data 

labels, 212
legend, 212

copy and paste format, 236
creation, 214
custom types, 237
data labels, 229
data series, 219
display gridlines, 231
embedded, 207, 209
from embedded to chart  

sheets, 215

Index
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in embedded workbooks, 240
Excel preferences window, 238
format pane, 235
layout, 218
legends, 228
paste into Word/PowerPoint, 242
scale/numbering

of axes, 222
horizontal axis, 222
vertical axis, 225

sheets, 207, 209
styles, 219
switching rows and columns, 216
titles, 211–212, 220
types, 212
walls and floors formatting, 232
to Word document/PowerPoint 

presentation, 238
CHOOSE lookup and reference function, 194
Circular references, removal of, 164
CLEAN, text function, 200
CODE, text function, 200
Colleagues sharing workbook. See  

Shared Workbook
Color scales, 250
Column Chart Category, 213
COLUMN lookup and reference  

function, 194
COLUMNS lookup and reference  

function, 194
Comma-separated values (CSV) file, 369
Comments to cell

add comment, 371
delete comment, 373
Show/Hide Comment, 373

Comparison operators, 150
COMPLEX engineering function, 182
CONCATENATE, text function, 200
Conditional formatting, 124

cell, 130
custom creation, 127
icon sets panel, 125
preset forms, 126
range, 130
rules, 128
worksheet, 130

CONVERT engineering function, 182
COUNTBLANK, statistical function, 199
COUNT( ) function, 167
COUNTIF, statistical function, 199
COUNT, statistical function, 199
COUPDAYBS financial function, 185
COUPDAYS financial function, 185
COUPDAYSNC financial function, 185
COUPNCD financial function, 185
COUPNUM financial function, 186
COUPPCD financial function, 186
Cube functions, 202
CUMIPMT financial function, 186
CUMPRINC financial function, 186
Custom views, 46
Cut and paste options, 57

 ■D
Data bars

creation
different cells than data, 248
same cells as data, 246

graphical representation, 245–246
Database creation, 285

banded column, 291
banded rows, 290
connections, 292

data formatting and  
layout, 294

existing sheet, 293
name, 294
new sheet, 293
pivot table, 293
query definition, 294
refresh control, 294

enter data, 291
excel tables, 285
external data source, 291
first column, 290
flat-file database, 286
header row, 290
import data, 296
last column, 291
ODBC driver, 292
refresh command, 296
relational database, 286

Charts (cont.)
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remove duplicate records, 299
sorting

filtering, 301
multiple fields, 297
single field, 297

table creation, 287
table resizing, 296
table styles panel, 289
total row, 290

Database functions, 178, 303
Data labels, 212
Data markers, 212
Data tables, 305

FV( ) function, 306, 309
with one variable, 306
with two variable, 309

Data validation, 130
allow pop-up menu, 131
check box, 132
error alert tab, 133, 374
input message tab, 132, 374
style pop-up menu, 134
tab settings, 131
warning dialog, 134

Date and time functions, 172, 178
Date options, 58
DATEVALUE date and time function, 179
DAVERAGE, database function, 178
DAY, date and time function, 179
DAYS360 date and time function, 179
DB financial function, 186
DCOUNTA, database function, 178
DCOUNT, database function, 178
DDB financial function, 186
DEC2BIN engineering function, 182
DEC2HEX engineering function, 182
DEC2HEX( ) function, 173
DEC2OCT engineering function, 182
DELTA engineering function, 182
Derive values, 321
DGET, database function, 178
DISC financial function, 186
DMAX, database function, 178
DMIN, database function, 178
DOLLARDE financial function, 186
DOLLARFR financial function, 186
DOLLAR, text function, 200
DPRODUCT, database function, 178

DSTDEV, database function, 178
DSTDEVP, database function, 178
DSUM, database function, 178
DURATION financial function, 187
DVAR, database function, 178
DVARP, database function, 178

 ■E
EDATE date and time function, 180
Edit Formatting Rule dialog box, 249
Edit options

animation feedback, 57
data range, 57
decimal places, 57
direct cells, 56
drag and drop, 56
formulas, 57
links update, 57
move selection, 57

EFFECT financial function, 187
Embedded charts, 207, 209

to chart sheets, 215
Engineering functions, 181–184
EOMONTH date and time function, 180
ERFC engineering functions, 182
ERFC.PRECISE engineering functions, 182
ERF engineering functions, 182
ERF.PRECISE engineering functions, 182
ERROR.TYPE information function, 192
EXACT, text function, 200

 ■F
FALSE logical function, 191
Financial functions, 184
FIND, text function, 200
FIXED, text function, 200
Format cells and ranges, 107

borders and fills, 119
cells alignment, 117
date and time codes, 115
Excel number formats, 109
font tab, 118
number format codes, 114
protection tab, 122
text format codes, 116
themes, 116
tools, 107
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Formula Builder, 169–170
Formulas, 146

absolute reference, 149
AutoFill, 156–157
background error checking, 158
calculation operators, 149–150

arithmetic operators, 150
comparison operators, 150
reference operators, 150
text operators, 150

complex, 154
breaking up, 156
nesting parts of, 155
operator precedence, 155
order of evaluation, 154–155

error checking pane, 157–158
indicating errors, 158
making one row/column refer to  

another, 148
mixed reference, 149
referring to cell, 146
referring to range, 148
relative reference, 149
reset ignored errors, 158
Show Errors For check box, 159
straightforward operators, 151
troubleshooting, 160

common errors, 160–161
error tracing, 162
removing circular references, 164
Show Formulas button, 162
Trace Precedents, 163

FORMULATEXT lookup and reference 
function, 194

Freeze, rows and column, 44
Functions, 146

all functions, 172
AVERAGE( ) function, 177
calculation preferences, 203

calculate worksheets, 204
calculation preferences pane, 205
controlling iteration of  

calculations, 204
compatibility, 173
components of, 167
COUNT( ) function, 167
cube, 173, 202
database, 172, 178
date and time, 172, 178

definition, 167
engineering, 173, 181
financial, 172, 184
Help window, 173
information, 172, 192
insertion (see Inserting functions)
INT( ) function, 177
logical, 172, 191
lookup and reference, 172, 194
math and trigonometry, 172
mathematical and trigonometric, 195
most recently used, 172
nesting of, 176
NOW( ) function, 168
ROUND( ) function, 177
statistical, 172, 198–199
SUM( ) function, 167–168, 177
text, 172, 199, 202
TODAY( ) function, 167–168, 172
WEEKDAY( ) function, 172

FV financial function, 187
FVSCHEDULE financial function, 187

 ■G
General preferences pane, 51
GESTEP engineering function, 182
GETPIVOTDATA lookup and reference 

function, 194
Goal Seek, 305, 321

derive values, 321
Gridlines, 212

 ■H
Headers and footers, 140
HEX2BIN engineering function, 182
HEX2DEC engineering function, 183
HEX2OCT engineering function, 183
HEX2OCT( ) function, 173
HLOOKUP lookup and reference function, 194
HOUR date and time function, 179
HYPERLINK lookup and reference  

function, 194

 ■I, J
Icon sets, 252
IFERROR logical function, 191
IF logical function, 191
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IFNA logical function, 191
IMABS engineering function, 183
IMAGINARY engineering function, 183
IMARGUMENT engineering function, 183
IMCONJUGATE engineering function, 183
IMCOS engineering function, 183
IMCOSH engineering function, 183
IMCOT engineering function, 183
IMCSC engineering function, 183
IMCSCH engineering function, 183
IMDIV engineering function, 183
IMEXP engineering function, 183
IMLN engineering function, 183
IMLOG2 engineering function, 183
IMLOG10 engineering function, 183
IMPOWER engineering function, 183
IMPRODUCT engineering function, 184
IMREAL engineering function, 184
IMSEC engineering function, 184
IMSECH engineering function, 184
IMSIN engineering function, 184
IMSINH engineering function, 184
IMSQRT engineering function, 184
IMSUB engineering function, 184
IMSUM engineering function, 184
IMTAN engineering function, 184
INDEX lookup and reference function, 194
INDIRECT lookup and reference  

function, 194
INFO information function, 192
Information functions, 192
Inserting functions, 168

with AutoSum button, 169
with AutoSum pop-up menu, 169
Formula Builder, 169–170
with function library pop-up menu, 174
by typing, 175

INT( ) function, 177
INTRATE financial function, 187
IPMT financial function, 187
IRR financial function, 187, 190
ISBLANK information function, 192
ISERR information function, 192
ISERROR information function, 192
ISEVEN information function, 192
ISFORMULA information function, 192
ISLOGICAL information function, 193
ISNA information function, 193

ISNONTEXT information function, 193
ISNUMBER information function, 193
ISODD information function, 193
ISOWEEKNUM date and time function, 180
ISPMT financial function, 187
ISREF information function, 193
ISTEXT information function, 193

 ■K
Keyboard shortcuts, 4, 10, 62

 ■L
Launchpad icon, 3
LEFT, text function, 200
LEN, text function, 200
Line chart category, 213
Logical functions, 191
Lookup and reference functions, 194
LOOKUP lookup and reference  

function, 194
LOWER, text function, 201

 ■M
MATCH lookup and reference function, 194
Mathematical and trigonometric  

functions, 195
MAX, statistical function, 199
MDURATION financial function, 187
MEDIAN, statistical function, 199
Menus, 4, 10
MID, text function, 201
MIN, statistical function, 199
MINUTE date and time function, 179
MIRR FINANCIAL FUNCTION, 187
Mixed reference, 149
MODE, statistical function, 199
MONTH date and time function, 179

 ■N
NA information function, 193
Nesting of functions, 176
NETWORKDAYS date and time  

function, 180
NOMINAL financial function, 188
Normal view, 39
NOT logical function, 191
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NOW date and time function, 180
NOW( ) function, 168
NPER financial function, 188
NPV financial function, 188, 190

 ■O
OCT2BIN engineering function, 184
OCT2DEC engineering function, 184
OCT2HEX engineering function, 184
ODDFPRICE financial function, 188
ODDFYIELD financial function, 188
ODDLPRICE financial function, 188
ODDLYIELD financial function, 188
OFFSET lookup and reference  

function, 194
Open extra windows, 42
OR logical function, 192

 ■P, Q
Page Layout view, 39
Paste Special dialog, 122
Pie Chart Category, 213
PivotTable, 329, 331

Builder window, 335
COUNT() function, 344
creation, 331, 333
data tab, 353

connection area, 355
data area, 354

Design tab, 346
Blank Rows, 348
grand totals, 346
Report Layout, 346
subtotals, 346

different data, 340
display tab

OLAP data source, 351
options, 350
Print area, 351

formatting
check boxes, 348
styles, 348

framework, 336
layout tab, 351

Report filter area, 353
settings, 352
Sort area, 353

refresh command, 355
renaming, 350
sorting and filtering, 356
source data, 355
SUM() function, 344
worksheet, 330–331

Plot area, 211
PMT financial function, 189
Portable Document Format (PDF), 366
PPMT financial function, 189
Preferences pane, 49
PRICEDISC financial function, 189
PRICE financial function, 189
PRICEMAT financial function, 189
Printing, 361

page layout, 362
setting print area, 362
worksheet/workbook, 364

PROPER, text function, 201
PV financial function, 189

 ■R
Radar chart category, 213
Range of contiguous cells, 15
RATE financial function, 189
RECEIVED financial function, 189
Reference operators, 150
Relative reference, 149
REPLACE, text function, 201
REPT text function, 201
Ribbon, 4

active tab, 6
collapse, 9
data tab, 7
definition, 5
formulas tab, 7
groups and controls, 8
home tab, 6
insert tab, 6
page layout tab, 6
review tab, 7
view tab, 7

RIGHT, text function, 201
ROUND() function, 177
ROW lookup and reference  

function, 194
Rows and columns, 101
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add, 96
column width, 105
delete, 96, 103
grouping, 95
hiding, 106
insert, 102
row height, 104
ungrouping, 96

ROWS lookup and reference function, 194
RRI financial function, 189
RTD lookup and reference function, 194

 ■S
Scatter chart category, 213
Scenario, 305

apply protection, 316
Collapse Dialog button, 314
creation, 313
definition, 311
edit and delete, 317
Financial Contribution column, 312
hide button, 315
Manager dialog, 313
merge command, 318
monthly rent column, 312
operating costs column, 312
prevent changes, 315
property address column, 312
property profitability column, 312
property profit column, 312
report creation, 319
switching, 317

Search box, 171
SEARCH, text function, 201
SECOND date and time function, 180
Set precision as displayed check box, 205
Shared Workbook

for editing, 379–381
merging, 384–385
protection, 374
resolving conflicts, 382–383
tracked changes in, 383–384
working restrictions, 381–382
worksheet protection, 376

SHEET information function, 193
SLN financial function, 190
Solver, 305

Add Constraint dialog, 325
cell reference, 325
Collapse Dialog button, 325
enable, 323
parameter dialog, 324
Solve button, 326

Sparklines
column, 256
formatting, 257
insertion, 257
plain, 256
single-cell charts, 256
win/loss, 256

Splitting, 40
Statistical function, 198–199
Stock chart category, 213
Style formatting

cell styles panel, 136
copy styles, 139
custom creation, 137
delete styles, 140
format cells dialog, 135

Style pop-up menu, 249
SUBSTITUTE, text function, 201
SUM() function, 161, 167, 177

extra arguments, 168
optional argument, 168
required argument, 168

Surface chart category, 213
SYD financial function, 190

 ■T
Table formatting, 135
Tab-separated values (TSV), 17
TBILLEQ financial function, 190
TBILLPRICE financial function, 190
TBILLYIELD financial function, 190
Text and formulas, 17

AutoCorrect
check box, 26
entry creation, 27
Preferences pane, 25
Replace-as-you-text, 27

AutoFill
built-in capabilities, 28
custom lists, 31
delete command, 30
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comma-separated format, 35
external data sources, 25
find and replace, 35
import data

CSV file, 17, 19
existing file, 18
FileMaker Pro database, 17, 22
HTML file, 17, 25
space-separated values, 17
TSV file, 17

insert symbols, 37
paste options, 32
table from word, paste, 35
transpose command, 33

Text functions, 199, 202
Text operator, 150
TEXT, text function, 202
3-D Clustered Column chart type, 214
Time and date functions. See Date and  

time functions
TIMEVALUE date and  

time function, 179
TODAY date and time function, 180
TODAY() function, 167–168, 172
TRANSPOSE lookup and reference  

function, 194
TRIM, text function, 202
TRUE logical function, 192
TYPE information function, 193

 ■U
UPPER, text function, 202
User interface elements

active cell, 13
cells, 13
column headings, 13
formula bar, 12
insert Sheetbutton, 13
record macro button, 13
reference area, 12
row headings, 12
scroll button, 13
select all button, 13
split boxes, 13
view buttons, 13
worksheet tabs, 13
zoom control, 13

 ■V
VALUE, text function, 202
VDB financial function, 190
View preferences pane

display comments, 54
display objects, 55
formula bar, 53
formulas, 54
gridlines, 54
outline symbols, 54
page breaks, 54
ribbon options, 55
row and column headers, 54
ScreenTips, 54
sheet tabs, 53
Zero values, 54

VLOOKUP lookup and reference  
function, 194

 ■W
WEEKDAY date and time function, 180
WEEKDAY() function, 172
WEEKNUM date and time function, 180
Workbook(s), 67

AutoRecover files, 60
cells and ranges (see Cells and ranges)
creation, 59
documentation, 370

comments to cells, 371
data validation, 373
text in cells, 371

existing workbook, 69
merging, 384
MS excel dialog box, 68
no contents/formatting, 68
open one or more, 64
passwords, 70
problems, 80

older version, 80
trickier, 81

properties, 62, 73
custom tab, 75
find options, 77
summary tab, 75

save command, 70
save, default format, 59
shared (see Shared Workbook)

Text and formulas (cont.)
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templates, 69
creation, 98
overview, 97
save command, 98

worksheets (see Worksheet)
WORKDAY date and time function, 180
Worksheet(s), 82

adjusting pictures, 270
cropping, 271
picture style, 271
saving space, 273
sharpness, brightness, contrast and 

colors, 270
consolidate

by category, 388
by position, 385
reference creation, 385

data to CSV file, 369
delete, 82
graphical objects

order arrangement, 281
positioning, 269, 279
rotation, 268

headers and footers, 140
inserting pictures, 262

from Mac’s file system, 263
from Photos App, 262

lay out rules, 84
multiple data, 85
naming, 82
navigation, 14
outlining, 91

collapsed sheets, 92
expand and collapse, 96
formula creation, 92
remove command, 97
rows/columns, 95
settings, 94

PDFs shared, 366
printing, 364
rearrange order, 83
shapes

insertion, 264
styles, 266

SmartArt feature, 274
tab color, 82
WortArt feature, 277

 ■X
XIRR financial function, 190
XNPV financial function, 190
XOR logical function, 192

 ■Y
YEAR date and time function, 179
YEARFRAC date and time function, 179
YIELDDISC financial function, 191
YIELD financial function, 190
YIELDMAT financial function, 191

 ■Z
Zoom dialog, 44
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