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Introduction

Welcome to Dreamweaver CS6: Visual 
QuickStart Guide! Adobe Dreamweaver 
has long (initially under its previous name, 
Macromedia Dreamweaver) been the 
premier visual tool for Web site developers, 
allowing you to build great-looking Web 
pages and smoothly running Web sites. 
Dreamweaver’s ease-of-use takes much of 
the pain out of creating Web sites, without 
sacrificing flexibility. It’s possible to use 
Dreamweaver to create terrific Web sites 
without knowing much about HTML, CSS, 
and JavaScript. 

Dreamweaver is a rich, powerful, and deep 
program, and at first glance, it can be a bit 
intimidating. We’ve written this book as 
a painless introduction to Dreamweaver 
and its features, and with our help, you will 
use Dreamweaver to build an excellent 
Web site. 

Using this Book
We’ve organized the different elements of 
building Web sites with Dreamweaver CS6 
into chapters, and within each chapter are 
numbered, step-by-step directions that 
tell you exactly how to accomplish various 
tasks. You don’t have to work through the 
entire book in order, but it is structured so 
the more complex material builds on the 
earlier tasks. 

We start with an overview of Dreamweaver, 
move on to setting up your Web site and 
creating your first Web page, then discuss 
how to add content, structure, and interac-
tivity to your pages. Finally, we show you 
how to work with HTML code and manage 
your Web site. 

When we first decided to write this book, 
we wanted to take a fresh look at Dream-
weaver—at how people use it, and how 
people should use it. Throughout the book, 
we’ve tried to show you how to use Dream-
weaver using its most modern features, 
rather than using some of the features that 
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are still in the program but that are “old 
school.” Specifically, we’ll show you how 
to apply styles and lay out your page ele-
ments using Cascading Style Sheets, rather 
than older, obsolete methods. If you don’t 
know what that means, don’t worry; it’s all 
explained in Chapters 7 through 9. 

For keyboard commands, we’ve included 
Mac keyboard shortcuts in parentheses 
immediately after the Windows shortcut, 
like this:

To open the Find & Replace dialog, press 
Ctrl-F (Cmd-F).

While writing this book, we’ve made the 
assumption that you’re familiar with the 
basics of using Windows or OS X. You 
don’t need to be a computer expert by any 
means, but you shouldn’t be stumped by 
concepts like selecting text, using menus, 
clicking and dragging, and using files and 
folders. Naturally, you should be familiar 
with Web surfing and how to use a Web 
browser to view a Web site.

Tips

Throughout the book we’ve included 
many tips that will help you get things done 
faster, better, or both. 

Be sure to read the figure captions, too; 
sometimes you’ll find extra nuggets of infor-
mation there.

When we’re showing HTML, CSS, or 
JavaScript code, we’ve used this code font. 
We also use the code font for Web addresses.

You’ll also find sidebars (with gray back-
grounds) that delve deeper into subjects. 

Getting the most from Dreamweaver
Dreamweaver is a professional-class tool, 
and it provides professional results. Dream-
weaver allows you to build Web sites visu-
ally, without needing to know the details 
of HTML, CSS, and JavaScript. But to best 
use Dreamweaver, you will still need some 
fundamental knowledge of what these lan-
guages are, and how they work together 
to make up a Web site. Similarly, you will 
find it helpful to know basic things such 
as what a Web page is and what a Web 
server does.

Where necessary, throughout this book 
we explain what you’ll need to know 
about HTML, CSS, and JavaScript to work 
with Dreamweaver. But there is much 
more to say about these subjects, and 
there are thousands of books devoted 
to that job. In fact, we wrote one of the 
most popular books on JavaScript. You’ll 
find information about that book, as well 
as some of our favorite Web design and 
development books written by other 
authors, in Appendix A.

A note for our Mac-using friends
If you’ve flipped through this book already, 
you probably noticed that the vast major-
ity of the screenshots were taken on 
machines running Windows. That doesn’t 
mean that the book (or its authors) doesn’t 
welcome Dreamweaver users on the Mac. 
Far from it; in fact, both of us are primarily 
Mac users, and we are frequent contribu-
tors to Macworld magazine and other Mac-
oriented publications.

However, our crack research department 
tells us that most Dreamweaver users 
are running the program on Windows 
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machines, so we have included screen-
shots that will reflect the experience of the 
majority of our readers. Happily, Dream-
weaver works almost identically on both 
platforms. In the few cases where there are 
differences, we’ve included separate pro-
cedures for Windows and for Mac users.

There is one other thing that we haven’t
done in this book that we have done in 
our previous Mac books. We are no longer 
telling Mac users to Control-click to bring 
up a context menu (also known as a short-
cut or contextual menu). Instead, we’ve 
adopted right-click, because Apple now 
ships its multiple-button mouse with all of 
its computers that come with a mouse. If 
you are using a Mac with a trackpad, just 
mentally substitute Control-click wherever 
you see right-click in the book. Better 
yet, we suggest that you get any USB 
or wireless mouse with multiple buttons 
and a scroll wheel. It will really increase 
your productivity.

There’s more online
We’ve prepared a companion Web site for 
this book, which you’ll find at:

www.dreamweaverbook.com

On this site, you’ll find news about the 
book and links to other online resources 
that will help you use Dreamweaver CS6 
more productively. If we discover any 
mistakes in the book that somehow got 
through the editing process, we’ll list the 
updates on the site, too.

Because of space limitations in the paper 
edition, we’re taking some sections that 
were in previous editions of the book 
and posting them on the Web site. These 
bonus chapters have been updated for 

Dreamweaver CS6. By moving them to 
the Web, we can also easily keep them 
up to date between paper editions of the 
book. If you bought the paper edition, you 
can download the bonus chapters from 
our site. If you bought the ebook edition, 
there’s no need to download the bonus 
chapters; the ebook edition includes all the 
bonus chapters.

If you have any questions about the book’s 
contents, please first check the FAQ 
(Frequently Asked Questions) page on the 
companion Web site. It’s clearly marked. 
If you’ve read the FAQ and your question 
isn’t answered there, you can contact us 
via email at dwcs6@dreamweaverbook.com.  
We regret that because of the large vol-
ume of email that we get, we cannot, and 
will not, answer email about the book sent 
to our personal email addresses or via the 
contact forms on our personal sites. We 
can promise that messages sent only to 
the dwcs6@dreamweaverbook.com email 
address will be read and answered, as time 
allows. Unfortunately, due to the danger 
of computer viruses being spread with 
email attachments, we cannot accept any 
messages with attachments. We also must 
limit ourselves to responding to questions 
about the book; time doesn’t permit us 
to answer general questions about Web 
design and development.

Let’s get started
Every journey begins with a first step, and 
if you’ve read this far, your journey with 
Dreamweaver has already begun. Thanks 
for joining us, and let’s get started building 
your great Web site. 

—Tom Negrino and Dori Smith, June 2012

www.dreamweaverbook.com
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Introducing 

Dreamweaver
Welcome to the world of Dreamweaver! 
The premier Web design and develop-
ment tool from Adobe may appear a little 
daunting at first, so this chapter shows you 
what’s what and what’s where. Once you 
understand what all the parts of its interface  
do, you’ll soon find that Dreamweaver is 
an invaluable application for creating and 
maintaining Web sites.

In this chapter, you’ll learn about the 
Dreamweaver Welcome screen and docu-
ment window. Then you’ll see the plethora 
of toolbars and panels included with the 
software: the menu bar, the Document tool-
bar, the Browser Navigation toolbar, and 
the Standard toolbar. The Status bar, the 
Property inspector, the Insert panel, and 
other panels are next, and then you’ll learn 
about the included workspace layouts and 
how to set up your own custom workspace. 
Finally, there’s a summary of the new fea-
tures in Dreamweaver CS6.

In This Chapter
A Quick Tour of Dreamweaver 2

Setting Up Your Workspace 19

What’s New in Dreamweaver CS6 22
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A Quick Tour of 
Dreamweaver
In this section, you’ll learn about the dif-
ferent windows, panels, pages, views, 
toolbars, and inspectors that make up the 
Dreamweaver experience. Whether you’re 
a novice to Web design, an experienced 
pro who’s new to Dreamweaver, or some-
one who primarily wants to know what’s 
new in Dreamweaver CS6, this will bring 
you up to speed.

The Welcome screen
The first time you launch Dreamweaver, 
you’ll see the Welcome screen, as shown 
in A. This page (which changes based 
on what you’ve recently done in Dream-
weaver) is your starting point for creating 
and modifying pages and sites. If you close 
all your open Dreamweaver windows, the 
Welcome screen reappears. A list of recently 

opened items

New blank 
pages of each of 
the below types

Video clips explaining 
top features

Displays an online interactive tutorial

Shows the New Features 
documentation in your default browser

Takes your default browser 
to online training resources

Shows the Dreamweaver Exchange 
site in your default browser

If you don’t want to see 
the Welcome screen 
again, select this box

Shows the New 
Document dialog

This link opens more 
online assistance in 
your default browser

A Dreamweaver’s Welcome screen will soon become familiar—
but if you don’t want to see it, you can make it go away.
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The Welcome screen consists of several 
sections:

n	 Open a Recent Item: This section 
contains a list of the nine most recently 
opened items in Dreamweaver. If you’ve 
opened fewer than nine, it shows just 
that number; if you’ve never used 
Dreamweaver, it appears with just a 
button showing an Open folder; clicking 
the button displays the Open dialog, 
just as if you had chosen File > Open.

n	 Create New: If you want to create a new 
page or site, this is the column for you. 
Choosing one of these options creates 
a new HTML, ColdFusion, PHP, CSS, 
JavaScript, XML, or fluid grid layout file. 
You can also create a new Dreamweaver 
or Business Catalyst site. In addition, you 
can choose More, which will display the 
New Document dialog B, about which 
you’ll learn more later.

continues on next page

B The New Document dialog offers a multitude of choices.

www.allitebooks.com

http://www.allitebooks.org
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n	 Top Features (videos): If you’re the type 
of person who likes video training, these 
clips open in your default browser and 
give you an overview of some of the 
new features in Dreamweaver CS6. This 
section may change from time to time as 
Adobe updates the video selection.

n	 Getting Started: Choosing this option 
gives you a quick tour of Dream-
weaver’s functionality. You’ll see a short 
online tutorial on Adobe’s Web site.

n	 New Features: This opens the online 
New Features documentation using 
your default browser.

n	 Resources: If, despite having this book, 
you still want further training, you 
can follow this link to find additional 
resources on Adobe’s site.

n	 More Help: This link, at the lower-right 
corner of the window, takes you to Ado-
be’s Web site for more help resources.

n	 Dreamweaver Exchange: Dreamweaver 
is built with an extensible architecture—
that is, it’s easy to add functionality 
to Dreamweaver that wasn’t included 
when it shipped. That’s done through 
a technology called extensions, which 
are bits of software that extend Dream-
weaver’s capabilities.

You can get additional extensions 
through the Adobe Dreamweaver 
Exchange at www.adobe.com/exchange/
by clicking the Dreamweaver category. 
Some of them have an additional 
charge, and some are free, but it’s worth 
checking out what’s available when 
Dreamweaver alone doesn’t scratch 
your itch. See Appendix B “Customizing 
and Extending Dreamweaver” for more 
information.

www.adobe.com/exchange/
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n	 Don’t show again: Adobe knows that 
although some people love the Wel-
come screen, other people aren’t so 
fond of it. Throughout this book, you’ll 
see many examples of how you can 
personalize your copy of Dreamweaver 
so that it works just the way you want it 
to. Here, you can choose to never see 
the Welcome screen again.

If you reconsider, though, it’s easy to 
bring back the Welcome screen: in 
Dreamweaver, choose Edit (Windows) /
Dreamweaver (Mac) > Preferences > 
General > Document Options, and select 
the Show Welcome Screen check box.

Editor setup (Windows only)
If you’ve just launched Dreamweaver for 
the first time and you’re using Windows, 
you’ll see a dialog before the Welcome 
screen A. The Default Editor dialog lets 
you choose which file types you want to 
tell Windows to assign to Dreamweaver as 
the primary editor. In other words, when 
you double-click a file with one of the listed 
extensions, Dreamweaver will launch to 
edit the file.

Many of these file types are types that are 
used with the kinds of Web sites that we 
won’t be covering in this book, but unless 
you have a preference for a different edit-
ing program, there’s no harm in clicking the 
Select All button in the dialog. You should 
make sure that at least the JavaScript, 
Cascading Style Sheets, and Extensible 
Markup Language choices are selected. 
The Default Editor dialog appears only the 
first time you run Dreamweaver.

A Windows users will see the Default Editor 
dialog the first time they launch Dreamweaver.
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The menu bar
The Dreamweaver menu bar looks about 
like what you’d expect to see on your plat-
form. There is one big difference between 
the Windows menu bar A and the Mac 
menu bar B: the latter also contains a 
Dreamweaver menu. On it are the About 
Dreamweaver, Keyboard Shortcuts, and 
Preferences menu options. On Windows, 
the first can be found under Help, and the 
latter two under Edit. And of course, the 
Windows menu bar is part of the Dream-
weaver window, whereas on the Mac the 
menu bar is always at the top of the screen.

The other big difference is that on Windows, 
the Layout, Extend Dreamweaver, Site, and 
Workspace menus and the Search online 
help field, which together are called the 
Application bar, usually (if the window is 
maximized or wide enough) appear as part 
of the menu bar. On Mac, these appear in a 
separate toolbar below the menu bar.

On both platforms, you can turn the 
Application bar off (and on Mac, recover some 
valuable vertical screen real estate) by choosing 
Window > Application Bar. Since the Application 
bar contains items that you probably won’t use 
every day (and are also available via the regular 
menu bar), hiding it is usually a good idea.

A The Dreamweaver menu bar on Windows.

Menu bar Application bar

Layout menu

Extend Dreamweaver menu

Site menu

B The Dreamweaver menu bar on a Mac, which includes an additional Dreamweaver menu and the 
Application bar below.
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The document window
Now that you’ve opened a file, you see the 
document window and all its surrounding 
panels, inspectors, and so on A. It may 
look busy and cluttered at first, but you’ll 
soon learn your way around.

The document window shown here is a 
blank white Web page, ready for you to 
add your design and content. If you want, 
you can just click inside the window and 
start typing away! The details of creating 
a Web page are covered in Chapter 3.

Document toolbar Menu bar Workspace Switcher

Search online help field

Insert panel

Tag selector Document window Property inspector Status bar CSS Styles 
panel

Files 
panel

A This shows your basic vanilla Dreamweaver document window, but you can modify it to fit your work habits.
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New to Dreamweaver CS6 on the Mac is 
the Application frame, which gathers all 
of Dreamweaver’s panels and windows—
including the document window—in a 
single window, allowing you to move the 
program’s interface as a group. Or to put 
it another way, Dreamweaver on the Mac 
can now be made to work like it does on 
the Windows version, with the exception 
that the menu bar still stays at the top of 
the Mac screen instead of being part of the 
application window, as it is on Windows. If 
you don’t want to use the Application frame 
on Mac, you can turn it off by clearing the 
check mark next to Window > Application 
Frame. Dreamweaver will then display 
free-floating panels, which can be placed as 
you wish. Even though we’re hard-core Mac 
users, we preferred using the Application 
frame, as it requires less mouse travel to get 
from one panel to another.

If you have multiple files open at once (a 
fairly common occurrence), you’ll see a row 
of tabs across the top of the document win-
dow B. To go from one file to another, just 
click the name of the file you want to edit.

Don’t like tabs? Dreamweaver lets you get 
rid of them:

n	 Windows: When you open a document 
in Dreamweaver, click the Restore 
Down button C in the upper-right 
corner of the document window (not 
the one in the Dreamweaver window). 
Once one document has been moved 
into its own window, all the others auto-
matically move, too. To go back to the 
original view, click the Maximize button 
(which has replaced the Restore Down 
button) in the upper-right corner of any 
of the open document windows.

n	 Mac: Tabs are the normal interface in 
Windows, so Windows users have to 
manually lose the tabs any time they 

B Switch from document to document by clicking 
the tab with the document name.

C On Windows, the Restore Down 
button changes Dreamweaver from a 
tabbed view to a multiple document view.
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want to do without them. Dreamweaver 
allows Mac users to choose whether 
or not to use tabs (they are active by 
default). This can be set by choosing 
Dreamweaver > Preferences > General >  
Document Options and selecting (or 
not) “Open documents in tabs.”

The Document toolbar
Below any document tabs you have open, 
you’ll find the Document toolbar A. The 
Document toolbar consists of three parts:

n	 View mode buttons: These let you 
choose between Design, Code, and Split 
views of your document. This area also 
includes the Live button, which turns on 
Live view—a rendered view of your page 
right in the document window. When 
you turn on Live view, two more buttons 
appear: Live Code and Inspect B.  See 
“Using document views” for more on 
what each of these does and when you’d 
want to choose each. Live Code view is 
discussed in Chapter 17, “Editing Code.”

n	 The page title: Every page needs a 
descriptive title, and here’s where you’ll 
change yours. The page title, and how 
it differs from the name of a page, will 
be covered in Chapter 3, “Building Your 
First Page.”

n	 Miscellaneous buttons: These contain 
everything from a “preview in browser” 
button, to a button to validate content, 
to a button to show additional visual 
aids inside Dreamweaver.

A The Document toolbar on Windows.

B When you turn on Live view, the Live Code 
and Inspect buttons are added to the toolbar.
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Using document views
The six document views allow you to 
choose which version of the document you 
want to see:

n	 Design: A shows a Web page in Design 
view. This mode, known as WYSIWYG 
(What You See Is What You Get), allows 
you to get an idea of how your page 
will appear when viewed in a browser. 
For the most part, almost everything 
you want to do in Dreamweaver can be 
done in Design view, and this book will 
be largely about what you can do here 
(except for Chapter 15, “Working with 
Content Management Systems,” and 
Chapter 17, “Editing Code”).

n	 Code: B shows the exact same page 
in Code view. Here’s what the underly-
ing markup and tags look like. Although 
Chapter 17 will cover the ins and outs of 
tags, many people work quite well with 
Dreamweaver without ever using Code 
view. Note that in Code view, you get a 
new toolbar (also covered in Chapter 17) 
down the left side of the document 
window, with specialized tools to work 
with code.

n	 Split: C shows the same page, again, 
in Split view. If you can’t decide whether 
you want to look at code or design, 
Split lets you have the best of both, 
with code in one pane and Design 
view in another. It’s a great way to start 
to learn about markup, and it’s also 
handy for control freaks (you know 
who you are) who want to tweak their 
tags to be just so and simultaneously 
see how their design looks. You can 

A A Web page displayed in Design view.

B The same Web page displayed in Code view.

Split bar

C And the same Web page displayed in Split view.
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resize the amount of space taken up by 
each of the two views by dragging the 
split bar between the two panes. With 
the View > Split Vertically and View > 
Design View commands, you can also 
choose to have the split be vertical or 
horizontal, and to have Design view 
in the left or top panes rather than the 
default right or bottom panes.

n	 Live: This view is perfect for giving you 
a good idea of what pages powered by 
JavaScript or other code will look like 
in a browser. With Live view, a browser 
engine (the cross-platform WebKit, 
the engine used by Apple’s Safari and 
Google’s Chrome browsers) is built into 
Dreamweaver, and clicking the Live but-
ton displays the page using WebKit in 
the document window D.

n	 Live Code: This button splits the 
window into Live view in the Design 
pane and opens the Code pane. If your 
Web page uses JavaScript or Ajax for 
visual effects, the scripts will actually be 
rewriting the HTML under script control 
as the user interacts with the page. Live 
Code view allows you to see how the 
HTML changes as you interact with the 
page in Design pane. You’ll learn more 
abut Live Code view in Chapter 17.

n	 Inspect: This button also enhances 
Live view. It allows you to turn on CSS 
Inspect mode, which outlines and 
highlights the CSS block styles in the 
Design pane as you move the cursor 
over the different blocks. There’s more 
about CSS Inspect mode in Chapter 9.

D Live view allows you to see how a page looks 
in Dreamweaver’s regular editing mode (top) and 
how it would look rendered in a browser (bottom). 
Note that in Live view the table shows CSS styling, 
as well as its JavaScript-driven ability to sort the 
table by clicking its column headings.
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The Browser Navigation toolbar
The Browser Navigation toolbar A, which 
automatically appears when you enter Live 
view, allows you to navigate from page to 
page in a natural way when you are using 
Live view. It includes an address field and 
the usual Back, Forward, Refresh, and 
Home buttons. It also includes a button that 
allows you to access Live view options.

The Related Files bar
Modern Web pages often have several 
supporting files that help make up the 
page. For example, what appears to the 
user as a single Web page may actually 
consist of an HTML file, a CSS file, and a 
JavaScript file. The Related Files feature 
adds a bar with the names of these sup-
porting files under the documents tab B. 
You’ll learn more about using the Related 
Files feature in Chapters 7 and 15.

Other toolbars
If you right-click in a blank part of the Doc-
ument toolbar, you’ll see that there are two 
other bars that aren’t enabled by default:

n	 Style Rendering bar: If you’ve set 
up your CSS style sheets so that 
your pages appear differently in, for 
example, a screen view versus a page 
designed for printing, this is what you’ll 
use to switch between the two style 
renderings C. Most of the time, you’ll 
just want the default screen view. The 
Toggle button works a little differently: 
It toggles the page between a view that 
includes the rendered CSS styles and a 
view with CSS styles turned off.

A The Browser Navigation toolbar allows you to 
move between pages in your site, much as you 
would in a stand-alone Web browser.

Related files

B The Related Files bar makes it easy to switch 
to files that are attached to the current document, 
such as CSS or JavaScript files.

Toggle button

C The Toggle button on the Style Rendering 
toolbar allows you to view the page with or without 
any attached CSS styles.

D The little-used Standard toolbar gives you 
access to functions such as Save, Copy, Paste, 
and Undo.

n	 Standard bar: While Adobe refers to 
this bar as “standard,” it’s actually used 
to make Dreamweaver feel more like a 
word processing application D. Some 
examples of what it contains—New, 
Open, Save, Print, Cut, Copy, Paste—
give you an idea of what’s here. As with 
the Style Rendering bar, the chances 
are that Adobe’s default for these tool-
bars (off) is what you’ll want to use.

You can turn off any of the four toolbars 
(Style Rendering, Document, Standard, or 
Browser Navigation) if you want the clean-
est possible layout (for instance, if you’re 
working on a very small screen). To turn 
them back on, choose View > Toolbars, 
and select the ones you want to see again.
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control, a pop-up menu, shows the cur-
rent zoom percentage of the page. Next 
are three preset window size buttons, for 
Mobile, Tablet, and Desktop screen sizes. 
After that is the window size currently 
being displayed; click this to get a pop-up 
menu of available window sizes C. If you 
don’t like the default values for these last 
two controls, you can change either or 
both by selecting Edit Sizes from the pop-
up menu, which opens the Window Sizes 
pane of the Preferences panel. We’ll cover 
this more extensively in Chapter 12. Next 
is an estimate of how long it would take 
a browser to download this page. Finally, 
the status bar tells you the document text 
encoding for the page. The encoding tells 
the browser which character set should be 
used to display the fonts on the page.

A The tag selector at the bottom of the document 
window makes it easy to select all the contents of 
a tag.

Select 
tool

Zoom 
tool

Window 
sizes

Current 
window size

Text 
encoding

Hand 
tool

Zoom 
percentage

Download 
time

B The controls on the right side of the Status bar.

The Status bar
The Status bar is the bottommost part 
of the document window. It’s often also 
referred to as the tag selector, although 
that’s really the correct name for just the 
leftmost part. Click anywhere in a docu-
ment, and the tag selector shows you the 
current tags based on the current location 
of the cursor. You can then click any of the 
tags in the tag selector A to select every-
thing contained within that tag. Clicking 
the <body> tag always selects the entire 
contents of the page.

The rightmost side of the Status bar con-
tains more controls B. The Select, Hand, 
and Zoom tools let you (respectively) select 
objects on the page, scroll around the 
page, and zoom into the page. The next 

C Use this pop-up menu to choose the 
dimensions of your document window.

www.allitebooks.com
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The Property inspector
At the bottom of the screen is the Property 
inspector A. Based on what is selected 
in the document window, different options 
appear in this inspector; that is, if you’ve 
selected some text, you’ll see text options, 
but if you’ve selected an image, image 
options appear. The Property inspector can 
be used to view and modify the displayed 
options. The many uses of the Property 
inspector will be covered throughout the 
rest of the book.

In the lower-right corner of the inspector is 
an expand/collapse triangle. Depending on 
its current state, this either expands or col-
lapses the inspector. This lets you choose 
whether you want to display the extra 
information shown in the bottom half.

The Property inspector has two tabs: HTML 
and CSS. Depending on which tab you’re 
on, Dreamweaver will apply properties of 
that type. For example, if you’re on the 
HTML tab, select some text in the docu-
ment window, click the Italic button, and 
Dreamweaver will apply the style using the 
HTML <em> tag. If you’re on the CSS tab of 
the Property inspector B, select some text, 
click the Italic button, and Dreamweaver 
will walk you through creating a new CSS 
style rule for the selection.

A The HTML tab of the Property inspector.

B The CSS tab of the Property inspector.
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The panels
Along the right side of the Dreamweaver 
window are panels. In the default instal-
lation of Dreamweaver A, the Adobe 
BrowserLab, Insert, CSS Styles, AP Ele-
ments, Business Catalyst (a Web site host-
ing service from Adobe), Files, and Assets 
panels are visible and docked (in the default 
Designer workspace; more about work-
spaces later in this chapter). Also available, 
although not visible until you turn them on, 
are Databases, Bindings, Server Behaviors, 
Components, Snippets, CSS Transitions, Tag 
inspector, Behaviors, History, Frames, Code 
inspector, and Results. These can all be 
found under the Window menu.

The different panels appear by default 
in the dock area on the right side of the 
screen. You can move this area to the left 
side of the screen by dragging the dock 
header bar at the top of the stack of 
docked panels.

You can hide, show, move, resize, and  
rearrange panels to fit the way that you 
work. There are controls on each panel 
that help you do these things:

n	 Tab area: At the top of each panel, next 
to the tab with its name, is a dark gray 
area. This is the tab area. Click and drag 
this to move the panel to a new location. 
If you drag the panel out of the dock 
area, you undock the panel B, and the 
dock header bar appears. To dock the 
panel again, use the tab area to drag the 
panel back into the dock area.

Double-clicking the tab area will expand 
and collapse it to show either the whole 
panel or just the tab area. You can also 
resize a panel by clicking and dragging 
its left or bottom edge.

continues on next page

Tab area Dock header bar Collapse to 
Icons button

Panel options 
button

Collapsed 
panels

A A panel and 
its parts.

B An undocked panel 
has a dock header bar 
with a close box.
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n	 Dock header bar: The bar across the top 
of an undocked panel is the dock header 
bar. Click and drag the dock header bar 
to move the panel to a new location. 
Clicking the close box (Windows) or close 
button (Mac) closes the panel group; it 
does not re-dock it. To re-dock, drag the 
panel back into the dock.

n	 Collapse to Icons button: You can 
reduce screen clutter by clicking the 
Collapse to Icons button at the upper-
right corner of the dock, which shrinks 
the panels to icons C. To use the iconic 
panel, click its icon, and the panel 
appears as a drawer next to the dock D.

n	 Panel options button: If you click the panel 
options button, a menu appears that gives 
you a variety of options E based on which 
panel and tab you’re currently on. This 
example shows the options for the Insert 
panel. From here, you can hide the labels 
in the Insert panel, or show its icons in 
color. The ability to close tabs and move 
tabs from one panel to another allows you 
to set up Dreamweaver to work just the 
way you want it.

Panels have an occasional tendency 
to go missing. If you have a situation where 
the Window menu says a panel is open but 
you can’t find it anywhere, choose Window > 
Arrange Panels to make all currently open 
panels visible again.

If you want to completely concentrate on 
working in your document window, you can 
hide the dock with all of the panels and the 
Property inspector by pressing F4 or choos-
ing Window > Hide Panels. The panels and 
inspector shrink down to a thin gray strip on 
the right and bottom edges of your screen 
called the reveal strip. Click the reveal strip to 
briefly show the dock or Property inspector; it 
will shrink back down after a short delay when 
you move the cursor away. Press F4 or use the 
menu choice again to bring the hidden ele-
ments back for good.

C If you need more 
screen space, you can shrink 
your panels to icons in the 
dock area.

D Clicking a panel icon opens the panel in a 
drawer next to the dock area.

E Different 
panels have 
different menu 
options, but 
these are the 
most common.
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The Insert panel
In the default Designer workspace, the 
top panel is the Insert panel A. As you 
might have guessed, the Insert panel is 
used to insert content and objects into 
your Web page.

The Insert panel has nine categories, which 
you can switch between with a pop-up menu. 
You get different tools in each category:

n	 Common: This set of objects contains 
most commonly used objects, such as 
links and images.

n	 Layout: This tab includes divs and 
tables: all objects that let you describe 
how you want to lay out your page.

n	 Forms: The Forms set includes form 
elements such as text fields, buttons, 
and check boxes.

n	 Data: If you’re someday going to work 
with external data such as databases, 
that’s when you’ll use the Data set.

n	 Spry: Spry is a JavaScript library for 
designers and developers that allows 
them to add rich page functionality 
using Ajax widgets, such as menus, 
form validation, and tabbed panels. 
The Spry tab allows you to insert Spry 
widgets onto your pages, with no cod-
ing required.

n	 jQuery Mobile: This section allows 
you to insert widgets from the jQuery 
Mobile JavaScript library. It’s used when 
making specialized sites designed for 
use on mobile devices.

continues on next page

A The Insert 
panel contains 
many of the 
tools you’ll use 
most often to 
insert objects on 
your Web pages.
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n	 InContext Editing: InContext Editing (ICE) 
is part of Business Catalyst, a hosted ser-
vice that Adobe acquired in 2009 and 
that is now part of the Creative Cloud 
subscription service. Business Catalyst 
includes content management, email 
marketing, e-commerce, and extensive 
business analytics. ICE allows users 
to make relatively simple edits to their 
Web pages from a Web browser, with 
no other software required. In Dream-
weaver, the Insert panel allows you to 
add certain areas to pages to make 
them available to ICE end users. Busi-
ness Catalyst and ICE are outside of the 
scope of this book.

n	 Text: The Text tab doesn’t actually 
contain objects to insert on the page; 
instead, it lets you use HTML markup to 
style text that’s already on the page.

n	 Favorites: This starts off empty, but 
you can modify it to contain just what 
you’d like it to have. To do this, choose 
the Favorites set and then right-click. 
You’ll be presented with a dialog that 
allows you to add your most commonly 
used objects.

The Insert panel is just a different orien-
tation of the Insert bar, which was a staple of 
past versions of Dreamweaver. If you’re a long-
time user and miss the Insert bar, just drag 
the Insert panel’s tab above the document 
window, and the panel will transform back 
into the familiar Insert bar B. You lose a little 
vertical space for your document window, but 
you get back an old friend. Judging by the dis-
cussion on Adobe forums, this is the preferred 
setup for many professional-level users.

If you’re ever wondering what an icon on 
the Insert bar does, just move your cursor over 
it—a tool tip will appear with the icon’s name. 
If there’s a small black triangle to the right 
of an icon, it means that the object contains 
related tools and objects. Click the object to 
view the pop-up menu of choices.

B If you’re an old-school Dreamweaver user, you can turn the Insert panel 
back into the Insert bar.
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Setting Up Your 
Workspace
It’s not just a matter of deciding what you 
do want to see—setting up your workspace 
also means figuring out what you don’t
want to see. Given the toolbars and all the 
possible panels and the Property inspec-
tor, you can run out of room for the actual 
Web page you’re trying to work on A. In 
Dreamweaver’s parlance, a workspace
is an arrangement of panels, the dock, 
the document window, and the Property 
inspector. Here’s how to set up a work-
space that works for you.

A Not all the tools and panels are visible, but this is already an unusable workspace.
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The included workspace layouts
Dreamweaver CS6 has preset workspaces 
that look and work the same on Windows 
and Mac and are designed for different 
classes of users:

n	 App Developer

n	 App Developer Plus

n	 Business Catalyst

n	 Classic

n	 Coder

n	 Coder Plus

n	 Designer (the default workspace)

n	 Designer Compact

n	 Dual Screen

n	 Fluid Layout

n	 Mobile Applications

These workspaces rearrange the docu-
ment window, panels, and Property inspec-
tor to work more efficiently for each type 
of user.

The Dual Screen layout isn’t associated with 
a kind of user; rather, it attempts to make 
the best of your hardware. If you’re lucky 
enough to have two (or more) monitors, 
the Dual Screen layout attempts to make 
the most of all of them. For example, the 
document window is expanded to cover 
the whole primary monitor, and the panels 
are moved onto the secondary monitor.

You switch between the different layouts 
with the Workspace Switcher in the Appli-
cation bar B. Just choose from the pop-up 
menu to switch between workspaces.

B The Workspace 
Switcher makes 
it easy to change 
between workspace 
layouts.
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Saving custom layouts
Chances are that the workspaces that 
come with Dreamweaver aren’t exactly 
what you want. No problem! You can save 
your own workspaces.

To save a custom workspace:
1. Set up your layout just the way you 

want it. Show or hide panels, and drag 
them to where you want.

2. From the Workspace Switcher menu, 
choose New Workspace.

The New Workspace dialog appears A.

3. Enter a name for your custom work-
space, and then click OK.

Your new workspace appears at the top 
of the Workspace Switcher menu.

If at any point you’ve added, deleted, 
and moved around panels and documents to 
the point where everything’s all over the place, 
you can always go back to the original layout 
for any workspace by first choosing it from the 
Workspace Switcher menu, and then choosing 
Reset [workspace name] from the same menu.

To delete or rename a 
custom workspace:
1. If you later decide that you don’t want a 

custom workspace any more, or want to 
give it another name, you can change 
it. From the Workspace Switcher menu, 
choose Manage Workspaces.

The Manage Workspaces dialog 
appears B.

2. Select the workspace you want to 
change, and then delete or rename 
your custom layout (but you can’t do 
this to any of the included layouts).

A Give your new custom workspace  
a name.

B The Manage Workspaces dialog lets you 
rename or delete your custom layouts.
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What’s New in 
Dreamweaver CS6
If you’ve used Dreamweaver before, you’ll 
notice that although some things look 
similar, some things look very different. A 
comprehensive description of all the new 
features in Dreamweaver CS6 would take 
up an entire chapter, so here are just a few 
of the highlights:

n	 Fluid grid layouts: This new choice in 
the New Document dialog A lets you 
design your site based on grids with 
rows and columns; you use one layout 
for smart phones, another for tablets, 
and a third for computer monitors—
and which layout is displayed is based 
on the width of the browser window. 

A You begin creating a fluid grid layout in the New Document dialog.
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You lay out your divs on the grid B, 
and Dreamweaver creates the code to 
automatically switch between layouts 
depending on the screen size. See 
Chapter 12 for more.

n	 Improved Multiscreen Preview:  Dream-
weaver CS5.5 introduced a new feature, 
Multiscreen Preview, that works with Live 
view to show you simultaneous views of 
three different screen sizes: Mobile, Tab-
let, and Desktop. Multiscreen Preview 
makes it much easier to make your Web 
pages multi-device aware. In CS6, the 
real-time rendering of the screen sizes is 
faster and more accurate. We also cover 
this in Chapter 12.

n	 Enhanced Live view: Dreamweaver has 
a built-in rendering engine that is based 
on the latest version of WebKit, the 
browser engine used in Safari, Chrome, 
iOS, Android, and other browsers and 
operating systems. In Dreamweaver 
CS6, Live view has improved rendering 
of HTML5 and CSS3 code.

continues on next page

B The grid, in the background, constrains the divs with your content areas.
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n	 CSS transitions: It’s been possible for a 
long time to change the CSS of a page 
on the fly when the user interacts with 
it, in ways such as a hover or a click. 
Dreamweaver CS6 implements CSS 
transitions, part of CSS3. With a transi-
tion, you can control the timing and other 
characteristics of the change from one 
CSS state to another, creating smooth 
animation effects without JavaScript. 
Turn to Chapter 14 for more info.

n	 W3C validation: Make sure your pages 
adhere to Web standards with the new 
W3C Validator feature. You can validate 
static or dynamic HTML documents 
with the W3C validation service from 
within Dreamweaver. We cover this in 
Chapter 17.

n	 Better code editing: Dreamweaver 
has added tools to make it faster and 
easier to write CSS, JavaScript, browser-
specific properties, and jQuery code. 
With code hinting, Dreamweaver uses 
pop-up menus to suggest properties and 
attributes as you type, saving you time.
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Starting Your 

First Site
Dreamweaver is all about building Web 
sites. Sure, it has all of the tools you need 
to create great Web pages. But the basic 
building block is the site, not the page. 
You need to define a site in Dreamweaver, 
which will then be the container for all 
of the files and folders that will make up 
your Web site.

When you build sites, you start by creating 
and testing the site on your local machine. 
Then, when the site is ready, you will send 
it over the Internet to your Web server, 
where it will go live for the world to see. 
Dreamweaver has all the tools you’ll need 
to create the site, work with its files and 
folders, and then transfer it to the Web 
server. That’s what we’ll be covering in this 
chapter. So let’s get started!

In This Chapter
Understanding Local and Remote Sites 26

Creating the Local Site 
28

Defining the Remote Server 
32

Editing Site Definitions 
38

Working with the Files Panel 
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Cloaking Files and Folders 

52
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Understanding Local 
and Remote Sites
Dreamweaver can do a great job of helping 
you manage all the files and folders that 
make up your Web site, but for the best 
results, you’ll need to use the program’s 
site management tools to set up and main-
tain the site. You first need to understand 
some of the terminology Dreamweaver 
uses for sites. You’ll want to build and test 
your Web site within a single folder on your 
hard disk, which Dreamweaver calls the 
local root folder. This folder contains all of 
the files and folders that make up the site. 
For example, let’s say that you’re building 
a company site that has two sections in it, 
one for contact information (called contact),   
and the other for information about the 
company (called about). Each of the 
two sections gets its own folder. These 
folders are located inside the local root 
folder (which is usually the site name; in 
this example, Homecook.info). Because 
each section shares some of the same 
graphic images, there is also an images
folder in the local root folder. The site 
structure would look something like A. 
With one main exception, each of the Web 
pages that you build for the site will go 
into either the about or contact folder or 
other folders you create for the site (not 
shown), such as products or reviews. The 
exception is the main site page (the one 
that people see when they load your site 
in their browsers). That’s called the index 
page, and it usually goes in the local root 
folder (which is also called the local site).

A The top folder here is the local 
root folder, which contains all of 
the files and folders that make up 
the Web site.
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After you build the pages for your site, you 
will use Dreamweaver to copy all of the 
files and folders (usually over the Internet) 
to the Web server. Dreamweaver replicates 
the folder structure from your hard disk on 
the Web server, so the site’s structure and 
all of the links between the pages are pre-
served. Dreamweaver refers to the copy of 
the site on the Web server as the remote 
site. The remote site should always be a 
mirror image of your local site, and Dream-
weaver has tools that can synchronize the 
two sites (you’ll learn more about that later 
in this chapter and in Chapter 18).

Strictly speaking, you don’t have to cre-
ate all of your site’s files within the local root 
folder. But if you do not, Dreamweaver will 
often put up dialogs complaining that files 
aren’t in a local site, and you’ll lose access to 
very useful Dreamweaver features, such as the 
ability to automatically update all links to a file 
that has been moved to another location in the 
site. We strongly recommend that you always 
build your pages in a local site and keep all of 
the elements that make up those pages in the 
local root folder.

If you were using Dreamweaver’s ability 
to work with sites built using a database, you 
could have a third copy of your site on a test-
ing or staging server.

Static vs. Dynamic Sites
There are two main kinds of Web sites 
that you can create in Dreamweaver: 
static sites, where you build all of the 
pages of the site on your local machine, 
and then upload them to the Web server; 
and dynamic sites, in which all the pages 
are created from information drawn from 
a database. The content from a dynamic 
page is created when the user loads 
the page. Many e-commerce sites are 
dynamic sites; for example, when you go 
to Amazon.com and see pages that greet 
you by name and offer personalized rec-
ommendations, those pages are created 
and served just for you, based on the 
programming of Amazon’s database.

One big new feature introduced in 
Dreamweaver CS5 was the ability to 
work with dynamic sites that are built 
using content management systems 
(CMSs). The three supported systems are 
WordPress, Joomla, and Drupal. These 
systems create and serve pages dynami-
cally from their internal databases. We’ll 
discuss using Dreamweaver with these 
systems in Chapter 15, “Working with 
Content Management Systems.” The 
groups who have created these CMSs 
have done a lot of programming so that 
you don’t have to, and you can now use 
Dreamweaver to build on their work.

With the exception of working with the 
CMS, we’re covering how to build static 
sites with Dreamweaver in this book. 
Dreamweaver still has plenty of features 
that allow Web programmers to build 
database-backed sites from scratch, and 
those features are so extensive that they 
would require and deserve a book of 
their own. When we run into the options 
that Dreamweaver offers to work with 
dynamic sites, we’ll mention them, but 
we generally will not cover those options 
in detail in this book.
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Creating the Local Site
Because the process of setting up your 
local and remote sites has several steps, 
Dreamweaver provides a handy Site Setup 
dialog that contains all the settings. Begin-
ning with Dreamweaver CS5, the process 
of site definition was considerably stream-
lined to make it easier and faster.

You’ll use the Site Setup dialog to create 
both the local and remote sites. In this 
section, however, we’ll just create the local 
site. See “Defining the Remote Server,” 
later in this chapter, for instructions on how 
to tell Dreamweaver about the remote site.

To create the local site:
1. In the Dreamweaver Welcome screen, 

click the Dreamweaver Site link A.

or

Choose Site > New Site.

The Site Setup dialog appears, set to 
the Site category B.

B In the Site pane of the Site Setup dialog, enter the name and local site folder of 
your site.

A Click the 
Dreamweaver Site 
link in the Welcome 
screen to begin 
creating your site.
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2. In the Site Name field, enter the name 
you want for your site.

The site name is only for your refer-
ence; it won’t be visible to users of 
the site.

3. Local Site Folder is the location on your 
computer where you want to store 
your files. Click the folder icon to the 
right of the text field, which brings up 
the Choose Root Folder dialog, and 
browse to the folder on your hard disk 
that contains all of the files for your site. 
If the folder doesn’t already exist, click 
the New Folder button in the dialog and 
then name and save the folder. It’s usu-
ally a good idea to give the folder the 
same or a similar name to the site name.

On Windows, select the folder in the 
dialog, click Open, and then click the 
Select button.

or

On OS X, select the folder in the dialog 
and click the Choose button.

The dialog closes and you will return to 
the Site Setup dialog. The field next to 
Local Site Folder now shows the path 
to the folder you just selected.

That’s all you absolutely need to do to 
define a site and get started with it in 
Dreamweaver. You can click Save now 
and start working. As you build your 
site and Dreamweaver needs addi-
tional information, it will prompt you 
as needed.

Our recommendation, however, is to go 
ahead and complete two other items in 
the Site Setup dialog.

continues on next page
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4. Click the Advanced Settings category in 
the Site Setup dialog.

The Advanced Settings subcategories 
appear, with the Local Info category 
selected C.

5. Click the folder icon next to the Default 
Images Folder field. This brings up the 
Choose Image Folder dialog inside the 
local root folder.

6. You need to create the Images folder, so 
click the New Folder button in the dialog 
to create the folder. Name it images. 
On Windows, you can create the folder 
without a naming dialog; on OS X, you’ll 
have to click Create after you enter the 
name. You will return to the dialog show-
ing the contents of the root site folder, 
which will now contain the new images
folder. Click Select (Choose).

You will return to the Local Info category 
of the Site Setup dialog, with the path to 
the images folder entered in the Default 
Images folder field.

C Next, in the Local Info category, you should tell Dreamweaver where the images folder is and 
the site’s Web URL.
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7. In the Web URL field, enter the Web 
address of your site, including the  
leading http:// D.

We’ll cover the other items in this panel 
in other places in the book. For now, you 
can leave them at their default values.

8. Click Save.

In this case, we are only creating the 
local site. If you want to continue on 
and define the remote site, go to step 3 
in “Defining the Remote Server,” later in 
this chapter.

Getting Organized
Before you dive deeper into Dreamweaver, it’s useful to spend some time deciding the structure 
and design of your site. In fact, this is a great time to push away from the computer and pick up  
much older design tools: a pencil and pad of paper. While a primer on site design would take 
up much more space than we have in this sidebar (indeed, entire books are devoted to the 
subject), before you begin building your site with Dreamweaver, consider the following and then 
sketch out your designs.

. What do your customers need from your site? Your site’s visitors are your customers. Create  
your sites for them, not for you. Customers can visit your site for a variety of reasons: to 
purchase something, to get information or entertainment, or to be part of a community. Sites 
centered on your customer’s needs are sites that visitors will return to. Sites driven by company 
structure or by the designer’s ego—not so popular.

. What is the best structure and navigation for your site? Site structure is generally like an 
upside-down tree or an organizational chart. The index page is the main trunk that branches off 
to folders with other pages inside (and often other folders with their own pages). On your pad, 
add the main folders that you’ll create from the index page (the home page of your site). Your 
structure will also determine the site navigation you choose. Again, put yourself in the place 
of your customers and imagine what they’ll need to get around your site. Remember that they 
may not enter your site at your home page, so make sure the navigation is clear and consistent 
throughout the site.

Take the time to work out your customer’s needs and then the site’s structure and navigation on 
paper before you start creating things in Dreamweaver. You’ll end up saving time by avoiding dead 
ends and wasted effort. To get some suggestions for good Web design books, see the appendix, 
“Where to Learn More.”

D When you enter the information about the 
images folder, Dreamweaver displays the path to 
the folder.
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Defining the 
Remote Server
The remote site lives on your Web server, 
and it is the destination for the files and fold-
ers from the local site on your computer’s 
hard disk. Dreamweaver can connect to 
your Web server in several ways. The most 
common connection, called FTP, is used 
when your server resides on the Internet or 
on your company’s intranet. Another way to 
connect is called SFTP, for Secure FTP. A 
third way to connect is via a protocol called 
WebDAV (see the sidebar “What Are FTP, 
SFTP, FTPS, and WebDAV?”).

Before you begin creating a connection 
to the remote site, you need to ask your 
network administrator for some information 
about the Web server you’re using. You 
will need the following:

n	 The connection type, which will typically 
be FTP, SFTP, or WebDAV. Dreamweaver 
CS5.5 added two additional flavors of 
FTP: FTP over SSL/TLS (implicit encryp-
tion) and FTP over SSL/TLS (explicit 
encryption), both of which, when chosen, 
add an additional Authentication pop-up 
menu to the Server Definition dialog; 
both should be used only at the direction 
of your site administrator.

n	 The FTP, SFTP, or WebDAV address for 
your server.

n	 The login (sometimes called the user-
name) for the server.

n	 The password associated with the login.

n	 The folder’s path on the server that 
contains your Web site.

Once you gather this information, you’re 
ready to define the remote site in Dream-
weaver. You’ll begin by editing the 
site definition.

Dreamweaver offers another way to 
connect to remote sites: RDS, which is used 
for database-backed sites and will not be dis-
cussed in this book.
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What Are FTP, SFTP, FTPS, and WebDAV?
If you’ve never done any Web site maintenance before, you might be baffled by the term FTP. 
It stands for File Transfer Protocol, and it’s a common method for transferring files (such as Web 
pages and images) between two computers connected to the Internet. Web servers often use FTP 
to send files between the server and the computer of whomever is maintaining the Web site. To 
do this, the server machine runs an FTP server program in addition to the Web server software. 
Normally you need a program called an FTP client on your computer to transfer files to and from 
an FTP server. Dreamweaver has built-in FTP client functions.

One of the drawbacks to FTP is that it is a protocol with no built-in security; all information is sent 
“in the clear,” including your username, password, and the files themselves. The Secure FTP 
(SFTP) protocol solves this problem by encrypting all information sent between the SFTP client (in 
this case, Dreamweaver) and the SFTP server. SFTP uses the Secure Shell protocol to add security 
to the connection. As a result, it allows encryption but not authentication; the client and the server 
can’t exchange credentials to verify that access is really allowed.

A newer method of adding security to FTP connections is FTPS (though Dreamweaver doesn’t 
use that terminology; it instead uses the more precise FTP over SSL/TLS [implicit encryption] and 
FTP over SSL/TLS [explicit encryption]). In these methods, Dreamweaver not only encrypts its data 
transfers with the server, but also exchanges security credentials with the servers. These creden-
tials are in the form of digitally signed server certificates, guaranteed by certificate authorities like 
Verisign and Thawte. The explicit encryption method allows both secure and insecure clients to 
use the server, but implements security if the client requests it. The implicit encryption method 
allows only secure clients to use the server.

The WebDAV protocol provides security and deals with another problem faced by Dreamweaver 
users: that of ensuring that only one person at a time is modifying a particular Web page. WebDAV 
locks a file while it is being edited and releases the lock when the page is completed. Dream-
weaver has its own system of locking and unlocking files when you use protocols other than 
WebDAV; in practice, you won’t see a difference in the way Dreamweaver works no matter which 
connection protocol you select.

www.allitebooks.com

http://www.allitebooks.org


ptg8274339

34 Chapter 2

To define the remote site 
with FTP or SFTP:
1. Choose Site > Manage Sites.

The Manage Sites dialog appears A.

2. Select the site you want, and then 
click the Edit Selected Site icon.

The Site Setup dialog appears.

3. Click the Servers category.

The Servers pane appears B with no 
servers defined yet.

4. Click the Add New Server button at the 
bottom of the server list (it looks like a 
plus sign).

The Server Definition dialog 
appears C, set to the Basic tab.

Delete selected site

Edit selected site Duplicate site

Export site

A Begin adding the remote server to your site 
definition in the Manage Sites dialog.

Add new server Server list

B You’ll use the Servers category in the Site Setup dialog to enter the remote 
server information.
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5. Enter the name of the server in the 
Server Name field. Dreamweaver uses 
the name “Remote Server” elsewhere 
in the program, and that’s what we sug-
gest you do, too.

6. From the pop-up menu labeled “Con-
nect using,” choose FTP, SFTP, FTP 
over SSL/TLS (implicit encryption), or 
FTP over SSL/TLS (explicit encryption), 
depending on which kind of connection 
you are making.

The dialog changes to show fields you 
need to fill in for the FTP and SFTP con-
nection types D. Depending on your 
choice, one of the fields will be named 
FTP Address or SFTP Address.

7. In the FTP or SFTP Address field, enter 
the hostname or FTP/SFTP address of 
your Web server.

The hostname could be a name like 
www.peachpit.com or ftp.dori.com. 
It will usually be the name you would 
enter into a Web browser without the 
http://. It must begin with www or ftp
and cannot be just the domain name, 
such as dori.com. The name should not 
contain directories or slashes, such as 
www.negrino.com/books/. You can also 
enter a numeric IP address in this field, 
such as 64.28.85.14.

8. In the Username field, enter the FTP/
SFTP login name.

9. Enter the FTP/SFTP password.

Don’t forget that FTP/SFTP logins 
and passwords are case sensitive on 
many servers.

10. If you want Dreamweaver to remember 
the FTP/SFTP login and password (rec-
ommended), make sure the Save check 
box is selected.

continues on next page

C Begin adding the remote server information 
by giving it a name (we suggest “Remote Server” 
because that’s the name Dreamweaver uses 
elsewhere in the program).

D You’ll need to enter the FTP information in 
the Server Definition screen. We’ve blurred some 
private information here.

www.peachpit.com
www.negrino.com/books/
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11. In the next field, enter the name of the 
folder on the Web site that contains 
your site’s files and will serve as the 
root folder for your site.

This folder is also called the host direc-
tory and is usually a path from the FTP 
folder to the root folder. Depending 
on your Web hosting company, this 
path could be named many different 
things. Typical host directory names are 
htdocs, public_html, and www/public/ 
docs/. If you’re unsure of the exact 
name of the host directory, check with 
your Web hosting company. Sometimes, 
the FTP host connects to the correct 
directory automatically, and you can 
leave the field blank.

12. If you were directed by your site 
admin to choose FTP over SSL/TLS 
(implicit encryption) or FTP over SSL/
TLS (explicit encryption) in step 6, an 
Authentication pop-up menu appears in 
the dialog. For either method, choose 
either None (encryption only) or Trusted 
Server from the pop-up menu—again, 
as directed by the admin.

13. Click the Test button to make sure that 
Dreamweaver can connect successfully 
to your Web server.

If Dreamweaver reports an error, check 
the information you entered.

14. Click Save.

You are returned to the Site Setup 
dialog. The server you just added now 
appears in the Server list.

15. Click Save to close the dialog.

To define the remote 
site with WebDAV:
1. Choose Site > Manage Sites.

The Manage Sites dialog appears.

www/public/docs/
www/public/docs/
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2. Select the site you want, and then 
click the Edit Selected Site icon.

The Site Setup dialog appears.

3. Click the Servers category.

The Servers pane appears with no serv-
ers defined yet.

4. Click the Add New Server button at the 
bottom of the server list (it looks like a 
plus sign).

The Server Definition dialog appears, 
set to the Basic tab.

5. Enter the name of the server in the 
Server Name field. Dreamweaver uses 
the name “Remote Server” elsewhere 
in the program, and that’s what we sug-
gest you do, too.

6. From the pop-up menu labeled “Con-
nect using,” choose WebDAV.

The dialog changes to show fields you 
need to fill in for the WebDAV connec-
tion type E.

7. Enter the URL of your WebDAV server.

8. In the Username field, enter the Web-
DAV login name.

9. Enter the WebDAV password.

If you want Dreamweaver to remember 
the WebDAV login and password (rec-
ommended), make sure the Save check 
box is selected.

10. Click the Test button to make sure that 
Dreamweaver can connect successfully 
to your Web server.

If Dreamweaver reports an error, check 
the information you entered.

11. Click Save.

You are returned to the Site Setup 
dialog. The server you just added now 
appears in the Server list.

12. Click Save to close the dialog.

E If you connect to your Web server via WebDAV, 
you’ll need to enter the connection information.
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Editing Site Definitions
Once you have created your site defini-
tions, you might need to change them. 
For example, you might want to change 
the location of the local root folder, or you 
may change the path on the remote server. 
You’ll use the Site Setup dialog.

To change a site definition:
1. Choose Site > Manage Sites.

The Manage Sites dialog appears.

2. Select the site you want, and then 
click the Edit Selected Site icon.

The Site Setup dialog appears.

3. Choose the category on the left side of 
the dialog for the kind of change you 
want to make.

The right side of the dialog changes 
to show the options for the category 
you chose.

4. Make the changes you need to make.

5. Click Save.
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A The Files panel is your command 
center for working with files 
in Dreamweaver.

Get file

Check out

Synchronize

Refresh

Put file Check in

File view pop-up menu

Expand/Collapse

Browse pop-up menu

Connect/Disconnect Cancel current file operation

Working with 
the Files Panel
To work with the files and folders that make 
up your Web sites, you’ll use the Files 
panel. This panel allows you to add and 
delete files and folders; view and change 
the local or remote sites; and do other 
maintenance tasks for your sites.

The Files panel appears at the right side 
of the Dreamweaver window, docked with 
other panels. By default, the Files panel 
is at the bottom of the group of panels. 
The panel consists of a couple of pop-
up menus, a toolbar, and the files area 
below A.
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Navigating Disks 
and Sites
The Browse pop-up menu at the top of the 
Files panel allows you to browse through 
your hard disk and easily switch between 
sites that you have defined. The menu 
looks a bit different on Windows and OS X, 
reflecting the differences between the 
operating systems A. On both platforms, 
sites you have defined appear in the menu 
as folders.

To browse your hard disk:
1. In the Files panel, choose the disk you 

want from the Browse pop-up menu.

The disk’s contents appear in the files 
area B.

2. Navigate to the folder and file that 
you want.

To switch between defined sites:
In the Files panel, choose the site from the 
Browse pop-up menu.

A The Browse menu in the Files panel reflects 
the differences in the Windows (left) and OS X 
(right) operating systems.

B If you choose your hard disk 
from the Browse pop-up menu, 
you can then navigate to any file 
or folder on the disk.
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Switching Between 
Local View and the 
Remote Server
The File view pop-up menu, next to the 
Browse pop-up menu, allows you to switch 
the view in the Files panel between the 
local and remote sites.

To switch between local 
and remote views:
1. Choose a site you have defined from 

the Browse pop-up menu.

The site’s local files appear in the files 
area, and the File view pop-up menu 
switches to Local view.

2. From the File view pop-up menu, 
choose Remote server A.

Dreamweaver connects to the site (you 
can tell because the Connect/Discon-
nect button in the Files panel toolbar 
will highlight), and the remote files 
appear in the files area.

The File view pop-up menu has two other 
choices: Testing server and Repository view. 
We talk about using testing servers in Chapter 
15; we won’t be discussing Repository view in 
this book.

A To see the files on the 
remote site, choose Remote 
server from the File view 
pop-up menu.
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Refreshing Views
When you switch to the local or remote 
views of a site, Dreamweaver scans the 
contents of your local or remote site fold-
ers and displays the current contents. On 
occasion, the view you’re looking at in the 
Files panel may become out of date. For 
example, if you happen to upload or delete 
items on the remote site with a program 
other than Dreamweaver, those changes 
won’t be shown in the Files panel. Similarly, 
if you move files into the local root folder 
by working on the Windows or OS X desk-
top, you may need to tell Dreamweaver 
to rescan and refresh its display of the 
local site.

To refresh the local or remote view:
1. Choose the site you want to refresh 

from the Browse pop-up menu.

2. Choose the view (Local view or Remote 
server) you want from the File view 
pop-up menu.

3. Click the Refresh button in the Files 
panel toolbar.

Dreamweaver rescans the site you 
selected and updates the files area.
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Working with Files 
and Folders
The Files panel is great for organizing all of 
the files on your site and creating new files 
and folders. You should do most of your 
file creation and management in the Files 
panel, because it can often save you quite 
a bit of time compared to using another 
method in Dreamweaver.

For example, you can create a new page 
by choosing File > New, choosing the kind 
of page you want from the New Document 
dialog, and then editing the page. When 
you save the page, you must navigate to 
the correct folder in the local site folder, 
name the page, and then save it. In con-
trast, to create a new page in a particular 
folder using the Files panel, you select the 
folder that you want to contain the page 
and then choose the New File command, 
as described next.

Just because the Dreamweaver files 
area is reminiscent of the Windows Explorer or 
OS X Finder, don’t be fooled into thinking that 
it is the same and that you could do your local 
file management on your computer’s desktop. 
Dreamweaver is designed for working with 
Web pages, and it can do incredibly useful 
things—like updating the links on a page to 
work correctly, even if you move the page 
that contains the links to a different folder 
on the site.

www.allitebooks.com
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To create a new file or folder:
1. Use the File view pop-up menu to 

select the local or remote site. You will 
usually create files or folders in the 
local site.

2. Right-click a file or folder in the 
files area.

A context menu appears that gives you 
many options A.

3. From the context menu, choose New 
File or New Folder.

The new file or folder appears in the 
files area. If you selected a folder in 
step 2, the new file or folder will be cre-
ated inside the selected folder.

4. The name of the newly created file 
or folder (“untitled.html” for a file, or 
“untitled” for a folder) is selected in the 
Files panel. Type the name you want.

You could also use the panel options 
button at the upper-right corner of the Files 
panel, which gives you a different menu, but 
it’s easier to use the right-click context menu.

To move files or folders:
1. Select a file or folder in the files area. 

To move multiple items, Ctrl-click (Cmd-
click) to select each of the items you 
want to move.

2. Drag the selected item or items to the 
new location.

The Update Files dialog appears B.

3. Click Update.

Dreamweaver updates all of the links in 
the site that are affected by the move.

A The context 
menu in the 
Files panel is the 
fastest way to 
create a new file 
or new folder.

B If you move files that are the target of links, 
Dreamweaver asks to update the pages that link 
to the file you moved.
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To rename files or folders:
1. Select a file or folder in the files area.

2. Click the name of the file or folder.

or

Press F2.

The name becomes highlighted.

3. Type the new name. Don’t forget to add 
the correct file extension for the file that 
you’re renaming. For example, most 
Web pages have the file extension .htm
or (preferably) .html.

4. Press Enter (Return).

The Update Files dialog appears.

5. Click Update.

Dreamweaver updates all of the files 
in the site that are affected by the 
renamed file.

To edit files or folders:
1. Right-click a file or folder in the 

files area.

2. From the resulting context menu, 
choose Edit C.

3. Choose one of the items in the 
Edit submenu.

You can Cut, Copy, Paste, Delete, 
Duplicate, or Rename the file or folder. 
If a file operation will affect other files, 
Dreamweaver may display an “Are you 
sure?” dialog or the Update Files dialog.

Note the shortcut keys listed next to 
each of the items in the Edit menu. As you 
become more comfortable working with files 
in Dreamweaver, using the shortcut keys can 
save you time.

C The Edit submenu in the Files panel context 
menu gives you several options for working with 
files or folders.



ptg8274339

46 Chapter 2

Putting and 
Getting Files
You can copy selected files or folders (or the 
entire site) between the local and remote 
sites using the Files panel. Dreamweaver 
calls moving an item from the local to the 
remote site putting the item; moving the 
item from the remote to the local site is get-
ting the item. If a put or get operation will 
overwrite a file, Dreamweaver warns you. 
If you select a folder, Dreamweaver moves 
the folder and all of the items that it con-
tains. So if you select the local root folder, 
you can put the entire site up on the remote 
server in just a couple of clicks. Sometimes, 
however, you’ll want to use Dreamweaver’s 
site synchronization feature rather than 
putting or getting individual items. See 
“Synchronizing the Local and Remote Sites,” 
later in this chapter.
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To put or get a file or folder:
1. In the Files panel, choose Local view 

or Remote server from the File view 
pop-up menu.

The local or remote view is displayed in 
the files area.

2. Select the file or folder you want 
to move.

3. Click the Get file or Put file button in the 
Files panel toolbar.

4. If any of the files that you’re transferring 
are open and have unsaved changes, 
Dreamweaver asks if you want to save 
the files before they are sent. Click Yes; 
if there are multiple files, click Yes to All.

5. Dreamweaver may also display a 
dialog asking if you want to transfer 
any dependent files. An example of 
dependent files would be the graphics 
on the pages that you are uploading. If 
the dependent files have already been 
uploaded to the server, click No; there’s 
no reason to reupload files that haven’t 
changed. If you want to transfer depen-
dent files that have changed, click Yes.

Checking Files In and Out
We’ll discuss operations with the Check 
In and Check Out buttons in the Files 
panel toolbar in Chapter 18, “Managing 
Your Site.”
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Expanding the 
Files Panel
Normally, the Files panel will only show 
either the local site or the remote site. But 
if you would like to compare the list of files 
and folders on both sites, you can do that 
by expanding the Files panel. This feature 
works slightly differently on Windows and 
OS X. On Windows, expanding the Files 
panel causes it to grow to take over the 
entire screen, replacing the rest of the 
Dreamweaver interface. On OS X, expand-
ing the Files panel opens the panel in a 
new window that allows you to see the 
remote site on the left and the local site on 
the right A.

To expand the Files panel:
Click the Expand/Collapse button in the 
Files panel toolbar.

To collapse the Files panel, click the 
Expand/Collapse button again.

A On OS X, when you expand the Files panel, it opens in a new window with 
the remote site on the left and the local site on the right.
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Synchronizing 
the Local and 
Remote Sites
Having two copies of a Web site—one on 
your local machine and the other on a Web 
server—can potentially lead to trouble. It’s 
possible, for example, for you to update 
several pages on your local site and lose 
track of just which files you changed. In 
that case, it might be difficult for you to 
determine which copy of the site (local or 
remote) has the latest version of the files. 
Dreamweaver’s Synchronize command 
compares the local and remote sites and 
transfers the newer files in either direction.

To synchronize local 
and remote sites:
1. Click the Synchronize button in the 

Files panel.

or

Choose Site > Synchronize Sitewide.

The Synchronize with Remote Server 
dialog appears A.

2. From the Synchronize pop-up menu, 
choose the files you want to update.

Your choices are to synchronize all the 
files in the site, or just files or folders 
that you selected in the Local view.

continues on next page

A In the Synchronize with Remote Server dialog, 
you’ll need to select the synchronization method 
you want to use.
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3. From the Direction pop-up menu, 
choose how you would like to copy 
newer files:

>	 Put newer files to remote sends 
newer files from your local site folder 
to the Web server.

>	 Get newer files from remote finds 
newer files on the Web server and 
copies them to your local site folder. 
This option also copies completely 
new files that are on the Web server 
(ones, for example, that may have 
been placed there by a coworker) to 
your local site folder.

>	 Get and Put newer files synchronizes 
files both ways. New files on the local 
site will be transferred to the remote 
site and vice versa.

4. (Optional) If you want, select the 
“Delete remote files not on local drive” 
check box.

This is a good option to choose when 
you’ve made substantial deletions in 
the local site (perhaps because you 
did a big site cleanup). The wording 
of this option changes depending on 
what you chose in step 3. If you chose 
to transfer newer files from the remote 
site, the wording changes to “Delete 
local files not on remote server.” If you 
chose to get and put files, this option 
becomes inactive.

5. Click Preview.

Dreamweaver connects to the remote 
site, compares the files you chose to 
synchronize, and then displays the 
Synchronize dialog B. This allows you 
to preview the changes that will be 
made on the site. The Action column in 
the dialog tells you what Dreamweaver 
proposes to do to each file.
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6.  If desired, select one or more files in the 
Synchronize dialog and choose one of 
the action buttons at the bottom of the 
dialog. You have the following choices:

>	 Get marks the selected files to be 
retrieved from the remote site.

>	 Put marks the selected files to be 
sent to the remote site.

>	 Delete marks the selected files 
for deletion.

>	 Ignore tells Dreamweaver to 
ignore the selected files for 
this synchronization.

>	 Compare opens the local and remote 
versions of the file so you can com-
pare their differences.

>	 Mark as synchronized tells Dream-
weaver to consider the selected files 
as already synchronized, so no action 
will be taken.

7. Click OK.

Dreamweaver performs the 
synchronization.

Put

Ignore

Mark as synchronizedGet

Delete

Compare

B You can select actions in the 
Synchronize dialog that will determine 
how the files are affected as they 
are synchronized.
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Cloaking Files 
and Folders
Not every file or folder in your local site 
needs to be uploaded to the remote site 
on the Web server. Dreamweaver allows 
files and folders to be cloaked, which 
means that they will be exempt from 
synchronization. This can save you a lot 
of time. Imagine that you’re working on a 
site that contains large movie files. Cloak-
ing the folder that contains the movie files 
means that while you’re working on other 
parts of the site, Dreamweaver won’t take 
the time to scan through the folders when 
synchronizing and won’t upload any of the 
files. When you’re ready to upload the files, 
uncloak the movies folder and synchronize 
the local and remote sites.

To cloak a file or folder:
1. Right-click a file or folder in the 

Files panel.

2. From the resulting context menu, 
choose Cloaking, and then from the 
submenu, choose Cloak A.

In the Files panel, Dreamweaver 
displays the file or folder with a slash 
through it, indicating that it is cloaked.

To uncloak a file or folder:
1. Right-click a cloaked file or folder in the 

Files panel.

2. From the resulting context menu, 
choose Cloaking > Uncloak or Cloak-
ing > Uncloak All.

A Choosing Cloak from the Files panel context 
menu keeps a file or a folder and its contents from 
being affected during synchronization operations.

B The Cloaking category in the Site Setup dialog 
allows you to set particular kinds of files to always 
be cloaked.

You can cloak all files of a particular type. 
Choose Site > Manage Sites, and then select 
the site you’re working on. Click the Advanced 
Settings category of the Site Setup dialog, and 
then choose the Cloaking category. Select the 
“Cloak files ending with” check box, and then 
enter the file extensions of the kinds of files 
you want to cloak B.
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Building Your 

First Page
After you’ve set up your local site, you can 
begin filling the site with pages. To do that, 
you’ll need to create a page, give it a title, 
add some content to the page, and save it. 
To check your work, you should view the 
page in one or more Web browsers before 
you upload it to your Web server. Dream-
weaver has always made it easy to view 
your work in different browsers, and the 
new (as of CS5) integration with Adobe’s 
BrowserLab service makes it even simpler.

If you need a little inspiration, Dream-
weaver offers a variety of sample pages 
that you can use as a jumping-off point 
for your own creative efforts. You can also 
choose from a variety of page designs cre-
ated entirely with CSS.

In this chapter, we’ll also briefly discuss 
how you add text, images, and links to your 
pages, although we go into those subjects 
in much greater detail in Chapters 4, 5, 
and 6, respectively.
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Creating a New Page
The first HTML page that you create in a 
new site should be the index page, which 
is the page that a Web browser loads 
automatically when a visitor goes to the 
site. Depending on how you are naming 
pages on your site, the index page could 
have a variety of names, but it is most often 
named index.html. After you create the 
index page, you will want to create other 
pages for the site.

As is often the case with Dreamweaver, 
there is more than one way to do the task 
at hand. You can create a new page using 
the Welcome screen, or you can use the 
New Document dialog.

Using the Welcome screen
The Welcome screen is the fastest 
way to create a new HTML page. It 
appears when you have closed all other 
document windows.

To create a new page from 
the Welcome screen:
1. Close any open document windows.

The Welcome screen appears A. Each 
of the items in the Welcome screen is 
a link.

2. In the Create New section, click HTML.

Dreamweaver creates the new blank 
HTML page B.

You can also use the Welcome screen to 
open pages that you recently worked on. Just 
click the item’s name in the Open a Recent 
Item section of the Welcome screen.

Clicking ColdFusion or PHP in the  
Create New section of the Welcome screen 
also creates an HTML page. Clicking CSS  
creates a new CSS style sheet. Clicking any of 
the other choices creates documents designed 
for different Web programming languages that 
you would normally work with in Code view.

If you don’t want to use the Welcome 
screen at all, you can turn it off in Dreamweav-
er’s Preferences. Choose Edit > Preferences 
(Dreamweaver > Preferences), and click the 
General category. Then deselect the check box 
next to “Show Welcome screen.”

Using the New Document Dialog
The New Document dialog gives you 
a bit more flexibility than the Welcome 
screen when creating new documents. 
As with the Welcome screen, you can 
create several different types of new 
documents, plus it allows you to choose 
the doctype of the new document.
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A Click the links in the Welcome screen to open a recent item or create a new item.

B A brand-new page in Dreamweaver showing the Design view.
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To create a new page from 
the New Document dialog:
1. Choose File > New, or press Ctrl-N 

(Cmd-N).

The New Document dialog appears C
set to the Blank Page tab.

2. Click to choose one of the tabs in the 
leftmost column.

The second column changes to show 
the available items for the tab you 
selected. The name of this column also 
changes to match the name of the tab.

If you chose the Blank Page tab and 
HTML as the page type, as in C, the 
third column shows a number of CSS 
starter layouts. These starter layouts are 
discussed in more detail in Chapter 8.

C You’ll probably create most of your new pages from the New Document dialog.
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3. Click the item you want in the third 
column.

If Dreamweaver has a preview image 
of the item you selected available, it 
appears in the Preview pane (previews 
are mostly available for sample pages 
and templates) with its description 
below the preview area.

4. (Optional) Some of the kinds of docu-
ments you can create in this dialog 
allow you to declare their doctype, and 
for those the DocType pop-up menu 
will be available. Most of the time the 
default choice is fine, but if you want, 
you can change the doctype from the 
pop-up menu D.

5. Click Create.

Dreamweaver creates the new docu-
ment and displays it in a new window.

If you want to change any of the defaults 
for a new document, click the Preferences but-
ton in the New Document dialog. In the result-
ing dialog E, you can change the default 
document type for the New Document dialog; 
the extension used for that document; the 
default document type (DTD); and the default 
character encoding. You can also choose 
whether or not you want the New Document 
dialog to appear when you press Ctrl-N (Cmd-
N), or if you just want Dreamweaver to create 
a new default document.

We’ll cover the Blank Template and Page 
from Template tabs of the New Document 
dialog in Chapter 15.

D You can 
choose from 
the available 
doctypes 
in the New 
Document 
dialog.

E Change the defaults for new pages in the 
New Document category of Dreamweaver’s 
Preferences dialog.

Behind the Doctype
If you’re not familiar with doctype, it’s 
a declaration at the start of an HTML 
page that specifies the DTD (Document 
Type Definition) that is in use for the file. 
Web browsers use the doctype declara-
tion to determine how the page should 
be rendered.

By default, Dreamweaver CS6 inserts 
the “XHTML 1.0 Transitional” doctype, 
and the code it creates is consistent with 
that standard. This version also has the 
option of using the HTML5 doctype. 
HTML5 is an emerging standard that is 
expected to become the dominant Web 
standard in the years to come.



ptg8274339

58 Chapter 3

Using Sample Pages
Dreamweaver has many sample pages 
available, which do some of the work of 
creating new pages for you. The sample 
pages are often good jumping-off points 
for your own pages. After you create  
a document from one of the sample  
pages, you can customize and modify  
it as you wish.

The sample pages come in two categories:

n	 CSS Style Sheet chooses external CSS 
style sheet documents that contain 
style definitions with a wide variety 
of looks for your pages. You can click 
any of the sample style sheets to see a 
preview and description A.

n	 Mobile Starters has three premade 
jQuery-based pages B. Using these 
pages to create layouts destined for 
mobile devices is considerably easier 
than doing it by hand.

A Dreamweaver provides many starter CSS 
style sheets, which you can preview in the New 
Document dialog.

B You can preview and choose from the 
predefined jQuery-based mobile starter pages.
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To create a page from 
a sample page:
1. Choose File > New, or press Ctrl-N 

(Cmd-N).

The New Document dialog appears.

2. Click the Page from Sample tab in the 
leftmost column C.

The second column changes to show 
the available items for the tab you 
selected. The name of this column also 
changes to Sample Folder.

3. Click the item you want in the third 
column.

The preview image of the item you 
selected appears in the Preview pane 
(previews are mostly available for 
sample pages and templates) with its 
description below the preview.

4. Click Create.

Dreamweaver creates the page in a 
new window.

5. Modify the sample page as you like.

C You can choose from two categories of sample pages.

If you’re looking for rapid prototyping 
of sites, one possibility is to download or 
purchase one of the many free or inexpen-
sive Dreamweaver templates; a quick Google 
search for “Dreamweaver templates” will 
turn up a large selection. When you find one 
that you like, make sure that its layout is CSS 
based, not table based. It makes no sense to 
use templates that won’t be easy to maintain 
in the future.
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Titling Your Page
The first thing you should do with your new 
page is to add a title. The title is the text 
that appears in the title bar of Web browser 
windows, at the top of the window A. 
You’ll enter this text in the Dreamweaver 
document window.

To add a title to your page:
1. If necessary, open the page you want 

to title.

2. Click in the Title field at the top of the 
page’s document window.

3. Type in the title B.

Don’t forget to add the title; it’s easy 
to forget, and when you do forget, it makes 
it harder for people to find your pages using 
a search engine. As we write this, a quick 
Google search for “Untitled Document” in the 
title of pages brings up more than 117 million 
hits. Don’t be one of them!

A The title of an HTML document appears at the top of a Web browser’s window or, 
for browsers that use tabbed windows (like Firefox does here), as the title of the tab.

B Enter the title in, well, the Title field.
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Adding Text to 
Your Page
In this section, we’ll cover adding a bit of 
text to your page, just enough to get you 
started. You’ll find a much more detailed 
discussion of working with text in Dream-
weaver in Chapter 4. In short, adding text is 
a lot like typing text in any word processor.

To add text to a page:
1. On the new page, click to set a blink-

ing insertion point. You can press Enter 
(Return) to move the insertion point 
down on the page.

2. Type your text.

The text appears on the page, aligned 
to the left.

To format the text:
1. In the Insert panel, choose the Text 

category from the pop-up menu.

The Text category of the Insert panel 
appears A.

2. Using the Insert panel and the HTML 
tab of the Property inspector, apply any 
formatting you want, as you would with 
a word processor.

See Chapter 4 for much more detail 
about using the Text category of the 
Insert panel.

This formatting would, of course, add 
HTML markup to your page. You’ll probably 
want to use CSS formatting for text instead; 
that’s covered in Chapter 7.

A Use the Text 
category of the 
Insert panel to 
format your text 
using HTML 
markup.
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Creating Links
To add a hyperlink to a page, you need 
to select the text you want to turn into a 
link, and then provide the URL for the link. 
A URL (Uniform Resource Locator) is the 
Web address that you would type into the 
Address bar of a Web browser.

You will find much more information about 
adding links to your pages in Chapter 6. 
You’ll see how to add links to either text or 
graphics and lots of other linky goodness.

To add a link to a page:
1. Select the text you want to turn into a 

link A.

In this example, I want to turn the 
“HomeCook.info” text at the top of the 
page into a link to the home page of the 
site, so I’ve selected that text.

2. Do one of the following:

If you are linking to a page in your site, 
click the Point to File button in the Prop-
erty inspector B and then drag to a file 
in the Files panel C. When you release 
the mouse button, the filename appears 
in the Link field.

or

A Begin creating a link by selecting the text that 
you want to turn into the link.

Point to File button

Link field

Browse for File button

B Click the Point to File button to begin the linking process…

C …then drag to point at the file you want to link to in the Files panel. As you drag, Dreamweaver 
follows your mouse pointer with an arrow to make it clear which file you’re pointing at.
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If you are linking to a file on your hard 
drive (inside or outside of your local site 
folder), click the Browse for File button 
in the Property inspector. The Select File 
dialog appears D. Navigate to the file 
you want to link to, select it, and then 
click OK (Choose). The filename appears 
in the Link field. If the file is outside of 
the local root folder, Dreamweaver lets 
you know and offers to copy the file into 
the local root folder E.

or

If you are linking to a Web address, 
click in the Link field in the Property 
inspector and type the full URL of the 
link destination. You must include the 
http:// portion of the address.

You can also copy a URL from the 
Address bar of a Web browser (or anywhere 
else) and paste the URL into the Link field.

You aren’t limited to Web links, which 
begin with http://, of course; you can put any 
valid URL in the Link field, including links for 
FTP sites, email addresses, and more. Again, 
see Chapter 6 for more information.

D You can also create a link by clicking the 
Browse for File button in the Property inspector, 
which brings up the Select File dialog.

E If the file you are selecting is outside your local 
root folder, Dreamweaver offers to copy the file to 
that folder as part of the linking process.
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Adding Images
Much of the visual interest in Web pages 
is provided by images, and Dreamweaver 
makes it easy to add images to your pages. 
For much more information about add-
ing images, sound, or movie files to your 
pages, see Chapter 5.

To add an image to your page:
1. In your document, click where you want 

the image to appear.

2. In the Common category of the Insert 
panel, click the Images: Image button A.

The Select Image Source dialog 
appears B.

B The Select Image Source dialog lets you pick an image and shows you a preview of 
it as well.

A To add an 
image to your 
page, click 
the Images: 
Image button 
in the Common 
category of the 
Insert panel.
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3. Navigate to the image file you want, 
and select it.

Dreamweaver shows you a preview of 
the image in the Select Image Source 
dialog.

4. Click OK (Choose).

If the image is not inside the /images
directory of your local root folder, 
Dreamweaver copies the image to that 
location. Dreamweaver next displays 
the Image Tag Accessibility Attributes 
dialog C.

5. (Optional, but strongly recommended) 
Enter a description of the image in the 
Alternate text field.

Alternate text is text attached to the 
image for use by screen readers for the 
visually impaired or by people who are 
browsing with images turned off.

6. Click OK.

The image appears in your document D.

The Long description field in the Image 
Tag Accessibility Attributes dialog links to a 
file that can contain a full description of the 
image. This option is not often used.

If you don’t want to add alternate text, 
you can turn off the prompt dialog in the 
Accessibility category of Dreamweaver’s 
Preferences panel. But you shouldn’t; this is a 
key attribute to add for the benefit of visually 
impaired visitors to your site.

C Use this dialog to enter the alternate text for 
an image.

D The image appears on the page at the 
insertion point.
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Naming and Saving 
Your Page
After you’ve built your page, you’ll want to 
name it and save it in your local site folder. 
After you work on the page, you’ll need to 
save your changes. You should get in the 
habit of saving often; there’s nothing more 
annoying than lost work due to a power 
failure or because your computer decides 
to lock up.

It’s important to understand the difference 
between a page’s title and its name. The 
title appears at the top of the page in a 
Web browser; the name is the file’s name 
and will be part of the Web address, or 
URL, of the page. For example, “Welcome 
to HomeCook.info!” is the page’s title, but 
index.html is the page’s name.

To save your page for the first time:
1. Choose File > Save, or press Ctrl-S 

(Cmd-S).

The Save As dialog appears A.

A Use the Save As dialog to place your new 
document where you want it inside your local root 
folder and also to give it a filename.
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2. Enter the name for the page.

Dreamweaver gives the page a default 
name of Untitled-x, where x is the num-
ber of pages you’ve created since you 
launched Dreamweaver. On Windows, 
the dialog shows the name in the “File 
name” field without showing the exten-
sion; on the Mac, the name appears 
with the extension, but only the name 
is selected, ready for replacement with 
whatever you type B.

Not all characters are acceptable in a 
filename; be sure to read the “What’s in 
a Name?” sidebar.

3. You should save the file inside your 
local site folder. If you want the file to 
be in a particular folder inside your site, 
navigate to that folder.

4. Click Save.

To save changes you 
make in your pages:
Choose File > Save, or press Ctrl-S (Cmd-S).

B The Mac version of the Save As dialog shows 
you the document’s extension and selects the 
name for you.

What’s in a Name?
Your computer may allow you to enter 
characters in a filename that aren’t 
acceptable in a URL. For example, on the 
Mac, it’s perfectly OK to use the slash (/) 
in a filename. But you can’t use a slash in 
a URL (Web servers can’t handle a slash 
in a filename), so you shouldn’t include 
slashes. Similarly, you can use spaces 
in filenames on both Windows and Mac, 
but you cannot have spaces in a URL, 
so don’t use spaces in your filenames. 
Other characters to avoid include #, $, &, 
and %. We recommend that for safety’s 
sake, you use only letters, numbers, and 
the underscore character (to substi-
tute for a space). Remember that some 
people may want to manually type a URL 
from your site into a browser, so make 
things easy for them by using relatively 
short filenames. Using all lowercase 
makes it easier for visitors, too.
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Opening a Page
Opening a page is straightforward; you’ll 
usually want to use Dreamweaver’s Files 
panel. You can also use the File menu or 
the Welcome screen if you like.

To open a page:
1. In the Files panel A, find the page you 

want to open and double-click it.

The page opens.

or

Choose File > Open, or press Ctrl-O 
(Cmd-O).

The Open dialog appears.

2. Navigate to the file, select it, and 
click Open.

The file opens in a new window (or in 
a new tab if you already have open 
windows).

If you want to open a page that you 
worked on recently, find the page in the Open 
a Recent Item category in the Welcome screen, 
and click it.

Click the Site Root button in the Open 
or Save As dialog to jump quickly to the site’s 
root folder.

A Use the 
Files panel to 
find a page and 
open it.
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Previewing in 
a Browser
The page preview you see in Dream-
weaver’s Design view is useful, but it’s no 
substitute for previewing your pages in 
real Web browsers. The reason is simple: 
The Design view shows one rendering of 
the HTML page, but Web browsers, which 
may be based on different rendering 
software (often called “rendering engines”), 
may show the same page differently. For 
example, you’ll often see pages that look 
different in Internet Explorer for Windows 
(especially versions prior to IE9), Mozilla 
Firefox, Google Chrome, Opera, and Safari 
on either Mac or Windows. That’s because 
each browser lays out and draws pages in 
its own way A. Even the preview you get 
in Live view isn’t always exactly the same 
as the most common Windows browsers 
(Internet Explorer and Firefox). Although 
Dreamweaver’s Live view is much more 
true to what you’ll see in a Web browser—
since it uses WebKit, the same rendering 
engine used by Chrome and Safari—it’s still 
a good idea to preview in more than one 
real browser, preferably on Mac, Windows, 
and mobile devices.

By default, Dreamweaver makes your com-
puter’s default Web browser the default 
browser for previewing pages, but you can 
change that if you prefer.

A Thanks to the widespread acceptance of 
CSS across all browser makers, pages display 
similarly in different browsers, provided they are 
relatively modern, as with this Firefox example. 
The biggest problem to watch for is old (pre-IE9) 
versions of Internet Explorer, which had serious 
CSS rendering issues.
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To preview a page in a Web browser:
1. Save your page.

Dreamweaver requires that the page be 
saved before it can create a preview. If 
you forget, a dialog will ask you if you 
want to save. If you click No in this dia-
log, the preview that appears will be of 
the last saved version of the page—not 
necessarily the latest version—so get 
used to saving before previewing.

2. Press F12 (Opt-F12).

The page opens in the default preview 
browser.

or

Choose File > Preview in Browser, and 
then choose a browser from the sub-
menu B.

The page opens in the browser you 
selected.

or

Click the Preview/Debug in Browser 
button on the Document toolbar C. A 
pop-up menu appears with the browser 
choices available on your system.

If you’re using the built-in keyboard 
on a Mac laptop, you may need to press 
Fn-Opt-F12.

Depending on which Mac and which 
version of Mac OS X (Mountain Lion, Lion, or 
Snow Leopard) you’re running, F12 could be 
assigned by the system to Mission Control, 
Exposé, or Dashboard. On the Mac, Dream-
weaver requires that you use Opt-F12 for 
the primary browser, and Cmd-F12 for the 
secondary browser. If you have any OS X 
features that use these keys, you can change 
them to different keys in the Mission Control, 
Dashboard & Exposé, Keyboard, or Exposé & 
Spaces pane of the System Preferences panel.

B Choose the browser you want to use for the 
preview from the Preview in Browser submenu.

C You can also choose your preview browser 
from the Preview/Debug in Browser button on the 
Document toolbar.
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To set the browsers that 
appear in the Browser list:
1. Choose File > Preview in Browser, and 

then choose Edit Browser List from the 
submenu.

The Preview in Browser category of the 
Preferences panel appears D.

2. Do one or more of the following:

>	 To add a browser to the list, click the 
+ button and then fill out the informa-
tion in the resulting Add Browser 
dialog.

>	 To remove a browser from the list, 
select the browser and click the 
– button.

>	 To set a browser as the primary 
preview browser (this will cause it to 
open when you press F12 [Opt-F12]), 
select it and then select the Primary 
browser check box.

>	 To set a browser as the secondary 
preview browser (this will cause it 
to open when you press Ctrl-F12 
[Cmd-F12]), select it and then click the 
Secondary browser check box.

3. Click OK to close the Preferences dialog.

Note that there is a choice in C
that doesn’t appear in the list in D: 
Adobe BrowserLab. BrowserLab is an online 
previewing service that’s integrated with 
Dreamweaver and discussed later in this 
chapter. You can’t remove BrowserLab from 
the submenu.

D You can choose which browsers on your 
system appear in the Preview in Browser list and 
also set browsers as your primary and secondary 
preview browsers.
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Preview Using Preset 
Screen Sizes
By default, when you view a page in 
Design or Live view, it takes up the entire 
document page A. Dreamweaver already 
has a Window Sizes feature, which shrinks 
the document window to the horizontal 
and vertical sizes you specify. But the new 
Resolution Management feature lets you 
choose from different view settings for 
your document, regardless of whether you 
have the Dreamweaver window in a maxi-
mized or non-maximized mode.

There is now a Window Size menu that 
contains a list of common screen sizes, 
which you can edit to match the window 
sizes you’re targeting with your design.

A In the Dreamweaver document window, shown here in Live view, you’ll see the entire 
page you’re working on.

To make it easier for you to follow along, 
you can use the demo assets that Adobe has 
supplied on their Dreamweaver Developer 
Center site. Download the sample files from 
www.adobe.com/devnet/dreamweaver/
articles/dw_html5_pt3.html. Look for the 
citrus_pt3_completed.zip sample files. 
In order to use them, unzip the download, 
put the sample files on your local hard drive, 
and then set them up as a site within Dream-
weaver by using Site > New Site.

www.adobe.com/devnet/dreamweaver/articles/dw_html5_pt3.html
www.adobe.com/devnet/dreamweaver/articles/dw_html5_pt3.html
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To display screen sizes:
1. In the Document toolbar, click the Live 

view button B.

The document renders using the  
WebKit browser engine.

2. From the Window Size drop-down 
menu attached to the Multiscreen but-
ton in the Document menu, choose one 
of the preset sizes C. For example, 
320 x 480 Smart Phone is the nominal 
size of an iPhone screen.

The new viewport appears within the 
document window D.

If you have only one version of the 
page, the viewport will just be a window 
into the full-size page, starting from 
the upper-left corner of the page. But 
if you’ve created different CSS layouts 
for different screen sizes (this is called 
a media query, and there’s lots more 
about those in Chapter 12), the view-
port will respect the media query for 
the selected screen size and will show 
you the version of the page using the 
proper CSS layout.

3. (Optional) You can simulate changing 
the orientation of a mobile device by 
choosing either Orientation Landscape 
or Orientation Portrait from the menu.

B Look at your document in Live view in order to 
properly view different window sizes.

C The drop-down menu, part of the Multiscreen 
button in the Document toolbar, shows you 
the preset screen sizes you can display in the 
document window.

D When this low-resolution screen size is shown 
in the document window, the linked CSS file 
springs into action, changing the layout of the 
page to show the site’s logo and menus in a 
vertical layout.
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You can also access the view settings by 
clicking the Window Size menu in the status 
toolbar at the bottom of the document window 
or by choosing View > Window Size.

If you have created media queries for the 
page, they will also appear in the Window Size 
menu, below the orientation choices.

One good way to work interactively with 
your code and design is to use Split view (which 
shows code in one pane and either Design or 
Live view in the other) and then choose View > 
Split Vertically. If you drag the border between 
the two panes to the right or left—and you have 
created different CSS layouts for smaller screen 
sizes—the Live view pane will respect the 
layout file for the smaller size, and the display 
will automatically switch the CSS layout and 
change the view in that pane.

Dreamweaver’s resolution management 
preview does a decent job, but you shouldn’t 
fully rely on it for what your page will really 
look like when displayed on a mobile device. 
For example, the Safari browser on an iPhone 
automatically zooms the page so that you 
see more of it E. As always, there is no true 
substitute for viewing your pages on as many 
real-world devices as are important to you.

E Whenever possible, preview the page on the 
actual device you’re targeting. As you can see, on 
a real iPhone, the Safari browser zooms the page 
to show more of its content.

WebKit Enhancements
Dreamweaver’s Live view is powered by WebKit, the browser engine used by Apple’s Safari 
browser (which ships as the default browser on Mac and iOS devices, such as the iPhone and iPad) 
and by Google Chrome. Other devices in the mobile space, notably Android smart phones and 
some RIM BlackBerry smartphones, also include the WebKit browser engine.

Dreamweaver CS5.5 updated the built-in WebKit browser engine. Adobe says the new render-
ing is equivalent to Safari 5.0. Dreamweaver’s Live view now renders several CSS properties 
as described in the W3C specifications for CSS3. CSS rules that include font-face, svg, and  
box-shadow now render properly.

Its support of the font-face property is especially interesting, as it allows you to use non-Web-safe 
fonts by defining the location of a font resource in the CSS rule. The font resource can be either local 
to your site or an external reference. See Chapter 7 for more about implementing Web fonts and 
font-face in your documents.

Dreamweaver also supports code hinting for font-face and box-shadow. You’ll see more about 
code hints in Chapter 17.
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To customize screen sizes:
1. From the Window Size menu, choose 

Edit Sizes.

Dreamweaver’s Preferences window 
appears, set to the Window Sizes  
category F.

2. Any of the Width, Height, or Description 
fields are editable.

For example, I’ve changed the 
320 x 480 resolution’s Description to 
iPhone, and the 768 x 1024 resolution’s 
Description to iPad.

3. (Optional) If you want to add a window 
size, click the plus button below the list. 
Similarly, if you want to remove any of 
the window sizes from the menu, select 
that size in the list, then click the minus 
button below the list.

4. When you’re done customizing the win-
dow sizes, click OK. The Preferences 
window closes, and the customizations 
will appear in the Window Size menu.

F In the Window Sizes category of Dreamweaver’s Preferences 
panel, you can customize the entries that appear in the menu. Here, 
I’ve changed the Description field for the iPhone and iPad resolutions 
from the generic Smart Phone and Tablet to the device’s names.
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Viewing Pages in 
BrowserLab
One of the difficulties of browsers is that 
there are an awful lot of them, and most of us 
don’t have the resources to maintain a lab of 
computers, operating systems, and different 
browsers to see how a page will look in the 
myriad combinations of these environments. 
A service from Adobe, BrowserLab, is specifi-
cally designed to solve this problem. It allows 
you to see how your pages will render in a 
variety of browsers by emulating how those 
browsers render pages.

Adobe BrowserLab displays its page 
renderings using Flash. You can choose 
which browsers you are emulating, and 
you can view rendered pages in a 2-up 
mode, viewing them side by side to see 
the rendering differences. There’s even an 
Onion Skin mode that allows you to place 
one rendered page over another to see 
how different browsers change the layout 
of page elements.

Adobe BrowserLab is integrated into 
Dreamweaver, so you have the benefit of 
using it as just another preview mode.

To preview a page in 
Adobe BrowserLab:
1. In Dreamweaver, open the page you 

want to preview in BrowserLab.

2. Choose File > Preview in Browser > 
Adobe BrowserLab, or press Ctrl-Shift-
F12 (Cmd-Shift-F12).

The first time you connect to Browser-
Lab, you’ll need to create or enter your 
Adobe ID, the username and password 
Adobe requires to access its online 
services.

Dreamweaver will also open a Browser-
Lab panel A.

A Choose 
whether 
you want to 
preview the 
local or server 
copy of your 
page from the 
BrowserLab 
panel.
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3.  From the pop-up menu in the Browser-
Lab panel, choose Local/Network (if 
you want to preview the local copy of 
the page you’re working on) or Server 
(if you want to preview the copy of the 
page on the server), and then click the 
Preview button.

Your default browser opens and ren-
ders the page as it would appear in 
BrowserLab’s default, which was Inter-
net Explorer 7.0 when we wrote this B.

Browser menu URL field Refresh View menu Zoom levelPage rendering

B The selected page rendering appears in BrowserLab inside your default browser.
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To switch to a different 
browser rendering:
Click the browser menu in the BrowserLab 
window, and then choose the browser you 
want to see C.

For example, you could choose a browser 
that is known for up-to-date CSS render-
ing, such as Safari for Mac OS X. After a 
moment, the new rendering appears D.

To switch to 2-up or Onion Skin view:
From the View menu in the BrowserLab 
window, choose 2-up View.

The window splits into two panes to show 
how the page would render in two different 
browsers. You can change the browsers 
you are comparing with the browser menu 
in each pane E.

or

From the View menu in the BrowserLab 
window, choose Onion Skin View.

The Onion Skin view overlays the two 
renderings with a 50 percent view of each 
rendering and a slider above F. You can 
move the slider toward one rendering or 
the other to make that rendering more vis-
ible and get an idea of how that browser is 
affecting the page elements.

C You can pick from many other browsers and 
operating systems in BrowserLab.

D If you compare this figure to B, you can see 
how differently a modern, standards-compliant 
browser (Safari for Mac) renders the page versus 
an older browser with CSS rendering issues, like 
Internet Explorer 7. Note the rounded corners of 
the items in the navigation menu, and the drop 
shadow on the headline.
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Note that BrowserLab displays static 
renderings of your pages, so if you have user-
interactive elements using JavaScript or Ajax, 
those won’t be shown.

If you make changes to the page in 
Dreamweaver, you can click the Refresh but-
ton in the BrowserLab toolbar to re-render the 
pages in the displayed browser simulations.

E In the 2-up View, you can compare two 
different browser renderings. Moving the 
horizontal or vertical scroll bars in either pane 
moves the view in both panes simultaneously.

Browser rendering slider

F The Onion Skin view overlays the two page renderings, so you can easily see how page elements are 
moved on the page. You can use the browser rendering slider to make one of the renderings more visible.
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Setting Page  
Properties
Information that is contained in the <head>
tag concerns the entire page. These page 
properties include information about the 
appearance of the page, how links should 
be displayed, the font settings for head-
ings, and the encoding to be used, which 
is the character set a browser should use 
to render the page.

For example, Dreamweaver defaults to Uni-
code (UTF-8) encoding, which can safely 
represent all characters. Dreamweaver and 
Web browsers use the encoding to load 
the appropriate character set for the page. 
If you set the encoding to, say, one of the 
Chinese encodings, Dreamweaver and 
the Web browser will load the appropriate 
Chinese character set.

Dreamweaver defines CSS rules for prop-
erties that you specify in the Appearance 
(CSS), Links (CSS), and Headings (CSS) 
categories of the Page Properties dialog. 
These rules are placed in the <head> sec-
tion of the page.



ptg8274339

Building Your First Page 81

To set page properties:
1. Choose Modify > Page Properties, or 

press Ctrl-J (Cmd-J).

The Page Properties dialog opens A.

2. Click the category you want.

See the following sections for details 
on each of the categories and their 
options.

3. Set the options as you like.

4. Click Apply to see the changes on the 
open document without closing the 
Page Properties dialog.

or

Click OK to save your changes.

A Use the Appearance (CSS) category of the Page Properties dialog to use CSS 
styles to set the page font and size, text and background colors, background images, 
and margins.

Note that the available encodings are 
different on Windows and Mac. This is not a 
problem for English, but if you will be working 
in languages other than English, you should 
make sure that you use an encoding for that 
language that will work well across platforms 
and that you test your site using browsers on 
Windows and Mac.
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Appearance (CSS)
The Appearance (CSS) category of the 
Page Properties dialog A has the follow-
ing options that apply CSS styles:

n	 Page font specifies the default font 
family your Web pages will use. Dream-
weaver uses the font family you specify 
unless the font is overridden by another 
CSS style. You can also set the font to 
be bold (strong) or italic (emphasis).

n	 Size sets the default font size. Dream-
weaver uses this font size unless the 
size is overridden by another CSS style. 
You can choose an absolute size (such 
as 9, 10, 12, and so forth) or relative 
sizes (such as small, medium, large, 
x-large, and so on). Choosing an abso-
lute size allows you to pick any of the 
measurement units (pixels, points, in, 
cm, mm, picas, ems, exs, and %).

n	 Text color lets you set the default color 
for text. Click the color well to bring up 
a color picker to help you set the color.

n	 Background color lets you set the 
default color for the page background. 
Click the color well to bring up a color 
picker to help you set the color.

n	 Background image allows you to set 
an image that will appear behind all the 

text and images on the page. Click the 
Browse button to bring up the Select 
Image Source dialog, navigate to the 
image, and then click OK (Choose). If 
you set a background image, it over-
rides the background color.

n	 Repeat sets how the background image 
will be displayed if it doesn’t fill the whole 
page. You can choose repeat to tile the 
image horizontally and vertically; repeat-x 
to tile the image horizontally; repeat-y to 
tile the image vertically; or no-repeat to 
display the image only once.

n	 Margins allows you to set the Left, Right, 
Top, and Bottom margins of the page. You 
can use any of the measurement systems 
as units, as you can with text size.

Appearance (HTML)
The Appearance (HTML) category of the 
Page Properties dialog B has the follow-
ing options, implemented as HTML markup:

n	 Background image allows you to set 
an image that will appear behind all the 
text and images on the page. Click the 
Browse button to bring up the Select 
Image Source dialog, navigate to the 
image, and then click OK (Choose). If 
you set a background image, it over-
rides the background color.

B The Appearance (HTML) category applies properties to your 
page using HTML markup.
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Links (CSS)
You find the following options in the Links 
category—unsurprisingly, all affect how 
links are displayed C:

n	 Link font specifies the default font fam-
ily your Web pages use to display links. 
Dreamweaver uses the font family you 
specify unless the font is overridden 
by another CSS style. You can also 
set the font to be bold (strong) or italic 
(emphasis).

n	 Size sets the default font size for link 
text. Dreamweaver uses this font size 
unless the size is overridden by another 
CSS style. You can choose an absolute 
size or a relative size. Choosing an 
absolute size allows you to pick any of 
the measurement units (pixels, points, 
in, cm, mm, picas, ems, exs, and %).

n	 Link color sets the color to apply to link 
text. Click the color well to bring up a 
color picker to help you set the color.

n	 Visited links sets the color to apply to 
visited link text. Click the color well to 
bring up a color picker to help you set 
the color.

continues on next page

n	 Background lets you set the default 
color for the page background. Click 
the color well to bring up a color picker 
to help you set the color.

n	 Text lets you set the default color for 
text. Click the color well to bring up a 
color picker to help you set the color.

n	 Links sets the color to apply to link text. 
Click the color well to bring up a color 
picker to help you set the color.

n	 Visited links sets the color to apply to 
visited link text. Click the color well to 
bring up a color picker to help you set 
the color.

n	 Active links sets the color to apply to 
link text when you click the text. Click 
the color well to bring up a color picker 
to help you set the color.

n	 Margins allows you to set the Left, 
Right, Top, and Bottom margins of the 
page. You can use any of the measure-
ment systems as units.

C You can control many aspects of how links display with the 
Page Properties dialog, which sets the link properties with CSS.
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n	 Rollover links sets the color to apply to 
link text when you place the mouse cur-
sor over the text. Click the color well to 
bring up a color picker to help you set 
the color.

n	 Active links sets the color to apply to 
link text when you click the text. Click 
the color well to bring up a color picker 
to help you set the color.

n	 Underline style sets the way links 
are underlined. Your choices are 
Always underline, Never underline, 
Show underline only on rollover, 
and Hide underline on rollover.

If your page already has an underline 
style defined through an external CSS style 
sheet, the Underline style pop-up menu dis-
plays Don’t change. You can actually change 
it; the option is there to tell you that there 
is already a style defined. If you change the 
underline style in the Page Properties dialog, 
it overrides the previous underline style 
definition.

Headings (CSS)
The Headings category D has the follow-
ing options for headings:

n	 Heading font specifies the default font 
family used for headings. Dreamweaver 
uses the font family you specify unless 
the font is overridden by another CSS 
style. You can also set the font to be 
bold (strong) or italic (emphasis).

n	 Heading 1 through Heading 6 allows 
you to set size and color options for 
each heading size. The size pop-up 
menus allow you to set absolute sizes 
(sized with numbers, such as 9, 12, 18, 
and so on) or relative sizes (such as 
small, medium, or large); for absolute 
sizes, you can choose from any of the 
available measurement units. Click the 
color well to bring up a color picker to 
help you set the heading color.

You get more control over the text when 
you use CSS directly to redefine a Heading 
style. See Chapter 7 for more information 
about redefining HTML styles.

D You can set the default font, size, and color for headings in the 
Headings (CSS) category.
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Title/Encoding
The Title/Encoding category allows you 
to change the title and some of the more 
arcane items in a Web page E:

n	 Title allows you to change the page 
title. It’s equivalent to the Title field at 
the top of a document window.

n	 Document Type (DTD) allows you to 
change the doctype of the page. When 
you make a change here, Dreamweaver 
changes the page’s code (if necessary) to 
make it compliant with the selected DTD.

n	 Encoding sets the text encoding used 
for the page.

n	 Unicode Normalization Form and 
Include Unicode Signature (BOM) are 
only enabled when you use Unicode 
UTF-8 as the encoding. Choose Help > 
Dreamweaver to learn more.

If you keep the default Unicode (UTF-8) 
encoding, you should also make sure that from 
the Unicode Normalization Form pop-up menu 
you choose C (Canonical Decomposition, fol-
lowed by Canonical Composition). The exact 
meaning of this is mostly of interest to true char-
acter set geeks. What you need to know is that 
the C setting is the one used for Web pages.

E Set the title, document type, and encoding for the page in 
this dialog.
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Tracing Image
Some people prefer to design their pages 
in a graphics tool such as Adobe Photo-
shop or Adobe Fireworks. They can then 
export that image and bring it into Dream-
weaver as a background image. It isn’t a 
background image for the page; rather, it is 
a guide that you can use as a reference to 
re-create the same look in Dreamweaver. 
This guide is called a tracing image. The 
tracing image appears only in Dream-
weaver; it doesn’t show up when you 
preview the page in a browser.

The tracing image category has only two 
options F:

n	 Tracing image has a Browse button 
that, when clicked, brings up the Select 
Image Source dialog. Navigate to the 
image, and then click OK (Choose).

n	 Transparency is a slider that controls the 
opacity of the tracing image. You can set 
the image from zero to 100% opacity.

F A tracing image can be a useful guide for re-creating page 
designs created in a graphics program.
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Defining Meta Tags
Information about the page is contained in 
a kind of HTML tag called a meta tag. Meta 
tags can include a variety of the page’s 
summary information, including keywords 
to help search engines index the page, a 
text description of the page, and links to 
external documents such as style sheets.

When you insert meta information, it 
appears within the document’s <head> tag, 
inside a <meta> tag:

<meta name="keywords" content= 
"HomeCook.info, food, wine, cooking, 
home cooking, homecook, dining">

You can set six categories of meta tags:

n	 Meta is a general category that allows 
you to add any information you want. 
You must give it a name and specify 
the content.

n	 Keywords adds one or more words to 
the document for use by search engines 
to aid them in indexing the page.

n	 Description adds a text description 
of the site, again for use by search 
engines.

n	 Refresh reloads the current document 
after a specified interval of seconds or 
redirects the document to another URL.

n	 Base sets the base URL for the page. 
All of the document-relative paths in 
the page are considered relative to the 
base URL. For more information about 
document-relative links, see Chapter 6.

n	 Link adds a link to an external docu-
ment. It’s used most often to define the 
location for an external CSS style sheet.
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To add a meta tag:
1. Choose Insert > HTML > Head Tags, and 

then choose the tag you want from the 
submenu A.

Depending on the kind of tag you 
chose, the appropriate dialog appears. 
For example, if you choose Keywords, 
the Keywords dialog appears B. In this 
dialog, you need to enter the page’s 
keywords, separated by commas.

2. Fill out the dialog, and then click OK.

Don’t go overboard with your keywords 
or description. Search engines have long since 
figured out that lots of keywords or a very long 
description are attempts to artificially improve 
search engine rankings, and sites with exces-
sive keywords or descriptions will be screened 
out of search results.

A Dreamweaver allows you to set many meta 
tags for your document.

B Separate keywords with commas; 
Dreamweaver turns these keywords into a meta 
tag for you.
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Adding Text to 

Your Pages
The main message of most Web sites is 
conveyed by the site’s text, and a major 
part of your job in working with any site 
will be adding, modifying, and styling that 
text. Dreamweaver gives you the tools you 
need to effectively put text on your pages 
and get your message across.

When you add text, you need to deal 
with two different aspects of the text: its 
structure and its presentation. Structural 
elements are things like paragraphs, head-
ings, lists, and the like; presentation is how 
the text looks, including things like the font, 
font size, text color, and so on. Most sites 
these days separate the structure and the 
presentation. Structure is about organizing 
the content on the page, and presentation 
involves making the content look good.

In this chapter, we’ll concentrate on getting 
text onto your page and applying structure 
using headings and lists. We’ll also cover 
using basic HTML text styles to change the 
look of your text. You’ll learn how to more 
precisely style text and present it using 
Cascading Style Sheets in Chapter 7.
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Adding Text
Most of the text on a Web page is formatted 
in blocks, which are enclosed by beginning 
and ending HTML tags. For example, the 
HTML for a line of text with paragraph tags 
wrapped around it looks like this:

<p>This text is wrapped in beginning 
and ending paragraph tags.</p>

For a browser to understand that this is 
a paragraph, you (or in this case, Dream-
weaver) have to make it one by adding the 
surrounding <p> tags.

Of course, in Dreamweaver’s Design view 
or Live view, you won’t see the HTML 
tags. All of the text contained between the 
opening <p> tag and the closing </p> tag is 
considered by a Web browser to be within 
the same paragraph, no matter how much 
text is between the tags. The <p>…</p>
combination is an example of a container 
tag. Virtually all of the structural formatting 
that you can apply with Dreamweaver is 
done with container tags.

Selecting Text
Besides selecting text by dragging over it with the mouse cursor, Dreamweaver also gives you 
some text selection shortcuts in Design view:

. Double-click a word to select it.

. Move your cursor to the left of a line of text until the cursor changes from an I-beam to an arrow 
pointing at the text. Then click once to highlight a single line, or drag up or down to select 
multiple lines.

. Triple-click anywhere in a paragraph to select the entire paragraph.

. For finer control over selecting individual letters, hold down the Shift key and press the left or 
right arrow key to extend the selection one letter at a time.

. Ctrl-Shift (Cmd-Shift) plus the left or right arrow key extends the selection one word at a time. 
Ctrl (Cmd) plus the left or right arrow key moves the cursor one word to the left or right but 
doesn’t select any text.

. Press Ctrl-A (Cmd-A) to Select All (the entire contents of the current document).
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When you add text to a page with Dream-
weaver, the program automatically wraps 
the text with paragraph tags when you 
press the Enter (Return) key on your key-
board. You can see this if you switch to 
Code view by clicking the Code button  
at the top of the Dreamweaver editing 
window A.

Dreamweaver also has special commands 
that help you import entire Microsoft 
Word or Excel documents as Web pages. 
(See “Using Paste Special,” later in this 
chapter. Also, refer to the bonus chapter 
“Working with Other Applications” at the 
end of the ebook edition or download it 
from www.dreamweaverbook.com.)

To insert text:
1. In Dreamweaver’s Design view, click in 

the page where you want to add text.

2. Type the text you want.

A Dreamweaver adds paragraph tags around text when you press the Enter (Return) key.

www.dreamweaverbook.com
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Cutting, Copying, 
and Pasting Text
Just as with a word processor, you can cut, 
copy, and paste text on a page in Dream-
weaver, which shares the same menu com-
mands with virtually all standard Windows 
and Mac word processors and text editors. 
When pasting text in Design view from one 
part of a Dreamweaver page to another or 
between Dreamweaver pages, text format-
ting is automatically maintained.

Dreamweaver also allows you to paste text 
and maintain some or all of the text’s format-
ting. This is especially useful when moving 
text from applications such as Microsoft 
Word or Excel to a Web page. See “Using 
Paste Special,” later in this chapter.

To cut or copy text:
1. Select the text you want to cut or copy.

2. To cut the text to the clipboard, choose 
Edit > Cut or press Ctrl-X (Cmd-X).

or

To copy the text to the clipboard, 
choose Edit > Copy or press Ctrl-C 
(Cmd-C).

The text is placed on the clipboard.

When you have text selected, most of the 
time you can right-click to cut or copy the text 
using a context menu. You can also right-click 
to paste text from the context menu. If you 
have a single-button mouse on the Mac, you 
can Ctrl-click to bring up the context menu.
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To paste plain text:
1. Click to place the insertion point on 

the page where you want the text 
to appear.

2. Choose Edit > Paste, or press Ctrl-V 
(Cmd-V).

If you copy some HTML source code 
from another program, such as the Source 
view of a Web browser, and paste it into a 
Dreamweaver page in Design view, the HTML 
appears on the page with tags and all. That’s 
because although what you’ve pasted in is 
HTML markup, Dreamweaver is trying to be 
smarter than you—it assumes that markup is 
what you want to display. If that’s not what 
you want, but rather you want the result of the 
markup to display in your page, just switch to 
Code view in Dreamweaver before you paste. 
The HTML code will paste into the page, and 
when you switch back to Design view, it will 
display the proper formatting.

Dreamweaver offers Undo and Redo 
commands in the Edit menu, which can often 
be very useful for fixing mistakes or repeating 
operations. You can also press Ctrl-Z (Cmd-Z) 
for Undo and Ctrl-Y (Cmd-Y) for Redo.
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Dragging and 
Dropping Text
If all you want to do is move some text 
from one place on a page to another, it’s 
often faster to drag and drop the text.

To drag and drop text:
1. Select the text you want to move A.

2. Move the cursor over the selected text.

The cursor changes from an I-beam to 
an arrow.

3. Click and hold your mouse button over 
the selected text, and drag it to its new 
location, releasing the mouse button 
when the cursor is where you want 
the text B.

The text moves to its new home.

To duplicate the text, hold down the Ctrl 
(Option) key while dragging and dropping. A 
copy of the text appears when you release the 
mouse button.

A Begin dragging and dropping text by 
selecting it.

B When you release the mouse button, the text 
moves to where you dragged it.
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Using Paste Special
Dreamweaver’s Paste Special command in 
the Edit menu gives you a variety of options 
that control the way formatted content is 
pasted into Dreamweaver’s Design view.

You will probably use the Paste Special 
command most often when pasting in text 
from Microsoft Word or Excel to maintain 
the formatting that the text had in those 
programs A. Text pasted in from Excel 
can appear in Dreamweaver as a format-
ted table, which saves you a lot of time 
and effort.

The Paste Special options include:

n	 Text only pastes just the text; paragraph 
marks and all formatting are stripped 
from the text B.

n	 Text with structure pastes the text and 
maintains the structure (notably para-
graphs, tabs, and lists) but eliminates 
other text formatting C.

continues on next page

A Paste Special will do a great job of maintaining 
the formatting from this Microsoft Word document.

B This is the “Text only” version of the text 
from A, with paragraph marks and formatting 
stripped out.

C With the “Text with structure” option, the text 
and paragraph marks are there, but there’s no 
character formatting.
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n	 Text with structure plus basic format-
ting keeps the text and text structure 
and retains bold and italic formatting D.

n	 Text with structure plus full formatting 
preserves the text, structure, and styles 
from the original document E.

To use Paste Special:
1. Select the text you want to cut or copy.

The text will usually be in a different 
application than Dreamweaver.

2. Cut or copy the text.

3. Switch to Dreamweaver, and click to set 
the insertion point where you want the 
text to appear.

4. Choose Edit > Paste Special, or press 
Ctrl-Shift-V (Cmd-Shift-V).

The Paste Special dialog appears F.

5. In the dialog, click the radio button next 
to the paste option you want.

6. Click OK.

The text pastes in according to the 
option you selected.

If you use the “Text with structure plus 
basic formatting” or “Text with structure plus 
full formatting” choices, you can also paste 
graphics into Dreamweaver along with the 
formatted text.

You can copy and paste graphics from 
most applications into Dreamweaver, but if 
you want to paste a graphic along with format-
ted text, you must use Paste Special.

When pasting from Word and main-
taining full styles, Dreamweaver reads the 
Word styles and creates CSS styles with the 
same names and attributes. It places the CSS 
styles in the same document. If you want to 
use these styles elsewhere on your site, you 
should move these internal styles to an exter-
nal style sheet. See “Moving Internal Styles to 
External” in Chapter 9 to learn how to do that.

D The “Text with structure plus basic formatting” 
option maintains bold and italic formatting.

E The final option, “Text with structure plus full 
formatting,” maintains all the formatting from the 
Word document.

F Choose the option you want from the Paste 
Special dialog.
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Applying Headings
After paragraphs, headings are the most 
important structural element on most Web 
pages. Headings point your site’s visitors 
to essential information on the page, and 
they separate sections of the page. Think 
of headings as being similar to headlines in 
a newspaper.

Text you enter into Dreamweaver begins 
with no heading; Dreamweaver refers to 
this text as None in the Property inspec-
tor. As soon as you press Enter (Return), 
Dreamweaver wraps the text in paragraph 
tags, and the text becomes paragraph text.

HTML has six sizes of headings, plus 
paragraph text A. These headings don’t 
have a fixed point size, unlike headings 
in, say, Microsoft Word or Adobe InDe-
sign. Instead, they are sized relative to 
one another and to the size of the para-
graph text, and the size that the user sees 
depends on the settings in the user’s Web 
browser. By default, headings are usually 
displayed in boldface.

You can change the look of headings (their 
size, font, color, and so forth) using CSS, 
which we’ll cover in Chapter 7.

You can have only one size of HTML 
heading in a particular element. You can work 
around this limitation with CSS styles.

Headings are also important because 
they help search engines find and index con-
tent on your pages. Google in particular uses 
headings in this fashion, so it’s a good idea 
to use headings when they are appropriate to 
your content.

A Examples of the six heading sizes, plus 
paragraph, which is usually used for body text.
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To apply a heading:
1. Click in the line you want to change.

Note that you don’t have to select text; 
a heading is a block style, so it affects 
the entire paragraph the cursor is in.

2. Choose Format > Paragraph Format > 
Heading x, where x is the heading size 
you want B.

or

Press Ctrl-1 for Heading 1, Ctrl-2 for 
Heading 2, and so on. On the Mac, 
press Cmd-1 for Heading 1, Cmd-2 for 
Heading 2, and so on.

or

Choose a heading from the Format 
pop-up menu in the HTML mode of the 
Property inspector C.

or

Click one of the heading buttons in the 
Text category of the Insert panel D.

There are only buttons for Heading 1, 
Heading 2, and Heading 3, which are 
listed as h1, h2, and h3, respectively.

The text changes to the heading 
you selected.

B Choose the heading size you want from the 
Paragraph Format submenu.

C Another 
way to choose 
the heading 
size is to use 
the Format 
menu in the 
HTML mode of 
the Property 
inspector.

D The Text 
category of 
the Insert 
panel gives 
you buttons 
with many 
options, 
including ways 
to apply three 
heading sizes.
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To turn text into paragraph text:
1. Click in the line you want to change.

2. Choose Format > Paragraph Format > 
Paragraph.

or

Choose Paragraph from the Format 
pop-up menu in the HTML mode of the 
Property inspector.

or

Press Ctrl-Shift-P (Cmd-Shift-P).

Dreamweaver changes the text into 
a paragraph.

To remove heading formatting:
1. Click in the line you want to change.

2. Choose Format > Paragraph Format > 
None.

or

Press Ctrl-0 (Cmd-0). (Those are zeros, 
not the letter “O.”)

The Format menu of the Property 
inspector changes to None, indicating 
that the text has no heading or para-
graph style assigned to it.
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Applying Character 
Formats
Character formatting is styling that you 
can apply to words and individual charac-
ters rather than to blocks such as para-
graphs. This formatting includes changing 
the font, font size, and font color.

Beginning several versions ago and 
continuing through the current version of 
Dreamweaver, the program dispensed with 
the old method of applying these sorts 
of character formatting (which was to use 
the HTML <font> tag) in favor of using 
CSS styles. This change happened mostly 
behind the scenes in Code view, so if you 
have been using Dreamweaver for quite 
some time, you may not have even noticed 
the change. Beginning with Dreamweaver 
CS4, the program enforces the use of CSS 
for text styling by requiring you to partici-
pate in defining CSS rules for changing 
fonts, font sizes, and font colors.

The reason for the change to CSS is 
important. Pages styled with CSS are much 
more flexible than pages that use HTML 
<font> tags, and they can be maintained 
more easily. For example, when a site is 
redesigned, every page that uses <font>
tags must be individually changed to match 
the new design. If you have hundreds or 
thousands of pages in your site, that’s a 
lot of work. Sites that use CSS to style text 
only need to change the style sheet docu-
ment, and the changes automatically ripple 
through the whole site. You’ll learn more 
about using CSS to style text (especially 
for setting font properties) in Chapter 7. 
Some other formatting operations are still 
performed using HTML markup, and those 
are the ones we’ll explore in this chapter.
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Applying HTML 
Text Styles
The most common text formatting is to 
make text bold or italicized, and of course 
Dreamweaver can do that with either 
HTML markup or a CSS rule. But it can also 
apply several other text styles, some of 
which are for specialized uses, as shown 
in A and Table 4.1.

A Dreamweaver offers a number of useful (and not so useful) HTML text styles.

TAbLe 4.1 Text Styles

Style Description

Bold Makes text boldface.

Italic Italicizes text.

Underline Underlines text.

Strikethrough Text is shown with a line through it.

Teletype Reminiscent of an old typewriter. Usually shows text in a monospaced font such as Courier.

Emphasis Italicizes text onscreen. Causes screen readers to stress importance in speech.

Strong Bolds text onscreen. Causes screen readers to add additional importance to speech.

Code Depicts programming code, usually in a monospaced font.

Variable Marks variables in programming code. Usually displayed as italics.

Sample Meant to display sample output from a computer program or script. Usually displayed in a 
monospaced font.

Keyboard Meant to depict text a user would type on the keyboard. Usually displayed in a monospaced font.

Citation Used to mark citations and references. Usually displayed as italics.

Definition Used to mark the first, defining usage of a term in a document. Usually displayed as italics 
(Safari on the Mac displays this as regular text).

Deleted Marks deleted text. Shown the same as strikethrough.

Inserted Marks inserted text. Shown the same as underlined.
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Many of these text styles are meant for 
displaying programming or script code, 
so they won’t be used at all on many 
sites. Others, such as Underline and 
Strikethrough, are deprecated as of the 
HTML 4.01 standard, which means that 
they are obsolete and may not work in 
future browsers. Instead, you should use 
a CSS property. See “Dreamweaver CSS 
Categories” in Chapter 7.

To apply an HTML text style:
1. Select the text you want to change.

2. Choose Format > Style, and then 
choose the style you want from 
the submenu.

The text’s appearance changes.

Actually, by default Dreamweaver does 
not use the traditional <b> and <i> HTML tags 
for bold and italic, respectively. Instead it uses 
<strong> and <em> (for emphasis). The latter 
tags are preferred as part of best practices, 
because they are better handled by the screen 
readers used by visually impaired users. If 
you want to switch Dreamweaver back to 
using <b> and <i>, choose Edit > Preferences 
(Dreamweaver > Preferences) and, in the 
General category of the Preferences dialog, 
deselect “Use <strong> and <em> in place of 
<b> and <i>.”
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Using Preformatted 
Text
Browsers usually ignore invisible formatting 
that doesn’t affect page content, such as 
tabs, extra spaces, extra line feeds, and the 
like. If you need to display text exactly as 
entered, however, you can use the Prefor-
matted paragraph format, which wraps the 
text in the <pre>…</pre> tags and makes 
browsers display all of the text characters.

Originally, preformatted text was meant to 
display tabular data in rows and columns, 
as in the output of a spreadsheet. To make 
the information line up, browsers display 
preformatted text in a monospaced font 
such as Courier A.

To apply preformatting:
1. Select the text you want to change.

2. From the Format pop-up menu of the 
HTML mode of the Property inspector, 
choose Preformatted.

or

In the Text category of the Insert panel, 
click the Preformatted Text button B.

or

Choose Format > Paragraph Format > 
Preformatted Text.

The text changes appearance.

If you want to display tabular data, it 
often makes more sense to use a table rather 
than preformatted text. You get much more 
control over the table style and spacing of the 
items in the table, and you can add CSS to 
style the table’s contents if needed. See Chap-
ter 10 for information about using tables.

A Preformatted text lines up neatly, as in 
this table.

B Apply the 
style with the 
Preformatted 
Text button.
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Adding Line breaks
Just as in a word processor, you press 
Enter (Return) in Dreamweaver to create a 
new paragraph. This is fine when you want 
to actually create a new paragraph, but 
not so great when you just want to move 
the cursor down a line, as you might want 
to do when entering an address. That’s 
because Web browsers (and Dream-
weaver) insert a blank line above and 
below a paragraph, so if you make each 
line of the address its own paragraph, it 
looks goofy A.

What you want to do is add a line break, 
which moves the cursor down one line 
without creating a new paragraph. In the 
code, Dreamweaver adds the HTML  
<br /> tag to the end of the line.

To insert a line break:
At the end of the line you want to break, 
press Shift-Enter (Shift-Return).

or

At the end of the line you want to break, in 
the Text category of the Insert panel, select 
Line Break from the Special Characters 
pop-up menu.

The text changes B.

Line breaks are invisible characters in 
both Dreamweaver and Web browsers, but 
you can make them visible in Dreamweaver if 
you want. Choose Edit > Preferences (Dream-
weaver > Preferences), and then click the 
Invisible Elements category. Select the check 
box next to “Line breaks,” and then click OK. 
Dreamweaver then displays line breaks in 
Design view C.

A Paragraphs 
have whitespace 
before and after 
them, which isn’t 
really appropriate 
for things like 
addresses.

B After you replace 
the paragraph tags 
with line breaks, the 
address looks better.

C With the 
appropriate 
preference enabled, 
you can see the 
invisible line break 
characters.
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Indenting and Aligning 
Text with HTML
You won’t indent or align text in Dream-
weaver as you would with a word proces-
sor. The most common kind of indenting, 
indenting the first line in a paragraph, is 
usually done with a tab in a word processor, 
but tabs have no effect in HTML. Instead, 
you can use the text-indent CSS style 
property. Similarly, there are CSS properties 
for text alignment. See Chapter 7 for more 
about using CSS.

You can add whitespace to text—and 
simulate a tab—with non-breaking spaces. 
See “Inserting Special Characters,” later in 
this chapter.

When you are indenting paragraphs to set 
them apart from preceding and following 
paragraphs, Dreamweaver uses the HTML 
<blockquote> tag. This indents both the 
left and right margins of the block-quoted 
paragraph. You aren’t limited to para-
graphs; you can block quote any block 
element, such as headings.

Dreamweaver can align text with the left 
margin, right margin, or center of the page. 
You can also justify text, which adds space 
as needed between words so that both the 
left and right margins are aligned.

The method shown here adds alignment 
attributes to the HTML markup. You can 
also use Cascading Style Sheets to align 
text, which is covered in Chapters 7 and 8.
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To block quote text:
1. Click in the paragraph or other block 

element you want to indent.

2. Click the Indent button on the HTML 
mode of the Property inspector A.

or

In the Text category of the Insert panel, 
click the Block Quote button.

or

Choose Format > Indent or press 
Ctrl-Alt-] (Cmd-Opt-]).

The text changes B.

To add more indenting, click the Indent 
button on the Property inspector again. This 
nests the <blockquote> tags.

The CSS margin property is a much 
more flexible way to indent block elements, 
as described in Chapter 7.

To remove block quoting:
1. Click in the paragraph or other block 

element you no longer want to indent.

2. Click the Outdent button on the 
Property inspector.

or

Choose Format > Outdent or press 
Ctrl-Alt-[ (Cmd-Opt-[ ).

The text changes.

Outdent Indent

A Use the Indent 
button to apply 
a block quote to 
your text.

B The block quote nicely sets off the sonnet from 
the commentary text.
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To align text:
1. Click inside the paragraph you want 

to align.

2. Choose Format > Align, and then 
choose Left, Center, Right, or Justify 
from the submenu C.

or

Use one of the keyboard shortcuts 
listed in Table 4.2.

Longtime Dreamweaver users may be 
thrown a bit by the removal of the alignment 
buttons from the HTML mode of the Property 
inspector. Those buttons have been moved 
to the CSS mode of the Property inspec-
tor, and Dreamweaver will enforce creating 
and naming a new style rule if you use the 
alignment buttons. The program will also 
alert you if you enter a name for the style 
rule that is the same as the HTML alignment 
attributes (left, center, right, or justify). 
Use different names to prevent confusion.

C Choose a text alignment from the Format menu.

TAbLe 4.2 Alignment Shortcut Keys

Shortcut Key 
(Windows)

Shortcut Key 
(Mac) What It Does

Ctrl-Alt-Shift-L Cmd-Opt-Shift-L Left  
alignment

Ctrl-Alt-
Shift-C

Cmd-Opt-Shift-C Center 
alignment

Ctrl-Alt-Shift-R Cmd-Opt-Shift-R Right 
alignment

Ctrl-Alt-Shift-J Cmd-Opt-Shift-J Full 
justification
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Working with Lists
Lists are an easy way to organize content 
on your Web page. Dreamweaver supports 
three types of lists:

n	 Numbered lists or Ordered lists, for lists 
with items that need to be in a particular 
order A. List items are numbered and 
indented from the left margin. If you add 
or remove items from the numbered list, 
it automatically renumbers.

n	 Bulleted lists or Unordered lists, for 
lists of items in no particular order B.

n	 Definition lists, where each item has an 
indented subitem C.

A Numbered lists automatically renumber if you 
insert a new item between two existing items.

B Bulleted lists 
are single-spaced 
and indented.

C Definition lists have the definitions indented under the definition terms. The definition terms don’t have to 
be all uppercase—they just happen to be in this figure.
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To create a list:
1. Type the items for your list into the 

window. After typing each item, press 
Enter (Return).

2. Select the items in the list.

3. Choose Format > List, and then choose 
Unordered List, Ordered List, or Defini-
tion List from the submenu.

or

Click either the Unordered List or 
Ordered List button in the HTML mode 
of the Property inspector.

or

Click one of three buttons in the Text 
category of the Insert panel: ul for Unor-
dered List, ol for Ordered List, or dl for 
Definition List.

The text changes to the kind of list 
you chose.

At the end of your list, you can turn 
off the list function either by pressing Enter 
(Return) twice or by clicking the appropriate 
list button in the Property inspector again.

There are three other buttons in the Text 
category of the Insert panel that you can use 
to apply list tags to text. The li button marks 
text as a list item; the text must be within a 
bulleted or numbered list. The other two but-
tons are used for definition lists. The dt button 
marks text as a definition term, and the dd but-
ton marks text as a definition description.

Because the Text category of the Insert 
panel was originally designed to help you work 
in Code view, some of the list buttons will cause 
the Dreamweaver window to change to Split 
view, so you can see the Code and Design 
panes at the same time. If you want to avoid 
code altogether, use the Property inspector or 
the menu bar to format your lists.
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Setting List Properties
You can change numbered list and bul-
leted list properties in Dreamweaver. 
Choose between five types of numbering, 
as shown in Table 4.3. For bulleted lists, 
you can choose either a round bullet (the 
default) or a square bullet. There are no 
properties to set for a definition list.

To set list properties:
1. Click in the list you want to change to 

place the insertion point.

2. Choose Format > List > Properties.

The List Properties dialog appears D.

3. Do one or more of the following:

>	 In the List type pop-up menu, select 
Bulleted List, Numbered List, or 
Directory List (“definition list” is called 
“Directory List” in this dialog for 
some reason).

>	 In the Style pop-up menu, select one 
of the Bulleted List or Numbered 
List styles.

>	 Use the Start count text box to set 
the value for the first item in the 
numbered list.

4. Click OK.

You may notice that there is a fourth 
choice in the List type pop-up menu: Menu 
List. That choice creates an unusual type of list 
that is based on the <menu> tag. That tag was 
deprecated (that is, it was recommended that 
it not be used) when HTML 4.01 was standard-
ized in 1999. We suggest that you avoid the 
use of the Menu List option. It’s one of those 
little things that should have long since been 
removed from Dreamweaver, in our view.

D In the List Properties dialog, you can change 
the way lists are numbered and bulleted.

TAbLe 4.3 Numbered List Style Options

List Name Example

Number 1, 2, 3, 4

Roman Small i, ii, iii, iv

Roman Large I, II, III, IV

Alphabet Small a, b, c, d

Alphabet Large A, B, C, D
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Nesting Lists
You can indent lists within lists to create 
nested lists. Because nested lists do not 
have to be of the same type, you can cre-
ate, for example, a numbered list with an 
indented bulleted list, and you can have 
multiple levels of nested lists within one 
overall list E.

E You can nest numbered lists inside bulleted lists.
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To create a nested list:
1. Click the end of a line within an existing 

list to place the insertion point.

2. Press Enter (Return).

Dreamweaver creates another line of 
the list.

3. Press Tab.

Dreamweaver creates a new indented 
sublist of the same type as the parent 
list. For example, if the parent list is a 
numbered list, the new sublist will also 
be a numbered list.

4. (Optional) If you want the sublist to be 
a different type of list than the parent 
list, click the Numbered List or Bulleted 
List button in the HTML mode of the 
Property inspector.

5. Type the list item.

6. Press Enter (Return).

Dreamweaver creates a new 
sublist item.

7. To return to the original list, use the up 
or down arrow keys to move the inser-
tion point into one of the items in the 
original list, or click to place the inser-
tion point where you want it.

You can also click the Outdent button in 
the HTML mode of the Property inspector to 
merge the sublist back into the main list.

Use the List Properties dialog to format 
sublists as well as lists.

If you try to create a sublist within a 
list that is in a table by pressing Tab, Dream-
weaver jumps to the next cell rather than 
indenting and creating a nested list. One work-
around is to create the nested list outside of 
the table, cut it, and then paste it in the table 
cell where you want it to go.



ptg8274339

Adding Text to Your Pages 113

Inserting Special  
Characters
You can add special characters, such as 
the Euro, copyright, or trademark symbol, 
to your page in Dreamweaver without 
having to remember their bizarre HTML 
equivalents or odd keyboard combina-
tions. In Dreamweaver, relief is just a menu 
choice away.

About Non-breaking Spaces
An oddity about HTML is that it ignores multiple spaces. One of the special characters you can 
insert is the non-breaking space, which is useful for adding multiple consecutive spaces and occa-
sionally for nudging text and even images. Dreamweaver uses the HTML code for a non-breaking 
space (which is &nbsp;) inside paragraph tags so that blank lines appear in Web browsers, like so:

<p>&nbsp;</p>

If you want multiple spaces between words, insert one or more non-breaking spaces. The easi-
est way to do this is to press Ctrl-Shift-spacebar (Cmd-Shift-spacebar), but you can also use the 
Characters pop-up menu in the Text category of the Insert panel or the Insert > HTML > Special 
Characters submenu.

Dreamweaver by default ignores multiple spaces, but you can change this behavior and force the 
program to insert multiple non-breaking spaces in the code. Choose Edit > Preferences (Dream-
weaver > Preferences), choose the General category, and then select the check box next to “Allow 
multiple consecutive spaces.”
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To insert a special character:
1. Click in the page to place the insertion 

point where you want the special char-
acter to appear.

2. In the Text category of the Insert panel, 
choose the character you want from the 
Characters pop-up menu A.

or

Choose Insert > HTML > Special Char-
acters, and then choose the special 
character you want from the submenu.

or

If the character you want doesn’t 
appear in the menu, choose Other 
Characters from the pop-up menu in 
the Insert panel or choose Other from 
the Insert > HTML > Special Characters 
submenu. The Insert Other Character 
dialog appears B.

3. Click the character you want to use, and 
then click OK to close the dialog.

Dreamweaver inserts the special char-
acter on your page.

A Insert unusual 
characters from the 
Characters pop-up 
menu in the Text 
category of the 
Insert panel.

B The Insert Other Character dialog provides 
the rest of the special characters Dreamweaver 
can insert.
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Adding Automatic 
Dates
Dreamweaver can insert the current date 
and time in a variety of formats into your 
Web page. You can choose whether or not 
to add the day of the week.

To insert the current date:
1. Click in your page to place the inser-

tion point where you want the date 
to appear.

2. Choose Insert > Date.

The Insert Date dialog appears A.

3. Do one or more of the following:

>	 If you want the name of the day to 
appear, use the Day format pop-up 
menu to set the appearance of the 
day of the week.

>	 Make a selection from the Date 
format list.

>	 If you want the time to appear, 
choose the 12-hour or 24-hour format 
from the Time format list.

>	 Select “Update automatically on 
save,” if you want that to happen. This 
is very useful if you want visitors to 
your site to know when the page was 
last updated.

4. Click OK.

Dreamweaver inserts the date (and 
any additional items you chose) into 
your page.

A Dreamweaver lets you insert dates into your 
pages in a variety of formats.
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Finding and Replacing
Dreamweaver’s Find and Replace feature 
can save you a lot of time, because you 
can automatically find and change text on 
a single page, in pages within a folder, on 
pages you select, or throughout your site. 
You can choose to change text in Design 
view, or you can search and change just in 
Code view.

Imagine that you have a company’s site 
with dozens of pages devoted to sing-
ing the praises of its premier product, the 
amazing WonderWidget. Then one day 
you get a call from your client letting you 
know that because of a trademark dispute, 
the company has to rename the product 
WonderThing. Rather than opening each 
page and making one or more changes on 
each of them, just put Dreamweaver’s Find 
and Replace feature to work, and you’ll be 
done in just a few minutes.

The Find and Replace window
The Find and Replace window, which you 
open by choosing Edit > Find and Replace 
or by pressing Ctrl-F (Cmd-F), will be the 
tool you use for changing text A. Let’s 
look at some of this window’s parts.

Save Query Load Query

Find in pop-up menu

Search pop-up menu

Find field

Replace field

Search options

A The Find and Replace dialog provides a lot of power for making quick changes 
on a single page or throughout your site.
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n	 The Save Query button allows you to 
save searches for later use. This is great 
for instances where you create complex 
queries, so you don’t have to do all the 
work to set up the search again.

n	 The Load Query button allows you to 
retrieve a saved search.

n	 The Search options let you constrain 
your searches. “Match case” returns 
results with the same uppercase and 
lowercase letters as the text you 
entered in the Find field. “Match whole 
word” finds the text only if it matches 
one or more complete words. “Ignore 
whitespace” tells Dreamweaver not 
to pay attention to additional spaces 
and non-breaking spaces. It’s on by 
default, and it’s usually best to leave 
it on. Finally, “Use regular expression” 
(covered later in this chapter) lets you 
use wildcard characters to construct 
extremely complex searches.

n	 The Find in pop-up menu allows you 
to tell Dreamweaver the scope of the 
search. You can choose to find text in 
the Current Document (the default); 
Selected Text; Open Documents; in a 
Folder you select; in Selected Files in 
Site; or in the Entire Current Local Site.

n	 The Search pop-up menu lets you 
choose what kind of search you want 
to do. You can choose Text; Text 
(Advanced), which gives you additional 
search options; Source Code, which 
allows you to search in the HTML; or 
Specific Tag, which searches the con-
tents of HTML tags that you select. The 
latter two options are covered later in 
this chapter.

n	 The Find field is where you enter the 
text you want to find.

n	 The Replace field is where you enter 
the text you want to use to replace the 
found word.
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Finding Text with 
a Simple Search
Simple searches in Dreamweaver work 
pretty much the same way that they do 
in a word processor. Just enter the text 
you want to find and the text that you 
want to replace it with, and away you 
go. Of course, you don’t have to replace 
text; if you want you can just use the Find 
and Replace dialog to find text in one or 
more files.

To find text:
1. Choose Edit > Find and Replace, or 

press Ctrl-F (Cmd-F).

The Find and Replace dialog appears 
(see figure A in “The Find and Replace 
window”).

2. From the Find in pop-up menu, choose 
one of the options for the scope of 
your search.

3. From the Search pop-up menu, 
choose Text.

4. In the Find field, type the word or 
phrase that you’re looking for.
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5. Click the Find Next button.

Dreamweaver finds and highlights the 
found text. If the scope of the search 
included more than one page, Dream-
weaver opens the first file the text was 
found within and highlights the text. If 
the text isn’t found, you’ll get a mes-
sage to that effect at the bottom of the 
Find and Replace dialog.

or

Click the Find All button.

Dreamweaver does the search, closes 
the Find and Replace dialog, and opens 
the Search tab of the Results panel A.

6. If you clicked Find All in step 5, double-
click one of the search results in the 
Results panel to open it and highlight 
the found text.

If you select some text before you bring 
up the Find and Replace dialog, the text auto-
matically appears in the Find field, as long as 
you selected fewer than 255 characters.

You can do a quick find on the current 
page by selecting some text and then choos-
ing Edit > Find Selection or pressing Shift-F3 
(Cmd-Shift-G). Dreamweaver highlights the 
next occurrence of the text you selected.

Reopen Find and Replace 
with same search items

Cancel currently 
running search

A The Search tab of the Results panel shows you the filename and matched 
text when you click the Find All button.

You can click the green triangle button 
in the Results panel to reopen the Find and 
Replace dialog with the same search terms.

If you have a search that’s running for a 
very long time, you can cancel it by clicking the 
octagonal red Cancel button in the Results panel 
(this button is dimmed in figure A).

You can clear the search results in the 
Results panel by right-clicking in the panel and 
choosing Clear Results.
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To find the next result:
Choose Edit > Find Next, or press 
F3 (Cmd-G).

Dreamweaver finds and highlights the next 
result of the search without reopening the 
Find and Replace dialog.

To find and replace text:
1. Choose Edit > Find and Replace, or 

press Ctrl-F (Cmd-F).

The Find and Replace dialog appears.

2. From the Find in pop-up menu, choose 
one of the options for the scope of 
your search.

3. From the Search pop-up menu, 
choose Text.

4. In the Find field, type the word or 
phrase that you’re looking for.

5. In the Replace field, type the replace-
ment word or phrase.

6. Click the Find Next button.

When Dreamweaver finds the text, it 
is highlighted.

7. Click the Replace button.

Dreamweaver replaces the found text 
with the contents of the Replace field.

or

Click Replace All.

Dreamweaver warns you that you can-
not undo changes made in unopened 
files. Of course, you can undo changes 
in any open documents by choosing 
Edit > Undo. If you still want to make the 
changes, click Yes.

Dreamweaver searches through the 
entire scope of the search, replacing 
all occurrences of the found text. When 
it is done, you’ll see a message telling 
you how many changes it made.

Use a Replace operation to expand 
abbreviations and save time while you’re cre-
ating pages. For example, let’s say that you’re 
creating a Web site about JavaScript. Rather 
than typing JavaScript again and again while 
writing the site, just type “JS”; then before you 
upload the site, do a Find and Replace, chang-
ing every occurrence of “JS” to “JavaScript.” 
You can do the same thing with company 
names, people’s names, or almost any text 
that you repeat a lot.

Dreamweaver does not update the 
Search tab of the Results panel when you 
perform Replace operations.

If you get a bunch of search results but 
only want to make replacements in some 
of those results, you can do that—and save 
a bunch of time in the process. Rather than 
opening each page separately and apply-
ing the replacement, do it all in one swoop 
by using the Results panel and the Find and 
Replace dialog together. First, click the green 
triangle in the Results panel, which reopens 
the Find and Replace dialog. In the Results 
panel, Ctrl-click (Cmd-click) the results where 
you want to make replacements. Those lines 
will highlight. Then switch back to the Find 
and Replace dialog, and click Replace (not 
Replace All). The files that are modified are 
marked by a green dot next to their names in 
the Results panel.
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Performing Advanced  
Text Searches
An advanced text search allows you to 
do a more precise search by looking for 
text within (or outside of) particular HTML 
tags. You can further fine-tune the search 
by specifying particular attributes of the 
HTML tags.

Perhaps the most common example of why 
you would want to use such a search lies in 
the title of your Web pages. Whenever you 
create a new page in Dreamweaver, the 
page automatically gets the title “Untitled 
Document.” If you forget to enter titles, you 
could end up with a bunch of pages on 
your site with the same “Untitled Docu-
ment” name (it’s easy to do; while writing 
this section, I found and fixed a page on my 
personal site that had been titled “Untitled 
Document” for four years!). A basic search 
and replace won’t help, because “Untitled 
Document” is within the <title> tag of the 
pages, and a basic search only searches 
the body of a document. An advanced text 
search, which combines text and HTML 
searches, is the solution.

To perform an advanced text search:
1. Choose Edit > Find and Replace, or 

press Ctrl-F (Cmd-F).

The Find and Replace dialog appears.

2. From the Find in pop-up menu, choose 
one of the options for the scope of 
your search.

continues on next page
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3. From the Search pop-up menu, choose 
Text (Advanced).

The dialog changes and adds the 
option to search tags A.

4. In the Find field, type the word or 
phrase that you’re looking for.

5. Choose either Inside Tag or Not Inside 
Tag from the pop-up menu next to the 
+ and – buttons.

Inside Tag refers to text that is enclosed 
within a container tag, such as <p>…</p>.

6. Choose an HTML tag from the Tag 
pop-up menu.

7. (Optional) If you want to narrow the 
search further by limiting the search 
to a particular attribute of the tag you 
chose in step 6, click the + button. If you 
do not, skip to step 12.

The attribute line is added to the 
dialog B.

An example of an attribute would be 
the class attribute of the <table> tag.

Tag pop-up menu

A The Text (Advanced) option allows you to search for text within HTML tags.
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8. (Optional) From the first pop-up menu in 
the attribute line, choose With Attribute 
or Without Attribute.

9. (Optional) Choose the attribute you 
want from the next pop-up menu.

Dreamweaver only shows the attributes 
for the tag you chose in step 6.

10. (Optional) Set a comparison in the next 
pop-up menu, choosing from = (equal), 
< (less than), > (greater than), or != (not 
equal). These only work if the attribute’s 
value is a numeric amount, such as the 
size attribute of the <input> tag—for 
example, <input size="4">.

11. (Optional) In the next field (which is also 
a pop-up menu), type the value of the 
attribute. This can be a number or text.

or

Choose [any value] from the pop-up 
menu. This is useful when you want 
all tags with a particular attribute, but 
you don’t care what the value of the 
attribute is.

12. If you want to replace the found text, 
type the replacement word or phrase in 
the Replace field.

13. Depending on what you want to do, 
click Find Next, Find All, Replace, or 
Replace All.

B You can narrow your search further by adding one or more attributes 
to the tag search.

For more information about the different 
HTML tags and their attributes, choose Win-
dow > Results > Reference, click the Results 
panel, click the Reference tab, and from the 
Book pop-up menu choose O’Reilly HTML 
Reference.
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Finding and Replacing 
in Source Code
Dreamweaver’s ability to find and replace 
within the HTML source code is extremely 
powerful. You can look for text within par-
ticular tags, and you can even look within 
particular tags for specific attributes. You 
can also find text relative to other tags. For 
example, you can change specified text 
within a <table> tag and leave everything 
else alone. If you like, you can even use 
Find and Replace to replace, delete, or 
change tags and attributes.

Searching and replacing inside source 
code is much like regular text searches 
except you’ll be working in Code view. 
When you perform the search, Dream-
weaver automatically changes to Code 
view, so you don’t have to do it manually 
before you start the search.

To find and replace in source code:
1. Choose Edit > Find and Replace, or 

press Ctrl-F (Cmd-F).

The Find and Replace dialog appears.

2. From the Find in pop-up menu, choose 
one of the options for the scope of 
your search.

3. From the Search pop-up menu, choose 
Source Code A.

4. In the Find field, type the word or 
phrase that you’re looking for.

5. In the Replace field, type the replace-
ment word or phrase.

6. Depending on what you want to do, 
click Find Next, Find All, Replace, or 
Replace All.

A Choose Source Code to search the HTML in 
Code view.

If you choose Current Document from 
the Find in pop-up menu, searches will not 
search related files, such as attached CSS 
or JavaScript files. To include those in your 
search scope, choose Open Documents in the 
Find in pop-up menu.
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Finding and Replacing 
with a Specific Tag
A specific tag search lets you find and 
modify HTML tags. This has many uses; for 
example, you may still need to convert old 
sites that used <font> tags to CSS. You 
can use a specific tag search to strip out 
all those old tags, replacing them with CSS 
classes. Or you can change the now-passé 
<b> and <i> tags to their more modern 
equivalents, <strong> and <em>.

The key to the specific tag search is the 
Action menu, which specifies what replace-
ment action Dreamweaver will carry out on 
the tags found in the search. See Table 4.4
for a list of the actions available.

TAbLe 4.4 Action Menu Options

Action Description

Replace Tag & Contents Replaces the tag and everything within the tag with the contents of the 
field that appears to the right of the Action pop-up menu when this action is 
selected. This can be either plain text or HTML.

Replace Contents Only Replaces the contents of the tag with the contents of the With field.

Remove Tag & Comments Deletes the tag and all of its contents.

Strip Tag Removes the tag, but leaves any content within the tag.

Change Tag Substitutes one tag for another.

Set Attribute Changes an existing attribute to a new value, or adds a new attribute.

Remove Attribute Removes an attribute from a tag.

Add Before Start Tag Inserts text or HTML before the opening tag.

Add After End Tag Inserts text or HTML after the closing tag.

Add After Start Tag Inserts text or HTML after the opening tag.

Add Before End Tag Inserts text or HTML before the closing tag.
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To find and replace within 
a specific tag:
1. Choose Edit > Find and Replace, or 

press Ctrl-F (Cmd-F).

The Find and Replace dialog appears.

2. From the Find in pop-up menu, choose 
one of the options for the scope of 
your search.

3. From the Search pop-up menu, choose 
Specific Tag.

The Find and Replace dialog changes 
to show the tag functions A.

4. Choose the tag that you want from the 
tag pop-up menu that appears next to 
the Search pop-up menu.

You can either scroll the pop-up menu 
to find a tag, or you can type the first 
letter of the tag in the box. Dream-
weaver automatically scrolls the list. 
Depending on the tag you choose, 
Dreamweaver will change the available 
actions in the Action pop-up menu, so 
don’t be surprised if the contents of that 
menu look a bit different from those 
listed in Table 4.4.

A When you are searching within a specific tag, you can add attributes 
for that tag, and you can also specify actions that you want to perform 
on the found tag.
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5. (Optional) If you want to narrow the 
search to a particular attribute of the tag 
that you selected, click the + button and 
then choose values for that attribute, as 
discussed previously in this chapter.

If you want to narrow the search further, 
you can do so by clicking the + button 
and adding attributes.

6. Choose from the Action pop-up menu 
and, depending on the action you 
chose, set any required values.

7. Depending on what you want to do, 
click Find Next, Find All, Replace, or 
Replace All.
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Using Regular 
expressions for 
Searching
A regular expression is a pattern, writ-
ten using special symbols, that describes 
one or more text strings. You use regular 
expressions to match patterns of text, so 
that Dreamweaver can easily recognize 
and manipulate that text. Like an arith-
metic expression, you create a regular 
expression by using operators—in this 
case, operators that work on text rather 
than numbers.

The operators in a regular expression 
(see Table 4.5 on the next page) are like 
the wildcard symbols that you may have 
seen in find and replace features in other 
programs, such as word processors, 
except that regular expressions are much 
more powerful. They can also be complex 
and difficult to learn and understand, so 
if Dreamweaver’s other find and replace 
methods are sufficient for you, you may not 
need to bother with regular expressions.

Learning regular expressions is beyond 
the scope of this book, but we’ll show you 
how to use one in an example. Let’s say 
that you want to find all of the HTML com-
ments throughout your site. You can use 
this simple regular expression (we know 
it looks weird, but don’t lose heart; all will 
be explained):

<!--[\w\W]*?-->
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TAbLe 4.5 Regular Expression Special Characters

Character Matches

\ Escape character; allows you to search for text containing one of the below special 
characters by preceding it with the backslash

^ Beginning of text or a line

$ End of text or a line

* The preceding character zero or more times

+ The preceding character one or more times

? The preceding character zero or one time

. Any character except newline

\b Word boundary (such as a space or carriage return)

\B Non-word boundary

\d Any digit 0 through 9 (same as [0-9])

\D Any non-digit character

\f Form feed

\n Line feed

\r Carriage return

\s Any single whitespace character (same as [ \f\n\r\t\v])

\S Any single non-whitespace character

\t Tab

\w Any letter, number, or the underscore (same as [a-zA-Z0-9_])

\W Any character other than a letter, number, or underscore

[abcde] A character set that matches any one of the enclosed characters

[̂ abcde] A complemented or negated character set; one that does not match any of the 
enclosed characters

[a-e] A character set that matches any one in the range of enclosed characters

[\b] The literal backspace character (different from \b)

{n} Exactly n occurrences of the previous character

{n,} At least n occurrences of the previous character

{n,m} Between n and m occurrences of the previous character

() A grouping, which is also stored for later use

x|y Either x or y
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Let’s break down that expression. You read 
a regular expression from left to right. This 
one begins by matching the beginning 
characters of the HTML comment, <!--. 
The square brackets indicate a range of 
characters; for example, [a-z] would match 
any character in the range from a to z. In 
this case, the range includes two regular 
expression operators: \w means “any single 
letter, number, or the underscore,” and \W
means “any character other than a letter, 
number, or underscore.” Taken together as 
a range, [\w\W] means “any character.”

The * means “the preceding character 
(in this case, everything found by the 
contents of the square brackets) zero or 
more times,” and the ? means “the pre-
ceding character zero or one time.” Taken 
together, they match a comment of any 
length. The regular expression ends by 
matching the closing characters of an 
HTML comment, -->.

To search with a regular expression:
1. Choose Edit > Find and Replace, or 

press Ctrl-F (Cmd-F).

The Find and Replace dialog appears.

2. From the Find in pop-up menu, choose 
one of the options for the scope of 
your search.
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3. From the Search pop-up menu, choose 
any of the options.

In this case, since we’re looking for 
HTML comments, you should choose 
Source Code.

4. Enter the regular expression in the Find 
field A.

5. Select the check box next to “Use regu-
lar expression.”

When you choose “Use regular 
expression,” it disables the “Ignore 
whitespace” search option, because 
they are mutually exclusive.

6. (Optional) Enter text or a regular expres-
sion in the Replace field.

7. Depending on what you want to do, 
click Find Next, Find All, Replace, or 
Replace All.

There’s a lot to say about regular expres-
sions, certainly enough to fill an entire book or 
12. If you’re interested in learning more, check 
out Mastering Regular Expressions by Jeffrey 
Friedl (O’Reilly Media, 2006). For a lighter 
read, try Teach Yourself Regular Expressions in 
10 Minutes by Ben Forta (Sams, 2004). There 
are also many Web sites that provide regular 
expression tutorials, which you can find with a 
Google search.

A You can add regular expressions to both the Find and Replace fields.
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Checking Spelling
No word processor comes without a spell-
ing checker these days, and Dreamweaver 
is no different (even though it’s not a word 
processor). You can check the spelling on 
the currently open page and add words 
to Dreamweaver’s spelling checker in a 
personal dictionary.

To spell-check your page:
1. Choose Commands > Check Spelling, 

or press Shift-F7 (same on Windows 
and Mac).

If Dreamweaver finds a word it believes 
is spelled incorrectly, the Check Spell-
ing dialog opens A. Otherwise, you’ll 
get a dialog that says “Spelling check 
completed.”

2. Click the Add to Personal button if the 
word Dreamweaver found is correct 
and you want to add it to your personal 
dictionary so that Dreamweaver doesn’t 
flag it as an error again.

or

Click Ignore to tell the spelling checker 
to ignore this instance of the word, 
or click Ignore All to ignore the word 
throughout the document.

or

Select a replacement from the Sug-
gestions list, or type the replacement 
in the Change to text box. Then click 
the Change button, or click Change 
All to replace the word throughout 
the document.

3. When the spelling check is finished, 
click Close.

A Click Add to Personal in the Check Spelling 
dialog to add an unknown word to the user’s 
personal Dreamweaver dictionary.
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and Media
Image and media files convey much of the 
message of your Web site. You may even 
get most of your message across with 
video and animation, although most sites 
use images to supplement the text.

Some Web sites suffer from graphic 
overkill. There’s a balancing act between 
using graphics to enhance the message 
and using images to bludgeon visitors into 
submission. Think of sites that use images 
of green text on a red background, for 
instance, or sites that are so proud of their 
“fabulous” graphic look that they relegate 
text to microscopic type.

Dreamweaver has many ways to place and 
modify images, as well as to control how 
text wraps around images. The program 
does a great job of adding dynamic media 
to your pages, such as Flash animations 
and movies, and also other formats such 
as QuickTime and Windows Media. In 
this chapter, we’ll cover how you can use 
Dreamweaver to add graphics and media 
files to your Web pages. You’ll get to use 
your talents to add images to express and 
enhance your site’s message.

In This Chapter
Adding Images 134

Inserting Images from the Assets Panel 138

Adding Image Placeholders 139

Setting Image Properties 141

Editing Images 143

Optimizing Images 147

Working with Photoshop 148

Adding a Background Image 154

Adding a Favicon 156

Adding Flash and Shockwave 158

Adding Flash Video 160

Adding QuickTime and Other Media 163
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Adding Images
Dreamweaver can place images on your 
Web page that come from your local hard 
disk or that are already on your Web site. 
By default, Dreamweaver prompts you to 
add alternate text to the image, which is 
text that is read aloud by screen reader 
software used by the visually disabled. If 
you have existing images on your pages 
that don’t have alternate text, it’s easy 
to add. You can, of course, easily delete 
images from your page.

To add an image to your page:
1. Click to place the insertion point in the 

document where you want the image 
to appear.

2. In the Common category of the Insert 
panel, click the Images button A.

The Images: Image button is actu-
ally a pop-up menu that allows you to 
add a variety of image types. We’ll be 
talking about these different types later 
in this chapter.

or

Choose Insert > Image, or press  
Ctrl-Alt-I (Cmd-Opt-I).

or

Drag the icon of an image file from 
the Windows or Macintosh desktop 
into your document. If you choose this 
method, skip to step 6.

The Select Image Source dialog 
appears B.

By default, the dialog will be set to the 
images folder of your local site folder.

3. In the dialog, navigate to and select the 
file that you want to insert.

A preview of the image appears in 
the Select Image Source dialog, with 

A Begin inserting 
an image by 
clicking the Images: 
Image button in the 
Insert panel.

B Navigate to the image you want in the Select 
Image Source dialog.

C Dreamweaver lets you know that it will use an 
absolute file reference rather than a relative reference 
to the image file until you save the document.
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information below the image including 
the image’s size in pixels, its graphic 
format, its file size, and the estimated 
time for the file to download (based on 
the Connection Speed pop-up menu in 
the Window Sizes category of Dream-
weaver’s Preferences).

4. Click OK (Choose).

If you have not already saved the docu-
ment, and the Relative to pop-up menu 
in B is set to Document rather than 
Site Root, Dreamweaver displays an 
alert letting you know that it can’t use a 
document-relative path, and that it will 
use an absolute file reference until you 
save the file C.

5. Click OK to dismiss the alert.

The Image Tag Accessibility Attributes 
dialog appears D. This is the dialog 
you use to add alternate text.

6. In the Alternate text box, type the alter-
nate text you want to use for the image.

7. (Optional) In the Long description text 
box, add a URL that leads to a page 
with a detailed description of the image.

8. Click OK.

The image appears on your page E.

In some browsers, an image’s alternate 
text appears when you hover the mouse 
pointer over the image on the page.

The Image Tag Accessibility Attributes 
dialog only appears if the option for images 
has been set in the Accessibility category 
of the Preferences dialog F. Because 
using alternate text is one of the commonly 
accepted Web best practices, the option is 
turned on by default. If you don’t want Dream-
weaver to prompt you for alternate text every 
time you insert an image, clear the Images 
check box in Preferences.

D Enter alternate text for use by screen reader 
software used by the visually disabled.

E The image 
appears in the 
document.

F You can set Accessibility settings in 
Dreamweaver’s Preferences dialog.

If you click Cancel in the Image Tag 
Accessibility Attributes dialog, the image 
appears on your page without alternate text. 
You can always add alternate text later using 
the Property inspector.
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To add alternate text to an 
existing image on your page:
1. Click an image to select it.

2. In the Alt text box in the Property 
inspector G, type the alternate text, 
and then press Enter (Return).

Dreamweaver adds the alternate text to 
the image.

To delete an image:
1. Click an image to select it.

2. Press Backspace (Delete).

The image disappears from the page.

You can cut, copy, or paste images as 
you would with text.

G You can also add alternate text in the Alt field of the Property inspector.
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About Graphic Formats
There are three main still (as opposed to moving) image formats used on the Web: JPEG, GIF, and 
PNG. If you are not already familiar with these formats, here’s a quick rundown, in the order in 
which they were originally developed:

. GIF, which stands for Graphics Interchange Format, is a lower-resolution graphics format with 
only eight bits of color information, which means that a GIF file can only contain up to 256 
colors. GIFs are usually used for line drawings, flat cartoons, logos, and the like; in other words, 
images that don’t need thousands or millions of colors (as would, for example, a photograph). 
There are two nice things about the GIF format. One is that it allows for transparency, which 
means you can set one or more colors in the GIF file to be the same as the background color 
of the page. This allows for irregularly shaped objects to appear on your page and for them to 
appear to be other than a rectangular image. The other useful feature of this format is the abil-
ity to add simple animation to images. A particular GIF file can contain multiple frames, and the 
file automatically steps through the frames to produce a rudimentary animation, like a flipbook. 
GIF files are used less frequently than they once were, giving way mostly to PNG files.

. JPEG, which stands for Joint Photographic Experts Group, is a format that was developed 
specifically to handle photographic images. A JPEG file can use 24 bits of color information, 
which allows it to offer millions of colors. The JPEG format is “lossy,” which means that it uses 
compression to reduce the file size. The look of the image depends on the amount of compres-
sion used to record it. High levels of compression will result in noticeable image degradation, 
because image information is actually being thrown away to reduce the file size. However, you 
can realize a significant reduction in file size at moderate levels of compression, with little or 
no visible effect, especially at the relatively low resolutions provided on Web pages. Unlike the 
GIF format, a JPEG file can contain neither transparency nor animation.

. PNG, or Portable Network Graphics, was created to replace the GIF format with an image 
format that didn’t require a patent license to use (the owner of the GIF patent began enforcing 
the patent in 1995 and demanding royalty payments from software companies whose software 
created GIF files; those patents have since expired). PNG also improves upon GIF’s 256-color 
limitation; a PNG file supports millions of colors and much better transparency options (but 
PNG does not offer animation). PNG files are usually smaller than the same file in GIF format, 
due to better compression. Adobe Fireworks uses PNG as its native file format, and of course 
Dreamweaver fully supports the PNG format. Some very old Web browsers (for example, Inter-
net Explorer 3) don’t support PNG graphics, but there are so few of these browsers still in use 
that you generally shouldn’t worry about it.
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Inserting Images from 
the Assets Panel
Any images that you’ve used on your site 
will be listed in the Assets panel, which is 
a tab in the same panel group as the Files 
panel. The Assets panel has buttons run-
ning down its left side that show you differ-
ent asset categories A. The first of these 
categories is Images. When you click the 
Images button in the panel, you get a list 
of all of the images in your site. Clicking an 
item in the list shows you a preview of the 
image in the Assets panel’s preview pane, 
allowing you to easily browse through the 
images. You can browse any of the other 
asset categories in the same fashion.

To insert an image from 
the Assets panel:
1. Click in your document to set the inser-

tion point where you want the image 
to appear.

2. If it’s not already showing, click the tab 
for the Assets panel, or choose Win-
dow > Assets, or press F11 (Opt-F11).

3. Click the Site radio button at the top of 
the Assets panel.

The images in your site appear in the 
asset list.

4. Click the image you want to insert.

A preview of the image appears in the 
Assets panel’s preview pane.

5. Click the Insert button at the bottom of 
the Assets panel.

or

Drag the image from the asset list into 
the document.

or

Right-click the image you want in the 
asset list, and then choose Insert from 
the context menu.

The image appears in your document.

A Choose the image that you want 
to work with in the Assets panel.

Images
Colors

URLs
Flash

Shockwave
Movies
Scripts

Templates
Library

Insert button

Preview pane

Asset list
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Adding Image 
Placeholders
When you first work on a page, you’ll 
often be creating pages without all of the 
finished elements, such as the text and 
images. That shouldn’t stop you from 
working on the page’s design, of course. 
You can always copy and paste “The quick 
brown fox…” or similar text as a placeholder 
for the text that’s to come, and Dream-
weaver gives you the ability to insert image 
placeholders as well. The placeholder 
lets you allot the space on the page for a 
future image, allowing you to position and 
size the placeholder and finish your design 
before you have all the content. When you 
are ready to turn the placeholder into the 
final image, all you have to do is double-
click the placeholder.

To insert an image placeholder:
1. Click in your document to set the inser-

tion point where you want the image 
placeholder to appear.

2. Choose Insert > Image Objects > Image 
Placeholder.

or

In the Common category of the Insert 
panel, choose Image Placeholder from 
the Images pop-up menu A.

The Image Placeholder dialog 
appears B.

continues on next page

A Use the Images 
pop-up menu in the 
Insert panel to insert 
an image placeholder.

B Use the Image Placeholder dialog to specify 
the placeholder’s parameters.
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3. Fill out the Width and Height fields for the 
image placeholder (the units are pixels).

The Name and Alternate text fields are 
optional; if you fill them out, the text will 
appear in the Property inspector in the 
Name and Alt text boxes. You cannot 
use spaces in the Name field.

The default color for an image placeholder 
is a light gray; if you want to change that 
color, click in the color well and choose a 
new color from the resulting color picker.

4. Click OK.

The new image placeholder appears in 
your document C.

To replace the placeholder 
with an image:
1. Double-click the image placeholder.

The Select Image Source dialog appears 
(see figure B in “Adding Images”).

2. Select the file that you want to insert.

3. Click OK (Choose).

The image appears on your page.

If you own Adobe Fireworks, when you 
select an image placeholder you’ll see a button 
in the Property inspector that has the Fireworks 
logo and the word Create D. Clicking this 
button launches Fireworks and creates a new 
image with the same dimensions as the place-
holder. After you finish making the image in 
Fireworks, save the image in your site’s images 
folder. You are then returned to Dreamweaver. 
The new image is inserted automatically in your 
document, replacing the image placeholder.

C The image placeholder appears in the 
document, with its name and size (these are cut off 
if the image isn’t big enough, as shown here).

D Click the Create button in the Property inspector when an image 
placeholder is selected to launch Adobe Fireworks so that you can replace 
the placeholder with a finished graphic.
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Setting Image 
Properties
There are several properties that you can set 
for images using the Property inspector A:

n	 ID lets you name the image. This name 
is used to refer to the image in scripts, 
and you must enter a name for scripts 
to be able to manipulate the image, 
as you might want to do for a rollover. 
You cannot use spaces or punctuation 
in an image name. Instead of spaces, 
we suggest you use the underscore 
character ( _ ).

n	 Src (for Source) shows the path to the 
image file on your site.

n	 Link shows the destination if the image 
has a link to a URL.

n	 Alt shows the alternate text for the image.

n	 W (for Width) is the width of the image 
in pixels or percent of the image size.

n	 H (for Height) is the height of the image 
in pixels or percent of the image size.

n	 Class shows the CSS class, if any, that 
has been applied to the image.

continues on next page

A You can make a variety of adjustments to an image in the Property inspector.

Image map tools Image editing and adjustment tools
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n	 Edit includes buttons that allow you 
to edit the image in an external editor; 
change image setting, including image 
file format; and update Smart Objects 
(more about Smart Objects later in 
this chapter).

n	 Crop, Resample, Brightness and Con-
trast, and Sharpen are a group of tools 
that allow you to make adjustments to 
the image.

n	 Map is a field and four tools that allow 
you to name and add an image map to 
the image. See “Creating Image Maps” 
in Chapter 6 for more information.

n	 Target specifies the frame or window 
in which the destination of a link should 
load. The pop-up menu next to the 
Target field shows the names of all the 
frames in the current frameset. There are 
also five other target possibilities. The 
_blank target loads the linked file into a 
new browser window. The _new target 
acts like _blank the first time it’s used, 
but after that, each time a link using the 
_new target is clicked, it will reuse the 
same “new” window. We think that _new
is confusing, and we don’t recommend 
its use. The _parent target loads the 
linked file into the parent frameset, the 
window of the frame that contains the 
link, or the full browser window. The 
_self target loads the linked file into the 
same frame or window as the link. This 
is the default choice. The _top target 
loads the linked file into the full browser 
window and removes all frames.

n	 Original shows the location of the origi-
nal file (usually a Photoshop file) that is 
the basis of the selected image. This 
field shows the path to the source of a 
Smart Object.

To set image properties:
1. Click to select the image to which you 

want to apply one or more properties.

2. In the Property inspector, apply the 
property you want.

The property is immediately applied.

If you don’t want to apply an interactive 
effect (like a rollover) to an image, you can 
leave its ID field blank.

The pop-up menu next to the Alt field 
has one choice, <empty>. You can use this 
attribute for images, such as spacer GIFs, that 
don’t need to be read by screen readers for 
the visually disabled. Because accessibility 
guidelines state that all images should have 
alternate text, it’s a good idea to apply this 
attribute to any images that are literally just 
taking up space.

If you want to add a border around an 
image, you can do so using the CSS border 
properties. Previous versions of Dreamweaver 
let you set borders in the Property inspector 
using HTML, but CS6 removes that ability. 
You’ll have more control over the kind and 
color of the border with a CSS rule. See Chap-
ter 7 for more information.
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Editing Images
When you’re working with images on 
your site, you’ll often want to tweak them 
to improve their looks. You could use an 
external image editing program, such as 
Adobe Photoshop or Adobe Fireworks, to 
do the job, but it’s more convenient to work 
right in Dreamweaver for simple changes. 
For extensive modifications, you’ll still 
need an external image editor, however.

The Property inspector gives you seven 
buttons that allow you to edit an image A. 
Two of the buttons, Edit and Update from 
Original, hand the image off to Photoshop 
or another editor for editing and update 
the Dreamweaver image when the original 
Photoshop image changes. We cover using 
these buttons in “Working with Photoshop,” 
later in this chapter.

Edit Image Settings lets you change the file 
format and optimization of the image. We’ll 
cover this in more detail in “Optimizing 
Images,” later in this chapter.

The other four buttons let you make quick 
image adjustments right in Dreamweaver. 
They are Crop, which lets you trim away 
portions of an image; Resample, which 
adds or subtracts pixels from an image that 
has been resized (this reduces the image 
size for better download performance); 
Brightness and Contrast, which allows you 
to correct images that are too dark or too 
light; and Sharpen, which changes the con-
trast of the edges inside an image, making 
it appear to be more in focus.

If you select an image and the image 
editing tools are grayed out, it’s probably 
because you enabled Check In/Check Out for 
your site, and you need to check out the file 
for editing. For more about Check In/Check 
Out, see Chapter 18.

Edit 
Image 

Settings

Edit Update 
from 

Original

Crop

SharpenResample

Brightness/
Contrast

A The Property inspector gives you access to a 
variety of image editing tools.

To halt the editing process after you 
begin it and leave the image unchanged, press 
the Esc key.
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To crop an image:
1. Select the image that you want to crop.

2. In the Property inspector, click the 
Crop button.

or

Choose Modify > Image > Crop.

3. Dreamweaver puts up an alert dialog 
letting you know that the changes you 
will be making to the image are perma-
nent, but that you can still use Undo to 
back away from the changes. Click OK.

A crop selection box with eight resize 
handles appears within the image. Parts 
of the image outside of the crop selec-
tion box are dimmed B.

4. Click and drag the crop selection box 
to move it around the image, and resize 
the box by dragging any of its selection 
handles, until you have the portion of the 
image you want to keep inside the box.

5. To complete the crop, press Enter 
(Return).

or

Double-click inside the crop selection 
box.

Dreamweaver trims the image.

B The part of the image outside the selection 
rectangle will be cropped out.
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To resize and resample an image:
1. Select the image that you want to change.

2. Using the image’s resize handles, make 
the image larger or smaller.

or

Use the W and H text boxes in the 
Property inspector to resize the image 
numerically.

The image resizes, and the Resample  
button in the Property inspector 
becomes available for use. In the Prop-
erty inspector, two new buttons appear 
next to the W and H text boxes: Reset to 
Original Size and Commit Image Size C.

3. Click the Commit Image Size button.

4. In the Property inspector, click the  
Resample button.

or

Choose Modify > Image > Resample.

Dreamweaver resamples the image. On 
many images, the effect is quite subtle.

To adjust the brightness and 
contrast of an image:
1. Select the image that you want to adjust.

2. In the Property inspector, click the 
Brightness and Contrast button.

or

Choose Modify > Image > Brightness/
Contrast.

The Brightness/Contrast dialog appears D.

3. If it isn’t already checked, select the 
Preview check box.

This makes adjusting the image a little 
slower, but it allows you to see the 
effects of your changes on the image as 
you make them.

continues on next page

Reset to Original Size Commit Image Size

C Click the 
Commit Image Size 
button to accept 
the new image size.

D Drag the sliders in the Brightness/
Contrast dialog to change the intensity 
of the image.
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4. Move the Brightness and Contrast  
sliders until the picture looks the way 
you want it.

or

Enter a numeric value in the text boxes 
next to Brightness and Contrast. The 
sliders begin in the middle of the range, 
and the acceptable range for each 
slider is from -100 to 100.

5. Click OK.

To sharpen an image:
1. Select the image that you want to 

sharpen.

2. In the Property inspector, click the 
Sharpen button.

or

Choose Modify > Image > Sharpen.

The Sharpen dialog appears E.

3. If it isn’t already checked, select the 
Preview check box.

This makes sharpening the image a 
bit slower, but it allows you to see the 
effects of your changes on the image as 
you make them.

4. Move the Sharpness slider until the 
picture looks the way you want it.

or

Enter a numeric value in the text box 
next to Sharpness. The slider begins at 
zero and goes to 10.

5. Click OK.

Use a light hand when using the Sharpen 
tool. Oversharpening an image often makes it 
look unnatural, with edges in the picture that 
look too prominent or even oddly outlined F.

E Sharpening an image often brings 
out important detail that isn’t as 
noticeable in the unsharpened image.

F Oversharpening an image (bottom) 
can make items in the image look weird.
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Optimizing Images
You can optimize images that are in a 
Dreamweaver document. Optimization 
means that you can change the image from 
one format to another (for example, from 
PNG to JPEG), change the quality setting, 
and more.

To optimize an image:
1. Select the image you want to optimize.

2. In the Property inspector, click the Edit 
Image Settings button (see figure A in 
“Editing Images”).

or

Choose Modify > Image > Optimize.

The Image Optimization dialog 
appears A. The dialog has two pop-up 
menus (Preset and Format) and a set-
tings area below Format.

The Preset pop-up menu B lets you 
pick from six different PNG, GIF, and 
JPEG presets. By default, this menu is 
set to no value.

You can use the Format pop-up 
menu C to change the file format 
to PNG, JPEG, or GIF. Depending on 
the format you choose, the dialog will 
change to show the appropriate set-
tings used to modify the parameters of 
the selected format.

3. Make your choices from the Preset and 
Format pop-up menus.

As you make your choices, the File 
size figure at the bottom of the dialog 
updates.

4. Click OK.

The image is saved and updated.

A You can make a variety of changes in the 
Image Optimization dialog, including changing the 
graphics format.

B Use the Preset pop-up menu to 
apply formats for the image. Each choice 
includes a bit of information to help you 
choose the correct format.

C The Format 
pop-up menu 
lets you pick 
the image’s 
file format 
and gives you 
settings to 
make further 
adjustments.

Keep a close eye on the File size display 
as you experiment with changes; with some 
presets, such as PNG 24, you can easily end 
up making the file size significantly larger, 
which is usually not what you want.
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Working with 
Photoshop
Dreamweaver has built-in integration with 
Adobe Photoshop CS3 or later. There are 
two methods of moving Photoshop images 
into your Dreamweaver document. In the 
first, you begin in Photoshop by opening 
an image and copying all or a portion of 
the image (a portion can be a selected part 
of the image, or one or more image layers). 
Then you switch to Dreamweaver and 
paste. Dreamweaver asks you how you 
want to save your image, and then places 
it on your Web page. You can choose the 
graphic format you want as the object is 
placed on the Web page.

In the second method, introduced with 
Dreamweaver CS4, you can choose a 
Photoshop file in the Select Image Source 
dialog and then place it into Dreamweaver. 
It is copied and placed into Dreamweaver 
in JPEG, GIF, or PNG format as a Smart 
Object, which maintains a link to the origi-
nal Photoshop .psd file. When the .psd file 
is updated and saved, Dreamweaver rec-
ognizes the changes and offers to update 
the copy in the Dreamweaver document. 
Dreamweaver also remembers the path to 
the Photoshop source file and allows you 
to reopen it for modifications in Photoshop.

The benefit of the Smart Object approach 
is that you can have a single .psd file that 
is used in many different pages of your 
site. When you update the Photoshop file, 
you can update any Smart Objects based 
on that file throughout your site at once.
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To copy and paste Photoshop 
images into Dreamweaver:
1. In Photoshop, open the image you want 

to bring into Dreamweaver.

2. Select the image or part of the image 
you want to copy.

You can select one or more layers in 
your document, or use one of Photo-
shop’s many other selection tools A.

3. If you made a selection from a single 
layer, choose Edit > Copy.

or

If you selected multiple layers, choose 
Edit > Copy Merged.

4. Switch to Dreamweaver.

continues on next page

A In Photoshop, the background layer and the text layer have been selected in the Layers panel.
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5. Choose Edit > Paste.

The image appears on the page full 
size, along with the Image Optimization 
dialog B.

6. Make any adjustments you want in the 
Image Optimization dialog:

Using the Preset and Format pop-up 
menus, you can change the format of 
the saved image to GIF, JPEG, or PNG 
and make adjustments specific to each 
file type. For example, if you choose GIF 
format, you can set one of the colors in 
the image to be transparent.

7. Click OK.

The Save Web Image dialog appears C.

8. Give the image a name, and navigate 
to where you want to save it (usually 
inside your site’s images folder).

Remember that you can’t use spaces in 
names for images for the Web, and that 
the only other characters you should 
use besides letters and numbers are 
the hyphen and underscore.

9. Click Save.

The Image Description (Alt Text) dialog 
appears. Alternate text is used by 
screen reading programs utilized by 
the disabled.

10. Enter the description for the image, and 
then click OK.

The image from Photoshop appears on 
your Web page.

B When the image appears in Dreamweaver, you 
can see that the image contains both the text and 
background layers from the Photoshop image. 
You can also make adjustments to the image 
optimization settings.

C Give the image a name, and save it in your 
images directory.
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11. Use the image editing tools to adjust 
the image, if needed, to get the final 
appearance in your layout D. For 
example, you will almost always want 
to resize and resample the image to fit 
your Web layout, if you haven’t already 
done so in your image editor.

This copy-and-paste integration process 
also works with Fireworks.

When images are placed and saved in 
Dreamweaver, they are flattened and lose their 
layers. If you want to maintain layers, use the 
Smart Object method to maintain a link to the 
original .psd.

Information about the image, such as the 
optimization settings and the location of the 
original .psd source file, is saved in a Design 
Note regardless of whether you have enabled 
Design Notes for your site.

To edit copy-and-pasted 
images using Photoshop:
1. Select the image in Dreamweaver.

2. Ctrl-double-click (Cmd-double-click) 
the image.

or

Click the Edit button in the Property 
inspector (see figure A in “Editing 
Images”).

Dreamweaver opens the source file in 
Photoshop.

3. Make your changes to the image in 
Photoshop and save the file.

4. Select all or part of the image and choose 
Edit > Copy, or if you selected multiple 
layers, choose Edit > Copy Merged.

5. Switch to Dreamweaver.

continues on next page

D After resizing and resampling, here is the 
image in the finished layout.

From Preview to Optimization
Dreamweaver CS6 changes the work-
flow of Photoshop integration quite a bit. 
Previous versions used an Image Preview 
dialog, which has been replaced by the 
Image Optimization dialog. In some ways 
the new workflow is improved, in that 
there are fewer options and the new 
dialog encourages you to do your image 
preparation in a real image editor. But on 
the other hand, you could do things (like 
resizing images) in the Image Preview 
dialog that you can’t do in the Image 
Optimization dialog. So now if you want 
to import the high-resolution PSD file into 
Dreamweaver, it comes in at full size. Then 
you must resize and (sometimes) resam-
ple the image in Dreamweaver. That’s two 
separate operations, not just one. In our 
opinion, that’s a step backwards.
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6. Paste the image over the image in the 
Web page. Dreamweaver optimizes the 
.psd image on the clipboard using the 
original optimization settings and then 
replaces the image on the page with 
the updated version.

To place a Photoshop image 
as a Smart Object:
1. Click to place the insertion point in the 

document where you want the image 
to appear.

2. In the Common category of the Insert 
panel, click the Images button (see 
figure A in “Adding Images”).

or

Choose Insert > Image, or press  
Ctrl-Alt-I (Cmd-Opt-I).

The Select Image Source dialog appears 
(see figure B in “Adding Images”).

3. In the dialog, navigate to and select the 
Photoshop file that you want to insert.

With Photoshop files, you don’t get the 
usual preview of the image in the Select 
Image Source dialog.

4. Click OK (Choose).

5. The Image Optimization dialog 
appears B.

6. Using the Preset and Format pop-up 
menus, select the file format you want 
to use, and tweak the settings for that 
format, if needed.

7. Click OK.

The Save Web Image dialog appears C.

8. Give the image a name, and navigate to 
where you want to save it.

9. Click Save.

The Image Tag Accessibility Attributes 
dialog appears. 
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10. Enter the description for the image, and 
then click OK.

The image from Photoshop appears on 
your Web page, with a difference: It has 
a badge in the upper-left corner, show-
ing that it is a Smart Object E.

To update a Smart Object:
1. Click to select the image that you want 

to change.

If the Smart Object needs updating, 
the badge will change, with the bottom 
arrow turning red, indicating that the 
copy of the image in the Dreamweaver 
document is out of sync with the origi-
nal Photoshop file F.

2. Click the Update from Original button in 
the Property inspector (see figure A in 
“Editing Images”).

or

Right-click the image and choose Update 
from Original from the context menu.

The image updates to show the 
changes in the Photoshop docu-
ment G, and the Smart Object badge 
shows that it is in sync.

The Smart Object badge appears only 
in Dreamweaver, not on your published 
Web pages.

You can have multiple Smart Objects 
on a single page (perhaps in different sizes, 
or cropped differently) that all link to the 
same Photoshop file. You can update each 
Smart Object independently.

You can update Smart Objects in the 
Assets panel by right-clicking them and choos-
ing Update from Original from the context 
menu. The great thing about this method is 
that if you have used the Smart Object on mul-
tiple Web pages, the image is updated on all 
pages without you needing to open them.

Smart Object badge

E The road sign has the Smart Object badge in 
its upper-left corner.

F The bottom arrow 
in this Smart Object 
badge has turned red, 
indicating that the image 
is out of sync with the 
original Photoshop file.

G After updating, the image shows the changes 
that had been made to the Photoshop file.
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Adding a Background 
Image
Most pages use a solid color or no color as 
their background, but sometimes you may 
want to use an image as the background 
of your page. This image will underlie all 
of the text and other images on your page. 
Though background images are a bit of a 
dated look, they can still be used on mod-
ern pages if you use them well.

Dreamweaver creates background images 
by creating a CSS rule to redefine the 
<body> tag. You can do this by creating the 
rule manually (see Chapter 7 for details on 
how to do that), but it’s easier to use the 
Page Properties dialog.

To add a background 
image to your page:
1. Open the page to which you want to 

add the background image.

2. In the Property inspector, click the Page 
Properties button.

or

Choose Modify > Page Properties, or 
press Ctrl-J (Cmd-J).

The Page Properties dialog appears A.

3. In the Appearance (CSS) category of 
the dialog, click the Browse button next 
to “Background image.”

The Select Image Source dialog appears.

4. Navigate to and select the image you 
want to use as the background image, 
and then click OK (Choose).

A Use the Page Properties dialog to insert a 
background image.
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5. From the Repeat pop-up menu in the 
Page Properties dialog, choose how 
you want the image to be repeated on 
the page (if it is smaller than the page):

>	 no-repeat places the image on the 
page just once, in the upper-left cor-
ner of the page.

>	 repeat tiles the image across and 
down the page, filling the page.

>	 repeat-x tiles the image across the 
top of the page.

>	 repeat-y tiles the image down the left 
edge of the page.

6. To see how the image will appear on 
the page, click Apply.

The background image appears on the 
page B.

7. Click OK.

B The background image of our cat was repeated endlessly on this page by setting the Repeat 
field to “repeat.” Remember how we said that background images look dated and tacky if you’re not 
careful? This is what we meant.

Before CSS, designers set background 
images by adding a background attribute to 
the <body> tag. If you are asked to work on 
older sites, one of the renovations you should 
make is to remove this old attribute and 
replace it with a CSS rule.

Be careful when using tiled background 
images. As you can see from the figure that 
showcases our cat, it can make the page very 
hard to read.
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Adding a Favicon
One of the little touches that will finish up 
your Web site is the addition of a favicon, 
that little icon that appears in the address 
bar of a browser when your site loads A. 
A favicon is another way to underscore 
your site’s brand identification, and often 
represents the logo of the organization that 
runs the site. Favicons are only 16 by 16 
pixels large, and all modern Web browsers 
support them.

Before you can add a favicon to the index 
page of your site, you’ll need to create one. 
There are dedicated favicon editing pro-
grams available for purchase, but we prefer 
to use one of the free online tools that con-
vert graphic files into favicons, such as the 
ones at favicon.htmlkit.com/favicon/ or 
tools.dynamicdrive.com/favicon/.

Once you have your favicon file, which 
must be named favicon.ico (see the tip 
at the end of this section for more detail), 
you’ll add it to your site’s pages in Dream-
weaver. You’ll do that with the <link> tag, 
which, while more often used for linking 
CSS style sheets, works fine for this pur-
pose, too.

A Here are the favicons for four different sites, as 
seen in Mozilla Firefox.



ptg8274339

Including Images and Media 157

To add a favicon to your page:
1. Obtain your favicon.ico file, and move 

it into your local site folder.

Because it’s an image, it makes sense 
to us to put the favicon file into the 
images folder, but you can put it any-
where you want in the local site folder.

2. Open the page to which you want to 
add the link to the favicon.

3. Choose Insert > HTML > Head Tags > 
Link.

The Link dialog appears B.

4. In the Href text box, enter the path to 
the favicon.ico file.

or

Click the Browse button to open the 
Select File dialog. Navigate to the 
favicon.ico file and click OK (Choose).

5. In the Rel text box, type shortcut icon.

6. Click OK, and then save the page by 
choosing File > Save.

After you next synchronize your local 
site to the remote site, the favicon will 
show up when you load the page in a 
Web browser.

You must repeat the process of adding 
the link to the favicon on every page in your 
site. If your site uses templates, adding the 
link to a template file automatically adds it to 
all the pages based on that template. For more 
about using templates, see Chapter 16.

The favicon file should be named  
favicon.ico for the widest compatibility, though 
it isn’t strictly necessary with all browsers. 
As usual, Internet Explorer is the culprit. It 
requires the .ico format, while other browsers 
can use .gif, .png, or .jpg files, as shown in B.

B The Link dialog allows you to add the path to 
the favicon file.
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Adding Flash and 
Shockwave
Because Adobe is the maker of the Flash 
multimedia format, it should come as no 
surprise that Dreamweaver makes it easy to 
add many different varieties of Flash objects 
to your pages. The two kinds we’ll discuss 
here are Flash animations and Shockwave 
animations. A Flash animation is a Flash file 
that has been optimized for playback on the 
Web. This kind of file has the .swf extension. 
You can play this animation in Dreamweaver 
or in a Web browser. A Shockwave file is an 
animation format very similar to a Flash file, 
but it’s created by Adobe Director rather than 
Adobe Flash. A Flash file can be displayed 
by any Web browser that has the free Flash 
Player; Adobe claims that more than 98 per-
cent of Internet users have the Flash Player.

Files with the .fla extension are Flash docu-
ment files that can only be opened in the 
Flash program. These sorts of files can’t be 
played in Dreamweaver or Web browsers.

To insert a Flash or 
Shockwave animation:
1. Click to set the insertion point where 

you want the Flash or Shockwave ani-
mation to appear.

2. Choose Insert > Media > SWF, or press 
Ctrl-Alt-F (Cmd-Opt-F).

or

Choose Insert > Media > Shockwave.

The Select File dialog appears.

3. Navigate to the file you want, select it, 
and click OK (Choose).

The Object Tag Accessibility Attributes 
dialog appears A.

A Add alternate text for the Flash or Shockwave 
file in the Object Tag Accessibility Attributes dialog.
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4. Enter alternate text in the Title field of 
the dialog.

5. Click OK.

Dreamweaver inserts the animation file 
into your document as a placeholder.

The Access key and Tab index fields 
in the Object Tag Accessibility Attributes 
dialog are used with forms. See the “Labeling 
Your Fields” sidebar in Chapter 11 for more 
information.

To play the animation 
placeholder in Dreamweaver:
1. Select the placeholder.

Selection handles appear at the edges 
of the placeholder.

2. Click the Live View button at the top of 
the document window.

or

Click the Play button in the Property 
inspector B.

Dreamweaver plays the animation file in 
the document window.

Animation placeholder

Play button

B To preview your animation, use the Play button 
in the Property inspector or switch to Live view.
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Adding Flash Video
Flash video is a way of showing video on 
your Web site. Like other video formats, 
such as QuickTime, Windows Media, 
Silverlight, and RealVideo, Flash video 
can show full-motion video in context on 
your Web page. But one of the big advan-
tages of Flash video is that most browsers 
already have the Flash plug-in installed, 
so your video is likely to be viewable by 
more people.

Before you can put a Flash video file on 
your Web page, you must, of course, con-
vert your video to the Flash video format, 
which has the .flv extension. Adobe Flash 
Professional CS6 includes the Adobe 
Media Encoder, which can convert Quick-
Time, DV, MPEG, AVI, and Windows Media 
files into Flash video.

To insert a Flash video file:
1. Click to place the insertion point where 

you want the Flash video file to appear.

2. Choose Insert > Media > FLV.

or

In the Common category of the Insert 
panel, choose FLV from the Media pop-
up menu.

The Insert FLV dialog appears A.

3. From the Video type pop-up menu, 
choose either Progressive Download 
Video or Streaming Video.

You will most often choose Progressive 
Download Video, which downloads the 
Flash video file to the user’s hard disk 
and then plays it. The Streaming Video 
choice requires extra server-side soft-
ware (Adobe Flash Media Server).

A You get a preview of the different media 
controllers available to you for Flash video directly 
below the Skin pop-up menu.
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4. In the URL field, enter the path to the 
Flash video file. You could also click 
the Browse button, which brings up 
the Select File dialog and allows you to 
navigate to select the video file.

If the media file is not inside your site 
folder, Dreamweaver will, as usual, offer 
to copy it there for you.

5. From the Skin pop-up menu, choose 
the kind of video controller you want to 
appear with the video.

As you choose the skin, the dialog 
shows you a preview of what the video 
controls look like for that skin.

6. Enter the Width and Height (in pixels) 
that you want to use to display the video.

or

Click the Detect Size button, which 
attempts to read the Flash video file 
and figure out what size it is. Depend-
ing on your video, this option some-
times may not work, but it is always 
worth trying.

7. If you want the video to automatically 
begin playing when the Web page is 
loaded, select the Auto play check box.

8. If you want playback control to auto-
matically return to the starting position 
after the video finishes playing, select 
the Auto rewind check box.

9. Click OK.

A placeholder for the Flash video file 
appears on your page B. To play the 
Flash video file inside Dreamweaver, 
click the Live View button at the top of 
the document window.

B When you’ve set all the options in the 
Insert FLV dialog, a placeholder appears in the 
document window. When you preview the Flash 
video in Live view, you can see and hear the 
video playing.
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To edit a Flash video 
file’s properties:
1. Click to select the Flash video file.

2. In the Property inspector, make the 
changes you want C.

There are many variables involved in 
converting one kind of video file to another, 
and a complete discussion is way beyond the 
scope of this book. Instead, we suggest that 
you begin learning more about Flash video 
on the Adobe Web site at www.adobe.com/
devnet/video/.

Dreamweaver, when purchased as a 
stand-alone product, doesn’t come with Adobe 
Media Encoder. However, all the Creative Suite 
6 bundles that include Dreamweaver include 
Adobe Media Encoder.

C Adjust the settings for a Flash video file in the Property inspector.

www.adobe.com/devnet/video/
www.adobe.com/devnet/video/


ptg8274339

Including Images and Media 163

Adding QuickTime 
and Other Media
Video and audio files, with the excep-
tion of the various flavors of Flash media, 
are handled by Dreamweaver as plug-in 
media. That’s because these files need 
plug-in software to be installed in a Web 
browser to be played. The most common 
plug-in media are QuickTime, Windows 
Media, Silverlight, and MP3 audio files.

To add plug-in media files:
1. Click to place the insertion point where 

you want the media file to appear.

2. Choose Insert > Media > Plugin.

or

In the Common category of the Insert 
panel, choose Plugin from the Media 
pop-up menu.

The Select File dialog appears.

3. Navigate to and select the media file 
you want, and then click OK (Choose).

A placeholder for the plug-in file 
appears on your page A.

A Dreamweaver puts a placeholder for the 
plug-in media file in the document window.
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To preview your media file:
1. Select the placeholder for the media file.

2. In the Property inspector, click the Play 
button.

This may not work if Dreamweaver can’t 
find the appropriate plug-in on your 
system. In that case, save the page and 
preview the file in a Web browser B.

Dreamweaver creates the placeholder 
file as a small square icon on the page. When 
you preview the file, that icon will be replaced 
by the media file controller, which has the 
playback controls. The small size of the icon 
won’t allow you to use the media controller, so 
before you preview the file, click the place-
holder icon and use its selection handles to 
make it wide enough so that you can see the 
entire media controller.

For video files, use a video player pro-
gram, such as QuickTime Player or VLC, to 
get the dimensions of the video file, and enter 
those dimensions into the W and H fields in 
the Property inspector.

If you find that the video playback con-
trols are missing or cut off, increase the value 
in the H field. For example, I needed to add 20 
pixels to the H field to make the controller in 
B appear.

To edit a plug-in file’s properties:
1. Click to select the plug-in file.

2. In the Property inspector, make the 
changes you want C.

B You usually need to preview media that 
uses plug-ins, like this QuickTime movie, in a 
Web browser.

C You can adjust the settings for a plug-in media file in the Property inspector.
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Working with Links

Links are what make the Web, well, 
webby—the interconnections between 
pages and sites are a fundamental part of 
why the Web is different from print. Without 
links coming in to your site, no one will ever 
find it. And without links going out from your 
site, it’s a dead end. Dreamweaver makes it 
easy to add links to your site.

There are a number of different kinds of 
links: some links are internal to a page, 
some internal to a site, and some links go 
to another server altogether. This chapter 
will cover all of these, along with targets, 
image links, and email links.

In This Chapter
Creating Text Links 166

Changing Link Relative To 170

Formatting Links 172

Targeting Links 174

Adding Named Anchors 175

Adding Links to Graphics 178

Creating Image Maps 179

Adding Email Links 181
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Creating Text Links
If you can drag your mouse from here to 
there, you can create a link inside Dream-
weaver. All you have to do is decide what 
on the page you want to turn into the link, 
and where you want that link to point.

Because creating links is such a large part 
of developing a Web site, there are mul-
tiple ways to create links. You can figure 
out which method works best for you.

To create a text link:
1. Select some text on the page to be 

the link. A shows that the title  
“HomeCook.info” has been selected.

Point to File icon Browse for File icon

A Drag the Point to File icon, and the arrow will follow to the selected link file.
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2. In the HTML tab of the Property inspec-
tor, click the Point to File icon immedi-
ately to the right of the Link field. An 
arrow appears, and that arrow can be 
dragged into the Files panel. Drag it to 
the file you want, and release the mouse.

or

In the Property inspector, click the 
Browse for File icon, which looks like a 
folder, to the right of the Link field. The 
Select File dialog appears B. Choose 
the file you want and click OK (Choose).

or

In the Property inspector, click in the 
Link text field and type the name of 
the file you want to link to.

or

In the Property inspector, click the 
pop-up menu to the right of the Link 
text field, and choose from the list of 
recently used links C.

or

In the Common category of the Insert 
panel, click the Hyperlink button. The 
Hyperlink dialog appears D. Type 
the name of the file to link to, or click 
the Browse for File icon to select a file. 
Click OK when you’re done.

If you want to remove a link, click inside 
the text you want to de-link, click the <a> in 
the tag selector, and then clear the Link text 
field in the Property inspector.

B You can also select a link file from the Select 
File dialog.

C Or use this 
pop-up menu 
in the Property 
inspector.

D Finally, you can type the link filename in the 
Hyperlink dialog.



ptg8274339

168 Chapter 6

The Different Types of Links
When you create a link from one Web page to another, there are three possible types of links 
you can add: absolute, document relative, or site root relative. E shows the file list from  
www.homecook.info, a fairly typical site, with a number of files in various folders. F shows 
another way of looking at the same information.

. Absolute: The index.html file contains a link to  
http://www.dori.com/index.html, which is another site  
altogether. This is an absolute link. The link starts with the 
explicit name of a server where the file can be found. It’s also 
correct for the link to just go to either http://www.dori.com/
or http://www.dori.com; in both cases, the link takes you to 
the default file for that domain (in this case, index.html).

. Document relative: The index.html file also contains a  
link to the index.html file in the about folder. To tell the 
browser how to navigate from one to the other, the link is 
about/index.html. That link is relative to the document it’s 
being called from: the server knows, based on that link, that it 
needs to find a folder named about at the same level as the 
index.html file, and within that folder, a file named index.html.

If about/index.html linked back to index.html, it would 
link to ../index.html. Once again, the server starts look-
ing for the next file at the same level as the current file, and 
those two periods tell the server to go up a level—back to 
www.homecook.info. And from there, it’s easy to find the 
index.html file. A file two levels deep would link to the main 
index page by linking to ../../index.html. It goes up two 
levels of folders before looking for a particular file.

Document relative links are especially useful when you’re 
testing on your local machine—the browser can get from 
one page to another just based on the location of the 
current document.

E Here’s a list of folders 
and files (as seen in the Files 
panel) from a site of medium 
complexity.

www.homecook.info
http://www.dori.com/index.html
http://www.dori.com
http://www.dori.com/
www.homecook.info
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The Different Types of Links (continued)

. Site root relative: Another way to reference files within the same site is by referencing them by 
where they are within the site; that is, relative to the root of the site, not the current document. 
The root of the site is always identified with a forward slash: /. With a site root relative link, the 
page at /food/index.html would link to /index.html. You no longer need to tell the server 
to go up a level or two; instead, you just tell it to start at the root and look for that particular file.

Site root relative links are useful when you’re creating site-wide library items. For instance,  
the left navigation menu in the document shown in A contains links to /recipes/index.html and  
/food/index.html. With site root relative links, you know that those links work everywhere on 
the site, no matter what page contains that menu. Library items are covered in Chapter 16.

Links to external sites must be absolute links. Links within a site can use document relative links, 
site root relative links, or a combination of the two. The kind of link a site uses by default is set in 
Dreamweaver’s preferences (see “Changing Link Relative To”).

index.html

dori.com

homecook.info
site root

index.html

index.html
index.html

newsabout

index.html

index.html index.html

about/index.html
(document relative)

../index.html  
(document relative)

../food/index.html (document relative)
/food/index.html (site root relative)

food recipes

http://www.dori.com/index.html
(absolute)

F The about, news, food, and recipes folders (or directories) are all contained within the site root folder.

http://www.dori.com/index.html
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Changing Link 
Relative To
It’s awkwardly named, but it’s useful: you 
can change the Link Relative To (that is, 
whether the link is document relative or 
site root relative) for either a single file or 
for the site as a whole. As mentioned in the 
sidebar “The Different Types of Links,” your 
links can either be document relative or 
site root relative, or even a mix of the two 
on each page.

To change the “Link 
Relative To” for a link:
1. In the Property inspector, click the 

Browse for File icon. The Select File 
dialog appears A.

2. Near the bottom of the dialog is a  
pop-up menu labeled “Relative to.” 
From that pop-up, you can switch 
between Document and Site Root A, 
and the URL for the link will change.

3. Click OK to save your changes.

A Use the Select File dialog to make your link site 
root relative or document relative.
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To change the “Link 
Relative To” for a site:
1. In the Property inspector, click the 

Browse for File icon. The Select File 
dialog appears A.

2. Near the bottom of the dialog is a link 
that says “Change default Link Relative 
To in the site definition.” If you click the 
link (the part that’s blue and underlined), 
you’ll end up in the Advanced Settings 
category for the Site Setup for your site, 
with the Local Info category chosen B. 
From here, you can choose either radio 
button next to “Links relative to,” where 
the choices are Document or Site Root. 
This changes the link that you’re cur-
rently modifying, as well as the default 
for future links, but it will not change any 
other existing links on the page or site.

3. Click OK to save your changes.

You can also follow the directions found 
in Chapter 2 for editing the site setup. If you 
click the Advanced Settings category and then 
choose the Local Info category, you’ll end up 
in the same place.

B Or you can set the “Links relative to” for the 
entire site.



ptg8274339

172 Chapter 6

Formatting Links
One of the most common uses of CSS is 
to change the way links are displayed in 
the browser. Want your links to only be 
underlined when the cursor is over them? 
Want the background or text color to 
change when a visitor clicks? Or maybe 
you just want something other than your 
visitor’s default colors? That’s all CSS, and 
Dreamweaver can handle that. You’ll need 
to know if your site is going to use internal 
or external styles (see Chapter 7).

To format links:
1. Click the New CSS Rule button at the 

bottom of the CSS Styles panel. The 
New CSS Rule dialog appears.

2. If you want to set a style that will apply 
to all links (whatever their state) or to 
set the default appearance for links, 
in the Selector Type section, choose 
“Tag (redefines an HTML element)” for 
the Selector Type, and in the Selector 
Name section, choose a.

or

For the Selector Type, choose “Com-
pound (based on your selection),” and for 
Selector name, choose any option from 
the pop-up menu: a:link, a:visited, 
a:hover, or a:active A. Other CSS rules 
attached to your document can also 
appear in this pop-up menu.

>	 a:link is the default state of the link, 
seen when none of the other states 
are in use.

>	 a:visited is how the link will appear 
after the link has been clicked and 
the linked page loaded.

A The New CSS Rule dialog lets you choose 
which rule you’re going to define.

The Style of Links
How to style links has been an ongo-
ing controversy over the years: should 
a Web designer ever mess with a user’s 
defaults? Should links always be under-
lined? Should links always, sometimes, 
or never say “Click here”?

The answers, as with so much about 
Web design, depend on who’s visit-
ing your site. If you have a traditional 
e-commerce site geared toward average 
surfers, you’ll probably want to make 
things as simple and straightforward as 
possible. If you have a cutting-edge art 
gallery site that attracts people used to 
fashion-forward sites, you can be a little 
more daring. If you aren’t sure which way 
to go, figure out what sites attract visitors 
like yours, and style your links similarly.

There’s one rule that’s always true: be 
consistent across your site. No one 
should ever have to learn a new naviga-
tion style on every page.
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>	 a:hover is how the link will appear 
while the visitor’s cursor is over the link.

>	 a:active is how the link will appear 
while the visitor is clicking that par-
ticular link.

3. For Rule Definition, there are at least 
two options: (New Style Sheet File) 
or (This document only). If the current 
document links to any style sheets, 
their names are included in the pop-up 
menu. Choose whichever is appropriate 
for this site, and click OK.

4. If you chose to create a new style 
sheet, you’ll see the Save Style Sheet 
File As dialog B. Choose where to 
save it and what to name it, and click 
Save. The CSS Rule Definition dialog 
appears C. You can create the specific 
rules you want for links either here or 
directly in the CSS Styles panel D.

It is important to set styles for your links; 
otherwise, they are likely to display underlined 
and blue (unvisited) and purple (visited)—but 
you can’t be sure of that. To control the look of 
your page, set the link styles.

D shows some of the most common 
rules for CSS-formatted links: bold font weight, 
and no underline except when the cursor is 
over the link.

B When you want a new style sheet, you can 
create that file here.

C After you create the rule, define its values here.

D The CSS 
Styles panel, 
after various 
a rules have 
been defined. 
New properties 
can be set from 
here, also.



ptg8274339

174 Chapter 6

Targeting Links
Sometimes you want a link to go to a new 
window or to an existing window other than 
the one you’re clicking. That’s done by giving 
the link a target—the name of the window in 
which you want the new page to load.

To give a link a target:
1. Follow the earlier steps to create a link, 

and then click the <a> in the tag selector.

2. Directly next to Link in the Property 
inspector is a text field named Target 
where the target is entered. Alterna-
tively, you can click the pop-up menu to 
the right of the field to choose the target.

3. If you’re working on a site without 
frames, you have five choices: _blank,  
_new, _parent, _self, and _top (sites with 
frames are different and are covered in 
the bonus chapter on frames). Choose 
one from the pop-up menu A, and the 
Target field will show your choice.

>	 _blank: Open a new, blank window.

>	 _new: Acts like _blank the first time 
it’s used, but after that, each time a 
link using the _new target is clicked, 
it will reuse the same “new” window. 
We think that _new is confusing, and 
we don’t recommend using it.

>	 _parent: If the current window was 
opened by a previous link to a blank 
target (that is, the current window is a 
newly opened window), open this link 
in the previous window. If the cur-
rent window wasn’t opened that way, 
what happens depends on the user’s 
browser—but usually, it just opens in 
the current window.

>	 _self and _top: For non-framed 
sites, these are both equivalent to not 
using any target at all.

A Set a link’s target in the Property inspector with 
this pop-up menu.

To remove a target, just click in the 
Target text field in the Property inspector and 
erase its content.

The underscore before the name of a 
target tells the browser that this is a special 
type of target, not just the name of another 
window. You’ll learn about named windows 
in the bonus chapter “Adding Frames”  
(at the end of the ebook edition or online at 
www.dreamweaverbook.com).

www.dreamweaverbook.com
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Adding Named 
Anchors
Normally, when a new Web page is dis-
played, it does so showing the very top of a 
page. Adding an anchor to a link allows you 
to display the page starting at a given point 
on a page. To use an anchor, you’ll need to 
create at least two things: the anchor itself 
and then the link to that anchor.

To create an anchor:
1. Open your document, and click in the 

spot in the file where you want the 
named anchor to be.

2. In the Common category of the Insert 
panel, click the Named Anchor but-
ton, and the Named Anchor dialog 
appears A.

3. Choose a name for the anchor that will 
be unique for this page. Remember that 
this anchor is going to be part of a URL, 
so it can contain only characters that 
are valid: no spaces, ampersands, ques-
tion marks, and so on.

continues on next page

A The Named Anchor dialog lets you create a 
new anchor on your page.
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4. Click OK. In the spot where you cre-
ated the new anchor, an anchor icon 
appears B. If you click that anchor, the 
tag selector will show the anchor with 
its name, and the Property inspector will 
allow you to modify the name C.

Although you do see that anchor on 
the page in Dreamweaver, it won’t be there 
when you or anyone else views the page in a 
browser—it’s just there for your editing conve-
nience, and it’s one of the few ways in which 
Dreamweaver isn’t 100 percent WYSIWYG. 
Hate seeing them? From the menu bar, choose 
View > Visual Aids > Invisible Elements to 
toggle the visibility of these icons on or off.

There are many ways to delete a named 
anchor. One way is to click to select the 
anchor icon and delete it. Or, in the Property 
inspector, clear the NamedAnchor Name field. 
Or, of course, you can do it in Code view.

B The part of the page shown here, part 
of the world’s most boring blog, has two 
anchors: the selected one is blue, and the 
unselected one is yellow.

C The Property inspector for a named anchor.
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To link to an anchor on 
the same page:
Follow the directions from “Creating Text 
Links” earlier in this chapter, but drag the 
Point to File icon to the Named Anchor 
icon on the page. The selected text is now 
linked to the new anchor.

It’s possible that the Point to File icon 
and the Point to File arrow can end up going 
to different spots on the page. The one that 
matters, in this case, is the icon itself, not the 
tip of the arrow.

To link to an anchor on 
another page:
If you’re using Dreamweaver’s tabbed 
interface, you won’t be able to see the link 
source and the destination at the same 
time, so you’ll have to add the anchor part 
of the link manually. Follow the directions 
from “Creating Text Links” earlier in this 
chapter to link to another file, and when 
that’s complete, click in the Link field in the 
Property inspector and add a # followed by 
the anchor name to the end of the existing 
link. So if you want to link to the chap07
anchor on the dwvqs.html page, your link 
would be to dwvqs.html#chap07.

or

If the two files are open in different win-
dows, arrange the windows so you can see 
both the link source and the link destina-
tion. Then, follow the directions for linking 
to an anchor on the same page, but drag 
the Point to File icon to the anchor on the 
other page.
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Adding Links 
to Graphics
Making a graphic a link isn’t all that dif-
ferent from creating a text link. The main 
difference is that the Link and Target fields 
in the Property inspector are in different 
areas, so you might not see them at first 
glance. Additionally, you don’t get the 
handy pop-up menu on the Link field, so 
you can’t just reuse one of the links you’ve 
recently made.

To add a link to a graphic:
1. Select the image in the document 

window.

2. Using the Property inspector A, click 
the Point to File icon next to the Link 
field. An arrow appears, and that arrow 
can be dragged into the Files panel. 
Drag it to the file you want, and release 
the mouse.

or

Click the Browse for File button next 
to the Link field; then in the result-
ing Select File dialog, navigate to and 
select the file you want as the link’s 
destination, and click OK (Choose).

A For images, the Link and Target fields aren’t where you might expect them to be in the 
Property inspector.

As mentioned in “Creating Text Links,” 
there are many ways to create links. Over 
time, you’ll find the one that works best for 
you.

It’s very common that images in the 
upper-left corner of a Web page (usually the 
site’s logo) link back to a site’s home page; 
common enough that if you don’t do this, your 
site’s visitors may be confused. Unless there’s 
a good reason why you shouldn’t do this for a 
site, set this up as the default.

You can make individual parts of an 
image link to different Web pages. That’s done 
with image maps, and they are covered in the 
next section.
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Creating Image Maps
It’s easy to add a link to an image: just 
select the image, and use the Link text 
box in the Property inspector to define the 
link’s destination. But what if you want dif-
ferent parts of an image to link to different 
pages? You’ll need an image map. With 
an image map, you can define areas of the 
image as hotspots, and each hotspot has 
its own link.

To create an image map:
1. Select the image you want to turn into 

an image map.

In this example, we’re using a map of 
Washington, Oregon, California, and 
Nevada A. We’ll add hotspots to each 
of the states.

2. In the Map text box of the Property 
inspector, enter a name for the image 
map B.

The name cannot begin with a number 
and can contain only letters, numbers, 
and the underscore character.

continues on next page

A We’ll turn this map of four Western states into 
an image map.

B Both the image and 
the image map have been 
named in this figure.

Polygon

Circle

Rectangle

Selection
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3. Use the Rectangle, Circle, or Polygon 
tool to draw a hotspot over part of 
your image.

The tool you use depends on the shape 
of the area that you want to make into 
a hotspot. For example, we used the 
Rectangle tool to create the hotspots 
for Washington and Oregon, and the 
Polygon tool to create the hotspots for 
California and Nevada.

Dreamweaver shows the hotspot 
as a light blue area overlaid on your 
image C. The blue highlighting won’t 
show up on your Web pages.

4. When a hotspot is selected, the Prop-
erty inspector shows properties for the 
hotspot D. Use the Link field to attach 
a link to the hotspot.

5. (Optional) Use the Target pop-up menu 
to target the destination of the link.

If you need more information about the 
use of the Target control, see “Targeting 
Links,” earlier in this chapter.

6. Enter the alternate text for the hotspot 
in the Alt field.

7. Repeat steps 3–6 for each of the other 
areas on the image you want to turn 
into hotspots.

To change the properties of a hotspot, 
use the hotspot Selection tool to select the 
hotspot; then make changes in the Property 
inspector.

You can resize and reshape hotspots; 
just select the hotspot with the hotspot Selec-
tion tool, and then click and drag one of the 
selection handles that appear at the corners of 
the hotspot.

C Each of the state 
images has been 
overlaid with a 
hotspot.

D Add the link for a hotspot in the Property 
inspector.

Image maps have somewhat fallen out 
of favor recently; you see more sites using 
interactive Flash movies to provide users the 
benefits of clickable images. But they are still 
perfectly usable and valid ways to make parts 
of images clickable, and they work on some 
browsers that don’t support Flash, such as 
the Safari browser on the iPhone, iPod touch, 
and iPad. Even if your sites use Flash, you can 
use image maps as a fallback plan, serving a 
version of the page that uses image maps for 
browsers that aren’t Flash-capable.
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Adding Email Links
If you want your site’s visitors to be able to 
contact you, you’ll need to add a link that 
allows people to send you email.

To add an email link:
1. Click the spot on the page where you 

want to add an email link.

2. In the Common category of the Insert 
panel, click the Email Link button, and 
the Email Link dialog appears A.

3. Fill in the Text field with the text you 
want to display in the Web browser, 
and fill in the Email field with the email 
address. Click OK when you’re done.

Dreamweaver doesn’t do any kind of 
error checking to make sure that the email 
address is in a valid format, so be careful when 
you’re entering it.

Putting an email address on a Web site 
can lead to that address getting all kinds 
of garbage or spam. There are a variety of 
ways to help protect your email address. The 
simplest is just to encode—put it into a format 
that the browser can understand but that a 
spider sent out by a spammer can’t. To learn 
more about this, search on Google for “email” 
+ “obfuscator.” This approach works with some 
spambots that harvest email links from Web 
pages, but certainly not all.

A The Email Link dialog lets you set the link (the 
email address) and the text that will be displayed 
on the Web page.
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Styling Page 

Content
You want your Web site to look inviting, 
colorful, and organized, right? You need 
style! With styles, your site doesn’t just 
look good—you get other benefits as well. 
Compared to older font-tag-based styling, 
your site is easier to maintain and update, it 
downloads faster and uses less bandwidth, 
and it’s more accessible to every type of 
browser. In this chapter you’ll get a basic 
understanding of Cascading Style Sheets, 
better known as CSS. Then we’ll get into the 
details of how to use Dreamweaver’s CSS 
Styles panel and CSS Rule definition dialog 
to create and apply styles to your pages.
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Understanding CSS 184

Creating a Style Rule for a Tag 188

Dreamweaver CSS Categories 190

Creating a Custom Class 
193

Creating Compound Selectors 195
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Understanding CSS
Cascading Style Sheets are all about style, 
looks, and presentation. CSS properties 
and rules give you an amazing array of 
control over foregrounds, backgrounds, 
colors, fonts, positions, alignments, mar-
gins, borders, lists, and other aspects of 
presentation.

Dreamweaver organizes the CSS proper-
ties it supports (which is most of them) via a 
couple of manageable interfaces: the CSS 
Rule definition dialog and the CSS Styles 
panel. With these two features, you can 
control every style aspect of every element 
on your page. From your document’s body 
to its paragraphs, lists, tables, and links, to 
styling individual words or even individual 
letters, it’s all handled with the CSS Styles 
panel or the CSS Rule definition dialog.

Content vs. presentation
Content is king, the saying goes, because 
users seek content when they come to 
your site. Content is the actual information 
in the headings, paragraphs, lists, divs, 
tables, forms, images, blockquotes, links, 
and other HTML elements you use on a 
page. With no styling, content looks some-
thing like an outline A.

The unstyled content should be useful 
and informative, even if it doesn’t look like 
much. That’s because some of your visitors 
get only the text content—for instance, 
those with screen readers, some mobile 
browsers, or text-only browsers. Some of 
these also get images, but not all, so make 
sure your pages are understandable and 
navigable even without graphics.

A A page with no styles shows content and 
working links, even though it isn’t beautifully 
arranged.

B Add styles to the same page to determine rules 
for layout, background, fonts, margins, and other 
presentation features.
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Some tags are containers; that is, they can 
contain content, other tags, or both. Other 
tags are empty elements; for instance, the 
<img> tag, used for graphical elements, 
cannot also contain text.

Containers have beginning and ending 
tags. For instance, each paragraph inside 
your documents should be inside a <p>
tag, where <p> stands for paragraph. To put 
some text into a paragraph tag, all you (or 
more often, Dreamweaver) have to do is 
add a <p> before the text and a </p> after 
(that forward slash is what tells the browser 
that it’s at the end of the paragraph). 
Makes sense so far?

Next, to apply a style to that paragraph, 
you apply it to that <p> tag. You’re not 
taking anything out of the paragraph or 
adding anything to the paragraph. It’s still 
a paragraph; but with CSS, you have some 
say about how that paragraph appears. 
Each style has instructions that define the 
style and what it does, and these instruc-
tions are called rules.

You can learn just enough about HTML 
tags by looking at the tag selector of your 
Dreamweaver document. If you find you 
want to know even more, check out Chap-
ter 17, “Editing Code.”

Once you add presentation rules, you 
have the layout, color scheme, font choice, 
background, and other “pretties” that 
make a Web page look good in a stan-
dard browser B. The content itself hasn’t 
changed. What has changed is the way the 
content is presented on the page. Change 
the presentation—that is, use different 
styles—and the same content completely 
changes its appearance.

The power of CSS derives from the sepa-
ration of content from presentation. You 
can make the content look like anything 
you want simply by changing the way it is 
styled and presented.

Working with tags
HTML consists of tags, and adding tags to 
your document turns it into something that 
a computer knows how to handle. A tag is 
simply a name inside angle brackets, and 
every browser has certain names (that is, 
tags) that it understands.

Now, when you look through this chap-
ter, you might be thinking to yourself at 
first, “Hey, I bought a WYSIWYG tool so I 
wouldn’t have to learn about HTML tags!” 
That’s understandable—but you’ll need to 
learn at least the basics about HTML tags 
to take full advantage of CSS.
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Setting CSS Preferences
When you’re first learning CSS, set your preferences so that Dreamweaver gives you the 
maximum help.

In the CSS Styles category A, setting the styles to use shorthand is optional. Shorthand omits 
default values, which saves on bandwidth when downloading style sheets, but it can be confusing 
to a novice. To make things easier while you’re learning, don’t enable shorthand.

For the “When double-clicking in CSS panel” preference, select “Edit using CSS dialog” while 
you’re still learning about styles. If you find you prefer to edit using the Properties pane in the CSS 
Styles panel, you can change it later.

A The CSS Styles preferences should be set based on how you like to work.
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Anatomy of the CSS Styles Panel
If you’re new to Dreamweaver, start off by taking a long look at the CSS Styles panel—it will 
become a good friend.

B shows the CSS Styles panel in All mode, with the All Rules and Properties panes displayed. 
The Properties pane is in Category view.

C shows the CSS Styles panel in Current mode, with the Summary, Rules, and Properties panes 
displayed. The Properties pane is in Set view.

All mode 
button 

(selected)

All Rules 
pane

Properties 
pane

Category 
view 

(selected) List view Set view

B The CSS Styles panel in All mode 
shows the All Rules and Properties panes.

Current 
mode 
button 
(selected)

Summary 
pane

Rules 
pane

Properties 
pane

Show 
information

Show 
cascade 
(selected)

Set view (selected)

Attach style sheet

New CSS rule

Delete rule

Disable rule

Edit rule

C The CSS Styles panel in Current mode. The 
Summary, Rules, and Properties panes are visible.
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Creating a Style 
Rule for a Tag
Everything you do to create new styles, 
apply styles, and edit styles starts with 
creating a rule. Style rules begin with a 
selector. A selector can be a tag, an id, 
or a class.

To create a style rule for a tag:
1. With a page open in Dreamweaver, click 

the New CSS Rule button in the CSS 
Styles panel. The New CSS Rule dialog 
appears A.

2. Complete the following:

>	 Selector Type: Choose Tag (redefines 
an HTML element).

>	 Selector Name: Dreamweaver makes 
its best guess (based on your current  
selection or cursor placement when 
you clicked the New CSS Rule button) 
as to what tag you want this style 
to apply to. That tag automatically 
appears in the Selector Name field. 
If that tag isn’t the one you want, 
choose the correct tag using the pop-
up menu B.

>	 Rule Definition: Select “This docu-
ment only” to add the style to just the 
document you have open. We’ll cover 
the other options available here later.

3. Click OK, and the CSS Rule definition 
dialog appears C.

4. Set properties in the nine categories as 
desired. Which category contains which 
field is covered in “Dreamweaver CSS 
Categories,” next. If you want to see 
how something looks without dismiss-
ing the dialog, click Apply.

5. Click OK, and the new rule takes effect.

A If you select a tag in the document, it may 
automatically appear in the Selector Name field 
in the New CSS Rule dialog.

B Any tag can be styled—just select the one 
you want.

C The Type category is where you set font rules, 
including your choice of foreground (text) colors.
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This example creates an internal style: 
one where the style information is included 
inside the Web page. Internal styles are useful 
for testing, but in the long run, you’ll want to 
make all your styles external—that is, in their 
own file. We’ll cover that in Chapter 9, “Man-
aging Styles.”

New rules can also be created by select-
ing text in the document window and choosing 
Format > CSS Styles > New.

There’s a lot more to the New CSS Rule 
dialog, but don’t fret—we’ll cover its other 
options later in this chapter.

Not familiar with class and id? What 
you need to know is covered in the sidebar 
“Choosing Between Classes and IDs,” later in 
this chapter.

Choosing Between Divs and Spans
Divs and spans are generic containers. A div, short for division, holds a section of a page that 
you use and style as a block. Use divs to organize content into meaningful containers. You might 
structure your page with a div for the masthead, a div for the navigation, a div for the content, 
and a div for the footer. Positioning divs creates your layout. Blocks of content can then be nested 
inside other divs. In D, for example, the highlighted div #maincontent is inside another div, 
which is itself inside the body tag.

The span element is for inline use. A span can, for example, enclose a letter, word, or phrase. 
For example, the word “span” in the previous sentence is in a different font; if this were a Web 
page, we would achieve that effect by wrapping “span” in a span and then applying a style to 
just that element. With a style rule applied to the span, you achieve a distinctive presentation for 
an inline element.

Tag selector

D You can nest, position, and 
style divs individually. The tag 
selector indicates a named 
div with a # symbol, such as 
<div#mainContent>.

Selected div
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Dreamweaver 
CSS Categories
Dreamweaver uses the CSS Rule Defini-
tion dialog to break down CSS into various 
categories. Below, you’ll find each of 
the categories in the CSS Rule definition 
dialog, along with what you can find in that 
category. Each item in the dialog is named 
according to its CSS property value.

Type A
n	 Font-family

n	 Font-size

n	 Font-style

n	 Line-height

n	 Text-decoration

n	 Font-weight

n	 Font-variant

n	 Text-transform

n	 Color

Background B
n	 Background-color

n	 Background-image

n	 Background-repeat

n	 Background-attachment

n	 Background-position (X)

n	 Background-position (Y)

Block C
n	 Word-spacing

n	 Letter-spacing

n	 Vertical-align

n	 Text-align

n	 Text-indent

n	 White-space

n	 Display

A In the Type category, you can set the most 
common styling properties to text.

B Always give a page a background color, even if 
you’re using a background image.

C Set rules for spacing and alignment of text in 
the Block category. Text indent affects the first line 
only—yes, you can have old-fashioned paragraph 
indentation with CSS!
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Box D
n	 Width

n	 Height

n	 Float

n	 Clear

n	 Padding (Same for all, Top, Right,  
Bottom, Left)

n	 Margin (Same for all, Top, Right,  
Bottom, Left)

Border E
n	 Style (Same for all, Top, Right,  

Bottom, Left)

n	 Width (Same for all, Top, Right,  
Bottom, Left)

n	 Color (Same for all, Top, Right,  
Bottom, Left)

List F
n	 List-style-type

n	 List-style-image

n	 List-style-Position

continues on next page

D Set rules for width and height in the 
Box category. Margin and padding are both 
transparent, which means that a background 
shows through either.

E Set rules for borders in the Border category. 
Deselect “Same for all” to style borders individually.

F Set rules for list type and position in the 
List category. If you want an image instead of a 
standard bullet, specify it here.
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Positioning G
n	 Position

n	 Width

n	 Height

n	 Visibility

n	 Z-Index

n	 Overflow

n	 Placement (Top, Right, Bottom, Left)

n	 Clip (Top, Right, Bottom, Left)

Extensions H
n	 Page-break-before

n	 Page-break-after

n	 Cursor visual effect

n	 Filter visual effect

Transition I
n	 All animatable properties

n	 Duration

n	 Delay

n	 Timing function

Page break properties are used in style 
sheets for print.

The nine categories of style definitions 
in the CSS Rule definition dialog cover nearly 
every CSS property available. What’s impres-
sive is that you can apply any of the properties 
in any of the nine categories to virtually any 
element in your document. Backgrounds, for 
example, can be applied not just to the body
element, but also to the tags div, table, 
blockquote, span, acronym, quote, form, 
and many others.

G Set position in the Positioning category. The 
Z-Index option refers to the stacking order when 
more than one layer occupies the same position. 
Clip refers to material that might overflow the size 
set for width and height.

H Set extensions in the Extensions category. 
Internet Explorer is the only browser that supports 
the Filter extensions.

I Set transitions in the Transition category. If you 
deselect “All animatable properties,” you’ll see that 
you can set unique transitions for almost every 
CSS property.
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Creating a 
Custom Class
Redefining the style for a tag gives you 
considerable control, because HTML has a 
tag for nearly any type of text you need to 
format. And yet, there are times when you 
want to create a style rule for something 
that doesn’t already have a logical tag as 
a label. You can do that with a class. And 
you get to create a custom name for the 
style when you create a class.

To create a class:
1. With a page open in Dreamweaver, click 

the New CSS Rule button in the CSS 
Styles panel. The New CSS Rule dialog 
appears A.

2. Set the Selector Type option to Class 
(can apply to any HTML element), and 
set the Selector Name option to a name 
of your own choosing, preceded by a 
period (.). This is your new class name.

3. Click OK, and the CSS Rule definition 
dialog appears.

4. When you’ve completed filling out the 
CSS Rule definition dialog, click OK to 
accept your changes.

Pick a class name that will serve you 
over time. A name that describes a purpose 
rather than a particular property works best. 
For example, if you wanted to highlight certain 
vocabulary words in red, you could name a 
class either .red or .vocab. If you redesign 
the site later and change the color scheme, 
the name .red might not make sense any lon-
ger, but .vocab would still have meaning.

A A class selector name is preceded by a period 
when creating a new style.

Don’t create a class to describe text 
when there is already a logical tag that does 
the job. For example, don’t create a class to 
make text big and bold and use it as a head-
ing. HTML already provides six heading tags 
(h1, h2, h3, h4, h5, and h6). Simply redefine 
one of the existing heading tags to suit your 
purpose. Remember, you want to use HTML to 
create a logical structure for your content, and 
CSS to style the structured content.
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Choosing Between Classes and IDs
You can identify any particular element on a page by assigning it a name. Named elements can then 
be targeted with CSS rules. The two attributes used to assign names in CSS are classes and ids.

A class is reusable. A single class can be assigned to many 
different elements on a page. For example, your blog might 
have a class called blogentry applied to every blog entry. 
Or there might be several vocabulary words on a page that 
use a common vocab class.

An id, on the other hand, can only be used once per page. 
Since each id is unique, it can be used for all sorts of tasks in 
addition to CSS rules, such as link destinations and JavaScript. 
When working with CSS, it’s also useful for a div to have an 
id, because it enables you to write rules for that specific block 
of content with regard to its position, background, margins, 
and other properties.

In the CSS Styles panel, you see the name of each id and 
class style rule you add to your style sheet B. In the style 
sheet, a hash or pound sign (#) precedes an id selector. A 
period (.) precedes a class selector.

B This complete style sheet 
contains ids (#container, 
#sidebar), restyled tags (body, h1), 
classes (.floatRight, .photo), 
and pseudo-class selectors 
(tr:first-child).
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Creating Compound 
Selectors
Elements in HTML can nest. Inside the 
body might be a div named content, with 
a div named newitem nested inside that. 
Each of these nested elements exists in a 
parent-child relationship that allows CSS 
properties to be inherited. The child ele-
ments are descendants of the parent ele-
ments and inherit properties from them.

You can create extremely selective selec-
tors with descendant elements. Take the 
lowly list item, or li. If you redefine the 
default li style, you style every list item any-
where in the body of your page. However, 
if you have a div named content and list 
items using li within that, you can create a 
rule using the selector #content li. Instead 
of styling every li in the document, it will 
only style each li that is inside content.

Dreamweaver calls contextual selectors 
like this compound. There’s more about 
compound selectors in the “Compound 
Terminology” sidebar, later in this chapter.

To create a compound style:
1. With a page open in Dreamweaver, click 

the New CSS Rule button in the CSS 
Styles panel. The New CSS Rule dialog 
appears A.

continues on next page

A The New CSS Rule dialog lets you choose a 
type, name, and definition for your new rule.
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2. Set Selector Type to Compound (based 
on your selection). For Selector Name, 
one of the pseudo-class selectors may 
appear in the dialog by default. Select a 
pseudo-class selector from the pop-up 
menu or type a selector of your own 
choosing in this field by doing one of 
the following:

Type a pound sign (#) and an id to style 
a named section of the page—usually 
a div B.

or

Type a pound sign (#), the id, and a 
space before the pseudo-class selector 
to style only those navigation links in a 
particular named section of the page C.

or

Type a pound sign (#), the id, a space, 
and an HTML tag to style an element 
found only in the named section of the 
page D.

or

Type a group of selectors, each 
separated by a comma and a space, 
to assign the same style properties 
to every selector in the group with a 
single rule E.

If possible, Dreamweaver will parse 
your selectors and give you an explana-
tion of them in the dialog (B and D).

3. Click OK, and the CSS Rule definition 
dialog appears.

4. When you’ve completed filling out the 
CSS Rule definition dialog, click OK to 
accept your changes.

B A selector based on an id must begin with a 
pound sign (#).

C Type in the Selector Name field to create 
selectors that fit your document.

D A contextual or compound selector lets rules 
apply only to tags within certain named divs.
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Rules for link pseudo-classes won’t 
work reliably with the cascade unless you 
define them in the following order: a:link, 
a:visited, a:hover, a:active. A way to 
remember the L-V-H-A order is the memory 
device LoVeHAte.

If you use the Insert Div Tag button in the 
Insert panel (found in both the Common and 
Layout categories) to insert a div, Dream-
weaver offers you the chance to create a style 
for the div immediately F. Click the New 
CSS Rule button in the Insert Div Tag dialog to 
define properties for the new div.

Compound Terminology
Compound selectors are extremely powerful, and they have a specific vocabulary that 
describes them.

Pseudo-classes are so named because pseudo-states don’t actually exist in the document. The 
user must do something to create the pseudo-class, such as visit a link, hover over a link, or even 
hover over a visited link.

Comma-separated lists of selectors (p, td, li) are called group selectors.

Selectors such as #nav li or #content p are known as contextual, compound, or descendant
selectors. These selectors are the workhorses of CSS because they allow you to write specific 
rules based on the element in context (or the element from which it descends). For instance, the 
selector #content p styles only the p elements in #content, and #footer p styles only the p ele-
ments in #footer. So while you may have paragraphs in your content area and paragraphs in your 
footer area, there is no reason why they have to share the same presentation rules.

E Every tag in this group list of selectors will 
follow the same style rule.

F Dreamweaver politely suggests that you create 
a new rule for a new div as soon as you insert it in 
your document.
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Working with the 
CSS Styles Panel
The CSS Styles panel (Window > CSS 
Styles) shows all the styles affecting a 
document or a selected style. You can 
apply, modify, delete, and do other style-
related tasks right in the CSS Styles panel 
without having to open the CSS Rule defi-
nition dialog. If you need an overview of 
what’s where in the panel, look back at the 
“Anatomy of the CSS Styles Panel” sidebar, 
earlier in this chapter.

To work in All mode:
1. In your document, click All at the top of 

the CSS Styles panel A. All the styles 
affecting the document appear: any 
linked or imported external style sheets 
as well as any styles only in the open 
document. An external style sheet is 
indicated by a filename—for example, 
pagestyles.css. Styles internal to this 
document are in the <style> category.

Click the plus (+) (Windows) or the 
disclosure triangle (Mac) to expand a 
category if it isn’t already expanded.

A When 
you’re in All 
mode in the 
CSS Styles 
panel, any 
external 
style sheets 
are listed 
by filename, 
whereas 
internal styles 
are shown in 
<style>.

B Expand 
a style sheet 
name to see all 
the style rules. 
The Category 
view of the 
Properties 
pane shows 
categories, 
which must 
be expanded 
to examine 
properties.
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2. Examine the rules for individual styles 
by highlighting a specific style and 
doing one of the following:

Click the “Show category view” icon at 
the lower left of the CSS Styles panel. 
Properties for the selector appear in 
categories in the Properties pane at 
the bottom B. Click the plus (+) or the 
disclosure triangle (Mac) to expand 
any category.

or

Click the “Show list view” icon at the 
lower left of the CSS Styles panel. Prop-
erties for the selector appear as a list in 
the Properties pane at the bottom C.

or

Click the “Show only set properties” 
icon at the lower left of the CSS Styles 
panel. Set properties for the selector 
appear in the Properties pane D.

continues on next page

C Pick a specific style from the 
list, and its properties are shown 
in the Properties pane. In List 
view, the Properties pane shows 
a list of all the properties for a 
selected style.

D In Set view, the Properties 
pane eliminates everything 
except the set properties for the 
selected style.
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3. To add a new property directly in the 
CSS Styles panel, click the icon for 
“Show only set properties” and then 
click Add Property. An editable field 
appears with a pop-up menu listing 
every possible property E.

4. To modify a property, click the property 
value. An editable field appears F. Type 
any change and press Enter (Return).

To work in Current mode:
1. In your document, do one of the 

following:

Place the cursor in an element in the 
document window.

or

Select an element using the tag selec-
tor at the lower left of the document 
window G. E To set a new property while in 

the Properties pane, choose from 
the list.

Tag selector

G Elements you want to style 
can be selected in the document 
window with the tag selector.

F Any property value is editable 
in the Properties pane.
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2. Click Current at the top of the CSS 
Styles panel H. The Summary for 
Selection pane appears.

3. In the middle pane, you can choose 
whether to show information about the 
selected property (About, H) or show 
the cascade of rules for the selected 
tag (Rules, I). Click a property high-
lighted in the Summary for Selection 
list, and then choose either the About 
or Rules button on the right.

At the bottom, the Properties list shows 
the properties and their values.

4. If properties for the selected element 
were overridden by rules for other 
selectors, Dreamweaver indicates this 
with a strike through of the property 
name J. Use the mouse to hover over 
the property showing a strikethrough, 
and a pop-up appears explaining why 
this property is not applied.

Verify how styles are implemented on 
your pages by previewing them in a variety of 
browsers, as well as in Dreamweaver’s Live 
view. More than one style rule can affect a 
particular page element. Sometimes the style 
rules conflict and you get unexpected results.

When things don’t look as expected in 
the browser, troubleshoot style rules by using 
Current mode in the CSS Styles panel. The 
Properties pane provides valuable help to spot 
style conflicts.

Inheritance information in the About 
pane of the CSS Styles panel in Current mode 
is also useful when troubleshooting conflicting 
style rules.

H Current mode 
focuses on only 
the currently 
selected style.

I You can see 
information 
about the 
selected 
property or 
see the cascade 
of rules that 
apply to the 
selected tag.

J In Current 
mode, you can 
see inherited 
styles affecting 
a selector. 
The style is 
shown with a 
strikethrough if 
it doesn’t apply 
to the current 
selection.
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External, Internal, and Inline: Look Ma, It’s the Cascade
Styles can be external, internal, or inline. An external style resides in a separate style sheet file, 
one with a name that usually ends in .css. An internal style lives inside each Web page that needs 
it and is located within style tags inside the document’s head. And inline styles live within the 
HTML tags and only apply to whatever’s inside that tag.

Style rules cascade. This means that although multiple styles can cover a particular element, there 
are rules to determine which style takes precedence. The order of the cascade is first external, 
then internal (meaning in the document head), and then inline. When style rules conflict, the laws 
of the cascade determine how the conflict is settled.

In general, the closer a rule is to the element being styled, the more power the rule has in the bat-
tle of conflicting style rules. The whole idea is a lot easier to understand with a specific example.

Let’s look at the selector p. Suppose in your external style sheet you redefined p to be black, Arial, 
and 100% in size. Every p element in your document will be black, Arial, and 100%. No conflict there.

Into your conflict-free life comes a need to have just one document that uses your attached exter-
nal style sheet to display paragraphs that are black, Arial, and 90% in size. You know how to create 
a style for just one document, and you write an internal style making the p 90%. Now you have a 
conflict. Is a p element going to follow the rule in the external style or the rule in the internal style? 
The cascade goes from external to internal, so the internal rule is closer and has the power to over-
rule the external rule in this conflict. Conflict solved. Any p element in this one document will be 
90% in size.

But you want one paragraph to be red, not black. So you write a class rule and apply it inline to 
the paragraph. Now you have an inline style and a new conflict. The cascade goes from external 
to internal to inline, so the inline style has the power to overrule both the external rule and the 
internal rule. Conflict solved. Any p element in this one class will be red.

Note that this is the simplest possible case, and there are a number of factors that affect prece-
dence. For instance, the cascade also takes into account how precise one given selector is over 
another. Many designers have earned gray hairs trying to debug exactly why a particular rule took 
precedence at a given time, and thankfully, Dreamweaver is a big help in this regard.
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Adding CSS3 
Properties with the 
CSS Styles Panel
As we just saw, the CSS Styles panel 
(Window > CSS Styles) shows all the styles 
affecting a document or a selected style. 
Dreamweaver CS5.5 brought support for 
many CSS3 properties and attributes to 
the CSS Styles panel. And the program’s 
added support for HTML5 tags means that 
you can target the parts of your document 
directly. For example, instead of needing 
to wrap your navigation bar in a div and 
then adding CSS classes to that div, you 
can use the HTML5 nav tag and then apply 
styles that modify the tag.

To work with CSS3 properties:
1. In your document, click All at the top 

of the CSS Styles panel, then click the 
plus (+) (Windows) or the disclosure 
triangle (Mac) to expand a category if it 
isn’t already expanded.

2. To modify a property, click the property 
value. An editable field appears. Type 
any change and press Enter (Return).

Properties with multiple values display 
the names of those values in a tooltip 
when you hover the mouse over the 
values A.

continues on next page

A Hovering over a property with multiple values 
gives you a tooltip with the names of those values.

Welcome to RGB and RGBA
Previous versions of Dreamweaver speci-
fied colors in hex values; for example, 
white was #FFF. Dreamweaver, as of 
CS5.5, now supports setting colors in 
RGB and RGBA, another two CSS3 units 
for color property values. In addition to 
the red, green, and blue components of 
the color, in RGBA there is also an alpha
component that allows you to specify an 
opacity value for color. Where before you 
might have needed to create partially 
transparent images in Adobe Photoshop 
and then bring those images into Dream-
weaver, now you can reduce the opacity 
of the color through a CSS rule.

The opacity of the alpha value is set as 
a fourth value in the RGBA declaration. 
For example, with RGB you would show 
the color white as rgb(255, 255, 255). If 
you wanted to use white at 50% opacity, 
you would set it as rgba(255, 255, 255, 
0.5). The range of acceptable values for 
the alpha value is from 0.0 (completely 
transparent) to 1.0 (completely opaque).



ptg8274339

204 Chapter 7

3. To modify a property with multiple val-
ues, click the Add Values icon  in the 
values column. A values box will pop 
up, allowing you to enter the appropri-
ate values for the property B. If you’re 
viewing your document in Live view, 
you’ll see the results of your changes 
in real time.

For more information on which new 
properties are covered in Dream-
weaver, see the “HTML5 and CSS3 
Code Hinting Additions” sidebar in 
Chapter 17.

B Different properties 
have different 
acceptable values (and 
so may look different), 
but this values box 
for text-shadow is 
representative.

Working with HTML5
In addition to supporting HTML5 tags as 
targets for CSS3 rules, Dreamweaver (as 
of CS5.5) supports HTML5 in a couple of 
other ways. In the New Document dialog, 
you can now choose an HTML5 Doc-
Type, and Adobe has also provided two 
HTML5 starter layouts: two-column and 
three-column fixed layouts. These starter 
layouts, instead of being made up of div
soup, use HTML5 semantics to make the 
structure and meaning of the markup 
clearer. For example, instead of adding a 
div for a navigation bar and then apply-
ing one or more classes to it, the starter 
layouts simply use the nav element. Simi-
larly, sidebars use the aside element.
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Applying Attributes
Most styles take effect immediately in the 
current document and in any other docu-
ments linked to an external style sheet. If 
you redefine the style for a tag such as h3, 
then any time you use the h3 tag, the style 
is applied. Pseudo-class selectors such 
as a:link also are immediately applied 
to the selected elements in any linked 
documents.

Other styles are different—they’re based 
on adding a class or id attribute to an ele-
ment. For instance, after you create a style 
rule for a class, you must then apply that 
class to text in the document. The same 
goes for id.

To apply a class:
1. In a document, select the text to which 

you want to apply the class.

or

Place the cursor anywhere in a para-
graph to apply the class to the entire 
paragraph.

or

Select a tag with the tag selector at the 
lower left of the document window.

2. Do one of the following:

In the CSS Styles panel, select All 
mode, right-click the name of the class
you want, and choose Apply A.

or

In the HTML tab of the Property inspec-
tor, choose the class you want to apply 
from the Class pop-up menu B.

or

continues on next page

A Use the context menu to apply a class style rule.

B Use the Class pop-up menu in the Property 
inspector to apply a class style rule.
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In the CSS tab of the Property inspec-
tor, choose the class you want to apply 
from the Targeted Rule pop-up menu C.

or

In the document, right-click the selected 
text, choose CSS Styles, and then 
choose the class you want to apply.

or

Choose Format > CSS Styles, and in the 
submenu choose the class you want to 
apply D.

C You can apply classes from either the HTML 
tab or the CSS tab of the Property inspector.

D Another way to apply a class style rule is to 
choose Format > CSS Styles and then choose from 
the submenu.



ptg8274339

Styling Page Content 207

To remove a class:
1. Select the text to which the class

was applied. The tag selector in the 
lower left of the document indicates 
the presence of a class with a period; 
for example, <p.current> means that 
the class current was applied to the 
<p> tag E.

2. Do one of the following:

In the HTML tab of the Property inspec-
tor, choose None from the Class pop-up 
menu.

or

In the CSS tab of the Property inspec-
tor, choose <Remove Class> from the 
Targeted Rule pop-up menu.

or

In the document, right-click the selected 
text, choose CSS Styles, and then 
choose None.

or

Choose Format > CSS Styles, and in the 
submenu choose None F.

3. The class is no longer applied to the 
selected text. However, the class is still 
available in the style sheet.

Selected tag uses a class

E In the tag selector bar, it’s easy to identify an 
element that has a class applied to it, because 
the element has a period in its name—for example, 
<div.content>.

F Removing a class is as simple as choosing 
None from the CSS Styles submenu.
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To apply an ID:
1. In a document, select the text or tag to 

which you want to add an id.

2. Do one of the following:

In the CSS Styles panel, select All 
mode, right-click the id you want to 
apply, and then choose Apply A.

or

Right-click the element in the tag selec-
tor, choose Set ID, and then choose an 
id from the submenu G.

or

Use the HTML tab of the Property 
inspector to choose an id to apply from 
the pop-up menu H.

or

Use the CSS tab of the Property inspec-
tor to choose the id you want to apply 
from the Targeted Rule pop-up menu C.

3. Check the tag selector to verify that 
the id has been applied by looking for 
the name of the tag followed by a # fol-
lowed by the name of the id.

When you remove a class from the 
selected element, it’s still available to be 
applied elsewhere. Removing the class
attribute from the tag doesn’t remove the rule 
from your page.

If you select some text that isn’t inside 
a container (such as a paragraph or div) and 
apply a class or id, Dreamweaver wraps a 
new span tag around that text and applies the 
new attribute to the span.

If the pop-up menu in the Property 
inspector doesn’t show the id you want, it 
may be because that id is used elsewhere on 
the page. An id must be unique on the page, 
so if you want to move it from one place to 
another, remove it from the first place before 
attempting to apply it to the second.

G Even the tag selector has a context menu, 
giving you an easy way to add an id.

H The Property inspector 
can also be used to add 
an id.
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To apply multiple classes using 
the Property inspector:
1. In a document, select the text to which 

you want to apply the class.

or

Place the cursor anywhere in a para-
graph to apply the class to the entire 
paragraph.

or

Select a tag with the tag selector at the 
lower left of the document window.

2. Do one of the following:

In the HTML tab of the Property inspec-
tor, choose Apply Multiple Classes from 
the Class pop-up menu B.

or

In the CSS tab of the Property inspector, 
choose Apply Multiple Classes from the 
Targeted Rule pop-up menu C.

3. The Multiclass Selection dialog 
appears I, showing all the available 
classes. Choose the ones you want to 
apply and click OK.

I If you want to assign more than one class, do 
so in the Multiclass Selection dialog.
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Working with Browser-
Specific CSS Properties
Dreamweaver CS5.5 added support in the 
CSS Styles panel for browser-specific prop-
erties, specifically for the Mozilla (Firefox), 
Microsoft (Internet Explorer), WebKit (Safari 
and Chrome), and Opera browsers.

To use browser-specific properties:
1. With your document open, click All at 

the top of the CSS Styles panel.

2. In the All Rules section of the CSS 
Styles panel, click to select the rule to 
which you want to apply the browser-
specific property.

3. At the bottom of the CSS Styles panel, 
click the “Show Category view” button.

In the Properties section of the panel, 
scroll down until you see the Mozilla, 
Microsoft, Opera, and WebKit catego-
ries A.

4. Click the plus (+) Windows or the dis-
closure triangle (Mac) to expand any 
category.

5. To apply one of the properties, simply 
add a value in the column next to that 
property name B.

The names of active properties will 
turn blue.

6. Clicking the “Show only set properties” 
button at the bottom of the CSS Styles 
panel shows the browser-specific prop-
erties you set C.

A There 
are four new 
categories at 
the bottom of 
the CSS Styles 
panel for the 
browser-specific 
properties.

B Expanding 
one of the 
categories 
shows you 
the available 
properties for 
that browser. 
The names of 
active properties 
turn blue.

C When you view the active 
properties for the selected 
CSS rule, you can see the 
browser-specific properties 
(in this case, for Mozilla and 
WebKit browsers).
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Creating Styles with 
the Property Inspector
If you’re upgrading from a much older ver-
sion of Dreamweaver, it’s the most natural 
thing in the world to use the Property 
inspector to create styles. You can still style 
text with the Property inspector, but there 
are a few things to keep in mind.

The old way of using Dreamweaver added 
dozens, perhaps hundreds, of font tags to 
a page with the Property inspector. Getting 
rid of all those bandwidth-eating font tags 
is a good thing. As of Dreamweaver CS4, 
you can only apply two HTML styling tags 
with the Property inspector: <strong> and 
<em>. All other style choices create CSS 
styles, and you’re prompted to create a 
new CSS rule when you try to style text.

Another big change in Dreamweaver CS4 
was splitting the Property inspector into 
two tabs: HTML A and CSS B. In the 
HTML tab, you can apply HTML attributes, 
such as headings, lists, and indenting. You 
can also apply CSS classes and ids. In the 
CSS tab, you can create CSS rules, apply 
font families, change the size and color of 
fonts, and align text.

A The HTML tab of the Property inspector allows you to apply HTML tags.

B The CSS tab of the Property inspector allows you to apply CSS styles.
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To create styles with the 
Property inspector:
1. Open a new, blank document or a docu-

ment with content but with no styles yet 
applied.

2. Click the Page Properties button on 
either tab of the Property inspector. The 
Page Properties dialog appears C.

This dialog applies styles and properties  
that will affect the entire page, and 
the styles will be written as an internal 
style sheet. You can move the styles to 
an external sheet later, if needed; see 
“Moving Internal Styles to External” in 
Chapter 9.

3. The Page Properties dialog contains six 
categories. You can set properties as 
desired in the following:

>	 Appearance (CSS): Set appearance 
properties for the body, including 
page font, size, text color, back-
ground color, and background image. 
If you use a background image, you 
should also set how it repeats. Mar-
gins are set individually for top, right, 
bottom, and left.

>	 Appearance (HTML): Sets HTML 
appearance properties for the page, 
including background image, text  
colors, link colors, and margins D. 
We recommend that you set these 
with CSS styles instead.

>	 Links (CSS): Set the font and size, set 
colors for unvisited, visited, rollover, 
and active links, and select underline 
style from the pop-up menu E.

>	 Headings (CSS): Set a heading font, 
and choose a size and color for each 
heading F.

C Page Properties for Appearance (CSS) 
determine backgrounds, fonts, colors, and 
margins, using CSS.

D You can set HTML page properties in the 
Appearance (HTML) category.

E Page Properties for Links set up fonts, colors, 
and sizes for links.

F Page Properties for Headings set up fonts, 
colors, and sizes for headings.
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>	 Title/Encoding: Type a page title. 
Choose the Document Type (DTD) 
from the pop-up menu. Leave the 
Encoding and Unicode Normalization 
Form settings alone unless you know 
what you’re doing and are creating 
pages in multiple languages G.

>	 Tracing Image: Browse to locate the 
tracing image and set the degree of 
transparency H. We discussed trac-
ing images in Chapter 3, “Building 
Your First Page.”

4. Click Apply to see how your changes 
look, and then click OK to accept your 
changes.

The styles and properties you set are 
stored internally in this document only. You 
can inspect them in Code view. The Document 
Type appears in the first line of code. The 
language encoding appears in a meta ele-
ment in the head. The styles are enclosed in a 
style element in the head. If you set a tracing 
image, it appears in Design view.

Names in the Page Properties dialog 
are not always standard CSS selector or 
property names. For example, in the Links 
category, Rollover links correspond to the CSS 
pseudo-class selector a:hover and Under-
line style corresponds to the CSS property 
text-decoration.

To create classes or inline styles 
with the Property inspector:
1. Open a document and select the text or 

tag to be styled.

On the CSS tab of the Property inspec-
tor, <New CSS Rule> is automatically 
selected in the Targeted Rule pop-up 
menu I.

continues on next page

G Page Properties for Title/Encoding determine 
title, document type, and language encoding.

H Page Properties for Tracing Image allow you 
to set an image to trace over when designing 
your page.

I The Targeted Rule pop-up menu in the 
Property inspector lists available classes 
and ids. Choose one from this menu to 
apply it.
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If you look in the menu, you’ll see that 
there are other styles you can apply; 
the Cascade section lists styles avail-
able in external sheet(s), the New Rule 
section allows you to create a new CSS 
rule or a new inline style, and the Apply 
Class section allows you to apply exist-
ing classes.

2. Set new values for any or all of the 
following settings: Font, Size, and 
Color. For color, use the color picker to 
choose a color for the selected text.

If you’re creating a new inline style, the 
style is created in the document and is 
applied to the selection. You’re done.

or

If you’re creating a new CSS style, the 
New CSS Rule dialog appears J.

(Optional) Instead of applying values in 
the Property inspector, you can click the 
Edit Rule button on the CSS tab of the 
Property inspector B.

3. Choose the selector type, enter the 
selector name, and choose where you 
want the new style to reside with the 
Rule Definition pop-up menu.

4. Click OK. If you formatted the selection 
with the controls in the Property inspec-
tor in step 2, the style is applied. If you 
used the Edit Rule button, the CSS Rule 
definition dialog appears. Set the style 
properties in this dialog, then click OK.

Dreamweaver creates the class with 
a generic name, and the new class
appears in the Targeted Rule pop-up 
menu in the Property inspector. The 
class is applied with a span tag to 
inline text. If the selected text is a com-
plete element, such as a paragraph, the 
class is applied to the element’s tag.

J The New CSS Rule dialog appears to help you 
specify the location for your new rule.
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Modifying a Style
Changing a style is quick and easy. You’re 
already familiar with the CSS Rule defini-
tion dialog and the CSS Styles panel, and 
you can modify styles using either one.

To modify a style with the 
CSS Rule definition dialog:
1. Open a document. In the CSS Styles 

panel, click All mode, choose a style, 
and then do either of the following:

Right-click the style name and choose 
Edit A.

or

Click the Edit Rule button at the lower 
right of the CSS Styles panel (see C in 
“Anatomy of the CSS Styles Panel”).

2. The CSS Rule definition dialog appears. 
Make changes as desired.

3. Click OK to accept your changes.

To modify a style with 
the CSS Styles panel:
1. Open a document. In the CSS Styles 

panel, choose a style in either All or Cur-
rent mode. Properties for the selected 
style appear in the Properties pane.

2. Click a value in the Properties pane. 
An editable field appears B.

3. Change as desired, and press Enter 
(Return) to complete your changes.

A Right-click any style to reveal the Edit menu.

B Edit any 
property value 
directly in the 
Properties pane.
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Working with 
Related Files
The vast majority of Web pages you see 
these days aren’t standalone HTML files. 
Rather, they are HTML files with links to 
other, related files, including CSS style 
sheets; external JavaScript files; server-
side include (SSI) files; and sometimes 
even XML and other HTML files.

In pre-CS4 versions of Dreamweaver, it was 
sometimes difficult to find and get to these 
related files when you were working on a 
page. You would have to check the page’s 
source code in Code view or fiddle around 
in the CSS Styles panel to track down the 
name of the external style sheets.

Dreamweaver CS4 added the Related Files 
bar A at the top of the document win-
dow, giving you quick, one-click access to 
related files.

Related files

A The Related Files bar lets you quickly jump to 
CSS and script files.

B When you click the name of a style sheet in the Related Files bar, you end up in Split view 
ready to edit the style sheet.
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To use related files:
1. Open a document that uses external 

files.

The names of the files appear in the 
Related Files bar. At the left side of the 
bar, you will always see the Source 
Code button, so that you can easily 
display the source code for the current 
document after you have opened a 
related file.

2. Click the name of one of the related 
files in the Related Files bar.

Dreamweaver switches to Split view, 
with the document in the Design View 
pane, and the related file in the Code 
View pane B.

3. View or edit code in the Code View pane.

The Related Files feature is enabled by 
default, but you can turn it off in the General 
category of Dreamweaver’s Preferences panel.

You can also access related files by 
choosing View > Related Files and then choos-
ing the file you want from the submenu C.

Dreamweaver will show all linked CSS 
files in the Related Files bar, even if the CSS 
files are linked to one another rather than to 
the current document. In other words, the 
Related Files bar will show all the style sheets 
in the cascade. However, it only shows other 
types of files (such as scripts) when they are 
directly linked by the current document.

Related files are especially useful when 
working with the Code Navigator feature (see 
“Using the Code Navigator,” later in this chap-
ter) and with Dreamweaver’s Live view.

C You can also see the related files in the 
View menu.
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Working with 
Font Groups
Font groups determine which fonts a 
browser displays on your Web page. 
A browser uses the first font in the group 
that is installed on the user’s system. If 
none of the fonts in the group are installed, 
the browser displays the text as specified 
by the user’s browser preferences.

To modify a font group:
1. Open a document in Dreamweaver.

2. Choose Format > Font > Edit Font List.

or

Choose Edit Font List from the Font 
pop-up menu in the Property inspector.

The Edit Font List dialog appears A
and displays three categories of 
information:

>	 Font list: Displays current font groups.

>	 Chosen fonts: Displays fonts in the 
chosen group.

>	 Available fonts: Displays all the 
fonts available on your system. The 
font selected is displayed in the text 
field below.

A Use the Edit Font List dialog to create, modify, 
or remove font groups.
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3. Do any of the following:

>	 To add or remove fonts from a font 
group, select the font and click the 
arrow buttons between the Chosen 
fonts and Available fonts lists.

>	 To add or remove a font group, select 
it and click the plus (+) or minus (–) 
button at the top left of the dialog.

>	 To add the name of a font that is not 
installed on your system, type the font 
name in the text field below the Avail-
able fonts list and click the left-facing 
arrow button to add it to the group.

>	 To move a font group up or down in 
the list, select it from the Font list box 
and then click the arrow buttons at 
the top right of the dialog.

4. Click OK to accept your changes.

To avoid surprises, it’s good practice to 
stick with the commonly available fonts for 
most text. If you really need to use a fancy, 
decorative font for short bits of text, you may 
be better off making an image of the text and 
placing it as a graphic.

We would love to add something here 
like “You can be assured that people with 
this version of this browser on this operating 
system will have these fonts”—but we can’t. 
New browser versions get shipped that don’t 
include the same fonts the older versions did. 
The same goes for operating systems. And 
then, of course, people can always delete or 
disable their existing fonts. The font groups 
that ship with Dreamweaver, as a general rule, 
are dependable. And of course, always end 
your font list with either serif or sans serif as 
fallbacks for best results.

There’s one exception to that previous 
caveat: Web fonts, which are covered in the 
next task.

Fonts, Browsers, and Operating 
Systems
Not all computers have the same fonts. 
For example, a common sans serif font 
on Windows systems is Arial. A similar 
sans serif font on Macintosh systems 
is Helvetica. Many Linux systems have 
Helvetica, but not all.

But don’t assume that you can make 
generalizations just based on operating 
system; different versions of operating 
systems can come with different fonts. 
And on top of that, different browsers 
(even on the same operating system) can 
ship with different defaults for serif and 
sans serif fonts. All these systems have 
some default fonts, however.

When choosing font groups, select 
fonts that share similar characteristics 
and try to cover all the bases in terms of 
operating systems. Then, add either the 
generic serif or sans serif choice at the 
end, just in case none of your preferred 
choices are available.

Why add a font you don’t even have to 
your font group? One reason is that you 
expect a lot of your viewers to have a 
particular font (even though you don’t 
have it). For example, if you are develop-
ing pages for a corporate client for use 
in its intranet, your client may ask for a 
particular font that is installed on all of 
the company’s machines.
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Using Web Fonts
One of the big constrictions on the freedom 
of Web designers has always been the 
limited range of fonts they could use on 
pages. Because there are so many brows-
ers running on so many different platforms, 
designers were more or less forced to use 
a very restricted set of fonts (often known 
as Web-safe fonts) that were most likely to 
appear on Windows, Mac, Linux, and mobile 
devices. Microsoft’s set of Web-safe fonts, 
including Arial, Verdana, Times New Roman, 
and Trebuchet, gained widespread use. 
They’re fine, but they’re boring.

Once again, CSS3 comes to the rescue. 
The @font-face rule allows you to use 
non-Web-safe fonts by defining the loca-
tion of a font resource, which can be either 
local to your machine or external. As of CS 
5.5, Dreamweaver supports @font-face, 
and Google now makes a wide selection 
of attractive fonts available at www.google.
com/webfonts. At that site, you can create 
a collection of one or more fonts and then 
either download the collection for use on 
your own Web server or, even better, use 
Google-provided code to link to the fonts, 
which are then served on the fly by Google 
with minimal impact on page-loading time. 
Google provides linking code in your 
choice of HTML, CSS, or JavaScript.

To show you how easy it is to use Web 
fonts, we’ve created a simple example 
based on Alice’s Adventures in Wonder-
land. It shows part of a famous conversation 
between Alice and the White Queen, with 
different fonts used for each character’s 
dialogue A. First, we chose two fonts 
from Google and used their CSS code as 
the basis of our CSS style sheet. Then we 
applied new styles to our text, with one font 
for each of the two speakers. The following 
steps explain how the process is done.

A In this example, we styled Alice and the White 
Queen’s dialogue differently by using Web fonts.

www.google.com/webfonts
www.google.com/webfonts
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To use Web fonts:
1. Go to Google’s Web fonts site, choose 

the fonts you want to use, and add 
them to a collection (we picked “Over 
the Rainbow” and “Redressed”). When 
you’re done, click the Use button to get 
to the code page B.

2. On that page, you have three choices: 
Standard, @import, and JavaScript. We 
think the simplest is @import, so that’s 
what we’ll use here. Copy that line of 
CSS C.

continues on next page

B Pick two fonts you like, and click Use.

C Copy the @import line of CSS to paste into your local CSS file.
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3. In Dreamweaver, use the Related Files 
bar to open your CSS file and paste in 
the @import rule you just copied D. 
Save the CSS file and switch back to 
your Web page; you’ll notice that the 
CSS Styles panel now contains two new 
rules: one @font-face for each of the 
two fonts we just added E.

4. From the CSS Styles panel, select the 
.alice class. In the Properties pane, add 
the font-family property with a value of 
Over the Rainbow (or the equivalent for 
whatever font you chose) F.

D Our CSS file after we added @import.

E And suddenly, we’ve got two  
@font-face rules, bringing in our 
new fonts.

F To use these new fonts, just type 
their names into the CSS Styles panel.
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5. Now, select the .queen class, and add 
a font-family property with a value of 
Redressed G.

6. At this point, you may be wondering  
why your Web page still looks the 
same—just switch into Live view, and 
you’ll see your new fonts appear H.

You don’t have to use Google to serve 
your fonts—but why not? They almost defi-
nitely have faster download speeds than your 
server, and there’s a slight chance that users 
may have already downloaded your particular 
font—both of which make your site appear 
snappier and more responsive.

Wish you had a wider variety of fonts 
than just the ones from Google? Here are  
two more popular resources: Font Squirrel 
(www.fontsquirrel.com) and Typekit  
(www.typekit.com). And given that Adobe 
recently bought the latter, we won’t be sur-
prised to see it integrated into a future version 
of Dreamweaver. 

We’re sure you know this, so this tip is 
just for other people: Google has a tendency 
to change the functionality of their Web sites 
at the drop of a hat. And if that hat does drop, 
you might not see screens exactly like the 
ones in B and C—but they should be close 
enough for you to get the idea.

G We’re nearly done when the queen has her 
new font.

H Switch to Live view, and see your fonts in action.

www.fontsquirrel.com
www.typekit.com
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The Not-So-Helpful GUI
You may have noticed that Dreamweaver has a Modify > Web Fonts menu item that brings up the 
Web Fonts Manager and Add Web Font dialogs I. We tested it while writing this section, and 
we found it harder to use than the method we describe in the previous section. Similarly, in the 
Advanced Settings panel of the Site Setup dialog, you’ll find a Web Fonts category where you 
can set a Web fonts folder J. We don’t recommend that you use that, either—if you do, it makes 
Dreamweaver act in confusing ways and gives you less flexibility. And worse, once you add it, you 
can’t remove it.

Of course, these are issues that Adobe can choose to address at any time, so keep an eye out 
for updates.

I The Web Fonts Manager and Add Web Font 
dialogs. We don’t think they’re quite ready for 
prime time.

J Until Adobe says otherwise, this demo site will 
always have a Web Fonts folder. 
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Using the Code 
Navigator
One of the challenges of working with 
modern sites is that sometimes it can be 
difficult to figure out which of the linked 
style sheets or script files is actually being 
applied to a given element on your page. 
Sure, you can use the Property inspector 
or the CSS Styles panel to get the name 
of the style that is applied to the element, 
but that style could be being modified 
by another style sheet elsewhere in the 
cascade. What you need is a tool that 
shows all of the style sheets and scripts 
that are affecting your selection and that 
then allows you to easily make changes 
to those styles and scripts. That’s what the 
Code Navigator does.

To use the Code Navigator:
1. Point at the element on your page 

that you want to inspect, then Alt-click 
(Cmd-Opt-click).

or

Press Ctrl-Alt-N (Cmd-Opt-N).

or

Right-click the selection or a tag in the 
tag selector, and then choose Code 
Navigator.

or

Choose View > Code Navigator.

or

Click the Code Navigator indicator that 
appears near where you last clicked in 
the document when Dreamweaver has 
been idle for a few seconds A.

continues on next page

Code Navigator indicator

A Click the Code Navigator indicator to open the 
Code Navigator window.
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The Code Navigator window appears B
showing you the script and CSS files 
associated with the selection. For CSS 
styles, indented under the name of 
each style sheet are the names of the 
CSS rules that apply to the selection.

2. To jump directly to a particular rule, click 
its name in the Code Navigator window.

The Dreamweaver window changes to 
Split view and places the insertion point 
in the Code View pane ready to edit the 
style rule you chose.

or

To view the properties defined in each 
of the rules shown in the Code Naviga-
tor, hover the cursor over a rule’s name. 
After a moment, a tool tip appears 
showing you the properties C.

3. If you ended up in the Code View pane 
in step 2, edit the style rule. If all you 
wanted to do was view the rules and 
properties for the selection, press Esc 
or click elsewhere in the document to 
dismiss the Code Navigator window.

You can also invoke the Code Navigator 
in Code view by placing the insertion point 
inside a <script> or <link> tag, or inside 
a text block that is being styled by CSS, and 
then clicking the Code Navigator button on 
the Coding toolbar. See Chapter 17 for more 
information about working in Code view.

The Code Navigator is incredibly use-
ful, but the Code Navigator indicator (A) is 
actually pretty annoying, because it pops up 
whenever you pause your work. You can (and 
probably will) turn off the indicator by select-
ing the “Disable <Code Navigator symbol> 
indicator” check box at the bottom of the Code 
Navigator window. You can always bring up 
the Code Navigator manually, as discussed 
in step 1.

B The Code Navigator window shows the 
different style sheets associated with the 
element you selected and also shows which 
particular rules affect the element.

C Hovering over a CSS rule reveals the 
rule’s properties
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Using Styles 
for Layout

In Chapter 7, you saw how to use CSS 
(Cascading Style Sheets) to style text. 
CSS can do a whole lot more than just 
make your words look pretty—style sheets 
can also be used to lay out the elements 
on your page.

This chapter covers creating pages using 
Dreamweaver’s CSS layouts, including how 
to modify them to match your designs.

In This Chapter
CSS Layout Basics 228

Using the Included Layouts 231

Laying Out Your Page 233

Laying Out Your Navigation 237

Modifying Your Navigation 239
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CSS Layout Basics
When CSS first started becoming popular 
(that is, when enough browsers supported it 
consistently), its primary use was for styling 
text, and Web designers were thrilled to say 
goodbye to the font tag. Besides styling 
text, it’s also possible to use CSS to define 
how your page is laid out, and thankfully, 
modern browsers now have sufficient mar-
ket share that CSS layouts are standard.

The box model
When you lay out a page using CSS, you’re 
using the box model—that is, you’re creat-
ing boxes (almost always done by adding 
a div) and laying them out on your pages. 
Each box contains several elements A: 
margin, border, padding, and content. 
Using CSS, you can set rules for each ele-
ment. If you want, you can (for example) 
set different rules for the top, right, bottom, 
and left sides of an element.

Let’s say that you want to put a line above 
and below your text. You can set the bor-
der around your text (that is, to the tag that 
contains your text) to 1px black solid just 
for the top and bottom. If you don’t set the 
other sides, they’ll be set to 0 by default.

Here is the content 

inside the box 

itself. It can contain 

anything you want, 

not just text. It 

can be an image, 

or it can even 

be another box 

entirely.

Margin Border Padding Content

A The CSS box model, broken down into parts.
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Positioning your boxes
When you’ve created boxes on your page, 
you’ll want to place them. To do that, you 
need to understand two new concepts: 
position and float.

The position of a box can be static, rela-
tive, inherit, absolute, or fixed B.

n	 Static: The simplest position is static; it 
just means that the box ends up wher-
ever it would normally end up, all on its 
own. Any left or top offsets you give it 
are ignored.

n	 Relative: The next simplest is relative, 
which is just like static except that you 
can set its left and top positions.

n	 Inherit: Inherit is used when you want a 
box to automatically inherit the proper-
ties of its parent (that is, its container). 
Wherever that box happens to be, it just 
takes on the position rules based on 
its container.

n	 Absolute: Absolute and fixed are similar 
in that you can specify exactly where 
on your page you want the box to 
appear. The difference between the two 
involves their frame of reference: an 
absolutely positioned box is positioned 
in reference to its container. If you have 
an absolutely positioned box placed 
100 pixels from the top of a page, and 
another absolutely positioned box 
inside that box that is also set to be 100 
pixels down, the interior box will be 200 
pixels down, not 100—because its frame 
of reference is to the box that it’s inside.

n	 Fixed: Fixed positioning, on the other 
hand, is based on the page itself. If you 
set a box to be fixed at 100 pixels down, it 
will always be there, even if you scroll the 
page. When you scroll, that box will move 
down with you so that it’s always 100 pix-
els down from the top of the visible page.

B An example of an absolutely positioned box 
with set width.
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Floating your boxes
Alternatively, a box can be set to float, such 
that its contents stick to one side or the other 
of its containing element C. The values  
for float are left, right, none, and inherit.

n	 Left: A box that is floated to the left 
causes everything else on the page 
(everything that isn’t explicitly told to be 
somewhere else, that is) to wrap around 
it to the right.

n	 Right: A box floated to the right causes 
everything else to wrap around it on 
the left.

n	 None: This is the default, but it’s some-
times useful to be able to explicitly tell 
a box not to float (usually when trying to 
work around browser bugs).

n	 Inherit: If you want a box to inherit the 
float value of its container, just set float 
to inherit.

All browsers released in the last several  
years handle positioning and floating boxes 
well. Older browsers may have varying 
degrees of difficulty with these concepts. 
As always, we recommend testing your 
site in as many browsers (and versions and 
platforms) as possible. Adobe’s BrowserLab 
online service is useful if, like most of us, you 
don’t have your own computer lab filled with 
test machines.

The information about the box model 
here is just a quick and dirty definition. Many 
pages (and some entire books) have been writ-
ten on the intricacies of the box model.

C This div (and 
the navigation 
area it contains) is 
floated to the left.

Just Say No to Absolute 
Positioning
Once upon a time, it was difficult to 
make a Web page look just the way you 
wanted it to, because browsers had 
very little support for layout. Despite the 
poor browser support, Dreamweaver 
worked hard to make layout with precise 
positioning possible through what it (in 
pre-CS4 versions) called layers and now 
calls absolutely positioned elements, or 
more commonly, AP elements.

Given Dreamweaver’s capabilities 
and the commonly used browsers, AP 
elements are, in our opinion, obsolete. 
We might seem to be coming off a little 
heavy-handed here, but it’s from experi-
ence: don’t use AP elements. Just don’t. 
If you have a site that uses AP elements, 
it’s worth taking the time to carefully con-
vert it to use a block-positioned layout 
with divs.

AP elements, along with converting 
AP elements to tables and vice versa, 
are remnants of an older, sadder time. 
Dreamweaver leaves them in for historical 
reasons, but they’re the wrong way to go.
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Using the Included 
Layouts
Initially, you might think that it’s difficult to 
get started using CSS for layout, but for-
tunately, Dreamweaver has included CSS 
layouts to make getting started as easy as 
can be. These files are flexible, profession-
ally developed templates that make a great 
starting point.

To use the included layouts:
1. From Dreamweaver’s menu, choose 

File > New. The New Document dialog 
appears A.

continues on next page

A The familiar New Document dialog contains handy CSS-based page designs to get you started. Look at 
the preview column to decide which of the designs you want to use as the basis for your page.
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2. If it wasn’t chosen by default, select the 
category Blank Page, and select HTML 
from the Page Type menu. You should 
see 18 designs listed in the center 
column. Choose any of these to see 
a preview in the right column. Directly 
below the preview is a short description 
of the design.

3. If you see a design you like, click 
Create. A new, untitled Dreamweaver 
document opens in the chosen design 
B. You now have a template for your 
site that’s entirely CSS-based. You can 
modify the page content and its styles.

4. Save the new layout by choosing File > 
Save or by pressing Ctrl-S (Cmd-S).

Even if none of the included design files 
suit your taste, take a look at them and check 
out how they work. They’re a good way to 
learn how to use CSS to lay out a page.

When creating a new page based on an 
included layout, you’re given the option of put-
ting the required CSS in the head of the docu-
ment, in a new file, or in an existing file. When 
you put your site online, your CSS should be 
in an external file, but it’s easier to test and 
debug when it’s in the head of the document. 
If you decide to start with it in the head, you’ll 
want to check out Chapter 9, which covers 
moving internal styles to an external file.

Don’t forget to add a title to your page in 
the Title field of the Document toolbar.

If you previously used a much older ver-
sion of Dreamweaver, you might be wondering 
where some of its included layouts went. The 
answer is that while it was great that there 
were so many options, the sheer number of 
them (elastic, fixed, liquid, hybrid, and so on) 
ended up confusing people. Some of them, 
sadly, were so complex that they were brittle—
that is, they could break when new browser 
versions shipped. Back in CS5, Adobe pruned 
the list, keeping only those that are commonly 
used and rock solid. They also rewrote the 
templates to use cleaner code and to include 
instructions in the layouts that make it easier 
for you to understand how the different parts 
of the layouts work.

B Here’s your new page, ready to receive your content.
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Laying Out Your Page
Here’s where things get interesting: now 
that you’ve got the theory, it’s time to put 
it into practice. With the included CSS lay-
outs, it’s straightforward.

Before you start laying out your page, you 
need to think about what you want on that 
page and where you want it to go. As dis-
cussed in Chapter 2, the best way to do that 
is with pencil and paper. That should tell 
you what styles you’ll need—for instance, a 
header, footer, content area, and navigation 
area. Once you have a design in mind, look 
through the included CSS layouts to see 
which best fits your idea A.

Now you’re ready to start. In this case, 
we’ll start with the 2-column liquid layout, 
with a left sidebar, header, and footer B. 
The liquid part of the name means that the 
page content expands and contracts to fit 
the width of the browser window.

A You’ll want to have a plan before you start laying out your 
page; here’s our planned design.

B Start by selecting a new blank page with a new layout.
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To lay out your page:
1. Choose the “2-column liquid, left 

sidebar, header and footer” layout, and 
Dreamweaver gives you a bare-bones 
page to start C.

2. Almost all your work will be done in 
the CSS Styles panel D. Here the 
body styles are all fine except for the 
background color—we want it to be 
gray instead of the default blue, so we 
changed its value to #666666.

3. Next is the .container rule, which 
applies to the one large div that con-
tains all the content on the page. Again, 
we only want to change the back-
ground color; now it will be a lighter 
shade of gray, #EBEBEB E.

C This page doesn’t just contain dummy text— 
it also contains many helpful tips.

F The .content style needs 
a white background, which we 
added here.

E Next, change the styles for 
the class named .container. 

D Start your new page by 
changing the styles for the 
body tag.
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4. The .content area is the section that 
will contain (as you might guess) the 
bulk of the page content. For easy 
readability, we want its background to 
be #FFFFFF (that is, white). This section 
doesn’t have a default background 
color, so we have to add it F.

5. The default page assigned a back-
ground color to the sidebar, which 
we don’t want. To remove the default, 
select the background-color property 
(found under .sidebar1) and click the 
trashcan icon G.

6. Our page header has two parts: the 
foreground banner and the background 
color. The banner image is named 
header.jpg, and it simply needs to be 
dragged into the .header div. Next, 
delete the dummy logo image place-
holder that came with the layout, and 
change the blue background to a green 
that blends into the header graphic 
(#91A43D). And finally, add a text-align
style declaration with a value of center
to center the banner horizontally within 
the header area H.

7. All that’s left to change is the back-
ground color of .footer to another 
shade of gray, #DDDDDD I.

G Click the trashcan icon in the CSS 
Styles panel to delete a property and 
its value.

H Once you’ve set up the header, you’re a long way toward having your Web page just the way you want it.

I Styling the footer finishes the page.
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Setting the background color for 
.sidebar1 by letting the background color 
for .container show through is a technique 
called faux columns. To produce the desired 
effect (a sidebar with a background color 
going from the header to the footer), each 
page needs to have enough content so that 
the main content area is longer than the 
sidebar’s content. Thankfully, our navigation 
needs here are minimal enough that that isn’t 
a problem.

You don’t really need to know that white 
is #FFFFFF—you can just select the color you 
want from the color well in the panel.

Using CSS Shorthand
Chapter 7 mentioned CSS shorthand 
properties, and here you can see them 
in action.

If you’re used to colors in HTML always 
having six hexadecimal digits, you 
may initially be confused when you 
see values like #03F or #C96. Three-
digit color values are just shorthand; to 
translate one to its six character version, 
just double each digit—for instance, 
the colors just mentioned are actually 
#0033FF and #CC9966, respectively. Keep 
in mind, though, that you can only use 
the three-digit version when all the digits 
are doubled; there are no shorthand ver-
sions of #91A43D or #EBEBEB.
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Laying Out Your 
Navigation
The previous task laid out the entire page 
except for one small section: the navigation 
menu. While the menu is only a small sec-
tion of the Web page, it’s a vitally important 
part to your visitors. Here’s how to person-
alize it to match the rest of your design.

1. Start by removing the one unwanted 
style rule: the border-bottom on the 
ul.nav li rule.

2. The only change the ul.nav rule needs 
is to the top border’s color, and that’s 
done by changing the value of  
border-top to 1px solid #EBEBEB A.

3. The changes to the ul.nav a, ul.nav
a:visited rule are a little more  
complex. Start by changing color to 
#EBEBEB and background-color to 
#336666. Then add two new proper-
ties: font-weight, which should be set 
to bold; and border-bottom, which 
should be set to 1px #EBEBEB solid B.

4. You may think you’re done C, but you 
still need to handle rollovers. That’s 
where users get feedback so they know 
where to click.

The rule to change is ul.nav a:hover, 
ul.nav a:active, ul.nav a:focus. 
Change the color to #336666 and the 
background color to #EBEBEB: the same 
colors you used in the last step, just 
reversed. When you roll the cursor 
over a link, it will go from gray text on a 
green background to green on gray D.

5. Make the links look like buttons by set-
ting their padding and border values E. 
To achieve the desired button-like effect, 
you have to do a little bit of calculating.

continues on next page

A Here you’ve 
changed the 
standard ul.nav
rule.

B Once you’ve 
changed the rule 
for your links, 
you can see how 
the navigation 
will look.

C The almost-
completed 
navigation 
section before 
styling the 
rollovers.

D Swapping the 
color scheme 
from gray on 
green to green 
on gray means 
you’re almost 
there.

E Adding a 
border to the 
right and bottom 
makes your links 
look like 3D 
buttons.
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For each side of the button, add 
together the width of the padding and 
the width of the border for the non-
hovering (inactive) version of the button. 
Then for the hover state, the width of 
the padding added to the width of the 
border must be the same sum as the 
non-hover version.

In this example, look at the bottom of 
any navigation link: when inactive, the 
padding is 5px and the border is 1px, 
for a total of 6 pixels. So when you’re 
hovering, the sum of the padding and 
the border must also be 6 pixels—if not, 
the button will appear to jump around. 
With the border and the padding each 
set to 3px, you get the effect you want.

Now look at the right side. The inactive 
state has 5px padding and no border, 
for a sum of 5 pixels. To get a nice even 
button when hovering, set the right bor-
der to 3px, which means the padding 
needs to be 2px.

Now that you have the values you 
need, all you have to do is add them to 
the ul.nav a:hover, ul.nav a:active,
ul.nav a:focus rule. Set both the  
border-bottom and border-right
properties to 3px #999999 solid. And 
finally, add padding-bottom with a 
value of 3px and padding-right with 
a value of 2px F.

Don’t forget that you can inspect any 
element on the page by Alt-clicking 
(Opt-clicking) to show the Code Naviga-
tor, including the rules that apply to that 
element. Hovering over a rule, as in G, 
shows all the declarations that make up 
the rule. The tool tip also shows the val-
ues (if any) of float, position, top, right, 
bottom, left, width, height, and overflow. 
See Chapter 7 for more about using the 
Code Navigator.

F Here you’ve set the necessary 
properties to make the rollover 
happen.

G Hovering over a style in the Code Navigator 
gives you useful information about that element.

If you’re trying to find the padding width 
for a particular side, you might be thrown off 
by padding having a value of 5px 5px 5px
15px—which is the one you want? When you 
see four values like this in CSS, they’re always 
in the order top, right, bottom, left (a clockwise 
direction). So with that value, the bottom and 
right sides each have 5 pixels of padding.

Not seeing the rollovers? Turn on Live 
view, which shows your site the way a browser 
would display it. And if you’re trying to track 
down a layout issue and want the hover effect 
even when you aren’t actually hovering, choose 
View > Style Rendering > Show :hover Styles—
but don’t forget to set it back again afterwards.
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Modifying Your 
Navigation
You have your page now just the way you 
want it—or so you think. After working with 
it, you realize that the left sidebar needs to 
be used for other purposes, and you want 
the navigation horizontally along the top. 
Back to the drawing board to start all over 
again, right? Nope; here’s where the power 
of CSS really comes through.

To modify your navigation:
1. Using the tag selector, select ul.nav A, 

and then drag the selection to just after 
the header and before the sidebar. This 
can be a little tricky, so use Edit > Undo 
until you get it right. The result should 
look like B. But don’t panic because of 
the way it looks—you’re not done yet.

continues on next page

A Select the 
ul.nav element 
from the tag 
selector, and then 
carefully move it 
to its new home.

B Now the 
navigation 
is above the 
content, but 
every button 
goes clear across 
the page.
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2. Now you just need to modify the CSS, 
so you start by changing the ul.nav
rule C:

>	 Delete the margin-bottom and 
border-top properties.

>	 Add the property height with a value 
of 1.8em.

>	 Add the property background-color
with a value of #336666.

>	 Add the border-left and  
border-bottom properties with  
values of 1px #EBEBEB solid.

>	 Add the property padding-bottom
with a value of 3px.

3. Make these changes to the ul.nav a,
ul.nav a:visited rule D:

>	 Delete the border-bottom property.

>	 Add the property float set to left.

>	 Add the property border-right with 
a value of 1px #EBEBEB solid.

>	 Change the width of the  
padding-bottom property from 5px
to 3px.

>	 Add the property width set to 22%.

As shown in E, the navigation has now 
taken shape. Floating each link to the 
left caused them to display in a single 
horizontal line.

C A few 
modifications to 
the ul.nav rule 
fix some of the 
issues.

D Tweaking the 
link rule takes 
you most of the 
way there.

E Looks good—all that’s left to do are the rollovers.
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4. Make these changes to the ul.nav
a:hover, ul.nav a:active, ul.nav
a:focus rule F:

>	 Change the padding-bottom prop-
erty from 3px to 0px.

>	 Change the padding-right property 
from 2px to 3px.

Your menu should now look like G, 
with button-like links spread evenly 
across the page under the header.

F The rollover 
rule needs some 
changes to the 
right and bottom 
padding.

G And here’s the finished product.
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We gave the buttons a width of 22% to 
spread them out. You could also have done 
this by setting the width to a specific pixel 
size, but using a percentage makes them 
expand and contract with the rest of the liquid 
layout. However, you’ll need to remember to 
lower that number if you want to add another 
navigation button.

We did the same calculation here as in 
the previous task to make sure that the bot-
tom and right sides appear button-like. The 
bottom has 3 pixels of padding and no border 
when inactive, and no padding and a 3-pixel 
border when active. The right has 5 pixels of 
padding with a 1-pixel border when inactive, 
and 3 pixels of padding and a 3-pixel border 
when active.

You might be wondering if you could 
have just left out the declaration setting 
padding-bottom to 0px. In this case, no—you 
need that declaration of zero pixels of padding 
to explicitly override the three pixels of pad-
ding set in the previous step. If you left out the 
declaration, the browser would use the inher-
ited padding, throwing off your button layout.
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Managing Styles

The two previous chapters covered CSS 
and how it works with your Web pages. 
After you’ve gotten the hang of CSS, 
though, you may find that you’re spending 
too much time trying to figure out which 
styles affect which sections of the page. 
Or maybe you’ll find that you’re trying to 
keep track of where your styles are (inline? 
internal? external?) and in what order they 
apply to your site. Or maybe it’ll be that 
you are testing styles but don’t want to 
change your entire site yet.

No matter what your particular issue, 
Dreamweaver has made it simple and 
straightforward to manage moving, dupli-
cating, debugging, and deleting styles.

In This Chapter
Renaming Styles 244

Deleting Styles 246

Creating Rules from Inline Styles 247

Creating a New External Style Sheet 249

Moving Internal Styles to External 252

Attaching a Style Sheet 254

Using Drag-and-Drop Styles 256

Using CSS Inspection 258

Using the Visual Aids 260

Experimenting with CSS  
Enable/Disable 262

Using Design-Time Style Sheets 264
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Renaming Styles
It’s a good idea to give styles a descrip-
tive name of your choosing. You may want 
to rename a style because your site has 
changed, or maybe you just don’t like the 
style names in the default CSS layouts. 
Whatever the reason, they should have 
meaningful names.

To rename a style for a class:
1. In the HTML tab of the Property inspec-

tor, choose Rename from the Class pop-
up menu A. The Rename Style dialog 
appears B.

or

In the CSS Styles panel, find and select 
the rule you want to rename C. Right-
click the rule name and select Rename 
Class from the context menu D. The 
Rename Class dialog appears E.

A Choose Rename from the 
Class pop-up menu to give a 
style a new name.

B Type the new name in the field to rename 
your style.

Attach style sheet

Delete CSS rule

New CSS rule

Disable/Enable CSS property

Edit rule

C You can also rename styles from the CSS 
Styles panel.
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2. If the class you want to rename isn’t 
already selected, use the pop-up menu 
to choose it. Type a name in the New 
name field, and click OK.

3. If the style you chose is used in multiple 
places or it’s in an external style sheet 
that can affect multiple pages, you’ll be 
prompted as to whether you want to 
make this change everywhere F. If you 
want this (you usually will), click Yes.

If you click Yes, the Find and Replace 
dialog appears, with the parameters 
you need to search for and replace 
already filled in, and with the scope of 
the search set for your entire site. See 
the section “Finding and Replacing with 
a Specific Tag” in Chapter 4 to learn 
more about using this dialog.

If you click No, the Find and Replace 
dialog does not appear, and you will 
need to make any updates manually.

The two dialogs have different names, 
but they do identical tasks.

D In the CSS Styles panel, choose your 
style, right-click, and choose Rename Class.

E They may have different names, but the 
Rename Style dialog and the Rename Class dialog 
do the same thing.

F If you want, Dreamweaver will update the name 
everywhere in your site after you rename a style.
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Deleting Styles
When you delete a style from a style sheet, 
the formatting of any element using that 
style immediately changes.

To delete a style:
1. Open a document, and in the CSS 

Styles panel, choose the style name to 
delete.

2. Click the Delete CSS Rule button in the 
lower right of the panel. Note that you 
don’t have to click OK or accept any-
thing—it just disappears immediately.

Even though you’ve deleted the style, 
any references to it will still exist in the 
document. That is, classes and ids aren’t 
removed from your pages when you delete 
rules that apply to those classes and ids.
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Creating Rules 
from Inline Styles
Inline styles (first covered back in Chap-
ter 7) are a handy way to test properties 
to see if using a particular bit of CSS does 
what you want it to do. However, remem-
ber that the main power of CSS is being 
able to apply it in many places in a docu-
ment and many documents in a site—and 
if you’re only applying it to a single tag, 
you’re missing out on all that power. So 
while inline styles are great for quick tests, 
once your CSS has passed the test, it’s 
time to turn it into a rule.

To create a rule from an inline style:
1. In your document, click anywhere 

within the area where the inline style is 
applied. In the CSS Styles panel, make 
sure that you’re in Current mode and 
that the Rules pane is visible by clicking 
the Show cascade button. You should 
see a rule called <inline style> A.

2. Right-click the <inline style> rule and 
choose Convert to Rule from the menu.

or

Choose Format > CSS Styles > Convert 
Inline CSS to Rule B.

The Convert Inline CSS dialog 
appears C.

continues on next page

Show 
information

Show 
cascade

A To turn an inline style into a rule, first find the 
<inline style> rule in the CSS Styles panel.

B One way to convert the style to a rule is with 
Convert Inline CSS to Rule, found under the 
Format menu.

C The Convert Inline CSS dialog lets you set all 
the options for your new rule.
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3. The first choice in that dialog is what 
type of rule you want to end up with D:

>	 A new CSS class, where you get to 
choose the class name.

>	 A rule that applies to all tags of the 
given type; that is, if the inline style is 
applied to a <p> (paragraph) tag, you 
can apply that style to all paragraphs.

>	 A new CSS selector, where the 
default is a rule based on the location 
of the inline style.

The last two are context-sensitive, so 
your defaults change depending on 
your inline style selection.

4. Next, you have a choice of creating the 
new rule in an external style sheet or in 
the head of the current document. Any 
currently linked external style sheets 
will be in the pop-up menu. If you don’t 
have any external style sheets, you can 
either create one here or put the new 
rule into the head of the current docu-
ment (you’ll see how to move the inter-
nal rule to an external style sheet later 
in the chapter). Choose an option, click 
OK, and your new rule will be created.

D You can make a new class, a new selector, or a new rule that applies to all 
instances of a certain tag.

It’s possible for the Rules pane to show 
more than one style named <inline style>, 
so make sure you’re choosing the correct one.

Dreamweaver CS5 added the ability to 
create a new external style sheet from the 
Convert Inline CSS dialog. If you want your 
new rule to be in a new external style sheet, 
you can either:

Follow the preceding steps to create a new 
rule, and then in the Convert Inline CSS dia-
log, enter a name for your new file. A dialog 
appears telling you it doesn’t exist and asking 
if you want to create it. If you do, click Yes and 
your new CSS file is created (containing your 
new CSS rule) and attached to the HTML page.

or

Follow the preceding steps to create a new 
internal rule, and then follow the steps in 
“Moving Internal Styles to External,” later in 
this chapter.

or

Follow the steps in the next task, “Creating a 
New External Style Sheet,” and then use the 
steps in this task to put the new rule into that 
style sheet.
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Creating a New 
External Style Sheet
Up to now, we’ve covered how to create 
internal styles, but we also mentioned that 
internal styles may not always be the right 
choice. Here’s how to create a new external 
style sheet, either from scratch or using one 
of the many sample files that are included in 
Dreamweaver as a starting point.

To create a new external style 
sheet based on a sample file:
1. From Dreamweaver’s menu, choose 

File > New. The New Document 
dialog appears.

2. If it wasn’t chosen by default, select 
the category Page from Sample. Under 
Sample Folder, select CSS Style Sheet 
to display a list of style sheets in the 
center column A. Choose any of them 
to see a preview and description in the 
right column.

continues on next page

A Dreamweaver comes 
with plenty of CSS designs 
for you to use as starting 
points.
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3. If you see a design you like, click Create. 
A new untitled style sheet document 
opens in Code view that contains the 
rules defined in the style sheet you 
selected. Save this file with a name that 
ends in .css.

To create a new external 
style sheet from scratch:
1. Choose File > New. The New Document 

dialog appears A.

2. In the New Document dialog, select 
Blank Page for the Category, select CSS 
for the page type, and click Create. A 
new blank style sheet opens in Code 
view B. Save this file with a name that 
ends in .css.

or

1. With a document open, click the Insert 
Div Tag button in the Common or Lay-
out category of the Insert panel, and the 
Insert Div Tag dialog displays C. Click 
New CSS Rule, and the New CSS Rule 
dialog opens D.

B A blank 
CSS document, 
ready for you to 
add your rules.

C Use the Insert Div Tag dialog to open the New 
CSS Rule dialog.

D Enter the selector information you need for the 
new rule, and set the Rule Definition pop-up menu 
to New Style Sheet File.
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2. Enter any class, tag, id, or pseudo-
class selector that you’d like in your 
new CSS file. Set the Rule Definition 
pop-up menu to (New Style Sheet File) 
and click OK. The Save Style Sheet File 
As dialog appears E.

3. Choose a filename that ends in .css, 
and click Save. The CSS Rule Definition 
dialog appears F. Add the rules you 
want (as described in Chapter 7), click 
OK, and you’ll return to the Insert Div 
Tag dialog, with your new style sheet 
(including any rules you set) available 
as a related file in the bar at the top of 
the current document G.

4. If you created a new style sheet using 
the Insert Div Tag dialog and don’t 
actually want to insert a new div, click 
Cancel to dismiss the dialog.

If you’ve created a new style sheet using 
the Insert Div Tag dialog, your new style sheet 
is automatically attached to your document. 
If you created the new style sheet any other 
way, you’ll have to attach it manually. That’s 
covered in “Attaching a Style Sheet,” later in 
this chapter.

E If you said you wanted a new style sheet file, 
here’s where it’s actually created.

F Now that you’ve created a new style sheet file, 
you need to add rules to it.

G The new style sheet appears in the related files 
at the top of the document window.
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Moving Internal 
Styles to External
There are a number of reasons why your 
pages might have internal styles instead 
of using an external style sheet: possibly 
they’re from an older site (when that was 
more common), or possibly you used 
internal styles to test your layout. But now 
your internal style sheet is ready to live on 
its own, so your styles need to come out of 
your Web page and into a stand-alone file, 
because external style sheets are much 
easier to maintain and a single sheet can 
apply to many different HTML pages in 
your site.

To move styles:
1. Open the Web page that contains the 

style (or styles) you want to move. In 
the CSS Styles panel, make sure that 
you’re in All mode. Select the rules 
that you want to move, right-click, and 
choose Move CSS Rules from the con-
text menu. The Move To External Style 
Sheet dialog appears A.

A To move a rule to an external style sheet, bring up the Move To External Style 
Sheet dialog.
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2. If you are moving the rules to an exist-
ing external style sheet (the default), 
choose it from the pop-up menu and 
click OK. If the sheet you want isn’t 
listed, click Browse, find the sheet in the 
resulting Find Style Sheet File dialog, 
and click OK.

or

If you want to move the rules to a new 
style sheet, click “A new style sheet” and 
then click OK. You should be prompted 
with the correct place to save your file. 
Come up with a good, descriptive name 
(ending in .css) and click Save.

Your rules will be moved to the style 
sheet, and the style sheet will be 
attached to the current page (if that’s 
not already the case).

When you moved internal styles to exter-
nal in versions of Dreamweaver prior to CS3, 
the styles were only copied, not moved. You 
no longer have to manually attach the style 
sheet and then delete the styles from the cur-
rent document, because Dreamweaver does it 
all for you.

If your external style sheet already con-
tains any rules with the same name as the rules 
you’re moving, Dreamweaver displays a dialog 
B. You can choose if you want both rules in 
the style sheet or just the previous version.

B If you’re moving a rule that might cause a collision, Dreamweaver 
warns you about the problem.
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Attaching a 
Style Sheet
It doesn’t do you any good to create a style 
sheet if your Web pages don’t know about 
it. For a Web page to use an external style 
sheet, that style sheet must be attached to 
the Web page.

To attach a style sheet:
1. Click the Attach Style Sheet icon at the 

bottom of the CSS Styles panel (see 
figure C in “Renaming Styles”).

or

Right-click in the CSS Styles panel and 
choose Attach Style Sheet A.

or

From the HTML tab of the Property 
inspector, choose Attach Style Sheet 
from the Class pop-up menu (see figure 
A in “Renaming Styles”).

2. The Attach External Style Sheet dialog 
appears B. Click the Browse button 
to bring up the Select Style Sheet File 
dialog C. Navigate to an existing style 
sheet, select it, and click OK.

3. Back in the Attach External Style Sheet 
dialog, select Add as Link if it isn’t 
already chosen, and click OK to attach 
the style sheet. If your style sheet 
includes any rules that affect the active 
document, you’ll see those changes 
reflected immediately.

A There are at least two ways to 
attach a style sheet from the CSS 
Styles panel.

B Choose which style sheet you want to attach to 
your Web page and how you want to attach it.

C Choose which style sheet file to attach by 
browsing for it.
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Take a look at the All Rules pane of the 
CSS Styles panel. Notice that your style sheet 
is now included, and all of its properties can 
be viewed.

You’re offered a choice of using link or 
import to attach your style sheet. Each has its 
advantages: link, the default choice, works in 
more browsers, whereas import allows you 
to nest style sheets (that is, you can attach a 
style sheet using import, and then that style 
sheet can include an import of another style 
sheet, and so on).

You can use both link and import in the 
same document. That’s a handy way to use 
two style sheets, where the link attaches 
a bare-bones style sheet and the import 
attaches a more complex style sheet that very 
old browsers (such as Netscape 4.x) can’t 
handle.

When attaching a style sheet, you’re also 
offered a choice of media in the Attach Exter-
nal Style Sheet dialog. Among the choices 
included in the Media pop-up menu are all, 
handheld, print, projection, and screen D. It’s 
also acceptable to use no media type at all; in 
that case, the style sheet applies to all media 
types. And finally, you can also enter a list of 
media types (comma-separated) if you want 
your style sheet to apply to some media types 
but not others.

If you set the media type for your style 
sheet, you can test it by choosing View > Style 
Rendering and picking which media type to 
view. When you do this, though, remember that 
few browsers offer full support for media types.

D Media options are set here. 
For instance, if you want your style 
sheet to apply only when the page is 
printed, choose the print media type.
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Using Drag-and-Drop  
Styles
If you’ve found all the methods so far 
for dealing with style management to be 
somewhat complicated, then here’s what 
you’ve been wishing you could do: drag 
and drop styles.

Moving styles inside a document
As mentioned in the Chapter 7 sidebar 
“External, Internal, and Inline: Look Ma, It’s 
the Cascade,” where style rules are physi-
cally located determines which rules take 
precedence when there’s a conflict. If you 
have two rules that conflict inside a docu-
ment (either a Web page or a style sheet) 
and you want the one that’s currently being 
overridden to dominate, all you have to do 
is drag that rule below the other.

To move a style inside a document:
1. Open the Web page or style sheet that 

contains the style (or styles) you want 
to move. In the CSS Styles panel, make 
sure that you’re in All mode, select the 
rules that you want to move, and drag 
them to their new location A. A blue line 
(a black line on the Mac) appears show-
ing where the rules will be relocated.

On the Mac, a ghostly version of the 
style name moves with the cursor. 
On Windows, a small document icon 
appears instead.

2. When you’re happy with the new loca-
tion, release the mouse, and Dream-
weaver moves the rules for you.

A You can see which style it 
is you’re dragging while you’re 
dragging it.
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Moving styles from one 
document to another
Not only can you move styles inside a 
document, but you can also move them 
from document to document—whether the 
documents are style sheets or Web pages.

To move a style from one 
document to another:
1. Open a Web page that either links to 

two style sheets or that contains the 
style (or styles) and also links to an 
external style sheet. In the CSS Styles 
panel, make sure that you’re in All 
mode and that both files are displayed 
(if no external style sheet is displayed, 
follow the directions in “Attaching a 
Style Sheet”). Select the rules that you 
want to move, and drag them to their 
new location B. A line appears show-
ing where the rules will be relocated.

2. When you’re happy with the new loca-
tion, release the mouse, and Dream-
weaver moves the rules for you.

If you want to copy a style rule (that is, 
you want it to end up in both the original docu-
ment and the target document), hold down the 
Ctrl (Opt) key while dragging the rules.

If you’re moving a style rule into a docu-
ment that already contains a rule with that 
name, you’ll get a warning dialog like the 
one in figure B in “Moving Internal Styles 
to External.”

B On either platform, you can drag multiple style 
rules at one time.
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Using CSS Inspection
Laying out pages with CSS can be frustrat-
ing because it can be difficult to tell which 
elements are where and why. Thankfully, 
Dreamweaver has a few clever features 
that make creating CSS-based layouts 
much simpler. CSS inspection, added in 
CS5, is one of the handy ways to tell you 
just what’s going on in a selected area.

CSS inspection works with Live view mode 
to visually display the box model for an 
element. Hover over an element on your 
page, and it displays with an aqua back-
ground, yellow margins, lavender padding, 
and gray borders A. But that’s not all—as 
you hover over various parts of your docu-
ment, the CSS Styles panel (in Current 
mode) dynamically updates to display the 
rules currently in effect.

Turning on Inspect mode:
Click the Live view button and then the 
Inspect button in the Document toolbar 
to enable both CSS inspection and Live 
view B.

or

Choose View > Inspect to enable both CSS 
inspection and Live view.

or

Press Alt-Shift-F11 (Opt-Shift-F11) to enable 
both CSS inspection and Live view.

or

While in Live view mode, right-click the 
document and choose Inspect from the 
context menu C.

A Inspecting an element shows the margins, 
padding, and borders.

B Click the Live View button, and the Inspect 
Mode button appears.

C When in 
Live view, you 
can inspect 
any element 
by right-
clicking it.



ptg8274339

Managing Styles 259

Modifying styles with 
CSS inspection:
1. While in Inspect mode, hover over any 

section of your document A to display 
the box model for that element.

2. If you have a problem with how an ele-
ment displays, click the element, freez-
ing Inspect mode. When CSS inspection 
is frozen, the colors remain visible and 
don’t change when you move the cursor.

3. In the CSS Styles panel, change a rule, 
and the colored borders around the ele-
ment update to match your change.

4. Click anywhere in your document to get 
rid of the colors.

D Dreamweaver wants you to know the right way to use Inspect mode.

E But if you don’t want to see this suggestion 
again, you can turn it off.

To leave both Inspect mode and Live view, 
just click the Live View button. You can’t be in 
Inspect mode if you aren’t also in Live view.

Dreamweaver has definite opinions 
about how you ought to work with CSS 
inspection, and it says so every time you turn 
it on D. If you click More Info, you’ll see E, 
which says that if you’re in CSS Inspect mode, 
you should also be in Split view with Live 
Code view on, and that the CSS Styles panel 
should display Current mode. If you get tired 
of seeing this, just select “Don’t show me this 
message again.”
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Using the Visual Aids
If you’ve tried CSS Inspection and wished 
you could apply it to an entire page, you 
want what Dreamweaver refers to as 
visual aids.

A shows our example CSS-based page 
with all visual aids turned off, which is 
fine. But if we had a problem, it would be 
difficult to tell where each div begins and 
ends. That’s where the visual aids shine.

The Visual Aids menu is found in the 
Document toolbar. Although it looks like a 
button, that little downward facing arrow 
means that it’s actually a pop-up menu. If 
you click it, you’ll see the options shown 
in B. Or, you can choose View > Visual 
Aids and then select any of the submenu 
options C.

To turn each visual aid on or off, choose it 
from the menu to toggle its check mark, 
or you can choose Hide All (Ctrl-Shift-I or 
Cmd-Shift-I) to turn them all off temporarily. 
For day-to-day use, we keep CSS Layout 
Backgrounds turned off and CSS Lay-
out Box Model and CSS Layout Outlines 
turned on.

A Here’s our standard page.

B Here’s the Visual Aids menu in the 
Document toolbar.

C You can also access the Visual Aids menu via 
the menu bar.
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Here’s a rundown of the CSS-related items 
in these menus:

n	 CSS Layout Backgrounds: Put on your 
sunglasses and turn on CSS Layout 
Backgrounds D. With this aid, Dream-
weaver assigns a different background 
color for every layout block. If you’ve 
already set a background color, that will 
go away, as will background images—
note that you can see the header logo, 
but you can’t see the header back-
ground color.

Dreamweaver’s documentation 
describes the color choices as “visually 
distinctive,” but we prefer to not beat 
around the bush: we just call them loud 
and bright. Sorry, but there’s no way to 
change the color choices. On the other 
hand, the garishness makes it very clear 
which div is which.

n	 CSS Layout Box Model: You’ve seen 
the Layout Box Model aid E used 
previously. When enabled, it shows 
just the selected element, including its 
margin, borders, and padding. Here, the 
a tag has varying amounts of padding 
on each side. When this visual aid is 
enabled, each is shown visually on the 
document along with the dimensions of 
the element.

n	 CSS Layout Outlines: The CSS Layout 
Outlines option simply puts a dashed 
line around the border of each layout 
block F. It can be tricky to see what 
your borders are set to when this is on, 
and you should also keep in mind that 
the dashed line includes the padding 
but excludes the margins.

D CSS layout backgrounds are gaudy but useful.

E The CSS 
Layout Box Model 
option shows you 
the exact limits 
of the currently 
selected element.

F  CSS layout outlines 
give you a subtle 
way of telling your 
elements apart.
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Experimenting with 
CSS Enable/Disable
Another way to debug CSS is to enable 
and disable rules. Adobe made this easy to 
do in CS5 with CSS Enable/Disable, which 
is available on the CSS Styles panel.

To use CSS Enable/Disable:
1. In the Properties pane of the CSS Styles 

panel, move your cursor just to the left 
of a property name. You should see a 
gray Disable CSS Property icon appear 
(it looks like the universal sign for 
“No”: the circle with the diagonal slash 
through it) A. Click the icon, which will 
turn it red. If you are in Current mode, 
a red Disable CSS Property icon also 
appears next to the property name in 
the Summary pane B.

or

In the Properties pane of the CSS Styles 
panel, select a property. Underneath 
the Properties pane, in the bottom part 
of the panel on the right side, click the 
gray Disable button C, which turns 
the CSS Property icon to the left of 
the property red. If you are in Current 
mode, a red Disable CSS Property icon 
also appears next to the property name 
in the Summary pane.

or

With the CSS Styles panel in Current 
mode, find a property in the Summary 
pane that you want to disable. Click the 
gray Disable CSS Property icon to its 
left, which turns it red. In the Properties 
pane, the selected property will also 
display the red Disable CSS Property 
icon.

or

A Hover just to the left of a 
property, and the Disable CSS 
Property icon appears.

B Disabling in either pane 
shows the result in both.

C You can also disable a property 
via the button at the bottom of the 
CSS Properties pane.



ptg8274339

Managing Styles 263

With the CSS Styles panel in Current 
mode, find a property in the Summary 
pane that you want to disable. Select 
the property, click the gray Disable but-
ton under the Properties pane, and the 
red Disable CSS Property icon appears 
next to the property name. In the 
Properties pane, the selected property 
will also display the red Disable CSS 
Property icon.

2. If your document is open in Design 
view, Dreamweaver displays the page 
without that rule. If you are in Code 
view, Dreamweaver scrolls the source 
to show the rule commented out. If 
you’re in Split view, you’ll see both D.

3. To re-enable a disabled rule, click the 
red Disable CSS Property icon in either 
the Properties pane or the Summary 
pane E.

D Disable rules in the CSS Styles panel, and you’ll see changes in both the 
page display and the CSS source code.

E To re-enable a property, 
simply toggle the icon.

If you select a property or disable a 
property from the Summary pane, the Rules 
and Properties panes update to show the 
affected rule.

If the open document is an HTML file in 
Code or Split view, and the rule you disabled 
is in an external CSS file, the commented-out 
code doesn’t automatically display.

Disabled rules aren’t only disabled within 
Dreamweaver. If you disable a rule, save the 
file, and then upload your changes to the live 
server, the rule stays disabled until you enable 
it again. If you want similar functionality that 
only applies while testing, use design-time style 
sheets (described in the next task) instead.
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Using Design-Time 
Style Sheets
It’s common when working with CSS-based 
layouts to want something to display in a 
particular way while you’re designing, but 
only while you’re designing—that is, during 
design time. You can tell Dreamweaver 
to use certain style sheets only at design 
time, and even to turn off certain style 
sheets only at design time.

As with the previous visual aids, you 
wouldn’t want your real Web site to look 
like that, but it’s handy while trying to 
do those last few tweaks or track down 
a problem. If you want something that 
Dreamweaver’s built-in visual aids don’t 
provide, design-time style sheets allow you 
to create your own.

To show a design-time style sheet:
1. Create and save a new style sheet 

containing the style rules that should 
display only inside Dreamweaver. A 
shows an example that contains two 
simple rules: p is set to display:block, 
and h1 gets a background color of 
orange. See the “CSS Layout Blocks” 
sidebar for an explanation of why you’d 
want to modify the p tag.

2. To choose a design-time style sheet, 
either choose Format > CSS Styles > 
Design-time B or right-click inside 
the CSS Styles panel and choose 
Design-time from the context menu C. 
The Design-Time Style Sheets dialog 
appears D.

A This very 
simple style 
sheet gives you 
extra information 
in Dreamweaver.

B Design-time style sheets can be chosen from 
the Format menu.

C Or they can be 
chosen from the 
CSS panel.

D But either way, you end up at the Design-Time 
Style Sheets dialog.
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3. To add a style sheet that shows only at 
design time, click the upper plus button. 
The Select File dialog appears E. Navi-
gate to your new style sheet, choose it, 
and click OK.

4. Back in the Design-Time Style Sheets 
dialog, your new style sheet is now 
listed next to “Show only at design 
time.” If it’s correct, click OK.

5. The Web page now appears with some 
slight changes F: the h1 title has an 
orange background, and paragraphs 
can be identified using the CSS Layout 
Box Model visual aid. If we use the 
CSS Layout Backgrounds visual aid G, 
paragraphs are now clearly distinct from 
other elements on the page.

E The Select File dialog lets you choose your 
design-time style sheet.

F Now the h1 is all lit up.

G Paragraphs are delineated when the 
background visual aid is used.

CSS Layout Blocks
Dreamweaver uses what it refers to as 
CSS layout blocks, which are:

. A div without display:inline

. An element with display:block

. An element with position:absolute

. An element with position:relative

CSS layout blocks are used by the visual 
aids and design-time style sheets to help 
designers understand how the parts of 
a CSS-based layout work together on 
your page.

For instance, say you have a design-
time style sheet that assigns position:
relative to all of your links (that is, to 
all a tags). When you then turn on CSS 
Layout Backgrounds, all of your links will 
be their own bright color, allowing you to 
easily pick them out.
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To hide a style sheet at design time:
Follow steps 2 through 4 from “To show a 
design-time style sheet,” but click the lower 
plus button instead. Select a style sheet to 
hide, and click OK.

In H, the main style sheet for the page has 
been hidden. This allows you to see the 
page without the effect of styles or to see 
the page with some styles but not others. 
This can be a big help when trying to track 
down CSS-related issues.

To remove a design-time style sheet:
1. Bring up the Design-Time Style Sheets 

dialog, as described earlier. Select the 
style sheet to remove, and click the 
minus button above the style sheet 
name in either box of the dialog. If you 
have multiple style sheets to remove, 
continue to delete them in this way.

2. Click OK, and your Web page displays 
closer to the way it will appear on 
the Web.

When used in conjunction with Dream-
weaver’s CSS layout blocks, design-time style 
sheets are an extremely powerful tool.

Despite how it looks, your document is 
not actually being changed—only the way the 
page is displayed is being changed. Design-
time style sheets are not really added to or 
removed from your Web page: Dreamweaver 
handles it all internally.

Don’t forget that you also have the Style 
Rendering toolbar (covered in Chapter 1), 
which you can use to display your page as it 
would appear with print style sheets, hand-
held style sheets, projection style sheets, and 
so on. You can also use the Style Rendering 
toolbar to turn off the display of style sheets 
altogether.

It’s worth noting that when you remove 
design-time style sheets from your document, 
you’re not actually deleting the style sheet—
you’re just removing the relationship between 
your page and the style sheet.

H Style sheets can also be hidden, as shown on 
this plain page.
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Inserting Tables

You will often use tables on Web pages to 
present tabular information—that is, data 
best presented in the form of rows and 
columns. It’s also possible to use tables 
for layout—that is, to align text and images 
on the page—but as you’ll see later in the 
chapter, in most cases you should be using 
CSS for layout instead.

In this chapter, you’ll learn how to create 
and format tables, ensure that tables and 
their content look the way you intend, work 
with Dreamweaver’s many table tools, and 
save time when you’re using tables.

In This Chapter
Moving Away from Tables for Layout 268

Creating a Table 270

Selecting Table Elements 274

Making Table Selections Easier 276

Adding Rows and Columns 278

Merging and Splitting Cells 280

Resizing Table Elements 281
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Moving Away from 
Tables for Layout
In previous years, one of the most wide-
spread uses for a table was as a layout 
device (sometimes called layout tables). 
You can create tables on your page and 
then use the table cells to contain the text 
and images on the page. Because you 
have good control over the size of the 
cells and the position of their boundaries, 
you can line up and lay out elements on 
the page with precision, though it often 
requires some extremely complex tables. 
By hiding the borders of the table cells, the 
site visitor doesn’t notice the tables. This, 
up until the last several years, is how most 
nicely designed Web pages were created.

However, there are many problems with 
using tables for layout. First of all, the table 
has nothing to do with the content of the 
page (the information your visitor sees); 
all it does is affect the presentation of 
the content. One of the biggest benefits 
of CSS is that it separates content from 
presentation. As a result, you can com-
pletely redesign CSS-based sites largely by 
changing one file, the style sheet. If your 
presentation is mixed with your content, as 
it is with a table-based layout, it makes site 
redesigns difficult and expensive. Similarly, 
tables make it difficult to maintain visual 
consistency throughout a site (because the 
layout tables on different pages may not 
be the same).

So that’s what is wrong with tables from 
the standpoint of the Web designer, but 
there are problems for the site visitor, too. 
Tables make the size of an HTML page 
unnecessarily large (costing you extra 
bandwidth charges), and site visitors must 
download the layout tables on every page 
they visit in the site (ditto). Pages load more 
slowly than with a CSS-based layout, and 
slow page loads drive visitors away. Table-
based pages are also much more difficult 
to read by users with disabilities and by 
visitors using mobile devices, such as cell 
phones and tablets.

Tables were necessary for good-looking 
Web sites back in 1997 because the Web 
browsers of the day had many limitations, 
not the least of which was that none of 
them supported the then-emerging CSS 
standards for layout. But all modern brows-
ers have good support for using CSS for 
layout (including browsers such as Internet 
Explorer 8 and 9, Mozilla Firefox, Google 
Chrome, Apple Safari, and Opera). The 
vast majority of users of the Web now use 
Web browsers that can handle CSS-based 
layouts just fine. And most mobile device 
browsers are based on the WebKit frame-
work (also used by Safari and Chrome), so 
they display CSS well.

As a result, you can (and should!) use 
Dreamweaver to build great-looking, 
CSS-based sites that are faster to load, 
accessible for everyone, and easier for you 
to redesign and maintain. To learn more 
about laying out your pages with CSS, 
see Chapter 8.
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Table-based layout was pervasive for most 
of the first decade of the Web, and Dream-
weaver can still be used to create page 
layouts with tables. But Dreamweaver CS4 
removed a set of tools, called Table Layout 
Mode, that made it easier to use tables for 
layout. The page templates that come with 
Dreamweaver were completely revised 
with CS5 to use CSS layout rather than 
tables. Adobe has clearly—and correctly—
endorsed CSS for layout, and it keeps 
adding CSS features to Dreamweaver to 
support that direction.

By the way, even with sites that use tables 
for layout, you can still use CSS to style the 
text inside the tables. Some CSS markup 
is devoted to styling text, and some is 
devoted to positioning elements on the 
page. You can use the styling kind of CSS 
to make your text look good, even inside a 
table. You just shouldn’t mix the positioning 
elements of CSS with tables; choose one 
method or the other for positioning ele-
ments on your pages.

By using CSS for layout, tables can go 
back to what they were originally intended 
to do—namely, to display tabular informa-
tion that lines up in neat rows and columns. 
Think of a baseball box score or a timeta-
ble showing a bus schedule—both perfect 
candidates for tables.



ptg8274339

270 Chapter 10

Creating a Table
Tables typically consist of one or more rows 
and one or more columns. Each rectangular 
area at the intersection of a row and column 
is called a cell. Cells contain the page’s 
text or images, and items within a cell can’t 
extend past the cell’s boundaries.

You can insert a table anywhere on a page, 
even within another table (this is called 
nesting a table). By default, Dreamweaver 
creates tables with three rows and three 
columns, but you can easily change that 
format during the process of inserting the 
table. After you do make changes, Dream-
weaver remembers them and uses them as 
the defaults for the next table you create.

To add a table to your page:
1. Place the insertion point where you 

want the table to appear.

2. In the Layout category of the Insert 
panel, click the Table button A.

or

Choose Insert > Table, or press Ctrl-Alt-
T (Cmd-Opt-T).

The Table dialog appears B.

3. Enter the number of rows you want in 
the table, and press Tab.

4. Enter the number of columns you want 
in the table, and press Tab.

5. In the Table width text box, enter a 
number that will be either in pixels or a 
percentage of the page width, and then 
choose the units from the pop-up menu 
to the right of the text box C.

A You’ll use the 
Layout category 
of the Insert 
panel to add 
tables to your 
pages.

B The Table dialog lets you get started building 
a table.

C You can set 
the width of 
your table either 
in pixels or as 
a percentage 
of the browser 
page width.
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6. Set one or more (or none) of the fol-
lowing (see the “Anatomy of a Table” 
sidebar for explanations of the settings):

>	 Enter a figure in the Border thickness 
text box to set the size of the bor-
der, in pixels, that will be displayed 
between cells.

>	 Enter a figure in the Cell padding 
text box to set the amount of space, 
in pixels, between the content in the 
cells and the cell border.

>	 Enter a figure in the Cell spacing text 
box to set the number of pixels of 
space between cells.

7. In the Header section, choose the kind 
of header you want: None, Left, Top, or 
Both. The icons for the headers tell you 
what each choice looks like.

8. (Optional, but recommended.) In the 
Accessibility section, enter a caption 
for the table. Caption text appears in all 
browsers. If you enter text in the Sum-
mary text box, that text appears only in 
screen readers for the visually disabled.

9. Click OK.

The table appears in your page D. 
When a table is selected, as in the 
figure, or when the insertion point is in 
a table cell, Dreamweaver shows green 
dimension lines above or below the 
table. The top dimension line shows the 
width of the table in pixels. Each column 
also has a dimension line, which shows 
the width of the column in pixels if you 
have set a fixed width for the column. 
Columns with widths relative to the 
table width show dimension lines (so 
you can easily see each column) with-
out pixel values. These dimension lines 
appear only in Dreamweaver’s Design 
view, not in a Web browser.

D The green dimension lines tell you the width 
of the table in pixels. The dimension lines above 
each column do not show pixel widths in this figure 
because the columns are set to be a percentage 
of the table width.
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To insert a table within a table, place the 
insertion point inside a cell of an existing table 
and then choose either of the methods in step 2. 
The new table appears inside the first table E.

You don’t have to get the number of 
rows and columns right the first time; you can 
always add or subtract them later. See the sec-
tions “Adding Rows and Columns” and “Delet-
ing Table Elements” later in this chapter.

If you don’t want to see the dimension 
lines above tables, you can turn them off by 
choosing View > Visual Aids > Table Widths, 
which removes the check mark from the 
menu item.

Captions are actually part of the table. 
When you move the table, the caption moves 
with it. Table captions appear above the table 
by default, but you can change that in the 
code. Switch to Code view, and then find the 
table’s <caption> tag. Click inside the tag to 
put the insertion point after the word, and then 
press the spacebar. A pop-up menu appears 
with the <caption> tag’s possible attributes. 
Choose align (which inserts align="" into 
the code and gives you another pop-up menu 
with the alignment values); then choose one of 
the five possible alignments (bottom, center, 
left, right, top) from the pop-up menu.

To edit a caption, select it in Design view 
and type over the existing text. To change the 
horizontal alignment of the caption in relation 
to the table, place the insertion point in the 
caption and then right-click and pick one of the 
choices (left, center, right, or justify) 
from the Align submenu in the context menu.

E You can nest a second table inside any cell of 
an existing table.
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Anatomy of a Table
Besides rows and columns, tables have several 
other attributes that affect how they look. You’ll 
find controls for these items in the Property 
inspector when you select a table.

. Border thickness is the width of the border 
around the table, in pixels F. Dreamweaver 
sets it to 1 pixel by default, which results in a 
thin border. If the border thickness is set to 
a nonzero amount, you will also see a bor-
der between table cells. You’ll often see the 
border thickness set to 0 on pages that are 
using tables for page layout and the designer 
doesn’t want you to see borders. Borders 
with 0 thickness appear in Design view with 
dotted borders.

. Cell padding is the amount of space, in pixels, 
between a cell’s borders and its content G. 
Use this setting to give cell content more 
breathing room within cells. If you don’t specify 
a number here, most browsers use a default 
value of 1 pixel.

. Cell spacing is the amount of space between 
each table cell, also measured in pixels H. If 
you don’t specify a number here, most brows-
ers use a default value of 2 pixels. Wide cell 
spacing gives the table a look that is very 
1996, so use this setting with care.

The following table attributes can’t be set in 
the Property inspector, but can be changed in 
Code view:

. Table header tags part of the table as a 
header. The header is formatted as bold and 
centered, but more important, it has the <th>
HTML tag, which allows screen readers used 
by visually disabled users to correctly read 
the table. It’s better to use a table header tag 
in Dreamweaver than to manually make cells 
bold and centered.

. Border color is the color of the border around 
the table and between the table’s cells. This 
gives a dated look, so use with care.

F The same table with a border thickness 
of 0 pixels (top), 1 pixel (middle), and 10 pixels 
(bottom). Cell padding and cell spacing are 
set to zero.

G Cell padding has been set to 5 pixels, 
which gives more whitespace around the 
table contents.

H Cell spacing of 7 pixels creates a wide 
border between cells—a dated look.
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Selecting Table 
Elements
To work effectively with a table, you’ll need 
to know how to select its elements. You 
can select an entire table; one or more 
rows and columns; an individual cell or 
multiple cells; and nonadjacent cells, rows, 
or columns.

To select the entire table:
Click the table’s upper-left corner.

or

Click the bottom or the right edge of 
the table.

or

Click in the table, and then choose  
Modify > Table > Select Table.

A border with resize handles appears 
around the table A. Dimension lines 
also appear.

Clicking any interior cell border also 
selects the entire table.

To select an entire row:
1. Place the pointer at the left edge of 

a row.

The pointer becomes an arrow.

2. Click to select the entire row B.

You can click and drag to select mul-
tiple rows.

The cell borders for the selected row 
highlight.

To select an entire column:
1. Place the pointer at the top edge of 

a column.

The pointer becomes an arrow.

A You can tell this table is selected because it 
has a thick border around its edges with resize 
handles.

B When you move the cursor to the left edge of a 
table and the pointer changes to an arrow, you can 
click to select the whole row.
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2. Click to select the entire column C.

You can click and drag to select mul-
tiple columns.

or

Click the triangle in the dimension line 
above any column to display a pop-up 
menu, then choose Select Column D.

The cell borders for the selected col-
umn highlight.

To select a single cell:
Click and drag in the cell.

or

Click in the cell, and then choose Edit > 
Select All or press Ctrl-A (Cmd-A).

or

If the cell is empty, triple-click inside 
the cell.

The cell highlights to show it has been 
selected.

To select multiple adjacent cells:
Click in the first cell you want to select, and 
drag to the last cell.

or

Click in the first cell you want to select, 
hold down Shift, and then click in the last 
cell. All the cells in between will also be 
selected. You can also Shift-click in this 
manner to select rows or columns.

To select nonadjacent cells:
Ctrl-click (Cmd-click) in the first cell, hold 
down Ctrl (Cmd), and then click the other 
cells you want to select E. You can also 
Ctrl-click (Cmd-click) to select nonadjacent 
rows or columns.

C The pointer also changes to an arrow above 
columns. Click to select the column.

D If you prefer, you can use the pop-up column 
menu to select the column.

E By Ctrl-clicking (Cmd-clicking), you can select 
nonadjacent cells.
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Making Table 
Selections Easier
When you’re selecting tables and table 
elements, it can sometimes be difficult 
to select the particular part you’re after, 
especially if some of the table cells are nar-
row horizontally or vertically A. To make 
things easier on you, Dreamweaver offers 
Expanded Tables mode, which tempo-
rarily adds a border (if there is none) and 
increases the cell padding and cell spac-
ing. These changes aren’t permanent and 
don’t show up in a Web browser.

A Because they are so small, it could 
be difficult to select the cells under 
Q3 or Q4.
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To enter Expanded Tables mode:
1. Choose View > Table Mode > Expanded 

Tables Mode.

or

In the Layout category of the Insert 
panel, click the Expanded button B.

or

Press Alt-F6 (Opt-F6).

The Design view switches to Expanded 
Tables mode C, changing the appear-
ance of all the tables in the document.

An indicator bar appears at the top of 
the document window to let you know 
you’re in the Expanded Tables mode.

2. Select and edit table elements as 
you like.

Remember that Expanded Tables mode 
is not a WYSIWYG (What You See Is What You 
Get) view, as is the standard Design view. 
Always switch out of Expanded Tables mode 
before you do any serious table formatting. 
When you are in Expanded Tables mode, you 
cannot use Live view.

To exit Expanded Tables mode:
Choose View > Table Mode > Expanded 
Tables Mode.

or

In the Layout category of the Insert panel, 
click the Standard button.

or

Click the [exit] link in the Expanded Tables 
mode indicator bar at the top of the docu-
ment window.

or

Press Alt-F6 (Opt-F6).

B Click the 
Expanded button 
in the Layout 
category of the 
Insert panel to enter 
Expanded Tables 
mode.

C Expanded Tables mode makes all the tables 
in the document bigger, so you can select table 
elements more easily. Note the indicator bar at 
the top of the document window that tells you that 
you’re in a special mode.
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Adding Rows 
and Columns
You may find you need to add additional 
content to your table. Dreamweaver allows 
you to add rows or columns to your table, 
either singly or in multiples.

To insert a single row in a table:
1. Place the insertion point in a table cell.

2. In the Layout category of the Insert 
panel, click either the Insert Row Above 
or Insert Row Below button A. A new 
row appears above or below the row 
where the insertion point is.

or

Choose Insert > Table Objects > Insert 
Row Above, or press Ctrl-M (Cmd-M).

or

Choose Insert > Table Objects > Insert 
Row Below.

or

Right-click in the cell, and choose 
Table > Insert Row from the context 
menu. This adds a row above the row 
where the insertion point is.

The row appears in your table B.

If the insertion point is in the last cell of 
the table, pressing Tab adds a row to the bot-
tom of the table.

To insert a single column in a table:
1. Place the insertion point in a table cell.

2. In the Layout category of the Insert 
panel, click either the Insert Column to 
the Left or Insert Column to the Right 
button. A new column appears to the 
left or right of the column where the 
insertion point is.

Insert Row 
buttons

Insert Column 
buttons

A You’ll use the Layout category 
of the Insert panel to make 
changes to tables.

B A new row has appeared in the 
middle of this table.
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or

Choose Insert > Table Objects > Insert 
Column to the Left.

or

Choose Insert > Table Objects > Insert 
Column to the Right.

or

Right-click in the cell, and from the 
context menu choose Table > Insert 
Column. This adds a column to the 
left of the column where the insertion 
point is.

The column appears in your table.

To insert multiple rows or 
columns into a table:
1. Place the insertion point in a table cell.

2. Right-click, and then choose Table > 
Insert Rows or Columns from the con-
text menu.

or

Choose Modify > Table > Insert Rows 
or Columns.

The Insert Rows or Columns dialog 
appears C.

3. Select either the Rows or Columns 
radio button.

4. Enter the number of rows or col-
umns you want to add. To increase or 
decrease the number, you can either 
type a number into the text box or use 
the arrow buttons next to the text box.

5. Next to Where, click the appropriate 
button to select the location of the new 
rows or columns.

6. Click OK.

The rows or columns appear in your 
table.

C Use the Insert Rows or Columns dialog to 
add multiple rows or columns to a table in one 
operation.
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Merging and 
Splitting Cells
Dreamweaver lets you combine two or 
more adjacent cells into one larger cell 
(called merging) or split a single cell into 
two or more cells.

To merge cells:
1. Select the cells you want to merge.

2. Choose Modify > Table > Merge Cells, 
or press Ctrl-Alt-M (Cmd-Opt-M).

or

Right-click, and then choose Table > 
Merge Cells from the context menu.

The cells merge A.

You can merge an entire row or column 
into one cell.

To split cells:
1. Place the insertion point in the cell you 

want to split into two or more cells.

2. Choose Modify > Table > Split Cell, or 
press Ctrl-Alt-S (Cmd-Opt-S).

or

Right-click, and then choose Table > 
Split Cell from the context menu.

The Split Cell dialog appears B.

3. Choose whether to split the cell into 
rows or columns.

4. Enter the number of new rows or col-
umns for the split.

5. Click OK.

The cell divides into two or more cells C.

Even if you select multiple cells, Dream-
weaver can split only one cell at a time. If you 
try to split multiple cells at once, the Split Cell 
menu item will be unavailable.

A The four cells at the left edge of this table (top) 
have been merged into one cell (bottom).

B You can use the Split Cell dialog to divide cells 
into multiple rows or columns.

C In this example, the center cell has been split 
into four cells.
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Resizing Table 
Elements
You can resize tables horizontally or verti-
cally, and also make columns wider and 
rows taller. You can resize table elements 
by clicking and dragging, or you can 
specify the width of tables numerically, and 
numerically specify the width and height of 
rows and columns.

To resize an entire table:
1. Click the bottom or the right edge of the 

table. The table will be selected, and 
a border with resize handles appears 
around it.

2. Drag one of the resize handles. To 
widen the table, drag the handle on 
the right edge of the table; to make the 
table taller, drag the handle on the bot-
tom edge of the table; and to make the 
table grow in both directions simultane-
ously, drag the handle at the bottom-
right corner of the table. Holding down 
the Shift key as you drag maintains the 
proportions of the table.

To resize a table numerically:
1. Click the bottom or the right edge of 

the table to select it.

2. In the Property inspector, enter a num-
ber in the W (for width) field A. In the 
pop-up menu next to the field, choose 
either %, which makes the table width 
a percentage of the overall width of the 
page, or pixels, to set an absolute size 
for the table width.

3. Press the Tab key or click in the docu-
ment window to apply your changes.

A Use the Property inspector to change the width 
of a table numerically.



ptg8274339

282 Chapter 10

To resize columns:
1. Select the column you want to resize.

2. Drag the column’s right border to make 
the column wider.

or

In the Property inspector, type a number 
in the W (for width) field B. The width 
unit is in pixels. Alternatively, in the 
document window, click the triangle in 
the dimension line above the column 
and choose Clear Column Width from 
the pop-up menu; this makes the col-
umn resize to fit the contents.

To resize rows:
1. Select the row you want to resize.

2. Drag the bottom border of the row to 
make the row taller.

or

In the Property inspector, type a number 
in the H (for height) field C. The height 
unit is in pixels.

If you set a width in percentage for a 
table, the table resizes based on the 
width of the user’s browser window. 
This may really change the look of your 
table. Be sure to preview the page in a 
Web browser and resize the browser 
window to see the effect.

B When you select a column, 
the Property inspector changes 
and you can numerically set the 
column’s width.

C Selecting a row allows you to 
numerically set the row’s height.
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Tables always stretch to fit the content 
inside the table.

Text inside cells usually wraps to fit the 
width of the cell. To force the cell to expand 
to the width of the text, you can turn off text 
wrapping on a cell-by-cell basis. Click in the 
cell, and then in the Property inspector, select 
the “No wrap” check box.

Don’t be misled into thinking you have 
ultimate control over row height and column 
width and therefore control over what your 
site visitor sees. Different browsers display 
content differently, and short of previewing 
your site with every browser ever made on 
every computer platform, there’s no way to be 
absolutely certain that your site visitor will see 
exactly what you intended.

Older versions of Dreamweaver had an 
H (Height) field in the Property inspector for 
the entire table. That is an invalid property 
for current HTML, so the field was removed in 
Dreamweaver CS3.

Clearing and Converting 
Table Values
When you have a table selected, there 
are four buttons in the Property inspec-
tor that can be very handy and save you 
a bunch of time D. These buttons clear 
the width and height values for the table, 
or convert table units from percent to pix-
els or vice versa.

Clear Column Widths and Clear Row 
Heights are great for collapsing a table 
to fit its contents. Convert Table Widths 
to Pixels lets you change widths from 
relative to fixed measurements. Con-
vert Table Widths to Percent does the 
opposite, converting a fixed-size table to 
a relative one.

Convert Table Widths to Pixels

Clear Column 
Widths

Convert Table 
Widths to Percent

Clear Row Heights

D Use these four buttons in the Property 
inspector to quickly clear width and height 
values or to convert tables to and from 
fixed widths.
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Deleting Table 
Elements
If you want to remove tables, rows, or col-
umns, you can make short work of the task.

To delete a table:
1. Select the table by clicking its right 

or bottom edge. A border with resize 
handles appears around the table.

2. Press Backspace (Delete).

To delete rows:
1. Select one or more rows.

2. Press Backspace (Delete).

or

Choose Modify > Table > Delete Row, or 
press Ctrl-Shift-M (Cmd-Shift-M).

or

Right-click the row, and then 
choose Table > Delete Row from the 
context menu.

The row disappears from the table.

To delete columns:
1. Select one or more columns.

2. Press Backspace (Delete).

or

Choose Modify > Table > Delete 
Column, or press Ctrl-Shift-minus key 
(Cmd-Shift-minus key).

or

Right-click the row, and then choose 
Table > Delete Column from the 
context menu.

The columns disappear from the table.
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Specifying Table 
Alignment
When you have a table and text together, 
you can set the alignment of the table, in 
some cases wrapping the text around the 
table A. You can choose from four differ-
ent alignments:

n	 Default uses the browser’s default 
alignment for tables (usually it places 
the table to the left side of the page). 
This setting prevents text from wrap-
ping around the table to the right.

n	 Left places the table to the left side 
of the page and allows text to wrap 
around the right side of the table.

n	 Center centers the table on the page 
with no text wrapping.

n	 Right places the table to the right side 
of the page and allows text to wrap 
around the left side of the table.

You can use the Property inspector to set 
table alignment. This applies HTML attri-
butes to the <table> tag, which is accept-
able but not really compliant with best 
practices. Instead, you should specify table 
alignment with a CSS style. See Chapter 7 
for more information.

To set table alignment:
1. Select the table you want to align.

2. In the Property inspector, choose the 
alignment you want from the Align  
pop-up menu.

The table moves to the alignment you 
selected.

A The effects of different types of table 
alignment. From top to bottom: Default, Left, 
Center, and Right alignments.
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Setting Cell Properties
Alignment of the text or images inside a 
cell requires using the Property inspector 
to set cell properties for each cell. You 
can use these alignment cell properties to 
set both the horizontal alignment and the 
vertical alignment. You can also set cell 
properties for the background color of the 
cell, and set the color of the cell border.

To set cell alignment:
1. Place the insertion point in the cell you 

want to format.

2. In the Property inspector, from the Horz 
pop-up menu choose Default, Left, Cen-
ter, or Right A.

The Default choice usually gives the 
same visual result as Left B.

3. From the Vert pop-up menu, choose 
Default, Top, Middle, Bottom, or 
Baseline.

The Default choice usually gives the 
same visual result as Middle. Baseline 
sets the cell alignment to match the 
baseline of the text within the cell and 
is usually used to align images and text 
that are inside the same cell. Baseline 
usually gives the same visual result as 
Bottom C.

A Use the Property inspector to set 
horizontal and vertical alignment for 
cell contents.

B Horizontal text alignment within a cell. From top 
to bottom: Left, Center, and Right text alignment.
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To set a cell background color:
1. Place the insertion point in the cell you 

want to format.

2. In the Property inspector, click the color 
well next to Bg to bring up the color 
picker and select the cell’s background 
color.

The cell’s background color changes.

Dreamweaver accomplishes this color 
change by adding an HTML attribute to 
the table cell, which is not considered 
a current best practice. Instead, you 
should apply table cell background 
color changes via CSS. See “Formatting 
Tables,” later in this chapter, for more 
information.

C Vertical text alignment within a cell. From top to 
bottom: Top, Middle, and Bottom alignment.
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Sorting Table Content
It’s not uncommon to enter data into a 
table, add more data, and then want to sort 
the whole thing. You asked for it, Dream-
weaver can do it. The program sorts by the 
content of any column in your table, either 
numerically or alphabetically, in ascending 
or descending order, and it can sort on two 
successive criteria.

There are some limitations to Dreamweav-
er’s sorting abilities. You cannot sort merged 
cells, and Dreamweaver doesn’t have the 
ability to sort part of a table, so you can’t, 
for example, have the program ignore the 
merged cells you used for your table’s title 
(though you can have the program include 
or ignore header rows). Dreamweaver 
displays an error message if you try to sort 
a table containing merged cells.

Another problem is that the sorting 
algorithm Dreamweaver uses isn’t terribly 
smart. For example, you can sort numeri-
cally, but Dreamweaver doesn’t understand 
dates in tables, so you’re liable to get sorts 
like this:

	 3/19/99

	 3/25/77

	 3/3/02

Dreamweaver sorted the dates numeri-
cally, reading left to right, which resulted in 
an incorrect sort.

Despite these restrictions, table sorting in 
Dreamweaver is useful—you just have to 
be aware of the limitations.
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To sort a table:
1. Place the insertion point in any cell of 

the table you want to sort.

2. Choose Commands > Sort Table.

The Sort Table dialog appears A.

3. From the Sort by pop-up menu, choose 
the column you want to use to sort 
the table.

4. In the Order pop-up menu on the left, 
choose whether to sort the column 
alphabetically or numerically.

5. In the Order pop-up menu on the right, 
choose whether to sort the column in 
ascending or descending order.

6. If you want to sort on a second set of 
criteria, repeat steps 3 through 5 and 
use the Then by set of pop-up menus.

7. Make any selections from the 
Options list.

By default, the “Sort includes the first 
row” option is not selected, because 
the first row of a table is frequently a 
header row. If your table doesn’t seem 
to be sorting properly, select this option.

8. Click OK.

Dreamweaver sorts your table accord-
ing to the criteria you selected.

Dreamweaver can’t sort by rows, just 
columns.

If you want a merged row at the top of 
your table, do the sort first and then merge the 
cells.

Be careful when you’re sorting numbers. 
If you accidentally leave the sort on Alphabeti-
cally, you’ll get an alphanumeric sort (1, 10, 
2, 20, 3, 30) instead of a numeric sort (1, 2, 3, 
10, 20, 30).

A The Sort Table dialog lets you sort the contents 
of your table either alphabetically or numerically.
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Formatting Tables
You can apply a CSS style to an entire 
table (which can change the look of the 
table), or you can apply a CSS style to 
selected table cells, which can change the 
look of the table contents.

When you use a CSS style to format a table, 
the table’s look is defined by instructions 
in a CSS style sheet. You can choose to 
have the table style apply to all tables in 
your document (if you use the style sheet to 
redefine the <table> tag), or you can create 
a custom CSS class for a particular kind of 
table you want to use, and apply the style to 
the table with the Property inspector.

To apply a CSS style to a table:
1. Select the table or table cells you want 

to format.

2. In the Property inspector, choose the 
style you want from the Class pop-up 
menu A.

The selection takes on the formatting 
from the CSS style you chose.

You can create, format, and save an 
empty table for later use. Just create 
and format the table, select it, and then 
save it as a snippet. See Chapter 16 for 
more about creating snippets.

A Apply a CSS 
style to a table in the 
Property inspector.
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Importing 
and Exporting 
Tabular Data
Because tables are best used for tabular 
data, it stands to reason that Dreamweaver 
has an easy way to import such data (from 
database programs or Microsoft Excel, for 
example) and turn it into a table. This data 
needs to be in the form of a delimited text 
file—that is, a file that includes the data, 
separated by some character, such as a 
tab, a comma, or another delimiter.

To explain how a delimited file works, 
imagine that you have some data that 
would be displayed well in a table, such as 
baseball standings. Each row of the table 
with the standings contains information on 
a team, and the different columns of the 
table contain the team’s name, number 
of wins, number of losses, and winning 
percentage, as in the example (shown 
in Excel) in A. To use this Excel data in 
Dreamweaver, you first need to export the 
data out of Excel as a delimited file, which 
is easy: You simply save a copy of the file 
in the “Text (Tab delimited)” format. This 
saves the data in the Excel worksheet as 
a plain text file. Each column of data is 
separated by a tab character, and each row 
of the data ends with a return character. 
Dreamweaver can then read this delimited 
text file and convert it into a table.

Dreamweaver can also do the reverse 
trick of turning the data in a table into a 
delimited text file. This allows you to export 
table data to Excel or a database program 
for further processing, or you can take a 
table on a Web page and move it to a word 
processor or page layout program such as 
Adobe InDesign.

A Tabular data to be imported into Dreamweaver 
often starts out as a Microsoft Excel worksheet.
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To import tabular data into a table:
1. Place the insertion point where you 

want the table to appear.

2. Choose File > Import > Tabular Data.

or

Choose Insert > Table Objects > Import 
Tabular Data.

The Import Tabular Data dialog 
appears B.

3. Click the Browse button to select the 
delimited data file.

The Open dialog appears.

4. Navigate to the data file, select it in the 
Open dialog, and then click Open.

The name of the data file appears in the 
Import Tabular Data dialog’s Data file 
text box.

5. From the Delimiter pop-up menu, 
choose the delimiter character used in 
the data file.

Your choices in this pop-up menu are 
Tab, Comma, Semicolon, Colon, and 
Other. If the data file uses an unusual 
delimiter character, choose Other and 
type that character into the text box 
next to the Delimiter pop-up menu.

B Use the Import Tabular Data dialog to select 
the delimited text file and format the table you are 
about to create.
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6. In the Table width section, choose “Fit 
to data” if you want the table width to 
be just as wide as the data, or choose 
“Set to” if you want the table to be a 
fixed width. If you choose the latter 
option, enter a number in the text box 
and choose the units from the pop-up 
menu (either percent or pixels).

7. You can enter values for cell padding, 
cell spacing, and the table border. You 
can also choose to format the text in 
the top row of the table (which is usually 
a header of some sort). Your choices 
are No Formatting, Bold, Italic, or Bold 
Italic.

8. Click OK.

Dreamweaver reads the delimited text 
file and inserts it into your page as an 
unformatted table C.

If the table imports incorrectly, chances 
are that the data file uses a delimiter different 
from the one you chose in step 5. You have to 
delete the incorrect table and import it again 
with the correct setting.

If you are importing tabular data from 
Word or Excel, consider copying and pasting 
the data using Edit > Paste Special. Dream-
weaver understands Office program format-
ting, and you’ll save time because you won’t 
have to reformat in Dreamweaver. See Chap-
ter 4 for more about using Paste Special.

C The unformatted table, built from the imported 
data, appears in your document. You can use 
Dreamweaver’s tools to style the table as you like.
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To export a Dreamweaver table’s 
data to a delimited file:
1. Place the insertion point in any cell of 

the table.

2. Choose File > Export > Table.

The Export Table dialog appears D.

3. From the Delimiter pop-up menu, 
choose the delimiter character you 
want to use in the exported text file. 
Your choices are Tab, Space, Comma, 
Semicolon, or Colon.

4. From the Line breaks pop-up menu, 
choose the operating system that is the 
destination for the text file. Your choices 
are Windows, Mac, or UNIX.

The reason for this option is that each 
of the platforms has a different way of 
indicating the end of a line of text.

5. Click Export.

The Export Table As dialog appears.

6. Give the file a name, navigate to where 
you want to save it, and click Save.

Dreamweaver saves the table data as a 
delimited text file.

If you want to export only a portion of a 
table (for example, the top ten rows), select 
those rows, copy them, and then paste them 
into a different part of the document, where 
they will create a new table. Export the new 
table as a delimited text file, and then delete 
the new table.

D Use the Export Table dialog to save the data 
from a Dreamweaver table as a delimited text file.
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Using Forms 
and Fields

A lot of Web sites exist just to provide infor-
mation and entertainment to site visitors. 
But if you want your site to get information 
back from your visitors, you’ll need some 
way to let them interact with you and your 
site. To do that, you’ll need to add a form.

A form contains fields, and those fields can 
be anything from a simple check box to a 
group of radio buttons or a single or multi-
line text entry area. And of course, you’ll 
want some sort of “OK” or “Submit” button 
so that your visitors know how to send you 
their completed form. Look at the Forms 
category of the Insert panel A, and you’ll 
see that it contains everything you need to 
add any kind of form and field to your site.

In This Chapter
Adding a Form to a Page 297

Adding Text Fields 300

Adding a Text Area 304

Adding Check Boxes 305

Adding a Fieldset 306

Adding a Radio Button Group 307

Adding a List/Menu 309

Adding a Button 312



ptg8274339

296 Chapter 11

The Uncovered Fields
There are nine items in the Insert panel 
that aren’t covered in this chapter:

. Jump Menu: We cover jump menus 
in Chapter 13, “Using Behaviors and 
Navigation Objects.”

. File Field: If you need to upload a 
file to a server, you’ll want to use 
this type of form field. It’s fairly self-
explanatory, but you’ll need to talk 
to your server administrator about 
how they’ve set up their server to 
accept files.

. Spry Validation: These seven  
buttons help you use Spry, Adobe’s 
Ajax user interface library, to validate 
form entries. We cover Spry in Chap-
ter 14, “Building Pages with Dynamic 
Elements.”

A The Forms 
category of the 
Insert panel 
contains all the 
items you might 
want to add to 
your form.
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Adding a Form 
to a Page
You could start creating a page by throw-
ing fields onto it, but when your visitor 
clicks Submit, the browser won’t know 
what to do with the data. That’s where you 
need a form—it tells the browser that all 
this information is part of one package, and 
it tells the browser what it should do with 
all of the information that it has gathered.

A form is made of a number of differ-
ent elements, but not all of them need to 
appear on every form. A shows the form 
we’ll be creating in this chapter. This form, 
which for layout purposes is created within 
the main page content div, contains a 
nested div that includes the First Name 
and Last Name text fields and the com-
ments text area.

A The completed form, with its components, as it appears in a browser.

Fieldset with 
check boxes

List/Menu
Buttons

Radio button 
groupText area

Text fields
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To add a form to a page:
1. Choose where on your Web page you 

want your form, and click the Form  
button on the Insert panel. A red 
dashed box appears on your page B.

The red box is the form area, and 
behind the scenes in the code, Dream-
weaver has added a <form>…</form> 
container tag.

2. If that box isn’t automatically selected, 
select it, and you’ll see the options you 
can change for your new form in the 
Property inspector C. The ones that 
apply solely to forms are:

>	 Form ID: If you’re going to be doing 
any JavaScript validation of your 
form, it’s a requirement to give it a 
name. In addition, some CGI proto-
cols need their associated forms to 
have a particular name. (CGI stands 
for Common Gateway Interface— 
a server program that interprets the 
data sent by your form.)

>	 Action: This is the program on the 
Web server that is executed when the 
form is submitted. You’ll need to get 
the name of this from your system 
administrator or hosting provider. 
It’s also commonly referred to as a 
System CGI.

C The Property inspector is where you set a form’s name, action, and method.

Form area

B A form looks bare until you add the form fields.
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>	 Method: The most common options 
are GET and POST. POST passes the 
form data as part of the header of 
the request to the server. GET passes 
the data as part of the URL of the 
request to the server. Because of 
this, and because GET has a length 
limitation, POST is what you’ll usually  
want. Dreamweaver also has a 
Default choice in the Method pop-up 
menu, which allows the form to be 
submitted using the browser’s default 
setting. This is usually a GET method, 
and we don’t recommend it.

>	 Enctype: This field describes the 
enclosure type being sent to the 
server. The default is application/ 
x-www-form-urlencoded. The only 
time you’ll want to use multipart/
form-data is if you’re asking your 
visitors to upload a file.

Make sure that all your form fields are 
inside your form; if they are not, their contents 
won’t be sent to the server.

If you try to add a form field to a page 
that doesn’t have a form, you’ll be asked if you 
want to add a form tag. You might think from 
this that it’s not worth bothering to add a form 
tag manually first, but it is. You’ll have better 
control over where the form is placed, and 
what ends up going inside it.

No, that red border around the form 
won’t actually display on your site. It’s just 
there in Dreamweaver’s Design view so 
that you’ll know where the form begins and 
ends. If you turn on Live view, the red outline 
disappears.
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Adding Text Fields
The simplest type of form field you can 
have is a single-line text field. Your average 
form will have several of them, allowing 
people to enter anything from their name 
to their phone number to their shoe size.

To add text fields:
1. Choose where in your form you want 

your text field to appear (by clicking in 
the document), and click the Text Field 
button on the Insert panel. The Input 
Tag Accessibility Attributes dialog may 
appear, depending on the settings in 
Dreamweaver’s Preferences. If it does, 
see how to handle it in the “Labeling 
Your Fields” sidebar, later in this chap-
ter, and then return to this point. The 
new text field appears on your page A.

2. If the text field hasn’t been automati-
cally selected, select it, and you’ll see 
the options you can change for your 
new field in the Property inspector B. 
From there, you can change the fields:

>	 TextField: This field contains the 
name of the field, which can be used 
by JavaScript behaviors and by 
scripts on the server.

A The first text entry field added to the form.

B Set a text field’s properties using the Property inspector.
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>	 Char width: The width of the text 
input area on your page. The larger 
this number, the wider the space it 
needs. And because it’s the number 
of characters allowed, the larger the 
font you’ve set (usually with CSS), the 
wider the space will be.

>	 Max chars: The maximum number of 
characters that a user can enter into 
this field. For instance, you could limit 
a credit card to 16 characters.

>	 Type: This has three values: Single 
line, Multi line, and Password. Multi 
line is covered in the next section, 
“Adding a Text Area.” The only dif-
ference between Single line and 
Password is what users see when 
they enter something into this field: 
if the type is Password, no matter 
what your visitor types, it will appear 
as black dots. The correct value will 
be sent back to the server, though.

>	 Init val: This is the initial value of the 
field. This text is displayed when the 
page is loaded.

>	 Class: This is the CSS class, if any, 
applied to the field.

A hidden field is similar to a text field. 
It’s used when there’s information that a script 
needs from a form, but which a user doesn’t 
enter—so the field contains a value but isn’t 
seen in the document. Adding a hidden field 
is virtually identical to adding a text field: just 
click the Hidden Field button in the Insert panel 
(obviously, where it’s put on the Web page 
doesn’t matter), and then set the value and 
unique field name in the Property inspector.
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Labeling Your Fields
When you click a button in the Insert panel to 
add a form field to your page, the Input Tag 
Accessibility Attributes dialog may appear A. 
This dialog allows you to set certain attributes 
that can enhance accessibility for people with 
disabilities. These fields are:

. ID: This is the same as the field name 
in the Property inspector. It’s used by 
scripts (both client-side and server-side) 
to manipulate the contents of fields and 
process the form.

. Label: A shows a label of “First Name:” 
being entered. Figure A from “Adding 
Text Fields” shows the result: that text 
is displayed just to the left of the new 
text field.

. Style: There are three style options: 
Attach label tag using ‘for’ attribute, 
Wrap with label tag, and No label tag. If 
you choose Wrap with label tag, Dream-
weaver surrounds your new <input> tag 
with a <label> tag:

<label>First Name: <input type="text" name="textfield" /></label>

If you choose Attach label tag using ‘for’ attribute, Dreamweaver writes the <label> tag 
based on what you enter for Position (covered below):

<label for="textfield">First Name: </label><input type="text" 
name="textfield" id="textfield" />

Unfortunately, Dreamweaver doesn’t offer full WYSIWYG support for this option— you can 
change the name and id attributes of your new text field (by changing the TextField field), 
but the label’s for attribute, which should change to match, doesn’t. There isn’t any way to 
change it short of going into the markup and changing it by hand.

If you choose No label tag, the text you enter appears, but it’ll be just that: text.

The <label> tag helps make your site more accessible in two ways: it tells voice browsers 
that this is the text associated with this field, and it allows users with certain browsers (such as 
Firefox) to click the text label as an alternative to only clicking inside a check box. This gives 
your visitor a larger space in which to click. Accessibility is important, and using the <label>
tag helps make your site more accessible—but if you want to use it with Dreamweaver’s Design 
view, stick with the Wrap with label tag option.

A To enable your site to be accessible for people 
with disabilities, set the label attributes here. The 
default position for a text field label is before the 
form item.
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Labeling Your Fields (continued)

. Position: The label for a form field can be 
either before or after the field. For text fields, 
you’ll usually see the label before the field. For 
check boxes and radio buttons, you’ll usually 
see the label afterwards. The default value of 
the position changes depending on the type 
of field B.

. Access key: Some browsers allow users to 
enter keyboard shortcuts to select form fields. 
If you want this option, enter the keyboard 
shortcut for the field here. For instance, if I 
entered g in figure B, a user with Internet 
Explorer for Windows could click that check 
box by pressing Alt-G.

. Tab Index: If you want users to be able to tab 
from form field to form field in a particular 
order, you’ll want to assign each field a tab 
index. This is the numbered order in which the user can tab through your form’s fields. It’s 
especially useful to set this when your form fields are inside table cells, as the default can be 
quite different from what you actually want to occur. The numbers need to be between 0 and 
32767, and they don’t have to be in sequence: you can make your fields be (for instance) 100, 
200, and so on, leaving room for future changes to your form.

If you don’t use labels, access keys, or tab indices and are annoyed at seeing this dialog come up 
every time you add another form field, you can get rid of it by clicking the link at the bottom. This 
opens Dreamweaver’s Preferences, and turning off “Show attributes when inserting Form objects” 
makes the dialog go away for good. If you later decide you want it back, go back into Preferences, 
choose the Accessibility category, and you can turn it on again.

You can also add a label afterwards by clicking the Label button on the Insert panel, but it doesn’t 
do what you expect. Instead of bringing up the Input Tag Accessibility Attributes dialog, Dream-
weaver adds a <label> tag around whatever you selected and throws you into Split view. If you 
are markup-phobic, stick with adding labels along with their associated fields.

B For a check box, the label’s default 
position is usually after the form item.



ptg8274339

304 Chapter 11

Adding a Text Area
It’s possible that you want your visitors 
to enter more than just a single line of 
text—maybe they have a lot to say, or you 
just want them to have a free-form area in 
which to enter their comments. If that’s the 
case, you’ll want to use a text area.

To add a text area:
1. Choose where in your form you want 

your text area to appear, and click the 
Textarea button on the Insert panel. The 
new text area appears on your page A.

2. If the text area isn’t automatically 
selected, select it, and you’ll see the 
options you can change for your new 
field in the Property inspector B. From 
there, you can change the same values 
that you could for text fields, with some 
small differences:

>	 Num Lines: This is the number of 
lines that you want the field to take 
up on the page. If you only want a 
single line, use a text field instead.

>	 Disabled and Read-only: These check 
boxes do similar but not identical 
things. Disabled displays the text area, 
but doesn’t let users select or change 
it. You might use this with a script 
that enables the text area if the user 
performs a particular action. Read-only 
makes the text area unchangeable 
by users, but they can still select and 
copy the field’s contents.

A A text area lets your visitors enter 
multiple lines of text, and it will scroll 
when necessary.

B Use the Property inspector to set the dimensions and initial value of the text area.
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Adding Check Boxes
Check boxes are one of the most commonly 
used form fields, and you’re likely to want 
several on your forms. They’re particularly 
useful when you want specific responses 
from your site visitors and you don’t want 
them to have to enter data into text fields 
(and possibly misspell their entry).

To add a check box:
1. Choose where in your form you want 

your check box to appear, and click the 
Checkbox button on the Insert panel. 
A new check box appears on your 
page A.

2. If the check box isn’t automatically 
selected, select it, and you’ll see the 
options you can change for your new 
field in the Property inspector B:

>	 Checkbox name: This is the 
name of the field, and it’s used by 
JavaScript validation as well as 
server-side scripts.

>	 Checked value: This is the value 
that’s passed to the server (and 
JavaScript client-side code) when the 
user has checked the check box.

>	 Initial state: This refers to the appear-
ance of the check box when the page 
is first loaded—is the box checked or 
unchecked?

B Set the name and value of the check box in the Property inspector along 
with the checked status of the box when the page is loaded.

A Check boxes 
are an easy way 
to get exact 
information from 
your site’s visitors.

Just a reminder: the difference between 
check boxes and radio buttons is that for a 
group of radio buttons, only a single option 
can be picked. When you have a group of 
check boxes, however, the state of each check 
box is not dependent on the other check 
boxes, so you can select multiple check boxes.
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Adding a Fieldset
A fieldset is HTML’s way of grouping fields 
on your form to add additional meaning 
for the user. How a fieldset displays on a 
Web page depends on the browser being 
used, and you can’t control that: Dream-
weaver’s Design view shows a thin gray 
line around a fieldset’s contents. Compare 
figure A in “Adding Check Boxes” with A: 
it’s easier to see that those check boxes 
are grouped together and that all have a 
similar function.

To add a fieldset:
1. Choose where in your form you want 

your fieldset to appear, and click the 
Fieldset button on the Insert panel.

2. The Fieldset dialog appears B, asking 
you to enter a legend—that’s the text 
that appears at the beginning of the 
fieldset A. Enter that text, click OK, 
and the fieldset box appears in the 
document.

3. If you’re adding a fieldset to an existing 
form, drag the related fields into the 
fieldset. If it’s a new form, click inside 
the fieldset and create its fields.

If the fieldset contains no form fields, 
the legend appears inside the box. When form 
fields are added, the legend is displayed as 
part of the box.

If you’re dragging fields inside the field-
set, be careful when selecting—make sure (for 
example) that all of a label is selected.

You can’t change a fieldset or a legend 
using the Property inspector. You can change 
the legend by modifying the text in the docu-
ment window, and you can change the fieldset 
by going into Code view.

A fieldset can contain any form fields, 
not just check boxes.

A Adding a fieldset to your form helps 
group related form fields, making 
your form easier for your visitors to 
understand. Dreamweaver puts a 
thin gray line around the fieldset in 
the document (top). Selecting the 
<fieldset> tag in the tag selector 
shows you the items in the fieldset 
(middle), and selecting the <legend>
tag in the tag selector highlights the 
fieldset’s legend (bottom).

B Enter the legend text in the Fieldset dialog.
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Adding a Radio 
Button Group
Radio buttons don’t exist by themselves—
they always come in a group. And of that 
group, only one option can be chosen: your 
visitors can pick rock or paper or scissors.

To add a radio button group:
1. Choose where in your form you want 

your radio button group to appear, and 
click the Radio Group button on the 
Insert panel.

2. The Radio Group dialog appears A, 
asking you to enter several fields:

>	 Name: A radio group needs a name 
that associates all of the radio but-
tons together. In this example, your 
visitor is choosing whether or not 
to subscribe to a newsletter, so the 
name is “newsletter.” This name will 
not appear in the finished form.

>	 Label: Each radio button needs a 
label to distinguish it from its neigh-
bors. In this example, the labels are 
“Yes” and “No.”

>	 Value: Each radio button needs a 
value, which will be passed back to 
the server, to JavaScript, or to both. 
The example values here are, again, 
“yes” and “no.”

>	 Lay out using: Radio buttons are 
normally aligned vertically, so here 
you make your choice of how you 
want that layout to be done in the 
HTML markup. Your choices are “Line 
breaks” and “Table.” Line breaks will 
almost always be sufficient.

continues on next page

A The Radio Group dialog lets you enter all of 
your radio buttons in a single dialog.
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The Radio Group dialog starts with two 
fields, which you can overwrite to say 
whatever you want. If you want to add 
more radio buttons, click the + on the 
left side. If you want to delete buttons, 
in the list, select the one you want to 
remove, and click the –.

To rearrange the order of buttons, in 
the list, select the name of the button 
to move, and then click the up/down 
arrows to move that button.

3. Click OK to accept your entries, and 
your new radio button group is added 
to your document B.

If you want your buttons to all be on the 
same line (as in this example), select “Lay out 
using: Line breaks,” and then remove the line 
breaks. Sadly, Dreamweaver doesn’t include 
an option of “just leave them on the same 
line, OK?”

There’s also an option on the Insert panel 
to add a single radio button (Radio Button): It’s 
unlikely, though, that you’ll ever want to have 
only a single radio button on a page. If you 
add a single radio button to an existing radio 
group, be sure to copy the name of the group 
exactly into the Property inspector C. In fact, 
your best bet is to click one of the existing 
radio buttons, copy the name from the Prop-
erty inspector, click the new radio button (if 
it already exists; add it if it doesn’t), and then 
paste the name in from the clipboard.

B Here’s your radio group.  
Only one item can be selected.

If you want one of your radio buttons to 
be set as selected, click that button in your 
document and then change the Initial state 
in the Property inspector from Unchecked 
to Checked.

Dreamweaver will happily let you set 
multiple radio buttons with their initial state 
checked even though browsers won’t display 
it that way. Each kind of browser may display 
this error in a different fashion, so don’t make 
the mistake in the first place. Be careful that 
you’re only setting one (or no) radio button to 
be checked.

C When setting the properties for an individual radio button, set the name of 
the group carefully—it has to match other radio buttons to work correctly.
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Adding a List/Menu
Another common form element is what’s 
referred to in the Forms category of the 
Insert panel as Select (List/Menu). It’s actu-
ally the two forms of the HTML <select>
tag: either a pop-up menu or a scrolling list 
of options. If it’s the latter, you can decide 
whether the user can click a single option 
or multiple options.

To add a pop-up menu:
1. Choose where in your form you want 

your pop-up menu to appear, and click 
the Select (List/Menu) button on the 
Insert panel. The Input Tag Accessibility 
Attributes dialog may appear. If so, fill it 
out as described earlier in this chapter.

The empty list appears in your layout, 
with a downward-pointing triangle indi-
cating the future pop-up menu.

2. Make sure the empty list is selected in 
the layout; then, in the Property inspec-
tor, click the List Values button. The List 
Values dialog appears A. Enter your 
desired options. The Item Label is what 
appears in the pop-up, and the Value is 
what’s sent to the server/JavaScript.

3. Click OK, and your new pop-up appears 
on your page B.

continues on next page

A You’ll enter all the values for pop-up menus 
and scrolling option lists in the List Values dialog.

B The new 
pop-up menu is 
now on your form 
(shown here in Live 
view to display the 
menu in action).



ptg8274339

310 Chapter 11

4. If the pop-up menu isn’t automatically 
selected, select it, and you’ll see the 
options you can change for your new 
field in the Property inspector C:

>	 Name: This text field at the left side 
of the Property inspector contains the 
field name that will be passed back to 
the server-side CGI/JavaScript when 
it processes the form.

>	 Type: The choices are Menu or List; 
for a pop-up menu, choose Menu.

>	 Initially selected: You can choose one 
of the menu options to be the default 
that’s shown when the page loads.

>	 List Values: Clicking this button 
causes the List Values dialog D to 
reappear, so you can easily change 
the list contents.

C You can change the existing pop-up menu into a scrolling option list by 
clicking the List button in the Property inspector.

D You can return to the List Values dialog to view 
or change the items by clicking the List Values 
button in the Property inspector.
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To add a scrolling option list:
1. Follow steps 1–3 in the previous 

exercise to create a pop-up menu, and 
select the pop-up menu.

2. In the Property inspector E, change 
Type to List. You’ll notice that even 
though you’ve changed the type to list, 
your field still displays as a pop-up menu.

3. Change the Height field to show the 
number of items you want displayed at 
any one time in the scrolling list. Chang-
ing this causes the field to display as a 
scrolling list F.

4. If desired, change the Selections option 
to allow multiple choices. When you do 
this, visitors to your site will be able to 
pick several options in the scrolling list 
at one time.

If you leave the Height set to 1 and 
change Selections to “Allow multiple,” you’ll 
also see your pop-up menu change to a scroll-
ing list. But a scrolling list with a height of one 
isn’t much of a scrolling list—it’s too difficult 
for your users to see what’s available.

E If you change from a pop-up menu to a scrolling list, you’ll get a couple of 
new options in the Property inspector.

F Here's what a scrolling 
list looks like.
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Adding a Button
A form on your site doesn’t do you much 
good unless you can get the information 
that’s entered into it, and that’s the primary 
use of buttons. A Submit button triggers the 
action specified in the form tag (described 
earlier in this chapter). Another type of but-
ton is the Reset button, which allows a user 
to go back to a form’s original state.

To add a button:
1. Choose where in your form you want 

your button to appear, and click the But-
ton icon on the Insert panel. The default 
value—the Submit button—appears on 
your document A.

2. If the button isn’t automatically selected, 
select it, and you’ll see the options you 
can change for your new button in the 
Property inspector B:

>	 Button name: This is the name of the 
button; generally, you’ll use “submit” 
to specify that it’s a Submit button, 
and “reset” or “cancel” to show that 
it’s a Reset button C (from a user 
interface standpoint, “Cancel” is 

A Add a Submit button to your Web form so you 
can receive your visitor’s completed form.

B The buttons you’ll usually use are Submit and Reset; this one’s a 
Submit button.

C A button can be changed to a Reset button using the Property inspector.
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preferable as the button name in the 
Value field). Note that the value in 
this field is what will be used by the 
code processing the form (the user 
doesn’t see it), so lowercase is gener-
ally preferable; by standardizing on 
all lowercase for code names, you 
lessen the possibility for errors if you 
modify the code by hand. You should 
use the properly capitalized name for 
the Value field.

>	 Value: This is the message that is 
displayed on the Submit button itself. 
It’s common for it to say “Submit,” but 
it can also say, “Place order,” “OK,” 
or whatever you think your users will 
understand.

>	 Action: There are three possible 
actions. Submit form and Reset form
do what you’d expect. None creates 
a generic button, which can later 
be set to trigger a JavaScript action 
(covered in Chapter 13).

There is actually one other type of but-
ton: an image button. It is created by clicking 
the Image Field button on the Insert panel. 
You’ll be prompted to browse for an image 
file in your site, and the image then appears 
in your document. When a visitor comes to 
your site and completes the form, clicking that 
image triggers an immediate submission of 
the form.
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Submit/Reset or Reset/Submit?
If you want to start a fight in a group of designers, just ask which order your Submit and Reset 
buttons should be in. There are two vocal schools of thought, and they tend to break down into 
Windows advocates versus Mac advocates.

In a nutshell, Windows users expect to find the OK/Submit button as the first button in a group, 
whereas Mac users are accustomed to always seeing it as the rightmost button. As shown in D 
and E, interface designers who work on cross-platform applications are able to change the order 
depending on the user’s platform. While this is the same General Preferences dialog on both plat-
forms, notice that where Mac and Windows users click to accept their changes is very different.

If you’re working on a Web site, you don’t have that flexibility, but you should be aware that visitors 
to your site will have expectations about how your forms should work—and at least some of those 
expectations may be different than yours. We’re not going to make the call here as to which is pref-
erable; that call should be made based on your visitor logs and your personal preferences.

D Dreamweaver’s General Preferences panel on 
Windows shows the buttons as OK and Cancel at 
the bottom right and Help at the bottom left.

E The General Preferences panel on the Mac 
also has Help at the bottom left, but uses the order 
Cancel and OK at the bottom right.
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Layout Tools
The layout of elements on your pages is key 
to the usability of your sites, and Dream-
weaver has many tools that help you view 
and work with your page layouts. These 
tools fall into two main areas: tools that help 
you work within your document window to 
align and view page elements, and tools to 
help you visualize your CSS-based layouts.

The document window tools will be familiar 
from image editing programs, and include 
an onscreen grid, page guides, and rulers. 
Because it’s often useful to get a closer look 
at your work, you also have the ability to 
zoom the document window.

CSS-based layouts allow you to create Web 
pages that look good on computers, tablets, 
and smart phones, and Dreamweaver gives 
you two ways to do the trick. One is to create 
and add separate media query style sheets 
and swap out the style sheet for the page 
to match the screen size that is calling for 
the page. Another way is to create a single 
grid-based layout that builds and includes 
the media queries in the same style sheet 
and automatically switches screen sizes as 
needed. Dreamweaver CS6 handles both 
approaches, and we’ll see that in this chapter.
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Using the Grid
If you want items on a page to line up, a 
handy way to make sure they’re aligned 
is to use the grid—a feature you may well 
be familiar with from other applications, 
such as Photoshop. If you’re used to it 
elsewhere, it’s easy; if you’re not, here’s 
a quick overview.

The grid overlays graph-paper-like lines 
on your Web page, making it easy to see 
if elements on the page are horizontally or 
vertically aligned. Nothing on your page 
is actually changed, and the lines are only 
visible inside Dreamweaver. If you choose 
to have elements on your page snap to the 
grid, whenever you move an element close 
to a grid line, it will “jump” (or snap) to match 
up with it. That way, you know for sure that 
your elements are perfectly aligned.

To turn the grid on or off:
To toggle the grid display, choose View > 
Grid > Show Grid A.

or

Press Ctrl-Alt-G (Cmd-Opt-G).

Your document displays the grid if it wasn’t 
already displayed B, and vice versa.

A You can get to all the grid options from the menu.

B Here’s the page with the grid visible.
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To change the grid settings:
1. Choose View > Grid > Grid Settings A. 

The Grid Settings dialog appears C.

2. From this dialog, you can change the 
color, the spacing, and whether the grid 
displays as lines or dots. You can also 
use this as a way to set the Show Grid 
and Snap To Grid options at the same 
time. If you want to check how a setting 
looks, click Apply. When you like your 
results, click OK, and if the grid is set to 
show, your document appears with your 
chosen grid style. If the grid is not set to 
show, the settings will still be changed 
and will display their new values the 
next time you show the grid.

To make elements snap to the grid:
1. Choose View > Grid > Snap To Grid A.

or

Select the “Snap to grid” check box in 
the Grid Settings dialog C.

or

Press Ctrl-Alt-Shift-G (Cmd-Opt-Shift-G).

2. Move an absolutely positioned page 
element. It snaps to line up with the grid 
if you move the element within a few 
pixels of a grid line.

C If you don’t like the grid defaults, you can 
change the settings.
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Using Rulers 
and Guides
Rulers and guides are also tools commonly 
found in other design applications. Dream-
weaver has both horizontal and vertical 
rulers, which can use pixels, inches, or 
centimeters as units.

Guides can do almost everything grids can 
and a whole lot more. For instance, guides 
can be locked into place, guides can be set 
to percentages of the page, and not only 
can elements snap to guides, but guides 
can be set to snap to elements.

To turn rulers on or off:
To toggle the display of rulers, choose 
View > Rulers > Show A. You can also 
choose the ruler units in this menu.

or

Press Ctrl-Alt-R (Cmd-Opt-R).

To turn guides on or off:
To toggle the display of guides, choose 
View > Guides > Show Guides B.

or

Press Ctrl-; (Cmd-;).

A You can turn rulers on and off in the View 
menu.

B As you could with the grid options, you can get 
to many guide options in the View menu.
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To add a guide to your page:
1. Click in either the horizontal or vertical 

ruler, and then drag into the document. 
The guide appears along with a tip that 
displays the number of pixels that the 
guide is currently away from the edge 
of the document C.

2. When the guide is where you want it, 
release the mouse button. The line 
remains, but the tip goes away.

To edit guide settings:
1. Choose View > Guides > Edit Guides, 

and the Guides dialog appears D.

2. From here, you can set:

>	 The guide and distance colors

>	 Whether guides should show

>	 Whether elements should snap to 
guides, guides snap to elements, 
both, or neither

>	  Whether guides are locked

You can also use it to clear all the current 
guides by clicking the Clear All button.

3. When your changes are complete, 
click OK.

To move a guide, move the mouse over 
the guide. When the cursor changes, click the 
guide and drag it to its new location.

To remove a guide from your page, move 
the guide off the document. Mac users will 
see a little “puff of smoke” animation—sorry, 
Windows users! You can also remove all the 
guides at once (without the animated effect) 
by choosing View > Guides > Clear Guides or 
by clicking Clear All in the Guides dialog D.

To inspect the current position of a 
guide, hover the cursor over the guide, and a 
tip showing the position appears.

C By default, guides are measured in pixels.

D Use the Guides dialog to change any of 
its settings.
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To position a guide based on the per-
centage distance of the document rather than 
pixels, hold down the Shift key while moving 
the guide E. The tip displays the current 
location in both pixels and percentage when 
you’re moving it and also when you check the 
guide’s position later.

To see how far a guide is from the sides 
of your document, hold down the Ctrl (Cmd) 
key. Lines appear showing the distance in pix-
els (and percentage, if set in the previous tip) 
to the edges of the document F. If you have 
multiple guides on your page, the distance 
shown will be from guide to guide or from 
guide to edge.

Guides can be locked on your page so 
that they can’t be moved. To do this, choose 
View > Guides > Lock Guides B or use the 
Guides dialog D. It’s a toggle, so just do it 
again to unlock your guides.

Rulers have to be visible for you to add 
guides, but you can view, move, and delete 
guides even when the rulers are hidden.

Guides can be used to simulate dimen-
sions of standard browsers. Choose View > 
Guides and pick one of the standard sizes 
from the bottom of the menu B. This creates 
both vertical and horizontal guides on your 
page. Be careful, though, because you can still 
move them accidentally, and then they aren’t 
much use for providing dimension hints. This 
is the one exception to the previous tip: you 
can create guides with this method even when 
the ruler is hidden.

As with the grid, you can choose to 
snap elements to your guides—but you can 
also choose to snap guides to your elements. 
Choose View > Guides > Snap To Guides, or 
View > Guides > Guides Snap To Elements, 
or even both B. Or, you can set them in the 
Guides dialog D.

If you double-click a guide, the Move 
Guide dialog appears G. Use this dialog to 
set the guide to a precise position in pixels, 
inches, centimeters, or percentages.

E If you want a percentage instead 
of pixels, hold down the Shift key.

F Holding down the Ctrl (Cmd) key gives you 
the distance between the document edge and the 
guide.

G Double-click a guide to get to the 
Move Guide dialog.
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Zooming In on 
Your Page
Yes, it’s another feature borrowed from 
standard design applications, just like the 
grid and guides. The Zoom feature lets you 
design your pages more precisely. And as 
with the grid and guides, you’ll need to be 
in Design view to use it.

To zoom in on your page:
Select the Zoom tool from the Status bar at 
the bottom right of your document A and 
your cursor changes to a magnifying glass 
with a plus. While in Zoom mode, you can 
do either of two things:

n	 Click and drag to draw a box over the 
area you want to zoom in on. That 
rectangle expands to take up the entire 
document window B.

n	 Click the spot on the page you want to 
magnify. Continue to click it until you 
get the magnification level you want.

or

Press Ctrl- = (Cmd- =) until you’ve 
reached the level you want.

or

Select a magnification level from the 
Zoom pop-up menu in the Status bar.

or

Type your desired magnification level 
into the Zoom text box in the Status bar.

or

continues on next page

Pointer 
tool

Zoom 
tool

Hand tool Zoom 
pop-up 
menu

A The magnification tools in the Status bar are 
especially useful when making detailed changes 
to your pages.

B You can zoom in on a particular part of the screen.
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Select View > Magnification and pick a 
magnification level C.

or

Select an element on the page, and 
then choose View > Magnification > Fit 
Selection C.

or

Select an element on the page, and 
then choose Fit Selection from the 
Zoom pop-up menu in the Status bar.

To zoom out from your page:
Select the Zoom tool from the Status bar at 
the bottom right of your document. Press 
Alt (Opt) and the cursor changes to a mag-
nifying glass and a minus. Click the page to 
zoom out.

or

Press Ctrl- – (minus key) (Cmd- – [minus 
key]) until you’ve reached the level you 
want.

or

Select View > Magnification and pick a 
magnification level C.

or

Choose View > Magnification > Fit All or 
View > Magnification > Fit Width C.

or

Choose Fit All or Fit Width from the Zoom 
pop-up menu in the Status bar.

To edit your page in Zoom mode, select 
the pointer in the Status bar and click inside 
the page.

To pan your page after you’ve zoomed 
in, select the hand icon in the Status bar, and 
then drag the page to move around.

C You can also access the magnification levels 
from the menu.
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Setting Page 
Dimensions
It’s handy to be able to easily set guides to 
show the dimensions of common browsers, 
but it’s not quite the same as seeing how 
your design actually appears in a window 
of that size. That’s where setting page 
dimensions comes in.

To resize the window 
to a preset size:
Click the Window Size pop-up menu in 
the Status bar, and select one of the listed 
sizes A. Your document window resets 
to that size. If the new size fits within the 
document window, you see a view of the 
selected size B.

A Dreamweaver comes with preset 
window sizes for the most commonly 
used monitors.

B If the window size you set fits in the document window, Dreamweaver shows it to you 
as a view.
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To edit the preset window sizes:
1. Click the Window Size pop-up menu 

in the Status bar, and select Edit Sizes. 
The Window Sizes Preferences pane 
appears C.

or

Open Dreamweaver’s Preferences 
panel and select the Window Sizes 
category.

2. Click in any of the fields and write over 
the current value to replace it. To add 
a value, click in the first unfilled line D. 
To delete a value, clear the entire line 
by deleting the contents of each field.

3. Click OK to accept. The new size now 
appears in the Window Size pop-up 
menu E.

You can resize the window to a fixed 
width (leaving the height as is) by entering 
only a width value. To make the window resize 
to a fixed height, enter only the height.

Although it looks like you can sort the 
values in the Window Sizes Preferences pane, 
you actually can’t.

Sadly, if you enter a new window size, it 
doesn’t get added as a new possible value for 
creating guides—it’s only for resizing.

While you’re in the Window Sizes Prefer-
ences pane, take the chance to reset the Con-
nection speed if it’s not appropriate for you or 
your audience. Dreamweaver uses that num-
ber to calculate page download time, which is 
shown on the far-right end of the Status bar.

C You can view or edit the window sizes in 
the Window Sizes category of Dreamweaver’s 
Preferences panel.

D New sizes can be added just by clicking in 
the first unused line and typing the appropriate 
dimensions.

E And here’s the new window size.
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Using Multiscreen 
Preview
Not too long ago, it was perfectly reason-
able to create a Web page that was simply 
meant to be viewed in a browser. We didn’t 
ask, “What kind of machine will this browser 
be running on?” We had browsers running 
on computers, darn it, and we liked it! But 
this Cranky Old Man approach doesn’t 
work with today’s clients. Clients these days 
think it’s perfectly reasonable to request 
that their Web pages look good on comput-
ers, tablets, and smart phones. Those Web 
pages don’t have to look the same on every 
device, but they do have to render grace-
fully no matter the size of the screen, prefer-
ably using HTML5 and CSS to make the 
pages look good at any resolution. Happily, 
these client requests are also ushering out 
the era of execrable restaurant Web sites 
created entirely in Flash.

Dreamweaver CS5.5 introduced a new fea-
ture, Multiscreen Preview, that works with 
Live view to show you simultaneous views 
of three different screen sizes, for Phone, 
Tablet, and Desktop. Multiscreen Preview 
makes it much easier to make your Web 
pages multi-device aware.

In this section, you’ll see how to bring up 
the Multiscreen Preview panel and change 
the size of its viewports. In the next sec-
tion, you’ll see how to really put Multiscreen 
Preview to work, by creating and linking in 
a media queries CSS file that can work site-
wide and change the display of your sites 
on the fly, according to the screen size of 
the device that is viewing your page.
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To activate Multiscreen Preview:
1. Open the page you want to view in 

multiple resolutions.

2. In the Document toolbar, click Design view.

It doesn’t matter if you have Live view 
turned on or off.

3. Click the Multiscreen button in the 
Document toolbar A.

or

Choose Window > Multiscreen Preview.

or

Choose File > Multiscreen Preview.

The Multiscreen Preview panel 
appears B. Note that in this screen-
shot, the viewports all show the same 
layout, beginning with the upper-left 
corner of the page. That’s because we 
have yet to implement media queries, 
which will be covered later in this 
chapter. The viewports are also all in 
Live view; you can tell because in the 
screenshot the Menus button under the 
hand cursor is animated.

Each of the three viewports shows its 
pixel dimensions (horizontal and verti-
cal), and each has independent scroll 
bars. Because you’re looking at a live 
rendered view of the page, you can 
click links (to go to another page in your 
site, for example) and all three view-
ports will update.

4. (Optional) Navigate within your site. The 
Multiscreen Preview window has a tool-
bar with the familiar browser controls of 
Back, Refresh, Home, and an address 
bar that shows the URL C. You can’t 
type in the address bar; instead, you’re 
meant to open a document in the main 
Dreamweaver window, then invoke the 
Multiscreen Preview panel.

Multiscreen button

A Click the Multiscreen button in the Document 
toolbar to activate the Multiscreen Preview panel.

B The three viewports of the Multiscreen Preview 
panel: Phone, Tablet, and Desktop.

C Use the familiar browsing controls to 
change the pages you’re looking at in 
the Multiscreen Preview panel.
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The Multiscreen Preview panel doesn’t 
sync automatically with Design view or Live 
view, so if you make changes in one of those 
views, you need to click the Refresh button in 
the Multiscreen Preview panel. Similarly, if you 
switch between different top-level document 
tabs in Dreamweaver, you will also need to 
click the Refresh button in the Multiscreen 
Preview panel in order to render the newly 
selected file.

By default it opens as its own window, 
but the Multiscreen Preview panel is just like 
other Dreamweaver panels, and you can treat 
it as such, docking it with the rest of your pan-
els or even collapsing it to an icon. Just use 
the regular panel controls in the upper-right 
corner of the panel.

If you don’t have a browser-renderable 
document open (for example, a CSS or  
JavaScript file), the Multiscreen button in 
the Document toolbar will be disabled. It 
is also disabled when you click on tabs for 
related files at the top of the Dreamweaver 
document window.

To set viewport sizes:
1. On the right end of the toolbar in the 

Multiscreen Preview panel, click View-
port Sizes.

The Viewport Sizes window appears D.

2. Change the values (in pixels) for any of 
the three viewports (Phone, Tablet, or 
Desktop).

3. Click OK.

The viewport changes you made are 
reflected in the Multiscreen Preview 
window E.

Note that you can’t change the Height 
value of the Desktop viewport. That’s because 
the Multiscreen Preview panel can’t show the 
full size of today’s desktop screens, and the 
important value to target for the desktop is 
the Width. You can always scroll the Desktop 
viewport if needed.

D Change any of the values to change the 
width or height of any of the viewports (you can 
only change the width of the Desktop viewport, 
because its height automatically resizes along with 
the Multiscreen Preview panel).

E In this example, we added 150 pixels to the 
height of the Tablet viewport.
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Adding Media Queries
It’s not enough to simply design your 
pages for the desktop; now any designer 
worth his or her salt needs to design with 
the mobile Web in mind. Using media que-
ries, a part of the CSS3 specification, you 
can automatically link your HTML pages to 
different CSS style sheets that rearrange 
the layout of your pages for given screen 
sizes. The reason to rearrange the layout 
is simple: a page layout that looks great 
and is perfectly functional on a desktop 
browser may initially look fine on a smaller 
screen (such as an iPad, iPhone, or Android 
device), but chances are the browser on 
the mobile device will automatically zoom 
the page out to fit as much of it as possible 
on the device’s screen. Making the user 
pinch, scroll, and zoom the screen just to 
see your content isn’t a good user experi-
ence. It’s better to anticipate and adapt the 
page for the smaller screen size. You’re not 
changing the content of the page for differ-
ent screen sizes; instead you’re changing 
the presentation of that content for a bet-
ter user experience.

Dreamweaver’s Media Queries dialog 
allows you to insert a link to a media query 
CSS style sheet, and helps build that style 
sheet for you. You can choose to insert the 
link to the media query style sheet on just 
the page that you’re working on, or you can 
create a site-wide media query style sheet.

It’s important to note that although you can 
use Dreamweaver to create a style sheet 
optimized for a given screen size, the pro-
gram can’t create it for you automatically. 
You’ll need to make your layout decisions 
and create the alternative style sheets 
yourself, though they will usually be able 
to inherit many properties from the main 
desktop style sheet. 
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To create a media 
queries style sheet:
1. Open (or create) the HTML document 

you want to style.

2. Choose Modify > Media Queries.

or

More often, you’ll want to begin work-
ing from the Multiscreen Preview panel, 
so click the Multiscreen button in the 
Document toolbar, then click the Media 
Queries button in the Multiscreen Pre-
view panel.

The Media Queries dialog appears A.

3. If you want to create a site-wide media 
queries style sheet, in the “Write media 
queries to” section of the dialog, click 
Site-wide media queries file.

or

If you want the media queries to apply 
only to the current document (though 
most of the time it’s better to reuse 
media queries throughout the site), click 
the “This document” button, then skip 
to step 5.

4. Continuing with the process of creat-
ing a site-wide media queries file, click 
Specify.

In the resulting dialog B, choose either 
Use existing file or Create new file 
from the pop-up menu. If you choose 
the former, click the folder icon at the 
right side of the dialog to browse to the 
existing file. Of course, if you choose to 
create a new file, you should also click 
the folder icon at the right side of the 
dialog to specify the name and location 
of the new style sheet. Click OK.

continues on next page

A The Media Queries dialog allows you to easily 
make media queries for multiple screen sizes.

B Browse to or create the site-wide media 
query file.
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Behind the scenes, Dreamweaver has 
added the path to the site-wide media 
query file to the Local Info subcat-
egory of Advanced Settings for the site 
setup C. You won’t see this unless you 
go looking for it.

5. Because some devices (notably Apple’s 
iPhones with the high-resolution Retina 
displays) play tricks when reporting 
their screen size, you should select 
“Force devices to report actual width” in 
the Media Queries dialog D.

6. Chances are you’re going to want to 
create media queries for smart phones 
and tablets, so click the Default Presets 
button in the Media Queries dialog.

In the list, Dreamweaver creates 
defaults for Phone, Tablet, and Desk-
top E. If you want to create additional 
media queries for other devices you 
specifically want to target, click the plus 
button at the bottom of the list.

C If you created a site-wide media query file, Dreamweaver 
records it in the site setup’s Advanced Settings.

D It’s a good idea to always force devices to report their actual 
screen width.

E Clicking Default Presets creates three media queries.
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7. Change the defaults to target particular 
screen sizes, and to point at appropri-
ate CSS style sheets for each media 
query. When Dreamweaver creates the 
default presets, the first one, for Phone, 
is selected. In the Properties section 
below the list F, you can change the 
description. For a phone, you can leave 
the Min Width blank (implying zero 
pixels), but you should specify the larg-
est width in Max Width (the default is 
the iPhone’s 320 pixels). In the CSS File 
field, create or browse to the CSS style 
sheet you want to use for this preset.

8. Click the Tablet preset. This style 
sheet’s properties G include a Min 
Width—which starts at 1 pixel wider than 
the Phone style sheet’s Max Width—and 
a Max Width of 768 pixels (correspond-
ing to the iPad in portrait mode). Browse 
to the tablet.css style sheet.

The final preset, Desktop, has a Min 
Width of 769 pixels and leaves the Max 
Width field blank. It uses the style sheet 
desktop.css.

9. Click OK.

The Media Queries dialog disappears. 
In the <head> section of the document’s 
HTML, Dreamweaver has now created 
a link to the site-wide media queries 
file (in this example, because we’re 
using the Adobe demo assets, the code 
was <link href="css/citrus_mq.css"
rel="stylesheet" type="text/css">). 
In the citrus_mq.css style sheet, there 
are @import rules pointing to the three 
style sheet files, with the media query 
rule for each preset you see in the 
Media Query column in E.

Back in the Multiscreen Preview panel, 
the display for each viewport changes 
to reflect the style sheet associated 
with each viewport size H.

F Specify the destination CSS file for the Phone 
preset.

G The Tablet preset has both Min Width and Max 
Width values.

H After setting the media queries, the Multiscreen 
Preview panel shows you the result of the different 
style sheets at each screen resolution.
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Using Fluid Grid 
Layouts
Years ago, it was common for Web design-
ers to look forward to the day when every-
one would have big displays and could see 
their works as intended. In recent years, 
that goal has become obsolete—sure, you 
have a big screen on your desk, but you’ve 
also got a small screen in your pocket 
and a medium-sized screen in your bag. 
You want your site to look its best on all of 
them, but you don’t want to have to create  
multiple sites. And that’s why Dreamweaver  
now has fluid grid layouts.

Fluid grid layouts let you design your site 
based on grids with rows and columns: 
using one layout for smart phones, another 
for tablets, and a third for computer 
monitors—and which layout is displayed is 
based on the width of the browser window. 
As our example, we’ll use the good old 
Home Cook site you’ve seen before—but 
now it will work on a variety of screen 
sizes A. For our purposes here, we’re 
using Dreamweaver’s terminology of Desk-
top for computer monitors, but of course 
that also covers laptop screens.

To create a fluid grid layout:
1. Choose File > New Fluid Grid Layout B.

The New Document dialog appears, 
with the Fluid Grid Layout tab 
selected C. This is where we create 
our grids for the three screen sizes: 
Mobile, Tablet, and Desktop.

A We like the way this site looks—but not on 
mobile devices.

B Both File > New and File > New Fluid Grid 
Layout take you to the New Document dialog.

C The New Document dialog is where you set up 
the grid for each of the three screen sizes.
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2. In this example, for mobile devices 
(such as smart phones) we’ve entered 
4 columns, and for tablets, we’ll say 8. 
For either kind of device, given their 
limited space, we want to use 100% of 
the screen. For desktops, we can use 
12 columns, but we’ll leave some space 
for margins on either side, so we’ve 
entered 90% as the page width in C. 
When done, click Create. The Save 
Style Sheet File As dialog appears.

3. Dreamweaver requires you to start off by 
saving a style sheet D, and we’ve called 
ours fluidgrid.css. Enter the name for 
your style sheet, and then click Save.

Your screen will look like E after you cre-
ate your style sheet; this example shows 
the smart phone (four-column) layout.

To build your fluid grid layout, you’ll 
lay out the divs separately on each of 
the three screen sizes. Dreamweaver 
automatically starts you on the Mobile 
size layout.

4. Save the page by choosing File > Save, 
and Dreamweaver lets you know that 
you’ll also need a couple of dependent 
files F. Click the Copy button to copy 
them (they’re required). That puts us 
back to E, and now it’s time to start 
building our layout grid.

If you can’t read the fine print in the fig-
ure, it says, “Use Insert Panel for addi-
tional Fluid Grid Layout Div tags. Note: 
All Layout Div tags must be inserted 
directly inside the gridContainer div 
tag. Nested Layout Div tags are not 
currently supported.” The italicized 
part is what you need to keep in mind; 
normally, you can insert divs anywhere 
you want, but not when you’re working 
with fluid grid layouts.

continues on next page

D Start off by saving your fluid grid layout style 
sheet and giving it a meaningful name.

E Dreamweaver starts off on the Mobile layout; 
the theory being that you should design for the 
smallest size first, and then add the extras on to 
the larger versions.

F Here are the two files that Dreamweaver 
requires you to have: one is a style sheet, and the 
other is a collection of JavaScripts.
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5. To add new elements to the page, fol-
low the onscreen directions: go to the 
Insert Panel, and choose Insert Fluid 
Grid Layout Div Tag G. The Insert Fluid 
Grid Layout Div Tag dialog appears H.

6. Enter the name of your new div; we’ve 
called ours navbar. Once we add that 
div and a couple of others we need for 
the layout we’ve designed (in this case, 
contentArea and reviews), the page 
now looks like I.

7. Now that we’ve created the divs, we’re 
ready to do some layout work. Select 
the navbar div J, and then move the 
right handle to make the div thinner. 
One column is enough for the navbar
on smart phones, and the result is 
shown in K.

8. The content area can fit into three 
columns, so resize the div to be three 
columns, as shown in L.

G Be careful 
here: Insert Div 
Tag doesn’t do 
the same thing as 
Insert Fluid Grid 
Layout Div Tag.

H It’s OK to leave “Start New Row” selected, as 
you’ll have plenty of chance to change it later.

J Drag the right handle to resize the div. in this 
figure, we’re in the middle of the drag, so the div 
hasn’t visually updated its size yet, though you see 
the onscreen tip showing the div’s current size.

L Again, here the right handle is being dragged, 
giving the content area the remaining three 
columns.

I Here are the four divs: the three just created 
plus the one that was automatically generated.

K Here’s the div after it’s been resized.
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9. Of course, you’ll want that three-column 
content area to be to the right of the 
navigation, and clicking the “Move Up 
a Row” arrow on the right side of the 
selected div M gives you N.

10. Switch between the different layouts 
by choosing between the Window 
Size icons at the bottom of the docu-
ment window O. You’ll notice (pos-
sibly to your surprise) that when you 
changed the smart phone layout, the 
others didn’t change P. That’s because 
although each layout shares the same 
files, their designs are independent.

11. For the eight-column tablet view, give 
the navbar and reviews divs two col-
umns each, and the main content area 
four columns Q.

12. The 12-column desktop view R gets two 
columns for the navigation, three for the 
reviews, and seven for the main content.

continues on next page

M All that’s left to do now is click the arrow button 
to move the div into position.

N And here’s our navigation and content divs, 
just the way we want them to appear on smart 
phones.

Mobile size

Tablet size

Desktop size

O Click these icons to switch between the 
different layouts.

P All the divs we added are full width again 
when we switch to Tablet layout. 

Q We can choose to lay out our divs any way we 
wish; here, we’ve chosen a simple 2-4-2 column 
design.

R On the desktop we have all the room we need, so we’re going for an asymmetrical 2-7-3 column layout.
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13. Next up is the easy part: copying and 
pasting the content from our old Home 
Cook page A into our new fluid grid 
layout. Once that’s accomplished (plus 
a little bit of CSS tweaking), you can see 
the results in S (Mobile size), T (Tablet 
size), and U (Desktop size).

S The Mobile layout has a header 
(with site name and tagline below the 
graphic) above the navigation and 
content areas.

T The Tablet layout has the header (with site name and 
tagline in a condensed font) above the navigation, content, 
and reviews areas. 
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U And finally, the Desktop layout has the header (with expanded font) above 
the navigation, content, and reviews areas—and there’s still room for left and 
right margins.

In order to make the most of the limited 
space on a smart phone, set the reviews 
column to have a style of display:none. It’s 
a handy way to hide less-important content 
when there just isn’t room.

Wondering how to get rid of those 
annoying pink bars and green highlights when 
you actually want to see how your page looks? 
Refer back to “Using the Visual Aids” in Chap-
ter 9 for how to toggle them on and off.

Dreamweaver started us off with one 
default grid div E. Here, we’ve repurposed it 
as the header for our pages.
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Using jQuery for Layout
Since Dreamweaver 5.5, the program has allowed you to create layouts for mobile devices using 
the jQuery Mobile JavaScript framework. You’ll find jumping-off points for these layouts in the 
Page from Sample tab of the New Document dialog. In the Mobile Starters sample folder, there are 
three kinds of jQuery Mobile layouts:

. jQuery Mobile (CDN) uses .css and .js files directly from jQuery’s Content Delivery Network 
(CDN). That’s another way of saying that the jQuery files are hosted on servers spread across 
the Internet and are often going to be served to your user more quickly than they would be if 
they were hosted on your own server.

. jQuery Mobile (Local) uses the same files as the CDN choice, but now they’re hosted on 
your server.

. jQuery Mobile with Theme (Local) again uses the same files, but with the addition of your 
own jQuery theme file, so you can specify the look of the resulting layout.

All of this is just to provide a mobile site using standard user interface widgets—which is nice, but 
your smart phone site will then look like a standard smart phone site. And it doesn’t help the non–
smart phone versions at all. Making pretty much any kind of modification involves diving into and 
modifying the HTML, CSS, and JavaScript in Dreamweaver’s Code view, which puts it outside the 
scope of this book.

Our opinion is that it’s a bad idea for designers to create multiple versions of the same site. And 
this—unless all you want is a mobile site—forces Dreamweaver users into exactly that situation.
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Using Behaviors and 
Navigation Objects

Dreamweaver provides a number of 
built-in JavaScript actions you can easily 
add to your pages. No prior knowledge of 
JavaScript is required to use them. Adobe 
calls these JavaScript actions behaviors. 
Behaviors can add interactivity to your site. 
Many times the behavior is triggered by 
a user’s action; for example, the behavior 
will happen when the user clicks a link or 
hovers over a link. Other behaviors hap-
pen without any overt user action, such as 
when a browser checks for a needed plug-
in as a page loads.

In Dreamweaver, you add many behaviors 
with the Behaviors tab of the Tag Inspector 
panel. Some behaviors are also available in 
the Insert panel. In addition, Dreamweaver 
imports behaviors from other Adobe soft-
ware, such as Fireworks.

In this chapter, you’ll learn how to use 
behaviors to add rollovers, open new win-
dows, check for plug-ins, validate forms, and 
insert jump and pop-up menus. Table 13.1
lists some of the available behaviors.

In This Chapter
Using the Behaviors Panel 341

Adding Rollovers 345

Opening a New Browser Window 348

Checking for Plug-ins 351

Using Jump Menus 353

Validating Forms 356

Inserting Fireworks Pop-Up Menus 359
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Table 13.1 Dreamweaver Behaviors

Behavior Description

Call JavaScript Specify that a custom JavaScript should execute for a specific event. 
You can write the custom JavaScript yourself or use one from the many 
available JavaScript libraries.

Change Property Change the value of an object’s properties. Only certain properties can be 
changed, and only in certain browsers.

Check Plugin Send visitors to specific pages based on whether they have certain plug-ins 
installed. This works only in certain browsers.

Drag AP Element Set up movable elements that users can drag. Attach this behavior to the 
document to make interactive puzzles, games, or sliders.

Effects Add one of seven visual effects: Appear/Fade, Blind, Grow/Shrink, Highlight, 
Shake, Slide, and Squish.

Go To URL Open a new page in a specified window or frame, or change the contents 
of two or more frames with one click.

Jump Menu Create or edit a jump menu. Normally, you create a jump menu using 
Insert > Form Objects > Jump Menu, and merely use the Behaviors panel 
to edit it.

Jump Menu Go Like Jump Menu but adds a Go button to the menu to activate or reactivate 
the menu choice.

Open Browser Window Open a URL in a new window. You can set the properties for the new window.

Popup Message Create a JavaScript alert with the message you specify, usually a brief 
informative statement.

Preload Images Preload images that won’t be seen right away (for example, images for 
rollovers). That way, there’s no wait to see the image when the action 
is triggered.

Set Text of Container Replace the content and formatting of an existing absolutely positioned 
element with new content. The new content can include text, HTML, and 
JavaScript functions.

Set Text of Frame Change the text display in a frame to the new content and formatting you 
specify. The new content can include text, HTML, and JavaScript functions.

Set Text of Status Bar Put a message in the browser’s status bar.

Set Text of Text Field Replace the content of a form’s text field with new content. The new 
content can include text or JavaScript functions.

Show-Hide Elements Show, hide, or restore the default visibility of one or more absolutely 
positioned elements.

Swap Image Swap one image for another to create rollover effects or even swap more 
than one image at a time.

Swap Image Restore Restore the last set of swapped images to their previous source files. If you 
leave the Restore option selected when you attach a Swap Image action, 
this action gets automatically added.

Validate Form Check the contents of specified text fields to be sure the user has entered 
the proper type of data. You can also check whether the user entered 
something in a required field.
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Using the 
behaviors Panel
To add interactivity to your site, you’ll want 
to add behaviors to the objects on your 
pages, such as images and links. To add, 
modify, and remove behaviors, you’ll use 
the Behaviors tab of the Tag Inspector 
panel (in this chapter, we’ll just refer to 
the “Behaviors panel”). Objects can have 
multiple behaviors attached, so you’ll also 
need to know how to rearrange their order.

To add a behavior:
1. If the Behaviors panel is not visible, 

choose Window > Behaviors (Shift-F4).

2. Select an object on the page, such as 
an image or a text link.

3. Click the plus button on the Behaviors 
panel to see the list of available actions 
for the selected object A. If a choice is 
grayed out, that action is not available 
for the selected object. Click to choose 
an action.

4. The dialog for the chosen action 
opens B. Enter the requested informa-
tion in the dialog.

continues on next page

A Behaviors are shown in black if 
they are available for the particular 
element you chose, and in gray if they 
aren’t. You can’t select a grayed-out 
behavior.

B The Go To URL dialog is nice and simple. If you’re using frames, frame 
names appear in the “Open in” box.
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5. The default event for that action is dis-
played in the events column on the left 
side of the Behaviors panel C. If you 
want a different event, select it from the 
pop-up menu in the events column D 
by clicking the default.

To edit a behavior:
1. Select an object with an attached 

behavior.

2. Double-click the behavior name in the 
behaviors column of the Behaviors 
panel.

or

Select the behavior name and press 
Enter (Return). The dialog for the behav-
ior opens.

3. Change any parameters and click OK.

C The Behaviors panel shows the event 
handler and the behavior name.

Remove event

Move selected event up

Move selected event down

Add behavior

Show all events

Show set events

Event Behavior
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To change the order of behaviors:
If more than one behavior is attached to an 
object, the behaviors run in the order listed 
in the Behaviors panel, from the top to the 
bottom E. Select an event and use the up 
or down arrow to change the order.

To delete a behavior:
1. On your Web page, select an object 

with an attached behavior.

2. In the Behaviors panel, select the name 
of the behavior you want to delete.

3. Click the minus button.

or

Press Delete.

You can extend Dreamweaver by adding  
additional behaviors from the Adobe Dream-
weaver Exchange. Download the bonus online 
chapter “Customizing and Extending Dream-
weaver” (www.dreamweaverbook.com)  
for more information about extending 
Dreamweaver.

JavaScript you write yourself can be 
inserted in Dreamweaver. To learn more 
about JavaScript, check out another of our 
books: JavaScript: Visual QuickStart Guide
(Peachpit, 2011).

You might be wondering about those 
behaviors in the Effects submenu. We’ll cover 
them in Chapter 14, “Building Pages with 
Dynamic Elements.”

D If you want 
to change the 
event handler, 
click the event. 
An arrow 
appears, and 
clicking it brings 
up the pop-up 
menu.

E Behaviors 
attached to an 
element execute 
in the order in 
which they are 
listed in the 
Behaviors panel.

www.dreamweaverbook.com
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events and browsers
JavaScript includes many event handlers, such as onClick or onDblClick, as seen in figure D
of “Using the Behaviors Panel.” The name of the event handler is usually pretty descriptive of the 
user event involved.

Not every browser understands every event. Dreamweaver previously gave you a say as to the 
browsers you could choose events for, but as part of Adobe’s embrace of standards-compliant 
browsers, that ability was removed in Dreamweaver CS5. Now, the only behaviors in Dreamweaver 
are those that work in modern browsers.

Events can be applied only to certain tags. Table 13.2 shows specific event names and associ-
ated tags. Not all events available in Dreamweaver are listed here, and some event handlers avail-
able in JavaScript are not available in Dreamweaver.

Table 13.2 Dreamweaver Event Handlers

Event Triggered when Associated with

onAbort The user stops the browser from completely loading the object documents, images

onBlur A field loses focus form fields

onChange The user changes a default value on the page form fields

onClick The user clicks an object links, forms

onDblClick The user double-clicks an object links, images

onFocus A field gains focus form fields

onHelp The user clicks F1 or something labeled Help links, images

onKeyDown The user presses a key on the keyboard form fields

onKeyPress The user presses any key form fields

onKeyUp The user releases a key form fields

onLoad When a page, frameset, or image finishes loading documents, images

onMouseDown The user presses the mouse button links, images

onMouseMove The user moves the mouse links, images

onMouseOut The user moves the mouse off a selected object links, images

onMouseUp The user releases the mouse button links, images

onMouseOver The user points the mouse at an object links, images

onReset The user clicks a form reset button forms

onResize The user resizes the browser window documents

onScroll The user scrolls up or down documents

onSelect The user selects text in a form field form fields

onSubmit The user clicks the Submit button in a form forms

onUnload The user leaves a page documents
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adding Rollovers
Web users love rollovers, sometimes 
called mouseovers. There’s something 
endlessly pleasing about running a mouse 
over a page and watching things change. 
A color changes, an image changes, or 
an image somewhere else on the page 
changes or pops up. Web users also 
expect rollovers—if they move their mouse 
over an image and nothing happens, they’ll 
assume that it’s not a link and move on to 
something else.

To add a rollover:
1. Prepare two images, such as those in 

A and B, for the rollover’s Up and 
Over states.

2. Position the insertion point in the docu-
ment where you want the rollover to 
appear.

3. Select Insert > Image Objects > Rollover 
Image.

or

In the Common category of the Insert 
panel, click the arrow beside the Images 
icon and select Rollover Image C.

continues on next page

A An example of an 
Up state image.

B An example of an 
Over state image.

C The Images icon in 
the Common category 
of the Insert panel has 
a pop-up menu with 
several options.
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4. The Insert Rollover Image dialog 
appears D. Fill out the fields:

>	 Image name: This is the name that 
JavaScript uses internally to refer to 
this image.

>	 Original image: The path to the Up 
state of the image, which is what 
displays when the page is loaded.

>	 Rollover image: The path to the Over 
state of the image, which is what dis-
plays when the user’s cursor is over 
the image.

>	 Preload rollover image: This should 
be selected so the Over version of 
the image is in the browser’s cache 
when it’s needed. Don’t make users 
wait for the Over image to down-
load—they might think the page isn’t 
working and give up on your site.

>	 Alternate text: This is the alternate 
information for users with nongraphi-
cal browsers.

>	 When clicked, Go to URL: This is the 
URL of the Web page you want to 
open when the user clicks the image.

D Specify both the Up and Over images to insert a rollover image.
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5. Click OK to accept the changes.

6. Check the newly created events in the 
Behaviors panel to be sure they’re what 
you want E.

Note that if your rollover is within an 
HTML tag, that tag appears in the 
Behaviors panel. In this case, the roll-
over is within the a tag.

To preview the rollover, click the Live 
view button at the top of the document win-
dow and then roll over the image with your 
cursor. You can also preview the page in a 
browser to see the rollover.

Select the behavior in the Behaviors 
panel if you want to change the mouse events 
or edit the parameters of the Insert Rollover 
Image dialog.

Adding a single rollover adds two events 
to the Behaviors panel: one for the action 
of moving the mouse over the image (Swap 
Image) and one for the action of moving the 
mouse off the image (Swap Image Restore). 
Check to make sure that both parts are added, 
or your rollover won’t work the way you 
expect it to.

E Be sure 
the Swap 
Image Restore 
behavior is 
added along 
with the Swap 
Image behavior.

Image States
To understand rollovers, buttons, and 
navigation bars, you need to know some-
thing about image states. An image state 
corresponds with a mouse event. The 
most common image states are:

. Up: This image appears when the 
page first loads. It’s the default 
image, in that it’s what is displayed 
unless the user is interacting with this 
image.

. Over: This image appears when 
the user moves the mouse over the 
image.

. Down: This image appears when the 
user clicks the image. Down state 
images are often used in navigation 
bars to indicate the current page.

. OverWhileDown: This image appears 
when the user moves the mouse over 
an image after clicking.

Most rollovers use only the Up and 
Over states.
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Opening a New 
browser Window
It isn’t a good idea to open a new browser 
window unless you really, really need one. 
Some users may not realize that a new 
window opened. Users may become lost or 
confused by the grayed-out Back button. 
Users may not realize they must close the 
new window to get back to the original 
page. Certain browsers, particularly those 
used by people with accessibility needs, 
may not deal with new windows in a way 
that helps the user understand what’s  
happening. Depending on the action you 
use to trigger the opening of the new 
window, some users may not see it at all. 
For example, setting a new window to open 
during an onLoad event is the trick to get-
ting a pop-up or pop-under ad in a user’s 
face, so many users set their browsers so 
that pop-up windows won’t open, ever.

Given all that, when is a new browser win-
dow justified? Consider it when the content 
of the new window is a small example 
or elaboration of one idea. Small means 
smaller than a normal-sized browser win-
dow. Small also means small in concept: if 
the main content of your page is already 
clear, a new window can add a little 
something that people can check if they’re 
interested. For instance, a reasonable use 
of a new window is to show an enlarged 
image of a product.

You should explicitly tell users that their 
click will cause a new window to open: 
“Click the image to see a larger view—
opens in new window.” Leave the decision 
about whether to click up to your users—
don’t blindside them with windows that 
automatically open without warning.
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To add the Open browser 
Window action:
1. Prepare an HTML page or image that 

will appear in the new window.

2. Select an object, such as a link or 
image, in the document window.

3. In the Behaviors panel, click the plus 
button to add a new behavior. Choose 
Open Browser Window from the pop-up 
menu, and the Open Browser Window 
dialog appears A.

continues on next page

A When you open a new browser window, you have all kinds of control 
over how it will appear.
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4. Fill out the following fields:

>	 URL to display: This is the HTML 
page or image that will appear in the 
new window.

>	 Window width and Window height: Set 
an exact pixel size for the new window.

>	 Navigation toolbar: Selecting this 
adds Back, Forward, Home, and 
Reload buttons.

>	 Location toolbar: Selecting this adds 
a location text box with the page URL 
showing.

>	 Status bar: Selecting this adds a 
display at the bottom of the browser 
window showing status information.

>	 Menu bar: Selecting this adds browser 
menu items, such as File, Edit, View, 
Go, and Help. This option applies only 
to Windows users; Mac users always 
have access to the menu.

>	 Scrollbars as needed: Selecting this 
adds scrollbars (horizontal or vertical) 
only if needed. If deselected, there 
will be no scrollbars. It’s a good idea 
to always select this attribute.

>	 Resize handles: Selecting this adds 
a gripper in the lower-right corner of 
the window for the user to drag, and 
a maximize button at the top of the 
window. If deselected, the user can’t 
resize the window by either method. 
This is another good attribute to rou-
tinely include.

>	 Window name: This is a required iden-
tifier needed by JavaScript. Remember, 
no spaces are allowed in this name.

5. Click OK to accept.

6. Check the default event. If it isn’t the 
event you want, select another event 
from the pop-up menu.

If the new window contains only an 
image, the pixel dimensions of the image and 
the pixel dimensions of the window won’t 
be an exact match. For better control, many 
designers put the single image on an HTML 
page and link to the HTML page.

Dreamweaver can be extended with 
an action to add a “Close Window” script 
to an HTML page. It’s a good idea to give users 
an obvious way to close the new window. 
See Appendix B, “Customizing and Extending 
Dreamweaver” for more information.

Though it’s certainly reasonable to use 
Dreamweaver’s built-in behaviors to work with 
opening windows, you might instead want to 
use a widget based on jQuery or Spry to do 
the job, especially if you’re displaying some-
thing like an image gallery. A widget is likely 
to be more flexible to use. See Chapter 14 
for more.
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Checking for Plug-ins
The Check Plugin behavior sends users 
to different pages depending on whether 
they have particular plug-ins. For example, 
if a user has Flash installed, you might 
send them to one page; otherwise, you 
might send them to a page where they get 
the same information but without Flash.

You can depend on most Dreamweaver 
behaviors to work on a wide variety of 
browsers, but the Check Plugin action 
smacks into some browser issues. You 
can’t detect plug-ins in Internet Explorer for 
Windows using JavaScript.

In general, plug-ins are on their way out, 
driven in large part by Apple’s refusal to 
support Flash on their mobile devices 
and Adobe’s subsequent abandonment 
of its mobile Flash development, but also 
because HTML5 can now handle displaying 
rich media content natively. Plug-in detection  
is still useful for desktop browsers, but it’s 
rapidly becoming yesterday’s technique.

To add the Check Plugin action:
1. In the document window, use the tag 

selector to select either the document 
(the body tag) or a link (the a tag).

continues on next page
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2. In the Behaviors panel, click the plus 
button and select the Check Plugin 
action from the pop-up menu. The 
Check Plugin dialog opens A and 
shows the following:

>	 Choose a plug-in from the pop-up 
menu: Flash, Shockwave, Live Audio, 
QuickTime, or Windows Media Player.

or

>	 Click the Enter radio button and type 
the name of a plug-in in the text 
box. The name must be exactly the 
same as the name in bold on the 
Enabled Plugins page in a Mozilla-
based browser such as Firefox. 
To see the Enabled Plugins page, 
enter about:plugins in the Firefox 
address bar.

>	 If found, go to URL: Enter the URL in 
this text box. This field is optional; if you 
leave it blank, the user stays on the 
same page if the plug-in is detected.

>	 Otherwise, go to URL: Enter the 
alternate URL in the text box. If you 
leave this field blank, users without
the plug-in stay on the same page.

>	 Always go to first URL if detection is 
not possible: When detection is impos-
sible, the user is normally sent to the 
URL in the “Otherwise, go to URL” box. 
But if you select this check box, the 
user instead goes to the first URL (the 
one labeled “If found, go to URL”). If this 
is selected, users may be prompted by 
the browser to download the plug-in.

3. Click OK to accept changes.

4. Check the default event in the Behaviors 
panel to be sure it’s the one you want.

A You can check for any plug-in if you know the 
correct name for it. In this case, we’re looking for 
the Flash plug-in, which is in the pop-up menu.

All Netscape browsers since version 2.0 
can detect plug-ins. By “Netscape browser,” 
we mean Netscape Navigator, Netscape Com-
municator, Mozilla Firefox, and other browsers 
based on any of these.



ptg8274339

Using Behaviors and Navigation Objects 353

Using Jump Menus
A jump menu is a pop-up menu listing links 
to documents or files. When users choose an 
item, they “jump” directly to the new URL.

Jump menus save space on the page. For 
example, to find a retailer in your area, 
you might be asked to select your state or 
country. A list of states or countries could 
be very lengthy. Putting the links in a jump 
menu saves you from listing them in full as 
part of the page layout.

In addition to the required list of linked 
items, a jump menu can optionally include 
a menu selection prompt, such as “Select 
one,” and a Go button.

To insert a jump menu:
1. Place the insertion point in the 

document.

2. Select Insert > Form > Jump Menu.

or

In the Form category of the Insert panel, 
click the Jump Menu button.

The Insert Jump Menu dialog 
appears A. Fill it out as follows:

>	 Menu items: Don’t type anything 
in this list. As you add items to the 
menu, they automatically appear.

Move items up or down in the list by 
selecting one and using the up or 
down arrow to change its order.

>	 Text: Type the text you want for the 
menu item. You can type a prompt 
such as “Choose one” here. For text 
to be a prompt, leave the URL blank.

>	 When selected, go to URL: Browse 
for or type the URL to go to here.

continues on next page

A Here’s a brand-new Insert Jump Menu dialog, 
ready for you to add as many items as you want.
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>	 Open URLs in: Select the window 
where you want the URL to display. 

>	 Menu ID: Type a name here for 
JavaScript to use; as always, it cannot 
contain any spaces.

>	 Insert go button after menu: Select 
this if you want a Go button. The Go 
button isn’t required to make the 
menu work for users with JavaScript 
enabled in their browsers. If the user’s 
browser doesn’t use JavaScript, the 
Go button is needed.

>	 Select first item after URL change:
If you entered a prompt in the Text 
field, select this.

3. Click OK to accept your changes, and 
the jump menu appears on your page.

To edit a jump menu:
1. Double-click the behavior name in the 

Behaviors panel. The Jump Menu dia-
log opens B.

2. Make any changes needed.

3. Click OK to accept the changes, and 
the revised jump menu appears in your 
document.

B When you edit a jump menu, some of the 
original options are missing, particularly the 
“Insert go button after menu” choice.
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To insert a jump menu Go button:
1. Select an insertion point in the docu-

ment window. A jump menu must 
already exist in the document.

2. Insert a button from the Forms category 
of the Insert panel. In the Property 
inspector, set the button’s Action to 
None and its Value to Go (or something 
similar), as in C.

3. In the document, select your new but-
ton. In the Behaviors panel, click the 
plus button and select Jump Menu Go. 
The Jump Menu Go dialog opens D.

4. Select a jump menu for the Go button 
to activate. A Go button needs to be 
associated with a jump menu to work. 
If you have only one jump menu on the 
page, you can take the default.

5. Click OK to add the behavior to the but-
ton. The finished menu appears on the 
page E.

A jump menu requires a form, which 
Dreamweaver adds automatically. You’ll notice 
the red form indicator bordering the jump 
menu in the document window, and you’ll see 
a form tag in the tag selector bar.

C Make sure your new button has a value and 
that it doesn’t have an action.

D The Jump Menu Go dialog attaches a Go 
button to an existing jump menu of your choice.

E The finished 
jump menu, with a 
Go button.
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Validating Forms
Dreamweaver behaviors can check up on 
how users complete forms. You can require 
certain fields, check to make sure that a 
user has entered a value in a required field, 
or check to make sure that the user entered 
the correct type of information in a field.

With the Validate Form behavior, you can 
set parameters for an entire form. You can 
also use the Validate Form behavior on indi-
vidual fields. See Chapter 11, “Using Forms 
and Fields,” for more information about 
making a form with Dreamweaver, and 
Chapter 14, “Building Pages with Dynamic 
Elements” for form validation routines using 
the Spry or jQuery JavaScript frameworks.

To validate a form:
1. In the document window, select the 

Submit button.

or

Select the form tag from the tag selector 
at the bottom of the document window.
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2. In the Behaviors panel, click the plus 
button and select Validate Form. The 
Validate Form dialog opens A:

>	 Fields: Select a field in the box.

>	 Required: Select this if the user must
enter data in this field for the form to 
be accepted.

>	 Anything: Select this radio button if 
any combination of text and numbers 
is acceptable.

>	 Number: Select this if you want the 
user to enter a zip code, phone  
number, or other strictly numerical data.

>	 Email address: Select this if you want 
to check for an @ symbol within the 
entered data.

>	 Number from: Select this if you need 
to check for a number within a speci-
fied range.

3. Select the remaining fields in the Fields 
box and set the parameters for each 
until you have completed the dialog for 
each field in the form.

4. Click OK to accept your changes.

A One form validation option is to require an email address from the 
user. You can also see here why you should always name your form fields: 
it makes it easier to know which field is which in this dialog.
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You can also select an individual form 
field and add a Validate Form behavior. The 
dialog is the same, but the event handler (that’s 
the real name for those fields on the Behaviors 
panel) is different. Check the Behaviors panel 
to be sure it’s the correct event (onBlur or 
onChange) when setting validation parameters 
field by individual field. Be careful with this 
method, because it can get annoying to a user 
who wants to skip certain questions and come 
back to them later. Saving the validation for 
last, when the user finally clicks the Submit  
button, is a better idea.

When a user enters something incor-
rectly or neglects to fill in a required field, a 
JavaScript alert box similar to B pops up with 
a message about the error.

It’s good practice to give users an explicit 
cue when a field is required. An asterisk next 
to a required field is a common visual cue, 
along with a note to the user that the asterisk 
denotes a required field. You may have color-
blind users, so merely formatting the required 
field labels in a different color isn’t considered 
adequate.

The Dreamweaver behaviors for validat-
ing forms are different from server-side scripts 
used to handle submitted information. The 
same validity checks on user data you add 
with Dreamweaver should also be done with 
server-side scripts. Why both? The server-side 
checks are necessary because not all users 
have JavaScript enabled in their browser 
(some mobile browsers may lack JavaScript 
altogether). The client-side JavaScript checks 
added here are also useful because they give 
faster feedback to users.

B The user sees an alert if the form validation 
requirements aren’t met.
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Inserting Fireworks 
Pop-Up Menus
If you own Adobe Fireworks, you can use 
it to create a pop-up menu. When you 
insert a Fireworks pop-up menu into a 
Dreamweaver document, it’s best to use 
the round-trip editing feature to edit the 
menu in Fireworks. You will be able to edit 
the pop-up menu in Dreamweaver, but if 
you do, you lose the ability to edit it in Fire-
works later. Stick with Fireworks.

When you have the Fireworks pop-up menu 
completed, simply export it. Fireworks cre-
ates all the image and HTML files for you 
and adds them to the Dreamweaver site root 
folder. With the files in your site folder, you’re 
ready to insert the menu in Dreamweaver.

To insert a Fireworks pop-up menu:
1. Place the insertion point in the docu-

ment where you want the menu.

2. Choose Insert > Image Objects >  
Fireworks HTML.

or

In the Common category of the Insert 
panel, click the pop-up menu by the 
Images icon and select Fireworks 
HTML A.

The Insert Fireworks HTML dialog 
opens B.

continues on next page

A You can choose to 
add Fireworks HTML 
from the Images icon in 
the Common category 
of the Insert panel.

B Getting Fireworks HTML into Dreamweaver is as easy as 
pointing to the HTML file.
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3. Browse for or type the name of the 
Fireworks HTML file.

4. (Optional) Select the “Delete file after 
insertion” option if you no longer want 
the Fireworks HTML to be stored as a 
separate file. Selecting this option won’t 
affect the source PNG file associated 
with the HTML file or your ability to use 
round-trip editing to edit the pop-up 
menu in Fireworks.

5. Click OK to insert your menu. All the 
HTML, image links, and JavaScript 
connected to the pop-up menu are 
inserted in the appropriate areas in 
the document.

Deleting the HTML file after insertion 
has its pros and cons. You might want to keep 
it around to use elsewhere, or you might want 
to delete it to clean up after yourself. Either 
way, you can re-create it inside Fireworks, 
so if you delete it accidentally, it’s not the end 
of the world.
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14
Building Pages with 
Dynamic Elements

A common feature of modern Web sites 
is widespread user interactivity enabled 
by extensive use of CSS and JavaScript. 
This allows applications that run inside a 
Web browser to offer the kind of respon-
siveness that was once reserved for 
native applications.

In Dreamweaver CS3, Adobe added a library 
of widgets to enable Web builders to make 
their sites look like cutting-edge destinations. 
This library—also referred to as a frame-
work—is named Spry. In Dreamweaver CS5, 
Adobe expanded the program’s ability to use 
other, more popular frameworks (Spry never 
really caught on outside Dreamweaver), such 
as jQuery. No matter the framework, you 
don’t need to know anything about CSS or 
JavaScript to use widgets.

In this chapter, we’ll take a quick look at 
the Spry elements that come with Dream-
weaver, but we’ll focus on working with 
jQuery and using the Adobe Widget 
Browser to use elements from other frame-
works in your pages. And we’ll end the 
chapter with one of Dreamweaver CS6’s 
new features: CSS3 transitions, which allow 
fancy effects without any JavaScript at all.

In This Chapter
What Are Spry and jQuery? 362

Adding Spry Elements 364

Using the Adobe Widget Browser 366

Using Widgets 370

Adding CSS3 Transitions 372
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What Are Spry 
and jQuery?
Before you start using jQuery and Spry 
widgets, it helps to know a little bit more 
about the frameworks and how they work 
behind the scenes.

A (brief) history of frameworks
When people first started adding JavaScript 
to pages, they quickly realized that a lot of 
the work they were doing was the same 
stuff, over and over and over again. In recent 
years, it’s become common to let JavaScript 
handle more and more of the user interface 
(UI) duties. This means that Web sites have 
become smarter and more flexible, but it’s 
also been a lot more work for people who 
write code. Programmers tend to hate writing 
new code when they know someone else 
has already solved that particular problem. 
Instead, they go looking for free code offered 
by others, and in return offer their own 
solutions. The result is shared libraries of 
code that can handle most of the usual user 
interface requirements.

However, programmers also tend to have 
definite (and idiosyncratic) opinions about 
the “right” way to write code, and the result 
of that has been the creation of many dif-
ferent frameworks. If you’ve ever heard 
of libraries such as Dojo, YUI, or Prototype, 
they’re all more or less the same thing, 
built by developers who thought that their
way of doing things was better than what 
already existed.

Spry is Adobe’s answer to this challenge, 
geared to work with Dreamweaver. It’s not 
an application; instead, it’s a collection of 
code snippets (both CSS and JavaScript) 
that when added to your pages creates 
some standard effects.

What’s in Spry
Spry contains three types of components:

n	 Widgets: These elements let you create 
a more interactive Web site. There are 
two main types of widgets: UI widgets 
(such as the accordion, menu bar, and 
collapsible panel) and form validation 
(such as text fields and text areas).

n	 Effects: Unlike widgets, effects don’t 
so much interact with the user as just 
look good on their own. You can use 
effects to visually highlight transitions or 
to emphasize elements on your page. 
Some examples of effects are highlight, 
shrink, and squish.

n	 XML data sets: If you want data on your 
page that’s read from an external file, 
or you want users to be able to sort 
displayed information without having  
to reload the page, or you want to 
show some detailed information when 
the user selects various options, then 
you’re looking at using Spry data sets.
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n	 Active development community:  
If you have a question, you can ask it in 
their forum and get a fast response, or 
you can search the archives to see if it’s 
a FAQ.

n	 Plug-in architecture: If you need a feature 
that isn’t in jQuery, there’s a good chance 
that someone’s written it as a plug-in. An 
additional benefit of plug-ins is that you’re 
only adding them to your site when 
they’re needed—that is, you don’t have 
their added weight on every page.

n	 Speed: Even in tests created by its 
competition, jQuery comes out ahead 
(see http://mootools.net/slickspeed, 
for instance).

n	 Ease of use for non-geeks: Because 
its selection queries are based on CSS, 
someone who isn’t a full-time professional 
programmer can easily drop into jQuery, 
add some functionality to their site, and 
have it work the way they expect.

For all of the above reasons, jQuery has 
become one of the—if not the—most popu-
lar JavaScript frameworks available.

If after working with jQuery and Spry 
you decide that you want to learn more about 
JavaScript, we recommend another book 
we’ve written: JavaScript: Visual QuickStart 
Guide, Eighth Edition (Peachpit, 2012).

About jQuery
The jQuery framework (jquery.com) is a 
freely downloadable, open-source set of 
utilities and controls that help you build 
interactive Web applications. We think it’s 
one of the best, and since it’s become 
the most popular framework, it appears 
most other folks agree. These are some of 
jQuery’s strengths:

n	 Lightweight: It’s considerably smaller 
than many of its competitors, which 
means sites using it load more quickly.

n	 Ubiquitous: It’s very easy to integrate 
jQuery into your Web sites. You can 
host it on your own server, but many 
people prefer to use a link to jQuery 
hosted on one of the content delivery 
networks (CDNs), which are systems of 
servers spread throughout the Inter-
net’s infrastructure, connected by fast 
pipes. When the user needs jQuery, 
the CDN serves it up from the closest 
server to them, making the page more 
responsive. Google and Microsoft both 
host the latest version (and some older 
versions) of jQuery on their CDNs. Best 
of all, if the user has recently visited 
a page that uses jQuery, they may 
already have some of the jQuery files 
cached, making your site appear to be 
amazingly fast.

http://mootools.net/slickspeed
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Adding Spry Elements
By now, you’ve surely noticed the Spry cat-
egory A in the Insert panel. It’s just one of 
the many places where you can find Spry 
elements to add to your page.

This section shows you how to insert Spry 
elements on your pages. To learn much 
more about working with Spry and how 
you configure Spry widgets, see the bonus 
chapter “Using Spry Widgets.” Bonus 
chapters are included in the ebook edition 
of this book, and they are freely download-
able from www.dreamweaverbook.com for 
readers of the paper edition.

To add a Spry element:
For widgets and data objects: With the 
Spry category showing in the Insert panel, 
choose where on your page you want to 
add the element, and then click the desired 
Spry button.

or

For widgets and data objects: Choose 
Insert > Spry from the menu bar, and then 
choose which Spry element you want to 
add from the submenu B.

or

For form validation widgets: Choose 
Insert > Form from the menu bar, and then 
choose which Spry widget you want to add 
from the submenu B.

or

For UI widgets: Choose Insert > Layout 
Objects from the menu bar, and then 
choose which Spry widget you want to add 
from the submenu B.

or

A Spry widgets are found in the 
Spry category of the Insert panel.

For effects: Select the element on the 
page you want the effect to affect, click the 
plus button on the Behaviors tab of the Tag 
inspector, and choose an action from the 
Effects submenu C.

If you’ve added a widget, you’ll see the 
object on the page outlined with a bright blue 
border and the name of the widget. If you’ve 
added an effect, you’ll see it listed in the 
Behaviors tab of the Tag inspector.

Believe it or not, these aren’t all the 
places where you can find options to add Spry 
elements in Dreamweaver.

www.dreamweaverbook.com
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C Spry effects are considered behaviors, so they’re 
found in the Behaviors tab of the Tag inspector.

B Spry commands can be 
found in several locations 
in the Insert menu, as 
shown in this composite 
illustration.
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Using the Adobe 
Widget Browser
There are many JavaScript frameworks, not 
just jQuery and Spry, and it would be useful 
if developers could integrate components 
written in any of them into Dreamweaver for 
easy use by Web designers. Recognizing 
this fact, Adobe added the Adobe Widget 
Browser to Dreamweaver CS5. The Widget 
Browser is an Adobe AIR application that 
makes it easy to browse and download 
widgets (which Adobe is defining as small 
collections of JavaScript, CSS, and HTML 
packaged together to form a complex Web 
component) from the Adobe Exchange, 
a Web site that contains extensions for 
many Adobe programs (www.adobe.com/
exchange/). In Dreamweaver CS5.5, Adobe 
added the ability to launch the Widget 
Browser from Dreamweaver and to drag-
and-drop widgets from the Widget Browser 
directly into Dreamweaver’s Design view.

The problem that the Widget Browser 
solves is that while there are many widgets 
that are freely available on the Web, it 
can be difficult for designers to customize 
and configure the code for their particular 
needs. For example, while a widget may 
allow you to change its colors and fonts, 
it may not be easy to do so without dig-
ging into the code. The Widget Browser 
provides a user interface for this configura-
tion. However, for the Widget Browser to 
use a widget, the widget must be specially 
packaged for use by the Widget Browser 
and added to Adobe Exchange. The nice 
thing for the Web designer is that it doesn’t 
matter if the widget developer’s favorite 
JavaScript framework is jQuery, Spry, or 
others; as long as it is packaged as a wid-
get, Dreamweaver will be able to use it.

www.adobe.com/exchange/
www.adobe.com/exchange/
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With the Adobe Widget Browser, you 
can look through the available choices, 
preview them to see if they’ll do what you 
want, download widgets, and configure a 
widget to set its properties. After you have 
downloaded and configured a widget, the 
Widget Browser makes it available for use 
in Dreamweaver.

To browse and download widgets:
1. Choose Extend Dreamweaver > Widget 

Browser A.

2. The first time you launch the program, 
you’ll have to sign in to the Adobe 
Exchange using your Adobe ID. When 
you are signed in, the browser window 
appears B.

continues on next page

B The Adobe Widget Browser allows you to pick from a variety of new widgets for your pages.

A The Extend 
Dreamweaver 
menu looks 
like a gear in 
the menu bar.
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3. Click a widget in the browser window to 
get more information on it C.

4. To see the widget in action, click the 
Preview button in the Widget Browser’s 
toolbar. The widget preview is dis-
played D.

Depending on the widget, you may be 
able to click the preview to try it out. 
Also, presets may appear on the left 
side of the window, allowing you to 
change the parameters of the widget.

C Clicking a widget gives you details about it.

D Click the Preview button in the Widget Browser’s toolbar to 
take the widget for a spin.
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5. When you find the widget you want, 
click the Add to My Widgets button to 
download it to your computer and make 
it available for Dreamweaver’s use.

The widget downloads, and the Widget 
Browser displays a dialog that tells you 
that you can change the presets for the 
widget and that it has been added to 
Dreamweaver.

To configure a widget:
1. In the Widget Browser’s toolbar, click 

My Widgets.

The program shows you the widgets 
you have downloaded.

2. Click to select the widget you want to 
configure.

The widget appears in the Widget 
Browser window with the default pre-
sets. New features include a My Presets 
section in the preset area and a Config-
ure button below E.

3. Click Configure.

The window changes to show you the 
available parameters for the widget F.

4. Make any changes you want in the 
properties area on the left side of the 
window, and then enter a name for the 
preset in the Name field (you may also 
add an optional description).

5. Click Save Preset.

The new preset appears in the 
presets list.

E After you download the widget and add it to My 
Widgets, you can begin to configure it.

F Widgets allow you to configure and save your 
own presets.
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Using Widgets
Widgets that have been downloaded into 
the My Widgets panel of the Adobe Widget 
Browser and configured by you are avail-
able for use in Dreamweaver. You insert 
them into your pages as you would other 
Dreamweaver elements.

You can export presets as an XML file from 
your widgets, so you may share with other 
people a custom preset that you create for 
a widget. Of course, there is a matching 
import preset feature.

To insert a widget:
1. In Dreamweaver’s Design view (make 

sure that Live view is turned off), click in 
the document to place the cursor where 
you want the widget to appear, and 
then choose Insert > Widget.

or

From the Common category of the 
Insert panel, click Widget.

or

Drag-and-drop the widget you want 
from the My Widgets panel of the 
Widget browser into the Dreamweaver 
document window.

The Widget dialog appears A.

2. From the Widget pop-up menu, choose 
the widget you want to use.

The widget must have been made avail-
able to Dreamweaver by the Adobe 
Widget Browser to appear in this menu. 
Or to put it another way, you must have 
first added the widget to the My Wid-
gets section of the Widget Browser.

3. Choose the preset you want from the 
Preset pop-up menu.

4. Click OK.

The widget appears in the document B.

A Choose the widget, and then choose the 
preset you want for it; clicking OK inserts it on your 
page in Dreamweaver.

B The widget appears on the page, shown here 
in Design view. With this Google Maps widget, you 
can configure many aspects of the map, including 
the starting location, the map type, and more. 
Because we’re in Design view, the widget appears 
here as a placeholder.
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Because the widget is a dynamic 
element, if you’re in Design view, it 
appears as a placeholder. To see it 
working, click the Live View button.

5. If appropriate to the widget you are 
using, edit the widget’s settings, place-
holder text, or graphics to customize 
the widget’s contents for your page C.

Sometimes it is easier to change a 
widget’s text information in Code view than 
in Design view, because you can see with 
more precision where the text needs to go 
inside a div.

To export and import 
widget presets:
1. Switch to the My Widgets view of the 

Adobe Widget Browser.

2. Click the widget for which you want to 
export presets.

3. At the bottom of the left column of 
the Widget Browser, click the Export 
button D.

A Save File dialog appears, asking you 
to name the preset file and save it in a 
particular place. Do so, then click Save.

If you have not created any custom pre-
sets, the Export button may not be active. 
Also, all of the presets will be exported, 
not just the preset that’s currently 
selected in the Widget Browser. There 
isn’t any way to export a single preset.

4. Those who import the presets will 
need to have added the same widget 
that the presets were exported from 
to their copy of the Widget Browser, 
and of course they will need a copy of 
the exported XML file from step 3. To 
import the presets, they should click the 
widget they want to import the presets 
from, click the Import button, and then 
select the XML file with the presets.

C The inserted and configured maps widget, as 
shown in Live view.

D The Adobe 
Widget Browser 
now has the 
ability to export 
and import 
widget presets.
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Adding CSS3 
Transitions
You’ve seen how you can change a CSS 
property when the user performs some 
action. For example, in Chapter 8, you saw 
how to use CSS to make navigation menus 
without needing JavaScript. In that case, 
when the user hovered the cursor over 
a menu, the CSS property was changed 
instantly and the menu appeared or disap-
peared. But what if you wanted to have the 
CSS change from one property to another 
over time, creating an animation effect? 
You can do that with a CSS3 feature that 
is new to Dreamweaver CS6: CSS transi-
tions. Transitions are designed to smoothly 
change properties when triggered by the 
user’s interactions (hovering, clicking, and 

the like), and you have a lot of control over 
the effect’s duration and how the effect 
changes over time.

Here’s a page with a lovely gallery of 
alpacas, but we’d like to allow viewers 
to see an image at a larger scale when 
they hover the cursor over it. The image 
smoothly grows from its initial size to its 
final size. Here’s how to make it happen.

To add a CSS3 transition:
1. Open the gallery page in Dreamweaver, 

and choose Window > CSS Transitions.

The CSS Transitions panel appears A. 
It may appear as a floating panel. You 
can use it in this way, or you can drag it 
into the same tab group as CSS Styles, 
as we’ve done here.

A Begin with CSS transitions by opening the panel of the same name, which we’ve 
docked in a tab group with the CSS Styles panel.
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2. In the CSS Transitions panel, click the + to 
bring up the New Transition dialog, which 
is where all the work gets done B.

3. As always with CSS, start by figuring out 
the target rule. In this case, the action 
should happen on all images that are 
inside paragraphs, so the target rule is 
p img C.

4. Transition On is the pop-up menu where 
you set when you want your transition 
to occur D:

>	 active is triggered when an element 
is engaged or activated.

>	 checked is triggered when an ele-
ment (such as a check box or radio 
button) is selected.

>	 disabled is triggered when a UI ele-
ment is disabled.

>	 enabled is triggered when a UI ele-
ment is enabled.

>	 focus is triggered when an element 
on the page is given focus.

>	 hover is triggered when a user moves 
the cursor over an element but has 
not yet clicked it.

>	 indeterminate is triggered when the 
browser can’t tell if a UI element has 
been enabled or disabled.

>	 target allows one element on the 
page to modify another.

We want things to happen when users 
hover over the images, so we set Tran-
sition On to hover.

continues on next page

B The CSS transition is created entirely in this 
dialog.

C You first need to specify the target rule, either 
by choosing it from the pop-up menu or by typing 
it into the Target Rule field. Because we’ve chosen 
a compound rule here, we needed to type it in.

D Pick the event that will trigger your CSS 
transition.
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5. We could make the image’s height 
and width expand and shrink at dif-
ferent rates, but that would be obnox-
ious, so we’ll leave the default, “Use 
the same transition for all properties,” 
selected E.

6. The Duration setting is how long an 
effect takes to complete, and the Delay 
setting is how long the browser should 
wait before beginning the effect. Either 
can be set in seconds or microseconds; 
we’ll set Duration to 2 seconds and 
leave Delay alone F.

7.  Unless you can handle how Bezier 
curves work in your sleep, the Timing 
Function setting can be a little com-
plex G. Here’s a high-level cheat sheet:

>	 cubic-bezier(x1,y1,x2,y2): Allows 
more technical users to set their own 
values.

>	 ease: Transition starts moderately 
slowly, picks up speed, and then 
slows down gradually. Equivalent to 
cubic-bezier(0.25, 0.1, 0.25, 1.0).

>	 ease-in: Transition starts slowly, then 
speeds up at the end. Equivalent to 
cubic-bezier(0.42, 0.0, 1.0, 1.0).

>	 ease-in-out: Transition starts slowly, 
speeds up in the middle, and then 
slows down again at the end. Equiva-
lent to cubic-bezier(0.42, 0.0, 
0.58, 1.0).

>	 ease-out: Transition starts quickly, 
then slows down at the end. Equiva-
lent to cubic-bezier(0.0, 0.0, 
0.58, 1.0).

>	 linear: Transition occurs at a steady 
rate. Equivalent to cubic-bezier(0.0, 
0.0, 1.0, 1.0).

The default is ease, so that’s what we’ll 
stick with.

E You have the choice of using the same or 
different transitions for each property.

F Enter the duration and delay of the transition 
effect.

G The choices in the Timing Function pop-up 
menu describe the speed of the transition effect 
over time.
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8. Property is where you choose the prop-
erties that you want to modify. Click 
the + button under Property to select 
your choice from the pop-up menu H. 
Dreamweaver lets you set each prop-
erty’s end value, so the choices avail-
able on the right will vary depending 
on which property you’re changing (for 
example, the visibility property has 
the end values shown in the pop-up 
menu in I).

Here, we’re going to set two proper-
ties (height and width), and our end 
values will be three times the size of the 
current value. That is, our image width 
of 256 pixels and image height of 192 
pixels become 768 and 576, respec-
tively J.

Repeat this step for each property of 
the target rule that needs a transition.

continues on next page

H Pick the property you want to modify with the 
CSS transition. If you have more than one property 
you want to modify, you’ll be using this pop-up 
menu for each property.

I The choices available for End Value change to match the allowable 
values for the selected property. For the visibility property, for 
example, the End Value choices are included in a simple pop-up menu.

J Here, we are setting the end value of the height property to 576 
pixels. As usual in Dreamweaver, you can choose different units from the 
pop-up menu, such as points, ems, percentage, and the like.
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9. Finally, decide where you want to  
create the transition—in the current 
page, or in a new or existing external 
style sheet K. When you’re done, click 
Create Transition.

10. Switch into Live view, or load the page 
in your browser L, and view the result-
ing beauty of the gentle members of 
the camelid family M.

If you’re not sure about which Timing 
Function setting to use, play around with 
them! The best way to decide is to just try 
different values and see which one works best 
for you.

If you want a rule that applies to a par-
ticular ID or class and you’re having trouble 
remembering the name, click the Target Rule 
pop-up, and you’ll get a list of every CSS prop-
erty currently in use.

The end values of properties aren’t 
always sizes. Because of the varying nature 
of properties that support transitions, you can 
have anything from color pickers on up. The 
choices for text-shadow, for instance, are 
fairly complex N.

K Choose whether you want the transition to be 
saved in an existing style sheet or a new one.

L When the page loads, all three images are the 
same size.

M Hovering over one of the images applies the 
CSS transition, zooming the image to three times 
its original size.

N Depending on the property, there will be a 
variety of possible settings. For example, the  
text-shadow property allows you to set horizontal 
and vertical offsets and the amount of blur for the 
text shadow, and it includes a color picker so you 
can set the shadow’s color.
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Working with Content 
Management Systems
A particularly powerful feature in Dream-
weaver CS6 is the ability to work with 
sites that are built upon the foundation of 
a content management system (CMS). 
There are many types of CMSs, but the 
ones we (and Dreamweaver) focus on are 
Web content management systems, which 
are applications that run on a Web server 
and create and manage Web content. The 
CMS manages and controls a dynamic col-
lection of Web material and usually (but not 
always) assembles and creates Web pages 
that are served to the user “on the fly”; that 
is, the page is built and sent to the user 
when the user requests the page. Unlike 
the static HTML pages we discuss creating 
in most of the rest of this book, pages that 
come out of a CMS often don’t exist at all 
before the CMS software puts together the 
HTML, CSS, images, and scripts and squirts 
them over the Internet to a user’s waiting 
Web browser.

Dreamweaver CS6 supports three of the 
most popular Web CMSs: WordPress, 
Joomla, and Drupal. You can use Dream-
weaver to author and test content from any 
of these systems.

In This Chapter
About Content Management Systems 378

Connecting to Your CMS 380

Using Dynamically Related Files 384

Filtering Related Files 387

Using Live View Navigation 388

Freezing or Disabling JavaScript 390
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About Content 
Management Systems
Dreamweaver supports the three most 
popular PHP-based CMSs: WordPress, 
Joomla, and Drupal. (PHP is a program-
ming language that typically is installed 
and run on Web servers.) These systems 
have several things in common. They are 
all open-source projects and can be down-
loaded from their respective project Web 
sites at no cost. Many Web hosting com-
panies make it easy to install these CMSs 
from their hosting control panel, often with 
only a few clicks, demystifying what was 
previously a complex process. Installations 
generally (but not always) use a MySQL 
database to store and manage their data. 
As noted, Web pages and their elements 
are assembled by the CMS upon request, 
with text, images, and other content drawn 
from the database. The CMS takes content 
out of the database and serves it up as a 
Web page.

Pages generated by a CMS are based on 
templates that control the site’s look and 
feel. Because the content of the site is 
separate from its presentation, you can 
easily change the entire look of the site by 
modifying or switching the set of templates 
used by the site. A CMS can accommo-
date multiple users, with an administrator 
assigning different roles to particular users 
(for example, subscriber, contributor, edi-
tor, and so on). All of the systems provide 
plug-in architectures that make it easy for 
developers to extend the features of the 
core software.

Each CMS has its own passionate adher-
ents. Imagine that a group of Web geeks 
walk into a bar. After a few rounds of 
drinks, the conversation turns to an appar-
ently simple question: Which is the best 
CMS? The discussion goes on for a while, 
becoming more spirited, and, as more 
drinks are consumed, people’s opinions 
are expressed with more emphasis. Finally, 
the frank exchange of views ends when 
the bouncers break up the fistfight and turn 
everyone out into the street.

Let’s leave the sound and fury behind and 
just talk a bit about each of the three.

WordPress
In contrast with the other two systems, 
WordPress is primarily known as weblog 
creation software, though it is certainly not 
limited to creating weblogs. By far the most 
popular blog software, WordPress was 
in use by more than 70 million Web sites 
worldwide as of 2011. WordPress blogs are 
based on sets of templates called themes
and can include widgets that add extra 
features to a site, such as Twitter integra-
tion, easy access to the site archives, and 
much more. One of the reasons for its 
popularity is that it has an installer program 
that makes setting up WordPress relatively 
easy for the novice. You can use a single 
installation of WordPress to run multiple 
sites. WordPress’s home can be found at 
www.wordpress.org A. WordPress has a 
very active developer community, provid-
ing free and paid themes, widgets, and 
other plug-ins. These extensions add an 
incredible range of capabilities to the base 
WordPress installation.

www.wordpress.org
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Joomla
Joomla excels at creating larger sites, such 
as corporate Web sites, e-commerce sites, 
online newspapers and magazines, com-
munity sites, and government sites. Joomla 
is fairly easy to install and set up for the 
novice user. Many Web hosting services 
offer easy installs that help you get your 
site up and running with little effort. Web 
designers can create sites in Joomla, and 
then turn the sites over to clients to add 
and manage content. Joomla’s user man-
agement system can be configured to give 
different user groups varying levels of per-
missions for editing and publishing. Joomla 
allows the administrator to easily set up 
polls and provides extensive template 
management features. You can get started 
with Joomla at www.joomla.org B.

Drupal
Well known as a workhorse for sites with 
heavy traffic, Drupal is in use at many large 
corporate and government sites, including 
Sony Music, Popular Science magazine, and 
whitehouse.gov. The CMS makes it easy to 
create a static Web site, a single or multiuser 
blog, online forums, or a community Web 
site that can accept user-generated content. 
Drupal sites also boast advanced search 
features, a robust commenting system, a 
multilevel menu system, and the ability to 
host multiple sites from a single installation. 
Drupal is widely considered to have a steep 
learning curve for new administrators but 
makes up for it in part by having excellent 
performance in delivering pages and being 
scalable when your site becomes popular. 
Drupal’s home is at www.drupal.org C.

In this chapter, we’ll use a WordPress blog 
in our examples. There are only minor 
differences in the way that Dreamweaver 
interacts with each of the three CMSs.

A The WordPress Web site has launched a 
zillion blogs.

B The Joomla site lets you download the CMS 
and boasts extensive documentation to help you 
get started.

C Like the sites of the other two systems, the 
Drupal site provides news about the platform.

www.joomla.org
www.drupal.org
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Connecting to 
Your CMS
To get started working on your site, you’ll 
need to make the initial connection to the 
CMS in Dreamweaver. You can work with 
a testing server (preferred) or directly on 
your live server.

You need to let Dreamweaver know where 
each of the servers resides. If you have a 
local testing server (see the “Using XAMPP, 
MAMP, and LAMP for Local Testing Serv-
ers” sidebar), you need to make sure that it 
is installed, configured, and running.

A Before you can discover dynamically related files, you have to set up a testing server.

B You define the testing server in the Site Setup dialog.

To connect to your CMS:
1. If you have not already done so, define 

the local and remote sites. See Chap-
ter 2 for more information, if necessary.

2. In the Files panel, open the folder 
that contains your dynamic site and 
double-click the index file (usually 
called index.php).

Dreamweaver opens the file, but you 
don’t see any content. Instead, in a 
status bar at the top of the document 
window, Dreamweaver tells you that 
you need to set up a testing server A.

3. Click the Setup link in the status bar.

Dreamweaver opens the Site Setup 
dialog, which is set to the Servers 
category B.
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4. (Optional: Perform this step only if you 
want to use the live remote server as 
the testing server, which we do not rec-
ommend.) Select the Testing check box 
next to the previously defined remote 
site, and then skip to step 10.

5. Click the plus button at the bottom left 
to add a server.

6. In the resulting dialog C, enter a name 
in the Server Name field (we recom-
mend Testing Server).

7. Choose Local/Network from the Con-
nect Using menu.

8. Click the folder icon next to the Remote 
Folder field, and navigate to the local 
copy of your site that is inside the 
appropriate Web directory on your test-
ing server.

Depending on the testing server soft-
ware you’re using, this folder could be 
named /www/ or /htdocs/.

9. Click Save.

You return to the Site Setup dialog, and 
now you can see that a testing server 
has been added and selected as the 
Testing server D.

10. Click Save to close the Site Setup dialog.

It’s possible for you to use the same 
server as both the remote server and the 
testing server. You’ll have to decide if you are 
comfortable with the risk of messing up your 
live site as you make changes to it.

C Enter the testing server configuration 
information in the server definition dialog.

D You can tell at a glance which server is the 
remote server and which is the testing server.
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Using XAMPP, MAMP, and LAMP for Local Testing Servers
A CMS needs a server to run on, and the CMSs supported by Dreamweaver need a server that 
must be running at least three programs: a Web server program, such as Apache; the database 
program MySQL; and the programming language PHP.

Most professional sites use at least two servers: a server on which content is developed and 
tested (called a local, testing, or staging server) and the server that the site’s users interact with 
(the live or production server). In many situations, the testing server is on a machine elsewhere on 
a company intranet, or even on the Internet (suitably access-protected, of course; you probably 
don’t want people looking at your site while it’s under construction). You might, for example, create 
a subdomain at your Web hosting company for your testing server. So the main, live site would be 
at www.domain.com, and the testing server could be at test.domain.com.

If you don’t have a handy intranet, you can run the testing server on your own machine with the 
help of three freely downloadable packages: XAMPP for Windows (www.apachefriends.org/en/
xampp.html), MAMP for Mac (www.mamp.info), and LAMP for Linux (many possibilities, because 
of the sundry Linux distributions; Google the LAMP package for the Linux distro you use). These 
packages make it easy to install an instance of Apache, PHP, and MySQL on your machine; install-
ing these programs can otherwise be frustratingly complex and difficult. In contrast, installing and 
using XAMPP, MAMP, or LAMP is a simple process, like working with any other program.

The Mac and Windows packages have a 
control panel A from which you can access 
the Web-based configuration tools for the 
running server programs (the Linux version is 
controlled from the command line in a termi-
nal application). You will also have to create a 
local installation of your preferred CMS. Once 
you have local and remote versions of your 
site, you can work with the different files on 
your machine and use Dreamweaver’s syn-
chronization tools to upload changes from the 
testing server to the live remote server.

A The MAMP control panel gives you the server 
status and lets you start and stop the Apache and 
MySQL servers.

www.domain.com
www.mamp.info
www.apachefriends.org/en/xampp.html
www.apachefriends.org/en/xampp.html
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Using XAMPP, MAMP, and LAMP for Local Testing Servers continued

If you do a lot of WordPress development, there’s an excellent paid ($50) alternative to the open-
source testing servers called DesktopServer (www.serverpress.com) B. It’s based on MAMP and 
XAMPP, but it has many specialized features for WordPress developers (not to mention that it is con-
siderably easier to set up for use with Dreamweaver). DesktopServer includes a preconfigured copy 
of WordPress, so you don’t need to install it separately. It automatically creates a testing server with 
your site name mapped to the pseudo top-level domain .dev (for example, www.yoursite.dev), so 
it’s easy to tell the live version of your site from the local testing server when previewing in a browser. 
The program allows you to import live WordPress sites, and it creates a local testing server and then 
a Dreamweaver Site Definition file that you import into Dreamweaver. You can work on the local test-
ing copy of your WordPress site and then export and deploy it to your live server.

B DesktopServer allows professional WordPress developers to easily create 
local testing servers, experiment with site design changes, and then deploy to 
live servers with a few clicks.

www.serverpress.com
www.yoursite.dev
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Using Dynamically 
Related Files
As mentioned earlier in this chapter, Web 
pages served by a CMS are assembled on 
the fly from many different elements (often 
dozens or hundreds of PHP, JavaScript, 
CSS, and other types of files), so you often 
have no idea exactly what the page will look 
like until you preview it in a Web browser. 
Each CMS has a back-end administrative 
interface where you enter content and con-
trol the elements of the site, but they all rely 
on browsers to view the final output.

As you might guess, this presents a chal-
lenge for a tool like Dreamweaver. It 
requires the CMS to put together the page 
you want to work with before Dreamweaver 
can show it to you. Then Dreamweaver can 
display the page to you in Live View.

Dreamweaver knows how to work with the 
supported CMSs so that it can discover 

all of the files that go into building the 
page you want to work with in the docu-
ment window. Once Dreamweaver has 
discovered all the files that make up the 
document, it lists them in the Related Files 
toolbar. You can then open any of the 
related files and edit them using Dream-
weaver’s tools. Dreamweaver makes it 
relatively easy to do something that was 
previously quite difficult and required seri-
ous expertise in a particular CMS: find the 
particular related files you need.

To discover dynamically related files:
1. In the Files panel, double-click a file you 

want to view (you will usually start with 
index.php).

Dreamweaver displays a status bar 
under the document toolbar letting 
you know that “This page may have 
dynamically-related files that can only 
be discovered by the server” A.

A Dreamweaver lets you know that you need to discover the dynamically 
related files.
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2. Click the Discover link in the status bar.

Depending on the CMS, Dreamweaver 
may display a Script Warning dialog B.

3. Click Yes to dismiss the Script Warning 
dialog.

Dreamweaver begins discovering the 
dynamically linked files and displays 
them in the Related Files toolbar.

4. If you’re not already in Live View, 
Dreamweaver may use the status bar 
to alert you that you need to switch to 
that view. Click the Live View link in the 
status bar.

Dreamweaver displays the rendered 
page in the document window C.

B This alert dialog lets you know that to discover 
the dynamically related files, Dreamweaver must 
execute the scripts included in the page.

C The page in the document window is a dynamic page being served by WordPress.
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To work with dynamically 
related files:
n	 Clicking any of the files in the Related 

Files toolbar will change the document 
window into Split view, displaying the 
file in the Code pane D.

n	 You can click the Inspect button in 
the document toolbar to turn on CSS 
Inspect mode, so you can see the box 
model for elements on the page E. 
Just hover over an element on your 
page, and it displays with different col-
ors for the background, margins, pad-
ding, and borders. For more information 
about CSS Inspect mode, see “Using 
CSS Inspection” in Chapter 9.

n	 Nobody’s monitor is wide enough to 
display all of the dynamically related 
files, so the Related Files toolbar now 
supports scroll arrows on either end 
when there are too many related files to 
display F. Scroll as needed to find the 
files that you want to work with. Click 
the Show More button next to the right 
scroll arrow to display the related files 
in a menu G.

D Clicking this CSS file in the Related Files 
toolbar displays it in Split view.

E In CSS Inspect mode, you can see the box 
model for elements on the page, with divs and 
padding in different colors.

Show MoreScroll

F When there are too many 
files to fit in the window, the 
Related Files toolbar scrolls.

G The Show More 
menu displays all of the 
related files.
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Filtering Related Files
One of the problems with discovering the 
dynamically related files in a CMS-backed 
site is that you can get an embarrassment 
of riches. There can be so many files that 
it can be difficult to scroll through them in 
the Related Files toolbar or find them in the 
Show More menu. Dreamweaver allows 
you to filter the related files to show only 
the file types you want. That lets you easily 
work on just the CSS files, for example, or 
those and the JavaScript files, hiding all the 
PHP files. You can also customize the filter 
to show only the files you want.

To filter related files:
1. At the right edge of the Related Files tool-

bar, click the Filter Related Files button.

Dreamweaver shows that the button is 
actually a menu that contains the file 
types in the Related Files toolbar A.

2. In the menu, deselect the file types 
you do not want to view. To go back to 
viewing all file types, choose Show All 
File Types.

To create a custom filter:
1. From the bottom of the Filter Related 

Files menu in the Related Files toolbar, 
choose Custom Filter.

The Custom Filter dialog appears B.

2. In the dialog, enter the filenames or file 
extensions you want to display in the 
Related Files toolbar. Separate different 
names or extensions with a semicolon. 
You can also use asterisks as wildcard 
symbols. For example, in B we used 
jquery* to create a filter that captured 
jQuery-specific files, producing the 
result shown in C.

3. Click OK to put your filter into action.

Filter Related Files button

A The Filter 
Related Files menu 
shows you the file 
types represented 
in the Related Files 
toolbar.

B Enter your custom filter criteria.

C After filtering, the Related Files toolbar (or, 
if there are enough files, the Show More menu) 
displays considerably fewer files.

You can filter the results in the Related 
Files toolbar at any time, not just when you are 
viewing dynamically related files.
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Using Live View 
Navigation
Live view, introduced in Dreamweaver 
CS4, renders pages in the Dreamweaver 
document window by using WebKit (the 
same page rendering engine found in sev-
eral standards-compliant browsers; WebKit 
is constantly being improved, so the ver-
sion of WebKit included in Dreamweaver 
has been updated in each successive ver-
sion of Dreamweaver). This greatly speeds 
Web development, because designers 
don’t always have to resort to previewing 
in a separate browser. But because Live 
view originally couldn’t follow links, you 
couldn’t easily explore your sites. Now that 
Dreamweaver can work with dynamically 
based sites, the ability to follow links is 
vital, so it was added in Dreamweaver CS5.

Live view navigation allows you to interact 
with server-side applications and dynamic 
data. In addition, Live Code view highlights 
changes as they happen, allowing you to 
quickly locate the dynamically loaded data 
or code changes triggered by JavaScript. 
You can also enter a URL in the Browser 
Navigation toolbar to inspect pages from 
a live Web server and edit pages you’ve 
browsed to, as long as they exist in one of 
your locally defined sites.

To use Live view navigation:
1. Open a document that contains links 

and elements that are updated via 
JavaScript—for example, a navigational 
menu.

2. Click Live Code in the Document 
toolbar.

or

Choose View > Live Code.

The document window splits to display 
both the Live Code and Live View panes 
A. As usual with Live Code, the Code 
pane isn’t editable but will show how the 
code changes as you interact with the 
document in the Live View pane.

3. Use the menu. As you do, note how the 
code changes in the code pane.

4. Click one of the links in the menu.

Notice that the link is not followed, as it 
would have been in a browser. Dream-
weaver does this purposely so that you 
can create, style, and modify active links.

Code added by JavaScript

A Live Code view shows you the code as it is being rewritten by JavaScript.
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5. To follow the link, Ctrl-click (Cmd-click) 
the link.

Dreamweaver follows the link.

6. To follow links as you would in a 
browser, choose Follow Links Continu-
ously from the Live View Options menu 
in the Browser Navigation toolbar B. 
You can then click a link in the Live 
View pane, and it will change to the 
link’s destination.

You can enter any URL in the address 
field of the Browser Navigation toolbar, and 
Dreamweaver will display the page in Live 
view and list its associated files in the Related 
Files toolbar C. If you click one of the files in 
that toolbar, Dreamweaver switches to Split 
view and displays the code, but it will also 
show a status bar telling you that you cannot 
edit the remote file.

B Choosing Follow Links Continuously 
makes Dreamweaver’s Live view treat links 
the same way a Web browser would.

C You can enter any URL you want in the Browser Navigation toolbar, and Dreamweaver will 
display that URL in Live view.
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Freezing or Disabling 
JavaScript
When you are working with interactive ele-
ments, it can be very useful to freeze the 
action when it is in a particular state. You 
can then inspect the code in that state with-
out worrying that a stray movement of your 
mouse will change the state (and therefore 
the code you’re trying to inspect). Dream-
weaver allows you to freeze JavaScript as it 
is executing. You can then edit your CSS or 
JavaScript and then refresh the page to see 
the effect of your changes. You can also dis-
able JavaScript altogether, which re-renders 
the page to show how it would appear in a 
browser that has JavaScript disabled.

A Dreamweaver lets you know when 
you freeze JavaScript.

To freeze JavaScript:
1. Click the Live View button in the Docu-

ment toolbar.

2. (Optional) Click the Live Code button in 
the Document toolbar.

3. Interact with the document in the Live 
View pane until the page is in the state 
you want.

4. Press F6.

or

Choose Freeze JavaScript from the 
Live View Options menu in the Browser 
Navigation toolbar (see figure B in 
“Using Live View Navigation”).

Dreamweaver displays a status bar tell-
ing you that JavaScript is frozen A.

5. (Optional) Edit your JavaScript or CSS. 
Save your changes, and then press F6 
to resume JavaScript rendering. Click 
the Refresh Design View button in the 
Document toolbar (or press F5) to see 
your changes.

To disable JavaScript:
Choose Disable JavaScript from the Live 
View Options menu in the Browser Naviga-
tion toolbar.
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Making Life Easier: 
Using Templates, 

Libraries, and Snippets
The first thing you do when you begin a 
site in Dreamweaver is define a site root 
folder, as discussed in Chapter 2. You tell 
Dreamweaver where you’re keeping all 
your site files, and Dreamweaver rewards 
you for sharing the information by making 
all sorts of cool site-wide tools available 
to speed up your workflow and make your 
life easier. In seconds, Dreamweaver’s site 
management tools can make changes to 
every file in your local site root folder—
changes that would take you much longer 
done one file at a time.

We’ll cover two of those timesaving whole-
site tools—templates and library items—in 
this chapter. In addition, you’ll learn how to 
create time-saving bits of reusable code 
called snippets. You access templates and 
library items from the Assets panel. Snip-
pets have a separate panel.

In This Chapter
Creating a Template 393

Adding Editable Regions 395

Removing Editable Regions 397

Building Pages Based on a Template 398

Modifying a Template 400

Creating a Library Item 403

Using a Library Item 405

Editing a Library Item 406

Working on Library Items with  
the Property Inspector 409

Using Dreamweaver Snippets 411
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Before getting into the details, some brief 
definitions are in order. Templates are like 
master page designs. They create a uni-
form page design for a site while allowing 
certain material on each page to be cus-
tomized for individual pages. Library items
are not full pages, but reusable objects 
with text, code, images, or other elements 
that you insert in documents; for example, 
you can create a navigation bar as a 
library item. Updating either a template 
or a library item results in the automatic 
updating of any page in the entire site that 
is attached to the template or library. Snip-
pets are custom-built code samples that 
you save for quick insertion. Changing a 
snippet doesn’t have any site-wide effects.

They Can’t Break Your Sites!
Pages made from templates are perfect for use in organizations that want relatively inexperienced 
people to be able to make changes and updates to sites without the possibility of accidentally 
“breaking” the site. In fact, Adobe has a program, Adobe Contribute (part of Adobe Creative Suite 
Web Premium and Master Collection, also available separately and as part of the subscription-
based Adobe Creative Cloud), that works hand in hand with sites built using Dreamweaver 
templates to allow people to add content and make changes to Web sites without being able to 
mess up the site’s design elements. With Contribute, the site designer can assign site contributors 
to user roles, which specify the editing tasks the user is allowed. For example, you can specify 
that a user can add text and change text on a page but can only style that text with CSS styles you 
supply, or you can prevent the user from styling text at all. You can also require that users send 
their changed pages to a supervisor for review before making the page live on the site. Many other 
permissions and restrictions are possible if people who work on your site use Contribute.

With the launch of the CS4 suite, Adobe introduced a hosted service called InContext Editing that 
worked entirely in a Web browser. With InContext Editing, inexperienced users could make simple 
changes to Web sites, again without the possibility of breaking the site. The separate InContext 
Editing service was discontinued in 2010 and rolled into a paid, more full-featured service called 
Business Catalyst, which is supported in Dreamweaver CS5 and later. To get more information 
about using Dreamweaver to work with Contribute and Business Catalyst, download “Working with 
Other Applications,” part of the bonus material from www.dreamweaverbook.com.

www.dreamweaverbook.com
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Creating a Template
Templates are perfect for many situations. 
For example, let’s say you have a large site 
where many different individuals change 
content and add pages. Using a template 
provides control over the page layout 
and design by restricting changes to only 
certain editable regions on a page. Other 
areas on the page are locked regions, 
which can’t be changed by people working 
on an individual page. Locked regions can 
be edited only in the original template file. 
This kind of control guarantees a consis-
tent look and feel for a site and prevents 
any accidental changes to locked regions.

When a change is made to a template, 
every page made from, or attached to, the 
template is automatically updated through-
out the entire site. You can create a tem-
plate from scratch, but it is simpler to use an 
existing page as a model for the template, 
and that’s what we’ll explain here.

Before you save a document as a template, 
make sure you’ve already included any 
needed <meta> tags, style sheets, behav-
iors, or other underlying parameters. These 
page elements are located in the locked 
regions of a template. There’s no way to 
add things like style sheet links to indi-
vidual pages made from a template—they 
must exist in the template already.



ptg8274339

394 Chapter 16

To create a template from 
an existing page:
1. Open the document you want to turn 

into a template.

2. Choose File > Save as Template.

or

Choose Make Template from the Tem-
plates pop-up menu in the Common 
category of the Insert panel A.

The Save As Template dialog appears 
with the Site pop-up menu set to the 
current local site B.

3. Enter the requested information in 
this dialog.

>	 Existing templates: You don’t enter 
anything in this field. Dreamweaver 
lists any existing templates for the 
site automatically.

>	 Description: Type a brief description 
of the template. This is optional but 
recommended.

>	 Save as: Type the name of the tem-
plate. You can omit the file extension; 
Dreamweaver takes care of that for 
you, as described next.

4. Click Save.

If it doesn’t already exist, Dreamweaver 
adds a Templates folder to your site 
files. Your new template will be inside 
this folder, with the file extension .dwt, 
which indicates that the document is a 
Dreamweaver template.

It’s possible to create a template from 
scratch. Choose File > New and select Blank 
Template in the New Document window. Or 
you can start one using the New Template but-
ton in the Templates area of the Assets panel.

A The pop-up menu 
for the Template 
icon in the Common 
category of the Insert 
panel covers the 
basic commands 
you’ll need.

B Any page can be saved as a template. The 
name you type in the Save as field will be followed 
by the file extension .dwt in the Assets list.

Templates are for local use; they’re never 
loaded in a browser. The Templates folder 
and its .dwt files don’t need to be uploaded 
to the server. Just upload the individual HTML 
pages made from the template. To make this 
easier, you can cloak the Templates folder, 
which prevents Dreamweaver from uploading 
it to the remote server. See “Cloaking Files 
and Folders” in Chapter 2 for more informa-
tion. On the other hand, you might choose to 
upload your Templates folder to the server 
so that you always have a handy backup of 
your templates.

There is still an InContext Editing 
category of the Insert panel. Though the 
standalone InContext Editing service has been 
discontinued, the functions in that panel still 
work with Business Catalyst.
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Adding Editable 
Regions
Once you’ve saved the .dwt file, you will 
want to open it and define any regions you 
want to be editable. Regions on the page 
that you don’t specifically mark as editable 
will be locked and can’t be changed by 
anyone who is using Contribute or Business 
Catalyst and working on pages made from 
your template—hey, that’s the whole point!

To add an editable region:
1. Open the template document.

2. Select the element to make editable (for 
example <div>, <img>, or <td>) with the 
tag selector in the document window.

or

Select the text to make editable. This 
choice is most useful when the text is 
within a div. Selecting the entire div, 
rather than just the text within it, makes 
everything about the div editable, 
including its position. You probably 
don’t want your users to be able to 
change anything other than the text, 
so select just that text and it will be the 
only editable part of the div.

3. Choose Editable Region from the Tem-
plates pop-up menu in the Common 
category of the Insert panel A.

or

Choose Insert > Template Objects > 
Editable Region.

The New Editable Region dialog 
appears B.

4. Type a name for the region.

continues on next page

A Use the pop-up 
menu for the Template 
icon in the Common 
category of the Insert 
panel to designate 
editable regions in 
the template.

B A short, descriptive name is best for a template 
region. It’s best not to use spaces in the name; 
instead, use the underscore character, as shown.
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5. Click OK.

The editable region will be outlined in 
green in the document window. A tab 
at the upper-left corner of the region 
displays the region name C.

6. (Optional) Delete the text that was in 
the region and replace it with some 
general instruction regarding the 
region—for example, “This region is for 
main content.” If you don’t do this, it’s 
OK—anyone making a page from the 
template can replace the text later.

You can make any of the following edit-
able: an entire table, the table header, a table 
row, or individual cells within a table. But you 
can’t put a table column or multiple noncon-
tiguous table cells in a single editable region.

Don’t use special characters in region 
names: no ampersands (&), single quote marks 
(’), double quote marks (”), or angle brackets 
(<) and (>). You can use spaces, but we recom-
mend you use the underscore character (_) 
instead to match the naming conventions of 
other items in Dreamweaver, such as form ele-
ments and CSS IDs.

Page titles (the title that appears at the 
top of a Web browser window, defined by the 
<title> tag) are editable by default on pages 
that are created from templates.

When you name your editable regions, 
give them region names that make their pur-
pose clear for the people who will eventually 
be entering content into the region, such as 
Main_Content in this example.

Region name

C In the document window, the editable region is indicated by a visible tab giving the 
region name.
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Removing Editable 
Regions
If you make a region editable and later 
decide you want to lock it instead, it’s easy 
to remove the editable region. This doesn’t 
remove the content within the region; 
it removes the ability of the user to edit 
anything in the region. As the designer, you 
can still put any content you want in the 
region. But that content won’t be editable 
by the user.

To remove an editable region:
1. Click the tab in the upper-left corner of 

the region to select the region.

2. Choose Modify > Templates > Remove 
Template Markup A.

3. The region is locked.

Other Kinds of Template Regions
Dreamweaver can create more complex editable areas in addition to the basic editable region. 
These kinds of editable regions are used less frequently, but they’re still useful when you need 
them. You probably noticed the options in the Templates pop-up menu in the Common category 
of the Insert panel (see figure A in “Creating a Template” and figure A in “Adding Editable 
Regions”). They are:

. Repeating Region: Repeating regions can be duplicated by the user as often as needed. 
They’re useful for things that vary from page to page— for example, a chart of product colors or 
sizes or a list of recipe ingredients. Repeating regions aren’t editable until you define the edit-
able areas of the region.

. Optional Region: You set conditions for optional regions, indicated by the word if in the tab 
showing the region name. Optional content can be either hidden or displayed, depending 
on whether the conditions are met. For example, let’s say that you have a page of upcoming 
events. You have an image that says “Coming Soon!” that you want to appear next to events 
that will occur in the next month. You can write code that checks the date and then displays the 
“Coming Soon!” image in an optional region when the code expression is true.

. Editable Optional Region: As with optional regions, you can decide whether or not to display 
content in these regions. Editable optional regions are, well, editable.

. Repeating Table: Repeating tables are actually repeating regions, but they automatically 
include table tags, so you can easily use them for tabular data.

A To remove an editable region from a template, 
choose Remove Template Markup.
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Building Pages Based 
on a Template
Most of the time, you will create new 
pages based on your template. This is the 
easiest and least confusing way to make 
templates work. It’s also possible to take 
an existing page, say from an older site 
that you’re completely redesigning, and 
apply a template to that page. That method 
is a bit trickier.

To make a new page 
from a template:
1. Choose File > New.

The New Document dialog appears.

2. Click the Page from Template tab, and 
then click the site you are working on in 
the Site column.

The existing templates for that site 
appear in the Template for Site column.

3. Select the template you want from the 
Template for Site column.

A preview of the template appears in 
the dialog A.

4. Click Create.

A new page, based on the template, 
appears.

5. Add content to the editable regions, 
and save the new document with an 
appropriate filename and location on 
your site.

You can create a new page from a 
template faster once you get used to working 
with templates. In the Assets panel, click the 
Templates category, and then right-click the 
template name and choose New from Tem-
plate from the context menu B.

A If you begin a new page from a template with 
the File > New command, you must choose the 
site and then the template.

B Fewer steps are involved in starting a new 
page from a template if you right-click the 
template name in the Assets panel.



ptg8274339

Making Life Easier: Using Templates, Libraries, and Snippets 399

To apply a template to 
an existing page:
1. Open the existing document to which 

you want to apply the template.

2. In the Assets panel, select the template 
you want and click the Apply button (in 
the lower-left corner) C.

or

Drag the template from the Assets 
panel to the document window.

or

Choose Modify > Templates > Apply 
Template to Page. The Select Template 
dialog appears. Click a template in the 
list to choose it.

The Inconsistent Region Names dialog 
appears D. This dialog allows you to 
tell Dreamweaver in which region of the 
new page it should place the docu-
ment’s existing content.

3. In the Inconsistent Region Names dia-
log, do the following:

>	 In the scrolling list, select an unre-
solved region.

>	 Use the “Move content to new 
region” pop-up menu to select an 
editable region for the content.

If you choose Nowhere from the pop-up 
menu, the content is removed from the 
document. If you click the “Use for all” 
button, all the unresolved content is 
moved to the selected region.

4. Click OK.

5. The resulting document probably needs 
some cleaning up to work seamlessly 
with the template. For example, you 
may need to restyle some text or move 
a bit of content manually. After that is 
completed, save as usual.

Apply button

C Modify an 
existing page 
to fit into a 
template page 
by selecting 
the template 
and clicking the 
Apply button.

D When retrofitting an existing page to work 
with a template, you must decide where to put the 
content. The pop-up menu shows possible regions.

Dreamweaver expects the Templates
folder to be at the top level of your site struc-
ture. Don’t move it into a subfolder. If you do, 
Dreamweaver won’t display the template files 
in your Assets panel or in the New Document 
template list.
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Modifying a Template
Templates give you tons of control over 
what can be edited and what can’t. Sure, 
that’s important. But what happens if you 
make lots of pages from your template and 
then something changes? Maybe you need 
to add a new item to the menu, or you 
need a new editable region on the page. 
The answer is that something really cool 
happens when a Dreamweaver template 
is modified: Dreamweaver automatically 
changes all the pages you’ve already 
made using that template. So you can 
make changes to just one page (the tem-
plate) and have those changes automati-
cally ripple through the site.

Normally, you’d start your modification 
directly in the template file. But you can 
also start from any document that is 
attached to the template. You can pick and 
choose the attached pages to which you 
want the changes to apply.

To modify a template file:
1. In the Assets panel, click the Templates 

button to display the templates, and 
then double-click the template file you 
want to edit.

or

In the Assets panel, click the Templates 
button to display the templates, and 
then highlight the template file and click 
the Edit button at the bottom of the 
panel.

The template file opens in the docu-
ment window.

2. Edit as desired, and then choose File > 
Save or press Ctrl-S (Cmd-S).

The Update Files dialog appears. Each 
file attached to the template is listed in 
the dialog A.

A Here’s the powerful part of using templates: 
Dreamweaver offers to update template-based 
pages when you change a template.
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3. (Optional) Select one or more of the 
files in the dialog. To select a single 
file, click its name. You may also select 
noncontiguous files in the list by hold-
ing down the Ctrl (Cmd) key and then 
clicking the files you want. Surprisingly, 
selecting no files in this dialog is the 
same as selecting them all.

If you click Update, every selected file 
attached to the template will update. If 
you click Don’t Update, none of the files 
attached to the template will update.

4. Click Update.

The Update Pages dialog appears B. 
Dreamweaver sorts through all the files 
in your site and makes the updates, 
showing you the progress in the Update 
Pages dialog.

This dialog also allows you to update 
all the pages in the site to their corre-
sponding templates, or to just update 
files based on a specific template. If you 
don’t need any additional updates other 
than the ones Dreamweaver already 
made, go to step 8.

5. (Optional) From the “Look in” pop-up 
menu, choose Entire Site, Files That 
Use, or Selected Files.

The first choice reapplies all the tem-
plates in the site to files made from 
those templates. The second choice, 
which is what you will want most of the 
time, updates only the pages that are 
based on the template you just edited. 
Selected Files applies changes only to 
the pages that you selected in step 3.

When you make a choice from the 
“Look in” pop-up menu, the inactive 
Done button becomes active and its 
label changes to Start.

continues on next page

B If you allow Dreamweaver to update template-
based pages, it reports the results when it’s finished.
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6. (Optional) Make sure the Templates 
check box is selected.

7. (Optional) Click Start.

When the process is complete, the Start 
button changes to Done and becomes 
inactive.

8. Click Close to dismiss the Update 
Pages dialog.

9. Close the template file.

To modify a template attached 
to a current document:
1. With a document based on a template 

open, choose Modify > Templates > 
Open Attached Template.

The template opens in a separate 
window.

2. Make your modifications as described 
in the previous section.

When you save the template, you’ll be 
prompted to update pages attached to 
that template, including the page you 
started with.

To modify an individual 
template-based page:
1. Change a template file, as described 

previously. In the Update Files dia-
log A, click Don’t Update.

2. Open a document attached to the same 
template.

3. Choose Modify > Templates > Update 
Current Page.

The page updates with the changes 
you made to the template. No other 
pages on the site will update.

When your template links to a CSS file, 
all your template-based pages link to it as well. 
If you change your CSS rules, the pages cre-
ated from the template automatically reflect 
those changes in exactly the same way non-
template-based pages reflect CSS changes.

HTML pages changed by the update of 
a template file need to be uploaded to the 
server for the change to be visible to your 
site’s visitors. The easiest way to do this is to 
synchronize the local and remote sites. See 
“Synchronizing the Local and Remote Sites” 
in Chapter 2 for more information.
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Creating a 
Library Item
For someone working alone, the restric-
tions imposed by using a template may 
be unnecessary or even annoying. For 
example, when you use templates, you 
have to set up the editable and locked 
regions, and then when you go to modify 
a page based on the template, you don’t 
have access to page elements in the 
locked regions. These restrictions are 
great if you’re a designer who is giving 
pages to co-workers to modify. But on sites 
where you want to exercise total control 
over editing every page, library items offer 
some of the same time-saving abilities as 
templates, including the ability to update 
pages and maintain consistency, but with 
far fewer restrictions.

Library items aren’t full pages. They’re 
small bits of text, images, or code that you 
insert when needed. Good material for a 
library item might be a navigation bar, a 
copyright notice, a list of links, a graphic 
masthead, or perhaps a search box. If you 
want to use something frequently, have 
it display consistently on any page, and 
update all instances of it at one time, a 
library item fits the bill. And library items 
are easy to create and use.
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To create a library item:
1. Open a document.

2. Select an element in the document 
body. It can be anything you want to 
reuse: text, tables, forms, navigation 
bars, images, or other elements.

3. Do one of the following:

Choose Modify > Library > Add Object 
to Library.

or

In the Library category of the Assets 
panel, click the New Library Item button.

or

Drag the selection into the Library cat-
egory of the Assets panel.

4. The item appears in the Library cat-
egory of the Assets panel A. Type a 
name for the item.

In the document window, the item will 
be highlighted with a color, indicating 
that it’s a library item.

The default color used to highlight a 
library item is yellow. If desired, you can 
change this color in the Highlighting category 
of Dreamweaver’s Preferences panel.

If it doesn’t already exist, Dreamweaver 
creates a Library folder at the top level of 
your site. Library items are stored in this folder, 
with the file extension .lbi. The folder is for 
local use and doesn’t need to be uploaded to 
the server.

A Type a 
name for your 
new library 
item here.
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Using a Library Item
All you have to decide is where you want 
to use your library items on your pages. 
The rest is easy.

To insert a library item:
1. Position the insertion point in the 

document.

2. Drag the library item from the Library 
category of the Assets panel into the 
document.

or

Highlight the library item and click the 
Insert button in the lower-left corner of 
the Assets panel A.

The library item appears in the document.

To delete a library item:
n From a document: Select the library 

item in the document window and press 
Backspace (Delete).

n From a site: Choose the library item in 
the Library category of the Assets panel 
and press Backspace (Delete). This step 
cannot be undone.

Library items become part of the page’s 
code and are subject to any CSS rules in style 
sheets linked to the page. For example, if your 
library item contains a paragraph and you 
have a CSS rule for the p selector, the inserted 
item will reflect the rule.

Insert button

A A quick 
way to insert a 
library item into 
a document 
is to use the 
Insert button in 
the lower-left 
corner of the 
Assets panel.
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Editing a Library Item
You need to be a bit careful when you edit 
library items, because when you change 
a library item, Dreamweaver changes all 
instances of that item throughout all the 
pages of your site, except any documents 
that are currently being edited. This can 
take some time if you have a large site, and 
you have to edit the item again to undo a 
mistake; the Undo command won’t save 
you in this case. It’s nothing to worry about; 
just be aware that changes can have far-
reaching effects.

To edit a library item:
1. Do one of the following:

Double-click the item in the Library 
category in the Assets panel.

or

Highlight the item in the Library cate-
gory in the Assets panel, and then click 
the Edit button in the lower-right corner 
of the Assets panel.

or

Highlight the item in the document 
window. The Property inspector shows 
information for the library item A. 
Click Open.

A When you select a library item in the document window, you can use the Property inspector 
to open the library item.
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2. A window much like a document win-
dow appears, but it contains only the 
library item B.

3. Edit the item as needed.

4. Choose File > Save, or press Ctrl-S 
(Cmd-S). The Update Library Items dia-
log appears.

>	 Update: Updates every instance of 
the library item used in your site.

>	 Don’t Update: No library items are 
updated.

See the following section, “To update 
a library item only in the current docu-
ment,” if you want to select individual 
pages to update.

5. Click Update to have Dreamweaver 
open the Update Pages dialog, run 
through all the files containing the 
library item, update them, and report 
“Done” to you in the dialog when it’s 
finished C.

6. Click Close to dismiss the Update 
Pages dialog.

To update a library item only 
in the current document:
1. Edit the library item, and then click 

Don’t Update in the Update Library 
Items dialog (see the previous section, 
“To edit a library item”).

2. Open a document containing the 
library item.

3. Choose Modify > Library > Update 
Current Page. The library item on this 
single page updates.

4. Save the document.

B An open library item window is rather like a 
normal document window, except there’s nothing 
there but the library item.

C If you update library items, Dreamweaver 
reports on what will happen.
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To rename a library item:
1. Highlight the name of the library item 

in the Library category of the Assets 
panel. Do one of the following:

Right-click and choose Rename from 
the context menu.

or

Click the item name, wait a second, and 
click it again.

The library item’s name is selected and 
becomes editable D.

2. Type the new name for the item.

3. The Update Files dialog appears E. 
Click Update to change the name of 
the library item on every page where 
it is in use.

Library items can’t contain any head
elements, so you don’t have access to the 
CSS panel when editing a library item (internal 
CSS style sheets appear within the <head> tag).

Library items can’t contain a <body> tag, 
so you don’t have access to the Page Proper-
ties panel when editing a library item.

HTML pages changed by the update of a 
library item need to be uploaded to the server 
for the change to be visible to your site’s visitors.

If a document is open when a library item 
updates, you’ll have to save the document 
manually. Updates save automatically in a 
closed document.

D Need a 
better name for 
a library item? 
You can change 
it here.

E When you change a library item name, 
Dreamweaver asks you if you want to change all 
the instances of the item in the site to reflect the 
new name.
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Working on Library 
Items with the 
Property Inspector
As we mentioned in the previous sec-
tion, “Editing a Library Item,” the Property 
inspector offers some options for working 
on library items. You saw how to edit the 
library item using the Open button, but 
there are two as yet unexplained buttons 
on the Property inspector: “Detach from 
original” and Recreate.

Detaching a library item doesn’t remove 
the item from the page. It breaks the con-
nection between the copy of the library 
item on the current page and the original 
source in the site’s Library folder. If you 
later update the original library item, the 
current page’s code won’t be changed by 
the update. You might want to do this if 
you have a library item that you want to be 
based on, but slightly different from, the 
original library item.

Sometimes you can have a page that con-
tains the code from a library item that was 
removed from the site’s Library folder 
(or never existed there). For example, let’s 
say that you copied a page (that contained 
a library item) from one of your sites to 
a different site. The site that now con-
tains the page will not, of course, have a 
corresponding library item in its Library
folder. You can use the code in the current 
document to re-create the library item in 
the new local site.
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To detach the library item:
1. Select a library item in the document 

window.

2. In the Property inspector, click “Detach 
from original” A. Dreamweaver displays 
a dialog asking if you’re sure you want 
to detach the item. Click OK. The link 
between the item on the page and the 
original in the Library folder is broken.

To re-create a missing or 
deleted library item:
1. Open a document containing code for 

a library item that is missing from the 
Library category of the Assets panel.

2. Highlight the item. The tag selector 
should display <mm:libitem>.

3. In the Property inspector, click Recreate. 
The item is re-created using the name 
it has on this page. The re-created item 
appears in the Library category of the 
Assets panel.

If you detach a library item from a page, 
the highlighting in the document window that 
indicated that the element was a library item 
disappears along with the broken connection to 
the library item source. But the detached library 
item still remains on the page; all you’ve done 
is sever its link to the original item.

Right-clicking a library item in the docu-
ment window reveals a context menu with the 
same options available on the Property inspec-
tor: Open, Detach, and Recreate.

A The Property inspector can be used to detach a library item from the source or 
to re-create a library item that’s lost or missing.



ptg8274339

Making Life Easier: Using Templates, Libraries, and Snippets 411

Using Dreamweaver 
Snippets
The Snippets panel is used to store use-
ful bits of code, or snippets, that can be 
inserted any time, any place. In that way, 
snippets are like library items. But there’s a 
big difference between snippets and library 
items. If you change or update a snippet, 
there’s no sitewide update to previously 
inserted versions of the snippet. There’s no 
connection between the code in an inserted 
snippet and the original snippet.

Dreamweaver comes with many useful pre-
built snippets already loaded and ready to 
use. You’ll find them in the Snippets panel. 
If the Snippets panel is not already vis-
ible, choose Window > Snippets to bring 
it forward.

In the Snippets panel A, the snippets that 
come with Dreamweaver are nicely orga-
nized into folders for you. Inside the folders 
you find individual snippets. Click an indi-
vidual snippet to see a preview in the pre-
view pane at the top of the panel. You can 
also see a description of the highlighted 
snippet. If you work with a narrow window, 
as in A, you may have to scroll to the right 
with the horizontal scrollbar at the bottom 
of the Snippets panel to see the descrip-
tion. Expand the width of the panel B to 
read the description without scrolling.

You’ve probably already figured out that 
any custom snippets you save appear in 
the Snippets panel, too. Your snippets and 
Dreamweaver’s snippets are used in the 
same way. We’ll explain how to save a new 
snippet first, and then how to use it.

A The Snippets 
panel comes 
preloaded with 
many useful 
snippets.

New Snippet 
Folder button

New Snippet button Edit Snippet button

Remove button

B There’s a brief description of the snippet to the 
right of its name.
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To save a snippet:
1. Open a document containing the mate-

rial you’d like to make into a snippet. 
Select the snippet C. Be sure you get 
all the surrounding material needed by 
clicking the tag in the tag selector.

2. Click the New Snippet icon in the lower-
right corner of the Snippets panel. The 
Snippet dialog appears D. Complete 
the following fields:

>	 Name: Type a name for the new 
snippet. See the tip at the end of this 
section regarding rules for naming 
snippets.

>	 Description: Type a description. This 
is helpful, but optional.

>	 Snippet type: Select “Wrap selection” 
if the snippet is meant to wrap around 
a selection. Select “Insert block” if 
the snippet is meant to be inserted 
as a block.

D When you save your own snippets, you decide on a name, a description, and 
other basics.

C Select 
something on a 
page to save as 
a snippet.
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If you choose “Wrap selection,” you will 
be asked to choose the parts of the 
snippet to insert before or insert after 
the wrapped selection.

>	 Insert code: The code you selected in 
the document is displayed here. This 
is an editable field.

>	 Preview type: Choose either Design 
or Code.

3. Click OK.

4. The snippet appears in the Snippets 
panel E. The preview displays in the 
preview pane.

E Snippets you 
save appear in 
the Snippets 
panel. You can 
drag them into 
existing folders 
or organize 
new folders of 
your own.
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To use a snippet:
1. Position the insertion point in the 

document.

2. Highlight the snippet in the Snippets 
panel and do one of the following:

Click the Insert button in the lower-left 
corner of the Snippets panel.

or

Double-click the snippet name.

or

Drag the snippet from the Snippets 
panel onto the document.

3. The snippet appears in the document. 
Replace any dummy text with the cor-
rect content F.

The snippet preview pane won’t display 
the snippet with any CSS shown. The snip-
pet must be on a page before CSS rules take 
effect.

Delete or modify snippets by highlighting 
them and using the Edit Snippet or Remove 
buttons in the lower-right corner of the Snip-
pets panel.

Organize your snippets by dragging 
them into preexisting folders or by creating 
new folders of your own naming.

Don’t use any special characters, such as 
ampersands (&) or angle brackets (< and >), in 
snippet names.

F When you insert a snippet into a document, the 
text or other element the snippet contains appears 
on your page.
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Editing Code

Dreamweaver is a WYSIWYG (What You 
See Is What You Get) application. Given 
Dreamweaver’s design strengths, why 
would you ever bother looking at code, 
much less editing it?

Believe it or not, there are people who pur-
chase Dreamweaver and then spend most 
of their time in Code view. There are a 
number of reasons why; some of the more 
common we hear are

n	 “It’s perfect for control freaks like me 
who just want to change that one char-
acter or move things one pixel.”

n	 “I learned tags before good WYSIWYG 
editors existed, so it’s faster for me to 
make changes this way.”

n	 “There are things I can do this way 
that can’t be done any other way in 
Dreamweaver.”

These are all perfectly valid reasons to 
want to use Code view (and there are 
plenty of other reasons). If you haven’t 
before, check it out. You might find that 
Code view works best for you or that it’s 
useful when you simply want to tweak one 
small thing on your page.

In This Chapter
Using the Coding Toolbar 416

Using Split View 424

Using Live Code View 426

Using the Quick Tag Editor 428

Using the Tag Editor 430

Using the Tag Chooser 431

Collapsing Code 433

Using Code Hints 436

Using the Tag Inspector 442

Using the JavaScript Extractor 444

Using the Code Reference 446

Using the W3C Validator 448
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Using the Coding 
Toolbar
Yes, it’s another toolbar in Dreamweaver, 
but the Coding toolbar is a little different: 
it only shows up when you’re in Code view, 
and it only acts on those things that you 
would deal with when you’re in Code view.

To use the Coding toolbar:
1. If you’re in Design view, click the 

Code button in the Document toolbar. 
This switches you into Code view, so 
you’ll now see the tags (instead of the 
WYSIWYG appearance of your page) 
and the Coding toolbar. For instance, A 
shows a page in Design view, whereas 
B shows the same page in Code view.

A Here’s the familiar Design view that you’ve 
grown to know and love.

B The Code view shows the exact same page but in a whole new light.
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Open Documents

Show Code Navigator

Collapse Full Tag

Collapse Selection

Expand All

Select Parent Tag

Balance Braces

Line Numbers

Highlight Invalid Code

Word Wrap

Syntax Error Alerts in Info Bar

Apply Comment

Remove Comment

Wrap Tag

Recent Snippets

Move or Convert CSS

Indent Code

Outdent Code

Format Source Code

C The Coding toolbar provides everything you 
need to manage text and tags.

2. On the left side of the document window, 
you’ll see the Coding toolbar C. Let’s 
review its buttons, from top to bottom:

>	 Open Documents: The name of this 
button might make you think that it’s 
a way to open documents, but that’s 
incorrect; it actually offers a pop-up 
menu of all the items that are cur-
rently open.

>	 Show Code Navigator: Displays the 
Code Navigator window. Code Navi-
gator is covered in Chapter 7.

>	 Collapse Full Tag: Collapsing code 
(and why you’d want to do it) is 
covered later in this chapter. For now, 
it’s enough to know that this button 
will do it. Holding the Alt (Option) key 
while clicking this button collapses 
everything outside the current tag.

>	 Collapse Selection: This button col-
lapses the current selection of code, 
and holding down the Alt (Option) key 
while clicking this button collapses 
everything outside the selection.

>	 Expand All: If any code on the page 
is collapsed, clicking this button 
expands it again.

>	 Select Parent Tag: This button causes 
the selection area to change to 
include the parent tag, based on the 
current cursor position.

>	 Balance Braces: If your current cur-
sor position is inside a <script> or 
<style> container, clicking this button 
causes the innermost set of braces—
( ), { }, or [ ]—to be selected. This 
also works inside external JavaScript 
and CSS files.

continues on next page
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>	 Line Numbers: Toggles the display of 
line numbers in the current docu-
ment. If they’re currently displayed, 
they’ll be hidden, and if they’re cur-
rently hidden, they’ll display.

>	 Highlight Invalid Code: If you enter 
tags that Dreamweaver doesn’t like 
and you’ve chosen this option, your 
mistake will be highlighted in yellow. 
If you click in the highlighted area, the 
Property inspector will tell you more 
about the error D.

>	 Word Wrap: Toggles between wrap-
ping code to the window (on) and 
allowing long lines to scroll horizon-
tally off the screen (off).

>	 Syntax Error Alerts in Info Bar: Turns 
on or off an information bar that 
appears at the top of the page if 
Dreamweaver detects a code syntax 
error. The program also highlights the 
line of code containing the error.

>	 Apply Comment: The pop-up menu 
on this button gives several choices, 
each of which wraps comments 
around the selected text:

n	 Apply HTML Comment: Inserts 
<!-- and --!> before and after the 
selection, respectively.

n	 Apply /* */ Comment: Wraps 
this type of comment around the 
selected CSS or JavaScript.

n	 Apply // Comment: Inserts this 
type of comment at the begin-
ning of each selected line of CSS, 
JavaScript, or both.

n	 Apply ' Comment: Inserts this 
type of comment at the beginning 
of each selected line of VBScript.

n	 Apply Server Comment: If you’re 
working on a server-side file such 
as PHP, JSP, or ColdFusion,  
Dreamweaver automatically 
detects the file type and inserts 
the correct type of comment.

>	 Remove Comment: Removes comment   
tags from the selected code.

>	 Wrap Tag: Opens the Quick Tag Editor  
(described later in this chapter), allow-
ing you to wrap a tag around the 
selection.

>	 Recent Snippets: Allows you to insert 
a recently used snippet. Snippets are 
covered in Chapter 16, “Making Life 
Easier: Using Templates, Libraries, 
and Snippets.”

>	 Move or Convert CSS: Here you can 
either convert inline CSS to a rule or 
move CSS rules. CSS is covered in 
Chapters 7–9.

D It’s always a good idea to tell 
Dreamweaver to highlight invalid code, 
so you can see problems at a glance.
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>	 Indent Code: Takes the selection and 
moves it to the right, based on your 
chosen indentation preference in the 
Code Format settings (covered in the 
sidebar “Text Editing Tips,” later in 
this chapter).

>	 Outdent Code: Takes the selection 
and moves it to the left.

>	 Format Source Code: From this pop-
up menu, you can choose whether to 
apply formatting to the file as a whole 
or to just the current selection. Which-
ever you choose will be formatted as 
specified in the Code Format settings, 
which can also be accessed via this 
pop-up menu.

Some of these options can also be set 
from View > Code View Options E. There are a 
few extra ones there, also: Hidden Characters, 
Syntax Coloring, and Auto Indent. In earlier 
versions of Dreamweaver, you could get to this 
from the View Options button in the Document 
toolbar, but that’s gone away as of CS5.

If you appear to be missing a button or 
two, don’t fret—your document window may 
just be smaller than the Coding toolbar.  
If that’s the case, you’ll see a couple of 
downward-facing arrows at the bottom of the 
toolbar. Click those arrows, and the missing 
buttons appear off to the side F.

If for some reason you don’t like this 
toolbar and just want to make it go away, 
you can do that just as you would with other 
Dreamweaver toolbars: choose View > Tool-
bars > Coding. And if you change your mind, 
that same command brings it back.

Dreamweaver opens files in Design view 
by default. If you want all your HTML files to 
open in Code view instead, open the Prefer-
ences panel and choose the File Types/Editors 
category. In the “Open in Code View” text 
box, add a space followed by .html. You can 
add any other file types where you want to 
use Code view by default by adding those file 
extensions, too.

E The Code View Options choice in the View 
menu contains some very useful settings.

F If you have too many 
buttons for your screen 
size, you’ll find they’re still 
accessible once you learn 
where they’re hiding.
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Layout for Coders
If you’ve chosen to use the Coder layout, rather than the Designer layout, your screen will look 
a little different than our screenshots. You may also check out Coder layout because you decide, 
after using Code view for a bit, that it’s the way you want to work in the future. G shows you how 
a CSS style sheet appears if you change the Workspace Switcher menu to Coder layout H.

G Coder layout is for those who want to see lots of code with as few distractions as possible.

H It’s simple to switch between the different 
layouts with the Workspace Switcher menu.
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Layout for Coders continued

Other preset workspaces of interest to codeheads include Coder Plus, which adds an icon bar to the 
right of the document window, providing easy access to the Insert, CSS Styles, and AP Elements  
panels; and App Developer and App Developer Plus, which are useful for people setting up 
database-backed Web sites I. The latter two workspaces display the document window in Split 
view and show the Databases, Bindings, and Server Behaviors panels.

I If you’re setting up a database-backed Web site, check out the App Developer workspace.
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Text Editing Tips
When you start using Code view and see tags and markup for the first time, you’ll find that there are a 
lot of things that Dreamweaver assumes you already know. In case you don’t, here are a few handy tips:

. Word Wrap: You may want all of your paragraphs to be one long string of text, but if you 
have Word Wrap turned off, all your long lines will go off the right side of the document. You 
can turn Word Wrap on in the Coding toolbar C.

When you’re entering code, be careful about putting in hard returns (where you press Enter/
Return) versus the soft returns that Dreamweaver displays even though you didn’t type anything 
in. If you want soft returns, just keep typing and Dreamweaver will handle it for you. If you want 
hard returns, you might as well turn off Word Wrap.

. Syntax coloring: At first, you might wonder why the text in the code editor is so many different 
colors. Even if all the colors confuse you and make you think about turning off syntax color-
ing, give it a try with colors first. Syntax coloring is one of the best ways to learn what’s what in 
code, because similar elements will have identical coloring.

Wish there were fewer colors all at once? In the Code Coloring category of the Preferences 
panel, you can change any color to any other color. And if for some reason you want to make 
things even more tasteless, you can add unique background colors to each different fore-
ground color. But you shouldn’t.

. Line numbers: These are another matter of personal preference. Some people love them, 
whereas other people find them terribly annoying. What you’ll want to note is how they work in 
conjunction with Word Wrap: soft-wrapped lines only get a single line number D.

. Indentation: If you haven’t worked with code before, you might not immediately get why inden-
tation is so useful. But if you’re trying to figure out where your divs begin and end, you’ll get it 
quickly when you can see them lined up with each other, with their contents indented.

There’s no single “right” way to indent code. What we’ve found works best is to find one style 
that works for you and then stick to it. It’s the consistency that matters most, especially when 
you have multiple people working on a site.

If you want to manually indent/outdent your code, you can (with the Indent Code and Outdent 
Code buttons on the Coding toolbar C), but we recommend instead turning on Auto Indent by 
choosing View > Code View Options E.
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Text Editing Tips continued

. Code formatting: The last button on the Coding toolbar (actually a pop-up menu) lets you for-
mat your source code C. If your tags are all over the place because your code came from here 
and there (as happens to all of us), the Apply Source Formatting option can be found in that 
pop-up menu. If you don’t like the way Dreamweaver formats your code by default, you can 
choose the Code Format Settings option from the pop-up menu, and you’ll be presented with 
the Code Format category of the Preferences panel. Even if you don’t know much about tags, 
it’s easy to use this to put your text just where you want it J.

J Dreamweaver lets you format 
your code precisely the way that 
you want it.
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Using Split View
Does losing your WYSIWYG view freak 
you out a little? Wish you had a way to see 
Code view and Design view at once? Well, 
that’s exactly what Split view is about. It 
splits the document window into two sepa-
rate panes, so you can see both code and 
WYSIWYG simultaneously.

Dreamweaver adds two enhancements to 
the basic split idea:

n	 A Split Code view, where both panes 
show code. This is very useful when 
you want to copy and paste code from 
one section of your page to another 
part of the same page.

n	 An option to split the pane vertically 
rather than horizontally. In both hori-
zontal and vertical split modes, you can 
choose which panes contain the Code 
and Design views.

A Split view is like training wheels for code—it lets you see how changing the design 
changes the code, and vice versa.

To use Split view:
1. Whether you’re in Design view or Code 

view, click the Split button in the Docu-
ment toolbar. Your document window 
splits into two: one part for Design view 
and one for Code view. By default, the 
split is vertical A.

2. If you want to reverse the two (you 
prefer Code view on the right instead of 
Design view, or vice versa), use the Lay-
out button pop-up menu on the Applica-
tion bar B. When you’re in Split view, 
you can choose whether Design view 
should go on the top (when split hori-
zontally) or left (when split vertically).

3. (Optional) If you want to use the hori-
zontal Split view, toggle Split Vertically 
from the View menu or the Layout 
button. The display changes from the 
vertical split to the horizontal split C.
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4. (Optional) If you want the Code view 
in both panes, so that you can look at 
different parts of the same page in each 
pane, choose Split Code from the View 
menu or the Layout button. Your display 
changes to reflect your choice.

When you update your page in Design 
view, Code view automatically updates in 
response. But when you update in Code view, 
the Property inspector displays the message 
“You have made changes to the code. To edit 
selection properties, click Refresh or press F5.”

When you’re in vertical Split view, the 
Coding toolbar only extends down the left 
side of the Code pane, not down the full docu-
ment window.

If you select anything in one view, the 
document automatically scrolls to show and 
highlight the same selection in the other view.

B The Layout button 
pop-up menu on the 
Application bar lets you 
split your view horizontally 
or vertically and then pick 
which view goes on the 
top or left.

If you’ve never looked at HTML tags 
before, Split view can be a great way to famil-
iarize yourself with which tags go with which 
elements of your design.

You can change the size of the panes by 
pointing at the border between them. When 
the cursor changes into a two-headed arrow, 
you can drag the border to resize the panes.

C Depending on your working style, you may prefer the horizontal Split view instead of 
the vertical Split view.
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Using Live Code View
Live Code view is a version of Split view 
that complements Live view (see Chapter 1 
for more about using Live view). Normally, 
when you’re in Split view, you see the 
Design view in one pane and the Code 
view in the other. If you then click the Live 
view button, Dreamweaver changes the 
rendering in the Design pane to show how 
the contents of that pane would look in a 
Web browser. The underlying code in the 
Code View pane remains the same. But 
what if your Web page uses JavaScript for 
visual effects such as rollovers? As the script 
executes, it’s actually changing the HTML 
on the page, rewriting it under script control. 
Live Code view allows you to see how the 
HTML in the Code View pane changes as 
you interact with the page in the Design 
View pane. This is especially useful if you’re 
trying to debug a script because it is not 
producing the effect that you want.

To turn on Live Code view:
1. In any view, click the Live view button 

on the Document toolbar.

The page rendering changes to show 
what the Web page would look like in a 
Web browser A.

2. Click the Live Code button on the Docu-
ment toolbar.

The document changes to Split view, 
with the code in the Code View pane 
highlighted to indicate that it is live B. 
As you interact with the page in the 
Design View pane, the code in the 
Code View pane is updated.

There are useful options for Live Code 
view, found in the Live View Options menu in 
the Browser Navigation toolbar. We discuss 
these options in more detail in Chapter 15, 
“Working with Content Management Systems.”

A In Design view, Dreamweaver shows you the 
usual view (top). In Live view (bottom), you can 
see the application of the CSS styles and the 
highlighting of the row under the cursor thanks 
to JavaScript.
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B In Live Code view, the HTML code changes under JavaScript control as you interact with the page in the 
Design pane (bottom).
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Using the Quick 
Tag Editor
If you prefer Design view (as do most 
people who’ve bought a WYSIWYG editor, 
after all) but wish you could type a little bit 
of HTML now and then without switching 
back and forth between modes, there’s an 
answer: the Quick Tag Editor.

To use the Quick Tag Editor:
1. With your page in Design view, put the 

cursor in the place where you want to 
add a tag, or select the tag you want to 
change, or select the element you want 
to wrap a tag around.

2. Press Ctrl-T (Cmd-T).

or

Click the Quick Tag Editor button at the 
right edge of the Property inspector.

3. The Quick Tag Editor appears, in one 
of its three modes: Insert, Edit, or Wrap. 
In any of these modes, start typing, and 
the possible options appear in the code 
hints menu below.

>	 Insert HTML: This mode allows you to 
place a new tag on the page A.

>	 Edit tag: This allows you to modify an 
existing tag, either to change it or to 
add attributes to it B.

>	 Wrap tag: In this mode, you can 
wrap a new tag around an existing 
element C.

A With the Quick Tag Editor, you can easily insert 
a new tag on the page.

B The Quick Tag Editor also lets you edit 
existing tags.

C And lastly, you can tell the Quick Tag Editor 
that you want to wrap a tag around existing 
page elements.
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4. To accept your changes and leave the 
Quick Tag Editor, press Enter (Return). 
To leave the Quick Tag Editor without 
making any changes, press Esc.

Dreamweaver tries to guess which Quick 
Tag mode you want to be in. If it guesses incor-
rectly, you can cycle through the three modes 
by pressing Ctrl-T (Cmd-T) again. Be careful 
about what’s actually chosen when you do that, 
though—sometimes, the selected area can 
expand. For instance, if you’ve selected the text 
of a link with the goal of modifying that link, but 
you’ve also (accidentally) selected something 
outside the <a> (link) tag, you can find that 
you’re modifying the <p> (paragraph) around 
the text instead of the link itself.

If the Quick Tag Editor appears but is 
covering an area you want to see, you can 
move it. Just click and drag in the area that 
displays the mode name to put it in the loca-
tion you want.
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Using the Tag Editor
You’ve seen the Quick Tag Editor; now 
here’s the Tag Editor itself. It’s not really 
slower than the Quick version, and it’s 
handy for when you want more control 
than you can get in, say, the Property 
inspector but don’t want to deal with actual 
HTML tags.

To use the Tag Editor:
1. With your page in Design view, select 

an element where you want to edit 
an existing tag. For instance, you can 
select an image or the text of a link.

2. Right-click, and choose Edit Tag.

or

Press Shift-F5.

or

From Dreamweaver’s menu, choose 
Modify > Edit Tag.

3. The Tag Editor dialog for that particular 
tag appears. Every tag has a custom 
dialog of its own, with a variety of cat-
egories in the left column. A shows the 
Tag Editor dialog for an <img> tag, and 
B shows the Tag Editor dialog for an 
<a> tag. Make any desired changes.

4. Click OK when complete.

Near the bottom right of the Tag Editor 
dialog is the Tag info disclosure arrow. Click 
it, and the dialog size increases to include a 
description of the tag you’re modifying. For 
more information about this description, see 
“Using the Tag Chooser” and “Using the Code 
Reference,” later in this chapter.

You can also access the Tag Editor from 
Code view by right-clicking a tag C.

A The Tag Editor for images lets you modify every 
possible image attribute and event.

B The Tag Editor for the a tag allows you to 
change attributes and events for links.

C Right-click a tag, and this menu appears with 
the available options.
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Using the Tag Chooser
If you’re beginning to think that there are a 
lot of different ways to insert elements into 
a Dreamweaver page, you’re right—except 
that you haven’t even seen many of them 
yet. Here’s a tool you might not have run 
across yet—Dreamweaver’s Tag Chooser.

To use the Tag Chooser 
to insert tags:
1. With your page in Code view, put the 

cursor into the section of the document 
that you want to add to or edit.

2. Right-click, and a menu of the available 
options appears. Choose Insert Tag 
(see figure C in “Using the Tag Editor”). 
The Tag Chooser dialog appears A.

3. Click any of the icons or tag categories 
on the left side, and the matching tags 
will appear on the right.

4. Select one of the tags on the right, 
and click Insert. If the tag you chose 
contains angle brackets (< >), it will be 
inserted into the page. Otherwise, a 
Tag Editor dialog appears, allowing you 
to enter the required information. For 
more about the Tag Editor dialog, see 
“Using the Tag Editor.”

5. When you are done with the Tag 
Chooser dialog, click Close.

A The Tag Chooser lets you insert tags.
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To use the Tag Chooser to 
get tag information:
1. With the Tag Chooser open A, select a 

tag on the right side.

2. Click the Tag Info button that’s just 
above the Help button on the bottom  
left. The Tag Info reference area 
appears, along with useful information 
about the tag you selected B.

or

Click the <?> button directly to the 
right of the Tag Info button. The same 
information appears, but in the Code 
Reference panel. For more information 
about the Code Reference panel, see 
“Using the Code Reference,” later in 
this chapter.

You can also open the Tag Chooser 
by clicking the bottommost icon in the 
Insert panel when you’re in the Common  
category. If you do this in Design view, 
Dreamweaver automatically switches to 
Split view.

B When you select a tag and then click the Tag Info button, 
Dreamweaver displays a reference guide to that tag.
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Collapsing Code
If you spend much time working with tags 
and code, you’ll often find yourself in a 
situation where you wish you could hide 
just some of it. Thankfully, that’s something 
you can do with Dreamweaver.

To collapse code:
1. In Code view, select the code that you 

want to collapse A. The simplest way to 
do this is to click somewhere inside the 
area and then click the Select Parent Tag 
button on the Coding toolbar (see figure 
C in “Using the Coding Toolbar”).

continues on next page

A Select the code to collapse, and then look for the vertical line on the left.
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2. Just to the left of the code, you’ll see a 
vertical line that goes from the beginning   
of the selected area to the end. Win-
dows users will see a white box with a 
minus sign on each end; Mac users will 
see two gray triangles, the top one fac-
ing down and the bottom one facing up. 
Click one of these endpoints, and the 
selected code collapses B. You’ll now 
see the first part of the first line inside 
a highlighted box, plus a white box with 
a plus sign (Windows) or a right-facing 
gray arrow (Mac).

or

Click anywhere inside the tag you want 
to collapse, and click the Collapse Full 
Tag button on the Coding toolbar.

or

Select the code you want to collapse, 
and click the Collapse Selection button 
on the Coding toolbar.

B Click one of the icons on the endpoints of the line, and the 
selected text collapses to a single line.

or

Click in a particular location on the 
page, and press the Alt (Option) key 
while clicking the Collapse Full Tag 
button on the Coding toolbar. This 
collapses everything but the full tag 
around your particular cursor position.

or

Select a segment of code, and press 
the Alt (Option) key while clicking the 
Collapse Selection button on the Cod-
ing toolbar. This collapses everything 
but the current selection.

or

Right-click inside a tag on the page, and 
choose Selection C. From there, you 
can choose Collapse Selection, Col-
lapse Outside Selection, Collapse Full 
Tag, or Collapse Outside Full Tag.
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To work with collapsed code:
n	 Put your cursor over the highlighted 

box, and a tool tip appears displaying 
all of the collapsed code D.

n	 Collapse a section of code if you need 
to move it from one area of the page to 
another. You’ll know that you’re moving  
exactly what you want to move and 
no more.

n	 If you collapse a section of code and 
then save and close the page, the next 
time you open the page that section will 
still show as collapsed.

To expand code:
Click the collapsed code symbol (the white 
box with a plus sign [Windows] or the right-
facing gray arrow [Mac] ) to the left of the 
code you want to expand.

or

Double-click the highlighted box.

or

Click the Expand All button on the Coding 
toolbar, which expands all the collapsed 
code on the page.

or

Right-click on the page, and choose 
Selection C. From there, you can choose 
Expand Selection or Expand All.

D If you want to know what’s collapsed, this tool tip gives you the info without actually 
expanding the code.

C You can also collapse code by right-
clicking the selection and choosing one of the 
collapse options.
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Using Code Hints
When it comes to working with HTML, not 
all text editors are created equally—and 
Dreamweaver’s code hints are one reason 
why text editor fans will use its Code view 
rather than someone else’s garden variety 
notepad-like application. While the basic 
process of code hinting is unchanged from 
previous versions of Dreamweaver, the 
CS5.5 version introduced code-hinting fea-
tures for HTML5, CSS3, browser-specific 
properties, and jQuery. Rather than dupli-
cate the same process with minor varia-
tions, we’ll run through the entire process 
for HTML and then show brief examples for 
the other types of code hinting.

Code Hints for HTML
Dreamweaver CS6’s code hints for HTML 
are largely unchanged from CS5, with 
the exception that hints for HTML5 have 
been added.

To get hints for HTML:
1. In Code view (or the Code pane of Split 

view), click anywhere on the HTML 
page that you want to add a tag. Start a 
new tag by typing <, and the code hints 
appear in a pop-up menu A.

2. Type the first character or two of the 
tag, and the code hints menu should 
change to reflect your typing B. When 
the hinted value is the tag you want, 
press Tab.

3. To add an attribute to your new tag, 
press the spacebar and continue to 
type. The code hints pop-up menu 
will appear again, this time displaying 
just the valid attributes for that tag C. 
Again, choose the one you want and 
press Tab to get the full attribute added 
to your tag.

A Start typing, and the code hints 
pop-up menu appears.

B As you continue to type, the code 
hints narrow down your choices.

C Code hints work for attributes as 
well as tags. Note that Dreamweaver 
is smart enough to find all of the 
instances in which the typed letters 
(sr) appear.
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4. If you select an attribute that needs to 
link to a file, the code hint changes to 
a Browse button D. Click the button to 
browse to the file on your disk.

5. If you want to add an attribute to an 
existing tag, click immediately after the 
tag name (for instance, right after the g
in <img), press the spacebar, and begin 
to type. The available attributes will 
display E.

6. To end a tag, type />, and the most 
recently opened tag will automatically 
be closed.

If the code hints pop-up menu doesn’t 
appear, press Ctrl-spacebar (Cmd-spacebar) to 
make it display.

You can use the arrow keys on your 
keyboard to move up and down through code 
hints to choose the tag or attribute you want.

If you’re using XHTML and you end a tag 
with > rather than />, code hints will automati-
cally change it to the proper format.

You can’t modify an attribute with code 
hints; instead, delete the attribute and re-create it.

If you want a special character but can’t 
remember its exact name (such as &nbsp; for 
non-breaking space), just type the first letter 
or symbol (&, in this case) and you’ll get a code 
hint that lists all the possible characters you 
can enter.

If there’s anything you don’t like about 
how code hints work, you can change them to 
suit your taste by modifying the values in the 
Code Hints category of Dreamweaver’s Prefer-
ences panel F.

D Code hints can tell you when the 
attribute needs a URL as its value.

E You can add an attribute to an 
existing tag—just click inside the 
tag and start typing.

F Dreamweaver lets you make code hints work 
just the way you choose.

Dreamweaver CS5 introduced improved 
code hinting for PHP, including custom class 
hinting, integrated documentation, and site-
specific code hinting for CMS and application 
frameworks. To control the site-specific code 
hinting, choose Site > Site-Specific Code Hints. 
The resulting dialog has presets for the three 
CMS platforms that Dreamweaver supports, 
allowing you to control how code hints are pro-
vided for WordPress, Joomla, and Drupal sites.
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Code Hints for CSS
You’ll find code hints for CSS3 and the 
browser-specific properties in Dream-
weaver CS6.

To get hints for CSS:
In a CSS style sheet, begin creating a rule 
and then simply start typing a CSS prop-
erty. Properties matching what you type 
will appear in the pop-up menu G.

or

To get a browser-specific property, create 
a rule and then type the dash (–). Dream-
weaver will pop up a menu containing the 
four types of browser-specific properties H. 
Choose from the pop-up menu, or keep typ-
ing to continue narrowing your choices until 
you have inserted the property you want.

HTML5 and CSS3 Code Hinting Additions
Dreamweaver has code hinting support for the following HTML5 elements and their associated 
attributes: <article>, <aside>, <audio>, <canvas>, <command>, <datalist>, <details>, <embed>, 
<figcaption>, <figure>, <footer>, <header>, <hgroup>, <keygen>, <mark>, <menu>, <meter>, 
<nav>, <output>, <progress>, <rp>, <rt>, <ruby>, <section>, <source>, <summary>, <times>, 
<video>, and <wbr>.

For CSS3, there are too many properties to list, but they include properties and attributes from 
the following W3C categories: Border and Background, User Interface, Multi-column Layout, Line 
Layout, Text, Marquee, Ruby, Transitions, and Animations 2-D and 3-D. Because CSS3 is still very 
much in a state of flux (there’s no final standard, just a bewildering array of Working Drafts, Candi-
date Recommendations, Proposed Recommendations, and Recommendations for each category 
listed), you can expect that future versions of Dreamweaver will support newer versions of the 
many parts of CSS3 when those parts are supported by more browsers. Historically, the browsers 
with the most up-to-date support for CSS3 rules are Safari and Chrome.

G In CSS files, the code hints work 
when you’re adding properties to a 
rule.

H To get the browser-specific code 
hints, begin by typing the dash.
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Code Hints for jQuery
Before you start using code hinting for 
jQuery, you should confirm that it is turned 
on in the Code Hints category of Dream-
weaver’s Preferences panel I. jQuery 
code hints are on by default, and they will 
work in any .js file. You have the option of 
turning them off if you prefer to work with a 
different JavaScript framework.

To get hints for jQuery 
static methods:
In a JavaScript document, type either 
jQuery. or its more common shortcut, $.. 
Dreamweaver will pop up a list of static 
methods J.

To get hints for jQuery 
non-static methods:
In a JavaScript document, type either 
jQuery() or $(). Dreamweaver will pop up 
a list of non-static methods K.

I Confirm that jQuery code hinting is turned on in 
Dreamweaver’s Preferences panel.

J This is the list of jQuery static methods.

K Here are the code hints for jQuery non-static methods.
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Code Hints for DOM Elements
In previous versions of Dreamweaver, if 
you wanted to write your own JavaScript 
you needed to manually keep track of the 
named elements, ids, HTML tag names, 
and class names so that you could refer-
ence them using the appropriate Java-
Script methods (getElementsByTagName, 
getElementById, getElementsByName, and 
getElementsByClassName). Dreamweaver 
CS5.5 added DOM element hinting. When 
you’re typing in a JavaScript window, 
Dreamweaver shows in the code window a 
list of names that it collects from the DOM 
of the parent HTML page.

To get hints for DOM elements:
In a JavaScript document, type document.
getElementsByTagName(". Dreamweaver 
pops up a list of HTML tag names L. This 
is the same list that it uses for HTML code 
hinting.

or

In a JavaScript document, type document.
getElementById(". Dreamweaver pops 
up a list of ids found in the parent HTML 
document M.

or

L Dreamweaver lets you use code hints for DOM elements used in JavaScript, in this case, tag names.

M Dreamweaver scans the document and pops up a list with the ids it finds.
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In a JavaScript document, type document.
getElementsByName('. Dreamweaver 
pops up a list of named elements in the 
document N. If the name applies to more 
than one element, you’ll be told that, too.

or

In a JavaScript document, type document.
getElementsByClassName('. Dreamweaver 
pops up a list of the classes found in the 
parent HTML document O.

Dreamweaver allows you to use either 
single or double quotes to get hints for DOM 
elements. We prefer to use double quotes, so 
we've used those in the steps above. But as 
you can see from the figures, either works.

N If you ask for elements by name, Dreamweaver populates the hint list, and lets you know if the name has 
been used more than once.

O Finally, if you want to manipulate elements with a particular class name, Dreamweaver can help you find 
them.



ptg8274339

442 Chapter 17

Using the Tag 
Inspector
If you prefer to stay in Design view but 
every so often just want to tweak some-
thing, the Tag inspector is one of the 
simplest ways to do so. Along with the Tag 
Editor and the Quick Tag Editor (covered 
earlier), it’s a great way to modify existing 
tags, and it’s an easy way to get used to 
the attributes that exist for each tag.

To use the Tag inspector:
1. If the Tag inspector currently isn’t 

displaying, choose Window > Tag 
Inspector.

2. If you’re in Design view, click an ele-
ment on the page or choose a tag 
from the tag selector. If you’re in Code 
view, click anywhere inside a tag. The 
tag and its attributes appear in the Tag 
inspector A. Be sure the Attributes tab 
is selected.

3. There are two ways to view the attri-
butes in the Tag inspector: by category 
or as a list.

>	 To view by category, click the Show 
Category view button. Categories can 
be open or closed. To open a closed 
category, click the plus (+) button 
(Windows) or the right-facing triangle 
(Mac); to close an open category, 
click the minus (–) button (Windows) 
or the downward-facing triangle 
(Mac). When a category is open, the 
list of attributes that fall into that cat-
egory are displayed.

>	 To view as a list, click the Show List 
view button. This choice displays all 
the tag’s attributes in an alphabetical 
list B.

Show Category view

Show List view

A The Tag 
inspector can 
be found in 
the Attributes 
tab of the Tag 
Inspector panel. 
Here’s the 
Category view.

B Or optionally, 
there’s also the 
List view, which 
shows all of that 
tag’s attributes 
in alphabetical 
order.
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4. You can now modify, add, or delete 
attributes. There are different ways to 
edit different types of attributes:

>	 If you’re adding or modifying an 
attribute whose value is a URL C, 
you’ll see the Point to File icon and a 
browse icon to the right of the entry 
field. Alternatively, you can type into 
the entry box, which is also the case 
for most attributes.

>	 If your attribute has particular defined 
values, clicking in the value column 
displays a pop-up menu containing 
the valid values D.

>	 If the attribute contains a color, click-
ing the small box in the value column 
brings up the standard color picker E.

5. There’s no OK or Accept button on the 
panel; simply clicking away from the 
attributes or off the panel implements 
your changes on your page.

As you might remember from Chapter 1, 
it’s also possible to change tag attributes in 
the Property inspector. Because the Property 
inspector shows only the most commonly used 
attributes, you’ll want to use the Tag inspector 
when you need to get at the others.

C The standard 
Point to File 
and browse 
icons work 
the same way 
here as they do 
everywhere else 
in Dreamweaver.

D For those 
attributes that 
can have only 
certain values, 
Dreamweaver 
lets you know 
what those 
possibilities are.

E The color picker lets you choose 
the color you want without having to 
remember odd color codes.
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Using the JavaScript 
Extractor
Best practices for Web pages call for 
content to be separated from structure 
and behavior, so you should have separate 
HTML, CSS, and JavaScript documents. 
Separating the functions like this makes it 
easier to make changes in any of the docu-
ments without accidentally breaking your 
site. And since CSS and JavaScript docu-
ments can apply to many HTML pages on 
your site, changes you make in them are 
automatically applied to all the pages that 
reference those files.

Many older pages, and even pages that 
are created in Dreamweaver (for example, 
pages that use the built-in behaviors, as dis-
cussed in Chapter 12), can have JavaScript 
that is embedded in the HTML page. This 
can be within the document’s <head> tag 
or in the <body>. The JavaScript Extractor 
automates moving embedded JavaScript 
code into an external .js file.

To extract embedded JavaScript:
1. Open a page containing JavaScript 

code.

2. Choose Commands > Externalize 
JavaScript.

Dreamweaver will analyze the page, 
and the Externalize JavaScript dialog 
will appear A.

A Choose the JavaScript you want to extract from 
the page.
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3. In the dialog, select “Externalize  
JavaScript and attach unobtrusively.”

This option will move the JavaScript 
from the HTML page to a new external 
JavaScript file and add a link to the 
external file to the head section of the 
HTML page.

4. Select or deselect any of the proposed 
JavaScript edits in the dialog.

5. Click OK.

Dreamweaver displays a dialog that 
gives you a rundown of what the Exter-
nalize JavaScript command did B. Pay 
special attention to the line or lines that 
tell you the names of the new external 
files, and make sure you upload those 
files to your server.

Once you externalize Dreamweaver 
behaviors, you can’t re-edit them in the Behav-
iors panel, because Dreamweaver doesn’t 
have a way to read JavaScript code from 
external files.

B When the JavaScript Extractor is done, it reports 
on what it accomplished.
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Using the Code 
Reference
It’s often very handy to have a book close 
by when you’re first starting to work with 
code (we recommend HTML5 and CSS3 
Visual QuickStart Guide, Seventh Edition, 
by Elizabeth Castro and Bruce Hyslop 
[Peachpit Press, 2012], by the way). If you 
don’t happen to have a book nearby, don’t 
fret—Dreamweaver has several built-in 
reference books.

To open the Code Reference tab:
Right-click the element on the page that 
you have questions about, and select 
Reference A. The Reference tab of the 
Results panel appears B.

or

Follow the directions in “Using the Tag 
Chooser,” earlier in this chapter.

or

From Dreamweaver’s menu, choose Win-
dow > Reference.

A Choosing Reference from this menu displays 
the Reference tab of the Results panel.

B The Reference tab can display material about HTML, CSS, JavaScript, and more.
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To insert code from the reference 
into your document:
1. In the Reference tab, find the code frag-

ment you want and then click it once; 
the entire fragment will be selected C.

2. Right-click the selected text and 
choose Copy.

3. Paste the copied code into your docu-
ment wherever you want it.

If you don’t like the size of the text in the 
Reference tab, you can change it. Right-click 
anywhere inside the panel, and you’ll have 
your choice of small, medium, or large text.

The HTML, CSS, and JavaScript refer-
ence material included in Dreamweaver is 
excerpted from Danny Goodman’s book 
Dynamic HTML, The Definitive Reference 
(O’Reilly Media, 1998). It’s a good book but out 
of date, so for learning HTML, we still recom-
mend the Visual QuickStart Guide. Want to 
learn CSS or JavaScript? We’re required to rec-
ommend Styling Web Pages with CSS: Visual 
QuickProject Guide (2009) and JavaScript: 
Visual QuickStart Guide (2011), both from 
Peachpit Press and by, well, us (so you can 
guess who required it).

Besides the reference material, the Ref-
erence tab also includes information on Cold-
Fusion, ASP, JSP, PHP, SQL, XML, and XSLT 
(and probably a few other three-letter acro-
nyms, too). There’s also the UsableNet Access-
ibility Reference, a great resource for learning 
how to make your sites more accessible.

C Click the code sample once, and it will be selected.
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Using the W3C 
Validator
It’s important to have pages that adhere to 
Web standards. Although pages that you 
create in Dreamweaver will generally be 
standards compliant, changing the code by 
hand may introduce errors that prevent the 
page from being standards compliant and 
from rendering correctly in browsers. Or you 
may be reworking an old site to make use 
of modern Web technologies and make it 
standards compliant for the first time.

Dreamweaver CS5.5 introduced a W3C 
Validator feature that can validate, from 
within Dreamweaver, static or dynamic 
HTML documents with the W3C validation 
service. Any errors are displayed in the 
Validation tab of the Property inspector. 
The processes for validating static pages 
and dynamic pages are slightly different.

To validate static pages:
1. Open the page you want to validate.

2. Choose File > Validate > Validate Cur-
rent Document (W3C).

or

From the Document toolbar, click the 
Validate button and then choose Vali-
date Current Document (W3C) A.

Dreamweaver displays a dialog let-
ting you know it’s going to send your 
page to the W3C validation service B. 
Naturally, you’ll have to have an active 
Internet connection.

3. Click OK.

A To begin validating a document, 
choose Validate Current Document 
(W3C) from the Validate menu in the 
Document toolbar.

B Dreamweaver asks permission to send your 
document to the W3C validation service.
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Dreamweaver sends the source code 
from the Code view to the validation 
service. When it gets a response (usu-
ally within seconds), it opens the Valida-
tion tab of the Property inspector C.

4. If there are any errors listed in the 
Validation tab, double-clicking one of 
them will switch to Split view and place 
the cursor in the Code pane where the 
error is, so you may fix it D.

To validate dynamic pages:
1. Open the page you want to validate.

2. Click the Live view button in the Docu-
ment toolbar.

As usual with dynamic sites (ones that 
you have created with a content man-
agement system such as WordPress, 
Drupal, or Joomla), Dreamweaver will 
go through the process of discovering 
and loading all the associated files.

continues on next page

C If the service finds any problems, the error appears in the Validation panel in the Property inspector.

D Double-clicking the error in the Property inspector opens a code pane and highlights 
the problem.
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3. Choose File > Validate > Validate Live 
Document (W3C).

or

From the Document toolbar, click the 
Validate button and then choose Vali-
date Live Document (W3C).

4. Click OK.

Dreamweaver sends the source code 
from the Code view to the validation 
service. When it gets a response, it 
opens the Validation tab of the Property 
inspector E.

5. Since the error may have been dynami-
cally created, double-clicking an error in 
the Validation tab opens the W3C Error 
Info window F (rather than taking you to 
the source code, as with static pages).

The error information tells you what the 
problem is and sometimes (not always) 
gives useful suggestions on how to 
rectify the error.

Validating a dynamic site is often fraught 
with uncertainty, because sometimes you 
don’t know whether the error was introduced 
by you or by the CMS that you’re using. It’s 
nice that Dreamweaver allows you to validate 
live documents, but in practice you may not 
find it to be that useful.

F Double-clicking an error in a dynamic page 
brings up a dialog that will help you zero in on 
the error.

Have a vague recollection that you used 
to be able to validate your pages? You’re not 
imagining things—up until CS5, Dreamweaver 
did have a built-in validator. It was removed in 
CS5, and it’s now making its new and improved 
reappearance. The problem with the old valida-
tor was that, because it was built in, it didn’t 
keep up with new standards such as HTML5. 
Now that it uses the W3C’s validation service, 
Dreamweaver no longer has that limitation.

E With dynamic pages, Dreamweaver sends for validation the source code of the current page, which may 
include links to many supporting files. Any errors will still show up in the Validation panel.
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Managing Your Site

As you’ve seen in the rest of this book, 
building a site means creating dozens, 
hundreds, or even thousands of files that 
work together to present a dynamic, excit-
ing Web site. Keeping track of and manag-
ing all these files—a process called site 
management—may not be an exciting job, 
but it is essential.

The problem of site management gets even 
more complex when (as is common) you 
are just one member of a team responsible 
for building and maintaining a site. Imagine 
that you have several people who can all 
edit pages—it would be easy for one person 
to overwrite changes made by a coworker. 
That’s where Dreamweaver’s collaboration 
features come in. With Check In/Check Out, 
team members are notified if another per-
son is already working on a particular file. 
Support for the Subversion version control 
system allows Dreamweaver to be inte-
grated into even the largest sites.

In this chapter, you will learn how to man-
age the files and folders that make up your 
site; work with Dreamweaver’s collabora-
tive tools; and learn different ways to look 
at and work with your site.

In This Chapter
Planning for Site Expansion 452

Expanding the Files Panel 453

Setting Up Check In and Check Out 456

Checking Files In and Out 459

Using Design Notes 461

Setting Up Subversion 464

Generating Site Reports 466

Checking for Broken Links 469

Finding External Links and  
Orphaned Files 471

Checking Browser Compatibility 472

Deleting Sites 475

Exporting and Importing Site Definitions 476
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Planning for Site 
Expansion
When you’re designing a site, you take the 
time to think about the site navigation so 
that your site visitors have an easy time 
finding the information they need. But what 
about your needs? When you’re building 
and maintaining a site, it’s just as important 
for you to plan the folder structure so that 
you can easily and quickly find items you 
need to work on. Web sites have a disturb-
ing tendency to grow, so when you set up 
your site, lay out your folder structure logi-
cally, and leave room for expansion in your 
site structure A.

For example, if you have different sections of 
a site (as represented in the site’s navigation), 
it’s a good idea to create a folder for each 
section (which will contain all of the pages 
for the section). Then consider creating an 
image folder inside each section folder. After 
all, you will probably have images for each 
section that are used only in that section of 
the site. A separate image folder in the root 
of your site can handle images that are used 
globally throughout the site.

As your site grows, you can add additional 
folders for new sections from the site root, 
or you can add folders inside the existing 
section folders for new subsections.

Make sure that you name your files 
and folders meaningfully and understand-
ably. While you are creating a site, you may 
remember what the med_sec_hed.html file 
is used for, but when you come back to the 
site four months later, you might not have 
a clue, at least without opening the file and 
looking at it. Instead, name the file something 
like media_home.html, and it makes it easier 
for you to pick up where you left off. This also 
helps make your site easier for other people 
to maintain.

Expand/
Collapse 
button

A You should 
create your site 
structure with 
logical sections 
(shown here as 
folders) and plan 
for growth.

Don’t forget that there are some charac-
ters that you can’t use in file and folder names, 
including space, #, &, @, /, and most other 
punctuation. Use a hyphen or underscore as 
substitutes for a space.

If you create image folders inside section 
folders, give those image folders descrip-
tive names, too. We like to use the name of 
the section, followed by an underscore, then 
images, like so: recipes_images.
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Expanding the 
Files Panel
The Files panel does an adequate job of 
showing you the files and folders in your 
site, but it has some drawbacks. The big-
gest of these is that it is cramped for space, 
especially for larger sites. You also can’t see 
the local files and the remote server at the 
same time, making it difficult to compare 
items that are on your machine with those 
that are on the server. Dreamweaver allows 
you to expand the Files panel to solve 
these problems. You can view the local and 
remote sites and easily create, move, and 
delete files on either copy of the site. Of 
course, you can still use the Get, Put, Check 
Out, Check In, and Synchronize buttons at 
the top of the Files panel.

You can also select multiple files in the fol-
lowing categories:

n	 All files

n	 Checked Out files

n	 Newer Local files

n	 Newer Remote files

n	 Recently Modified files



ptg8274339

454 Chapter 18

To expand the Files panel:
1. At the top of the Files panel, click the 

Expand/Collapse button.

On Windows, the Dreamweaver window 
will be replaced by the expanded Files 
panel A.

On the Mac, the expanded Files panel 
will appear in a new window B.

2. Create, delete, rename, or move files 
and folders as you like. See Chapter 2 
for more details.

3. When you’re done with the expanded 
Files panel, click the Expand/Collapse 
button again to toggle the window back 
to the normal Files panel.

A The expanded Files panel 
allows you to easily see both 
remote (left) and local (right) 
files. On Windows, the panel 
completely replaces the 
Dreamweaver window.

B On the Mac, the Files panel 
expands into its own window.



ptg8274339

Managing Your Site 455

To select multiple files in the 
expanded Files panel:
1. At the top of the Files panel, click the 

Expand/Collapse button.

2. On Windows, from the Edit menu, 
choose Select All, Select Checked Out 
Files, Select Newer Local, Select Newer 
on Remote Server, or Select Recently 
Modified C.

or

On Mac, right-click in the Local Files 
section of the expanded Files panel, 
and from the Select menu choice in 
the context menu, choose Select All, 
Select Checked Out Files, Select Newer 
Local, Select Newer Remote, or Select 
Recently Modified.

The files highlight.

If you want the opposite selection of 
what is already selected, choose Invert Selec-
tion in step 2 above.

If you select a file or folder in either the 
Remote Server or Local Files panes and right-
click, you can easily find the corresponding 
file in the other pane by choosing Locate on 
Remote Server (if your selection is in the Local 
pane) or Locate in Local Site (if your selection 
is in the Remote pane) from the context menu.

Dreamweaver usually doesn’t show the 
hidden files it places on the remote server. For 
example, when you check a file out, Dream-
weaver creates a small file on the server called 
filename.LCK. These .LCK files are how 
Dreamweaver knows that the file is checked 
out. If you want to see these hidden files, on 
the expanded Files panel in Windows, choose 
View > Show Hidden Files. On Mac, there 
doesn’t appear to be a way to do this.

It’s usually a good idea to do your 
file management in Dreamweaver, but you 
can easily show a selected file in Windows 
Explorer or the Mac OS Finder. Select a file, 
right-click, and from the context menu choose 
Explore (Reveal in Finder).

C On Windows, 
the Edit menu 
allows you to 
highlight specific 
groups of files.

What Happened to the Site Map?
If you haven’t upgraded Dreamweaver 
for quite some time, you may be won-
dering what happened to the Site Map, 
which was a visual tool that helped you 
see the links and relationships between 
the files on your site and which was 
available in all versions of Dreamweaver 
before CS4. The Site Map was a dif-
ferent view in the Files panel, and it 
allowed you to see the links between the 
different files in the site in a tree display 
resembling an organizational chart, 
descending from the site’s index page. 
Some people preferred the Site Map 
because it made it easier to visualize the 
site structure.

In August 2007, Adobe released a list 
of features that it planned to remove 
from Dreamweaver, because research 
revealed they weren’t being used by 
many people. The Site Map was on this 
list. Some of the features on the list were 
also dated and didn’t conform to current 
best practices, such as the old Table 
Layout Mode (modern sites use CSS for 
layout). Rather than continuing to put 
resources into maintaining unpopular 
or obsolete features, Adobe chose to 
relegate them to the mists of history.
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Setting Up Check 
In and Check Out
In Chapter 2, you learned how to copy 
selected files or folders between the local 
and remote sites in the Files panel using 
the Get File and Put File buttons. Get 
and Put work fine when you are the only 
person working on a site, but you don’t 
want to use them when you are working 
on a site with other members of a team. In 
that case, you would want to prevent one 
person from accidentally undoing or over-
writing changes made by another member 
of the team when the page is transferred 
back to the remote site.

When you are working with other people 
on a Web site, you will come to rely on 
Dreamweaver’s ability to keep track of and 
manage who is working on a file. Known as 
Check In/Check Out, this feature prevents 
more than one team member from work-
ing on a particular file at a time. The feature 
also lets all members of the team know who 
is currently working on what file. Check In/
Check Out replaces the use of Get and 
Put for sites that have Check In/Check Out 
enabled. When you want to work on a file, 
you check it out, and when you are done 
working on the file and want to send it back 
to the remote server, you check it in.

Dreamweaver shows the status of files in 
the Files panel. Files that are checked out 
to you appear with a green check mark next 
to them, and files that are checked out by 
others appear with a red check mark next 
to them. Files that are read-only (because 
they are files that Dreamweaver can’t edit 
or because the last time Dreamweaver con-
nected to the remote server and checked 
their status they were checked out) appear 
with a padlock icon A.

Checked out 
by another

Checked out 
by you

Read-only 
file

A These files in the Files panel show their 
checked-out status.
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To get the Check In/Check Out system to 
work properly, there are two cardinal rules 
all members of the Web team must follow:

n	 All members of the team must enable 
Check In/Check Out and Design Notes 
in their site definitions.

n	 All members of the team must always
use Dreamweaver or Contribute (and 
no other tools, such as an FTP program) 
to transfer files to and from the remote 
Web server.

If Check In/Check Out is enabled for your 
site and you use the Get File or Put File button 
in the Files panel rather than the Check In or 
Check Out button, Dreamweaver transfers 
read-only versions of the file to and from the 
remote server.

When any team member checks out a 
file, Dreamweaver places a small text file on 
the remote site with the name of the checked-
out file plus the extension .LCK. Dreamweaver 
uses this file to store the Check Out name and 
email address of the person who is using the 
file. When the file is checked back in, Dream-
weaver automatically deletes the .LCK file.

To enable Check In/Check 
Out for your site:
1. Choose Site > Manage Sites.

The Manage Sites dialog appears B.

2. In the list of sites, click to select the site 
for which you want to enable Check In/
Check Out, and click the Edit icon at the 
bottom of the dialog.

The Site Setup dialog appears, set to 
the Site category.

continues on next page

Delete site

Edit site

Duplicate site definition

Export site definition

B You use the Manage Sites dialog to set up 
Check In/Check Out.
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3. In the Category list on the left side of 
the dialog, click the Servers category.

The dialog changes to show the 
defined servers C.

4. Click to select the remote server in 
the list, and then click the Edit Exist-
ing Server button at the bottom of the 
server list.

The Edit Server dialog appears.

5. Click the Advanced tab D.

6. Select the “Enable file check-out” check 
box.

7. Select the “Check out files when open-
ing” check box.

8. Enter a check-out name.

Because you may be working on a 
page using different programs or differ-
ent systems, it’s a good idea to use a 
name that describes the program and/
or system you’re working on. For exam-
ple, the check-out name tom-dw-win
indicates “Tom, using Dreamweaver, 
on Windows.” The check-out name 
tom-ct-mac would indicate “Tom, using 
Contribute, on Macintosh.”

9. (Optional but recommended) Enter 
your email address in the Email Address 
text box.

This allows coworkers to easily send 
you email if they need to communicate 
with you about the status of a file.

10. Click Save.

The Site Setup dialog reappears.

11. Click Save.

The Manage Sites dialog reappears.

12. Click Done.

Edit Existing Server button

C You begin enabling Check In/Check Out in the 
Servers pane of the Site Setup dialog…

D …and finish the process in the Advanced tab of 
the Edit Server dialog.
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Checking Files 
In and Out
When Check In/Check Out is enabled for 
your site and you use the Check Out but-
ton at the top of the Files panel, Dream-
weaver checks to see if anyone else is 
currently working on the file. If someone 
else has the file checked out, Dream-
weaver displays a dialog asking if you want 
to override that check out A. In general, 
it’s a bad idea to do so, because it could 
lead to exactly the problems with multiple 
people working on the file that you want 
to avoid. On the other hand, if the person 
who checked out the file is you, just work-
ing on another machine, and you know 
the current state of the file, go ahead and 
override the lock on the file.

To check out a file for editing:
1. In the Files panel, from the Site pop-up 

menu, choose the site that contains the 
file you want to check out B.

The site must have Check In/Check 
Out enabled.

2. Click the Connect to Remote Site 
button.

Dreamweaver connects to the 
remote site.

3. Choose the file (or files) you want to 
check out from the Files panel.

4. Click the Check Out button in the Files 
panel toolbar.

The Dependent Files dialog appears C.

continues on next page

A If someone else has already checked out a file, 
Dreamweaver lets you know and asks what you 
want to do.

Expand/ 
Collapse

Synchronize

Check In

Check OutPut File

Get File

Refresh

Connect to 
Remote Site

Site pop-up menu

B You’ll check files in and out with the toolbar in 
the Files panel.

C You can choose whether or not to download 
dependent files. If they haven’t changed, 
don’t bother.
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5. If you need to also edit the dependent 
files, such as images or external style 
sheets, click Yes. In most cases, how-
ever, you will click No.

Dreamweaver transfers the selected 
files and puts green check marks next to 
the files in both the Local Files and the 
Remote Site views in the Files panel.

6. Make the changes you want to the 
checked-out files.

To check in a file to the 
remote server:
1. In the Files panel, select the checked-

out file or files.

2. Click the Check In button in the Files 
panel toolbar.

If the files you’re checking in have not 
been saved, Dreamweaver prompts you 
to save them. After you save the files, 
Dreamweaver removes the green check 
marks from the files in the Files panel.

You can have Dreamweaver automati-
cally save unsaved files before checking them 
in by enabling the “Save files before putting” 
option in the Site category in Dreamweaver’s 
Preferences panel.

If you save and close a file without 
checking it in, the copy of the file on the 
remote site will not be updated. You should 
always check a file in when you are done 
working with it.

If you make a mistake and check out the 
wrong file, you can revert to the version of the 
file on the remote server, even if you modi-
fied and saved the checked-out version on 
your machine. Just right-click the checked-out 
file in the Files panel, and then choose Undo 
Check Out from the context menu. Dream-
weaver removes your check-out lock from the 
remote server and replaces your local copy 
with the copy from the server, and that local 
copy of the file becomes read-only.
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Using Design Notes
Dreamweaver’s Design Notes are XML files 
that Dreamweaver places on the site that can 
be used by Web team members to annotate 
changes or note when a file was modified 
and by whom. A Design Note is associated 
with a file on your site, but it is a separate 
XML file with different fields that can be read 
by the Adobe programs A. Design Note files 
aren’t visible to your site’s visitors.

You can create a Design Note yourself, and 
Dreamweaver and other programs in the 
Creative Suite can also make automated 
Design Note entries. For example, when 
you create an image in Fireworks and then 
export it to Dreamweaver, Fireworks creates  
(and places in the Dreamweaver site) a 
Design Note entry for the exported file, which 
could be in GIF or JPEG format. The entry 
records the name of the Fireworks source file 
(remember, the Fireworks file format is PNG) 
associated with the exported image in your 
site. That’s how Dreamweaver, Fireworks, 
Photoshop, and other external image editors 
know how to integrate the source file with 
the exported site image when you go to edit 
it (refer to Chapter 5 for more information 
about editing images in Dreamweaver with 
external image editors).

A Design Notes are XML files that Dreamweaver knows how to read.
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Dreamweaver stores Design Notes in fold-
ers called _notes in each of the site folders 
that have files with associated notes. 
These folders don’t appear in the Files 
panel, but you can see them if you use an 
FTP program to view your site B. These 
notes folders contain one Design Note file 
for each site file that has a note.

To add a Design Note:
1. Open the file to which you want to add 

a Design Note, and then choose File > 
Design Notes.

or

In the Files panel’s Local view, select the 
file to which you want to add a Design 
Note, and then right-click and choose 
Design Notes from the context menu.

The Design Notes dialog appears, set 
to the Basic info tab C. This tab shows 
you the filename and the location of the 
file at the top of the dialog.

2. (Optional) From the Status pop-up 
menu, choose the status you want to 
set for the Design Note.

The preset statuses are draft, revision1, 
revision2, revision3, alpha, beta, final, 
and needs attention.

3. (Optional) If you want to date-stamp 
your note, click the calendar icon in 
the dialog.

The current date appears in the 
Notes field.

4. Type your note about the file.

5. Click OK.

Dreamweaver saves the Design 
Note, and the Design Notes dialog 
disappears.

B Design Notes appear in the special _notes
folders Dreamweaver creates in your site, seen 
here in an FTP program.

C Use the Design Notes dialog to enter your notes.



ptg8274339

Managing Your Site 463

Adobe Contribute also uses Design Notes 
to make note of when a Contribute user has 
updated a page. But Contribute doesn’t have 
an interface to make specific notes; it just cre-
ates automated notes with the contributor’s 
username and the page’s modification date. 
Contribute Design Notes also keep track of roll-
backs, which allow Contribute users to revert to 
previously published versions of pages.

You must check out the file associated 
with a Design Note before you can add or 
modify the Design Note.

To modify a Design Note:
1. Open the file that contains a Design 

Note you want to modify, and then 
choose File > Design Notes.

or

In the Files panel, select the file whose 
Design Note you want to modify, and 
then right-click and choose Design 
Notes from the context menu.

The Design Notes dialog appears.

2. Make changes to the Status pop-
up menu, or enter a new note in the 
Notes field.

If you click the calendar icon to add a 
new date stamp, the new note appears 
at the top of the dialog, and older notes 
appear below the newest entry, in 
reverse chronological order.

3. Click OK.
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Setting Up Subversion
Dreamweaver features support for Subver-
sion, which is a free, open-source version 
control system (VCS). A VCS is software 
that runs on the remote server and man-
ages multiple revisions of the same bit of 
information. Every time a file changes, a 
VCS server creates a new version of the 
file, handles users checking files in and out 
of the server repository, and flags possible 
conflicts (when more than one user has 
made changes to the same file). Most VCS 
servers allow permitted users to get the lat-
est versions of files, check in changed files, 
and revert files to an unmodified state or to 
a past version.

A Subversion (SVN) setup would generally 
be used on large Web sites or with Web 
sites maintained by very technically savvy 
users. Your site administrator will know 
whether or not your Web site uses an SVN 
version control system.

The Subversion server support in Dream-
weaver allows you to move, copy, and 
delete files locally and then synchronize 
changes with your remote SVN repository.

This still does not completely replace all of 
the capabilities of a true Subversion client, 
but it’s good for working with a Subversion 
repository without having to constantly 
switch from Dreamweaver to a separate 
Subversion client program.

To enable Subversion 
version control:
1. Choose Site > Manage Sites.

The Manage Sites dialog appears A.

2. In the list of sites, click to select the site 
for which you want to enable SVN, and 
click the Edit icon (it looks like a pencil).

The Site Setup dialog appears.

A Begin setting up Subversion support in the 
Manage Sites dialog.
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3. In the Category list on the left side of 
the dialog, click the Version Control 
category.

The dialog changes to show the Ver-
sion Control pane.

4. From the Access pop-up menu, choose 
Subversion.

The server settings appear in the 
pane B.

5. From the Protocol pop-up menu, 
choose the communications protocol 
used by your Web site’s Subversion 
server. Check with your site administra-
tor if necessary.

Your choices are HTTP, HTTPS, SVN, or 
SVN+SSH.

6. In the Server Address field, enter the 
Subversion server’s URL.

7. In the Repository Path field, enter the 
path to the server’s database. Again, you 
can get this from your site administrator.

8. Most of the time, the default entry in 
the Server Port field will be correct (it 
changes according to the choice in the 
Protocol pop-up menu). If not, your site 
administrator will know the correct port. 
Click into the field, and then enter the 
correct port number.

9. Enter your username and password, 
and then click the Test button.

If all is well, Dreamweaver reports a suc-
cessful connection to your SVN server.

10. Click OK.

The Manage Sites dialog reappears.

11. Click Done.

You cannot use both a Subversion 
server and Dreamweaver’s built-in Check In/
Check Out system on the same Web site. You 
must choose one or the other (or neither).

B Enter the information needed to connect to the 
Subversion server.

Doing More with Subversion
Some of the Subversion abilities 
introduced with Dreamweaver CS5 
further allow you to avoid resorting to a 
dedicated Subversion client. The Revert 
command allows you to quickly correct 
tree conflicts or roll back to a previous 
version of a file. From the Repository 
view of the Files panel in Dreamweaver, 
you can reduce clutter by directly 
performing svn:ignore commands 
to hide files you don’t need to access 
(this is the SVN equivalent of Dream-
weaver’s familiar cloaking ability). To 
ensure future compatibility, the built-in 
Subversion libraries in Dreamweaver are 
designed to be updated by the Adobe 
Extension Manager.

The version of the Subversion client 
installed in your copy of Dreamweaver 
is listed in the Version Control pane of 
the Site Setup dialog. As newer versions 
of the Subversion libraries become 
available, they will be made available to 
the public as free extensions at Adobe 
Exchange at www.adobe.com/cfusion/
exchange. Rather than entering that 
URL, you can instead click the Adobe 
Subversion Central link in the Version 
Control pane.

www.adobe.com/cfusion/exchange
www.adobe.com/cfusion/exchange
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Generating Site 
Reports
A large part of site management, especially 
if you are managing a team working on the 
site, is keeping up with all of the things that 
are happening to the site. For example, let’s 
say that you want to know which pages 
each of your team members is working on 
at the moment. Dreamweaver allows you to 
get a report of the checked-out pages and 
who has checked them out. Similarly, you 
can get reports on many other aspects of 
your site, listed in Table 18.1. Dreamweaver 
splits reports into two categories: Workflow, 
with reports detailing who has worked 
on the site and when; and HTML Reports, 
which search through files on your site look-
ing for HTML errors.

TablE 18.1 Dreamweaver Reports

Workflow Category

Report name Description

Checked Out By Reports filename and the name of the team member who has checked it out.

Design Notes Shows the contents of the Design Note for files that have them.

Recently Modified Shows the last modified date for the selected files, based on search 
criteria you specify.

HTML Reports Category

Report name Description

Combinable Nested Font Tags Finds markup with font tags.

Accessibility Checks the selected pages for adherence to accessibility guidelines.

Missing ALT Text Flags missing alternate text attributes for images on your pages.

Redundant Nested Tags Reports unnecessarily repeated nested tags; e.g., <b><b>example  
text</b></b>.

Removable Empty Tags Shows any empty tags that can be safely removed.

Untitled Documents Reveals documents in which you have forgotten to enter a title.
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Some reports will let you enter parameters 
for the report that allow you to widen or 
narrow the criteria used for the report. All 
the reports, however, allow you to report on 
just the current document; the entire current 
local site; just selected files in the site; or 
files within a selected folder in the site.

To get site reports:
1. Choose Site > Reports.

The Reports dialog appears A.

2. From the Report on pop-up menu, 
choose the scope of the report.

Your choices are Current Document, 
Entire Current Local Site, Selected Files 
in Site, or Folder.

3. In the Select reports list, select the 
report or reports that you want to run.

If the report you have selected allows 
you to choose report criteria, the Report 
Settings button becomes active.

continues on next page

A Specify the kind of site report you want in the 
Reports dialog.
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4. (Optional) For reports that allow addi-
tional settings, click Report Settings 
and then complete the resulting set-
tings dialog.

Each report that allows additional set-
tings has a different criteria dialog. B 
shows, for example, the criteria dialog 
for the Recently Modified report.

After you click OK in the settings dialog, 
you return to the Reports dialog.

5. Click Run.

Dreamweaver runs the report and 
shows the report output in the Site 
Reports tab of the Results panel below 
the Property inspector C and also in 
an HTML page, which it opens in your 
default browser.

B The Recently Modified dialog, brought up by 
the Report Settings button, allows you to specify 
the scope of the report. Other reports have 
different Report Settings dialogs.

C The report appears in the Results panel.
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Checking for 
broken links
One of the more vexing problems with 
Web sites is broken links—that is, links that 
no longer point to valid destinations within 
your site. Dreamweaver usually does a 
pretty good job of updating links when you 
move or rename a page, but you can still 
end up with broken links if you cut or copy 
page content from one page to another 
on your site. Dreamweaver allows you to 
check all of the links on your site to make 
sure they are still valid and reports any 
broken links it finds. You can then easily 
open the file that contains the broken link 
to fix it.

To check for and fix broken 
links throughout your site:
1. Choose Site > Check Links Sitewide, or 

press Ctrl-F8 (Cmd-F8).

Dreamweaver checks all the pages on 
your site and shows you files with bro-
ken links in the Link Checker tab of the 
Results panel A.

continues on next page

A Files with broken links appear in the Results panel.



ptg8274339

470 Chapter 18

2. Double-click one of the results.

The file with the broken link opens, with 
the broken link highlighted B.

3. Using the Property inspector, fix the 
broken link.

For more information about using the 
Property inspector to work with links, 
see Chapter 6.

4. Repeat steps 2 and 3 until you have 
eliminated all of the broken links.

Dreamweaver only checks for the validity 
of links to documents within your site. If you 
have external links on your site (links that 
point to other sites on the Internet), Dream-
weaver does not follow those links, and so it 
does not ensure that those sites still exist and 
are reachable. If you need to validate external 
links, you need to follow those links manually 
in a Web browser.

You can also check for broken links on 
just the page you are editing. Choose File > 
Check Page > Links, or press Shift-F8.

B To fix the broken link, double-click one of the report results; the file with the broken link 
opens with the broken link selected; in this case, the top picture is highlighted because it 
links to a nonexistent page.
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Finding External links 
and Orphaned Files
You can get two other types of reports from 
Dreamweaver. The first is a list of links from 
your site to other sites, called external links, 
and the other is a report of orphaned files, 
which are files that have no links pointing to 
them. In the first case, after Dreamweaver 
finds the external links, you can (if needed) 
easily change them. In the case of orphaned 
files, you should create links to the files from 
your other Dreamweaver pages.

To find external links 
and orphaned files:
1. Choose Site > Check Links Sitewide, or 

press Ctrl-F8 (Cmd-F8).

Dreamweaver checks all the pages on 
your site and shows you files with bro-
ken links in the Link Checker tab of the 
Results panel.

2. From the Show pop-up menu in the 
Results panel, choose External Links.

or

From the Show pop-up menu in the 
Results panel, choose Orphaned Files A.

The results appear in the Results panel.

3. (Optional) If you chose External Links in 
step 2, the Results panel shows a list of 
files and the external links that appear on 
them. Click one of the links to highlight it 
and make it editable. You can then enter 
a new destination for the link B.

or

(Optional) If you chose Orphaned Files 
in step 2, the Results panel shows a list 
of files with no links pointing to them. 
Double-click a filename to open that 
file, or open other files in the Files panel 
to create links to the orphaned file.

A Choose either External Links or Orphaned Files 
to obtain a report on those items.

B You can change external links right in the 
Results panel.
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Checking browser 
Compatibility
In terms of the HTML document type, 
Dreamweaver creates XHTML 1.0 Tran-
sitional files by default, as discussed in 
Chapter 3 (though you can override this 
in the Preferences panel if, for example, 
you would rather HTML5 be the default). 
These files are readable by and valid for all 
commonly used modern Web browsers. So 
you might consider Dreamweaver’s ability 
to check files for HTML browser support 
to be somewhat vestigial. But you may 
find you need to work on older pages that 
haven’t been retrofitted for current brows-
ers. Dreamweaver allows you to check 
your pages for errors with targeted brows-
ers. It does this by keeping a database of 
browser profiles, which details how differ-
ent browsers render pages. You can check 
the open page for browser compatibility. 
Errors appear in the Results panel.

The version of this feature that has been 
included in Dreamweaver since CS3 is 
much more complete than that of previous 
versions because it checks the CSS—not 
just the HTML—for possible rendering 
bugs. For each bug that it finds, Dream-
weaver provides an estimate of the bug’s 
severity and a link to a discussion about 
the bug on Adobe CSS Advisor, a Web site 
that offers solutions for fixing CSS bugs.

There’s a difference between browser 
checking and validation. Dreamweaver 
validates pages against W3C standards (as 
shown in Chapter 17) by sending the page 
to the W3C validation service. Browser 
checking compares the page against inter-
nal browser profiles. As new browsers and 
versions are produced, Adobe updates the 
appropriate browser profiles.
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To define browsers for checking:
1. Open any file in your site.

2. From the Check Page pop-up menu 
at the top of the document window, 
choose Settings A.

The Target Browsers dialog appears B.

3. To enable a particular browser, select 
the check box next to its name. Choose 
from the pop-up menu next to the name 
to select the minimum version of that 
browser you want to check against.

4. Click OK to dismiss the Target Browsers 
dialog.

A Use the Check Page pop-up menu to 
make sure your pages appear correctly in 
different browsers.

B Choose the target browsers for your 
compatibility check.
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To check for browser compatibility:
1. From the Check Page pop-up menu 

at the top of the document window, 
choose Check Browser Compatibility.

If there are no errors found, a status 
line appears in the Results pane stating 
“No issues detected.” Pop a cold one 
and relax.

2. If errors are found, a list appears in the 
Results panel C.

There are three kinds of possible errors 
reported in the Results panel: errors, 
warnings, and informational messages. 
An error indicates a problem in the code 
that can cause serious visual problems 
with the page. A warning indicates that 
the page won’t be displayed exactly as 
desired in the targeted browser but that 
the problem isn’t serious. An informa-
tional message is used for code that isn’t 
supported in a particular browser but 
that has no visual effect.

3. Double-click an error in the Results 
panel to change the document window 
to Split view, highlighting the error in 
Code and Design views.

4. Fix the error in Code view.

C Errors in your document appear in the Results panel, along with the names of the browsers affected by 
the errors. In this case, to show some errors, we set Dreamweaver to check errors against IE6, a browser that 
is so old that it doesn’t understand CSS (and that hardly anybody uses anymore).

All browser compatibility errors that 
Dreamweaver finds are not necessarily errors, 
as such. For example, on our example site, 
www.alpacarepo.com, Dreamweaver dutifully 
reports an error against Internet Explorer 6. 
But that’s because the page uses CSS that 
is more advanced than IE6 can handle, not 
because the CSS is incorrect. We recommend 
that you take the Dreamweaver report as advi-
sory rather than prescriptive.

www.alpacarepo.com
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Deleting Sites
When you will no longer be working with a 
site (perhaps because the project has been 
taken over by another developer), you can 
delete its site definition. This removes the 
site from the Manage Sites dialog and from 
the Site pop-up menu in the Files panel. Of 
course, all the settings for the site are also 
deleted. You should be careful when you 
delete site definitions, because there’s no 
way to undo the action.

To delete a site from Dreamweaver:
1. Choose Site > Manage Sites.

The Manage Sites dialog appears A.

2. From the list of sites, click the site that 
you want to delete.

3. Click the Remove icon (it looks like a 
minus sign).

Dreamweaver alerts you that you can-
not undo this operation B.

4. Click Yes.

Dreamweaver deletes the selected site.

Although Dreamweaver is asking if you 
want to delete the site, the site itself (that is, 
the files in the local site folder on your hard 
drive) won’t be touched. The only things that 
are deleted are the site definitions: what 
Dreamweaver knows about your site. And of 
course, nothing is changed on the remote site.

A Begin deleting a site in the Manage Sites dialog.

B When you try to delete a site, 
Dreamweaver asks you to confirm 
your action.
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Exporting and 
Importing Site 
Definitions
When you create a local site on your 
machine, Dreamweaver creates a local 
site definitions file with all the information 
about the site’s settings, including infor-
mation about the server connection, your 
server password, and any site-specific 
preferences you may have set in the Site 
Definition dialog. If you need to move the 
site from one machine to another, or if you 
want to add members of your Web team 
and have them share the same site prefer-
ences, you must export the site definition. 
When you do that, Dreamweaver saves the 
site definition information as an XML file 
with the .ste file extension.

Dreamweaver allows you to export the 
site definition in one of two ways. You can 
export it with your server username and 
password information (this facilitates mov-
ing the site to a different machine), or you 
can export the site with the site prefer-
ences but without your server login infor-
mation (this is good for adding coworkers 
to the site).

You can, of course, also import a site defini-
tion file that you had previously exported 
or one you received from a colleague.
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To export a site definition:
1. Choose Site > Manage Sites.

The Manage Sites dialog appears.

2. From the list of sites, click the site you 
want to export.

3. Click Export.

The Exporting Site dialog appears A.

4. Click “Back up my settings (includes login, 
password, and local paths)” if you plan to 
move the site to another machine.

or

Click “Share settings with other users 
(does not include login, password, or 
local paths)” if you want to create a site 
definition file that does not include your 
server login information.

5. Click OK.

The Export Site dialog appears.

6. Navigate to where you want to save the 
site definition file, make sure that the 
name Dreamweaver has given the file is 
OK (by default it gives the file the name 
of your site and appends the .ste file 
extension), and then click Save.

Dreamweaver saves the site definition 
file onto your hard disk.

You’ll return to the Manage Sites dialog.

7. Click Done.

A Choose whether or not you want to include your login information in the 
exported site definition file.
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To import a site definition:
1. Choose Site > Manage Sites.

The Manage Sites dialog appears.

2. Click Import.

The Import Site dialog appears.

3. Navigate to and select the site defini-
tion file you want to import.

4. Click Open.

Dreamweaver imports the site defini-
tion and adds it to the list of sites in the 
Manage Sites dialog.

5. Click Done to dismiss the Manage 
Sites dialog.

You can use the ability to export the site 
definition file as a way to back up your site’s 
settings, but this is no substitute for a regular 
and comprehensive backup strategy cover-
ing all of the important documents on your 
hard drive.

If you happen to work on multiple com-
puters and multiple sites, and each of the com-
puters has a copy of Dreamweaver, you can 
export your site definitions for all of your sites 
and then copy them to a USB flash drive. You 
could then plug in the flash drive on whichever 
computer you happen to be working on, and 
you will have your site settings, including your 
server passwords. Of course, you would need 
to resynchronize the remote site with a newly 
created copy that would then become the 
local site folder on the machine you are work-
ing on. See Chapter 2 for more information 
about synchronizing sites.
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Learn More
Once you’ve worked through this book, 
you should be well on your way to creat-
ing great Web pages with Dreamweaver. 
But Dreamweaver is such a comprehen-
sive program that there is plenty more to 
learn about it and about building Web sites 
in general.

In this appendix, we’ll point to several of 
the most helpful Dreamweaver-oriented 
Web sites and other sites where you can 
learn more about building standards-com-
pliant Web sites, and we’ll even mention a 
few other books that will help you deepen 
your knowledge not just of Dreamweaver, 
but also of Web design and JavaScript.

As usual with products that can be found 
on the Internet, Web sites come, go, and 
change addresses with alarming regular-
ity. The sites listed here were in existence 
when this book went to press and may 
be available when you check them out, 
or they may not. We are just reporting the 
URLs; we have no control over them. If you 
find a link that has become stale, we would 
appreciate it if you would drop a note to 
dwcs6@dreamweaverbook.com so that we 
can update the next edition of the book.

Find It Online!
You’ll find an updated list of the 
sites and books in this appendix at 
this book’s companion Web site at  
www.dreamweaverbook.com. We’ll keep 
the Web site current with a list of Dream-
weaver-oriented sites, and if eagle-eyed 
readers spot any errors in the book, we’ll 
note them on the site, too.

In This Chapter
Web Sites 480

Other Online Resources 484

Other Dreamweaver Books 486

Web Design and JavaScript Books 486

www.dreamweaverbook.com
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Web Sites
Almost as soon as Dreamweaver came 
upon the scene, people began gather-
ing online to discuss the program and 
help each other use it. There are several 
Dreamweaver community sites, informa-
tional sites, places where you can pur-
chase premade Dreamweaver templates, 
and sites from developers who have cre-
ated new Dreamweaver extensions. This 
list is by no means comprehensive, but it 
does include sites that we have found to 
be helpful.

Of course, Adobe has a variety of online 
support options as well.

Adobe Sites

Dreamweaver Support
n	 helpx.adobe.com/dreamweaver.html

This should be your first stop when 
looking for answers to a Dream-
weaver question (after this book, of 
course!) A. This site allows you to 
search not just Adobe’s Dreamweaver 
resources but also get help from the 
larger Dreamweaver community. There 
are also tutorials, videos, articles, and 
documentation. 

Adobe Marketplace & Exchange
n	 www.adobe.com/exchange/

This is the place to go when you’re 
looking for Dreamweaver add-ons and 
extensions. At press time, there were 
more than 2000 items for download B.

A Adobe’s support site for Dreamweaver offers 
help on levels ranging from absolute beginner to 
experts who want to become, well, more expert.

B Dreamweaver Exchange should be 
your first stop when you are looking for a 
Dreamweaver extension.

www.adobe.com/exchange/
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Dreamweaver Weblogs
n	 feeds.adobe.com

Once you go to the URL above, click the 
link for the Dreamweaver category. This 
is an aggregator site that lists posts from 
many people’s Dreamweaver-related 
weblogs C. It’s a great way to keep up 
with the Dreamweaver community.

n	 blogs.adobe.com/dreamweaver/

This blog is written by the Dream-
weaver team, which makes it a great 
place to find out about the latest hap-
penings directly from the people doing 
the work.

Dreamweaver Developer Center
n	 www.adobe.com/devnet/dreamweaver/

Dreamweaver Developer Center has 
tutorials focused on the new features 
of Dreamweaver CS6 and articles that 
will help you better use Dreamweaver 
to build your sites. There are also some 
additional templates and sample lay-
outs if the ones that came with Dream-
weaver aren’t enough for you.

n	 cookbooks.adobe.com/dreamweaver 

Did you come up with a slick way to 
accomplish something in Dreamweaver 
and want to tell others about it? Or 
maybe you’re looking for someone 
else’s slick way to accomplish some-
thing in Dreamweaver? In either case, 
Developer Center’s Cookbook section 
is the place you’re looking for.

Dreamweaver Forums
n	 forums.adobe.com/community/

dreamweaver/

Adobe’s Dreamweaver forums are active 
and a good place to get help from other 
knowledgeable users. The Dream-
weaver FAQ can also be found here.

C Adobe’s weblog aggregator brings together 
interesting blog posts about Dreamweaver from all 
over the Web.

www.adobe.com/devnet/dreamweaver/
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Tutorials and Add-ons

WebAssist
n	 www.webassist.com

WebAssist is one of the premier devel-
opers of Dreamweaver extensions 
and Web apps ready to be integrated 
into your sites D. Its Design Extender 
extension helps you build customized 
site designs using wizards, with almost 
no effort. They also sell extensions 
that let you easily add shopping carts, 
database-driven back ends, advanced 
forms, and more to your site.

Besides the paid products, the WebAssist 
site also contains many tutorials cover-
ing CSS, images, navigation, and other 
subjects.

Adobe TV
n	 tv.adobe.com

Tons of constantly updated video con-
tent, including podcasts, demos, and 
tutorials by experts and Adobe employ-
ees, are available from Adobe TV E, 
which not only covers Dreamweaver, 
but other Adobe products. The site 
shows off not just released products, 
but previews of Adobe products that are 
still in beta. For example, at press time, 
there were several previews of a pro-
gram codenamed Muse, which is a Web 
animation application based on HTML5 
(and is likely to be named something 
else by the time you read this).

Content Management Systems
Now that Dreamweaver has solid CMS 
support, you’re likely to want to learn more 
about them. The three most common—
WordPress, Joomla, and Drupal—are all 
open source, which means that you can 

D WebAssist makes a variety of great 
Dreamweaver extensions, including ways 
to make customizable site designs and add 
e-commerce features to your sites.

E Adobe TV provides a large number of video 
tutorials and information.

www.webassist.com
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download, install, and take a good long 
look at them without spending a penny.

These are our recommended Web sites to 
start learning about each.

WordPress
n	 www.wordpress.org

WordPress started life as blogging 
software but has grown far beyond that. 
This is its official Web site.

n	 knowit.co.nz/category/wordpress

KnowIT is WordPress expert Miraz Jor-
dan’s blog, and this category contains 
her WP-related articles and how-to’s. 
She also has ebooks available from the 
site’s bookstore section.

Drupal
n	 www.drupal.org

This is the official Web site of the Drupal 
Project.

n	 www.buildamodule.com

This tutorial site has hundreds of videos 
to help you learn Drupal—some free, but 
most by subscription. It covers a wide 
range of topics from beginner to expert.

Joomla
n	 www.joomla.org

This is the official Web site for the 
Joomla CMS.

n	 resources.joomla.org

The Joomla Resource Directory F is 
invaluable in pointing you to training, 
extension providers, support compa-
nies, and hosting resources that let you 
leverage your investment in Dream-
weaver and your Joomla site. 

F The Joomla Resource Directory is your 
gateway to all things Joomla.

www.wordpress.org
www.drupal.org
www.buildamodule.com
www.joomla.org
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Other Online 
Resources
You can find interesting and useful help 
with Dreamweaver if you look beyond just 
Web sites. 

Dreamweaver Mailing List
tech.groups.yahoo.com/group/
adobe-dreamweaver/

This Dreamweaver mailing list is hosted on 
Yahoo and is a high-volume list that’s worth 
a look. You can also ask your questions 
about Dreamweaver on this list.

Wise-Women Mailing List
www.wise-women.org

Wise-Women is an online community with 
a Web site and an email discussion list A. 
The purpose of the list is to provide women 
on the Web with a supportive atmosphere 
to deal with issues of Web development, 
design, and consulting. Wise-Women was 
founded in 1999 by one of the authors of 
this book (Dori) and is going strong today. 
You’ll find lots of useful information on 
the mailing list about using Dreamweaver, 
among many other subjects. And in case 
you’re wondering, the community is not 
only for women.

A The Wise-Women online community offers 
support and help for women and men alike.

www.wise-women.org
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Creative Edge
www.creativeedge.com

If you’re looking for ebooks on Dream-
weaver or complementary technologies, 
Creative Edge has them B. Or maybe you 
prefer videos? Creative Edge has those, 
too. Or maybe you want a book that isn’t 
available in stores yet? Creative Edge 
even has those. In fact, as we wrote this 
appendix, a Rough Cut (a work in progress) 
of this very book was already available for 
download—legally, too!

Creative Edge lets you sample books and 
videos before you buy them. You can even 
comment on Rough Cuts, giving authors 
feedback while they can still do something 
about it.

Lynda.com Online Training Library
www.lynda.com

Lynda.com offers an excellent series of 
video training programs that cover Dream-
weaver and the rest of the Adobe prod-
uct line, as well as many other software 
packages C. You can purchase these 
training programs as discs that you can 
view on your computer, or you can access 
the videos over the Internet through the 
Online Training Library, for which you’ll 
need to purchase a subscription. Tom 
produced Contribute 3 Essential Training
and Quicken 2009 for Windows Essential 
Training for Lynda.com, and Dori produced 
JavaScript Essential Training and Ajax 
Essential Training.

B The Creative Edge Web site offers sneak peeks 
of upcoming books along with ebooks and videos.

C The Lynda.com Online Training Library offers 
many hours of video training on Dreamweaver.

www.creativeedge.com
www.lynda.com
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Other Dreamweaver 
Books
Though the authors would naturally like to 
think that the book you have in your hands 
is all you’ll ever need to become a Dream-
weaver expert, we recognize that you 
might just want a bit more information after 
you’ve completely devoured this book. 
There are approximately a million different 
Dreamweaver books on the market; here 
are two we think are the best.

Dreamweaver CS6 Bible
Joseph Lowery is well known in the Dream-
weaver community, and this massive refer-
ence, published by Wiley (2012), shows 
why. At well over 1000 pages, we think 
this is perhaps the most comprehensive 
Dreamweaver reference book available.

Adobe Dreamweaver CS5 with 
PHP: Training from the Source 
If you want to learn more about dynamic 
sites than we could cover in a QuickStart 
Guide, this book by David Powers (Peach-
pit, 2010) is your next stop. Along with its 
quick introduction to PHP, you’ll learn how 
to work with databases and content man-
agement systems. It’s not being updated 
for CS6, but it’s still useful.

Web Design and 
JavaScript Books
Readers of previous editions of this book 
have asked for our suggestions for books 
about JavaScript and Web design. There 
are too many books to count about these 
subjects, so here are some of our favorites. 

Styling Web Pages with CSS: 
Visual QuickProject Guide

JavaScript: Visual QuickStart Guide
Written by Tom Negrino and Dori Smith 
(hey, that’s us!), these books are great 
introductions to their topics (Peachpit, 
2009 and 2012). If you liked this book, 
you’ll find more of the same solid informa-
tion, delivered in an informal style.

Designing with Web 
Standards, Third Edition
Jeffrey Zeldman was one of the earliest 
and strongest voices evangelizing Web 
standards, and this book explains the gos-
pel to designers in familiar terms that they 
understand. This book is best for readers 
who are already familiar with using CSS to 
build Web sites (New Riders, 2010).

The CSS Detective Guide
CSS is terrific and amazingly flexible, but 
it’s not always easy to figure out the culprit 
when your CSS isn’t acting the way you 
want it to. Denise R. Jacobs has written a 
fun, engaging book that helps you track 
down your CSS bugs and teaches real-
world troubleshooting skills. It also has 
one of our favorite topics, “The Case of the 
Browser Who Hated Me.” This book was 
published by New Riders (2010).
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Customizing and 

Extending 
Dreamweaver

One of the best things about Dreamweaver 
is that it is both customizable and incredibly 
extensible. What’s the difference? Customiz-
able means that you can change the keyboard 
shortcuts to suit your style of working, and 
of course you can customize using Dream-
weaver’s Preferences dialog. That’s fine, but 
extensibility, the ability to add new features to 
the program, is where the real action is.

As you’ve seen in the rest of our book, Dream-
weaver can do an awful lot. But just because 
Dreamweaver is amazingly capable doesn’t 
mean that it does absolutely everything that 
people want it to do. Adobe allows software 
developers to write add-ons, called extensions, 
that add new features to Dreamweaver. These 
new features can range from the mundane 
(adding improved form handling abilities) to the 
amazing (creating full site generators with asso-
ciated page templates and navigation bars).

In this appendix, we’ll show you how to cus-
tomize Dreamweaver’s keyboard shortcuts 
and how to find, acquire, and install Dream-
weaver extensions.

In This Chapter
Customizing Keyboard Shortcuts 488

Finding and Installing Extensions 493
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Customizing 
Keyboard Shortcuts
Sometimes the keyboard shortcuts that 
come with Dreamweaver aren’t quite what 
you want. For example, some shortcut keys 
used for editing code with BBEdit (on Mac) 
or, for longtime users, the now-defunct 
HomeSite (on Windows) aren’t the same 
as the shortcuts used for the equivalent 
commands in Dreamweaver. No problem; 
you can change Dreamweaver shortcuts 
to match those in your favorite code editor. 
In fact, Dreamweaver comes with shortcut 
key sets for those two code editors, which 
makes it a snap to change shortcut keys 
and increase your productivity.

Of course, you can also change any 
keyboard shortcut, add shortcuts to menu 
items that may not already have them, or 
delete shortcut keys you don’t like. You can 
also print out a cheat sheet of keyboard 
commands to help you learn them.
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different set found in a previous ver-
sion of Dreamweaver; BBEdit, which 
modifies the code editing keyboard 
shortcuts to match those used by the 
popular Macintosh code editor; and 
HomeSite, which modifies the code 
editing keyboard shortcuts to match 
the popular (yet discontinued) Windows 
code editor.

3. Click OK.

Dreamweaver changes its keyboard 
shortcuts to match the set that you chose.

To change between 
shortcut key sets:
1. Choose Edit > Keyboard Shortcuts 

(Dreamweaver > Keyboard Shortcuts).

The Keyboard Shortcuts dialog 
appears A.

2. Choose the keyboard shortcuts that you 
want from the Current set pop-up menu.

Your choices are: Dreamweaver 
Standard, which includes the standard 
shortcut keys for the current version; 
Dreamweaver MX 2004, a slightly 

Rename set

Duplicate set

Export set as HTML

Delete setCommands list

Add shortcut Delete shortcut

A Begin customizing your Dreamweaver experience in the Keyboard 
Shortcuts dialog.
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To create a personalized set 
of keyboard shortcuts:
1. Choose Edit > Keyboard Shortcuts 

(Dreamweaver > Keyboard Shortcuts).

The Keyboard Shortcuts dialog 
appears A.

2. From the Current set pop-up menu, 
choose the keyboard shortcuts set that 
you want to use as the basis for your 
personalized set.

Dreamweaver won’t let you change 
any of the included sets, so you must 
duplicate one of them, then modify 
the duplicate.

3. Click the Duplicate set button.

The Duplicate Set dialog appears B.

4. Type the name for your duplicate set.

5. Click OK.

Dreamweaver creates the duplicate set 
and makes it the active set. You can 
then personalize it, as shown next.

To add or change a 
keyboard shortcut:
1. In the Keyboard Shortcuts dialog, 

choose the kind of command you want 
to modify from the Commands pop-up 
menu C.

This pop-up menu differs on Windows 
and Mac, with more choices (and more 
functionality) on Windows. Besides 
Menu commands, Code editing, Docu-
ment editing, and Snippets keyboard 
shortcuts, Dreamweaver for Windows 
also allows you to set keyboard short-
cuts for the Files panel options menu, 
the Site panel, and the Site window.

Depending on what you chose, the 
Commands list changes.

B Enter the name of your new keyboard 
shortcuts set.

C You can customize keyboard shortcuts for more 
items on Windows (top) than on Mac (bottom).
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2. In the Commands list, navigate to the 
command that you want to change. 
Click the + icon next to the name of the 
menu to expand the choices for that 
menu. On the Mac, click the disclosure 
triangle next to the name of the menu.

The menu choices are shown with any 
existing shortcut keys D.

3. Click the command that you want 
to change.

The shortcuts assigned to the command 
appear in the Shortcuts text box E.

4. To add a shortcut, click the Add short-
cut button (marked with a plus sign).

A new blank line appears in the Short-
cuts text box.

or

To change an existing shortcut, select it 
in the Shortcuts text box.

5. Click in the Press key text box.

6. Press the key combination you want to 
use for the shortcut key.

If the key combination is already in use, 
Dreamweaver lets you know with a 
message at the bottom of the Keyboard 
Shortcuts dialog.

7. Click Change.

The new shortcut appears in the Short-
cuts text box.

8. Click OK to save your changes and 
dismiss the Keyboard Shortcuts dialog.

D Click the + buttons to display menu choices in 
an indented tree form.

E Select the shortcut key that you want to change.
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To export a keyboard 
command cheat sheet:
1. Choose Edit > Keyboard Shortcuts 

(Dreamweaver > Keyboard Shortcuts).

The Keyboard Shortcuts dialog 
appears A.

2. Click the Export set as HTML button.

The Save as HTML file dialog appears.

3. In the Save as text box, give the 
exported file a name, then navigate to 
where you want to save the HTML file.

4. Click Save.

Dreamweaver saves the list of key-
board commands to your hard disk as 
an HTML file. You can then open it in 
Dreamweaver or any Web browser F.

F You can print your keyboard command cheat sheet from a Web browser.
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Finding and Installing 
Extensions
You add extensions to Dreamweaver using 
Adobe Extension Manager, a program 
that was installed when you installed 
Dreamweaver on your system. After you 
install an extension, it appears as part of 
Dreamweaver. Where it appears within the 
program depends on what kind of exten-
sion it is. For example, if you have installed 
an extension that allows you to easily add 
Google search boxes or maps, that exten-
sion would appear in the Insert menu. An 
extension that provides new ways to add 
pop-up menus may appear in the Com-
mands menu. And extensions that add 
new scripting behaviors will appear in the 
Behaviors panel. Because Dreamweaver is 
almost infinitely extensible, the extensions 
you add can appear almost anywhere 
within the program.

You can find extensions in a variety of 
ways. Some extensions are free for down-
loading, and others are paid products. 
Many extension developers have Web 
sites where they host (and sometimes 
sell) their extensions. A Google search for 
“Dreamweaver extensions” will result in a 
large number of useful results.

But the most common way to find  
Dreamweaver extensions (and also exten-
sions for other Adobe products, such as 
Photoshop, Fireworks, Flash, and so on)  
is to use the Adobe Exchange site, at  
www.adobe.com/exchange/. The Dream-
weaver Exchange portion of the site has 
lists and short descriptions of more than 
2000 extensions.

www.adobe.com/exchange/
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In Dreamweaver, it’s easy to go to the 
Dreamweaver Exchange site. Just choose 
Help > Dreamweaver Exchange, and your 
default Web browser opens to the site A. 
From the Exchange site, or from an exten-
sion developer’s site, download the exten-
sion file to your hard disk. Then you’re 
ready to use Adobe Extension Manager 
to install the extension.

A The Dreamweaver Exchange site lists more than 2000 extensions.
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To install an extension:
1. If it’s running, quit Dreamweaver by 

choosing File > Quit (Dreamweaver > 
Quit).

2. Launch Adobe Extension Manager by 
double-clicking its icon.

On Windows, launch the program from 
the Start menu. On Mac, you’ll find it 
in /Applications/Adobe Extension 
Manager CS6/.

The Adobe Extension Manager window 
appears B.

continues on next page

Go to Adobe 
Exchange

Installed 
extensions list Install extension

Remove 
selected 
extensionProducts list

Extension 
description

B Use the Adobe Extension Manager program to install or remove extensions.
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3. From the Products column on the left 
side of the window, choose Dream-
weaver CS6.

Any extensions you have installed 
for Dreamweaver CS6 appear in the 
Installed extensions list.

4. Click the Install button.

The Select Extension to Install dialog 
appears C.

5. Navigate to and select the extension 
file you wish to install.

6. Click Open (Select).

A license dialog appears.

7. Click Accept.

The Extension Manager installs the 
extension and reports success with an 
alert dialog.

8. Click OK to dismiss the alert dialog.

The new extension appears in the 
Installed extensions list.

9. Choose File > Exit (Extension Manager > 
Quit Extension Manager).

10. Launch Dreamweaver to use the new 
extension D.

If you have more than one version of 
Dreamweaver installed (perhaps you didn’t 
want to remove an older copy immediately 
when you upgraded to Dreamweaver CS6), 
you can have different sets of extensions 
installed for each version.

Because each extension works differ-
ently, you need to refer to the instructions 
that came with the extension to discover 
how to access the extension from within 
Dreamweaver.

C Find and select the extension file that you want 
to install.

D Extensions can provide a complete user 
interface, as in this example, Tools for Google, 
which helps you easily create a Google search 
box, map, or other Google service on your site.
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Index

Media Encoder, 160, 162
Photoshop. See Photoshop
Web sites, 480–483
Widget Browser, 366–371

Adobe Dreamweaver CS5 with PHP, 486
Adobe TV, 482
Advanced Settings category, 30, 52, 171, 224, 330
Ajax Essential Training, 485
alignment

cell, 286
with HTML, 105–107
shortcut keys, 107
table, 285

All mode, CSS Styles panel, 198–200
All Rules pane, 255
alternate text, 65, 134, 135, 136
anchors, 175–177
animations, 158–159
Apache, 382
AP elements, 230. See also absolute positioning
App Developer workspace, 20, 421
Appearance (CSS), Page Properties dialog, 80, 

81–82, 212
Appearance (HTML), Page Properties dialog, 

82–83, 212
Application bar, 6
Application frame, 8
ASP, 447
Assets panel

accessing library items from, 404–406, 408, 410
accessing templates from, 394, 398–400
buttons/controls, 138
inserting images from, 138
updating Smart Objects in, 153

Attach External Style Sheet dialog, 255
authentication, 32, 33, 36

B
<b> tag, 102
backgrounds

color, 82, 83, 234–236, 287
CSS rule definitions, 190
images, 82, 154–155

base URLs, 87

Symbols
# (pound sign) using with anchors, 177

using with id selectors, 189, 194, 195–197
() (parentheses), selecting in Coding toolbar, 417
. (period), before class selectors, 194
// comments, applying from Coding toolbar, 

417–418
/* */ comment, applying from Coding toolbar, 

417–418
[] (square brackets) selecting in Coding toolbar, 417
_ (underscore), preceding targets with, 174
{} (braces), selecting in Coding toolbar, 417
<!--  --!> comments, applying from Coding 

toolbar, 417–418
</, ending tags with Code Hints, 437
' comments, applying from Coding toolbar, 

417–418
2-column liquid layout, 233–234
2-up view, 78–79

A
absolute links, 168
absolute positioning, 229, 230, 317
accessibility

and alternate text for images, 65, 134, 135
and new browser windows, 348
preferences, 65, 135, 303
recommended book on, 447

access keys, 303
Action menu, 125
active links, 83, 84, 173
Add Web Font dialog, 224
Adobe

BrowserLab, 15, 71, 76–79, 230
Business Catalyst, 15, 18, 20, 392, 394, 395
Contribute, 392, 395, 457, 463
Creative Cloud, 18, 392
Creative Suite, 392
Dreamweaver. See Dreamweaver
Exchange, 366, 493
Extension Manager, 493, 496
Fireworks, 140, 143, 359–360, 461
InContext Editing, 18, 392
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behaviors, 339–360
adding, 341–342
changing order of, 343
deleting, 343
editing, 342
list of, 340
for specific purposes

checking for plug-ins, 351–352
inserting Fireworks pop-up menus, 359–360
inserting jump menus, 353–355
inserting rollovers, 345–347
opening new browser window, 348–350
validating forms, 356–358

Behaviors panel, 339, 341–343, 347, 357, 365, 
445, 493

Behaviors tab, Tag Inspector panel. See Behaviors 
panel

Bezier curves, 374
Block, CSS rule definitions, 190
<blockquote> tag, 105, 106
blogs, 481
blog software, 378
<body> tag, 13, 154, 155, 189, 192, 194, 195, 234, 

351, 404, 408, 444,
bold text, 101
bonus chapters, xv, 91, 174, 343, 350, 364, 392
book resources

Adobe Dreamweaver CS5 with PHP, 486
CSS Detective Guide, The, 486
Designing with Web Standards, Third Edition, 

486
Dreamweaver CS6 Bible, 486
Dynamic HTML, The Definitive Reference, 447
HTML5 and CSS3 Visual QuickStart Guide, 446
JavaScript: Visual QuickStart Guide, 343, 363, 

447, 486
Mastering Regular Expressions, 131
Styling Web Pages with CSS: Visual 

QuickProject Guide, 447, 486
Teach Yourself Regular Expressions, 131
UsableNet Accessibility Reference, 447

Border, CSS rule definitions, 191
borders

image, 142
table, 273

Box, CSS rule definitions, 191
box model, 228, 261
box-shadow property, 74
breaks

line, 104
page, 192

Brightness/Contrast dialog, 145–146
broken links, 469–470
Browse for File button, 62, 63, 166
Browse pop-up menu, 40, 41, 42
browser compatibility, checking, 472–474
BrowserLab (Adobe), 15, 71, 76–79, 230
Browser Navigation toolbar, 12, 388, 389, 390
browsers. See Web browsers

browser-specific properties, 210
browser window, opening new, 348–350
<br> tag, 104
bulleted lists, 108, 110. See also lists
Business Catalyst (Adobe), 15, 18, 20, 392, 394, 395

C
captions, table, 272
Cascading Style Sheets. See CSS
Castro, Elizabeth, 446
cells. See also tables

defined, 270
merging/splitting, 280
padding/spacing for, 273
selecting, 275
setting properties for, 286–287
wrapping of text in, 283

certificate authorities, 33
CGI, 298, 310
character formatting, 100
Characters pop-up menu, 114
cheat sheet, keyboard command, 492
check boxes, 305
Check Browser Compatibility command, 474
Check In/Check Out feature, 451, 456–460, 465
Check Page pop-up menu, 473–474
Check Plugin behavior, 351–352
Check Spelling dialog, 132
Choose Root Folder dialog, 29
Chrome (Google), 11, 23, 69, 74, 210, 438
classes

applying, 205–206, 209, 214
creating, 193, 213–214
pseudo-classes, 197, 205
removing, 207, 208
renaming styles for, 244–245
vs. id selectors, 194

Classic workspace, 20
Class pop-up menu, 244
Cloak command, 52
cloaking files/folders, 52, 394
CMSs, 377–390

back-end administrative interface for, 384
connecting to, 380–381
discovering related files in, 384–386
Dreamweaver support for, 27, 377, 378
how they work, 378, 384
installing, 378
meaning of acronym, 377
most popular, 377–379
purpose of, 377
recommended Web sites on, 482–483

code, 415–450
collapsing, 433–435
editing, 24, 415, 422–423, 428–430
expanding, 435
extracting embedded, 444–445
finding and replacing, 124–127
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formatting, 423
highlighting invalid, 418
hinting. See code hints
indenting, 422
reference material, 446–447
snippets. See snippets
validating, 448–450
viewing

in Code view, 416–419
in Live Code view, 426–427
in Split view, 424–425

Code Coloring preferences, 422
Code Format options, 423
code hints, 436–441

for CSS, 74, 438
for DOM elements, 440–441
for HTML, 436–437, 438
for jQuery, 439
for PHP, 437

Code Navigator feature, 217, 225–226, 238, 417
Code Reference tab, 446–447
Coder workspace, 20, 420–421
Coder Plus workspace, 20, 421
Code view

finding and replacing code in, 124–127
how pages appear in, 10, 416
opening HTML files in, 419
reasons for using, 415
using Coding toolbar in, 416–419

Coding toolbar, 226, 416–419, 422, 425
collapsing code, 433–435
color

background, 82, 83, 234–236, 287
hex vs. RGB/RGBA, 203
values, 203, 236

color property values, 203
columns. See also tables

deleting, 284
inserting, 278–279
resizing, 282
selecting, 274–275

Commands menu, 23, 493
Common tab, Insert panel, 17
companion Web site, this book’s, xv, 91, 174, 343, 

364, 392, 479
compound selectors, 195–197
containers, 90, 185, 189
content management systems, 377. See also CMSs
content vs. presentation, 184–185, 268, 328
context menus, xv, 20, 92
contextual selectors, 195, 197
Contribute (Adobe), 392, 395, 457, 463
Contribute 3 Essential Training, 485
Convert Inline CSS dialog, 247–248
Copy command, 45, 92
copying and pasting, 92–93, 149–151
Creative Cloud (Adobe), 18, 392
Creative Edge, 485
Creative Suite (Adobe), 392

cropping images, 144
CSS. See also styles; style sheets

benefits of using, 183, 184
box model, 228, 261
categories, 190–192
code hints for, 74, 438
content vs. presentation, 184–185, 268
creating compound styles in, 195–197
enable/disable rules feature, 262–263
and HTML tags, 185
Inspect mode, 11, 258–259, 386
layout basics, 228–230
layout blocks, 265, 266
recommended books on, 446, 447, 486
Rule Definition dialog. See CSS Rule Definition 

dialog
setting appearance with, 82
setting headings with, 84
setting link appearance with, 83–84
setting preferences for, 186
Styles panel. See CSS Styles panel
transitions, 24, 372–376
and Web fonts, 220–223

CSS3 properties, 203–204
CSS-based layouts

and CSS inspection, 258
and design-time style sheets, 264
purpose of, 315

CSS Detective Guide, The, 486
.css file extension, 202, 251
CSS Layout Backgrounds, 261
CSS Layout Outlines, 261
CSS Rule Definition dialog

categories in, 190–192
creating rules for links in, 173
modifying styles with, 215
purpose of, 184
saving external style sheet in, 251

CSS Styles panel
adding CSS3 properties in, 203–204
attaching style sheet in, 254–255
buttons/controls, 187
creating rule from inline style in, 247–248
deleting styles in, 246
formatting links in, 172–173
laying out pages in, 234–235
modifying styles in, 215
purpose of, 184
renaming styles in, 244
using browser-specific properties in, 210
using CSS Enable/Disable in, 262–263
working in All mode, 198–200
working in Current mode, 200–201

CSS tab, Property inspector, 14, 211
CSS Transitions panel, 372
Current mode, CSS Styles panel, 200–201
Custom Filter dialog, 387
Cut command, 45, 92
cutting and pasting, 92–93
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D
database-backed sites, 27, 32
Data tab, Insert panel, 17
data sets, 362
dates, 115
Default Editor dialog, 5
definition lists, 108–109
delimited text files, 291, 294
dependent files, 47, 333, 459–460
descendant selectors, 195, 197
description, site, 87, 88
Designer Compact workspace, 20
Designer workspace, 20
Designing with Web Standards, Third Edition, 486
Design Notes, 461–463
design-time style sheets, 264–266
Design view, 10, 55, 69, 91, 93
Desktop preset, 330, 331
DesktopServer, 383
Desktop viewport, 327
Developer Center, Dreamweaver, 72, 481
dimensions, setting page, 323–324
Direction pop-up menu, 50
Disable JavaScript command, 390
<div> tag, 189, 197
dock area, 15–16
doctype, 57, 85
document relative links, 168, 170
Document toolbar, 7, 9
Document Type Definition, 57, 85
document views, 10–11
document window, 7–9, 315
Dojo, 362
DOM elements, code hints for, 440–441
Down state, 347
dragging and dropping

styles, 256–257
text, 94

Dreamweaver
adding extensions to, 4, 487, 493–496
built-in JavaScript actions, 339–340
built-in reference books, 446
and CMSs, 377, 378. See also CMSs
collaboration features, 451
CSS categories, 190–192
customizing, 487–492
Developer Center, 72, 481
document window, 7–9
event handlers, 344
Exchange, 4, 343, 480, 493–494
file/folder terminology, 26–27
file management with, 43
frameworks, 361
and HTML5, 204
importing Excel data to, 291–293
interface, 2–18
knowledge required for, xiv
layout tools, 315–338

mailing list, 484
menu bar, 6
naming conventions, 396
new features in CS6, 22–23
online resources, 4, 479–485
platform considerations, xiv–xv
purpose of, xiii
recommended books on, 486
setting up workspace in, 19–21
site management tools, 391. See also Web site 

management
templates, 59
tutorials, 4, 482
Welcome screen, 2–5

dreamweaverbook.com. See companion Web 
site, this book’s

Dreamweaver CS6 Bible, 486
Drupal, 27, 377, 379, 483
DTD, 57, 85
Dual Screen layout, 20
Duplicate command, 45
.dwt file extension, 394
dynamically related files, 384–386
Dynamic HTML, The Definitive Reference, 447
dynamic pages, 449–450
dynamic sites, 27

E
Edit Browser List command, 71
Edit Font List dialog, 218
Edit Guides command, 319
Edit menu, 45, 93, 95, 455
Edit Tag command, 430
editable optional regions, 397
editable regions

adding, 395–396
purpose of, 393
removing, 397
types of, 397

editing
behaviors, 342
browser list, 71
code, 24, 415, 422–423
files/folders, 45
Flash video files, 162
font lists, 218–219
images, 143–146, 151–152
jump menus, 354
library items, 406–408
plug-in file’s properties, 164
preset window sizes, 324
property values, 215
site definitions, 38
snippets, 414
templates, 400–402

Editor setup, 5
effects, 362, 364, 365
<em> tag, 102, 211
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email links, 181
enclosure types, 299
encodings, 80, 81, 85
encryption, 32, 33
Enctype, 299
event handlers, 344
Excel (Microsoft), 91, 95–96, 291–293
Exchange. See Dreamweaver Exchange
Expand/Collapse button, 48, 452
Expanded Tables mode, 276–277
expanding code, 435
explicit encryption, 32, 33
exporting

site definitions, 476–478
tables, 294
widget presets, 371

Export Site dialog, 477
Export Table dialog, 294
Extend Dreamweaver menu, 367
Extension Manager (Adobe), 493, 495–496
extensions

Dreamweaver, 4, 487, 493–496
file, 45, 67

Extensions, CSS rule definitions, 192
external links, 471
external style sheets, 202

attaching to Web page, 254–255
creating, 249–251
moving internal styles to, 252–253

F
FAQ page, this book’s, xv
favicons, 156–157
Favorites tab, Insert panel, 18
fields. See also forms

adding, 300–301
hidden, 301
labeling, 302–303

fieldsets, 306
file extensions, 45, 67
File Field, Forms category, 296
file management, 43. See also Web site 

management
File menu, 68
files

adding/deleting, 39
annotating, 461–463
browsing, 40
checking in/out, 47, 459–460
cloaking, 52, 394
comparing local/remote, 48
creating, 44
finding orphaned, 471
locking/unlocking, 33
moving, 44
naming, 44, 45, 452
organizing, 43

putting/getting, 46–47
working with related, 216–217

Files panel
context menu in, 44
expanding, 48, 453–455
opening pages in, 68
purpose of, 39, 43
putting/getting files with, 47
selecting multiple files in, 455
vs. New Document dialog, 43

File Transfer Protocol, 33. See also FTP
File view pop-up menu, 41, 44
Filter extensions, 192
Filter Related Files menu, 387
Find All button, 119
Find and Replace dialog, 116–117, 122
Find and Replace feature, 116–131

advanced text searches with, 121–123
buttons/controls, 116–117
purpose of, 116
regular expression searches with, 128–131
simple text searches with, 118–120
source code searches with, 124
tag searches with, 125–127

Find in pop-up menu, 117
Find Next button, 119
Find Selection command, 119
Firefox (Mozilla)

and browser-specific CSS properties, 210
and CSS-based layouts, 268
and favicons, 156
and <label> tag, 302
and plug-in detection, 352
previewing pages in, 69

Fireworks (Adobe), 140, 143, 359–360
fixed positioning, 229
.fla file extension, 158
Flash (Adobe)

animation, 158–159
and BrowserLab, 76
video, 160–162
vs. image maps, 180

floating boxes, 230
fluid grid layouts, 22–23, 332–337
Fluid Layout workspace, 20
.flv file extension, 160
folders

browsing, 40
cloaking, 52, 394
comparing local/remote, 48
creating, 44
moving, 44
naming, 29, 44, 45, 452
planning structure of, 452
putting/getting, 46–47

@font-face property, 74, 220, 222
font families, 190
font groups, 218–219
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fonts
and CSS Type rule definitions, 190
displaying available, 218
for links, 83
sources of, 223
Web browser considerations, 219
for Web pages, 82, 220–224

font size, 82, 83, 84, 190
Font Squirrel, 223
<font> tag, 100, 211
footers, 235
Format menu, 98, 99, 107, 247, 264
formatting

code, 423
links, 172–173
tables, 290
text, 61

form fields. See fields
forms, 295–314

adding buttons to, 312–314
adding check boxes to, 305
adding fieldsets to, 306
adding pop-up menus to, 309–310
adding radio buttons to, 307–308
adding scrolling lists to, 311
adding text areas to, 304
adding text fields to, 300–301
adding to pages, 297–299
designating required fields in, 358
labeling fields in, 302–303
naming, 298
purpose of, 295, 297
red border around, 299
validating, 296, 356–358

Forms tab, Insert panel, 17, 295, 296
form validation widgets, 362, 364
Forta, Ben, 131
forums, 481
frames, 137, 142, 174, 341
framesets, 142, 344
frameworks, 361, 362–363
Freeze JavaScript command, 390
Friedl, Jeffrey, 131
FTP, 32, 33, 34–36
FTPS, 33

G
Get button, 51
GET method, 299
getting files/folders, 46–47
GIF files, 137
Go button, 355
Goodman, Danny, 447
Google

browser. See Chrome
and headings, 97
Web fonts, 220

Go To URL dialog, 341

graphic formats, 137
graphics. See also images

adding links to, 178
copying and pasting, 96
overuse of, 133

grids, 316–317. See also fluid grid layouts
Grid Settings dialog, 317
group selectors, 197
guides, 318, 319–320

H
Hand tool, 13
hard returns, 422
headings, 97–99

applying, 98
purpose of, 97
removing formatting from, 99

Headings (CSS), Page Properties dialog, 84, 212
<head> tag, 80, 87
hex values, 203, 236
hidden fields, 301
hidden files, 455
host directory, 36
hotspots, 179–180
hover style, 173, 213, 238
.htm/.html file extension, 45
HTML

aligning text with, 105–107
applying page properties with, 82–83
for bold/italic, 102
character formatting with, 100
code hints for, 436–437, 438
copying and pasting, 93
finding and replacing, 125–127
heading sizes, 97
indenting text with, 105–107
nesting elements in, 195
for non-breaking space, 113
recommended books on, 446, 447
reference, 123
tags. See HTML tags
text styles, 101–102
validating, 24, 448–450

HTML5, 57, 204, 446
HTML5 and CSS3 Visual QuickStart Guide, 446
HTML Reports category, 466
HTML tab, Property inspector, 14, 211
HTML tags. See also specific tags

applying with Property inspector, 211
creating style rules for, 188–189
and CSS, 185
finding and replacing, 125–127
purpose of, 90, 185
reference document, 123

Hyperlink dialog, 167
hyperlinks, 62–63. See also links
Hyslop, Bruce, 446
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I
.ico file extension, 157
icons, 156–157
id attribute, 141, 194, 205, 208, 302
IE. See Internet Explorer
image buttons, 313
image editing programs, 143. See also specific 

programs
image folders, 452
image formats, 137, 147
image maps, 141, 142, 179–180
Image Optimization dialog, 147, 151
image placeholders, 139–140
Image Preview dialog, 151
images, 133–155. See also graphics

adding alternate text to, 65, 134, 135, 136
adding borders to, 142
adding to pages, 64–65, 134–136
background, 82, 154–155
copying and pasting, 149–151
creating folders for, 30, 452
cropping, 144
deleting, 136
editing, 143–146, 151–152
inserting from Assets panel, 138
naming, 141
optimizing, 147
rollover, 345–347
setting properties for, 141–142
transparent, 203

image states, 347
Image Tag Accessibility Attributes dialog, 65, 135
implicit encryption, 32, 33
@import rule, 221–222
importing

site definitions, 476, 478
widget presets, 371
Word documents/data, 91, 293

Import Site dialog, 478
Import Tabular Data dialog, 292
Include Unicode Signature (BOM), 85
InContext Editing (Adobe), 18, 392
InContext Editing tab, Insert panel, 18, 394
Indent Code button, 422
indenting

with Coding toolbar, 422
with CSS Block rule definitions, 190
with HTML, 105–106

index page, 26, 31, 54
inheritance, 201
inherit positioning, 229
inline style rules, 247–248
inline styles, 202, 213–214, 247–248
Input Tag Accessibility Attributes dialog, 302–303
Insert Date dialog, 115
Insert Div Tag dialog, 197, 250, 251
Insert Fireworks HTML dialog, 359
Insert Jump Menu dialog, 353

Insert menu, 365, 483
Insert Other Character dialog, 114
Insert panel

location of, 7
purpose of, 17
tabs, 17–18, 61
vs. Insert bar, 18

Insert Rollover Image dialog, 346
Inspect mode, CSS, 11, 258–259, 386
interactivity, 341, 361, 390
internal styles, 189, 202, 252–253
Internet Explorer (Microsoft)

and browser-compatibility errors, 474
and browser-specific CSS properties, 210
and CSS-based layouts, 268
and CSS Filter extensions, 192
and CSS rendering, 69, 78
and favicons, 157
and plug-in detection, 351
and PNG graphics, 137

invisible characters, 104
<i> tag, 102
italicized text, 101

J
Jacobs, Denise R., 486
JavaScript

behaviors, 339–343
disabling, 390
event handlers, 344
extracting embedded, 444–445
frameworks, 361, 362, 366
freezing, 390
and mobile layouts, 338
recommended book on, 343, 363, 447, 486
and Spry, 361, 362

JavaScript Essential Training, 485
JavaScript Extractor, 444–445
JavaScript: Visual QuickStart Guide, 343, 363, 

447, 486
Joomla, 27, 377, 379, 483
JPEG files, 137
jQuery

code hints for, 439
strengths of, 363

jQuery-based pages, 58, 338
jQuery Mobile tab, Insert panel, 17
jQuery Mobile JavaScript framework, 338
JSP, 447
jump menus, 296, 340, 353–355
justifying text, 107

K
keyboard shortcuts, xiv, 488–492
keywords, 87, 88
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L
<label> tag, 302, 303
LAMP, 382–383
layout blocks, 265, 266
Layout tab, Insert panel, 17
layouts

for coders, 420–421
CSS-based. See CSS-based layouts
and CSS box model, 228–230
jQuery-based, 58, 338
for mobile devices, 22, 58, 325
starter, 204
using Dreamweaver’s included, 231–232
using tables for, 267, 268–269

layout tables, 268
layout tools, 315–338

fluid grid layouts, 332–337
grids, 316–317
jQuery, 338
media queries, 328–331
multiscreen preview, 325–327
rulers/guides, 318–320
setting page dimensions, 323–324
zooming in on page, 321–322

.lbi file extension, 404

.LCK file extension, 457
Library folder, 404, 409
library items, 403–410

creating, 403–404
defined, 392
deleting, 405
detaching, 409, 410
editing, 406–408
file extension for, 404
inserting, 405
naming/renaming, 404, 408
and Property inspector, 409–410
re-creating missing/deleted, 410
updating, 407
vs. snippets, 411
vs. templates, 403

line breaks, 104
line numbers, 422
link properties, 83
Link Relative To, 170–171
<link> tag, 226
links, 165–181

adding anchors to, 175–177
adding to graphics, 178
checking for broken, 469–470
creating, 62–63, 166–167
to email addresses, 181
formatting, 172–173
purpose of, 165
removing, 167
setting color for, 83
targeting, 174, 180
types of, 165, 168–169

Links (CSS), Page Properties dialog, 83–84, 212
Linux systems, 219, 382
liquid layout, 233–234
List, CSS rule definitions, 191
List Properties dialog, 110, 112
lists, 108–112

creating, 109
nesting, 111–112
scrolling, 309, 311
setting properties for, 110
types of, 108

List Values dialog, 310
Live Code view, 11, 388, 426–427
Live view

displaying screen sizes in, 73
enhancements, 23
navigation, 388–389
previewing pages in, 69
purpose of, 11
using CSS inspection in, 258–259
and WebKit, 11, 74

Live View button, 347
Live View Options menu, 389, 390, 426
Load Query button, 117
Local Info category, 30
local root folder, 26
local site

alternate name for, 26
building pages for, 53
creating, 28–31
displaying contents of, 42
moving items to/from, 46–47
naming, 29
saving pages for, 66–67
switching between remote site and, 41
synchronizing remote site and, 49–51, 402
viewing/changing, 39

locked regions, 393, 397
Lock Guides command, 320
Lowery, Joseph, 486
Lynda.com, 485

M
Macintosh

and Application frame, 8
Dreamweaver menu bar on, 6
encodings, 81
font considerations, 219
getting rid of tabs on, 8–9
keyboard shortcuts, xiv
mouse considerations, xv
previewing pages on, 70
and Submit/Reset buttons, 314
testing server package for, 382
using Dreamweaver on, xiv–xv

magnification tools, 321, 322
mailing list, Dreamweaver, 484
Make Template command, 394
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MAMP, 382–383
Manage Sites dialog, 34, 38, 457, 475
Manage Workspaces dialog, 21
margins, 82, 83, 191
Mastering Regular Expressions, 131
Media Encoder (Adobe), 160, 162
media files, 133, 163–164
Media Queries dialog, 328–331
media query style sheets, 315, 329–331
menu bar, 6
Menu List, 110
menus

context, xv, 20, 92
jump, 296, 340, 353–355
pop-up, 359–360

Merge Cells command, 280
<meta> tag, 87–88
Microsoft

Excel. See Excel
Internet Explorer. See Internet Explorer
Web-safe fonts, 220
Windows. See Windows systems
Word. See Word

Mobile Applications workspace, 20
mobile devices, 22, 73, 220, 325, 328
Mobile layout, 336
Mobile Starters, 58, 338
mouseovers, 345
Move Guide dialog, 320
Move To External Style Sheet dialog, 252
MP3 files, 163
Multiclass Selection dialog, 209
Multiscreen button, 73
Multiscreen Preview feature, 23, 325–327
MySQL, 382

N
Named Anchor dialog, 175
naming conventions, 396
naming/renaming

anchors, 175
buttons, 312
classes, 193
editable regions, 395, 396
favicons, 157
files, 44, 45, 452
folders, 29, 44, 45, 452
forms, 298
host directory, 36
images, 141
library items, 404, 408
local site, 29
radio groups, 307
remote server, 35
snippets, 412, 414
styles, 244–245
Web pages, 66–67
workspaces, 21

navigation
laying out, 237–238
Live view, 388–389
modifying, 239–242

&nbsp; (non-breaking space), 113
nesting

HTML elements, 195
lists, 111–112
tables, 270, 272

Netscape browsers, 352
New CSS Rule dialog

creating classes in, 193, 213–214
creating compound styles in, 195–197
creating inline styles in, 213–214
creating style rule for tags in, 188–189
formatting links in, 172–173

New Document dialog
changing document defaults in, 57
creating new external style in, 249
creating new page from, 3, 56–57
and HTML5, 204
previewing CSS style sheets in, 58
using included CSS layouts in, 231–232
vs. Files panel, 43
vs. Welcome screen, 54

New Editable Region dialog, 395
new features, 4, 22–23
New File command, 44
New Folder command, 44
New from Template command, 398
New Site command, 28
non-breaking spaces, 113
numbered lists, 108, 110. See also lists

O
OK/Submit buttons, 314
Onion Skin view, 76, 78, 79
online magazines, 379
online newspapers, 379
online resources, 479–485
opacity values, 203
Open Browser Window dialog, 349
Open dialog, 68
Opera, 69, 210, 268
operators, 128, 130
Optimize command, 147
optional regions, 397
ordered lists, 108. See also lists
O’Reilly HTML Reference, 123
orphaned files, 471
Outdent Code button, 422
Over state, 347
OverWhileDown state, 347
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P
<p> tag, 90, 185. See also paragraph tags
padding, 191, 238, 242, 273
padlock icon, 456
page breaks, 192
page dimensions, 323–324
page headers, 235
page-layout tools. See layout tools
page properties, 80–86
Page Properties dialog, 80–85

Appearance (CSS), 80, 81–82, 212
Appearance (HTML), 82–83, 212
Headings (CSS), 84, 212
Links (CSS), 83–84, 212
names in, 213
Title/Encoding, 85, 213
Tracing Image, 86, 213

pages. See Web pages
page titles, 9, 60, 66, 85, 121, 396
panels, 15–18
paragraph tags, 90, 91, 104, 185
parent-child relationships, 195
Paste command, 45, 93
Paste Special command, 95–96, 293
Phone preset, 330, 331
Phone viewport, 327
Photoshop (Adobe), 143, 148–153
PHP, 54, 378, 382, 437, 447
placeholders

image, 139–140
media file, 163, 164

plug-in media, 163
plug-ins, checking for, 351–352
PNG files, 137, 147, 148, 150, 360, 461
Point to File icon, 62, 166, 177, 443
pop-up menus, 309–310, 359–360
Positioning, CSS rule definitions, 192
POST method, 299
Powers, David, 486
preferences

accessibility, 65, 135, 303
bold/italic, 102
browser list, 71
code coloring, 422
code formatting, 423
code hinting, 437, 439
CSS styles, 186
default document type, 57
field labels, 303
file saving, 460
highlight color, 404
line breaks, 104
links, 169
non-breaking spaces, 113
OK/Submit buttons, 314
opening files, 419
related files, 217
tabs, 8–9

Welcome screen, 5, 54
window size, 13, 75, 135, 324

preformatted text, 103
presentation

vs. content, 184–185, 268, 328
vs. structure, 89

presets
widget, 371
window size, 323–324

<pre> tag, 103
Preview/Debug in Browser button, 70
Preview in Browser submenu, 70, 71
previewing

in browser, 69–71
snippets, 411, 414
using preset screen sizes, 72–75

properties
adding, 200
disabling, 262–263
displaying, 199
modifying, 200, 204
working with browser-specific, 210
working with CSS3, 203–204

Properties pane, 199–200
Property inspector

adding alternate text with, 136
applying CSS styles with, 211
applying HTML tags with, 211
applying multiple classes with, 209
creating classes with, 213–214
creating inline styles with, 213–214
creating styles with, 211–214
CSS tab, 14
HTML tab, 14
image editing tools, 143
setting image properties with, 141–142
setting text field properties with, 300
styling text with, 211
Validation panel, 448, 449
working on library items with, 409–410

Prototype, 362
PSD files, 148, 151
pseudo-classes, 197, 205
Put button, 51
putting files/folders, 46–47

Q
Quicken 2009 for Windows Essential Training, 485
Quick Tag Editor, 428–429, 442
QuickTime, 160, 163

R
radio buttons, 305, 307–308
Radio Group dialog, 307–308
RDS, 32
RealVideo, 160
Redo command, 93
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Reference tab. See Code Reference tab
regular expressions, 128–131
related files

discovering, 384–386
examples of, 216
filtering, 387
viewing, 217

Related Files toolbar, 12, 216–217, 222, 384, 386
relative positioning, 229
“Relative to” pop-up menu, 170–171
remote servers. See also remote site

checking in files to, 460
defining, 32–37
naming, 35

remote site
defining, 32–37
displaying contents of, 42
moving items to/from, 46–47
switching between local site and, 41
synchronizing local site and, 49–51, 402
viewing/changing, 39
vs. local site, 27

Remove Template Markup command, 397
Rename Class dialog, 244–245
Rename command, 45, 244
Rename Style dialog, 244
rendering software, 69, 74
repeating regions, 397
repeating tables, 397
replacing text. See Find and Replace feature
Reports dialog, 467
Repository view, 41
resampling images, 145
Reset button, 312, 314
resizing images, 145
Resolution Management feature, 72, 74
reusable code snippets, 391. See also snippets
Revert command, 465
RGB/RGBA color, 203
rollover images, 345–347
rollover links, 84, 213, 238
root folder, 29, 36, 68
round-trip editing feature, 359
rows. See also tables

deleting, 284
inserting, 278, 279
resizing, 282
selecting, 274

Rule Definition pop-up menu, 173, 188, 251
rulers, 318, 320
rules

creating from inline style, 247–248
enabling/disabling, 262–263
moving, 252–253, 257
for pseudo-classes, 197
viewing properties for, 226

Rules pane, 247–248

S
Safari (Apple)

and browser-specific CSS properties, 210
and CSS3 code hinting, 438
and CSS-based layouts, 268
and CSS rendering, 78
and Flash, 180
and image maps, 180
and Live view, 11, 23, 74
and mobile devices, 74, 180
previewing pages in, 69
and WebKit, 74

sample pages, 53, 58–59
Save As dialog, 66–67
Save As Template dialog, 394
Save Query button, 117
screen readers, 65, 134
screen sizes

customizing, 75
displaying, 73–74
previewing using preset, 72–75

<script> tag, 226
Script Warning dialog, 385
scrolling lists, 309, 311
search engines, 87, 88, 97
searching

HTML tags, 125–127
with regular expressions, 128–131
source code, 124
text, 118–123

Search pop-up menu, 117, 118
Secure FTP, 32, 33. See also SFTP
Secure Shell protocol, 33
Select (List/Menu) button, 309
Select File dialog, 167, 170–171
Select Image Source dialog, 64, 134
Selector Name, 188, 196
selectors, 188, 195–197
Selector Type, 172–173, 188, 196
Select tool, 13
Servers category, 34
Set Text behaviors, 340
SFTP, 32, 33, 34–36
sharpening images, 146
Shockwave animations, 158
shortcut keys, 107, 488–492
Show Grid command, 316
Show Guides command, 318
Show More menu, 386
Silverlight, 160, 163
site definitions, 38, 476–478
site descriptions, 87, 88
site design, 31
site files, 391
site management tools, 26, 391, 451. See also 

Web site management
Site Map, 455
Site menu, 6
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Site pane, 28
site reports, 466–468
Site Root button, 68
site root folder, 29, 36, 68, 391
site root relative links, 168, 169, 170
sites. See Web sites
Site Setup dialog

Advanced Settings category, 30, 52, 224
Cloaking category, 52
Local Info category, 30
Local Site Folder field, 29
purpose of, 28, 380
Servers category, 34
Site category, 28
Site Name field, 29
Web Fonts category, 224

Smart Objects, 148, 152–153
smart phones, 22, 74, 180, 325. See also mobile 

devices
Snap to Grid command, 317
Snap to Guides command, 320
snippets, 411–414

defined, 392
deleting, 414
editing, 414
inserting, 414
naming, 412, 414
organizing, 414
previewing, 411, 414
saving, 412–413
updating, 411
vs. library items, 411

Snippets panel, 411–414
Sort Table dialog, 289
source code, 124
Source view, 93
spacer GIFs, 142
spaces, 113
spacing, cell, 273
<span> tag, 189, 208
special characters, 113–114, 129
spelling checker, 132
Split Cell command, 280
Split Code view, 424
Split view, 10–11, 74, 424–425
Spry

commands, 365
components of, 362
data sets, 362
opening browser windows with, 350
purpose of, 361, 362
widgets, 364

Spry tab, Insert panel, 17, 364
Spry Validation, Forms category, 296
SQL, 447
SSL/TLS, 32, 33
staging servers, 27, 382
Standard bar, 12
starter layouts, 204

states, image, 347
static positioning, 229
static sites, 27
Status bar, 13
.ste file extension, 476
strikethrough text style, 102
<strong> tag, 102, 211
structural elements, 89, 95, 97
Style Rendering toolbar, 12, 266
style rules

cascading of, 202
conflicting, 202
displaying all, 198
enabling/disabling, 262–263
moving, 257
for tags, 188–189
troubleshooting, 201
viewing properties for, 226

styles, 243–259. See also CSS; style sheets
applying with Property inspector, 211
creating compound, 195–197
creating rules from inline, 247–248
creating with Property inspector, 211–214
deleting, 246
displaying properties for, 199
dragging and dropping, 256–257
modifying, 215, 259
moving, 252–253, 256–257
previewing in browsers, 201
renaming, 244–245
showing all/selected, 198–201
types of, 202
using for layout, 227–242

style sheets. See also CSS
attaching, 254–255
creating external, 249–251
deleting styles from, 246
hiding, 266
media query, 315, 329–331
setting media type for, 255
using design-time, 264–266

Styling Web Pages with CSS: Visual QuickProject 
Guide, 447, 486

Submit button, 312–313, 314
Subversion, 451, 464–465
SVN, 464–465
Swap Image Restore behavior, 347
.swf file extension, 158
symbols, 113–114
synchronization feature, 46, 49–51, 402
syntax coloring, 422
System CGI, 298

T
Tab Index field, 303
table captions, 272
Table dialog, 270
Table Layout Mode, 269
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tables, 267–294
adding rows/columns to, 278–279
adding to Web pages, 270–272
anatomy of, 273
applying CSS styles to, 290
clearing values for, 283
creating, 270–272
deleting elements in, 284
exporting to delimited files, 294
formatting, 290
as layout device, 267, 268–269
merging cells in, 280
nesting, 270, 272
repeating, 397
resizing, 281–283
selecting elements in, 274–277
setting alignment for, 285
setting cell properties for, 286–287
sorting, 288–289
splitting cells in, 280
vs. preformatted text, 103
ways of using, 267
and Web browsers, 283

Tablet layout, 336
Tablet preset, 330, 331
Tablet viewport, 327
tabs, opening documents in, 8–9
tabular data, 103, 267, 291–294. See also tables
Tag Chooser, 431–432
Tag Editor, 430, 442
Tag inspector, 339, 341, 365, 442–443
tags

creating style rules for, 188–189
and CSS, 185
editing, 428–430
finding and replacing, 125–127
inserting, 431–432
modifying, 442–443
purpose of, 185

tag searches, 125–127
tag selector, 13
Target Browsers dialog, 473
Targeted Rule pop-up menu, 206, 213
targeting links, 174, 180
Target Rule field, 373, 376
Teach Yourself Regular Expressions, 131
templates, 393–402

adding editable regions to, 395–396
building pages based on, 398–399
creating, 393–394
defined, 392
file extension for, 394
finding free/inexpensive, 59
modifying, 400–402
purpose of, 393, 400
removing editable regions from, 397
saving documents as, 393
vs. library items, 403

Templates folder, 394, 399

terminology, 26–27
testing servers, 27, 41, 380–383
text, 89–132

adding, 61, 90–91
aligning, 105–107
applying headings to, 97–99
block quoting, 106
choosing fonts for, 219
cutting/copying, 92
dragging and dropping, 94
duplicating, 94
encoding, 85
finding and replacing, 116–123
formatting, 61
indenting, 105–106, 190
inserting line breaks in, 104
inserting special characters in, 113–114
moving, 94
pasting, 93, 95–96
preformatting, 103
selecting, 90
setting default color for, 82, 83
spell-checking, 132
structure vs. presentation, 89

text areas, 304
Text tab, Insert panel, 18
text fields, 300–301
text-indent property, 105
text links, 166–167. See also links
text styles, 101–102
Thawte, 33
Timing Function pop-up menu, 374, 376
Title/Encoding category, 85–86, 213
titles, page, 9, 60, 66, 85, 121, 396
toolbars, 12
tracing images, 86, 213
trackpads, xv
transitions, CSS, 24, 192, 372–376
transparency slider, 86
tutorials, 4, 482
Type, CSS rule definitions, 190
Typekit, 223

U
UI widgets, 362, 364
Uncloak command, 52
underline style, 84, 101, 102
Undo command, 93
Unicode encoding, 80, 85
Unicode Normalization Form, 85
Uniform Resource Locators, 62. See also URLs
unordered lists, 108. See also lists
Update Files dialog, 44, 400
Update Pages dialog, 401
Up state, 347
URLs, 62, 63, 67, 87
usability, site, 315
UsableNet Accessibility Reference, 447
UTF-8 encoding, 80, 85
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V
Validate Form behavior, 356–358
validating

dynamic pages, 449–450
forms, 296, 356–358
static pages, 448–449

VCS. See version control system
Verisign, 33
version control system, 451, 464–465
video formats, 160
video training programs, 485
View menu, 77, 217, 318, 419, 425
view mode buttons, 9
Viewport Sizes window, 327
views

refreshing, 42
switching between local/remote, 41

visited links, 83, 172
visual aids, 176, 260–261
visually impaired site visitors, 65, 134, 142.  

See also accessibility

W
W3C Validator feature, 24, 448–450, 472
WebAssist, 482
Web browsers. See also specific browsers

and AP elements, 230
checking compatibility with, 472–474
and CSS-based layouts, 268
editing list of, 71
and event handlers, 344
and floating boxes, 230
font considerations, 219
and positioning, 230
previewing pages in, 69–71
previewing styles in, 201
and tables, 283

Web content management systems, 377.  
See also CMSs

WebDAV, 32, 33, 36–37
Web design, 31, 486
Web fonts, 220–224
Web Fonts Manager dialog, 224
WebKit, 11, 23, 74, 268
Web links, 63. See also links
weblogs, 481
Web pages. See also Web sites

adding animations to, 158–159
adding automatic dates to, 115
adding background image to, 154–155
adding favicons to, 156–157
adding forms to, 297–299
adding headings to, 97–99
adding images to, 64–65, 134–136
adding links to, 62–63, 166–167
adding special characters to, 113–114
adding tables to, 270–272. See also tables
adding text to, 61, 89–96

adding titles to, 60
adding video to, 160–162
aligning elements on, 316–317
attaching style sheet to, 254–255
choosing fonts for, 218–219
creating, 54–59, 398–399
defining meta tags for, 87–88
extracting embedded JavaScript from, 

444–445
file extensions for, 45
laying out, 233–236. See also layout tools
naming, 66–67
navigation for, 237–242
opening, 68
previewing in browser, 69–71
sample pages for, 58–59
saving, 66–67
setting properties for, 80–86
showing all styles for, 198–200
spell-checking, 132
template-based, 398–402
updating, 49
validating, 448–450
viewing in BrowserLab, 76–79
vs. Web sites, 25
zooming in on, 321–322

Web-safe fonts, 220
Web servers

for CMSs, 382
ways of connecting to, 32

Web site management, 451–478
checking browser compatibility, 472–474
checking for broken links, 469–471
deleting site from Dreamweaver, 475
exporting/importing site definitions, 476–478
generating site reports, 466–468
planning for site expansion, 452
setting up Check In/Check Out, 456–458
setting up version control, 464–465
using Design Notes, 461–463

Web sites. See also Web pages
adding interactivity to, 341, 361
checking/fixing broken links in, 469–471
choosing structure/design for, 31, 452
creating, 28–31
database-backed, 27
defining remote server for, 32–37
deleting from Dreamweaver, 475
Dreamweaver terminology for, 26–27
key to usability of, 315
local vs. remote, 26–27
managing files for. See Web site management
naming, 29
navigation for, 237–242
preventing “breaking” of, 392
prototyping, 59
restricting changes to, 392, 393
static vs. dynamic, 27
styling page content for, 183. See also CSS
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switching between, 40
synchronizing local and remote, 49–51, 402
this book’s companion, xv, 479
vs. Web pages, 25

Web standards, 24
Welcome screen

buttons/controls, 2–5
creating new page from, 54–55
Dreamweaver Site link, 28
opening pages with, 54–55, 68
turning on/off, 5, 54

whitespace, 105
Widget Browser (Adobe), 366–371
widgets, 366–371

customizing/configuring, 366, 369
downloading, 367–369
exporting/importing presets for, 371
inserting, 370–371
previewing, 368
purpose of, 361
Spry, 364
types of, 362

wildcard symbols, 128
Window menu, 15, 16
windows, opening new browser, 348–350
Window Size menu, 72, 73, 74, 75, 323–324
Windows Media, 160, 163
Windows systems

browsers for, 69. See also specific browsers
Document toolbar on, 9
Dreamweaver menu bar on, 6
encodings, 81
font considerations, 219
getting rid of tabs on, 8

keyboard shortcuts, xiv
and Submit/Reset buttons, 314
testing server package for, 382

Wise-Women online community, 484
Word (Microsoft)

importing documents from, 91
importing tabular data from, 293
pasting text from, 95–96

WordPress, 27, 377, 378, 383, 385, 483
Word Wrap, 422
workflow reports, 466
workspaces

defined, 19
deleting, 21
preset, 20
renaming, 21
saving custom, 21
switching between, 20, 420

WYSIWYG tools, 185, 277, 415, 424, 428

X
XAMPP, 382–383
XHTML, 472
XML, 362, 447, 461, 476
XSLT, 447

Y
YUI, 362

Z
Zeldman, Jeffrey, 486
Zoom tool, 13, 321–322
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B1
Adding Frames

Normally, a Web page fills an entire 
browser window. However, a browser win-
dow can be split into two or more smaller 
individual panes called frames. Each frame 
contains an individual Web page.

Frames are used to define areas of a page, 
such as a navigation bar or a masthead, 
that remain constant as the user moves 
through the site. They are also used to 
define content areas where the content 
changes each time a navigation link is 
clicked. Frames allow you to have a site 
where the navigation part of the window 
loads only a single time (reducing your 
bandwidth needs) but the content part of 
the window changes whenever the user 
requests a new page.

In this chapter you’ll learn how to cre-
ate framed layouts, insert individual Web 
pages into the frames, and manage the 
navigation for a framed site.

In This Chapter
How Frames Work B1-2

Creating a Frameset B1-5

Using the Frames Panel B1-8

Inserting Pages into Frames B1-14

Saving Framesets and Frames B1-18

Targeting Frames with Links B1-21

Adding noframes Content B1-23
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How Frames Work
When you look at a framed site, you 
are actually seeing multiple pages A. 
You’ve seen the site in A before, but not 
in frames. At first glance you might not 
notice that the site is framed. But once you 
start scrolling you’ll realize the difference. 
Notice the scrollbar in A. See how it starts 
about halfway down the side of the page? 
That’s because there are actually three 
framed pages shown, and only the frame 
on the lower right has a scrollbar.

The arrangement of the individual frames is 
determined by the frameset document. The 
frameset document contains one or more 
frameset tags, which set up the number of 
frames, how they will be arranged, and which 
individual Web pages will be displayed when 
the page is opened for the first time.

Top frame

Side frame Scrollbar

Main frame

A The HomeCook.info site in a framed layout looks much like the other layout.

Exiting the Frame(set)
As detailed in the “Should You Use 
Frames?” sidebar, frames are on their 
way out, and Dreamweaver CS6 
removes several features found in prior 
versions that supported frames. You’ll 
no longer find Frameset options in the 
Page from Sample tab of the New Docu-
ment dialog. The Frames button in the 
Layout category of the Insert panel has 
been removed. Now, you need to create 
custom framesets instead of beginning 
with predefined framed layouts. We’ve 
updated this chapter to cover the frame 
features still found in Dreamweaver 
CS6, but we won’t be surprised to see 
all frame assistance removed in the next 
major revision.
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But wait, there’s an accessibility issue. 
Not all browsers work with framesets. 
For example, really old browsers didn’t 
understand frames, and even today, brows-
ers built into mobile devices may have 
problems with framesets. Therefore, each 
frameset document contains a noframes
section. Use the noframes section to 
provide basic information in case the user’s 
browser cannot display frames. Links to 
your content pages are an example of 
good information to include in a noframes
section. That way every user can find your 
valuable content.

Dreamweaver lets you set up the frameset 
and then work on the individual Web pages 
for the frames separately. Or you can work 
on the individual Web pages while they 
are displayed in the frameset. Both are 
perfectly valid choices; for instance, an 
individual might manage a site with only 
a few pages inside the frameset, whereas 
a larger site might have numerous people 
handling different content pages.

No matter how many frames a browser 
window displays, there is usually only 
one frameset document for a site. A Web 
page with three frames actually needs four 
separate documents to display correctly: 
the frameset document and the three indi-
vidual documents that fill the three frames.

A frameset divides a window into either 
columns or rows, but not both at once. 
Luckily, framesets can be nested, or put 
one inside another. A frameset of columns 
can be nested in a row of another frame-
set. Or, a frameset of rows can be nested 
in a column of another frameset. In A, 
the frameset has two rows. The top row 
holds the site identification. The bottom 
row splits into two columns with a nested 
frameset. One column holds the naviga-
tion, and the other holds the content. The 
content frame is the one with the scrollbar.

The frameset document is invisible to the 
user. It sets up the arrangement of the vis-
ible pages shown in the frames. The user 
sees the results of the frameset document, 
but not the actual frameset document.
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Should You Use Frames?
Using frames is often a poor choice for layout. Although frames do have some advantages, they’re 
outweighed by the disadvantages, to the point that few professional or commercial sites now use 
frames. For every advantage of frames, there are usually ways to achieve the same effect with-
out frames. Because frames are no longer considered to be included in a Web designer’s best 
practices, we removed this chapter from the paper edition of this book beginning with the CS6 edi-
tion. But because some people may still need to work with framed sites, we’ve moved the chapter 
to the ebook edition and made it separately downloadable for purchasers of the paper edition.

Dreamweaver has many tools for creating framed pages and sites, so it’s important to know that 
those tools are there if you need them. The most common reason for using frames is navigation. 
A navigation bar displayed in a frame is always visible no matter how much you scroll in other 
frames. Some disadvantages of using frames are:

. Not all browsers provide good frame support. Mobile phone browsers and browsers for users 
with disabilities may have problems with frames. A noframes section helps, but it’s a poor  
substitute for the good browsing experience you hope users have at your site.

. It’s not possible to bookmark framed pages. The URL of a framed page doesn’t appear in the 
browser’s address bar.

. It’s difficult to get graphic elements to line up precisely between frames.

. Testing the navigation is time consuming.

. Search engines may not be able to properly navigate and index a framed site.

. Visitors who come to your site from search engines will load an unframed page, because 
search engines will send visitors to your content pages and skip your navigation. Working 
around that requires some way to get to the “real” version—the content page they want, inside 
the proper frameset.

Some advantages of using frames are:

. Static frames such as navigation bars or graphical banners don’t have to be reloaded each time 
the content changes, making your site load faster. But with broadband increasingly available, 
this argument is much less important than in the past.

. Each frame has its own scrollbar and can be scrolled individually.

Sometimes frames are the best layout choice in spite of their disadvantages. When that is the case, 
be extra careful to:

. Provide helpful noframes content, such as a list (with links) of your content pages. See “Adding 
noframes Content,” later in this chapter.

. Use the title attribute to give each frame a descriptive name. This helps with frame identifica-
tion and navigation. See “Creating a Frameset” for details.

. Provide a friendly way for visitors arriving from a search engine to get into your framed site. 
This could be a link to the frameset, or you could use JavaScript to force the user’s browser to 
load the frameset. There’s no built-in behavior in Dreamweaver to do this, but we cover it in our 
book JavaScript: Visual QuickStart Guide (Peachpit, 2012).
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Creating a Frameset
Dreamweaver allows you to create frame-
sets to match the needs of your site. For 
example, the HomeCook.info site needs 
a top frame for the masthead, a left frame 
for the navigation, and a right frame for the 
changing content.

To make a frameset, you build a custom 
frameset from scratch by manually draw-
ing frames into a page or choosing some 
basic frameset layouts from a menu. 
Dreamweaver gives you the tools to create 
and resize frames.

To create a frameset:
1. Choose File > New.

The New Document dialog appears.

2. Choose HTML in the Page Type column, 
and <none> in the Layout column.

3. From the DocType popup menu, 
choose HTML 4.01 Transitional (frames 
are deprecated in HTML5, so that’s not 
a good doctype to use).

4. Click Create.

A blank page appears.

5. Choose Insert > HTML > Frames, then 
choose one of the frameset options A.

Dreamweaver opens the new, framed 
window, and the Frame Tag Accessibil-
ity Attributes dialog appears if you have 
your Preferences set for frames acces-
sibility B. (You do have Preferences set 
for frames accessibility, right?)

continues on next page

A Choose the kind of frameset you want from the 
Insert menu.

B The Frame pop-up menu lets you select each 
frame to give it a title attribute.
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In the dialog, select each frame from 
the Frame pop-up menu and give a 
descriptive title attribute to each 
frame by typing it into the Title field. 
When you are done assigning frame 
titles, click OK.

In B, we replaced the default sug-
gestion for mainFrame with the more 
descriptive title “content.” A good title
for the topFrame is “identification.” A 
good title for the leftFrame is “naviga-
tion.” Remember, title attributes help 
users whose browsers can’t display 
frames understand and navigate your 
site, so be informative.

or

Choose View > Visual Aids > Frame 
Borders C.

This turns on a dotted border around 
the frame edges. Click and drag the 
dotted border to insert frames. The cur-
sor changes to a double-headed arrow 
cursor to drag D.

If you drag from the top or bottom, 
the document splits horizontally. If you 
drag from the left or right, the docu-
ment splits vertically. If you drag from 
a corner, the document splits into 
four frames.

The Frame Tag Accessibility Attributes 
dialog appears. Enter the frame titles, 
as described above.

C One of the visual aids you can view is Frame 
Borders.

D The dotted line 
around the outside 
of the document 
window indicates the 
frame borders. Drag 
to create frames, as 
shown here.

You can also add frames to a frameset 
by choosing Modify > Frameset > Split Frame 
Left, Split Frame Right, Split Frame Up, or Split 
Frame Down.
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To delete a frame from a frameset:
1. Choose View > Visual Aids > Frame 

Borders C.

2. Click and drag the dotted border to the 
edge of the document window to delete 
a frame.

or

Click the frame border and drag it until 
it meets another frame border.

Frame Name vs. Frame Title
Frame navigation won’t work unless you can point to a frame by name. (See “Targeting Frames 
with Links,” a little later in this chapter.) Every frame needs a name. Dreamweaver assigns a default 
name based on location or assumed purpose—for example, topFrame, leftFrame, mainFrame.

The Frame name displays at the left in the Property inspector when a frame is selected. If you 
don’t like Dreamweaver’s choice of name, you can type a different one in the Frame name field. If 
you use a name of your own choosing, there are a few rules:

. No spaces are allowed in a frame name.

. The name must begin with a letter or number.

. It’s OK to mix uppercase and lowercase letters.

Frame names work behind the scenes to make the frameset function. They don’t make any differ-
ence to your users.

Frame titles, on the other hand, do make a difference to at least some of your users. As we 
mentioned previously, the title attribute provides important identification and navigation help 
for users with certain types of browsers. Dreamweaver suggests title attribute text for you as 
a prompt in the Frame Tag Accessibility Attributes dialog. This is your one chance to enter title
information if you work in Design view.

The rules are different for title attribute text. More than one word, spaces, and even sentences 
can go into a title attribute. For example, the title attribute for the topFrame might be some-
thing like “Site identification and a link back to the home page.”

Look at the markup for topFrame to see where name and title are used:

<frame src="masthead.html" name="topFrame" scrolling="No" noresize="noresize"
id="topFrame" title="site identification and a link back to the home page" />

Everything in that code snippet can be modified from the Property inspector except title. That’s 
why you need to grab your chance to write a great blurb for the title text when the Frame Tag 
Accessibility Attributes dialog prompts you for a title. But don’t worry too much if you miss that 
chance; you can still add and make changes to the title text by switching to Code view and edit-
ing the code as needed.
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Using the 
Frames Panel
You’ve probably noticed by now that 
Dreamweaver has a panel for everything. 
Frames are no exception. If the Frames 
panel isn’t visible, choose Window > 
Frames to bring it into view.

It’s a good idea to keep the Frames panel 
in view when working with a framed site. 
It gives you a miniature view of the frames 
within a frameset. It also gives you an easy 
way to select either an individual frame or 
an entire frameset.

To select frames and framesets 
with the Frames panel:
1. In the Frames panel, click the outermost 

border around the frameset A.

The selected frameset displays a thick 
black border.

2. Do one of the following:

>	 To select a nested frameset, click the 
white border around the frameset B.

The selected frameset displays a 
thick black border.

or

>	 To select an individual frame, simply 
click inside the frame C.

The selected frame displays a black 
border, thinner than the one used for 
the frameset.

A A thick border indicates the 
selected frameset.

B The nested frameset in the 
bottom row is outlined with a thick 
border, indicating that it is selected.

C The black border indicates the 
selected frame. Note that the border 
for a frame is not quite as thick as 
the border for a frameset.
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When you select a frameset in the 
Frames panel, the corresponding frameset is 
selected in the document window. A dotted 
border highlights the frameset E. The tag 
selector displays the appropriate element—in 
this example, it’s <frameset><frameset>.

D In the document window, the selected identification frame is indicated by a 
dotted border.

E The dotted border indicates that the nested frameset in the bottom row is selected.

When you select a frame in the Frames 
panel, the corresponding frame is selected 
in the document window. A dotted border 
highlights the selected frame in the docu-
ment window D. The tag selector displays 
the appropriate element—in this example, it’s 
<frameset><frame#identification>.
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To adjust rows or columns 
of the frameset:
1. Select the frameset in the Frames panel.

2. Make adjustments with the Property 
inspector F.

The Property inspector displays options 
for Borders, Border width, and Border 
color. You can also set either the row 
height or column width, depending on 
which is selected. Enter a value, and 
then choose pixels, percentage, or rela-
tive units.

If the selected frameset contains rows, 
the rows are miniaturized on the Prop-
erty inspector. The selected row is indi-
cated in dark gray. Clicking a row in this 
miniature display on the Property inspec-
tor selects it. Set the Row Value (that is, 
the height) for each row as needed.

If the selected frameset contains col-
umns, the columns are miniaturized on 
the Property inspector G. The selected 
column is indicated in dark gray. Click-
ing a miniature column in this display 
on the Property inspector selects it. Set 
the Column Value (that is, the width) for 
each column as needed.

F The Property 
inspector shows a 
miniature frameset with 
rows when a frameset 
with rows is selected. 
Options to adjust the 
frameset are displayed.

G The Property 
inspector with a column 
frameset selected. You 
see a miniature frameset 
indicating which column 
your adjustments 
will affect.
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Row height and column width can be set 
in exact units (pixels), as a percentage of the 
frameset, or as relative. If you choose relative, 
the row or column takes up whatever space 
is available. Relative rows and columns can 
shrink or grow, depending on the size of the 
browser window. Relative units are considered 
the most accessible.

As you work with frames, you’ll see that 
Dreamweaver provides many visual cues, 
such as dotted borders around selected 
framesets in the document window and thick 
borders around selected framesets in the 
Frames panel. These visual cues are important 
to watch because it is easy to accidentally 
change something you don’t intend to change 
in a complicated frameset if you don’t pay 
attention to the selected element. These cues 
also help you make sure you have the right 
element selected when it is time to save your 
work. Remember that these visual cues won’t 
show up in the Web browser.

Selecting a frame or frameset in the 
Frames panel is not the same as placing an 
insertion point in a frame by clicking within a 
frame in the document window.

Turning frame borders on or setting 
frame border colors in the Property inspec-
tor creates a very dated look, and we advise 
against it, unless you’re shooting for that retro 
1996 look.
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To adjust frame properties:
1. Select the frame you want in the 

Frames panel.

2. The Property inspector displays proper-
ties for that frame H. Make changes in 
one or more of the properties:

>	 Frame name gives a needed identi-
fier to the frame (see the sidebar 
“Frame Name vs. Frame Title”). Each 
frame must have a name. If you cre-
ate a custom frameset, you need to 
supply the name for the frameset 
yourself. A name that helps you 
make sense of your layout, such as 
leftFrame, navFrame, or menuFrame, 
is usually what you want here. No 
spaces are allowed in the name.

>	 Src is the URL of the page that initially 
is displayed in the frameset. Setting  
this field is covered in “Inserting 
Pages into Frames.”

H With a frame selected, the Property inspector displays options for adjusting and 
naming the frame.

Working with Frames and CSS
You won’t use CSS to lay out a framed 
site, but what about for everything 
besides layout? CSS works just fine with 
framed sites to control the various dis-
play properties of the individual pages.

In Chapter 9, “Managing Styles,” you 
learned how to attach a style sheet to 
a document. To use CSS with a framed 
site, you simply attach a style sheet 
to every individual page that will be 
inserted in your frameset.
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If you click inside a frame in the document 
window, the Property inspector displays the 
standard text properties for that frame’s docu-
ment. To change the properties of the frame, 
use the Frames panel to select the frame.

Monitor size and screen resolution can 
vary widely among users. Some users must 
enlarge the text with the browser controls in 
order to read it. It is a good idea to test your 
framed site with various browser configura-
tions. Only testing shows you whether scroll-
bars or resizing are needed so that all your 
content is viewable.

Size issues can also lead to printing 
problems in some situations. You may need 
to provide special printer-friendly pages for a 
framed site.

One of the reasons that frames got such 
a bad reputation was due to the tacky look of 
sites after frame border colors were applied. If 
you’re considering changing your framed site’s 
border colors, please reconsider unless you’ve 
got a darned good reason.

>	 Scroll options are Yes, No, Auto, and 
Default. Yes means that a scrollbar 
will always appear regardless of 
the size of the browser window. No
means that particular frame will not 
have a scrollbar ever, even if not all 
the contents of the frame are visible. 
Auto means a scrollbar appears auto-
matically if the contents of the frame 
are larger than the frame can display. 
Default is the browser’s default, 
which is usually Auto. Scrollbars can 
be horizontal or vertical, depending 
on which is needed to see all the 
contents of a frame.

>	 Normally, a frame can be resized in 
the browser. Selecting the No resize
check box means that there will be no 
way to resize a frame in the browser. 
If you leave it unselected, users can 
drag the frame borders in the browser 
window. This is useful for users who 
prefer to have especially small or 
especially large browser windows.

>	 Margin width and Margin height refer 
to the margin surrounding an indi-
vidual frame.

>	 Borders, which can be set at the 
frameset level, can also be set indi-
vidually for each frame. The choices 
are Default (the browser default, 
which is usually No), Yes, and No.

>	 Border color allows you to set the 
color for the frame borders. Click the 
color well to bring up a color picker to 
help you set the color.
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Inserting Pages 
into Frames
Now that you’ve got your frames set up, 
you’ll need to create pages to fill every 
frame. These pages are normal Web 
pages in every way except that they contain 
just a part of what appears in the overall 
window. To prepare the HomeCook.info 
example, it took four individual pages: 
masthead.html A, menu.html B,  
home.html C, and the frameset document.

A This individual HTML page will be placed in the identification frame of the frameset.
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B This individual HTML page will be placed in the navigation frame of the frameset.

C This individual HTML page will be placed in the content frame of the frameset.
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To add a prepared page to a frame:
1. Click anywhere in the frame.

2. Choose File > Open in Frame.

The Select HTML File dialog appears.

3. Browse to select the file you want to 
insert, and then click OK (Choose).

4. Repeat the steps to add files to other 
frames D.

5. When every frame has its opening file, 
choose File > Save Frameset.

The inserted files are now the Src 
documents for the various frames in 
the frameset.

For more about saving framesets, see 
“Saving Framesets and Frames.”

D The identification and navigation frames have files inserted, but the content frame is still unfilled.

Naming a “home” page is slightly differ-
ent with framed sites. You’d normally name 
the home page index.html. But in a framed 
site, you need that filename for the frameset. 
With a framed site, think of the initial set of 
files displayed when the frameset opens as 
Home. The page in C is named home.html 
because it’s in the opening content frame 
before any links are clicked.
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To add content to a page in a frame:
1. Click anywhere in the frame.

2. Insert text and images with your nor-
mal Web content creation verve E. 
If you need a refresher, take a peek at 
Chapter 3, “Building Your First Page” or 
Chapter 4, “Adding Text to Your Pages.”

3. Choose File > Save Frame.

For more about saving frames, see 
“Saving Framesets and Frames,” later in 
this chapter.

E You can type or insert material in a framed file while it is part of the frameset.
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Working with iframes
An iframe is an inline frame or an inline 
subwindow. In much the same way that 
you can insert an image into a page of 
text, you can insert an iframe. The iframe 
element inserts an entire miniature view 
of an HTML page into another page. This 
is handy when you want some small bit 
of content to come from somewhere 
else, in a page that otherwise isn’t 
framed. For instance, those ubiquitous 
Google AdSense ads you see on many 
sites are done with iframes.

Dreamweaver is only minimally 
equipped to create iframes fresh out of 
the box, but you can get an extension to 
add more capabilities. For instance, one 
named iFrame Suite contains five exten-
sions for working with iframes. It, along 
with other extensions related to iframes, 
is available at the Adobe Exchange 
at www.adobe.com. If you’d like more 
information on installing and using 
extensions, refer to Appendix B, “Cus-
tomizing and Extending Dreamweaver."

Saving Framesets 
and Frames
As soon as you create a frameset, it’s 
selected in the document window. But 
if you’ve been working with frames and 
files, it can get tricky to know just what file 
you’re working on. Sometimes the option 
to save what you want is grayed out. This 
could mean that the file was already saved. 
If you know it wasn’t, recheck all the visual 
clues to figure out what you have selected. 
Be sure you have the frame or frameset 
you intend to save selected.

To save a frameset:
1. To select the frameset, click the 

outer border of the frameset in the 
Frames panel.

The thick border indicates the selected 
frameset (as in figure A in “Using the 
Frames Panel,” earlier in this chapter).

2. Choose File > Save Frameset.

If the frameset document has never 
been saved before, you’ll be prompted 
to name the file. The frameset docu-
ment is the file that is opened when a 
visitor first arrives at a URL, so frameset 
files are often saved as index.html.

or

Choose File > Save All.

This saves the frameset and all other 
open files at once. If this is the first time 
you are saving the files, Dreamweaver 
prompts you to name each file prior to 
saving it.

or

Choose File > Save Frameset As.

This prompts you to save the frameset 
with a different name from the one you 
might already be using, and it is useful 
for making a backup or saving a copy.

www.adobe.com
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To save a frame:
1. Click anywhere in an individual frame.

2. Several File menu options related to 
frames are now available:

>	 Choose File > Save Frame to save the 
currently selected frame.

>	 Choose File > Save Frame As to 
save the current frame with a differ-
ent name.

>	 Choose File > Save Frame As Tem-
plate. This creates a template you 
can use to create similar pages (see 
Chapter 16, “Making Life Easier: Using 
Templates, Libraries, and Snippets”).

Double-check the document window to 
verify that the frameset or frame you want 
to save is what’s selected. Dotted borders 
outline the selected frameset A. In the 
figure, because the selected frame is inside 
a nested frameset, the tag selector at the 
bottom of the window displays <frameset> 
<frameset><frame#navFrame>.

If you’re working on an internal content 
page of your site while typing in a frame in the 
frameset document window, be careful when 
you save. You want to save only the file in the 
frame, not the entire frameset. If you inadver-
tently save the frameset, you’ll be accidentally 
changing the Src file in the frameset document 
to that of the file you just saved—probably not 
what you wanted. Make sure that you’re sav-
ing the frame file, not the frameset file.

A Check for the dotted lines indicating a selection to be sure about what you are saving.
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Page Title and Frame Title
Every document you create in Dreamweaver has a Title field in the toolbar at the top of the docu-
ment window. The frameset page title may be the only title a user ever sees for your framed site, 
so make it count. However, it’s a good idea to give each document in the site a title, too.

We need a little semantic clarification here, because there are title elements, and then there are 
title attributes. You first heard about title elements in Chapter 3. There you learned how to 
create the document title in the Title field at the top of the window. This is the title that appears in 
the title bar of a Web browser when the page is loaded.

In this chapter, we talk a lot about title attributes for frames. Now, title attributes are very 
important, but they’re not the same thing as the title elements that give a document a title.

Attributes modify elements. An element is made with an HTML tag. If you wrap some text with 
an HTML tag, you’ve got an element. HTML elements are things like paragraphs, lists, images, 
headings, and frames. All those elements have attributes like size, color, border, margin, and 
possibly title. A title attribute lets you set some characteristic of an element. In this chapter, a 
title attribute adds information to its frame element.

If all this semantic talk is too much for you, just remember this: if Dreamweaver gives you a chance 
to put a title anywhere, do it!
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Targeting Frames 
with Links
You probably surfed the Web for all of a 
minute and a half before you first real-
ized that if you click a link, the current 
page goes away and a new page fills the 
window. That’s a great system—except for 
framed sites. Often, when a link is clicked 
in one frame, the new file should open in 
some other frame entirely. You can make 
that happen by using a target attribute 
in the link. The target names the frame 
where the new file will open. Yep, that’s 
why you named the frames.

To make a target link while 
working in the frameset:
1. Open the frameset with the page where 

you want the link visible.

2. Highlight the text for the link.

3. The Property inspector link options 
appear.

Browse for the file you want the link 
to open.

or

Click the Point to File icon and point 
to a file in the Files panel to create 
the link.

Choose the target frame from the 
Target menu A. Dreamweaver 
already knows which frames are in 
the frameset.

4. Choose Save > Frame to save your 
changes.

A When you create a link 
while working in the frameset 
document, Dreamweaver 
provides the Target options in 
the Property inspector.
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To make a target link while 
working on an individual page:
1. Open the page where the link will be.

2. Highlight the text for the link.

3. The Property inspector link options 
appear.

Browse for the file you want the link 
to open.

or

Click the Point to File icon and point 
to a file in the Files panel to create 
the link.

Type the frame name in the Target 
field B. Spelling and capitalization of 
the frame name must be exactly right.

4. Save your changes.

Although it’s definitely handy to have 
the pop-up menu of frame targets right there 
in the Property inspector when making links 
in the frameset document window, it’s not 
without peril. Inadvertent improper saves can 
play havoc with the frameset. If you create the 
individual pages for the site independently, 
outside of the frameset document, you do 
have to do a bit of extra typing to get the 
Target field filled in. However, when you save 
an individual page, you can’t possibly save 
anything besides the individual page.

B When you create a link in an individual document, you must manually type the 
target in the Target field of the Property inspector.
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Adding noframes 
Content
Some wireless users who access the Web 
with mobile phones, tablets, or other small 
devices can’t view frames—nor can users 
with disabilities who have specialized 
browsers. These folks need noframes con-
tent—unless you want them all to go away 
and leave your site alone, never to return.

The content in a noframes element could 
be an entire alternate Web page, provid-
ing all the information a frames-capable 
user would find in the framed site. A less 
ambitious noframes element might contain 
an invitation for the user to click through to 
a site navigation page or a site index page 
so that the content you offer could still 
be accessed.

Search engines also sometimes make use 
of noframes content. Use it to describe the 
site’s key information and provide links for 
the search engine robots (or other users) 
to follow.
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To add noframes content:
1. Select the frameset in the Frames panel.

2. Choose Modify > Frameset > Edit 
NoFrames Content A.

3. A blank page appears in the document 
window, replacing the framed pages B.

Type or paste the noframes content in 
this blank window C.

4. To return to the frameset, choose  
Modify > Frameset > Edit NoFrames 
Content again.

If you preview your site in a regular 
browser (which has no trouble displaying 
frames), you won’t see the noframes content.

B The Edit NoFrames Content command brings up an empty NoFrames Content document.

C Site information and links are added to the NoFrames Content document.

A To set what will be displayed for non-frames-
supporting browsers, choose Edit NoFrames 
Content from the Frameset submenu of the 
Modify menu.
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B2
Using Spry Widgets

One foundation of “Web 2.0” is widespread 
user interactivity enabled by extensive use 
of CSS and JavaScript. This allows applica-
tions that run inside a Web browser to offer 
the kind of responsiveness that was once 
reserved for native applications.

In Dreamweaver CS3, Adobe added a 
library of widgets that enable Web builders 
to make their sites look like cutting-edge 
destinations. This library—also referred 
to as a framework—is named Spry. Spry 
is a collection of HTML, CSS, JavaScript, 
and graphics, the relevant pieces of which 
are automatically added to your site when 
you add any of the Spry elements. No, you 
don’t need to know anything about CSS or 
JavaScript to use Spry.

In Dreamweaver CS5, Adobe expanded 
the program’s ability to use other popular 
frameworks (such as jQuery), which are 
covered in Chapter 14. In this chapter, we’ll 
focus on using the Spry elements that 
come with Dreamweaver.

In This Chapter
What Is Spry? B2-2

Adding Spry Elements B2-4

Using the Menu Bar Widget B2-6

Using the Accordion Widget B2-11

Using the Collapsible Panel Widget B2-13

Validating Forms with Spry B2-15

Adding Spry Tooltips 

B2-23

Adding Spry Effects 

B2-25
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What Is Spry?
To use Spry’s full functionality, it helps to 
know a little bit more about what Spry is 
and how it works behind the scenes.

A (brief) history of frameworks
When people first started adding JavaScript 
to pages, they quickly realized that a lot of 
the work they were doing was the same 
stuff, over and over and over again. Just 
about every JavaScripter has their collec-
tion of code snippets that they’ve already 
debugged and now reuse regularly.

In recent years, it’s become common to let 
JavaScript handle more and more of the 
user interface (UI) duties. This means that 
Web sites have become smarter and more 
flexible, but it’s also been a lot more work 
for people who write code. Programmers 
tend to hate writing new code when they 
know someone else has already solved that 
particular problem. Instead, they go looking 
for free code offered by others, and in return 
offer their own solutions. The result is shared 
libraries of code that can handle most of the 
usual user interface requirements.

However, programmers also tend to have 
definite (and idiosyncratic) opinions about 
the “right” way to write code, and the result 
of that has been the creation of many dif-
ferent frameworks. If you’ve ever heard 
of libraries such as Dojo, YUI, jQuery, or 
Prototype, they’re all more or less the same 
thing, built by developers who thought that 
their way of doing things was better than 
what already existed.

Dynamic Data
Working with XML data is beyond the 
scope of this book, but that doesn’t 
mean that you can’t check out Spry 
data sets. Take a look at the examples 
at Adobe’s online Spry site (labs.
adobe.com/technologies/spry/); 
they should give you some good ideas 
of what’s possible.
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Spry is Adobe’s answer to this same chal-
lenge, geared to work with Dreamweaver 
and to stand on its own; in fact, you can 
download Spry from the Adobe website and 
use it as you would any other JavaScript 
framework, even if you don’t use Dream-
weaver. It’s not an application; instead, it’s a 
collection of code snippets (both CSS and 
JavaScript) that when added to your pages 
creates some standard effects.

What’s in Spry
Spry contains three types of components:

n	 Widgets: These elements let you create 
a more interactive Web site. There are 
two main types of widgets: UI widgets 
(such as the accordion, menu bar, and 
collapsible panel) and form validation 
(such as text fields and text areas).

n	 Effects: Unlike widgets, effects don’t 
so much interact with the user as just 
look good on their own. You can use 
effects to visually highlight transitions or 
to emphasize elements on your page. 
Some examples of effects are highlight, 
shrink, and squish.

n	 XML data sets: If you want data on your 
page that’s read from an external file, 
or you want users to be able to sort 
displayed information without hav-
ing to reload the page, or you want to 
show some detailed information when 
the user selects various options, then 
you’re looking at using Spry data sets.

This Looks Familiar…
If you’ve already read Chapter 14, you’ve 
probably noticed that the first couple of 
sections of this chapter are substantially 
identical to Chapter 14. For this CS6 revi-
sion, we needed to move most of the dis-
cussion of Spry out of the paper edition 
of the book to save space. Because Spry 
is moribund in Dreamweaver compared 
to jQuery, we chose to include more 
jQuery and less Spry in the main part of 
the book. But Spry hasn’t been entirely 
moved out of Dreamweaver, so we 
wanted to give readers of the paper edi-
tion a grounding in Spry—we hoped you 
would read this chapter if you wanted 
to know more. If you’re reading this, our 
strategy succeeded!
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Adding Spry Elements
By now, you’ve surely noticed the Spry cat-
egory A in the Insert panel. It’s just one of 
the many places where you can find Spry 
elements to add to your page.

To add a Spry element:
For widgets and data objects: With the 
Spry category showing in the Insert panel, 
choose where on your page you want to 
add the element, and then click the desired 
Spry button.

or

For widgets and data objects: Choose 
Insert > Spry from the menu bar, and then 
choose which Spry element you want to 
add from the submenu B.

or

For form validation widgets: Choose 
Insert > Form from the menu bar, and then 
choose which Spry widget you want to add 
from the submenu B.

or

For UI widgets: Choose Insert > Layout 
Objects from the menu bar, and then 
choose which Spry widget you want to add 
from the submenu B.

or

For effects: Select the element on the 
page you want the effect to affect, click the 
plus button on the Behaviors tab of the Tag 
inspector, and choose an action from the 
Effects submenu C.

If you’ve added a widget, you’ll see the 
object on the page outlined with a bright blue 
border and the name of the widget. If you’ve 
added an effect, you’ll see it listed in the 
Behaviors panel tab of the Tag inspector.

A Spry widgets are found in the 
Spry category of the Insert panel.

Believe it or not, these aren’t all the 
places where you can find options to add Spry 
elements in Dreamweaver.
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C Spry effects are considered behaviors, so they’re 
found in the Behaviors tab of the Tag inspector.

B Spry commands can be 
found in several locations 
in the Insert menu, as 
shown in this composite 
illustration.
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Using the Menu 
Bar Widget
One of the most common user interface 
items you’re likely to add to a site is the 
common menu bar. As mentioned in Chap-
ter 13, you can build complex menu bars 
in Fireworks—but what if you don’t have 
Fireworks, or its menus aren’t quite what 
you want? Spry menu bars are simple, flex-
ible, and powerful.

To add a menu bar widget:
1. Decide where you want the menu bar 

on your page, and click the Spry Menu 
Bar button in the Spry category of the 
Insert panel. The Spry Menu Bar dialog 
appears A.

2. Decide if you want a horizontal menu 
bar (a pull-down, where the main menu 
options go across and submenu options 
go down) or a vertical menu bar (a 
flyout, where the main menu options go 
down and submenu options go across). 
Click OK to accept.

3. The Spry menu bar appears on your 
page with default data displayed in the 
Property inspector B.

4. To change the names of menu items, 
click any item name in the first col-
umn of the Property inspector C and 

A The Spry menu bar can be horizontal or 
vertical.

B The brand-new Spry menu bar on our page 
starts off with some default values.

C After you’ve created the menu bar, you’ll set its values using the Property inspector.
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change the Text field on the right. Items 
in the second and third columns are 
submenus of the selected item in the 
previous column. To delete an item, 
select it and click the minus button at 
the top of the column. To add items, 
click the plus button at the top of the 
column and then change the name from 
the automatically named default. And 
to change the order, select an item and 
then click the up or down arrow at the 
top of the column.

5. Turn menu options into links by select-
ing the option and changing the Link 
field to the URL of the desired page D.

continues on next page

D Set the link for each menu bar item in the Property inspector.
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6. Click the Turn Styles Off button in the 
lower left of the Property inspector to see 
how the menu bar appears when CSS 
isn’t available E. Click the Turn Styles On 
button to make the styles reappear.

7. When you first save the page, or when 
you view the page in a browser, you’ll 
see the Copy Dependent Files dia-
log F. This lets you know that the 
required Spry files are being added. 
They’ll all be in a directory named Spry-
Assets at the root of your site, and you’ll 
need to upload that directory and the 
files it contains to your server so your 
site works correctly.

8. When you view your site in a 
browser G, you’ll see your new flyout 
(or pull-down) menu.

However, what you see is the menu 
in Dreamweaver’s default menu style. 
If that isn’t quite what you want, you’ll 
need to edit the widget’s styles.

E It’s a good idea to always check to 
see how your Spry elements appear 
without styling.

G And here’s our Web page with its new flyout 
menu.

F Every Spry command has one or more 
associated JavaScript, CSS, or graphics files. 
Dreamweaver warns you that it’s adding them to 
your site.
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To edit a menu bar widget:
1. This page uses an attached style sheet 

(hiking.css) that defines the desired 
appearance of its elements. To use the 
styles you’ve defined in the style sheet 
for menus, you first need to change 
the menu bar’s id from MenuBar1 to 
navlist, which you do by changing its 
name in the Property inspector H.

continues on next page

H You can modify the way the menu looks by changing the styles, as seen in the CSS Styles panel. 
We’ve begun the process by disabling some of the selected properties.
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2. SpryMenuBarVertical.css contains the 
CSS for the Spry menu bar. You proba-
bly don’t want all the default Spry styles, 
so you need to figure out which rules 
affect the menu. Once that’s done, you 
can either add rules to hiking.css to 
override them, or delete/disable them 
in SpryMenuBarVertical.css. The 
easiest way to see which rules affect 
the menu is with the Code Navigator 
(see Chapter 7 for more about using the 
Code Navigator).

3. And finally, when you view the page 
in the browser, you see the new flyout 
menu just the way you’d expect it to 
appear I.

The Turn Styles Off button on the 
Property inspector is also useful to verify that 
you’ve set up all your menus and submenus 
correctly, because it causes them to display all 
at once on the page.

Be sure to always test your pages in a 
browser, though you can also get a good idea 
of how the menu will look by clicking the Live 
View button on the Document toolbar.

To delete the widget, make sure the 
entire menu bar is selected and then press 
Delete.

When using any Spry widget, be careful 
to test your pages for accessibility for those 
users who don’t have JavaScript, those with 
older browsers, and those with disabilities. 
Your sites need to work for everyone, not just 
people with the latest and greatest browsers, 
and the current version of Spry doesn’t always 
create widgets that work when (for instance) a 
visitor to your site sees it on a mobile device.

In D, you can add a tool tip to any link 
simply by typing text into the Title field.

I The new flyout menu looks even better when 
its design matches the rest of the site.
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Using the Accordion 
Widget
An accordion widget is a set of panels, 
where one (and only one) is displayed at 
a time. It’s a handy way to present sev-
eral discrete chunks of information in a 
limited space.

To add an accordion widget:
1. Decide where you want the accor-

dion on your page, and click the Spry 
Accordion button in the Spry category 
of the Insert panel. A Spry Accordion 
widget with defaults and the Accordion 
Property inspector display A.

2. To change the default labels and con-
tent panels, simply type over them in 
the Dreamweaver document. The first 
panel is always shown by default when 
the page first loads.

3. To delete panels, select the panel in the 
Property inspector and then click the 
minus button. To add panels, click the 
plus button. And to change the display 
order of the panels, select a panel and 
then click the up or down arrow.

4. To view a specific panel inside Dream-
weaver, hover over the label until you 
see the eye icon. Click the eye, and that 
panel displays B.

continues on next page

A The accordion widget might be a better match 
for the type of information that we’re trying to 
display, so we’ve added one here.

B The panels can be set to display or hide 
inside Dreamweaver.
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5. Here’s your new accordion as seen in a 
browser C. Simply click the label, and 
the currently open panel closes and the 
desired panel opens. By adjusting the 
CSS of the widget, you can increase or 
decrease the height of the accordion 
panels (see the tip below). If you don’t 
adjust the height of the panel to match 
your content, it automatically displays a 
scrollbar, as in C.

To change the height of an accordion 
panel, we first needed to discover which CSS 
rule controlled the panel’s height. We clicked 
in the panel’s content and chose View > Code 
Navigator (see Chapter 7 for more on that 
feature). The Code Navigator window showed 
a rule named .AccordionPanelContent, 
which had a default height of 200 pixels. We 
clicked the rule in the Code Navigator window, 
which changed the document window to Split 
view, highlighting the rule in the Code pane. 
We then changed the value of the height
attribute to 100 pixels and saved the file.

When adding a widget to an existing 
page, be careful about moving text that’s 
already on the page into the widget. Wid-
gets can be fragile, and if you don’t drag and 
drop the text into exactly the right spot, you 
can end up with a mess. We’ve had better 
luck just deleting text and retyping it directly 
into widgets.

C And here’s the final accordion in the browser.
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Using the Collapsible 
Panel Widget
If the accordion widget is almost, but not 
quite, just what you want, then the collaps-
ible panel widget is probably what you’re 
looking for. Where the accordion widget 
allows you to have one—and only one—
open panel, the collapsible panel widget 
lets you have as many or as few as you 
and your visitors want.

To add a collapsible panel widget:
1. Decide where you want the collapsible 

panel on your page, and click the Spry 
Collapsible Panel button in the Spry 
category of the Insert panel. A Spry Col-
lapsible Panel widget with defaults and 
the Collapsible panel Property inspec-
tor display. A shows a document with 
two collapsible panel widgets that have 
content in each panel.

2. You can set each panel to be open or 
closed when the page loads. Toggle the 
display by changing the Default state 
in the Property inspector from Open to 
Closed or vice versa.

3. Choose whether or not the panel con-
tents are viewable inside Dreamweaver 
by toggling the Display value in the 
Property inspector from Open to Closed 
and back again.

or

Hover over the label until you see the 
eye icon, as seen in A. If the panel is 
closed, the eye icon is open. Click it to 
open the panel B. If the panel is open, 
the eye icon is closed, and clicking it 
closes the panel.

continues on next page

A Multiple collapsible panels is another UI 
approach, allowing us to have multiple panels 
display at one time.

B Again, panels can be seen and 
hidden inside Dreamweaver without 
affecting how they will appear in the 
browser. When you hover over a panel, 
a tool tip with the panel’s CSS property 
information will also briefly appear, as 
shown here.
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4. Change the default labels and con-
tent panels by simply typing over their 
current values in the Dreamweaver 
document.

5. Finish up by checking the display 
in Dreamweaver’s Live view or a 
browser. C shows the panels in their 
collapsed state, and D shows them in 
their open state.

The Property inspector also contains a 
check box to enable (or disable) animation. If 
it’s on, visitors to your site see a brief anima-
tion when they open and close panels. If you 
think that people might get impatient, turn off 
the animation.

C Here are the two panels— 
both closed—in the browser window.

D Click each label, 
and its panel slides 
open so you can see 
all the information 
at once.
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Validating Forms 
with Spry
The form in A should look familiar, 
because it’s the same form example used 
earlier in this book. But if you look at B, 
it’s actually a little different—you can see 
that Spry has added some smarts to it. The 
addition of the new error messages (which 
only appear on your site if the form is filled 
out incorrectly) tell people filling out the 
form more about what kind of data they 
need to enter where.

Dreamweaver has the ability to validate a 
group of radio buttons, validate password 
fields, and require the user to enter a pass-
word twice for verification.

To add Spry validation 
to a text field:
1. Select an existing text field and click 

the Spry Validation Text Field button in 
the Spry category of the Insert panel. 
The usual blue box appears around the 
field, and the Spry TextField Property 
inspector appears C.

continues on next page

A This contact form doesn’t look particularly 
intelligent.

B But once visitors see the error messages, they 
have a better idea of what’s required.

C Text fields can be set to require some value before the form can be submitted.
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2. Using the Property inspector, you can 
make your text fields require a wide 
range of input types. C shows a text field 
that requires that something (anything) 
be in the Last Name field. That’s done by 
selecting the Required check box, and 
setting the Min chars field to one.

D shows the email address field, 
which is a little more complex. Here, 
the Type drop-down menu is set to 
Email Address, which rejects the user’s 
entry unless it matches the format of an 
email address.

The Last Name field is set to show 
the field required error, and the Email 
field is set to show the invalid format 
error. These are done via the Preview 
states drop-down menu in the Property 
inspector, which lets you see how each 
possible error message displays inside 
Dreamweaver. And along with the error 
messages, the entry field has a pink 
background, showing that the current 
entry is insufficient.

D Text fields can also be set to require very particular data, such as in this Email field, before submission 
is allowed.
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To add Spry validation 
to a select field:
Select an existing pop-up menu and click 
the Spry Validation Select button in the 
Spry category of the Insert panel. Once 
again, you’ll see the blue box appear with 
its associated Property inspector E.

A pop-up menu can be set to have a 
required value or to only allow certain 
selections. You can also preview the vari-
ous error messages inside Dreamweaver.

E This pop-up menu is now set to require visitors to make a choice.



ptg8274339

B2-18 Bonus Chapter B2

To add Spry validation 
to check boxes:
1. Select where you want your new check 

boxes to be placed, and click the Spry 
Validation Checkbox button in the  
Spry category of the Insert panel.  
The Input Tag Accessibility Attributes 
dialog appears, which was covered 
in Chapter 11. Enter the appropriate 
data and click OK. Your new check box 
appears in its standard blue box, and 
the Property inspector displays the Spry 
Checkbox F.

2. If you want the validation to apply to 
a group of check boxes instead of a 
single check box, add them inside the 
Spry region at this point or drag existing 
check boxes into the region.

3. The Property inspector allows you to 
require a single check box to be set, or 
to require a certain minimum number of 
check boxes to be set. In this example, 
we want visitors to click at least one 
check box of the five, so the minimum is 
set to one and the maximum to five. F 
shows the error message that displays 
when they submit the page without 
picking any of the check boxes.

F Check boxes can be validated individually or in groups.
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To add Spry validation 
to radio buttons:
1. Select where you want your new radio 

buttons to be placed, and click the Spry 
Validation Radio Group button in the 
Spry category of the Insert panel.

The Spry Validation Radio Group dialog 
appears G. This is similar to the Radio 
Group dialog discussed in Chapter 11.

2. Fill out the dialog, and then click OK.

The radio buttons appear on the page, 
and you see the Spry Radio Group in 
the Property inspector H.

A radio button group must have one of 
its choices selected, but Dreamweaver doesn’t 
know which button you want selected, so you 
must do it yourself. Click the button that you 
want to use as the default choice, and the 
Property inspector will change to show that 
button’s properties. In the Initial state section, 
choose Checked.

G Begin adding your validated radio button group 
by entering the button values.

H By default, a radio button group is set to have a required value.
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To add Spry validation 
to a text area:
1. Select an existing text area field, and 

click the Spry Validation Textarea but-
ton in the Spry category of the Insert 
panel. You’ll see the usual blue box and 
Property inspector I.

2. In the Property inspector, you can set 
it so the text area is required and set 
it to have a minimum or maximum 
length. Additionally, you can choose to 
display a counter of characters filled in 
or characters remaining, so that users 
know how close they are to the limit. 
And finally, the Hint field puts optional 
text into the field when the form loads, 
telling users what type of information 
you’re requiring them to enter.

3. J shows how the form appears in the 
browser when the page first loads. K 
is an attempt to validate our bad input, 
showing the two error messages 
we’ve received.

Any field can be set to validate on blur, 
change, or submit, where the default is sub-
mit. Blur refers to when users exit the field, 
whether or not they’ve actually changed its 
value.

The text area Hint text automatically 
clears itself when the user enters the field. 
Hint text also doesn’t count as characters 
toward the entry requirements or limits.

I Text area boxes can require that at least a 
certain amount of data be entered and give a hint 
to the visitor as to what’s necessary.

J The form looks straightforward when it’s first 
loaded in the browser.

K But this form won’t let us get away with trying 
to submit it without the required fields.
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To add Spry validation 
to a password field:
1. Click to place the insertion point where 

you want to add your password field, 
and click the Spry Validation Password 
button in the Spry category of the Insert 
panel.

The Input Tag Accessibility Attributes 
dialog appears L.

2. Enter the appropriate data and click OK.

The password field appears in the 
document, and the Property inspector 
changes to reflect the Spry Password 
choices M.

3. Set the requirements for the password 
in the Property inspector. You can spec-
ify the minimum and maximum number 
of characters, how many letters and 
numbers must appear in the password, 
whether or not letters must be upper-
case, and whether special characters 
are allowed or required.

L You need to give the password field an ID and 
a label.

M Set the password’s requirements in the Property inspector.
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To add a Spry confirmation field:
1. Confirmation fields require the user 

to reenter the same value as another 
field in the form. They’re usually used 
with password fields. Begin by placing 
the insertion point where you want to 
add your confirmation field, and click 
the Spry Validation Confirm button in 
the Spry category of the Insert panel. 
The Input Tag Accessibility Attributes 
dialog appears.

2. Enter the appropriate data and click OK.

The confirmation field appears in the 
document, and the Property inspector 
changes to reflect the Spry Confirm 
choices N.

3. In the Validate against pop-up menu, 
choose the field you want to validate 
against. If there is only one field and 
one form on the page, it will appear in 
the pop-up menu automatically.

N The confirming password field is set to validate against the original password field.
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Adding Spry Tooltips
Dreamweaver allows you to add a Spry 
Tooltip, which is a short bit of text that 
appears when you hover over an area on 
your page. Spry Tooltips have two parts: 
the trigger, which is the part of your page 
that serves as the hotspot for the user’s 
cursor, and the content, which is the 
Tooltip’s text.

To add a Spry Tooltip:
1. Click to place the insertion point where 

you want to add the Tooltip, and click 
the Spry Tooltip button in the Spry cat-
egory of the Insert panel.

Default trigger text and a field for the 
content appear in the document A.

or

Select an element on the page and 
click the Spry Tooltip button in the Spry 
category of the Insert panel.

The field for the Tooltip’s content 
appears in the document. When you 
first select an existing element, Dream-
weaver assumes that you want the ele-
ment to be the Tooltip’s trigger.

The Property inspector changes to 
reflect the Spry Tooltip choices.

continues on next page

A If you don’t select an element before adding a Spry Tooltip widget, 
you get boilerplate text for the Tooltip’s trigger and content.

The Future of Spry
As mentioned at the beginning of this 
chapter, it’s possible to get Spry as a free 
download and use it with your sites even 
if you don’t have Dreamweaver. Because 
this is a book on Dreamweaver, we won’t 
get into how Spry is used outside of 
Dreamweaver.

Dreamweaver CS6 is shipping with Spry 
1.6.1 as this book goes to press. However, 
that was also the version that shipped 
with Dreamweaver CS4, so it’s clear that 
Spry development has stalled. By add-
ing the ability to use widgets from other 
JavaScript frameworks, notably jQuery, 
in Dreamweaver CS5, Adobe is signaling 
that Spry will be maintained for now but 
not expanded.

You can check to see if there’s a 
newer version of Spry by going to the 
Adobe Labs page at labs.adobe.com/
technologies/spry/. There, you’ll find 
Spry demos, forums, and documenta-
tion of what’s possible to create with 
Spry. The Spry team even has a blog, 
which you can find at blogs.adobe.com/
spryteam/.

To get newer versions of Spry (if or when 
they’re available), use the Extension 
Manager. The process is described in 
Appendix B, “Customizing and Extending 
Dreamweaver.”
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2. If you did not select an element before 
you inserted the Tooltip, type over the 
default trigger text with the text you 
want to appear on the page. If you did 
select an element, skip to step 3.

3. Type over the default text in the Tooltip 
content field, replacing it with your 
desired text.

4. In the Property inspector, choose from 
the Trigger pop-up menu B.

5. (Optional) Choose how the Tooltip will 
appear to the user in the browser by 
setting its horizontal or vertical offset 
and whether there will be a delay or a 
visual effect as the Tooltip appears or 
disappears C.

B You need to set the Tooltip’s trigger and visual effects (if you want them) in the Property inspector.

C The Tooltip appeared when I hovered the  
cursor over the password field.
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Adding Spry Effects
You can use Spry to add visual effects to 
elements on your page with behaviors. 
As shown in C in “Adding Spry Ele-
ments,” Spry effects are in the Behaviors 
tab of the Tag inspector. There are seven 
Spry effects: Appear/Fade, Blind, Grow/
Shrink, Highlight, Shake, Slide, and Squish. 
See them in action at labs.adobe.com/
technologies/spry/demos/effects/.

If you need a refresher on behaviors, please 
review Chapter 13. Remember to be careful 
setting which events trigger behaviors; if 
you want an effect to take place when an 
element is clicked, it should happen on the 
onClick (for instance), not onMouseOut.

Appear/Fade
The Appear/Fade effect makes an element 
appear or fade away. A shows the dialog, 
which allows you to set the element, the 
duration, the effect (appear or fade), the 
start and end percentages, and whether 
you want the effect to be reversible.

Blind
The Blind up/down effect works like a 
window blind that hides or shows the ele-
ment. The dialog B lets you choose the 
element, the duration, the effect (blind up or 
down), the start and end values, and whether 
you want the effect to be reversible.

Grow/Shrink
The Grow/Shrink effect makes the ele-
ment larger or smaller. Use the dialog C 
to set the element, the duration, the effect 
(grow or shrink), the start and end values, 
whether you want the element to move 
toward the center of the page or its upper-
left corner, and whether you want the 
effect to be reversible.

A The Appear/Fade dialog lets you control 
that effect.

B The Blind dialog might sound scary, but in 
reality it makes an element on your page look like 
it’s a window shade.

C The Grow/Shrink dialog allows you to make 
objects on your page get larger or smaller.
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Highlight
The Highlight effect changes the back-
ground color of the element, causing it to 
stand out on the page. The Highlight dialog 
D is where you set the element, the dura-
tion, the start and end colors of the high-
light, the color you want displayed after the 
effect has completed running, and whether 
you want the effect to be reversible.

Shake
The Shake effect does just what it sounds 
like—it makes the selected element 
shimmy in place. As E shows, all you can 
set is the target element.

Slide
The Slide up/down effect moves the 
selected element up or down on the page. 
The Slide dialog allows you to set the tar-
get element, the duration, the effect (slide 
up or down), the beginning and ending 
values, and whether you want the effect to 
be reversible F.

Squish
The Squish effect makes the selected ele-
ment disappear into the upper-left corner 
of the page. The element is set in the 
Squish dialog, as shown in G.

Not all effects can be applied to all elements. 
Play with them to see which behaviors work 
with particular objects on your page.

You can combine effects as well; all you 
have to do is keep adding behaviors to a given 
element. Be careful, though, to avoid getting 
too tacky!

D The Highlight effect changes the background 
color for the target element.

E The Shake effect does just what it sounds like.

F Make an element slide up or down your page 
with the Slide effect.

G The Squish dialog lets you make elements on 
your page appear smooshed.
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Working with 

Other Applications
When building a Web site, no single applica-
tion can stand alone; to get the best results, 
you must orchestrate elements from a 
variety of programs. For example, you might 
get your text from Microsoft Word, data for 
a table from Microsoft Excel, and the site’s 
images from Adobe Photoshop, Adobe Fire-
works, or any other image editing program.

Dreamweaver can help you expertly tie 
together these disparate elements into a 
unified Web site. It has special features that 
allow it to work with other programs, mak-
ing it easy to incorporate files from those 
other programs into your pages.

In Chapter 5, we covered how Dream-
weaver integrates with Photoshop to work 
with images. In this chapter, you’ll learn 
how you can use other programs to edit 
elements on a page you’re working on in 
Dreamweaver; use Dreamweaver’s integra-
tion with Fireworks to edit and optimize 
images; and import and modify Microsoft 
Office documents. You’ll also learn how 
Dreamweaver and Adobe Contribute 
work together to make editing your Web 
site easy, even for people who aren’t 
Web savvy.

In This Chapter
Assigning External Editing Programs B3-2

Editing Images with Fireworks B3-5

Using Adobe Bridge 
B3-10

Cleaning Up Word HTML 
B3-12

Using Content from Excel 
B3-14

Working with Contribute 

B3-17
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Assigning External 
Editing Programs
When you are working on your Web pages, 
you can launch another program to edit 
files that Dreamweaver can’t edit itself, 
such as graphics and media files. For 
example, if you want to edit a JPEG file, 
you can have Dreamweaver use Fireworks 
or Photoshop or even something like Win-
dows Paint. You specify an external editor 
for a particular file type.

Dreamweaver can use any programs that 
you have on your machine to edit files, 
but you’ll need to tell Dreamweaver about 
these programs first. You do that in Dream-
weaver’s Preferences dialog.

A Use the File Types/Editors category of the Preferences dialog to set which programs you want to 
use to edit particular kinds of files.

To assign an external editor:
1. Choose Edit > Preferences (Dream-

weaver > Preferences) or press Ctrl-U 
(Cmd-U).

The Preferences dialog appears.

2. Click the File Types/Editors category.

The File Types/Editors pane appears A.

3. The field at the top of the pane, Open in 
Code View, has extensions of all kinds 
of files that Dreamweaver automatically 
opens in Code view. If you will be work-
ing on code files of a type not listed, 
enter one or more extensions in the 
field, separated by a single space.
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4. On Windows, if you want to assign an 
external code editing program, click the 
Browse button next to External Code 
Editor, navigate to the program you 
want, and click Open.

If you assign an external code editor, 
Dreamweaver changes the Edit > Edit 
with External Editor menu choice to 
Edit > Edit with [program name].

or

On the Mac, as shown in figure A, 
Dreamweaver can use Bare Bones 
Software’s BBEdit, a popular text editor, 
as its external code editor. In the File 
Types/Editors pane of Preferences, 
there is a check box labeled Enable 
BBEdit Integration. Select this check 
box to make BBEdit the external code 
editor. This also changes the Edit > Edit 
with External Editor menu choice to 
Edit > Edit with BBEdit.

5. From the Reload Modified Files pop-up 
menu, choose what you want Dream-
weaver to do when it detects that 
changes have been made in another 
program to a file that is open in Dream-
weaver. Your choices are Prompt 
(Dreamweaver will ask you whether 
it should reload the page), Always, 
or Never. On the Mac, if you chose 
Enable BBEdit Integration, this item is 
unavailable.

6. From the Save on Launch pop-up 
menu, choose whether Dreamweaver 
should always save the current docu-
ment before starting the external editor, 
never save the document, or ask you 
if it should save the document. On the 
Mac, if you chose Enable BBEdit Inte-
gration, this item is unavailable.

continues on next page
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7. If you have Adobe Fireworks on your 
system, tell Dreamweaver its location: 
click the Browse button, navigate to 
Fireworks in the resulting Select Exter-
nal Editor dialog, and click Open.

Dreamweaver uses Fireworks by 
default to edit most graphics files, and 
Fireworks has special features that 
allow it to update images directly on 
Dreamweaver pages.

8. The Extensions column has a list of 
graphic and media types. Click to select 
the media type for which you want to 
assign an external editor.

If the media type has an editor already 
assigned, that editor appears in the  
Editors column.

or

To add a media type, click the plus (+) 
button above the Extensions column. 
A new entry appears at the bottom of 
the Extensions column. Type a new 
extension for the new media type B.

9. To add an editor, click the plus (+) but-
ton above the Editors column.

The Select External Editor dialog 
appears. Navigate to the program you 
want to use and click Open.

10. Repeat steps 8 and 9 for the rest of the 
media types in the Extensions column.

11. Click OK to dismiss the Preferences 
dialog.

If you prefer to use Adobe Photoshop 
as your image editor, set it to be the external 
image editor for JPEG, GIF, and PNG files.

Dreamweaver can make some edits to 
graphics files itself, including resizing, adjust-
ing brightness and contrast, cropping, and 
more. See Chapter 5 for more information.

B When you add a 
new file extension, 
you enter it at 
the bottom of the 
Extensions column.
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Editing Images 
with Fireworks
You can use Adobe Fireworks to edit 
images on your Dreamweaver pages, and 
the two programs work together to make 
it easier. When you start editing an image 
in Dreamweaver, Dreamweaver hands the 
image off to Fireworks. It’s in Fireworks that 
you’ll make the changes you want. Then 
you tell Fireworks that you’re done editing 
the image and you want to go back to 
Dreamweaver. Fireworks saves the image 
and sends it back to Dreamweaver, which 
then updates the Web page with the modi-
fied image.

You can also have Fireworks objects on 
your Web pages, and Dreamweaver opens 
Fireworks when you need to make any 
changes to those objects. For example, 
in Fireworks you can create navigation 
bars complete with links and rollover 
effects. Fireworks saves these navigation 
bars as HTML and CSS, with associated 
images. Fireworks makes it easy to export 
its navigation bars to Dreamweaver, and 
Dreamweaver recognizes that the naviga-
tion bar was created in Fireworks, so that 
when you attempt to edit the navigation 
bar in Dreamweaver, Fireworks automati-
cally launches.

In order to edit images in Fireworks, it 
must be selected as the external editor in 
Dreamweaver’s Preferences dialog for the 
particular image file type you want to edit. 
See “Assigning External Editing Programs,” 
earlier in this chapter, for more information.
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To edit images with Fireworks:
1. Select the image on the Dreamweaver 

page.

2. Click the Edit button in the Property 
Inspector A.

Fireworks launches and displays the 
Find Source dialog. This gives you the 
choice to edit a PNG file that could be 
the original Fireworks file B. That’s 
because PNG is Fireworks’ native 
format, and files that you create in 
Fireworks are saved as PNGs and then, 
if necessary, exported to JPEG or GIF 
for use on your Web site. Fireworks pro-
vides more editing options for PNG files 
than it does for other formats. So if you 
create images in Fireworks, you can 
often have two copies of the image: the 
PNG source and the exported JPEG or 
GIF.

3. If you originally created the image in 
Fireworks and want to edit the PNG, 
click Use a PNG.

The Open dialog appears. Navigate 
to the PNG file, select it, and click OK 
(Choose).

or

If you want to edit the file itself, click 
Use This File.

The image opens in Fireworks C.

Note that a status bar appears in the 
Fireworks document window and 
includes a Done button and the nota-
tion “Editing from Dreamweaver.”

4. Make your changes in Fireworks.

A Click the Edit button in the 
Property Inspector to begin 
modifying an image with Fireworks 
(top). If Photoshop is set as the 
external file editor for the kind of 
image file you have selected, the 
Photoshop icon appears in the 
Property inspector instead (bottom).

B Fireworks gives you the choice to edit the file 
in the Dreamweaver page or to edit a Fireworks 
PNG source file.

C When you are editing an image from 
Dreamweaver, Fireworks lets you know in a status 
bar at the top of the Fireworks document window 
and includes a Done button.
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5. Click Done in the Fireworks window.

Fireworks saves and closes the image. 
Behind the scenes, it has told Dream-
weaver to update the image on the 
Dreamweaver document page.

6. Switch back to Dreamweaver to con-
tinue your work.

The updated image will be on the page.

To export Fireworks HTML 
to Dreamweaver:
1. In Fireworks, prepare and save the doc-

ument (such as a navigation bar) that 
you want to export to Dreamweaver D.

2. Choose File > Export.

The Export dialog appears E.

3. Navigate to the place in your local site 
folder where you want to save the Fire-
works HTML file.

4. (Optional, but recommended) Select 
the “Put images in subfolder” check 
box, then click Browse and select the 
images directory, so that the different 
images that make up the Fireworks 
table don’t clutter up the root directory 
of your site.

5. Click Save.

Fireworks saves the HTML and associ-
ated images in your site folder.

D This navigation bar in Fireworks is destined for 
Dreamweaver.

E Use the Export feature to begin sending the 
navigation bar to Dreamweaver.
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To edit a Fireworks image or table:
1. In Dreamweaver, select the image or 

table that was originally created in 
Fireworks.

Dreamweaver shows you in the Prop-
erty inspector that the object came from 
Fireworks, and it shows you in the Src 
field the name of the original Fireworks 
PNG file F.

2. Click the Edit button in the Property 
inspector.

or

Right-click, and choose Edit in Fireworks 
from the resulting context menu.

Fireworks launches and displays the 
PNG file for the object you wish to 
edit G. A status bar appears in the Fire-
works document window, with a Done 
button and the notation “Editing from 
Dreamweaver.”

3. Make the changes you want in 
Fireworks.

4. Click Done in the Fireworks window.

Fireworks saves and closes the object 
or table. Behind the scenes, it has told 
Dreamweaver to update the object on 
the Dreamweaver document page.

5. Switch back to Dreamweaver to con-
tinue your work.

The updated object will be on the page.

F The Dreamweaver Property inspector recognizes objects from Fireworks, and it 
shows you the name of the original Fireworks source file in the Src field.

Fireworks source file Edit in Fireworks button
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When Fireworks creates a navigation bar 
(or any complex image that uses scripts), it 
slices the PNG file into many different pieces, 
some of which are buttons and some of which 
are spacers. Some of these pieces also have 
JavaScript associated with them, for func-
tionality such as rollovers. When Fireworks 
exports the navigation bar to Dreamweaver, 
Fireworks converts the format of the slices to 
many different JPEG files and creates a bor-
derless table to contain all the slices H.

Fireworks exports its images to JPEG 
or GIF formats, which are less flexible to edit 
than PNG files. For example, once you have 
exported an image from Fireworks’ native PNG 
format, you can’t easily go back and edit text, 
effects settings, or paths in the artwork. That 
is why it’s important to keep the original PNG 
files, so that you can easily go back and edit 
your work. We recommend that you save your 
original Fireworks PNG files in the same folder 
with the exported files, which usually means 
your site’s images folder. If you don’t want to 
upload the PNG files to your server (there’s 
usually no reason to do so), cloak them, as 
discussed in Chapter 2.

G When you click the Edit in Fireworks button, 
the original PNG file opens for editing in Fireworks.

H We’ve selected the borderless table that 
contains the navigation bar’s components to show 
the slices that Fireworks creates.
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Using Adobe Bridge
When you install Photoshop or Fireworks, 
Adobe Bridge CS6 is also installed. Bridge 
works with most of the Creative Suite com-
ponents and acts as a central repository for 
project files such as graphics. The Bridge 
window shows thumbnails of your images, 
and you can drag images from Bridge and 
drop them on your Web pages in Dream-
weaver (or in other Creative Suite program 
document windows). Bridge provides 
many tools for organizing your project files, 
including searching, sorting, and keywords.

To copy images from Bridge 
to Dreamweaver:
1. In Dreamweaver, open the page that 

will receive the image from Bridge, and 
click to place the insertion point where 
you want the image to appear.

2. Launch Adobe Bridge by choosing 
File > Browse in Bridge.

The Bridge window appears A.

3. In Bridge, navigate to the folder that 
contains the image you want.

A The Adobe Bridge window lets you browse your computer in the left column, shows you thumbnails of 
your content in the center, and shows details of the item you have selected on the right.
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4. In the Content panel, click the image’s 
thumbnail to select it.

5. Drag the thumbnail from Bridge into the 
Dreamweaver document window.

Dreamweaver copies the image into 
your site’s images folder.

6. The Image Tag Accessibility Attributes 
dialog appears B. This is another 
dialog where you can enter descriptive 
alternate text.

7. Enter the description for the image, 
then click OK.

The image from Bridge appears on your 
Web page.

You can use Bridge to organize other 
file types besides images. If you insert a 
non-image file, such as HTML, MP3, PDF, or a 
file with an unknown file type, Dreamweaver 
inserts a link to the source file.

B It’s a good idea to always enter alternate text 
for images.
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Cleaning Up 
Word HTML
Back in Chapter 4, you learned how to 
bring content from Microsoft Word into 
Dreamweaver with the Paste Special com-
mand, which allows you to preserve varying 
amounts of the formatting from the Word 
document. By using the Paste Special com-
mand, you will get very good results.

There’s another way to get content from 
Word into Dreamweaver, though we don’t 
recommend it. We are only telling you 
because you might have to deal with it 
anyway. Word can export its files as HTML 
documents, which can then be opened in 
Dreamweaver. The problem is that when 
Word (and other Microsoft Office applica-
tions) saves a document as a Web page, 
the HTML code created includes lots of 
excess or Microsoft-specific code that is 
designed to enable these Web pages to 
be brought back into Word or Excel more 
easily, but that most browsers don’t need. 
This excess code can easily bloat the size 
of a Web page to two or three times the 
size of a Web page created entirely in 
Dreamweaver.

Happily, Dreamweaver has the ability to 
import a Word HTML document and clean 
up its code. It does this by eliminating 
Word-specific styles, removing nonstan-
dard CSS, getting rid of empty paragraphs, 
deleting Microsoft-specific XML tags, and 
more. In short, if you have been given 
Word documents that were exported to 
HTML, Dreamweaver has the means to 
clean them up.
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To clean up a Word HTML document:
1. Open the Word HTML document.

The document appears on the screen.

2. Choose Commands > Clean Up Word 
HTML.

The Clean Up Word HTML dialog 
appears A. Dreamweaver automati-
cally detects whether the HTML was 
produced by Word 97/98 or Word 2000 
or later.

3. Choose to turn on or off any of the 
options on the Basic or Detailed tabs of 
the dialog.

By default, all of the options are turned 
on. We recommend that you leave things 
this way, unless you know that there are 
specific options you don’t need.

4. Click OK.

Dreamweaver processes the Word 
HTML document, then displays a 
dialog summarizing the results of the 
process B.

5. Click OK.

The converted document appears in 
the Dreamweaver document window.

The Paste Special command does a bet-
ter job of preserving the original formatting 
and styling of the Word document than the 
Clean Up Word HTML command.

Long Word documents may take more 
than a minute to complete processing, 
depending on the size of the document and 
the speed of your computer.

A Use the Clean Up Word HTML command to 
optimize the HTML from Word documents that 
were exported as Web pages.

B Dreamweaver lets you know the changes it 
made in the Word document.

There is a third way to bring Word or Excel 
documents into Dreamweaver for Windows, 
but again, we don’t recommend it. You can 
choose File > Import > Word Document or 
File > Import > Excel Document. After choos-
ing the document you want from an Open 
dialog, Dreamweaver converts the document 
and inserts its contents into the current page. 
Unfortunately, you get approximately the same 
quality results as you would get if you exported 
the Word or Excel document to HTML, imported 
it into Dreamweaver, then used the Clean Up 
Word HTML command—which is to say, not as 
good as if you had used Paste Special.
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Using Content 
from Excel
There are two kinds of information that you 
might want to use from Microsoft Excel on 
your Web pages. First, you may want the 
information in the worksheet—the data and 
calculations that make up all or part of the 
worksheet. Second, you may wish to place 
a graph taken from an Excel worksheet on 
a Web page.

In both cases, you’ll copy and paste the 
information from Excel into your Dream-
weaver document.

To import Excel worksheet data:
1. In the Excel worksheet, select the infor-

mation you want to bring into Dream-
weaver A.

2. Choose Edit > Copy, or press Ctrl-C 
(Cmd-C).

3. Switch to Dreamweaver.

4. Click in the document at the insertion 
point where you want the Excel informa-
tion to appear.

5. Choose Edit > Paste Special.

The Paste Special dialog appears B. 
This dialog has four choices. The first 
choice, “Text only,” pastes all the infor-
mation from the worksheet into a single 
line. This jumbles all the information 
together, so don’t use it. The next three 
choices paste the worksheet informa-
tion as a table, retaining increasing 
amounts of formatting information from 
the original worksheet. In most cases, 
you’ll find that the best choice is “Text 
with structure plus full formatting.”

A Begin importing Excel worksheet data into 
Dreamweaver by selecting and copying the 
information in Excel.

B Use the Paste Special dialog to control how 
much formatting you want to maintain from the 
Excel worksheet.
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6. Choose the formatting option you want.

7. Click OK.

Dreamweaver pastes the Excel informa-
tion into the document as a table C. 
In the figure, note that Dreamweaver 
preserved all the original formatting, 
including the bold text.

If you want to style the worksheet in 
Dreamweaver after import, you should use 
the “Text with structure plus basic format-
ting” choice in the Paste Special dialog. The 
reason is that the “Text with structure plus full 
formatting” choice creates CSS styles in your 
Dreamweaver document that make it difficult 
to restyle the table.

To import an Excel chart:
1. In the Excel worksheet, select the chart 

you want to bring into Dreamweaver D.

2. Choose Edit > Copy, or press Ctrl-C 
(Cmd-C).

3. Switch to Dreamweaver.

4. Click in the Dreamweaver document to 
set the insertion point where you want 
the Excel chart to appear.

continues on next page

C The Excel worksheet data appears in 
Dreamweaver as a table.

D Begin bringing an Excel chart into 
Dreamweaver by selecting and copying the chart 
in Excel.
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5. Choose Edit > Paste, or press Ctrl-V 
(Cmd-V).

The Image Optimization dialog 
appears E.

6. Make any format adjustments you want 
in the Image Optimization dialog.

7. Click OK.

The Save Web Image dialog appears.

8. Give the image a name, and navigate 
to where you want to save it (usually 
inside your site’s images folder).

9. Click Save.

The Image Description (Alt Text) dialog 
appears. Alternate text is used by 
screen reading programs utilized by the 
visually impaired.

10. Enter the description for the image, 
then click OK.

11. The chart appears in the Dreamweaver 
document F.

E You can make adjustments to the chart image 
in the Image Optimization dialog.

F The Excel chart ends up on the Dreamweaver 
page as a graphic.
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Working with 
Contribute
One of the difficulties faced by Web 
designers is the problem of maintaining a 
Web site in good order after you launch 
the site. Because Web sites need constant 
changing to remain vital, there is a need 
to update content throughout the site on 
a regular basis. But as a designer, you are 
probably reluctant to let everyday users 
make changes and updates to your Web 
sites for fear that minor mistakes will cause 
major problems.

That’s where Adobe Contribute comes in. 
With a combination of Dreamweaver tem-
plates and Contribute, you can allow virtu-
ally anyone who can use a word processor 
to make changes to your Web sites, with-
out the possibility of accidentally breaking 
the site. Contribute users can change page 
content only within the template’s editable 
areas, and the Contribute site administrator 
can restrict the Contribute user’s editing 
abilities. Contribute allows designers to get 
back to the job of designing sites (rather 
than maintaining pages) and allows clients 
to maintain sites themselves (rather than 
trying to track down the designers to make 
small changes).

In Dreamweaver, besides designing your 
pages using Dreamweaver templates (see 
Chapter 16 for more information about 
templates), you need to set some Dream-
weaver preferences so that your site is 
ready for the Contribute user. You can also 
launch Contribute to perform site adminis-
tration from Dreamweaver.
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To set your site to use Contribute:
1. Choose Site > Manage Sites.

The Manage Sites dialog appears A.

2. From the list of sites, select the site that 
you want to enable for Contribute.

3. Click the Edit button (it looks like a pencil).

The familiar Site Setup dialog 
appears. Click the Advanced Settings 
category B.

A In the Manage Sites 
dialog, choose the site for 
which you want to enable 
Contribute compatibility.

B The Site Setup dialog 
allows you to make 
many settings that are 
associated with the 
particular site you chose in 
the Manage Sites dialog.



ptg8274339

Working with Other Applications B3-19

4. In the list on the left side of the dialog, 
click the Contribute category.

The Contribute pane appears C.

5. Select the “Enable Contribute compat-
ibility” check box.

6. In the Site Root URL text box, the URL 
of your site should appear. If it does not, 
enter it now.

7. Click the Test button.

Dreamweaver connects to the Web 
site and confirms that the connection is 
working. Dreamweaver puts up an alert 
box letting you know the connection 
was successful.

8. Click OK to dismiss the confirmation alert.

9. Click Save to dismiss the Site Setup dialog.

To administer a site in Contribute:
1. Choose Site > Manage Sites.

The Manage Sites dialog appears.

2. From the list of sites, select the site that 
you want to enable for Contribute.

3. Click Edit.

The Site Definition dialog appears.

4. In the list on the left side of the dialog, 
click the Contribute category.

The Contribute pane appears C.

5. Click the Administer Site in Contribute 
button.

You must also have a copy of Contrib-
ute on your hard disk. The Administra-
tor Password dialog appears D.

6. Enter your Contribute administrator 
password, and click OK.

The Contribute Administer Website 
dialog appears E.

7. Make any administrative changes you 
desire, then click Save and Close to 
dismiss the Administer Website dialog.

C You enable Contribute compatibility in the 
Contribute pane of the Site Setup dialog.

D Begin administering the Contribute site 
by entering your administrator password.

E Use the Administer Website dialog to adjust 
user roles and permissions.
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Rollback and the Contribute Publishing Server
When you enable Contribute compatibility in Dreamweaver, you are setting up Dreamweaver to 
take advantage of two Contribute features. The first feature is rollbacks.

Contribute has the ability to roll back published pages—that is, revert to previously published ver-
sions of the pages. You can think of it as a sort of “Super Undo” for your Web page. The Contribute 
user can roll back to the last published version, or to any saved version, up to 99 previous versions.  
Enabling Contribute compatibility in Dreamweaver tracks page changes (using Dreamweaver’s 
Design Notes feature) and marks pages as eligible for rollback, whether they are changed in Con-
tribute or Dreamweaver. However, only Contribute users can roll back pages; that functionality isn’t 
built into Dreamweaver.

The other feature is the Contribute Publishing Server (CPS), an Adobe product designed for enter-
prises that have many Contribute users. CPS is a server application, created as a J2EE application, 
that provides central administration, tracks users and user access, and handles publishing activi-
ties for a Web site. The CPS can be installed on Windows, Linux, or Solaris server machines.

The CPS server allows enterprise-sized organizations to deploy Contribute to dozens or hundreds 
of users. The CPS works with standard user directory systems, such as LDAP and Active Directory, 
to easily assign users to what Contribute refers to as user roles, which are the editing permis-
sions granted to individual users. The CPS server also keeps track of page graphs and allows the 
Contribute site administrator to implement a publishing flow for pages. For example, administrators 
can force writers to submit pages to editors for review and approval before publishing the pages to 
the live Web site.

When you enable Contribute compatibility in Dreamweaver, and if you’re using the CPS, Dream-
weaver notifies the CPS every time you do a network operation such as checking in or checking 
out a file.
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