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Who This Book Is For
This book is for the reader who has never used this 
particular technology or software application. It is 
also for readers who want to expand their knowledge.

The Conventions in This Book
1 	 Steps

This book uses a step‐by‐step format to guide you 
easily through each task. Numbered steps are actions 
you must do; bulleted steps clarify a point, step, or 
optional feature; and indented steps give you the 
result.

2 	 Notes
Notes give additional information — special 
conditions that may occur during an operation, a 
situation that you want to avoid, or a cross reference 
to a related area of the book.

3 	 Icons and Buttons
Icons and buttons show you exactly what you need to 
click to perform a step.

4 	 Tips
Tips offer additional information, including warnings 
and shortcuts.

5 	 Bold
Bold type shows command names, options, and text 
or numbers you must type.

6 	 Italics
Italic type introduces and defines a new term.

How to Use This Book

CHAPTER

13Adding Worksheet Graphics

You can improve the look of an Excel worksheet by adding a clip art image to the sheet. Clip art 
refers to small images or artwork that you can insert into your documents. Excel 2016 does not 

come with its own clip art, but it does give you access to online clip art collections that contains 
thousands of images from various categories, such as business, people, nature, and symbols. By 
default, these images are licensed under Creative Commons, so you can use them without charge.

 A Excel displays a list of clip art 
images that match your search 
term.

9 Click the clip art image you 
want to use.

 B The address of the website that 
offers the image appears here.

10 Click Insert.

Insert a Clip Art Image

The Insert Pictures window 
appears.

6 Click Bing Image Search.

7 Use the text box to type a word 
that describes the kind of clip 
art image you want to insert.

8 Click Search ( ).

1 Display the worksheet on which 
you want to insert the clip art 
image.

2 Click the cell where you want 
the upper‐left corner of the 
image to appear.

3 Click the Insert tab.

4 Click Illustrations.

5 Click Online Pictures.

Insert a Clip Art Image

 C Excel inserts the clip art.

Note: If you need to move or size 
the clip art, see the “Move or Resize 
a Graphic” section later in this 
chapter.

What is a Creative Commons license?
Creative Commons (http://creativecommons.org) is a 
non‐pro�t organization that enables artists to license 
their works for other people to use free of charge. 
There are several different Creative Commons licenses, 
so you should visit the website that offers the image 
you select to check the speci�cs of the license.

Can I insert other online images?
Yes. If you have connected your Facebook or your 
Flickr account to Windows 8 or later, you can also 
use the Facebook or Flickr option to choose a 
photo. If you are using a Microsoft account with 
Windows 8 or later, you can use the OneDrive 
option to select an image from your OneDrive.

TIPS

1

2

3 4

5

6
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CHAPTER  1

Working with 
Ranges
In Excel, a range is a collection of two or more cells that you work 
with as a group rather than separately. This enables you to fill the 
range with values, move or copy the range, sort the range data, and 
insert and delete ranges. You learn these and other range techniques 
in this chapter.
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Select a Rectangular Range
1 	Position the mouse ( ) over 

the first cell you want to 
include in the range.

2 	Click and drag the  over the 
cells that you want to include 
in the range.

A 	Excel selects the cells.

3 	Release the mouse button.

Select a Range of Individual 
Cells
1 	Click in the first cell that you 

want to include in the range.

2 	Hold down  and click in each 
of the other cells that you want 
to include in the range.

B 	Each time you click in a cell, 
Excel adds it to the range.

3 	Release .

Select a Range

Select a Range

To work with a range in Excel, you must first select the cells that you want to include in the range. 
After you select the range, you can fill it with data, move it to another part of the worksheet, 

format the cells, and perform the other range‐related tasks that you learn about in this chapter.

You can select a range as a rectangular group of cells, as a collection of individual cells, or as an 
entire row or column.
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CHAPTER

1Working with Ranges

Select an Entire Row
1 	Position the mouse ( ) over the 

header of the row you want to 
select (  changes to ).

2 	Click the row header.

C 	Excel selects the entire row.

	 To select multiple rows, click and 
drag across the row headers or 
hold down  and click each 
row header.

Select an Entire Column
1 	Position the mouse ( ) over the 

header of the column you want 
to select (  changes to ).

2 	Click the column header.

D 	Excel selects the entire column.

	 To select multiple columns, click 
and drag across the column 
headers, or hold down  and 
click each column header.

TIPS
Are there keyboard techniques I can use to 
select a range?
Yes. To select a rectangular range, navigate to the 
first cell that you want to include in the range, 
hold down , and then press  or  to extend 
the selection. To select an entire row, navigate to 
any cell in the row and press  +  . 
To select an entire column, navigate to any cell in 
the column and then press  +  .

Is there an easy way to select every cell in the 
worksheet?
Yes. There are two methods you can use. Either press 

 +  , or click the Select All button ( ) in the 
upper‐left  
corner of the 
worksheet ( A ).
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4 	Release the mouse button.

A 	Excel fills the range with the 
initial cell value.

Fill a Vertical or Horizontal 
Range
1 	In the first cell of the range you 

want to work with, enter the data 
you want to fill.

2 	Position the mouse ( ) over the 
bottom‐right corner of the cell 
(  changes to ).

3 	Click and drag  down to fill a 
vertical range or across to fill  
a horizontal range.

Fill a Range with the Same Data

Fill a Range with the Same Data

If you need to fill a range with the same data, you can save time by getting Excel to fill the range 
for you. The AutoFill feature makes it easy to fill a vertical or horizontal range with the same 

value, but you can also fill any selected range. This method is much faster than manually entering 
the same data in each cell.

See the previous section, “Select a Range,” to learn how to select a range of cells.
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Fill a Selected Range
1 	Select the range you want to fill.

2 	Type the text, number, or other 
data.

3 	Press  +  .

TIP
How do I fill a vertical or horizontal range without also copying the formatting of the original cell?
	 Follow these steps:

1 	Perform steps 1 to 4 to fill the data.

A 	Excel displays the AutoFill Options smart tag ( ).

2 	Click the AutoFill Options .

3 	Click Fill Without Formatting.

	 Excel removes the original cell’s formatting from 
the copied cells.

B 	Excel fills the range with the 
value you typed.
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Fill a Range with a Series of Values

AutoFill a Series of Numeric, 
Date, or Alphanumeric Values
1 	Click in the first cell and type the 

first value in the series.

2 	Click in an adjacent cell and type 
the second value in the series.

3 	Select the two cells.

4 	Position the mouse ( ) over the 
bottom‐right corner of the 
second cell (  changes to ).

5 	Click and drag  down to fill a 
vertical range or across to fill a 
horizontal range.

A 	As you drag through each cell, 
Excel displays the series value 
that it will add to the cell.

6 	Release the mouse button.

B 	Excel fills the range with a series 
that continues the pattern of the 
initial two cell values.

Fill a Range with a Series of Values

If you need to fill a range with a series of values, you can save time by using the AutoFill feature 
to create the series for you. AutoFill can fill a series of numeric values such as 5, 10, 15, 20, and 

so on; a series of date values such as January 1, 2016, January 2, 2016, and so on; or a series of 
alphanumeric values such as Chapter 1, Chapter 2, Chapter 3, and so on.

You can also create your own series with a custom step value, which determines the numeric 
difference between each item in the series.
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1Working with Ranges

Fill a Custom Series  
of Values
1 	Click in the first cell and type 

the first value in the series.

2 	Select the range you want to 
fill, including the initial value.

3 	Click the Home tab.

4 	Click Fill ( ).

5 	Click Series.

	 The Series dialog box appears.

6 	In the Type group, select the  
type of series you want to fill  
(  changes to ).

7 	If you selected Date in  
step 6, select an option  
in the Date unit group  
(  changes to ).

8 	In the Step value text box, 
type the value you want to use.

9 	Click OK.

C 	Excel fills the range with the 
series you created.

TIP
Can I create my own AutoFill series?
Yes. You can create a custom list, which is a series 
of text values. When you add the first value in your 
custom list, you can then use AutoFill to fill a 
range with the rest of the series. Follow these 
steps:

1 	Click the File tab.

2 	Click Options.

	 The Excel Options dialog box appears.

3 	Click Advanced.

4 	Scroll down to the General section and then 
click Edit Custom Lists.

	 The Custom Lists dialog box appears.

5 	Click NEW LIST.

6 	In the List entries box, type each item in your 
list, and press  after each item.

7 	Click Add.

8 	Click OK to return to the Excel Options dialog box.

9 	Click OK.
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Flash Fill a Range

Flash Fill a Range with 
Extracted Data
1 	Make sure the column of original 

data has a heading.

2 	Type a heading for the column of 
extracted data.

3 	Type the first value you want in 
the new column.

4 	Begin typing the second value.

A 	Excel recognizes the pattern and 
displays suggestions for the rest 
of the column.

5 	Press .

B 	Excel flash fills the column with 
the extracted data.

Flash Fill a Range

You can save time and effort by using the Flash Fill feature in Excel to automatically fill a range of 
data based on a sample pattern that you provide.

Although there are many ways to use Flash Fill, the two most common are flash filling a range with 
extracted data and flash filling a range with formatted data. For example, if you have a column of 
full names, you might want to create a new column that includes just the first names extracted from 
the original column. Similarly, if you have a column of phone numbers in the form 1234567890, you 
might want a new column that formats the numbers as (123) 456‐7890.
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Flash Fill a Range with 
Formatted Data
1 	Make sure the column of original 

data has a heading.

2 	Type a heading for the new 
column of formatted data.

3 	Type the first value you want in 
the new column.

4 	Begin typing the second value.

C 	Excel recognizes the pattern and 
displays suggestions for the rest 
of the column.

5 	Press .

D 	Excel flash fills the column with 
the formatted data.

TIPS
Why do I not see the automatic Flash Fill suggestions when 
I type the sample data?
For Flash Fill’s automatic suggestions to appear, you must have 
headings at the top of both the column of original data and 
the column you are using for the filled data. Also, the flash fill 
column must be adjacent to the original column and the 
sample entries you make in the fill column must occur one 
after the other. Finally, note that Flash Fill’s automatic 
suggestions usually only work with text data, not numeric data.

Can I still use Flash Fill even though I 
do not see the automatic suggestions?
Yes, you can still invoke Flash Fill on any 
range by running the Ribbon command. 
In the fill range, type the first value, 
then select that value and the rest of the 
fill range. Click the Data tab and then 
click Flash Fill ( ). Excel flash fills the 
selected range.
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Move a Range
1 	Select the range you want to 

move.

2 	Position the mouse ( ) over  
any outside border of the range 
(  changes to ).

3 	Click and drag the range to the 
new location (  changes to ).

A 	Excel displays an outline of the 
range.

B 	Excel displays the address of the 
new location.

4 	Release the mouse button.

C 	Excel moves the range to the new 
location.

Move or Copy a Range

Move or Copy a Range

If your worksheet is not set up the way you want, you can restructure or reorganize the worksheet 
by moving an existing range to a different part of the sheet.

You can also make a copy of a range, which is a useful technique if you require a duplicate of the 
range elsewhere, or if you require a range that is similar to an existing range. In the latter case, 
after you copy the range, you can then edit the copied version of the data as needed.
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Copy a Range
1 	Select the range you want to copy.

2 	Press and hold .

3 	Position the mouse ( ) over any 
outside border of the range  
(  changes to ).

4 	Click and drag the range to the 
location where you want the copy 
to appear.

D 	Excel displays an outline of the 
range.

E 	Excel displays the address of the 
new location.

5 	Release the mouse button.

6 	Release .

F 	Excel creates a copy of the range 
in the new location.

TIPS
Can I move or copy a range to another 
worksheet?
Yes. Click and drag the range as described in 
this section. Remember to hold down  if you 
are copying the range. Press and hold  and 
then drag the mouse pointer over the tab of the 
sheet you want to use as the destination. Excel 
displays the worksheet. Release  and then 
drop the range on the worksheet.

Can I move or copy a range to another workbook?
Yes. If you can see the other workbook on‐screen, click 
and drag the range as described in this section, and 
then drop it on the other workbook. Remember to hold 
down  if you are copying the range. Otherwise, 
select the range, click the Home tab, click Cut ( ) to 
move the range or Copy ( ) to copy it, switch to the 
other workbook, select the cell where you want the 
range to appear, click Home, and then click Paste ( ).
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Insert a Row or Column

Insert a Row or Column

You can insert a row or column into your existing worksheet data to accommodate more 
information. The easiest way to add more information to a worksheet is to add it to the right 

or at the bottom of your existing data. However, you will often find that the new information you 
need to add fits naturally within the existing data. In such cases, you first need to insert a new row 
or column in your worksheet at the place where you want the new data to appear, and then add the 
new information in the blank row or column.

Insert a Row
1 	Click any cell in the row below 

where you want to insert the 
new row.

2 	Click the Home tab.

3 	Click the Insert .

4 	Click Insert Sheet Rows.

A 	Excel inserts the new row.

B 	The rows below the new row are 
shifted down.

5 	Click the Insert Options smart 
tag ( ).

6 	Select a formatting option for the 
new row (  changes to ).
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TIP
Can I insert more than one row or column at a time?
Yes. You can insert as many new rows or columns as you need. First, select the same number of rows or 
columns that you want to insert. (See the “Select a Range” section earlier in this chapter to learn how to 
select rows and columns.) For example, if you want to insert four rows, select four existing rows. For rows, 
be sure to select existing rows below where you want the new rows inserted and then follow steps 2 to 4 in 
the “Insert a Row” subsection. For columns, be sure to select existing columns to the right of where you 
want to insert the new columns and then follow steps 2 to 4 in the “Insert a Column” subsection.

Insert a Column
1 	Click any cell in the row to the 

right of where you want to insert 
the new column.

2 	Click the Home tab.

3 	Click the Insert .

4 	Click Insert Sheet Columns.

C 	Excel inserts the new column.

D 	The columns to the right of the 
new column are shifted to the 
right.

5 	Click the Insert Options smart  
tag ( ).

6 	Select a formatting option for the 
new column (  changes to ).
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Insert a Cell or Range

Insert a Cell or Range

If you need to add data to an existing range, you can insert a single cell or a range of cells within 
that range. When you insert a cell or range, Excel shifts the existing data to accommodate the 

new cells.

Although it is often easiest to create room for new data within a range by inserting an entire row 
or column, as explained in the previous section, “Insert a Row or Column,” this causes problems 
for some types of worksheet layouts. (See the first tip to learn more.) You can work around such 
problems by inserting just a cell or range.

1 	Select the cell or range where 
you want the inserted cell or 
range to appear.

2 	Click the Home tab.

3 	Click the Insert .

4 	Click Insert Cells.

Note: You can also press  
 +   +  .

www.allitebooks.com
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	 The Insert dialog box appears.

5 	Select the option that 
corresponds to how you want 
Excel to shift the existing cells  
to accommodate your new cells 
(  changes to ).

Note: In most cases, if you selected 
a horizontal range, you should click 
the Shift cells down option; if you 
selected a vertical range, you should 
click the Shift cells right option.

6 	Click OK.

A 	Excel inserts the cell or range.

B 	The existing data is shifted down 
(in this case) or to the right.

7 	Click the Insert Options smart 
tag ( ).

8 	Select a formatting option for the 
new row (  changes to ).

TIPS
Under what circumstances would I insert a cell 
or range instead of inserting an entire row or 
column?
In most cases, it is better to insert a cell or 
range when you have other data either to the left 
or right of the existing range, or above or below 
the range. For example, if you have data to the 
left or right of the existing range, inserting an 
entire row would create a gap in the other data.

How do I know which cells to select to get my 
inserted cell or range in the correct position?
The easiest way to do this is to select the existing cell 
or range that is exactly where you want the new cell 
or range to appear. For example, if you want the new 
range to be A5:B5 as shown in this section’s example, 
you first select the existing A5:B5 range. When you 
insert the new range, Excel shifts the existing cells 
(down in this case) to accommodate it.
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Delete Data from a Range

Delete Data from a Range

If your worksheet has a range that contains data you no longer need, you can delete that data. 
This helps to reduce worksheet clutter and makes your worksheet easier to read.

Note that deleting cell data does not adjust the structure of your worksheet in any way. That is, after 
you delete the cell data, the rest of your worksheet data remains intact and in the same place that it 
was before the data deletion. If you want to delete cells and not just the data within the cells, see 
the following section, “Delete a Range.”

Delete Range Data
1 	Select the range that 

contains the data you want 
to delete.

2 	Click the Home tab.

3 	Click Clear ( ).

4 	Click Clear Contents.

A 	If you want to delete the 
range data and its 
formatting, click Clear All 
instead.
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B 	Excel removes the range data.

Undo Range Data Deletion
1 	Click the Undo .

2 	Click Clear.

Note: If the data deletion was the most recent 
action you performed, you can undo it by pressing 

 +   or by clicking Undo ( ).

C 	Excel restores the data to the range.

TIPS
Are there faster ways to delete the data 
from a range?
Yes. Probably the fastest method is to select 
the range and then press . You can 
also select the range, right‐click any part of 
the range, and then click Clear Contents.

Is it possible to delete a cell’s numeric formatting?
Yes. Select the range with the formatting that you want to 
remove, click Home, click , and then click Clear Formats. 
Excel removes all the formatting from the selected range.  
If you prefer to delete only the numeric formatting, click 
Home, click the Number Format , and then click General.
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Delete a Range

Delete a Range

If your worksheet contains a range that you no longer need, you can delete that range. Note that 
this is not the same as deleting the data within a cell or range, as described in the previous 

section, “Delete Data from a Range.” When you delete a range, Excel deletes not just the data within 
the range, but also the range of cells. Excel then shifts the remaining worksheet data to replace the 
deleted range. Excel displays a dialog box that enables you to choose whether the data is shifted up 
or to the left.

1 	Select the range that you want to 
delete.

2 	Click the Home tab.

3  Click the Delete .

4 	Click Delete Cells.
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	 The Delete dialog box appears.

5 	Select the option that 
corresponds to how you want 
Excel to shift the remaining cells 
after it deletes the range  
(  changes to ).

Note: In most cases, if you have data 
below the selected range, you should 
click the Shift cells up option; if you 
have data to the right of the selected 
range, you should click the Shift 
cells left option.

6 	Click OK.

A 	Excel deletes the range and shifts 
the remaining data.

TIPS
Are there faster ways to delete a range?
Yes. Probably the fastest method is to 
select the range and then press  +  . 
You can also select the range, right‐click 
any part of the range, and then click 
Delete. Both methods display the Delete 
dialog box.

How do I delete a row or column?
To delete a row, select any cell in the row, click the Home 
tab, click the Delete , and then click Delete Sheet Rows. 
To delete a column, select any cell in the column, click the 
Home tab, click the Delete , and then click Delete Sheet 
Columns. Note, too, that you can delete multiple rows or 
columns by selecting at least one cell in each row or column.
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Hide a Row or Column

Hide a Row or Column

If you do not need to see or work with a row or column temporarily, you can make your worksheet 
easier to read and to navigate by hiding the row or column. Hiding a row or column is also useful 

if you are showing someone a worksheet that contains private or sensitive data that you do not want 
the person to see.

Hiding a row or column does not affect other parts of your worksheet. In particular, formulas that 
use or rely on data in the hidden rows and columns still display the same results.

Hide a Row
1 	Click in any cell in the row you 

want to hide.

2 	Click the Home tab.

3 	Click Format.

4 	Click Hide & Unhide.

5 	Click Hide Rows.

Note: You can also hide a row by 
pressing  +  .

A 	Excel removes the row from the 
worksheet display.

B 	Excel displays a double‐line 
border between the surrounding 
row headers to indicate that a 
hidden row lies between them.

	 Another way to hide a row is to 
move the mouse ( ) over the 
bottom edge of the row heading 
(  changes to ), and then 
click and drag the edge up until 
the height displays 0.
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Hide a Column
1 	Click in any cell in the column 

you want to hide.

2 	Click the Home tab.

3 	Click Format.

4 	Click Hide & Unhide.

5 	Click Hide Columns.

Note: You can also hide a column by 
pressing  +  .

TIP
How do I display a hidden row or column?
To display a hidden row, select the row above and the row below the hidden row, click Home, click Format, 
click Hide & Unhide, and then click Unhide Rows. Alternatively, move the mouse ( ) between the 
headings of the selected rows (  changes to ) and then double‐click. To unhide row 1, right‐click the 
top edge of the row 2 header and then click Unhide.

To display a hidden column, select the column to the left and the column to the right of the hidden 
column, click Home, click Format, click Hide & Unhide, and then click Unhide Columns. Alternatively, 
move the  between the headings of the selected columns (  changes to ) and then double‐click. To 
unhide column A, right‐click the left edge of the column B header and then click Unhide.

C 	Excel removes the column from 
the worksheet display.

D 	Excel displays a slightly thicker 
heading border between the 
surrounding columns to indicate 
that a hidden column lies 
between them.

	 Another way to hide a column is 
to move the mouse ( ) over the 
right edge of the column heading 
(  changes to ), and then 
click and drag the edge left until 
the width displays 0.
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Freeze Rows or Columns

Freeze Rows or Columns

You can keep your column labels in view as you scroll the worksheet by freezing the row or rows 
that contain the labels. This makes it easier to review and add data to the worksheet because you 

can always see the column labels.

If your worksheet also includes row labels, you can keep those labels in view as you horizontally 
scroll the worksheet by freezing the column or columns that contain the labels.

Freeze Rows
1 	Scroll the worksheet so that the 

row or rows that you want to 
freeze are visible.

2 	Select the cell in column A that 
is one row below the last row you 
want to freeze.

	 For example, if you want to 
freeze row 1, select cell A2.

3 	Click the View tab.

4 	Click Freeze Panes.

5 	Click Freeze Panes.

	 Excel freezes the rows.
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TIPS
Are there easier methods I can use to freeze just the top row 
or the first column?
Yes. To freeze just the top row, click View, click Freeze Panes, and 
then click Freeze Top Row. To freeze just the first column, click 
View, click Freeze Panes, and then click Freeze First Column. 
Note that in both cases you do not need to select a cell in advance.

How do I unfreeze a row or column?
If you no longer require a row or 
column to be frozen, you can 
unfreeze it by clicking View, clicking 
Freeze Panes, and then clicking 
Unfreeze Panes.

Freeze Columns
1 	Scroll the worksheet so that the 

column or columns that you 
want to freeze are visible.

2 	Select the cell in row 1 that is 
one row to the right of the last 
column you want to freeze.

	 For example, if you want to 
freeze column A, select cell B1.

3 	Click the View tab.

4 	Click Freeze Panes.

5 	Click Freeze Panes.

	 Excel freezes the columns.
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Merge Two or More Cells

Merge Two or More Cells

You can create a single large cell by merging two or more cells. For example, it is common to 
merge several cells in the top row to use as a worksheet title.

Another common reason for merging cells is to create a label that applies to multiple columns of 
data. For example, if you have three columns labeled January, February, and March, you could select 
the three cells in the row above these labels, merge them, and then use the merged cell to add the 
label First Quarter.

1 	Select the cells that you 
want to merge.

2 	Click the Home tab.

3 	Click the Merge & Center .

4 	Click Merge Cells.
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A 	Excel merges the selected cells 
into a single cell.

5 	Type your text in the merged cell.

TIP
How do I center text across multiple columns?
This is a useful technique for your worksheet titles or headings. You can center a title across the entire 
worksheet, or you can center a heading across the columns that it refers to. Follow steps 1 to 3 and then 
click Merge & Center. Excel creates the merged cell and formats the cell with the Center alignment option. 
Any text you enter into the merged cell appears centered within the cell.
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Transpose Rows and Columns

Transpose Rows and Columns

You can use the Transpose command in Excel to easily turn a row of data into a column of data, or 
a column of data into a row of data.

The Transpose command is useful when you enter data into a row (or column) or receive a worksheet 
from another person that has data in a row (or column), and you decide the data would be better 
presented as a column (or row). You can also transpose rows and columns together in a single 
command, which is handy when you need to restructure a worksheet.

1 	Select the range that includes 
the data you want to transpose.

2 	Click the Home tab.

3 	Click Copy ( ).
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TIPS
How do I know which cells to select?
The range you select before copying depends on what 
you want to transpose. If you want to transpose a 
single horizontal or vertical range of cells, then 
select just that range. If you want to transpose a 
horizontal range of cells and a vertical range of cells 
at the same time, select the range that includes all 
the cells, as shown in this section’s example.

Can I transpose range values as well as range 
labels?
Yes. The Transpose command works with text, 
numbers, dates, formulas, and any other data that 
you can add to a cell. So if you have a rectangular 
region of data that includes row labels, column 
labels, and cell values within each row and column, 
you can select the entire range and transpose it.

4 	Click where you want the 
transposed range to appear.

5 	Click the Paste .

6 	Click Transpose ( ).

A 	Excel transposes the data and 
then pastes it to the worksheet.
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Select Data
1 	Tap the first cell you want to 

select.

2 	Tap and hold the lower‐right 
selector, and then slide down 
and/or to the right to extend the 
selection.

3 	Tap and hold the upper‐left 
selector, and then slide up and/
or to the left to extend the 
selection.

Enter and Edit Data
1 	Double‐tap the cell you want to 

use to enter or edit data.

Select and Enter Data Using Touch Gestures

Select and Enter Data Using Touch Gestures

If you will also be working with the Excel app on a touchscreen device, such as an iPad or Surface, 
you need to know how to use touch gestures to select, enter, and edit data. Although you can 

attach external keyboards to these devices, most of the time you might not have access to a physical 
keyboard. In such cases, you need to use touch gestures — tapping, sliding, and so on — to 
manipulate the data that you see on the Excel screen.
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	 The Excel app opens the Formula 
bar for editing and displays the 
on‐screen keyboard.

2 	Using the on‐screen keyboard, 
add or edit the cell data.

Note: To position the cursor within 
the Formula bar, tap and hold inside 
the Formula bar, then slide left or 
right.

A 	Tap Abc or 123 to toggle the 
keyboard between letters and 
numbers.

3 	To confirm the cell entry or edit, 
tap OK ( ).

B 	If you do not want to accept  
the changes to the cell, tap 
Cancel ( ).

TIPS
Is there an easier way to enter a long list of items in a 
column or a row of cells?
Yes. Rather than tapping OK ( ) after each entry, tap 
123 to display the numeric keyboard, and then tap an arrow 
key. The active cell moves in the direction of the arrow or 
to the cell you tapped, and Excel leaves the Formula bar 
open for editing.

Is there an easier way to enter several 
items randomly in a worksheet?
Yes. Instead of tapping OK ( ) after 
each entry, tap the next cell you want to 
use. The active cell moves to the cell you 
tapped, and Excel leaves the Formula bar 
open for editing.
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Working with 
Range Names
You can make it easier to navigate Excel worksheets and build Excel 
formulas by applying names to your ranges. This chapter explains 
range names and shows you how to define, edit, and use range names.
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A range name is a text label that you apply to a single cell or to a range of cells. Once you have 
defined a name for a range, you can use that name in place of the range coordinates, which has 

several benefits. These benefits include making your worksheets more intuitive and making your work 
more accurate. In addition, a range name is easier to remember than range coordinates, it does not 
change when you move the underlying range, and it makes it easier to navigate your worksheets.

Understanding the Benefits of Using Range Names

More Intuitive
Range names are more 
intuitive than range 
coordinates, particularly 
in formulas. For example, 
if you see the range 
B2:B10 in a formula, the 
only way to know what 
the range refers to is to look at the data. However, if you see the name Quarterly_Sales in the formula, then 
you already know what the range refers to.

More Accurate
Range names are more 
accurate than range 
coordinates. For example, 
consider the range address 
A1:B3, which consists of 
four different pieces of 
information: the column 
(A) and row (1) of the cell 
in the upper‐left corner of 
the range, and the column 
(B) and row (3) of the cell in the lower‐right corner. If you get even one of these values wrong, it can cause 
errors throughout a spreadsheet. By contrast, with a range name you need only reference the actual name.
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Easier to Remember
Range names are easier to 
remember than range 
coordinates. For example, 
if you want to use a 
particular range in a 
formula, but that range is 
not currently visible, to 
get the coordinates you 
must scroll until you can 
see the range and then 
determine the range’s coordinates. However, if you have already assigned the range an intuitive name such 
as Project_Expenses, you can add that name directly without having to view the range.

Names Do Not Change
Range names do not change 
when you adjust the position of 
a range, as they do with range 
coordinates. For example, if you 
move the range A1:B5 to the 
right by five columns, the range 
coordinates change to F1:G5.  
If you have a formula that 
references that range, Excel 
updates the formula with the  
new range coordinates, which could confuse someone examining the worksheet. By contrast, a range name 
does not change when you move the range.

Easier Navigation
Range names make it easier to navigate a worksheet. For example,  
Excel has a Go To command that enables you to choose a range name, 
and Excel takes you directly to the range. You can also use the Name box 
to select a range name and navigate to that range. You can also use Go 
To and the Name box to specify range coordinates, but range coordinates 
are much more difficult to work with.
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Define a Range Name

Before you can use a range name in your formulas or to navigate a worksheet, you must first 
define the range name. You can define as many names as you need, and you can even define 

multiple names for the same range.

You can create range names manually, or you can get Excel to create the names for you automatically 
based on the existing text labels in a worksheet. To do this, see the following section, “Using 
Worksheet Text to Define a Range Name.”

Define a Range Name

1 	Select the range you want to 
name.

2 	Click the Formulas tab.

3 	Click Define Name.

www.allitebooks.com
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	 The New Name dialog box appears.

4 	Type the name you want to use in the Name 
text box.

Note: The first character of the name must be a 
letter or an underscore (_). The name cannot 
include spaces or cell references, and it cannot be 
any longer than 255 characters.

Note: You can only use a particular range name 
once in a workbook.

5 	Click OK.

	 Excel assigns the name to the range.

A 	�The new name appears in the Name box 
whenever you select the range.

TIP
Is there an easier way to define a range name?
Yes, you can follow these steps to bypass the New Name dialog box:

1 	Select the range you want to name.

2 	Click inside the Name box.

3 	Type the name you want to use.

4 	Press .

	 Excel assigns the name to the range.
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2 	Click the Formulas tab.

3 	Click Create from Selection.

1 	Select the range or ranges you 
want to name.

A 	Be sure to include the text labels 
you want to use for the range 
names.

Using Worksheet Text to Define a Range Name

Using Worksheet Text to Define a Range Name

If you have several ranges to name, you can speed up the process by getting Excel to create the 
names for you automatically based on each range’s text labels.

You can create range names from worksheet text when the labels are in the top or bottom row of the 
range, or the left or right column of the range. For example, if you have a column named Company, using 
the technique in this section results in that column’s data being assigned the range name “Company.”
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	 The Create Names from Selection dialog 
box appears.

4 	Select the setting or settings that 
correspond to where the text labels  
are located in the selected range  
(  changes to ).

	 If Excel has activated a check box that  
does not apply to your data, deselect it  
(  changes to ).

5 	Click OK.

	 Excel assigns the text labels as range 
names.

B 	When you select one of the ranges, the  
range name assigned by Excel appears in 
the Name box.

Note: If the label text contains any illegal 
characters, such as a space, Excel replaces each 
of those characters with an underscore (_).

TIPS
Is there a faster way to run 
the Create from Selection 
command?
Yes, Excel offers a keyboard 
shortcut for the command.  
Select the range or ranges you 
want to work with and then 
press + + . Excel 
displays the Create Names from 
Selection dialog box. Follow 
steps 4 and 5 to create the 
range names.

Given a table with labels in the top row and left column, is there a 
way to automatically assign a name to the table data?
Yes. The table data refers to the range 
of cells that does not include the table 
headings in the top row and left 
column. To assign a name to the data 
range, type a label in the top‐left 
corner of the table. When you run the 
Create from Selection command  
on the entire table, Excel assigns the 
top‐left label to the data range, as 
shown here.
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A 	Excel selects the range.

Use the Name Box
1 	Open the workbook that contains 

the range you want to work with.

2 	Click the Name box .

3 	Click the name of the range you 
want to select.

Navigate a Workbook Using Range Names

Navigate a Workbook Using Range Names

One of the big advantages of defining range names is that they make it easier to navigate 
a workbook. You can choose a range name from a list and Excel automatically selects the 

associated range. This works even if the named range exists in a different worksheet of the same 
workbook.

Excel offers two methods for navigating a workbook using range names: the Name box and the  
Go To command.
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Use the Go To Command
1 	Open the workbook that contains the range 

you want to work with.

2 	Click the Home tab.

3 	Click Find & Select ( ).

4 	Click Go To.

Note: You can also select the Go To command 
by pressing + .

	 The Go To dialog box appears.

5 	Click the name of the range you want to 
select.

6 	Click OK.

	 Excel selects the range.

	 Replace workbook with the filename of the workbook; 
replace worksheet with the name of the worksheet  
that contains the range; and replace name with the  
range name.

3 	Click OK.

TIP
Is it possible to navigate to a named 
range in a different workbook?
Yes, but it is not easy or straightforward:

1 	Follow steps 1 to 4 in the “Use the  
Go To Command” subsection to display 
the Go To dialog box.

2 	In the Reference text box, type the 
following: ’[workbook]worksheet’!name
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	 The Name Manager dialog 
box appears.

4 	Click the name you want to 
change.

5 	Click Edit.

1 	Open the workbook that 
contains the range name you 
want to change.

2 	Click the Formulas tab.

3 	Click Name Manager.

Change a Range Name

Change a Range Name

You can change any range name to a more suitable or accurate name. Changing a range name is 
useful if you are no longer satisfied with the original name you applied to a range or if the existing 

name no longer accurately reflects the contents of the range. You might also want to change a range 
name if you do not like the name that Excel generated automatically from the worksheet labels.

If you want to change the range coordinates associated with a range name, see the second tip.
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	 The Edit Name dialog box appears.

6 	Use the Name text box to edit the 
name.

7 	Click OK.

A 	The new name appears in the Name 
Manager dialog box.

8 	Click Close.

	 Excel closes the dialog box and 
returns you to the worksheet.

TIPS
Is there a faster method I can use to 
open the Name Manager dialog box?
Yes, Excel offers a shortcut key that 
enables you to bypass steps 2 and 3.  
Open the workbook that contains the range 
name you want to change, and then press 

+ . Excel opens the Name Manager 
dialog box.

Can I assign a name to a different range?
Yes. If you add another range to your workbook and you feel 
that an existing name would be more suited to that range, 
you can modify the name to refer to the new range. Follow 
steps 1 to 5 to open the Edit Name dialog box. Click inside 
the Refers to reference box, click and drag the mouse ( ) 
on the worksheet to select the new range, and then press 

. Click Close.
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	 The Name Manager dialog box 
appears.

4 	Click the name you want to delete.

5 	Click Delete.

1 	Open the workbook that contains the 
range name you want to delete.

2 	Click the Formulas tab.

3 	Click Name Manager.

Note: You can also open the Name 
Manager dialog box by pressing + .

Delete a Range Name

Delete a Range Name

If you have a range name that you no longer need, you should delete it. This reduces clutter in the 
Name Manager dialog box, and makes the Name box easier to navigate.

Note, however, that deleting a range name will generate an error in any formula that uses the name. 
This occurs because when you delete a range name, Excel does not convert the name to its range 
coordinates in formulas that use the name. Therefore, before deleting a range name, you should 
convert that name to its range coordinates in every formula that uses the name.
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	 Excel asks you to confirm the 
deletion.

6 	Click OK.

A 	Excel deletes the range name.

7 	Click Close.

	 Excel closes the dialog box and 
returns you to the worksheet.

TIP
Is there a faster way to delete multiple range names?
Yes, you can delete two or more range names at once. First, follow steps 1 to 3 to display the Name 
Manager dialog box. Next, select the range names you want to delete: To select consecutive names, click 
the first name you want to delete, hold down , and then click the last name you want to delete; to 
select nonconsecutive names, hold down  and click each name you want to delete. When you have 
selected the names you want to remove, click Delete and then click OK when Excel asks you to confirm the 
deletion. Click Close to return to the worksheet.
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3 	Click the Formulas tab.

4 	Click Use in Formula.

5 	Click Paste Names.

1 	Open the workbook that 
contains the range names you 
want to paste.

2 	Select the cell where you want 
the pasted list to appear.

Note: Excel will overwrite existing 
data, so select a location where 
there is no existing cell data or 
where it is okay to delete the 
existing cell data.

Paste a List of Range Names

Paste a List of Range Names

To make your workbook easier to use, particularly for other people who are not familiar with the 
names you have defined, you can paste a list of the workbook’s range names to a worksheet. This 

is also useful for a workbook you have not used in a while. Examining the list of range names can 
help you familiarize yourself once again with the workbook’s contents.

The pasted list contains two columns: one for the range names and one for the range coordinates 
associated with each name.
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	 The Paste Name dialog box 
appears.

6 	Click Paste List.

	 Excel closes the Paste Name  
dialog box.

A 	Excel pastes the list of range 
names to the worksheet.

TIP
Is there a faster method I can use to paste a list of range names?
Yes, Excel offers a handy keyboard shortcut that you can use. Open the workbook that contains the range 
names you want to paste, and then select the cell where you want the pasted list to appear. Press  to 
open the Paste Name dialog box, and then click Paste List.



CHAPTER  3

Formatting 
Excel Ranges
Microsoft Excel 2016 offers many commands and options for 
formatting ranges, including the font, text color, text alignment, 
background color, number format, column width, row height, 
and more.
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Change the Font and Font Size

Change the Font
1 	Select the range you want to format.

2 	Click the Home tab.

3 	Click  in the Font list.

A 	When you use the mouse  to point to a 
typeface, Excel temporarily changes the 
selected text to that typeface.

4 	Click the typeface you want to apply.

B 	Excel applies the font to the text in the 
selected range.

Change the Font and Font Size

When you work in an Excel worksheet, you can add visual appeal to a cell or range by changing 
the font. In this section and throughout this book, the term font is synonymous with typeface, 

and both terms refer to the overall look of each character.

You can also make labels and other text stand out from the rest of the worksheet by changing the 
font size. The font size is measured in points, where there are roughly 72 points in an inch.
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TIPS
In the Theme Fonts section of the Font list, what do 
the designations Body and Headings mean?
When you create a workbook, Excel automatically applies 
a document theme to the workbook, and that theme 
includes predefined fonts. The theme’s default font is 
referred to as Body, and it is the font used for regular 
worksheet text. Each theme also defines a Headings font, 
which Excel uses for cells formatted with a heading or 
title style.

Can I change the default font and font 
size?
Yes. Click the File tab and then click Options 
to open the Excel Options dialog box. Click 
the General tab, click the Use this as the 
default font , and then click the typeface 
you want to use as the default. Click the 
Font size  and then click the size you 
prefer to use as the default. Click OK.

Change the Font Size
1 	Select the range you want to 

format.

2 	Click the Home tab.

3 	Click  in the Font Size list.

C 	When you use the mouse  to 
point to a font size, Excel 
temporarily changes the selected 
text to that size.

4 	Click the size you want to apply.

D 	You can also type the size you 
want in the Size text box.

E 	Excel applies the font size to the 
text in the selected range.
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You can improve the look and impact of text in an Excel worksheet by applying font effects to a 
cell or to a range.

Font effects include common formatting such as bold, which is often used to make labels stand out 
from regular text; italic, which is often used to add emphasis to text; and underline, which is often 
used for worksheet titles and headings. You can also apply special effects such as strikethrough, 
superscripts (for example, x2+y2), and subscripts (for example, H2O).

1 	Select the range you want to 
format.

2 	Click the Home tab.

3 	To format the text as bold, click 
the Bold button ( ).

A 	Excel applies the bold effect to 
the selected range.

4 	To format the text as italic, click 
the Italic button ( ).

5 	To format the text as underline, 
click the Underline button ( ).

B 	Excel applies the effects to the 
selected range.

6 	Click the Font dialog box 
launcher ( ).

Apply Font Effects

Apply Font Effects
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TIP
Are there any font‐related keyboard shortcuts I can use?
Yes. Excel supports the following font shortcuts:

Press To
+ Toggle the selected range as bold
+ Toggle the selected range as italic
+ Toggle the selected range as underline
+ Toggle the selected range as strikethrough
+ Display the Format Cells dialog box

8 	To format the text as a superscript, click 
Superscript (  changes to ).

C 	To format the text as a subscript, click 
Subscript (  changes to ).

9 	Click OK.

	 Excel applies the font effects.

	 The Format Cells dialog box appears with the 
Font tab displayed.

7 	To format the text as strikethrough, click 
Strikethrough (  changes to ).
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4 	Click a theme color.

A 	Alternatively, click one of the 
Excel standard colors.

B 	Excel applies the color to the 
selected range.

Select a Theme or Standard 
Color
1 	Select the range you want to 

format.

2 	Click the Home tab.

3 	Click  in the Font Color 
list ( ).

Change the Font Color

When you work in an Excel worksheet, you can add visual interest by changing the font color. 
Most worksheets are meant to convey specific information, but that does not mean the sheet 

has to be plain. By adding a bit of color to your text, you make your worksheets more appealing. 
Adding color can also make the worksheet easier to read by, for example, differentiating titles, 
headings, and labels from regular text.

You can change the font color by applying a color from the workbook’s theme, from the Excel palette 
of standard colors, or from a custom color that you create.

Change the Font Color
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TIP
How can I make the best use of fonts in my documents?
•	 Do not use many different typefaces in a single document. Stick to one, or at most two, typefaces to 

avoid the ransom note look.

•	 Avoid overly decorative typefaces because they are often difficult to read.

•	 Use bold only for document titles, subtitles, and headings.

•	 Use italics only to emphasize words and phrases, or for the titles of books and magazines.

•	 Use larger type sizes only for document titles, subtitles, and, possibly, the headings.

•	 If you change the text color, be sure to leave enough contrast between the text and the background. 
In general, dark text on a light background is the easiest to read.

	 The Colors dialog box appears.

5 	Click the color you want to 
use.

C 	You can also click the Custom 
tab and then either click the 
color you want or enter the 
values for the Red, Green, and 
Blue components of the color.

6 	Click OK.

	 Excel applies the color to the 
selected range.

Select a Custom Color
1 	Select the range you want to 

format.

2 	Click the Home tab.

3 	Click  in the Font Color list 
( ).

4 	Click More Colors.
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	 Excel aligns the data horizontally 
within each selected cell.

A 	In this example, the data in the  
cells is centered.

Align Text Horizontally
1 	Select the range you want to format.

2 	Click the Home tab.

3 	In the Alignment group, click the 
horizontal alignment option you want 
to use:

	 Click Align Text Left ( ) to align 
data with the left side of each cell.

	 Click Center ( ) to align data with 
the center of each cell.

	 Click Align Text Right ( ) to align 
data with the right side of each cell.

Align Text Within a Cell

You can make your worksheets easier to read by aligning text and numbers within each cell. By 
default, Excel aligns numbers with the right side of the cell, and it aligns text with the left side 

of the cell. You can also align numbers or text with the center of each cell.

Excel also allows you to align your data vertically within each cell. By default, Excel aligns all data 
with the bottom of each cell, but you can also align text with the top or middle.

Align Text Within a Cell
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TIPS
How do I format text so that it aligns with both 
the left and right sides of the cell?
This is called justified text, and it is useful if you 
have a lot of text in one or more cells. Select the 
range, click the Home tab, and then click the dialog 
box launcher ( ) in the Alignment group. The 
Format Cells dialog box appears with the Alignment 
tab displayed. In the Horizontal list, click  and 
then click Justify. Click OK to justify the cells.

How do I indent cell text?
Select the range you want to indent, click the Home 
tab, and then click the Alignment group’s dialog 
box launcher ( ). In the Alignment tab, click the 
Horizontal list  and then click Left (Indent). 
Use the Indent text box to type the indent, in 
characters, and then click OK. You can also click the 
Increase Indent ( ) or Decrease Indent ( ) 
button in the Home tab’s Alignment group.

Align Text Vertically
1 	Select the range you want to 

format.

2 	Click the Home tab.

3 	In the Alignment group, click the 
vertical alignment option you 
want to use:

	 Click Top Align ( ) to align data 
with the top of each cell.

	 Click Middle Align ( ) to align 
data with the middle of each cell.

	 Click Bottom Align ( ) to align 
data with the bottom of each 
cell.

	 Excel aligns the data vertically 
within each selected cell.

B 	In this example, the text is 
aligned with the middle of 
the cell.
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2 	Click the Home tab.

3 	In the Alignment group, click 
the dialog box launcher ( ).

1 	Select a range that consists of 
the text you want to work with 
and the cells across which you 
want to center the text.

Center Text Across Multiple Columns

You can make a worksheet more visually appealing and easier to read by centering text across 
multiple columns. This feature is most useful when you have text in a cell that you use as a label 

or title for a range. Centering the text across the range makes it easier to see that the label or title 
applies to the entire range.

Center Text Across Multiple Columns
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A 	Excel centers the text across the 
selected cells.

	 Excel opens the Format Cells dialog  
box with the Alignment tab displayed.

4 	Click the Horizontal  and then  
click Center Across Selection.

5 	Click OK.

TIP
Is there an easier way to center text across multiple columns?
Yes, although this technique also merges the selected cells 
into a single cell. (See Chapter 1 to learn more about 
merging cells.) Follow these steps:

1 	Repeat steps 1 and 2.

2 	In the Alignment group, click the Merge & Center  
button ( ).

	 Excel merges the selected cells into a single cell and 
centers the text within that cell.
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	 The Format Cells dialog box 
appears with the Alignment tab 
displayed.

5 	Click an orientation marker.

B 	You can also use the Degrees 
spin box to type or click a 
degree of rotation (see the tip).

1 	Select the range containing the 
text you want to angle.

2 	Click the Home tab.

3 	Click Orientation ( ).

A 	If you want to use a predefined 
orientation, click one of the 
menu items and skip the rest of 
the steps.

4 	Click Format Cell Alignment.

Rotate Text Within a Cell

You can add visual interest to your text by slanting the text upward or downward in the cell. You 
can also use this technique to make a long column heading take up less horizontal space on the 

worksheet.

You can choose a predefined rotation, or you can make cell text angle upward or downward by 
specifying the degrees of rotation.

Rotate Text Within a Cell
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TIP
How does the Degrees spin box work?
If you use the Degrees spin box to set the text orientation, you can set the orientation to a positive 
number, such as 25, and Excel angles the text in an upward (counterclockwise) direction. If you set the text 
orientation to a negative number, such as –40, Excel angles the text in a downward (clockwise) direction.

You can specify values in the range from 90 degrees (which is the same as clicking the Rotate Text Up 
command in the Orientation menu) to –90 degrees (which is the same as clicking the Rotate Text Down 
command).

D 	Excel rotates the cell text.

E 	The row height automatically 
increases to contain the slanted 
text.

F 	You can reduce the column width 
to free up space and make your 
cells more presentable.

C 	You can click the vertical text area  
to display your text vertically  
instead of horizontally in the cell.

6 	Click OK.
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4 	Click a theme color.

A 	Alternatively, click one of the 
standard Excel colors.

B 	Excel applies the color to the 
selected range.

C 	To remove the background color 
from the range, click No Fill.

Select a Theme or Standard 
Color
1 	Select the range you want to 

format.

2 	Click the Home tab.

3 	Click  in the Fill Color list ( ).

Add a Background Color to a Range

You can make a range stand out from the rest of the worksheet by applying a background color to 
the range. Note, however, that if you want to apply a background color to a range based on the 

values in that range — for example, red for negative values and green for positive — it is easier 
to apply a conditional format, as described in the “Apply a Conditional Format to a Range” section, 
later in this chapter.

You can change the background color by applying a color from the workbook’s theme, from the Excel 
palette of standard colors, or from a custom color that you create.

Add a Background Color to a Range
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TIPS
Are there any pitfalls to watch out for when I 
apply background colors?
Yes. The biggest pitfall is applying a background 
color that clashes with the range text. For 
example, the default text color is black, so if you 
apply any dark background color, the text will be 
very difficult to read. Always use either a light 
background color with dark‐colored text, or a dark 
background color with light‐colored text.

Can I apply a background that fades from one color 
to another?
Yes. This is called a gradient effect. Select the range, 
click the Home tab, and then click the Font group’s 
dialog box launcher ( ). Click the Fill tab and then 
click Fill Effects. In the Fill Effects dialog box, use 
the Color 1  and the Color 2  to choose your 
colors. Click an option in the Shading styles section 
(  changes to ), and then click OK.

	 The Colors dialog box appears.

5 	Click the color you want to use.

D 	You can also click the Custom 
tab and then either click the 
color you want or enter the 
values for the Red, Green, and 
Blue components of the color.

6 	Click OK.

	 Excel applies the color to the 
selected range.

Select a Custom Color
1 	Select the range you want to 

format.

2 	Click the Home tab.

3 	Click  in the Fill Color list  
( ).

4 	Click More Colors.
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2 	Click the Home tab.

3 	Click the Number Format .

4 	Click the number format you want 
to use.

1 	Select the range you want to format.

Apply a Number Format

You can make your worksheet easier to read by applying a number format to your data. For 
example, if your worksheet includes monetary data, you can apply the Currency format to display 

each value with a dollar sign and two decimal places.

Excel offers ten number formats, most of which apply to numeric data. However, you can also apply 
the Date format to date data, the Time format to time data, and the Text format to text data.

Apply a Number Format
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TIP
Is there a way to get more control over the number formats?
Yes. You can use the Format Cells dialog box to control properties such as the display of negative numbers, 
the currency symbol used, and how dates and times appear. Follow these steps:

1 	Select the range you want to format.

2 	Click the Home tab.

3 	Click the Number group’s dialog box 
launcher ( ).

	 The Format Cells dialog box appears with the 
Number tab displayed.

4 	In the Category list, click the type of 
number format you want to apply.

5 	Use the controls that Excel displays to 
customize the number format.

	 The controls you see vary, depending on the 
number format you chose in step 4.

6 	Click OK.

	 Excel applies the number format.

A 	Excel applies the number 
format to the selected range.

B 	For monetary values, you can 
also click Accounting 
Number Format ( ).

C 	For percentages, you can also 
click Percent Style ( ).

D 	For large numbers, you can 
also click Comma Style ( ).
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A 	Excel decreases the number of 
decimal places by one.

4 	Repeat step 3 until you get 
the number of decimal places 
you want.

Decrease the Number of 
Decimal Places
1 	Select the range you want to 

format.

2 	Click the Home tab.

3 	Click the Decrease Decimal 
button ( ).

Change the Number of Decimal Places Displayed

You can make your numeric values easier to read and interpret by adjusting the number of decimal 
places that Excel displays. For example, you might want to ensure that all dollar‐and‐cent values 

show two decimal places, while dollar‐only values show no decimal places. Similarly, you can adjust 
the display of percentage values to suit your audience by showing more decimals (greater accuracy 
but more difficult to read) or fewer decimals (less accuracy but easier to read).

You can either decrease or increase the number of decimal places that Excel displays.

Change the Number of Decimal Places Displayed
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TIP
My range currently has values that display different numbers of decimal places. What happens when I 
change the number of decimal places?
In this situation, Excel uses the value that has the most displayed decimal places as the basis for format-
ting all the values. For example, if the selected range has values that display no, one, two, or four decimal 
places, Excel uses the value with four decimals as the basis. If you click Decrease Decimal, Excel displays 
every value with three decimal places; if you click Increase Decimal, Excel displays every value with five 
decimal places.

B 	Excel increases the number of 
decimal places by one.

4 	Repeat step 3 until you get the 
number of decimal places you 
want.

Increase the Number of 
Decimal Places
1 	Select the range you want to 

format.

2 	Click the Home tab.

3 	Click the Increase Decimal 
button ( ).
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2 	Click AutoFormat ( ).

Note: See the second tip to learn how 
to add a button to the Quick Access 
Toolbar. In this case, you must add the 
AutoFormat button.

1 	Select the range you want to 
format.

Apply an AutoFormat to a Range

You can save time when formatting your Excel worksheets by using the AutoFormat feature. This 
feature offers a number of predefined formatting options that you can apply to a range all at 

once. The formatting options include the number format, font, cell alignment, borders, patterns, row 
height, and column width.

The AutoFormats are designed for data in a tabular format, particularly where you have headings in 
the top row and left column, numeric data in the rest of the cells, and a bottom row that shows the 
totals for each column.

Apply an AutoFormat to a Range
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TIPS
Is there a way to apply an AutoFormat without 
using some of its formatting?
Yes. Follow steps 1 to 3 to choose the AutoFormat 
you want to apply. Click Options to expand the 
dialog box and display the Formats to apply 
group. Deselect the option for each format you do 
not want to apply (  changes to ), and then 
click OK.

How do I add a button to the Quick Access 
Toolbar?
Click the Customize Quick Access Toolbar button 
( ). If you see the command you want, click it; 
otherwise, click More Commands. Click the Choose 
commands from , click the category you want to 
use, click the command you want to add, click Add, 
and then click OK.

A 	Excel applies the AutoFormat to 
the selected range.

Note: If you do not like or no longer 
need the AutoFormat you applied to 
the cells, you can revert them to a 
plain, unformatted state. Select the 
range and then click  to display 
the AutoFormat dialog box. At the 
bottom of the format list, click 
None, and then click OK. Excel 
removes the AutoFormat from the 
selected range.

	 The AutoFormat dialog box  
appears.

3 	Click the AutoFormat you  
want to use.

4 	Click OK.
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	 An operator dialog box appears, 
such as the Greater Than dialog 
box shown here.

6 	Type the value you want to use 
for your condition.

A 	You can also click the Collapse 
Dialog button ( ) and then 
click a worksheet cell.

	 Depending on the operator, you 
may need to specify two values.

7 	Click the with  and then click 
the formatting you want to use.

B 	To create your own format, click 
Custom Format.

1 	Select the range you want to 
work with.

2 	Click the Home tab.

3 	Click Conditional Formatting.

4 	Click Highlight Cells Rules.

5 	Click the operator you want to 
use for your condition.

Apply a Conditional Format to a Range

You can make a worksheet easier to analyze by applying a conditional format to a range. A 
conditional format is formatting that Excel applies only to cells that meet the condition you 

specify. For example, you can tell Excel to apply the formatting only if a cell’s value is greater than 
some specified amount.

When you set up your conditional format, you can specify the font, border, and background pattern, 
which helps to ensure that the cells that meet your criteria stand out from the other cells in the 
range.

Apply a Conditional Format to a Range
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TIPS
Can I set up more than one condition for a 
single range?
Yes. Excel enables you to specify multiple 
conditional formats. For example, you could set 
up one condition for cells that are greater than 
some value, and a separate condition for cells 
that are less than some other value. You can 
apply unique formats to each condition. Follow 
steps 1 to 8 to configure the new condition.

How do I remove a conditional format from a range?
If you no longer require a conditional format, you can 
delete it. Follow steps 1 to 3 to select the range and 
display the Conditional Formatting menu, and then click 
Manage Rules. Excel displays the Conditional Formatting 
Rules Manager dialog box. Click the Show formatting 
rules for  and then click This Worksheet. Click the 
conditional format you want to remove and then click 
Delete Rule. Click OK to return to the worksheet.

C 	Excel applies the formatting to 
cells that meet your condition.

8 	Click OK.
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2 	Click the Home tab.

3 	Click Cell Styles.

1 	Select the range you want to 
format.

Apply a Style to a Range

You can reduce the time it takes to format your worksheets by applying the predefined Excel styles 
to your ranges. Excel comes with more than 20 predefined styles for different worksheet elements 

such as headings, numbers, calculations, and special range types such as explanatory text, worksheet 
notes, and warnings. Excel also offers two dozen styles associated with the current document theme.

Each style includes the number format, cell alignment, font typeface and size, border, and fill color.

Apply a Style to a Range
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TIPS
Are there styles I can use to format tabular 
data?
Yes. Excel comes with a gallery of table styles 
that offer formatting options that highlight the 
first row, apply different formats to alternating 
rows, and so on. Select the range that includes 
your data, click the Home tab, and then click 
Format as Table. In the gallery that appears, 
click the table format you want to apply.

Can I create my own style?
Yes. This is useful if you find yourself applying the 
same set of formatting options over and over. By sav-
ing those options as a custom style, you can apply 
it by following steps 1 to 4. Apply your formatting 
to a cell or range, and then select that cell or range. 
Click Home, click Cell Styles, and then click New Cell 
Style. In the Style dialog box, type a name for your 
style, and then click OK.

A 	Excel applies the style to the 
range.

	 Excel displays the Cell Styles 
gallery.

4 	Click the style you want to 
apply.

Note: If the style is not exactly 
the way you want, you can 
right‐click the style, click Modify, 
and then click Format to 
customize the style.
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2 	Click the Home tab.

3 	Click Format.

4 	Click Column Width.

1 	Click in any cell in the column 
you want to resize.

Change the Column Width

You can make your worksheets neater and more readable by adjusting the column widths to suit 
the data contained in each column.

For example, if you have a large number or a long line of text in a cell, Excel may display only part 
of the cell value. To avoid this, you can increase the width of the column. Similarly, if a column only 
contains a few characters in each cell, you can decrease the width to fit more columns on the screen.

Change the Column Width
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TIPS
Is there an easier way to adjust the column 
width to fit the contents of a column?
Yes. You can use the Excel AutoFit feature, which 
automatically adjusts the column width to fit 
the widest item in a column. Click any cell in the 
column, click Home, click Format, and then 
click AutoFit Column Width. Alternatively, move 

 over the right edge of the column heading 
(  changes to ) and then double‐click.

Is there a way to change all the column widths at 
once?
Yes. Click  to select the entire worksheet, and then 
follow the steps in this section to set the width you 
prefer. If you have already adjusted some column 
widths and you want to change all the other widths, 
click Home, click Format, and then click Default 
Width to open the Standard Width dialog box. Type 
the new standard column width, and then click OK.

A 	Excel adjusts the column width.

B 	You can also move  over the right edge  
of the column heading (  changes to )  
and then click and drag the edge to set  
the width.

	 The Column Width dialog box appears.

5 	In the Column width text box, type 
the width you want to use.

6 	Click OK.
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2 	Click the Home tab.

3 	Click Format.

4 	Click Row Height.

1 	Select a range that includes at 
least one cell in every row you 
want to resize.

Change the Row Height

You can make your worksheet more visually appealing by increasing the row heights to create more 
space. This is particularly useful in worksheets that are crowded with text. Changing the row 

height is also useful if the current height is too small and your cell text is cut off at the bottom.

If you want to change the row height to display multiline text within a cell, you must also turn on 
text wrapping within the cell. See the following section, “Wrap Text Within a Cell.”

Change the Row Height

www.allitebooks.com

http://www.allitebooks.org
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A 	Excel adjusts the row heights.

B 	You can also move  over the 
bottom edge of a row heading 
(  changes to ) and then 
click and drag the bottom edge 
to set the height.

	 The Row Height dialog box appears.

5 	In the Row height text box, type the  
height you want to use.

6 	Click OK.

TIPS
Is there an easier way to adjust the 
row height to fit the contents of 
a row?
Yes. You can use the Excel AutoFit 
feature, which automatically adjusts 
the row height to fit the tallest item in 
a row. Click in any cell in the row, click 
Home, click Format, and then click 
AutoFit Row Height. Alternatively, 
move  over the bottom edge of the 
row heading (  changes to ) and 
then double‐click.

Is there a way to change all the row heights at once?
Yes. Click  to select the entire worksheet. You can then either 
follow the steps in this section to set the height manually, or 
move  over the 
bottom edge of 
any row heading 
(  changes to  

) and then click 
and drag the edge 
to set the height 
of all the rows.
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2 	Click the Home tab.

1 	Select the cell that you want to 
format.

Wrap Text Within a Cell

You can make a long text entry in a cell more readable by formatting the cell to wrap the text. 
Wrapping cell text means that the text is displayed on multiple lines within the cell instead of 

just a single line.

If you type more text in a cell than can fit horizontally, Excel either displays the text over the next 
cell if it is empty or displays only part of the text if the next cell contains data. To prevent Excel 
from showing only truncated cell data, you can format the cell to wrap text within the cell.

Wrap Text Within a Cell
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TIP
My text is only slightly bigger than the cell. Is there a way to view all of the text without turning on 
text wrapping?
Yes. There are several things you can try. For example, you can widen the column until you see all your text; 
see the “Change the Column Width” section, earlier in this chapter.

Alternatively, you can try reducing the cell font size. One way to do this is to choose a smaller value in the 
Font Size list of the Home tab’s Font group. However, an easier way is to click the Alignment group’s dialog 
box launcher ( ) to open the Format Cells dialog box with the Alignment tab displayed. Select the Shrink 
to fit check box (  changes to ) and then click OK.

3 	Click Wrap Text ( ).

	 Excel turns on text wrapping for 
the selected cell.

A 	If the cell has more text than can 
fit horizontally, Excel wraps the 
text onto multiple lines and 
increases the row height to 
compensate.
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2 	Click the Home tab.

3 	Click the Borders .

1 	Select the range that you want to 
format.

Add Borders to a Range

You can make a range stand out from the rest of your worksheet data by adding a border around 
the range. For example, if you have a range of cells that are used as the input values for one or 

more formulas, you could add a border around the input cells to make it clear the cells in that range 
are related to each other.

You can also use borders to make a range easier to read. For example, if your range has totals on the 
bottom row, you can add a double border above the totals.

Add Borders to a Range



81

CHAPTER

3Formatting Excel Ranges

TIPS
How do I get my borders to stand out from the 
worksheet gridlines?
One way to make your borders stand out is to click 
the Borders , click Line Style, and then click a 
thicker border style. You can also click Line Color 
and then click a color that is not a shade of gray. 
However, perhaps the most effective method is to 
turn off the worksheet gridlines. Click the View 
tab, and then in the Show group, select the 
Gridlines check box (  changes to ).

None of the border types is quite right for my 
worksheet. Can I create a custom border?
Yes. You can draw the border manually. Click the 
Borders  and then click Draw Border. Use the Line 
Style and Line Color lists to configure your border. 
Click a cell edge to add a border to that edge; click 
and drag a range to add a border around that range. 
If you prefer to create a grid where the border 
surrounds every cell, click the Draw Border Grid 
command instead.

A 	Excel applies the border to the range.

4 	Click the type of border you want to use.
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2 	Click the Home tab.

3 	Click Format Painter ( ).

	  changes to .

1 	Select the cell that has the 
formatting you want to copy.

Copy Formatting from One Cell to Another

You can save yourself a great deal of time by copying existing formatting to other areas of a 
worksheet.

As you have seen in this chapter, although formatting cells is not difficult, it can be time‐consuming 
to apply the font, color, alignment, number format, and other options. After you spend time 
formatting text or data, rather than spending time repeating the steps for other data, you can use 
the Format Painter tool to copy the formatting with a couple of mouse clicks.

Copy Formatting from One Cell to Another
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TIP
Is there an easy way to copy formatting to multiple cells or ranges?
Yes. If the cells are together, you can click and drag over the cells to apply the copied formatting. If the 
cells or ranges are not together, Excel offers a shortcut that means you do not have to select the Format 
Painter multiple times to copy formatting to multiple ranges.

Click the cell that contains the formatting you want to copy, click the Home tab, and then double‐click . 
Click each cell to which you want to copy the formatting, or click and drag over each range that you want 
to format. When you are done, click  to cancel the Format Painter command.

4 	Click the cell to which you want 
to copy the formatting.

Note: If you want to apply the 
formatting to multiple cells, click and 
drag  over the cells.

A 	Excel copies the formatting to 
the cell.



CHAPTER  4

Building 
Formulas
Are you ready to start creating powerful and useful worksheets by 
building your own formulas? This chapter explains formulas, shows 
you how to build them, and shows you how to incorporate the 
versatile worksheet functions in Excel into your formulas.
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Understanding Excel Formulas

Although you can use Excel to create simple databases to store text, numbers, dates, and other 
data, the spreadsheets you create are also designed to analyze data and make calculations. 

Therefore, to get the most out of Excel, you need to understand formulas so that you can use them 
to analyze and perform calculations on your worksheet data.

To build accurate and useful formulas, you need to know the components of a formula, including 
operators and operands. You also need to understand arithmetic and comparison formulas and you 
need to understand the importance of precedence when building a formula.

Formulas
A formula is a set of symbols and values that perform some kind of 
calculation and produce a result. All Excel formulas have the same general 
structure: an equal sign (=) followed by one or more operands and 
operators. The equal sign tells Excel to interpret everything that follows 
in the cell as a formula. For example, if you type =5+8 into a cell, Excel 
interprets the 5+8 text as a formula, and displays the result (13) in the cell.

Operands
Every Excel formula includes one or more operands, which are the 
data that Excel uses in the calculation. The simplest type of 
operand is a constant value, which is usually a number. However, 
most Excel formulas include references to worksheet data, which 
can be a cell address (such as A1), a range address (such as 
B1:B5), or a range name. Finally, you can also use any of the 
built‐in Excel functions as an operand.

Operators
In an Excel formula that contains two or more operands, each 
operand is separated by an operator, which is a symbol that 
combines the operands in some way, usually mathematically. 
Example operators include the plus sign (+) and the multiplication 
sign (*). For example, the formula =B1+B2 adds the values in cells 
B1 and B2.
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Arithmetic Formulas
An arithmetic formula combines numeric operands — 
numeric constants, functions that return numeric 
results, and fields or items that contain numeric 
values — with mathematical operators to perform a 
calculation. Because Excel worksheets primarily deal 
with numeric data, arithmetic formulas are by far the 
most common formulas used in worksheet calculations.

The following table lists the seven arithmetic operators 
that you can use to construct arithmetic formulas:

Operator Name Example Result
+ Addition =10 + 5 15

– Subtraction =10 – 5 5

– Negation =–10 –10

* Multiplication =10 * 5 50

/ Division =10 / 5 2

% Percentage =10% 0.1

^ Exponentiation =10 ^ 5 100000

Comparison Formulas
A comparison formula combines numeric operands — numeric constants, functions that return numeric results, 
and fields or items that contain numeric values — with special operators to compare one operand with another. 
A comparison formula always returns a logical 
result. This means that if the comparison is true, 
then the formula returns the value 1, which is 
equivalent to the logical value TRUE; if the 
comparison is false, then the formula returns 
the value 0, which is equivalent to the logical 
value FALSE.

The following table lists the six operators that 
you can use to construct comparison formulas:

Operator Name Example Result
= Equal to =10 = 5 0

< Less than =10 < 5 0

< = Less than or equal to =10 < = 5 0

> Greater than =10 > 5 1

> = Greater than or equal to =10 > = 5 1

< > Not equal to =10 < > 5 1

Operator Precedence
Most of your formulas include multiple operands and operators. In many cases, the order in which Excel 
performs the calculations is crucial. For example, consider the formula =3 + 5 ^ 2. If you calculate from left 
to right, the answer you get is 64 (3 + 5 equals 8, and 8 ^ 2 equals 64). However, if you perform the 
exponentiation first and then the addition, 
the result is 28 (5 ^ 2 equals 25, and 3 + 25 
equals 28). Therefore, a single formula can 
produce multiple answers, depending on the 
order in which you perform the calculations.

To solve this problem, Excel evaluates a 
formula according to a predefined order of 
precedence, which is determined by the 
formula operators, as shown in the following 
table:

Operator Operation Precedence
( ) Parentheses 1st

– Negation 2nd

% Percentage 3rd

^ Exponentiation 4th

* and / Multiplication and division 5th

+ and – Addition and subtraction 6th

= < < = > > = < > Comparison 7th
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Build a Formula

Build a Formula

You can add a formula to a worksheet cell using a technique similar to adding data to a cell. To 
ensure that Excel treats the text as a formula, be sure to begin with an equal sign (=) and then 

type your operands and operators.

When you add a formula to a cell, Excel displays the formula result in the cell, not the actual 
formula. For example, if you add the formula =C3+C4 to a cell, that cell displays the sum of the 
values in cells C3 and C4. To see the formula, click the cell and examine the Formula bar.

1 	Click in the cell in which you 
want to build the formula.

2 	Type =.

A 	Your typing also appears in 
the Formula bar.

Note: You can also type the 
formula into the Formula bar.

3 	Type or click an operand. For 
example, to reference a cell 
in your formula, click in the 
cell.

B 	Excel inserts the address of 
the clicked cell into the 
formula.
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C 	Excel displays the formula 
result in the cell.

4 	Type an operator.

5 	Repeat steps 3 and 4 to add 
other operands and operators 
to your formula.

6 	Click  or press .

TIPS
If Excel displays only the result of the formula, 
how do I make changes to the formula?
Excel displays the formula result in the cell, but 
it still keeps track of the original formula. To 
display the formula again, you have two choices: 
Click the cell and then edit the formula using 
the Formula bar, or double‐click the cell to 
display the original formula in the cell and then 
edit the formula. In both cases, click  or 
press  when you finish editing the formula.

If I have many formulas, is there an easy way to 
view them?
Yes. You can configure the worksheet to show the 
formulas instead of their results. Click File and then 
click Options to open the Excel Options dialog box.  
Click the Advanced tab, scroll to the Display options 
for this worksheet section, select the Show formulas 
in cells instead of their calculated results check box 
(  changes to ), and then click OK. You can also 
toggle between formulas and results by pressing  +  .
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Understanding Excel Functions

To build powerful and useful formulas, you often need to include one or more Excel functions as 
operands. To get the most out of functions and to help you build formulas quickly and easily, you 

need to understand a few things about functions. For example, you need to understand the advantages 
of using functions and you need to know the basic structure of every function. To get a sense of what 
is available and how you might use functions, you need to review the Excel function types.

Functions
A function is a predefined formula that performs a 
specific task. For example, the SUM function 
calculates the total of a list of numbers, and the 
PMT (payment) function calculates a loan or 
mortgage 
payment. You 
can use 
functions on 
their own, 
preceded by =, 
or as part of a 
larger formula.

Function Advantages
Functions are designed to take you beyond the basic 
arithmetic and comparison formulas by offering two 
main advantages. First, functions make simple but 
cumbersome formulas easier to use. For example, 
calculating a loan payment requires a complex 
formula, but the Excel PMT function makes this easy. 
Second, functions enable you to include complex 
mathematical expressions in your worksheets that 
otherwise would 
be difficult or 
impossible to 
construct using 
simple 
arithmetic 
operators.

Function Structure
Every worksheet function has the same basic 
structure: NAME(Argument1, Argument2, . . .). The 
NAME part identifies the function. In worksheet 
formulas and custom PivotTable formulas, the function 
name always appears in uppercase letters: PMT, SUM, 
AVERAGE, and so on. The items that appear within  
the parentheses are the functions’ arguments. The 
arguments are the inputs that functions use  
to perform 
calculations. For 
example, the 
function SUM(B2, 
B3, B4) adds the 
values in cells B2, 
B3, and B4.

Mathematical Functions
The following table lists some common 
mathematical functions:

Function Description
MOD(number,divisor) Returns the remainder of a num-

ber after dividing by the divisor
PI( ) Returns the value Pi
PRODUCT(number1, 
number2, . . .)

Multiplies the specified  
numbers

RAND( ) Returns a random number 
between 0 and 1

RANDBETWEEN 
(number1,number2)

Returns a random number 
between the two numbers

ROUND(number,digits) Rounds the number to a 
specified number of digits

SQRT(number) Returns the positive square  
root of the number

SUM(number1, 
number2, . . .)

Adds the arguments
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Statistical Functions
The following table lists some common statistical functions:

Function Description
AVERAGE(number1,number2, . . .) Returns the average of the arguments

COUNT(number1,number2, . . .) Counts the numbers in the argument list

MAX(number1,number2, . . .) Returns the maximum value of the arguments

MEDIAN(number1,number2, . . .) Returns the median value of the arguments

MIN(number1,number2, . . .) Returns the minimum value of the arguments

MODE(number1,number2, . . .) Returns the most common value of the arguments

STDEV(number1,number2, . . .) Returns the standard deviation based on a sample

STDEVP(number1,number2, . . .) Returns the standard deviation based on an entire population

Financial Functions
Most of the Excel financial functions use the following arguments:

Argument Description
rate The fixed rate of interest over the term of the loan or investment

nper The number of payments or deposit periods over the term of the 
loan or investment

pmt The periodic payment or deposit

pv The present value of the loan (the principal) or the initial 
deposit in an investment

fv The future value of the loan or investment

type The type of payment or deposit: 0 (the default) for end‐of‐period 
payments or deposits; 1 for beginning‐of‐period payments or 
deposits

The following table lists some common financial functions:

Function Description
FV(rate,nper,pmt,pv,type) Returns the future value of an investment or loan

IPMT(rate,per,nper,pv,fv,type) Returns the interest payment for a specified period of a loan

NPER(rate,pmt,pv,fv,type) Returns the number of periods for an investment or loan

PMT(rate,nper,pv,fv,type) Returns the periodic payment for a loan or investment

PPMT(rate,per,nper,pv,fv,type) Returns the principal payment for a specified period of a loan

PV(rate,nper,pmt,fv,type) Returns the present value of an investment

RATE(nper,pmt,pv,fv,type,guess) Returns the periodic interest rate for a loan or investment
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Add a Function to a Formula

1 	Click in the cell in which you want to  
build the formula.

2 	Type =.

3 	Type any operands and operators you need before 
adding the function.

4 	Click the Insert Function button ( ).

	 The Insert Function dialog box appears.

5 	Click  and then click the category that contains 
the function you want to use.

6 	Click the function.

7 	Click OK.

Add a Function to a Formula

To get the benefit of an Excel function, you need to use it within a formula. You can use a 
function as the only operand in the formula, or you can include the function as part of a larger 

formula. To make it easy to choose the function you need and to add the appropriate arguments, 
Excel offers the Insert Function feature. This is a dialog box that enables you to display functions by 
category and then choose the function you want from a list. You then see the Function Arguments 
dialog box that enables you to easily see and fill in the arguments used by the function.
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	 The Function Arguments dialog 
box appears.

8 	Click inside an argument box.

9 	Click the cell that contains the 
argument value.

	 You can also type the argument 
value.

10 	Repeat steps 8 and 9 to fill as 
many arguments as you need.

A 	The function result appears here.

11 	Click OK.

B 	Excel adds the function to the 
formula.

C 	Excel displays the formula result.

Note: In this example, the result 
appears in the parentheses to 
indicate a negative value. In loan 
calculations, money that you pay 
out is always a negative amount.

Note: If your formula requires any 
other operands and operators, press 

 and then type what you need to 
complete your formula.

TIPS
Do I have to specify a value for every 
function argument?
Not necessarily. Some function arguments 
are required to obtain a result, but  
others are optional. In the PMT function, 
for example, the rate, nper, and pv 
arguments are required, but the fv and 
type arguments are optional. When the 
Function Arguments dialog box displays a 
result for the function, you know you have 
entered all of the required arguments.

How do I calculate a monthly financial result if I only 
have yearly values?
This is a common problem. For example, if your loan payment 
worksheet contains an annual interest rate and a loan term 
in years, how do you calculate the monthly payment using 
the PMT function? You need to convert the rate and term to 
monthly values. That is, you divide the annual interest rate 
by 12, and you multiply the term by 12. For example, if the 
annual rate is in cell B2, the term in years is in B3, and the 
loan amount is in B4, then the function PMT(B2/12, B3*12, 
B4) calculates the monthly payment.
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3 	Use the mouse  to click and 
drag the row or column of 
numbers that you want to add.

B 	Excel adds a reference for the 
range to the formula.

1 	Click in the cell where you want 
the sum to appear.

2 	Type =sum(.

A 	When you begin a function, Excel 
displays a banner that shows you 
the function’s arguments.

Note: In the function banner, bold 
arguments are required, and 
arguments that appear in square 
brackets are optional.

Add a Row or Column of Numbers

Add a Row or Column of Numbers

You can quickly add worksheet numbers by building a formula that uses the Excel SUM function. 
When you use the SUM function in a formula, you can specify as the function’s arguments a series of 

individual cells. For example, SUM(A1, B2, C3) calculates the total of the values in cells A1, B2, and C3.

However, you can also use the SUM function to specify just a single argument, which is a range 
reference to either a row or a column of numbers. For example, SUM(C3:C21) calculates the total of 
the values in all the cells in the range C3 to C21.
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C 	Excel displays the formula.

D 	Excel displays the sum in the cell.

4 	Type ).

5 	Click  or press .

TIPS
Can I use the SUM function to total rows 
and columns at the same time?
Yes, the SUM function works not only with 
simple row and column ranges, but with any 
rectangular range. After you type =sum(, 
use the mouse  to click and drag the 
entire range that you want to sum.

Can I use the SUM function to total only certain values 
in a row or column?
Yes. The SUM function can accept multiple arguments, so 
you can enter as many cells or ranges as you need. After 
you type =sum(, hold down  and either click each cell 
that you want to include in the total, or use the mouse  
to click and drag each range that you want to sum.
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2 	Click the Home tab.

3 	Click the Sum button ( ).

A 	If you want to use a function 
other than SUM, click the  
Sum  and then click the 
operation you want to use: 
Average, Count Numbers,  
Max, or Min.

1 	Click in the cell where you want 
the sum to appear.

Note: For AutoSum to work, the cell 
you select should be below or to the 
right of the range you want to sum.

Build an AutoSum Formula

Build an AutoSum Formula

You can reduce the time it takes to build a worksheet as well as reduce the possibility of errors 
by using the Excel AutoSum feature. This tool adds a SUM function formula to a cell and 

automatically adds the function arguments based on the structure of the worksheet data. For 
example, if there is a column of numbers above the cell where you want the SUM function to appear, 
AutoSum automatically includes that column of numbers as the SUM function argument.
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B 	Excel adds a SUM function 
formula to the cell.

Note: You can also press  +   
instead of clicking .

C 	Excel guesses that the range 
above (or to the left of) the cell 
is the one you want to add.

	 If Excel guessed wrong, you can 
select the correct range 
manually.

4 	Click  or press .

D 	Excel displays the formula.

E 	Excel displays the sum in  
the cell.

TIPS
Is there a way to see the sum of a range without adding 
an AutoSum formula?
Yes. You can use the Excel status bar to do this. When you 
select any range, Excel adds the range’s numeric values and 
displays the result in the middle of the status bar — for 
example, SUM: 76,650. By default, Excel also displays the 
Average and Count. If you want to see a different calculation, 
right‐click the result in the status bar and then click the 
operation you want to use: Numerical Count, Maximum, or 
Minimum.

Is there a faster way to add an AutoSum 
formula?
Yes. If you know the range you want to 
sum, and that range is either a vertical 
column with a blank cell below it or a 
horizontal row with a blank cell to its 
right, select the range (including the blank 
cell) and then click  or press  +  . 
Excel populates the blank cell with a SUM 
formula that totals the selected range.
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Add a Range Name to a Formula

1 	Click in the cell in which you want 
to build the formula, type =, and 
then type any operands and 
operators you need before adding 
the range name.

2 	Click the Formulas tab.

3 	Click Use in Formula.

A 	Excel displays a list of the range 
names in the current workbook.

4 	Click the range name you want  
to use.

Add a Range Name to a Formula

You can make your formulas easier to build, more accurate, and easier to read by using range 
names as operands instead of cell and range addresses. For example, the formula =SUM(B2:B10) 

is difficult to decipher on its own, particularly if you cannot see the range B2:B10 to examine its 
values. However, if you use the formula =SUM(Expenses), instead, it becomes immediately obvious 
what the formula is meant to do.

See Chapter 2 to learn how to define names for ranges in Excel.
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C 	If you need to insert other 
range names into your formula, 
repeat steps 2 to 5 for each 
name.

6 	Click  or press .

	 Excel calculates the formula 
result.

B 	Excel inserts the range name 
into the formula.

5 	Type any operands and 
operators you need to 
complete your formula.

TIPS
If I create a range name after I build my formula, is 
there an easy way to convert the range reference to 
the range name?
Yes. Excel offers an Apply Names feature that replaces 
range references with their associated range names 
throughout a worksheet. Click the Formulas tab, click 
the Define Name , and then click Apply Names to 
open the Apply Names dialog box. In the Apply names 
list, click the range name you want to use, and then 
click OK. Excel replaces the associated range references 
with the range name in each formula in the current 
worksheet.

Do I have to use the list of range names to 
insert range names into my formula?
No. As you build your formula, you can type 
the range name manually, if you know it. 
Alternatively, as you build your formula, click 
the cell or select the range that has the 
defined name, and Excel adds the name to  
your formula instead of the range address. If 
you want to work from a list of defined range 
names, click an empty area of the worksheet, 
click Formulas, click Use in Formula, click 
Paste Names, and then click Paste List.
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Reference Another Worksheet Range in a Formula

1 	Click in the cell in which you 
want to build the formula, 
type =, and then type any 
operands and operators you 
need before adding the range 
reference.

2 	Press  +   until the 
worksheet you want to use 
appears.

Reference Another Worksheet Range in a Formula

You can add flexibility to your formulas by adding references to ranges that reside in other 
worksheets. This enables you to take advantage of work you have done in other worksheets, so 

you do not have to waste time repeating your work in the current worksheet.

Referencing a range in another worksheet also gives you the advantage of having automatically 
updated information. For example, if the data in the other worksheet range changes, Excel 
automatically updates your formula to include the changed data when you save your work.
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3 	Select the range you want to use.

4 	Press  +   until you return 

to the original worksheet.

A 	A reference to the range on the 
other worksheet appears in your 
formula.

5 	Type any operands and operators 
you need to complete your 
formula.

6 	Click  or press .

	 Excel calculates the formula 
result.

TIPS
Can I manually reference a range in 
another worksheet?
Yes. Rather than selecting the other 
worksheet range with your mouse, you can 
type the range reference directly into your 
formula. Type the worksheet name, 
surrounded by single quotation marks (’) if 
the name contains a space; type an 
exclamation mark (!); then type the cell or 
range address. Here is an example: 
’Expenses 2013’!B2:B10.

Can I reference a range in another workbook in  
my formula?
Yes. First make sure the workbook you want to reference is 
open. When you reach the point in your formula where 
you want to add the reference, click the Excel icon ( ) in 
the Windows taskbar, and then click the other workbook 
to switch to it. Click the worksheet that has the range you 
want to reference, and then select the range. Click  and 
then click the original workbook to switch back to it. 
Excel adds the other workbook range reference to your 
formula.
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Move or Copy a Formula

Move a Formula
1 	Click the cell that contains the 

formula you want to move.

2 	Position  over any outside 
border of the cell (  changes 
to ).

3 	Click and drag the cell to the 
new location (  changes to ).

A 	Excel displays an outline of the 
cell.

B 	Excel displays the address of the 
new location.

4 	Release the mouse button.

C 	Excel moves the formula to the 
new location.

D 	Excel does not change the 
formula’s range references.

Move or Copy a Formula

You can restructure or reorganize a worksheet by moving an existing formula to a different part of 
the worksheet. When you move a formula, Excel preserves the formula’s range references.

Excel also enables you to make a copy of a formula, which is a useful technique if you require a 
duplicate of the formula elsewhere or if you require a formula that is similar to an existing formula. 
When you copy a formula, Excel adjusts the range references to the new location.
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Copy a Formula

1 	Click the cell that contains the 
formula you want to copy.

2 	Press and hold .

3 	Position  over any  
outside border of the cell  
(  changes to ).

4 	Click and drag the cell to the 
location where you want the 
copy to appear.

E 	Excel displays an outline of the 
cell.

F 	Excel displays the address of  
the new location.

5 	Release the mouse button.

6 	Release .

G 	Excel creates a copy of the 
formula in the new location.

H 	Excel adjusts the range references.

Note: You can make multiple copies by 
dragging the bottom‐right corner of 
the cell. Excel fills the adjacent cells 
with copies of the formula. See the 
following section, “Switch to Absolute 
Cell References,” for an example.

TIP
Why does Excel adjust the range references when I copy a formula?
When you make a copy of a formula, Excel assumes that you want that copy to reference different ranges than 
in the original formula. In particular, Excel assumes that the ranges you want to use in the new formula are 
positioned relative to the ranges used in the original formula, and that the relative difference is equal to the 
number of rows and columns you dragged the cell to create the copy.

For example, suppose your original formula references cell A1, and you make a copy of the formula in the 
cell one column to the right. In that case, Excel also adjusts the cell reference one column to the right,  
so it becomes B1 in the new formula. To learn how to control this behavior, see the following section, 
“Switch to Absolute Cell References.”
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A 	Excel switches the address to an 
absolute cell reference.

4 	Repeat steps 2 and 3 to switch any 
other cell addresses that you 
require in the absolute reference 
format.

5 	Click  or press .

1 	Double‐click the cell that contains 
the formula you want to edit.

2 	Select the cell reference you want 
to change.

3 	Press .

Switch to Absolute Cell References

Switch to Absolute Cell References

You can make some formulas easier to copy by switching to absolute cell references. When you 
use a regular cell address — called a relative cell reference — such as A1 in a formula, Excel 

adjusts that reference when you copy the formula to another location. To prevent that reference from 
changing, you must change it to the absolute cell reference format: $A$1.

See the first tip at the end of this section to learn more about the difference between relative and 
absolute cell references.
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C 	Excel preserves the absolute 
cell references in the copied 
formulas.

B 	Excel adjusts the formula.

6 	Copy the formula.

Note: See the previous section, 
“Move or Copy a Formula,” to learn 
how to copy a formula.

TIPS
What is the difference between absolute cell 
references and relative cell references?
When you use a cell reference in a formula, Excel treats 
that reference as being relative to the formula’s cell. 
For example, if the formula is in cell B5 and it 
references cell A1, Excel effectively treats A1 as the 
cell four rows up and one column to the left. If you 
copy the formula to cell D10, then the cell four rows 
up and one column to the left now refers to cell C6, so 
in the copied formula Excel changes A1 to C6. If the 
original formula instead refers to $A$1, then the 
copied formula in cell D10 also refers to $A$1.

How do I restore a cell address back to a 
relative cell reference?
You can use the  keyboard technique, which 
actually runs the address through four different 
reference formats. Press  once to switch to the 
absolute cell reference format, such as $A$1. Press 

 again to switch to a mixed reference format 
that uses a relative column and absolute row 
(A$1). Press  a third time to switch to a mixed 
reference format that uses an absolute column 
and relative row ($A1). Finally, press  a fourth 
time to return to the relative cell reference (A1).
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Hide the Formula Bar
1 	Click the View tab.

Hide the Formula Bar or Ribbon

Hide the Formula Bar or Ribbon

You can give yourself a bit more room in the Excel window by hiding the Formula bar or Ribbon. 
Hiding the Formula bar is a good idea if you never use the Formula bar to enter or edit cell data 

and you never use Formula bar features such as the Name box, the Enter button, and the Insert 
Function button. After hiding the Formula bar, if you find that you need it, you can quickly restore it 
to the Excel window. You can also gain more worksheet room by hiding the Ribbon. When you hide 
the Ribbon, Excel keeps the tabs visible, so you can still access the commands.

2 	Click Formula Bar  
(  changes to ).

A 	Excel removes the Formula bar 
from the window.

Note: To restore the Formula  
bar, repeat steps 1 and 2  
(  changes to ).
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B 	Excel hides the Ribbon.

C 	Excel keeps the Ribbon tabs 
visible.

Note: To restore the Ribbon, click 
any tab and then click Pin the 
Ribbon ( ).

Note: You can also hide and display 
the Ribbon by pressing  +  .

Hide the Ribbon
1 	Click Unpin the Ribbon ( ).

TIP
If I have a long entry in a cell, I only see part of the entry in the Formula bar. Can I fix that?
Yes, you can use the Expand Formula Bar feature in Excel to expand the formula to show multiple lines  
of data instead of just a single line. On the right side of the Formula bar, click the Expand Formula Bar 
button ( ) or press  +   +   to increase the size of the Formula bar as shown here. If you still 
cannot see the entire cell entry, either click and drag the bottom edge of the Formula bar to expand it  
even further, or click  and  to scroll through the entry.

When you are done, click the Collapse Formula Bar button ( ) or press  +   +   to return the 
Formula bar to its normal state.
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Troubleshoot Formula Errors

Despite your best efforts, a formula may return an inaccurate or erroneous result. To help you 
fix such problem formulas, there are a few troubleshooting techniques you can use, such as 

checking for incorrect range references or function arguments, confirming your data, and checking 
for punctuation errors such as missing colons or parentheses.

If Excel displays an error such as #DIV/0 instead of a result, then you also need to understand these 
error messages so that you can troubleshoot and correct the problem.

Confirm Range References
If your formula is returning an 
unexpected or inaccurate result, 
the first thing to check is your 
range and cell references. For 
example, if your data is in the 
range A1:A10, but your formula 
uses A1:A9, then the result will 
be inaccurate. The easiest way  
to check the range and cell 
references is to double‐click the 
cell containing the formula. 
Excel highlights the range 
referenced by the formula, so 
you can see at a glance which 
range your formula is using.

Confirm Range Data
If your formula is correct but it 
is still producing unexpected 
results, the problem might lie 
with the data instead of the 
formula. Double‐check your 
range data to make sure that it 
is accurate and up to date.



109

CHAPTER

4Building Formulas

Confirm Punctuation
Many formulas produce inaccurate or 
erroneous results because of incorrect 
punctuation. Look for missing colons in range 
references; missing or misplaced quotation 
marks in string data or links to other 
worksheets or workbooks; and missing 
commas in function arguments. Also check 
parentheses to make sure you have one 
closing parenthesis for each opening 
parenthesis, and that your parentheses are in 
the correct locations within the formula.

Confirm Operator Precedence
The order in which Excel calculates 
numeric formulas can make a big 
difference to the final result, 
particularly if you are mixing 
addition and subtraction with 
multiplication and division. Confirm 
the correct order of precedence 
that your formula requires; compare 
this with the natural order of operator precedence in Excel, as described in the “Understanding Excel 
Formulas” section earlier in this chapter; and then use parentheses to force the correct order if necessary.

Understand the Excel Error Values
Excel may display an error value instead of a formula result. Here are descriptions of the six main error types:

Error Description
#DIV/0 Your formula is dividing by zero. Check the divisor input cells for values that are either zero or blank.

#N/A Your formula cannot return a legitimate result. Check that your function arguments are appro-
priate for each function.

#NAME? Your formula uses a name that Excel does not recognize. Check your range names and function 
names.

#NUM! Your formula uses a number inappropriately. Check the arguments for your mathematical 
functions to make sure they use the correct types of numbers.

#REF# Your formula contains an invalid cell reference. This usually occurs when you delete a cell 
referenced by a formula. Adjust the formula to use a different cell.

#VALUE! Your formula uses an inappropriate value in a function argument. Check your function argu-
ments to make sure they use the correct data type.
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Manipulating 
Worksheets
An Excel worksheet is where you enter your headings and data and build 
your formulas. You will spend most of your time in Excel operating 
within a worksheet, so you need to know how to navigate and perform 
worksheet tasks such as renaming, moving, copying, and deleting.
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Navigate a Worksheet

You can use a few keyboard techniques that make it easier to navigate data after you have entered 
it in a worksheet.

It is usually easiest to use your mouse to click in the next cell you want to work with. If you are 
using Excel on a tablet or PC that has a touchscreen, then you can tap the next cell you want to 
use. However, if you are entering data, then using the keyboard to navigate to the next cell is often 
faster because your hands do not have to leave the keyboard.

Keyboard Techniques for Navigating a Worksheet

Press To move

Left one cell

Right one cell

Up one cell

Down one cell

To the beginning of the current row

Down one screen

Up one screen

 + 
One screen to the right

 + 
One screen to the left

 +  To the top‐left corner of the worksheet (cell A1)

 +  To the bottom‐right corner of the used portion of the worksheet

 + arrow keys In the direction of the arrow to the next non‐blank cell if the current cell is 
blank, or to the last non‐blank cell if the current cell is not blank
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1 	Display the worksheet you want 
to rename.

2 	Click the Home tab.

3 	Click Format.

4 	Click Rename Sheet.

A 	You can also double‐click the 
worksheet’s tab.

B 	Excel opens the worksheet name 
for editing and selects the text.

5 	If you want to edit the existing 
name, press either  or  to 
deselect the text.

6 	Type the new worksheet name.

7 	Press .

	 Excel assigns the new name to 
the worksheet.

Rename a Worksheet

Rename a Worksheet

You can make your Excel workbooks easier to understand and navigate by providing each worksheet 
with a name that reflects the contents of the sheet.

Excel provides worksheets with generic names such as Sheet1 and Sheet2, but you can change these 
to more descriptive names such as Sales 2013, Amortization, or Budget Data. Note, however, that 
although worksheet names can include any combination of letters, numbers, symbols, and spaces, 
they cannot be longer than 31 characters.
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Create a New Worksheet

Insert a Blank Worksheet
1 	Open the workbook to which you 

want to add the worksheet.

2 	Click the Home tab.

3 	Click the Insert .

4 	Click Insert Sheet.

Create a New Worksheet

When you create a new workbook, Excel includes a single worksheet that you can use to build a 
spreadsheet model or store data. If you want to build a new model or store a different set of 

data, and this new information is related to the existing data in the workbook, you can create a new 
worksheet to hold the new information. Excel supports multiple worksheets in a single workbook, so 
you can add as many worksheets as you need for your project or model.

In most cases, you will add a blank worksheet, but Excel also comes with several predefined 
worksheet templates that you can use.

A 	Excel inserts the worksheet.

Note: You can also insert a blank 
worksheet by pressing  +  .

B 	Another way to add a blank 
worksheet is to click the Insert 
Worksheet button ( ).
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Insert a Worksheet from a 
Template
1 	Open the workbook to which you 

want to add the worksheet.

2 	Right‐click a worksheet tab.

3 	Click Insert.

	 The Insert dialog box appears.

4 	Click the Spreadsheet 
Solutions tab.

5 	Click the type of worksheet 
you want to add.

C 	You can also click Templates 
on Office.com to download 
worksheet templates from  
the web.

6 	Click OK.

TIP
How do I navigate from one worksheet to another?
The easiest way is to click the tab of the worksheet you want to use. You can also click the following controls:

    Move to the previous worksheet.  +      Move to the first worksheet.

    Move to the next worksheet.  +      Move to the last worksheet.

D 	Excel inserts the worksheet.
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1 	If you want to move the 
worksheet to another workbook, 
open that workbook and then 
return to the current workbook.

2 	Click the tab of the worksheet 
you want to move.

3 	Click the Home tab.

4 	Click Format.

5 	Click Move or Copy Sheet.

A 	You can also right‐click the tab 
and then click Move or Copy 
Sheet.

Move a Worksheet

Move a Worksheet

You can organize an Excel workbook and make it easier to navigate by moving your worksheets to 
different positions within the workbook. You can also move a worksheet to another workbook.

When you add a new worksheet to a workbook, Excel adds the sheet to the left of the existing 
sheets. However, it is unlikely that you will add each new worksheet in the order you want them to 
appear in the workbook. For example, in a budget‐related workbook, you might prefer to have all the 
sales‐related worksheets together, all the expense‐related worksheets together, and so on.
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	 The Move or Copy dialog box appears.

6 	If you want to move the sheet to another 
workbook, click the To book  and then click the 
workbook.

7 	Use the Before sheet list to click a destination 
worksheet.

	 When Excel moves the worksheet, it will appear to 
the left of the sheet you selected in step 7.

8 	Click OK.

B 	Excel moves the worksheet.

TIP
Is there an easier way to move a worksheet within the same workbook?
Yes. It is usually much easier to use your mouse to move a worksheet within the same workbook:

1 	Move  over the tab of the workbook you want to move.

2 	Click and drag the worksheet tab left or right to the new position within the workbook  
(  changes to ).

A 	As you drag, an arrow shows the position of the 
worksheet.

3 	When you have the worksheet positioned where 
you want it, drop the worksheet tab.

	 Excel moves the worksheet.
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Copy a Worksheet

1 	If you want to copy the worksheet  
to another workbook, open that 
workbook and then return to the 
current workbook.

2 	Click the tab of the worksheet you  
want to copy.

3 	Click the Home tab.

4 	Click Format.

5 	Click Move or Copy Sheet.

A 	You can also right‐click the tab and 
then click Move or Copy Sheet.

	 The Move or Copy dialog box appears.

Copy a Worksheet

Excel enables you to make a copy of a worksheet, which is a useful technique if you require a new 
worksheet that is similar to an existing worksheet. You can copy the sheet to the same workbook 

or to another workbook.

One of the secrets of productivity in Excel is to not repeat work that you have already done. For 
example, if you have already created a worksheet and you find that you need a second sheet that is 
very similar, then you should not create the new worksheet from scratch. Instead, you should copy 
the existing worksheet and then edit the new sheet as needed.
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6 	If you want to copy the sheet to another workbook, 
click the To book  and then click the workbook.

7 	Use the Before sheet list to click a destination 
worksheet.

	 When Excel copies the worksheet, the copy will appear 
to the left of the sheet you selected in step 7.

8 	Select the Create a copy check box (  changes to ).

9 	Click OK.

B 	Excel copies the worksheet.

C 	Excel gives the new worksheet the 
same name as the original, but 
with (2) appended.

Note: See the “Rename a Worksheet” 
section earlier in this chapter to learn 
how to edit the name of the copied 
worksheet.

TIP
Is there an easier way to copy a worksheet within the same workbook?
Yes. It is usually much easier to use your mouse to copy a worksheet within the same workbook:

1 	Move  over the tab of the workbook you want to copy.

2 	Hold down .

3 	Click and drag the worksheet tab left or right (  changes to ).

A 	As you drag, an arrow shows the position of 
the worksheet.

4 	When you have the worksheet positioned 
where you want it, drop the worksheet tab.

	 Excel copies the worksheet.
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1 	Click the tab of the worksheet you 
want to delete.

2 	Click the Home tab.

3 	Click the Delete .

4 	Click Delete Sheet.

A 	You can also right‐click the tab 
and then click Delete Sheet.

Delete a Worksheet

Delete a Worksheet

If you have a worksheet that you no longer need, you can delete it from the workbook. This reduces 
the size of the workbook and makes the workbook easier to navigate.

You cannot undo a worksheet deletion, so check the worksheet contents carefully before proceeding 
with the deletion. To be extra safe, save the workbook before performing the worksheet deletion. If 
you delete the wrong sheet accidentally, close the workbook without saving your changes.
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	 If the worksheet contains data, 
Excel asks you to confirm that 
you want to delete the 
worksheet.

5 	Click Delete.

B 	Excel removes the worksheet.

TIP
I have several worksheets that I need to delete. Do I have to delete them individually?
No. You can select all the sheets you want to remove and then run the deletion. To select multiple 
worksheets, click the tab of one of the worksheets, hold down , and then click the tabs of the other 
worksheets.

If your workbook has many worksheets and you want to delete most of them, an easy way to select the 
sheets is to right‐click any worksheet tab and then click Select All Sheets. Hold down , and then click 
the tabs of the worksheets that you do not want to delete.

After you have selected your worksheets, follow steps 3 to 5 to delete all the selected worksheets at once.
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Change the Gridline Color

1 	Click the tab of the worksheet 
you want to customize.

2 	Click the File tab.

3 	Click Options.

Change the Gridline Color

You can add some visual interest to your worksheet by changing the color that Excel uses to 
display the gridlines. The default color is black, but Excel offers a palette of 56 colors that you 

can choose from.

Changing the gridline color also has practical value because it enables you to differentiate between 
the gridlines and the borders that you add to a range or a table. See Chapter 3 to learn how to add 
borders to your worksheet ranges.
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	 The Excel Options dialog box 
appears.

4 	Click Advanced.

5 	Scroll down to the Display 
options for this worksheet 
section.

A 	The worksheet you selected in 
step 1 appears here.

6 	Click the Gridline color .

7 	Click the color you want to use.

8 	Click OK.

B 	Excel displays the gridlines using 
the color you selected.

TIP
Can I change the gridline color for all the sheets in my workbook?
Yes. One method would be to follow the steps in this section for each worksheet in your workbook. 
However, an easier method is to first select all the sheets in the workbook. To do this, right‐click any 
worksheet tab and then click Select All Sheets.
You can now follow steps 2 to 8 to apply the new gridline color to all your worksheets. Once you have done 
that, right‐click any worksheet tab and then click Ungroup Sheets to collapse the grouping.
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3 	Click Gridlines (  changes to ).

A 	Excel turns off the gridline display.

Turn Gridlines On
B 	To turn the gridlines back on, click 

Gridlines (  changes to ).

Turn Gridlines Off

1 	Click the tab of the worksheet  
you want to work with.

2 	Click the View tab.

Toggle Worksheet Gridlines On and Off

Toggle Worksheet Gridlines On and Off

You can make your worksheet look cleaner and make the worksheet text easier to read by turning 
off the sheet gridlines. When you do this, Excel displays the worksheet with a plain white 

background, which often makes the worksheet easier to read. This is particularly true on a worksheet 
where you have added numerous borders to your ranges, as described in Chapter 3.

If you find you have trouble selecting ranges with the gridlines turned off, you can easily turn them 
back on again.
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3 	Click Headings (  changes 
to ).

A 	Excel turns off the headings.

Turn Headings On
B 	To turn the headings back 

on, click Headings  
(  changes to ).

Turn Headings Off

1 	Click the tab of the worksheet  
you want to work with.

2 	Click the View tab.

Toggle Worksheet Headings On and Off

Toggle Worksheet Headings On and Off

You can give yourself a bit more room to work by turning off the worksheet’s row headings — the 
numbers 1, 2, and so on to the left of the worksheet — and column headings — the letters A, B, 

and so on above the worksheet.

If you find you have trouble reading your worksheet or building formulas with the headings turned 
off, you can easily turn them back on again.
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Set the Worksheet Tab Color

1 	Click the tab of the worksheet 
you want to format.

2 	Click the Home tab.

3 	Click Format.

4 	Click Tab Color.

Set the Worksheet Tab Color

You can make a workbook easier to navigate by color‐coding the worksheet tabs. For example, if 
you have a workbook with sheets associated with several projects, you could apply a different tab 

color for each project. Similarly, you could format the tabs of incomplete worksheets with one color, 
and completed worksheets with another color.

Excel offers 10 standard colors as well as 60 colors associated with the current workbook theme. You 
can also apply a custom color if none of the standard or theme colors suits your needs.
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	 Excel displays the Tab Color 
palette.

5 	Click the color you want to use 
for the current tab.

A 	To apply a custom color, click 
More Colors and then use the 
Colors dialog box to choose the 
color you want.

B 	Excel applies the color to  
the tab.

Note: You can also right‐click the 
tab, click Tab Color, and then click 
the color you want to apply.

Note: The tab color appears very 
faintly when the tab is selected, but 
the color appears quite strongly 
when any other tab is selected.

TIPS

If I want to apply the same color to several worksheets,  
do I have to format them individually?
No. You can select all the sheets you want to format and then 
apply the tab color. To select multiple worksheets, click the tab 
of one of the worksheets, hold down , and then click the 
tabs of the other worksheets. After you have selected your 
worksheets, follow steps 2 to 5 to apply the tab color to all the 
selected worksheets at once.

How do I remove a tab color?
If you no longer require a worksheet to 
have a colored tab, you can remove 
the color. Follow steps 1 to 4 to select 
the worksheet and display the Tab 
Color palette, and then click No Color. 
Excel removes the color from the 
worksheet’s tab.
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Set the Worksheet Background

You can add visual interest to a worksheet by replacing the standard white sheet background with 
a photo, drawing, or other image. For example, a worksheet that tracks the amount needed for a 

future vacation could show a photo from the proposed destination as the background.

When choosing the image you want to use as the background, be sure to select a picture that will 
not make the worksheet text difficult to read. For example, if your sheet text is a dark color, choose 
a light‐colored image as the background.

Set the Worksheet Background

1 	Click the tab of the worksheet 
you want to customize.

2 	Click the Page Layout tab.

3 	Click Background ( ).

	 The Insert Pictures dialog box 
appears.

4 	Click From a file.
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	 The Sheet Background dialog 
box appears.

5 	Select the location of the image 
you want to use.

6 	Click the image.

7 	Click Insert.

A 	Excel formats the worksheet 
background with the image you 
selected.

TIPS

How do I apply a background color instead of a 
background image?
Excel does not have a command that changes the 
background color of the entire worksheet. Instead, you 
must first select all the cells in the worksheet by 
clicking Select All ( ). Click the Home tab, click the 
Fill Color , and then click the color you want to use. 
Excel applies the color to the background of every cell.

How do I remove the background image from 
the worksheet?
If you find that having the background image 
makes it difficult to read the worksheet text, then 
you should remove the background. Click the tab 
of the worksheet, click Page Layout, and then 
click Delete Background ( ). Excel removes the 
background image from the worksheet.
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2 	Click the View tab.

3 	Click Zoom ( ).

A 	You can also run the Zoom 
command by clicking the zoom 
level in the status bar.

1 	Click the tab of the worksheet 
you want to zoom.

Zoom In on or Out of a Worksheet

Zoom In on or Out of a Worksheet

You can get a closer look at a portion of a worksheet by zooming in on that range. When you zoom 
in on a range, Excel increases the magnification of the range, which makes it easier to see the 

range data, particularly when the worksheet font is quite small.

On the other hand, if you want to get a sense of the overall structure of a worksheet, you can also 
zoom out. When you zoom out, Excel decreases the magnification, so you see more of the worksheet.
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	 The Zoom dialog box appears.

4 	Click the magnification level 
you want to use (  changes  
to ).

B 	You can also click Custom  
(  changes to ) and then 
type a magnification level in 
the text box.

Note: Select a magnification level 
above 100% to zoom in on the 
worksheet; select a level under 
100% to zoom out of the worksheet.

5 	Click OK.

	 Excel changes the magnification 
level and redisplays the 
worksheet.

C 	You can click 100% ( ) to 
return to the normal zoom level.

TIPS

How can I zoom in on a particular 
range?
Excel offers the Zoom to Selection feature 
that enables you to quickly and easily 
zoom in on a range. First, select the range 
that you want to magnify. Click the View 
tab and then click Zoom to Selection  
( ). Excel magnifies the selected range 
to fill the entire Excel window.

Is there an easier way to zoom in and out of a worksheet?
Yes, you can use the Zoom slider, which appears on the far‐
right side of the Excel status bar. Drag the slider  to the 
right to zoom in on the worksheet, or drag  to the left to 
zoom out. You can also 
click the Zoom In ( ) 
or Zoom Out ( ) 
button to change the 
magnification.
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2 	 Select a cell in column A 
that is below the point where 
you want the split to occur.

	 For example, if you want to 
place the first five rows in 
the top pane, select cell A6.

1 	 Click the tab of the 
worksheet you want to split.

Split a Worksheet into Two Panes

Split a Worksheet into Two Panes

You can make it easier to examine your worksheet data by splitting the worksheet into two 
scrollable panes that each show different parts of the worksheet. This is useful if you have 

cell headings at the top of the worksheet that you want to keep in view as you scroll down the 
worksheet.

Splitting a worksheet into two panes is also useful if you want to keep some data or a formula result 
in view while you scroll to another part of the worksheet.
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3 	Click the View tab.

4 	Click Split ( ).

A 	Excel splits the worksheet into 
two horizontal panes at the 
selected cell.

B 	You can adjust the size of the 
panes by clicking and dragging 
the split bar up or down.

	 To remove the split, either  
click  again, or double‐ 
click the split bar.

TIPS

Can I split a worksheet into two vertical panes?
Yes. To do this, you must first select a cell in the 
top row of the worksheet. Specifically, select the 
top cell in the column to the right of where you 
want the split to occur. For example, if you want 
to show only column A in the left pane, select cell 
B1. When you click , Excel splits the worksheet 
into two vertical panes.

Can I split a worksheet into four panes?
Yes. This is useful if you have three or four worksheet 
areas that you want to examine separately. To perform 
a four‐way split, first select the cell where you want the 
split to occur. Note that this cell must not be in either 
row 1 or column A. When you click , Excel splits the 
worksheet into four panes. The cell you selected 
becomes the upper‐left cell in the bottom‐right pane.
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B 	Excel temporarily removes 
the worksheet from the 
workbook.

Hide a Worksheet

1 	Click the tab of the worksheet 
you want to hide.

2 	Click the Home tab.

3 	Click Format.

4 	Click Hide & Unhide.

5 	Click Hide Sheet.

A 	You can also right‐click the 
worksheet tab and then click 
Hide Sheet.

Hide and Unhide a Worksheet

Hide and Unhide a Worksheet

You can hide a worksheet so that it no longer appears in the workbook. This is useful if you need 
to show the workbook to other people, but the workbook contains a worksheet with sensitive 

or private data that you do not want others to see. You might also want to hide a worksheet if it 
contains unfinished work that is not ready for others to view.

To learn how to protect a workbook so that other people cannot unhide a worksheet, see Chapter 14.
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Unhide a Worksheet

1 	Click the Home tab.

2 	Click Format.

3 	Click Hide & Unhide.

4 	Click Unhide Sheet.

C 	You can also right‐click any 
worksheet tab and then click 
Unhide Sheet.

TIP

I have several worksheets that I need to hide. Do I have to hide them individually?
No. You can select all the sheets you want to work with and then hide them. To select multiple worksheets, 
click the tab of one of the worksheets, hold down , and then click the tabs of the other worksheets.

If your workbook has many worksheets and you want to hide most of them, an easy way to select the 
sheets is to right‐click any worksheet tab and then click Select All Sheets. Hold down , and then click 
the tabs of the worksheets that you do not want to hide.

After you have selected your worksheets, follow steps 3 to 5 to hide all the selected worksheets at once.

	 The Unhide dialog box appears.

5 	Click the worksheet you want 
to restore.

6 	Click OK.

D 	Excel returns the worksheet to 
the workbook.



CHAPTER  6

Dealing with 
Workbooks
Everything you do in Excel takes place within a workbook, which is 
the standard Excel file. This chapter shows you how to get more out 
of workbooks by creating new files; saving, opening, and closing files; 
checking spelling; and more.
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2	 Click New.

1	 Click the File tab.

Create a New Blank Workbook

Create a New Blank Workbook

To perform new work in Excel, you need to first create a new, blank Excel workbook. When you 
launch Excel, it prompts you to create a new workbook and you can click Blank Workbook to start 

with a blank file that contains a single empty worksheet. However, for subsequent files you must use 
the File tab to create a new blank workbook.

If you prefer to create a workbook based on one of the Excel templates, see the following section, 
“Create a New Workbook from a Template.”
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	A	 Excel creates the blank workbook 
and displays it in the Excel 
window.

3	 Click Blank Workbook.

TIPS

Is there a faster method 
I can use to create a 
new workbook?
Yes. Excel offers a 
keyboard shortcut for 
faster workbook creation. 
From the keyboard,  
press  +  .

When I start Excel and then open an existing workbook, Excel often 
removes the new, blank workbook that it opened automatically. How can I 
prevent this?
Excel assumes that you want to use a fresh workbook when you start the program, 
so it prompts you to create a new workbook. However, if you do not make any 
changes to the blank workbook and then open an existing file, Excel assumes you 
do not want to use the new workbook, so it closes it. To prevent this from 
happening, make a change to the blank workbook before opening another file.
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2	 Click New.

	A	 To use an Office Online template, 
use the Search Online Templates 
text box to type a word or two 
that defines the type of template 
you want to use.

3	 Click the template you want to use.

1	 Click the File tab.

Create a New Workbook from a Template

You can save time and effort by creating a new workbook based on one of the Excel template files. 
Each template includes a working spreadsheet model that contains predefined headings, labels, 

and formulas, as well as preformatted colors, fonts, styles, borders, and more. In many cases, you 
can use the new workbook as is and just fill in your own data.

Excel 2016 offers more than two dozen templates, and many more are available through Microsoft 
Office Online.

Create a New Workbook from a Template
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	B	 A preview of the template 
appears.

4	 Click Create.

	C	 Excel creates the new workbook 
and displays it in the Excel 
window.

TIP
Can I create my own template?
Yes. If you have a specific workbook structure that you use frequently, you should save it as a template so 
that you do not have to re‐create the same structure from scratch each time. Open the workbook, click File, 
and then click Save as. In the Save As dialog box, click Computer, and then click Browse. Click the Save as 
type  and then click Excel Template. Type a name in the File name text box and then click Save. To use 
the template, click File and click Open; then, in the Open dialog box, click Computer, click Browse, and 
then click your template file.
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After you create a workbook in Excel and make changes to it, you can save the document to 
preserve your work. When you edit a workbook, Excel stores the changes in your computer’s 

memory, which is erased each time you shut down your computer. Saving the document preserves 
your changes on your computer’s hard drive. To ensure that you do not lose any work if your computer 
crashes or Excel freezes up, you should save your work frequently: at least every few minutes.

Save a Workbook

The Save As tab appears.

2	 Click This PC.

3	 Click Browse.

1	 Click Save ( ).

You can also press  +  .

If you have saved the document 
previously, your changes are now 
preserved, and you do not need 
to follow the rest of the steps in 
this section.

Save a Workbook

The Save As dialog box appears.

4	 Select a folder in which to store 
the file.

5	 Click in the File name text box 
and type the name that you want 
to use for the document.

6	 Click Save.

Excel saves the file.

Note: To learn how to save a 
workbook in an older Excel format, 
see Chapter 14.
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The Open dialog box appears.

5	 Select the folder that contains the 
workbook you want to open.

6	 Click the workbook.

7	 Click Open.

The workbook appears in a 
window.

1	 Click the File tab (not shown).

2	 Click Open.

The Open tab appears.

	A	 You can click Recent to see a 
list of your recently used 
workbooks. If you see the file 
you want, click it and then skip 
the rest of these steps.

3	 Click This PC.

4	 Click Browse.

You can also press  +  .

Open a Workbook

Open a Workbook

To view or make changes to an Excel workbook that you have saved in the past, you must open the 
workbook in Excel. To open a workbook, you must first locate it in the folder you used when you 

originally saved the file.

If you have used the workbook recently, you can save time by opening the workbook from the Excel 
Recent Workbooks menu, which displays a list of the 25 workbooks that you have used most recently.
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3	 Click Arrange All ( ).

1	 Open the workbooks you want to 
view.

2	 Click the View tab.

Arrange Workbook Windows

You can view two or more workbooks at once by arranging the workbook windows on the Windows 
desktop. This is useful if, for example, you want to compare or contrast data in two or more 

workbooks. By arranging the workbooks so that they do not overlap each other, you can see the 
workbooks’ data without having to switch from one window to another.

Excel offers four view modes for arranging workbook windows: Tiled, Horizontal, Vertical, and Cascade.

Arrange Workbook Windows
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The Arrange Windows dialog box 
appears.

4	 Click a view mode (  changes 
to ).

Tiled arranges the workbooks 
evenly on the Windows desktop.

Horizontal stacks the workbooks 
one above the other.

Vertical displays the workbooks 
side by side.

Cascade arranges the workbooks 
in an overlapping cascade 
pattern.

5	 Click OK.

	A	 Excel arranges the workbook 
windows.

This example shows two 
workbooks arranged with the 
Vertical view mode.

TIPS

How do I return to viewing one workbook at  
a time?
Click the workbook you want to use, and then click 
the workbook window’s Maximize button ( ). 
This maximizes the workbook on the Windows 
desktop, so you only see that workbook. To switch 
to another open workbook, click the Excel icon  
( ) in the taskbar to display thumbnail versions 
of the open workbooks, and then click the one you 
want to view.

Is it possible to view two different sections  
of a single workbook at the same time?
Yes. Excel enables you to create a second window for 
a workbook and you can then arrange the two 
windows as described in this section. Switch to the 
workbook you want to view, click the View tab, and 
then click New Window ( ). Follow steps 1 to 3 to 
open the Arrange Windows dialog box and select a 
view option. Select the Windows of active workbook 
check box (  changes to ), and then click OK.
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Most spreadsheet models require at most a screen or two in a single worksheet, so locating the text 
you want is usually not difficult. However, you might be working with a large spreadsheet model 

that takes up either multiple screens in a single worksheet or multiple worksheets. In such large 
workbooks, locating specific text can be difficult and time‐consuming. You can make this task easier 
and faster using the Excel Find feature, which searches the entire workbook in the blink of an eye.

Find Text in a Workbook

The Find and Replace dialog box 
appears.

4	 Click in the Find what text box 
and type the text you want to 
find.

5	 Click Find Next.

1	 Click the Home tab.

2	 Click Find & Select.

3	 Click Find.

Note: You can also run the Find 
command by pressing  +  .

Find Text in a Workbook
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	A	 Excel selects the next cell that 
contains an instance of the 
search text.

Note: If the search text does not 
exist in the document, Excel displays 
a dialog box to let you know.

6	 If the selected instance is not 
the one you want, click Find 
Next until Excel finds the correct 
instance.

7	 Click Close to close the Find and 
Replace dialog box.

	B	 Excel leaves the cell selected.

TIPS

When I search for a particular term, Excel 
only looks in the current worksheet. How 
can I get Excel to search the entire 
workbook?
In the Find and Replace dialog box, click 
Options to expand the dialog box. Click the 
Within  and then click Workbook. This 
option tells Excel to examine the entire 
workbook for your search text.

When I search for a name such as Bill, Excel also matches 
the non‐name bill. Is there a way to fix this?
Yes. In the Find and Replace dialog box, click Options  
to expand the dialog box. Select the Match case check  
box (  changes to ). This option tells Excel to match 
the search text only if it has the same mix of uppercase  
and lowercase letters that you specify in the Find what 
text box. If you type Bill, for example, the program 
matches only Bill and not bill.
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Do you need to replace a word or part of a word with some other text? If you only need to replace 
one or two instances of the text, you can usually perform the replacement quickly and easily. 

However, if you have many instances of the text to replace, the replacement can take a long time 
and the more instances there are, the more likely it is that you will make a mistake. You can save 
time and do a more accurate job if you let the Excel Replace feature replace the text for you.

Replace Text in a Workbook

The Find and Replace dialog box 
appears.

4	 In the Find what text box, type 
the text you want to find.

5	 Click in the Replace with text 
box and type the text you want 
to use as the replacement.

6	 Click Find Next.

1	 Click the Home tab.

2	 Click Find & Select.

3	 Click Replace.

Note: You can also run the Replace 
command by pressing  +  .

Replace Text in a Workbook
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	A	 Excel selects the cell that 
contains the next instance of the 
search text.

Note: If the search text does not 
exist in the document, Excel displays 
a dialog box to let you know.

7	 If the selected instance is not 
the one you want, click Find 
Next until Excel finds the correct 
instance.

8	 Click Replace.

	B	 Excel replaces the selected text 
with the replacement text.

	C	 Excel selects the next instance of 
the search text.

9	 Repeat steps 7 and 8 until you 
have replaced all the instances 
you want to replace.

10	 Click Close to close the Find and 
Replace dialog box.

Is there a faster way to replace every instance of the search text with the replacement text?
Yes. In the Find and Replace dialog box, click Replace All. This tells Excel to replace every instance of the 
search text with the replacement text. However, you should exercise some caution with this feature because it 
may make some replacements that you did not intend. Click Find Next a few times to make sure the matches 
are correct. Also, consider clicking Options and then selecting the Match case check box (  changes to ), 
as described in the previous section, “Find Text in a Workbook.”

TIP
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	A	 The Spelling dialog box 
appears and selects the cell 
that contains the first error.

3	 Click the correction you want 
to use.

4	 Click Change.

	B	 Click Change All to correct 
every instance of the error.

1	 Click the Review tab.

2	 Click Spelling ( ).

Note: You can also press .

Check Spelling and Grammar

Although Excel workbooks are mostly concerned with numbers, formulas, and data, a workbook 
that contains misspelled words might not be taken as seriously as one that is free of jarring 

typos. You can eliminate any text errors in your Excel workbooks by taking advantage of the spell‐
checker, which identifies potentially misspelled words and offers suggested corrections.

When the spell‐checker flags a word as misspelled, you can correct the word, tell the spell‐checker to 
ignore it, or add it to the spell‐checker’s dictionary.

Check Spelling and Grammar
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	C	 The spell‐checker displays the 
next error.

5	 If you want to correct the 
word, repeat step 4.

	D	 If you do not want to correct 
the word, click one of the 
following buttons:

Click Ignore Once to skip this 
instance of the error.

Click Ignore All to skip all 
instances of the error.

Click Add to Dictionary to 
include the word in the spell‐
checker’s dictionary.

6	 When the check is complete, 
click OK.

TIP
Can I remove a word that I added to the spell‐checker’s dictionary?
Yes. Follow these steps:

1	 Click File.

2	 Click Options to open the Excel Options dialog box.

3	 Click Proofing.

4	 Click Custom Dictionaries to open the Custom Dictionaries  
dialog box.

5	 Click the dictionary marked as Default and then click  
Edit Word List.

6	 Click the term you want to remove.

7	 Click Delete.

8	 Click OK to return to the Custom Dictionaries dialog box.

9	 Click OK to return to the Excel Options dialog box.

10	 Click OK.
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Formatting 
Workbooks
Excel offers several settings that enable you to control the look of a 
workbook, including the workbook colors, fonts, and special effects. 
You can also apply a workbook theme and add a header and footer  
to a workbook.
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Modify the Workbook Colors

Modify the Workbook Colors

You can give your workbook a new look by selecting a different color scheme. Each color scheme 
affects a dozen workbook elements, including the workbook’s text colors, background colors, 

border colors, chart colors, and more. Excel offers more than 20 color schemes. However, if none of 
these predefined schemes suits your needs, you can also create your own custom color scheme.

To get the most out of the Excel color schemes, you must apply styles to your ranges, as described in 
Chapter 3.

1	 Open or switch to the workbook 
you want to format.

2	 Click the Page Layout tab.

3	 Click Colors ( ).
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4	 Click the color scheme you want 
to apply.

	A	 Excel applies the color scheme to 
the workbook.

TIP
Can I create my own color scheme?
Yes, by following these steps:

1	 Click the Page Layout tab.

2	 Click .

3	 Click Customize Colors.

The Create New Theme Colors 
dialog box appears.

4	 For each theme color, click  
and then click the color you 
want to use.

	A	 The Sample area shows what 
your theme colors look like.

5	 Type a name for the custom 
color scheme.

6	 Click Save.
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Set the Workbook Fonts

You can add visual appeal to your workbook by selecting a different font scheme. Each font scheme 
has two defined fonts: a heading font for the titles and headings, and a body font for the regular 

worksheet text. Excel offers more than 20 font schemes. However, if none of the predefined schemes 
is suitable, you can create a custom font scheme.

To get the most out of the Excel font schemes, particularly the heading fonts, you must apply styles 
to your ranges, as described in Chapter 3.

Set the Workbook Fonts

1	 Open or switch to the workbook 
you want to format.

2	 Click the Page Layout tab.

3	 Click Fonts ( ).
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4	 Click the font scheme you want  
to apply.

	A	 Excel applies the heading font to 
the workbook’s headings.

	B	 Excel applies the body font to 
the workbook’s regular text.

TIP
Can I create my own font scheme?
Yes, by following these steps:

1	 Click the Page Layout tab.

2	 Click .

3	 Click Customize Fonts.

The Create New Theme Fonts dialog box 
appears.

4	 Click the Heading font  and then click the 
font you want to use for titles and headings.

5	 Click the Body font  and then click the 
font you want to use for regular sheet text.

	A	 The Sample area shows what your theme fonts 
look like.

6	 Type a name for the custom font scheme.

7	 Click Save.
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Choose Workbook Effects

You can enhance the look of your workbook by selecting a different effect scheme. The effect 
scheme applies to charts and graphic objects, and each scheme defines a border style, fill style, 

and added effect such as a drop shadow or glow. Excel offers more than 20 effect schemes.

To get the most out of the Excel effect schemes, you must apply a style to your chart, as described in 
Chapter 12, or to your graphic object, as described in Chapter 13.

Choose Workbook Effects

1	 Open or switch to the workbook 
you want to format.

2	 Click the Page Layout tab.

3	 Click Effects ( ).
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TIPS
Can I create a custom effect 
scheme?
No. Unlike with the color schemes 
and font schemes described earlier 
in this chapter, Excel does not 
have a feature that enables you to 
create your own effect scheme.

Why are all the effect schemes the same color?
The color you see in the effect schemes depends on the color scheme 
you have applied to your workbook. If you apply a different color 
scheme, as described in the “Modify the Workbook Colors” section 
earlier in the chapter, you will see a different color in the effect 
schemes. If you want to use a custom effect color, create a custom 
color scheme and change the Accent 1 color to the color you want.

4	 Click the effect scheme you want 
to apply.

	A	 Excel applies the effect scheme 
to the workbook’s charts and 
graphics.
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Apply a Workbook Theme

You can give your workbook a completely new look by selecting a different workbook theme. Each 
theme consists of the workbook’s colors, fonts, and effects. Excel offers ten predefined workbook 

themes.

To get the most out of the Excel workbook themes, you must apply styles to your ranges, as 
described in Chapter 3; to your charts, as described in Chapter 12; and to your graphic objects, as 
described in Chapter 13.

Apply a Workbook Theme

1	 Open or switch to the workbook 
you want to format.

2	 Click the Page Layout tab.

3	 Click Themes ( ).
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TIP
Can I create my own workbook theme?
Yes, by following these steps:

1	 Format the workbook with a color scheme, 
font scheme, and effect scheme, as described 
in the previous three sections.

2	 Click the Page Layout tab.

3	 Click .

4	 Click the workbook theme you 
want to apply.

	A	 Excel applies the theme to the 
workbook.

Note: After you apply the theme, the 
new font size might require you to 
adjust the column widths to see your 
data properly.

4	 Click Save Current Theme.

The Save Current Theme dialog box appears.

5	 Type a name for the custom theme.

6	 Click Save.
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Add a Workbook Header

If you will be printing a workbook, you can enhance the printout by building a custom header that 
includes information such as the page number, date, filename, or even a picture.

The header is an area on the printed page between the top of the page text and the top margin. 
Excel offers a number of predefined header items that enable you to quickly add data to the 
workbook header. If none of the predefined header items suits your needs, Excel also offers tools 
that make it easy to build a custom header.

Add a Workbook Header

1	 Click the View tab.

2	 Click Page Layout ( ).

Excel switches to Page Layout 
view.

	A	 You can also click the Page 
Layout button ( ).

3	 Click the Add header text.

	B	 Excel opens the header area for 
editing.

	C	 Excel adds the Header & Footer 
Tools tab.

4	 Click the Design tab.
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7	 Click a button in the Header & 
Footer Elements group to add 
that element to the header.

	D	 Excel inserts a code into the 
header, such as &[Date] for the 
Current Date element, as shown 
here.

8	 Repeat steps 5 to 7 to build the 
header.

9	 Click outside the header area.

Excel applies the header. When 
you are in Page Layout view, 
you see the current values for 
elements such as the date.

5	 Type your text in the header.

6	 If you want to include a 
predefined header item, click 
Header and then click the item.

TIP
Can I have multiple headers in a workbook?
Yes. You can have a different header and footer on the first page, which is useful if you want to add a  
title or explanatory text to the first page. In the Design tab, select the Different First Page check box  
(  changes to ).

You can also have different headers and footers on the even and odd pages of the printout, such as showing 
the filename on the even pages and the page numbers on the odd pages. In the Design tab, select the 
Different Odd & Even Pages check box (  changes to ).
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	B	 Excel opens the footer area for editing.

	C	 Excel adds the Header & Footer  
Tools tab.

4	 Click the Design tab.

1	 Click the View tab.

2	 Click Page Layout ( ).

Excel switches to Page Layout view.

	A	 You can also click the Page Layout 
button ( ).

3	 Scroll down to the bottom of the page 
and click the Add footer text.

Note: You can also click the Add header text 
and then click the Design tab’s Go to Footer 
command ( ).

Add a Workbook Footer

If you will be printing a workbook, you can enhance the printout by building a custom footer that 
includes information such as the current page number, the total number of pages, the worksheet 

name, and more.

The footer is an area on the printed page between the bottom of the page text and the bottom 
margin. Excel offers a number of predefined footer items that enable you to quickly add data to the 
workbook footer. If none of the predefined footer items suits your needs, Excel also offers tools that 
make it easy to build a custom footer.

Add a Workbook Footer
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7	 Click a button in the Header & 
Footer Elements group to add that 
element to the footer.

	D	 Excel inserts a code into the footer, 
such as &[Pages] for the Number of 
Pages element, as shown here.

8	 Repeat steps 5 to 7 to build the 
footer.

9	 Click outside the footer area.

Excel applies the footer. When you 
are in Page Layout view, you see 
the current values for elements 
such as the page number.

5	 Type your text in the footer.

6	 If you want to include a predefined 
footer item, click Footer and then 
click the item.

TIP
Can I view my headers and footers before I print the workbook?
Yes. Follow these steps:

1	 Click the File tab.

2	 Click Print.

	A	 The right side of the Print tab shows you a preview of the workbook printout.

	B	 The header appears here.

	C	 The footer appears here.
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Importing Data 
into Excel
Excel offers a number of tools that enable you to import external data 
into the program. Excel can access a wide variety of external data 
types. However, this chapter focuses on the six most common types: 
data source files, Access tables, Word tables, text files, web pages, 
and XML files.
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Understanding External Data

External data is data that resides outside of Excel in a file, database, server, or website. You can import 
external data directly into an Excel PivotTable or worksheet for additional types of data analysis.

Before you learn the specifics of importing external data into your Excel workbooks, you need to 
understand the various types of external data that you are likely to encounter. For the vast majority 
of applications, external data comes in one of the following six formats: data sources, Access tables, 
Word tables, text files, web pages, and XML files.

Data Source File
Open Database Connectivity (ODBC) data sources 
give you access to data residing in databases such 
as Access and dBase, or on servers such as SQL 
Server and Oracle. However, there are many other 
data‐source types that connect to specific objects 
in a data source. For more information, see the 
next section, “Import Data from a Data Source.”

Access Table
Microsoft Access is the Office suite’s relational database 
management system, and so it is often used to store and 
manage the bulk of the data used by a person, team, 
department, or company. For more information, see the 
section “Import Data from an Access Table.”

Word Table
Some simple data is often stored in a table embedded in a 
Word document. You can only perform so much analysis on that 
data within Word, and so it is often useful to import the data 
from the Word table into an Excel worksheet. For more 
information, see the section “Import Data from a Word Table.”

Text File
Text files often contain useful data. If that data is 
formatted properly — for example, where each line has 
the same number of items, all separated by spaces, 
commas, or tabs — then it is possible to import that 
data into Excel for further analysis. For more information, 
see the section “Import Data from a Text File.”
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Web Page
People and companies often store useful data on web pages 
that reside either on the Internet or on company Intranets. This 
data is often a combination of text and tables, but you cannot 
analyze web‐based data in any meaningful way in your web 
browser. Fortunately, Excel enables you to create a web query 
that lets you import text and tables from a web page. For more 
information, see the section “Import Data from a Web Page.”

XML
XML — Extensible Markup Language — is redefining how data is 
stored. This is reflected in the large number of tools that Excel now 
has for dealing with XML data, particularly tools for importing XML 
data into Excel. For more information, see the section “Import Data 
from an XML File.”

Access to External Data
To use external data, you must have access to it. This 
usually means knowing at least one of the following: the 
location of the data or the login information required to 
authorize your use of the data.

Location
To access external data, you must at least know where it is located. Here 
are the most common possibilities: in a file on your computer; in a file 
on your network; on a network server, particularly as part of a large, 
server‐based database management system, such as SQL Server or Oracle; 
on a web page; or on a web server.

Login
Knowing where the data is located is probably all that you 
require if you are dealing with a local file or database or, 
usually, a web page. However, after you start accessing 
data remotely — on a network, database server, or web 
server — you will also require authorization to secure that 
access. See the administrator of the resource to obtain a 
username or login ID as well as a password.
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The Existing Connections dialog box appears.

4	 Click the data source you want to import.

5	 Click Open.

1	 Click the Data tab.

2	 Click Get External Data.

3	 Click Existing Connections.

Import Data from a Data Source

You can quickly import data into just about any format by importing the data from a defined data 
source file.

In this section, you learn how to import data from a data connection file. This is a data source 
that connects you to a wide variety of data, including ODBC, SQL Server, SQL Server OLAP Services, 
Oracle, and web‐based data retrieval services. You can also read the tip to learn how to create a data 
connection file.

Import Data from a Data Source
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The Import Data dialog box 
appears.

6	 Click Table (  changes to ).

	A	 To import the data directly into 
a PivotTable, click PivotTable 
Report (  changes to ).

7	 Click Existing worksheet  
(  changes to ).

8	 Click the cell where you want 
the imported data to appear.

	B	 To import the data to a new 
sheet, click New worksheet  
(  changes to ).

9	 Click OK.

Excel imports the data into the 
worksheet.

How do I create a data connection file?
To create your own data connection (.odc) file, click the Data tab, click Get External Data, click From Other 
Sources, and then click From Data Connection Wizard. Click the data source you want, and then click Next.
The next steps depend on the data source. For example, for Microsoft SQL Server or Oracle, you specify the 
server name or address and your server login data; similarly, for ODBC DSN (Database Source Name) you 
choose the ODBC data source, specify the location of the file, and select the table or query to which you 
want to connect.

When you get to the Import Data dialog box, click OK to import the data or click Cancel if you just want to 
create the data source file for now.

TIP
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If you want to use Excel to analyze data from a table within an Access database, you can import 
the table to an Excel worksheet.

In Excel, you can use Microsoft Query to create a database query to extract records from a database, 
to filter and sort the records, and then to return the results to your worksheet. Excel offers tools 
creating a database query for any ODBC data source, including an Access database. However, Excel 
also gives you an easier way to do this: You can import the table directly from the Access database.

Import Data from an Access Table

1	 Click the Data tab.

2	 Click Get External Data.

3	 Click From Access.

The Select Data Source dialog 
box appears.

4	 Open the folder that contains 
the database.

5	 Click the file.

6	 Click Open.

Note: If the Data Link Properties 
dialog box appears, make sure the 
login information is correct, and 
then click Test Connection until 
you can connect. Click OK.

The Select Table dialog box 
appears.

7	 Click the table or query you 
want to import.

8	 Click OK.

Import Data from an Access Table
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The Import Data dialog box 
appears.

9	 Click Table (  changes to ).

	A	 To import the data directly into  
a PivotTable, click PivotTable 
Report (  changes to ).

10	 Select Existing worksheet  
(  changes to ).

11	 Click the cell where you want  
the imported data to appear.

	B	 To import the data to a new 
sheet, click New worksheet  
(  changes to ).

12	 Click OK.

Excel imports the data to the 
worksheet.

Why am I prompted multiple times for my password?
To avoid this extra step, tell Excel to save the database password along 
with the external data. Click the Data tab, click the Refresh All drop‐
down arrow ( ), and then click Connection Properties. In the 
Connection Properties dialog box, click the Definition tab, and then 
select the Save password check box (  changes to ). Click Yes,  
and then click OK.

TIP
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Word tables are collections of rows, columns, and cells that look like Excel ranges. You can insert 
fields into Word table cells to perform calculations. In fact, Word fields support cell references, 

built‐in functions such as SUM and AVERAGE, and operators such as addition (+) and multiplication 
(*), to build formulas that calculate results based on the table data.

However, even the most powerful Word formulas cannot perform the tasks available to you in Excel, 
which offers much more sophisticated data analysis tools. Therefore, to analyze your Word table data 
properly, you should import the table into an Excel worksheet.

Import Data from a Word Table

1	 Launch Microsoft Word and open 
the document that contains the 
table.

2	 Click a cell inside the table you 
want to import.

3	 Click the Layout tab.

4	 Click Select.

5	 Click Select Table.

	A	 You can also select the table by 
clicking the table selection 
handle ( ).

6	 Click the Home tab.

7	 Click Copy ( ).

You can also press  +  .

Word copies the table to the 
Clipboard.

Import Data from a Word Table
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8	 Switch to the Excel workbook 
into which you want to import 
the table.

9	 Click the cell where you want the 
table to appear.

10	 Click the Home tab.

11	 Click Paste ( ).

You can also press  +  .

Excel pastes the Word table data.

If I make changes to the Word data, are those changes automatically reflected in the Excel data?
No. If this is a concern, a better approach is to shift the data’s container application from Word to Excel. That 
is, after you paste the table data into Excel, copy the Excel range, switch to Word, click the Home tab, click 
the Paste drop‐down arrow ( ), and then click Paste Special. In the Paste Special dialog box, click HTML 
Format in the As list, and then click Paste link (  changes to ). Click OK, and the resulting table is 
linked to the Excel data. This means that any changes you make to the data in Excel automatically appear 
in the Word table. Note, however, that if you change the data in Word, you cannot update the original data 
in Excel.

TIP
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The Import Text File dialog box 
appears.

5	 Open the folder that contains the 
text file.

6	 Click the text file.

7	 Click Import.

The Text Import Wizard – Step 1  
of 3 dialog box appears.

Note: For delimited text, continue 
with the subsection “Import Delimited 
Data”; for fixed‐width text, skip to the 
subsection “Import Fixed‐Width Data.”

Start the Text Import Wizard
1	 Click the cell where you want the 

imported data to appear.

2	 Click the Data tab.

3	 Click Get External Data.

4	 Click From Text.

Import Data from a Text File

Today, most data resides in some kind of special format, such as an Excel workbook, Access 
database, or web page. However, it is still relatively common to find data stored in simple text 

files because text is a universal format that works on any system and a wide variety of programs. You 
can analyze the data contained in certain text files by importing the data into an Excel worksheet.

Note, however, that although you can import any text file into Excel, you will get the best results if 
you only import delimited or fixed‐width text files. See the tip to learn more.

Import Data from a Text File
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Import Delimited Data
1	 Click Delimited (  changes to ).

2	 Use the Start import at row spin box 
( ) to set the first row you want to 
import.

3	 If the first import row consists of 
column headers, select the My data has 
headers check box (  changes to ).

4	 Click Next.

The Text Import Wizard – Step 2 of 3 
dialog box appears.

5	 Select the check box beside the 
delimiter character that your text data 
uses (  changes to ( ).

	A	 If you choose the correct delimiter, 
the data appears in separate columns.

6	 Click Next.

The Text Import Wizard – Step 3 of 3 
dialog box appears.

Note: To complete this section, follow the 
steps in the subsection “Finish the Text 
Import Wizard.”

What are delimited and fixed‐width text files?
A delimited text file uses a text structure in which each item on a line of text is separated by a character 
called a delimiter. The most common text delimiter is the comma (,). A delimited text file is imported into 
Excel by treating each line of text as a record and each item between the delimiter as a field.

A fixed‐width text file uses a text structure in which all the items on a line of text use a set amount of  
space — say, 10 or 20 characters — and these fixed widths are the same on every line of text. A fixed‐width 
text file is imported into Excel by treating each line of text as a record and each fixed‐width item as a field.

TIP
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If you are importing data that uses the fixed‐width structure, you need to tell Excel where the 
separation between each field occurs.

In a fixed‐width text file, each column of data is a constant width. The Text Import Wizard is usually 
quite good at determining the width of each column, and in most cases, the wizard automatically 
sets up column break lines, which are vertical lines that separate one field from the next. However, 
titles or introductory text at the beginning of the file can impair the wizard’s calculations. Make sure 
the proposed break lines are accurate.

Import Data from a Text File (continued)

Import Fixed‐Width Data
Note: You need to have run through the 
steps in the subsection “Start the Text 
Import Wizard” before continuing with this 
section.

1	 Click Fixed width (  changes to ).

2	 Use the Start import at row spin box ( ) 
to set the first row you want to import.

3	 If the first import row consists of column 
headers, select the My data has headers 
check box (  changes to ).

4	 Click Next.

The Text Import Wizard – Step 2 of 3 
dialog box appears.

5	 Click and drag a break line to set the 
width of each column.

	B	 To create a break line, you can click the 
ruler at the point where you want the 
break to appear.

	C	 To delete a break line, you can  
double‐click it.

6	 Click Next.

The Text Import Wizard – Step 3 of 3 
dialog box appears.

Import Data from a Text File (continued)
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Finish the Text Import Wizard
1	 Click a column.

2	 Click the radio button of the data 
format you want Excel to apply to 
the column (  changes to ).

	D	 If you select the Date option, you 
can use this drop‐down list to select 
the date format your data uses.

3	 Repeat steps 1 and 2 to set the data 
format for all the columns.

4	 Click Finish.

The Import Data dialog box appears.

5	 Click Existing worksheet (  changes 
to ).

	E	 If you want the data to appear in a 
new sheet, click New worksheet  
(  changes to ).

6	 Click OK.

Excel imports the data to the 
worksheet.

What do I do when my data uses a comma 
instead of a dot as the decimal separator?
To import such data, click Advanced in the Text 
Import Wizard – Step 3 of 3 dialog box to display 
the Advanced Text Import Settings dialog box. Click 
the Decimal separator drop‐down arrow ( ), and 
then click the text’s decimal separator. You can also 
click the Thousands separator drop‐down arrow 
( ), and then click the text’s thousands separator.

If I make a mistake when importing a text file, 
do I have to start over?
No. Click any cell in the imported data, click the  
Data tab, click the Refresh All drop‐down arrow ( ), 
and then click Connection Properties. Click the 
Definition tab, and then click Edit Query. The Import 
Text File dialog box appears. Click the file you want, 
and then click Import. Excel launches the Import Text 
Wizard so you can run through the options again.

TIPS
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Data is often available on web pages. Although this data is usually text, some web page data comes 
as either a table (a rectangular array of rows and columns) or as preformatted text (text that has 

been structured with a predefined spacing used to organize data into columns with fixed widths).

Both types are suitable for import into Excel so that you can perform more extensive data analysis. 
To import web page data, the file must reside on your computer or on your network.

Import Data from a Web Page

The New Web Query dialog box 
appears.

5	 Type the address of the web page.

6	 Click Go.

	A	 Excel loads the page into the  
dialog box.

7	 Click the Select Table icon ( ) 
beside the table that you want  
to import.

	B	 Excel selects the table.

8	 Click Import.

1	 Click the cell where you want the 
imported data to appear.

2	 Click the Data tab.

3	 Click Get External Data.

4	 Click From Web.

Import Data from a Web Page
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The Import Data dialog box appears.

9	 Click Existing worksheet (  changes 
to ).

	C	 If you want the data to appear in a 
new sheet, click New worksheet  
(  changes to ).

10	 Click OK.

Excel imports the data to the 
worksheet.

Are there other ways to import a web page into Excel?
Yes. Excel gives you two other methods for creating web queries. Both of these alternative methods assume 
that you already have the web page open in Internet Explorer:

•	 Right‐click the page, and then click Export to Microsoft Excel.
•	 Copy the web page text, switch to Excel, and then paste the text. When the Paste Options smart tag 

appears, click the smart tag drop‐down arrow ( ), and then click Refreshable Web Query.

Each of these methods opens the New Web Query dialog box and automatically loads the web page.

If you want to save the web query for future use in other workbooks, click Save Query ( ) in the New Web 
Query dialog box, and then use the Save Workspace dialog box to save the query file.

TIP
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The Select Data Source dialog box 
appears.

6	 Select the folder that contains the 
XML file you want to import.

7	 Click the XML file.

8	 Click Open.

1	 Click the cell where you want 
the imported data to appear.

2	 Click the Data tab.

3	 Click Get External Data.

4	 Click From Other Sources.

5	 Click From XML Data Import.

Import Data from an XML File

You can analyze data that currently resides in XML format by importing that data into Excel and 
then manipulating and analyzing the resulting table.

XML, or extensible markup language, is a standard that enables the management and sharing of 
structured data using simple text files. These XML files organize data using tags that specify the 
equivalent of a table name and field names. Because XML is just text, if you want to perform data 
analysis on the XML file, you must import the XML file into an Excel table.

Import Data from an XML File
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Note: If you see a dialog box that 
says there is a problem with the 
data, click OK.

The Import Data dialog box 
appears.

9	 Click XML table in existing 
worksheet (  changes to ).

10	 Click OK.

Excel imports the data into the 
worksheet as an XML table.

What does an XML file look like?
An XML file is a text file that uses a specific structure. Here is 
a simple XML example that constitutes a single record in a 
table named Products:

<Products>

<ProductName>Chai</ProductName>

<CompanyName>Exotic Liquids</CompanyName>

<ContactName>Charlotte Cooper</ContactName>

</Products>

TIPS
Can I remove a field in the XML table?
Yes. Right‐click the XML table, click XML, 
and then click XML Source to display the 
XML Source pane. The XML Source pane 
displays a list of the fields — called 
elements in the XML table. To remove an 
element, right‐click it and then click 
Remove element. To add an element back 
into the XML list, right‐click the element 
and then click Map element.
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External data often changes; you can ensure that you are working with the most up‐to‐date version 
of the information by refreshing the imported data.

Refreshing the imported data means retrieving the most current version of the source data. This 
is usually a straightforward operation. However, it is possible to construct a query that accesses 
confidential information or destroys some or all of the external data. Therefore, when you refresh 
imported data, Excel always lets you know the potential risks and asks if you are sure the query is safe.

Refresh Imported Data

Refresh Non‐Text Data
1	 Click any cell inside the imported 

data.

Refresh Imported Data

2	 Click the Data tab.

3	 Click the Refresh All drop‐down 
arrow ( ).

4	 Click Refresh.

Note: You can also refresh the current 
data by pressing  +  .

	A	 To refresh all the imported data  
in the current workbook, you  
can click Refresh All, or press 

 +   +  .

Excel refreshes the imported data.
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Refresh Text Data
1	 Click any cell inside the imported 

text data.

2	 Click the Data tab.

3	 Click the Refresh All drop‐down 
arrow ( ).

4	 Click Refresh.

Note: You can also refresh the 
current data by pressing  +  .

The Import Text File dialog box 
appears.

5	 Open the folder that contains the 
text file.

6	 Click the text file.

7	 Click Import.

Excel refreshes the imported  
text data.

Is there an easier way to refresh data regularly?
In most cases, you can set up a schedule that 
automatically refreshes the data at a specified 
interval. Follow steps 1 to 3 in the subsection 
“Refresh Non‐Text Data,” and then click Connection 
Properties. Select the Refresh Every check box  
(  changes to ). Use the spin box ( ) to specify 
the refresh interval in minutes (not every type of 
imported data supports this feature).

Why does my refresh not seem to be working?
The refresh may take a long time. To check the 
status of the refresh, follow steps 1 to 3 in the 
subsection “Refresh Non‐Text Data,” and then click 
Refresh Status to display the External Data 
Refresh Status dialog box; click Close to continue 
the refresh. If the refresh is taking too long, 
repeat steps 1 to 3, and then click Cancel Refresh 
to stop it.

TIPS
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You can make imported data easier to analyze by separating the text in each cell into two or more 
columns of data.

An imported data column may contain multiple items of data. In imported contact data, for example, 
a column might contain each person’s first and last name, separated by a space. This is problematic 
when sorting the contacts by last name, so you need to organize the names into separate columns. 
Excel makes this easy with the Text to Columns feature, which examines a column of data and then 
separates it into two or more columns.

Separate Cell Text into Columns

1	 Insert a column to the right 
of the column you want to 
separate.

Note: If the data will separate into 
three or more columns, you can 
insert as many new columns as you 
need to hold the separated data.

2	 Select the data you want to 
separate.

3	 Click the Data tab.

4	 Click Text to Columns ( ).

Separate Cell Text into Columns

The Convert Text to Columns Wizard –  
Step 1 of 3 dialog box appears.

5	 Click Delimited (  changes to ).

6	 Click Next.
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The Convert Text to Columns Wizard – 
Step 2 of 3 dialog box appears.

7	 Select the check box beside the delimiter 
character that your text data uses  
(  changes to ).

	A	 If you choose the correct delimiter, the 
data appears in separate columns.

8	 Click Next.

The Convert Text to Columns Wizard – 
Step 3 of 3 dialog box appears.

9	 Click a column.

10	 Click the radio button of the data format 
you want Excel to apply to the column 
(  changes to ).

	B	 If you click the Date option, you can use 
this list to click the date format your 
data uses.

11	 Repeat steps 9 and 10 to set the data 
format for all the columns.

12	 Click Finish.

Excel asks if you want to replace the 
contents of the destination cells.

13	 Click OK (not shown).

Excel separates the data.

TIPS

What do I do if my column contains  
fixed‐width text?
Follow steps 1 to 4 to start the Convert 
Text to Columns Wizard. Click the Fixed 
width radio button (  changes to ). 
Click Next, and then click and drag a break 
line to set the width of each column. Click 
Next, and then follow steps 9 to 13 to 
complete the wizard.

Does Excel always create only one extra column  
from the data?
No, not always. For example, in a column of contact names, 
if any of those names use three words, Excel assumes that 
you want to create two extra columns for all the data. 
Unfortunately, this might cause Excel to overwrite some of 
your existing data. Therefore, before separating data into 
columns, check the data to see exactly how many columns 
Excel will create.
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Printing 
Workbooks
If you want to distribute hard copies of one or more worksheets or 
an entire workbook, you can use the Excel Print feature. Before you 
print, you can adjust print‐related options such as the margins, page 
orientation, and paper size.



Adjust the Workbook Margins .   .   .   .   .   .   .   .   .   .   .   .   .   .  190

Change the Page Orientation .  .  .  .  .  .  .  .  .  .  .  .  .  .  .               192

Insert a Page Break  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                   193

Choose a Paper Size .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                   194

Set the Print Area .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                    196

Configure Titles to Print on Each Page .   .   .   .   .   .   .   .   .   .  198

Preview the Printout .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                  200

Print a Workbook  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                    202



190

5	 Use the spin boxes to specify the 
margin sizes in inches.

Note: Do not make the margins too 
small or your document may not print 
properly. Most printers cannot handle 
margins smaller than about 0.25 inch, 
although you should consult your 
printer manual to confirm this. In 
particular, see if your printer offers a 
“borderless” printing option.

6	 Click OK.

Excel adjusts the margin sizes.

Use the Ribbon
1	 Open the workbook you want to 

print.

2	 Click the Page Layout tab.

3	 Click Margins ( ).

	A	 If you see a margin setting you 
want to use, click the setting and 
skip the rest of these steps.

4	 Click Custom Margins.

The Page Setup dialog box 
appears with the Margins tab 
selected.

Adjust the Workbook Margins

Adjust the Workbook Margins

You can get more space on the printed page to display your worksheet data by using smaller page 
margins. The margins are the blank areas that surround the printed data. For example, if you find 

that Excel is printing extra pages because your data is a bit too wide or a bit too long to fit on a 
single page, you can reduce either the left and right margins or the top and bottom margins.

If you or another person will be writing notes on the printouts, consider using wider margins to 
allow more room for the notes.
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Use the Ruler
1	 Open the workbook you want to print.

2	 Click Page Layout ( ).

3	 Move the  over the right edge of the 
ruler’s left margin area (  changes  
to ).

4	 Click and drag the edge of the margin 
to set the left margin width.

5	 Click and drag the left edge of the right 
margin area to set the margin width.

TIPS
I increased my margin sizes to get more room around 
the text. Is there a way to center the text on the page?
Yes. This is a good idea if you want to ensure that you 
have the same amount of whitespace above and below 
the text, and to the left and right of the text. Follow 
steps 1 to 4 in the “Use the Ribbon” subsection to open 
the Page Setup dialog box with the Margins tab selected. 
Click Horizontally (  changes to ), click Vertically  
(  changes to ), and then click OK.

What are the header and footer margins?
The header margin is the space between the 
workbook header and the top of the page, and 
the footer margin is the space between the 
workbook footer and the bottom of the page. 
(See Chapter 7 to learn how to add a header and 
footer to your workbook.) In the Margins tab  
of the Page Setup dialog box, use the Header 
and Footer spin boxes to set these margins.

6	 Move the  over the bottom edge 
of the ruler’s top margin area  
(  changes to ).

7	 Click and drag the edge of the 
margin to set the top margin width.

8	 Click and drag the top edge of the 
bottom margin area (not shown) 
to set the bottom margin width.

Note: You need to scroll down to the 
bottom of the page to see the bottom 
margin.

Excel adjusts the margin sizes.
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You can improve the look of your printout by changing the page orientation to suit your data. 
The page orientation determines whether Excel prints more rows or columns on a page. Portrait 

orientation is taller, so it prints more rows; landscape orientation is wider, so it prints more columns.

Choose the orientation based on your worksheet data. If your worksheet has many rows and only a few 
columns, choose portrait; if your worksheet has many columns but just a few rows, choose landscape.

Change the Page Orientation

1	 Open the workbook you want 
to print.

2	 Click the Page Layout tab.

3	 Click Orientation ( ).

Change the Page Orientation

4	 Click the orientation you want 
to use.

	A	 Excel adjusts the orientation.

	B	 Click  to see the orientation.



193

CHAPTER

9Insert a Page Break

You can control what data appears on each printed page by inserting a page break in your 
worksheet. A page break is a location within a worksheet where Excel begins a new printed page. 

Excel normally inserts its own page breaks based on the number and height of rows in the sheet, the 
number and width of the sheet columns, the margin widths, and the page orientation.

A vertical page break starts a new page at a particular column; a horizontal page break starts a new 
page at a particular row.

1	 Open the workbook you want to 
print.

2	 Select the cell to the right of 
and below where you want the 
vertical and horizontal page 
breaks to appear.

Note: Select a cell in row 1 to create 
just a vertical page break; select a 
cell in column A to create just a 
horizontal page break.

3	 Click the Page Layout tab.

4	 Click Breaks ( ).

5	 Click Insert Page Break.

	A	 Excel inserts the page breaks and 
indicates the breaks with thicker 
horizontal and vertical lines.

Insert a Page Break
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Choose a Paper Size

You can customize your print job by choosing a paper size that is appropriate for your printout. 
For example, if your worksheet has many rows, you might prefer to print it on a longer sheet of 

paper, such as a legal‐size page (8½ inches wide by 14 inches long). Similarly, if your worksheet has 
many columns, you might also want to use a longer sheet of paper, but switch to landscape mode, as 
described in the “Change the Page Orientation” section earlier in the chapter.

Check your printer manual to make sure your printer can handle the paper size you select.

Choose a Paper Size

1	 Open the workbook you want to 
print.

2	 Click the Page Layout tab.

3	 Click Size ( ).

	A	 If you see a page size you want 
to use, click the size and skip the 
rest of these steps.

4	 Click More Paper Sizes.
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6	 Click OK.

Excel uses the new paper size 
option when you print the 
workbook.

The Page Setup dialog box 
appears with the Page tab 
selected.

5	 Click the Paper size  and then 
click the size you want to use.

TIP
Is there a way to ensure that all my worksheet columns fit onto a single page?
Yes. First, try selecting a wider page size as described in this section. You can also try reducing the left 
and right margins, as described in the “Adjust the Workbook Margins” section earlier in the chapter. 
Alternatively, switch to the landscape orientation, as described in the “Change the Page Orientation” 
section earlier in the chapter. You can also follow steps 1 to 4 to display the Page Setup dialog box with 
the Page tab selected. Click Fit to (  changes to ), and set the page(s) wide by spin box to 1. Set the 
tall spin box to a number large enough that all your printed rows will fit on a single page. (If you are not 
sure about the correct number, you can click Print Preview to check.) Click OK.
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2	 Select the range that you want 
to print.

1	 Open the workbook you want to 
print.

Set the Print Area

You can control the cells that Excel includes in the printout by setting the print area for the 
worksheet. The print area is a range of cells that you select. When Excel prints the workbook, it 

prints only the cells within the print area.

You normally define a single range of cells as the print area, but it is possible to set up two or more 
ranges as the print area. See the first tip for more information.

Set the Print Area
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	A	 Excel displays a border around 
the print area.

When you print the worksheet, 
Excel prints only the cells within 
the print area.

3	 Click the Page Layout tab.

4	 Click Print Area ( ).

5	 Click Set Print Area.

TIPS
Can I define two different ranges as the  
print area?
Yes. The easiest way to do this is to follow the 
steps in this section to set the first range as the 
print area. Next, select the second range, click the 
Page Layout tab, click , and then click Add to 
Print Area. You can repeat this procedure to add 
as many ranges as you require to the print area.

How do I remove an existing print area?
First, note that if you just want to set a new print 
area, you do not need to remove the existing print 
area first. Instead, select the range you want to use 
and then follow steps 3 to 5. Excel replaces the 
original print area with the new one. If you no longer 
want a print area defined, click the Page Layout tab, 
click , and then click Clear Print Area.
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1	 Open the workbook you want 
to print.

2	 Click the tab of the worksheet 
you want to configure.

3	 Click the Page Layout tab.

4	 Click Print Titles ( ).

You can make your printout easier to read by configuring the worksheet to print the range titles 
on each page of the printout. For example, if your data has a row of headings at the top, you can 

configure the worksheet to display those headings at the top of each printout page.

Similarly, if your data has a column of headings at the left, you can configure the worksheet to 
display those headings on the left side of each printout page.

Configure Titles to Print on Each Page

Excel opens the Page Setup  
dialog box with the Sheet tab 
displayed.

5	 Click inside the Rows to repeat at 
top range box.

6	 Click Collapse Dialog ( ).

Configure Titles to Print on Each Page
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	A	 Excel collapses the Page Setup 
dialog box.

The mouse pointer changes  
from  to .

7	 Use the mouse  to click the 
row that you want to appear at 
the top of each printed page.

If you want more than one row to 
repeat at the top of each page, 
use the mouse  to click the 
last row that you want to repeat.

8	 Click Restore Dialog ( ).

	B	 The address of the row appears in 
the Rows to repeat at top box.

9	 Click OK.

When you print this worksheet, 
Excel displays the selected row at 
the top of each page.

TIP
How do I configure my worksheet to print a column of headings on each page?
If your headings appear in a column rather than a row, you can still configure the sheet to print them on 
each page. Follow these steps:

1	 Follow steps 1 to 4 to open the Page Setup dialog box with the Sheet tab displayed.

2	 Click inside the Columns to repeat at left range box.

3	 Click .

4	 Use the mouse  to click the column that you want to appear on the left of each printed page.

5	 Click .

6	 Click OK.
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You can save time and paper by using the Print Preview feature to examine your printout on‐screen 
before you send it to the printer. You can use Print Preview to make sure settings such as margins, 

page orientation, page breaks, print areas, and sheet titles all result in the printout you want.

If you see a problem in the preview, you can use the Print Preview screen to make adjustments to 
some printout options.

Preview the Printout

1	 Open the workbook you want to 
print.

2	 Click the tab of the worksheet 
you want to preview.

3	 Click the File tab.

4	 Click Print.

The Print window appears.

	A	 Excel displays a preview of the 
printout.

Note: If you do not see the preview, 
click Show Print Preview.

5	 Click Print Preview Next Page  
( ) to scroll through the printout 
pages.

Preview the Printout
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7	 When you are done, click Back  
( ) to return to the workbook.

6	 Click Print Preview Previous Page 
( ) to return to a printout page.

	B	 You can click the Page 
Orientation  to change the 
page orientation.

	C	 You can click the Page Size  to 
change the page size.

	D	 You can click the Margins  to 
change the margins.

TIP
Can I fine‐tune the margins in Print Preview?
Yes. The Margins list only offers a few predefined margin sets. 
To define custom margins in Print Preview, follow these steps:

1	 Click Show Margins ( ).

	A	 Print Preview augments the preview with lines that indicate 
the margins.

2	 Click and drag a line to adjust that margin.
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1	 Open the workbook you want to 
print.

2	 If you only want to print a single 
worksheet, click the tab of that 
worksheet.

Note: To print multiple worksheets, 
hold down  and click the tab of 
each sheet you want to print.

3	 Click the File tab.

Print a Workbook

When you need a hard copy of your document, either for your files or to distribute to someone 
else, you can send the document to your printer.

This section assumes that you have a printer connected to your computer and that the printer is 
turned on. Also, before printing you should check that your printer has enough paper to complete 
the print job.

Print a Workbook

4	 Click Print.

Note: You can also press  +  .
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The Print window appears.

5	 Type the number of copies you want to 
print in the Copies text box.

	A	 If you have more than one printer, click 
the Printer  and then click the printer 
that you want to use.

	B	 By default, Print Active Sheets appears in 
the Print What list, which tells Excel to 
print only the selected sheets. If you want 
to print all the sheets in the workbook, 
click the Print What  and then click 
Print Entire Workbook.

6	 Click Print.

Excel prints the document.

	C	 The printer icon ( ) appears in the 
taskbar’s notification area while the 
document prints.

TIPS
Is there a faster way to print?
Yes. To print a single copy of the selected worksheet, 
you can use the Excel Quick Print command to send the 
worksheet directly to your default printer. Click  in 
the Quick Access Toolbar, and then click Quick Print to 
add this command to the toolbar. You can then click 
Quick Print ( ) to print the current worksheet 
without having to go through the Print window.

Can I print just part of a worksheet?
Yes, you can tell Excel to print just a range. 
Begin by selecting the range or ranges you want 
to print. (See Chapter 1 to learn how to select a 
range.) Follow steps 3 and 4 to open the Print 
window and choose the number of copies. Click 
the Print What  and then click Print 
Selection. Click Print.
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Working with 
Tables
The forte of Excel is spreadsheet work, of course, but its row‐and‐
column layout also makes it a natural flat‐file database manager. That 
is, instead of entering data and then using the Excel tools to build 
formulas and analyze that data, you can also use Excel simply to store 
data in a special structure called a table.
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Understanding Tables

In Excel, a table is a rectangular range of cells used to store data. The table is a collection of related 
information with an organizational structure that makes it easy to find or extract data from its 

contents. To get the most out of Excel tables, you need to understand a few basic concepts, such as 
how a table is like a database, the advantages of tables, and how tables help with data analysis.

A Table Is a Database
A table is a type of database where the data  
is organized into rows and columns: Each 
column represents a database field, which  
is a single type of information, such as a  
name, address, or phone number; each row 
represents a database record, which is a 
collection of associated field values, such as 
the information for a specific contact.

Advantages of a Table
A table differs from a regular Excel range in 
that Excel offers a set of tools that makes it 
easier for you to work with the data within 
a table. As you see in this chapter, these 
tools make it easy to convert existing 
worksheet data into a table, add new 
records and fields to a table, delete existing 
records and fields, insert rows to show 
totals, and apply styles.

Data Analysis
Tables are also useful tools for analyzing your data. For example, as you 
see later in this chapter in the “Create a PivotTable” section, you can 
easily use a table as the basis of a PivotTable, which is a special object 
for summarizing and analyzing data. In Chapter 11, you also learn how 
to sort table records and how to filter table data to show only specific 
records.
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Although a table looks much like a regular Excel range, it offers a number of features that 
differentiate it from a range. To understand these differences and make it as easy as possible to 

learn how to build and use tables, you need to know the various features in a typical table, such as 
the table rows and columns, the table headers, and the filter buttons.

A	 Table Column
A single type of 
information, such as 
names, addresses, or phone 
numbers. In an Excel table, 
each column is the 
equivalent of a database 
field.

B	 Column Headers
The unique names you 
assign to every table 
column that serve to label 
the type of data in each column. These names are always found in the first row of the table.

C	 Table Cell
An item in a table column that represents a single instance of that column’s data, such as a name, address, 
or phone number. In an Excel table, each cell is equivalent to a database field value.

D	 Table Row
A collection of associated table cells, such as the data for a single contact. In Excel tables, each row is the 
equivalent of a database record.

E	 Column Filter Button
A feature that gives you access to a set of commands that perform various actions on a column, such as 
sorting or filtering the column data.
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In Excel 2016, you cannot create a table from scratch and then fill that table with data. Instead, 
you must first create a range that includes at least some of the data you want in your table and 

then convert that range to a table.

Note that you do not need to enter all your data before converting the range to a table. Once you 
have the table, you can add new rows and columns as needed, as described later in this chapter. 
However, it is best to decide up front whether you want your table to have column headers.

Convert a Range to a Table

1	 Click a cell within the range 
that you want to convert to a 
table.

Convert a Range to a Table

2	 Click the Insert tab.

3	 Click Table ( ).

Note: You can also choose the Table 
command by pressing  + .
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The Create Table dialog box 
appears.

	A	 Excel selects the range that it 
will convert to a table.

	B	 If you want to change the range,  
click , drag the mouse  
over the new range, and then 
click .

4	 If your range has labels that 
you want to use as column 
headers, click My table has 
headers (  changes to ).

5	 Click OK.

Excel converts the range to a 
table.

	C	 Excel applies a table format to 
the range.

	D	 The Table Tools contextual tab 
appears.

	E	 Filter buttons appear in each 
column heading.

6	 Click the Design tab to see the 
Excel table design tools.

TIPS
Do I need to add labels to the top of each column 
before converting my range to a table?
No, you do not need to add labels before performing 
the conversion. In this case, follow steps 1 to 3 to 
display the Create Table dialog box, then click My table 
has headers (  changes to ). After you click OK, 
Excel converts the range to a table and automatically 
adds headers to each column. These headers use the 
generic names Column1, Column2, and so on.

If I selected the wrong range for my table, 
is there a way to tell Excel the correct range?
Yes, although you cannot change the location of 
the headers. To redefine the range used in the 
table, first select any cell in the table. Under the 
Table Tools contextual tab, click the Design tab 
and then click Resize Table ( ) to open the 
Resize Table dialog box. Drag the mouse  over 
the new range and then click OK.
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If you want to work with part of a table, you first need to select that part of the table. For 
example, if you want to apply a format to an entire column or copy an entire row, you first need 

to select that column or row.

The normal range‐selection techniques in Excel often do not work well with a table. For example, 
selecting an entire worksheet column or row does not work because no table uses up an entire 
worksheet column or row. Instead, Excel provides several tools for selecting a table column (just the 
data or the data and the header), a table row, or the entire table.

Select Table Data

Select a Table Column  
and Header
1	 Right‐click any cell in the 

column you want to select.

2	 Click Select.

3	 Click Entire Table Column.

Excel selects the column’s data 
and header.

Select a Table Column
1	 Right‐click any cell in the 

column you want to select.

2	 Click Select.

3	 Click Table Column Data.

Excel selects all the column’s 
data cells.

Select Table Data
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Select a Table Row
1	 Right‐click any cell in the row 

you want to select.

2	 Click Select.

3	 Click Table Row.

Excel selects all the data within 
the row.

Select the Entire Table
1	 Click any cell within the table.

2	 Press  + .

Excel selects the entire table.

TIP
Can I select multiple columns or rows in a table?
Yes. To select two or more table columns, first select one cell in each of the columns that you want to 
include in your selection. If the columns are not side‐by‐side, click the first cell and then hold down   
as you click each of the other cells. Right‐click any selected cell, click Select, and then click Table Column 
Data (or Entire Table Column if you also want to include the column headers in the selection).

To select two or more table rows, first select one cell in each of the rows that you want to include in your 
selection. Again, if the rows are not adjacent, click the first cell and then hold down  as you click each 
of the other cells. Right‐click any selected cell, click Select, and then click Table Row.
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You can add a new record to your Excel table by inserting a new row. You can insert a row either 
within the table or at the end of the table.

Once you have entered the initial set of data into your table, you will likely add most new records 
within the table by inserting a new row above a current row. However, when you are in the initial data 
entry phase, you will most likely prefer to add new records by adding a row to the end of the table.

Insert a Table Row

	A	 Excel inserts the new row.

	B	 To insert a new row at the 
end of the table, select 
the lower‐right table cell 
and then press .

1	 Select a cell in the row below 
which you want to insert the 
new row.

2	 Click the Home tab.

3	 Click Insert ( ).

4	 Click Insert Table Rows Above.

Insert a Table Row
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You can add a new field to your Excel table by inserting a new column. You can insert a column 

either within the table or at the end of the table.

To make data entry easier and more efficient, you should decide in advance all the fields you want 
to include in the table. However, if later on you realize you forgot a particular field, you can still 
add it to the table. Inserting a table column is also useful if you imported or inherited the data from 
elsewhere and you see that the data is missing a field that you require.

Insert a Table Column

Insert a Table Column

1	 Select a cell in the column to 
the left of which you want to 
insert the new column.

	A	 If you want to insert the new 
column at the end of the table, 
select a cell in the last table 
column.

2	 Click the Home tab.

3	 Click Insert ( ).

4	 Click Insert Table Columns to 
the Left.

To insert a column at the end of 
the table instead, click Insert 
Table Columns to the Right 
(not shown).

	B	 Excel inserts the new column.

5	 Name the new field by editing 
the column header.
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If your table contains a record that includes inaccurate, outdated, or unnecessary data, you should 
delete that row to preserve your table’s data integrity.

An Excel table is a repository of data that you can use as a reference source or to analyze or 
summarize the data. However you use the table, it is only as beneficial as its data is accurate, so you 
should take extra care to ensure the data you enter is correct. If you find that an entire record is 
inaccurate or no longer needed, Excel enables you to quickly delete that row.

Delete a Table Row

	A	 Excel deletes the row.

1	 Select a cell in the row you 
want to delete.

Note: To delete multiple rows, 
select a cell in each row you 
want to delete.

2	 Click the Home tab.

3	 Click Delete ( ).

4	 Click Delete Table Rows.

Delete a Table Row
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If your table contains a field that you do not require, you should delete that column to make your 

table easier to work with and manage.

As you see later in this chapter and in Chapter 11, you analyze and summarize your table information 
based on the data in one or more fields. If your table contains a field that you never look at and that 
you never use for analysis or summaries, consider deleting that column to reduce table clutter and 
make your table easier to navigate.

Delete a Table Column

	A	 Excel deletes the column.

1	 Select a cell in the column 
you want to delete.

Note: To delete multiple 
columns, select a cell in each 
column you want to delete.

2	 Click the Home tab.

3	 Click Delete ( ).

4	 Click Delete Table Columns.

Delete a Table Column
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You can get more out of your table data by summarizing a field with a subtotal that appears at the 
bottom of the column.

Although the word subtotal implies that you are summing the numeric values in a column, Excel 
uses the term more broadly. That is, a subtotal can be not only a numeric sum, but also an average, 
a maximum or minimum, or a count of the values in the field. You can also choose more esoteric 
subtotals such as a standard deviation or a variance.

Add a Column Subtotal

2	 Click the Quick Analysis smart 
tag ( ).

1	 Select all the data in the 
column you want to total.

Note: See the “Select Table Data” 
section earlier in the chapter to 
learn how to select column data.

Add a Column Subtotal
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The Quick Analysis options 
appear.

3	 Click Totals.

4	 Click the type of calculation you 
want to use.

 
	A	 Excel adds a Total row to the 

bottom of the table.

	B	 Excel inserts a SUBTOTAL 
function to perform the 
calculation you chose in step 4.

	C	 Click the cell’s  to choose a 
different type of subtotal.

TIP
Is there a quick way to insert a total row in my table?
Yes. If the column you want to total is the last column in the table, you can add the total row and include 
a SUBTOTAL function for that column with just a few mouse clicks:

1	 Click any cell within the table.

2	 Click the Design tab.

3	 Select the Total Row check box  
(  changes to ).

	A	 Excel automatically inserts a row named 
Total at the bottom of the table.

	B	 Excel adds a SUBTOTAL function below 
the last column.

4	 Click the cell’s  and then click the 
type of subtotal you want to use.
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If you no longer require the Excel table tools, you can convert a table to a normal range.

Convert a Table to a Range

Excel asks you to confirm.

4	 Click Yes.

Excel converts the table to a 
normal range.

1	 Click a cell inside the table.

2	 Click the Design tab.

3	 Click Convert to Range ( ).

Convert a Table to a Range

Tables are extremely useful Excel features, but they can occasionally be bothersome. For example, if 
you click a table cell, click the Design tab, and then click a cell outside the table, Excel automatically 
switches to the Home tab. If you then click a table cell again, Excel automatically switches back 
to the Design tab. If you are not using the table features in the Design tab, this behavior can be 
annoying, but you can prevent it from happening by converting the table to a normal range.
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You can give an Excel table more visual appeal and make it easier to read by applying a table style.

Apply a Table Style

The Table Quick Styles gallery 
appears.

4	 Click the table style you want 
to use.

	A	 Excel applies the style to the 
table.

1	 Click a cell inside the table.

2	 Click the Design tab.

3	 Click Table Quick Styles.

Apply a Table Style

A table style is a combination of formatting options that Excel applies to 13 different table elements, 
including the first and last columns, the header row, the total row, and the entire table. For each 
element, Excel applies one or more of the following formatting options: the font, including the 
typeface, style, size, color, and text effects; the border; and the background color and fill effects.
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You can make it easier to format tables the way you prefer by creating a custom table style.

Build a Custom Table Style

The New Table Style dialog 
box appears.

5	 Type a name for the style.

6	 Click the table element you 
want to format.

7	 Click Format.

1	 Click a cell inside the table.

2	 Click the Design tab.

3	 Click Table Quick Styles.

	A	 The Table Styles gallery 
appears.

4	 Click New Table Style.

Build a Custom Table Style

Excel comes with dozens of predefined table styles, all of which vary with the document theme. If 
none of the predefined table styles is right for your needs, you can use the Format Cells dialog box 
to apply your own formatting to the various table elements. If you want to reuse this formatting in 
other workbooks, you can save the formatting options as a custom table style.
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The Format Cells dialog box appears.

8	 Use the tabs to select the formatting 
options you want in your cell style.

Note: Depending on the table element you 
are working with, some of the formatting 
options may be disabled.

9	 Click OK.

10	 Repeat steps 5 to 8 to set the 
formatting for the other table 
elements, as needed.

11	 Click OK in the New Table Style dialog 
box (not shown).

Is there an easy way to use the custom style for all the tables 
I create?
Yes. If you want to use your custom table style for all or most of the 
tables you create, you should set the custom style as the default. 
When you are creating a new custom table style, follow steps 1 to 10 
and then select the Set as default table style for this document 
check box (  changes to ). For an existing custom table style, 
click a table cell, click the Design tab, click the Table Styles , 
right‐click the custom style, and then click Set As Default.

How do I make changes to a 
custom table style?
To change the formatting for a 
custom table style, click a table cell, 
click the Design tab, and then click 
the Table Styles  to display the 
Table Styles gallery. Right‐click the 
custom style, click Modify, and then 
follow steps 6 to 11.

TIPS

12	 Click Table Quick Styles.

	B	 Your table style appears in the Custom 
section of the Table Styles gallery.
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You can more easily analyze a large amount of data by creating a PivotTable from that data. A 
PivotTable is a powerful data analysis tool because it automatically groups large amounts of data 

into smaller, more manageable categories, and it displays summary calculations for each group.

You can also manipulate the layout of — or pivot — the PivotTable to see different views of your 
data. Although you can create a PivotTable from a normal range, for best results, you should convert 
your range to a table before creating the PivotTable (see the “Convert a Range to a Table” section 
earlier in the chapter).

Create a PivotTable

The Create PivotTable dialog box 
appears.

4	 Click New Worksheet (  changes 
to ).

	A	 If you want to place the PivotTable 
in an existing location, click 
Existing Worksheet (  changes to 

) and then use the Location range 
box to select the worksheet and cell 
where you want the PivotTable to 
appear.

5	 Click OK.

1	 Click a cell within the table that 
you want to use as the source 
data.

2	 Click the Design tab.

3	 Click Summarize with 
PivotTable ( ).

Create a PivotTable
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	B	 Excel creates a blank 
PivotTable.

	C	 Excel displays the PivotTable 
Fields list.

6	 Click and drag a field and 
drop it inside the ROWS area.

	D	 Excel adds the field’s unique 
values to the PivotTable’s 
row area.

7	 Click and drag a numeric field 
and drop it inside the VALUES 
area.

	E	 Excel sums the numeric values 
based on the row values.

8	 If desired, click and drag fields 
and drop them in the COLUMNS 
area and the FILTERS area.

Each time you drop a field in 
an area, Excel updates the 
PivotTable to include the new 
data.

Are there faster ways to build a PivotTable?
Yes. In the PivotTable Fields list, if you 
select a check box for a text or date field  
(  changes to ), Excel adds the field to 
the ROWS area; if you select a check box for 
a numeric field (  changes to ), Excel 
adds the field to the VALUES area. You can 
also right‐click a field and then click the area 
you want to use.

Can I add multiple fields to each area?
Yes. You can add as many fields as you like to each area. 
You can also move a PivotTable’s fields from one area of 
the PivotTable to another. This enables you to view your 
data from different perspectives, which can greatly 
enhance the analysis of the data. Moving a field within a 
PivotTable is called pivoting the data. To move a field, use 
the PivotTable Fields list to click and drag a field from one 
area and drop it on another.

TIPS
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Analyzing Data
You can get more out of Excel by performing data analysis, which is 
the application of tools and techniques to organize, study, and reach 
conclusions about a specific collection of information. In this chapter, 
you learn data analysis techniques such as sorting and filtering a 
range, setting validation rules, and using subtotals and scenarios.
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Sort a Range or Table

You can make a range or table easier to read and analyze by sorting the data based on the values 
in one or more columns.

You can sort the data in either ascending or descending order. An ascending sort arranges the 
values alphabetically from A to Z, or numerically from 0 to 9; a descending sort arranges the values 
alphabetically from Z to A, or numerically from 9 to 0.

The Sort dialog box appears.

4	 Click the Sort by  and then 
click the field you want to use 
for the main sort level.

5	 Click the Order  and then 
click a sort order for the field.

6	 To sort on another field, click 
Add Level.

1	 Click any cell in the range you 
want to sort.

2	 Click the Data tab.

3	 Click Sort ( ).

Sort a Range or Table
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	A	 Excel adds another sort level.

7	 Click the Then by  and then 
click the field you want to use 
for the sort level.

8	 Click the Order  and then 
click a sort order for the field.

9	 Repeat steps 6 to 8 to add more 
sort levels as needed.

10	 Click OK.

	B	 Excel sorts the range.

TIPS
Is there a faster way to sort a range?
Yes, as long as you only need to sort your range on 
a single column. First, click in any cell inside the 
column you want to use for the sort. Click the Data 
tab and then click one of the following buttons in 
the Sort & Filter group:

Click for an ascending sort.

Click for a descending sort.

How do I sort a range using the values in a row 
instead of a column?
Excel normally sorts a range from top to bottom 
based on the values in one or more columns. 
However, you can tell Excel to sort the range from 
left to right based on the values in one or more 
rows. Follow steps 1 to 3 to display the Sort dialog 
box. Click Options to display the Sort Options 
dialog box, select the Sort left to right option  
(  changes to ), and then click OK.
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	A	 Excel adds a Filter button ( ) 
to each field.

Filter the Data
1	 Click  for the field you want 

to use as the filter.

Display the Filter Buttons
Note: If you are filtering a table, 
you can skip directly to the “Filter 
the Data” subsection.

1	 Click inside the range.

2	 Click the Data tab.

3	 Click Filter ( ).

Filter a Range or Table

You can analyze table data much faster by only viewing those table records that you want to work 
with. In Excel, this is called filtering a range.

The easiest way to filter a range is to use the Filter buttons, each of which presents you with a list of 
check boxes for each unique value in a column. You filter the data by selecting the check boxes for 
the rows you want to see. If you have converted the range to a table, as described in Chapter 10, the 
Filter buttons for each column are displayed automatically.

Filter a Range or Table
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	B	 Excel displays a list of the 
unique values in the field.

2	 Select the check box for  
each value you want to see  
(  changes to ).

	C	 You can toggle all the check 
boxes on and off by clicking 
Select All.

3	 Click OK.

	D	 Excel filters the table to show 
only those records that have the 
field values you selected.

	E	 Excel displays the number of 
records found.

	F	 The field’s drop‐down list 
displays a filter icon ( ).

To remove the filter, click  
the Data tab and then click 
Clear ( ; not shown).

TIP
Can I create more sophisticated filters?
Yes, by using a second technique called quick filters, 
which enables you to specify criteria for a field:

1	 Click  for the field you want to use as the 
filter.

2	 Click Number Filters.

Note: If the field is a date field, click Date Filters; 
if the field is a text field, click Text Filters.

3	 Click the filter you want to use.

4	 Enter the value you want to use.

5	 Click OK.
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You can make Excel data entry more efficient by setting up data entry cells to accept only certain 
values. To do this, you can set up a cell with data validation criteria that specify the allowed 

value or values. This is called a data validation rule.

Excel also lets you tell the user what to enter by defining an input message that appears when the 
user selects the cell. You can also configure the data validation rule to display a message when the 
user tries to enter an invalid value.

Set Data Validation Rules

1	 Click the cell you want to 
restrict.

2	 Click the Data tab.

3	 Click Data Validation ( ).

Set Data Validation Rules

The Data Validation dialog box 
appears.

4	 Click the Settings tab.

5	 In the Allow list, click  and 
select the type of data you want to 
allow in the cell.

6	 In the Data list, click  and 
select the operator you want to 
use to define the allowable data.

7	 Specify the validation criteria, such 
as the Maximum and Minimum 
allowable values shown here.

Note: The criteria boxes you see depend 
on the operator you chose in step 6.
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8	 Click the Input Message tab.

9	 Make sure the Show input message 
when cell is selected check box is 
selected ( ).

10	 Type a message title in the Title  
text box.

11	 Type the message you want to display 
in the Input Message text box.

12	 Click OK.

Excel configures the cell to 
accept only values that meet 
your criteria.

	A	 When the user selects the cell, 
the input message appears.

TIPS
Can I configure the cell to display a message 
if the user tries to enter an invalid value?
Yes. Follow steps 1 to 3 to open the Data Validation 
dialog box, and then click the Error Alert tab. Make 
sure the Show error alert after invalid data is 
entered check box is selected ( ), and then specify 
the Style, Title, and Error Message. Click OK.

How do I remove data validation from a cell?
If you no longer need to use data validation on a 
cell, you should clear the settings. Follow steps 1 
to 3 to display the Data Validation dialog box  
and then click Clear All. Excel removes all the 
validation criteria, as well as the input message 
and the error alert. Click OK.
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If you are interested in studying the effect a range of values has on the formula, you can set up a 
data table. This is a table that consists of the formula you are using, and multiple input values for 

that formula. Excel automatically creates a solution to the formula for each different input value.

Do not confuse data tables with the Excel tables that you learned about in Chapter 10. A data table 
is a special range that Excel uses to calculate multiple solutions to a formula.

Create a Data Table

2	 Select the range that includes the 
input values and the formula.

3	 Click the Data tab.

4	 Click What‐If Analysis ( ).

5	 Click Data Table.

1	 Type the input values:

To enter the values in a column, start 
the column one cell down and one 
cell to the left of the cell containing 
the formula, as shown here.

To enter the values in a row, start 
the row one cell up and one cell to 
the right of the cell containing the 
formula.

Create a Data Table
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The Data Table dialog box 
appears.

6	 Specify the formula cell you 
want to use as the data table’s 
input cell:

If the input values are in a 
column, enter the input cell’s 
address in the Column input 
cell text box.

If you entered the input values 
in a row, enter the input cell’s 
address in the Row input cell 
text box.

7	 Click OK.

	A	 Excel displays the results.

TIPS
What is what‐if analysis?
The technique called what‐if analysis is perhaps the 
most basic method for analyzing worksheet data. 
With what‐if analysis, you first calculate a formula 
D, based on the input from variables A, B, and C. 
You then say, “What happens to the result if I 
change the value of variable A?”, “What happens if  
I change B or C?”, and so on.

When I try to delete part of the data table,  
I get an error. Why?
The data table results are created as an array 
formula, which is a special formula that Excel treats 
as a unit. This means that you cannot move or 
delete part of the results. If you need to work with 
the data table results, you must first select the 
entire results range.
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Although you can use formulas and worksheet functions to summarize your data in various ways, 
including sums, averages, counts, maximums, and minimums, if you are in a hurry, or if you just 

need a quick summary of your data, you can get Excel to do most of the work for you. The secret 
here is a feature called automatic subtotals, which are formulas that Excel adds to a worksheet 
automatically.

Summarize Data with Subtotals

2	 Click the Data tab.

3	 Click Subtotal ( ).

1	 Click a cell within the range you 
want to subtotal.

Summarize Data with Subtotals
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The Subtotal dialog box 
appears.

4	 Click the At each change 
in  and then click the 
column you want to use to 
group the subtotals.

5	 In the Add subtotal to 
list, select the check box 
for the column you want 
to summarize (  changes 
to ).

6	 Click OK.

	A	 Excel calculates the 
subtotals and adds them 
into the range.

	B	 Excel adds outline symbols 
to the range.

Note: See the next section, 
“Group Related Data,” to learn 
more about outlining in Excel.

TIPS
Do I need to prepare my worksheet to use 
subtotals?
Yes. Excel sets up automatic subtotals based on data 
groupings in a selected field. For example, if you 
ask for subtotals based on the Customer field, Excel 
runs down the Customer column and creates a new 
subtotal each time the name changes. To get useful 
summaries, you need to sort the range on the field 
containing the data groupings you are interested in.

Can I only calculate totals?
No. The word subtotal here is a bit misleading 
because you can summarize more than just totals. 
You can also count values, calculate the average of 
the values, determine the maximum or minimum 
value, and more. To change the summary calcula­
tion, follow steps 1 to 4, click the Use function 

, and then click the function you want to use  
for the summary.
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You can control a worksheet range display by grouping the data based on the worksheet formulas 
and data.

Grouping the data creates a worksheet outline, which you can use to “collapse” sections of the sheet 
to display only summary cells, or “expand” hidden sections to show the underlying detail. Note 
that when you add subtotals to a range as described in the previous section, “Summarize Data with 
Subtotals,” Excel automatically groups the data and displays the outline tools.

Group Related Data

	A	 Excel outlines the worksheet 
data.

	B	 Excel uses level bars to indicate 
the grouped ranges.

	C	 Excel displays level symbols to 
indicate the various levels of the 
detail that are available in the 
outline.

Create the Outline
1	 Display the worksheet you want 

to outline.

2	 Click the Data tab.

3	 Click the Group .

4	 Click Auto Outline.

Group Related Data
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Use the Outline to Control 
the Range Display

1	 Click a Collapse symbol ( ) to 
hide the range indicated by the 
level bar.

	D	 You can also collapse multiple 
ranges that are on the same 
outline level by clicking the 
appropriate level symbol.

Do I have to prepare my worksheet before I can group the data?
Yes. Not all worksheets can be grouped, so you need to make sure your worksheet is a candidate for 
outlining. First, the worksheet must contain formulas that reference cells or ranges directly adjacent to the 
formula cell. Worksheets with SUM( ) functions that subtotal cells above or to the left are particularly good 
candidates for outlining.

Second, there must be a consistent pattern to the direction of the formula references. For example, a 
worksheet with formulas that always reference cells above or to the left can be outlined. Excel will not 
outline a worksheet with, say, SUM( ) functions that reference ranges above and below a formula cell.

TIP

	E	 Excel collapses the range.

2	 Click the Expand symbol ( ) to 
view the range again.

	F	 You can also show multiple 
ranges that are on the same 
outline level by clicking the 
appropriate level symbol.
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If you already know the formula result you want, but you must find an input value that produces 
that result, you can use the Excel Goal Seek tool to solve the problem. You tell Goal Seek the final 

value you need and which variable to change, and it finds a solution for you.

For example, you might know that you want to have $50,000 saved to purchase new equipment five 
years from now, so you need to calculate how much to invest each year.

Analyze Data with Goal Seek

2	 Click the Data tab.

3	 Click What‐If Analysis ( ).

4	 Click Goal Seek.

The Goal Seek dialog box 
appears.

1	 Set up your worksheet model.

Note: See the first tip to learn more 
about setting up a worksheet for 
Goal Seek.

Analyze Data with Goal Seek
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5	 Click inside the Set cell box.

6	 Click the cell that contains the 
formula you want Goal Seek to 
work with.

7	 Use the To value text box to 
type the value that you want 
Goal Seek to find.

8	 Click in the By changing cell box.

9	 Click the cell that you want Goal 
Seek to modify.

10	 Click OK.

	A	 Goal Seek adjusts the changing 
cell value until it reaches a 
solution.

	B	 The formula now shows the 
value you entered in step 7.

11	 Click OK.

TIPS
How do I set up my worksheet to use Goal Seek?
Setting up your worksheet model for Goal Seek 
means doing three things. First, set up one cell as 
the changing cell, which is the value that Goal Seek 
will manipulate to reach the goal. Enter an initial 
value (such as 0) into the cell. Second, set up the 
other input values for the formula and give them 
proper initial values. Third, create a formula for Goal 
Seek to use to reach the goal.

What other types of problems can Goal Seek solve?
One common problem is called a break‐even analysis, 
where you determine the number of units you have 
to sell of a product so that your total profits are 0. 
In this case, the changing cell is the number of 
units sold, and the formula is the profit calculation. 
You can also use Goal Seek to determine which price 
(the changing cell) is required to return a particular 
profit margin (the formula).
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You can analyze the result of a formula by creating sets of values that enable you to quickly use 
those values as the inputs for a formula.

For example, one set of values might represent a best‐case approach, while another might represent 
a worst‐case approach. In Excel, each of these coherent sets of input values — known as changing 
cells — is called a scenario. By creating multiple scenarios, you can easily apply these different value 
sets to analyze how the result of a formula changes under different conditions.

Analyze Data with Scenarios

2	 Click the Data tab.

3	 Click What‐If Analysis ( ).

4	 Click Scenario Manager.

Create a Scenario
1	 Set up your worksheet model.

Analyze Data with Scenarios
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The Scenario Manager dialog 
box appears.

5	 Click Add.

TIPS
Are there any restrictions on the changing 
cells?
When you are building a worksheet model for 
use with scenarios, make sure that each 
changing cell is a constant value. If you use a 
formula for a changing cell, Excel replaces that 
formula with a constant value defined in the 
scenario, so you lose your formula.

Do I need to add a description to each scenario?
Yes. As you see in the next section, once you have one or 
more scenarios defined, they appear in the Scenario 
Manager, and for each scenario you see its changing cells 
and its description. The description is often very useful, 
particularly if you have several scenarios defined, so be 
sure to write a detailed description in step 9 to help you 
differentiate your scenarios later on.

The Add Scenario dialog box 
appears.

6	 Type a name for the scenario.

7	 Click in the Changing cells box.

8	 Select the cells you want to 
change in the scenario.

9	 Type a description for the 
scenario.

10	 Click OK.
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Excel stores your scenarios in the Scenario Manager. You can use the Scenario Manager to perform 
a number of scenario‐related tasks. For example, you can select one of your scenarios and then 

click a button to display the scenario’s values in your worksheet. You can also use the Scenario 
Manager to edit existing scenarios and to delete scenarios you no longer need.

Analyze Data with Scenarios (continued)

13	 Click Close.

The Scenario Values dialog box appears.

11	 Use the text boxes to specify a value for each 
changing cell.

	A	 To add more scenarios, click Add and then repeat 
steps 6 to 11.

12	 Click OK.

Analyze Data with Scenarios (continued)
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Display Scenarios

1	 Click the Data tab.

2	 Click .

3	 Click Scenario Manager.

TIPS
How do I edit a scenario?
If you need to make changes to a scenario, 
you can edit the name, the changing cells, 
the description, and the scenario’s input 
values. Click the Data tab, click , and then 
click Scenario Manager. In the Scenario 
Manager dialog box, click the scenario you 
want to modify, and then click Edit.

How do I remove a scenario?
If you have a scenario that you no longer need, you should 
delete it to reduce clutter in the Scenario Manager. Click 
the Data tab, click , and then click Scenario Manager. 
Click the scenario you want to delete. Note that Excel does 
not ask you to confirm the deletion, so double‐check that 
you have selected the correct scenario. Click Delete and 
then click Close.

The Scenario Manager dialog  
box appears.

4	 Click the scenario you want  
to display.

5	 Click Show.

	B	 Excel enters the scenario values 
into the changing cells and 
displays the formula result.

6	 Repeat steps 4 and 5 to display 
other scenarios.

7	 Click Close.
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You can make your Excel data more accurate for analysis by removing any duplicate records. 
Duplicate records throw off your calculations by including the same data two or more times. 

To prevent this, you should delete duplicate records. However, rather than looking for duplicates 
manually, you can use the Remove Duplicates command, which can quickly find and remove 
duplicates in even the largest ranges or tables.

Before you use the Remove Duplicates command, you must decide what defines a duplicate record in 
your data. That is, does every field have to be identical or is it enough that only certain fields are 
identical?

Remove Duplicate Values from a Range or Table

Remove Duplicate Values from a Range or Table

1	 Click a cell inside the range or 
table.

2	 Click the Data tab.

3	 Click Remove Duplicates ( ).
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The Remove Duplicates dialog box appears.

4	 Select the check box beside each field that 
you want Excel to check for duplication 
values (  changes to ).

Note: Excel does not give you a chance to 
confirm the deletion of the duplicate records, so 
be sure you want to do this before proceeding.

5	 Click OK.

TIPS
If I have a lot of columns, is there a quick way to 
check for duplicates based on just a couple of 
those fields?
Yes. If your table has many fields, you may want 
Excel to use only one or two of those fields to look 
for duplicate records. Rather than deselecting all 
the other check boxes manually, first click Unselect 
All in the Remove Duplicates dialog box to clear all 
the check boxes (  changes to ). You can then 
select just the check boxes you want Excel to use 
(  changes to ).

Can I remove duplicates even if my range does 
not have column headers?
Yes. Excel can still examine the column data  
even if there are no headers. In this case, follow 
steps 1 to 3 to open the Remove Duplicates 
dialog box, then make sure the My data has 
headers check box is deselected ( ). Use the 
check boxes labeled Column A, Column B, and  
so on to choose the columns that you want Excel 
to check for duplicate values (  changes to ) 
and then click OK.

Excel deletes any duplicate 
records that it finds.

	A	 Excel tells you the number of 
duplicate records that it deleted.

6	 Click OK.
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1	 Select the range with which  
you want to work.

2	 Click the Home tab.

3	 Click Conditional  
Formatting ( ).

4	 Click Highlight Cells Rules.

5	 Click the operator you want  
to use for the condition.

A dialog box appears, the  
name of which depends on  
the operator you clicked in  
step 5.

6	 Type the value you want to  
use for the condition.

	A	 You can also click Collapse 
Dialog ( ), click a worksheet 
cell, and then click Restore 
Dialog ( ).

Depending on the operator,  
you may need to specify two 
values.

7	 Click this drop‐down arrow  
( ), and then click the 
formatting you want to use.

	B	 To create your own format, click 
Custom Format.

Highlight Cells That Meet Some Criteria

A conditional format is formatting that Excel applies only to cells that meet the criteria you specify. 
For example, you can tell Excel to apply the formatting only if a cell’s value is greater or less 

than some specified amount, between two specified values, or equal to some value. You can also look 
for cells that contain specified text, dates that occur during a specified timeframe, and more.

You can specify the font, border, and background pattern, which helps to ensure that the cells that 
meet your criteria stand out from the other cells in the range.

Highlight Cells That Meet Some Criteria
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8	 Click OK.

TIPS
Can I set up more than one conditional format  
on a range?
Yes, Excel enables you to specify multiple conditional 
formats. For example, you could set up one condition 
for cells that are greater than some value, and a 
separate condition for cells that are less than some 
other value. You can apply unique formats to each 
condition. Follow steps 1 to 8 to configure the new 
condition.

How do I remove a conditional format?
If you no longer require a conditional format, 
you can delete it. Follow steps 1 to 3 to select 
the range and display the Conditional 
Formatting drop‐down menu, and then click 
Manage Rules. Excel displays the Conditional 
Formatting Rules Manager dialog box. Click the 
conditional format you want to remove and then 
click Delete Rule.

	C	 Excel applies the formatting to 
cells that meet the condition 
you specified.
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A dialog box appears, whose 
name depends on the type of 
rule you clicked in step 5.

6	 Type the value you want to use 
for the condition.

7	 Click this drop‐down arrow  
( ), and then click the 
formatting you want to use.

	A	 To create your own format, click 
Custom Format.

1	 Select the range with which you 
want to work.

2	 Click the Home tab.

3	 Click Conditional  
Formatting ( ).

4	 Click Top/Bottom Rules.

5	 Click the type of rule you want 
to create.

Highlight the Top or Bottom Values in a Range

When analyzing worksheet data, it is often useful to look for items that stand out from the 
norm. For example, you might want to know which sales reps sold the most last year, or which 

departments had the lowest gross margins.

You can do this by setting up top/bottom rules, where Excel applies a conditional format to those 
items that are at the top or bottom of a range of values. For the top or bottom values, you can 
specify a number, such as the top 5 or 10, or a percentage, such as the bottom 20 percent.

Highlight the Top or Bottom Values in a Range
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8	 Click OK.

TIPS
Can I highlight cells that are above or below  
the average?
Yes, Excel also enables you to create top/bottom rules based 
on the average value in the range. First, follow steps 1 to 4 
to select the range and display the Top/Bottom Rules menu. 
Then click either Above Average to format those values that 
exceed the range average, or Below Average to format those 
values that are less than the range average.

How do I remove a top/bottom rule?
If you no longer require a top/bottom rule, 
you can delete it. Follow steps 1 to 3 to 
select the range and display the Conditional 
Formatting drop‐down menu. Click Clear 
Rules, and then click Clear Rules from 
Selected Cells. Excel removes the rule from 
the range.

	B	 Excel applies the formatting to cells that 
meet the condition you specified.
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2	 Click the Home tab.

3	 Click Conditional Formatting ( ).

4	 Click Data Bars.

1	 Select the range with which you want 
to work.

Analyze Cell Values with Data Bars

In some data analysis scenarios, you might be interested more in the relative values within a range 
than the absolute values. For example, if you have a table of products that includes a column 

showing unit sales, how do you compare the relative sales of all the products?

This sort of analysis is often easiest if you visualize the relative values. You can do that by using 
data bars. Data bars are a data visualization feature that applies colored, horizontal bars to each cell 
in a range of values, and these bars appear “behind” the values in the range.

Analyze Cell Values with Data Bars
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5	 Click the fill type of data bars 
you want to create:

	A	 Gradient Fill data bars begin with 
a solid color, and then gradually 
fade to a lighter color.

	B	 Solid Fill data bars are a solid 
color.

TIPS
How do data bars work?
The length of the data bar that appears in each cell 
depends on the value in that cell: The larger the 
value, the longer the data bar. The cell with the 
highest value has the longest data bar, the cell with 
the lowest value has the shortest data bar, and the 
other cells have data bars with lengths that reflect 
each cell’s value.

How do I delete data bars from a range?
If you no longer require the data bars, you can 
remove them. Follow steps 1 to 3 to select the 
range and display the Conditional Formatting drop‐
down menu, and then click Manage Rules. Excel 
displays the Conditional Formatting Rules Manager 
dialog box. Click the data bar rule you want to 
remove, click Delete Rule, and then click OK.

	C	 Excel applies the data bars to 
each cell in the range.
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2	 Click the Home tab.

3	 Click Conditional  
Formatting ( ).

4	 Click Color Scales.

1	 Select the range with which you 
want to work.

Analyze Cell Values with Color Scales

When analyzing worksheet data, it is often useful to get some idea about the overall distribution 
of the values. For example, it might be useful to know whether a range has a lot of low values 

and just a few high values.

You can analyze your worksheet data by using a conditional format called color scales. A color scale 
compares the relative values of cells in a range by applying shading to each cell, where the shading 
color is a reflection of the cell’s value.

Analyze Cell Values with Color Scales
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5	 Click the color scale that has the 
color scheme you want to apply.

	A	 Excel applies the color scales to 
each cell in the range.

TIPS
In what other situations are color scales useful?
Besides showing patterns, color scales can also tell 
you whether your data includes any outliers, values 
that are much higher or lower than all or most of the 
others. Similarly, you can also use color scales to 
make value judgments about your data. For example, 
high sales and low numbers of product defects are 
good, whereas low margins and high employee 
turnover rates are bad.

When should I use a three‐color scale versus  
a two‐color scale?
If your goal is to look for outliers or to make value 
judgments about your data, go with a three‐color 
scale because outliers stand out more, and you can 
assign your own values to the colors (such as 
positive, neutral, and negative). Use a two‐color 
scale when you want to look for patterns in the 
data, as a two‐color scale offers less contrast.



254

2	 Click the Home tab.

3	 Click Conditional  
Formatting ( ).

4	 Click Icon Sets.

1	 Select the range with which you 
want to work.

Analyze Cell Values with Icon Sets

When you are trying to make sense of a large data set, symbols that have common or well‐known 
associations are often useful for clarifying the data. For example, for most people a check mark 

means something is good or finished or acceptable, whereas an X means something is bad or unfinished 
or unacceptable; a green circle is positive, whereas a red circle is negative (think traffic lights).

Excel puts these and many other symbolic associations to good use with the icon sets feature. You 
use icon sets to visualize the relative values of cells in a range.

Analyze Cell Values with Icon Sets
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5	 Click the type of icon set you want  
to apply.

The categories include Directional, 
Shapes, Indicators, and Ratings.

TIPS
How do icon sets work?
With icon sets, Excel adds a particular icon to each 
cell in the range, and that icon tells you something 
about the cell’s value relative to the rest of the 
range. For example, the highest values might be 
assigned an upward‐pointing arrow, the lowest 
values a downward‐pointing arrow, and the values 
in between a horizontal arrow.

How do I use the different icon set categories?
The Excel icon sets come in four categories: 
Directional, Shapes, Indicators, and Ratings. Use 
Directional icon sets for indicating trends and data 
movement; use Shapes icon sets for pointing out the 
high (green) and low (red) values; use Indicators to 
add value judgments; and use Ratings to show where 
each cell resides in the overall range of data values.

	A	 Excel applies the icons to each cell  
in the range.
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Excel’s conditional formatting rules in Excel — highlight cells rules, top/bottom rules, data bars, 
color scales, and icon sets — offer an easy way to analyze data through visualization.

However, these predefined rules do not suit particular types of data or data analysis. For example, the 
icon sets assume that higher values are more positive than lower values, but that is not always true; 
in a database of product defects, lower values are better than higher ones. To get the type of data 
analysis you prefer, you can create a custom conditional formatting rule and apply it to your range.

Create a Custom Conditional Formatting Rule

2	 Click the Home tab.

3	 Click Conditional Formatting ( ).

4	 Click New Rule.

1	 Select the range you want to work with.

Create a Custom Conditional Formatting Rule
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The New Formatting Rule dialog box 
appears.

5	 Click the type of rule you want to 
create.

6	 Edit the rule’s style and formatting.

The controls you see depend on the rule 
type you selected.

	A	 With Icon Sets, click Reverse Icon 
Order if you want to reverse the normal 
icon assignments, as shown here.

7	 Click OK.

TIPS
How do I modify a custom conditional 
formatting rule?
Follow steps 1 to 3 to select the range and 
display the Conditional Formatting drop‐down 
menu, and then click Manage Rules. Excel 
displays the Conditional Formatting Rules 
Manager dialog box. Click the rule you want 
to modify and then click Edit Rule.

How do I remove a custom rule?
Follow steps 1 to 3 to select the range and display the 
Conditional Formatting drop‐down menu, click Clear Rules, 
and then click Clear Rules from Selected Cells. If you 
have multiple custom rules defined for a worksheet and no 
longer require them, you can remove all of them. Click the 
Home tab, click Conditional Formatting, click Clear 
Rules, and then click Clear Rules from Entire Sheet.

	B	 Excel applies the conditional formatting 
to each cell in the range.
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Consolidate by Position
1	 Create a new worksheet that 

uses the same layout (including 
row and column headers) as the 
sheets you want to consolidate.

2	 Open the workbooks that contain 
the worksheets you want to 
consolidate.

3	 Select the upper‐left corner  
of the destination range.

4	 Click the Data tab.

5	 Click Consolidate ( ).

The Consolidate dialog box 
appears.

6	 Click the Function drop‐down 
arrow ( ), and then click the 
summary function you want  
to use.

7	 Click inside the Reference  
text box.

8	 Select one of the ranges you 
want to consolidate.

9	 Click Add.

Consolidate Data from Multiple Worksheets

It is common to distribute similar worksheets to multiple departments to capture budget numbers, 
inventory values, survey data, and so on. Those worksheets must then be combined into a 

summary report showing company‐wide totals. This is called consolidating the data.

Rather than doing this manually, Excel can consolidate your data automatically. You can use the 
Consolidate feature to consolidate the data either by position or by category. In both cases, you 
specify one or more source ranges (the ranges that contain the data you want to consolidate) and 
a destination range (the range where the consolidated data will appear).

Consolidate Data from Multiple Worksheets
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	A	 Excel adds the range to the All 
References list.

10	 Repeat steps 7 to 9 to add all 
the consolidation ranges.

11	 Click OK.

Is there an easy way to update the consolidation if the source data changes?
If the source data changes, then you probably want to reflect those changes in the consolidation 
worksheet. Rather than running the entire consolidation over again, a much easier solution is to select the 
Create links to source data check box (  changes to ) in the Consolidate dialog box. This enables you 
to update the consolidation worksheet by clicking the Data tab and then clicking Refresh All.
This also means that Excel creates an outline in the consolidation sheet, and you can use that outline to 
see the detail from each of the source ranges. See the “Group Related Data” section earlier in the chapter 
to learn more about outlines in Excel.

TIP

	B	 Excel consolidates the data from 
the source ranges and displays 
the summary in the destination 
range.
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If the worksheets you want to summarize do not use the same layout, you need to tell Excel to 
consolidate the data by category. This method consolidates the data by looking for common row 

and column labels in each worksheet.

For example, suppose you are consolidating sales and Division A sells software, books, and videos; 
Division B sells books and CD‐ROMs; and Division C sells books, software, videos, and CD‐ROMs. When 
you consolidate this data, Excel summarizes the software from Divisions A and C, the CD‐ROMs from 
Divisions B and C, and the books from all three.

Consolidate Data from Multiple Worksheets (continued)

Consolidate by Category
1	 Create a new worksheet for the 

consolidation.

2	 Open the workbooks that contain 
the worksheets you want to 
consolidate.

3	 Select the upper‐left corner of the 
destination range.

4	 Click the Data tab.

5	 Click Consolidate ( ).

Consolidate Data from Multiple Worksheets (continued)

The Consolidate dialog box appears.

6	 Click the Function drop‐down arrow 
( ), and then click the summary 
function you want to use.

7	 Click inside the Reference text box.

8	 Select one of the ranges you want 
to consolidate.

Note: Be sure to include the row and 
column labels in the range.

9	 Click Add.
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	C	 Excel adds the range to the 
All references list.

10	 Repeat steps 7 to 9 to add 
all the consolidation ranges.

11	 If you have labels in the top 
row of each range, click Top 
Row (  changes to ).

12	 If you have labels in the  
left‐column row of each 
range, click Left Column  
(  changes to ).

13	 Click OK.

What happens if the source data layout changes?
If the layout of the source data changes, then you must run the consolidation again.

If you consolidated by position, then before you can rerun the consolidation, you must first adjust the 
layout of the consolidation worksheet to match the changes to the source data. (You do not need to do this 
if you consolidated by category.)

No matter which consolidation method you used, before you run the consolidation again, you must delete 
the existing source ranges. Click the Data tab, and then click Consolidate ( ) to display the Consolidate 
dialog box. For each source range, click the range in the All references list and then click Delete.

TIP

	D	 Excel consolidates the data 
from the source ranges and 
displays the summary in the 
destination range.
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The Excel Options dialog box 
appears.

3	 Click Add‐Ins.

4	 In the Manage list, click  
Excel Add‐ins.

5	 Click Go.

1	 Click the File tab (not shown).

2	 Click Options.

Load the Excel Analysis ToolPak

You can get access to a number of powerful statistical analysis tools by loading the Analysis 
ToolPak add‐in. The Analysis ToolPak consists of 19 statistical tools that calculate statistical 

measures such as correlation, regression, rank and percentile, covariance, and moving averages.

You can also use the analysis tools to generate descriptive statistics (such as median, mode, and 
standard deviation), random numbers, and histograms.

Load the Excel Analysis ToolPak
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The Add‐Ins dialog box appears.

6	 Select the Analysis ToolPak  
check box (  changes to ).

7	 Click OK.

Excel loads the Analysis  
ToolPak add‐in.

8	 Click the Data tab.

9	 Click Data Analysis ( ) to 
access the Analysis ToolPak 
tools.

TIP
How do I use the statistical tools?
The specific steps you follow vary from tool to 
tool, but you can follow these general steps to 
use any of the Analysis ToolPak’s statistical tools:

1	 Click the Data tab.

2	 Click .

The Data Analysis dialog box appears.

3	 Click the tool you want to use.

4	 Click OK.

Excel displays a dialog box for the tool.

5	 Fill in the dialog box (the controls vary from 
tool to tool).

6	 Click OK.
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Visualizing 
Data with 
Charts
You can take a worksheet full of numbers and display them as a chart. 
Visualizing your data in this way makes the data easier to understand 
and analyze. To help you see your data exactly the way you want, Excel 
offers a wide variety of chart types, and a large number of chart options.
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One of the best ways to analyze your worksheet data — or get your point across to other people — 
is to display your data visually in a chart, which is a graphic representation of spreadsheet data. 

As the data in the spreadsheet changes, the chart also changes to reflect the new numbers.

You have dozens of different chart formats to choose from, and if none of the built‐in Excel formats 
is just right, you can further customize these charts to suit your needs. To get the most out of 
charts, you need to familiarize yourself with the basic chart elements.

Examine Chart Elements

A	 Category Axis
The axis (usually the  
X axis) that contains the 
category groupings.

B	 Chart Title
The title of the chart.

C	 Data Marker
A symbol that represents 
a specific data value. The 
symbol used depends on 
the chart type.

D	 Data Series
A collection of related data 
values. Normally, the 
marker for each value in a series has the same pattern.

E	 Data Value
A single piece of data, also called a data point.

F	 Gridlines
Optional horizontal and vertical extensions of the axis tick marks. These lines make data values easier to read.

G	 Legend
A guide that shows the colors, patterns, and symbols used by the markers for each data series.

H	 Plot Area
The area bounded by the category and value axes. It contains the data points and gridlines.

I	 Value Axis
The axis (usually the Y axis) that contains the data values.
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Excel offers 15 different types of charts, including column charts, bar charts, line charts, and pie 
charts. The chart type you use depends on the type of data and how you want to present that 

data visually.

Chart Types

Chart Type Description
Area chart Shows the relative contributions over time that each data series makes to the whole picture.

Bar chart Compares distinct items or shows single items at distinct intervals. A bar chart is laid out 
with categories along the vertical axis and values along the horizontal axis.

Box & Whisker 
chart

Visualizes several statistical values for the data in each category, including the average, the 
range, the minimum, and the maximum.

Column chart Like a bar chart, compares distinct items or shows single items at distinct intervals. 
However, a column chart is laid out with categories along the horizontal axis and values 
along the vertical axis.

Doughnut 
chart

Like a pie chart, shows the proportion of the whole that is contributed by each value in a 
data series. The advantage of a doughnut chart is that you can plot multiple data series.

Histogram Groups the category values into ranges — called bins — and shows the frequency with 
which the data values fall within each bin.

Line chart Shows how a data series changes over time. The category (X) axis usually represents a 
progression of even increments (such as days or months), and the series points are plotted 
on the value (Y) axis.

Pie chart Shows the proportion of the whole that is contributed by each value in a single data series. 
The whole is represented as a circle (the “pie”), and each value is displayed as a 
proportional “slice” of the circle.

Radar chart Makes comparisons within a data series and between data series relative to a center point. 
Each category is shown with a value axis extending from the center point.

Stock chart Designed to plot stock-market prices, such as a stock’s daily high, low, and closing values.

Sunburst chart Displays hierarchical data as a series of concentric circles, with the top level as the 
innermost circle and each circle divided proportionally according to the data values within 
that level.

Surface chart Analyzes two sets of data and determines the optimum combination of the two.

Treemap chart For hierarchical data, shows a large rectangle for each item in the top level, then divides 
each rectangle proportionally based on the value of each item in the next level.

Waterfall chart Shows a running total as category values are added (positive values) or subtracted 
(negative values).

XY chart Shows the relationship between numeric values in two different data series. It can also plot 
a series of data pairs in XY coordinates. (This is also called a scatter chart.)
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You can create a chart from your Excel worksheet data with just a few mouse clicks. Excel offers 
nearly 100 default chart configurations, so there should always be a type that best visualizes 

your data. If you would prefer to let Excel suggest a chart type based on your data, see the following 
section, “Create a Recommended Chart.”

Regardless of the chart type you choose originally, you can change to a different chart type at any 
time. See the “Select a Different Chart Type” section later in this chapter.

Create a Chart

1	 Select the data that you want 
to visualize in a chart.

	A	 If your data includes headings, 
be sure to include those 
headings in the selection.

2	 Click the Insert tab.

3	 Click a chart type.

Create a Chart
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	B	 Excel displays a gallery of 
configurations for the chart 
type.

4	 Click the chart configuration 
you want to use.

	C	 Excel inserts the chart.

The sections in the rest of 
this chapter show you how to 
configure, format, and move the 
chart.

TIP
Is there a way to create a chart on a separate sheet?
Yes. You can use a special workbook sheet called a chart sheet. If you have not yet created your chart, select 
the worksheet data, right‐click any worksheet tab, and then click Insert to display the Insert dialog box. 
Click the General tab, click Chart, and then click OK. Excel creates a new chart sheet and inserts the chart.

If you have already created your chart, you can move it to a separate chart sheet. See the first tip in the 
“Move or Resize a Chart” section later in this chapter.
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You can make it easier and faster to create a chart by choosing from one of the chart 
configurations recommended by Excel.

With close to 100 possible chart configurations, the Excel chart tools are certainly comprehensive. 
However, that can be an overwhelming number of choices if you’re not sure which type would best 
visualize your data. Rather than wasting a great deal of time looking at dozens of different chart 
configurations, the Recommended Charts command examines your data and then narrows down the 
possible choices to about ten configurations that would work with your data.

Create a Recommended Chart

2	 Click the Insert tab.

3	 Click Recommended Charts.

1	 Select the data that you want 
to visualize in a chart.

	A	 If your data includes headings, 
be sure to include those 
headings in the selection.

Create a Recommended Chart
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The Insert Chart dialog box 
appears with the Recommended 
Charts tab displayed.

4	 Click the chart type you want 
to use.

	B	 A preview of the chart appears 
here.

5	 Click OK.

	C	 Excel inserts the chart.

TIP
Is there a faster way to insert a recommended 
chart?
Yes, you can use the Quick Analysis feature in Excel:

1	 Select the data that you want to visualize in a 
chart, including the headings, if any.

2	 Click the Quick Analysis Smart tag ( ).

3	 Click Charts.

Excel displays the chart types recommended for 
your data.

4	 Click the chart type you want to use.

Excel inserts the chart.
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You can make your chart easier to understand by adding chart titles, which are labels that appear 
in specific sections of the chart. By including descriptive titles, you make it easier for other 

people to see at a glance what your chart is visualizing.

There are three types of chart titles that you can add. The first type is the overall chart title, which 
usually appears at the top of the chart. You can also add a title for the horizontal axis to describe 
the chart categories, as well as a title for the vertical axis, which describes the chart values.

Add Chart Titles

7	 Click Add Chart Element.

8	 Click Axis Titles.

9	 Click Primary Horizontal.

	B	 Excel adds the title box.

10	 Type the title.

11	 Click Add Chart Element.

12	 Click Axis Titles.

13	 Click Primary Vertical.

	C	 Excel adds the title box.

14	 Type the title.

1	 Click the chart.

2	 Click the Design tab.

3	 Click Add Chart Element.

4	 Click Chart Title.

5	 Click Above Chart.

	A	 Excel adds the title box.

6	 Type the title.

Add Chart Titles
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You can make your chart easier to read by adding data labels. A data label is a small text box that 

appears in or near a data marker and displays the value of that data point.

Excel offers several position options for the data labels, and these options depend on the chart type. 
For example, with a column chart you can place the data labels within or above each column, and for 
a line chart you can place the labels to the left or right, or above or below, the data marker.

Add Data Labels

Add Data Labels

	A	 Excel adds the labels to the 
chart.

1	 Click the chart.

2	 Click the Design tab.

3	 Click Add Chart Element.

4	 Click Data Labels.

5	 Click the position you want 
to use for the data labels.

Note: Remember that the 
position options you see depend 
on the chart type.
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You can change the position of the chart legend, which identifies the colors associated with  
each data series in the chart. The legend is a crucial chart element for interpreting and 

understanding your chart, so it is important that you place it in the best position. For example,  
you might find the legend easier to read if it appears to the right of the chart. Alternatively,  
if you want more horizontal space to display your chart, you can move the legend above or  
below the chart.

Position the Chart Legend

1	 Click the chart.

2	 Click the Design tab.

3	 Click Add Chart Element.

4	 Click Legend.

5	 Click the position you want to 
use for the legend.

Position the Chart Legend

	A	 Excel moves the legend.
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You can make your chart easier to read and analyze by adding gridlines. Horizontal gridlines 

extend from the vertical (value) axis, and are useful with area, bubble, and column charts. 
Vertical gridlines extend from the horizontal (category) axis and are useful with bar and line charts.

Major gridlines are gridlines associated with the major units (the values you see displayed on the 
vertical and horizontal axes), while minor gridlines are gridlines associated with the minor units 
(values between each major unit).

Display Chart Gridlines

1	 Click the chart.

2	 Click the Design tab.

3	 Click Add Chart Element.

4	 Click Gridlines.

5	 Click the horizontal gridline 
option you prefer.

	A	 Excel displays the horizontal 
gridlines.

6	 Click Add Chart Element.

7	 Click Gridlines.

8	 Click the vertical gridline option 
you prefer.

	B	 Excel displays the vertical 
gridlines.

Display Chart Gridlines
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You can make it easier for yourself and others to interpret your chart by adding a data table. A 
data table is a tabular grid where each row is a data series from the chart, each column is a chart 

category, and each cell is a chart data point.

Excel gives you the option of displaying the data table with or without legend keys, which are 
markers that identify each series.

Display a Data Table

1	 Click the chart.

2	 Click the Design tab.

3	 Click Add Chart Element.

4	 Click Data Table.

5	 Click With Legend Keys.

	A	 If you prefer not to display the 
legend keys, click No Legend 
Keys.

Display a Data Table

	B	 Excel adds the data table below 
the chart.
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You can quickly format your chart by applying a different chart layout and chart style. The chart 

layout includes elements such as the titles, data labels, legend, gridlines, and data table. The 
Quick Layouts feature in Excel enables you to apply these elements in different combinations with 
just a few mouse clicks. The chart style represents the colors used by the chart data markers and 
background.

Change the Chart Layout and Style

6	 Click the chart style you want 
to use.

	B	 Excel applies the style to the 
chart.

1	 Click the chart.

2	 Click the Design tab.

3	 Click Quick Layout.

4	 Click the layout you want to use.

	A	 Excel applies the layout.

5	 Click the Chart Styles .

Change the Chart Layout and Style
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If you feel that the current chart type is not showing your data in the best way, you can change 
the chart type. This enables you to experiment not only with the 11 different chart types offered 

by Excel, but also with its nearly 100 chart type configurations.

For example, if you are graphing a stock’s high, low, and closing prices, a line chart shows you each 
value, but a stock chart gives you a better sense of the daily price movements. Similarly, if you are 
using a bar chart to show percentages of some whole, you would more readily visualize the data by 
switching to a pie chart.

Select a Different Chart Type

The Change Chart Type dialog 
box appears.

4	 Click the chart type you want 
to use.

1	 Click the chart.

2	 Click the Design tab.

3	 Click Change Chart Type.

Select a Different Chart Type
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Excel displays the chart type 
configurations.

5	 Click the configuration you want 
to use.

6	 Click OK.

	A	 Excel applies the new chart 
type.

TIP
Can I save the chart type and formatting so that I can reuse it later on a different chart?
Yes. You do this by saving your work as a chart template. Follow the steps in this section and in the 
previous few sections of this chapter to set the chart type, titles, labels, legend position, gridlines, layout, 
and style. Right‐click the chart’s plot area or background, click Save as Template, type a name for the 
template, and then click Save. To reuse the template, follow steps 1 to 3, click Templates, click your 
template, and then click OK.
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In Excel, a chart’s source data is the original range used to create the chart. You can keep your 
chart up to date and accurate by adjusting the chart when its source data changes.

You normally do this when the structure of the source data changes. For example, if the source range 
adds a row or column, you can adjust the chart to include the new data. However, you do not need 
to make any adjustments if just the data within the original range changes. In such cases, Excel 
automatically adjusts the chart to display the new data.

Change the Chart Source Data

	A	 Excel selects the chart’s source 
data.

2	 Move the mouse  over the 
lower‐right corner of the range.

 changes to .

1	 Click the chart to select it.

Change the Chart Source Data
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4	 Release the mouse button.

	C	 Excel redraws the chart to 
include the new data.

3	 Click and drag  until the 
selection includes all the data 
you want to include in the 
chart.

	B	 Excel extends the blue outline 
to show you the new selection.

Is there a way to swap the chart series with the 
chart categories without modifying the source 
data?
Yes. Excel has a feature that enables you to switch the 
row and column data, which swaps the series and 
categories without affecting the source data. First 
click the chart to select it, and then click the Design 
tab. Click Switch Row/Column ( ). Excel swaps the 
series and categories. Click  again to return to the 
original layout.

Is there a way to remove a series from a chart 
without deleting the data from the source 
range?
Yes. You can use the Select Data Source dialog 
box in Excel to remove individual series. Click the 
chart to select it, and then click the Design tab. 
Click Select Data ( ) to open the Select Data 
Source. In the Legend Entries (Series) list, click 
the series you want to get rid of, and then click 
Remove. Click OK.

TIPS
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You can move a chart to another part of the worksheet. This is useful if the chart is blocking the 
worksheet data or if you want the chart to appear in a particular part of the worksheet.

You can also resize a chart. For example, if you find that the chart is difficult to read, making 
the chart bigger often solves the problem. Similarly, if the chart takes up too much space on the 
worksheet, you can make it smaller.

Move or Resize a Chart

3	 Click and drag the chart border 
to the location you want.

4	 Release the mouse button.

	B	 Excel moves the chart.

Move a Chart
1	 Click the chart.

	A	 Excel displays a border around 
the chart.

2	 Move  over the chart border.  
 changes to .

Note: Do not position the mouse 
pointer over a corner or over the 
middle of any side of the border.

Move or Resize a Chart
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Resize a Chart
1	 Click the chart.

	C	 Excel displays a border around 
the chart.

	D	 The border includes sizing 
handles on the corners and 
sides.

2	 Move  over a sizing handle.  
 changes to  (left or right),  

 (top or bottom), or  (corner).

3	 Click and drag the handle.

	E	 Excel displays a gray outline of 
the new chart size.

4	 Release the mouse button.

	F	 Excel resizes the chart.

Can I move a chart to a separate sheet?
Yes. In the “Create a Chart” section earlier in this chapter, 
you learned how to create a new chart in a separate sheet. 
If your chart already exists on a worksheet, you can move it 
to a new sheet. Click the chart, click the Design tab, and 
then click Move Chart to open the Move Chart dialog box. 
Select the New sheet option (  changes to ). In the 
New sheet text box, type a name for the new sheet, and 
then click OK.

How do I delete a chart?
How you delete a chart depends on 
whether your chart exists as an object on 
a worksheet or in its own sheet. If the 
chart is on a worksheet, click the chart 
and then press . If the chart exists 
on a separate sheet, right‐click the sheet 
tab, click Delete Sheet, and then click 
Delete.

TIPS
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If you want a quick visualization of your data without having a chart take up a large amount 
of worksheet space, you can add a sparkline to a single cell. A sparkline is a small chart that 

visualizes a row or column of data and fits inside a single cell.

Excel offers three types of sparklines: Line (similar to a line chart), Column (similar to a column 
chart), and Win/Loss (for data that includes positive and negative values).

Add a Sparkline to a Cell

2	 Click the Insert tab.

3	 Click the type of sparkline you 
want to create.

1	 Select the row or column of 
data you want to visualize.

Add a Sparkline to a Cell
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	A	 Excel adds the sparkline to the 
cell.

	B	 Excel displays the Sparkline 
Tools tab.

	C	 Use the tools in the Design tab 
to format your sparkline.

The Create Sparklines dialog box 
appears.

4	 Click inside the Location Range 
box.

5	 Click the cell where you want 
the sparkline to appear.

6	 Click OK.

TIP
Can I add a sparkline to multiple rows or columns at once?
Yes. To do this, first select the rows or columns of data that you want to visualize. Follow steps 2 and 3 to 
open the Create Sparklines dialog box and place the cursor inside the Location Range box. Select a single 
cell for each row or column that you have selected. For example, if you have selected five rows, select five 
cells. Click OK. Excel adds a sparkline for each selected row or column.
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Adding 
Worksheet 
Graphics
You can enhance the visual appeal and effectiveness of your Excel 
worksheets by incorporating graphic objects such as shapes, clip art, 
pictures, or WordArt and SmartArt images. This chapter shows you not 
only how to insert graphics on your worksheets, but also how to edit 
and format those graphics.
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You can add visual appeal or enhance the readability of your worksheets by adding one or more 
shapes. The Excel Shapes gallery comes with more than 150 predefined objects called shapes 

(or sometimes AutoShapes) that enable you to quickly and easily draw anything from simple 
geometric figures such as lines, rectangles, and ovals, to more elaborate items such as starbursts, 
flowchart symbols, and callout boxes. You can add these shapes to a worksheet either to enhance 
the aesthetics of your data or to help other people read and understand your work.

Draw a Shape

4	 Click Shapes.

5	 Click the shape you want to 
draw.

 changes to .

1	 Display the worksheet on which 
you want to draw the shape.

2	 Click the Insert tab.

3	 Click Illustrations.

Draw a Shape
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6	 Click and drag the mouse  to 
draw the shape.

7	 When the shape is the size you 
want, release the mouse button.

	A	 The program draws the shape 
and adds edit handles around 
the shape’s edges.

Note: If you need to move or size 
the shape, see the “Move or Resize 
a Graphic” section later in this 
chapter.

TIPS
Is there an easy way to draw a perfect circle  
or square?
Yes, Excel offers an easy technique for drawing 
circles and squares. Hold down the  key as you 
click and drag the shape to constrain the shape into 
a perfect circle or square. When you finish drawing 
the shape, release the  key.

Can I add text to a shape?
Yes. You can add text to the interior of any 2‐D 
shape (that is, any shape that is not a line). After 
you draw the shape, right‐click the shape, click Edit 
Text, and then type your text inside the shape. You 
can use the Home tab’s Font controls to format the 
text. When you finish, click outside of the shape.



290

You can improve the look of an Excel worksheet by adding a clip art image to the sheet. Clip art 
refers to small images or artwork that you can insert into your documents. Excel 2016 does not 

come with its own clip art, but it does give you access to online clip art collections that contains 
thousands of images from various categories, such as business, people, nature, and symbols. By 
default, these images are licensed under Creative Commons, so you can use them without charge.

Insert a Clip Art Image

The Insert Pictures window 
appears.

6	 Click Bing Image Search.

7	 Use the text box to type a word 
that describes the kind of clip 
art image you want to insert.

8	 Click Search ( ).

1	 Display the worksheet on which 
you want to insert the clip art 
image.

2	 Click the cell where you want 
the upper‐left corner of the 
image to appear.

3	 Click the Insert tab.

4	 Click Illustrations.

5	 Click Online Pictures.

Insert a Clip Art Image
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	A	 Excel displays a list of clip art 
images that match your search 
term.

9	 Click the clip art image you 
want to use.

	B	 The address of the website that 
offers the image appears here.

10	 Click Insert.

	C	 Excel inserts the clip art.

Note: If you need to move or size 
the clip art, see the “Move or Resize 
a Graphic” section later in this 
chapter.

What is a Creative Commons license?
Creative Commons (http://creativecommons.org) is a 
non‐profit organization that enables artists to license 
their works for other people to use free of charge. 
There are several different Creative Commons licenses, 
so you should visit the website that offers the image 
you select to check the specifics of the license.

Can I insert other online images?
Yes. If you have connected your Facebook or your 
Flickr account to Windows 8 or later, you can also 
use the Facebook or Flickr option to choose a 
photo. If you are using a Microsoft account with 
Windows 8 or later, you can use the OneDrive 
option to select an image from your OneDrive.

TIPS

http://creativecommons.org
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You can enhance the visual appeal and strengthen the message of an Excel worksheet by adding a 
photo to the file.

Excel can work with the most popular picture formats, including BMP, JPEG, TIFF, PNG, and GIF. This 
means that you can insert almost any photo that you have stored on your computer. If you would 
like to insert a photo that is located online instead, see the tips in the previous section, “Insert a 
Clip Art Image.”

Insert a Photo

3	 Click the Insert tab.

4	 Click Illustrations.

5	 Click Pictures.

1	 Open the worksheet where you 
want to insert the photo.

2	 Click the cell where you want 
the upper‐left corner of the 
photo to appear.

Insert a Photo



293

CHAPTER

13Adding Worksheet Graphics

The Insert Picture dialog box 
appears.

6	 Open the folder that contains 
the photo you want to insert.

7	 Click the photo.

8	 Click Insert.

	A	 Excel inserts the photo into the 
worksheet.

Note: If you need to move or size 
the photo, see the “Move or Resize 
a Graphic” section later in this 
chapter.

My photo has a distracting background. Can I 
remove it?
Yes. Excel comes with a Background Removal feature 
that can eliminate the background in most photos. 
Click the photo, click the Format tab, and then click 
Remove Background ( ). If part of the foreground is 
in the removal color, click Mark Areas to Keep and 
then click and drag a line through the part you want 
to retain. When you are finished, click Keep Changes.

Is there a way to reduce the size of a workbook 
that has a lot of photos?
Yes, you can use the Compress Pictures feature to 
convert the photos to a lower resolution and so 
reduce the size of the workbook. Click any image 
in the workbook, click the Format tab, and then 
click Compress Pictures ( ). Click Apply only 
to this picture (  changes to ), click a Target 
output (  changes to ), and then click OK.

TIPS
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You can add some pizzazz to your Excel workbooks by inserting a WordArt image. A WordArt image 
is a graphic object that contains text stylized with shadows, outlines, reflections, and other 

predefined effects.

WordArt images enable you to apply sophisticated and fun effects to text with just a few mouse 
clicks. However, some of the more elaborate WordArt effects can make text difficult to read, so make 
sure that whatever WordArt image you use does not detract from your worksheet message.

Insert a WordArt Image

2	 Click the Insert tab.

3	 Click Text.

4	 Click WordArt.

The WordArt gallery appears.

5	 Click the WordArt style you want 
to use.

1	 Open the worksheet in which 
you want to insert the WordArt 
image.

Insert a WordArt Image
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	A	 The WordArt image appears in 
the worksheet.

6	 Type the text that you want to 
appear in the WordArt image.

7	 Click outside the image to  
set it.

Note: You will likely have to move 
the WordArt image into position; 
see the “Move or Resize a Graphic” 
section later in this chapter.

Can I change the default WordArt formatting?
Yes. Click the WordArt image to select it, and then use 
the Home tab’s Font controls to adjust the WordArt 
text font. Click the Format tab. In the WordArt Styles 
group, use the Text Fill ( ), Text Outline ( ), and 
Text Effects ( ) galleries to format the WordArt 
image. You can also use the Quick Styles gallery to 
select a different WordArt style.

Can I make my WordArt text run vertically?
Yes. Click the WordArt image to select it. Click  
the Format tab, and then click the dialog box 
launcher ( ) in the WordArt Styles group. In the 
Format Shape task pane, click Text Options and 
then click the Textbox icon ( ). Click the Text 
direction  and then click Stacked. Click Close. 
Excel displays the WordArt text vertically.

TIPS
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You can add a SmartArt graphic to a workbook to help present information in a compact, visual 
format. A SmartArt graphic is a collection of nodes — shapes with some text inside — that 

enables you to convey information visually.

For example, you can use a SmartArt graphic to present a company organization chart, the 
progression of steps in a workflow, the parts that make up a whole, and much more.

Insert a SmartArt Graphic

The Choose a SmartArt Graphic 
dialog box appears.

5	 Click a SmartArt category.

6	 Click the SmartArt style you 
want to use.

7	 Click OK.

1	 Open the worksheet in which 
you want to insert the SmartArt 
image.

2	 Click the Insert tab.

3	 Click Illustrations.

4	 Click SmartArt.

Insert a SmartArt Graphic
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	A	 The SmartArt graphic appears in 
the document.

	B	 You use the Text pane to type 
the text for each node and to 
add and delete nodes.

8	 Click a node in the Text pane.

9	 Type the text that you want to 
appear in the node.

	C	 The text appears automatically 
in the associated shape.

10	 Repeat steps 8 and 9 to fill in 
the other nodes in the SmartArt 
graphic.

	D	 You can click Text Pane ( ) to 
hide the Text pane.

Note: You will likely have to move 
the SmartArt graphic into position; 
see the following section, “Move or 
Resize a Graphic.”

How do I add a node to my SmartArt graphic?
To add a node to the SmartArt graphic, first decide where 
you want that node to appear in the current image. That 
is, decide which existing node you want the new node to 
come before or after. Click the existing node, click the 
Design tab, click the Add Shape , and then click Add 
Shape After. (If you want the new node to appear before 
the existing node, click Add Shape Before.)

Can I use shapes other than the ones 
supplied in the default SmartArt graphics?
Yes. Begin by clicking the node you want to 
change. Click the Format tab, and then click 
the Change Shape  to display the Shapes 
gallery. Click the shape you want to use. 
Excel updates the SmartArt graphic node 
with the new shape.

TIPS
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To ensure that a graphic is ideally placed within an Excel worksheet, you can move the graphic to a 
new location or you can resize the graphic in its current location. For example, you might want to 

move or resize a graphic so that it does not cover existing worksheet text. Similarly, you might want 
to move or resize a graphic so that it is positioned near a particular worksheet element or fits within 
an open worksheet area. You can move or resize any graphic, including shapes, clip art, pictures, 
WordArt images, and SmartArt graphics.

Move or Resize a Graphic

2	 Drag the graphic to the location 
you prefer.

	A	 Excel moves the graphic to the 
new location.

Move a Graphic
1	 Move the mouse pointer over an 

edge of the graphic you want to 
move.

The mouse  changes to .

Move or Resize a Graphic
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Resize a Graphic
1	 Click the graphic.

	B	 Sizing handles appear around  
the edges.

2	 Move the mouse  over a  
sizing handle.

	C	 Use a left or right handle  
(  changes to ) to adjust  
the width.

	D	 Use a top or bottom handle  
(  changes to ) to adjust  
the height.

	E	 Use a corner handle (  changes  
to ) to adjust the two sides 
adjacent to the corner.

3	 Drag the sizing handle (the mouse 
pointer changes to ).

4	 Release the mouse button when 
the handle is in the position you 
want.

	F	 Excel resizes the graphic.

5	 Repeat steps 2 to 4 to resize other 
sides of the graphic, as necessary.

Can I rotate a graphic?
Yes. Most graphic objects come with a rotate handle. Follow these  
steps:

1	 Move the mouse  over the 
rotate handle (  changes to ).

2	 Click and drag the rotate handle 
clockwise or counterclockwise to 
rotate the graphic.

3	 Release the mouse button when 
the graphic is in the position 
you want.

Is it possible to resize a 
graphic in all directions  
at once to keep the 
proportions the same?
Yes. You normally resize one 
side at a time by dragging a 
side handle, or two sides at 
a time by dragging a corner 
handle. To resize all four 
sides at once, hold down 
the  key and then click 
and drag any corner handle.

TIPS
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If a picture contains extraneous material near the outside edges of the image, you can often 
cut out those elements using a process called cropping. When you crop a picture, you specify 

a rectangular area of the image that you want to keep. Excel discards everything outside of the 
rectangle.

Cropping is a useful feature because it can help viewers focus on the subject of a picture. Cropping  
is also useful for removing extraneous elements that appear on or near the edges of a photo.

Crop a Picture

2	 Click the Format tab.

3	 Click the Crop button ( ).

	A	 Crop handles appear around 
the picture.

1	 Click the picture you want to 
crop.

Crop a Picture
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4	 Click and drag a crop handle.

The mouse  changes to .

	B	 Click and drag a side handle to 
crop that side.

	C	 Click and drag a corner handle 
to crop the two sides adjacent 
to the corner.

5	 Release the mouse button when 
the handle is in the position 
you want.

6	 Click .

Excel turns off the Crop feature.

	D	 Excel crops the picture.

If I have a picture with the main element in the 
middle, is it possible to crop in all directions at 
once to keep just that middle element?
Yes. You normally crop one side at a time by 
clicking and dragging a side crop handle, or two 
sides at a time by clicking and dragging a corner 
crop handle. To crop all four sides at once, hold 
down the  key and then click and drag any 
corner crop handle.

Can I crop a picture to a particular aspect ratio  
or shape?
Yes. Excel offers a couple of cropping options. If you 
know the aspect ratio (the ratio of the width to the 
height) you want, click the Crop , click Aspect 
Ratio, and then click the ratio, such as 3:5 or 4:6.  
If you prefer to crop to a shape, such as an oval or 
arrow, click the Crop , click Crop to Shape, and 
then click the shape.

TIPS
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You can enhance your shapes, clip art, photos, WordArt images, and SmartArt graphics by 
formatting the images. For example, Excel offers more than two dozen picture styles, which are 

predefined formats that apply various combinations of shadows, reflections, borders, and layouts.

Excel also offers a dozen picture effects, which are preset combinations of special effects such as 
glows, soft edges, bevels, and 3‐D rotations.

Format a Picture

	A	 Excel displays the Picture Styles 
gallery.

4	 Click the picture style you want 
to use.

	B	 Excel applies the style to the 
picture.

Apply a Picture Style
1	 Click the picture you want to 

format.

2	 Click the Format tab.

3	 Click the Picture Styles .

Format a Picture
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Apply a Picture Effect
1	 Click the picture you want to 

format.

2	 Click the Format tab.

3	 Click the Picture Effects  
button ( ).

Note: If the image is a shape, the 
 button is named Shape Effects.

4	 Click Preset.

5	 Click the effect you want to 
apply.

	C	 Excel applies the effect to the 
picture.

I applied a style to a picture, but now I want 
to change the picture to something else. Do I  
have to start over?
No. You can simply replace the existing picture 
with the other picture, and Excel preserves the 
style so you do not have to repeat your work. 
Click the existing picture, click the Format tab, 
and then click the Change Picture button ( ). 
Select the new picture you want to use and 
then click Insert.

If I do not like the formatting that I have applied  
to a picture, can I return the picture to its original 
look?
Yes. If you have not performed any other tasks since 
applying the formatting, click Undo ( ) until Excel has 
removed the formatting. Alternatively, click , click 
Preset, and then click the icon in the No Presets 
section. To reverse all the changes you have made to a 
picture since you inserted the image, click the picture, 
click Format, and then click Reset Picture ( ).

TIPS
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Collaborating 
with Others
If you want to collaborate with other people on a workbook, Excel 
gives you several ways to do this, including adding comments, sharing 
a workbook, and even working on a spreadsheet online. You can also 
control your collaborations by protecting worksheet data and tracking 
the changes that others make.



Add a Comment to a Cell .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                 306

Protect a Worksheet’s Data .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .               308

Protect a Workbook’s Structure .  .  .  .  .  .  .  .  .  .  .  .  .  .             310

Share a Workbook with Other Users  .   .   .   .   .   .   .   .   .   .   .  312

Track Workbook Changes .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                314

Accept or Reject Workbook Changes .   .   .   .   .   .   .   .   .   .   .  316

Save a Workbook to Your OneDrive .  .  .  .  .  .  .  .  .  .  .  .            318

Send a Workbook as an E‐Mail Attachment  .  .  .  .  .  .  .  .        320

Save Excel Data as a Web Page .  .  .  .  .  .  .  .  .  .  .  .  .  .              322

Make a Workbook Compatible with  
Earlier Versions of Excel .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .                324

Mark Up a Worksheet with a Digital Pen .   .   .   .   .   .   .   .   .  326

Collaborate on a Workbook Online  .  .  .  .  .  .  .  .  .  .  .  .            328



306

Excel displays a comment balloon.

	A	 Excel precedes the comment with 
your Excel username.

4	 Type your comment.

5	 Click outside the comment balloon.

Add a Comment
1	 Click the cell you want to  

comment on.

2	 Click the Review tab.

3	 Click New Comment ( ).

Note: You can also right‐click the cell 
and then click Insert Comment.

Add a Comment to a Cell

If you have received a workbook from another person, you can provide feedback to that person 
by adding a comment to a cell in the workbook. A comment is often the best way to provide 

corrections, questions, critiques, and other feedback because it does not change anything on the 
actual worksheet.

Each comment is attached to a particular cell and Excel uses a comment indicator to mark which cells 
have comments. When you view a comment, Excel displays the comment in a balloon.

Add a Comment to a Cell
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	B	 Excel adds a comment indicator 
( ) to the top‐right corner of  
the cell.

View a Comment
1	 Move the mouse  over the cell.

	C	 Excel displays the comment in a 
balloon.

	D	 In the Review tab, you can also 
click Next ( ) and Previous ( ) 
to run through the comments.

	E	 In the Review tab, you can also 
click Show All Comments ( ) to 
display every comment at once.

TIPS
Can I edit or remove a comment?
Yes. To edit an existing comment, click the 
cell that contains the comment, click the 
Review tab, click Edit Comment ( ) to 
open the comment in a balloon, and then 
edit the balloon text. To remove a comment, 
click the cell that contains the comment, 
click the Review tab, and then click Delete 
Comment ( ).

How do I change my Excel username?
When collaborating, your username is important because it 
tells other people who added the comments. If you current 
username consists of only your first name or your initials, 
you can change it. Click File and then click Options to open 
the Excel Options dialog box. Click the General tab and then 
use the User name text box to edit the name. Click OK. 
Note, however, that this does not change your username in 
any existing comments.
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If you will be distributing a workbook to other people, you can enable the options in Excel for 
safeguarding worksheet data by activating the sheet’s protection feature. You can also configure 

the worksheet to require a password to unprotect it.

There are two main methods you can use to safeguard worksheet data: You can unlock only those 
cells that users are allowed to edit and you can configure a range to require a password before it can 
be edited.

Protect a Worksheet’s Data

1	 Display the worksheet you want 
to protect.

2	 Click the Review tab.

3	 Click Protect Sheet ( ).

Excel displays the Protect Sheet 
dialog box.

4	 Make sure the Protect 
worksheet and contents of 
locked cells check box is 
selected ( ).

5	 Use the Password to unprotect 
sheet text box to type a 
password.

Protect a Worksheet’s Data
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6	 Select the check box beside 
each action that you want to 
allow unauthorized users to 
perform (  changes to ).

7	 Click OK.

Excel asks you to confirm the 
password.

8	 Type the password.

9	 Click OK.

If you want to make changes to a 
worksheet, click the Review tab, 
click Unprotect Sheet ( ), type 
the unprotect password, and 
then click OK.

TIPS
When I protect a worksheet, no one can edit 
any of the cells. Is there a way to allow users 
to edit some of the cells?
Yes. This is useful if you have a data entry area or 
other range that you want other people to be able 
to edit but you do not want them to alter any 
other part of the worksheet. First, unprotect the 
sheet if it is currently protected. Select the range 
you want to unlock, click Home, click Format, and 
then click Lock Cell to turn off that option for the 
selected range.

When I protect a worksheet, can I configure a  
range to require a password before a user can edit 
the range?
Yes. First, unprotect the sheet if it is currently protected. 
Select the range you want to protect, click the Review 
tab, and then click Allow Users to Edit Ranges. In the 
Allow Users to Edit Ranges dialog box, click New to open 
the New Range dialog box. Type a title for the range, use 
the Range text box to type a password, and then click 
OK. When Excel prompts you to reenter the password, 
type the password and then click OK.
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Excel displays the Protect 
Structure and Windows dialog box.

4	 Select the Structure check box 
(  changes to ).

5	 Type a password in the 
Password text box, if required.

6	 Click OK.

1	 Display the workbook you want 
to protect.

2	 Click the Review tab.

3	 Click Protect Workbook ( ).

Protect a Workbook’s Structure

You can prevent unwanted changes to a workbook by activating protection for the workbook’s 
structure. You can also configure the workbook to require a password to unprotect it.

Protecting a workbook’s structure means preventing users from inserting new worksheets, renaming 
or deleting existing worksheets, moving or copying worksheets, hiding and unhiding worksheets, and 
more. See the tips to learn which commands Excel disables when you protect a workbook’s structure.

Protect a Workbook’s Structure
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	A	 Excel disables most worksheet‐
related commands on the 
Ribbon.

	B	 Excel disables most worksheet‐
related commands on the 
worksheet shortcut menu.

If you specified a password, 
Excel asks you to confirm it.

7	 Type the password.

8	 Click OK.

TIPS
What happens when I protect a workbook’s 
structure?
Excel disables most worksheet‐related commands, 
including Insert Sheet, Delete Sheet, Rename Sheet, 
Move or Copy Sheet, Tab Color, Hide Sheet, and 
Unhide Sheet. Excel also prevents the Scenario 
Manager from creating a summary report.

How do I remove workbook structure protection?
If you no longer require your workbook structure to 
be protected, you can remove the protection by 
following steps 1 to 3. If you protected your 
workbook with a password, type the password and 
then click OK. Excel removes the workbook’s 
structure protection.
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The Share Workbook dialog box 
appears.

4	 Click the Editing tab.

5	 Select the Allow changes 
by more than one user at 
the same time check box  
(  changes to ).

6	 Click OK.

1	 Display the workbook you want 
to share.

2	 Click the Review tab.

3	 Click Share Workbook ( ).

Share a Workbook with Other Users

You can allow multiple users to modify a workbook simultaneously by sharing the workbook. 
Once you have shared a workbook, other users can open the workbook via a network connection 

and edit the file at the same time. Note that Excel cannot share a workbook that contains a table, 
so you need to convert any tables to ranges before performing this task. See Chapter 10 for more 
information.

When you share a workbook, Excel automatically begins tracking the changes made to the file. For 
more information on this feature, see the following section, “Track Workbook Changes.”

Share a Workbook with Other Users
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Excel tells you that it will now 
save the workbook.

7	 Click OK.

Excel saves the workbook and 
activates sharing.

	A	 Excel displays [Shared] in the 
title bar.

You and users on your network 
can now edit the workbook at 
the same time.

How do I know if other people currently have the 
workbook open?
The Editing tab of the Share Workbook dialog box maintains 
a list of the users who have the workbook open. To see this 
list, follow these steps:

1	 Display the shared workbook.

2	 Click the Review tab.

3	 Click .

The Share Workbook dialog box appears.

4	 Click the Editing tab.

	A	 The Who has this workbook open now list displays  
the users who are currently editing the file.

5	 Click OK.

TIP
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If you want other people to make changes to a workbook, you can keep track of those changes 
so you can either accept or reject them (see the following section, “Accept or Reject Workbook 

Changes”). The Track Changes feature in Excel enables you to do this.

When you turn on Track Changes, Excel monitors the activity of each reviewer and stores that 
reviewer’s cell edits, row and column additions and deletions, range moves, worksheet insertions, 
and worksheet renames.

Track Workbook Changes

The Highlight Changes dialog 
box appears.

5	 Select the Track changes while 
editing check box (  changes 
to ).

	A	 Leave the When check box 
selected ( ) and leave All 
selected in the list.

	B	 To learn more about the Who 
and Where options, see the tips.

	C	 Leave the Highlight changes on 
screen check box selected ( ) 
to view the workbook changes.

6	 Click OK.

1	 Display the workbook you want 
to track.

2	 Click the Review tab.

3	 Click Track Changes ( ).

4	 Click Highlight Changes.

Track Workbook Changes
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Excel activates the Track 
Changes feature.

	D	 Excel shares the workbook and 
indicates this by displaying 
[Shared] beside the workbook 
name.

Note: See the previous section, 
“Share a Workbook with Other 
Users,” to learn more about 
workbook sharing.

Excel tells you it will now save 
the workbook.

7	 Click OK.

TIPS
Is there a way to avoid having my own changes 
highlighted?
Yes, you can configure the workbook to show every 
user’s changes but your own. Follow steps 1 to 4 
to open the Highlight Changes dialog box. Select 
the Who check box (  changes to ), click the 
Who , and then click Everyone but Me. Click 
OK to put the new setting into effect.

Can I track changes in just part of the worksheet?
Yes, you can modify this task so that Excel only 
tracks changes in a specific range. Follow steps 1 
to 4 to open the Highlight Changes dialog box. 
Select the Where check box (  changes to ), 
click inside the Where range box, and then select 
the range you want to track. Click OK to put the 
new setting into effect.
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After you turn on the Track Changes features in Excel, as described in the previous section, “Track 
Workbook Changes,” you can accept or reject the changes that other users make to the workbook. 

As a general rule, you should accept the changes that other users make to a workbook. The exception 
is when you know a change is incorrect. If you are not sure, it is best to talk to the other user before 
rejecting a change. If you and another user make changes to the same cell, Excel lets you resolve the 
conflict by accepting your edit or the other user’s edit.

Accept or Reject Workbook Changes

1	 Display the workbook you are 
tracking.

2	 Click the Review tab.

3	 Click Track Changes ( ).

4	 Click Accept/Reject Changes.

Accept or Reject Workbook Changes

If your workbook has unsaved 
changes, Excel tells you it will 
now save the workbook.

5	 Click OK.
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The Select Changes to Accept or Reject 
dialog box appears.

	A	 Leave the When check box selected  
( ) and leave Not yet reviewed 
selected in the list.

	B	 If you only want to review changes 
made by a particular user, select the 
Who check box (  changes to ), 
click the Who , and then click the 
user’s name.

6	 Click OK.

The Accept or Reject Changes dialog box 
appears.

	C	 Excel displays the details of the current 
change.

7	 Click an action for the change.

	D	 Click Accept to leave the change in the 
workbook.

	E	 Click Reject to remove the change from 
the workbook.

Excel displays the next change.

8	 Repeat step 7 to review all the changes.

	F	 You can also click Accept All or Reject All 
to accept or reject all changes at once.

TIPS
What happens if I and another user make changes 
that affect the same cell?
In this situation, when you save the workbook, Excel 
displays the Accept or Reject Changes dialog box, 
which shows the change you made as well as the 
change the other user made. Click whatever change 
is the correct one and then click Accept. If there are 
multiple conflicts, you can save time by clicking your 
change or the other user’s change and then clicking 
either Accept All or Reject All.

When I complete my review, should I turn off 
the tracking feature?
Unless you know that other people still require 
access to the workbook, you should turn off the 
tracking feature when your review is complete. To 
do this, click the Review tab, click , and then 
click Highlight Changes to open the Highlight 
Changes dialog box. Select the Track changes 
while editing check box (  changes to ), and 
then click OK.
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If you are using Windows 8 or later under a Microsoft account, then as part of that account you get 
a free online storage area called OneDrive. You can use Excel to add any of your workbooks to your 

OneDrive. This is useful if you are going to be away from your computer but still require access to a 
workbook. Because the OneDrive is accessible anywhere you have web access, you can view and work 
with your spreadsheet without using your computer.

Save a Workbook to Your OneDrive

3	 Click Save As.

1	 Open the workbook you want to 
save to your OneDrive.

2	 Click the File tab.

Save a Workbook to Your OneDrive
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The Save As tab appears.

4	 Double‐click OneDrive.

	A	 If you see the OneDrive folder 
you want to use to store the 
workbook, click it and skip to 
step 6.

The Save As dialog box appears.

5	 Double‐click the folder you want 
to use to store the workbook.

6	 Click Save.

Excel saves the workbook to 
your OneDrive.

TIP
How do I open a workbook that 
has been saved to my OneDrive?
Follow these steps:

1	 Click the File tab.

2	 Click Open.

3	 Double‐click OneDrive.

The Open dialog box appears.

4	 Open the OneDrive 
folder that contains 
the workbook.

5	 Click the workbook.

6	 Click Open.

Excel opens the 
OneDrive workbook.
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If you want to send an Excel workbook to another person, you can attach the workbook to an e‐mail 
message and send it to that person’s e‐mail address.

A typical e‐mail message is fine for short notes but you may have something more complex to 
communicate, such as budget numbers or a loan amortization. Instead of trying to copy that 
information to an e‐mail message, it would be better to send the recipient a workbook that contains 
the data. That way, the other person can then open the workbook in Excel after receiving your message.

Send a Workbook as an E‐Mail Attachment

3	 Click Share.

4	 Click Email.

Excel displays the Email 
commands.

5	 Click Send as Attachment.

1	 Open the workbook you want to 
send.

2	 Click the File tab.

Send a Workbook as an E‐Mail Attachment
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7	 Type your message text.

8	 Click Send.

Outlook sends the message.

Outlook creates a new e‐mail 
message.

	A	 Outlook attaches the workbook 
to the message.

6	 Type the address of the 
recipient.

Are there any restrictions related to sending file 
attachments?
There is no practical limit to the number of workbooks 
you can attach to a message. However, you should be 
careful with the total size of the files you send. If you 
or the recipient has a slow Internet connection, sending 
or receiving the message can take an extremely long 
time. Also, many Internet service providers (ISPs) place 
a limit on the size of a message’s attachments, which is 
usually between 2 and 10MB.

What can I do if the recipient does not have 
Excel?
If the other person does not use Excel, you can 
send the workbook in a different format. One 
possibility would be to save the workbook as a 
web page (see the following section, “Save 
Excel Data as a Web Page”). Alternatively, if 
your recipient can view PDF (Portable Document 
Format) files, follow steps 1 to 4 to display the 
Email commands, and then click Send as PDF.

TIPS
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If you have an Excel range, worksheet, or workbook that you want to share on the web, you can 
save that data as a web page that you can then upload to your website.

When you save a document as a web page, you can also specify the title text that appears in the 
browser’s title bar and the keywords that search engines use to index the page. You can also choose 
whether you want to publish the entire workbook to the web, just a single worksheet, or just a range 
of cells.

Save Excel Data as a Web Page

3	 Click Save As.

4	 Click This PC.

5	 Click Browse.

1	 Open the workbook that 
contains the data you want to 
save as a web page.

	A	 If you want to save a worksheet 
as a web page, click the 
worksheet tab.

	B	 If you want to save a range as a 
web page, select the range.

2	 Click the File tab.

Save Excel Data as a Web Page
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The Save As dialog box appears.

6	 Click the Save as type  and 
then click Web Page.

7	 Select the folder where you want 
to store the web page file.

8	 Click Change Title.

The Enter Text dialog box 
appears.

9	 Type the page title in the Page 
title text box.

10	 Click OK.

11	 Click Tags and then type one 
or more keywords, separated by 
semicolons.

12	 Choose which part of the file 
you want to save as a web page 
(  changes to ):

	C	 Click Entire Workbook to save 
the whole workbook.

	D	 Click Selection to save either the 
current worksheet or the selected 
cells.

13	 Click Save.

Excel saves the data as a web 
page.

TIP
If I make frequent changes to the workbook, do I have to go through this procedure after every change?
No, you can configure the workbook to automatically save your changes to the web page file. This is called 
AutoRepublish. To set it up, follow steps 1 to 11 to get the workbook ready for the web and then click 
Publish. In the Publish as Web Page dialog box, click AutoRepublish every time this workbook is saved 
(  changes to ). Click Publish. Excel saves the workbook as a web page and will now update the web 
page file each time you save the workbook.
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You can save an Excel workbook in a special format that makes it compatible with earlier versions 
of Excel. This enables you to share your workbook with other Excel users.

If you have another computer that uses a version of Excel prior to Excel 2007, or if the people 
you work with use earlier Excel versions, those programs cannot read documents in the standard 
format used by Excel 2016, Excel 2013, Excel 2010, and Excel 2007. By saving a workbook using 
the Excel 97‐2003 Workbook file format, you make that file compatible with earlier Excel versions.

Make a Workbook Compatible with  
Earlier Versions of Excel

3	 Click Save As.

4	 Click This PC.

5	 Click Browse.

1	 Open the workbook you want to 
make compatible.

2	 Click File.

Make a Workbook Compatible with Earlier Versions of Excel
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9	 Click the Excel 97‐2003 
Workbook file format.

10	 Click Save.

Excel saves the file using the 
Excel 97‐2003 Workbook format.

The Save As dialog box appears.

6	 Select the folder in which 
you want to store the new 
workbook.

7	 Click in the File name text 
box and type the name that 
you want to use for the new 
workbook.

8	 Click the Save as type .

Can people using Excel 2013, Excel 2010, and 
Excel 2007 open my Excel 2016 workbooks?
Yes. The default file format used by Excel 2013, 
Excel 2010, and Excel 2007 is the same as the 
one used by Excel 2016. If you only work with 
people who use these Excel versions, then you 
should stick with the default file format — 
which is called Excel Workbook — because it 
offers many benefits in terms of Excel features.

Which versions of Excel are compatible with  
the Excel 97‐2003 Workbook file format?
For Windows, the Excel 97‐2003 Workbook file format is 
compatible with Excel 97, Excel 2000, Excel XP, and Excel 
2003. For the Mac, the Excel 97‐2003 Workbook file format 
is compatible with Excel 98, Excel 2001, and Office 2004. 
In the unlikely event that you need to share a document 
with someone using either Excel 5.0 or Excel 95, use the 
Microsoft Excel 5.0/95 Workbook file format instead.

TIPS
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Excel comes with a digital ink feature that enables you to give feedback by marking up a worksheet 
with pen marks and highlights. This is often easier than adding comments or cell text.

To use digital ink on a worksheet, you must have either a tablet PC or a graphics tablet, each of 
which comes with a pressure‐sensitive screen. You can then use a digital pen — or sometimes your 
finger — to draw directly on the screen, a technique known as digital inking.

Mark Up a Worksheet with a Digital Pen

Mark Up with a Pen
1	 Tap the Pens tab.

2	 Tap Pen ( ).

3	 Use the Pens gallery to select a 
pen color and thickness.

	A	 You can also use the Color ( ) 
and Thickness ( ) buttons to 
customize the pen.

4	 Use your digital pen (or finger) 
to write your marks or text on 
the worksheet.

Activate Digital Inking
1	 Tap the Review tab.

2	 Tap Start Inking ( ).

Excel enables digital inking.

Mark Up a Worksheet with a Digital Pen
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Erase Digital Ink
1	 Tap the Pens tab.

2	 Tap Eraser ( ).

3	 Use your digital pen (or finger) 
to tap the ink you want to 
remove.

Excel erases the ink.

	C	 When you no longer need to mark 
up the worksheet with digital 
ink, tap Stop Inking ( ).

Mark Up with a Highlighter
1	 Tap the Pens tab.

2	 Tap Highlighter ( ).

3	 Use the Pens gallery to select a 
highlighter color and thickness.

	B	 You can also use  and  to 
customize the highlighter.

4	 Use your digital pen (or finger) 
to highlight the worksheet text.

TIP
Is there a way to hide a worksheet’s digital ink without deleting that ink?
Yes. This is a good idea if you want to show the worksheet to other people but you do not want them to 
see the digital ink, either because it contains sensitive information or because it makes the worksheet 
harder to read. To toggle your digital ink off and on, click the Review tab and then click Show Ink ( ).
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If you have a Microsoft account, you can use the OneDrive feature to store an Excel workbook in 
an online folder (see the “Save a Workbook to Your OneDrive” section earlier in this chapter) and 

then allow other users to collaborate on that workbook using the Excel Web App.

Collaboration here means that you and the other users can edit the workbook online at the same 
time. To allow another person to collaborate with you on your online workbook, it is not necessary 
that the person have a Microsoft account. However, you can make your online workbooks more secure 
by requiring collaborators to have a Microsoft account.

Collaborate on a Workbook Online

Collaborate on a Workbook Online

1	 Use a Web browser to navigate 
to https://onedrive.live.com.

Note: If you are not already logged 
in, you are prompted to log on to 
your Microsoft account.

Your OneDrive appears.

2	 Click the folder that contains 
the workbooks you want to 
share.

3	 Click Share.

https://onedrive.live.com
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The folder’s sharing options 
appear.

4	 Click Invite people.

5	 Type the e‐mail address of the 
person you want to collaborate 
with.

Note: To add multiple addresses, 
press  after each one.

6	 Type a message to the user.

7	 Click Recipients can only view.

8	 Select Recipients can edit.

9	 If you want to require users 
to sign in with a Microsoft 
account, select Recipients 
need to sign in with a 
Microsoft account.

10	 Click Share.

OneDrive sends an e‐mail 
message to the user. The user 
clicks the link in that message, 
optionally logs on with a 
Microsoft account, and can then 
edit a workbook in the shared 
folder.

TIP
How do I know when other people are also using a workbook 
online?
When you open a workbook using the Excel Web App, examine the 
upper‐right corner of the Excel screen. If you see User is also 
editing, it means another person (named User) is collaborating on  
the workbook with you. If you see X other people are here, it 
means that X users are collaborating with you. To see who they are, 
click the X other people are here message ( A ), as shown here.
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A
absolute cell references, 104–105
accepting workbook changes, 316–317
access, to external data, 169
Access tables, 168, 172–173
accuracy, of range names, 34
activating Digital Inking, 326
adding

background color to ranges, 62–63
borders to ranges, 80–81
buttons to Quick Access Toolbar, 69
chart titles, 266, 272
column subtotals, 216–217
columns of numbers, 94–95
comments to cells, 306–307
data labels, 273
functions to formulas, 92–93
nodes to SmartArt graphics, 297
range names to formulas, 98–99
rows of numbers, 94–95
sparklines to cells, 284–285
text to shapes, 289
workbook footers, 164–165
workbook headers, 162–163
worksheet graphics. See graphics

aligning text within cells, 27, 56–59
alphanumeric values, filling ranges with, 8–9
Analysis ToolPak, 262–263
analyzing data. See data analysis
Apply Names feature, 99
applying

AutoFormats to ranges, 68–69
conditional formats to ranges, 70–71
font effects, 52–53
number formats, 64–65
picture effects, 303
picture styles, 302
styles to ranges, 72–73
table styles, 219, 220–221
workbook themes, 160–161

area chart, 267

arithmetic formulas, 87
arranging workbook windows, 144–145
array formula, 233
aspect ratio, 301
assigning names to ranges, 43
Autofill feature, 8–9, 77
AutoFit feature, 75
AutoFormats, applying to ranges, 68–69
AutoShapes feature, 288
AutoSum formulas, building, 96–97
AVERAGE() function, 91

B
backgrounds

adding color to ranges, 62–63
picture, 293
removing images from worksheets, 129
setting for worksheets, 128–129

bar chart, 267
benefits, of range names, 34–35
borders, adding to ranges, 80–81
box & whisker chart, 267
break-even analysis, 239
buttons, adding to Quick Access Toolbar, 69

C
categories, consolidating data from multiple, 260–261
category axis, 266
cells

adding
comments to, 306–307
sparklines to, 284–285

aligning text within, 56–57
analyzing values

with color scales, 252–253
with data bars, 250–251
with icon sets, 254–255

copying formatting between, 82–83
highlighting, 246–247
inserting, 16–17
merging, 26–27
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removing
data validation from, 231
numeric formatting from, 19

restoring addresses, 105
rotating text within, 60–61
selecting ranges, 4–5
separating text into columns, 186–187
table, 207
wrapping text within, 78–79

changing
chart layouts/styles, 277
chart source data, 280–281
column width, 74–75
custom conditional formatting rules, 257
font color, 54–55
font/font size, 50–51
gridline colors, 122–123
number of decimal places displayed, 66–67
page orientation, 192
range names, 42–43
row height, 76–77
username, 307
workbook margins, 190–191

chart legends, positioning, 274
chart sheet, 269
charts

adding
chart titles, 266, 272
data labels, 273
sparklines to cells, 284–285

changing
layouts, 277
source data, 280–281
styles, 277

creating, 268–271
deleting, 283
displaying

chart gridlines, 275
data tables, 276

elements of, 266
moving, 282–283

positioning chart legends, 274
resizing, 282–283
selecting types, 278–279
types of, 267

checking spelling and grammar, 150–151
clip art images, inserting, 290–291
collaboration

accepting workbook changes, 316–317
adding comments to cells, 306–307
compatibility, 324–325
marking up worksheets with digital pens, 326–327
protecting

workbook structure, 310–311
worksheet data, 308–309

rejecting workbook changes, 316–317
saving

data as web pages, 322–323
workbooks to OneDrive, 318–319

sending workbooks as e-mail attachments, 320–321
sharing workbooks, 312–313
tracking workbook changes, 314–315
on workbooks online, 328–329

color
background, 62–63
font, 54–55
gridline, 122–123
tab, 126–127
workbook, 154–155

color scales, analyzing cell values with, 252–253
color schemes, creating, 155
column chart, 267
Column Filter button, 207
column headers

selecting, 210
in tables, 207

columns
adding

of numbers, 94–95
subtotals, 216–217

centering text across, 27, 58–59
changing width, 74–75
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columns (continued)
deleting, 21
displaying, 23
freezing, 24–25
hiding, 22–23
inserting, 14–15
selecting, 5
separating cell text into, 186–187
table, 207, 210, 213, 215
transposing, 28–29
unfreezing, 25

comma (,), 177, 179
comments

adding to cells, 306–307
editing, 307
removing, 307
viewing, 307

comparison formulas, 87
compatibility, 324–325
conditional formatting

about, 246–247
applying to ranges, 70–71
creating custom rules, 256–257
removing from ranges, 71

configuring titles to print on each page, 198–199
confirming

operator precedence, 109
punctuation, 109
range data, 108
range references, 108

consolidating data from multiple worksheets, 258–261
converting

ranges to tables, 208–209
tables to ranges, 218

copying
formatting between cells, 82–83
formulas, 102–103
ranges, 12–13
worksheets, 118–119

COUNT() function, 91
Create from Selection command, 39

creating
AutoSum formulas, 96–97
charts, 268–269
color schemes, 155
custom borders, 81
custom conditional formatting rules, 256–257
custom effect schemes, 159
custom lists, 9
custom styles, 220–221
data connection files, 171
data tables, 232–233
filters, 229
font schemes, 157
formulas, 88–89, 96–97
outlines, 236
PivotTables, 222–223
recommended charts, 270–271
styles, 73
templates, 141
workbook themes, 161
workbooks, 138–141
worksheets, 114–115

Creative Commons, 291
cropping pictures, 300–301
custom lists, creating, 9

D
data

deleting from ranges, 18–19
filling ranges with duplicate, 6–7
importing. See importing data
protecting worksheet, 308–309
saving as web pages, 322–323
selecting

in tables, 210–211
using touch gestures, 30–31

visualizing. See charts
data analysis

about, 206
analyzing

cell values with color scales, 252–253
cell values with data bars, 250–251
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cell values with icon sets, 254–255
data with Goal Seek, 238–239
data with scenarios, 240–243

consolidating data from multiple worksheets, 258–261
creating

custom conditional formatting rules, 256–257
data tables, 232–233

filtering ranges/tables, 228–229
grouping related data, 236–237
highlighting

cells, 246–247
top/bottom values in ranges, 248–249

loading Analysis ToolPak, 262–263
removing duplicate values from ranges/tables, 244–245
setting data validation rules, 230–231
sorting ranges/tables, 226–227
summarizing data with subtotals, 234–235

data bars, analyzing cell values with, 250–251
data connection files, creating, 171
data labels, adding, 273
data marker, 266
data series, 266
data sources, importing data from, 170–171
data tables

creating, 232–233
displaying, 276

data validation rules, setting, 230–231
data value, 266
date values, filling ranges with, 8–9
decimal places, changing number displayed, 66–67
defining

range names, 36–37
worksheet text with range names, 38–39

Degrees spin box, 61
delimited data, importing, 177
delimited text file, 177
delimiter, 177
Digital Inking, 326
digital pens, marking up worksheets with, 326–327
displaying

chart gridlines, 275
columns, 23

data tables, 276
Filter buttons, 228
rows, 23

#DIV/0 error, 109
division (/) operator, 87
doughnut chart, 267
drawing shapes, 288–289

E
editing

analyzing data with scenarios, 243
comments, 307

effects
choosing, 158–159
font, 52–53
picture, 303

e-mail attachments, sending workbooks as, 320–321
entering data using touch gestures, 30–31
equal to (=), 87
error values, 109
errors, troubleshooting for formulas, 108–109
exclamation mark (!), 101
Expand Formula Bar feature, 107
exponentiation (^) operator, 87
Extensible Markup Language (XML), 169, 182–183
external data, 168–169
extracted data, flash filling ranges with, 10

F
filling

horizontal ranges, 6–7
ranges with duplicate data, 6–7
ranges with series of values, 8–9
vertical ranges, 6–7

Filter buttons, displaying, 228
filtering ranges/tables, 228–229
filters, creating, 229
financial functions, 91
Find and Replace dialog box, 147, 149
finding text in workbooks, 146–147
fixed-width data, importing, 178
fixed-width text file, 177
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flash filling ranges, 10–11
Flickr, 291
fonts

applying effects, 52–53
changing color, 54–55
changing size, 50–51
creating schemes, 157
setting, 156–157

footer margins, 191
footers, adding to workbooks, 164–165
Format Cells dialog box, 65
formatted data, flash filling ranges with, 11
formatting pictures, 302–303. See also conditional formatting
formatting ranges

adding
background color to ranges, 62–63
borders to ranges, 80–81

aligning text within cells, 56–57
applying

AutoFormats to ranges, 68–69
conditional formats to ranges, 70–71
font effects, 52–53
number formats, 64–65
styles to ranges, 72–73

centering text across columns, 58–59
changing

column width, 74–75
font color, 54–55
font/font size, 50–51
number of decimal places displayed, 66–67
row height, 76–77

copying formatting between cells, 82–83
rotating text within cells, 60–61
wrapping text within cells, 78–79

formatting workbooks
adding

footers, 164–165
headers, 162–163

applying themes, 160–161
choosing effects, 158–159
modifying colors, 154–155
setting fonts, 156–157

Formula Bar, hiding, 106–107
formulas

about, 86–87
adding

functions to, 92–93
range names to, 98–99
rows/columns of numbers, 94–95

copying, 102–103
creating, 88–89, 96–97
functions, 90–91
hiding Formula Bar/Ribbon, 106–107
moving, 102–103
referencing worksheet ranges in, 100–101
switching to absolute cell references, 104–105
troubleshooting errors, 108–109

freezing rows/columns, 24–25
functions, 90–93
FV() function, 91

G
Go To command, 41
Goal Seek, analyzing data with, 238–239
gradient effect, 63
grammar, checking, 150–151
graphics

cropping pictures, 300–301
drawing shapes, 288–289
formatting pictures, 302–303
inserting

clip art images, 290–291
photos, 292–293
SmartArt graphics, 296–297
WordArt images, 294–295

moving, 298–299
resizing, 298–299
rotating, 299

greater than (>), 87
greater than or equal to (> =), 87
gridlines

about, 81, 266
changing color of, 122–123
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chart, 275
toggling on/off, 124

grouping related data, 236–237

H
header margins, 191
headers, adding to workbooks, 162–163
headings, toggling on/off, 125
hiding

columns, 22–23
digital ink, 327
Formula Bar, 106–107
Ribbon, 106–107
rows, 22–23
worksheets, 134–135

highlighter, marking up with, 327
highlighting

cells, 246–247
top/bottom values in ranges, 248–249

histogram, 267
horizontal alignment, 56
horizontal ranges, filling, 6–7

I
icon sets, analyzing cell values with, 254–255
images. See pictures
importing data

from Access tables, 172–173
from data sources, 170–171
delimited data, 177
external data, 168–169
refreshing imported data, 184–185
separating cell text into columns, 186–187
from text files, 176–179
from web pages, 180–181
from Word tables, 174–175
from XML files, 182–183

indenting cell text, 57
inserting

cells, 16–17
clip art images, 290–291
columns, 14–15

page breaks, 193
photos, 292–293
ranges, 16–17
rows, 14–15
SmartArt graphics, 296–297
table columns, 213
table rows, 212
WordArt images, 294–295

intuitiveness, of range names, 34
IPMT() function, 91

J
justified text, 57

K
keyboard techniques

font-related, 53
for navigating worksheets, 112
for selecting ranges, 5

L
layouts, chart, 277
legend, 266
less than (<), 87
less than or equal to (< =), 87
line chart, 267
loading Analysis ToolPak, 262–263
location, 169
login, 169

M
margins

adjusting for workbooks, 190–191
in Print Preview, 201

marking up worksheets with digital pens, 326–327
mathematical functions, 90
MAX() function, 91
MEDIAN() function, 91
merging cells, 26–27
Microsoft Access, 168
Microsoft Word, 168, 174–175
MIN() function, 91
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MOD() function, 90
MODE() function, 91
moving

charts, 282–283
formulas, 102–103
graphics, 298–299
ranges, 12–13
worksheets, 116–117

multiplication (*) operator, 86, 87

N
#N/A error, 109
Name box, 40
#NAME? error, 109
Name Manager dialog box, 43
navigating

for range names, 35
workbooks using range names,  

40–41
worksheets, 112

negation (-) operator, 87
nodes, adding to SmartArt graphics, 297
not equal to (< >), 87
NPER() function, 91
#NUM! error, 109
number formats

applying, 64–65
deleting from cells, 19

numeric values, filling ranges with,  
8–9

O
OneDrive, saving workbooks to, 318–319
Open Database Connectivity (ODBC), 168
opening workbooks, 143
operands, 86
operator precedence, 87, 109
operators, 86
orientation, page, 192
outliers, 253
outlines, creating, 236

P
page breaks, inserting, 193
page orientation, changing, 192
panes, splitting worksheets into, 132–133
paper size, choosing, 194–195
parentheses (()), 87
password, 173, 309
pasting lists of range names, 46–47
percentage (%) operator, 87
PI() function, 90
pictures

applying
effects, 303
styles, 302

background, 129
clip art, 290–291
cropping, 300–301
formatting, 302–303
inserting, 292–293

pie chart, 267
PivotTables, creating, 222–223
plot area, 266
PMT() function, 91
position, consolidating data by, 258–259
positioning chart legends, 274
PPMT() function, 91
previewing printouts, 200–201
print area, setting, 196–197
printing workbooks

adjusting margins, 190–191
changing page orientation, 192
choosing paper size, 194–195
configuring titles to print on each page,  

198–199
inserting page breaks, 193
previewing printouts, 200–201
process of, 202–203
setting print area, 196–197

printouts, previewing, 200–201
PRODUCT() function, 90
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protecting
workbook structure, 310–311
worksheet data, 308–309

punctuation, confirming, 109
PV() function, 91

Q
Quick Access Toolbar, adding buttons to, 69

R
radar chart, 267
RAND() function, 90
RANDBETWEEN() function, 90
range data, confirming, 108
range names

adding to formulas, 98–99
assigning, 43
benefits of, 34–35
changing, 42–43
defining, 36–37
defining worksheet text with, 38–39
deleting, 44–45
navigating workbooks using, 40–41
pasting lists of, 46–47

range references, confirming, 108
ranges

adding
background color, 62–63
borders to, 80–81

applying
AutoFormat to, 68–69
conditional formats to, 70–71
styles to, 72–73

assigning names to, 43
converting

to tables, 208–209
tables to, 218

copying, 12–13
defined, 2
entering data using touch gestures, 30–31
filling

with duplicate data, 6–7
with series of values, 8–9

filtering, 228–229
flash filling, 10–11
formatting. See formatting ranges
freezing rows or columns, 24–25
hiding rows/columns, 22–23
highlighting top/bottom values in, 248–249
inserting

cells, 16–17
columns, 14–15
rows, 14–15

merging cells, 26–27
moving, 12–13
removing

about, 20–21
data bars from, 251
data from, 18–19
duplicate values from, 244–245

selecting
about, 4–5
data using touch gestures, 30–31

sorting, 226–227
transposing rows or columns, 28–29

RATE() function, 91
recommended charts, creating, 270–271
rectangular ranges, selecting, 4
#REF# error, 109
referencing worksheet ranges in formulas, 100–101
refreshing imported data, 184–185
rejecting workbook changes, 316–317
related data, grouping, 236–237
relative cell references, compared with absolute cell 

references, 105
removing

background images from worksheets, 129
charts, 283
columns, 21
comments, 307
conditional formatting, 71, 247
custom conditional formatting rules, 257
data bars from ranges, 251
data from ranges, 18–19
data validation from cells, 231
Digital Ink, 327
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removing (continued)
duplicate values from ranges/tables, 244–245
fields in XML tables, 183
numeric formatting from cells, 19
photo backgrounds, 293
print areas, 197
range names, 44–45
ranges, 20–21
rows, 21
scenarios, 243
tab color, 127
table columns, 215
table rows, 214
top/bottom rules, 249
words from spell-checker's dictionary, 151
workbook structure protection, 311
worksheets, 120–121

renaming worksheets, 113
replacing text in workbooks, 148–149
resizing

charts, 282–283
graphics, 298–299
workbooks, 293

restoring cell addresses, 105
Ribbon

adjusting workbook margins, 190
hiding, 106–107

rotating
graphics, 299
text within cells, 60–61

ROUND() function, 90
rows

adding of numbers, 94–95
changing height, 76–77
deleting, 21
displaying, 23
freezing, 24–25
hiding, 22–23
inserting, 14–15
selecting, 5

table, 207, 211, 212, 214
transposing, 28–29
unfreezing, 25

Ruler, adjusting workbook margins, 191

S
saving

data as web pages, 322–323
workbooks, 142, 318–319

scatter chart, 267
scenarios, analyzing data with, 240–243
selecting

chart types, 278–279
columns, 5
data using touch gestures, 30–31
effects, 158–159
paper size, 194–195
ranges, 4–5
rows, 5
table data, 210–211

sending workbooks as e-mail attachments, 320–321
separating cell text into columns, 186–187
setting

data validation rules, 230–231
fonts, 156–157
print area, 196–197
tab color, 126–127
worksheet background, 128–129

shapes, drawing, 288–289
sharing workbooks, 312–313
single quotation marks ('), 101
size, font, 50–51
SmartArt graphics, inserting, 296–297
sorting ranges/tables, 226–227
source data, for charts, 280–281
sparklines, adding to cells, 284–285
spelling, checking, 150–151
splitting worksheets into panes, 132–133
SQRT() function, 90
stability, of range names, 35
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statistical functions, 91
STDEV() function, 91
STDEVP() function, 91
stock chart, 267
structure, workbook, 310–311
styles

applying to ranges, 72–73
chart, 277
creating, 73, 220–221
picture, 302
table, 219, 220–221

SUBTOTAL function, 216–217
subtotals

column, 216–217
summarizing data with, 234–235

subtraction (-) operator, 87
SUM() function, 90, 95, 237
summarizing data with subtotals, 234–235
sunburst chart, 267
surface chart, 267
switching to absolute cell references, 104–105

T
tables

about, 206
adding column subtotals, 216–217
applying styles, 219
converting

to ranges, 218
ranges to, 208–209

creating
custom table styles, 220–221
PivotTables, 222–223

data, 232–233, 276
features of, 207
filtering, 228–229
inserting

table columns, 213
table rows, 212

removing
duplicate values from, 244–245
table columns, 215
table rows, 214

selecting data in, 210–211
sorting, 226–227

tabs, setting color, 126–127
templates

creating, 141
creating workbooks from, 140–141
inserting worksheets from, 115

text
adding to shapes, 289
aligning within cells, 56–57
centering across columns, 27, 58–59
finding in workbooks, 146–147
replacing in workbooks, 148–149
rotating within cells, 60–61
separating into columns, 186–187
wrapping within cells, 78–79

text files, 168, 176–179
Text Import Wizard, 176, 179
themes, applying to workbooks, 160–161
three-color scales, 253
titles, configuring to print on each page, 198–199
toggling

gridlines on/off, 124
headings on/off, 125

touch gestures, selecting and entering data using, 30–31
tracking workbook changes, 314–315
transposing rows/columns, 28–29
treemap chart, 267
troubleshooting formula errors, 108–109
two-color scales, 253
type argument, 91

U
unfreezing rows/columns, 25
unhiding worksheets, 134–135
username, changing, 307

V
value axis, 266
#VALUE! error, 109
values

error, 109
filling ranges with series of, 8–9
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vertical alignment, 57
vertical ranges, filling, 6–7
viewing comments, 307
visualizing data. See charts

W
waterfall chart, 267
web pages

about, 169
importing data from, 180–181
saving data as, 322–323

what-if analysis, 233
windows, workbook, 144–145
Word tables, 168, 174–175
WordArt images, inserting, 294–295
workbooks

accepting changes, 316–317
adding

footers, 164–165
headers, 162–163

applying themes, 160–161
arranging windows, 144–145
changing margins, 190–191
checking spelling and grammar, 150–151
creating, 138–141
finding text in, 146–147
formatting. See formatting workbooks
navigating using range names, 40–41
online collaboration with, 328–329
opening, 143
printing. See printing workbooks
protecting structure of, 310–311
rejecting changes, 316–317
replacing text in, 148–149
resizing, 293
saving, 142, 318–319
sending as e-mail attachments, 320–321

sharing, 312–313
tracking changes, 314–315

worksheet graphics. See graphics
worksheets

about, 110
changing gridline colors, 122–123
consolidating data from multiple, 258–261
copying, 118–119
creating, 114–115
defining text with range names, 38–39
hiding, 134–135
marking up with digital pens, 326–327
moving, 116–117
navigating, 112, 115
protecting data, 308–309
referencing ranges in formulas, 100–101
removing

about, 120–121
background images from, 129

renaming, 113
setting

background images, 128–129
tab color, 126–127

splitting into panes, 132–133
toggling

gridlines on and off, 124
headings on and off, 125

unhiding, 134–135
zooming, 130–131

wrapping text within cells, 78–79

X
XML (Extensible Markup Language), 169, 182–183
XY chart, 267

Z
zooming worksheets, 130–131
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